%%phrase%%

Noemax FastInfoset.NET
Noemax.FastInfoset Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Noemax.FastInfoset |
Noemax.GZip |
Noemax.Lzf |
Noemax.Lzma |
Noemax.Xml |

Copyright © 2010 Noemax Technologies. All rights reserved.


%%ItemTitle%%

Noemax.FastInfoset Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | OptimizedVocabulary | Provides methods and properties to create an optimized Fast Infoset vocabulary.
Class | ReaderVocabulary | Provides a Fast Infoset vocabulary for use by XmlFastInfosetReader.
Class | SchemaVocabulary | Provides methods and properties for generating a Fast Infoset vocabulary from an XSD schema.
Class | Vocabulary | Provides the base implementation for Fast Infoset vocabularies.
Class | VocabularyWriter | Provides methods and proterties to populate the Fast Infoset vocabulary by writing an XML document.
Class | WriterVocabulary | Provides a Fast Infoset vocabulary for use by XmlFastInfosetWriter.
Class | XmlFastInfosetFactory | Manages XmlFastInfosetReader and XmlFastInfosetWriter objects.
Class | XmlFastInfosetReader | Represents a reader that provides fast, non-cached, forward-only access to Fast Infoset encoded XML data.
Class | XmlFastInfosetWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating streams or files containing Fast Infoset encoded XML data.
Class | XmlFastInfosetWriterProfile | Contains the settings that specify the way FastInfoset serializes primitive data types.

Interfaces

 | Interface | Description
Interface | IVocabularyProvider | Defines the interface for resolving URI references to Fast Infoset vocabularies.

Enumerations

 | Enumeration | Description
Enumeration | FastInfosetCompression | Defines the compression algorithm to be used for compressing and decompressing data.
Enumeration | XmlFastInfosetFormat | Defines the way that Fast Infoset serializes primitive data types.

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
OptimizedVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : OptimizedVocabulary Class

Provides methods and properties to create an optimized Fast Infoset vocabulary.

Object Model

OptimizedVocabulary Class

Syntax

Visual Basic (Declaration)
Public Class OptimizedVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
C#
public class OptimizedVocabulary : Vocabulary
Delphi
public class OptimizedVocabulary = class(Vocabulary)
JScript
public class OptimizedVocabulary extends Vocabulary
Managed Extensions for C++
public __gc class OptimizedVocabulary : public Vocabulary
C++/CLI
public ref class OptimizedVocabulary : public Vocabulary

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.OptimizedVocabulary

See Also

Reference

OptimizedVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
OptimizedVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : OptimizedVocabulary Class

The following tables list the members exposed by OptimizedVocabulary.

Public Constructors

 | Name | Description
public Constructor | OptimizedVocabulary Constructor | Creates a new instance of OptimizedVocabulary.
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name into the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string into the vocabulary attribute string table.
public Method | AddContentString | Overridden. Adds the string into the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name into the vocabulary.
public Method | AddLocalName | Overridden. Add the local name into the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI into the vocabulary.
public Method | AddPrefix | Overridden. Add the prefix into the vocabulary.
public Method | CreateWriterVocabulary | Creates a new WriterVocabulary using optimized string tables of this vocabulary.
Top

See Also

Reference

OptimizedVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
OptimizedVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : OptimizedVocabulary Constructor

Creates a new instance of OptimizedVocabulary.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New OptimizedVocabulary()
C#
public OptimizedVocabulary()
Delphi
public OptimizedVocabulary();
JScript
public function OptimizedVocabulary();
Managed Extensions for C++
public: OptimizedVocabulary();
C++/CLI
public:
OptimizedVocabulary();

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
OptimizedVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : OptimizedVocabulary Class

For a list of all members of this type, see OptimizedVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name into the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string into the vocabulary attribute string table.
public Method | AddContentString | Overridden. Adds the string into the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name into the vocabulary.
public Method | AddLocalName | Overridden. Add the local name into the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI into the vocabulary.
public Method | AddPrefix | Overridden. Add the prefix into the vocabulary.
public Method | CreateWriterVocabulary | Creates a new WriterVocabulary using optimized string tables of this vocabulary.
Top

See Also

Reference

OptimizedVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddAttributeName Method

prefix
The prefix of the attribute namespace.
name
The local of the attribute.
namespaceUri
The namespace of the attribute.
Adds the attribute qualified name into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of the attribute namespace.
name
The local of the attribute.
namespaceUri
The namespace of the attribute.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddAttributeString Method

text
Adds the string into the vocabulary attribute string table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddContentString Method

text
The string into vocabulary string table.
Adds the string into the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text
The string into vocabulary string table.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddElementName Method

prefix
The prefix of the element namespace.
name
The local name of the element
namespaceUri
The namespaceURI of the element.
Adds the element qualified name into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of the element namespace.
name
The local name of the element
namespaceUri
The namespaceURI of the element.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddLocalName Method

name
The local name to add.
Add the local name into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name
The local name to add.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddNamespace Method

namespaceUri
The namespaceUri to add.
Adds the namespace URI into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri
The namespaceUri to add.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : AddPrefix Method

prefix
The prefix to add.
Add the prefix into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix
The prefix to add.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriterVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > OptimizedVocabulary Class : CreateWriterVocabulary Method

maxItems
The maximum number of items per table to use.
minHitCount
The mimium number of hits per item required to add it into the writer vocabulary.
Creates a new WriterVocabulary using optimized string tables of this vocabulary.

Syntax

Visual Basic (Declaration)
Public Function CreateWriterVocabulary( _
   ByVal maxItems As Integer, _
   ByVal minHitCount As Integer _
) As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim instance As OptimizedVocabulary
Dim maxItems As Integer
Dim minHitCount As Integer
Dim value As WriterVocabulary

value = instance.CreateWriterVocabulary(maxItems, minHitCount)
C#
public WriterVocabulary CreateWriterVocabulary(
   int maxItems,
   int minHitCount
)
Delphi
public function CreateWriterVocabulary(
    maxItems: Integer;
    minHitCount: Integer
): WriterVocabulary;
JScript
public function CreateWriterVocabulary(
   maxItems : int,
   minHitCount : int
) : WriterVocabulary;
Managed Extensions for C++
public: WriterVocabulary* CreateWriterVocabulary(
   int maxItems,
   int minHitCount
)
C++/CLI
public:
WriterVocabulary^ CreateWriterVocabulary(
   int maxItems,
   int minHitCount
)

Parameters

maxItems
The maximum number of items per table to use.
minHitCount
The mimium number of hits per item required to add it into the writer vocabulary.

Return Value

The optimized writer vocabulary.

See Also

Reference

OptimizedVocabulary Class
OptimizedVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReaderVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

Provides a Fast Infoset vocabulary for use by XmlFastInfosetReader.

Object Model

ReaderVocabulary Class

Syntax

Visual Basic (Declaration)
Public Class ReaderVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
C#
public class ReaderVocabulary : Vocabulary
Delphi
public class ReaderVocabulary = class(Vocabulary)
JScript
public class ReaderVocabulary extends Vocabulary
Managed Extensions for C++
public __gc class ReaderVocabulary : public Vocabulary
C++/CLI
public ref class ReaderVocabulary : public Vocabulary

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.ReaderVocabulary

See Also

Reference

ReaderVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
ReaderVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

The following tables list the members exposed by ReaderVocabulary.

Public Constructors

 | Name | Description
public Constructor | ReaderVocabulary Constructor | Initializes a new instance of ParserVocabulary.
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears vocabulary tables.
public Method | SetInitialVocabulary | Sets the read-only initial vocabulary for this vocabulary.
public Method | SetReferencedVocabulary | Sets the read-only referenced vocabulary for this vocabulary.
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReaderVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : ReaderVocabulary Constructor

Initializes a new instance of ParserVocabulary.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ReaderVocabulary()
C#
public ReaderVocabulary()
Delphi
public ReaderVocabulary();
JScript
public function ReaderVocabulary();
Managed Extensions for C++
public: ReaderVocabulary();
C++/CLI
public:
ReaderVocabulary();

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
ReaderVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

For a list of all members of this type, see ReaderVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears vocabulary tables.
public Method | SetInitialVocabulary | Sets the read-only initial vocabulary for this vocabulary.
public Method | SetReferencedVocabulary | Sets the read-only referenced vocabulary for this vocabulary.
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddAttributeName Method

prefix
name
namespaceUri
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddAttributeString Method

text
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddContentString Method

text
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddElementName Method

prefix
name
namespaceUri
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddLocalName Method

name
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddNamespace Method

namespaceUri
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddPrefix Method

prefix
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : Clear Method

Clears vocabulary tables.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary

instance.Clear()
C#
public virtual void Clear()
Delphi
public procedure Clear(); virtual;
JScript
public function Clear();
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetInitialVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : SetInitialVocabulary Method

initialVocabulary
The vocabulary to use as initial vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.
Sets the read-only initial vocabulary for this vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetInitialVocabulary( _
   ByVal initialVocabulary As ReaderVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim initialVocabulary As ReaderVocabulary
Dim clear As Boolean

instance.SetInitialVocabulary(initialVocabulary, clear)
C#
public virtual void SetInitialVocabulary(
   ReaderVocabulary initialVocabulary,
   bool clear
)
Delphi
public procedure SetInitialVocabulary(
    initialVocabulary: ReaderVocabulary;
    clear: Boolean
); virtual;
JScript
public function SetInitialVocabulary(
   initialVocabulary : ReaderVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: virtual void SetInitialVocabulary(
   ReaderVocabulary* initialVocabulary,
   bool clear
)
C++/CLI
public:
virtual void SetInitialVocabulary(
   ReaderVocabulary^ initialVocabulary,
   bool clear
)

Parameters

initialVocabulary
The vocabulary to use as initial vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetReferencedVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : SetReferencedVocabulary Method

referencedVocabularyURI
The URI of external referenced vocabulary.
referencedVocabulary
The external referenced vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.
Sets the read-only referenced vocabulary for this vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetReferencedVocabulary( _
   ByVal referencedVocabularyURI As String, _
   ByVal referencedVocabulary As ReaderVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim referencedVocabularyURI As String
Dim referencedVocabulary As ReaderVocabulary
Dim clear As Boolean

instance.SetReferencedVocabulary(referencedVocabularyURI, referencedVocabulary, clear)
C#
public virtual void SetReferencedVocabulary(
   string referencedVocabularyURI,
   ReaderVocabulary referencedVocabulary,
   bool clear
)
Delphi
public procedure SetReferencedVocabulary(
    referencedVocabularyURI: String;
    referencedVocabulary: ReaderVocabulary;
    clear: Boolean
); virtual;
JScript
public function SetReferencedVocabulary(
   referencedVocabularyURI : String,
   referencedVocabulary : ReaderVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: virtual void SetReferencedVocabulary(
   string* referencedVocabularyURI,
   ReaderVocabulary* referencedVocabulary,
   bool clear
)
C++/CLI
public:
virtual void SetReferencedVocabulary(
   String^ referencedVocabularyURI,
   ReaderVocabulary^ referencedVocabulary,
   bool clear
)

Parameters

referencedVocabularyURI
The URI of external referenced vocabulary.
referencedVocabulary
The external referenced vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SchemaVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

Provides methods and properties for generating a Fast Infoset vocabulary from an XSD schema.

Object Model

SchemaVocabulary Class

Syntax

Visual Basic (Declaration)
Public Class SchemaVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
C#
public class SchemaVocabulary : Vocabulary
Delphi
public class SchemaVocabulary = class(Vocabulary)
JScript
public class SchemaVocabulary extends Vocabulary
Managed Extensions for C++
public __gc class SchemaVocabulary : public Vocabulary
C++/CLI
public ref class SchemaVocabulary : public Vocabulary

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.SchemaVocabulary

See Also

Reference

SchemaVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
SchemaVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

The following tables list the members exposed by SchemaVocabulary.

Public Constructors

 | Name | Description
public Constructor | SchemaVocabulary Constructor |
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | CopyTo | Copies all the tables of the current vocabulary into another Vocabulary.
public Method | CreateReaderVocabulary | Overloaded. Creates a new ReadVocabulary from this SchemaVocabulary instance.
public Method | CreateWriterVocabulary | Overloaded. Creates a new WriterVocabulary from this SchemaVocabulary instance.
static (Shared in Visual Basic) | FromSchemaSet | Overloaded. Generates a new SchemaVocabulary from the XSD schema set.
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SchemaVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : SchemaVocabulary Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SchemaVocabulary()
C#
public SchemaVocabulary()
Delphi
public SchemaVocabulary();
JScript
public function SchemaVocabulary();
Managed Extensions for C++
public: SchemaVocabulary();
C++/CLI
public:
SchemaVocabulary();

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
SchemaVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

For a list of all members of this type, see SchemaVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | CopyTo | Copies all the tables of the current vocabulary into another Vocabulary.
public Method | CreateReaderVocabulary | Overloaded. Creates a new ReadVocabulary from this SchemaVocabulary instance.
public Method | CreateWriterVocabulary | Overloaded. Creates a new WriterVocabulary from this SchemaVocabulary instance.
static (Shared in Visual Basic) | FromSchemaSet | Overloaded. Generates a new SchemaVocabulary from the XSD schema set.
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddAttributeName Method

prefix
name
namespaceUri
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddAttributeString Method

text
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddContentString Method

text
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddElementName Method

prefix
name
namespaceUri
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddLocalName Method

name
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddNamespace Method

namespaceUri
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddPrefix Method

prefix
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CopyTo Method

vocabulary
The vocabulary where to copy all entries too.
Copies all the tables of the current vocabulary into another Vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal vocabulary As Vocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim vocabulary As Vocabulary

instance.CopyTo(vocabulary)
C#
public void CopyTo(
   Vocabulary vocabulary
)
Delphi
public procedure CopyTo(
    vocabulary: Vocabulary
);
JScript
public function CopyTo(
   vocabulary : Vocabulary
);
Managed Extensions for C++
public: void CopyTo(
   Vocabulary* vocabulary
)
C++/CLI
public:
void CopyTo(
   Vocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary where to copy all entries too.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReaderVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CreateReaderVocabulary Method

Creates a new ReadVocabulary from this SchemaVocabulary instance.

Overload List

Overload | Description
CreateReaderVocabulary() | Creates a new ReadVocabulary from this SchemaVocabulary instance.
CreateReaderVocabulary(XmlSchemaSet) | Creates a new ReaderVocabulary from the specified XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReaderVocabulary() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateReaderVocabulary Method : CreateReaderVocabulary() Method

Creates a new ReadVocabulary from this SchemaVocabulary instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReaderVocabulary() As ReaderVocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim value As ReaderVocabulary

value = instance.CreateReaderVocabulary()
C#
public ReaderVocabulary CreateReaderVocabulary()
Delphi
public function CreateReaderVocabulary(): ReaderVocabulary;
JScript
public function CreateReaderVocabulary() : ReaderVocabulary;
Managed Extensions for C++
public: ReaderVocabulary* CreateReaderVocabulary();
C++/CLI
public:
ReaderVocabulary^ CreateReaderVocabulary();

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReaderVocabulary(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateReaderVocabulary Method : CreateReaderVocabulary(XmlSchemaSet) Method

schemaSet
Creates a new ReaderVocabulary from the specified XSD schema set.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateReaderVocabulary( _
   ByVal schemaSet As XmlSchemaSet _
) As ReaderVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As ReaderVocabulary

value = SchemaVocabulary.CreateReaderVocabulary(schemaSet)
C#
public static ReaderVocabulary CreateReaderVocabulary(
   XmlSchemaSet schemaSet
)
Delphi
public function CreateReaderVocabulary(
    schemaSet: XmlSchemaSet
): ReaderVocabulary; static;
JScript
public static function CreateReaderVocabulary(
   schemaSet : XmlSchemaSet
) : ReaderVocabulary;
Managed Extensions for C++
public: static ReaderVocabulary* CreateReaderVocabulary(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static ReaderVocabulary^ CreateReaderVocabulary(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriterVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CreateWriterVocabulary Method

Creates a new WriterVocabulary from this SchemaVocabulary instance.

Overload List

Overload | Description
CreateWriterVocabulary() | Creates a new WriterVocabulary from this SchemaVocabulary instance.
CreateWriterVocabulary(XmlSchemaSet) | Creates a new WriterVocabulary from the specified XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriterVocabulary() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateWriterVocabulary Method : CreateWriterVocabulary() Method

Creates a new WriterVocabulary from this SchemaVocabulary instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriterVocabulary() As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim value As WriterVocabulary

value = instance.CreateWriterVocabulary()
C#
public WriterVocabulary CreateWriterVocabulary()
Delphi
public function CreateWriterVocabulary(): WriterVocabulary;
JScript
public function CreateWriterVocabulary() : WriterVocabulary;
Managed Extensions for C++
public: WriterVocabulary* CreateWriterVocabulary();
C++/CLI
public:
WriterVocabulary^ CreateWriterVocabulary();

Return Value

The generated vocabulary

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriterVocabulary(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateWriterVocabulary Method : CreateWriterVocabulary(XmlSchemaSet) Method

schemaSet
The schema set to be used to generate the vocabulary.
Creates a new WriterVocabulary from the specified XSD schema set.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateWriterVocabulary( _
   ByVal schemaSet As XmlSchemaSet _
) As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As WriterVocabulary

value = SchemaVocabulary.CreateWriterVocabulary(schemaSet)
C#
public static WriterVocabulary CreateWriterVocabulary(
   XmlSchemaSet schemaSet
)
Delphi
public function CreateWriterVocabulary(
    schemaSet: XmlSchemaSet
): WriterVocabulary; static;
JScript
public static function CreateWriterVocabulary(
   schemaSet : XmlSchemaSet
) : WriterVocabulary;
Managed Extensions for C++
public: static WriterVocabulary* CreateWriterVocabulary(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static WriterVocabulary^ CreateWriterVocabulary(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet
The schema set to be used to generate the vocabulary.

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
FromSchemaSet Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : FromSchemaSet Method

Generates a new SchemaVocabulary from the XSD schema set.

Overload List

Overload | Description
FromSchemaSet(XmlSchemaSet) | Generates a new SchemaVocabulary from the XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
FromSchemaSet(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : FromSchemaSet(XmlSchemaSet) Method

schemaSet
The XmlSchemaSet to generate vocabulary from.
Generates a new SchemaVocabulary from the XSD schema set.

Syntax

Visual Basic (Declaration)
Public Shared Function FromSchemaSet( _
   ByVal schemaSet As XmlSchemaSet _
) As SchemaVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As SchemaVocabulary

value = SchemaVocabulary.FromSchemaSet(schemaSet)
C#
public static SchemaVocabulary FromSchemaSet(
   XmlSchemaSet schemaSet
)
Delphi
public function FromSchemaSet(
    schemaSet: XmlSchemaSet
): SchemaVocabulary; static;
JScript
public static function FromSchemaSet(
   schemaSet : XmlSchemaSet
) : SchemaVocabulary;
Managed Extensions for C++
public: static SchemaVocabulary* FromSchemaSet(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static SchemaVocabulary^ FromSchemaSet(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet
The XmlSchemaSet to generate vocabulary from.

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Vocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

Provides the base implementation for Fast Infoset vocabularies.

Object Model

Vocabulary Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
C#
public abstract class Vocabulary
Delphi
public class Vocabulary abstract;
JScript
public abstract class Vocabulary
Managed Extensions for C++
public __gc abstract class Vocabulary
C++/CLI
public ref class Vocabulary abstract

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.OptimizedVocabulary
Noemax.FastInfoset.ReaderVocabulary
Noemax.FastInfoset.SchemaVocabulary
Noemax.FastInfoset.WriterVocabulary

See Also

Reference

Vocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
Vocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

The following tables list the members exposed by Vocabulary.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary.
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary.
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary.
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Adds the attribute value string.
public Method | AddContentString | Adds the content string to the vocabulary.
public Method | AddElementName | Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Adds the local name to the vocabulary.
public Method | AddNamespace | Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Adds the prefix to the vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
Vocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

For a list of all members of this type, see Vocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Adds the attribute value string.
public Method | AddContentString | Adds the content string to the vocabulary.
public Method | AddElementName | Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Adds the local name to the vocabulary.
public Method | AddNamespace | Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Adds the prefix to the vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddAttributeName Method

prefix
The prefix of an attribute namespace.
name
The attribute local name.
namespaceUri
The namespace URI of an attribute.
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public abstract void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); abstract;
JScript
public __abstract function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
)
C++/CLI
public:
abstract void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
)

Parameters

prefix
The prefix of an attribute namespace.
name
The attribute local name.
namespaceUri
The namespace URI of an attribute.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddAttributeString Method

text
The attribute value string.
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public abstract void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); abstract;
JScript
public __abstract function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: abstract void AddAttributeString(
   string* text
)
C++/CLI
public:
abstract void AddAttributeString(
   String^ text
)

Parameters

text
The attribute value string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddContentString Method

text
The content string.
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim text As String

instance.AddContentString(text)
C#
public abstract void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); abstract;
JScript
public __abstract function AddContentString(
   text : String
);
Managed Extensions for C++
public: abstract void AddContentString(
   string* text
)
C++/CLI
public:
abstract void AddContentString(
   String^ text
)

Parameters

text
The content string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddElementName Method

prefix
The prefix of an element namespace.
name
The local name of the element.
namespaceUri
The namespace URI of the element qualified name.
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public abstract void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); abstract;
JScript
public __abstract function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
)
C++/CLI
public:
abstract void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
)

Parameters

prefix
The prefix of an element namespace.
name
The local name of the element.
namespaceUri
The namespace URI of the element qualified name.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddLocalName Method

name
The local name.
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim name As String

instance.AddLocalName(name)
C#
public abstract void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); abstract;
JScript
public __abstract function AddLocalName(
   name : String
);
Managed Extensions for C++
public: abstract void AddLocalName(
   string* name
)
C++/CLI
public:
abstract void AddLocalName(
   String^ name
)

Parameters

name
The local name.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddNamespace Method

namespaceUri
The namespace URI.
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public abstract void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); abstract;
JScript
public __abstract function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddNamespace(
   string* namespaceUri
)
C++/CLI
public:
abstract void AddNamespace(
   String^ namespaceUri
)

Parameters

namespaceUri
The namespace URI.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddPrefix Method

prefix
The prefix string.
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public abstract void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); abstract;
JScript
public __abstract function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: abstract void AddPrefix(
   string* prefix
)
C++/CLI
public:
abstract void AddPrefix(
   String^ prefix
)

Parameters

prefix
The prefix string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
Vocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

For a list of all members of this type, see Vocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary.
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary.
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ExternalVocabularyURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : ExternalVocabularyURI Property

Specifies the URI to an external vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Property ExternalVocabularyURI As String
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As String

instance.ExternalVocabularyURI = value

value = instance.ExternalVocabularyURI
C#
public virtual string ExternalVocabularyURI {get; set;}
Delphi
public read-write property ExternalVocabularyURI: String; virtual;
JScript
public function get,set ExternalVocabularyURI : String
Managed Extensions for C++
public: __property virtual string* get_ExternalVocabularyURI();
public: __property virtual void set_ExternalVocabularyURI(
   string* value
);
C++/CLI
public:
virtual property String^ ExternalVocabularyURI {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HasExternalVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : HasExternalVocabulary Property

Specifies whether this vocabulary is linked to an external vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasExternalVocabulary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As Boolean

value = instance.HasExternalVocabulary
C#
public virtual bool HasExternalVocabulary {get;}
Delphi
public read-only property HasExternalVocabulary: Boolean; virtual;
JScript
public function get HasExternalVocabulary : boolean
Managed Extensions for C++
public: __property virtual bool get_HasExternalVocabulary();
C++/CLI
public:
virtual property bool HasExternalVocabulary {
   bool get();
}

Property Value

true if this vocabulary is linked to an external vocabulary, false otherwise.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HasInitialVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : HasInitialVocabulary Property

Specifies whether this vocabulary uses initial read-only vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasInitialVocabulary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As Boolean

value = instance.HasInitialVocabulary
C#
public virtual bool HasInitialVocabulary {get;}
Delphi
public read-only property HasInitialVocabulary: Boolean; virtual;
JScript
public function get HasInitialVocabulary : boolean
Managed Extensions for C++
public: __property virtual bool get_HasInitialVocabulary();
C++/CLI
public:
virtual property bool HasInitialVocabulary {
   bool get();
}

Property Value

true if this vocabulary uses initial read-only vocabulary; false otherwise.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
VocabularyWriter Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : VocabularyWriter Class

Provides methods and proterties to populate the Fast Infoset vocabulary by writing an XML document.

Object Model

VocabularyWriter Class

Syntax

Visual Basic (Declaration)
Public Class VocabularyWriter
   Inherits System.Xml.XmlWriter
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
C#
public class VocabularyWriter : System.Xml.XmlWriter
Delphi
public class VocabularyWriter = class(System.Xml.XmlWriter)
JScript
public class VocabularyWriter extends System.Xml.XmlWriter
Managed Extensions for C++
public __gc class VocabularyWriter : public System.Xml.XmlWriter
C++/CLI
public ref class VocabularyWriter : public System.Xml.XmlWriter

Inheritance Hierarchy

System.Object
System.Xml.XmlWriter
Noemax.FastInfoset.VocabularyWriter

See Also

Reference

VocabularyWriter Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
VocabularyWriter Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : VocabularyWriter Class

The following tables list the members exposed by VocabularyWriter.

Public Constructors

 | Name | Description
public Constructor | VocabularyWriter Constructor | Creates a new instance of VocabualryWriter.
Top

Public Properties

 | Name | Description
public Property | Settings | (Inherited from System.Xml.XmlWriter)
public Property | WriteState | Overridden. Reports the state of the writer.
public Property | XmlLang | (Inherited from System.Xml.XmlWriter)
public Property | XmlSpace | (Inherited from System.Xml.XmlWriter)
Top

Public Methods

 | Name | Description
public Method | Close | Overridden. Finalizes writting into vocabulary and closes the VocabularyWriter.
public Method | Flush | Overridden. Flushes data into vocabulary.
public Method | LookupPrefix | Overridden. Resolves the namespace URI string into corresponding namespace prefix.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. This method does not add anything to the vocabulary.
public Method | WriteBinHex | (Inherited from System.Xml.XmlWriter)
public Method | WriteCData | Overridden. Adds the CDATA string to the vocabulary content strings table.
public Method | WriteCharEntity | Overridden. This method does not add anything to the vocabulary.
public Method | WriteChars | Overridden. Adds the string of characters to the vocabulary content string table.
public Method | WriteComment | Overridden. This method does not add anything to the vocabulary.
public Method | WriteDocType | Overridden. This method does not add anything to the vocabulary.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Adds the attribute value to the vocabulary attribute value strings table.
public Method | WriteEndDocument | Overridden. This method does not add anything to the vocabulary.
public Method | WriteEndElement | Overridden. This method does not add anything to the vocabulary.
public Method | WriteEntityRef | Overridden. This method does not add anything to the vocabulary.
public Method | WriteFullEndElement | Overridden. This method does not add anything to the vocabulary.
public Method | WriteName | (Inherited from System.Xml.XmlWriter)
public Method | WriteNmToken | (Inherited from System.Xml.XmlWriter)
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. This method does not add anything to the vocabulary.
public Method | WriteQualifiedName | (Inherited from System.Xml.XmlWriter)
public Method | WriteRaw | Overloaded. Overridden. Adds the string the vocabulary content string table.
public Method | WriteStartAttribute | Overloaded. Overridden. Adds the qualified name of an attribute into the vocabulary.
public Method | WriteStartDocument | Overloaded. Overridden. This method does not add anything to the vocabulary.
public Method | WriteStartElement | Overloaded. Overridden. This method does not add anything to the vocabulary.
public Method | WriteString | Overridden. Adds the string to the vocabulary content string table.
public Method | WriteSurrogateCharEntity | Overridden. This method does not add anything to the vocabulary.
public Method | WriteValue | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteWhitespace | Overridden. This method does not add anything to the vocabulary.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

VocabularyWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
VocabularyWriter Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : VocabularyWriter Constructor

vocabulary
The vocabulary where to write XML data.
Creates a new instance of VocabualryWriter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal vocabulary As Vocabulary _
)
Visual Basic (Usage) Copy Code
Dim vocabulary As Vocabulary

Dim instance As New VocabularyWriter(vocabulary)
C#
public VocabularyWriter(
   Vocabulary vocabulary
)
Delphi
public VocabularyWriter(
    vocabulary: Vocabulary
);
JScript
public function VocabularyWriter(
   vocabulary : Vocabulary
);
Managed Extensions for C++
public: VocabularyWriter(
   Vocabulary* vocabulary
)
C++/CLI
public:
VocabularyWriter(
   Vocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary where to write XML data.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
VocabularyWriter Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : VocabularyWriter Class

For a list of all members of this type, see VocabularyWriter members.

Public Methods

 | Name | Description
public Method | Close | Overridden. Finalizes writting into vocabulary and closes the VocabularyWriter.
public Method | Flush | Overridden. Flushes data into vocabulary.
public Method | LookupPrefix | Overridden. Resolves the namespace URI string into corresponding namespace prefix.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. This method does not add anything to the vocabulary.
public Method | WriteBinHex | (Inherited from System.Xml.XmlWriter)
public Method | WriteCData | Overridden. Adds the CDATA string to the vocabulary content strings table.
public Method | WriteCharEntity | Overridden. This method does not add anything to the vocabulary.
public Method | WriteChars | Overridden. Adds the string of characters to the vocabulary content string table.
public Method | WriteComment | Overridden. This method does not add anything to the vocabulary.
public Method | WriteDocType | Overridden. This method does not add anything to the vocabulary.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Adds the attribute value to the vocabulary attribute value strings table.
public Method | WriteEndDocument | Overridden. This method does not add anything to the vocabulary.
public Method | WriteEndElement | Overridden. This method does not add anything to the vocabulary.
public Method | WriteEntityRef | Overridden. This method does not add anything to the vocabulary.
public Method | WriteFullEndElement | Overridden. This method does not add anything to the vocabulary.
public Method | WriteName | (Inherited from System.Xml.XmlWriter)
public Method | WriteNmToken | (Inherited from System.Xml.XmlWriter)
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. This method does not add anything to the vocabulary.
public Method | WriteQualifiedName | (Inherited from System.Xml.XmlWriter)
public Method | WriteRaw | Overloaded. Overridden. Adds the string the vocabulary content string table.
public Method | WriteStartAttribute | Overloaded. Overridden. Adds the qualified name of an attribute into the vocabulary.
public Method | WriteStartDocument | Overloaded. Overridden. This method does not add anything to the vocabulary.
public Method | WriteStartElement | Overloaded. Overridden. This method does not add anything to the vocabulary.
public Method | WriteString | Overridden. Adds the string to the vocabulary content string table.
public Method | WriteSurrogateCharEntity | Overridden. This method does not add anything to the vocabulary.
public Method | WriteValue | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteWhitespace | Overridden. This method does not add anything to the vocabulary.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

VocabularyWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : Close Method

Finalizes writting into vocabulary and closes the VocabularyWriter.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : Flush Method

Flushes data into vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LookupPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : LookupPrefix Method

ns
The namespace URI to resolve.
Resolves the namespace URI string into corresponding namespace prefix.

Syntax

Visual Basic (Declaration)
Public Overrides Function LookupPrefix( _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim ns As String
Dim value As String

value = instance.LookupPrefix(ns)
C#
public override string LookupPrefix(
   string ns
)
Delphi
public function LookupPrefix(
    ns: String
): String; override;
JScript
public override function LookupPrefix(
   ns : String
) : String;
Managed Extensions for C++
public: string* LookupPrefix(
   string* ns
) override
C++/CLI
public:
String^ LookupPrefix(
   String^ ns
) override

Parameters

ns
The namespace URI to resolve.

Return Value

The prefix that corresponds to the specified namespace URI.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteBase64 Method

buffer
index
count
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBase64(buffer, index, count)
C#
public override void WriteBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBase64(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
index
count

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteCData Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteCData Method

text
The string to add to the vocabulary.
Adds the CDATA string to the vocabulary content strings table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteCData( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim text As String

instance.WriteCData(text)
C#
public override void WriteCData(
   string text
)
Delphi
public procedure WriteCData(
    text: String
); override;
JScript
public override function WriteCData(
   text : String
);
Managed Extensions for C++
public: void WriteCData(
   string* text
) override
C++/CLI
public:
void WriteCData(
   String^ text
) override

Parameters

text
The string to add to the vocabulary.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteCharEntity Method

ch
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteCharEntity( _
   ByVal ch As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim ch As Char

instance.WriteCharEntity(ch)
C#
public override void WriteCharEntity(
   char ch
)
Delphi
public procedure WriteCharEntity(
    ch: Char
); override;
JScript
public override function WriteCharEntity(
   ch : char
);
Managed Extensions for C++
public: void WriteCharEntity(
   char ch
) override
C++/CLI
public:
void WriteCharEntity(
   char ch
) override

Parameters

ch

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteChars Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteChars Method

buffer
The buffer containing characters to add.
index
The offset of the first character in buffer.
count
The number of characters to add into vocabulary.
Adds the string of characters to the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteChars(buffer, index, count)
C#
public override void WriteChars(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteChars(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteChars(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteChars(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteChars(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer containing characters to add.
index
The offset of the first character in buffer.
count
The number of characters to add into vocabulary.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteComment Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteComment Method

text
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteComment( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim text As String

instance.WriteComment(text)
C#
public override void WriteComment(
   string text
)
Delphi
public procedure WriteComment(
    text: String
); override;
JScript
public override function WriteComment(
   text : String
);
Managed Extensions for C++
public: void WriteComment(
   string* text
) override
C++/CLI
public:
void WriteComment(
   String^ text
) override

Parameters

text

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteDocType Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteDocType Method

name
pubid
sysid
subset
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim name As String
Dim pubid As String
Dim sysid As String
Dim subset As String

instance.WriteDocType(name, pubid, sysid, subset)
C#
public override void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
)
Delphi
public procedure WriteDocType(
    name: String;
    pubid: String;
    sysid: String;
    subset: String
); override;
JScript
public override function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);
Managed Extensions for C++
public: void WriteDocType(
   string* name,
   string* pubid,
   string* sysid,
   string* subset
) override
C++/CLI
public:
void WriteDocType(
   String^ name,
   String^ pubid,
   String^ sysid,
   String^ subset
) override

Parameters

name
pubid
sysid
subset

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteEndAttribute Method

Adds the attribute value to the vocabulary attribute value strings table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndAttribute()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.WriteEndAttribute()
C#
public override void WriteEndAttribute()
Delphi
public procedure WriteEndAttribute(); override;
JScript
public override function WriteEndAttribute();
Managed Extensions for C++
public: void WriteEndAttribute(); override
C++/CLI
public:
void WriteEndAttribute(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteEndDocument Method

This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndDocument()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.WriteEndDocument()
C#
public override void WriteEndDocument()
Delphi
public procedure WriteEndDocument(); override;
JScript
public override function WriteEndDocument();
Managed Extensions for C++
public: void WriteEndDocument(); override
C++/CLI
public:
void WriteEndDocument(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteEndElement Method

This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndElement()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.WriteEndElement()
C#
public override void WriteEndElement()
Delphi
public procedure WriteEndElement(); override;
JScript
public override function WriteEndElement();
Managed Extensions for C++
public: void WriteEndElement(); override
C++/CLI
public:
void WriteEndElement(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEntityRef Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteEntityRef Method

name
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEntityRef( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim name As String

instance.WriteEntityRef(name)
C#
public override void WriteEntityRef(
   string name
)
Delphi
public procedure WriteEntityRef(
    name: String
); override;
JScript
public override function WriteEntityRef(
   name : String
);
Managed Extensions for C++
public: void WriteEntityRef(
   string* name
) override
C++/CLI
public:
void WriteEntityRef(
   String^ name
) override

Parameters

name

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteFullEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteFullEndElement Method

This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteFullEndElement()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.WriteFullEndElement()
C#
public override void WriteFullEndElement()
Delphi
public procedure WriteFullEndElement(); override;
JScript
public override function WriteFullEndElement();
Managed Extensions for C++
public: void WriteFullEndElement(); override
C++/CLI
public:
void WriteFullEndElement(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteProcessingInstruction Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteProcessingInstruction Method

name
text
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim name As String
Dim text As String

instance.WriteProcessingInstruction(name, text)
C#
public override void WriteProcessingInstruction(
   string name,
   string text
)
Delphi
public procedure WriteProcessingInstruction(
    name: String;
    text: String
); override;
JScript
public override function WriteProcessingInstruction(
   name : String,
   text : String
);
Managed Extensions for C++
public: void WriteProcessingInstruction(
   string* name,
   string* text
) override
C++/CLI
public:
void WriteProcessingInstruction(
   String^ name,
   String^ text
) override

Parameters

name
text

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteRaw Method

Adds the string the vocabulary content string table.

Overload List

Overload | Description
WriteRaw(String) | Adds the string the vocabulary content string table.
WriteRaw(Char[],Int32,Int32) | Adds the string of characters to the vocabulary content string table.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteRaw Method : WriteRaw(String) Method

data
The string to add to the vocabulary.
Adds the string the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteRaw( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim data As String

instance.WriteRaw(data)
C#
public override void WriteRaw(
   string data
)
Delphi
public procedure WriteRaw(
    data: String
); override;
JScript
public override function WriteRaw(
   data : String
);
Managed Extensions for C++
public: void WriteRaw(
   string* data
) override
C++/CLI
public:
void WriteRaw(
   String^ data
) override

Parameters

data
The string to add to the vocabulary.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw(Char[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteRaw Method : WriteRaw(Char[],Int32,Int32) Method

buffer
The buffer containing characters to add.
index
The offset of the first character in buffer.
count
The number of characters to add into vocabulary.
Adds the string of characters to the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteRaw(buffer, index, count)
C#
public override void WriteRaw(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteRaw(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteRaw(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteRaw(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteRaw(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer containing characters to add.
index
The offset of the first character in buffer.
count
The number of characters to add into vocabulary.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteStartAttribute Method

Adds the qualified name of an attribute into the vocabulary.

Overload List

Overload | Description
WriteStartAttribute(String,String,String) | Adds the qualified name of an attribute into the vocabulary.
WriteStartAttribute(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartAttribute(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String,String) Method

prefix
The prefix of an attribute XML namespace.
localName
The attribute local name.
ns
The namespace URI.
Adds the qualified name of an attribute into the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartAttribute( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(prefix, localName, ns)
C#
public override void WriteStartAttribute(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartAttribute(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartAttribute(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartAttribute(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The prefix of an attribute XML namespace.
localName
The attribute local name.
ns
The namespace URI.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteStartDocument Method

This method does not add anything to the vocabulary.

Overload List

Overload | Description
WriteStartDocument(Boolean) | This method does not add anything to the vocabulary.
WriteStartDocument() | This method does not add anything to the vocabulary.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartDocument Method : WriteStartDocument(Boolean) Method

standalone
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartDocument( _
   ByVal standalone As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim standalone As Boolean

instance.WriteStartDocument(standalone)
C#
public override void WriteStartDocument(
   bool standalone
)
Delphi
public procedure WriteStartDocument(
    standalone: Boolean
); override;
JScript
public override function WriteStartDocument(
   standalone : boolean
);
Managed Extensions for C++
public: void WriteStartDocument(
   bool standalone
) override
C++/CLI
public:
void WriteStartDocument(
   bool standalone
) override

Parameters

standalone

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartDocument Method : WriteStartDocument() Method

This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartDocument()
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter

instance.WriteStartDocument()
C#
public override void WriteStartDocument()
Delphi
public procedure WriteStartDocument(); override;
JScript
public override function WriteStartDocument();
Managed Extensions for C++
public: void WriteStartDocument(); override
C++/CLI
public:
void WriteStartDocument(); override

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteStartElement Method

This method does not add anything to the vocabulary.

Overload List

Overload | Description
WriteStartElement(String,String,String) | This method does not add anything to the vocabulary.
WriteStartElement(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartElement(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartElement Method : WriteStartElement(String,String,String) Method

prefix
localName
ns
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartElement(prefix, localName, ns)
C#
public override void WriteStartElement(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartElement(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartElement(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartElement(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
localName
ns

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteString Method

text
The string to into the table.
Adds the string to the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim text As String

instance.WriteString(text)
C#
public override void WriteString(
   string text
)
Delphi
public procedure WriteString(
    text: String
); override;
JScript
public override function WriteString(
   text : String
);
Managed Extensions for C++
public: void WriteString(
   string* text
) override
C++/CLI
public:
void WriteString(
   String^ text
) override

Parameters

text
The string to into the table.

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteSurrogateCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteSurrogateCharEntity Method

lowChar
highChar
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteSurrogateCharEntity( _
   ByVal lowChar As Char, _
   ByVal highChar As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim lowChar As Char
Dim highChar As Char

instance.WriteSurrogateCharEntity(lowChar, highChar)
C#
public override void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
)
Delphi
public procedure WriteSurrogateCharEntity(
    lowChar: Char;
    highChar: Char
); override;
JScript
public override function WriteSurrogateCharEntity(
   lowChar : char,
   highChar : char
);
Managed Extensions for C++
public: void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override
C++/CLI
public:
void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override

Parameters

lowChar
highChar

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteWhitespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteWhitespace Method

ws
This method does not add anything to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteWhitespace( _
   ByVal ws As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim ws As String

instance.WriteWhitespace(ws)
C#
public override void WriteWhitespace(
   string ws
)
Delphi
public procedure WriteWhitespace(
    ws: String
); override;
JScript
public override function WriteWhitespace(
   ws : String
);
Managed Extensions for C++
public: void WriteWhitespace(
   string* ws
) override
C++/CLI
public:
void WriteWhitespace(
   String^ ws
) override

Parameters

ws

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
VocabularyWriter Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : VocabularyWriter Class

For a list of all members of this type, see VocabularyWriter members.

Public Properties

 | Name | Description
public Property | Settings | (Inherited from System.Xml.XmlWriter)
public Property | WriteState | Overridden. Reports the state of the writer.
public Property | XmlLang | (Inherited from System.Xml.XmlWriter)
public Property | XmlSpace | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

VocabularyWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteState Property
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteState Property

Reports the state of the writer.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property WriteState As WriteState
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As WriteState

value = instance.WriteState
C#
public override WriteState WriteState {get;}
Delphi
public read-only property WriteState: WriteState; override;
JScript
public override function get WriteState : WriteState
Managed Extensions for C++
public: __property WriteState get_WriteState() override;
C++/CLI
public:
property WriteState WriteState {
   WriteState get() override;
}

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriterVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

Provides a Fast Infoset vocabulary for use by XmlFastInfosetWriter.

Object Model

WriterVocabulary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WriterVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
C#
public sealed class WriterVocabulary : Vocabulary
Delphi
public class WriterVocabulary = class(Vocabulary)sealed;
JScript
public sealed class WriterVocabulary extends Vocabulary
Managed Extensions for C++
public __gc __sealed class WriterVocabulary : public Vocabulary
C++/CLI
public ref class WriterVocabulary sealed : public Vocabulary

Remarks

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.WriterVocabulary

See Also

Reference

WriterVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
WriterVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

The following tables list the members exposed by WriterVocabulary.

Public Constructors

 | Name | Description
public Constructor | WriterVocabulary Constructor | Creates a new WriterVocabulary.
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | ReadOnlyVocabulary | Returns a read-only vocabulary used by this vocabulary.
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string to the vocabulary attribute value string table.
public Method | AddContentString | Overridden. Adds the string to the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears the vocabulary.
public Method | SetExternalVocabulary | Sets an external read-only vocabulary to be used by this vocabulary.
public Method | SetInitialReadOnlyVocabulary | Overloaded. Sets an initial read-only vocabulary to be used by this vocabulary.
public Method | SetReadOnlyVocabulary | Sets a read-only vocabulary to be used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriterVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : WriterVocabulary Constructor

Creates a new WriterVocabulary.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WriterVocabulary()
C#
public WriterVocabulary()
Delphi
public WriterVocabulary();
JScript
public function WriterVocabulary();
Managed Extensions for C++
public: WriterVocabulary();
C++/CLI
public:
WriterVocabulary();

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
WriterVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

For a list of all members of this type, see WriterVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string to the vocabulary attribute value string table.
public Method | AddContentString | Overridden. Adds the string to the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears the vocabulary.
public Method | SetExternalVocabulary | Sets an external read-only vocabulary to be used by this vocabulary.
public Method | SetInitialReadOnlyVocabulary | Overloaded. Sets an initial read-only vocabulary to be used by this vocabulary.
public Method | SetReadOnlyVocabulary | Sets a read-only vocabulary to be used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddAttributeName Method

prefix
The prefix of the attribute qualified name.
localName
The local name.
namespaceUri
The namespace URI.
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String
Dim localName As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, localName, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string localName,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    localName: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* localName,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ localName,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of the attribute qualified name.
localName
The local name.
namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddAttributeString Method

text
Adds the string to the vocabulary attribute value string table.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddContentString Method

text
The string to add to the vocabulary.
Adds the string to the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text
The string to add to the vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddElementName Method

prefix
The prefix of element qualified name.
localName
The local name.
namespaceUri
The namespace URI.
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddElementName( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String
Dim localName As String
Dim namespaceUri As String

instance.AddElementName(prefix, localName, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string localName,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    localName: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* localName,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ localName,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of element qualified name.
localName
The local name.
namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddLocalName Method

name
The local name.
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name
The local name.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddNamespace Method

namespaceUri
The namespace URI.
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddPrefix Method

prefix
The prefix.
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix
The prefix.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : Clear Method

Clears the vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetExternalVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetExternalVocabulary Method

externalVocabularyURI
The URI to identify the external vocabulary in the document.
externalVocabulary
The external vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the external vocabulary.
Sets an external read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub SetExternalVocabulary( _
   ByVal externalVocabularyURI As String, _
   ByVal externalVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim externalVocabularyURI As String
Dim externalVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetExternalVocabulary(externalVocabularyURI, externalVocabulary, clear)
C#
public void SetExternalVocabulary(
   string externalVocabularyURI,
   WriterVocabulary externalVocabulary,
   bool clear
)
Delphi
public procedure SetExternalVocabulary(
    externalVocabularyURI: String;
    externalVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetExternalVocabulary(
   externalVocabularyURI : String,
   externalVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetExternalVocabulary(
   string* externalVocabularyURI,
   WriterVocabulary* externalVocabulary,
   bool clear
)
C++/CLI
public:
void SetExternalVocabulary(
   String^ externalVocabularyURI,
   WriterVocabulary^ externalVocabulary,
   bool clear
)

Parameters

externalVocabularyURI
The URI to identify the external vocabulary in the document.
externalVocabulary
The external vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the external vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetInitialReadOnlyVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetInitialReadOnlyVocabulary Method

Sets an initial read-only vocabulary to be used by this vocabulary.

Overload List

Overload | Description
SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) | Sets an initial read-only vocabulary to be used by this vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) Method

initialVocabulary
The initial vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the initial vocabulary.
Sets an initial read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub SetInitialReadOnlyVocabulary( _
   ByVal initialVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim initialVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetInitialReadOnlyVocabulary(initialVocabulary, clear)
C#
public void SetInitialReadOnlyVocabulary(
   WriterVocabulary initialVocabulary,
   bool clear
)
Delphi
public procedure SetInitialReadOnlyVocabulary(
    initialVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetInitialReadOnlyVocabulary(
   initialVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetInitialReadOnlyVocabulary(
   WriterVocabulary* initialVocabulary,
   bool clear
)
C++/CLI
public:
void SetInitialReadOnlyVocabulary(
   WriterVocabulary^ initialVocabulary,
   bool clear
)

Parameters

initialVocabulary
The initial vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the initial vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetReadOnlyVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetReadOnlyVocabulary Method

readOnlyVocabulary
The read-only vocabulary to use.
clear
If set to true then this vocabulary will be cleared prior setting the read-only vocabulary.
Sets a read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnlyVocabulary( _
   ByVal readOnlyVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim readOnlyVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetReadOnlyVocabulary(readOnlyVocabulary, clear)
C#
public void SetReadOnlyVocabulary(
   WriterVocabulary readOnlyVocabulary,
   bool clear
)
Delphi
public procedure SetReadOnlyVocabulary(
    readOnlyVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetReadOnlyVocabulary(
   readOnlyVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetReadOnlyVocabulary(
   WriterVocabulary* readOnlyVocabulary,
   bool clear
)
C++/CLI
public:
void SetReadOnlyVocabulary(
   WriterVocabulary^ readOnlyVocabulary,
   bool clear
)

Parameters

readOnlyVocabulary
The read-only vocabulary to use.
clear
If set to true then this vocabulary will be cleared prior setting the read-only vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
WriterVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

For a list of all members of this type, see WriterVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | ReadOnlyVocabulary | Returns a read-only vocabulary used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadOnlyVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : ReadOnlyVocabulary Property

Returns a read-only vocabulary used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadOnlyVocabulary As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim value As WriterVocabulary

value = instance.ReadOnlyVocabulary
C#
public WriterVocabulary ReadOnlyVocabulary {get;}
Delphi
public read-only property ReadOnlyVocabulary: WriterVocabulary;
JScript
public function get ReadOnlyVocabulary : WriterVocabulary
Managed Extensions for C++
public: __property WriterVocabulary* get_ReadOnlyVocabulary();
C++/CLI
public:
property WriterVocabulary^ ReadOnlyVocabulary {
   WriterVocabulary^ get();
}

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetFactory Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

Manages XmlFastInfosetReader and XmlFastInfosetWriter objects.

Object Model

XmlFastInfosetFactory Class

Syntax

Visual Basic (Declaration)
Public Class XmlFastInfosetFactory
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
C#
public class XmlFastInfosetFactory
Delphi
public class XmlFastInfosetFactory
JScript
public class XmlFastInfosetFactory
Managed Extensions for C++
public __gc class XmlFastInfosetFactory
C++/CLI
public ref class XmlFastInfosetFactory

Remarks

The XmlFastInfosetFactory performs pooling of XmlFastInfosetReader and XmlFastInfosetWriter instances to speed up the initialization of these objects.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.XmlFastInfosetFactory

See Also

Reference

XmlFastInfosetFactory Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetFactory Class Members
See Also Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

The following tables list the members exposed by XmlFastInfosetFactory.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetFactory Constructor |
Top

Public Methods

 | Name | Description
public Method | CreateReader | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetReader.
public Method | CreateWriter | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetWriter.
Top

See Also

Reference

XmlFastInfosetFactory Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetFactory Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : XmlFastInfosetFactory Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetFactory()
C#
public XmlFastInfosetFactory()
Delphi
public XmlFastInfosetFactory();
JScript
public function XmlFastInfosetFactory();
Managed Extensions for C++
public: XmlFastInfosetFactory();
C++/CLI
public:
XmlFastInfosetFactory();

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetFactory Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

For a list of all members of this type, see XmlFastInfosetFactory members.

Public Methods

 | Name | Description
public Method | CreateReader | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetReader.
public Method | CreateWriter | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetWriter.
Top

See Also

Reference

XmlFastInfosetFactory Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : CreateReader Method

Creates a new or reuses an existing instance of XmlFastInfosetReader.

Overload List

Overload | Description
CreateReader() | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,XmlReaderSettings) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,XmlReaderSettings) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,XmlReaderSettings,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader() Method

Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader() As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim value As XmlFastInfosetReader

value = instance.CreateReader()
C#
public XmlFastInfosetReader CreateReader()
Delphi
public function CreateReader(): XmlFastInfosetReader;
JScript
public function CreateReader() : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader();
C++/CLI
public:
XmlFastInfosetReader^ CreateReader();

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream) Method

stream
The stream containing the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream
)
Delphi
public function CreateReader(
    stream: Stream
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream
)

Parameters

stream
The stream containing the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String) Method

filename
The URI to the file containing the Fast Infoset document
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename)
C#
public XmlFastInfosetReader CreateReader(
   string filename
)
Delphi
public function CreateReader(
    filename: String
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename
)

Parameters

filename
The URI to the file containing the Fast Infoset document

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,XmlReaderSettings) Method

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal settings As XmlReaderSettings _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlReaderSettings
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, settings)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   XmlReaderSettings settings
)
Delphi
public function CreateReader(
    stream: Stream;
    settings: XmlReaderSettings
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   settings : XmlReaderSettings
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   XmlReaderSettings^ settings
)

Parameters

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(String,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,XmlReaderSettings) Method

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal settings As XmlReaderSettings _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlReaderSettings
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, settings)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   XmlReaderSettings settings
)
Delphi
public function CreateReader(
    filename: String;
    settings: XmlReaderSettings
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   settings : XmlReaderSettings
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   XmlReaderSettings^ settings
)

Parameters

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,FastInfosetCompression) Method

stream
The stream containing the Fast Infoset document.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, compression)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    stream: Stream;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   FastInfosetCompression compression
)

Parameters

stream
The stream containing the Fast Infoset document.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(String,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,FastInfosetCompression) Method

filename
The URI to the file containing the Fast Infoset document
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, compression)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    filename: String;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   FastInfosetCompression compression
)

Parameters

filename
The URI to the file containing the Fast Infoset document
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) Method

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, settings, compression)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    stream: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateReader(String,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,XmlReaderSettings,FastInfosetCompression) Method

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, settings, compression)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    filename: String;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : CreateWriter Method

Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Overload List

Overload | Description
CreateWriter() | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,XmlWriterSettings) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,XmlWriterSettings) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter() Method

Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter() As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter()
C#
public XmlFastInfosetWriter CreateWriter()
Delphi
public function CreateWriter(): XmlFastInfosetWriter;
JScript
public function CreateWriter() : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter();
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter();

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream) Method

stream
The stream to which you want to write.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream
)
Delphi
public function CreateWriter(
    stream: Stream
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream
)

Parameters

stream
The stream to which you want to write.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String) Method

filename
The URI of the file to write.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename
)
Delphi
public function CreateWriter(
    filename: String
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename
)

Parameters

filename
The URI of the file to write.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,XmlWriterSettings) Method

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal settings As XmlWriterSettings _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlWriterSettings
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, settings)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   XmlWriterSettings settings
)
Delphi
public function CreateWriter(
    stream: Stream;
    settings: XmlWriterSettings
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   settings : XmlWriterSettings
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   XmlWriterSettings^ settings
)

Parameters

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(String,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,XmlWriterSettings) Method

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal settings As XmlWriterSettings _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlWriterSettings
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, settings)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   XmlWriterSettings settings
)
Delphi
public function CreateWriter(
    filename: String;
    settings: XmlWriterSettings
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   settings : XmlWriterSettings
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   XmlWriterSettings^ settings
)

Parameters

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,FastInfosetCompression,Int32) Method

stream
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    stream: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

stream
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    stream: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(String,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,FastInfosetCompression,Int32) Method

filename
The URI of the file to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    filename: String;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

filename
The URI of the file to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) Method

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    filename: String;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

Represents a reader that provides fast, non-cached, forward-only access to Fast Infoset encoded XML data.

Object Model

XmlFastInfosetReader Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class XmlFastInfosetReader
   Inherits System.Xml.XmlReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
C#
[DefaultMemberAttribute("Item")]
public sealed class XmlFastInfosetReader : System.Xml.XmlReader
Delphi
public class XmlFastInfosetReader = class(System.Xml.XmlReader)sealed;
JScript
DefaultMemberAttribute("Item")
public sealed class XmlFastInfosetReader extends System.Xml.XmlReader
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class XmlFastInfosetReader : public System.Xml.XmlReader
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XmlFastInfosetReader sealed : public System.Xml.XmlReader

Inheritance Hierarchy

System.Object
System.Xml.XmlReader
Noemax.FastInfoset.XmlFastInfosetReader

See Also

Reference

XmlFastInfosetReader Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

The following tables list the members exposed by XmlFastInfosetReader.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetReader Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | Overridden. Gets a value indicating whether this reader can parse and resolve entities. Always returns false.
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | Overridden. Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overridden. Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class.
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | MaxDepth | Gets and sets the maximum nested node depth.
public Property | MaxNodeContentLength | Gets and sets the maximum length of the node content in bytes.
public Property | Name | Overridden. Gets the qualified name of the current node.
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of an attribute node.
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetReader class.
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadAs<T> | Reads the value from the current position in the stream as the type specified.
public Method | ReadAsBoolean | Reads a single or multiple occurrences of boolean values from the current position.
public Method | ReadAsDouble | Reads a single or multiple occurrences of double-precision floating-point values from the current position.
public Method | ReadAsFloat | Reads a single or multiple occurrences of single-precision floating-point values from the current position.
public Method | ReadAsInt | Reads a single or multiple occurrences of 32-bit integer values from the current position.
public Method | ReadAsLong | Reads a single or multiple occurrences of 64-bit integer values from the current position.
public Method | ReadAsShort | Reads a single or multiple occurrences of 16-bit integer values from the current position.
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBase64 | Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadBinHex | Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadContentAs | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsDateTime | Overridden. Reads the text content at the current position as a DateTime object.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsShort | Reads the text content at the current position as a 16-bit signed integer.
public Method | ReadContentAsString | Overridden. Reads the text content at the current position as a string.
public Method | ReadElementContentAs | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Reads the current element and returns the content as a boolean value.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Reads the node content at the current position as a decimal value.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Reads the current element and returns the content as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Reads the current element and returns the content as a single-precision floating-point number.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Reads the current element and returns the content as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Reads the current element and returns the content as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsShort | Reads the current element and returns the content as a 16-bit signed integer.
public Method | ReadElementContentAsString | Overloaded. Overridden. Reads the current element and returns the contents as a String object.
public Method | ReadElementString | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
public Method | ReadString | Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Sets the vocabulary to be used when read a Fast Infoset document.
public Method | Skip | (Inherited from System.Xml.XmlReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlFastInfosetReader Constructor

Overload List

Overload | Description
XmlFastInfosetReader Constructor() | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,FastInfosetCompression) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression) | Initializes a new instance of the XmlFastInfosetReader class.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor()
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor()

Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetReader()
C#
public XmlFastInfosetReader()
Delphi
public XmlFastInfosetReader();
JScript
public function XmlFastInfosetReader();
Managed Extensions for C++
public: XmlFastInfosetReader();
C++/CLI
public:
XmlFastInfosetReader();

Remarks

This constructor creates an instance of XmlFastInfosetReader which is is not associated with any stream and is intended for reusing the same reader for reading more than one stream.

If you use this constructor you must initialize the reader by calling Init before using it.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor(Stream)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream)

input

The stream containing the Fast Infoset encoded XML data to read.

Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream _
)
Visual Basic (Usage) Copy Code
Dim input As Stream

Dim instance As New XmlFastInfosetReader(input)
C#
public XmlFastInfosetReader(
   Stream input
)
Delphi
public XmlFastInfosetReader(
    input: Stream
);
JScript
public function XmlFastInfosetReader(
   input : Stream
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,XmlReaderSettings)

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings

Dim instance As New XmlFastInfosetReader(input, settings)
C#
public XmlFastInfosetReader(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    settings: XmlReaderSettings
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   settings : XmlReaderSettings
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor(Stream,FastInfosetCompression)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,FastInfosetCompression)

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to be used for decompressing the data.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim compression As FastInfosetCompression

Dim instance As New XmlFastInfosetReader(input, compression)
C#
public XmlFastInfosetReader(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    compression: FastInfosetCompression
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to be used for decompressing the data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression)

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used for decompressing the data.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression

Dim instance As New XmlFastInfosetReader(input, settings, compression)
C#
public XmlFastInfosetReader(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used for decompressing the data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

For a list of all members of this type, see XmlFastInfosetReader members.

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetReader class.
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadAs<T> | Reads the value from the current position in the stream as the type specified.
public Method | ReadAsBoolean | Reads a single or multiple occurrences of boolean values from the current position.
public Method | ReadAsDouble | Reads a single or multiple occurrences of double-precision floating-point values from the current position.
public Method | ReadAsFloat | Reads a single or multiple occurrences of single-precision floating-point values from the current position.
public Method | ReadAsInt | Reads a single or multiple occurrences of 32-bit integer values from the current position.
public Method | ReadAsLong | Reads a single or multiple occurrences of 64-bit integer values from the current position.
public Method | ReadAsShort | Reads a single or multiple occurrences of 16-bit integer values from the current position.
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBase64 | Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadBinHex | Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadContentAs | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsDateTime | Overridden. Reads the text content at the current position as a DateTime object.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsShort | Reads the text content at the current position as a 16-bit signed integer.
public Method | ReadContentAsString | Overridden. Reads the text content at the current position as a string.
public Method | ReadElementContentAs | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Reads the current element and returns the content as a boolean value.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Reads the node content at the current position as a decimal value.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Reads the current element and returns the content as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Reads the current element and returns the content as a single-precision floating-point number.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Reads the current element and returns the content as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Reads the current element and returns the content as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsShort | Reads the current element and returns the content as a 16-bit signed integer.
public Method | ReadElementContentAsString | Overloaded. Overridden. Reads the current element and returns the contents as a String object.
public Method | ReadElementString | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
public Method | ReadString | Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Sets the vocabulary to be used when read a Fast Infoset document.
public Method | Skip | (Inherited from System.Xml.XmlReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Clear Method

Clears the internal state of the reader.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

Clears the internal state of the reader. After a call to this method the reader remains in an uninitialized state. You must call the Init method in order to reuse the reader for reading another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Close Method

Changes the ReadState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseInput is true, the underlying stream is going to be closed as well.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Create Method

Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Overload List

Overload | Description
Create(Stream) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
Create(String) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file.
Create(Stream,XmlReaderSettings) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream using an XmlReaderSettings object.
Create(String,XmlReaderSettings) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(String,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(Stream,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
Create(Stream,XmlReaderSettings,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(String,XmlReaderSettings,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream) Method

input
The stream containing the Fast Infoset encoded XML data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input)
C#
public static XmlReader Create(
   Stream input
)
Delphi
public function Create(
    input: Stream
): XmlReader; static;
JScript
public static function Create(
   input : Stream
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input
)

Parameters

input
The stream containing the Fast Infoset encoded XML data.

Return Value

An XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String) Method

inputFileName
The system path to the file containing the Fast Infoset encoded XML data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName)
C#
public static XmlReader Create(
   string inputFileName
)
Delphi
public function Create(
    inputFileName: String
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName
)

Parameters

inputFileName
The system path to the file containing the Fast Infoset encoded XML data.

Return Value

An System.Xml.XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,XmlReaderSettings) Method

input
The stream containing the FastInfoset encoded XML data.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance. This value can be null.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, settings)
C#
public static XmlReader Create(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public function Create(
    input: Stream;
    settings: XmlReaderSettings
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   settings : XmlReaderSettings
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input
The stream containing the FastInfoset encoded XML data.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance. This value can be null.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,XmlReaderSettings) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal settings As XmlReaderSettings _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim settings As XmlReaderSettings
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, settings)
C#
public static XmlReader Create(
   string inputFileName,
   XmlReaderSettings settings
)
Delphi
public function Create(
    inputFileName: String;
    settings: XmlReaderSettings
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   settings : XmlReaderSettings
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   XmlReaderSettings* settings
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   XmlReaderSettings^ settings
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,FastInfosetCompression) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, compression)
C#
public static XmlReader Create(
   string inputFileName,
   FastInfosetCompression compression
)
Delphi
public function Create(
    inputFileName: String;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   FastInfosetCompression compression
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,FastInfosetCompression) Method

input
The stream containing the Fast Infoset encoded XML data.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, compression)
C#
public static XmlReader Create(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public function Create(
    input: Stream;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input
The stream containing the Fast Infoset encoded XML data.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,XmlReaderSettings,FastInfosetCompression) Method

input
The stream containing the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, settings, compression)
C#
public static XmlReader Create(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function Create(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input
The stream containing the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,XmlReaderSettings,FastInfosetCompression) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, settings, compression)
C#
public static XmlReader Create(
   string inputFileName,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function Create(
    inputFileName: String;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : GetAttribute Method

Gets the value of an attribute.

Overload List

Overload | Description
GetAttribute(Int32) | Gets the value of an attribute.
GetAttribute(String) | Gets the value of an attribute.
GetAttribute(String,String) | Gets the value of an attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetAttribute(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(Int32) Method

i
The index of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer
Dim value As String

value = instance.GetAttribute(i)
C#
public override string GetAttribute(
   int i
)
Delphi
public function GetAttribute(
    i: Integer
): String; override;
JScript
public override function GetAttribute(
   i : int
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   int i
) override
C++/CLI
public:
String^ GetAttribute(
   int i
) override

Parameters

i
The index of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(String) Method

name
The name of an attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As String

value = instance.GetAttribute(name)
C#
public override string GetAttribute(
   string name
)
Delphi
public function GetAttribute(
    name: String
): String; override;
JScript
public override function GetAttribute(
   name : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name
) override

Parameters

name
The name of an attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(String,String) Method

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim namespaceURI As String
Dim value As String

value = instance.GetAttribute(name, namespaceURI)
C#
public override string GetAttribute(
   string name,
   string namespaceURI
)
Delphi
public function GetAttribute(
    name: String;
    namespaceURI: String
): String; override;
JScript
public override function GetAttribute(
   name : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name,
   string* namespaceURI
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name,
   String^ namespaceURI
) override

Parameters

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Init Method

Initializes an instance of the XmlFastInfosetReader class.

Overload List

Overload | Description
Init(Stream,XmlReaderSettings) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream,XmlReaderSettings,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Byte[],Int32,Int32,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Byte[],Int32,Int32) | Initializes an instance of the XmlFastInfosetReader class.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,XmlReaderSettings) Method

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim settings As XmlReaderSettings

instance.Init(input, settings)
C#
public void Init(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public procedure Init(
    input: Stream;
    settings: XmlReaderSettings
);
JScript
public function Init(
   input : Stream,
   settings : XmlReaderSettings
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
void Init(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,XmlReaderSettings,FastInfosetCompression) Method

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
compression
The compression algorithm to be used for decompressing the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression

instance.Init(input, settings, compression)
C#
public void Init(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
compression
The compression algorithm to be used for decompressing the data.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream) Method

input

The stream containing the Fast Infoset encoded XML data to read.

Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream

instance.Init(input)
C#
public void Init(
   Stream input
)
Delphi
public procedure Init(
    input: Stream
);
JScript
public function Init(
   input : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* input
)
C++/CLI
public:
void Init(
   Stream^ input
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,FastInfosetCompression) Method

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to decompress the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim compression As FastInfosetCompression

instance.Init(input, compression)
C#
public void Init(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Stream;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : Stream,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to decompress the data.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Byte[],Int32,Int32,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Byte[],Int32,Int32,FastInfosetCompression) Method

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

compression
The compression algorithm to decompress the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input() As Byte
Dim offset As Integer
Dim length As Integer
Dim compression As FastInfosetCompression

instance.Init(input, offset, length, compression)
C#
public void Init(
   byte[] input,
   int offset,
   int length,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Bytearray of;
    offset: Integer;
    length: Integer;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : byte[],
   offset : int,
   length : int,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   byte[]* input,
   int offset,
   int length,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   array<byte>^ input,
   int offset,
   int length,
   FastInfosetCompression compression
)

Parameters

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

compression
The compression algorithm to decompress the data.

Remarks

Initializes the reader and sets it to use the provided array of bytes as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another source.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Byte[],Int32,Int32) Method

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input() As Byte
Dim offset As Integer
Dim length As Integer

instance.Init(input, offset, length)
C#
public void Init(
   byte[] input,
   int offset,
   int length
)
Delphi
public procedure Init(
    input: Bytearray of;
    offset: Integer;
    length: Integer
);
JScript
public function Init(
   input : byte[],
   offset : int,
   length : int
);
Managed Extensions for C++
public: void Init(
   byte[]* input,
   int offset,
   int length
)
C++/CLI
public:
void Init(
   array<byte>^ input,
   int offset,
   int length
)

Parameters

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

Remarks

Initializes the reader and sets it to use the provided array of bytes as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another source.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsStartElement Method

Tests if the current content node is a start element.

Overload List

Overload | Description
IsStartElement() | Tests if the current content node is a start tag.
IsStartElement(String,String) | Tests if the current content node is a start element with specified name and namespace.
IsStartElement(String) | Tests if the current content node is a start element with specified name and namespace.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsStartElement() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement() Method

Tests if the current content node is a start tag.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsStartElement()
C#
public override bool IsStartElement()
Delphi
public function IsStartElement(): Boolean; override;
JScript
public override function IsStartElement() : boolean;
Managed Extensions for C++
public: bool IsStartElement(); override
C++/CLI
public:
bool IsStartElement(); override

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement(String,String) Method

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String
Dim value As Boolean

value = instance.IsStartElement(localname, ns)
C#
public override bool IsStartElement(
   string localname,
   string ns
)
Delphi
public function IsStartElement(
    localname: String;
    ns: String
): Boolean; override;
JScript
public override function IsStartElement(
   localname : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
bool IsStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement(String) Method

name
The string to match against the Name property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.IsStartElement(name)
C#
public override bool IsStartElement(
   string name
)
Delphi
public function IsStartElement(
    name: String
): Boolean; override;
JScript
public override function IsStartElement(
   name : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* name
) override
C++/CLI
public:
bool IsStartElement(
   String^ name
) override

Parameters

name
The string to match against the Name property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LookupNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : LookupNamespace Method

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Resolves the namespace prefix in the current element's scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function LookupNamespace( _
   ByVal prefix As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim prefix As String
Dim value As String

value = instance.LookupNamespace(prefix)
C#
public override string LookupNamespace(
   string prefix
)
Delphi
public function LookupNamespace(
    prefix: String
): String; override;
JScript
public override function LookupNamespace(
   prefix : String
) : String;
Managed Extensions for C++
public: string* LookupNamespace(
   string* prefix
) override
C++/CLI
public:
String^ LookupNamespace(
   String^ prefix
) override

Parameters

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Return Value

The namespace URI to which the prefix maps or a null reference (Nothing in Visual Basic) if no matching prefix is found.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToAttribute Method

Moves to the specified attribute.

Overload List

Overload | Description
MoveToAttribute(Int32) | Moves to the attribute specified by the index.
MoveToAttribute(String) | Moves to the attribute specified by the qualified name.
MoveToAttribute(String,String) | Moves to the attribute specified by the local name and namespace URI.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToAttribute(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(Int32) Method

i
The index of the attribute.
Moves to the attribute specified by the index.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub MoveToAttribute( _
   ByVal i As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer

instance.MoveToAttribute(i)
C#
public override void MoveToAttribute(
   int i
)
Delphi
public procedure MoveToAttribute(
    i: Integer
); override;
JScript
public override function MoveToAttribute(
   i : int
);
Managed Extensions for C++
public: void MoveToAttribute(
   int i
) override
C++/CLI
public:
void MoveToAttribute(
   int i
) override

Parameters

i
The index of the attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(String) Method

name
The qualified name of the attribute.
Moves to the attribute specified by the qualified name.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.MoveToAttribute(name)
C#
public override bool MoveToAttribute(
   string name
)
Delphi
public function MoveToAttribute(
    name: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name
) override

Parameters

name
The qualified name of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(String,String) Method

name
The local name of the attribute.
ns
The namespace URI of the attribute.
Moves to the attribute specified by the local name and namespace URI.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function MoveToAttribute( _
   ByVal name As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim ns As String
Dim value As Boolean

value = instance.MoveToAttribute(name, ns)
C#
public override bool MoveToAttribute(
   string name,
   string ns
)
Delphi
public function MoveToAttribute(
    name: String;
    ns: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name,
   string* ns
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name,
   String^ ns
) override

Parameters

name
The local name of the attribute.
ns
The namespace URI of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToContent Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToContent Method

Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToContent() As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNodeType

value = instance.MoveToContent()
C#
public override XmlNodeType MoveToContent()
Delphi
public function MoveToContent(): XmlNodeType; override;
JScript
public override function MoveToContent() : XmlNodeType;
Managed Extensions for C++
public: XmlNodeType MoveToContent(); override
C++/CLI
public:
XmlNodeType MoveToContent(); override

Return Value

The NodeType of the current node found by the method or XmlNodeType.None if the reader has reached the end of the input stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToElement Method

Moves to the element that contains the current attribute node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToElement()
C#
public override bool MoveToElement()
Delphi
public function MoveToElement(): Boolean; override;
JScript
public override function MoveToElement() : boolean;
Managed Extensions for C++
public: bool MoveToElement(); override
C++/CLI
public:
bool MoveToElement(); override

Return Value

true if the reader is positioned on an attribute (the reader moves to the element that owns the attribute); false if the reader is not positioned on an attribute (the position of the reader does not change).

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToFirstAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToFirstAttribute Method

Moves to the first attribute.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToFirstAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToFirstAttribute()
C#
public override bool MoveToFirstAttribute()
Delphi
public function MoveToFirstAttribute(): Boolean; override;
JScript
public override function MoveToFirstAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToFirstAttribute(); override
C++/CLI
public:
bool MoveToFirstAttribute(); override

Return Value

true if an attribute exists (the reader moves to the first attribute); otherwise, false (the position of the reader does not change).

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MoveToNextAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToNextAttribute Method

Moves to the next attribute.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToNextAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToNextAttribute()
C#
public override bool MoveToNextAttribute()
Delphi
public function MoveToNextAttribute(): Boolean; override;
JScript
public override function MoveToNextAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToNextAttribute(); override
C++/CLI
public:
bool MoveToNextAttribute(); override

Return Value

true if there is a next attribute; false if there are no more attributes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Read Method

Reads the next node from the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.Read()
C#
public override bool Read()
Delphi
public function Read(): Boolean; override;
JScript
public override function Read() : boolean;
Managed Extensions for C++
public: bool Read(); override
C++/CLI
public:
bool Read(); override

Return Value

true if the next node was read successfully; false if there are no more nodes to read.

Remarks

When an XmlFastInfosetReader is first created and initialized, there is no information available. You must call Read to read the first node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

T
The type to which the value read should be converted to.
[image]
Noemax FastInfoset.NET
ReadAs<T> Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAs<T> Method

Reads the value from the current position in the stream as the type specified.

Syntax

Visual Basic (Declaration)
Public Function ReadAs(Of T)() As T
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As T

value = instance.ReadAs(Of T)()
C#
public T ReadAs<T>()
Delphi
public function ReadAs(): T;
JScript
public function ReadAs() : T;
Managed Extensions for C++
public: T* ReadAs<T>();
C++/CLI
public:
T^ ReadAsgeneric<typename T>
();

Type Parameters

T
The type to which the value read should be converted to.

Return Value

The value of the type T read from the stream.

Remarks

If the value in the stream was encoded as a different type, the reader converts it to the required type. For example if the stream contains a binary encoded int value and a double value was requested, the reader will perform an int to double conversion automatically.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsBoolean Method

Reads a single or multiple occurrences of boolean values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsBoolean() As Boolean()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Boolean

value = instance.ReadAsBoolean()
C#
public bool[] ReadAsBoolean()
Delphi
public function ReadAsBoolean(): array of Boolean;
JScript
public function ReadAsBoolean() : boolean[];
Managed Extensions for C++
public: bool[]* ReadAsBoolean();
C++/CLI
public:
array<bool>^ ReadAsBoolean();

Return Value

The boolean values read.

Remarks

The ReadAsBoolean method reads a single or multiple boolean values from the current position in the content.

The boolean values must have been encoded using Fast Infoset's binary encoding of boolean values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsDouble Method

Reads a single or multiple occurrences of double-precision floating-point values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsDouble() As Double()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Double

value = instance.ReadAsDouble()
C#
public double[] ReadAsDouble()
Delphi
public function ReadAsDouble(): array of Double;
JScript
public function ReadAsDouble() : double[];
Managed Extensions for C++
public: double[]* ReadAsDouble();
C++/CLI
public:
array<double>^ ReadAsDouble();

Return Value

The double-precision floating-point values read.

Remarks

The ReadAsDouble method reads a single or multiple double values from the current position in the content.

The double values must have been encoded using Fast Infoset's binary encoding of double values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsFloat Method

Reads a single or multiple occurrences of single-precision floating-point values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsFloat() As Single()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Single

value = instance.ReadAsFloat()
C#
public float[] ReadAsFloat()
Delphi
public function ReadAsFloat(): array of Single;
JScript
public function ReadAsFloat() : float[];
Managed Extensions for C++
public: float[]* ReadAsFloat();
C++/CLI
public:
array<float>^ ReadAsFloat();

Return Value

The single-precision floating-point values read.

Remarks

The ReadAsFloat method reads a single or multiple single values from the current position in the content.

The single values must have been encoded using Fast Infoset's binary encoding of single values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsInt Method

Reads a single or multiple occurrences of 32-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsInt() As Integer()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Integer

value = instance.ReadAsInt()
C#
public int[] ReadAsInt()
Delphi
public function ReadAsInt(): array of Integer;
JScript
public function ReadAsInt() : int[];
Managed Extensions for C++
public: int[]* ReadAsInt();
C++/CLI
public:
array<int>^ ReadAsInt();

Return Value

The 32-bit integer values read.

Remarks

The ReadAsInt method reads a single or multiple integer values from the current position in the content.

The integer values must have been encoded using Fast Infoset's binary encoding of integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsLong Method

Reads a single or multiple occurrences of 64-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsLong() As Long()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Long

value = instance.ReadAsLong()
C#
public long[] ReadAsLong()
Delphi
public function ReadAsLong(): array of Int64;
JScript
public function ReadAsLong() : long[];
Managed Extensions for C++
public: long[]* ReadAsLong();
C++/CLI
public:
array<int64>^ ReadAsLong();

Return Value

The 64-bit integer values read.

Remarks

The ReadAsLong method reads a single or multiple long integer values from the current position in the content.

The long integer values must have been encoded using Fast Infoset's binary encoding of long integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsShort Method

Reads a single or multiple occurrences of 16-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsShort() As Short()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Short

value = instance.ReadAsShort()
C#
public short[] ReadAsShort()
Delphi
public function ReadAsShort(): array of ShortInt;
JScript
public function ReadAsShort() : short[];
Managed Extensions for C++
public: short[]* ReadAsShort();
C++/CLI
public:
array<short>^ ReadAsShort();

Return Value

The 16-bit integer values read.

Remarks

The ReadAsShort method reads a single or multiple short integer values from the current position in the content.

The short integer values must have been encoded using Fast Infoset's binary encoding of short integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadAttributeValue Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAttributeValue Method

Reads the attribute value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadAttributeValue() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadAttributeValue()
C#
public override bool ReadAttributeValue()
Delphi
public function ReadAttributeValue(): Boolean; override;
JScript
public override function ReadAttributeValue() : boolean;
Managed Extensions for C++
public: bool ReadAttributeValue(); override
C++/CLI
public:
bool ReadAttributeValue(); override

Return Value

true if there are nodes to return. false if the reader is not positioned on an attribute node when the initial call is made or if all the attribute values have been read.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadBase64 Method

Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.

Syntax

Visual Basic (Declaration)
Public Function ReadBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadBase64()
C#
public byte[] ReadBase64()
Delphi
public function ReadBase64(): array of Byte;
JScript
public function ReadBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadBase64();
C++/CLI
public:
array<byte>^ ReadBase64();

Return Value

An array of bytes read.

Remarks

If the node at the current position is Fast Infoset binary encoded Base64 bytes, the reader returns these bytes without transformation.

If the current node is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadBinHex Method

Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.

Syntax

Visual Basic (Declaration)
Public Function ReadBinHex() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadBinHex()
C#
public byte[] ReadBinHex()
Delphi
public function ReadBinHex(): array of Byte;
JScript
public function ReadBinHex() : byte[];
Managed Extensions for C++
public: byte[]* ReadBinHex();
C++/CLI
public:
array<byte>^ ReadBinHex();

Return Value

An array of bytes read.

Remarks

If the node at the current position is Fast Infoset binary encoded BinHex bytes, the reader returns these bytes without transformation.

If the current node is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBase64 Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Overload List

Overload | Description
ReadContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
ReadContentAsBase64() | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadContentAsBase64 Method : ReadContentAsBase64(Byte[],Int32,Int32) Method

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method.
Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBase64(buffer, index, count)
C#
public override int ReadContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method.

Return Value

The number of bytes written to the buffer.

Remarks

If the content is binary encoded Base64 bytes, the reader returns the bytes read. If the content is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsBase64() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadContentAsBase64 Method : ReadContentAsBase64() Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadContentAsBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadContentAsBase64()
C#
public byte[] ReadContentAsBase64()
Delphi
public function ReadContentAsBase64(): array of Byte;
JScript
public function ReadContentAsBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadContentAsBase64();
C++/CLI
public:
array<byte>^ ReadContentAsBase64();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBinHex Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method
Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBinHex(buffer, index, count)
C#
public override int ReadContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method

Return Value

The number of bytes written to the buffer.

Remarks

If the content is binary encoded BinHex bytes, the reader returns the bytes read. If the content is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBoolean Method

Reads the content at the current position as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadContentAsBoolean()
C#
public override bool ReadContentAsBoolean()
Delphi
public function ReadContentAsBoolean(): Boolean; override;
JScript
public override function ReadContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadContentAsBoolean(); override
C++/CLI
public:
bool ReadContentAsBoolean(); override

Return Value

The content as a boolean value.

Remarks

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsDateTime Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDateTime Method

Reads the text content at the current position as a DateTime object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Date

value = instance.ReadContentAsDateTime()
C#
public override DateTime ReadContentAsDateTime()
Delphi
public function ReadContentAsDateTime(): DateTime; override;
JScript
public override function ReadContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadContentAsDateTime(); override
C++/CLI
public:
DateTime ReadContentAsDateTime(); override

Return Value

The text content as a DateTime object.

Remarks

Implements XmlReader.ReadContentAsDateTime.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsDecimal Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDecimal Method

Reads the text content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Decimal

value = instance.ReadContentAsDecimal()
C#
public override decimal ReadContentAsDecimal()
Delphi
public function ReadContentAsDecimal(): Currency; override;
JScript
public override function ReadContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadContentAsDecimal(); override
C++/CLI
public:
decimal ReadContentAsDecimal(); override

Return Value

The text content as a decimal value.

Remarks

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDouble Method

Reads the content at the current position as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Double

value = instance.ReadContentAsDouble()
C#
public override double ReadContentAsDouble()
Delphi
public function ReadContentAsDouble(): Double; override;
JScript
public override function ReadContentAsDouble() : double;
Managed Extensions for C++
public: double ReadContentAsDouble(); override
C++/CLI
public:
double ReadContentAsDouble(); override

Return Value

The content as a double-precision floating-point number.

Remarks

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsFloat Method

Reads the content at the current position as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Single

value = instance.ReadContentAsFloat()
C#
public override float ReadContentAsFloat()
Delphi
public function ReadContentAsFloat(): Single; override;
JScript
public override function ReadContentAsFloat() : float;
Managed Extensions for C++
public: float ReadContentAsFloat(); override
C++/CLI
public:
float ReadContentAsFloat(); override

Return Value

The content as a single-precision floating-point number.

Remarks

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsInt Method

Reads the text content at the current position as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.ReadContentAsInt()
C#
public override int ReadContentAsInt()
Delphi
public function ReadContentAsInt(): Integer; override;
JScript
public override function ReadContentAsInt() : int;
Managed Extensions for C++
public: int ReadContentAsInt(); override
C++/CLI
public:
int ReadContentAsInt(); override

Return Value

The content as a 32-bit signed integer.

Remarks

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsLong Method

Reads the text content at the current position as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Long

value = instance.ReadContentAsLong()
C#
public override long ReadContentAsLong()
Delphi
public function ReadContentAsLong(): Int64; override;
JScript
public override function ReadContentAsLong() : long;
Managed Extensions for C++
public: long ReadContentAsLong(); override
C++/CLI
public:
int64 ReadContentAsLong(); override

Return Value

The content as a 64-bit signed integer.

Remarks

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsShort Method

Reads the text content at the current position as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function ReadContentAsShort() As Short
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Short

value = instance.ReadContentAsShort()
C#
public short ReadContentAsShort()
Delphi
public function ReadContentAsShort(): ShortInt;
JScript
public function ReadContentAsShort() : short;
Managed Extensions for C++
public: short ReadContentAsShort();
C++/CLI
public:
short ReadContentAsShort();

Return Value

The content as a 16-bit signed integer.

Remarks

If the content is a binary encoded 16-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 16-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsString Method

Reads the text content at the current position as a string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadContentAsString()
C#
public override string ReadContentAsString()
Delphi
public function ReadContentAsString(): String; override;
JScript
public override function ReadContentAsString() : String;
Managed Extensions for C++
public: string* ReadContentAsString(); override
C++/CLI
public:
String^ ReadContentAsString(); override

Return Value

The node content as String object.

Remarks

Implements XmlReader.ReadContentAsString.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBase64 Method

Reads the binary or Base64 encoded element content and returns the decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded element content and returns the decoded bytes.
ReadElementContentAsBase64(Int32) | Reads binary or Base64 encoded element content and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads the binary or Base64 encoded element content and returns the decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBase64(buffer, index, count)
C#
public override int ReadElementContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is binary encoded Base64 bytes, the reader returns the bytes read.

If the content is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBase64(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64(Int32) Method

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads binary or Base64 encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBase64( _
   ByVal maxArrayLength As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim maxArrayLength As Integer
Dim value() As Byte

value = instance.ReadElementContentAsBase64(maxArrayLength)
C#
public byte[] ReadElementContentAsBase64(
   int maxArrayLength
)
Delphi
public function ReadElementContentAsBase64(
    maxArrayLength: Integer
): array of Byte;
JScript
public function ReadElementContentAsBase64(
   maxArrayLength : int
) : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBase64(
   int maxArrayLength
)
C++/CLI
public:
array<byte>^ ReadElementContentAsBase64(
   int maxArrayLength
)

Parameters

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

An array with bytes.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded Base64 bytes block, reader returns the bytes read.

If content is text, reader performs Base64 decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBinHex Method

Reads the binary or BinHex encoded element content and returns the decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBinHex(Byte[],Int32,Int32) | Reads the binary or BinHex encoded element content and returns the decoded bytes.
ReadElementContentAsBinHex(Int32) | Reads binary or BinHex encoded element content and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBinHex(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count

The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Reads the binary or BinHex encoded element content and returns the decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBinHex(buffer, index, count)
C#
public override int ReadElementContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count

The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is binary encoded BinHex bytes, the reader returns the bytes read.

If the content is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBinHex(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex(Int32) Method

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads binary or BinHex encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBinHex( _
   ByVal maxArrayLength As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim maxArrayLength As Integer
Dim value() As Byte

value = instance.ReadElementContentAsBinHex(maxArrayLength)
C#
public byte[] ReadElementContentAsBinHex(
   int maxArrayLength
)
Delphi
public function ReadElementContentAsBinHex(
    maxArrayLength: Integer
): array of Byte;
JScript
public function ReadElementContentAsBinHex(
   maxArrayLength : int
) : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBinHex(
   int maxArrayLength
)
C++/CLI
public:
array<byte>^ ReadElementContentAsBinHex(
   int maxArrayLength
)

Parameters

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

An array with bytes.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded BinHex bytes block, reader returns the bytes read.

If content is text, reader performs BinHex decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBoolean Method

Reads the current element and returns the content as a boolean value.

Overload List

Overload | Description
ReadElementContentAsBoolean() | Reads the current element and returns the content as a boolean value.
ReadElementContentAsBoolean(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBoolean() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean() Method

Reads the current element and returns the content as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadElementContentAsBoolean()
C#
public override bool ReadElementContentAsBoolean()
Delphi
public function ReadElementContentAsBoolean(): Boolean; override;
JScript
public override function ReadElementContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(); override
C++/CLI
public:
bool ReadElementContentAsBoolean(); override

Return Value

The element content as a boolean value.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDateTime Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDateTime Method

Reads the node content at the current position as a DateTime value.

Overload List

Overload | Description
ReadElementContentAsDateTime() | Reads the node content at the current position as a DateTime value.
ReadElementContentAsDateTime(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDateTime() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime() Method

Reads the node content at the current position as a DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Date

value = instance.ReadElementContentAsDateTime()
C#
public override DateTime ReadElementContentAsDateTime()
Delphi
public function ReadElementContentAsDateTime(): DateTime; override;
JScript
public override function ReadElementContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(); override
C++/CLI
public:
DateTime ReadElementContentAsDateTime(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDecimal Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDecimal Method

Reads the node content at the current position as a decimal value.

Overload List

Overload | Description
ReadElementContentAsDecimal() | Reads the node content at the current position as a decimal value.
ReadElementContentAsDecimal(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDecimal() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal() Method

Reads the node content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Decimal

value = instance.ReadElementContentAsDecimal()
C#
public override decimal ReadElementContentAsDecimal()
Delphi
public function ReadElementContentAsDecimal(): Currency; override;
JScript
public override function ReadElementContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(); override
C++/CLI
public:
decimal ReadElementContentAsDecimal(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDouble Method

Reads the current element and returns the content as a double-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsDouble() | Reads the current element and returns the content as a double-precision floating-point number.
ReadElementContentAsDouble(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDouble() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble() Method

Reads the current element and returns the content as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Double

value = instance.ReadElementContentAsDouble()
C#
public override double ReadElementContentAsDouble()
Delphi
public function ReadElementContentAsDouble(): Double; override;
JScript
public override function ReadElementContentAsDouble() : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(); override
C++/CLI
public:
double ReadElementContentAsDouble(); override

Return Value

The element content as a double-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsFloat Method

Reads the current element and returns the content as a single-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsFloat() | Reads the current element and returns the content as a single-precision floating-point number.
ReadElementContentAsFloat(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsFloat() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat() Method

Reads the current element and returns the content as a single-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Single

value = instance.ReadElementContentAsFloat()
C#
public override float ReadElementContentAsFloat()
Delphi
public function ReadElementContentAsFloat(): Single; override;
JScript
public override function ReadElementContentAsFloat() : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(); override
C++/CLI
public:
float ReadElementContentAsFloat(); override

Return Value

The element content as a single-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsInt Method

Reads the current element and returns the content as a 32-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsInt() | Reads the current element and returns the content as a 32-bit signed integer.
ReadElementContentAsInt(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsInt() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt() Method

Reads the current element and returns the content as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.ReadElementContentAsInt()
C#
public override int ReadElementContentAsInt()
Delphi
public function ReadElementContentAsInt(): Integer; override;
JScript
public override function ReadElementContentAsInt() : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(); override
C++/CLI
public:
int ReadElementContentAsInt(); override

Return Value

The element content as a 32-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsLong Method

Reads the current element and returns the content as a 64-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsLong() | Reads the current element and returns the content as a 64-bit signed integer.
ReadElementContentAsLong(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsLong() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong() Method

Reads the current element and returns the content as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Long

value = instance.ReadElementContentAsLong()
C#
public override long ReadElementContentAsLong()
Delphi
public function ReadElementContentAsLong(): Int64; override;
JScript
public override function ReadElementContentAsLong() : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(); override
C++/CLI
public:
int64 ReadElementContentAsLong(); override

Return Value

The element content as a 64-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsShort Method

Reads the current element and returns the content as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function ReadElementContentAsShort() As Short
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Short

value = instance.ReadElementContentAsShort()
C#
public short ReadElementContentAsShort()
Delphi
public function ReadElementContentAsShort(): ShortInt;
JScript
public function ReadElementContentAsShort() : short;
Managed Extensions for C++
public: short ReadElementContentAsShort();
C++/CLI
public:
short ReadElementContentAsShort();

Return Value

The element content as a 16-bit signed integer

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 16-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 16-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsString Method

Reads the current element and returns the contents as a String object.

Overload List

Overload | Description
ReadElementContentAsString() | Reads the current element and returns the contents as a String object.
ReadElementContentAsString(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsString() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsString Method : ReadElementContentAsString() Method

Reads the current element and returns the contents as a String object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadElementContentAsString()
C#
public override string ReadElementContentAsString()
Delphi
public function ReadElementContentAsString(): String; override;
JScript
public override function ReadElementContentAsString() : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(); override
C++/CLI
public:
String^ ReadElementContentAsString(); override

Return Value

The element content as a String.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadEndElement Method

Checks that the current content node is an end tag and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ReadEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ReadEndElement()
C#
public override void ReadEndElement()
Delphi
public procedure ReadEndElement(); override;
JScript
public override function ReadEndElement();
Managed Extensions for C++
public: void ReadEndElement(); override
C++/CLI
public:
void ReadEndElement(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadStartElement Method

Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.

Overload List

Overload | Description
ReadStartElement(String,String) | Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
ReadStartElement(String) | Checks that the current node is the element with specified qualified name and advances the reader to the next node.
ReadStartElement() | Checks that the current node is an element and advances the reader to the next node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement(String,String) Method

localname
The local name of the specified element
ns
The namespace of specified element
Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String

instance.ReadStartElement(localname, ns)
C#
public override void ReadStartElement(
   string localname,
   string ns
)
Delphi
public procedure ReadStartElement(
    localname: String;
    ns: String
); override;
JScript
public override function ReadStartElement(
   localname : String,
   ns : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
void ReadStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The local name of the specified element
ns
The namespace of specified element

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement(String) Method

name
The name of specified element.
Checks that the current node is the element with specified qualified name and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String

instance.ReadStartElement(name)
C#
public override void ReadStartElement(
   string name
)
Delphi
public procedure ReadStartElement(
    name: String
); override;
JScript
public override function ReadStartElement(
   name : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* name
) override
C++/CLI
public:
void ReadStartElement(
   String^ name
) override

Parameters

name
The name of specified element.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadStartElement() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement() Method

Checks that the current node is an element and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ReadStartElement()
C#
public override void ReadStartElement()
Delphi
public procedure ReadStartElement(); override;
JScript
public override function ReadStartElement();
Managed Extensions for C++
public: void ReadStartElement(); override
C++/CLI
public:
void ReadStartElement(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadString Method

Reads the contents of the current node into a string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadString()
C#
public override string ReadString()
Delphi
public function ReadString(): String; override;
JScript
public override function ReadString() : String;
Managed Extensions for C++
public: string* ReadString(); override
C++/CLI
public:
String^ ReadString(); override

Return Value

A string that contains the contents of the current node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ResetState Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ResetState Method

Resets the ReadState to Initial.

Syntax

Visual Basic (Declaration)
Public Sub ResetState()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ResetState()
C#
public void ResetState()
Delphi
public procedure ResetState();
JScript
public function ResetState();
Managed Extensions for C++
public: void ResetState();
C++/CLI
public:
void ResetState();

Remarks

ResetState enables you to parse multiple Fast Infoset documents in a single stream. When you reach the end of a Fast Infoset document, you can call ResetState to reset the state of the reader in preparation for the next Fast Infoset document.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ResolveEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ResolveEntity Method

Throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ResolveEntity()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ResolveEntity()
C#
public override void ResolveEntity()
Delphi
public procedure ResolveEntity(); override;
JScript
public override function ResolveEntity();
Managed Extensions for C++
public: void ResolveEntity(); override
C++/CLI
public:
void ResolveEntity(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : SetVocabulary Method

vocabulary
ReaderVocabulary to use.
Sets the vocabulary to be used when read a Fast Infoset document.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As ReaderVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim vocabulary As ReaderVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   ReaderVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: ReaderVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : ReaderVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   ReaderVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   ReaderVocabulary^ vocabulary
)

Parameters

vocabulary
ReaderVocabulary to use.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetReader Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

For a list of all members of this type, see XmlFastInfosetReader members.

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | Overridden. Gets a value indicating whether this reader can parse and resolve entities. Always returns false.
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | Overridden. Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overridden. Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class.
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | MaxDepth | Gets and sets the maximum nested node depth.
public Property | MaxNodeContentLength | Gets and sets the maximum length of the node content in bytes.
public Property | Name | Overridden. Gets the qualified name of the current node.
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of an attribute node.
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AttributeCount Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : AttributeCount Property

Gets the number of attributes on the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AttributeCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.AttributeCount
C#
public override int AttributeCount {get;}
Delphi
public read-only property AttributeCount: Integer; override;
JScript
public override function get AttributeCount : int
Managed Extensions for C++
public: __property int get_AttributeCount() override;
C++/CLI
public:
property int AttributeCount {
   int get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BaseURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : BaseURI Property

Gets the base URI of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property BaseURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.BaseURI
C#
public override string BaseURI {get;}
Delphi
public read-only property BaseURI: String; override;
JScript
public override function get BaseURI : String
Managed Extensions for C++
public: __property string* get_BaseURI() override;
C++/CLI
public:
property String^ BaseURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanReadBinaryContent Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanReadBinaryContent Property

Gets a value indicating whether this reader can parse binary content. Always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanReadBinaryContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanReadBinaryContent
C#
public override bool CanReadBinaryContent {get;}
Delphi
public read-only property CanReadBinaryContent: Boolean; override;
JScript
public override function get CanReadBinaryContent : boolean
Managed Extensions for C++
public: __property bool get_CanReadBinaryContent() override;
C++/CLI
public:
property bool CanReadBinaryContent {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanResolveEntity Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanResolveEntity Property

Gets a value indicating whether this reader can parse and resolve entities. Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanResolveEntity As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanResolveEntity
C#
public override bool CanResolveEntity {get;}
Delphi
public read-only property CanResolveEntity: Boolean; override;
JScript
public override function get CanResolveEntity : boolean
Managed Extensions for C++
public: __property bool get_CanResolveEntity() override;
C++/CLI
public:
property bool CanResolveEntity {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Depth Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Depth Property

Gets the depth of the current node in the XML document.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Depth As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.Depth
C#
public override int Depth {get;}
Delphi
public read-only property Depth: Integer; override;
JScript
public override function get Depth : int
Managed Extensions for C++
public: __property int get_Depth() override;
C++/CLI
public:
property int Depth {
   int get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EOF Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : EOF Property

Gets a value indicating whether the reader is positioned at the end of the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property EOF As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.EOF
C#
public override bool EOF {get;}
Delphi
public read-only property EOF: Boolean; override;
JScript
public override function get EOF : boolean
Managed Extensions for C++
public: __property bool get_EOF() override;
C++/CLI
public:
property bool EOF {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HasValue Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : HasValue Property

Gets a value indicating whether the current node can have a Value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property HasValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.HasValue
C#
public override bool HasValue {get;}
Delphi
public read-only property HasValue: Boolean; override;
JScript
public override function get HasValue : boolean
Managed Extensions for C++
public: __property bool get_HasValue() override;
C++/CLI
public:
property bool HasValue {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsDefault Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsDefault Property

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsDefault
C#
public override bool IsDefault {get;}
Delphi
public read-only property IsDefault: Boolean; override;
JScript
public override function get IsDefault : boolean
Managed Extensions for C++
public: __property bool get_IsDefault() override;
C++/CLI
public:
property bool IsDefault {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsEmptyElement Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsEmptyElement Property

Gets a value indicating whether the current node is an empty element.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsEmptyElement As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsEmptyElement
C#
public override bool IsEmptyElement {get;}
Delphi
public read-only property IsEmptyElement: Boolean; override;
JScript
public override function get IsEmptyElement : boolean
Managed Extensions for C++
public: __property bool get_IsEmptyElement() override;
C++/CLI
public:
property bool IsEmptyElement {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Item Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Item Property

i
Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class. Gets the value of the attribute. In C#, this property is the indexer for the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Default Property Item( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer
Dim value As String

value = instance.Item(i)
C#
public override string this(
   int i
) {get;}
Delphi
public  this: : String;(
    i: Integer
);override;  read-only
JScript
public override  this(
   i : int
) get : String
Managed Extensions for C++
public: __property string* get_Item(
   int i
) override;
C++/CLI
public:
property String^ default [int] override {
   String^ get(int i) override;
}

Parameters

i

Property Value

The value of the specified attribute.The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LocalName Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : LocalName Property

Gets the local name of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property LocalName As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.LocalName
C#
public override string LocalName {get;}
Delphi
public read-only property LocalName: String; override;
JScript
public override function get LocalName : String
Managed Extensions for C++
public: __property string* get_LocalName() override;
C++/CLI
public:
property String^ LocalName {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MaxDepth Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MaxDepth Property

Gets and sets the maximum nested node depth.

Syntax

Visual Basic (Declaration)
Public Property MaxDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

instance.MaxDepth = value

value = instance.MaxDepth
C#
public int MaxDepth {get; set;}
Delphi
public read-write property MaxDepth: Integer;
JScript
public function get,set MaxDepth : int
Managed Extensions for C++
public: __property int get_MaxDepth();
public: __property void set_MaxDepth(
   int value
);
C++/CLI
public:
property int MaxDepth {
   int get();
   void set (    int value);
}

Remarks

The default value assigned to this property during initialization of XmlFastInfosetReader is equal to Int32.MaxValue.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MaxNodeContentLength Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MaxNodeContentLength Property

Gets and sets the maximum length of the node content in bytes.

Syntax

Visual Basic (Declaration)
Public Property MaxNodeContentLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

instance.MaxNodeContentLength = value

value = instance.MaxNodeContentLength
C#
public int MaxNodeContentLength {get; set;}
Delphi
public read-write property MaxNodeContentLength: Integer;
JScript
public function get,set MaxNodeContentLength : int
Managed Extensions for C++
public: __property int get_MaxNodeContentLength();
public: __property void set_MaxNodeContentLength(
   int value
);
C++/CLI
public:
property int MaxNodeContentLength {
   int get();
   void set (    int value);
}

Remarks

This quota sets a limit on the node content length in bytes. This property applies to reading text and binary data content as well as element names, namespace URIs etc.

The default value assigned to this property during initialization of XmlFastInfosetReader is equal to Int32.MaxValue.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Name Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Name Property

Gets the qualified name of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Name
C#
public override string Name {get;}
Delphi
public read-only property Name: String; override;
JScript
public override function get Name : String
Managed Extensions for C++
public: __property string* get_Name() override;
C++/CLI
public:
property String^ Name {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
NamespaceURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NamespaceURI Property

Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NamespaceURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.NamespaceURI
C#
public override string NamespaceURI {get;}
Delphi
public read-only property NamespaceURI: String; override;
JScript
public override function get NamespaceURI : String
Managed Extensions for C++
public: __property string* get_NamespaceURI() override;
C++/CLI
public:
property String^ NamespaceURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
NameTable Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NameTable Property

Gets the XmlNameTable associated with this reader.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NameTable As XmlNameTable
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNameTable

value = instance.NameTable
C#
public override XmlNameTable NameTable {get;}
Delphi
public read-only property NameTable: XmlNameTable; override;
JScript
public override function get NameTable : XmlNameTable
Managed Extensions for C++
public: __property XmlNameTable* get_NameTable() override;
C++/CLI
public:
property XmlNameTable^ NameTable {
   XmlNameTable^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
NodeType Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NodeType Property

Gets the type of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NodeType As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNodeType

value = instance.NodeType
C#
public override XmlNodeType NodeType {get;}
Delphi
public read-only property NodeType: XmlNodeType; override;
JScript
public override function get NodeType : XmlNodeType
Managed Extensions for C++
public: __property XmlNodeType get_NodeType() override;
C++/CLI
public:
property XmlNodeType NodeType {
   XmlNodeType get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Prefix Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Prefix Property

Gets the namespace prefix associated with the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Prefix As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Prefix
C#
public override string Prefix {get;}
Delphi
public read-only property Prefix: String; override;
JScript
public override function get Prefix : String
Managed Extensions for C++
public: __property string* get_Prefix() override;
C++/CLI
public:
property String^ Prefix {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
QuoteChar Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : QuoteChar Property

Gets the quotation mark character used to enclose the value of an attribute node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property QuoteChar As Char
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Char

value = instance.QuoteChar
C#
public override char QuoteChar {get;}
Delphi
public read-only property QuoteChar: Char; override;
JScript
public override function get QuoteChar : char
Managed Extensions for C++
public: __property char get_QuoteChar() override;
C++/CLI
public:
property char QuoteChar {
   char get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadState Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadState Property

Gets the state of the reader.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReadState As ReadState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As ReadState

value = instance.ReadState
C#
public override ReadState ReadState {get;}
Delphi
public read-only property ReadState: ReadState; override;
JScript
public override function get ReadState : ReadState
Managed Extensions for C++
public: __property ReadState get_ReadState() override;
C++/CLI
public:
property ReadState ReadState {
   ReadState get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Settings Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Settings Property

Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Settings As XmlReaderSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlReaderSettings

value = instance.Settings
C#
public override XmlReaderSettings Settings {get;}
Delphi
public read-only property Settings: XmlReaderSettings; override;
JScript
public override function get Settings : XmlReaderSettings
Managed Extensions for C++
public: __property XmlReaderSettings* get_Settings() override;
C++/CLI
public:
property XmlReaderSettings^ Settings {
   XmlReaderSettings^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Value Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Value Property

Gets the text value of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Value
C#
public override string Value {get;}
Delphi
public read-only property Value: String; override;
JScript
public override function get Value : String
Managed Extensions for C++
public: __property string* get_Value() override;
C++/CLI
public:
property String^ Value {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
VocabularyProvider Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : VocabularyProvider Property

Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.

Syntax

Visual Basic (Declaration)
Public Property VocabularyProvider As IVocabularyProvider
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As IVocabularyProvider

instance.VocabularyProvider = value

value = instance.VocabularyProvider
C#
public IVocabularyProvider VocabularyProvider {get; set;}
Delphi
public read-write property VocabularyProvider: IVocabularyProvider;
JScript
public function get,set VocabularyProvider : IVocabularyProvider
Managed Extensions for C++
public: __property IVocabularyProvider* get_VocabularyProvider();
public: __property void set_VocabularyProvider(
   IVocabularyProvider* value
);
C++/CLI
public:
property IVocabularyProvider^ VocabularyProvider {
   IVocabularyProvider^ get();
   void set (    IVocabularyProvider^ value);
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

Represents a writer that provides a fast, non-cached, forward-only way of generating streams or files containing Fast Infoset encoded XML data.

Object Model

XmlFastInfosetWriter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlFastInfosetWriter
   Inherits System.Xml.XmlWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
C#
public sealed class XmlFastInfosetWriter : System.Xml.XmlWriter
Delphi
public class XmlFastInfosetWriter = class(System.Xml.XmlWriter)sealed;
JScript
public sealed class XmlFastInfosetWriter extends System.Xml.XmlWriter
Managed Extensions for C++
public __gc __sealed class XmlFastInfosetWriter : public System.Xml.XmlWriter
C++/CLI
public ref class XmlFastInfosetWriter sealed : public System.Xml.XmlWriter

Inheritance Hierarchy

System.Object
System.Xml.XmlWriter
Noemax.FastInfoset.XmlFastInfosetWriter

See Also

Reference

XmlFastInfosetWriter Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

The following tables list the members exposed by XmlFastInfosetWriter.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetWriter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AttributeStringsIndexed | Returns the number of the attribute value strings indexed in FastInfoset vocabulary.
public Property | ContentStringsIndexed | Returns the number of the element content strings indexed in FastInfoset vocabulary.
public Property | IgnoreComments | Gets and sets whether this writer should ignore calls to the WriteComment method.
public Property | IgnoreProcessingInstructions | Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | OtherStringsIndexed | Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Gets the current xml:lang scope.
public Property | XmlSpace | Overridden. Gets an XmlSpace representing the current xml:space scope.
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of XmlFastInfosetWriter.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementData | Overloaded. Writes an element containing a single value.Writes an element containing a single value.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteGuid | Writes GUID value.
public Method | WriteName | Overridden. Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.
public Method | WriteNmToken | Overridden. Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overridden. Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes a single or multiple simple-typed values.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlnsAttribute | Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlFastInfosetWriter Constructor

Overload List

Overload | Description
XmlFastInfosetWriter Constructor(Stream) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,Boolean) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor() | Initializes a new instance of the XmlFastInfosetWriter class.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream)

output
The stream to which you want to write.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim output As Stream

Dim instance As New XmlFastInfosetWriter(output)
C#
public XmlFastInfosetWriter(
   Stream output
)
Delphi
public XmlFastInfosetWriter(
    output: Stream
);
JScript
public function XmlFastInfosetWriter(
   output : Stream
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings)

output
The stream to which you want to write.
settings
XmlWriterSettings object containing writer configuratoin.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings

Dim instance As New XmlFastInfosetWriter(output, settings)
C#
public XmlFastInfosetWriter(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    settings: XmlWriterSettings
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   settings : XmlWriterSettings
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings object containing writer configuratoin.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,Boolean)

output
The stream to which you want to write.
closeOutput
If set to true writer will close the output stream when closed.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal closeOutput As Boolean _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim closeOutput As Boolean

Dim instance As New XmlFastInfosetWriter(output, closeOutput)
C#
public XmlFastInfosetWriter(
   Stream output,
   bool closeOutput
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    closeOutput: Boolean
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   closeOutput : boolean
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   bool closeOutput
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   bool closeOutput
)

Parameters

output
The stream to which you want to write.
closeOutput
If set to true writer will close the output stream when closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32)

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

Dim instance As New XmlFastInfosetWriter(output, compression, compressionLevel)
C#
public XmlFastInfosetWriter(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32)

output
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

Dim instance As New XmlFastInfosetWriter(output, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean)

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
closeOutput
If set to true writer will close the output stream when closed.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer, _
   ByVal closeOutput As Boolean _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim closeOutput As Boolean

Dim instance As New XmlFastInfosetWriter(output, compression, compressionLevel, closeOutput)
C#
public XmlFastInfosetWriter(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer;
    closeOutput: Boolean
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int,
   closeOutput : boolean
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
closeOutput
If set to true writer will close the output stream when closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Constructor()
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor()

Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetWriter()
C#
public XmlFastInfosetWriter()
Delphi
public XmlFastInfosetWriter();
JScript
public function XmlFastInfosetWriter();
Managed Extensions for C++
public: XmlFastInfosetWriter();
C++/CLI
public:
XmlFastInfosetWriter();

Remarks

This constructor creates an instance of XmlFastInfosetWriter which is is not associated to any stream and is intended for reusing the same writer for writing into more than one stream.

If you use this constructor you must initialize the reader by calling Init before using it.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

For a list of all members of this type, see XmlFastInfosetWriter members.

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of XmlFastInfosetWriter.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementData | Overloaded. Writes an element containing a single value.Writes an element containing a single value.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteGuid | Writes GUID value.
public Method | WriteName | Overridden. Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.
public Method | WriteNmToken | Overridden. Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overridden. Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes a single or multiple simple-typed values.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlnsAttribute | Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Clear Method

Clears the internal state of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

Clears the internal state of the writer. After a call to this method the writer remains in an uninitialized state. You must call Init in order to reuse the writer for writing into another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Close Method

Changes the WriteState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseOutput is set to true, the underlying stream will also be closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Create Method

Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.

Overload List

Overload | Description
Create(Stream) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
Create(String) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.
Create(Stream,XmlWriterSettings) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,XmlWriterSettings) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(Stream,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.
Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream) Method

output
The stream to which you want to write. The System.Xml.XmlWriter writes FastInfoset encoded XML and appends it to the specified stream.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output)
C#
public static XmlWriter Create(
   Stream output
)
Delphi
public function Create(
    output: Stream
): XmlWriter; static;
JScript
public static function Create(
   output : Stream
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output
)

Parameters

output
The stream to which you want to write. The System.Xml.XmlWriter writes FastInfoset encoded XML and appends it to the specified stream.

Return Value

An XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String) Method

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName)
C#
public static XmlWriter Create(
   string outputFileName
)
Delphi
public function Create(
    outputFileName: String
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName
)

Parameters

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,XmlWriterSettings) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, settings)
C#
public static XmlWriter Create(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public function Create(
    output: Stream;
    settings: XmlWriterSettings
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   settings : XmlWriterSettings
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,XmlWriterSettings) Method

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal settings As XmlWriterSettings _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim settings As XmlWriterSettings
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, settings)
C#
public static XmlWriter Create(
   string outputFileName,
   XmlWriterSettings settings
)
Delphi
public function Create(
    outputFileName: String;
    settings: XmlWriterSettings
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   settings : XmlWriterSettings
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   XmlWriterSettings* settings
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   XmlWriterSettings^ settings
)

Parameters

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,FastInfosetCompression,Int32) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, compression, compressionLevel)
C#
public static XmlWriter Create(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,FastInfosetCompression,Int32) Method

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, compression, compressionLevel)
C#
public static XmlWriter Create(
   string outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    outputFileName: String;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, settings, compression, compressionLevel)
C#
public static XmlWriter Create(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Create(String,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,XmlWriterSettings,FastInfosetCompression,Int32) Method

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, settings, compression, compressionLevel)
C#
public static XmlWriter Create(
   string outputFileName,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    outputFileName: String;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Flush Method

Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Init Method

Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Overload List

Overload | Description
Init(Stream) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,XmlWriterSettings) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,FastInfosetCompression,Int32) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream) Method

output
The stream to which you want to write.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream

instance.Init(output)
C#
public void Init(
   Stream output
)
Delphi
public procedure Init(
    output: Stream
);
JScript
public function Init(
   output : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* output
)
C++/CLI
public:
void Init(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,XmlWriterSettings) Method

output
The stream to which you want to write.
settings
XmlWriterSettings to be applied to writer.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim settings As XmlWriterSettings

instance.Init(output, settings)
C#
public void Init(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public procedure Init(
    output: Stream;
    settings: XmlWriterSettings
);
JScript
public function Init(
   output : Stream,
   settings : XmlWriterSettings
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
void Init(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings to be applied to writer.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,FastInfosetCompression,Int32) Method

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

instance.Init(output, compression, compressionLevel)
C#
public void Init(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public procedure Init(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function Init(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
void Init(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

output
The stream to which you want to write.
settings
XmlWriterSettings to be to configure the writer.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

instance.Init(output, settings, compression, compressionLevel)
C#
public void Init(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public procedure Init(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function Init(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
void Init(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings to be to configure the writer.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LookupPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : LookupPrefix Method

ns

The namespace URI whose prefix you want to find.

Returns the closest prefix defined in the current namespace scope for the namespace URI

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function LookupPrefix( _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ns As String
Dim value As String

value = instance.LookupPrefix(ns)
C#
public override string LookupPrefix(
   string ns
)
Delphi
public function LookupPrefix(
    ns: String
): String; override;
JScript
public override function LookupPrefix(
   ns : String
) : String;
Managed Extensions for C++
public: string* LookupPrefix(
   string* ns
) override
C++/CLI
public:
String^ LookupPrefix(
   String^ ns
) override

Parameters

ns

The namespace URI whose prefix you want to find.

Return Value

The matching prefix or a null reference (Nothing in Visual Basic) if no matching namespace URI is found in the current scope.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : SetVocabulary Method

vocabulary
The vocabulary to use.
Sets the vocabulary to be used when writing a Fast Infoset document.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As WriterVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim vocabulary As WriterVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   WriterVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: WriterVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : WriterVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   WriterVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   WriterVocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary to use.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteBase64 Method

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.
Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBase64(buffer, index, count)
C#
public override void WriteBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBase64(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteBinHex Method

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBinHex(buffer, index, count)
C#
public override void WriteBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBinHex(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteCData Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteCData Method

text

The text to place inside the CDATA block.

Writes out a <![CDATA[...]]> block containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteCData( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteCData(text)
C#
public override void WriteCData(
   string text
)
Delphi
public procedure WriteCData(
    text: String
); override;
JScript
public override function WriteCData(
   text : String
);
Managed Extensions for C++
public: void WriteCData(
   string* text
) override
C++/CLI
public:
void WriteCData(
   String^ text
) override

Parameters

text

The text to place inside the CDATA block.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteCharEntity Method

ch

The Unicode character for which to generate a character entity.

Forces the generation of a character entity for the specified Unicode character value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteCharEntity( _
   ByVal ch As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ch As Char

instance.WriteCharEntity(ch)
C#
public override void WriteCharEntity(
   char ch
)
Delphi
public procedure WriteCharEntity(
    ch: Char
); override;
JScript
public override function WriteCharEntity(
   ch : char
);
Managed Extensions for C++
public: void WriteCharEntity(
   char ch
) override
C++/CLI
public:
void WriteCharEntity(
   char ch
) override

Parameters

ch

The Unicode character for which to generate a character entity.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteChars Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteChars Method

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

Writes text one buffer at a time.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteChars(buffer, index, count)
C#
public override void WriteChars(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteChars(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteChars(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteChars(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteChars(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteComment Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteComment Method

text

The text to place inside the comment.

Writes out a comment containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteComment( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteComment(text)
C#
public override void WriteComment(
   string text
)
Delphi
public procedure WriteComment(
    text: String
); override;
JScript
public override function WriteComment(
   text : String
);
Managed Extensions for C++
public: void WriteComment(
   string* text
) override
C++/CLI
public:
void WriteComment(
   String^ text
) override

Parameters

text

The text to place inside the comment.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

If RemoveComments is set to true, the writer ignores all calls to this method.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteDocType Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteDocType Method

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String
Dim pubid As String
Dim sysid As String
Dim subset As String

instance.WriteDocType(name, pubid, sysid, subset)
C#
public override void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
)
Delphi
public procedure WriteDocType(
    name: String;
    pubid: String;
    sysid: String;
    subset: String
); override;
JScript
public override function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);
Managed Extensions for C++
public: void WriteDocType(
   string* name,
   string* pubid,
   string* sysid,
   string* subset
) override
C++/CLI
public:
void WriteDocType(
   String^ name,
   String^ pubid,
   String^ sysid,
   String^ subset
) override

Parameters

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

Remarks

Writing DOCTYPE is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteElementData Method

Writes an element containing a single value.Writes an element containing a single value.

Overload List

Overload | Description
WriteElementData(String,String,Int32) | Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Int64) | Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Int16) | Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Double) | Encodes a double-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Single) | Encodes a single-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Boolean) | Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int32) | Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int64) | Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int16) | Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Double) | Encodes a double-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Single) | Encodes a single-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Boolean) | Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int32) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Integer

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   int value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Integer
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : int
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   int value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   int value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int64) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Long

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   long value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Int64
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : long
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   long value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   int64 value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int16) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Short

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   short value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: ShortInt
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : short
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   short value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   short value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Double) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a double-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Double

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   double value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Double
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : double
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   double value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   double value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Single) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a single-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Single

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   float value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Single
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : float
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   float value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   float value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,String,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Boolean) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Boolean

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   bool value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Boolean
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : boolean
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   bool value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   bool value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int32) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Integer

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   int value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Integer
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : int
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   int value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   int value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int64) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Long

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   long value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Int64
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : long
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   long value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   int64 value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int16) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Short

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   short value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: ShortInt
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : short
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   short value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   short value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Double) Method

localName
The local name of the element.
value
The value of the element.
Encodes a double-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Double

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   double value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Double
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : double
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   double value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   double value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Single) Method

localName
The local name of the element.
value
The value of the element.
Encodes a single-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Single

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   float value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Single
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : float
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   float value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   float value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementData(String,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Boolean) Method

localName
The local name of the element.
value
The value of the element.
Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Boolean

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   bool value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Boolean
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : boolean
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   bool value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   bool value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndAttribute Method

Closes the previous WriteStartAttribute call.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndAttribute()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndAttribute()
C#
public override void WriteEndAttribute()
Delphi
public procedure WriteEndAttribute(); override;
JScript
public override function WriteEndAttribute();
Managed Extensions for C++
public: void WriteEndAttribute(); override
C++/CLI
public:
void WriteEndAttribute(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndDocument Method

Closes any open elements or attributes and changes the WriteState to Start.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndDocument()
C#
public override void WriteEndDocument()
Delphi
public procedure WriteEndDocument(); override;
JScript
public override function WriteEndDocument();
Managed Extensions for C++
public: void WriteEndDocument(); override
C++/CLI
public:
void WriteEndDocument(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndElement()
C#
public override void WriteEndElement()
Delphi
public procedure WriteEndElement(); override;
JScript
public override function WriteEndElement();
Managed Extensions for C++
public: void WriteEndElement(); override
C++/CLI
public:
void WriteEndElement(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteEntityRef Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEntityRef Method

name

The name of the entity reference.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEntityRef( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteEntityRef(name)
C#
public override void WriteEntityRef(
   string name
)
Delphi
public procedure WriteEntityRef(
    name: String
); override;
JScript
public override function WriteEntityRef(
   name : String
);
Managed Extensions for C++
public: void WriteEntityRef(
   string* name
) override
C++/CLI
public:
void WriteEntityRef(
   String^ name
) override

Parameters

name

The name of the entity reference.

Remarks

Writing of entity references is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteFullEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteFullEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteFullEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteFullEndElement()
C#
public override void WriteFullEndElement()
Delphi
public procedure WriteFullEndElement(); override;
JScript
public override function WriteFullEndElement();
Managed Extensions for C++
public: void WriteFullEndElement(); override
C++/CLI
public:
void WriteFullEndElement(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteGuid Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteGuid Method

value
Guid value to write.
Writes GUID value.

Syntax

Visual Basic (Declaration)
Public Sub WriteGuid( _
   ByVal value As Guid _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Guid

instance.WriteGuid(value)
C#
public void WriteGuid(
   Guid value
)
Delphi
public procedure WriteGuid(
    value: Guid
);
JScript
public function WriteGuid(
   value : Guid
);
Managed Extensions for C++
public: void WriteGuid(
   Guid value
)
C++/CLI
public:
void WriteGuid(
   Guid value
)

Parameters

value
Guid value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteName Method

name

The name to write.

Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteName(name)
C#
public override void WriteName(
   string name
)
Delphi
public procedure WriteName(
    name: String
); override;
JScript
public override function WriteName(
   name : String
);
Managed Extensions for C++
public: void WriteName(
   string* name
) override
C++/CLI
public:
void WriteName(
   String^ name
) override

Parameters

name

The name to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNmToken Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteNmToken Method

name

The name to write.

Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteNmToken( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteNmToken(name)
C#
public override void WriteNmToken(
   string name
)
Delphi
public procedure WriteNmToken(
    name: String
); override;
JScript
public override function WriteNmToken(
   name : String
);
Managed Extensions for C++
public: void WriteNmToken(
   string* name
) override
C++/CLI
public:
void WriteNmToken(
   String^ name
) override

Parameters

name

The name to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteProcessingInstruction Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteProcessingInstruction Method

name
The name of the processing instruction.
text

The text to include in the processing instruction.

Writes out a processing instruction.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String
Dim text As String

instance.WriteProcessingInstruction(name, text)
C#
public override void WriteProcessingInstruction(
   string name,
   string text
)
Delphi
public procedure WriteProcessingInstruction(
    name: String;
    text: String
); override;
JScript
public override function WriteProcessingInstruction(
   name : String,
   text : String
);
Managed Extensions for C++
public: void WriteProcessingInstruction(
   string* name,
   string* text
) override
C++/CLI
public:
void WriteProcessingInstruction(
   String^ name,
   String^ text
) override

Parameters

name
The name of the processing instruction.
text

The text to include in the processing instruction.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteQualifiedName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteQualifiedName Method

localName
The local name to write.
ns

The namespace URI for the name.

Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteQualifiedName( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteQualifiedName(localName, ns)
C#
public override void WriteQualifiedName(
   string localName,
   string ns
)
Delphi
public procedure WriteQualifiedName(
    localName: String;
    ns: String
); override;
JScript
public override function WriteQualifiedName(
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteQualifiedName(
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteQualifiedName(
   String^ localName,
   String^ ns
) override

Parameters

localName
The local name to write.
ns

The namespace URI for the name.

Remarks

If ns maps to the current default namespace, no prefix is generated.

This method generates a prefix if ns is not found.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteRaw Method

This method is not supported.

Overload List

Overload | Description
WriteRaw(Char[],Int32,Int32) | This method is not supported.
WriteRaw(String) | This method is not supported.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw(Char[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteRaw Method : WriteRaw(Char[],Int32,Int32) Method

buffer
The character array containing the text to write.
index
The position within the buffer indicating the start of the text to write.
count

The number of characters to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteRaw(buffer, index, count)
C#
public override void WriteRaw(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteRaw(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteRaw(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteRaw(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteRaw(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The character array containing the text to write.
index
The position within the buffer indicating the start of the text to write.
count

The number of characters to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteRaw(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteRaw Method : WriteRaw(String) Method

data

The string containing the text to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteRaw( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim data As String

instance.WriteRaw(data)
C#
public override void WriteRaw(
   string data
)
Delphi
public procedure WriteRaw(
    data: String
); override;
JScript
public override function WriteRaw(
   data : String
);
Managed Extensions for C++
public: void WriteRaw(
   string* data
) override
C++/CLI
public:
void WriteRaw(
   String^ data
) override

Parameters

data

The string containing the text to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartAttribute Method

Writes the start of an attribute.

Overload List

Overload | Description
WriteStartAttribute(String,String,String) | Writes the start of an attribute.
WriteStartAttribute(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartAttribute(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String,String) Method

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

Writes the start of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartAttribute( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(prefix, localName, ns)
C#
public override void WriteStartAttribute(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartAttribute(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartAttribute(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartAttribute(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartDocument Method

Writes the XML declaration with the version "1.0".

Overload List

Overload | Description
WriteStartDocument() | Writes the XML declaration with the version "1.0".
WriteStartDocument(Boolean) | Writes the XML declaration with the version "1.0".

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartDocument Method : WriteStartDocument() Method

Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteStartDocument()
C#
public override void WriteStartDocument()
Delphi
public procedure WriteStartDocument(); override;
JScript
public override function WriteStartDocument();
Managed Extensions for C++
public: void WriteStartDocument(); override
C++/CLI
public:
void WriteStartDocument(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartDocument(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartDocument Method : WriteStartDocument(Boolean) Method

standalone
Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartDocument( _
   ByVal standalone As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim standalone As Boolean

instance.WriteStartDocument(standalone)
C#
public override void WriteStartDocument(
   bool standalone
)
Delphi
public procedure WriteStartDocument(
    standalone: Boolean
); override;
JScript
public override function WriteStartDocument(
   standalone : boolean
);
Managed Extensions for C++
public: void WriteStartDocument(
   bool standalone
) override
C++/CLI
public:
void WriteStartDocument(
   bool standalone
) override

Parameters

standalone

Remarks

Since XmlFastInfosetWriter does not preserve the original XML declaration, standalone is ignored.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartElement Method

Writes the specified start tag.

Overload List

Overload | Description
WriteStartElement(String,String,String) | Writes the specified start tag.
WriteStartElement(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartElement(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String,String,String) Method

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.
Writes the specified start tag.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartElement(prefix, localName, ns)
C#
public override void WriteStartElement(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartElement(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartElement(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartElement(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteString Method

text

The text to write.

Writes the given text content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteString(text)
C#
public override void WriteString(
   string text
)
Delphi
public procedure WriteString(
    text: String
); override;
JScript
public override function WriteString(
   text : String
);
Managed Extensions for C++
public: void WriteString(
   string* text
) override
C++/CLI
public:
void WriteString(
   String^ text
) override

Parameters

text

The text to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteSurrogateCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteSurrogateCharEntity Method

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

Writes a Unicode surrogate char pair.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteSurrogateCharEntity( _
   ByVal lowChar As Char, _
   ByVal highChar As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim lowChar As Char
Dim highChar As Char

instance.WriteSurrogateCharEntity(lowChar, highChar)
C#
public override void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
)
Delphi
public procedure WriteSurrogateCharEntity(
    lowChar: Char;
    highChar: Char
); override;
JScript
public override function WriteSurrogateCharEntity(
   lowChar : char,
   highChar : char
);
Managed Extensions for C++
public: void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override
C++/CLI
public:
void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override

Parameters

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteValue Method

Writes a single or multiple simple-typed values.

Overload List

Overload | Description
WriteValue(Object) | Writes the value.
WriteValue(Int32[]) | Encodes a single or multiple 32-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Int64[]) | Encodes a single or multiple 64-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Int16[]) | Encodes a single or multiple 16-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Double[]) | Encodes a single or multiple double-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Single[]) | Encodes a single or multiple single-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Boolean[]) | Encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Decimal[]) | Encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Boolean) | Writes a boolean value.
WriteValue(Double) | Writes a double-precision floating point value.
WriteValue(Single) | Writes a single-precision floating point value.
WriteValue(Int64) | Writes a 64-bit signed integer value.
WriteValue(Int32) | Writes a 32-bit signed integer.
WriteValue(Int16) | Writes a 16-bit signed integer value.
WriteValue(TimeSpan) | Write TimeSpan value.
WriteValue(Decimal) | Write Decimal value.
WriteValue(DateTime) | Write DateTime value.
WriteValue(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Object) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Object) Method

value
The object representing the value to write.

Writes the value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Object

instance.WriteValue(value)
C#
public override void WriteValue(
   object value
)
Delphi
public procedure WriteValue(
    value: TObject
); override;
JScript
public override function WriteValue(
   value : Object
);
Managed Extensions for C++
public: void WriteValue(
   Object* value
) override
C++/CLI
public:
void WriteValue(
   Object^ value
) override

Parameters

value
The object representing the value to write.

Remarks

This method takes the common language runtime (CLR) object and converts the input value to the desired output type using the FastInfoset encoding rules. If the type cannot not be represented as a binary encoded value it's serialized as a string according to the XML Schema definition language (XSD) data type conversion rules.

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int32[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int32[]) Method

value
The array containing a single or multiple 32-bit signed integers.

Encodes a single or multiple 32-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Integer

instance.WriteValue(value)
C#
public new void WriteValue(
   int[] value
)
Delphi
public procedure WriteValue(
    value: Integerarray of
);
JScript
public hide function WriteValue(
   value : int[]
);
Managed Extensions for C++
public: new void WriteValue(
   int[]* value
)
C++/CLI
public:
new void WriteValue(
   array<int>^ value
)

Parameters

value
The array containing a single or multiple 32-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int64[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int64[]) Method

value
The array containing a single or multiple 64-bit signed integers.

Encodes a single or multiple 64-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Long

instance.WriteValue(value)
C#
public new void WriteValue(
   long[] value
)
Delphi
public procedure WriteValue(
    value: Int64array of
);
JScript
public hide function WriteValue(
   value : long[]
);
Managed Extensions for C++
public: new void WriteValue(
   long[]* value
)
C++/CLI
public:
new void WriteValue(
   array<int64>^ value
)

Parameters

value
The array containing a single or multiple 64-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int16[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int16[]) Method

value
The array containing a single or multiple 16-bit signed integers.

Encodes a single or multiple 16-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Short

instance.WriteValue(value)
C#
public new void WriteValue(
   short[] value
)
Delphi
public procedure WriteValue(
    value: ShortIntarray of
);
JScript
public hide function WriteValue(
   value : short[]
);
Managed Extensions for C++
public: new void WriteValue(
   short[]* value
)
C++/CLI
public:
new void WriteValue(
   array<short>^ value
)

Parameters

value
The array containing a single or multiple 16-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Double[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Double[]) Method

value
The array containing a single or multiple double-precision floating-point numbers.

Encodes a single or multiple double-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Double

instance.WriteValue(value)
C#
public new void WriteValue(
   double[] value
)
Delphi
public procedure WriteValue(
    value: Doublearray of
);
JScript
public hide function WriteValue(
   value : double[]
);
Managed Extensions for C++
public: new void WriteValue(
   double[]* value
)
C++/CLI
public:
new void WriteValue(
   array<double>^ value
)

Parameters

value
The array containing a single or multiple double-precision floating-point numbers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Single[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Single[]) Method

value
The array containing a single or multiple single-precision floating-point numbers.

Encodes a single or multiple single-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Single

instance.WriteValue(value)
C#
public new void WriteValue(
   float[] value
)
Delphi
public procedure WriteValue(
    value: Singlearray of
);
JScript
public hide function WriteValue(
   value : float[]
);
Managed Extensions for C++
public: new void WriteValue(
   float[]* value
)
C++/CLI
public:
new void WriteValue(
   array<float>^ value
)

Parameters

value
The array containing a single or multiple single-precision floating-point numbers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Boolean[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Boolean[]) Method

value
The array containing a single or multiple boolean values.

Encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Boolean

instance.WriteValue(value)
C#
public new void WriteValue(
   bool[] value
)
Delphi
public procedure WriteValue(
    value: Booleanarray of
);
JScript
public hide function WriteValue(
   value : boolean[]
);
Managed Extensions for C++
public: new void WriteValue(
   bool[]* value
)
C++/CLI
public:
new void WriteValue(
   array<bool>^ value
)

Parameters

value
The array containing a single or multiple boolean values.

Remarks

This method encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Decimal[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Decimal[]) Method

value
The array containing a single or multiple decimal values.

Encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Decimal

instance.WriteValue(value)
C#
public new void WriteValue(
   decimal[] value
)
Delphi
public procedure WriteValue(
    value: Currencyarray of
);
JScript
public hide function WriteValue(
   value : decimal[]
);
Managed Extensions for C++
public: new void WriteValue(
   decimal[]* value
)
C++/CLI
public:
new void WriteValue(
   array<decimal>^ value
)

Parameters

value
The array containing a single or multiple decimal values.

Remarks

This method encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Boolean) Method

value

The boolean value to write.

Writes a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.WriteValue(value)
C#
public override void WriteValue(
   bool value
)
Delphi
public procedure WriteValue(
    value: Boolean
); override;
JScript
public override function WriteValue(
   value : boolean
);
Managed Extensions for C++
public: void WriteValue(
   bool value
) override
C++/CLI
public:
void WriteValue(
   bool value
) override

Parameters

value

The boolean value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Double) Method

value

The double-precision floating-point value to write.

Writes a double-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Double

instance.WriteValue(value)
C#
public override void WriteValue(
   double value
)
Delphi
public procedure WriteValue(
    value: Double
); override;
JScript
public override function WriteValue(
   value : double
);
Managed Extensions for C++
public: void WriteValue(
   double value
) override
C++/CLI
public:
void WriteValue(
   double value
) override

Parameters

value

The double-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Single) Method

value

The single-precision floating-point value to write.

Writes a single-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Single

instance.WriteValue(value)
C#
public override void WriteValue(
   float value
)
Delphi
public procedure WriteValue(
    value: Single
); override;
JScript
public override function WriteValue(
   value : float
);
Managed Extensions for C++
public: void WriteValue(
   float value
) override
C++/CLI
public:
void WriteValue(
   float value
) override

Parameters

value

The single-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int64) Method

value

The 64-bit signed integer value to write.

Writes a 64-bit signed integer value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Long

instance.WriteValue(value)
C#
public override void WriteValue(
   long value
)
Delphi
public procedure WriteValue(
    value: Int64
); override;
JScript
public override function WriteValue(
   value : long
);
Managed Extensions for C++
public: void WriteValue(
   long value
) override
C++/CLI
public:
void WriteValue(
   int64 value
) override

Parameters

value

The 64-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int32) Method

value

The 32-bit signed integer value to write.

Writes a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.WriteValue(value)
C#
public override void WriteValue(
   int value
)
Delphi
public procedure WriteValue(
    value: Integer
); override;
JScript
public override function WriteValue(
   value : int
);
Managed Extensions for C++
public: void WriteValue(
   int value
) override
C++/CLI
public:
void WriteValue(
   int value
) override

Parameters

value

The 32-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int16) Method

value

The 16-bit signed integer value to write.

Writes a 16-bit signed integer value.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Short

instance.WriteValue(value)
C#
public new void WriteValue(
   short value
)
Delphi
public procedure WriteValue(
    value: ShortInt
);
JScript
public hide function WriteValue(
   value : short
);
Managed Extensions for C++
public: new void WriteValue(
   short value
)
C++/CLI
public:
new void WriteValue(
   short value
)

Parameters

value

The 16-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(TimeSpan) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(TimeSpan) Method

value
TimeSpan value to write.
Write TimeSpan value.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As TimeSpan

instance.WriteValue(value)
C#
public new void WriteValue(
   TimeSpan value
)
Delphi
public procedure WriteValue(
    value: TimeSpan
);
JScript
public hide function WriteValue(
   value : TimeSpan
);
Managed Extensions for C++
public: new void WriteValue(
   TimeSpan value
)
C++/CLI
public:
new void WriteValue(
   TimeSpan value
)

Parameters

value
TimeSpan value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Decimal) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Decimal) Method

value
Decimal value to writer.
Write Decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Decimal

instance.WriteValue(value)
C#
public override void WriteValue(
   decimal value
)
Delphi
public procedure WriteValue(
    value: Currency
); override;
JScript
public override function WriteValue(
   value : decimal
);
Managed Extensions for C++
public: void WriteValue(
   decimal value
) override
C++/CLI
public:
void WriteValue(
   decimal value
) override

Parameters

value
Decimal value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(DateTime) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(DateTime) Method

value
DateTime value to writer.
Write DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Date

instance.WriteValue(value)
C#
public override void WriteValue(
   DateTime value
)
Delphi
public procedure WriteValue(
    value: DateTime
); override;
JScript
public override function WriteValue(
   value : DateTime
);
Managed Extensions for C++
public: void WriteValue(
   DateTime value
) override
C++/CLI
public:
void WriteValue(
   DateTime value
) override

Parameters

value
DateTime value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteWhitespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteWhitespace Method

ws

The string of white space characters.

Writes out the given white space.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteWhitespace( _
   ByVal ws As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ws As String

instance.WriteWhitespace(ws)
C#
public override void WriteWhitespace(
   string ws
)
Delphi
public procedure WriteWhitespace(
    ws: String
); override;
JScript
public override function WriteWhitespace(
   ws : String
);
Managed Extensions for C++
public: void WriteWhitespace(
   string* ws
) override
C++/CLI
public:
void WriteWhitespace(
   String^ ws
) override

Parameters

ws

The string of white space characters.

Remarks

XmlFastInfosetWriter does not preserve non-significant white space unless it's written within the scope of the element with the xml:space attribute set to "true" (xml:space="true").

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteXmlnsAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteXmlnsAttribute Method

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.
Writes a namespace declaration attribute.

Syntax

Visual Basic (Declaration)
Public Sub WriteXmlnsAttribute( _
   ByVal prefix As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim namespaceUri As String

instance.WriteXmlnsAttribute(prefix, namespaceUri)
C#
public void WriteXmlnsAttribute(
   string prefix,
   string namespaceUri
)
Delphi
public procedure WriteXmlnsAttribute(
    prefix: String;
    namespaceUri: String
);
JScript
public function WriteXmlnsAttribute(
   prefix : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void WriteXmlnsAttribute(
   string* prefix,
   string* namespaceUri
)
C++/CLI
public:
void WriteXmlnsAttribute(
   String^ prefix,
   String^ namespaceUri
)

Parameters

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriter Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

For a list of all members of this type, see XmlFastInfosetWriter members.

Public Properties

 | Name | Description
public Property | AttributeStringsIndexed | Returns the number of the attribute value strings indexed in FastInfoset vocabulary.
public Property | ContentStringsIndexed | Returns the number of the element content strings indexed in FastInfoset vocabulary.
public Property | IgnoreComments | Gets and sets whether this writer should ignore calls to the WriteComment method.
public Property | IgnoreProcessingInstructions | Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | OtherStringsIndexed | Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Gets the current xml:lang scope.
public Property | XmlSpace | Overridden. Gets an XmlSpace representing the current xml:space scope.
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
AttributeStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : AttributeStringsIndexed Property

Returns the number of the attribute value strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AttributeStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.AttributeStringsIndexed
C#
public int AttributeStringsIndexed {get;}
Delphi
public read-only property AttributeStringsIndexed: Integer;
JScript
public function get AttributeStringsIndexed : int
Managed Extensions for C++
public: __property int get_AttributeStringsIndexed();
C++/CLI
public:
property int AttributeStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ContentStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : ContentStringsIndexed Property

Returns the number of the element content strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.ContentStringsIndexed
C#
public int ContentStringsIndexed {get;}
Delphi
public read-only property ContentStringsIndexed: Integer;
JScript
public function get ContentStringsIndexed : int
Managed Extensions for C++
public: __property int get_ContentStringsIndexed();
C++/CLI
public:
property int ContentStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IgnoreComments Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : IgnoreComments Property

Gets and sets whether this writer should ignore calls to the WriteComment method.

Syntax

Visual Basic (Declaration)
Public Property IgnoreComments As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.IgnoreComments = value

value = instance.IgnoreComments
C#
public bool IgnoreComments {get; set;}
Delphi
public read-write property IgnoreComments: Boolean;
JScript
public function get,set IgnoreComments : boolean
Managed Extensions for C++
public: __property bool get_IgnoreComments();
public: __property void set_IgnoreComments(
   bool value
);
C++/CLI
public:
property bool IgnoreComments {
   bool get();
   void set (    bool value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IgnoreProcessingInstructions Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : IgnoreProcessingInstructions Property

Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.

Syntax

Visual Basic (Declaration)
Public Property IgnoreProcessingInstructions As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.IgnoreProcessingInstructions = value

value = instance.IgnoreProcessingInstructions
C#
public bool IgnoreProcessingInstructions {get; set;}
Delphi
public read-write property IgnoreProcessingInstructions: Boolean;
JScript
public function get,set IgnoreProcessingInstructions : boolean
Managed Extensions for C++
public: __property bool get_IgnoreProcessingInstructions();
public: __property void set_IgnoreProcessingInstructions(
   bool value
);
C++/CLI
public:
property bool IgnoreProcessingInstructions {
   bool get();
   void set (    bool value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that may be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum number of strings specifies up to how many strings may be added to the vocabulary. When this limit is reached, no more values are added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : MaxVocabularyStringLength Property

Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum string length specifies the maximum number of characters that a string value may contain in order to be added to the vocabulary. Longer values are not added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
OtherStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : OtherStringsIndexed Property

Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OtherStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.OtherStringsIndexed
C#
public int OtherStringsIndexed {get;}
Delphi
public read-only property OtherStringsIndexed: Integer;
JScript
public function get OtherStringsIndexed : int
Managed Extensions for C++
public: __property int get_OtherStringsIndexed();
C++/CLI
public:
property int OtherStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Profile Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Profile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property Profile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlFastInfosetWriterProfile

instance.Profile = value

value = instance.Profile
C#
public XmlFastInfosetWriterProfile Profile {get; set;}
Delphi
public read-write property Profile: XmlFastInfosetWriterProfile;
JScript
public function get,set Profile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_Profile();
public: __property void set_Profile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ Profile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Settings Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Settings Property

Gets the XmlWriterSettings object used to create this XmlWriter instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Settings As XmlWriterSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlWriterSettings

value = instance.Settings
C#
public override XmlWriterSettings Settings {get;}
Delphi
public read-only property Settings: XmlWriterSettings; override;
JScript
public override function get Settings : XmlWriterSettings
Managed Extensions for C++
public: __property XmlWriterSettings* get_Settings() override;
C++/CLI
public:
property XmlWriterSettings^ Settings {
   XmlWriterSettings^ get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteState Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteState Property

Gets the state of the writer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property WriteState As WriteState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As WriteState

value = instance.WriteState
C#
public override WriteState WriteState {get;}
Delphi
public read-only property WriteState: WriteState; override;
JScript
public override function get WriteState : WriteState
Managed Extensions for C++
public: __property WriteState get_WriteState() override;
C++/CLI
public:
property WriteState WriteState {
   WriteState get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlLang Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlLang Property

Gets the current xml:lang scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As String

value = instance.XmlLang
C#
public override string XmlLang {get;}
Delphi
public read-only property XmlLang: String; override;
JScript
public override function get XmlLang : String
Managed Extensions for C++
public: __property string* get_XmlLang() override;
C++/CLI
public:
property String^ XmlLang {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlSpace Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlSpace Property

Gets an XmlSpace representing the current xml:space scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlSpace

value = instance.XmlSpace
C#
public override XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace; override;
JScript
public override function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property XmlSpace get_XmlSpace() override;
C++/CLI
public:
property XmlSpace XmlSpace {
   XmlSpace get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

Contains the settings that specify the way FastInfoset serializes primitive data types.

Object Model

XmlFastInfosetWriterProfile Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
C#
public sealed class XmlFastInfosetWriterProfile
Delphi
public class XmlFastInfosetWriterProfile sealed;
JScript
public sealed class XmlFastInfosetWriterProfile
Managed Extensions for C++
public __gc __sealed class XmlFastInfosetWriterProfile
C++/CLI
public ref class XmlFastInfosetWriterProfile sealed

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.XmlFastInfosetWriterProfile

See Also

Reference

XmlFastInfosetWriterProfile Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

The following tables list the members exposed by XmlFastInfosetWriterProfile.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetWriterProfile Constructor | Overloaded.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Basic | The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
static (Shared in Visual Basic) | Compact | The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
static (Shared in Visual Basic) | DotNet | This profile is obsolete. If selected, the Basic profile will be used instead.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
static (Shared in Visual Basic) | Literal | Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a copy cone of the XmlFastInfosetWriterProfile.
public Method | CopyFrom | Coppies all properties from already existing XmlFastInfosetWriterProfile object.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : XmlFastInfosetWriterProfile Constructor

Overload List

Overload | Description
XmlFastInfosetWriterProfile Constructor | Initializes a new instance of XmlFastInfosetWriterProfile by coping settings of already exisitng one.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : XmlFastInfosetWriterProfile Constructor

source
The profile to copy settings from.
Initializes a new instance of XmlFastInfosetWriterProfile by coping settings of already exisitng one.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As XmlFastInfosetWriterProfile _
)
Visual Basic (Usage) Copy Code
Dim source As XmlFastInfosetWriterProfile

Dim instance As New XmlFastInfosetWriterProfile(source)
C#
public XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile source
)
Delphi
public XmlFastInfosetWriterProfile(
    source: XmlFastInfosetWriterProfile
);
JScript
public function XmlFastInfosetWriterProfile(
   source : XmlFastInfosetWriterProfile
);
Managed Extensions for C++
public: XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile* source
)
C++/CLI
public:
XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile^ source
)

Parameters

source
The profile to copy settings from.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

For a list of all members of this type, see XmlFastInfosetWriterProfile members.

Public Methods

 | Name | Description
public Method | Clone | Creates a copy cone of the XmlFastInfosetWriterProfile.
public Method | CopyFrom | Coppies all properties from already existing XmlFastInfosetWriterProfile object.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clone Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Clone Method

Creates a copy cone of the XmlFastInfosetWriterProfile.

Syntax

Visual Basic (Declaration)
Public Function Clone() As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetWriterProfile

value = instance.Clone()
C#
public XmlFastInfosetWriterProfile Clone()
Delphi
public function Clone(): XmlFastInfosetWriterProfile;
JScript
public function Clone() : XmlFastInfosetWriterProfile;
Managed Extensions for C++
public: XmlFastInfosetWriterProfile* Clone();
C++/CLI
public:
XmlFastInfosetWriterProfile^ Clone();

Return Value

The clone of this object.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyFrom Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : CopyFrom Method

source
The source XmlFastInfosetWriterProfile object to copy properties from.
Coppies all properties from already existing XmlFastInfosetWriterProfile object.

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal source As XmlFastInfosetWriterProfile _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim source As XmlFastInfosetWriterProfile

instance.CopyFrom(source)
C#
public void CopyFrom(
   XmlFastInfosetWriterProfile source
)
Delphi
public procedure CopyFrom(
    source: XmlFastInfosetWriterProfile
);
JScript
public function CopyFrom(
   source : XmlFastInfosetWriterProfile
);
Managed Extensions for C++
public: void CopyFrom(
   XmlFastInfosetWriterProfile* source
)
C++/CLI
public:
void CopyFrom(
   XmlFastInfosetWriterProfile^ source
)

Parameters

source
The source XmlFastInfosetWriterProfile object to copy properties from.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
XmlFastInfosetWriterProfile Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

For a list of all members of this type, see XmlFastInfosetWriterProfile members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Basic | The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
static (Shared in Visual Basic) | Compact | The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
static (Shared in Visual Basic) | DotNet | This profile is obsolete. If selected, the Basic profile will be used instead.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
static (Shared in Visual Basic) | Literal | Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Basic Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Basic Property

The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Basic As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Basic
C#
public static XmlFastInfosetWriterProfile Basic {get;}
Delphi
public read-only property Basic: XmlFastInfosetWriterProfile; static;
JScript
public static function get Basic : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Basic();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Basic {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BooleanFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : BooleanFormat Property

Gets and sets the format used to serialize boolean values.

Syntax

Visual Basic (Declaration)
Public Property BooleanFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.BooleanFormat = value

value = instance.BooleanFormat
C#
public XmlFastInfosetFormat BooleanFormat {get; set;}
Delphi
public read-write property BooleanFormat: XmlFastInfosetFormat;
JScript
public function get,set BooleanFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_BooleanFormat();
public: __property void set_BooleanFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat BooleanFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Compact Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Compact Property

The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Compact As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Compact
C#
public static XmlFastInfosetWriterProfile Compact {get;}
Delphi
public read-only property Compact: XmlFastInfosetWriterProfile; static;
JScript
public static function get Compact : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Compact();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Compact {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DateTimeFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DateTimeFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
Public Property DateTimeFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DateTimeFormat = value

value = instance.DateTimeFormat
C#
public XmlFastInfosetFormat DateTimeFormat {get; set;}
Delphi
public read-write property DateTimeFormat: XmlFastInfosetFormat;
JScript
public function get,set DateTimeFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DateTimeFormat();
public: __property void set_DateTimeFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DateTimeFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DecimalFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DecimalFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
Public Property DecimalFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DecimalFormat = value

value = instance.DecimalFormat
C#
public XmlFastInfosetFormat DecimalFormat {get; set;}
Delphi
public read-write property DecimalFormat: XmlFastInfosetFormat;
JScript
public function get,set DecimalFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DecimalFormat();
public: __property void set_DecimalFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DecimalFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DotNet Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DotNet Property

This profile is obsolete. If selected, the Basic profile will be used instead.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DotNet As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.DotNet
C#
public static XmlFastInfosetWriterProfile DotNet {get;}
Delphi
public read-only property DotNet: XmlFastInfosetWriterProfile; static;
JScript
public static function get DotNet : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_DotNet();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ DotNet {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DoubleFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DoubleFormat Property

Gets and sets the format used to serialize double precision floating point values.

Syntax

Visual Basic (Declaration)
Public Property DoubleFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DoubleFormat = value

value = instance.DoubleFormat
C#
public XmlFastInfosetFormat DoubleFormat {get; set;}
Delphi
public read-write property DoubleFormat: XmlFastInfosetFormat;
JScript
public function get,set DoubleFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DoubleFormat();
public: __property void set_DoubleFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DoubleFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
FloatFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : FloatFormat Property

Gets and sets the format used to serialize floating point values.

Syntax

Visual Basic (Declaration)
Public Property FloatFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.FloatFormat = value

value = instance.FloatFormat
C#
public XmlFastInfosetFormat FloatFormat {get; set;}
Delphi
public read-write property FloatFormat: XmlFastInfosetFormat;
JScript
public function get,set FloatFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_FloatFormat();
public: __property void set_FloatFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat FloatFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GuidFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : GuidFormat Property

Gets and sets the format used to serialize guild values.

Syntax

Visual Basic (Declaration)
Public Property GuidFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.GuidFormat = value

value = instance.GuidFormat
C#
public XmlFastInfosetFormat GuidFormat {get; set;}
Delphi
public read-write property GuidFormat: XmlFastInfosetFormat;
JScript
public function get,set GuidFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_GuidFormat();
public: __property void set_GuidFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat GuidFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IntFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : IntFormat Property

Gets and sets the format used to encode integer values.

Syntax

Visual Basic (Declaration)
Public Property IntFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.IntFormat = value

value = instance.IntFormat
C#
public XmlFastInfosetFormat IntFormat {get; set;}
Delphi
public read-write property IntFormat: XmlFastInfosetFormat;
JScript
public function get,set IntFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_IntFormat();
public: __property void set_IntFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat IntFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Literal Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Literal Property

Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Literal As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Literal
C#
public static XmlFastInfosetWriterProfile Literal {get;}
Delphi
public read-only property Literal: XmlFastInfosetWriterProfile; static;
JScript
public static function get Literal : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Literal();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Literal {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LongFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : LongFormat Property

Gets and sets the format used to encode long integer values.

Syntax

Visual Basic (Declaration)
Public Property LongFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.LongFormat = value

value = instance.LongFormat
C#
public XmlFastInfosetFormat LongFormat {get; set;}
Delphi
public read-write property LongFormat: XmlFastInfosetFormat;
JScript
public function get,set LongFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_LongFormat();
public: __property void set_LongFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat LongFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ShortFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : ShortFormat Property

Gets and sets the format used to serialize short integer values.

Syntax

Visual Basic (Declaration)
Public Property ShortFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.ShortFormat = value

value = instance.ShortFormat
C#
public XmlFastInfosetFormat ShortFormat {get; set;}
Delphi
public read-write property ShortFormat: XmlFastInfosetFormat;
JScript
public function get,set ShortFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_ShortFormat();
public: __property void set_ShortFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat ShortFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
TimeSpanFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : TimeSpanFormat Property

Gets and sets the format used to encode TimeSpan values.

Syntax

Visual Basic (Declaration)
Public Property TimeSpanFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.TimeSpanFormat = value

value = instance.TimeSpanFormat
C#
public XmlFastInfosetFormat TimeSpanFormat {get; set;}
Delphi
public read-write property TimeSpanFormat: XmlFastInfosetFormat;
JScript
public function get,set TimeSpanFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_TimeSpanFormat();
public: __property void set_TimeSpanFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat TimeSpanFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
FastInfosetCompression Enumeration
See Also Send Feedback
Noemax.FastInfoset Namespace : FastInfosetCompression Enumeration

Defines the compression algorithm to be used for compressing and decompressing data.

Syntax

Visual Basic (Declaration)
Public Enum FastInfosetCompression
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetCompression
C#
public enum FastInfosetCompression : System.Enum
Delphi
public enum FastInfosetCompression = class(System.Enum)
JScript
public enum FastInfosetCompression extends System.Enum
Managed Extensions for C++
__value public enum FastInfosetCompression : public System.Enum
C++/CLI
public enum class FastInfosetCompression : public System.Enum

Members

Member | Description
Deflate | DEFLATE compression algorithm.
GZip | GZIP compression algorithm.
Lzf | LZF compression algorithm.
Lzf3 | LZF3 compression algorithm.
Lzma | LZMA compression algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.FastInfoset.FastInfosetCompression

See Also

Reference

Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlFastInfosetFormat Enumeration
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFormat Enumeration

Defines the way that Fast Infoset serializes primitive data types.

Syntax

Visual Basic (Declaration)
Public Enum XmlFastInfosetFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFormat
C#
public enum XmlFastInfosetFormat : System.Enum
Delphi
public enum XmlFastInfosetFormat = class(System.Enum)
JScript
public enum XmlFastInfosetFormat extends System.Enum
Managed Extensions for C++
__value public enum XmlFastInfosetFormat : public System.Enum
C++/CLI
public enum class XmlFastInfosetFormat : public System.Enum

Members

Member | Description
Binary | Encodes values in a binary format. Provides higher processing performance than Literal and Restricted Alphabet.
DotNet | This format is obsolete.
Literal | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
LiteralNoIndex | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
RestrictedAlphabet | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.
RestrictedAlphabetNoIndex | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.

Remarks

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. However, if there are few repeating values of the same data type then it might be preferable not to use indexing.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.FastInfoset.XmlFastInfosetFormat

See Also

Reference

Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IVocabularyProvider Interface
Members See Also Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

Defines the interface for resolving URI references to Fast Infoset vocabularies.

Syntax

Visual Basic (Declaration)
Public Interface IVocabularyProvider
Visual Basic (Usage) Copy Code
Dim instance As IVocabularyProvider
C#
public interface IVocabularyProvider
Delphi
public interface IVocabularyProvider
JScript
public interface IVocabularyProvider
Managed Extensions for C++
public __gc __interface IVocabularyProvider
C++/CLI
public interface class IVocabularyProvider

See Also

Reference

IVocabularyProvider Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
IVocabularyProvider Interface Members
See Also Methods Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

The following tables list the members exposed by IVocabularyProvider.

Public Methods

 | Name | Description
Method | ProvideVocabulary | Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.
Top

See Also

Reference

IVocabularyProvider Interface
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
IVocabularyProvider Interface Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

For a list of all members of this type, see IVocabularyProvider members.

Public Methods

 | Name | Description
Method | ProvideVocabulary | Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.
Top

See Also

Reference

IVocabularyProvider Interface
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ProvideVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > IVocabularyProvider Interface : ProvideVocabulary Method

uri
The URI to resolve.
reader
The reader to which vocabulary will be provided.
Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.

Syntax

Visual Basic (Declaration)
Sub ProvideVocabulary( _
   ByVal uri As String, _
   ByVal reader As XmlFastInfosetReader _
)
Visual Basic (Usage) Copy Code
Dim instance As IVocabularyProvider
Dim uri As String
Dim reader As XmlFastInfosetReader

instance.ProvideVocabulary(uri, reader)
C#
void ProvideVocabulary(
   string uri,
   XmlFastInfosetReader reader
)
Delphi
procedure ProvideVocabulary(
    uri: String;
    reader: XmlFastInfosetReader
);
JScript
function ProvideVocabulary(
   uri : String,
   reader : XmlFastInfosetReader
);
Managed Extensions for C++
void ProvideVocabulary(
   string* uri,
   XmlFastInfosetReader* reader
)
C++/CLI
void ProvideVocabulary(
   String^ uri,
   XmlFastInfosetReader^ reader
)

Parameters

uri
The URI to resolve.
reader
The reader to which vocabulary will be provided.

Remarks

The XmlFastInfosetReader calls this method when an external vocabulary URI is encountered within a document. The implementation of the IVocabularyProvider must resolve the vocabulary URI and, if found, call the SetVocabulary method of the specified reader instance.

See Also

Reference

IVocabularyProvider Interface
IVocabularyProvider Members


%%ItemTitle%%

Noemax.GZip Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | DeflateInputStream | Provides methods and properties for decompressing streams using the DEFLATE algorithm.
Class | DeflateOutputStream | Provides methods and properties for compressing streams using the DEFLATE algorithm.
Class | DeflateStream | Provides methods and properties for processing streams using the DEFLATE algorithm.
Class | ExtraFieldCollection | Represents a collection of GZip header fields.
Class | GZipHeaderField | Represents a GZip header field.
Class | GZipInputStream | Provides methods and properties to decompress GZIP stream.
Class | GZipOutputStream | Provides the compression stream writing GZip streams and files.
Class | GZipStream | Provides methods and properties for processing streams using GZIP.
Class | InvalidInputException | The exception that is thrown when a compressed input stream is in an invalid format.

Enumerations

 | Enumeration | Description
Enumeration | CompressionMode | Defines the compression modes for GZipStream.

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

Provides methods and properties for decompressing streams using the DEFLATE algorithm.

Object Model

DeflateInputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
C#
public class DeflateInputStream : System.IO.Stream
Delphi
public class DeflateInputStream = class(System.IO.Stream)
JScript
public class DeflateInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateInputStream : public System.IO.Stream
C++/CLI
public ref class DeflateInputStream : public System.IO.Stream

Remarks

By default, DeflateInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateInputStream

See Also

Reference

DeflateInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
DeflateInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

The following tables list the members exposed by DeflateInputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : DeflateInputStream Constructor

Overload List

Overload | Description
DeflateInputStream Constructor(String) | Initializes a new instance of DeflateInputStream
DeflateInputStream Constructor(Stream,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream,Boolean,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream) | Initializes a new instance of DeflateInputStream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of DeflateInputStream

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New DeflateInputStream(fileName)
C#
public DeflateInputStream(
   string fileName
)
Delphi
public DeflateInputStream(
    fileName: String
);
JScript
public function DeflateInputStream(
   fileName : String
);
Managed Extensions for C++
public: DeflateInputStream(
   string* fileName
)
C++/CLI
public:
DeflateInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Constructor(Stream,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen, zlibHeader)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New DeflateInputStream(stream)
C#
public DeflateInputStream(
   Stream stream
)
Delphi
public DeflateInputStream(
    stream: Stream
);
JScript
public function DeflateInputStream(
   stream : Stream
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
DeflateInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Close Method

Closes the stream and releases any associated resources.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
DeflateInputStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Restart Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Restart Method

Restarts the decompression starting from current possition of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Restart()
C#
public void Restart()
Delphi
public procedure Restart();
JScript
public function Restart();
Managed Extensions for C++
public: void Restart();
C++/CLI
public:
void Restart();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
DeflateInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BytesBuffered Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BytesBuffered Property

Returns the number of unprocessed bytes in DeflateInputStream buffer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BytesBuffered As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.BytesBuffered
C#
public int BytesBuffered {get;}
Delphi
public read-only property BytesBuffered: Integer;
JScript
public function get BytesBuffered : int
Managed Extensions for C++
public: __property int get_BytesBuffered();
C++/CLI
public:
property int BytesBuffered {
   int get();
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanRead Property

This property always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

Provides methods and properties for compressing streams using the DEFLATE algorithm.

Object Model

DeflateOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
C#
public class DeflateOutputStream : System.IO.Stream
Delphi
public class DeflateOutputStream = class(System.IO.Stream)
JScript
public class DeflateOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateOutputStream : public System.IO.Stream
C++/CLI
public ref class DeflateOutputStream : public System.IO.Stream

Remarks

By default, DeflateOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateOutputStream

See Also

Reference

DeflateOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
DeflateOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

The following tables list the members exposed by DeflateOutputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : DeflateOutputStream Constructor

Overload List

Overload | Description
DeflateOutputStream Constructor(String,Int32) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32) | Initializes a new instance DeflateOutputStream class.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(String,Int32)

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(fileName, compressionLevel)
C#
public DeflateOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(stream, compressionLevel)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
DeflateOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
DeflateOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Finish Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Finish Method

Concludes compression and flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Finish()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Finish()
C#
public void Finish()
Delphi
public procedure Finish();
JScript
public function Finish();
Managed Extensions for C++
public: void Finish();
C++/CLI
public:
void Finish();

Remarks

Finish concludes compression by writing the markup indicating the end of compressed data and flushing the content of the internal buffer.

After this method has been called, no more data can be written to this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Overload List

Overload | Description
Flush() | Flushes the content of the internal buffer to the underlying stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Flush() Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Finish or Close method is called.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
DeflateOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

This property is always true if Finish has not been called. After Finish has been called this property is false.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

Provides methods and properties for processing streams using the DEFLATE algorithm.

Object Model

DeflateStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
C#
public class DeflateStream : System.IO.Stream
Delphi
public class DeflateStream = class(System.IO.Stream)
JScript
public class DeflateStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateStream : public System.IO.Stream
C++/CLI
public ref class DeflateStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateStream

See Also

Reference

DeflateStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
DeflateStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateStream Class

The following tables list the members exposed by DeflateStream.

Public Constructors

 | Name | Description
public Constructor | DeflateStream Constructor | Overloaded. Initializes a new instance of the DeflateStream class.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Flushes the content of internal buffer and closes the current stream. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : DeflateStream Constructor

Initializes a new instance of the DeflateStream class.

Overload List

Overload | Description
DeflateStream Constructor(String,CompressionMode) | Initializes a new instance of DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(String,CompressionMode)

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New DeflateStream(fileName, mode)
C#
public DeflateStream(
   string fileName,
   CompressionMode mode
)
Delphi
public DeflateStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. There is no limit in the size of the stream to be compressed.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New DeflateStream(stream, mode)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default DeflateStream owns the underlying stream, so closing this stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New DeflateStream(stream, mode, compressionLevel)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
DeflateStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Flushes the content of internal buffer and closes the current stream. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Dispose Method

Flushes the content of internal buffer and closes the current stream.

Overload List

Overload | Description
Dispose(Boolean) | Flushes the content of internal buffer and closes the current stream.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
DeflateStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ExtraFieldCollection Class
Members See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

Represents a collection of GZip header fields.

Object Model

ExtraFieldCollection Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class ExtraFieldCollection
Delphi
public class ExtraFieldCollection sealed;
JScript
DefaultMemberAttribute("Item")
public sealed class ExtraFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class ExtraFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ExtraFieldCollection sealed

Inheritance Hierarchy

System.Object
Noemax.GZip.ExtraFieldCollection

See Also

Reference

ExtraFieldCollection Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
ExtraFieldCollection Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

The following tables list the members exposed by ExtraFieldCollection.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
ExtraFieldCollection Class Methods
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Add Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Add Method

Adds the header to the list of GZip headers.

Overload List

Overload | Description
Add(Int32,Byte[]) | Adds the header to the list of GZip headers.
Add(Byte,Byte,Byte[]) | Adds the header to the list of GZip headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Add(Int32,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Int32,Byte[]) Method

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id As Integer, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim data() As Byte

instance.Add(id, data)
C#
public void Add(
   int id,
   byte[] data
)
Delphi
public procedure Add(
    id: Integer;
    data: Bytearray of
);
JScript
public function Add(
   id : int,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   int id,
   byte[]* data
)
C++/CLI
public:
void Add(
   int id,
   array<byte>^ data
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Add(Byte, Byte, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Add(Byte,Byte,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Byte,Byte,Byte[]) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim data() As Byte

instance.Add(id1, id2, data)
C#
public void Add(
   byte id1,
   byte id2,
   byte[] data
)
Delphi
public procedure Add(
    id1: Byte;
    id2: Byte;
    data: Bytearray of
);
JScript
public function Add(
   id1 : byte,
   id2 : byte,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   byte id1,
   byte id2,
   byte[]* data
)
C++/CLI
public:
void Add(
   byte id1,
   byte id2,
   array<byte>^ data
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Add(Int32, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Clear Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Clear Method

Clears the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : CopyTo Method

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

Copies the content of the collection into an array of GZipHeaderField.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As GZipHeaderField, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim array() As GZipHeaderField
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   GZipHeaderField[] array,
   int arrayIndex
)
Delphi
public procedure CopyTo(
    array: GZipHeaderFieldarray of;
    arrayIndex: Integer
);
JScript
public function CopyTo(
   array : GZipHeaderField[],
   arrayIndex : int
);
Managed Extensions for C++
public: void CopyTo(
   GZipHeaderField*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<GZipHeaderField^>^ array,
   int arrayIndex
)

Parameters

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Get Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Get Method

Gets the header.Gets the header.

Overload List

Overload | Description
Get(Byte,Byte) | Gets the header associated with the ID represented as two ANSI character octet.
Get(Int32) | Gets the GZip header specified by its index in the list of headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Get(Byte,Byte) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Byte,Byte) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
Gets the header associated with the ID represented as two ANSI character octet.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim value() As Byte

value = instance.Get(id1, id2)
C#
public byte[] Get(
   byte id1,
   byte id2
)
Delphi
public function Get(
    id1: Byte;
    id2: Byte
): array of Byte;
JScript
public function Get(
   id1 : byte,
   id2 : byte
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   byte id1,
   byte id2
)
C++/CLI
public:
array<byte>^ Get(
   byte id1,
   byte id2
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Get(Int32) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Get(Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Int32) Method

index
The index of the header field.
Gets the GZip header specified by its index in the list of headers.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal index As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value() As Byte

value = instance.Get(index)
C#
public byte[] Get(
   int index
)
Delphi
public function Get(
    index: Integer
): array of Byte;
JScript
public function Get(
   index : int
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   int index
)
C++/CLI
public:
array<byte>^ Get(
   int index
)

Parameters

index
The index of the header field.

Return Value

The array of bytes stored in the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetByID Method

id
The 16-bit unsigned integer identifier of the header field.
Gets the header associated with the ID represented as a 16-bit unsigned integer. Gets the header.

Syntax

Visual Basic (Declaration)
Public Function GetByID( _
   ByVal id As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim value() As Byte

value = instance.GetByID(id)
C#
public byte[] GetByID(
   int id
)
Delphi
public function GetByID(
    id: Integer
): array of Byte;
JScript
public function GetByID(
   id : int
) : byte[];
Managed Extensions for C++
public: byte[]* GetByID(
   int id
)
C++/CLI
public:
array<byte>^ GetByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Get(Byte, Byte) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetEnumerator Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetEnumerator Method

Gets a list of items in a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of GZipHeaderField)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As IEnumerator(Of GZipHeaderField)

value = instance.GetEnumerator()
C#
public IEnumerator<GZipHeaderField> GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: IEnumerator<GZipHeaderField*>* GetEnumerator();
C++/CLI
public:
IEnumerator<GZipHeaderField^>^ GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Remove Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Remove Method

index
The index of header field.
Removes the header with the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Delphi
public procedure Remove(
    index: Integer
);
JScript
public function Remove(
   index : int
);
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index
The index of header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
RemoveByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : RemoveByID Method

id
The 16-bit unsigned integer identifier of the header field.

Removes the header specified by the 16-bit unsigned integer ID.

Syntax

Visual Basic (Declaration)
Public Sub RemoveByID( _
   ByVal id As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer

instance.RemoveByID(id)
C#
public void RemoveByID(
   int id
)
Delphi
public procedure RemoveByID(
    id: Integer
);
JScript
public function RemoveByID(
   id : int
);
Managed Extensions for C++
public: void RemoveByID(
   int id
)
C++/CLI
public:
void RemoveByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
ExtraFieldCollection Class Properties
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Count Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Count Property

Gets the number of contained headers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
IsReadOnly Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean;
JScript
public function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Item Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Item Property

index
Gets the header at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value As GZipHeaderField

value = instance.Item(index)
C#
public GZipHeaderField this(
   int index
) {get;}
Delphi
public  this: : GZipHeaderField;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : GZipHeaderField
Managed Extensions for C++
public: __property GZipHeaderField* get_Item(
   int index
);
C++/CLI
public:
property GZipHeaderField^ default [int] {
   GZipHeaderField^ get(int index);
}

Parameters

index

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipHeaderField Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

Represents a GZip header field.

Object Model

GZipHeaderField Class

Syntax

Visual Basic (Declaration)
Public Class GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
C#
public class GZipHeaderField
Delphi
public class GZipHeaderField
JScript
public class GZipHeaderField
Managed Extensions for C++
public __gc class GZipHeaderField
C++/CLI
public ref class GZipHeaderField

Inheritance Hierarchy

System.Object
Noemax.GZip.GZipHeaderField

See Also

Reference

GZipHeaderField Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
GZipHeaderField Class Members
See Also Properties Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

The following tables list the members exposed by GZipHeaderField.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
GZipHeaderField Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

For a list of all members of this type, see GZipHeaderField members.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Data Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : Data Property

The data contained in the header field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value() As Byte

value = instance.Data
C#
public byte[] Data {get;}
Delphi
public read-only property Data: array of Byte;
JScript
public function get Data : byte[]
Managed Extensions for C++
public: __property byte[]* get_Data();
C++/CLI
public:
property array<byte>^ Data {
   array<byte>^ get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ID Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID Property

The 16-bit identifier of the header field (concatenated ID1 and ID2).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As Short
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Short

value = instance.ID
C#
public short ID {get;}
Delphi
public read-only property ID: ShortInt;
JScript
public function get ID : short
Managed Extensions for C++
public: __property short get_ID();
C++/CLI
public:
property short ID {
   short get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ID1 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID1 Property

The 8-bit ID1 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID1
C#
public byte ID1 {get;}
Delphi
public read-only property ID1: Byte;
JScript
public function get ID1 : byte
Managed Extensions for C++
public: __property byte get_ID1();
C++/CLI
public:
property byte ID1 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ID2 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID2 Property

The 8-bit ID2 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID2
C#
public byte ID2 {get;}
Delphi
public read-only property ID2: Byte;
JScript
public function get ID2 : byte
Managed Extensions for C++
public: __property byte get_ID2();
C++/CLI
public:
property byte ID2 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

Provides methods and properties to decompress GZIP stream.

Object Model

GZipInputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
C#
public class GZipInputStream : System.IO.Stream
Delphi
public class GZipInputStream = class(System.IO.Stream)
JScript
public class GZipInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipInputStream : public System.IO.Stream
C++/CLI
public ref class GZipInputStream : public System.IO.Stream

Remarks

By default, GZipInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipInputStream

See Also

Reference

GZipInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
GZipInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

The following tables list the members exposed by GZipInputStream.

Public Constructors

 | Name | Description
public Constructor | GZipInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GZipInputStream Constructor

Overload List

Overload | Description
GZipInputStream Constructor(String) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream,Boolean) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream) | Initializes a new instance of GZipInputStream class.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New GZipInputStream(fileName)
C#
public GZipInputStream(
   string fileName
)
Delphi
public GZipInputStream(
    fileName: String
);
JScript
public function GZipInputStream(
   fileName : String
);
Managed Extensions for C++
public: GZipInputStream(
   string* fileName
)
C++/CLI
public:
GZipInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New GZipInputStream(stream, leaveOpen)
C#
public GZipInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public GZipInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function GZipInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New GZipInputStream(stream)
C#
public GZipInputStream(
   Stream stream
)
Delphi
public GZipInputStream(
    stream: Stream
);
JScript
public function GZipInputStream(
   stream : Stream
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
GZipInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.Closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream have been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
GZipInputStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown. A cyclic redundancy check (CRC) is performed when all data up to the end of stream have been read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadHeader Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadHeader Method

Reads the GZIP header from the stream.

Syntax

Visual Basic (Declaration)
Public Sub ReadHeader()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ReadHeader()
C#
public void ReadHeader()
Delphi
public procedure ReadHeader();
JScript
public function ReadHeader();
Managed Extensions for C++
public: void ReadHeader();
C++/CLI
public:
void ReadHeader();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
GZipInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanRead Property

Gets a value indicating whether the stream supports reading while decompressing a file.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports reading and is not closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

Remarks

The length check can fail on the files that are bigger than 4GB, since GZIP header does not support serializing bigger number. For this reason it's recommended to set this property to false in cases when original data might exceed the 4294967295 bytes.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ExtraFields Property

The collection of extra-fields read from the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

If the GZip header does not contain any extra-fields this property returns an empty ExtraFieldCollection.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Filename Property

Gets the filename specified in the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As String

value = instance.Filename
C#
public string Filename {get;}
Delphi
public read-only property Filename: String;
JScript
public function get Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
C++/CLI
public:
property String^ Filename {
   String^ get();
}

Remarks

If the filename is not present in the GZip header it returns null (Nothing for Visual Basic).

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GZipInputStream will try to read the Length property of the underlying stream. Check the the Length property documentation of the underlying stream for more information.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ParseExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ParseExtraFields Property

Gets and sets whether the reader should parse the extra-fields stored in the GZip header.

Syntax

Visual Basic (Declaration)
Public Property ParseExtraFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.ParseExtraFields = value

value = instance.ParseExtraFields
C#
public bool ParseExtraFields {get; set;}
Delphi
public read-write property ParseExtraFields: Boolean;
JScript
public function get,set ParseExtraFields : boolean
Managed Extensions for C++
public: __property bool get_ParseExtraFields();
public: __property void set_ParseExtraFields(
   bool value
);
C++/CLI
public:
property bool ParseExtraFields {
   bool get();
   void set (    bool value);
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

Provides the compression stream writing GZip streams and files.

Object Model

GZipOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
C#
public class GZipOutputStream : System.IO.Stream
Delphi
public class GZipOutputStream = class(System.IO.Stream)
JScript
public class GZipOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipOutputStream : public System.IO.Stream
C++/CLI
public ref class GZipOutputStream : public System.IO.Stream

Remarks

By default, GZipOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipOutputStream

See Also

Reference

GZipOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
GZipOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

The following tables list the members exposed by GZipOutputStream.

Public Constructors

 | Name | Description
public Constructor | GZipOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GZipOutputStream Constructor

Overload List

Overload | Description
GZipOutputStream Constructor(String,Int32) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32) | Initializes a new instance of the GZipOutputStream class.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(String,Int32)

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(fileName, compressionLevel)
C#
public GZipOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipOutputStream(stream, compressionLevel, leaveOpen)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(stream, compressionLevel)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
GZipOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Close Method

Flushes the internal buffer content and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

Before closing, the GZipOutputStream will also flush its buffer and write the GZip trailer fields into the underlying stream. Do not close the underlying stream before closing this stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
GZipOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush or Close method is called.

Upon the first write operation GZipOutputStream will write the GZip header into the underlying stream, therefore all required headers have to be specified before the first write operation.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
GZipOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports writing and is not closed; otherwise, false.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Comments Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Comments Property

Gets and sets the file comments to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Comments As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Comments = value

value = instance.Comments
C#
public string Comments {get; set;}
Delphi
public read-write property Comments: String;
JScript
public function get,set Comments : String
Managed Extensions for C++
public: __property string* get_Comments();
public: __property void set_Comments(
   string* value
);
C++/CLI
public:
property String^ Comments {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the comments for the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property has to be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ExtraFields Property

The collection of extra-fields to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

You can provide the set of extra-fields to be written into the GZip header by modifying this collection.

The GZip header will be written during the first write operation, therefore the extra-header fields should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Filename Property

Gets and sets the filename to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GzipOutputStream will try to readthe Length property of the underlying stream. Check the Length property documentation the underlying stream for more information .

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

Provides methods and properties for processing streams using GZIP.

Object Model

GZipStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
C#
public class GZipStream : System.IO.Stream
Delphi
public class GZipStream = class(System.IO.Stream)
JScript
public class GZipStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipStream : public System.IO.Stream
C++/CLI
public ref class GZipStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipStream

See Also

Reference

GZipStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
GZipStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipStream Class

The following tables list the members exposed by GZipStream.

Public Constructors

 | Name | Description
public Constructor | GZipStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Closes the stream and releases the allocated resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GZipStream Constructor

Overload List

Overload | Description
GZipStream Constructor(String,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the GZipStream class.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(String,CompressionMode)

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New GZipStream(fileName, mode)
C#
public GZipStream(
   string fileName,
   CompressionMode mode
)
Delphi
public GZipStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function GZipStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New GZipStream(stream, mode)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, compressionLevel, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GZipStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New GZipStream(stream, mode, compressionLevel)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
GZipStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Closes the stream and releases the allocated resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipStream Class
GZipStream Members
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Dispose Method

Closes the stream and releases the allocated resources.

Overload List

Overload | Description
Dispose(Boolean) | Closes the stream and releases the allocated resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Closes the stream and releases the allocated resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
GZipStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Filename Property

Gets and sets the filename to write into or read from the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InvalidInputException Class
Members See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The exception that is thrown when a compressed input stream is in an invalid format.

Object Model

InvalidInputException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidInputException
   Inherits System.IO.IOException
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
C#
public class InvalidInputException : System.IO.IOException
Delphi
public class InvalidInputException = class(System.IO.IOException)
JScript
public class InvalidInputException extends System.IO.IOException
Managed Extensions for C++
public __gc class InvalidInputException : public System.IO.IOException
C++/CLI
public ref class InvalidInputException : public System.IO.IOException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.IO.IOException
Noemax.GZip.InvalidInputException

See Also

Reference

InvalidInputException Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
InvalidInputException Class Members
See Also Properties Methods Events Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The following tables list the members exposed by InvalidInputException.

Public Constructors

 | Name | Description
public Constructor | InvalidInputException Constructor | Overloaded. Initializes a new instance of the InvalidInputException class.
Top

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InvalidInputException Constructor
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InvalidInputException Constructor

Initializes a new instance of the InvalidInputException class.

Overload List

Overload | Description
InvalidInputException Constructor() | Initializes a new instance of the InvalidInputException class.
InvalidInputException Constructor(String) | Initializes a new instance of the InvalidInputException class with a specified error message.
InvalidInputException Constructor(String,Exception) | Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InvalidInputException Constructor()
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor()

Initializes a new instance of the InvalidInputException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New InvalidInputException()
C#
public InvalidInputException()
Delphi
public InvalidInputException();
JScript
public function InvalidInputException();
Managed Extensions for C++
public: InvalidInputException();
C++/CLI
public:
InvalidInputException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InvalidInputException Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String)

message
Initializes a new instance of the InvalidInputException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As New InvalidInputException(message)
C#
public InvalidInputException(
   string message
)
Delphi
public InvalidInputException(
    message: String
);
JScript
public function InvalidInputException(
   message : String
);
Managed Extensions for C++
public: InvalidInputException(
   string* message
)
C++/CLI
public:
InvalidInputException(
   String^ message
)

Parameters

message

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InvalidInputException Constructor(String,Exception)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String,Exception)

message
innerException
Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As New InvalidInputException(message, innerException)
C#
public InvalidInputException(
   string message,
   Exception innerException
)
Delphi
public InvalidInputException(
    message: String;
    innerException: Exception
);
JScript
public function InvalidInputException(
   message : String,
   innerException : Exception
);
Managed Extensions for C++
public: InvalidInputException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidInputException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CompressionMode Enumeration
See Also Send Feedback
Noemax.GZip Namespace : CompressionMode Enumeration

Defines the compression modes for GZipStream.

Syntax

Visual Basic (Declaration)
Public Enum CompressionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CompressionMode
C#
public enum CompressionMode : System.Enum
Delphi
public enum CompressionMode = class(System.Enum)
JScript
public enum CompressionMode extends System.Enum
Managed Extensions for C++
__value public enum CompressionMode : public System.Enum
C++/CLI
public enum class CompressionMode : public System.Enum

Members

Member | Description
Compress | To compress data.
Decompress | To decompress data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.GZip.CompressionMode

See Also

Reference

Noemax.GZip Namespace


%%ItemTitle%%

Noemax.Lzf Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Lzf3InputStream | Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.
Class | Lzf3OutputStream | Provides methods and properties to compress streams using LZF3 compression algorithm.
Class | LzfInputStream | Provides methods and properties to decompress streams compressed by LZF compression algorithm.
Class | LzfOutputStream | Provides methods and properties to compress streams using LZF compression algorithm.

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3InputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.

Object Model

Lzf3InputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3InputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
C#
public sealed class Lzf3InputStream : System.IO.Stream
Delphi
public class Lzf3InputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3InputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3InputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3InputStream sealed : public System.IO.Stream

Remarks

By default, Lzf3InputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3InputStream

See Also

Reference

Lzf3InputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
Lzf3InputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

The following tables list the members exposed by Lzf3InputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3InputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3InputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Lzf3InputStream Constructor

Overload List

Overload | Description
Lzf3InputStream Constructor(String) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3InputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3InputStream(fileName)
C#
public Lzf3InputStream(
   string fileName
)
Delphi
public Lzf3InputStream(
    fileName: String
);
JScript
public function Lzf3InputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3InputStream(
   string* fileName
)
C++/CLI
public:
Lzf3InputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3InputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3InputStream(stream)
C#
public Lzf3InputStream(
   Stream stream
)
Delphi
public Lzf3InputStream(
    stream: Stream
);
JScript
public function Lzf3InputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3InputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3InputStream(stream, leaveOpen)
C#
public Lzf3InputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3InputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3InputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
Lzf3InputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
Lzf3InputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

Provides methods and properties to compress streams using LZF3 compression algorithm.

Object Model

Lzf3OutputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3OutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
C#
public sealed class Lzf3OutputStream : System.IO.Stream
Delphi
public class Lzf3OutputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3OutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3OutputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3OutputStream sealed : public System.IO.Stream

Remarks

By default, Lzf3OutputStream owns the underlying stream, so closing this stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3OutputStream

See Also

Reference

Lzf3OutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

The following tables list the members exposed by Lzf3OutputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3OutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Lzf3OutputStream Constructor

Overload List

Overload | Description
Lzf3OutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(String)

fileName
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3OutputStream(fileName)
C#
public Lzf3OutputStream(
   string fileName
)
Delphi
public Lzf3OutputStream(
    fileName: String
);
JScript
public function Lzf3OutputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3OutputStream(
   string* fileName
)
C++/CLI
public:
Lzf3OutputStream(
   String^ fileName
)

Parameters

fileName
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3OutputStream(stream)
C#
public Lzf3OutputStream(
   Stream stream
)
Delphi
public Lzf3OutputStream(
    stream: Stream
);
JScript
public function Lzf3OutputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3OutputStream(stream, leaveOpen)
C#
public Lzf3OutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3OutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3OutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
Lzf3OutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfInputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

Provides methods and properties to decompress streams compressed by LZF compression algorithm.

Object Model

LzfInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
C#
public class LzfInputStream : System.IO.Stream
Delphi
public class LzfInputStream = class(System.IO.Stream)
JScript
public class LzfInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfInputStream : public System.IO.Stream
C++/CLI
public ref class LzfInputStream : public System.IO.Stream

Remarks

By default, LzfInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfInputStream

See Also

Reference

LzfInputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
LzfInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

The following tables list the members exposed by LzfInputStream.

Public Constructors

 | Name | Description
public Constructor | LzfInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfInputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : LzfInputStream Constructor

Overload List

Overload | Description
LzfInputStream Constructor(String) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(String)

fileName
The path to the file from which to read copressed data from.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzfInputStream(fileName)
C#
public LzfInputStream(
   string fileName
)
Delphi
public LzfInputStream(
    fileName: String
);
JScript
public function LzfInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzfInputStream(
   string* fileName
)
C++/CLI
public:
LzfInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which to read copressed data from.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfInputStream(stream)
C#
public LzfInputStream(
   Stream stream
)
Delphi
public LzfInputStream(
    stream: Stream
);
JScript
public function LzfInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfInputStream(stream, leaveOpen)
C#
public LzfInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
LzfInputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
LzfInputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteTimeout Property

Get the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfOutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

Provides methods and properties to compress streams using LZF compression algorithm.

Object Model

LzfOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
C#
public class LzfOutputStream : System.IO.Stream
Delphi
public class LzfOutputStream = class(System.IO.Stream)
JScript
public class LzfOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfOutputStream : public System.IO.Stream
C++/CLI
public ref class LzfOutputStream : public System.IO.Stream

Remarks

By default, LzfOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfOutputStream

See Also

Reference

LzfOutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
LzfOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

The following tables list the members exposed by LzfOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzfOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfOutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : LzfOutputStream Constructor

Overload List

Overload | Description
LzfOutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfOutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(String)

filename
The path to the file to which the compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As New LzfOutputStream(filename)
C#
public LzfOutputStream(
   string filename
)
Delphi
public LzfOutputStream(
    filename: String
);
JScript
public function LzfOutputStream(
   filename : String
);
Managed Extensions for C++
public: LzfOutputStream(
   string* filename
)
C++/CLI
public:
LzfOutputStream(
   String^ filename
)

Parameters

filename
The path to the file to which the compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfOutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfOutputStream(stream)
C#
public LzfOutputStream(
   Stream stream
)
Delphi
public LzfOutputStream(
    stream: Stream
);
JScript
public function LzfOutputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzfOutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfOutputStream(stream, leaveOpen)
C#
public LzfOutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfOutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfOutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
LzfOutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
LzfOutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteTimeout Property

Gets the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%ItemTitle%%

Noemax.Lzma Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | LzmaInputStream | Provides methods and properties to decompress streams compressed by LZMA compression algorithm.
Class | LzmaOutputStream | Provides methods and properties to compress streams using LZMA compression algorithm.

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaInputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

Provides methods and properties to decompress streams compressed by LZMA compression algorithm.

Object Model

LzmaInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
C#
public class LzmaInputStream : System.IO.Stream
Delphi
public class LzmaInputStream = class(System.IO.Stream)
JScript
public class LzmaInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaInputStream : public System.IO.Stream
C++/CLI
public ref class LzmaInputStream : public System.IO.Stream

Remarks

By default, LzmaInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaInputStream

See Also

Reference

LzmaInputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
LzmaInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

The following tables list the members exposed by LzmaInputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaInputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : LzmaInputStream Constructor

Overload List

Overload | Description
LzmaInputStream Constructor(Stream) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(String) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzmaInputStream.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzmaInputStream(stream)
C#
public LzmaInputStream(
   Stream stream
)
Delphi
public LzmaInputStream(
    stream: Stream
);
JScript
public function LzmaInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzmaInputStream(fileName)
C#
public LzmaInputStream(
   string fileName
)
Delphi
public LzmaInputStream(
    fileName: String
);
JScript
public function LzmaInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzmaInputStream(
   string* fileName
)
C++/CLI
public:
LzmaInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzmaInputStream(stream, leaveOpen)
C#
public LzmaInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzmaInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzmaInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
LzmaInputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Close Method

Close this stream and the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Seek Method

offset
Not supported.
origin
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
Not supported.
origin
Not supported.

Return Value

Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : SetLength Method

value
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Write Method

buffer
Not supported.
offset
Not supported.
count
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
Not supported.
offset
Not supported.
count
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
LzmaInputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanRead Property

Returns true. This stream can read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanWrite Property

Returns false. This stream cannot write.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaOutputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

Provides methods and properties to compress streams using LZMA compression algorithm.

Object Model

LzmaOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
C#
public class LzmaOutputStream : System.IO.Stream
Delphi
public class LzmaOutputStream = class(System.IO.Stream)
JScript
public class LzmaOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaOutputStream : public System.IO.Stream
C++/CLI
public ref class LzmaOutputStream : public System.IO.Stream

Remarks

By default, LzmaOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

LzmaOutputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
LzmaOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

The following tables list the members exposed by LzmaOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaOutputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : LzmaOutputStream Constructor

Overload List

Overload | Description
LzmaOutputStream Constructor(String,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of LzmaOutputStream.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(String,Int32)

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(filename, compressionLevel)
C#
public LzmaOutputStream(
   string filename,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    filename: String;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   filename : String,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   string* filename,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   String^ filename,
   int compressionLevel
)

Parameters

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(stream, compressionLevel)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
LzmaOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New LzmaOutputStream(stream, compressionLevel, leaveOpen)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
LzmaOutputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Close Method

Flushes compressed bytes and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Flush Method

Flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
LzmaOutputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanRead Property

Returns false. This stream cannot be read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanWrite Property

Returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%ItemTitle%%

Noemax.Xml Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | XmlSchemaBasedConverter | This class takes XML input and processes it using its XML schema and performs original data-type aware serialization, taking into account node content types defined by schema. The final output of sialization depends on which writer is being used. This class can be used combined with binary XML writers to produce a more efficient representation of text XML document.

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlSchemaBasedConverter Class
Members See Also Send Feedback
Noemax.Xml Namespace : XmlSchemaBasedConverter Class

This class takes XML input and processes it using its XML schema and performs original data-type aware serialization, taking into account node content types defined by schema. The final output of sialization depends on which writer is being used. This class can be used combined with binary XML writers to produce a more efficient representation of text XML document.

Object Model

XmlSchemaBasedConverter Class

Syntax

Visual Basic (Declaration)
Public Class XmlSchemaBasedConverter
Visual Basic (Usage) Copy Code
Dim instance As XmlSchemaBasedConverter
C#
public class XmlSchemaBasedConverter
Delphi
public class XmlSchemaBasedConverter
JScript
public class XmlSchemaBasedConverter
Managed Extensions for C++
public __gc class XmlSchemaBasedConverter
C++/CLI
public ref class XmlSchemaBasedConverter

Inheritance Hierarchy

System.Object
Noemax.Xml.XmlSchemaBasedConverter

See Also

Reference

XmlSchemaBasedConverter Members
Noemax.Xml Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax FastInfoset.NET
XmlSchemaBasedConverter Class Members
See Also Properties Methods Send Feedback
Noemax.Xml Namespace : XmlSchemaBasedConverter Class

The following tables list the members exposed by XmlSchemaBasedConverter.

Public Constructors

 | Name | Description
public Constructor | XmlSchemaBasedConverter Constructor | Creates a new instance of XmlSchemaBasedConverter.
Top

Public Properties

 | Name | Description
public Property | ReaderSettings | The settings of the schema validating reader used by XmlSchemaBasedConverter while converting documents.
public Property | TypedValueCount | Reports the number of primitive typed values that were processed by the converter during processing document.
Top

Public Methods

 | Name | Description
public Method | Convert | Convert XML stream from the reader into format produced by the writer.
Top

See Also

Reference

XmlSchemaBasedConverter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlSchemaBasedConverter Constructor
See Also Send Feedback
Noemax.Xml Namespace > XmlSchemaBasedConverter Class : XmlSchemaBasedConverter Constructor

schemaSet
XML schema to use during converting XML documents.
validationEventHandler
The callback method that will handle XML schema validation events.
Creates a new instance of XmlSchemaBasedConverter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal schemaSet As XmlSchemaSet, _
   ByVal validationEventHandler As ValidationEventHandler _
)
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim validationEventHandler As ValidationEventHandler

Dim instance As New XmlSchemaBasedConverter(schemaSet, validationEventHandler)
C#
public XmlSchemaBasedConverter(
   XmlSchemaSet schemaSet,
   ValidationEventHandler validationEventHandler
)
Delphi
public XmlSchemaBasedConverter(
    schemaSet: XmlSchemaSet;
    validationEventHandler: ValidationEventHandler
);
JScript
public function XmlSchemaBasedConverter(
   schemaSet : XmlSchemaSet,
   validationEventHandler : ValidationEventHandler
);
Managed Extensions for C++
public: XmlSchemaBasedConverter(
   XmlSchemaSet* schemaSet,
   ValidationEventHandler* validationEventHandler
)
C++/CLI
public:
XmlSchemaBasedConverter(
   XmlSchemaSet^ schemaSet,
   ValidationEventHandler^ validationEventHandler
)

Parameters

schemaSet
XML schema to use during converting XML documents.
validationEventHandler
The callback method that will handle XML schema validation events.

See Also

Reference

XmlSchemaBasedConverter Class
XmlSchemaBasedConverter Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
XmlSchemaBasedConverter Class Methods
See Also Send Feedback
Noemax.Xml Namespace : XmlSchemaBasedConverter Class

For a list of all members of this type, see XmlSchemaBasedConverter members.

Public Methods

 | Name | Description
public Method | Convert | Convert XML stream from the reader into format produced by the writer.
Top

See Also

Reference

XmlSchemaBasedConverter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Convert Method
See Also Send Feedback
Noemax.Xml Namespace > XmlSchemaBasedConverter Class : Convert Method

writer
XmlWriter to write the result of conversion.
input
XmlReader from which to read the input to convert.
Convert XML stream from the reader into format produced by the writer.

Syntax

Visual Basic (Declaration)
Public Sub Convert( _
   ByVal writer As XmlWriter, _
   ByVal input As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlSchemaBasedConverter
Dim writer As XmlWriter
Dim input As XmlReader

instance.Convert(writer, input)
C#
public void Convert(
   XmlWriter writer,
   XmlReader input
)
Delphi
public procedure Convert(
    writer: XmlWriter;
    input: XmlReader
);
JScript
public function Convert(
   writer : XmlWriter,
   input : XmlReader
);
Managed Extensions for C++
public: void Convert(
   XmlWriter* writer,
   XmlReader* input
)
C++/CLI
public:
void Convert(
   XmlWriter^ writer,
   XmlReader^ input
)

Parameters

writer
XmlWriter to write the result of conversion.
input
XmlReader from which to read the input to convert.

See Also

Reference

XmlSchemaBasedConverter Class
XmlSchemaBasedConverter Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
XmlSchemaBasedConverter Class Properties
See Also Send Feedback
Noemax.Xml Namespace : XmlSchemaBasedConverter Class

For a list of all members of this type, see XmlSchemaBasedConverter members.

Public Properties

 | Name | Description
public Property | ReaderSettings | The settings of the schema validating reader used by XmlSchemaBasedConverter while converting documents.
public Property | TypedValueCount | Reports the number of primitive typed values that were processed by the converter during processing document.
Top

See Also

Reference

XmlSchemaBasedConverter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReaderSettings Property
See Also Send Feedback
Noemax.Xml Namespace > XmlSchemaBasedConverter Class : ReaderSettings Property

The settings of the schema validating reader used by XmlSchemaBasedConverter while converting documents.

Syntax

Visual Basic (Declaration)
Public Property ReaderSettings As XmlReaderSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlSchemaBasedConverter
Dim value As XmlReaderSettings

instance.ReaderSettings = value

value = instance.ReaderSettings
C#
public XmlReaderSettings ReaderSettings {get; set;}
Delphi
public read-write property ReaderSettings: XmlReaderSettings;
JScript
public function get,set ReaderSettings : XmlReaderSettings
Managed Extensions for C++
public: __property XmlReaderSettings* get_ReaderSettings();
public: __property void set_ReaderSettings(
   XmlReaderSettings* value
);
C++/CLI
public:
property XmlReaderSettings^ ReaderSettings {
   XmlReaderSettings^ get();
   void set (    XmlReaderSettings^ value);
}

See Also

Reference

XmlSchemaBasedConverter Class
XmlSchemaBasedConverter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
TypedValueCount Property
See Also Send Feedback
Noemax.Xml Namespace > XmlSchemaBasedConverter Class : TypedValueCount Property

Reports the number of primitive typed values that were processed by the converter during processing document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypedValueCount As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlSchemaBasedConverter
Dim value As Long

value = instance.TypedValueCount
C#
public long TypedValueCount {get;}
Delphi
public read-only property TypedValueCount: Int64;
JScript
public function get TypedValueCount : long
Managed Extensions for C++
public: __property long get_TypedValueCount();
C++/CLI
public:
property int64 TypedValueCount {
   int64 get();
}

See Also

Reference

XmlSchemaBasedConverter Class
XmlSchemaBasedConverter Members


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
OptimizedVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : OptimizedVocabulary Class

For a list of all members of this type, see OptimizedVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

See Also

Reference

OptimizedVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
ReaderVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

For a list of all members of this type, see ReaderVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
SchemaVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

For a list of all members of this type, see SchemaVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Settings Property
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : Settings Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Settings As XmlWriterSettings
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As XmlWriterSettings

value = instance.Settings
C#
public virtual XmlWriterSettings Settings {get;}
Delphi
public read-only property Settings: XmlWriterSettings; virtual;
JScript
public function get Settings : XmlWriterSettings
Managed Extensions for C++
public: __property virtual XmlWriterSettings* get_Settings();
C++/CLI
public:
virtual property XmlWriterSettings^ Settings {
   XmlWriterSettings^ get();
}

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributes Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteAttributes Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteAttributes( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteAttributes(reader, defattr)
C#
public virtual void WriteAttributes(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteAttributes(
    reader: XmlReader;
    defattr: Boolean
); virtual;
JScript
public function WriteAttributes(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: virtual void WriteAttributes(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
virtual void WriteAttributes(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteAttributeString Method

Overload List

Overload | Description
WriteAttributeString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteAttributeString Method : WriteAttributeString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim value As String

instance.WriteAttributeString(localName, value)
C#
public void WriteAttributeString(
   string localName,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    value: String
);
JScript
public function WriteAttributeString(
   localName : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* localName,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(localName, ns, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void WriteAttributeString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    ns: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function WriteAttributeString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void WriteAttributeString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void WriteAttributeString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(prefix, localName, ns, value)
C#
public void WriteAttributeString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteAttributeString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteBinHex Method

buffer
index
count

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBinHex(buffer, index, count)
C#
public virtual void WriteBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); virtual;
JScript
public function WriteBinHex(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteBinHex(
   byte[]* buffer,
   int index,
   int count
)
C++/CLI
public:
virtual void WriteBinHex(
   array<byte>^ buffer,
   int index,
   int count
)

Parameters

buffer
index
count

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteElementString Method

Overload List

Overload | Description
WriteElementString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteElementString Method : WriteElementString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim value As String

instance.WriteElementString(localName, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteElementString(
   string localName,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteElementString(
   localName : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteElementString(
   string* localName,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteElementString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteElementString Method : WriteElementString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(localName, ns, value)
C#
public void WriteElementString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteElementString Method : WriteElementString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(prefix, localName, ns, value)
C#
public void WriteElementString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteName Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim name As String

instance.WriteName(name)
C#
public virtual void WriteName(
   string name
)
Delphi
public procedure WriteName(
    name: String
); virtual;
JScript
public function WriteName(
   name : String
);
Managed Extensions for C++
public: virtual void WriteName(
   string* name
)
C++/CLI
public:
virtual void WriteName(
   String^ name
)

Parameters

name

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNmToken Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteNmToken Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteNmToken( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim name As String

instance.WriteNmToken(name)
C#
public virtual void WriteNmToken(
   string name
)
Delphi
public procedure WriteNmToken(
    name: String
); virtual;
JScript
public function WriteNmToken(
   name : String
);
Managed Extensions for C++
public: virtual void WriteNmToken(
   string* name
)
C++/CLI
public:
virtual void WriteNmToken(
   String^ name
)

Parameters

name

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteNode Method

Overload List

Overload | Description
WriteNode(XmlReader,Boolean) | (Inherited from System.Xml.XmlWriter)
WriteNode(XPathNavigator,Boolean) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode(XmlReader,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteNode Method : WriteNode(XmlReader,Boolean) Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteNode( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteNode(reader, defattr)
C#
public virtual void WriteNode(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteNode(
    reader: XmlReader;
    defattr: Boolean
); virtual;
JScript
public function WriteNode(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: virtual void WriteNode(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
virtual void WriteNode(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode(XPathNavigator,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteNode Method : WriteNode(XPathNavigator,Boolean) Method

navigator
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteNode( _
   ByVal navigator As XPathNavigator, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim navigator As XPathNavigator
Dim defattr As Boolean

instance.WriteNode(navigator, defattr)
C#
public virtual void WriteNode(
   XPathNavigator navigator,
   bool defattr
)
Delphi
public procedure WriteNode(
    navigator: XPathNavigator;
    defattr: Boolean
); virtual;
JScript
public function WriteNode(
   navigator : XPathNavigator,
   defattr : boolean
);
Managed Extensions for C++
public: virtual void WriteNode(
   XPathNavigator* navigator,
   bool defattr
)
C++/CLI
public:
virtual void WriteNode(
   XPathNavigator^ navigator,
   bool defattr
)

Parameters

navigator
defattr

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteQualifiedName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteQualifiedName Method

localName
ns

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteQualifiedName( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim ns As String

instance.WriteQualifiedName(localName, ns)
C#
public virtual void WriteQualifiedName(
   string localName,
   string ns
)
Delphi
public procedure WriteQualifiedName(
    localName: String;
    ns: String
); virtual;
JScript
public function WriteQualifiedName(
   localName : String,
   ns : String
);
Managed Extensions for C++
public: virtual void WriteQualifiedName(
   string* localName,
   string* ns
)
C++/CLI
public:
virtual void WriteQualifiedName(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartAttribute Method : WriteStartAttribute(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String

instance.WriteStartAttribute(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName
)
Delphi
public procedure WriteStartAttribute(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName
)

Parameters

localName

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartElement Method : WriteStartElement(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String

instance.WriteStartElement(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName
)
Delphi
public procedure WriteStartElement(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName
)

Parameters

localName

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteStartElement Method : WriteStartElement(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim localName As String
Dim ns As String

instance.WriteStartElement(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : WriteValue Method

Overload List

Overload | Description
WriteValue(Object) | (Inherited from System.Xml.XmlWriter)
WriteValue(String) | (Inherited from System.Xml.XmlWriter)
WriteValue(Boolean) | (Inherited from System.Xml.XmlWriter)
WriteValue(DateTime) | (Inherited from System.Xml.XmlWriter)
WriteValue(Double) | (Inherited from System.Xml.XmlWriter)
WriteValue(Single) | (Inherited from System.Xml.XmlWriter)
WriteValue(Decimal) | (Inherited from System.Xml.XmlWriter)
WriteValue(Int32) | (Inherited from System.Xml.XmlWriter)
WriteValue(Int64) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Boolean) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Boolean

instance.WriteValue(value)
C#
public virtual void WriteValue(
   bool value
)
Delphi
public procedure WriteValue(
    value: Boolean
); virtual;
JScript
public function WriteValue(
   value : boolean
);
Managed Extensions for C++
public: virtual void WriteValue(
   bool value
)
C++/CLI
public:
virtual void WriteValue(
   bool value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(DateTime) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(DateTime) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Date

instance.WriteValue(value)
C#
public virtual void WriteValue(
   DateTime value
)
Delphi
public procedure WriteValue(
    value: DateTime
); virtual;
JScript
public function WriteValue(
   value : DateTime
);
Managed Extensions for C++
public: virtual void WriteValue(
   DateTime value
)
C++/CLI
public:
virtual void WriteValue(
   DateTime value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Decimal) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Decimal) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Decimal

instance.WriteValue(value)
C#
public virtual void WriteValue(
   decimal value
)
Delphi
public procedure WriteValue(
    value: Currency
); virtual;
JScript
public function WriteValue(
   value : decimal
);
Managed Extensions for C++
public: virtual void WriteValue(
   decimal value
)
C++/CLI
public:
virtual void WriteValue(
   decimal value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Double) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Double

instance.WriteValue(value)
C#
public virtual void WriteValue(
   double value
)
Delphi
public procedure WriteValue(
    value: Double
); virtual;
JScript
public function WriteValue(
   value : double
);
Managed Extensions for C++
public: virtual void WriteValue(
   double value
)
C++/CLI
public:
virtual void WriteValue(
   double value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Int32) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Integer

instance.WriteValue(value)
C#
public virtual void WriteValue(
   int value
)
Delphi
public procedure WriteValue(
    value: Integer
); virtual;
JScript
public function WriteValue(
   value : int
);
Managed Extensions for C++
public: virtual void WriteValue(
   int value
)
C++/CLI
public:
virtual void WriteValue(
   int value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Int64) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Long

instance.WriteValue(value)
C#
public virtual void WriteValue(
   long value
)
Delphi
public procedure WriteValue(
    value: Int64
); virtual;
JScript
public function WriteValue(
   value : long
);
Managed Extensions for C++
public: virtual void WriteValue(
   long value
)
C++/CLI
public:
virtual void WriteValue(
   int64 value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Object) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Object) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Object

instance.WriteValue(value)
C#
public virtual void WriteValue(
   object value
)
Delphi
public procedure WriteValue(
    value: TObject
); virtual;
JScript
public function WriteValue(
   value : Object
);
Managed Extensions for C++
public: virtual void WriteValue(
   Object* value
)
C++/CLI
public:
virtual void WriteValue(
   Object^ value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(Single) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As Single

instance.WriteValue(value)
C#
public virtual void WriteValue(
   float value
)
Delphi
public procedure WriteValue(
    value: Single
); virtual;
JScript
public function WriteValue(
   value : float
);
Managed Extensions for C++
public: virtual void WriteValue(
   float value
)
C++/CLI
public:
virtual void WriteValue(
   float value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class > WriteValue Method : WriteValue(String) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As String

instance.WriteValue(value)
C#
public virtual void WriteValue(
   string value
)
Delphi
public procedure WriteValue(
    value: String
); virtual;
JScript
public function WriteValue(
   value : String
);
Managed Extensions for C++
public: virtual void WriteValue(
   string* value
)
C++/CLI
public:
virtual void WriteValue(
   String^ value
)

Parameters

value

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlLang Property
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : XmlLang Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As String

value = instance.XmlLang
C#
public virtual string XmlLang {get;}
Delphi
public read-only property XmlLang: String; virtual;
JScript
public function get XmlLang : String
Managed Extensions for C++
public: __property virtual string* get_XmlLang();
C++/CLI
public:
virtual property String^ XmlLang {
   String^ get();
}

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlSpace Property
See Also Send Feedback
Noemax.FastInfoset Namespace > VocabularyWriter Class : XmlSpace Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As VocabularyWriter
Dim value As XmlSpace

value = instance.XmlSpace
C#
public virtual XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace; virtual;
JScript
public function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property virtual XmlSpace get_XmlSpace();
C++/CLI
public:
virtual property XmlSpace XmlSpace {
   XmlSpace get();
}

See Also

Reference

VocabularyWriter Class
VocabularyWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanReadValueChunk Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanReadValueChunk Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanReadValueChunk As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanReadValueChunk
C#
public bool CanReadValueChunk {get;}
Delphi
public read-only property CanReadValueChunk: Boolean;
JScript
public function get CanReadValueChunk : boolean
Managed Extensions for C++
public: __property bool get_CanReadValueChunk();
C++/CLI
public:
property bool CanReadValueChunk {
   bool get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HasAttributes Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : HasAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasAttributes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.HasAttributes
C#
public bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: Boolean;
JScript
public function get HasAttributes : boolean
Managed Extensions for C++
public: __property bool get_HasAttributes();
C++/CLI
public:
property bool HasAttributes {
   bool get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAs Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAs Method

returnType
namespaceResolver

Syntax

Visual Basic (Declaration)
Public Function ReadContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadContentAs(returnType, namespaceResolver)
C#
public object ReadContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject;
JScript
public function ReadContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver
)
C++/CLI
public:
Object^ ReadContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver
)

Parameters

returnType
namespaceResolver

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadContentAsObject Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsObject Method

Syntax

Visual Basic (Declaration)
Public Function ReadContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Object

value = instance.ReadContentAsObject()
C#
public object ReadContentAsObject()
Delphi
public function ReadContentAsObject(): TObject;
JScript
public function ReadContentAsObject() : Object;
Managed Extensions for C++
public: Object* ReadContentAsObject();
C++/CLI
public:
Object^ ReadContentAsObject();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAs Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAs Method

Overload List

Overload | Description
ReadElementContentAs(Type,IXmlNamespaceResolver) | (Inherited from System.Xml.XmlReader)
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAs(Type,IXmlNamespaceResolver) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver) Method

returnType
namespaceResolver

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver)
C#
public object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject;
JScript
public function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver
)
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver
)

Parameters

returnType
namespaceResolver

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method

returnType
namespaceResolver
localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver, localName, namespaceURI)
C#
public object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver,
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver;
    localName: String;
    namespaceURI: String
): TObject;
JScript
public function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver,
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver,
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver,
   String^ localName,
   String^ namespaceURI
)

Parameters

returnType
namespaceResolver
localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsBoolean(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBoolean( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadElementContentAsBoolean(localName, namespaceURI)
C#
public bool ReadElementContentAsBoolean(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsBoolean(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadElementContentAsBoolean(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadElementContentAsBoolean(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDateTime(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDateTime( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Date

value = instance.ReadElementContentAsDateTime(localName, namespaceURI)
C#
public DateTime ReadElementContentAsDateTime(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDateTime(
    localName: String;
    namespaceURI: String
): DateTime;
JScript
public function ReadElementContentAsDateTime(
   localName : String,
   namespaceURI : String
) : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
DateTime ReadElementContentAsDateTime(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDecimal(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDecimal( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Decimal

value = instance.ReadElementContentAsDecimal(localName, namespaceURI)
C#
public decimal ReadElementContentAsDecimal(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDecimal(
    localName: String;
    namespaceURI: String
): Currency;
JScript
public function ReadElementContentAsDecimal(
   localName : String,
   namespaceURI : String
) : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
decimal ReadElementContentAsDecimal(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsDouble(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDouble( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Double

value = instance.ReadElementContentAsDouble(localName, namespaceURI)
C#
public double ReadElementContentAsDouble(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDouble(
    localName: String;
    namespaceURI: String
): Double;
JScript
public function ReadElementContentAsDouble(
   localName : String,
   namespaceURI : String
) : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
double ReadElementContentAsDouble(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsFloat(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsFloat( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Single

value = instance.ReadElementContentAsFloat(localName, namespaceURI)
C#
public float ReadElementContentAsFloat(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsFloat(
    localName: String;
    namespaceURI: String
): Single;
JScript
public function ReadElementContentAsFloat(
   localName : String,
   namespaceURI : String
) : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
float ReadElementContentAsFloat(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsInt(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsInt( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Integer

value = instance.ReadElementContentAsInt(localName, namespaceURI)
C#
public int ReadElementContentAsInt(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsInt(
    localName: String;
    namespaceURI: String
): Integer;
JScript
public function ReadElementContentAsInt(
   localName : String,
   namespaceURI : String
) : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
int ReadElementContentAsInt(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsLong(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsLong( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Long

value = instance.ReadElementContentAsLong(localName, namespaceURI)
C#
public long ReadElementContentAsLong(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsLong(
    localName: String;
    namespaceURI: String
): Int64;
JScript
public function ReadElementContentAsLong(
   localName : String,
   namespaceURI : String
) : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
int64 ReadElementContentAsLong(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsObject Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsObject Method

Overload List

Overload | Description
ReadElementContentAsObject() | (Inherited from System.Xml.XmlReader)
ReadElementContentAsObject(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsObject() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Object

value = instance.ReadElementContentAsObject()
C#
public object ReadElementContentAsObject()
Delphi
public function ReadElementContentAsObject(): TObject;
JScript
public function ReadElementContentAsObject() : Object;
Managed Extensions for C++
public: Object* ReadElementContentAsObject();
C++/CLI
public:
Object^ ReadElementContentAsObject();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsObject(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsObject( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAsObject(localName, namespaceURI)
C#
public object ReadElementContentAsObject(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsObject(
    localName: String;
    namespaceURI: String
): TObject;
JScript
public function ReadElementContentAsObject(
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAsObject(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
Object^ ReadElementContentAsObject(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementContentAsString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsString Method : ReadElementContentAsString(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsString( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As String

value = instance.ReadElementContentAsString(localName, namespaceURI)
C#
public string ReadElementContentAsString(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsString(
    localName: String;
    namespaceURI: String
): String;
JScript
public function ReadElementContentAsString(
   localName : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
String^ ReadElementContentAsString(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementString Method

Overload List

Overload | Description
ReadElementString() | (Inherited from System.Xml.XmlReader)
ReadElementString(String) | (Inherited from System.Xml.XmlReader)
ReadElementString(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementString() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadElementString()
C#
public string ReadElementString()
Delphi
public function ReadElementString(): String;
JScript
public function ReadElementString() : String;
Managed Extensions for C++
public: string* ReadElementString();
C++/CLI
public:
String^ ReadElementString();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementString(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As String

value = instance.ReadElementString(name)
C#
public string ReadElementString(
   string name
)
Delphi
public function ReadElementString(
    name: String
): String;
JScript
public function ReadElementString(
   name : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* name
)
C++/CLI
public:
String^ ReadElementString(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadElementString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString(String,String) Method

localname
ns

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString( _
   ByVal localname As String, _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String
Dim value As String

value = instance.ReadElementString(localname, ns)
C#
public string ReadElementString(
   string localname,
   string ns
)
Delphi
public function ReadElementString(
    localname: String;
    ns: String
): String;
JScript
public function ReadElementString(
   localname : String,
   ns : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* localname,
   string* ns
)
C++/CLI
public:
String^ ReadElementString(
   String^ localname,
   String^ ns
)

Parameters

localname
ns

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadInnerXml Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadInnerXml Method

Syntax

Visual Basic (Declaration)
Public Function ReadInnerXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadInnerXml()
C#
public string ReadInnerXml()
Delphi
public function ReadInnerXml(): String;
JScript
public function ReadInnerXml() : String;
Managed Extensions for C++
public: string* ReadInnerXml();
C++/CLI
public:
String^ ReadInnerXml();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadOuterXml Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadOuterXml Method

Syntax

Visual Basic (Declaration)
Public Function ReadOuterXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadOuterXml()
C#
public string ReadOuterXml()
Delphi
public function ReadOuterXml(): String;
JScript
public function ReadOuterXml() : String;
Managed Extensions for C++
public: string* ReadOuterXml();
C++/CLI
public:
String^ ReadOuterXml();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadSubtree Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadSubtree Method

Syntax

Visual Basic (Declaration)
Public Function ReadSubtree() As XmlReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlReader

value = instance.ReadSubtree()
C#
public XmlReader ReadSubtree()
Delphi
public function ReadSubtree(): XmlReader;
JScript
public function ReadSubtree() : XmlReader;
Managed Extensions for C++
public: XmlReader* ReadSubtree();
C++/CLI
public:
XmlReader^ ReadSubtree();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToDescendant Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToDescendant Method

Overload List

Overload | Description
ReadToDescendant(String) | (Inherited from System.Xml.XmlReader)
ReadToDescendant(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToDescendant(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToDescendant Method : ReadToDescendant(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDescendant( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToDescendant(name)
C#
public bool ReadToDescendant(
   string name
)
Delphi
public function ReadToDescendant(
    name: String
): Boolean;
JScript
public function ReadToDescendant(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToDescendant(
   string* name
)
C++/CLI
public:
bool ReadToDescendant(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToDescendant(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToDescendant Method : ReadToDescendant(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDescendant( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToDescendant(localName, namespaceURI)
C#
public bool ReadToDescendant(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToDescendant(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToDescendant(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToDescendant(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToDescendant(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToFollowing Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToFollowing Method

Overload List

Overload | Description
ReadToFollowing(String) | (Inherited from System.Xml.XmlReader)
ReadToFollowing(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToFollowing(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToFollowing Method : ReadToFollowing(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToFollowing( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToFollowing(name)
C#
public bool ReadToFollowing(
   string name
)
Delphi
public function ReadToFollowing(
    name: String
): Boolean;
JScript
public function ReadToFollowing(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToFollowing(
   string* name
)
C++/CLI
public:
bool ReadToFollowing(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToFollowing(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToFollowing Method : ReadToFollowing(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToFollowing( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToFollowing(localName, namespaceURI)
C#
public bool ReadToFollowing(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToFollowing(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToFollowing(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToFollowing(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToFollowing(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToNextSibling Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToNextSibling Method

Overload List

Overload | Description
ReadToNextSibling(String) | (Inherited from System.Xml.XmlReader)
ReadToNextSibling(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToNextSibling(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToNextSibling Method : ReadToNextSibling(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToNextSibling( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToNextSibling(name)
C#
public bool ReadToNextSibling(
   string name
)
Delphi
public function ReadToNextSibling(
    name: String
): Boolean;
JScript
public function ReadToNextSibling(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToNextSibling(
   string* name
)
C++/CLI
public:
bool ReadToNextSibling(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadToNextSibling(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToNextSibling Method : ReadToNextSibling(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToNextSibling( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToNextSibling(localName, namespaceURI)
C#
public bool ReadToNextSibling(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToNextSibling(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToNextSibling(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToNextSibling(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToNextSibling(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadValueChunk Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadValueChunk Method

buffer
index
count

Syntax

Visual Basic (Declaration)
Public Function ReadValueChunk( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Char
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadValueChunk(buffer, index, count)
C#
public int ReadValueChunk(
   char[] buffer,
   int index,
   int count
)
Delphi
public function ReadValueChunk(
    buffer: Chararray of;
    index: Integer;
    count: Integer
): Integer;
JScript
public function ReadValueChunk(
   buffer : char[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadValueChunk(
   char[]* buffer,
   int index,
   int count
)
C++/CLI
public:
int ReadValueChunk(
   array<char>^ buffer,
   int index,
   int count
)

Parameters

buffer
index
count

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SchemaInfo Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : SchemaInfo Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaInfo As IXmlSchemaInfo
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As IXmlSchemaInfo

value = instance.SchemaInfo
C#
public IXmlSchemaInfo SchemaInfo {get;}
Delphi
public read-only property SchemaInfo: IXmlSchemaInfo;
JScript
public function get SchemaInfo : IXmlSchemaInfo
Managed Extensions for C++
public: __property IXmlSchemaInfo* get_SchemaInfo();
C++/CLI
public:
property IXmlSchemaInfo^ SchemaInfo {
   IXmlSchemaInfo^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Skip Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Skip Method

Syntax

Visual Basic (Declaration)
Public Sub Skip()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Skip()
C#
public void Skip()
Delphi
public procedure Skip();
JScript
public function Skip();
Managed Extensions for C++
public: void Skip();
C++/CLI
public:
void Skip();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ValueType Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Type

value = instance.ValueType
C#
public Type ValueType {get;}
Delphi
public read-only property ValueType: Type;
JScript
public function get ValueType : Type
Managed Extensions for C++
public: __property Type* get_ValueType();
C++/CLI
public:
property Type^ ValueType {
   Type^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlLang Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlLang Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.XmlLang
C#
public string XmlLang {get;}
Delphi
public read-only property XmlLang: String;
JScript
public function get XmlLang : String
Managed Extensions for C++
public: __property string* get_XmlLang();
C++/CLI
public:
property String^ XmlLang {
   String^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
XmlSpace Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlSpace Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlSpace

value = instance.XmlSpace
C#
public XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace;
JScript
public function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property XmlSpace get_XmlSpace();
C++/CLI
public:
property XmlSpace XmlSpace {
   XmlSpace get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributes Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteAttributes Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Sub WriteAttributes( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteAttributes(reader, defattr)
C#
public void WriteAttributes(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteAttributes(
    reader: XmlReader;
    defattr: Boolean
);
JScript
public function WriteAttributes(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteAttributes(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
void WriteAttributes(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteAttributeString Method

Overload List

Overload | Description
WriteAttributeString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As String

instance.WriteAttributeString(localName, value)
C#
public void WriteAttributeString(
   string localName,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    value: String
);
JScript
public function WriteAttributeString(
   localName : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* localName,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(localName, ns, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void WriteAttributeString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    ns: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function WriteAttributeString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void WriteAttributeString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void WriteAttributeString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteAttributeString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(prefix, localName, ns, value)
C#
public void WriteAttributeString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteAttributeString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteElementString Method

Overload List

Overload | Description
WriteElementString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As String

instance.WriteElementString(localName, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteElementString(
   string localName,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteElementString(
   localName : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteElementString(
   string* localName,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteElementString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(localName, ns, value)
C#
public void WriteElementString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteElementString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(prefix, localName, ns, value)
C#
public void WriteElementString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteNode Method

Overload List

Overload | Description
WriteNode(XmlReader,Boolean) | (Inherited from System.Xml.XmlWriter)
WriteNode(XPathNavigator,Boolean) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode(XmlReader,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteNode Method : WriteNode(XmlReader,Boolean) Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteNode( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteNode(reader, defattr)
C#
public void WriteNode(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteNode(
    reader: XmlReader;
    defattr: Boolean
);
JScript
public function WriteNode(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteNode(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
void WriteNode(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteNode(XPathNavigator,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteNode Method : WriteNode(XPathNavigator,Boolean) Method

navigator
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteNode( _
   ByVal navigator As XPathNavigator, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim navigator As XPathNavigator
Dim defattr As Boolean

instance.WriteNode(navigator, defattr)
C#
public void WriteNode(
   XPathNavigator navigator,
   bool defattr
)
Delphi
public procedure WriteNode(
    navigator: XPathNavigator;
    defattr: Boolean
);
JScript
public function WriteNode(
   navigator : XPathNavigator,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteNode(
   XPathNavigator* navigator,
   bool defattr
)
C++/CLI
public:
void WriteNode(
   XPathNavigator^ navigator,
   bool defattr
)

Parameters

navigator
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String

instance.WriteStartAttribute(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName
)
Delphi
public procedure WriteStartAttribute(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String

instance.WriteStartElement(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName
)
Delphi
public procedure WriteStartElement(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteStartElement(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteValue(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(String) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As String

instance.WriteValue(value)
C#
public void WriteValue(
   string value
)
Delphi
public procedure WriteValue(
    value: String
);
JScript
public function WriteValue(
   value : String
);
Managed Extensions for C++
public: void WriteValue(
   string* value
)
C++/CLI
public:
void WriteValue(
   String^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.FastInfoset Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.OptimizedVocabulary
Noemax.FastInfoset.ReaderVocabulary
Noemax.FastInfoset.SchemaVocabulary
Noemax.FastInfoset.WriterVocabulary
Noemax.FastInfoset.XmlFastInfosetFactory
Noemax.FastInfoset.XmlFastInfosetWriterProfile
System.Xml.XmlReader
Noemax.FastInfoset.XmlFastInfosetReader
System.Xml.XmlWriter
Noemax.FastInfoset.VocabularyWriter
Noemax.FastInfoset.XmlFastInfosetWriter

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%% $$Events$$

[image]
Noemax FastInfoset.NET
InvalidInputException Class Events
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax FastInfoset.NET
InvalidInputException Class Methods
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax FastInfoset.NET
InvalidInputException Class Properties
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Data Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Data Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As IDictionary

value = instance.Data
C#
public virtual IDictionary Data {get;}
Delphi
public read-only property Data: IDictionary; virtual;
JScript
public function get Data : IDictionary
Managed Extensions for C++
public: __property virtual IDictionary* get_Data();
C++/CLI
public:
virtual property IDictionary^ Data {
   IDictionary^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetBaseException Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetBaseException Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.GetBaseException()
C#
public virtual Exception GetBaseException()
Delphi
public function GetBaseException(): Exception; virtual;
JScript
public function GetBaseException() : Exception;
Managed Extensions for C++
public: virtual Exception* GetBaseException();
C++/CLI
public:
virtual Exception^ GetBaseException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetObjectData Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
[SecurityCriticalAttribute()]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); virtual;
JScript
SecurityCriticalAttribute()
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetType Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetType Method

Overload List

Overload | Description
GetType() | (Inherited from System.Exception)

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetType() Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetType() Method

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Type

value = instance.GetType()
C#
public Type GetType()
Delphi
public function GetType(): Type;
JScript
public function GetType() : Type;
Managed Extensions for C++
public: Type* GetType();
C++/CLI
public:
Type^ GetType();

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HelpLink Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HelpLink Property

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.HelpLink = value

value = instance.HelpLink
C#
public virtual string HelpLink {get; set;}
Delphi
public read-write property HelpLink: String; virtual;
JScript
public function get,set HelpLink : String
Managed Extensions for C++
public: __property virtual string* get_HelpLink();
public: __property virtual void set_HelpLink(
   string* value
);
C++/CLI
public:
virtual property String^ HelpLink {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
HResult Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HResult Property

Syntax

Visual Basic (Declaration)
Protected Property HResult As Integer
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Integer

instance.HResult = value

value = instance.HResult
C#
protected int HResult {get; set;}
Delphi
protected read-write property HResult: Integer;
JScript
protected function get,set HResult : int
Managed Extensions for C++
protected: __property int get_HResult();
protected: __property void set_HResult(
   int value
);
C++/CLI
protected:
property int HResult {
   int get();
   void set (    int value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InnerException Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InnerException Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.InnerException
C#
public Exception InnerException {get;}
Delphi
public read-only property InnerException: Exception;
JScript
public function get InnerException : Exception
Managed Extensions for C++
public: __property Exception* get_InnerException();
C++/CLI
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Message Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Message Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.Message
C#
public virtual string Message {get;}
Delphi
public read-only property Message: String; virtual;
JScript
public function get Message : String
Managed Extensions for C++
public: __property virtual string* get_Message();
C++/CLI
public:
virtual property String^ Message {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
SerializeObjectState Event
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : SerializeObjectState Event

Syntax

Visual Basic (Declaration)
Protected Event SerializeObjectState As EventHandler(Of SafeSerializationEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim handler As EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
C#
protected event EventHandler<SafeSerializationEventArgs> SerializeObjectState
Delphi
protected event SerializeObjectState: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
protected: __event EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
C++/CLI
protected:
event EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState

Event Data

The event handler receives an argument of type SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext |

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Source Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Source Property

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.Source = value

value = instance.Source
C#
public virtual string Source {get; set;}
Delphi
public read-write property Source: String; virtual;
JScript
public function get,set Source : String
Managed Extensions for C++
public: __property virtual string* get_Source();
public: __property virtual void set_Source(
   string* value
);
C++/CLI
public:
virtual property String^ Source {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
StackTrace Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : StackTrace Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.StackTrace
C#
public virtual string StackTrace {get;}
Delphi
public read-only property StackTrace: String; virtual;
JScript
public function get StackTrace : String
Managed Extensions for C++
public: __property virtual string* get_StackTrace();
C++/CLI
public:
virtual property String^ StackTrace {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
TargetSite Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : TargetSite Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As MethodBase

value = instance.TargetSite
C#
public MethodBase TargetSite {get;}
Delphi
public read-only property TargetSite: MethodBase;
JScript
public function get TargetSite : MethodBase
Managed Extensions for C++
public: __property MethodBase* get_TargetSite();
C++/CLI
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.GZip Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.GZip.ExtraFieldCollection
Noemax.GZip.GZipHeaderField
System.IO.IOException
System.SystemException
System.Exception
Noemax.GZip.InvalidInputException
System.IO.Stream
System.MarshalByRefObject
Noemax.GZip.DeflateInputStream
Noemax.GZip.DeflateOutputStream
Noemax.GZip.DeflateStream
Noemax.GZip.GZipInputStream
Noemax.GZip.GZipOutputStream
Noemax.GZip.GZipStream

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzf Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzf.Lzf3InputStream
Noemax.Lzf.Lzf3OutputStream
Noemax.Lzf.LzfInputStream
Noemax.Lzf.LzfOutputStream

See Also

Reference

Noemax.FastInfoset Assembly


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax FastInfoset.NET
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzma Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzma.LzmaInputStream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

Noemax.FastInfoset Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Xml Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.Xml.XmlSchemaBasedConverter

See Also

Reference

Noemax.FastInfoset Assembly