Noemax.WebSockets Assembly

PowerWebSockets Class Reference for .NET
Noemax.WebSockets Assembly
Namespaces
Namespace | Description
Noemax.Newtonsoft.Json |
Noemax.Newtonsoft.Json.Bson |
Noemax.Newtonsoft.Json.Converters |
Noemax.Newtonsoft.Json.Linq |
Noemax.Newtonsoft.Json.Linq.JsonPath |
Noemax.Newtonsoft.Json.Schema |
Noemax.Newtonsoft.Json.Serialization |
Noemax.Newtonsoft.Json.Utilities |
Noemax.WebSockets |
Noemax.WebSockets.Core |
Noemax.WebSockets.Messaging |
Noemax.WebSockets.Messaging.Pom |
Send Feedback


Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | JsonArrayAttribute | Instructs the JsonSerializer how to serialize the collection.
Class | JsonConstructorAttribute | Instructs the JsonSerializer to use the specified constructor when deserializing that object.
Class | JsonContainerAttribute | Instructs the JsonSerializer how to serialize the object.
Class | JsonConvert | Provides methods for converting between common language runtime types and JSON types.
Class | JsonConverter | Converts an object to and from JSON.
Class | JsonConverterAttribute | Instructs the JsonSerializer to use the specified JsonConverter when serializing the member or class.
Class | JsonConverterCollection | Represents a collection of JsonConverter.
Class | JsonDictionaryAttribute | Instructs the JsonSerializer how to serialize the collection.
Class | JsonException | The exception thrown when an error occurs during Json serialization or deserialization.
Class | JsonExtensionDataAttribute | Instructs the JsonSerializer to deserialize properties with no matching class member into the specified collection and write values during serialization.
Class | JsonIgnoreAttribute | Instructs the JsonSerializer not to serialize the public field or public read/write property value.
Class | JsonObjectAttribute | Instructs the JsonSerializer how to serialize the object.
Class | JsonPropertyAttribute | Instructs the JsonSerializer to always serialize the member with the specified name.
Class | JsonReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | JsonReaderException | The exception thrown when an error occurs while reading Json text.
Class | JsonSerializationException | The exception thrown when an error occurs during Json serialization or deserialization.
Class | JsonSerializer | Serializes and deserializes objects into and from the JSON format. The JsonSerializer enables you to control how objects are encoded into JSON.
Class | JsonSerializerSettings | Specifies the settings on a JsonSerializer object.
Class | JsonTextReader | Represents a reader that provides fast, non-cached, forward-only access to JSON text data.
Class | JsonTextWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JsonValidatingReader | Represents a reader that provides Noemax.Newtonsoft.Json.Schema.JsonSchema validation.
Class | JsonWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JsonWriterException | The exception thrown when an error occurs while reading Json text.
Interfaces
 | Interface | Description
Interface | IJsonLineInfo | Provides an interface to enable a class to return line and position information.
Enumerations
 | Enumeration | Description
Enumeration | ConstructorHandling | Specifies how constructors are used when initializing objects during deserialization by the JsonSerializer.
Enumeration | DateFormatHandling | Specifies how dates are formatted when writing JSON text.
Enumeration | DateParseHandling | Specifies how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON text.
Enumeration | DateTimeZoneHandling | Specifies how to treat the time value when converting between string and System.DateTime.
Enumeration | DefaultValueHandling | Specifies default value handling options for the JsonSerializer.
Enumeration | FloatFormatHandling | Specifies float format handling options when writing special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity with JsonWriter.
Enumeration | FloatParseHandling | Specifies how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Enumeration | Formatting | Specifies formatting options for the JsonTextWriter.
Enumeration | JsonToken | Specifies the type of Json token.
Enumeration | MemberSerialization | Specifies the member serialization options for the JsonSerializer.
Enumeration | MetadataPropertyHandling | Specifies metadata property handling options for the JsonSerializer.
Enumeration | MissingMemberHandling | Specifies missing member handling options for the JsonSerializer.
Enumeration | NullValueHandling | Specifies null value handling options for the JsonSerializer.
Enumeration | ObjectCreationHandling | Specifies how object creation is handled by the JsonSerializer.
Enumeration | PreserveReferencesHandling | Specifies reference handling options for the JsonSerializer. Note that references cannot be preserved when a value is set via a non-default constructor such as types that implement ISerializable.
Enumeration | ReferenceLoopHandling | Specifies reference loop handling options for the JsonSerializer.
Enumeration | Required | Indicating whether a property is required.
Enumeration | StringEscapeHandling | Specifies how strings are escaped when writing JSON text.
Enumeration | TypeNameHandling | Specifies type name handling options for the JsonSerializer.
Enumeration | WriteState | Specifies the state of the JsonWriter.
See Also

Reference

Noemax.WebSockets Assembly


JsonArrayAttribute Class

JsonArrayAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonArrayAttribute Class
Instructs the JsonSerializer how to serialize the collection.
Object Model
JsonArrayAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Interface,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonArrayAttribute
   Inherits JsonContainerAttribute
'Usage

Dim instance As JsonArrayAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonArrayAttribute : JsonContainerAttribute
public class JsonArrayAttribute = class(JsonContainerAttribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=,
   Inherited=)
public sealed class JsonArrayAttribute extends JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonArrayAttribute : public JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonArrayAttribute sealed : public JsonContainerAttribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonArrayAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonArrayAttribute Class Members

JsonArrayAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonArrayAttribute Class

The following tables list the members exposed by JsonArrayAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonArrayAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AllowNullItems | Gets or sets a value indicating whether null items are allowed in the collection.
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonArrayAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonArrayAttribute Constructor

JsonArrayAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : JsonArrayAttribute Constructor
Overload List
Overload | Description
JsonArrayAttribute Constructor() | Initializes a new instance of the JsonArrayAttribute class.
JsonArrayAttribute Constructor(Boolean) | Initializes a new instance of the JsonObjectAttribute class with a flag indicating whether the array can contain null items
JsonArrayAttribute Constructor(String) | Initializes a new instance of the JsonArrayAttribute class with the specified container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


JsonArrayAttribute Constructor()

JsonArrayAttribute Constructor()

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class > JsonArrayAttribute Constructor : JsonArrayAttribute Constructor()
Initializes a new instance of the JsonArrayAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonArrayAttribute()
public JsonArrayAttribute()
public JsonArrayAttribute();
public function JsonArrayAttribute();
public: JsonArrayAttribute();
public:
JsonArrayAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members
Overload List


JsonArrayAttribute Constructor(Boolean)

JsonArrayAttribute Constructor(Boolean)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class > JsonArrayAttribute Constructor : JsonArrayAttribute Constructor(Boolean)
A flag indicating whether the array can contain null items.
Initializes a new instance of the JsonObjectAttribute class with a flag indicating whether the array can contain null items
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal allowNullItems As System.Boolean _
)
'Usage

Dim allowNullItems As System.Boolean

Dim instance As New JsonArrayAttribute(allowNullItems)
public JsonArrayAttribute(
   System.bool allowNullItems
)
public JsonArrayAttribute(
    allowNullItems: System.Boolean
);
public function JsonArrayAttribute(
   allowNullItems : System.boolean
);
public: JsonArrayAttribute(
   System.bool allowNullItems
)
public:
JsonArrayAttribute(
   System.bool allowNullItems
)

Parameters

allowNullItems
A flag indicating whether the array can contain null items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members
Overload List


JsonArrayAttribute Constructor(String)

JsonArrayAttribute Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class > JsonArrayAttribute Constructor : JsonArrayAttribute Constructor(String)
The container Id.
Initializes a new instance of the JsonArrayAttribute class with the specified container Id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal id As System.String _
)
'Usage

Dim id As System.String

Dim instance As New JsonArrayAttribute(id)
public JsonArrayAttribute(
   System.string id
)
public JsonArrayAttribute(
    id: System.String
);
public function JsonArrayAttribute(
   id : System.String
);
public: JsonArrayAttribute(
   System.string* id
)
public:
JsonArrayAttribute(
   System.String^ id
)

Parameters

id
The container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members
Overload List


JsonArrayAttribute Class Properties

JsonArrayAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonArrayAttribute Class

For a list of all members of this type, see JsonArrayAttribute members.

Public Properties
 | Name | Description
Public Property | AllowNullItems | Gets or sets a value indicating whether null items are allowed in the collection.
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonArrayAttribute Class
Noemax.Newtonsoft.Json Namespace


AllowNullItems Property (JsonArrayAttribute)

AllowNullItems Property (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : AllowNullItems Property
Gets or sets a value indicating whether null items are allowed in the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowNullItems As System.Boolean
'Usage

Dim instance As JsonArrayAttribute
Dim value As System.Boolean

instance.AllowNullItems = value

value = instance.AllowNullItems
public System.bool AllowNullItems {get; set;}
public read-write property AllowNullItems: System.Boolean;
public function get,set AllowNullItems : System.boolean
public: __property System.bool get_AllowNullItems();
public: __property void set_AllowNullItems(
   System.bool value
);
public:
property System.bool AllowNullItems {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if null items are allowed in the collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


JsonConstructorAttribute Class

JsonConstructorAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonConstructorAttribute Class
Instructs the JsonSerializer to use the specified constructor when deserializing that object.
Object Model
JsonConstructorAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonConstructorAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonConstructorAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonConstructorAttribute : System.Attribute
public class JsonConstructorAttribute = class(System.Attribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=,
   Inherited=)
public sealed class JsonConstructorAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonConstructorAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonConstructorAttribute sealed : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonConstructorAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonConstructorAttribute Class Members

JsonConstructorAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConstructorAttribute Class

The following tables list the members exposed by JsonConstructorAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonConstructorAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConstructorAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonConstructorAttribute Constructor

JsonConstructorAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : JsonConstructorAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonConstructorAttribute()
public JsonConstructorAttribute()
public JsonConstructorAttribute();
public function JsonConstructorAttribute();
public: JsonConstructorAttribute();
public:
JsonConstructorAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


JsonContainerAttribute Class

JsonContainerAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonContainerAttribute Class
Instructs the JsonSerializer how to serialize the object.
Object Model
JsonContainerAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Interface,
   AllowMultiple=False,
   Inherited=True)>
Public MustInherit Class JsonContainerAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public abstract class JsonContainerAttribute : System.Attribute
public class JsonContainerAttribute = class(System.Attribute)abstract;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=,
   Inherited=)
public abstract class JsonContainerAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public __gc abstract class JsonContainerAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonContainerAttribute abstract : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonArrayAttribute
Noemax.Newtonsoft.Json.JsonDictionaryAttribute
Noemax.Newtonsoft.Json.JsonObjectAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonContainerAttribute Class Members

JsonContainerAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonContainerAttribute Class

The following tables list the members exposed by JsonContainerAttribute.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description.
Public Property | Id | Gets or sets the id.
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references.
Public Property | ItemConverterType | Gets the collection's items converter.
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references.
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items.
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items.
Public Property | Title | Gets or sets the title.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonContainerAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonContainerAttribute Class Properties

JsonContainerAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonContainerAttribute Class

For a list of all members of this type, see JsonContainerAttribute members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description.
Public Property | Id | Gets or sets the id.
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references.
Public Property | ItemConverterType | Gets the collection's items converter.
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references.
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items.
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items.
Public Property | Title | Gets or sets the title.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonContainerAttribute Class
Noemax.Newtonsoft.Json Namespace


Description Property (JsonContainerAttribute)

Description Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : Description Property
Gets or sets the description.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As System.String
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.String

instance.Description = value

value = instance.Description
public System.string Description {get; set;}
public read-write property Description: System.String;
public function get,set Description : System.String
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


Id Property (JsonContainerAttribute)

Id Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : Id Property
Gets or sets the id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Id As System.String
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.String

instance.Id = value

value = instance.Id
public System.string Id {get; set;}
public read-write property Id: System.String;
public function get,set Id : System.String
public: __property System.string* get_Id();
public: __property void set_Id(
   System.string* value
);
public:
property System.String^ Id {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


IsReference Property (JsonContainerAttribute)

IsReference Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : IsReference Property
Gets or sets a value that indicates whether to preserve object references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsReference As System.Boolean
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Boolean

instance.IsReference = value

value = instance.IsReference
public System.bool IsReference {get; set;}
public read-write property IsReference: System.Boolean;
public function get,set IsReference : System.boolean
public: __property System.bool get_IsReference();
public: __property void set_IsReference(
   System.bool value
);
public:
property System.bool IsReference {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to keep object reference; otherwise, false. The default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


ItemConverterType Property (JsonContainerAttribute)

ItemConverterType Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : ItemConverterType Property
Gets the collection's items converter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemConverterType As System.Type
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Type

instance.ItemConverterType = value

value = instance.ItemConverterType
public System.Type ItemConverterType {get; set;}
public read-write property ItemConverterType: System.Type;
public function get,set ItemConverterType : System.Type
public: __property System.Type* get_ItemConverterType();
public: __property void set_ItemConverterType(
   System.Type* value
);
public:
property System.Type^ ItemConverterType {
   System.Type^ get();
   void set (    System.Type^ value);
}

Property Value

The collection's items converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


ItemIsReference Property (JsonContainerAttribute)

ItemIsReference Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : ItemIsReference Property
Gets or sets a value that indicates whether to preserve collection's items references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemIsReference As System.Boolean
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Boolean

instance.ItemIsReference = value

value = instance.ItemIsReference
public System.bool ItemIsReference {get; set;}
public read-write property ItemIsReference: System.Boolean;
public function get,set ItemIsReference : System.boolean
public: __property System.bool get_ItemIsReference();
public: __property void set_ItemIsReference(
   System.bool value
);
public:
property System.bool ItemIsReference {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to keep collection's items object references; otherwise, false. The default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


ItemReferenceLoopHandling Property (JsonContainerAttribute)

ItemReferenceLoopHandling Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : ItemReferenceLoopHandling Property
Gets or sets the reference loop handling used when serializing the collection's items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemReferenceLoopHandling As ReferenceLoopHandling
'Usage

Dim instance As JsonContainerAttribute
Dim value As ReferenceLoopHandling

instance.ItemReferenceLoopHandling = value

value = instance.ItemReferenceLoopHandling
public ReferenceLoopHandling ItemReferenceLoopHandling {get; set;}
public read-write property ItemReferenceLoopHandling: ReferenceLoopHandling;
public function get,set ItemReferenceLoopHandling : ReferenceLoopHandling
public: __property ReferenceLoopHandling get_ItemReferenceLoopHandling();
public: __property void set_ItemReferenceLoopHandling(
   ReferenceLoopHandling value
);
public:
property ReferenceLoopHandling ItemReferenceLoopHandling {
   ReferenceLoopHandling get();
   void set (    ReferenceLoopHandling value);
}

Property Value

The reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


ItemTypeNameHandling Property (JsonContainerAttribute)

ItemTypeNameHandling Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : ItemTypeNameHandling Property
Gets or sets the type name handling used when serializing the collection's items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemTypeNameHandling As TypeNameHandling
'Usage

Dim instance As JsonContainerAttribute
Dim value As TypeNameHandling

instance.ItemTypeNameHandling = value

value = instance.ItemTypeNameHandling
public TypeNameHandling ItemTypeNameHandling {get; set;}
public read-write property ItemTypeNameHandling: TypeNameHandling;
public function get,set ItemTypeNameHandling : TypeNameHandling
public: __property TypeNameHandling get_ItemTypeNameHandling();
public: __property void set_ItemTypeNameHandling(
   TypeNameHandling value
);
public:
property TypeNameHandling ItemTypeNameHandling {
   TypeNameHandling get();
   void set (    TypeNameHandling value);
}

Property Value

The type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


Title Property (JsonContainerAttribute)

Title Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : Title Property
Gets or sets the title.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As System.String
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.String

instance.Title = value

value = instance.Title
public System.string Title {get; set;}
public read-write property Title: System.String;
public function get,set Title : System.String
public: __property System.string* get_Title();
public: __property void set_Title(
   System.string* value
);
public:
property System.String^ Title {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The title.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


JsonConvert Class

JsonConvert Class
Members Example

Noemax.Newtonsoft.Json Namespace : JsonConvert Class
Provides methods for converting between common language runtime types and JSON types.
Object Model
JsonConvert Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class JsonConvert
'Usage

Dim instance As JsonConvert
public static class JsonConvert
public class JsonConvert abstract; sealed;
public abstract sealed class JsonConvert
public __gc abstract __sealed class JsonConvert
public ref class JsonConvert abstract sealed
Example
  • C#

Inheritance Hierarchy
System.Object
   Noemax.Newtonsoft.Json.JsonConvert

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
JsonConvert Members

Noemax.Newtonsoft.Json Namespace


JsonConvert Class Members

JsonConvert Class Members
Fields Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

The following tables list the members exposed by JsonConvert.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | False | Represents JavaScript's boolean value false as a string. This field is read-only.
static (Shared in Visual Basic) | NaN | Represents JavaScript's NaN as a string. This field is read-only.
static (Shared in Visual Basic) | NegativeInfinity | Represents JavaScript's negative infinity as a string. This field is read-only.
static (Shared in Visual Basic) | Null | Represents JavaScript's null as a string. This field is read-only.
static (Shared in Visual Basic) | PositiveInfinity | Represents JavaScript's positive infinity as a string. This field is read-only.
static (Shared in Visual Basic) | True | Represents JavaScript's boolean value true as a string. This field is read-only.
static (Shared in Visual Basic) | Undefined | Represents JavaScript's undefined as a string. This field is read-only.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | DefaultSettings | Gets or sets a function that creates default JsonSerializerSettings. Default settings are automatically used by serialization methods on JsonConvert, and Noemax.Newtonsoft.Json.Linq.JToken.ToObject``1 and Noemax.Newtonsoft.Json.Linq.JToken.FromObject on Noemax.Newtonsoft.Json.Linq.JToken. To serialize without using any default settings create a JsonSerializer with JsonSerializer.Create.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | DeserializeAnonymousType | Overloaded. Deserializes the JSON to the given anonymous type.
static (Shared in Visual Basic) | DeserializeObject | Overloaded. Deserializes the JSON to a .NET object.
static (Shared in Visual Basic) | DeserializeXmlNode | Overloaded. Deserializes the XmlNode from a JSON string.
static (Shared in Visual Basic) | DeserializeXNode | Overloaded. Deserializes the System.Xml.Linq.XNode from a JSON string.
static (Shared in Visual Basic) | PopulateObject | Overloaded. Populates the object with values from the JSON string.
static (Shared in Visual Basic) | SerializeObject | Overloaded. Serializes the specified object to a JSON string.
static (Shared in Visual Basic) | SerializeXmlNode | Overloaded. Serializes the XML node to a JSON string.
static (Shared in Visual Basic) | SerializeXNode | Overloaded. Serializes the System.Xml.Linq.XNode to a JSON string.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the System.DateTime to its JSON string representation.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


JsonConvert Class Methods

JsonConvert Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

For a list of all members of this type, see JsonConvert members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | DeserializeAnonymousType | Overloaded. Deserializes the JSON to the given anonymous type.
static (Shared in Visual Basic) | DeserializeObject | Overloaded. Deserializes the JSON to a .NET object.
static (Shared in Visual Basic) | DeserializeXmlNode | Overloaded. Deserializes the XmlNode from a JSON string.
static (Shared in Visual Basic) | DeserializeXNode | Overloaded. Deserializes the System.Xml.Linq.XNode from a JSON string.
static (Shared in Visual Basic) | PopulateObject | Overloaded. Populates the object with values from the JSON string.
static (Shared in Visual Basic) | SerializeObject | Overloaded. Serializes the specified object to a JSON string.
static (Shared in Visual Basic) | SerializeXmlNode | Overloaded. Serializes the XML node to a JSON string.
static (Shared in Visual Basic) | SerializeXNode | Overloaded. Serializes the System.Xml.Linq.XNode to a JSON string.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the System.DateTime to its JSON string representation.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


DeserializeAnonymousType Method (JsonConvert)

DeserializeAnonymousType Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DeserializeAnonymousType Method
Deserializes the JSON to the given anonymous type.
Overload List
Overload | Description
DeserializeAnonymousType<T>(String,T) | Deserializes the JSON to the given anonymous type.
DeserializeAnonymousType<T>(String,T,JsonSerializerSettings) | Deserializes the JSON to the given anonymous type using JsonSerializerSettings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


DeserializeAnonymousType<T>(String,T) Method

DeserializeAnonymousType<T>(String,T) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeAnonymousType Method : DeserializeAnonymousType<T>(String,T) Method
The anonymous type to deserialize to. This can't be specified traditionally and must be infered from the anonymous type passed as a parameter.
The JSON to deserialize.
The anonymous type object.
Deserializes the JSON to the given anonymous type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeAnonymousType(Of T)( _
   ByVal value As System.String, _
   ByVal anonymousTypeObject As T _
) As T
'Usage

Dim value As System.String
Dim anonymousTypeObject As T
Dim value As T

value = JsonConvert.DeserializeAnonymousType(Of T)(value, anonymousTypeObject)
public static T DeserializeAnonymousType<T>(
   System.string value,
   T anonymousTypeObject
)
public function DeserializeAnonymousType(
    value: System.String;
    anonymousTypeObject: T
): T; static;
public static function DeserializeAnonymousType(
   value : System.String,
   anonymousTypeObject : T
) : T;
public: static T* DeserializeAnonymousType<T>(
   System.string* value,
   T* anonymousTypeObject
)
public:
static T^ DeserializeAnonymousTypegeneric<typename T>
(
   System.String^ value,
   T^ anonymousTypeObject
)

Parameters

value
The JSON to deserialize.
anonymousTypeObject
The anonymous type object.

Type Parameters

T
The anonymous type to deserialize to. This can't be specified traditionally and must be infered from the anonymous type passed as a parameter.

Return Value

The deserialized anonymous type from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeAnonymousType<T>(String,T,JsonSerializerSettings) Method

DeserializeAnonymousType<T>(String,T,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeAnonymousType Method : DeserializeAnonymousType<T>(String,T,JsonSerializerSettings) Method
The anonymous type to deserialize to. This can't be specified traditionally and must be infered from the anonymous type passed as a parameter.
The JSON to deserialize.
The anonymous type object.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Deserializes the JSON to the given anonymous type using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeAnonymousType(Of T)( _
   ByVal value As System.String, _
   ByVal anonymousTypeObject As T, _
   ByVal settings As JsonSerializerSettings _
) As T
'Usage

Dim value As System.String
Dim anonymousTypeObject As T
Dim settings As JsonSerializerSettings
Dim value As T

value = JsonConvert.DeserializeAnonymousType(Of T)(value, anonymousTypeObject, settings)
public static T DeserializeAnonymousType<T>(
   System.string value,
   T anonymousTypeObject,
   JsonSerializerSettings settings
)
public function DeserializeAnonymousType(
    value: System.String;
    anonymousTypeObject: T;
    settings: JsonSerializerSettings
): T; static;
public static function DeserializeAnonymousType(
   value : System.String,
   anonymousTypeObject : T,
   settings : JsonSerializerSettings
) : T;
public: static T* DeserializeAnonymousType<T>(
   System.string* value,
   T* anonymousTypeObject,
   JsonSerializerSettings* settings
)
public:
static T^ DeserializeAnonymousTypegeneric<typename T>
(
   System.String^ value,
   T^ anonymousTypeObject,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to deserialize.
anonymousTypeObject
The anonymous type object.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Type Parameters

T
The anonymous type to deserialize to. This can't be specified traditionally and must be infered from the anonymous type passed as a parameter.

Return Value

The deserialized anonymous type from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject Method (JsonConvert)

DeserializeObject Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DeserializeObject Method
Deserializes the JSON to a .NET object.
Overload List
Overload | Description
DeserializeObject(String) | Deserializes the JSON to a .NET object.
DeserializeObject(String,JsonSerializerSettings) | Deserializes the JSON to a .NET object using JsonSerializerSettings.
DeserializeObject(String,Type) | Deserializes the JSON to the specified .NET type.
DeserializeObject<T>(String) | Deserializes the JSON to the specified .NET type.
DeserializeObject<T>(String,JsonConverter[]) | Deserializes the JSON to the specified .NET type using a collection of JsonConverter.
DeserializeObject<T>(String,JsonSerializerSettings) | Deserializes the JSON to the specified .NET type using JsonSerializerSettings.
DeserializeObject(String,Type,JsonConverter[]) | Deserializes the JSON to the specified .NET type using a collection of JsonConverter.
DeserializeObject(String,Type,JsonSerializerSettings) | Deserializes the JSON to the specified .NET type using JsonSerializerSettings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


DeserializeObject(String) Method

DeserializeObject(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject(String) Method
The JSON to deserialize.
Deserializes the JSON to a .NET object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject( _
   ByVal value As System.String _
) As System.Object
'Usage

Dim value As System.String
Dim value As System.Object

value = JsonConvert.DeserializeObject(value)
public static System.object DeserializeObject(
   System.string value
)
public function DeserializeObject(
    value: System.String
): System.TObject; static;
public static function DeserializeObject(
   value : System.String
) : System.Object;
public: static System.Object* DeserializeObject(
   System.string* value
)
public:
static System.Object^ DeserializeObject(
   System.String^ value
)

Parameters

value
The JSON to deserialize.

Return Value

The deserialized object from the Json string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject(String,JsonSerializerSettings) Method

DeserializeObject(String,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject(String,JsonSerializerSettings) Method
The JSON to deserialize.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Deserializes the JSON to a .NET object using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject( _
   ByVal value As System.String, _
   ByVal settings As JsonSerializerSettings _
) As System.Object
'Usage

Dim value As System.String
Dim settings As JsonSerializerSettings
Dim value As System.Object

value = JsonConvert.DeserializeObject(value, settings)
public static System.object DeserializeObject(
   System.string value,
   JsonSerializerSettings settings
)
public function DeserializeObject(
    value: System.String;
    settings: JsonSerializerSettings
): System.TObject; static;
public static function DeserializeObject(
   value : System.String,
   settings : JsonSerializerSettings
) : System.Object;
public: static System.Object* DeserializeObject(
   System.string* value,
   JsonSerializerSettings* settings
)
public:
static System.Object^ DeserializeObject(
   System.String^ value,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to deserialize.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Return Value

The deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject(String,Type) Method

DeserializeObject(String,Type) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject(String,Type) Method
The JSON to deserialize.
The System.Type of object being deserialized.
Deserializes the JSON to the specified .NET type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject( _
   ByVal value As System.String, _
   ByVal type As System.Type _
) As System.Object
'Usage

Dim value As System.String
Dim type As System.Type
Dim value As System.Object

value = JsonConvert.DeserializeObject(value, type)
public static System.object DeserializeObject(
   System.string value,
   System.Type type
)
public function DeserializeObject(
    value: System.String;
    type: System.Type
): System.TObject; static;
public static function DeserializeObject(
   value : System.String,
   type : System.Type
) : System.Object;
public: static System.Object* DeserializeObject(
   System.string* value,
   System.Type* type
)
public:
static System.Object^ DeserializeObject(
   System.String^ value,
   System.Type^ type
)

Parameters

value
The JSON to deserialize.
type
The System.Type of object being deserialized.

Return Value

The deserialized object from the Json string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject<T>(String) Method

DeserializeObject<T>(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject<T>(String) Method
The type of the object to deserialize to.
The JSON to deserialize.
Deserializes the JSON to the specified .NET type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject(Of T)( _
   ByVal value As System.String _
) As T
'Usage

Dim value As System.String
Dim value As T

value = JsonConvert.DeserializeObject(Of T)(value)
public static T DeserializeObject<T>(
   System.string value
)
public function DeserializeObject(
    value: System.String
): T; static;
public static function DeserializeObject(
   value : System.String
) : T;
public: static T* DeserializeObject<T>(
   System.string* value
)
public:
static T^ DeserializeObjectgeneric<typename T>
(
   System.String^ value
)

Parameters

value
The JSON to deserialize.

Type Parameters

T
The type of the object to deserialize to.

Return Value

The deserialized object from the Json string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject<T>(String,JsonConverter[]) Method

DeserializeObject<T>(String,JsonConverter[]) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject<T>(String,JsonConverter[]) Method
The type of the object to deserialize to.
The JSON to deserialize.
Converters to use while deserializing.
Deserializes the JSON to the specified .NET type using a collection of JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject(Of T)( _
   ByVal value As System.String, _
   ByVal ParamArray converters() As JsonConverter _
) As T
'Usage

Dim value As System.String
Dim converters() As JsonConverter
Dim value As T

value = JsonConvert.DeserializeObject(Of T)(value, converters)
public static T DeserializeObject<T>(
   System.string value,
   params JsonConverter[] converters
)
public function DeserializeObject(
    value: System.String;
   params  converters: JsonConverterarray of
): T; static;
public static function DeserializeObject(
   value : System.String,
   converters : JsonConverter[]
) : T;
public: static T* DeserializeObject<T>(
   System.string* value,
   params JsonConverter*[]* converters
)
public:
static T^ DeserializeObjectgeneric<typename T>
(
   System.String^ value,
   ... array<JsonConverter^>^ converters
)

Parameters

value
The JSON to deserialize.
converters
Converters to use while deserializing.

Type Parameters

T
The type of the object to deserialize to.

Return Value

The deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject<T>(String,JsonSerializerSettings) Method

DeserializeObject<T>(String,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject<T>(String,JsonSerializerSettings) Method
The type of the object to deserialize to.
The object to deserialize.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Deserializes the JSON to the specified .NET type using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject(Of T)( _
   ByVal value As System.String, _
   ByVal settings As JsonSerializerSettings _
) As T
'Usage

Dim value As System.String
Dim settings As JsonSerializerSettings
Dim value As T

value = JsonConvert.DeserializeObject(Of T)(value, settings)
public static T DeserializeObject<T>(
   System.string value,
   JsonSerializerSettings settings
)
public function DeserializeObject(
    value: System.String;
    settings: JsonSerializerSettings
): T; static;
public static function DeserializeObject(
   value : System.String,
   settings : JsonSerializerSettings
) : T;
public: static T* DeserializeObject<T>(
   System.string* value,
   JsonSerializerSettings* settings
)
public:
static T^ DeserializeObjectgeneric<typename T>
(
   System.String^ value,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to deserialize.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Type Parameters

T
The type of the object to deserialize to.

Return Value

The deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject(String,Type,JsonConverter[]) Method

DeserializeObject(String,Type,JsonConverter[]) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject(String,Type,JsonConverter[]) Method
The JSON to deserialize.
The type of the object to deserialize.
Converters to use while deserializing.
Deserializes the JSON to the specified .NET type using a collection of JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject( _
   ByVal value As System.String, _
   ByVal type As System.Type, _
   ByVal ParamArray converters() As JsonConverter _
) As System.Object
'Usage

Dim value As System.String
Dim type As System.Type
Dim converters() As JsonConverter
Dim value As System.Object

value = JsonConvert.DeserializeObject(value, type, converters)
public static System.object DeserializeObject(
   System.string value,
   System.Type type,
   params JsonConverter[] converters
)
public function DeserializeObject(
    value: System.String;
    type: System.Type;
   params  converters: JsonConverterarray of
): System.TObject; static;
public static function DeserializeObject(
   value : System.String,
   type : System.Type,
   converters : JsonConverter[]
) : System.Object;
public: static System.Object* DeserializeObject(
   System.string* value,
   System.Type* type,
   params JsonConverter*[]* converters
)
public:
static System.Object^ DeserializeObject(
   System.String^ value,
   System.Type^ type,
   ... array<JsonConverter^>^ converters
)

Parameters

value
The JSON to deserialize.
type
The type of the object to deserialize.
converters
Converters to use while deserializing.

Return Value

The deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObject(String,Type,JsonSerializerSettings) Method

DeserializeObject(String,Type,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObject Method : DeserializeObject(String,Type,JsonSerializerSettings) Method
The JSON to deserialize.
The type of the object to deserialize to.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Deserializes the JSON to the specified .NET type using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeObject( _
   ByVal value As System.String, _
   ByVal type As System.Type, _
   ByVal settings As JsonSerializerSettings _
) As System.Object
'Usage

Dim value As System.String
Dim type As System.Type
Dim settings As JsonSerializerSettings
Dim value As System.Object

value = JsonConvert.DeserializeObject(value, type, settings)
public static System.object DeserializeObject(
   System.string value,
   System.Type type,
   JsonSerializerSettings settings
)
public function DeserializeObject(
    value: System.String;
    type: System.Type;
    settings: JsonSerializerSettings
): System.TObject; static;
public static function DeserializeObject(
   value : System.String,
   type : System.Type,
   settings : JsonSerializerSettings
) : System.Object;
public: static System.Object* DeserializeObject(
   System.string* value,
   System.Type* type,
   JsonSerializerSettings* settings
)
public:
static System.Object^ DeserializeObject(
   System.String^ value,
   System.Type^ type,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to deserialize.
type
The type of the object to deserialize to.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Return Value

The deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXmlNode Method (JsonConvert)

DeserializeXmlNode Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DeserializeXmlNode Method
Deserializes the XmlNode from a JSON string.
Overload List
Overload | Description
DeserializeXmlNode(String) | Deserializes the XmlNode from a JSON string.
DeserializeXmlNode(String,String) | Deserializes the XmlNode from a JSON string nested in a root elment specified by deserializeRootElementName.
DeserializeXmlNode(String,String,Boolean) | Deserializes the XmlNode from a JSON string nested in a root elment specified by deserializeRootElementName and writes a .NET array attribute for collections.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


DeserializeXmlNode(String) Method

DeserializeXmlNode(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXmlNode Method : DeserializeXmlNode(String) Method
The JSON string.
Deserializes the XmlNode from a JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXmlNode( _
   ByVal value As System.String _
) As System.Xml.XmlDocument
'Usage

Dim value As System.String
Dim value As System.Xml.XmlDocument

value = JsonConvert.DeserializeXmlNode(value)
public static System.Xml.XmlDocument DeserializeXmlNode(
   System.string value
)
public function DeserializeXmlNode(
    value: System.String
): System.Xml.XmlDocument; static;
public static function DeserializeXmlNode(
   value : System.String
) : System.Xml.XmlDocument;
public: static System.Xml.XmlDocument* DeserializeXmlNode(
   System.string* value
)
public:
static System.Xml.XmlDocument^ DeserializeXmlNode(
   System.String^ value
)

Parameters

value
The JSON string.

Return Value

The deserialized XmlNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXmlNode(String,String) Method

DeserializeXmlNode(String,String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXmlNode Method : DeserializeXmlNode(String,String) Method
The JSON string.
The name of the root element to append when deserializing.
Deserializes the XmlNode from a JSON string nested in a root elment specified by deserializeRootElementName.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXmlNode( _
   ByVal value As System.String, _
   ByVal deserializeRootElementName As System.String _
) As System.Xml.XmlDocument
'Usage

Dim value As System.String
Dim deserializeRootElementName As System.String
Dim value As System.Xml.XmlDocument

value = JsonConvert.DeserializeXmlNode(value, deserializeRootElementName)
public static System.Xml.XmlDocument DeserializeXmlNode(
   System.string value,
   System.string deserializeRootElementName
)
public function DeserializeXmlNode(
    value: System.String;
    deserializeRootElementName: System.String
): System.Xml.XmlDocument; static;
public static function DeserializeXmlNode(
   value : System.String,
   deserializeRootElementName : System.String
) : System.Xml.XmlDocument;
public: static System.Xml.XmlDocument* DeserializeXmlNode(
   System.string* value,
   System.string* deserializeRootElementName
)
public:
static System.Xml.XmlDocument^ DeserializeXmlNode(
   System.String^ value,
   System.String^ deserializeRootElementName
)

Parameters

value
The JSON string.
deserializeRootElementName
The name of the root element to append when deserializing.

Return Value

The deserialized XmlNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXmlNode(String,String,Boolean) Method

DeserializeXmlNode(String,String,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXmlNode Method : DeserializeXmlNode(String,String,Boolean) Method
The JSON string.
The name of the root element to append when deserializing.
A flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.
Deserializes the XmlNode from a JSON string nested in a root elment specified by deserializeRootElementName and writes a .NET array attribute for collections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXmlNode( _
   ByVal value As System.String, _
   ByVal deserializeRootElementName As System.String, _
   ByVal writeArrayAttribute As System.Boolean _
) As System.Xml.XmlDocument
'Usage

Dim value As System.String
Dim deserializeRootElementName As System.String
Dim writeArrayAttribute As System.Boolean
Dim value As System.Xml.XmlDocument

value = JsonConvert.DeserializeXmlNode(value, deserializeRootElementName, writeArrayAttribute)
public static System.Xml.XmlDocument DeserializeXmlNode(
   System.string value,
   System.string deserializeRootElementName,
   System.bool writeArrayAttribute
)
public function DeserializeXmlNode(
    value: System.String;
    deserializeRootElementName: System.String;
    writeArrayAttribute: System.Boolean
): System.Xml.XmlDocument; static;
public static function DeserializeXmlNode(
   value : System.String,
   deserializeRootElementName : System.String,
   writeArrayAttribute : System.boolean
) : System.Xml.XmlDocument;
public: static System.Xml.XmlDocument* DeserializeXmlNode(
   System.string* value,
   System.string* deserializeRootElementName,
   System.bool writeArrayAttribute
)
public:
static System.Xml.XmlDocument^ DeserializeXmlNode(
   System.String^ value,
   System.String^ deserializeRootElementName,
   System.bool writeArrayAttribute
)

Parameters

value
The JSON string.
deserializeRootElementName
The name of the root element to append when deserializing.
writeArrayAttribute
A flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.

Return Value

The deserialized XmlNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXNode Method (JsonConvert)

DeserializeXNode Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DeserializeXNode Method
Deserializes the System.Xml.Linq.XNode from a JSON string.
Overload List
Overload | Description
DeserializeXNode(String) | Deserializes the System.Xml.Linq.XNode from a JSON string.
DeserializeXNode(String,String) | Deserializes the System.Xml.Linq.XNode from a JSON string nested in a root elment specified by deserializeRootElementName.
DeserializeXNode(String,String,Boolean) | Deserializes the System.Xml.Linq.XNode from a JSON string nested in a root elment specified by deserializeRootElementName and writes a .NET array attribute for collections.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


DeserializeXNode(String) Method

DeserializeXNode(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXNode Method : DeserializeXNode(String) Method
The JSON string.
Deserializes the System.Xml.Linq.XNode from a JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXNode( _
   ByVal value As System.String _
) As System.Xml.Linq.XDocument
'Usage

Dim value As System.String
Dim value As System.Xml.Linq.XDocument

value = JsonConvert.DeserializeXNode(value)
public static System.Xml.Linq.XDocument DeserializeXNode(
   System.string value
)
public function DeserializeXNode(
    value: System.String
): System.Xml.Linq.XDocument; static;
public static function DeserializeXNode(
   value : System.String
) : System.Xml.Linq.XDocument;
public: static System.Xml.Linq.XDocument* DeserializeXNode(
   System.string* value
)
public:
static System.Xml.Linq.XDocument^ DeserializeXNode(
   System.String^ value
)

Parameters

value
The JSON string.

Return Value

The deserialized XNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXNode(String,String) Method

DeserializeXNode(String,String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXNode Method : DeserializeXNode(String,String) Method
The JSON string.
The name of the root element to append when deserializing.
Deserializes the System.Xml.Linq.XNode from a JSON string nested in a root elment specified by deserializeRootElementName.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXNode( _
   ByVal value As System.String, _
   ByVal deserializeRootElementName As System.String _
) As System.Xml.Linq.XDocument
'Usage

Dim value As System.String
Dim deserializeRootElementName As System.String
Dim value As System.Xml.Linq.XDocument

value = JsonConvert.DeserializeXNode(value, deserializeRootElementName)
public static System.Xml.Linq.XDocument DeserializeXNode(
   System.string value,
   System.string deserializeRootElementName
)
public function DeserializeXNode(
    value: System.String;
    deserializeRootElementName: System.String
): System.Xml.Linq.XDocument; static;
public static function DeserializeXNode(
   value : System.String,
   deserializeRootElementName : System.String
) : System.Xml.Linq.XDocument;
public: static System.Xml.Linq.XDocument* DeserializeXNode(
   System.string* value,
   System.string* deserializeRootElementName
)
public:
static System.Xml.Linq.XDocument^ DeserializeXNode(
   System.String^ value,
   System.String^ deserializeRootElementName
)

Parameters

value
The JSON string.
deserializeRootElementName
The name of the root element to append when deserializing.

Return Value

The deserialized XNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeXNode(String,String,Boolean) Method

DeserializeXNode(String,String,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeXNode Method : DeserializeXNode(String,String,Boolean) Method
The JSON string.
The name of the root element to append when deserializing.
A flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.
Deserializes the System.Xml.Linq.XNode from a JSON string nested in a root elment specified by deserializeRootElementName and writes a .NET array attribute for collections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function DeserializeXNode( _
   ByVal value As System.String, _
   ByVal deserializeRootElementName As System.String, _
   ByVal writeArrayAttribute As System.Boolean _
) As System.Xml.Linq.XDocument
'Usage

Dim value As System.String
Dim deserializeRootElementName As System.String
Dim writeArrayAttribute As System.Boolean
Dim value As System.Xml.Linq.XDocument

value = JsonConvert.DeserializeXNode(value, deserializeRootElementName, writeArrayAttribute)
public static System.Xml.Linq.XDocument DeserializeXNode(
   System.string value,
   System.string deserializeRootElementName,
   System.bool writeArrayAttribute
)
public function DeserializeXNode(
    value: System.String;
    deserializeRootElementName: System.String;
    writeArrayAttribute: System.Boolean
): System.Xml.Linq.XDocument; static;
public static function DeserializeXNode(
   value : System.String,
   deserializeRootElementName : System.String,
   writeArrayAttribute : System.boolean
) : System.Xml.Linq.XDocument;
public: static System.Xml.Linq.XDocument* DeserializeXNode(
   System.string* value,
   System.string* deserializeRootElementName,
   System.bool writeArrayAttribute
)
public:
static System.Xml.Linq.XDocument^ DeserializeXNode(
   System.String^ value,
   System.String^ deserializeRootElementName,
   System.bool writeArrayAttribute
)

Parameters

value
The JSON string.
deserializeRootElementName
The name of the root element to append when deserializing.
writeArrayAttribute
A flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.

Return Value

The deserialized XNode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


PopulateObject Method (JsonConvert)

PopulateObject Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : PopulateObject Method
Populates the object with values from the JSON string.
Overload List
Overload | Description
PopulateObject(String,Object) | Populates the object with values from the JSON string.
PopulateObject(String,Object,JsonSerializerSettings) | Populates the object with values from the JSON string using JsonSerializerSettings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


PopulateObject(String,Object) Method

PopulateObject(String,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > PopulateObject Method : PopulateObject(String,Object) Method
The JSON to populate values from.
The target object to populate values onto.
Populates the object with values from the JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub PopulateObject( _
   ByVal value As System.String, _
   ByVal target As System.Object _
)
'Usage

Dim value As System.String
Dim target As System.Object

JsonConvert.PopulateObject(value, target)
public static void PopulateObject(
   System.string value,
   System.object target
)
public procedure PopulateObject(
    value: System.String;
    target: System.TObject
); static;
public static function PopulateObject(
   value : System.String,
   target : System.Object
);
public: static void PopulateObject(
   System.string* value,
   System.Object* target
)
public:
static void PopulateObject(
   System.String^ value,
   System.Object^ target
)

Parameters

value
The JSON to populate values from.
target
The target object to populate values onto.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


PopulateObject(String,Object,JsonSerializerSettings) Method

PopulateObject(String,Object,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > PopulateObject Method : PopulateObject(String,Object,JsonSerializerSettings) Method
The JSON to populate values from.
The target object to populate values onto.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Populates the object with values from the JSON string using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Sub PopulateObject( _
   ByVal value As System.String, _
   ByVal target As System.Object, _
   ByVal settings As JsonSerializerSettings _
)
'Usage

Dim value As System.String
Dim target As System.Object
Dim settings As JsonSerializerSettings

JsonConvert.PopulateObject(value, target, settings)
public static void PopulateObject(
   System.string value,
   System.object target,
   JsonSerializerSettings settings
)
public procedure PopulateObject(
    value: System.String;
    target: System.TObject;
    settings: JsonSerializerSettings
); static;
public static function PopulateObject(
   value : System.String,
   target : System.Object,
   settings : JsonSerializerSettings
);
public: static void PopulateObject(
   System.string* value,
   System.Object* target,
   JsonSerializerSettings* settings
)
public:
static void PopulateObject(
   System.String^ value,
   System.Object^ target,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to populate values from.
target
The target object to populate values onto.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject Method (JsonConvert)

SerializeObject Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : SerializeObject Method
Serializes the specified object to a JSON string.
Overload List
Overload | Description
SerializeObject(Object) | Serializes the specified object to a JSON string.
SerializeObject(Object,Formatting) | Serializes the specified object to a JSON string using formatting.
SerializeObject(Object,JsonConverter[]) | Serializes the specified object to a JSON string using a collection of JsonConverter.
SerializeObject(Object,Formatting,JsonConverter[]) | Serializes the specified object to a JSON string using formatting and a collection of JsonConverter.
SerializeObject(Object,JsonSerializerSettings) | Serializes the specified object to a JSON string using JsonSerializerSettings.
SerializeObject(Object,Type,JsonSerializerSettings) | Serializes the specified object to a JSON string using a type, formatting and JsonSerializerSettings.
SerializeObject(Object,Formatting,JsonSerializerSettings) | Serializes the specified object to a JSON string using formatting and JsonSerializerSettings.
SerializeObject(Object,Type,Formatting,JsonSerializerSettings) | Serializes the specified object to a JSON string using a type, formatting and JsonSerializerSettings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


SerializeObject(Object) Method

SerializeObject(Object) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object) Method
The object to serialize.
Serializes the specified object to a JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object _
) As System.String
'Usage

Dim value As System.Object
Dim value As System.String

value = JsonConvert.SerializeObject(value)
public static System.string SerializeObject(
   System.object value
)
public function SerializeObject(
    value: System.TObject
): System.String; static;
public static function SerializeObject(
   value : System.Object
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value
)
public:
static System.String^ SerializeObject(
   System.Object^ value
)

Parameters

value
The object to serialize.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,Formatting) Method

SerializeObject(Object,Formatting) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,Formatting) Method
The object to serialize.
Indicates how the output is formatted.
Serializes the specified object to a JSON string using formatting.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal formatting As Formatting _
) As System.String
'Usage

Dim value As System.Object
Dim formatting As Formatting
Dim value As System.String

value = JsonConvert.SerializeObject(value, formatting)
public static System.string SerializeObject(
   System.object value,
   Formatting formatting
)
public function SerializeObject(
    value: System.TObject;
    formatting: Formatting
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   formatting : Formatting
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   Formatting formatting
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   Formatting formatting
)

Parameters

value
The object to serialize.
formatting
Indicates how the output is formatted.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,JsonConverter[]) Method

SerializeObject(Object,JsonConverter[]) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,JsonConverter[]) Method
The object to serialize.
A collection converters used while serializing.
Serializes the specified object to a JSON string using a collection of JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal ParamArray converters() As JsonConverter _
) As System.String
'Usage

Dim value As System.Object
Dim converters() As JsonConverter
Dim value As System.String

value = JsonConvert.SerializeObject(value, converters)
public static System.string SerializeObject(
   System.object value,
   params JsonConverter[] converters
)
public function SerializeObject(
    value: System.TObject;
   params  converters: JsonConverterarray of
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   converters : JsonConverter[]
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   params JsonConverter*[]* converters
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   ... array<JsonConverter^>^ converters
)

Parameters

value
The object to serialize.
converters
A collection converters used while serializing.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,Formatting,JsonConverter[]) Method

SerializeObject(Object,Formatting,JsonConverter[]) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,Formatting,JsonConverter[]) Method
The object to serialize.
Indicates how the output is formatted.
A collection converters used while serializing.
Serializes the specified object to a JSON string using formatting and a collection of JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal formatting As Formatting, _
   ByVal ParamArray converters() As JsonConverter _
) As System.String
'Usage

Dim value As System.Object
Dim formatting As Formatting
Dim converters() As JsonConverter
Dim value As System.String

value = JsonConvert.SerializeObject(value, formatting, converters)
public static System.string SerializeObject(
   System.object value,
   Formatting formatting,
   params JsonConverter[] converters
)
public function SerializeObject(
    value: System.TObject;
    formatting: Formatting;
   params  converters: JsonConverterarray of
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   formatting : Formatting,
   converters : JsonConverter[]
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   Formatting formatting,
   params JsonConverter*[]* converters
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   Formatting formatting,
   ... array<JsonConverter^>^ converters
)

Parameters

value
The object to serialize.
formatting
Indicates how the output is formatted.
converters
A collection converters used while serializing.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,JsonSerializerSettings) Method

SerializeObject(Object,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,JsonSerializerSettings) Method
The object to serialize.
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.
Serializes the specified object to a JSON string using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal settings As JsonSerializerSettings _
) As System.String
'Usage

Dim value As System.Object
Dim settings As JsonSerializerSettings
Dim value As System.String

value = JsonConvert.SerializeObject(value, settings)
public static System.string SerializeObject(
   System.object value,
   JsonSerializerSettings settings
)
public function SerializeObject(
    value: System.TObject;
    settings: JsonSerializerSettings
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   settings : JsonSerializerSettings
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   JsonSerializerSettings* settings
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to serialize.
settings
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,Type,JsonSerializerSettings) Method

SerializeObject(Object,Type,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,Type,JsonSerializerSettings) Method
The object to serialize.
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.
Serializes the specified object to a JSON string using a type, formatting and JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal type As System.Type, _
   ByVal settings As JsonSerializerSettings _
) As System.String
'Usage

Dim value As System.Object
Dim type As System.Type
Dim settings As JsonSerializerSettings
Dim value As System.String

value = JsonConvert.SerializeObject(value, type, settings)
public static System.string SerializeObject(
   System.object value,
   System.Type type,
   JsonSerializerSettings settings
)
public function SerializeObject(
    value: System.TObject;
    type: System.Type;
    settings: JsonSerializerSettings
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   type : System.Type,
   settings : JsonSerializerSettings
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   System.Type* type,
   JsonSerializerSettings* settings
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   System.Type^ type,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to serialize.
type
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
settings
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,Formatting,JsonSerializerSettings) Method

SerializeObject(Object,Formatting,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,Formatting,JsonSerializerSettings) Method
The object to serialize.
Indicates how the output is formatted.
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.
Serializes the specified object to a JSON string using formatting and JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal formatting As Formatting, _
   ByVal settings As JsonSerializerSettings _
) As System.String
'Usage

Dim value As System.Object
Dim formatting As Formatting
Dim settings As JsonSerializerSettings
Dim value As System.String

value = JsonConvert.SerializeObject(value, formatting, settings)
public static System.string SerializeObject(
   System.object value,
   Formatting formatting,
   JsonSerializerSettings settings
)
public function SerializeObject(
    value: System.TObject;
    formatting: Formatting;
    settings: JsonSerializerSettings
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   formatting : Formatting,
   settings : JsonSerializerSettings
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   Formatting formatting,
   JsonSerializerSettings* settings
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   Formatting formatting,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to serialize.
formatting
Indicates how the output is formatted.
settings
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObject(Object,Type,Formatting,JsonSerializerSettings) Method

SerializeObject(Object,Type,Formatting,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObject Method : SerializeObject(Object,Type,Formatting,JsonSerializerSettings) Method
The object to serialize.
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
Indicates how the output is formatted.
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.
Serializes the specified object to a JSON string using a type, formatting and JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeObject( _
   ByVal value As System.Object, _
   ByVal type As System.Type, _
   ByVal formatting As Formatting, _
   ByVal settings As JsonSerializerSettings _
) As System.String
'Usage

Dim value As System.Object
Dim type As System.Type
Dim formatting As Formatting
Dim settings As JsonSerializerSettings
Dim value As System.String

value = JsonConvert.SerializeObject(value, type, formatting, settings)
public static System.string SerializeObject(
   System.object value,
   System.Type type,
   Formatting formatting,
   JsonSerializerSettings settings
)
public function SerializeObject(
    value: System.TObject;
    type: System.Type;
    formatting: Formatting;
    settings: JsonSerializerSettings
): System.String; static;
public static function SerializeObject(
   value : System.Object,
   type : System.Type,
   formatting : Formatting,
   settings : JsonSerializerSettings
) : System.String;
public: static System.string* SerializeObject(
   System.Object* value,
   System.Type* type,
   Formatting formatting,
   JsonSerializerSettings* settings
)
public:
static System.String^ SerializeObject(
   System.Object^ value,
   System.Type^ type,
   Formatting formatting,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to serialize.
type
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
formatting
Indicates how the output is formatted.
settings
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.

Return Value

A JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXmlNode Method (JsonConvert)

SerializeXmlNode Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : SerializeXmlNode Method
Serializes the XML node to a JSON string.
Overload List
Overload | Description
SerializeXmlNode(XmlNode) | Serializes the XML node to a JSON string.
SerializeXmlNode(XmlNode,Formatting) | Serializes the XML node to a JSON string using formatting.
SerializeXmlNode(XmlNode,Formatting,Boolean) | Serializes the XML node to a JSON string using formatting and omits the root object if omitRootObject is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


SerializeXmlNode(XmlNode) Method

SerializeXmlNode(XmlNode) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXmlNode Method : SerializeXmlNode(XmlNode) Method
The node to serialize.
Serializes the XML node to a JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXmlNode( _
   ByVal node As System.Xml.XmlNode _
) As System.String
'Usage

Dim node As System.Xml.XmlNode
Dim value As System.String

value = JsonConvert.SerializeXmlNode(node)
public static System.string SerializeXmlNode(
   System.Xml.XmlNode node
)
public function SerializeXmlNode(
    node: System.Xml.XmlNode
): System.String; static;
public static function SerializeXmlNode(
   node : System.Xml.XmlNode
) : System.String;
public: static System.string* SerializeXmlNode(
   System.Xml.XmlNode* node
)
public:
static System.String^ SerializeXmlNode(
   System.Xml.XmlNode^ node
)

Parameters

node
The node to serialize.

Return Value

A JSON string of the XmlNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXmlNode(XmlNode,Formatting) Method

SerializeXmlNode(XmlNode,Formatting) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXmlNode Method : SerializeXmlNode(XmlNode,Formatting) Method
The node to serialize.
Indicates how the output is formatted.
Serializes the XML node to a JSON string using formatting.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXmlNode( _
   ByVal node As System.Xml.XmlNode, _
   ByVal formatting As Formatting _
) As System.String
'Usage

Dim node As System.Xml.XmlNode
Dim formatting As Formatting
Dim value As System.String

value = JsonConvert.SerializeXmlNode(node, formatting)
public static System.string SerializeXmlNode(
   System.Xml.XmlNode node,
   Formatting formatting
)
public function SerializeXmlNode(
    node: System.Xml.XmlNode;
    formatting: Formatting
): System.String; static;
public static function SerializeXmlNode(
   node : System.Xml.XmlNode,
   formatting : Formatting
) : System.String;
public: static System.string* SerializeXmlNode(
   System.Xml.XmlNode* node,
   Formatting formatting
)
public:
static System.String^ SerializeXmlNode(
   System.Xml.XmlNode^ node,
   Formatting formatting
)

Parameters

node
The node to serialize.
formatting
Indicates how the output is formatted.

Return Value

A JSON string of the XmlNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXmlNode(XmlNode,Formatting,Boolean) Method

SerializeXmlNode(XmlNode,Formatting,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXmlNode Method : SerializeXmlNode(XmlNode,Formatting,Boolean) Method
The node to serialize.
Indicates how the output is formatted.
Omits writing the root object.
Serializes the XML node to a JSON string using formatting and omits the root object if omitRootObject is true.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXmlNode( _
   ByVal node As System.Xml.XmlNode, _
   ByVal formatting As Formatting, _
   ByVal omitRootObject As System.Boolean _
) As System.String
'Usage

Dim node As System.Xml.XmlNode
Dim formatting As Formatting
Dim omitRootObject As System.Boolean
Dim value As System.String

value = JsonConvert.SerializeXmlNode(node, formatting, omitRootObject)
public static System.string SerializeXmlNode(
   System.Xml.XmlNode node,
   Formatting formatting,
   System.bool omitRootObject
)
public function SerializeXmlNode(
    node: System.Xml.XmlNode;
    formatting: Formatting;
    omitRootObject: System.Boolean
): System.String; static;
public static function SerializeXmlNode(
   node : System.Xml.XmlNode,
   formatting : Formatting,
   omitRootObject : System.boolean
) : System.String;
public: static System.string* SerializeXmlNode(
   System.Xml.XmlNode* node,
   Formatting formatting,
   System.bool omitRootObject
)
public:
static System.String^ SerializeXmlNode(
   System.Xml.XmlNode^ node,
   Formatting formatting,
   System.bool omitRootObject
)

Parameters

node
The node to serialize.
formatting
Indicates how the output is formatted.
omitRootObject
Omits writing the root object.

Return Value

A JSON string of the XmlNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXNode Method (JsonConvert)

SerializeXNode Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : SerializeXNode Method
Serializes the System.Xml.Linq.XNode to a JSON string.
Overload List
Overload | Description
SerializeXNode(XObject) | Serializes the System.Xml.Linq.XNode to a JSON string.
SerializeXNode(XObject,Formatting) | Serializes the System.Xml.Linq.XNode to a JSON string using formatting.
SerializeXNode(XObject,Formatting,Boolean) | Serializes the System.Xml.Linq.XNode to a JSON string using formatting and omits the root object if omitRootObject is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


SerializeXNode(XObject) Method

SerializeXNode(XObject) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXNode Method : SerializeXNode(XObject) Method
The node to convert to JSON.
Serializes the System.Xml.Linq.XNode to a JSON string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXNode( _
   ByVal node As System.Xml.Linq.XObject _
) As System.String
'Usage

Dim node As System.Xml.Linq.XObject
Dim value As System.String

value = JsonConvert.SerializeXNode(node)
public static System.string SerializeXNode(
   System.Xml.Linq.XObject node
)
public function SerializeXNode(
    node: System.Xml.Linq.XObject
): System.String; static;
public static function SerializeXNode(
   node : System.Xml.Linq.XObject
) : System.String;
public: static System.string* SerializeXNode(
   System.Xml.Linq.XObject* node
)
public:
static System.String^ SerializeXNode(
   System.Xml.Linq.XObject^ node
)

Parameters

node
The node to convert to JSON.

Return Value

A JSON string of the XNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXNode(XObject,Formatting) Method

SerializeXNode(XObject,Formatting) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXNode Method : SerializeXNode(XObject,Formatting) Method
The node to convert to JSON.
Indicates how the output is formatted.
Serializes the System.Xml.Linq.XNode to a JSON string using formatting.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXNode( _
   ByVal node As System.Xml.Linq.XObject, _
   ByVal formatting As Formatting _
) As System.String
'Usage

Dim node As System.Xml.Linq.XObject
Dim formatting As Formatting
Dim value As System.String

value = JsonConvert.SerializeXNode(node, formatting)
public static System.string SerializeXNode(
   System.Xml.Linq.XObject node,
   Formatting formatting
)
public function SerializeXNode(
    node: System.Xml.Linq.XObject;
    formatting: Formatting
): System.String; static;
public static function SerializeXNode(
   node : System.Xml.Linq.XObject,
   formatting : Formatting
) : System.String;
public: static System.string* SerializeXNode(
   System.Xml.Linq.XObject* node,
   Formatting formatting
)
public:
static System.String^ SerializeXNode(
   System.Xml.Linq.XObject^ node,
   Formatting formatting
)

Parameters

node
The node to convert to JSON.
formatting
Indicates how the output is formatted.

Return Value

A JSON string of the XNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeXNode(XObject,Formatting,Boolean) Method

SerializeXNode(XObject,Formatting,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeXNode Method : SerializeXNode(XObject,Formatting,Boolean) Method
The node to serialize.
Indicates how the output is formatted.
Omits writing the root object.
Serializes the System.Xml.Linq.XNode to a JSON string using formatting and omits the root object if omitRootObject is true.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function SerializeXNode( _
   ByVal node As System.Xml.Linq.XObject, _
   ByVal formatting As Formatting, _
   ByVal omitRootObject As System.Boolean _
) As System.String
'Usage

Dim node As System.Xml.Linq.XObject
Dim formatting As Formatting
Dim omitRootObject As System.Boolean
Dim value As System.String

value = JsonConvert.SerializeXNode(node, formatting, omitRootObject)
public static System.string SerializeXNode(
   System.Xml.Linq.XObject node,
   Formatting formatting,
   System.bool omitRootObject
)
public function SerializeXNode(
    node: System.Xml.Linq.XObject;
    formatting: Formatting;
    omitRootObject: System.Boolean
): System.String; static;
public static function SerializeXNode(
   node : System.Xml.Linq.XObject,
   formatting : Formatting,
   omitRootObject : System.boolean
) : System.String;
public: static System.string* SerializeXNode(
   System.Xml.Linq.XObject* node,
   Formatting formatting,
   System.bool omitRootObject
)
public:
static System.String^ SerializeXNode(
   System.Xml.Linq.XObject^ node,
   Formatting formatting,
   System.bool omitRootObject
)

Parameters

node
The node to serialize.
formatting
Indicates how the output is formatted.
omitRootObject
Omits writing the root object.

Return Value

A JSON string of the XNode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString Method (JsonConvert)

ToString Method (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : ToString Method
Converts the System.DateTime to its JSON string representation.
Overload List
Overload | Description
ToString(DateTime) | Converts the System.DateTime to its JSON string representation.
ToString(DateTime,DateFormatHandling,DateTimeZoneHandling) | Converts the System.DateTime to its JSON string representation using the DateFormatHandling specified.
ToString(DateTimeOffset) | Converts the System.DateTimeOffset to its JSON string representation.
ToString(DateTimeOffset,DateFormatHandling) | Converts the System.DateTimeOffset to its JSON string representation using the DateFormatHandling specified.
ToString(Boolean) | Converts the System.Boolean to its JSON string representation.
ToString(Char) | Converts the System.Char to its JSON string representation.
ToString(Enum) | Converts the System.Enum to its JSON string representation.
ToString(Int32) | Converts the System.Int32 to its JSON string representation.
ToString(Int16) | Converts the System.Int16 to its JSON string representation.
ToString(UInt16) | Converts the System.UInt16 to its JSON string representation.
ToString(UInt32) | Converts the System.UInt32 to its JSON string representation.
ToString(Int64) | Converts the System.Int64 to its JSON string representation.
ToString(UInt64) | Converts the System.UInt64 to its JSON string representation.
ToString(Single) | Converts the System.Single to its JSON string representation.
ToString(Double) | Converts the System.Double to its JSON string representation.
ToString(Byte) | Converts the System.Byte to its JSON string representation.
ToString(SByte) | Converts the System.SByte to its JSON string representation.
ToString(Decimal) | Converts the System.Decimal to its JSON string representation.
ToString(Guid) | Converts the System.Guid to its JSON string representation.
ToString(TimeSpan) | Converts the System.TimeSpan to its JSON string representation.
ToString(Uri) | Converts the System.Uri to its JSON string representation.
ToString(String) | Converts the System.String to its JSON string representation.
ToString(String,Char) | Converts the System.String to its JSON string representation.
ToString(Object) | Converts the System.Object to its JSON string representation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


ToString(DateTime) Method

ToString(DateTime) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(DateTime) Method
The value to convert.
Converts the System.DateTime to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Date _
) As System.String
'Usage

Dim value As System.Date
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.DateTime value
)
public function ToString(
    value: System.DateTime
): System.String; static;
public static function ToString(
   value : System.DateTime
) : System.String;
public: static System.string* ToString(
   System.DateTime value
)
public:
static System.String^ ToString(
   System.DateTime value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.DateTime.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(DateTime,DateFormatHandling,DateTimeZoneHandling) Method

ToString(DateTime,DateFormatHandling,DateTimeZoneHandling) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(DateTime,DateFormatHandling,DateTimeZoneHandling) Method
The value to convert.
The format the date will be converted to.
The time zone handling when the date is converted to a string.
Converts the System.DateTime to its JSON string representation using the DateFormatHandling specified.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Date, _
   ByVal format As DateFormatHandling, _
   ByVal timeZoneHandling As DateTimeZoneHandling _
) As System.String
'Usage

Dim value As System.Date
Dim format As DateFormatHandling
Dim timeZoneHandling As DateTimeZoneHandling
Dim value As System.String

value = JsonConvert.ToString(value, format, timeZoneHandling)
public static System.string ToString(
   System.DateTime value,
   DateFormatHandling format,
   DateTimeZoneHandling timeZoneHandling
)
public function ToString(
    value: System.DateTime;
    format: DateFormatHandling;
    timeZoneHandling: DateTimeZoneHandling
): System.String; static;
public static function ToString(
   value : System.DateTime,
   format : DateFormatHandling,
   timeZoneHandling : DateTimeZoneHandling
) : System.String;
public: static System.string* ToString(
   System.DateTime value,
   DateFormatHandling format,
   DateTimeZoneHandling timeZoneHandling
)
public:
static System.String^ ToString(
   System.DateTime value,
   DateFormatHandling format,
   DateTimeZoneHandling timeZoneHandling
)

Parameters

value
The value to convert.
format
The format the date will be converted to.
timeZoneHandling
The time zone handling when the date is converted to a string.

Return Value

A JSON string representation of the System.DateTime.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(DateTimeOffset) Method

ToString(DateTimeOffset) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(DateTimeOffset) Method
The value to convert.
Converts the System.DateTimeOffset to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.DateTimeOffset _
) As System.String
'Usage

Dim value As System.DateTimeOffset
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.DateTimeOffset value
)
public function ToString(
    value: System.DateTimeOffset
): System.String; static;
public static function ToString(
   value : System.DateTimeOffset
) : System.String;
public: static System.string* ToString(
   System.DateTimeOffset value
)
public:
static System.String^ ToString(
   System.DateTimeOffset value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.DateTimeOffset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(DateTimeOffset,DateFormatHandling) Method

ToString(DateTimeOffset,DateFormatHandling) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(DateTimeOffset,DateFormatHandling) Method
The value to convert.
The format the date will be converted to.
Converts the System.DateTimeOffset to its JSON string representation using the DateFormatHandling specified.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.DateTimeOffset, _
   ByVal format As DateFormatHandling _
) As System.String
'Usage

Dim value As System.DateTimeOffset
Dim format As DateFormatHandling
Dim value As System.String

value = JsonConvert.ToString(value, format)
public static System.string ToString(
   System.DateTimeOffset value,
   DateFormatHandling format
)
public function ToString(
    value: System.DateTimeOffset;
    format: DateFormatHandling
): System.String; static;
public static function ToString(
   value : System.DateTimeOffset,
   format : DateFormatHandling
) : System.String;
public: static System.string* ToString(
   System.DateTimeOffset value,
   DateFormatHandling format
)
public:
static System.String^ ToString(
   System.DateTimeOffset value,
   DateFormatHandling format
)

Parameters

value
The value to convert.
format
The format the date will be converted to.

Return Value

A JSON string representation of the System.DateTimeOffset.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Boolean) Method

ToString(Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Boolean) Method
The value to convert.
Converts the System.Boolean to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Boolean _
) As System.String
'Usage

Dim value As System.Boolean
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.bool value
)
public function ToString(
    value: System.Boolean
): System.String; static;
public static function ToString(
   value : System.boolean
) : System.String;
public: static System.string* ToString(
   System.bool value
)
public:
static System.String^ ToString(
   System.bool value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Boolean.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Char) Method

ToString(Char) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Char) Method
The value to convert.
Converts the System.Char to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Char _
) As System.String
'Usage

Dim value As System.Char
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.char value
)
public function ToString(
    value: System.Char
): System.String; static;
public static function ToString(
   value : System.char
) : System.String;
public: static System.string* ToString(
   System.char value
)
public:
static System.String^ ToString(
   System.char value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Char.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Enum) Method

ToString(Enum) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Enum) Method
The value to convert.
Converts the System.Enum to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Enum _
) As System.String
'Usage

Dim value As System.Enum
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.Enum value
)
public function ToString(
    value: System.Enum
): System.String; static;
public static function ToString(
   value : System.Enum
) : System.String;
public: static System.string* ToString(
   System.Enum* value
)
public:
static System.String^ ToString(
   System.Enum^ value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Enum.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Int32) Method

ToString(Int32) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Int32) Method
The value to convert.
Converts the System.Int32 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Integer _
) As System.String
'Usage

Dim value As System.Integer
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.int value
)
public function ToString(
    value: System.Integer
): System.String; static;
public static function ToString(
   value : System.int
) : System.String;
public: static System.string* ToString(
   System.int value
)
public:
static System.String^ ToString(
   System.int value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Int32.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Int16) Method

ToString(Int16) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Int16) Method
The value to convert.
Converts the System.Int16 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Short _
) As System.String
'Usage

Dim value As System.Short
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.short value
)
public function ToString(
    value: System.Int16
): System.String; static;
public static function ToString(
   value : System.short
) : System.String;
public: static System.string* ToString(
   System.short value
)
public:
static System.String^ ToString(
   System.short value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Int16.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(UInt16) Method

ToString(UInt16) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(UInt16) Method
The value to convert.
Converts the System.UInt16 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Shared Function ToString( _
   ByVal value As System.UShort _
) As System.String
'Usage

Dim value As System.UShort
Dim value As System.String

value = JsonConvert.ToString(value)
[System.CLSCompliant(false)]
public static System.string ToString(
   System.ushort value
)
public function ToString(
    value: System.Word
): System.String; static;
System.CLSCompliantAttribute()
public static function ToString(
   value : System.ushort
) : System.String;
[System.CLSCompliant(false)]
public: static System.string* ToString(
   System.ushort value
)
[System.CLSCompliant(false)]
public:
static System.String^ ToString(
   System.ushort value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.UInt16.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(UInt32) Method

ToString(UInt32) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(UInt32) Method
The value to convert.
Converts the System.UInt32 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Shared Function ToString( _
   ByVal value As System.UInteger _
) As System.String
'Usage

Dim value As System.UInteger
Dim value As System.String

value = JsonConvert.ToString(value)
[System.CLSCompliant(false)]
public static System.string ToString(
   System.uint value
)
public function ToString(
    value: System.LongWord
): System.String; static;
System.CLSCompliantAttribute()
public static function ToString(
   value : System.uint
) : System.String;
[System.CLSCompliant(false)]
public: static System.string* ToString(
   System.uint value
)
[System.CLSCompliant(false)]
public:
static System.String^ ToString(
   System.uint value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.UInt32.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Int64) Method

ToString(Int64) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Int64) Method
The value to convert.
Converts the System.Int64 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Long _
) As System.String
'Usage

Dim value As System.Long
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.long value
)
public function ToString(
    value: System.Int64
): System.String; static;
public static function ToString(
   value : System.long
) : System.String;
public: static System.string* ToString(
   System.long value
)
public:
static System.String^ ToString(
   System.int64 value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Int64.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(UInt64) Method

ToString(UInt64) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(UInt64) Method
The value to convert.
Converts the System.UInt64 to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Shared Function ToString( _
   ByVal value As System.ULong _
) As System.String
'Usage

Dim value As System.ULong
Dim value As System.String

value = JsonConvert.ToString(value)
[System.CLSCompliant(false)]
public static System.string ToString(
   System.ulong value
)
public function ToString(
    value: System.UInt64
): System.String; static;
System.CLSCompliantAttribute()
public static function ToString(
   value : System.ulong
) : System.String;
[System.CLSCompliant(false)]
public: static System.string* ToString(
   System.ulong value
)
[System.CLSCompliant(false)]
public:
static System.String^ ToString(
   System.ulong value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.UInt64.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Single) Method

ToString(Single) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Single) Method
The value to convert.
Converts the System.Single to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Single _
) As System.String
'Usage

Dim value As System.Single
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.float value
)
public function ToString(
    value: System.Single
): System.String; static;
public static function ToString(
   value : System.float
) : System.String;
public: static System.string* ToString(
   System.float value
)
public:
static System.String^ ToString(
   System.float value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Single.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Double) Method

ToString(Double) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Double) Method
The value to convert.
Converts the System.Double to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Double _
) As System.String
'Usage

Dim value As System.Double
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.double value
)
public function ToString(
    value: System.Double
): System.String; static;
public static function ToString(
   value : System.double
) : System.String;
public: static System.string* ToString(
   System.double value
)
public:
static System.String^ ToString(
   System.double value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Double.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Byte) Method

ToString(Byte) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Byte) Method
The value to convert.
Converts the System.Byte to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Byte _
) As System.String
'Usage

Dim value As System.Byte
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.byte value
)
public function ToString(
    value: System.Byte
): System.String; static;
public static function ToString(
   value : System.byte
) : System.String;
public: static System.string* ToString(
   System.byte value
)
public:
static System.String^ ToString(
   System.byte value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Byte.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(SByte) Method

ToString(SByte) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(SByte) Method
The value to convert.
Converts the System.SByte to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Shared Function ToString( _
   ByVal value As System.SByte _
) As System.String
'Usage

Dim value As System.SByte
Dim value As System.String

value = JsonConvert.ToString(value)
[System.CLSCompliant(false)]
public static System.string ToString(
   System.sbyte value
)
public function ToString(
    value: System.ShortInt
): System.String; static;
System.CLSCompliantAttribute()
public static function ToString(
   value : System.sbyte
) : System.String;
[System.CLSCompliant(false)]
public: static System.string* ToString(
   System.sbyte value
)
[System.CLSCompliant(false)]
public:
static System.String^ ToString(
   System.sbyte value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.SByte.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Decimal) Method

ToString(Decimal) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Decimal) Method
The value to convert.
Converts the System.Decimal to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Decimal _
) As System.String
'Usage

Dim value As System.Decimal
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.decimal value
)
public function ToString(
    value: System.Currency
): System.String; static;
public static function ToString(
   value : System.decimal
) : System.String;
public: static System.string* ToString(
   System.decimal value
)
public:
static System.String^ ToString(
   System.decimal value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.SByte.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Guid) Method

ToString(Guid) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Guid) Method
The value to convert.
Converts the System.Guid to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Guid _
) As System.String
'Usage

Dim value As System.Guid
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.Guid value
)
public function ToString(
    value: System.Guid
): System.String; static;
public static function ToString(
   value : System.Guid
) : System.String;
public: static System.string* ToString(
   System.Guid value
)
public:
static System.String^ ToString(
   System.Guid value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Guid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(TimeSpan) Method

ToString(TimeSpan) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(TimeSpan) Method
The value to convert.
Converts the System.TimeSpan to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.TimeSpan _
) As System.String
'Usage

Dim value As System.TimeSpan
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.TimeSpan value
)
public function ToString(
    value: System.TimeSpan
): System.String; static;
public static function ToString(
   value : System.TimeSpan
) : System.String;
public: static System.string* ToString(
   System.TimeSpan value
)
public:
static System.String^ ToString(
   System.TimeSpan value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.TimeSpan.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Uri) Method

ToString(Uri) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Uri) Method
The value to convert.
Converts the System.Uri to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Uri _
) As System.String
'Usage

Dim value As System.Uri
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.Uri value
)
public function ToString(
    value: System.Uri
): System.String; static;
public static function ToString(
   value : System.Uri
) : System.String;
public: static System.string* ToString(
   System.Uri* value
)
public:
static System.String^ ToString(
   System.Uri^ value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(String) Method

ToString(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(String) Method
The value to convert.
Converts the System.String to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.String _
) As System.String
'Usage

Dim value As System.String
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.string value
)
public function ToString(
    value: System.String
): System.String; static;
public static function ToString(
   value : System.String
) : System.String;
public: static System.string* ToString(
   System.string* value
)
public:
static System.String^ ToString(
   System.String^ value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.String.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(String,Char) Method

ToString(String,Char) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(String,Char) Method
The value to convert.
The string delimiter character.
Converts the System.String to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.String, _
   ByVal delimiter As System.Char _
) As System.String
'Usage

Dim value As System.String
Dim delimiter As System.Char
Dim value As System.String

value = JsonConvert.ToString(value, delimiter)
public static System.string ToString(
   System.string value,
   System.char delimiter
)
public function ToString(
    value: System.String;
    delimiter: System.Char
): System.String; static;
public static function ToString(
   value : System.String,
   delimiter : System.char
) : System.String;
public: static System.string* ToString(
   System.string* value,
   System.char delimiter
)
public:
static System.String^ ToString(
   System.String^ value,
   System.char delimiter
)

Parameters

value
The value to convert.
delimiter
The string delimiter character.

Return Value

A JSON string representation of the System.String.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


ToString(Object) Method

ToString(Object) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > ToString Method : ToString(Object) Method
The value to convert.
Converts the System.Object to its JSON string representation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function ToString( _
   ByVal value As System.Object _
) As System.String
'Usage

Dim value As System.Object
Dim value As System.String

value = JsonConvert.ToString(value)
public static System.string ToString(
   System.object value
)
public function ToString(
    value: System.TObject
): System.String; static;
public static function ToString(
   value : System.Object
) : System.String;
public: static System.string* ToString(
   System.Object* value
)
public:
static System.String^ ToString(
   System.Object^ value
)

Parameters

value
The value to convert.

Return Value

A JSON string representation of the System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


JsonConvert Class Properties

JsonConvert Class Properties

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

For a list of all members of this type, see JsonConvert members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | DefaultSettings | Gets or sets a function that creates default JsonSerializerSettings. Default settings are automatically used by serialization methods on JsonConvert, and Noemax.Newtonsoft.Json.Linq.JToken.ToObject``1 and Noemax.Newtonsoft.Json.Linq.JToken.FromObject on Noemax.Newtonsoft.Json.Linq.JToken. To serialize without using any default settings create a JsonSerializer with JsonSerializer.Create.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


DefaultSettings Property (JsonConvert)

DefaultSettings Property (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DefaultSettings Property
Gets or sets a function that creates default JsonSerializerSettings. Default settings are automatically used by serialization methods on JsonConvert, and Noemax.Newtonsoft.Json.Linq.JToken.ToObject``1 and Noemax.Newtonsoft.Json.Linq.JToken.FromObject on Noemax.Newtonsoft.Json.Linq.JToken. To serialize without using any default settings create a JsonSerializer with JsonSerializer.Create.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Property DefaultSettings As System.Func(Of JsonSerializerSettings)
'Usage

Dim value As System.Func(Of JsonSerializerSettings)

JsonConvert.DefaultSettings = value

value = JsonConvert.DefaultSettings
public static System.Func<JsonSerializerSettings> DefaultSettings {get; set;}
public read-write property DefaultSettings: System.Func; static;
public static function get,set DefaultSettings : System.Func
public: __property static System.Func<JsonSerializerSettings*>* get_DefaultSettings();
public: __property static void set_DefaultSettings(
   System.Func<JsonSerializerSettings*>* value
);
public:
static property System.Func<JsonSerializerSettings^>^ DefaultSettings {
   System.Func<JsonSerializerSettings^>^ get();
   void set (    System.Func<JsonSerializerSettings^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


JsonConvert Class Fields

JsonConvert Class Fields

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

For a list of all members of this type, see JsonConvert members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | False | Represents JavaScript's boolean value false as a string. This field is read-only.
static (Shared in Visual Basic) | NaN | Represents JavaScript's NaN as a string. This field is read-only.
static (Shared in Visual Basic) | NegativeInfinity | Represents JavaScript's negative infinity as a string. This field is read-only.
static (Shared in Visual Basic) | Null | Represents JavaScript's null as a string. This field is read-only.
static (Shared in Visual Basic) | PositiveInfinity | Represents JavaScript's positive infinity as a string. This field is read-only.
static (Shared in Visual Basic) | True | Represents JavaScript's boolean value true as a string. This field is read-only.
static (Shared in Visual Basic) | Undefined | Represents JavaScript's undefined as a string. This field is read-only.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


False Field (JsonConvert)

False Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : False Field
Represents JavaScript's boolean value false as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly False As System.String
'Usage

Dim value As System.String

value = JsonConvert.False
public static readonly System.string False
public field False: System.String; static; readonly
public static var False : System.String;
public: static readonly System.string* False
public:
static readonly System.String^ False
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


NaN Field (JsonConvert)

NaN Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : NaN Field
Represents JavaScript's NaN as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly NaN As System.String
'Usage

Dim value As System.String

value = JsonConvert.NaN
public static readonly System.string NaN
public field NaN: System.String; static; readonly
public static var NaN : System.String;
public: static readonly System.string* NaN
public:
static readonly System.String^ NaN
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


NegativeInfinity Field (JsonConvert)

NegativeInfinity Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : NegativeInfinity Field
Represents JavaScript's negative infinity as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly NegativeInfinity As System.String
'Usage

Dim value As System.String

value = JsonConvert.NegativeInfinity
public static readonly System.string NegativeInfinity
public field NegativeInfinity: System.String; static; readonly
public static var NegativeInfinity : System.String;
public: static readonly System.string* NegativeInfinity
public:
static readonly System.String^ NegativeInfinity
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


Null Field (JsonConvert)

Null Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : Null Field
Represents JavaScript's null as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Null As System.String
'Usage

Dim value As System.String

value = JsonConvert.Null
public static readonly System.string Null
public field Null: System.String; static; readonly
public static var Null : System.String;
public: static readonly System.string* Null
public:
static readonly System.String^ Null
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


PositiveInfinity Field (JsonConvert)

PositiveInfinity Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : PositiveInfinity Field
Represents JavaScript's positive infinity as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly PositiveInfinity As System.String
'Usage

Dim value As System.String

value = JsonConvert.PositiveInfinity
public static readonly System.string PositiveInfinity
public field PositiveInfinity: System.String; static; readonly
public static var PositiveInfinity : System.String;
public: static readonly System.string* PositiveInfinity
public:
static readonly System.String^ PositiveInfinity
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


True Field (JsonConvert)

True Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : True Field
Represents JavaScript's boolean value true as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly True As System.String
'Usage

Dim value As System.String

value = JsonConvert.True
public static readonly System.string True
public field True: System.String; static; readonly
public static var True : System.String;
public: static readonly System.string* True
public:
static readonly System.String^ True
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


Undefined Field (JsonConvert)

Undefined Field (JsonConvert)

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : Undefined Field
Represents JavaScript's undefined as a string. This field is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Undefined As System.String
'Usage

Dim value As System.String

value = JsonConvert.Undefined
public static readonly System.string Undefined
public field Undefined: System.String; static; readonly
public static var Undefined : System.String;
public: static readonly System.string* Undefined
public:
static readonly System.String^ Undefined
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


JsonConverter Class

JsonConverter Class
Members

Noemax.Newtonsoft.Json Namespace : JsonConverter Class
Converts an object to and from JSON.
Object Model
JsonConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class JsonConverter
'Usage

Dim instance As JsonConverter
public abstract class JsonConverter
public class JsonConverter abstract;
public abstract class JsonConverter
public __gc abstract class JsonConverter
public ref class JsonConverter abstract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>
Noemax.Newtonsoft.Json.Converters.DataSetConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.DiscriminatedUnionConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter
Noemax.Newtonsoft.Json.Converters.ExpandoObjectConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Members
Noemax.Newtonsoft.Json Namespace


JsonConverter Class Members

JsonConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConverter Class

The following tables list the members exposed by JsonConverter.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this JsonConverter can read JSON.
Public Property | CanWrite | Gets a value indicating whether this JsonConverter can write JSON.
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter.
Public Method | ReadJson | Reads the JSON representation of the object.
Public Method | WriteJson | Writes the JSON representation of the object.
Top
See Also

Reference

JsonConverter Class
Noemax.Newtonsoft.Json Namespace


JsonConverter Class Methods

JsonConverter Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConverter Class

For a list of all members of this type, see JsonConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter.
Public Method | ReadJson | Reads the JSON representation of the object.
Public Method | WriteJson | Writes the JSON representation of the object.
Top
See Also

Reference

JsonConverter Class
Noemax.Newtonsoft.Json Namespace


CanConvert Method (JsonConverter)

CanConvert Method (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As JsonConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public abstract System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; abstract;
public __abstract function CanConvert(
   objectType : System.Type
) : System.boolean;
public: abstract System.bool CanConvert(
   System.Type* objectType
)
public:
abstract System.bool CanConvert(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


GetSchema Method (JsonConverter)

GetSchema Method (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : GetSchema Method
Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetSchema() As JsonSchema
'Usage

Dim instance As JsonConverter
Dim value As JsonSchema

value = instance.GetSchema()
public virtual JsonSchema GetSchema()
public function GetSchema(): JsonSchema; virtual;
public function GetSchema() : JsonSchema;
public: virtual JsonSchema* GetSchema();
public:
virtual JsonSchema^ GetSchema();

Return Value

The Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


ReadJson Method (JsonConverter)

ReadJson Method (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : ReadJson Method
The JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As JsonConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public abstract System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; abstract;
public __abstract function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: abstract System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
)
public:
abstract System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
)

Parameters

reader
The JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


WriteJson Method (JsonConverter)

WriteJson Method (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : WriteJson Method
The JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As JsonConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public abstract void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); abstract;
public __abstract function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: abstract void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
)
public:
abstract void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
)

Parameters

writer
The JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


JsonConverter Class Properties

JsonConverter Class Properties

Noemax.Newtonsoft.Json Namespace : JsonConverter Class

For a list of all members of this type, see JsonConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this JsonConverter can read JSON.
Public Property | CanWrite | Gets a value indicating whether this JsonConverter can write JSON.
Top
See Also

Reference

JsonConverter Class
Noemax.Newtonsoft.Json Namespace


CanRead Property (JsonConverter)

CanRead Property (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : CanRead Property
Gets a value indicating whether this JsonConverter can read JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property CanRead As System.Boolean
'Usage

Dim instance As JsonConverter
Dim value As System.Boolean

value = instance.CanRead
public virtual System.bool CanRead {get;}
public read-only property CanRead: System.Boolean; virtual;
public function get CanRead : System.boolean
public: __property virtual System.bool get_CanRead();
public:
virtual property System.bool CanRead {
   System.bool get();
}

Property Value

true if this JsonConverter can read JSON; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


CanWrite Property (JsonConverter)

CanWrite Property (JsonConverter)

Noemax.Newtonsoft.Json Namespace > JsonConverter Class : CanWrite Property
Gets a value indicating whether this JsonConverter can write JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property CanWrite As System.Boolean
'Usage

Dim instance As JsonConverter
Dim value As System.Boolean

value = instance.CanWrite
public virtual System.bool CanWrite {get;}
public read-only property CanWrite: System.Boolean; virtual;
public function get CanWrite : System.boolean
public: __property virtual System.bool get_CanWrite();
public:
virtual property System.bool CanWrite {
   System.bool get();
}

Property Value

true if this JsonConverter can write JSON; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverter Class
JsonConverter Members


JsonConverterAttribute Class

JsonConverterAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonConverterAttribute Class
Instructs the JsonSerializer to use the specified JsonConverter when serializing the member or class.
Object Model
JsonConverterAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Enum Or  _
    AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Interface Or  _
    AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonConverterAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonConverterAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Interface |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonConverterAttribute : System.Attribute
public class JsonConverterAttribute = class(System.Attribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Interface |
    AttributeTargets.Parameter,
   AllowMultiple=,
   Inherited=)
public sealed class JsonConverterAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Interface |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonConverterAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Enum |
    AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Interface |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonConverterAttribute sealed : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonConverterAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonConverterAttribute Class Members

JsonConverterAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConverterAttribute Class

The following tables list the members exposed by JsonConverterAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonConverterAttribute Constructor | Initializes a new instance of the JsonConverterAttribute class.
Top
Public Properties
 | Name | Description
Public Property | ConverterType | Gets the type of the converter.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConverterAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonConverterAttribute Constructor

JsonConverterAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : JsonConverterAttribute Constructor
Type of the converter.
Initializes a new instance of the JsonConverterAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal converterType As System.Type _
)
'Usage

Dim converterType As System.Type

Dim instance As New JsonConverterAttribute(converterType)
public JsonConverterAttribute(
   System.Type converterType
)
public JsonConverterAttribute(
    converterType: System.Type
);
public function JsonConverterAttribute(
   converterType : System.Type
);
public: JsonConverterAttribute(
   System.Type* converterType
)
public:
JsonConverterAttribute(
   System.Type^ converterType
)

Parameters

converterType
Type of the converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


JsonConverterAttribute Class Properties

JsonConverterAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonConverterAttribute Class

For a list of all members of this type, see JsonConverterAttribute members.

Public Properties
 | Name | Description
Public Property | ConverterType | Gets the type of the converter.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConverterAttribute Class
Noemax.Newtonsoft.Json Namespace


ConverterType Property (JsonConverterAttribute)

ConverterType Property (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : ConverterType Property
Gets the type of the converter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ConverterType As System.Type
'Usage

Dim instance As JsonConverterAttribute
Dim value As System.Type

value = instance.ConverterType
public System.Type ConverterType {get;}
public read-only property ConverterType: System.Type;
public function get ConverterType : System.Type
public: __property System.Type* get_ConverterType();
public:
property System.Type^ ConverterType {
   System.Type^ get();
}

Property Value

The type of the converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


JsonConverterCollection Class

JsonConverterCollection Class
Members

Noemax.Newtonsoft.Json Namespace : JsonConverterCollection Class
Represents a collection of JsonConverter.
Object Model
JsonConverterCollection Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonConverterCollection
   Inherits System.Collections.ObjectModel.Collection(Of JsonConverter)
'Usage

Dim instance As JsonConverterCollection
public class JsonConverterCollection : System.Collections.ObjectModel.Collection<JsonConverter>
public class JsonConverterCollection = class(System.Collections.ObjectModel.Collection)
public class JsonConverterCollection extends System.Collections.ObjectModel.Collection
public __gc class JsonConverterCollection : public System.Collections.ObjectModel.Collection<JsonConverter>
public ref class JsonConverterCollection : public System.Collections.ObjectModel.Collection<JsonConverter>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Noemax.Newtonsoft.Json.JsonConverterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Members
Noemax.Newtonsoft.Json Namespace


JsonConverterCollection Class Members

JsonConverterCollection Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConverterCollection Class

The following tables list the members exposed by JsonConverterCollection.

Public Constructors
 | Name | Description
Public Constructor | JsonConverterCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
Protected Properties
 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
Protected Methods
 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
See Also

Reference

JsonConverterCollection Class
Noemax.Newtonsoft.Json Namespace


JsonConverterCollection Constructor

JsonConverterCollection Constructor

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : JsonConverterCollection Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonConverterCollection()
public JsonConverterCollection()
public JsonConverterCollection();
public function JsonConverterCollection();
public: JsonConverterCollection();
public:
JsonConverterCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


JsonDictionaryAttribute Class

JsonDictionaryAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonDictionaryAttribute Class
Instructs the JsonSerializer how to serialize the collection.
Object Model
JsonDictionaryAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Interface,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonDictionaryAttribute
   Inherits JsonContainerAttribute
'Usage

Dim instance As JsonDictionaryAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonDictionaryAttribute : JsonContainerAttribute
public class JsonDictionaryAttribute = class(JsonContainerAttribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=,
   Inherited=)
public sealed class JsonDictionaryAttribute extends JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonDictionaryAttribute : public JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonDictionaryAttribute sealed : public JsonContainerAttribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonDictionaryAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonDictionaryAttribute Class Members

JsonDictionaryAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonDictionaryAttribute Class

The following tables list the members exposed by JsonDictionaryAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonDictionaryAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonDictionaryAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonDictionaryAttribute Constructor

JsonDictionaryAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : JsonDictionaryAttribute Constructor
Overload List
Overload | Description
JsonDictionaryAttribute Constructor() | Initializes a new instance of the JsonDictionaryAttribute class.
JsonDictionaryAttribute Constructor(String) | Initializes a new instance of the JsonDictionaryAttribute class with the specified container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


JsonDictionaryAttribute Constructor()

JsonDictionaryAttribute Constructor()

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class > JsonDictionaryAttribute Constructor : JsonDictionaryAttribute Constructor()
Initializes a new instance of the JsonDictionaryAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonDictionaryAttribute()
public JsonDictionaryAttribute()
public JsonDictionaryAttribute();
public function JsonDictionaryAttribute();
public: JsonDictionaryAttribute();
public:
JsonDictionaryAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members
Overload List


JsonDictionaryAttribute Constructor(String)

JsonDictionaryAttribute Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class > JsonDictionaryAttribute Constructor : JsonDictionaryAttribute Constructor(String)
The container Id.
Initializes a new instance of the JsonDictionaryAttribute class with the specified container Id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal id As System.String _
)
'Usage

Dim id As System.String

Dim instance As New JsonDictionaryAttribute(id)
public JsonDictionaryAttribute(
   System.string id
)
public JsonDictionaryAttribute(
    id: System.String
);
public function JsonDictionaryAttribute(
   id : System.String
);
public: JsonDictionaryAttribute(
   System.string* id
)
public:
JsonDictionaryAttribute(
   System.String^ id
)

Parameters

id
The container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members
Overload List


JsonException Class

JsonException Class
Members

Noemax.Newtonsoft.Json Namespace : JsonException Class
The exception thrown when an error occurs during Json serialization or deserialization.
Object Model
JsonException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.SerializableAttribute()>
Public Class JsonException
   Inherits System.Exception
'Usage

Dim instance As JsonException
[System.Serializable()]
public class JsonException : System.Exception
public class JsonException = class(System.Exception)
System.SerializableAttribute()
public class JsonException extends System.Exception
[System.Serializable()]
public __gc class JsonException : public System.Exception
[System.Serializable()]
public ref class JsonException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonReaderException
Noemax.Newtonsoft.Json.JsonSerializationException
Noemax.Newtonsoft.Json.JsonWriterException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Members
Noemax.Newtonsoft.Json Namespace


JsonException Class Members

JsonException Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonException Class

The following tables list the members exposed by JsonException.

Public Constructors
 | Name | Description
Public Constructor | JsonException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonException Class
Noemax.Newtonsoft.Json Namespace


JsonException Constructor

JsonException Constructor

Noemax.Newtonsoft.Json Namespace > JsonException Class : JsonException Constructor
Overload List
Overload | Description
JsonException Constructor() | Initializes a new instance of the JsonException class.
JsonException Constructor(String) | Initializes a new instance of the JsonException class with a specified error message.
JsonException Constructor(String,Exception) | Initializes a new instance of the JsonException class with a specified error message and a reference to the inner exception that is the cause of this exception.
JsonException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the JsonException class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


JsonException Constructor()

JsonException Constructor()

Noemax.Newtonsoft.Json Namespace > JsonException Class > JsonException Constructor : JsonException Constructor()
Initializes a new instance of the JsonException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonException()
public JsonException()
public JsonException();
public function JsonException();
public: JsonException();
public:
JsonException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members
Overload List


JsonException Constructor(String)

JsonException Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonException Class > JsonException Constructor : JsonException Constructor(String)
The error message that explains the reason for the exception.
Initializes a new instance of the JsonException class with a specified error message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New JsonException(message)
public JsonException(
   System.string message
)
public JsonException(
    message: System.String
);
public function JsonException(
   message : System.String
);
public: JsonException(
   System.string* message
)
public:
JsonException(
   System.String^ message
)

Parameters

message
The error message that explains the reason for the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members
Overload List


JsonException Constructor(String,Exception)

JsonException Constructor(String,Exception)

Noemax.Newtonsoft.Json Namespace > JsonException Class > JsonException Constructor : JsonException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Initializes a new instance of the JsonException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
'Usage

Dim message As System.String
Dim innerException As System.Exception

Dim instance As New JsonException(message, innerException)
public JsonException(
   System.string message,
   System.Exception innerException
)
public JsonException(
    message: System.String;
    innerException: System.Exception
);
public function JsonException(
   message : System.String,
   innerException : System.Exception
);
public: JsonException(
   System.string* message,
   System.Exception* innerException
)
public:
JsonException(
   System.String^ message,
   System.Exception^ innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members
Overload List


JsonException Constructor(SerializationInfo,StreamingContext)

JsonException Constructor(SerializationInfo,StreamingContext)

Noemax.Newtonsoft.Json Namespace > JsonException Class > JsonException Constructor : JsonException Constructor(SerializationInfo,StreamingContext)
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Initializes a new instance of the JsonException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New JsonException(info, context)
public JsonException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public JsonException(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
public function JsonException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
public: JsonException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
public:
JsonException(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Description
System.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization.SerializationException | The class name is null or System.Exception.HResult is zero (0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members
Overload List


JsonExtensionDataAttribute Class

JsonExtensionDataAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonExtensionDataAttribute Class
Instructs the JsonSerializer to deserialize properties with no matching class member into the specified collection and write values during serialization.
Object Model
JsonExtensionDataAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property Or  _
    AttributeTargets.Field,
   AllowMultiple=False,
   Inherited=True)>
Public Class JsonExtensionDataAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonExtensionDataAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public class JsonExtensionDataAttribute : System.Attribute
public class JsonExtensionDataAttribute = class(System.Attribute)
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=,
   Inherited=)
public class JsonExtensionDataAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public __gc class JsonExtensionDataAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonExtensionDataAttribute : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonExtensionDataAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonExtensionDataAttribute Class Members

JsonExtensionDataAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonExtensionDataAttribute Class

The following tables list the members exposed by JsonExtensionDataAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonExtensionDataAttribute Constructor | Initializes a new instance of the JsonExtensionDataAttribute class.
Top
Public Properties
 | Name | Description
Public Property | ReadData | Gets or sets a value that indicates whether to read extension data when deserializing the object.
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | WriteData | Gets or sets a value that indicates whether to write extension data when serializing the object.
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonExtensionDataAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonExtensionDataAttribute Constructor

JsonExtensionDataAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : JsonExtensionDataAttribute Constructor
Initializes a new instance of the JsonExtensionDataAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonExtensionDataAttribute()
public JsonExtensionDataAttribute()
public JsonExtensionDataAttribute();
public function JsonExtensionDataAttribute();
public: JsonExtensionDataAttribute();
public:
JsonExtensionDataAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


JsonExtensionDataAttribute Class Properties

JsonExtensionDataAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonExtensionDataAttribute Class

For a list of all members of this type, see JsonExtensionDataAttribute members.

Public Properties
 | Name | Description
Public Property | ReadData | Gets or sets a value that indicates whether to read extension data when deserializing the object.
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | WriteData | Gets or sets a value that indicates whether to write extension data when serializing the object.
Top
See Also

Reference

JsonExtensionDataAttribute Class
Noemax.Newtonsoft.Json Namespace


ReadData Property (JsonExtensionDataAttribute)

ReadData Property (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : ReadData Property
Gets or sets a value that indicates whether to read extension data when deserializing the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReadData As System.Boolean
'Usage

Dim instance As JsonExtensionDataAttribute
Dim value As System.Boolean

instance.ReadData = value

value = instance.ReadData
public System.bool ReadData {get; set;}
public read-write property ReadData: System.Boolean;
public function get,set ReadData : System.boolean
public: __property System.bool get_ReadData();
public: __property void set_ReadData(
   System.bool value
);
public:
property System.bool ReadData {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to read extension data when deserializing the object; otherwise, false. The default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


WriteData Property (JsonExtensionDataAttribute)

WriteData Property (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : WriteData Property
Gets or sets a value that indicates whether to write extension data when serializing the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WriteData As System.Boolean
'Usage

Dim instance As JsonExtensionDataAttribute
Dim value As System.Boolean

instance.WriteData = value

value = instance.WriteData
public System.bool WriteData {get; set;}
public read-write property WriteData: System.Boolean;
public function get,set WriteData : System.boolean
public: __property System.bool get_WriteData();
public: __property void set_WriteData(
   System.bool value
);
public:
property System.bool WriteData {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to write extension data when serializing the object; otherwise, false. The default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


JsonIgnoreAttribute Class

JsonIgnoreAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonIgnoreAttribute Class
Instructs the JsonSerializer not to serialize the public field or public read/write property value.
Object Model
JsonIgnoreAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property Or  _
    AttributeTargets.Field,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonIgnoreAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonIgnoreAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonIgnoreAttribute : System.Attribute
public class JsonIgnoreAttribute = class(System.Attribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=,
   Inherited=)
public sealed class JsonIgnoreAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonIgnoreAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonIgnoreAttribute sealed : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonIgnoreAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonIgnoreAttribute Class Members

JsonIgnoreAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonIgnoreAttribute Class

The following tables list the members exposed by JsonIgnoreAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonIgnoreAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonIgnoreAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonIgnoreAttribute Constructor

JsonIgnoreAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : JsonIgnoreAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonIgnoreAttribute()
public JsonIgnoreAttribute()
public JsonIgnoreAttribute();
public function JsonIgnoreAttribute();
public: JsonIgnoreAttribute();
public:
JsonIgnoreAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


JsonObjectAttribute Class

JsonObjectAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonObjectAttribute Class
Instructs the JsonSerializer how to serialize the object.
Object Model
JsonObjectAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Interface,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonObjectAttribute
   Inherits JsonContainerAttribute
'Usage

Dim instance As JsonObjectAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonObjectAttribute : JsonContainerAttribute
public class JsonObjectAttribute = class(JsonContainerAttribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Interface,
   AllowMultiple=,
   Inherited=)
public sealed class JsonObjectAttribute extends JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonObjectAttribute : public JsonContainerAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonObjectAttribute sealed : public JsonContainerAttribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonObjectAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonObjectAttribute Class Members

JsonObjectAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonObjectAttribute Class

The following tables list the members exposed by JsonObjectAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonObjectAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemRequired | Gets or sets a value that indicates whether the object's properties are required.
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | MemberSerialization | Gets or sets the member serialization.
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonObjectAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonObjectAttribute Constructor

JsonObjectAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : JsonObjectAttribute Constructor
Overload List
Overload | Description
JsonObjectAttribute Constructor() | Initializes a new instance of the JsonObjectAttribute class.
JsonObjectAttribute Constructor(MemberSerialization) | Initializes a new instance of the JsonObjectAttribute class with the specified member serialization.
JsonObjectAttribute Constructor(String) | Initializes a new instance of the JsonObjectAttribute class with the specified container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


JsonObjectAttribute Constructor()

JsonObjectAttribute Constructor()

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class > JsonObjectAttribute Constructor : JsonObjectAttribute Constructor()
Initializes a new instance of the JsonObjectAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonObjectAttribute()
public JsonObjectAttribute()
public JsonObjectAttribute();
public function JsonObjectAttribute();
public: JsonObjectAttribute();
public:
JsonObjectAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members
Overload List


JsonObjectAttribute Constructor(MemberSerialization)

JsonObjectAttribute Constructor(MemberSerialization)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class > JsonObjectAttribute Constructor : JsonObjectAttribute Constructor(MemberSerialization)
The member serialization.
Initializes a new instance of the JsonObjectAttribute class with the specified member serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal memberSerialization As MemberSerialization _
)
'Usage

Dim memberSerialization As MemberSerialization

Dim instance As New JsonObjectAttribute(memberSerialization)
public JsonObjectAttribute(
   MemberSerialization memberSerialization
)
public JsonObjectAttribute(
    memberSerialization: MemberSerialization
);
public function JsonObjectAttribute(
   memberSerialization : MemberSerialization
);
public: JsonObjectAttribute(
   MemberSerialization memberSerialization
)
public:
JsonObjectAttribute(
   MemberSerialization memberSerialization
)

Parameters

memberSerialization
The member serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members
Overload List


JsonObjectAttribute Constructor(String)

JsonObjectAttribute Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class > JsonObjectAttribute Constructor : JsonObjectAttribute Constructor(String)
The container Id.
Initializes a new instance of the JsonObjectAttribute class with the specified container Id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal id As System.String _
)
'Usage

Dim id As System.String

Dim instance As New JsonObjectAttribute(id)
public JsonObjectAttribute(
   System.string id
)
public JsonObjectAttribute(
    id: System.String
);
public function JsonObjectAttribute(
   id : System.String
);
public: JsonObjectAttribute(
   System.string* id
)
public:
JsonObjectAttribute(
   System.String^ id
)

Parameters

id
The container Id.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members
Overload List


JsonObjectAttribute Class Properties

JsonObjectAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonObjectAttribute Class

For a list of all members of this type, see JsonObjectAttribute members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemRequired | Gets or sets a value that indicates whether the object's properties are required.
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | MemberSerialization | Gets or sets the member serialization.
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonObjectAttribute Class
Noemax.Newtonsoft.Json Namespace


ItemRequired Property (JsonObjectAttribute)

ItemRequired Property (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : ItemRequired Property
Gets or sets a value that indicates whether the object's properties are required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemRequired As Required
'Usage

Dim instance As JsonObjectAttribute
Dim value As Required

instance.ItemRequired = value

value = instance.ItemRequired
public Required ItemRequired {get; set;}
public read-write property ItemRequired: Required;
public function get,set ItemRequired : Required
public: __property Required get_ItemRequired();
public: __property void set_ItemRequired(
   Required value
);
public:
property Required ItemRequired {
   Required get();
   void set (    Required value);
}

Property Value

A value indicating whether the object's properties are required.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


MemberSerialization Property (JsonObjectAttribute)

MemberSerialization Property (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : MemberSerialization Property
Gets or sets the member serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MemberSerialization As MemberSerialization
'Usage

Dim instance As JsonObjectAttribute
Dim value As MemberSerialization

instance.MemberSerialization = value

value = instance.MemberSerialization
public MemberSerialization MemberSerialization {get; set;}
public read-write property MemberSerialization: MemberSerialization;
public function get,set MemberSerialization : MemberSerialization
public: __property MemberSerialization get_MemberSerialization();
public: __property void set_MemberSerialization(
   MemberSerialization value
);
public:
property MemberSerialization MemberSerialization {
   MemberSerialization get();
   void set (    MemberSerialization value);
}

Property Value

The member serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


JsonPropertyAttribute Class

JsonPropertyAttribute Class
Members

Noemax.Newtonsoft.Json Namespace : JsonPropertyAttribute Class
Instructs the JsonSerializer to always serialize the member with the specified name.
Object Model
JsonPropertyAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property Or  _
    AttributeTargets.Field Or  _
    AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public NotInheritable Class JsonPropertyAttribute
   Inherits System.Attribute
'Usage

Dim instance As JsonPropertyAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public sealed class JsonPropertyAttribute : System.Attribute
public class JsonPropertyAttribute = class(System.Attribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Parameter,
   AllowMultiple=,
   Inherited=)
public sealed class JsonPropertyAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public __gc __sealed class JsonPropertyAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Property |
    AttributeTargets.Field |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public ref class JsonPropertyAttribute sealed : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.JsonPropertyAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Members
Noemax.Newtonsoft.Json Namespace


JsonPropertyAttribute Class Members

JsonPropertyAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonPropertyAttribute Class

The following tables list the members exposed by JsonPropertyAttribute.

Public Constructors
 | Name | Description
Public Constructor | JsonPropertyAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DefaultValueHandling | Gets or sets the default value handling used when serializing this property.
Public Property | IsReference | Gets or sets whether this property's value is serialized as a reference.
Public Property | ItemConverterType | Gets or sets the converter used when serializing the property's collection items.
Public Property | ItemIsReference | Gets or sets whether this property's collection items are serialized as a reference.
Public Property | ItemReferenceLoopHandling | Gets or sets the the reference loop handling used when serializing the property's collection items.
Public Property | ItemTypeNameHandling | Gets or sets the the type name handling used when serializing the property's collection items.
Public Property | NullValueHandling | Gets or sets the null value handling used when serializing this property.
Public Property | ObjectCreationHandling | Gets or sets the object creation handling used when deserializing this property.
Public Property | Order | Gets or sets the order of serialization and deserialization of a member.
Public Property | PropertyName | Gets or sets the name of the property.
Public Property | ReferenceLoopHandling | Gets or sets the reference loop handling used when serializing this property.
Public Property | Required | Gets or sets a value indicating whether this property is required.
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | TypeNameHandling | Gets or sets the type name handling used when serializing this property.
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonPropertyAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonPropertyAttribute Constructor

JsonPropertyAttribute Constructor

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : JsonPropertyAttribute Constructor
Overload List
Overload | Description
JsonPropertyAttribute Constructor() | Initializes a new instance of the JsonPropertyAttribute class.
JsonPropertyAttribute Constructor(String) | Initializes a new instance of the JsonPropertyAttribute class with the specified name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


JsonPropertyAttribute Constructor()

JsonPropertyAttribute Constructor()

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class > JsonPropertyAttribute Constructor : JsonPropertyAttribute Constructor()
Initializes a new instance of the JsonPropertyAttribute class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonPropertyAttribute()
public JsonPropertyAttribute()
public JsonPropertyAttribute();
public function JsonPropertyAttribute();
public: JsonPropertyAttribute();
public:
JsonPropertyAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members
Overload List


JsonPropertyAttribute Constructor(String)

JsonPropertyAttribute Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class > JsonPropertyAttribute Constructor : JsonPropertyAttribute Constructor(String)
Name of the property.
Initializes a new instance of the JsonPropertyAttribute class with the specified name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal propertyName As System.String _
)
'Usage

Dim propertyName As System.String

Dim instance As New JsonPropertyAttribute(propertyName)
public JsonPropertyAttribute(
   System.string propertyName
)
public JsonPropertyAttribute(
    propertyName: System.String
);
public function JsonPropertyAttribute(
   propertyName : System.String
);
public: JsonPropertyAttribute(
   System.string* propertyName
)
public:
JsonPropertyAttribute(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members
Overload List


JsonPropertyAttribute Class Properties

JsonPropertyAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonPropertyAttribute Class

For a list of all members of this type, see JsonPropertyAttribute members.

Public Properties
 | Name | Description
Public Property | DefaultValueHandling | Gets or sets the default value handling used when serializing this property.
Public Property | IsReference | Gets or sets whether this property's value is serialized as a reference.
Public Property | ItemConverterType | Gets or sets the converter used when serializing the property's collection items.
Public Property | ItemIsReference | Gets or sets whether this property's collection items are serialized as a reference.
Public Property | ItemReferenceLoopHandling | Gets or sets the the reference loop handling used when serializing the property's collection items.
Public Property | ItemTypeNameHandling | Gets or sets the the type name handling used when serializing the property's collection items.
Public Property | NullValueHandling | Gets or sets the null value handling used when serializing this property.
Public Property | ObjectCreationHandling | Gets or sets the object creation handling used when deserializing this property.
Public Property | Order | Gets or sets the order of serialization and deserialization of a member.
Public Property | PropertyName | Gets or sets the name of the property.
Public Property | ReferenceLoopHandling | Gets or sets the reference loop handling used when serializing this property.
Public Property | Required | Gets or sets a value indicating whether this property is required.
Public Property | TypeId | (Inherited from System.Attribute)
Public Property | TypeNameHandling | Gets or sets the type name handling used when serializing this property.
Top
See Also

Reference

JsonPropertyAttribute Class
Noemax.Newtonsoft.Json Namespace


DefaultValueHandling Property (JsonPropertyAttribute)

DefaultValueHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : DefaultValueHandling Property
Gets or sets the default value handling used when serializing this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValueHandling As DefaultValueHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As DefaultValueHandling

instance.DefaultValueHandling = value

value = instance.DefaultValueHandling
public DefaultValueHandling DefaultValueHandling {get; set;}
public read-write property DefaultValueHandling: DefaultValueHandling;
public function get,set DefaultValueHandling : DefaultValueHandling
public: __property DefaultValueHandling get_DefaultValueHandling();
public: __property void set_DefaultValueHandling(
   DefaultValueHandling value
);
public:
property DefaultValueHandling DefaultValueHandling {
   DefaultValueHandling get();
   void set (    DefaultValueHandling value);
}

Property Value

The default value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


IsReference Property (JsonPropertyAttribute)

IsReference Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : IsReference Property
Gets or sets whether this property's value is serialized as a reference.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsReference As System.Boolean
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Boolean

instance.IsReference = value

value = instance.IsReference
public System.bool IsReference {get; set;}
public read-write property IsReference: System.Boolean;
public function get,set IsReference : System.boolean
public: __property System.bool get_IsReference();
public: __property void set_IsReference(
   System.bool value
);
public:
property System.bool IsReference {
   System.bool get();
   void set (    System.bool value);
}

Property Value

Whether this property's value is serialized as a reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ItemConverterType Property (JsonPropertyAttribute)

ItemConverterType Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ItemConverterType Property
Gets or sets the converter used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemConverterType As System.Type
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Type

instance.ItemConverterType = value

value = instance.ItemConverterType
public System.Type ItemConverterType {get; set;}
public read-write property ItemConverterType: System.Type;
public function get,set ItemConverterType : System.Type
public: __property System.Type* get_ItemConverterType();
public: __property void set_ItemConverterType(
   System.Type* value
);
public:
property System.Type^ ItemConverterType {
   System.Type^ get();
   void set (    System.Type^ value);
}

Property Value

The collection's items converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ItemIsReference Property (JsonPropertyAttribute)

ItemIsReference Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ItemIsReference Property
Gets or sets whether this property's collection items are serialized as a reference.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemIsReference As System.Boolean
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Boolean

instance.ItemIsReference = value

value = instance.ItemIsReference
public System.bool ItemIsReference {get; set;}
public read-write property ItemIsReference: System.Boolean;
public function get,set ItemIsReference : System.boolean
public: __property System.bool get_ItemIsReference();
public: __property void set_ItemIsReference(
   System.bool value
);
public:
property System.bool ItemIsReference {
   System.bool get();
   void set (    System.bool value);
}

Property Value

Whether this property's collection items are serialized as a reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ItemReferenceLoopHandling Property (JsonPropertyAttribute)

ItemReferenceLoopHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ItemReferenceLoopHandling Property
Gets or sets the the reference loop handling used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemReferenceLoopHandling As ReferenceLoopHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As ReferenceLoopHandling

instance.ItemReferenceLoopHandling = value

value = instance.ItemReferenceLoopHandling
public ReferenceLoopHandling ItemReferenceLoopHandling {get; set;}
public read-write property ItemReferenceLoopHandling: ReferenceLoopHandling;
public function get,set ItemReferenceLoopHandling : ReferenceLoopHandling
public: __property ReferenceLoopHandling get_ItemReferenceLoopHandling();
public: __property void set_ItemReferenceLoopHandling(
   ReferenceLoopHandling value
);
public:
property ReferenceLoopHandling ItemReferenceLoopHandling {
   ReferenceLoopHandling get();
   void set (    ReferenceLoopHandling value);
}

Property Value

The collection's items reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ItemTypeNameHandling Property (JsonPropertyAttribute)

ItemTypeNameHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ItemTypeNameHandling Property
Gets or sets the the type name handling used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemTypeNameHandling As TypeNameHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As TypeNameHandling

instance.ItemTypeNameHandling = value

value = instance.ItemTypeNameHandling
public TypeNameHandling ItemTypeNameHandling {get; set;}
public read-write property ItemTypeNameHandling: TypeNameHandling;
public function get,set ItemTypeNameHandling : TypeNameHandling
public: __property TypeNameHandling get_ItemTypeNameHandling();
public: __property void set_ItemTypeNameHandling(
   TypeNameHandling value
);
public:
property TypeNameHandling ItemTypeNameHandling {
   TypeNameHandling get();
   void set (    TypeNameHandling value);
}

Property Value

The collection's items type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


NullValueHandling Property (JsonPropertyAttribute)

NullValueHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : NullValueHandling Property
Gets or sets the null value handling used when serializing this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NullValueHandling As NullValueHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As NullValueHandling

instance.NullValueHandling = value

value = instance.NullValueHandling
public NullValueHandling NullValueHandling {get; set;}
public read-write property NullValueHandling: NullValueHandling;
public function get,set NullValueHandling : NullValueHandling
public: __property NullValueHandling get_NullValueHandling();
public: __property void set_NullValueHandling(
   NullValueHandling value
);
public:
property NullValueHandling NullValueHandling {
   NullValueHandling get();
   void set (    NullValueHandling value);
}

Property Value

The null value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ObjectCreationHandling Property (JsonPropertyAttribute)

ObjectCreationHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ObjectCreationHandling Property
Gets or sets the object creation handling used when deserializing this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectCreationHandling As ObjectCreationHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As ObjectCreationHandling

instance.ObjectCreationHandling = value

value = instance.ObjectCreationHandling
public ObjectCreationHandling ObjectCreationHandling {get; set;}
public read-write property ObjectCreationHandling: ObjectCreationHandling;
public function get,set ObjectCreationHandling : ObjectCreationHandling
public: __property ObjectCreationHandling get_ObjectCreationHandling();
public: __property void set_ObjectCreationHandling(
   ObjectCreationHandling value
);
public:
property ObjectCreationHandling ObjectCreationHandling {
   ObjectCreationHandling get();
   void set (    ObjectCreationHandling value);
}

Property Value

The object creation handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


Order Property (JsonPropertyAttribute)

Order Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : Order Property
Gets or sets the order of serialization and deserialization of a member.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Order As System.Integer
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Integer

instance.Order = value

value = instance.Order
public System.int Order {get; set;}
public read-write property Order: System.Integer;
public function get,set Order : System.int
public: __property System.int get_Order();
public: __property void set_Order(
   System.int value
);
public:
property System.int Order {
   System.int get();
   void set (    System.int value);
}

Property Value

The numeric order of serialization or deserialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


PropertyName Property (JsonPropertyAttribute)

PropertyName Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : PropertyName Property
Gets or sets the name of the property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PropertyName As System.String
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.String

instance.PropertyName = value

value = instance.PropertyName
public System.string PropertyName {get; set;}
public read-write property PropertyName: System.String;
public function get,set PropertyName : System.String
public: __property System.string* get_PropertyName();
public: __property void set_PropertyName(
   System.string* value
);
public:
property System.String^ PropertyName {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


ReferenceLoopHandling Property (JsonPropertyAttribute)

ReferenceLoopHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : ReferenceLoopHandling Property
Gets or sets the reference loop handling used when serializing this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceLoopHandling As ReferenceLoopHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As ReferenceLoopHandling

instance.ReferenceLoopHandling = value

value = instance.ReferenceLoopHandling
public ReferenceLoopHandling ReferenceLoopHandling {get; set;}
public read-write property ReferenceLoopHandling: ReferenceLoopHandling;
public function get,set ReferenceLoopHandling : ReferenceLoopHandling
public: __property ReferenceLoopHandling get_ReferenceLoopHandling();
public: __property void set_ReferenceLoopHandling(
   ReferenceLoopHandling value
);
public:
property ReferenceLoopHandling ReferenceLoopHandling {
   ReferenceLoopHandling get();
   void set (    ReferenceLoopHandling value);
}

Property Value

The reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


Required Property (JsonPropertyAttribute)

Required Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : Required Property
Gets or sets a value indicating whether this property is required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As Required
'Usage

Dim instance As JsonPropertyAttribute
Dim value As Required

instance.Required = value

value = instance.Required
public Required Required {get; set;}
public read-write property Required: Required;
public function get,set Required : Required
public: __property Required get_Required();
public: __property void set_Required(
   Required value
);
public:
property Required Required {
   Required get();
   void set (    Required value);
}

Property Value

A value indicating whether this property is required.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


TypeNameHandling Property (JsonPropertyAttribute)

TypeNameHandling Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : TypeNameHandling Property
Gets or sets the type name handling used when serializing this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TypeNameHandling As TypeNameHandling
'Usage

Dim instance As JsonPropertyAttribute
Dim value As TypeNameHandling

instance.TypeNameHandling = value

value = instance.TypeNameHandling
public TypeNameHandling TypeNameHandling {get; set;}
public read-write property TypeNameHandling: TypeNameHandling;
public function get,set TypeNameHandling : TypeNameHandling
public: __property TypeNameHandling get_TypeNameHandling();
public: __property void set_TypeNameHandling(
   TypeNameHandling value
);
public:
property TypeNameHandling TypeNameHandling {
   TypeNameHandling get();
   void set (    TypeNameHandling value);
}

Property Value

The type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


JsonReader Class

JsonReader Class
Members

Noemax.Newtonsoft.Json Namespace : JsonReader Class
Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Object Model
JsonReader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class JsonReader
'Usage

Dim instance As JsonReader
public abstract class JsonReader
public class JsonReader abstract;
public abstract class JsonReader
public __gc abstract class JsonReader
public ref class JsonReader abstract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader
Noemax.Newtonsoft.Json.JsonTextReader
Noemax.Newtonsoft.Json.JsonValidatingReader
Noemax.Newtonsoft.Json.Linq.JTokenReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Members
Noemax.Newtonsoft.Json Namespace


JsonReader Class Members

JsonReader Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonReader Class

The following tables list the members exposed by JsonReader.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON.
Public Property | Depth | Gets the depth of the current token in the JSON document.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | Path | Gets the path of the current JSON token.
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring.
Public Property | TokenType | Gets the type of the current JSON token.
Public Property | Value | Gets the text value of the current JSON token.
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token.
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state.
Top
Public Methods
 | Name | Description
Public Method | Close | Changes the JsonReader.State to Closed.
Public Method | Read | Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token.
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type.
Protected Method | SetToken | Overloaded. Sets the current token.
Top
See Also

Reference

JsonReader Class
Noemax.Newtonsoft.Json Namespace


JsonReader Class Methods

JsonReader Class Methods

Noemax.Newtonsoft.Json Namespace : JsonReader Class

For a list of all members of this type, see JsonReader members.

Public Methods
 | Name | Description
Public Method | Close | Changes the JsonReader.State to Closed.
Public Method | Read | Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token.
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type.
Protected Method | SetToken | Overloaded. Sets the current token.
Top
See Also

Reference

JsonReader Class
Noemax.Newtonsoft.Json Namespace


Close Method (JsonReader)

Close Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Close Method
Changes the JsonReader.State to Closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Close()
'Usage

Dim instance As JsonReader

instance.Close()
public virtual void Close()
public procedure Close(); virtual;
public function Close();
public: virtual void Close();
public:
virtual void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Dispose Method (JsonReader)

Dispose Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Dispose Method
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases unmanaged and - optionally - managed resources
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub Dispose( _
   ByVal disposing As System.Boolean _
)
'Usage

Dim instance As JsonReader
Dim disposing As System.Boolean

instance.Dispose(disposing)
protected virtual void Dispose(
   System.bool disposing
)
protected procedure Dispose(
    disposing: System.Boolean
); virtual;
protected function Dispose(
   disposing : System.boolean
);
protected: virtual void Dispose(
   System.bool disposing
)
protected:
virtual void Dispose(
   System.bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Read Method (JsonReader)

Read Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Read Method
Reads the next JSON token from the stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Read() As System.Boolean
'Usage

Dim instance As JsonReader
Dim value As System.Boolean

value = instance.Read()
public abstract System.bool Read()
public function Read(): System.Boolean; abstract;
public __abstract function Read() : System.boolean;
public: abstract System.bool Read();
public:
abstract System.bool Read();

Return Value

true if the next token was read successfully; false if there are no more tokens to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsBytes Method (JsonReader)

ReadAsBytes Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsBytes Method
Reads the next JSON token from the stream as a Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsBytes() As System.Byte()
'Usage

Dim instance As JsonReader
Dim value() As System.Byte

value = instance.ReadAsBytes()
public abstract System.byte[] ReadAsBytes()
public function ReadAsBytes(): System.array of Byte; abstract;
public __abstract function ReadAsBytes() : System.byte[];
public: abstract System.byte[]* ReadAsBytes();
public:
abstract System.array<byte>^ ReadAsBytes();

Return Value

A Byte[] or a null reference if the next JSON token is null. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsDateTime Method (JsonReader)

ReadAsDateTime Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsDateTime Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsDateTime() As System.Nullable(Of Date)
'Usage

Dim instance As JsonReader
Dim value As System.Nullable(Of Date)

value = instance.ReadAsDateTime()
public abstract System.Nullable<DateTime> ReadAsDateTime()
public function ReadAsDateTime(): System.Nullable; abstract;
public __abstract function ReadAsDateTime() : System.Nullable;
public: abstract System.Nullable<DateTime> ReadAsDateTime();
public:
abstract System.Nullable<DateTime> ReadAsDateTime();

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsDateTimeOffset Method (JsonReader)

ReadAsDateTimeOffset Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsDateTimeOffset Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsDateTimeOffset() As System.Nullable(Of DateTimeOffset)
'Usage

Dim instance As JsonReader
Dim value As System.Nullable(Of DateTimeOffset)

value = instance.ReadAsDateTimeOffset()
public abstract System.Nullable<DateTimeOffset> ReadAsDateTimeOffset()
public function ReadAsDateTimeOffset(): System.Nullable; abstract;
public __abstract function ReadAsDateTimeOffset() : System.Nullable;
public: abstract System.Nullable<DateTimeOffset> ReadAsDateTimeOffset();
public:
abstract System.Nullable<DateTimeOffset> ReadAsDateTimeOffset();

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsDecimal Method (JsonReader)

ReadAsDecimal Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsDecimal Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsDecimal() As System.Nullable(Of Decimal)
'Usage

Dim instance As JsonReader
Dim value As System.Nullable(Of Decimal)

value = instance.ReadAsDecimal()
public abstract System.Nullable<decimal> ReadAsDecimal()
public function ReadAsDecimal(): System.Nullable; abstract;
public __abstract function ReadAsDecimal() : System.Nullable;
public: abstract System.Nullable<decimal> ReadAsDecimal();
public:
abstract System.Nullable<decimal> ReadAsDecimal();

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsInt32 Method (JsonReader)

ReadAsInt32 Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsInt32 Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsInt32() As System.Nullable(Of Integer)
'Usage

Dim instance As JsonReader
Dim value As System.Nullable(Of Integer)

value = instance.ReadAsInt32()
public abstract System.Nullable<int> ReadAsInt32()
public function ReadAsInt32(): System.Nullable; abstract;
public __abstract function ReadAsInt32() : System.Nullable;
public: abstract System.Nullable<int> ReadAsInt32();
public:
abstract System.Nullable<int> ReadAsInt32();

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ReadAsString Method (JsonReader)

ReadAsString Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ReadAsString Method
Reads the next JSON token from the stream as a System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsString() As System.String
'Usage

Dim instance As JsonReader
Dim value As System.String

value = instance.ReadAsString()
public abstract System.string ReadAsString()
public function ReadAsString(): System.String; abstract;
public __abstract function ReadAsString() : System.String;
public: abstract System.string* ReadAsString();
public:
abstract System.String^ ReadAsString();

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


SetStateBasedOnCurrent Method (JsonReader)

SetStateBasedOnCurrent Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : SetStateBasedOnCurrent Method
Sets the state based on current token type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub SetStateBasedOnCurrent()
'Usage

Dim instance As JsonReader

instance.SetStateBasedOnCurrent()
protected void SetStateBasedOnCurrent()
protected procedure SetStateBasedOnCurrent();
protected function SetStateBasedOnCurrent();
protected: void SetStateBasedOnCurrent();
protected:
void SetStateBasedOnCurrent();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


SetToken Method (JsonReader)

SetToken Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : SetToken Method
Sets the current token.
Overload List
Overload | Description
SetToken(JsonToken) | Sets the current token.
SetToken(JsonToken,Object) | Sets the current token and value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


SetToken(JsonToken) Method

SetToken(JsonToken) Method

Noemax.Newtonsoft.Json Namespace > JsonReader Class > SetToken Method : SetToken(JsonToken) Method
The new token.
Sets the current token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub SetToken( _
   ByVal newToken As JsonToken _
)
'Usage

Dim instance As JsonReader
Dim newToken As JsonToken

instance.SetToken(newToken)
protected void SetToken(
   JsonToken newToken
)
protected procedure SetToken(
    newToken: JsonToken
);
protected function SetToken(
   newToken : JsonToken
);
protected: void SetToken(
   JsonToken newToken
)
protected:
void SetToken(
   JsonToken newToken
)

Parameters

newToken
The new token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members
Overload List


SetToken(JsonToken,Object) Method

SetToken(JsonToken,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonReader Class > SetToken Method : SetToken(JsonToken,Object) Method
The new token.
The value.
Sets the current token and value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Sub SetToken( _
   ByVal newToken As JsonToken, _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonReader
Dim newToken As JsonToken
Dim value As System.Object

instance.SetToken(newToken, value)
protected void SetToken(
   JsonToken newToken,
   System.object value
)
protected procedure SetToken(
    newToken: JsonToken;
    value: System.TObject
);
protected function SetToken(
   newToken : JsonToken,
   value : System.Object
);
protected: void SetToken(
   JsonToken newToken,
   System.Object* value
)
protected:
void SetToken(
   JsonToken newToken,
   System.Object^ value
)

Parameters

newToken
The new token.
value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members
Overload List


Skip Method (JsonReader)

Skip Method (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Skip Method
Skips the children of the current token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Skip()
'Usage

Dim instance As JsonReader

instance.Skip()
public void Skip()
public procedure Skip();
public function Skip();
public: void Skip();
public:
void Skip();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


JsonReader Class Properties

JsonReader Class Properties

Noemax.Newtonsoft.Json Namespace : JsonReader Class

For a list of all members of this type, see JsonReader members.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON.
Public Property | Depth | Gets the depth of the current token in the JSON document.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | Path | Gets the path of the current JSON token.
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring.
Public Property | TokenType | Gets the type of the current JSON token.
Public Property | Value | Gets the text value of the current JSON token.
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token.
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state.
Top
See Also

Reference

JsonReader Class
Noemax.Newtonsoft.Json Namespace


CloseInput Property (JsonReader)

CloseInput Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : CloseInput Property
Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CloseInput As System.Boolean
'Usage

Dim instance As JsonReader
Dim value As System.Boolean

instance.CloseInput = value

value = instance.CloseInput
public System.bool CloseInput {get; set;}
public read-write property CloseInput: System.Boolean;
public function get,set CloseInput : System.boolean
public: __property System.bool get_CloseInput();
public: __property void set_CloseInput(
   System.bool value
);
public:
property System.bool CloseInput {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to close the underlying stream or System.IO.TextReader when the reader is closed; otherwise false. The default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Culture Property (JsonReader)

Culture Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Culture Property
Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Culture As System.Globalization.CultureInfo
'Usage

Dim instance As JsonReader
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
public System.Globalization.CultureInfo Culture {get; set;}
public read-write property Culture: System.Globalization.CultureInfo;
public function get,set Culture : System.Globalization.CultureInfo
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


CurrentState Property (JsonReader)

CurrentState Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : CurrentState Property
Gets the current reader state.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected ReadOnly Property CurrentState As JsonReader.State
'Usage

Dim instance As JsonReader
Dim value As JsonReader.State

value = instance.CurrentState
protected JsonReader.State CurrentState {get;}
protected read-only property CurrentState: JsonReader.State;
protected function get CurrentState : JsonReader.State
protected: __property JsonReader.State get_CurrentState();
protected:
property JsonReader.State CurrentState {
   JsonReader.State get();
}

Property Value

The current reader state.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


DateFormatString Property (JsonReader)

DateFormatString Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : DateFormatString Property
Get or set how custom date formatted strings are parsed when reading JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateFormatString As System.String
'Usage

Dim instance As JsonReader
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
public System.string DateFormatString {get; set;}
public read-write property DateFormatString: System.String;
public function get,set DateFormatString : System.String
public: __property System.string* get_DateFormatString();
public: __property void set_DateFormatString(
   System.string* value
);
public:
property System.String^ DateFormatString {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


DateParseHandling Property (JsonReader)

DateParseHandling Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : DateParseHandling Property
Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateParseHandling As DateParseHandling
'Usage

Dim instance As JsonReader
Dim value As DateParseHandling

instance.DateParseHandling = value

value = instance.DateParseHandling
public DateParseHandling DateParseHandling {get; set;}
public read-write property DateParseHandling: DateParseHandling;
public function get,set DateParseHandling : DateParseHandling
public: __property DateParseHandling get_DateParseHandling();
public: __property void set_DateParseHandling(
   DateParseHandling value
);
public:
property DateParseHandling DateParseHandling {
   DateParseHandling get();
   void set (    DateParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


DateTimeZoneHandling Property (JsonReader)

DateTimeZoneHandling Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : DateTimeZoneHandling Property
Get or set how System.DateTime time zones are handling when reading JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeZoneHandling As DateTimeZoneHandling
'Usage

Dim instance As JsonReader
Dim value As DateTimeZoneHandling

instance.DateTimeZoneHandling = value

value = instance.DateTimeZoneHandling
public DateTimeZoneHandling DateTimeZoneHandling {get; set;}
public read-write property DateTimeZoneHandling: DateTimeZoneHandling;
public function get,set DateTimeZoneHandling : DateTimeZoneHandling
public: __property DateTimeZoneHandling get_DateTimeZoneHandling();
public: __property void set_DateTimeZoneHandling(
   DateTimeZoneHandling value
);
public:
property DateTimeZoneHandling DateTimeZoneHandling {
   DateTimeZoneHandling get();
   void set (    DateTimeZoneHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Depth Property (JsonReader)

Depth Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Depth Property
Gets the depth of the current token in the JSON document.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Depth As System.Integer
'Usage

Dim instance As JsonReader
Dim value As System.Integer

value = instance.Depth
public virtual System.int Depth {get;}
public read-only property Depth: System.Integer; virtual;
public function get Depth : System.int
public: __property virtual System.int get_Depth();
public:
virtual property System.int Depth {
   System.int get();
}

Property Value

The depth of the current token in the JSON document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


FloatParseHandling Property (JsonReader)

FloatParseHandling Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : FloatParseHandling Property
Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FloatParseHandling As FloatParseHandling
'Usage

Dim instance As JsonReader
Dim value As FloatParseHandling

instance.FloatParseHandling = value

value = instance.FloatParseHandling
public FloatParseHandling FloatParseHandling {get; set;}
public read-write property FloatParseHandling: FloatParseHandling;
public function get,set FloatParseHandling : FloatParseHandling
public: __property FloatParseHandling get_FloatParseHandling();
public: __property void set_FloatParseHandling(
   FloatParseHandling value
);
public:
property FloatParseHandling FloatParseHandling {
   FloatParseHandling get();
   void set (    FloatParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


MaxDepth Property (JsonReader)

MaxDepth Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : MaxDepth Property
Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxDepth As System.Nullable(Of Integer)
'Usage

Dim instance As JsonReader
Dim value As System.Nullable(Of Integer)

instance.MaxDepth = value

value = instance.MaxDepth
public System.Nullable<int> MaxDepth {get; set;}
public read-write property MaxDepth: System.Nullable;
public function get,set MaxDepth : System.Nullable
public: __property System.Nullable<int> get_MaxDepth();
public: __property void set_MaxDepth(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MaxDepth {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Path Property (JsonReader)

Path Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Path Property
Gets the path of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Path As System.String
'Usage

Dim instance As JsonReader
Dim value As System.String

value = instance.Path
public virtual System.string Path {get;}
public read-only property Path: System.String; virtual;
public function get Path : System.String
public: __property virtual System.string* get_Path();
public:
virtual property System.String^ Path {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


QuoteChar Property (JsonReader)

QuoteChar Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : QuoteChar Property
Gets the quotation mark character used to enclose the value of a string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property QuoteChar As System.Char
'Usage

Dim instance As JsonReader
Dim value As System.Char

value = instance.QuoteChar
public virtual System.char QuoteChar {get;}
public read-only property QuoteChar: System.Char; virtual;
public function get QuoteChar : System.char
public: __property virtual System.char get_QuoteChar();
public:
virtual property System.char QuoteChar {
   System.char get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


SupportMultipleContent Property (JsonReader)

SupportMultipleContent Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : SupportMultipleContent Property
Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SupportMultipleContent As System.Boolean
'Usage

Dim instance As JsonReader
Dim value As System.Boolean

instance.SupportMultipleContent = value

value = instance.SupportMultipleContent
public System.bool SupportMultipleContent {get; set;}
public read-write property SupportMultipleContent: System.Boolean;
public function get,set SupportMultipleContent : System.boolean
public: __property System.bool get_SupportMultipleContent();
public: __property void set_SupportMultipleContent(
   System.bool value
);
public:
property System.bool SupportMultipleContent {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to support reading multiple pieces of JSON content; otherwise false. The default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


TokenType Property (JsonReader)

TokenType Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : TokenType Property
Gets the type of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TokenType As JsonToken
'Usage

Dim instance As JsonReader
Dim value As JsonToken

value = instance.TokenType
public virtual JsonToken TokenType {get;}
public read-only property TokenType: JsonToken; virtual;
public function get TokenType : JsonToken
public: __property virtual JsonToken get_TokenType();
public:
virtual property JsonToken TokenType {
   JsonToken get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


Value Property (JsonReader)

Value Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : Value Property
Gets the text value of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Value As System.Object
'Usage

Dim instance As JsonReader
Dim value As System.Object

value = instance.Value
public virtual System.object Value {get;}
public read-only property Value: System.TObject; virtual;
public function get Value : System.Object
public: __property virtual System.Object* get_Value();
public:
virtual property System.Object^ Value {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


ValueType Property (JsonReader)

ValueType Property (JsonReader)

Noemax.Newtonsoft.Json Namespace > JsonReader Class : ValueType Property
Gets The Common Language Runtime (CLR) type for the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property ValueType As System.Type
'Usage

Dim instance As JsonReader
Dim value As System.Type

value = instance.ValueType
public virtual System.Type ValueType {get;}
public read-only property ValueType: System.Type; virtual;
public function get ValueType : System.Type
public: __property virtual System.Type* get_ValueType();
public:
virtual property System.Type^ ValueType {
   System.Type^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReader Class
JsonReader Members


JsonReaderException Class

JsonReaderException Class
Members

Noemax.Newtonsoft.Json Namespace : JsonReaderException Class
The exception thrown when an error occurs while reading Json text.
Object Model
JsonReaderException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.SerializableAttribute()>
Public Class JsonReaderException
   Inherits JsonException
'Usage

Dim instance As JsonReaderException
[System.Serializable()]
public class JsonReaderException : JsonException
public class JsonReaderException = class(JsonException)
System.SerializableAttribute()
public class JsonReaderException extends JsonException
[System.Serializable()]
public __gc class JsonReaderException : public JsonException
[System.Serializable()]
public ref class JsonReaderException : public JsonException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonReaderException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Members
Noemax.Newtonsoft.Json Namespace


JsonReaderException Class Members

JsonReaderException Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonReaderException Class

The following tables list the members exposed by JsonReaderException.

Public Constructors
 | Name | Description
Public Constructor | JsonReaderException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | LineNumber | Gets the line number indicating where the error occurred.
Public Property | LinePosition | Gets the line position indicating where the error occurred.
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonReaderException Class
Noemax.Newtonsoft.Json Namespace


JsonReaderException Constructor

JsonReaderException Constructor

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : JsonReaderException Constructor
Overload List
Overload | Description
JsonReaderException Constructor() | Initializes a new instance of the JsonReaderException class.
JsonReaderException Constructor(String) | Initializes a new instance of the JsonReaderException class with a specified error message.
JsonReaderException Constructor(String,Exception) | Initializes a new instance of the JsonReaderException class with a specified error message and a reference to the inner exception that is the cause of this exception.
JsonReaderException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the JsonReaderException class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


JsonReaderException Constructor()

JsonReaderException Constructor()

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class > JsonReaderException Constructor : JsonReaderException Constructor()
Initializes a new instance of the JsonReaderException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonReaderException()
public JsonReaderException()
public JsonReaderException();
public function JsonReaderException();
public: JsonReaderException();
public:
JsonReaderException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members
Overload List


JsonReaderException Constructor(String)

JsonReaderException Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class > JsonReaderException Constructor : JsonReaderException Constructor(String)
The error message that explains the reason for the exception.
Initializes a new instance of the JsonReaderException class with a specified error message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New JsonReaderException(message)
public JsonReaderException(
   System.string message
)
public JsonReaderException(
    message: System.String
);
public function JsonReaderException(
   message : System.String
);
public: JsonReaderException(
   System.string* message
)
public:
JsonReaderException(
   System.String^ message
)

Parameters

message
The error message that explains the reason for the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members
Overload List


JsonReaderException Constructor(String,Exception)

JsonReaderException Constructor(String,Exception)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class > JsonReaderException Constructor : JsonReaderException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Initializes a new instance of the JsonReaderException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
'Usage

Dim message As System.String
Dim innerException As System.Exception

Dim instance As New JsonReaderException(message, innerException)
public JsonReaderException(
   System.string message,
   System.Exception innerException
)
public JsonReaderException(
    message: System.String;
    innerException: System.Exception
);
public function JsonReaderException(
   message : System.String,
   innerException : System.Exception
);
public: JsonReaderException(
   System.string* message,
   System.Exception* innerException
)
public:
JsonReaderException(
   System.String^ message,
   System.Exception^ innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members
Overload List


JsonReaderException Constructor(SerializationInfo,StreamingContext)

JsonReaderException Constructor(SerializationInfo,StreamingContext)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class > JsonReaderException Constructor : JsonReaderException Constructor(SerializationInfo,StreamingContext)
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Initializes a new instance of the JsonReaderException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New JsonReaderException(info, context)
public JsonReaderException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public JsonReaderException(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
public function JsonReaderException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
public: JsonReaderException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
public:
JsonReaderException(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Description
System.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization.SerializationException | The class name is null or System.Exception.HResult is zero (0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members
Overload List


JsonReaderException Class Properties

JsonReaderException Class Properties

Noemax.Newtonsoft.Json Namespace : JsonReaderException Class

For a list of all members of this type, see JsonReaderException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | LineNumber | Gets the line number indicating where the error occurred.
Public Property | LinePosition | Gets the line position indicating where the error occurred.
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

JsonReaderException Class
Noemax.Newtonsoft.Json Namespace


LineNumber Property (JsonReaderException)

LineNumber Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : LineNumber Property
Gets the line number indicating where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LineNumber As System.Integer
'Usage

Dim instance As JsonReaderException
Dim value As System.Integer

value = instance.LineNumber
public System.int LineNumber {get;}
public read-only property LineNumber: System.Integer;
public function get LineNumber : System.int
public: __property System.int get_LineNumber();
public:
property System.int LineNumber {
   System.int get();
}

Property Value

The line number indicating where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


LinePosition Property (JsonReaderException)

LinePosition Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : LinePosition Property
Gets the line position indicating where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LinePosition As System.Integer
'Usage

Dim instance As JsonReaderException
Dim value As System.Integer

value = instance.LinePosition
public System.int LinePosition {get;}
public read-only property LinePosition: System.Integer;
public function get LinePosition : System.int
public: __property System.int get_LinePosition();
public:
property System.int LinePosition {
   System.int get();
}

Property Value

The line position indicating where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


Path Property (JsonReaderException)

Path Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : Path Property
Gets the path to the JSON where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}

Property Value

The path to the JSON where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


JsonSerializationException Class

JsonSerializationException Class
Members

Noemax.Newtonsoft.Json Namespace : JsonSerializationException Class
The exception thrown when an error occurs during Json serialization or deserialization.
Object Model
JsonSerializationException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.SerializableAttribute()>
Public Class JsonSerializationException
   Inherits JsonException
'Usage

Dim instance As JsonSerializationException
[System.Serializable()]
public class JsonSerializationException : JsonException
public class JsonSerializationException = class(JsonException)
System.SerializableAttribute()
public class JsonSerializationException extends JsonException
[System.Serializable()]
public __gc class JsonSerializationException : public JsonException
[System.Serializable()]
public ref class JsonSerializationException : public JsonException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonSerializationException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Members
Noemax.Newtonsoft.Json Namespace


JsonSerializationException Class Members

JsonSerializationException Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonSerializationException Class

The following tables list the members exposed by JsonSerializationException.

Public Constructors
 | Name | Description
Public Constructor | JsonSerializationException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonSerializationException Class
Noemax.Newtonsoft.Json Namespace


JsonSerializationException Constructor

JsonSerializationException Constructor

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : JsonSerializationException Constructor
Overload List
Overload | Description
JsonSerializationException Constructor() | Initializes a new instance of the JsonSerializationException class.
JsonSerializationException Constructor(String) | Initializes a new instance of the JsonSerializationException class with a specified error message.
JsonSerializationException Constructor(String,Exception) | Initializes a new instance of the JsonSerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
JsonSerializationException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the JsonSerializationException class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


JsonSerializationException Constructor()

JsonSerializationException Constructor()

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class > JsonSerializationException Constructor : JsonSerializationException Constructor()
Initializes a new instance of the JsonSerializationException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSerializationException()
public JsonSerializationException()
public JsonSerializationException();
public function JsonSerializationException();
public: JsonSerializationException();
public:
JsonSerializationException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members
Overload List


JsonSerializationException Constructor(String)

JsonSerializationException Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class > JsonSerializationException Constructor : JsonSerializationException Constructor(String)
The error message that explains the reason for the exception.
Initializes a new instance of the JsonSerializationException class with a specified error message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New JsonSerializationException(message)
public JsonSerializationException(
   System.string message
)
public JsonSerializationException(
    message: System.String
);
public function JsonSerializationException(
   message : System.String
);
public: JsonSerializationException(
   System.string* message
)
public:
JsonSerializationException(
   System.String^ message
)

Parameters

message
The error message that explains the reason for the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members
Overload List


JsonSerializationException Constructor(String,Exception)

JsonSerializationException Constructor(String,Exception)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class > JsonSerializationException Constructor : JsonSerializationException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Initializes a new instance of the JsonSerializationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
'Usage

Dim message As System.String
Dim innerException As System.Exception

Dim instance As New JsonSerializationException(message, innerException)
public JsonSerializationException(
   System.string message,
   System.Exception innerException
)
public JsonSerializationException(
    message: System.String;
    innerException: System.Exception
);
public function JsonSerializationException(
   message : System.String,
   innerException : System.Exception
);
public: JsonSerializationException(
   System.string* message,
   System.Exception* innerException
)
public:
JsonSerializationException(
   System.String^ message,
   System.Exception^ innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members
Overload List


JsonSerializationException Constructor(SerializationInfo,StreamingContext)

JsonSerializationException Constructor(SerializationInfo,StreamingContext)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class > JsonSerializationException Constructor : JsonSerializationException Constructor(SerializationInfo,StreamingContext)
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Initializes a new instance of the JsonSerializationException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New JsonSerializationException(info, context)
public JsonSerializationException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public JsonSerializationException(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
public function JsonSerializationException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
public: JsonSerializationException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
public:
JsonSerializationException(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Description
System.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization.SerializationException | The class name is null or System.Exception.HResult is zero (0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members
Overload List


JsonSerializer Class

JsonSerializer Class
Members

Noemax.Newtonsoft.Json Namespace : JsonSerializer Class
Serializes and deserializes objects into and from the JSON format. The JsonSerializer enables you to control how objects are encoded into JSON.
Object Model
JsonSerializer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonSerializer
'Usage

Dim instance As JsonSerializer
public class JsonSerializer
public class JsonSerializer
public class JsonSerializer
public __gc class JsonSerializer
public ref class JsonSerializer
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Members
Noemax.Newtonsoft.Json Namespace


JsonSerializer Class Members

JsonSerializer Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonSerializer Class

The following tables list the members exposed by JsonSerializer.

Public Constructors
 | Name | Description
Public Constructor | JsonSerializer Constructor | Initializes a new instance of the JsonSerializer class.
Top
Public Properties
 | Name | Description
Public Property | Binder | Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Public Property | CheckAdditionalContent | Gets a value indicating whether there will be a check for additional JSON content after deserializing an object.
Public Property | ConstructorHandling | Gets or sets how constructors are used during deserialization.
Public Property | Context | Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Public Property | ContractResolver | Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Public Property | Converters | Gets a collection JsonConverter that will be used during serialization.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling during serialization and deserialization.
Public Property | DefaultValueHandling | Get or set how null default are handled during serialization and deserialization.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON text.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | MetadataPropertyHandling | Gets or sets how metadata properties are used during deserialization.
Public Property | MissingMemberHandling | Get or set how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Public Property | NullValueHandling | Get or set how null values are handled during serialization and deserialization.
Public Property | ObjectCreationHandling | Gets or sets how objects are created during deserialization.
Public Property | PreserveReferencesHandling | Gets or sets how object references are preserved by the serializer.
Public Property | ReferenceLoopHandling | Get or set how reference loops (e.g. a class referencing itself) is handled.
Public Property | ReferenceResolver | Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | TraceWriter | Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Public Property | TypeNameAssemblyFormat | Gets or sets how a type name assembly is written and resolved by the serializer.
Public Property | TypeNameHandling | Gets or sets how type name writing and reading is handled by the serializer.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates a new JsonSerializer instance. The JsonSerializer will not use default settings.
static (Shared in Visual Basic) | CreateDefault | Overloaded. Creates a new JsonSerializer instance. The JsonSerializer will use default settings.
Public Method | Deserialize | Overloaded. Deserializes the Json structure contained by the specified JsonReader.
Public Method | Populate | Overloaded. Populates the JSON values onto the target object.
Public Method | Serialize | Overloaded. Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Top
Public Events
 | Name | Description
Public Event | Error | Occurs when the JsonSerializer errors during serialization and deserialization.
Top
See Also

Reference

JsonSerializer Class
Noemax.Newtonsoft.Json Namespace


JsonSerializer Constructor

JsonSerializer Constructor

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : JsonSerializer Constructor
Initializes a new instance of the JsonSerializer class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSerializer()
public JsonSerializer()
public JsonSerializer();
public function JsonSerializer();
public: JsonSerializer();
public:
JsonSerializer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


JsonSerializer Class Methods

JsonSerializer Class Methods

Noemax.Newtonsoft.Json Namespace : JsonSerializer Class

For a list of all members of this type, see JsonSerializer members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded. Creates a new JsonSerializer instance. The JsonSerializer will not use default settings.
static (Shared in Visual Basic) | CreateDefault | Overloaded. Creates a new JsonSerializer instance. The JsonSerializer will use default settings.
Public Method | Deserialize | Overloaded. Deserializes the Json structure contained by the specified JsonReader.
Public Method | Populate | Overloaded. Populates the JSON values onto the target object.
Public Method | Serialize | Overloaded. Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Top
See Also

Reference

JsonSerializer Class
Noemax.Newtonsoft.Json Namespace


Create Method (JsonSerializer)

Create Method (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Create Method
Creates a new JsonSerializer instance. The JsonSerializer will not use default settings.
Overload List
Overload | Description
Create() | Creates a new JsonSerializer instance. The JsonSerializer will not use default settings.
Create(JsonSerializerSettings) | Creates a new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will not use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Create() Method

Create() Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Create Method : Create() Method
Creates a new JsonSerializer instance. The JsonSerializer will not use default settings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create() As JsonSerializer
'Usage

Dim value As JsonSerializer

value = JsonSerializer.Create()
public static JsonSerializer Create()
public function Create(): JsonSerializer; static;
public static function Create() : JsonSerializer;
public: static JsonSerializer* Create();
public:
static JsonSerializer^ Create();

Return Value

A new JsonSerializer instance. The JsonSerializer will not use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Create(JsonSerializerSettings) Method

Create(JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Create Method : Create(JsonSerializerSettings) Method
The settings to be applied to the JsonSerializer.
Creates a new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will not use default settings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal settings As JsonSerializerSettings _
) As JsonSerializer
'Usage

Dim settings As JsonSerializerSettings
Dim value As JsonSerializer

value = JsonSerializer.Create(settings)
public static JsonSerializer Create(
   JsonSerializerSettings settings
)
public function Create(
    settings: JsonSerializerSettings
): JsonSerializer; static;
public static function Create(
   settings : JsonSerializerSettings
) : JsonSerializer;
public: static JsonSerializer* Create(
   JsonSerializerSettings* settings
)
public:
static JsonSerializer^ Create(
   JsonSerializerSettings^ settings
)

Parameters

settings
The settings to be applied to the JsonSerializer.

Return Value

A new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will not use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


CreateDefault Method (JsonSerializer)

CreateDefault Method (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : CreateDefault Method
Creates a new JsonSerializer instance. The JsonSerializer will use default settings.
Overload List
Overload | Description
CreateDefault() | Creates a new JsonSerializer instance. The JsonSerializer will use default settings.
CreateDefault(JsonSerializerSettings) | Creates a new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


CreateDefault() Method

CreateDefault() Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > CreateDefault Method : CreateDefault() Method
Creates a new JsonSerializer instance. The JsonSerializer will use default settings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDefault() As JsonSerializer
'Usage

Dim value As JsonSerializer

value = JsonSerializer.CreateDefault()
public static JsonSerializer CreateDefault()
public function CreateDefault(): JsonSerializer; static;
public static function CreateDefault() : JsonSerializer;
public: static JsonSerializer* CreateDefault();
public:
static JsonSerializer^ CreateDefault();

Return Value

A new JsonSerializer instance. The JsonSerializer will use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


CreateDefault(JsonSerializerSettings) Method

CreateDefault(JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > CreateDefault Method : CreateDefault(JsonSerializerSettings) Method
The settings to be applied to the JsonSerializer.
Creates a new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will use default settings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function CreateDefault( _
   ByVal settings As JsonSerializerSettings _
) As JsonSerializer
'Usage

Dim settings As JsonSerializerSettings
Dim value As JsonSerializer

value = JsonSerializer.CreateDefault(settings)
public static JsonSerializer CreateDefault(
   JsonSerializerSettings settings
)
public function CreateDefault(
    settings: JsonSerializerSettings
): JsonSerializer; static;
public static function CreateDefault(
   settings : JsonSerializerSettings
) : JsonSerializer;
public: static JsonSerializer* CreateDefault(
   JsonSerializerSettings* settings
)
public:
static JsonSerializer^ CreateDefault(
   JsonSerializerSettings^ settings
)

Parameters

settings
The settings to be applied to the JsonSerializer.

Return Value

A new JsonSerializer instance using the specified JsonSerializerSettings. The JsonSerializer will use default settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Deserialize Method (JsonSerializer)

Deserialize Method (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Deserialize Method
Deserializes the Json structure contained by the specified JsonReader.
Overload List
Overload | Description
Deserialize(JsonReader) | Deserializes the Json structure contained by the specified JsonReader.
Deserialize(TextReader,Type) | Deserializes the Json structure contained by the specified System.IO.StringReader into an instance of the specified type.
Deserialize<T>(JsonReader) | Deserializes the Json structure contained by the specified JsonReader into an instance of the specified type.
Deserialize(JsonReader,Type) | Deserializes the Json structure contained by the specified JsonReader into an instance of the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Deserialize(JsonReader) Method

Deserialize(JsonReader) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Deserialize Method : Deserialize(JsonReader) Method
The JsonReader that contains the JSON structure to deserialize.
Deserializes the Json structure contained by the specified JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Deserialize( _
   ByVal reader As JsonReader _
) As System.Object
'Usage

Dim instance As JsonSerializer
Dim reader As JsonReader
Dim value As System.Object

value = instance.Deserialize(reader)
public System.object Deserialize(
   JsonReader reader
)
public function Deserialize(
    reader: JsonReader
): System.TObject;
public function Deserialize(
   reader : JsonReader
) : System.Object;
public: System.Object* Deserialize(
   JsonReader* reader
)
public:
System.Object^ Deserialize(
   JsonReader^ reader
)

Parameters

reader
The JsonReader that contains the JSON structure to deserialize.

Return Value

The System.Object being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Deserialize(TextReader,Type) Method

Deserialize(TextReader,Type) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Deserialize Method : Deserialize(TextReader,Type) Method
The System.IO.TextReader containing the object.
The System.Type of object being deserialized.
Deserializes the Json structure contained by the specified System.IO.StringReader into an instance of the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Deserialize( _
   ByVal reader As System.IO.TextReader, _
   ByVal objectType As System.Type _
) As System.Object
'Usage

Dim instance As JsonSerializer
Dim reader As System.IO.TextReader
Dim objectType As System.Type
Dim value As System.Object

value = instance.Deserialize(reader, objectType)
public System.object Deserialize(
   System.IO.TextReader reader,
   System.Type objectType
)
public function Deserialize(
    reader: System.IO.TextReader;
    objectType: System.Type
): System.TObject;
public function Deserialize(
   reader : System.IO.TextReader,
   objectType : System.Type
) : System.Object;
public: System.Object* Deserialize(
   System.IO.TextReader* reader,
   System.Type* objectType
)
public:
System.Object^ Deserialize(
   System.IO.TextReader^ reader,
   System.Type^ objectType
)

Parameters

reader
The System.IO.TextReader containing the object.
objectType
The System.Type of object being deserialized.

Return Value

The instance of objectType being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Deserialize<T>(JsonReader) Method

Deserialize<T>(JsonReader) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Deserialize Method : Deserialize<T>(JsonReader) Method
The type of the object to deserialize.
The JsonReader containing the object.
Deserializes the Json structure contained by the specified JsonReader into an instance of the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Deserialize(Of T)( _
   ByVal reader As JsonReader _
) As T
'Usage

Dim instance As JsonSerializer
Dim reader As JsonReader
Dim value As T

value = instance.Deserialize(Of T)(reader)
public T Deserialize<T>(
   JsonReader reader
)
public function Deserialize(
    reader: JsonReader
): T;
public function Deserialize(
   reader : JsonReader
) : T;
public: T* Deserialize<T>(
   JsonReader* reader
)
public:
T^ Deserializegeneric<typename T>
(
   JsonReader^ reader
)

Parameters

reader
The JsonReader containing the object.

Type Parameters

T
The type of the object to deserialize.

Return Value

The instance of T being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Deserialize(JsonReader,Type) Method

Deserialize(JsonReader,Type) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Deserialize Method : Deserialize(JsonReader,Type) Method
The JsonReader containing the object.
The System.Type of object being deserialized.
Deserializes the Json structure contained by the specified JsonReader into an instance of the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Deserialize( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type _
) As System.Object
'Usage

Dim instance As JsonSerializer
Dim reader As JsonReader
Dim objectType As System.Type
Dim value As System.Object

value = instance.Deserialize(reader, objectType)
public System.object Deserialize(
   JsonReader reader,
   System.Type objectType
)
public function Deserialize(
    reader: JsonReader;
    objectType: System.Type
): System.TObject;
public function Deserialize(
   reader : JsonReader,
   objectType : System.Type
) : System.Object;
public: System.Object* Deserialize(
   JsonReader* reader,
   System.Type* objectType
)
public:
System.Object^ Deserialize(
   JsonReader^ reader,
   System.Type^ objectType
)

Parameters

reader
The JsonReader containing the object.
objectType
The System.Type of object being deserialized.

Return Value

The instance of objectType being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Populate Method (JsonSerializer)

Populate Method (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Populate Method
Populates the JSON values onto the target object.
Overload List
Overload | Description
Populate(TextReader,Object) | Populates the JSON values onto the target object.
Populate(JsonReader,Object) | Populates the JSON values onto the target object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Populate(TextReader,Object) Method

Populate(TextReader,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Populate Method : Populate(TextReader,Object) Method
The System.IO.TextReader that contains the JSON structure to reader values from.
The target object to populate values onto.
Populates the JSON values onto the target object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Populate( _
   ByVal reader As System.IO.TextReader, _
   ByVal target As System.Object _
)
'Usage

Dim instance As JsonSerializer
Dim reader As System.IO.TextReader
Dim target As System.Object

instance.Populate(reader, target)
public void Populate(
   System.IO.TextReader reader,
   System.object target
)
public procedure Populate(
    reader: System.IO.TextReader;
    target: System.TObject
);
public function Populate(
   reader : System.IO.TextReader,
   target : System.Object
);
public: void Populate(
   System.IO.TextReader* reader,
   System.Object* target
)
public:
void Populate(
   System.IO.TextReader^ reader,
   System.Object^ target
)

Parameters

reader
The System.IO.TextReader that contains the JSON structure to reader values from.
target
The target object to populate values onto.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Populate(JsonReader,Object) Method

Populate(JsonReader,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Populate Method : Populate(JsonReader,Object) Method
The JsonReader that contains the JSON structure to reader values from.
The target object to populate values onto.
Populates the JSON values onto the target object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Populate( _
   ByVal reader As JsonReader, _
   ByVal target As System.Object _
)
'Usage

Dim instance As JsonSerializer
Dim reader As JsonReader
Dim target As System.Object

instance.Populate(reader, target)
public void Populate(
   JsonReader reader,
   System.object target
)
public procedure Populate(
    reader: JsonReader;
    target: System.TObject
);
public function Populate(
   reader : JsonReader,
   target : System.Object
);
public: void Populate(
   JsonReader* reader,
   System.Object* target
)
public:
void Populate(
   JsonReader^ reader,
   System.Object^ target
)

Parameters

reader
The JsonReader that contains the JSON structure to reader values from.
target
The target object to populate values onto.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Serialize Method (JsonSerializer)

Serialize Method (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Serialize Method
Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Overload List
Overload | Description
Serialize(TextWriter,Object) | Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Serialize(JsonWriter,Object,Type) | Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Serialize(TextWriter,Object,Type) | Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Serialize(JsonWriter,Object) | Serializes the specified System.Object and writes the Json structure to a Stream using the specified JsonWriter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Serialize(TextWriter,Object) Method

Serialize(TextWriter,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Serialize Method : Serialize(TextWriter,Object) Method
The System.IO.TextWriter used to write the Json structure.
The System.Object to serialize.
Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Serialize( _
   ByVal textWriter As System.IO.TextWriter, _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonSerializer
Dim textWriter As System.IO.TextWriter
Dim value As System.Object

instance.Serialize(textWriter, value)
public void Serialize(
   System.IO.TextWriter textWriter,
   System.object value
)
public procedure Serialize(
    textWriter: System.IO.TextWriter;
    value: System.TObject
);
public function Serialize(
   textWriter : System.IO.TextWriter,
   value : System.Object
);
public: void Serialize(
   System.IO.TextWriter* textWriter,
   System.Object* value
)
public:
void Serialize(
   System.IO.TextWriter^ textWriter,
   System.Object^ value
)

Parameters

textWriter
The System.IO.TextWriter used to write the Json structure.
value
The System.Object to serialize.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Serialize(JsonWriter,Object,Type) Method

Serialize(JsonWriter,Object,Type) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Serialize Method : Serialize(JsonWriter,Object,Type) Method
The JsonWriter used to write the Json structure.
The System.Object to serialize.
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Serialize( _
   ByVal jsonWriter As JsonWriter, _
   ByVal value As System.Object, _
   ByVal objectType As System.Type _
)
'Usage

Dim instance As JsonSerializer
Dim jsonWriter As JsonWriter
Dim value As System.Object
Dim objectType As System.Type

instance.Serialize(jsonWriter, value, objectType)
public void Serialize(
   JsonWriter jsonWriter,
   System.object value,
   System.Type objectType
)
public procedure Serialize(
    jsonWriter: JsonWriter;
    value: System.TObject;
    objectType: System.Type
);
public function Serialize(
   jsonWriter : JsonWriter,
   value : System.Object,
   objectType : System.Type
);
public: void Serialize(
   JsonWriter* jsonWriter,
   System.Object* value,
   System.Type* objectType
)
public:
void Serialize(
   JsonWriter^ jsonWriter,
   System.Object^ value,
   System.Type^ objectType
)

Parameters

jsonWriter
The JsonWriter used to write the Json structure.
value
The System.Object to serialize.
objectType
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Serialize(TextWriter,Object,Type) Method

Serialize(TextWriter,Object,Type) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Serialize Method : Serialize(TextWriter,Object,Type) Method
The System.IO.TextWriter used to write the Json structure.
The System.Object to serialize.
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
Serializes the specified System.Object and writes the Json structure to a Stream using the specified System.IO.TextWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Serialize( _
   ByVal textWriter As System.IO.TextWriter, _
   ByVal value As System.Object, _
   ByVal objectType As System.Type _
)
'Usage

Dim instance As JsonSerializer
Dim textWriter As System.IO.TextWriter
Dim value As System.Object
Dim objectType As System.Type

instance.Serialize(textWriter, value, objectType)
public void Serialize(
   System.IO.TextWriter textWriter,
   System.object value,
   System.Type objectType
)
public procedure Serialize(
    textWriter: System.IO.TextWriter;
    value: System.TObject;
    objectType: System.Type
);
public function Serialize(
   textWriter : System.IO.TextWriter,
   value : System.Object,
   objectType : System.Type
);
public: void Serialize(
   System.IO.TextWriter* textWriter,
   System.Object* value,
   System.Type* objectType
)
public:
void Serialize(
   System.IO.TextWriter^ textWriter,
   System.Object^ value,
   System.Type^ objectType
)

Parameters

textWriter
The System.IO.TextWriter used to write the Json structure.
value
The System.Object to serialize.
objectType
The type of the value being serialized. This parameter is used when TypeNameHandling is Auto to write out the type name if the type of the value does not match. Specifing the type is optional.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


Serialize(JsonWriter,Object) Method

Serialize(JsonWriter,Object) Method

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class > Serialize Method : Serialize(JsonWriter,Object) Method
The JsonWriter used to write the Json structure.
The System.Object to serialize.
Serializes the specified System.Object and writes the Json structure to a Stream using the specified JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Serialize( _
   ByVal jsonWriter As JsonWriter, _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonSerializer
Dim jsonWriter As JsonWriter
Dim value As System.Object

instance.Serialize(jsonWriter, value)
public void Serialize(
   JsonWriter jsonWriter,
   System.object value
)
public procedure Serialize(
    jsonWriter: JsonWriter;
    value: System.TObject
);
public function Serialize(
   jsonWriter : JsonWriter,
   value : System.Object
);
public: void Serialize(
   JsonWriter* jsonWriter,
   System.Object* value
)
public:
void Serialize(
   JsonWriter^ jsonWriter,
   System.Object^ value
)

Parameters

jsonWriter
The JsonWriter used to write the Json structure.
value
The System.Object to serialize.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members
Overload List


JsonSerializer Class Properties

JsonSerializer Class Properties

Noemax.Newtonsoft.Json Namespace : JsonSerializer Class

For a list of all members of this type, see JsonSerializer members.

Public Properties
 | Name | Description
Public Property | Binder | Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Public Property | CheckAdditionalContent | Gets a value indicating whether there will be a check for additional JSON content after deserializing an object.
Public Property | ConstructorHandling | Gets or sets how constructors are used during deserialization.
Public Property | Context | Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Public Property | ContractResolver | Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Public Property | Converters | Gets a collection JsonConverter that will be used during serialization.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling during serialization and deserialization.
Public Property | DefaultValueHandling | Get or set how null default are handled during serialization and deserialization.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON text.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | MetadataPropertyHandling | Gets or sets how metadata properties are used during deserialization.
Public Property | MissingMemberHandling | Get or set how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Public Property | NullValueHandling | Get or set how null values are handled during serialization and deserialization.
Public Property | ObjectCreationHandling | Gets or sets how objects are created during deserialization.
Public Property | PreserveReferencesHandling | Gets or sets how object references are preserved by the serializer.
Public Property | ReferenceLoopHandling | Get or set how reference loops (e.g. a class referencing itself) is handled.
Public Property | ReferenceResolver | Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | TraceWriter | Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Public Property | TypeNameAssemblyFormat | Gets or sets how a type name assembly is written and resolved by the serializer.
Public Property | TypeNameHandling | Gets or sets how type name writing and reading is handled by the serializer.
Top
See Also

Reference

JsonSerializer Class
Noemax.Newtonsoft.Json Namespace


Binder Property (JsonSerializer)

Binder Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Binder Property
Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Binder As System.Runtime.Serialization.SerializationBinder
'Usage

Dim instance As JsonSerializer
Dim value As System.Runtime.Serialization.SerializationBinder

instance.Binder = value

value = instance.Binder
public virtual System.Runtime.Serialization.SerializationBinder Binder {get; set;}
public read-write property Binder: System.Runtime.Serialization.SerializationBinder; virtual;
public function get,set Binder : System.Runtime.Serialization.SerializationBinder
public: __property virtual System.Runtime.Serialization.SerializationBinder* get_Binder();
public: __property virtual void set_Binder(
   System.Runtime.Serialization.SerializationBinder* value
);
public:
virtual property System.Runtime.Serialization.SerializationBinder^ Binder {
   System.Runtime.Serialization.SerializationBinder^ get();
   void set (    System.Runtime.Serialization.SerializationBinder^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


CheckAdditionalContent Property (JsonSerializer)

CheckAdditionalContent Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : CheckAdditionalContent Property
Gets a value indicating whether there will be a check for additional JSON content after deserializing an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property CheckAdditionalContent As System.Boolean
'Usage

Dim instance As JsonSerializer
Dim value As System.Boolean

instance.CheckAdditionalContent = value

value = instance.CheckAdditionalContent
public virtual System.bool CheckAdditionalContent {get; set;}
public read-write property CheckAdditionalContent: System.Boolean; virtual;
public function get,set CheckAdditionalContent : System.boolean
public: __property virtual System.bool get_CheckAdditionalContent();
public: __property virtual void set_CheckAdditionalContent(
   System.bool value
);
public:
virtual property System.bool CheckAdditionalContent {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if there will be a check for additional JSON content after deserializing an object; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


ConstructorHandling Property (JsonSerializer)

ConstructorHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : ConstructorHandling Property
Gets or sets how constructors are used during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property ConstructorHandling As ConstructorHandling
'Usage

Dim instance As JsonSerializer
Dim value As ConstructorHandling

instance.ConstructorHandling = value

value = instance.ConstructorHandling
public virtual ConstructorHandling ConstructorHandling {get; set;}
public read-write property ConstructorHandling: ConstructorHandling; virtual;
public function get,set ConstructorHandling : ConstructorHandling
public: __property virtual ConstructorHandling get_ConstructorHandling();
public: __property virtual void set_ConstructorHandling(
   ConstructorHandling value
);
public:
virtual property ConstructorHandling ConstructorHandling {
   ConstructorHandling get();
   void set (    ConstructorHandling value);
}

Property Value

The constructor handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Context Property (JsonSerializer)

Context Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Context Property
Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Context As System.Runtime.Serialization.StreamingContext
'Usage

Dim instance As JsonSerializer
Dim value As System.Runtime.Serialization.StreamingContext

instance.Context = value

value = instance.Context
public virtual System.Runtime.Serialization.StreamingContext Context {get; set;}
public read-write property Context: System.Runtime.Serialization.StreamingContext; virtual;
public function get,set Context : System.Runtime.Serialization.StreamingContext
public: __property virtual System.Runtime.Serialization.StreamingContext get_Context();
public: __property virtual void set_Context(
   System.Runtime.Serialization.StreamingContext value
);
public:
virtual property System.Runtime.Serialization.StreamingContext Context {
   System.Runtime.Serialization.StreamingContext get();
   void set (    System.Runtime.Serialization.StreamingContext value);
}

Property Value

The context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


ContractResolver Property (JsonSerializer)

ContractResolver Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : ContractResolver Property
Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property ContractResolver As IContractResolver
'Usage

Dim instance As JsonSerializer
Dim value As IContractResolver

instance.ContractResolver = value

value = instance.ContractResolver
public virtual IContractResolver ContractResolver {get; set;}
public read-write property ContractResolver: IContractResolver; virtual;
public function get,set ContractResolver : IContractResolver
public: __property virtual IContractResolver* get_ContractResolver();
public: __property virtual void set_ContractResolver(
   IContractResolver* value
);
public:
virtual property IContractResolver^ ContractResolver {
   IContractResolver^ get();
   void set (    IContractResolver^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Converters Property (JsonSerializer)

Converters Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Converters Property
Gets a collection JsonConverter that will be used during serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Converters As JsonConverterCollection
'Usage

Dim instance As JsonSerializer
Dim value As JsonConverterCollection

value = instance.Converters
public virtual JsonConverterCollection Converters {get;}
public read-only property Converters: JsonConverterCollection; virtual;
public function get Converters : JsonConverterCollection
public: __property virtual JsonConverterCollection* get_Converters();
public:
virtual property JsonConverterCollection^ Converters {
   JsonConverterCollection^ get();
}

Property Value

Collection JsonConverter that will be used during serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Culture Property (JsonSerializer)

Culture Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Culture Property
Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Culture As System.Globalization.CultureInfo
'Usage

Dim instance As JsonSerializer
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
public virtual System.Globalization.CultureInfo Culture {get; set;}
public read-write property Culture: System.Globalization.CultureInfo; virtual;
public function get,set Culture : System.Globalization.CultureInfo
public: __property virtual System.Globalization.CultureInfo* get_Culture();
public: __property virtual void set_Culture(
   System.Globalization.CultureInfo* value
);
public:
virtual property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


DateFormatHandling Property (JsonSerializer)

DateFormatHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : DateFormatHandling Property
Get or set how dates are written to JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DateFormatHandling As DateFormatHandling
'Usage

Dim instance As JsonSerializer
Dim value As DateFormatHandling

instance.DateFormatHandling = value

value = instance.DateFormatHandling
public virtual DateFormatHandling DateFormatHandling {get; set;}
public read-write property DateFormatHandling: DateFormatHandling; virtual;
public function get,set DateFormatHandling : DateFormatHandling
public: __property virtual DateFormatHandling get_DateFormatHandling();
public: __property virtual void set_DateFormatHandling(
   DateFormatHandling value
);
public:
virtual property DateFormatHandling DateFormatHandling {
   DateFormatHandling get();
   void set (    DateFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


DateFormatString Property (JsonSerializer)

DateFormatString Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : DateFormatString Property
Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DateFormatString As System.String
'Usage

Dim instance As JsonSerializer
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
public virtual System.string DateFormatString {get; set;}
public read-write property DateFormatString: System.String; virtual;
public function get,set DateFormatString : System.String
public: __property virtual System.string* get_DateFormatString();
public: __property virtual void set_DateFormatString(
   System.string* value
);
public:
virtual property System.String^ DateFormatString {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


DateParseHandling Property (JsonSerializer)

DateParseHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : DateParseHandling Property
Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DateParseHandling As DateParseHandling
'Usage

Dim instance As JsonSerializer
Dim value As DateParseHandling

instance.DateParseHandling = value

value = instance.DateParseHandling
public virtual DateParseHandling DateParseHandling {get; set;}
public read-write property DateParseHandling: DateParseHandling; virtual;
public function get,set DateParseHandling : DateParseHandling
public: __property virtual DateParseHandling get_DateParseHandling();
public: __property virtual void set_DateParseHandling(
   DateParseHandling value
);
public:
virtual property DateParseHandling DateParseHandling {
   DateParseHandling get();
   void set (    DateParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


DateTimeZoneHandling Property (JsonSerializer)

DateTimeZoneHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : DateTimeZoneHandling Property
Get or set how System.DateTime time zones are handling during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DateTimeZoneHandling As DateTimeZoneHandling
'Usage

Dim instance As JsonSerializer
Dim value As DateTimeZoneHandling

instance.DateTimeZoneHandling = value

value = instance.DateTimeZoneHandling
public virtual DateTimeZoneHandling DateTimeZoneHandling {get; set;}
public read-write property DateTimeZoneHandling: DateTimeZoneHandling; virtual;
public function get,set DateTimeZoneHandling : DateTimeZoneHandling
public: __property virtual DateTimeZoneHandling get_DateTimeZoneHandling();
public: __property virtual void set_DateTimeZoneHandling(
   DateTimeZoneHandling value
);
public:
virtual property DateTimeZoneHandling DateTimeZoneHandling {
   DateTimeZoneHandling get();
   void set (    DateTimeZoneHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


DefaultValueHandling Property (JsonSerializer)

DefaultValueHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : DefaultValueHandling Property
Get or set how null default are handled during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DefaultValueHandling As DefaultValueHandling
'Usage

Dim instance As JsonSerializer
Dim value As DefaultValueHandling

instance.DefaultValueHandling = value

value = instance.DefaultValueHandling
public virtual DefaultValueHandling DefaultValueHandling {get; set;}
public read-write property DefaultValueHandling: DefaultValueHandling; virtual;
public function get,set DefaultValueHandling : DefaultValueHandling
public: __property virtual DefaultValueHandling get_DefaultValueHandling();
public: __property virtual void set_DefaultValueHandling(
   DefaultValueHandling value
);
public:
virtual property DefaultValueHandling DefaultValueHandling {
   DefaultValueHandling get();
   void set (    DefaultValueHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


FloatFormatHandling Property (JsonSerializer)

FloatFormatHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : FloatFormatHandling Property
Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property FloatFormatHandling As FloatFormatHandling
'Usage

Dim instance As JsonSerializer
Dim value As FloatFormatHandling

instance.FloatFormatHandling = value

value = instance.FloatFormatHandling
public virtual FloatFormatHandling FloatFormatHandling {get; set;}
public read-write property FloatFormatHandling: FloatFormatHandling; virtual;
public function get,set FloatFormatHandling : FloatFormatHandling
public: __property virtual FloatFormatHandling get_FloatFormatHandling();
public: __property virtual void set_FloatFormatHandling(
   FloatFormatHandling value
);
public:
virtual property FloatFormatHandling FloatFormatHandling {
   FloatFormatHandling get();
   void set (    FloatFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


FloatParseHandling Property (JsonSerializer)

FloatParseHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : FloatParseHandling Property
Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property FloatParseHandling As FloatParseHandling
'Usage

Dim instance As JsonSerializer
Dim value As FloatParseHandling

instance.FloatParseHandling = value

value = instance.FloatParseHandling
public virtual FloatParseHandling FloatParseHandling {get; set;}
public read-write property FloatParseHandling: FloatParseHandling; virtual;
public function get,set FloatParseHandling : FloatParseHandling
public: __property virtual FloatParseHandling get_FloatParseHandling();
public: __property virtual void set_FloatParseHandling(
   FloatParseHandling value
);
public:
virtual property FloatParseHandling FloatParseHandling {
   FloatParseHandling get();
   void set (    FloatParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


Formatting Property (JsonSerializer)

Formatting Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Formatting Property
Indicates how JSON text output is formatted.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property Formatting As Formatting
'Usage

Dim instance As JsonSerializer
Dim value As Formatting

instance.Formatting = value

value = instance.Formatting
public virtual Formatting Formatting {get; set;}
public read-write property Formatting: Formatting; virtual;
public function get,set Formatting : Formatting
public: __property virtual Formatting get_Formatting();
public: __property virtual void set_Formatting(
   Formatting value
);
public:
virtual property Formatting Formatting {
   Formatting get();
   void set (    Formatting value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


MaxDepth Property (JsonSerializer)

MaxDepth Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : MaxDepth Property
Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property MaxDepth As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSerializer
Dim value As System.Nullable(Of Integer)

instance.MaxDepth = value

value = instance.MaxDepth
public virtual System.Nullable<int> MaxDepth {get; set;}
public read-write property MaxDepth: System.Nullable; virtual;
public function get,set MaxDepth : System.Nullable
public: __property virtual System.Nullable<int> get_MaxDepth();
public: __property virtual void set_MaxDepth(
   System.Nullable<int> value
);
public:
virtual property System.Nullable<int> MaxDepth {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


MetadataPropertyHandling Property (JsonSerializer)

MetadataPropertyHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : MetadataPropertyHandling Property
Gets or sets how metadata properties are used during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property MetadataPropertyHandling As MetadataPropertyHandling
'Usage

Dim instance As JsonSerializer
Dim value As MetadataPropertyHandling

instance.MetadataPropertyHandling = value

value = instance.MetadataPropertyHandling
public virtual MetadataPropertyHandling MetadataPropertyHandling {get; set;}
public read-write property MetadataPropertyHandling: MetadataPropertyHandling; virtual;
public function get,set MetadataPropertyHandling : MetadataPropertyHandling
public: __property virtual MetadataPropertyHandling get_MetadataPropertyHandling();
public: __property virtual void set_MetadataPropertyHandling(
   MetadataPropertyHandling value
);
public:
virtual property MetadataPropertyHandling MetadataPropertyHandling {
   MetadataPropertyHandling get();
   void set (    MetadataPropertyHandling value);
}

Property Value

The metadata properties handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


MissingMemberHandling Property (JsonSerializer)

MissingMemberHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : MissingMemberHandling Property
Get or set how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property MissingMemberHandling As MissingMemberHandling
'Usage

Dim instance As JsonSerializer
Dim value As MissingMemberHandling

instance.MissingMemberHandling = value

value = instance.MissingMemberHandling
public virtual MissingMemberHandling MissingMemberHandling {get; set;}
public read-write property MissingMemberHandling: MissingMemberHandling; virtual;
public function get,set MissingMemberHandling : MissingMemberHandling
public: __property virtual MissingMemberHandling get_MissingMemberHandling();
public: __property virtual void set_MissingMemberHandling(
   MissingMemberHandling value
);
public:
virtual property MissingMemberHandling MissingMemberHandling {
   MissingMemberHandling get();
   void set (    MissingMemberHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


NullValueHandling Property (JsonSerializer)

NullValueHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : NullValueHandling Property
Get or set how null values are handled during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property NullValueHandling As NullValueHandling
'Usage

Dim instance As JsonSerializer
Dim value As NullValueHandling

instance.NullValueHandling = value

value = instance.NullValueHandling
public virtual NullValueHandling NullValueHandling {get; set;}
public read-write property NullValueHandling: NullValueHandling; virtual;
public function get,set NullValueHandling : NullValueHandling
public: __property virtual NullValueHandling get_NullValueHandling();
public: __property virtual void set_NullValueHandling(
   NullValueHandling value
);
public:
virtual property NullValueHandling NullValueHandling {
   NullValueHandling get();
   void set (    NullValueHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


ObjectCreationHandling Property (JsonSerializer)

ObjectCreationHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : ObjectCreationHandling Property
Gets or sets how objects are created during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property ObjectCreationHandling As ObjectCreationHandling
'Usage

Dim instance As JsonSerializer
Dim value As ObjectCreationHandling

instance.ObjectCreationHandling = value

value = instance.ObjectCreationHandling
public virtual ObjectCreationHandling ObjectCreationHandling {get; set;}
public read-write property ObjectCreationHandling: ObjectCreationHandling; virtual;
public function get,set ObjectCreationHandling : ObjectCreationHandling
public: __property virtual ObjectCreationHandling get_ObjectCreationHandling();
public: __property virtual void set_ObjectCreationHandling(
   ObjectCreationHandling value
);
public:
virtual property ObjectCreationHandling ObjectCreationHandling {
   ObjectCreationHandling get();
   void set (    ObjectCreationHandling value);
}

Property Value

The object creation handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


PreserveReferencesHandling Property (JsonSerializer)

PreserveReferencesHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : PreserveReferencesHandling Property
Gets or sets how object references are preserved by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property PreserveReferencesHandling As PreserveReferencesHandling
'Usage

Dim instance As JsonSerializer
Dim value As PreserveReferencesHandling

instance.PreserveReferencesHandling = value

value = instance.PreserveReferencesHandling
public virtual PreserveReferencesHandling PreserveReferencesHandling {get; set;}
public read-write property PreserveReferencesHandling: PreserveReferencesHandling; virtual;
public function get,set PreserveReferencesHandling : PreserveReferencesHandling
public: __property virtual PreserveReferencesHandling get_PreserveReferencesHandling();
public: __property virtual void set_PreserveReferencesHandling(
   PreserveReferencesHandling value
);
public:
virtual property PreserveReferencesHandling PreserveReferencesHandling {
   PreserveReferencesHandling get();
   void set (    PreserveReferencesHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


ReferenceLoopHandling Property (JsonSerializer)

ReferenceLoopHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : ReferenceLoopHandling Property
Get or set how reference loops (e.g. a class referencing itself) is handled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property ReferenceLoopHandling As ReferenceLoopHandling
'Usage

Dim instance As JsonSerializer
Dim value As ReferenceLoopHandling

instance.ReferenceLoopHandling = value

value = instance.ReferenceLoopHandling
public virtual ReferenceLoopHandling ReferenceLoopHandling {get; set;}
public read-write property ReferenceLoopHandling: ReferenceLoopHandling; virtual;
public function get,set ReferenceLoopHandling : ReferenceLoopHandling
public: __property virtual ReferenceLoopHandling get_ReferenceLoopHandling();
public: __property virtual void set_ReferenceLoopHandling(
   ReferenceLoopHandling value
);
public:
virtual property ReferenceLoopHandling ReferenceLoopHandling {
   ReferenceLoopHandling get();
   void set (    ReferenceLoopHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


ReferenceResolver Property (JsonSerializer)

ReferenceResolver Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : ReferenceResolver Property
Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property ReferenceResolver As IReferenceResolver
'Usage

Dim instance As JsonSerializer
Dim value As IReferenceResolver

instance.ReferenceResolver = value

value = instance.ReferenceResolver
public virtual IReferenceResolver ReferenceResolver {get; set;}
public read-write property ReferenceResolver: IReferenceResolver; virtual;
public function get,set ReferenceResolver : IReferenceResolver
public: __property virtual IReferenceResolver* get_ReferenceResolver();
public: __property virtual void set_ReferenceResolver(
   IReferenceResolver* value
);
public:
virtual property IReferenceResolver^ ReferenceResolver {
   IReferenceResolver^ get();
   void set (    IReferenceResolver^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


StringEscapeHandling Property (JsonSerializer)

StringEscapeHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : StringEscapeHandling Property
Get or set how strings are escaped when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property StringEscapeHandling As StringEscapeHandling
'Usage

Dim instance As JsonSerializer
Dim value As StringEscapeHandling

instance.StringEscapeHandling = value

value = instance.StringEscapeHandling
public virtual StringEscapeHandling StringEscapeHandling {get; set;}
public read-write property StringEscapeHandling: StringEscapeHandling; virtual;
public function get,set StringEscapeHandling : StringEscapeHandling
public: __property virtual StringEscapeHandling get_StringEscapeHandling();
public: __property virtual void set_StringEscapeHandling(
   StringEscapeHandling value
);
public:
virtual property StringEscapeHandling StringEscapeHandling {
   StringEscapeHandling get();
   void set (    StringEscapeHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


TraceWriter Property (JsonSerializer)

TraceWriter Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : TraceWriter Property
Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property TraceWriter As ITraceWriter
'Usage

Dim instance As JsonSerializer
Dim value As ITraceWriter

instance.TraceWriter = value

value = instance.TraceWriter
public virtual ITraceWriter TraceWriter {get; set;}
public read-write property TraceWriter: ITraceWriter; virtual;
public function get,set TraceWriter : ITraceWriter
public: __property virtual ITraceWriter* get_TraceWriter();
public: __property virtual void set_TraceWriter(
   ITraceWriter* value
);
public:
virtual property ITraceWriter^ TraceWriter {
   ITraceWriter^ get();
   void set (    ITraceWriter^ value);
}

Property Value

The trace writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


TypeNameAssemblyFormat Property (JsonSerializer)

TypeNameAssemblyFormat Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : TypeNameAssemblyFormat Property
Gets or sets how a type name assembly is written and resolved by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property TypeNameAssemblyFormat As System.Runtime.Serialization.Formatters.FormatterAssemblyStyle
'Usage

Dim instance As JsonSerializer
Dim value As System.Runtime.Serialization.Formatters.FormatterAssemblyStyle

instance.TypeNameAssemblyFormat = value

value = instance.TypeNameAssemblyFormat
public virtual System.Runtime.Serialization.Formatters.FormatterAssemblyStyle TypeNameAssemblyFormat {get; set;}
public read-write property TypeNameAssemblyFormat: System.Runtime.Serialization.Formatters.FormatterAssemblyStyle; virtual;
public function get,set TypeNameAssemblyFormat : System.Runtime.Serialization.Formatters.FormatterAssemblyStyle
public: __property virtual System.Runtime.Serialization.Formatters.FormatterAssemblyStyle get_TypeNameAssemblyFormat();
public: __property virtual void set_TypeNameAssemblyFormat(
   System.Runtime.Serialization.Formatters.FormatterAssemblyStyle value
);
public:
virtual property System.Runtime.Serialization.Formatters.FormatterAssemblyStyle TypeNameAssemblyFormat {
   System.Runtime.Serialization.Formatters.FormatterAssemblyStyle get();
   void set (    System.Runtime.Serialization.Formatters.FormatterAssemblyStyle value);
}

Property Value

The type name assembly format.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


TypeNameHandling Property (JsonSerializer)

TypeNameHandling Property (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : TypeNameHandling Property
Gets or sets how type name writing and reading is handled by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property TypeNameHandling As TypeNameHandling
'Usage

Dim instance As JsonSerializer
Dim value As TypeNameHandling

instance.TypeNameHandling = value

value = instance.TypeNameHandling
public virtual TypeNameHandling TypeNameHandling {get; set;}
public read-write property TypeNameHandling: TypeNameHandling; virtual;
public function get,set TypeNameHandling : TypeNameHandling
public: __property virtual TypeNameHandling get_TypeNameHandling();
public: __property virtual void set_TypeNameHandling(
   TypeNameHandling value
);
public:
virtual property TypeNameHandling TypeNameHandling {
   TypeNameHandling get();
   void set (    TypeNameHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


JsonSerializer Class Events

JsonSerializer Class Events

Noemax.Newtonsoft.Json Namespace : JsonSerializer Class

For a list of all members of this type, see JsonSerializer members.

Public Events
 | Name | Description
Public Event | Error | Occurs when the JsonSerializer errors during serialization and deserialization.
Top
See Also

Reference

JsonSerializer Class
Noemax.Newtonsoft.Json Namespace


Error Event (JsonSerializer)

Error Event (JsonSerializer)

Noemax.Newtonsoft.Json Namespace > JsonSerializer Class : Error Event
Occurs when the JsonSerializer errors during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Error As System.EventHandler(Of ErrorEventArgs)
'Usage

Dim instance As JsonSerializer
Dim handler As System.EventHandler(Of ErrorEventArgs)

AddHandler instance.Error, handler
public event System.EventHandler<ErrorEventArgs> Error
public event Error: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<ErrorEventArgs*>* Error
public:
event System.EventHandler<ErrorEventArgs^>^ Error
Event Data

The event handler receives an argument of type ErrorEventArgs containing data related to this event. The following ErrorEventArgs properties provide information specific to this event.

Property | Description
CurrentObject | Gets the current object the error event is being raised against.
ErrorContext | Gets the error context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializer Class
JsonSerializer Members


JsonSerializerSettings Class

JsonSerializerSettings Class
Members

Noemax.Newtonsoft.Json Namespace : JsonSerializerSettings Class
Specifies the settings on a JsonSerializer object.
Object Model
JsonSerializerSettings Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonSerializerSettings
'Usage

Dim instance As JsonSerializerSettings
public class JsonSerializerSettings
public class JsonSerializerSettings
public class JsonSerializerSettings
public __gc class JsonSerializerSettings
public ref class JsonSerializerSettings
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonSerializerSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Members
Noemax.Newtonsoft.Json Namespace


JsonSerializerSettings Class Members

JsonSerializerSettings Class Members
Properties

Noemax.Newtonsoft.Json Namespace : JsonSerializerSettings Class

The following tables list the members exposed by JsonSerializerSettings.

Public Constructors
 | Name | Description
Public Constructor | JsonSerializerSettings Constructor | Initializes a new instance of the JsonSerializerSettings class.
Top
Public Properties
 | Name | Description
Public Property | Binder | Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Public Property | CheckAdditionalContent | Gets a value indicating whether there will be a check for additional content after deserializing an object.
Public Property | ConstructorHandling | Gets or sets how constructors are used during deserialization.
Public Property | Context | Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Public Property | ContractResolver | Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Public Property | Converters | Gets or sets a collection JsonConverter that will be used during serialization.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling during serialization and deserialization.
Public Property | DefaultValueHandling | Gets or sets how null default are handled during serialization and deserialization.
Public Property | Error | Gets or sets the error handler called during serialization and deserialization.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | MetadataPropertyHandling | Gets or sets how metadata properties are used during deserialization.
Public Property | MissingMemberHandling | Gets or sets how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Public Property | NullValueHandling | Gets or sets how null values are handled during serialization and deserialization.
Public Property | ObjectCreationHandling | Gets or sets how objects are created during deserialization.
Public Property | PreserveReferencesHandling | Gets or sets how object references are preserved by the serializer.
Public Property | ReferenceLoopHandling | Gets or sets how reference loops (e.g. a class referencing itself) is handled.
Public Property | ReferenceResolver | Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | TraceWriter | Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Public Property | TypeNameAssemblyFormat | Gets or sets how a type name assembly is written and resolved by the serializer.
Public Property | TypeNameHandling | Gets or sets how type name writing and reading is handled by the serializer.
Top
See Also

Reference

JsonSerializerSettings Class
Noemax.Newtonsoft.Json Namespace


JsonSerializerSettings Constructor

JsonSerializerSettings Constructor

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : JsonSerializerSettings Constructor
Initializes a new instance of the JsonSerializerSettings class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSerializerSettings()
public JsonSerializerSettings()
public JsonSerializerSettings();
public function JsonSerializerSettings();
public: JsonSerializerSettings();
public:
JsonSerializerSettings();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


JsonSerializerSettings Class Properties

JsonSerializerSettings Class Properties

Noemax.Newtonsoft.Json Namespace : JsonSerializerSettings Class

For a list of all members of this type, see JsonSerializerSettings members.

Public Properties
 | Name | Description
Public Property | Binder | Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Public Property | CheckAdditionalContent | Gets a value indicating whether there will be a check for additional content after deserializing an object.
Public Property | ConstructorHandling | Gets or sets how constructors are used during deserialization.
Public Property | Context | Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Public Property | ContractResolver | Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Public Property | Converters | Gets or sets a collection JsonConverter that will be used during serialization.
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling during serialization and deserialization.
Public Property | DefaultValueHandling | Gets or sets how null default are handled during serialization and deserialization.
Public Property | Error | Gets or sets the error handler called during serialization and deserialization.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Public Property | MetadataPropertyHandling | Gets or sets how metadata properties are used during deserialization.
Public Property | MissingMemberHandling | Gets or sets how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Public Property | NullValueHandling | Gets or sets how null values are handled during serialization and deserialization.
Public Property | ObjectCreationHandling | Gets or sets how objects are created during deserialization.
Public Property | PreserveReferencesHandling | Gets or sets how object references are preserved by the serializer.
Public Property | ReferenceLoopHandling | Gets or sets how reference loops (e.g. a class referencing itself) is handled.
Public Property | ReferenceResolver | Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | TraceWriter | Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Public Property | TypeNameAssemblyFormat | Gets or sets how a type name assembly is written and resolved by the serializer.
Public Property | TypeNameHandling | Gets or sets how type name writing and reading is handled by the serializer.
Top
See Also

Reference

JsonSerializerSettings Class
Noemax.Newtonsoft.Json Namespace


Binder Property (JsonSerializerSettings)

Binder Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Binder Property
Gets or sets the System.Runtime.Serialization.SerializationBinder used by the serializer when resolving type names.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Binder As System.Runtime.Serialization.SerializationBinder
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Runtime.Serialization.SerializationBinder

instance.Binder = value

value = instance.Binder
public System.Runtime.Serialization.SerializationBinder Binder {get; set;}
public read-write property Binder: System.Runtime.Serialization.SerializationBinder;
public function get,set Binder : System.Runtime.Serialization.SerializationBinder
public: __property System.Runtime.Serialization.SerializationBinder* get_Binder();
public: __property void set_Binder(
   System.Runtime.Serialization.SerializationBinder* value
);
public:
property System.Runtime.Serialization.SerializationBinder^ Binder {
   System.Runtime.Serialization.SerializationBinder^ get();
   void set (    System.Runtime.Serialization.SerializationBinder^ value);
}

Property Value

The binder.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


CheckAdditionalContent Property (JsonSerializerSettings)

CheckAdditionalContent Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : CheckAdditionalContent Property
Gets a value indicating whether there will be a check for additional content after deserializing an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckAdditionalContent As System.Boolean
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Boolean

instance.CheckAdditionalContent = value

value = instance.CheckAdditionalContent
public System.bool CheckAdditionalContent {get; set;}
public read-write property CheckAdditionalContent: System.Boolean;
public function get,set CheckAdditionalContent : System.boolean
public: __property System.bool get_CheckAdditionalContent();
public: __property void set_CheckAdditionalContent(
   System.bool value
);
public:
property System.bool CheckAdditionalContent {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if there will be a check for additional content after deserializing an object; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


ConstructorHandling Property (JsonSerializerSettings)

ConstructorHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : ConstructorHandling Property
Gets or sets how constructors are used during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ConstructorHandling As ConstructorHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As ConstructorHandling

instance.ConstructorHandling = value

value = instance.ConstructorHandling
public ConstructorHandling ConstructorHandling {get; set;}
public read-write property ConstructorHandling: ConstructorHandling;
public function get,set ConstructorHandling : ConstructorHandling
public: __property ConstructorHandling get_ConstructorHandling();
public: __property void set_ConstructorHandling(
   ConstructorHandling value
);
public:
property ConstructorHandling ConstructorHandling {
   ConstructorHandling get();
   void set (    ConstructorHandling value);
}

Property Value

The constructor handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


Context Property (JsonSerializerSettings)

Context Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Context Property
Gets or sets the System.Runtime.Serialization.StreamingContext used by the serializer when invoking serialization callback methods.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Context As System.Runtime.Serialization.StreamingContext
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Runtime.Serialization.StreamingContext

instance.Context = value

value = instance.Context
public System.Runtime.Serialization.StreamingContext Context {get; set;}
public read-write property Context: System.Runtime.Serialization.StreamingContext;
public function get,set Context : System.Runtime.Serialization.StreamingContext
public: __property System.Runtime.Serialization.StreamingContext get_Context();
public: __property void set_Context(
   System.Runtime.Serialization.StreamingContext value
);
public:
property System.Runtime.Serialization.StreamingContext Context {
   System.Runtime.Serialization.StreamingContext get();
   void set (    System.Runtime.Serialization.StreamingContext value);
}

Property Value

The context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


ContractResolver Property (JsonSerializerSettings)

ContractResolver Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : ContractResolver Property
Gets or sets the contract resolver used by the serializer when serializing .NET objects to JSON and vice versa.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContractResolver As IContractResolver
'Usage

Dim instance As JsonSerializerSettings
Dim value As IContractResolver

instance.ContractResolver = value

value = instance.ContractResolver
public IContractResolver ContractResolver {get; set;}
public read-write property ContractResolver: IContractResolver;
public function get,set ContractResolver : IContractResolver
public: __property IContractResolver* get_ContractResolver();
public: __property void set_ContractResolver(
   IContractResolver* value
);
public:
property IContractResolver^ ContractResolver {
   IContractResolver^ get();
   void set (    IContractResolver^ value);
}

Property Value

The contract resolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


Converters Property (JsonSerializerSettings)

Converters Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Converters Property
Gets or sets a collection JsonConverter that will be used during serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Converters As System.Collections.Generic.IList(Of JsonConverter)
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Collections.Generic.IList(Of JsonConverter)

instance.Converters = value

value = instance.Converters
public System.Collections.Generic.IList<JsonConverter> Converters {get; set;}
public read-write property Converters: System.Collections.Generic.IList;
public function get,set Converters : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<JsonConverter*>* get_Converters();
public: __property void set_Converters(
   System.Collections.Generic.IList<JsonConverter*>* value
);
public:
property System.Collections.Generic.IList<JsonConverter^>^ Converters {
   System.Collections.Generic.IList<JsonConverter^>^ get();
   void set (    System.Collections.Generic.IList<JsonConverter^>^ value);
}

Property Value

The converters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


Culture Property (JsonSerializerSettings)

Culture Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Culture Property
Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Culture As System.Globalization.CultureInfo
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
public System.Globalization.CultureInfo Culture {get; set;}
public read-write property Culture: System.Globalization.CultureInfo;
public function get,set Culture : System.Globalization.CultureInfo
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


DateFormatHandling Property (JsonSerializerSettings)

DateFormatHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : DateFormatHandling Property
Get or set how dates are written to JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateFormatHandling As DateFormatHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As DateFormatHandling

instance.DateFormatHandling = value

value = instance.DateFormatHandling
public DateFormatHandling DateFormatHandling {get; set;}
public read-write property DateFormatHandling: DateFormatHandling;
public function get,set DateFormatHandling : DateFormatHandling
public: __property DateFormatHandling get_DateFormatHandling();
public: __property void set_DateFormatHandling(
   DateFormatHandling value
);
public:
property DateFormatHandling DateFormatHandling {
   DateFormatHandling get();
   void set (    DateFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


DateFormatString Property (JsonSerializerSettings)

DateFormatString Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : DateFormatString Property
Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateFormatString As System.String
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
public System.string DateFormatString {get; set;}
public read-write property DateFormatString: System.String;
public function get,set DateFormatString : System.String
public: __property System.string* get_DateFormatString();
public: __property void set_DateFormatString(
   System.string* value
);
public:
property System.String^ DateFormatString {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


DateParseHandling Property (JsonSerializerSettings)

DateParseHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : DateParseHandling Property
Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateParseHandling As DateParseHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As DateParseHandling

instance.DateParseHandling = value

value = instance.DateParseHandling
public DateParseHandling DateParseHandling {get; set;}
public read-write property DateParseHandling: DateParseHandling;
public function get,set DateParseHandling : DateParseHandling
public: __property DateParseHandling get_DateParseHandling();
public: __property void set_DateParseHandling(
   DateParseHandling value
);
public:
property DateParseHandling DateParseHandling {
   DateParseHandling get();
   void set (    DateParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


DateTimeZoneHandling Property (JsonSerializerSettings)

DateTimeZoneHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : DateTimeZoneHandling Property
Get or set how System.DateTime time zones are handling during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeZoneHandling As DateTimeZoneHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As DateTimeZoneHandling

instance.DateTimeZoneHandling = value

value = instance.DateTimeZoneHandling
public DateTimeZoneHandling DateTimeZoneHandling {get; set;}
public read-write property DateTimeZoneHandling: DateTimeZoneHandling;
public function get,set DateTimeZoneHandling : DateTimeZoneHandling
public: __property DateTimeZoneHandling get_DateTimeZoneHandling();
public: __property void set_DateTimeZoneHandling(
   DateTimeZoneHandling value
);
public:
property DateTimeZoneHandling DateTimeZoneHandling {
   DateTimeZoneHandling get();
   void set (    DateTimeZoneHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


DefaultValueHandling Property (JsonSerializerSettings)

DefaultValueHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : DefaultValueHandling Property
Gets or sets how null default are handled during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValueHandling As DefaultValueHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As DefaultValueHandling

instance.DefaultValueHandling = value

value = instance.DefaultValueHandling
public DefaultValueHandling DefaultValueHandling {get; set;}
public read-write property DefaultValueHandling: DefaultValueHandling;
public function get,set DefaultValueHandling : DefaultValueHandling
public: __property DefaultValueHandling get_DefaultValueHandling();
public: __property void set_DefaultValueHandling(
   DefaultValueHandling value
);
public:
property DefaultValueHandling DefaultValueHandling {
   DefaultValueHandling get();
   void set (    DefaultValueHandling value);
}

Property Value

The default value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


Error Property (JsonSerializerSettings)

Error Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Error Property
Gets or sets the error handler called during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Error As System.EventHandler(Of ErrorEventArgs)
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.EventHandler(Of ErrorEventArgs)

instance.Error = value

value = instance.Error
public System.EventHandler<ErrorEventArgs> Error {get; set;}
public read-write property Error: System.EventHandler;
public function get,set Error : System.EventHandler
public: __property System.EventHandler<ErrorEventArgs*>* get_Error();
public: __property void set_Error(
   System.EventHandler<ErrorEventArgs*>* value
);
public:
property System.EventHandler<ErrorEventArgs^>^ Error {
   System.EventHandler<ErrorEventArgs^>^ get();
   void set (    System.EventHandler<ErrorEventArgs^>^ value);
}

Property Value

The error handler called during serialization and deserialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


FloatFormatHandling Property (JsonSerializerSettings)

FloatFormatHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : FloatFormatHandling Property
Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written as JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FloatFormatHandling As FloatFormatHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As FloatFormatHandling

instance.FloatFormatHandling = value

value = instance.FloatFormatHandling
public FloatFormatHandling FloatFormatHandling {get; set;}
public read-write property FloatFormatHandling: FloatFormatHandling;
public function get,set FloatFormatHandling : FloatFormatHandling
public: __property FloatFormatHandling get_FloatFormatHandling();
public: __property void set_FloatFormatHandling(
   FloatFormatHandling value
);
public:
property FloatFormatHandling FloatFormatHandling {
   FloatFormatHandling get();
   void set (    FloatFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


FloatParseHandling Property (JsonSerializerSettings)

FloatParseHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : FloatParseHandling Property
Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FloatParseHandling As FloatParseHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As FloatParseHandling

instance.FloatParseHandling = value

value = instance.FloatParseHandling
public FloatParseHandling FloatParseHandling {get; set;}
public read-write property FloatParseHandling: FloatParseHandling;
public function get,set FloatParseHandling : FloatParseHandling
public: __property FloatParseHandling get_FloatParseHandling();
public: __property void set_FloatParseHandling(
   FloatParseHandling value
);
public:
property FloatParseHandling FloatParseHandling {
   FloatParseHandling get();
   void set (    FloatParseHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


Formatting Property (JsonSerializerSettings)

Formatting Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : Formatting Property
Indicates how JSON text output is formatted.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Formatting As Formatting
'Usage

Dim instance As JsonSerializerSettings
Dim value As Formatting

instance.Formatting = value

value = instance.Formatting
public Formatting Formatting {get; set;}
public read-write property Formatting: Formatting;
public function get,set Formatting : Formatting
public: __property Formatting get_Formatting();
public: __property void set_Formatting(
   Formatting value
);
public:
property Formatting Formatting {
   Formatting get();
   void set (    Formatting value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


MaxDepth Property (JsonSerializerSettings)

MaxDepth Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : MaxDepth Property
Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxDepth As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Nullable(Of Integer)

instance.MaxDepth = value

value = instance.MaxDepth
public System.Nullable<int> MaxDepth {get; set;}
public read-write property MaxDepth: System.Nullable;
public function get,set MaxDepth : System.Nullable
public: __property System.Nullable<int> get_MaxDepth();
public: __property void set_MaxDepth(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MaxDepth {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


MetadataPropertyHandling Property (JsonSerializerSettings)

MetadataPropertyHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : MetadataPropertyHandling Property
Gets or sets how metadata properties are used during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MetadataPropertyHandling As MetadataPropertyHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As MetadataPropertyHandling

instance.MetadataPropertyHandling = value

value = instance.MetadataPropertyHandling
public MetadataPropertyHandling MetadataPropertyHandling {get; set;}
public read-write property MetadataPropertyHandling: MetadataPropertyHandling;
public function get,set MetadataPropertyHandling : MetadataPropertyHandling
public: __property MetadataPropertyHandling get_MetadataPropertyHandling();
public: __property void set_MetadataPropertyHandling(
   MetadataPropertyHandling value
);
public:
property MetadataPropertyHandling MetadataPropertyHandling {
   MetadataPropertyHandling get();
   void set (    MetadataPropertyHandling value);
}

Property Value

The metadata properties handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


MissingMemberHandling Property (JsonSerializerSettings)

MissingMemberHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : MissingMemberHandling Property
Gets or sets how missing members (e.g. JSON contains a property that isn't a member on the object) are handled during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MissingMemberHandling As MissingMemberHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As MissingMemberHandling

instance.MissingMemberHandling = value

value = instance.MissingMemberHandling
public MissingMemberHandling MissingMemberHandling {get; set;}
public read-write property MissingMemberHandling: MissingMemberHandling;
public function get,set MissingMemberHandling : MissingMemberHandling
public: __property MissingMemberHandling get_MissingMemberHandling();
public: __property void set_MissingMemberHandling(
   MissingMemberHandling value
);
public:
property MissingMemberHandling MissingMemberHandling {
   MissingMemberHandling get();
   void set (    MissingMemberHandling value);
}

Property Value

Missing member handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


NullValueHandling Property (JsonSerializerSettings)

NullValueHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : NullValueHandling Property
Gets or sets how null values are handled during serialization and deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NullValueHandling As NullValueHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As NullValueHandling

instance.NullValueHandling = value

value = instance.NullValueHandling
public NullValueHandling NullValueHandling {get; set;}
public read-write property NullValueHandling: NullValueHandling;
public function get,set NullValueHandling : NullValueHandling
public: __property NullValueHandling get_NullValueHandling();
public: __property void set_NullValueHandling(
   NullValueHandling value
);
public:
property NullValueHandling NullValueHandling {
   NullValueHandling get();
   void set (    NullValueHandling value);
}

Property Value

Null value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


ObjectCreationHandling Property (JsonSerializerSettings)

ObjectCreationHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : ObjectCreationHandling Property
Gets or sets how objects are created during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectCreationHandling As ObjectCreationHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As ObjectCreationHandling

instance.ObjectCreationHandling = value

value = instance.ObjectCreationHandling
public ObjectCreationHandling ObjectCreationHandling {get; set;}
public read-write property ObjectCreationHandling: ObjectCreationHandling;
public function get,set ObjectCreationHandling : ObjectCreationHandling
public: __property ObjectCreationHandling get_ObjectCreationHandling();
public: __property void set_ObjectCreationHandling(
   ObjectCreationHandling value
);
public:
property ObjectCreationHandling ObjectCreationHandling {
   ObjectCreationHandling get();
   void set (    ObjectCreationHandling value);
}

Property Value

The object creation handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


PreserveReferencesHandling Property (JsonSerializerSettings)

PreserveReferencesHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : PreserveReferencesHandling Property
Gets or sets how object references are preserved by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PreserveReferencesHandling As PreserveReferencesHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As PreserveReferencesHandling

instance.PreserveReferencesHandling = value

value = instance.PreserveReferencesHandling
public PreserveReferencesHandling PreserveReferencesHandling {get; set;}
public read-write property PreserveReferencesHandling: PreserveReferencesHandling;
public function get,set PreserveReferencesHandling : PreserveReferencesHandling
public: __property PreserveReferencesHandling get_PreserveReferencesHandling();
public: __property void set_PreserveReferencesHandling(
   PreserveReferencesHandling value
);
public:
property PreserveReferencesHandling PreserveReferencesHandling {
   PreserveReferencesHandling get();
   void set (    PreserveReferencesHandling value);
}

Property Value

The preserve references handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


ReferenceLoopHandling Property (JsonSerializerSettings)

ReferenceLoopHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : ReferenceLoopHandling Property
Gets or sets how reference loops (e.g. a class referencing itself) is handled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceLoopHandling As ReferenceLoopHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As ReferenceLoopHandling

instance.ReferenceLoopHandling = value

value = instance.ReferenceLoopHandling
public ReferenceLoopHandling ReferenceLoopHandling {get; set;}
public read-write property ReferenceLoopHandling: ReferenceLoopHandling;
public function get,set ReferenceLoopHandling : ReferenceLoopHandling
public: __property ReferenceLoopHandling get_ReferenceLoopHandling();
public: __property void set_ReferenceLoopHandling(
   ReferenceLoopHandling value
);
public:
property ReferenceLoopHandling ReferenceLoopHandling {
   ReferenceLoopHandling get();
   void set (    ReferenceLoopHandling value);
}

Property Value

Reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


ReferenceResolver Property (JsonSerializerSettings)

ReferenceResolver Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : ReferenceResolver Property
Gets or sets the Noemax.Newtonsoft.Json.Serialization.IReferenceResolver used by the serializer when resolving references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceResolver As IReferenceResolver
'Usage

Dim instance As JsonSerializerSettings
Dim value As IReferenceResolver

instance.ReferenceResolver = value

value = instance.ReferenceResolver
public IReferenceResolver ReferenceResolver {get; set;}
public read-write property ReferenceResolver: IReferenceResolver;
public function get,set ReferenceResolver : IReferenceResolver
public: __property IReferenceResolver* get_ReferenceResolver();
public: __property void set_ReferenceResolver(
   IReferenceResolver* value
);
public:
property IReferenceResolver^ ReferenceResolver {
   IReferenceResolver^ get();
   void set (    IReferenceResolver^ value);
}

Property Value

The reference resolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


StringEscapeHandling Property (JsonSerializerSettings)

StringEscapeHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : StringEscapeHandling Property
Get or set how strings are escaped when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StringEscapeHandling As StringEscapeHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As StringEscapeHandling

instance.StringEscapeHandling = value

value = instance.StringEscapeHandling
public StringEscapeHandling StringEscapeHandling {get; set;}
public read-write property StringEscapeHandling: StringEscapeHandling;
public function get,set StringEscapeHandling : StringEscapeHandling
public: __property StringEscapeHandling get_StringEscapeHandling();
public: __property void set_StringEscapeHandling(
   StringEscapeHandling value
);
public:
property StringEscapeHandling StringEscapeHandling {
   StringEscapeHandling get();
   void set (    StringEscapeHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


TraceWriter Property (JsonSerializerSettings)

TraceWriter Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : TraceWriter Property
Gets or sets the Noemax.Newtonsoft.Json.Serialization.ITraceWriter used by the serializer when writing trace messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceWriter As ITraceWriter
'Usage

Dim instance As JsonSerializerSettings
Dim value As ITraceWriter

instance.TraceWriter = value

value = instance.TraceWriter
public ITraceWriter TraceWriter {get; set;}
public read-write property TraceWriter: ITraceWriter;
public function get,set TraceWriter : ITraceWriter
public: __property ITraceWriter* get_TraceWriter();
public: __property void set_TraceWriter(
   ITraceWriter* value
);
public:
property ITraceWriter^ TraceWriter {
   ITraceWriter^ get();
   void set (    ITraceWriter^ value);
}

Property Value

The trace writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


TypeNameAssemblyFormat Property (JsonSerializerSettings)

TypeNameAssemblyFormat Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : TypeNameAssemblyFormat Property
Gets or sets how a type name assembly is written and resolved by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TypeNameAssemblyFormat As System.Runtime.Serialization.Formatters.FormatterAssemblyStyle
'Usage

Dim instance As JsonSerializerSettings
Dim value As System.Runtime.Serialization.Formatters.FormatterAssemblyStyle

instance.TypeNameAssemblyFormat = value

value = instance.TypeNameAssemblyFormat
public System.Runtime.Serialization.Formatters.FormatterAssemblyStyle TypeNameAssemblyFormat {get; set;}
public read-write property TypeNameAssemblyFormat: System.Runtime.Serialization.Formatters.FormatterAssemblyStyle;
public function get,set TypeNameAssemblyFormat : System.Runtime.Serialization.Formatters.FormatterAssemblyStyle
public: __property System.Runtime.Serialization.Formatters.FormatterAssemblyStyle get_TypeNameAssemblyFormat();
public: __property void set_TypeNameAssemblyFormat(
   System.Runtime.Serialization.Formatters.FormatterAssemblyStyle value
);
public:
property System.Runtime.Serialization.Formatters.FormatterAssemblyStyle TypeNameAssemblyFormat {
   System.Runtime.Serialization.Formatters.FormatterAssemblyStyle get();
   void set (    System.Runtime.Serialization.Formatters.FormatterAssemblyStyle value);
}

Property Value

The type name assembly format.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


TypeNameHandling Property (JsonSerializerSettings)

TypeNameHandling Property (JsonSerializerSettings)

Noemax.Newtonsoft.Json Namespace > JsonSerializerSettings Class : TypeNameHandling Property
Gets or sets how type name writing and reading is handled by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TypeNameHandling As TypeNameHandling
'Usage

Dim instance As JsonSerializerSettings
Dim value As TypeNameHandling

instance.TypeNameHandling = value

value = instance.TypeNameHandling
public TypeNameHandling TypeNameHandling {get; set;}
public read-write property TypeNameHandling: TypeNameHandling;
public function get,set TypeNameHandling : TypeNameHandling
public: __property TypeNameHandling get_TypeNameHandling();
public: __property void set_TypeNameHandling(
   TypeNameHandling value
);
public:
property TypeNameHandling TypeNameHandling {
   TypeNameHandling get();
   void set (    TypeNameHandling value);
}

Property Value

The type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializerSettings Class
JsonSerializerSettings Members


JsonTextReader Class

JsonTextReader Class
Members

Noemax.Newtonsoft.Json Namespace : JsonTextReader Class
Represents a reader that provides fast, non-cached, forward-only access to JSON text data.
Object Model
JsonTextReader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonTextReader
   Inherits JsonReader
   Implements IJsonLineInfo
'Usage

Dim instance As JsonTextReader
public class JsonTextReader : JsonReader, IJsonLineInfo
public class JsonTextReader = class(JsonReader, IJsonLineInfo)
public class JsonTextReader extends JsonReader implements IJsonLineInfo
public __gc class JsonTextReader : public JsonReader, IJsonLineInfo
public ref class JsonTextReader : public JsonReader, IJsonLineInfo
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.JsonTextReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Members
Noemax.Newtonsoft.Json Namespace


JsonTextReader Class Members

JsonTextReader Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonTextReader Class

The following tables list the members exposed by JsonTextReader.

Public Constructors
 | Name | Description
Public Constructor | JsonTextReader Constructor | Initializes a new instance of the JsonReader class with the specified System.IO.TextReader.
Top
Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | LineNumber | Gets the current line number.
Public Property | LinePosition | Gets the current line position.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Gets the path of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Changes the state to closed.
Public Method | HasLineInfo | Gets a value indicating whether the class can return line information.
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JsonTextReader Class
Noemax.Newtonsoft.Json Namespace


JsonTextReader Constructor

JsonTextReader Constructor

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : JsonTextReader Constructor
The TextReader containing the XML data to read.
Initializes a new instance of the JsonReader class with the specified System.IO.TextReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal reader As System.IO.TextReader _
)
'Usage

Dim reader As System.IO.TextReader

Dim instance As New JsonTextReader(reader)
public JsonTextReader(
   System.IO.TextReader reader
)
public JsonTextReader(
    reader: System.IO.TextReader
);
public function JsonTextReader(
   reader : System.IO.TextReader
);
public: JsonTextReader(
   System.IO.TextReader* reader
)
public:
JsonTextReader(
   System.IO.TextReader^ reader
)

Parameters

reader
The TextReader containing the XML data to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members


JsonTextReader Class Methods

JsonTextReader Class Methods

Noemax.Newtonsoft.Json Namespace : JsonTextReader Class

For a list of all members of this type, see JsonTextReader members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Changes the state to closed.
Public Method | HasLineInfo | Gets a value indicating whether the class can return line information.
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JsonTextReader Class
Noemax.Newtonsoft.Json Namespace


Close Method (JsonTextReader)

Close Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : Close Method
Changes the state to closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As JsonTextReader

instance.Close()
public override void Close()
public procedure Close(); override;
public override function Close();
public: void Close(); override
public:
void Close(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in Close


HasLineInfo Method (JsonTextReader)

HasLineInfo Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : HasLineInfo Method
Gets a value indicating whether the class can return line information.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function HasLineInfo() As System.Boolean
'Usage

Dim instance As JsonTextReader
Dim value As System.Boolean

value = instance.HasLineInfo()
public System.bool HasLineInfo()
public function HasLineInfo(): System.Boolean;
public function HasLineInfo() : System.boolean;
public: System.bool HasLineInfo();
public:
System.bool HasLineInfo();

Return Value

true if LineNumber and LinePosition can be provided; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members


Read Method (JsonTextReader)

Read Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : Read Method
Reads the next JSON token from the stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Diagnostics.DebuggerStepThroughAttribute()>
Public Overrides Function Read() As System.Boolean
'Usage

Dim instance As JsonTextReader
Dim value As System.Boolean

value = instance.Read()
[System.Diagnostics.DebuggerStepThrough()]
public override System.bool Read()
public function Read(): System.Boolean; override;
System.Diagnostics.DebuggerStepThroughAttribute()
public override function Read() : System.boolean;
[System.Diagnostics.DebuggerStepThrough()]
public: System.bool Read(); override
[System.Diagnostics.DebuggerStepThrough()]
public:
System.bool Read(); override

Return Value

true if the next token was read successfully; false if there are no more tokens to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in Read


ReadAsBytes Method (JsonTextReader)

ReadAsBytes Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsBytes Method
Reads the next JSON token from the stream as a Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsBytes() As System.Byte()
'Usage

Dim instance As JsonTextReader
Dim value() As System.Byte

value = instance.ReadAsBytes()
public override System.byte[] ReadAsBytes()
public function ReadAsBytes(): System.array of Byte; override;
public override function ReadAsBytes() : System.byte[];
public: System.byte[]* ReadAsBytes(); override
public:
System.array<byte>^ ReadAsBytes(); override

Return Value

A Byte[] or a null reference if the next JSON token is null. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsBytes


ReadAsDateTime Method (JsonTextReader)

ReadAsDateTime Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsDateTime Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTime() As System.Nullable(Of Date)
'Usage

Dim instance As JsonTextReader
Dim value As System.Nullable(Of Date)

value = instance.ReadAsDateTime()
public override System.Nullable<DateTime> ReadAsDateTime()
public function ReadAsDateTime(): System.Nullable; override;
public override function ReadAsDateTime() : System.Nullable;
public: System.Nullable<DateTime> ReadAsDateTime(); override
public:
System.Nullable<DateTime> ReadAsDateTime(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsDateTime


ReadAsDateTimeOffset Method (JsonTextReader)

ReadAsDateTimeOffset Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsDateTimeOffset Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTimeOffset() As System.Nullable(Of DateTimeOffset)
'Usage

Dim instance As JsonTextReader
Dim value As System.Nullable(Of DateTimeOffset)

value = instance.ReadAsDateTimeOffset()
public override System.Nullable<DateTimeOffset> ReadAsDateTimeOffset()
public function ReadAsDateTimeOffset(): System.Nullable; override;
public override function ReadAsDateTimeOffset() : System.Nullable;
public: System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override
public:
System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override

Return Value

A System.DateTimeOffset. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsDateTimeOffset


ReadAsDecimal Method (JsonTextReader)

ReadAsDecimal Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsDecimal Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDecimal() As System.Nullable(Of Decimal)
'Usage

Dim instance As JsonTextReader
Dim value As System.Nullable(Of Decimal)

value = instance.ReadAsDecimal()
public override System.Nullable<decimal> ReadAsDecimal()
public function ReadAsDecimal(): System.Nullable; override;
public override function ReadAsDecimal() : System.Nullable;
public: System.Nullable<decimal> ReadAsDecimal(); override
public:
System.Nullable<decimal> ReadAsDecimal(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsDecimal


ReadAsInt32 Method (JsonTextReader)

ReadAsInt32 Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsInt32 Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsInt32() As System.Nullable(Of Integer)
'Usage

Dim instance As JsonTextReader
Dim value As System.Nullable(Of Integer)

value = instance.ReadAsInt32()
public override System.Nullable<int> ReadAsInt32()
public function ReadAsInt32(): System.Nullable; override;
public override function ReadAsInt32() : System.Nullable;
public: System.Nullable<int> ReadAsInt32(); override
public:
System.Nullable<int> ReadAsInt32(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsInt32


ReadAsString Method (JsonTextReader)

ReadAsString Method (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : ReadAsString Method
Reads the next JSON token from the stream as a System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsString() As System.String
'Usage

Dim instance As JsonTextReader
Dim value As System.String

value = instance.ReadAsString()
public override System.string ReadAsString()
public function ReadAsString(): System.String; override;
public override function ReadAsString() : System.String;
public: System.string* ReadAsString(); override
public:
System.String^ ReadAsString(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members
Base Implementation in ReadAsString


JsonTextReader Class Properties

JsonTextReader Class Properties

Noemax.Newtonsoft.Json Namespace : JsonTextReader Class

For a list of all members of this type, see JsonTextReader members.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | LineNumber | Gets the current line number.
Public Property | LinePosition | Gets the current line position.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Gets the path of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JsonTextReader Class
Noemax.Newtonsoft.Json Namespace


LineNumber Property (JsonTextReader)

LineNumber Property (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : LineNumber Property
Gets the current line number.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LineNumber As System.Integer
'Usage

Dim instance As JsonTextReader
Dim value As System.Integer

value = instance.LineNumber
public System.int LineNumber {get;}
public read-only property LineNumber: System.Integer;
public function get LineNumber : System.int
public: __property System.int get_LineNumber();
public:
property System.int LineNumber {
   System.int get();
}

Property Value

The current line number or 0 if no line information is available (for example, HasLineInfo returns false).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members


LinePosition Property (JsonTextReader)

LinePosition Property (JsonTextReader)

Noemax.Newtonsoft.Json Namespace > JsonTextReader Class : LinePosition Property
Gets the current line position.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LinePosition As System.Integer
'Usage

Dim instance As JsonTextReader
Dim value As System.Integer

value = instance.LinePosition
public System.int LinePosition {get;}
public read-only property LinePosition: System.Integer;
public function get LinePosition : System.int
public: __property System.int get_LinePosition();
public:
property System.int LinePosition {
   System.int get();
}

Property Value

The current line position or 0 if no line information is available (for example, HasLineInfo returns false).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextReader Class
JsonTextReader Members


JsonTextWriter Class

JsonTextWriter Class
Members

Noemax.Newtonsoft.Json Namespace : JsonTextWriter Class
Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Object Model
JsonTextWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonTextWriter
   Inherits JsonWriter
'Usage

Dim instance As JsonTextWriter
public class JsonTextWriter : JsonWriter
public class JsonTextWriter = class(JsonWriter)
public class JsonTextWriter extends JsonWriter
public __gc class JsonTextWriter : public JsonWriter
public ref class JsonTextWriter : public JsonWriter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.JsonTextWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Members
Noemax.Newtonsoft.Json Namespace


JsonTextWriter Class Members

JsonTextWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonTextWriter Class

The following tables list the members exposed by JsonTextWriter.

Public Constructors
 | Name | Description
Public Constructor | JsonTextWriter Constructor | Creates an instance of the JsonWriter class using the specified System.IO.TextWriter.
Top
Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Indentation | Gets or sets how many IndentChars to write for each level in the hierarchy when Formatting is set to Formatting.Indented.
Public Property | IndentChar | Gets or sets which character to use for indenting when Formatting is set to Formatting.Indented.
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | QuoteChar | Gets or sets which character to use to quote attribute values.
Public Property | QuoteName | Gets or sets a value indicating whether object names will be surrounded with quotes.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the specified end token.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Overridden. Writes out the given white space.
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Overridden. Writes indent characters.
Protected Method | WriteIndentSpace | Overridden. Writes an indent space.
Protected Method | WriteValueDelimiter | Overridden. Writes the JSON value delimiter.
Top
See Also

Reference

JsonTextWriter Class
Noemax.Newtonsoft.Json Namespace


JsonTextWriter Constructor

JsonTextWriter Constructor

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : JsonTextWriter Constructor
The TextWriter to write to.
Creates an instance of the JsonWriter class using the specified System.IO.TextWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal textWriter As System.IO.TextWriter _
)
'Usage

Dim textWriter As System.IO.TextWriter

Dim instance As New JsonTextWriter(textWriter)
public JsonTextWriter(
   System.IO.TextWriter textWriter
)
public JsonTextWriter(
    textWriter: System.IO.TextWriter
);
public function JsonTextWriter(
   textWriter : System.IO.TextWriter
);
public: JsonTextWriter(
   System.IO.TextWriter* textWriter
)
public:
JsonTextWriter(
   System.IO.TextWriter^ textWriter
)

Parameters

textWriter
The TextWriter to write to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members


JsonTextWriter Class Methods

JsonTextWriter Class Methods

Noemax.Newtonsoft.Json Namespace : JsonTextWriter Class

For a list of all members of this type, see JsonTextWriter members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the specified end token.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Overridden. Writes out the given white space.
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Overridden. Writes indent characters.
Protected Method | WriteIndentSpace | Overridden. Writes an indent space.
Protected Method | WriteValueDelimiter | Overridden. Writes the JSON value delimiter.
Top
See Also

Reference

JsonTextWriter Class
Noemax.Newtonsoft.Json Namespace


Close Method (JsonTextWriter)

Close Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : Close Method
Closes this stream and the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As JsonTextWriter

instance.Close()
public override void Close()
public procedure Close(); override;
public override function Close();
public: void Close(); override
public:
void Close(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in Close


Flush Method (JsonTextWriter)

Flush Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : Flush Method
Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flush()
'Usage

Dim instance As JsonTextWriter

instance.Flush()
public override void Flush()
public procedure Flush(); override;
public override function Flush();
public: void Flush(); override
public:
void Flush(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in Flush


WriteComment Method (JsonTextWriter)

WriteComment Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteComment Method
Text to place inside the comment.
Writes out a comment /*...*/ containing the specified text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteComment( _
   ByVal text As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim text As System.String

instance.WriteComment(text)
public override void WriteComment(
   System.string text
)
public procedure WriteComment(
    text: System.String
); override;
public override function WriteComment(
   text : System.String
);
public: void WriteComment(
   System.string* text
) override
public:
void WriteComment(
   System.String^ text
) override

Parameters

text
Text to place inside the comment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteComment


WriteEnd Method (JsonTextWriter)

WriteEnd Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteEnd Method
Writes the specified end token.
Overload List
Overload | Description
WriteEnd(JsonToken) | Writes the specified end token.
WriteEnd() | Writes the end of the current Json object or array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteEnd


WriteEnd(JsonToken) Method

WriteEnd(JsonToken) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteEnd Method : WriteEnd(JsonToken) Method
The end token to write.
Writes the specified end token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub WriteEnd( _
   ByVal token As JsonToken _
)
'Usage

Dim instance As JsonTextWriter
Dim token As JsonToken

instance.WriteEnd(token)
protected override void WriteEnd(
   JsonToken token
)
protected procedure WriteEnd(
    token: JsonToken
); override;
protected override function WriteEnd(
   token : JsonToken
);
protected: void WriteEnd(
   JsonToken token
) override
protected:
void WriteEnd(
   JsonToken token
) override

Parameters

token
The end token to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteEnd(JsonToken)


WriteIndent Method (JsonTextWriter)

WriteIndent Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteIndent Method
Writes indent characters.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub WriteIndent()
'Usage

Dim instance As JsonTextWriter

instance.WriteIndent()
protected override void WriteIndent()
protected procedure WriteIndent(); override;
protected override function WriteIndent();
protected: void WriteIndent(); override
protected:
void WriteIndent(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteIndent


WriteIndentSpace Method (JsonTextWriter)

WriteIndentSpace Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteIndentSpace Method
Writes an indent space.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub WriteIndentSpace()
'Usage

Dim instance As JsonTextWriter

instance.WriteIndentSpace()
protected override void WriteIndentSpace()
protected procedure WriteIndentSpace(); override;
protected override function WriteIndentSpace();
protected: void WriteIndentSpace(); override
protected:
void WriteIndentSpace(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteIndentSpace


WriteNull Method (JsonTextWriter)

WriteNull Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteNull Method
Writes a null value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteNull()
'Usage

Dim instance As JsonTextWriter

instance.WriteNull()
public override void WriteNull()
public procedure WriteNull(); override;
public override function WriteNull();
public: void WriteNull(); override
public:
void WriteNull(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteNull


WritePropertyName Method (JsonTextWriter)

WritePropertyName Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WritePropertyName Method
Writes the property name of a name/value pair on a Json object.
Overload List
Overload | Description
WritePropertyName(String) | Writes the property name of a name/value pair on a Json object.
WritePropertyName(String,Boolean) | Writes the property name of a name/value pair on a JSON object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WritePropertyName


WritePropertyName(String) Method

WritePropertyName(String) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WritePropertyName Method : WritePropertyName(String) Method
The name of the property.
Writes the property name of a name/value pair on a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WritePropertyName( _
   ByVal name As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim name As System.String

instance.WritePropertyName(name)
public override void WritePropertyName(
   System.string name
)
public procedure WritePropertyName(
    name: System.String
); override;
public override function WritePropertyName(
   name : System.String
);
public: void WritePropertyName(
   System.string* name
) override
public:
void WritePropertyName(
   System.String^ name
) override

Parameters

name
The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WritePropertyName(String)


WritePropertyName(String,Boolean) Method

WritePropertyName(String,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WritePropertyName Method : WritePropertyName(String,Boolean) Method
The name of the property.
A flag to indicate whether the text should be escaped when it is written as a JSON property name.
Writes the property name of a name/value pair on a JSON object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WritePropertyName( _
   ByVal name As System.String, _
   ByVal escape As System.Boolean _
)
'Usage

Dim instance As JsonTextWriter
Dim name As System.String
Dim escape As System.Boolean

instance.WritePropertyName(name, escape)
public override void WritePropertyName(
   System.string name,
   System.bool escape
)
public procedure WritePropertyName(
    name: System.String;
    escape: System.Boolean
); override;
public override function WritePropertyName(
   name : System.String,
   escape : System.boolean
);
public: void WritePropertyName(
   System.string* name,
   System.bool escape
) override
public:
void WritePropertyName(
   System.String^ name,
   System.bool escape
) override

Parameters

name
The name of the property.
escape
A flag to indicate whether the text should be escaped when it is written as a JSON property name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WritePropertyName(String,Boolean)


WriteRaw Method (JsonTextWriter)

WriteRaw Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteRaw Method
The raw JSON to write.
Writes raw JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteRaw( _
   ByVal json As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim json As System.String

instance.WriteRaw(json)
public override void WriteRaw(
   System.string json
)
public procedure WriteRaw(
    json: System.String
); override;
public override function WriteRaw(
   json : System.String
);
public: void WriteRaw(
   System.string* json
) override
public:
void WriteRaw(
   System.String^ json
) override

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteRaw


WriteStartArray Method (JsonTextWriter)

WriteStartArray Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteStartArray Method
Writes the beginning of a Json array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartArray()
'Usage

Dim instance As JsonTextWriter

instance.WriteStartArray()
public override void WriteStartArray()
public procedure WriteStartArray(); override;
public override function WriteStartArray();
public: void WriteStartArray(); override
public:
void WriteStartArray(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteStartArray


WriteStartConstructor Method (JsonTextWriter)

WriteStartConstructor Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteStartConstructor Method
The name of the constructor.
Writes the start of a constructor with the given name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartConstructor( _
   ByVal name As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim name As System.String

instance.WriteStartConstructor(name)
public override void WriteStartConstructor(
   System.string name
)
public procedure WriteStartConstructor(
    name: System.String
); override;
public override function WriteStartConstructor(
   name : System.String
);
public: void WriteStartConstructor(
   System.string* name
) override
public:
void WriteStartConstructor(
   System.String^ name
) override

Parameters

name
The name of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteStartConstructor


WriteStartObject Method (JsonTextWriter)

WriteStartObject Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteStartObject Method
Writes the beginning of a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartObject()
'Usage

Dim instance As JsonTextWriter

instance.WriteStartObject()
public override void WriteStartObject()
public procedure WriteStartObject(); override;
public override function WriteStartObject();
public: void WriteStartObject(); override
public:
void WriteStartObject(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteStartObject


WriteUndefined Method (JsonTextWriter)

WriteUndefined Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteUndefined Method
Writes an undefined value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteUndefined()
'Usage

Dim instance As JsonTextWriter

instance.WriteUndefined()
public override void WriteUndefined()
public procedure WriteUndefined(); override;
public override function WriteUndefined();
public: void WriteUndefined(); override
public:
void WriteUndefined(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteUndefined


WriteValue Method (JsonTextWriter)

WriteValue Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteValue Method
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Overload List
Overload | Description
WriteValue(Object) | Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
WriteValue(String) | Writes a System.String value.
WriteValue(Int32) | Writes a System.Int32 value.
WriteValue(UInt32) | Writes a System.UInt32 value.
WriteValue(Int64) | Writes a System.Int64 value.
WriteValue(UInt64) | Writes a System.UInt64 value.
WriteValue(Single) | Writes a System.Single value.
WriteValue(Nullable<Single>) | Writes a System.Nullable`1 value.
WriteValue(Double) | Writes a System.Double value.
WriteValue(Nullable<Double>) | Writes a System.Nullable`1 value.
WriteValue(Boolean) | Writes a System.Boolean value.
WriteValue(Int16) | Writes a System.Int16 value.
WriteValue(UInt16) | Writes a System.UInt16 value.
WriteValue(Char) | Writes a System.Char value.
WriteValue(Byte) | Writes a System.Byte value.
WriteValue(SByte) | Writes a System.SByte value.
WriteValue(Decimal) | Writes a System.Decimal value.
WriteValue(DateTime) | Writes a System.DateTime value.
WriteValue(Byte[]) | Writes a Byte[] value.
WriteValue(DateTimeOffset) | Writes a System.DateTimeOffset value.
WriteValue(Guid) | Writes a System.Guid value.
WriteValue(TimeSpan) | Writes a System.TimeSpan value.
WriteValue(Uri) | Writes a System.Uri value.
WriteValue(Nullable<Int32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Boolean>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Char>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Byte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<SByte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Decimal>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTime>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTimeOffset>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Guid>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<TimeSpan>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteValue


WriteValue(Object) Method

WriteValue(Object) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Object) Method
The System.Object value to write.
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Object

instance.WriteValue(value)
public override void WriteValue(
   System.object value
)
public procedure WriteValue(
    value: System.TObject
); override;
public override function WriteValue(
   value : System.Object
);
public: void WriteValue(
   System.Object* value
) override
public:
void WriteValue(
   System.Object^ value
) override

Parameters

value
The System.Object value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Object)


WriteValue(String) Method

WriteValue(String) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(String) Method
The System.String value to write.
Writes a System.String value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.String

instance.WriteValue(value)
public override void WriteValue(
   System.string value
)
public procedure WriteValue(
    value: System.String
); override;
public override function WriteValue(
   value : System.String
);
public: void WriteValue(
   System.string* value
) override
public:
void WriteValue(
   System.String^ value
) override

Parameters

value
The System.String value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(String)


WriteValue(Int32) Method

WriteValue(Int32) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Int32) Method
The System.Int32 value to write.
Writes a System.Int32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Integer _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Integer

instance.WriteValue(value)
public override void WriteValue(
   System.int value
)
public procedure WriteValue(
    value: System.Integer
); override;
public override function WriteValue(
   value : System.int
);
public: void WriteValue(
   System.int value
) override
public:
void WriteValue(
   System.int value
) override

Parameters

value
The System.Int32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Int32)


WriteValue(UInt32) Method

WriteValue(UInt32) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(UInt32) Method
The System.UInt32 value to write.
Writes a System.UInt32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UInteger _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.UInteger

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.uint value
)
public procedure WriteValue(
    value: System.LongWord
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.uint
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.uint value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.uint value
) override

Parameters

value
The System.UInt32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(UInt32)


WriteValue(Int64) Method

WriteValue(Int64) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Int64) Method
The System.Int64 value to write.
Writes a System.Int64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Long _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Long

instance.WriteValue(value)
public override void WriteValue(
   System.long value
)
public procedure WriteValue(
    value: System.Int64
); override;
public override function WriteValue(
   value : System.long
);
public: void WriteValue(
   System.long value
) override
public:
void WriteValue(
   System.int64 value
) override

Parameters

value
The System.Int64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Int64)


WriteValue(UInt64) Method

WriteValue(UInt64) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(UInt64) Method
The System.UInt64 value to write.
Writes a System.UInt64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.ULong _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.ULong

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ulong value
)
public procedure WriteValue(
    value: System.UInt64
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ulong
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ulong value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ulong value
) override

Parameters

value
The System.UInt64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(UInt64)


WriteValue(Single) Method

WriteValue(Single) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Single) Method
The System.Single value to write.
Writes a System.Single value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Single _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Single

instance.WriteValue(value)
public override void WriteValue(
   System.float value
)
public procedure WriteValue(
    value: System.Single
); override;
public override function WriteValue(
   value : System.float
);
public: void WriteValue(
   System.float value
) override
public:
void WriteValue(
   System.float value
) override

Parameters

value
The System.Single value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Single)


WriteValue(Nullable<Single>) Method

WriteValue(Nullable<Single>) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Nullable<Single>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Nullable(Of Single) _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Nullable(Of Single)

instance.WriteValue(value)
public override void WriteValue(
   System.Nullable<float> value
)
public procedure WriteValue(
    value: System.Nullable
); override;
public override function WriteValue(
   value : System.Nullable
);
public: void WriteValue(
   System.Nullable<float> value
) override
public:
void WriteValue(
   System.Nullable<float> value
) override

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Nullable<Single>)


WriteValue(Double) Method

WriteValue(Double) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Double) Method
The System.Double value to write.
Writes a System.Double value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Double _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Double

instance.WriteValue(value)
public override void WriteValue(
   System.double value
)
public procedure WriteValue(
    value: System.Double
); override;
public override function WriteValue(
   value : System.double
);
public: void WriteValue(
   System.double value
) override
public:
void WriteValue(
   System.double value
) override

Parameters

value
The System.Double value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Double)


WriteValue(Nullable<Double>) Method

WriteValue(Nullable<Double>) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Nullable<Double>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Nullable(Of Double) _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Nullable(Of Double)

instance.WriteValue(value)
public override void WriteValue(
   System.Nullable<double> value
)
public procedure WriteValue(
    value: System.Nullable
); override;
public override function WriteValue(
   value : System.Nullable
);
public: void WriteValue(
   System.Nullable<double> value
) override
public:
void WriteValue(
   System.Nullable<double> value
) override

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Nullable<Double>)


WriteValue(Boolean) Method

WriteValue(Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Boolean) Method
The System.Boolean value to write.
Writes a System.Boolean value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Boolean _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Boolean

instance.WriteValue(value)
public override void WriteValue(
   System.bool value
)
public procedure WriteValue(
    value: System.Boolean
); override;
public override function WriteValue(
   value : System.boolean
);
public: void WriteValue(
   System.bool value
) override
public:
void WriteValue(
   System.bool value
) override

Parameters

value
The System.Boolean value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Boolean)


WriteValue(Int16) Method

WriteValue(Int16) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Int16) Method
The System.Int16 value to write.
Writes a System.Int16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Short _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Short

instance.WriteValue(value)
public override void WriteValue(
   System.short value
)
public procedure WriteValue(
    value: System.Int16
); override;
public override function WriteValue(
   value : System.short
);
public: void WriteValue(
   System.short value
) override
public:
void WriteValue(
   System.short value
) override

Parameters

value
The System.Int16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Int16)


WriteValue(UInt16) Method

WriteValue(UInt16) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(UInt16) Method
The System.UInt16 value to write.
Writes a System.UInt16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UShort _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.UShort

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ushort value
)
public procedure WriteValue(
    value: System.Word
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ushort
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ushort value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ushort value
) override

Parameters

value
The System.UInt16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(UInt16)


WriteValue(Char) Method

WriteValue(Char) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Char) Method
The System.Char value to write.
Writes a System.Char value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Char _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Char

instance.WriteValue(value)
public override void WriteValue(
   System.char value
)
public procedure WriteValue(
    value: System.Char
); override;
public override function WriteValue(
   value : System.char
);
public: void WriteValue(
   System.char value
) override
public:
void WriteValue(
   System.char value
) override

Parameters

value
The System.Char value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Char)


WriteValue(Byte) Method

WriteValue(Byte) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Byte) Method
The System.Byte value to write.
Writes a System.Byte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Byte _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte value
)
public procedure WriteValue(
    value: System.Byte
); override;
public override function WriteValue(
   value : System.byte
);
public: void WriteValue(
   System.byte value
) override
public:
void WriteValue(
   System.byte value
) override

Parameters

value
The System.Byte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Byte)


WriteValue(SByte) Method

WriteValue(SByte) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(SByte) Method
The System.SByte value to write.
Writes a System.SByte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.SByte _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.SByte

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.sbyte value
)
public procedure WriteValue(
    value: System.ShortInt
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.sbyte
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.sbyte value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.sbyte value
) override

Parameters

value
The System.SByte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(SByte)


WriteValue(Decimal) Method

WriteValue(Decimal) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Decimal) Method
The System.Decimal value to write.
Writes a System.Decimal value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Decimal _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Decimal

instance.WriteValue(value)
public override void WriteValue(
   System.decimal value
)
public procedure WriteValue(
    value: System.Currency
); override;
public override function WriteValue(
   value : System.decimal
);
public: void WriteValue(
   System.decimal value
) override
public:
void WriteValue(
   System.decimal value
) override

Parameters

value
The System.Decimal value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Decimal)


WriteValue(DateTime) Method

WriteValue(DateTime) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(DateTime) Method
The System.DateTime value to write.
Writes a System.DateTime value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Date _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Date

instance.WriteValue(value)
public override void WriteValue(
   System.DateTime value
)
public procedure WriteValue(
    value: System.DateTime
); override;
public override function WriteValue(
   value : System.DateTime
);
public: void WriteValue(
   System.DateTime value
) override
public:
void WriteValue(
   System.DateTime value
) override

Parameters

value
The System.DateTime value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(DateTime)


WriteValue(Byte[]) Method

WriteValue(Byte[]) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Byte[]) Method
The Byte[] value to write.
Writes a Byte[] value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value() As System.Byte _
)
'Usage

Dim instance As JsonTextWriter
Dim value() As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte[] value
)
public procedure WriteValue(
    value: System.Bytearray of
); override;
public override function WriteValue(
   value : System.byte[]
);
public: void WriteValue(
   System.byte[]* value
) override
public:
void WriteValue(
   System.array<byte>^ value
) override

Parameters

value
The Byte[] value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Byte[])


WriteValue(DateTimeOffset) Method

WriteValue(DateTimeOffset) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(DateTimeOffset) Method
The System.DateTimeOffset value to write.
Writes a System.DateTimeOffset value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.DateTimeOffset _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.DateTimeOffset

instance.WriteValue(value)
public override void WriteValue(
   System.DateTimeOffset value
)
public procedure WriteValue(
    value: System.DateTimeOffset
); override;
public override function WriteValue(
   value : System.DateTimeOffset
);
public: void WriteValue(
   System.DateTimeOffset value
) override
public:
void WriteValue(
   System.DateTimeOffset value
) override

Parameters

value
The System.DateTimeOffset value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(DateTimeOffset)


WriteValue(Guid) Method

WriteValue(Guid) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Guid) Method
The System.Guid value to write.
Writes a System.Guid value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Guid _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Guid

instance.WriteValue(value)
public override void WriteValue(
   System.Guid value
)
public procedure WriteValue(
    value: System.Guid
); override;
public override function WriteValue(
   value : System.Guid
);
public: void WriteValue(
   System.Guid value
) override
public:
void WriteValue(
   System.Guid value
) override

Parameters

value
The System.Guid value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Guid)


WriteValue(TimeSpan) Method

WriteValue(TimeSpan) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(TimeSpan) Method
The System.TimeSpan value to write.
Writes a System.TimeSpan value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.TimeSpan _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.TimeSpan

instance.WriteValue(value)
public override void WriteValue(
   System.TimeSpan value
)
public procedure WriteValue(
    value: System.TimeSpan
); override;
public override function WriteValue(
   value : System.TimeSpan
);
public: void WriteValue(
   System.TimeSpan value
) override
public:
void WriteValue(
   System.TimeSpan value
) override

Parameters

value
The System.TimeSpan value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(TimeSpan)


WriteValue(Uri) Method

WriteValue(Uri) Method

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class > WriteValue Method : WriteValue(Uri) Method
The System.Uri value to write.
Writes a System.Uri value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Uri _
)
'Usage

Dim instance As JsonTextWriter
Dim value As System.Uri

instance.WriteValue(value)
public override void WriteValue(
   System.Uri value
)
public procedure WriteValue(
    value: System.Uri
); override;
public override function WriteValue(
   value : System.Uri
);
public: void WriteValue(
   System.Uri* value
) override
public:
void WriteValue(
   System.Uri^ value
) override

Parameters

value
The System.Uri value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Overload List
Base Implementation in WriteValue(Uri)


WriteValueDelimiter Method (JsonTextWriter)

WriteValueDelimiter Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteValueDelimiter Method
Writes the JSON value delimiter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Sub WriteValueDelimiter()
'Usage

Dim instance As JsonTextWriter

instance.WriteValueDelimiter()
protected override void WriteValueDelimiter()
protected procedure WriteValueDelimiter(); override;
protected override function WriteValueDelimiter();
protected: void WriteValueDelimiter(); override
protected:
void WriteValueDelimiter(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteValueDelimiter


WriteWhitespace Method (JsonTextWriter)

WriteWhitespace Method (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : WriteWhitespace Method
The string of white space characters.
Writes out the given white space.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteWhitespace( _
   ByVal ws As System.String _
)
'Usage

Dim instance As JsonTextWriter
Dim ws As System.String

instance.WriteWhitespace(ws)
public override void WriteWhitespace(
   System.string ws
)
public procedure WriteWhitespace(
    ws: System.String
); override;
public override function WriteWhitespace(
   ws : System.String
);
public: void WriteWhitespace(
   System.string* ws
) override
public:
void WriteWhitespace(
   System.String^ ws
) override

Parameters

ws
The string of white space characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members
Base Implementation in WriteWhitespace


JsonTextWriter Class Properties

JsonTextWriter Class Properties

Noemax.Newtonsoft.Json Namespace : JsonTextWriter Class

For a list of all members of this type, see JsonTextWriter members.

Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Indentation | Gets or sets how many IndentChars to write for each level in the hierarchy when Formatting is set to Formatting.Indented.
Public Property | IndentChar | Gets or sets which character to use for indenting when Formatting is set to Formatting.Indented.
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | QuoteChar | Gets or sets which character to use to quote attribute values.
Public Property | QuoteName | Gets or sets a value indicating whether object names will be surrounded with quotes.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

JsonTextWriter Class
Noemax.Newtonsoft.Json Namespace


Indentation Property (JsonTextWriter)

Indentation Property (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : Indentation Property
Gets or sets how many IndentChars to write for each level in the hierarchy when Formatting is set to Formatting.Indented.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Indentation As System.Integer
'Usage

Dim instance As JsonTextWriter
Dim value As System.Integer

instance.Indentation = value

value = instance.Indentation
public System.int Indentation {get; set;}
public read-write property Indentation: System.Integer;
public function get,set Indentation : System.int
public: __property System.int get_Indentation();
public: __property void set_Indentation(
   System.int value
);
public:
property System.int Indentation {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members


IndentChar Property (JsonTextWriter)

IndentChar Property (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : IndentChar Property
Gets or sets which character to use for indenting when Formatting is set to Formatting.Indented.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IndentChar As System.Char
'Usage

Dim instance As JsonTextWriter
Dim value As System.Char

instance.IndentChar = value

value = instance.IndentChar
public System.char IndentChar {get; set;}
public read-write property IndentChar: System.Char;
public function get,set IndentChar : System.char
public: __property System.char get_IndentChar();
public: __property void set_IndentChar(
   System.char value
);
public:
property System.char IndentChar {
   System.char get();
   void set (    System.char value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members


QuoteChar Property (JsonTextWriter)

QuoteChar Property (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : QuoteChar Property
Gets or sets which character to use to quote attribute values.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property QuoteChar As System.Char
'Usage

Dim instance As JsonTextWriter
Dim value As System.Char

instance.QuoteChar = value

value = instance.QuoteChar
public System.char QuoteChar {get; set;}
public read-write property QuoteChar: System.Char;
public function get,set QuoteChar : System.char
public: __property System.char get_QuoteChar();
public: __property void set_QuoteChar(
   System.char value
);
public:
property System.char QuoteChar {
   System.char get();
   void set (    System.char value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members


QuoteName Property (JsonTextWriter)

QuoteName Property (JsonTextWriter)

Noemax.Newtonsoft.Json Namespace > JsonTextWriter Class : QuoteName Property
Gets or sets a value indicating whether object names will be surrounded with quotes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property QuoteName As System.Boolean
'Usage

Dim instance As JsonTextWriter
Dim value As System.Boolean

instance.QuoteName = value

value = instance.QuoteName
public System.bool QuoteName {get; set;}
public read-write property QuoteName: System.Boolean;
public function get,set QuoteName : System.boolean
public: __property System.bool get_QuoteName();
public: __property void set_QuoteName(
   System.bool value
);
public:
property System.bool QuoteName {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonTextWriter Class
JsonTextWriter Members


JsonValidatingReader Class

JsonValidatingReader Class
Members

Noemax.Newtonsoft.Json Namespace : JsonValidatingReader Class
Represents a reader that provides Noemax.Newtonsoft.Json.Schema.JsonSchema validation.
Object Model
JsonValidatingReader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonValidatingReader
   Inherits JsonReader
   Implements IJsonLineInfo
'Usage

Dim instance As JsonValidatingReader
public class JsonValidatingReader : JsonReader, IJsonLineInfo
public class JsonValidatingReader = class(JsonReader, IJsonLineInfo)
public class JsonValidatingReader extends JsonReader implements IJsonLineInfo
public __gc class JsonValidatingReader : public JsonReader, IJsonLineInfo
public ref class JsonValidatingReader : public JsonReader, IJsonLineInfo
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.JsonValidatingReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Members
Noemax.Newtonsoft.Json Namespace


JsonValidatingReader Class Members

JsonValidatingReader Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonValidatingReader Class

The following tables list the members exposed by JsonValidatingReader.

Public Constructors
 | Name | Description
Public Constructor | JsonValidatingReader Constructor | Initializes a new instance of the JsonValidatingReader class that validates the content returned from the given JsonReader.
Top
Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Overridden. Gets the depth of the current token in the JSON document.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Overridden. Gets the path of the current JSON token.
Public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of a string.
Public Property | Reader | Gets the JsonReader used to construct this JsonValidatingReader.
Public Property | Schema | Gets or sets the schema.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Overridden. Gets the type of the current JSON token.
Public Property | Value | Overridden. Gets the text value of the current JSON token.
Public Property | ValueType | Overridden. Gets the Common Language Runtime (CLR) type for the current JSON token.
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Public Methods
 | Name | Description
Public Method | Close | Changes the JsonReader.State to Closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Public Events
 | Name | Description
Public Event | ValidationEventHandler | Sets an event handler for receiving schema validation errors.
Top
See Also

Reference

JsonValidatingReader Class
Noemax.Newtonsoft.Json Namespace


JsonValidatingReader Constructor

JsonValidatingReader Constructor

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : JsonValidatingReader Constructor
The JsonReader to read from while validating.
Initializes a new instance of the JsonValidatingReader class that validates the content returned from the given JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal reader As JsonReader _
)
'Usage

Dim reader As JsonReader

Dim instance As New JsonValidatingReader(reader)
public JsonValidatingReader(
   JsonReader reader
)
public JsonValidatingReader(
    reader: JsonReader
);
public function JsonValidatingReader(
   reader : JsonReader
);
public: JsonValidatingReader(
   JsonReader* reader
)
public:
JsonValidatingReader(
   JsonReader^ reader
)

Parameters

reader
The JsonReader to read from while validating.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members


JsonValidatingReader Class Methods

JsonValidatingReader Class Methods

Noemax.Newtonsoft.Json Namespace : JsonValidatingReader Class

For a list of all members of this type, see JsonValidatingReader members.

Public Methods
 | Name | Description
Public Method | Close | Changes the JsonReader.State to Closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JsonValidatingReader Class
Noemax.Newtonsoft.Json Namespace


Read Method (JsonValidatingReader)

Read Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Read Method
Reads the next JSON token from the stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Read() As System.Boolean
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Boolean

value = instance.Read()
public override System.bool Read()
public function Read(): System.Boolean; override;
public override function Read() : System.boolean;
public: System.bool Read(); override
public:
System.bool Read(); override

Return Value

true if the next token was read successfully; false if there are no more tokens to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in Read


ReadAsBytes Method (JsonValidatingReader)

ReadAsBytes Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsBytes Method
Reads the next JSON token from the stream as a Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsBytes() As System.Byte()
'Usage

Dim instance As JsonValidatingReader
Dim value() As System.Byte

value = instance.ReadAsBytes()
public override System.byte[] ReadAsBytes()
public function ReadAsBytes(): System.array of Byte; override;
public override function ReadAsBytes() : System.byte[];
public: System.byte[]* ReadAsBytes(); override
public:
System.array<byte>^ ReadAsBytes(); override

Return Value

A Byte[] or a null reference if the next JSON token is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsBytes


ReadAsDateTime Method (JsonValidatingReader)

ReadAsDateTime Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsDateTime Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTime() As System.Nullable(Of Date)
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Nullable(Of Date)

value = instance.ReadAsDateTime()
public override System.Nullable<DateTime> ReadAsDateTime()
public function ReadAsDateTime(): System.Nullable; override;
public override function ReadAsDateTime() : System.Nullable;
public: System.Nullable<DateTime> ReadAsDateTime(); override
public:
System.Nullable<DateTime> ReadAsDateTime(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsDateTime


ReadAsDateTimeOffset Method (JsonValidatingReader)

ReadAsDateTimeOffset Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsDateTimeOffset Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTimeOffset() As System.Nullable(Of DateTimeOffset)
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Nullable(Of DateTimeOffset)

value = instance.ReadAsDateTimeOffset()
public override System.Nullable<DateTimeOffset> ReadAsDateTimeOffset()
public function ReadAsDateTimeOffset(): System.Nullable; override;
public override function ReadAsDateTimeOffset() : System.Nullable;
public: System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override
public:
System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override

Return Value

A System.Nullable`1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsDateTimeOffset


ReadAsDecimal Method (JsonValidatingReader)

ReadAsDecimal Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsDecimal Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDecimal() As System.Nullable(Of Decimal)
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Nullable(Of Decimal)

value = instance.ReadAsDecimal()
public override System.Nullable<decimal> ReadAsDecimal()
public function ReadAsDecimal(): System.Nullable; override;
public override function ReadAsDecimal() : System.Nullable;
public: System.Nullable<decimal> ReadAsDecimal(); override
public:
System.Nullable<decimal> ReadAsDecimal(); override

Return Value

A System.Nullable`1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsDecimal


ReadAsInt32 Method (JsonValidatingReader)

ReadAsInt32 Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsInt32 Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsInt32() As System.Nullable(Of Integer)
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Nullable(Of Integer)

value = instance.ReadAsInt32()
public override System.Nullable<int> ReadAsInt32()
public function ReadAsInt32(): System.Nullable; override;
public override function ReadAsInt32() : System.Nullable;
public: System.Nullable<int> ReadAsInt32(); override
public:
System.Nullable<int> ReadAsInt32(); override

Return Value

A System.Nullable`1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsInt32


ReadAsString Method (JsonValidatingReader)

ReadAsString Method (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ReadAsString Method
Reads the next JSON token from the stream as a System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsString() As System.String
'Usage

Dim instance As JsonValidatingReader
Dim value As System.String

value = instance.ReadAsString()
public override System.string ReadAsString()
public function ReadAsString(): System.String; override;
public override function ReadAsString() : System.String;
public: System.string* ReadAsString(); override
public:
System.String^ ReadAsString(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ReadAsString


JsonValidatingReader Class Properties

JsonValidatingReader Class Properties

Noemax.Newtonsoft.Json Namespace : JsonValidatingReader Class

For a list of all members of this type, see JsonValidatingReader members.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Overridden. Gets the depth of the current token in the JSON document.
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Overridden. Gets the path of the current JSON token.
Public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of a string.
Public Property | Reader | Gets the JsonReader used to construct this JsonValidatingReader.
Public Property | Schema | Gets or sets the schema.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Overridden. Gets the type of the current JSON token.
Public Property | Value | Overridden. Gets the text value of the current JSON token.
Public Property | ValueType | Overridden. Gets the Common Language Runtime (CLR) type for the current JSON token.
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JsonValidatingReader Class
Noemax.Newtonsoft.Json Namespace


Depth Property (JsonValidatingReader)

Depth Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Depth Property
Gets the depth of the current token in the JSON document.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Depth As System.Integer
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Integer

value = instance.Depth
public override System.int Depth {get;}
public read-only property Depth: System.Integer; override;
public override function get Depth : System.int
public: __property System.int get_Depth() override;
public:
property System.int Depth {
   System.int get() override;
}

Property Value

The depth of the current token in the JSON document.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in Depth


Path Property (JsonValidatingReader)

Path Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Path Property
Gets the path of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Path As System.String
'Usage

Dim instance As JsonValidatingReader
Dim value As System.String

value = instance.Path
public override System.string Path {get;}
public read-only property Path: System.String; override;
public override function get Path : System.String
public: __property System.string* get_Path() override;
public:
property System.String^ Path {
   System.String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in Path


QuoteChar Property (JsonValidatingReader)

QuoteChar Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : QuoteChar Property
Gets the quotation mark character used to enclose the value of a string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property QuoteChar As System.Char
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Char

value = instance.QuoteChar
public override System.char QuoteChar {get;}
public read-only property QuoteChar: System.Char; override;
public override function get QuoteChar : System.char
public: __property System.char get_QuoteChar() override;
public:
property System.char QuoteChar {
   System.char get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in QuoteChar


Reader Property (JsonValidatingReader)

Reader Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Reader Property
Gets the JsonReader used to construct this JsonValidatingReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Reader As JsonReader
'Usage

Dim instance As JsonValidatingReader
Dim value As JsonReader

value = instance.Reader
public JsonReader Reader {get;}
public read-only property Reader: JsonReader;
public function get Reader : JsonReader
public: __property JsonReader* get_Reader();
public:
property JsonReader^ Reader {
   JsonReader^ get();
}

Property Value

The JsonReader specified in the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members


Schema Property (JsonValidatingReader)

Schema Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Schema Property
Gets or sets the schema.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Schema As JsonSchema
'Usage

Dim instance As JsonValidatingReader
Dim value As JsonSchema

instance.Schema = value

value = instance.Schema
public JsonSchema Schema {get; set;}
public read-write property Schema: JsonSchema;
public function get,set Schema : JsonSchema
public: __property JsonSchema* get_Schema();
public: __property void set_Schema(
   JsonSchema* value
);
public:
property JsonSchema^ Schema {
   JsonSchema^ get();
   void set (    JsonSchema^ value);
}

Property Value

The schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members


TokenType Property (JsonValidatingReader)

TokenType Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : TokenType Property
Gets the type of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property TokenType As JsonToken
'Usage

Dim instance As JsonValidatingReader
Dim value As JsonToken

value = instance.TokenType
public override JsonToken TokenType {get;}
public read-only property TokenType: JsonToken; override;
public override function get TokenType : JsonToken
public: __property JsonToken get_TokenType() override;
public:
property JsonToken TokenType {
   JsonToken get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in TokenType


Value Property (JsonValidatingReader)

Value Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : Value Property
Gets the text value of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Value As System.Object
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Object

value = instance.Value
public override System.object Value {get;}
public read-only property Value: System.TObject; override;
public override function get Value : System.Object
public: __property System.Object* get_Value() override;
public:
property System.Object^ Value {
   System.Object^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in Value


ValueType Property (JsonValidatingReader)

ValueType Property (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ValueType Property
Gets the Common Language Runtime (CLR) type for the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ValueType As System.Type
'Usage

Dim instance As JsonValidatingReader
Dim value As System.Type

value = instance.ValueType
public override System.Type ValueType {get;}
public read-only property ValueType: System.Type; override;
public override function get ValueType : System.Type
public: __property System.Type* get_ValueType() override;
public:
property System.Type^ ValueType {
   System.Type^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members
Base Implementation in ValueType


JsonValidatingReader Class Events

JsonValidatingReader Class Events

Noemax.Newtonsoft.Json Namespace : JsonValidatingReader Class

For a list of all members of this type, see JsonValidatingReader members.

Public Events
 | Name | Description
Public Event | ValidationEventHandler | Sets an event handler for receiving schema validation errors.
Top
See Also

Reference

JsonValidatingReader Class
Noemax.Newtonsoft.Json Namespace


ValidationEventHandler Event (JsonValidatingReader)

ValidationEventHandler Event (JsonValidatingReader)

Noemax.Newtonsoft.Json Namespace > JsonValidatingReader Class : ValidationEventHandler Event
Sets an event handler for receiving schema validation errors.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ValidationEventHandler As ValidationEventHandler
'Usage

Dim instance As JsonValidatingReader
Dim handler As ValidationEventHandler

AddHandler instance.ValidationEventHandler, handler
public event ValidationEventHandler ValidationEventHandler
public event ValidationEventHandler: ValidationEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event ValidationEventHandler* ValidationEventHandler
public:
event ValidationEventHandler^ ValidationEventHandler
Event Data

The event handler receives an argument of type ValidationEventArgs containing data related to this event. The following ValidationEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the JsonSchemaException associated with the validation error.
Message | Gets the text description corresponding to the validation error.
Path | Gets the path of the JSON location where the validation error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonValidatingReader Class
JsonValidatingReader Members


JsonWriter Class

JsonWriter Class
Members

Noemax.Newtonsoft.Json Namespace : JsonWriter Class
Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Object Model
JsonWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class JsonWriter
'Usage

Dim instance As JsonWriter
public abstract class JsonWriter
public class JsonWriter abstract;
public abstract class JsonWriter
public __gc abstract class JsonWriter
public ref class JsonWriter abstract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter
Noemax.Newtonsoft.Json.JsonTextWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Members
Noemax.Newtonsoft.Json Namespace


JsonWriter Class Members

JsonWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonWriter Class

The following tables list the members exposed by JsonWriter.

Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed.
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | Path | Gets the path of the writer.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | WriteState | Gets the state of the writer.
Top
Public Methods
 | Name | Description
Public Method | Close | Closes this stream and the underlying stream.
Public Method | Flush | Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Writes the end of the current Json object or array.
Public Method | WriteEndArray | Writes the end of an array.
Public Method | WriteEndConstructor | Writes the end constructor.
Public Method | WriteEndObject | Writes the end of a Json object.
Public Method | WriteNull | Writes a null value.
Public Method | WritePropertyName | Overloaded. Writes the property name of a name/value pair on a JSON object.
Public Method | WriteRaw | Writes raw JSON without changing the writer's state.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state.
Public Method | WriteStartArray | Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current JsonReader token and its children.
Public Method | WriteUndefined | Writes an undefined value.
Public Method | WriteValue | Overloaded. Writes a System.String value.
Public Method | WriteWhitespace | Writes out the given white space.
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter,
Protected Method | WriteIndent | Writes indent characters.
Protected Method | WriteIndentSpace | Writes an indent space.
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter.
Top
See Also

Reference

JsonWriter Class
Noemax.Newtonsoft.Json Namespace


JsonWriter Class Methods

JsonWriter Class Methods

Noemax.Newtonsoft.Json Namespace : JsonWriter Class

For a list of all members of this type, see JsonWriter members.

Public Methods
 | Name | Description
Public Method | Close | Closes this stream and the underlying stream.
Public Method | Flush | Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Writes the end of the current Json object or array.
Public Method | WriteEndArray | Writes the end of an array.
Public Method | WriteEndConstructor | Writes the end constructor.
Public Method | WriteEndObject | Writes the end of a Json object.
Public Method | WriteNull | Writes a null value.
Public Method | WritePropertyName | Overloaded. Writes the property name of a name/value pair on a JSON object.
Public Method | WriteRaw | Writes raw JSON without changing the writer's state.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state.
Public Method | WriteStartArray | Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current JsonReader token and its children.
Public Method | WriteUndefined | Writes an undefined value.
Public Method | WriteValue | Overloaded. Writes a System.String value.
Public Method | WriteWhitespace | Writes out the given white space.
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter,
Protected Method | WriteIndent | Writes indent characters.
Protected Method | WriteIndentSpace | Writes an indent space.
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter.
Top
See Also

Reference

JsonWriter Class
Noemax.Newtonsoft.Json Namespace


Close Method (JsonWriter)

Close Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : Close Method
Closes this stream and the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Close()
'Usage

Dim instance As JsonWriter

instance.Close()
public virtual void Close()
public procedure Close(); virtual;
public function Close();
public: virtual void Close();
public:
virtual void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


Flush Method (JsonWriter)

Flush Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : Flush Method
Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Flush()
'Usage

Dim instance As JsonWriter

instance.Flush()
public abstract void Flush()
public procedure Flush(); abstract;
public __abstract function Flush();
public: abstract void Flush();
public:
abstract void Flush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


SetWriteState Method (JsonWriter)

SetWriteState Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : SetWriteState Method
The JsonToken being written.
The value being written.
Sets the state of the JsonWriter,
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub SetWriteState( _
   ByVal token As JsonToken, _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonWriter
Dim token As JsonToken
Dim value As System.Object

instance.SetWriteState(token, value)
protected void SetWriteState(
   JsonToken token,
   System.object value
)
protected procedure SetWriteState(
    token: JsonToken;
    value: System.TObject
);
protected function SetWriteState(
   token : JsonToken,
   value : System.Object
);
protected: void SetWriteState(
   JsonToken token,
   System.Object* value
)
protected:
void SetWriteState(
   JsonToken token,
   System.Object^ value
)

Parameters

token
The JsonToken being written.
value
The value being written.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteComment Method (JsonWriter)

WriteComment Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteComment Method
Text to place inside the comment.
Writes out a comment /*...*/ containing the specified text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteComment( _
   ByVal text As System.String _
)
'Usage

Dim instance As JsonWriter
Dim text As System.String

instance.WriteComment(text)
public virtual void WriteComment(
   System.string text
)
public procedure WriteComment(
    text: System.String
); virtual;
public function WriteComment(
   text : System.String
);
public: virtual void WriteComment(
   System.string* text
)
public:
virtual void WriteComment(
   System.String^ text
)

Parameters

text
Text to place inside the comment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteEnd Method (JsonWriter)

WriteEnd Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteEnd Method
Writes the end of the current Json object or array.
Overload List
Overload | Description
WriteEnd() | Writes the end of the current Json object or array.
WriteEnd(JsonToken) | Writes the specified end token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteEnd() Method

WriteEnd() Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteEnd Method : WriteEnd() Method
Writes the end of the current Json object or array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteEnd()
'Usage

Dim instance As JsonWriter

instance.WriteEnd()
public virtual void WriteEnd()
public procedure WriteEnd(); virtual;
public function WriteEnd();
public: virtual void WriteEnd();
public:
virtual void WriteEnd();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteEnd(JsonToken) Method

WriteEnd(JsonToken) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteEnd Method : WriteEnd(JsonToken) Method
The end token to write.
Writes the specified end token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overridable Sub WriteEnd( _
   ByVal token As JsonToken _
)
'Usage

Dim instance As JsonWriter
Dim token As JsonToken

instance.WriteEnd(token)
protected virtual void WriteEnd(
   JsonToken token
)
protected procedure WriteEnd(
    token: JsonToken
); virtual;
protected function WriteEnd(
   token : JsonToken
);
protected: virtual void WriteEnd(
   JsonToken token
)
protected:
virtual void WriteEnd(
   JsonToken token
)

Parameters

token
The end token to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteEndArray Method (JsonWriter)

WriteEndArray Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteEndArray Method
Writes the end of an array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteEndArray()
'Usage

Dim instance As JsonWriter

instance.WriteEndArray()
public virtual void WriteEndArray()
public procedure WriteEndArray(); virtual;
public function WriteEndArray();
public: virtual void WriteEndArray();
public:
virtual void WriteEndArray();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteEndConstructor Method (JsonWriter)

WriteEndConstructor Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteEndConstructor Method
Writes the end constructor.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteEndConstructor()
'Usage

Dim instance As JsonWriter

instance.WriteEndConstructor()
public virtual void WriteEndConstructor()
public procedure WriteEndConstructor(); virtual;
public function WriteEndConstructor();
public: virtual void WriteEndConstructor();
public:
virtual void WriteEndConstructor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteEndObject Method (JsonWriter)

WriteEndObject Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteEndObject Method
Writes the end of a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteEndObject()
'Usage

Dim instance As JsonWriter

instance.WriteEndObject()
public virtual void WriteEndObject()
public procedure WriteEndObject(); virtual;
public function WriteEndObject();
public: virtual void WriteEndObject();
public:
virtual void WriteEndObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteIndent Method (JsonWriter)

WriteIndent Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteIndent Method
Writes indent characters.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub WriteIndent()
'Usage

Dim instance As JsonWriter

instance.WriteIndent()
protected virtual void WriteIndent()
protected procedure WriteIndent(); virtual;
protected function WriteIndent();
protected: virtual void WriteIndent();
protected:
virtual void WriteIndent();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteIndentSpace Method (JsonWriter)

WriteIndentSpace Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteIndentSpace Method
Writes an indent space.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub WriteIndentSpace()
'Usage

Dim instance As JsonWriter

instance.WriteIndentSpace()
protected virtual void WriteIndentSpace()
protected procedure WriteIndentSpace(); virtual;
protected function WriteIndentSpace();
protected: virtual void WriteIndentSpace();
protected:
virtual void WriteIndentSpace();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteNull Method (JsonWriter)

WriteNull Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteNull Method
Writes a null value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteNull()
'Usage

Dim instance As JsonWriter

instance.WriteNull()
public virtual void WriteNull()
public procedure WriteNull(); virtual;
public function WriteNull();
public: virtual void WriteNull();
public:
virtual void WriteNull();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WritePropertyName Method (JsonWriter)

WritePropertyName Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WritePropertyName Method
Writes the property name of a name/value pair on a JSON object.
Overload List
Overload | Description
WritePropertyName(String) | Writes the property name of a name/value pair on a JSON object.
WritePropertyName(String,Boolean) | Writes the property name of a name/value pair on a JSON object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WritePropertyName(String) Method

WritePropertyName(String) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WritePropertyName Method : WritePropertyName(String) Method
The name of the property.
Writes the property name of a name/value pair on a JSON object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WritePropertyName( _
   ByVal name As System.String _
)
'Usage

Dim instance As JsonWriter
Dim name As System.String

instance.WritePropertyName(name)
public virtual void WritePropertyName(
   System.string name
)
public procedure WritePropertyName(
    name: System.String
); virtual;
public function WritePropertyName(
   name : System.String
);
public: virtual void WritePropertyName(
   System.string* name
)
public:
virtual void WritePropertyName(
   System.String^ name
)

Parameters

name
The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WritePropertyName(String,Boolean) Method

WritePropertyName(String,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WritePropertyName Method : WritePropertyName(String,Boolean) Method
The name of the property.
A flag to indicate whether the text should be escaped when it is written as a JSON property name.
Writes the property name of a name/value pair on a JSON object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WritePropertyName( _
   ByVal name As System.String, _
   ByVal escape As System.Boolean _
)
'Usage

Dim instance As JsonWriter
Dim name As System.String
Dim escape As System.Boolean

instance.WritePropertyName(name, escape)
public virtual void WritePropertyName(
   System.string name,
   System.bool escape
)
public procedure WritePropertyName(
    name: System.String;
    escape: System.Boolean
); virtual;
public function WritePropertyName(
   name : System.String,
   escape : System.boolean
);
public: virtual void WritePropertyName(
   System.string* name,
   System.bool escape
)
public:
virtual void WritePropertyName(
   System.String^ name,
   System.bool escape
)

Parameters

name
The name of the property.
escape
A flag to indicate whether the text should be escaped when it is written as a JSON property name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteRaw Method (JsonWriter)

WriteRaw Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteRaw Method
The raw JSON to write.
Writes raw JSON without changing the writer's state.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteRaw( _
   ByVal json As System.String _
)
'Usage

Dim instance As JsonWriter
Dim json As System.String

instance.WriteRaw(json)
public virtual void WriteRaw(
   System.string json
)
public procedure WriteRaw(
    json: System.String
); virtual;
public function WriteRaw(
   json : System.String
);
public: virtual void WriteRaw(
   System.string* json
)
public:
virtual void WriteRaw(
   System.String^ json
)

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteRawValue Method (JsonWriter)

WriteRawValue Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteRawValue Method
The raw JSON to write.
Writes raw JSON where a value is expected and updates the writer's state.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteRawValue( _
   ByVal json As System.String _
)
'Usage

Dim instance As JsonWriter
Dim json As System.String

instance.WriteRawValue(json)
public virtual void WriteRawValue(
   System.string json
)
public procedure WriteRawValue(
    json: System.String
); virtual;
public function WriteRawValue(
   json : System.String
);
public: virtual void WriteRawValue(
   System.string* json
)
public:
virtual void WriteRawValue(
   System.String^ json
)

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteStartArray Method (JsonWriter)

WriteStartArray Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteStartArray Method
Writes the beginning of a Json array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteStartArray()
'Usage

Dim instance As JsonWriter

instance.WriteStartArray()
public virtual void WriteStartArray()
public procedure WriteStartArray(); virtual;
public function WriteStartArray();
public: virtual void WriteStartArray();
public:
virtual void WriteStartArray();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteStartConstructor Method (JsonWriter)

WriteStartConstructor Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteStartConstructor Method
The name of the constructor.
Writes the start of a constructor with the given name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteStartConstructor( _
   ByVal name As System.String _
)
'Usage

Dim instance As JsonWriter
Dim name As System.String

instance.WriteStartConstructor(name)
public virtual void WriteStartConstructor(
   System.string name
)
public procedure WriteStartConstructor(
    name: System.String
); virtual;
public function WriteStartConstructor(
   name : System.String
);
public: virtual void WriteStartConstructor(
   System.string* name
)
public:
virtual void WriteStartConstructor(
   System.String^ name
)

Parameters

name
The name of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteStartObject Method (JsonWriter)

WriteStartObject Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteStartObject Method
Writes the beginning of a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteStartObject()
'Usage

Dim instance As JsonWriter

instance.WriteStartObject()
public virtual void WriteStartObject()
public procedure WriteStartObject(); virtual;
public function WriteStartObject();
public: virtual void WriteStartObject();
public:
virtual void WriteStartObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteToken Method (JsonWriter)

WriteToken Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteToken Method
Writes the current JsonReader token and its children.
Overload List
Overload | Description
WriteToken(JsonReader) | Writes the current JsonReader token and its children.
WriteToken(JsonReader,Boolean) | Writes the current JsonReader token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteToken(JsonReader) Method

WriteToken(JsonReader) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteToken Method : WriteToken(JsonReader) Method
The JsonReader to read the token from.
Writes the current JsonReader token and its children.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteToken( _
   ByVal reader As JsonReader _
)
'Usage

Dim instance As JsonWriter
Dim reader As JsonReader

instance.WriteToken(reader)
public void WriteToken(
   JsonReader reader
)
public procedure WriteToken(
    reader: JsonReader
);
public function WriteToken(
   reader : JsonReader
);
public: void WriteToken(
   JsonReader* reader
)
public:
void WriteToken(
   JsonReader^ reader
)

Parameters

reader
The JsonReader to read the token from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteToken(JsonReader,Boolean) Method

WriteToken(JsonReader,Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteToken Method : WriteToken(JsonReader,Boolean) Method
The JsonReader to read the token from.
A flag indicating whether the current token's children should be written.
Writes the current JsonReader token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteToken( _
   ByVal reader As JsonReader, _
   ByVal writeChildren As System.Boolean _
)
'Usage

Dim instance As JsonWriter
Dim reader As JsonReader
Dim writeChildren As System.Boolean

instance.WriteToken(reader, writeChildren)
public void WriteToken(
   JsonReader reader,
   System.bool writeChildren
)
public procedure WriteToken(
    reader: JsonReader;
    writeChildren: System.Boolean
);
public function WriteToken(
   reader : JsonReader,
   writeChildren : System.boolean
);
public: void WriteToken(
   JsonReader* reader,
   System.bool writeChildren
)
public:
void WriteToken(
   JsonReader^ reader,
   System.bool writeChildren
)

Parameters

reader
The JsonReader to read the token from.
writeChildren
A flag indicating whether the current token's children should be written.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteUndefined Method (JsonWriter)

WriteUndefined Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteUndefined Method
Writes an undefined value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteUndefined()
'Usage

Dim instance As JsonWriter

instance.WriteUndefined()
public virtual void WriteUndefined()
public procedure WriteUndefined(); virtual;
public function WriteUndefined();
public: virtual void WriteUndefined();
public:
virtual void WriteUndefined();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteValue Method (JsonWriter)

WriteValue Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteValue Method
Writes a System.String value.
Overload List
Overload | Description
WriteValue(String) | Writes a System.String value.
WriteValue(Int32) | Writes a System.Int32 value.
WriteValue(UInt32) | Writes a System.UInt32 value.
WriteValue(Int64) | Writes a System.Int64 value.
WriteValue(UInt64) | Writes a System.UInt64 value.
WriteValue(Single) | Writes a System.Single value.
WriteValue(Double) | Writes a System.Double value.
WriteValue(Boolean) | Writes a System.Boolean value.
WriteValue(Int16) | Writes a System.Int16 value.
WriteValue(UInt16) | Writes a System.UInt16 value.
WriteValue(Char) | Writes a System.Char value.
WriteValue(Byte) | Writes a System.Byte value.
WriteValue(SByte) | Writes a System.SByte value.
WriteValue(Decimal) | Writes a System.Decimal value.
WriteValue(DateTime) | Writes a System.DateTime value.
WriteValue(DateTimeOffset) | Writes a System.DateTimeOffset value.
WriteValue(Guid) | Writes a System.Guid value.
WriteValue(TimeSpan) | Writes a System.TimeSpan value.
WriteValue(Nullable<Int32>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<UInt32>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Int64>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<UInt64>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Single>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Double>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Boolean>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Int16>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<UInt16>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Char>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Byte>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<SByte>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Decimal>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<DateTime>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<DateTimeOffset>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<Guid>) | Writes a System.Nullable`1 value.
WriteValue(Nullable<TimeSpan>) | Writes a System.Nullable`1 value.
WriteValue(Byte[]) | Writes a Byte[] value.
WriteValue(Uri) | Writes a System.Uri value.
WriteValue(Object) | Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteValue(String) Method

WriteValue(String) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(String) Method
The System.String value to write.
Writes a System.String value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.String _
)
'Usage

Dim instance As JsonWriter
Dim value As System.String

instance.WriteValue(value)
public virtual void WriteValue(
   System.string value
)
public procedure WriteValue(
    value: System.String
); virtual;
public function WriteValue(
   value : System.String
);
public: virtual void WriteValue(
   System.string* value
)
public:
virtual void WriteValue(
   System.String^ value
)

Parameters

value
The System.String value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Int32) Method

WriteValue(Int32) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Int32) Method
The System.Int32 value to write.
Writes a System.Int32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Integer _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Integer

instance.WriteValue(value)
public virtual void WriteValue(
   System.int value
)
public procedure WriteValue(
    value: System.Integer
); virtual;
public function WriteValue(
   value : System.int
);
public: virtual void WriteValue(
   System.int value
)
public:
virtual void WriteValue(
   System.int value
)

Parameters

value
The System.Int32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(UInt32) Method

WriteValue(UInt32) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(UInt32) Method
The System.UInt32 value to write.
Writes a System.UInt32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.UInteger _
)
'Usage

Dim instance As JsonWriter
Dim value As System.UInteger

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.uint value
)
public procedure WriteValue(
    value: System.LongWord
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.uint
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.uint value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.uint value
)

Parameters

value
The System.UInt32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Int64) Method

WriteValue(Int64) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Int64) Method
The System.Int64 value to write.
Writes a System.Int64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Long _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Long

instance.WriteValue(value)
public virtual void WriteValue(
   System.long value
)
public procedure WriteValue(
    value: System.Int64
); virtual;
public function WriteValue(
   value : System.long
);
public: virtual void WriteValue(
   System.long value
)
public:
virtual void WriteValue(
   System.int64 value
)

Parameters

value
The System.Int64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(UInt64) Method

WriteValue(UInt64) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(UInt64) Method
The System.UInt64 value to write.
Writes a System.UInt64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.ULong _
)
'Usage

Dim instance As JsonWriter
Dim value As System.ULong

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.ulong value
)
public procedure WriteValue(
    value: System.UInt64
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.ulong
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.ulong value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.ulong value
)

Parameters

value
The System.UInt64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Single) Method

WriteValue(Single) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Single) Method
The System.Single value to write.
Writes a System.Single value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Single _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Single

instance.WriteValue(value)
public virtual void WriteValue(
   System.float value
)
public procedure WriteValue(
    value: System.Single
); virtual;
public function WriteValue(
   value : System.float
);
public: virtual void WriteValue(
   System.float value
)
public:
virtual void WriteValue(
   System.float value
)

Parameters

value
The System.Single value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Double) Method

WriteValue(Double) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Double) Method
The System.Double value to write.
Writes a System.Double value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Double _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Double

instance.WriteValue(value)
public virtual void WriteValue(
   System.double value
)
public procedure WriteValue(
    value: System.Double
); virtual;
public function WriteValue(
   value : System.double
);
public: virtual void WriteValue(
   System.double value
)
public:
virtual void WriteValue(
   System.double value
)

Parameters

value
The System.Double value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Boolean) Method

WriteValue(Boolean) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Boolean) Method
The System.Boolean value to write.
Writes a System.Boolean value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Boolean _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Boolean

instance.WriteValue(value)
public virtual void WriteValue(
   System.bool value
)
public procedure WriteValue(
    value: System.Boolean
); virtual;
public function WriteValue(
   value : System.boolean
);
public: virtual void WriteValue(
   System.bool value
)
public:
virtual void WriteValue(
   System.bool value
)

Parameters

value
The System.Boolean value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Int16) Method

WriteValue(Int16) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Int16) Method
The System.Int16 value to write.
Writes a System.Int16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Short _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Short

instance.WriteValue(value)
public virtual void WriteValue(
   System.short value
)
public procedure WriteValue(
    value: System.Int16
); virtual;
public function WriteValue(
   value : System.short
);
public: virtual void WriteValue(
   System.short value
)
public:
virtual void WriteValue(
   System.short value
)

Parameters

value
The System.Int16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(UInt16) Method

WriteValue(UInt16) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(UInt16) Method
The System.UInt16 value to write.
Writes a System.UInt16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.UShort _
)
'Usage

Dim instance As JsonWriter
Dim value As System.UShort

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.ushort value
)
public procedure WriteValue(
    value: System.Word
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.ushort
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.ushort value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.ushort value
)

Parameters

value
The System.UInt16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Char) Method

WriteValue(Char) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Char) Method
The System.Char value to write.
Writes a System.Char value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Char _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Char

instance.WriteValue(value)
public virtual void WriteValue(
   System.char value
)
public procedure WriteValue(
    value: System.Char
); virtual;
public function WriteValue(
   value : System.char
);
public: virtual void WriteValue(
   System.char value
)
public:
virtual void WriteValue(
   System.char value
)

Parameters

value
The System.Char value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Byte) Method

WriteValue(Byte) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Byte) Method
The System.Byte value to write.
Writes a System.Byte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Byte _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Byte

instance.WriteValue(value)
public virtual void WriteValue(
   System.byte value
)
public procedure WriteValue(
    value: System.Byte
); virtual;
public function WriteValue(
   value : System.byte
);
public: virtual void WriteValue(
   System.byte value
)
public:
virtual void WriteValue(
   System.byte value
)

Parameters

value
The System.Byte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(SByte) Method

WriteValue(SByte) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(SByte) Method
The System.SByte value to write.
Writes a System.SByte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.SByte _
)
'Usage

Dim instance As JsonWriter
Dim value As System.SByte

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.sbyte value
)
public procedure WriteValue(
    value: System.ShortInt
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.sbyte
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.sbyte value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.sbyte value
)

Parameters

value
The System.SByte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Decimal) Method

WriteValue(Decimal) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Decimal) Method
The System.Decimal value to write.
Writes a System.Decimal value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Decimal _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Decimal

instance.WriteValue(value)
public virtual void WriteValue(
   System.decimal value
)
public procedure WriteValue(
    value: System.Currency
); virtual;
public function WriteValue(
   value : System.decimal
);
public: virtual void WriteValue(
   System.decimal value
)
public:
virtual void WriteValue(
   System.decimal value
)

Parameters

value
The System.Decimal value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(DateTime) Method

WriteValue(DateTime) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(DateTime) Method
The System.DateTime value to write.
Writes a System.DateTime value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Date _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Date

instance.WriteValue(value)
public virtual void WriteValue(
   System.DateTime value
)
public procedure WriteValue(
    value: System.DateTime
); virtual;
public function WriteValue(
   value : System.DateTime
);
public: virtual void WriteValue(
   System.DateTime value
)
public:
virtual void WriteValue(
   System.DateTime value
)

Parameters

value
The System.DateTime value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(DateTimeOffset) Method

WriteValue(DateTimeOffset) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(DateTimeOffset) Method
The System.DateTimeOffset value to write.
Writes a System.DateTimeOffset value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.DateTimeOffset _
)
'Usage

Dim instance As JsonWriter
Dim value As System.DateTimeOffset

instance.WriteValue(value)
public virtual void WriteValue(
   System.DateTimeOffset value
)
public procedure WriteValue(
    value: System.DateTimeOffset
); virtual;
public function WriteValue(
   value : System.DateTimeOffset
);
public: virtual void WriteValue(
   System.DateTimeOffset value
)
public:
virtual void WriteValue(
   System.DateTimeOffset value
)

Parameters

value
The System.DateTimeOffset value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Guid) Method

WriteValue(Guid) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Guid) Method
The System.Guid value to write.
Writes a System.Guid value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Guid _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Guid

instance.WriteValue(value)
public virtual void WriteValue(
   System.Guid value
)
public procedure WriteValue(
    value: System.Guid
); virtual;
public function WriteValue(
   value : System.Guid
);
public: virtual void WriteValue(
   System.Guid value
)
public:
virtual void WriteValue(
   System.Guid value
)

Parameters

value
The System.Guid value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(TimeSpan) Method

WriteValue(TimeSpan) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(TimeSpan) Method
The System.TimeSpan value to write.
Writes a System.TimeSpan value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.TimeSpan _
)
'Usage

Dim instance As JsonWriter
Dim value As System.TimeSpan

instance.WriteValue(value)
public virtual void WriteValue(
   System.TimeSpan value
)
public procedure WriteValue(
    value: System.TimeSpan
); virtual;
public function WriteValue(
   value : System.TimeSpan
);
public: virtual void WriteValue(
   System.TimeSpan value
)
public:
virtual void WriteValue(
   System.TimeSpan value
)

Parameters

value
The System.TimeSpan value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Int32>) Method

WriteValue(Nullable<Int32>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Int32>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Integer) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Integer)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<int> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<int> value
)
public:
virtual void WriteValue(
   System.Nullable<int> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<UInt32>) Method

WriteValue(Nullable<UInt32>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<UInt32>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of UInteger) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of UInteger)

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.Nullable<uint> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.Nullable
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.Nullable<uint> value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.Nullable<uint> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Int64>) Method

WriteValue(Nullable<Int64>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Int64>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Long) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Long)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<long> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<long> value
)
public:
virtual void WriteValue(
   System.Nullable<int64> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<UInt64>) Method

WriteValue(Nullable<UInt64>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<UInt64>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of ULong) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of ULong)

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.Nullable<ulong> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.Nullable
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.Nullable<ulong> value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.Nullable<ulong> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Single>) Method

WriteValue(Nullable<Single>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Single>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Single) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Single)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<float> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<float> value
)
public:
virtual void WriteValue(
   System.Nullable<float> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Double>) Method

WriteValue(Nullable<Double>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Double>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Double) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Double)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<double> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<double> value
)
public:
virtual void WriteValue(
   System.Nullable<double> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Boolean>) Method

WriteValue(Nullable<Boolean>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Boolean>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Boolean) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Boolean)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<bool> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<bool> value
)
public:
virtual void WriteValue(
   System.Nullable<bool> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Int16>) Method

WriteValue(Nullable<Int16>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Int16>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Short) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Short)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<short> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<short> value
)
public:
virtual void WriteValue(
   System.Nullable<short> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<UInt16>) Method

WriteValue(Nullable<UInt16>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<UInt16>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of UShort) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of UShort)

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.Nullable<ushort> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.Nullable
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.Nullable<ushort> value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.Nullable<ushort> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Char>) Method

WriteValue(Nullable<Char>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Char>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Char) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Char)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<char> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<char> value
)
public:
virtual void WriteValue(
   System.Nullable<char> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Byte>) Method

WriteValue(Nullable<Byte>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Byte>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Byte) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Byte)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<byte> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<byte> value
)
public:
virtual void WriteValue(
   System.Nullable<byte> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<SByte>) Method

WriteValue(Nullable<SByte>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<SByte>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of SByte) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of SByte)

instance.WriteValue(value)
[System.CLSCompliant(false)]
public virtual void WriteValue(
   System.Nullable<sbyte> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
System.CLSCompliantAttribute()
public function WriteValue(
   value : System.Nullable
);
[System.CLSCompliant(false)]
public: virtual void WriteValue(
   System.Nullable<sbyte> value
)
[System.CLSCompliant(false)]
public:
virtual void WriteValue(
   System.Nullable<sbyte> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Decimal>) Method

WriteValue(Nullable<Decimal>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Decimal>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Decimal) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Decimal)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<decimal> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<decimal> value
)
public:
virtual void WriteValue(
   System.Nullable<decimal> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<DateTime>) Method

WriteValue(Nullable<DateTime>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<DateTime>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Date) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Date)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<DateTime> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<DateTime> value
)
public:
virtual void WriteValue(
   System.Nullable<DateTime> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<DateTimeOffset>) Method

WriteValue(Nullable<DateTimeOffset>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<DateTimeOffset>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of DateTimeOffset) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of DateTimeOffset)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<DateTimeOffset> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<DateTimeOffset> value
)
public:
virtual void WriteValue(
   System.Nullable<DateTimeOffset> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<Guid>) Method

WriteValue(Nullable<Guid>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<Guid>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of Guid) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of Guid)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<Guid> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<Guid> value
)
public:
virtual void WriteValue(
   System.Nullable<Guid> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Nullable<TimeSpan>) Method

WriteValue(Nullable<TimeSpan>) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Nullable<TimeSpan>) Method
The System.Nullable`1 value to write.
Writes a System.Nullable`1 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Nullable(Of TimeSpan) _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Nullable(Of TimeSpan)

instance.WriteValue(value)
public virtual void WriteValue(
   System.Nullable<TimeSpan> value
)
public procedure WriteValue(
    value: System.Nullable
); virtual;
public function WriteValue(
   value : System.Nullable
);
public: virtual void WriteValue(
   System.Nullable<TimeSpan> value
)
public:
virtual void WriteValue(
   System.Nullable<TimeSpan> value
)

Parameters

value
The System.Nullable`1 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Byte[]) Method

WriteValue(Byte[]) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Byte[]) Method
The Byte[] value to write.
Writes a Byte[] value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value() As System.Byte _
)
'Usage

Dim instance As JsonWriter
Dim value() As System.Byte

instance.WriteValue(value)
public virtual void WriteValue(
   System.byte[] value
)
public procedure WriteValue(
    value: System.Bytearray of
); virtual;
public function WriteValue(
   value : System.byte[]
);
public: virtual void WriteValue(
   System.byte[]* value
)
public:
virtual void WriteValue(
   System.array<byte>^ value
)

Parameters

value
The Byte[] value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Uri) Method

WriteValue(Uri) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Uri) Method
The System.Uri value to write.
Writes a System.Uri value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Uri _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Uri

instance.WriteValue(value)
public virtual void WriteValue(
   System.Uri value
)
public procedure WriteValue(
    value: System.Uri
); virtual;
public function WriteValue(
   value : System.Uri
);
public: virtual void WriteValue(
   System.Uri* value
)
public:
virtual void WriteValue(
   System.Uri^ value
)

Parameters

value
The System.Uri value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValue(Object) Method

WriteValue(Object) Method

Noemax.Newtonsoft.Json Namespace > JsonWriter Class > WriteValue Method : WriteValue(Object) Method
The System.Object value to write.
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub WriteValue( _
   ByVal value As System.Object _
)
'Usage

Dim instance As JsonWriter
Dim value As System.Object

instance.WriteValue(value)
public virtual void WriteValue(
   System.object value
)
public procedure WriteValue(
    value: System.TObject
); virtual;
public function WriteValue(
   value : System.Object
);
public: virtual void WriteValue(
   System.Object* value
)
public:
virtual void WriteValue(
   System.Object^ value
)

Parameters

value
The System.Object value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members
Overload List


WriteValueDelimiter Method (JsonWriter)

WriteValueDelimiter Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteValueDelimiter Method
Writes the JSON value delimiter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub WriteValueDelimiter()
'Usage

Dim instance As JsonWriter

instance.WriteValueDelimiter()
protected virtual void WriteValueDelimiter()
protected procedure WriteValueDelimiter(); virtual;
protected function WriteValueDelimiter();
protected: virtual void WriteValueDelimiter();
protected:
virtual void WriteValueDelimiter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteWhitespace Method (JsonWriter)

WriteWhitespace Method (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteWhitespace Method
The string of white space characters.
Writes out the given white space.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub WriteWhitespace( _
   ByVal ws As System.String _
)
'Usage

Dim instance As JsonWriter
Dim ws As System.String

instance.WriteWhitespace(ws)
public virtual void WriteWhitespace(
   System.string ws
)
public procedure WriteWhitespace(
    ws: System.String
); virtual;
public function WriteWhitespace(
   ws : System.String
);
public: virtual void WriteWhitespace(
   System.string* ws
)
public:
virtual void WriteWhitespace(
   System.String^ ws
)

Parameters

ws
The string of white space characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


JsonWriter Class Properties

JsonWriter Class Properties

Noemax.Newtonsoft.Json Namespace : JsonWriter Class

For a list of all members of this type, see JsonWriter members.

Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed.
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Public Property | DateFormatHandling | Get or set how dates are written to JSON text.
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text.
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text.
Public Property | Formatting | Indicates how JSON text output is formatted.
Public Property | Path | Gets the path of the writer.
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text.
Public Property | WriteState | Gets the state of the writer.
Top
See Also

Reference

JsonWriter Class
Noemax.Newtonsoft.Json Namespace


CloseOutput Property (JsonWriter)

CloseOutput Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : CloseOutput Property
Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CloseOutput As System.Boolean
'Usage

Dim instance As JsonWriter
Dim value As System.Boolean

instance.CloseOutput = value

value = instance.CloseOutput
public System.bool CloseOutput {get; set;}
public read-write property CloseOutput: System.Boolean;
public function get,set CloseOutput : System.boolean
public: __property System.bool get_CloseOutput();
public: __property void set_CloseOutput(
   System.bool value
);
public:
property System.bool CloseOutput {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true to close the underlying stream or System.IO.TextReader when the writer is closed; otherwise false. The default is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


Culture Property (JsonWriter)

Culture Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : Culture Property
Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Culture As System.Globalization.CultureInfo
'Usage

Dim instance As JsonWriter
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
public System.Globalization.CultureInfo Culture {get; set;}
public read-write property Culture: System.Globalization.CultureInfo;
public function get,set Culture : System.Globalization.CultureInfo
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


DateFormatHandling Property (JsonWriter)

DateFormatHandling Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : DateFormatHandling Property
Get or set how dates are written to JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateFormatHandling As DateFormatHandling
'Usage

Dim instance As JsonWriter
Dim value As DateFormatHandling

instance.DateFormatHandling = value

value = instance.DateFormatHandling
public DateFormatHandling DateFormatHandling {get; set;}
public read-write property DateFormatHandling: DateFormatHandling;
public function get,set DateFormatHandling : DateFormatHandling
public: __property DateFormatHandling get_DateFormatHandling();
public: __property void set_DateFormatHandling(
   DateFormatHandling value
);
public:
property DateFormatHandling DateFormatHandling {
   DateFormatHandling get();
   void set (    DateFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


DateFormatString Property (JsonWriter)

DateFormatString Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : DateFormatString Property
Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateFormatString As System.String
'Usage

Dim instance As JsonWriter
Dim value As System.String

instance.DateFormatString = value

value = instance.DateFormatString
public System.string DateFormatString {get; set;}
public read-write property DateFormatString: System.String;
public function get,set DateFormatString : System.String
public: __property System.string* get_DateFormatString();
public: __property void set_DateFormatString(
   System.string* value
);
public:
property System.String^ DateFormatString {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


DateTimeZoneHandling Property (JsonWriter)

DateTimeZoneHandling Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : DateTimeZoneHandling Property
Get or set how System.DateTime time zones are handling when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeZoneHandling As DateTimeZoneHandling
'Usage

Dim instance As JsonWriter
Dim value As DateTimeZoneHandling

instance.DateTimeZoneHandling = value

value = instance.DateTimeZoneHandling
public DateTimeZoneHandling DateTimeZoneHandling {get; set;}
public read-write property DateTimeZoneHandling: DateTimeZoneHandling;
public function get,set DateTimeZoneHandling : DateTimeZoneHandling
public: __property DateTimeZoneHandling get_DateTimeZoneHandling();
public: __property void set_DateTimeZoneHandling(
   DateTimeZoneHandling value
);
public:
property DateTimeZoneHandling DateTimeZoneHandling {
   DateTimeZoneHandling get();
   void set (    DateTimeZoneHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


FloatFormatHandling Property (JsonWriter)

FloatFormatHandling Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : FloatFormatHandling Property
Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property FloatFormatHandling As FloatFormatHandling
'Usage

Dim instance As JsonWriter
Dim value As FloatFormatHandling

instance.FloatFormatHandling = value

value = instance.FloatFormatHandling
public FloatFormatHandling FloatFormatHandling {get; set;}
public read-write property FloatFormatHandling: FloatFormatHandling;
public function get,set FloatFormatHandling : FloatFormatHandling
public: __property FloatFormatHandling get_FloatFormatHandling();
public: __property void set_FloatFormatHandling(
   FloatFormatHandling value
);
public:
property FloatFormatHandling FloatFormatHandling {
   FloatFormatHandling get();
   void set (    FloatFormatHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


Formatting Property (JsonWriter)

Formatting Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : Formatting Property
Indicates how JSON text output is formatted.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Formatting As Formatting
'Usage

Dim instance As JsonWriter
Dim value As Formatting

instance.Formatting = value

value = instance.Formatting
public Formatting Formatting {get; set;}
public read-write property Formatting: Formatting;
public function get,set Formatting : Formatting
public: __property Formatting get_Formatting();
public: __property void set_Formatting(
   Formatting value
);
public:
property Formatting Formatting {
   Formatting get();
   void set (    Formatting value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


Path Property (JsonWriter)

Path Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : Path Property
Gets the path of the writer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As JsonWriter
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


StringEscapeHandling Property (JsonWriter)

StringEscapeHandling Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : StringEscapeHandling Property
Get or set how strings are escaped when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StringEscapeHandling As StringEscapeHandling
'Usage

Dim instance As JsonWriter
Dim value As StringEscapeHandling

instance.StringEscapeHandling = value

value = instance.StringEscapeHandling
public StringEscapeHandling StringEscapeHandling {get; set;}
public read-write property StringEscapeHandling: StringEscapeHandling;
public function get,set StringEscapeHandling : StringEscapeHandling
public: __property StringEscapeHandling get_StringEscapeHandling();
public: __property void set_StringEscapeHandling(
   StringEscapeHandling value
);
public:
property StringEscapeHandling StringEscapeHandling {
   StringEscapeHandling get();
   void set (    StringEscapeHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


WriteState Property (JsonWriter)

WriteState Property (JsonWriter)

Noemax.Newtonsoft.Json Namespace > JsonWriter Class : WriteState Property
Gets the state of the writer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property WriteState As WriteState
'Usage

Dim instance As JsonWriter
Dim value As WriteState

value = instance.WriteState
public WriteState WriteState {get;}
public read-only property WriteState: WriteState;
public function get WriteState : WriteState
public: __property WriteState get_WriteState();
public:
property WriteState WriteState {
   WriteState get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriter Class
JsonWriter Members


JsonWriterException Class

JsonWriterException Class
Members

Noemax.Newtonsoft.Json Namespace : JsonWriterException Class
The exception thrown when an error occurs while reading Json text.
Object Model
JsonWriterException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.SerializableAttribute()>
Public Class JsonWriterException
   Inherits JsonException
'Usage

Dim instance As JsonWriterException
[System.Serializable()]
public class JsonWriterException : JsonException
public class JsonWriterException = class(JsonException)
System.SerializableAttribute()
public class JsonWriterException extends JsonException
[System.Serializable()]
public __gc class JsonWriterException : public JsonException
[System.Serializable()]
public ref class JsonWriterException : public JsonException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonWriterException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Members
Noemax.Newtonsoft.Json Namespace


JsonWriterException Class Members

JsonWriterException Class Members
Properties Methods Events

Noemax.Newtonsoft.Json Namespace : JsonWriterException Class

The following tables list the members exposed by JsonWriterException.

Public Constructors
 | Name | Description
Public Constructor | JsonWriterException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonWriterException Class
Noemax.Newtonsoft.Json Namespace


JsonWriterException Constructor

JsonWriterException Constructor

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : JsonWriterException Constructor
Overload List
Overload | Description
JsonWriterException Constructor() | Initializes a new instance of the JsonWriterException class.
JsonWriterException Constructor(String) | Initializes a new instance of the JsonWriterException class with a specified error message.
JsonWriterException Constructor(String,Exception) | Initializes a new instance of the JsonWriterException class with a specified error message and a reference to the inner exception that is the cause of this exception.
JsonWriterException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the JsonWriterException class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


JsonWriterException Constructor()

JsonWriterException Constructor()

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class > JsonWriterException Constructor : JsonWriterException Constructor()
Initializes a new instance of the JsonWriterException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonWriterException()
public JsonWriterException()
public JsonWriterException();
public function JsonWriterException();
public: JsonWriterException();
public:
JsonWriterException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members
Overload List


JsonWriterException Constructor(String)

JsonWriterException Constructor(String)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class > JsonWriterException Constructor : JsonWriterException Constructor(String)
The error message that explains the reason for the exception.
Initializes a new instance of the JsonWriterException class with a specified error message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New JsonWriterException(message)
public JsonWriterException(
   System.string message
)
public JsonWriterException(
    message: System.String
);
public function JsonWriterException(
   message : System.String
);
public: JsonWriterException(
   System.string* message
)
public:
JsonWriterException(
   System.String^ message
)

Parameters

message
The error message that explains the reason for the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members
Overload List


JsonWriterException Constructor(String,Exception)

JsonWriterException Constructor(String,Exception)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class > JsonWriterException Constructor : JsonWriterException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Initializes a new instance of the JsonWriterException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
'Usage

Dim message As System.String
Dim innerException As System.Exception

Dim instance As New JsonWriterException(message, innerException)
public JsonWriterException(
   System.string message,
   System.Exception innerException
)
public JsonWriterException(
    message: System.String;
    innerException: System.Exception
);
public function JsonWriterException(
   message : System.String,
   innerException : System.Exception
);
public: JsonWriterException(
   System.string* message,
   System.Exception* innerException
)
public:
JsonWriterException(
   System.String^ message,
   System.Exception^ innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members
Overload List


JsonWriterException Constructor(SerializationInfo,StreamingContext)

JsonWriterException Constructor(SerializationInfo,StreamingContext)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class > JsonWriterException Constructor : JsonWriterException Constructor(SerializationInfo,StreamingContext)
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Initializes a new instance of the JsonWriterException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New JsonWriterException(info, context)
public JsonWriterException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public JsonWriterException(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
public function JsonWriterException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
public: JsonWriterException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
public:
JsonWriterException(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Description
System.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization.SerializationException | The class name is null or System.Exception.HResult is zero (0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members
Overload List


JsonWriterException Class Properties

JsonWriterException Class Properties

Noemax.Newtonsoft.Json Namespace : JsonWriterException Class

For a list of all members of this type, see JsonWriterException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

JsonWriterException Class
Noemax.Newtonsoft.Json Namespace


Path Property (JsonWriterException)

Path Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : Path Property
Gets the path to the JSON where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}

Property Value

The path to the JSON where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


ConstructorHandling Enumeration

ConstructorHandling Enumeration

Noemax.Newtonsoft.Json Namespace : ConstructorHandling Enumeration
Specifies how constructors are used when initializing objects during deserialization by the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ConstructorHandling
   Inherits System.Enum
'Usage

Dim instance As ConstructorHandling
public enum ConstructorHandling : System.Enum
public enum ConstructorHandling = class(System.Enum)
public enum ConstructorHandling extends System.Enum
__value public enum ConstructorHandling : public System.Enum
public enum class ConstructorHandling : public System.Enum
Members
Member | Description
AllowNonPublicDefaultConstructor | Json.NET will use a non-public default constructor before falling back to a paramatized constructor.
Default | First attempt to use the public default constructor, then fall back to single paramatized constructor, then the non-public default constructor.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.ConstructorHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


DateFormatHandling Enumeration

DateFormatHandling Enumeration

Noemax.Newtonsoft.Json Namespace : DateFormatHandling Enumeration
Specifies how dates are formatted when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DateFormatHandling
   Inherits System.Enum
'Usage

Dim instance As DateFormatHandling
public enum DateFormatHandling : System.Enum
public enum DateFormatHandling = class(System.Enum)
public enum DateFormatHandling extends System.Enum
__value public enum DateFormatHandling : public System.Enum
public enum class DateFormatHandling : public System.Enum
Members
Member | Description
IsoDateFormat | Dates are written in the ISO 8601 format, e.g. "2012-03-21T05:40Z".
MicrosoftDateFormat | Dates are written in the Microsoft JSON format, e.g. "\/Date(1198908717056)\/".
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.DateFormatHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


DateParseHandling Enumeration

DateParseHandling Enumeration

Noemax.Newtonsoft.Json Namespace : DateParseHandling Enumeration
Specifies how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DateParseHandling
   Inherits System.Enum
'Usage

Dim instance As DateParseHandling
public enum DateParseHandling : System.Enum
public enum DateParseHandling = class(System.Enum)
public enum DateParseHandling extends System.Enum
__value public enum DateParseHandling : public System.Enum
public enum class DateParseHandling : public System.Enum
Members
Member | Description
DateTime | Date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed to DateTime.
DateTimeOffset | Date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed to DateTimeOffset.
None | Date formatted strings are not parsed to a date type and are read as strings.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.DateParseHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


DateTimeZoneHandling Enumeration

DateTimeZoneHandling Enumeration

Noemax.Newtonsoft.Json Namespace : DateTimeZoneHandling Enumeration
Specifies how to treat the time value when converting between string and System.DateTime.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum DateTimeZoneHandling
   Inherits System.Enum
'Usage

Dim instance As DateTimeZoneHandling
public enum DateTimeZoneHandling : System.Enum
public enum DateTimeZoneHandling = class(System.Enum)
public enum DateTimeZoneHandling extends System.Enum
__value public enum DateTimeZoneHandling : public System.Enum
public enum class DateTimeZoneHandling : public System.Enum
Members
Member | Description
Local | Treat as local time. If the System.DateTime object represents a Coordinated Universal Time (UTC), it is converted to the local time.
RoundtripKind | Time zone information should be preserved when converting.
Unspecified | Treat as a local time if a System.DateTime is being converted to a string. If a string is being converted to System.DateTime, convert to a local time if a time zone is specified.
Utc | Treat as a UTC. If the System.DateTime object represents a local time, it is converted to a UTC.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.DateTimeZoneHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


DefaultValueHandling Enumeration

DefaultValueHandling Enumeration
Example Example

Noemax.Newtonsoft.Json Namespace : DefaultValueHandling Enumeration
Specifies default value handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.FlagsAttribute()>
Public Enum DefaultValueHandling
   Inherits System.Enum
'Usage

Dim instance As DefaultValueHandling
[System.Flags()]
public enum DefaultValueHandling : System.Enum
public enum DefaultValueHandling = class(System.Enum)
System.FlagsAttribute()
public enum DefaultValueHandling extends System.Enum
[System.Flags()]
__value public enum DefaultValueHandling : public System.Enum
[System.Flags()]
public enum class DefaultValueHandling : public System.Enum
Members
Member | Description
Ignore | Ignore members where the member value is the same as the member's default value when serializing objects so that is is not written to JSON. This option will ignore all default values (e.g. null for objects and nullable types; 0 for integers, decimals and floating point numbers; and false for booleans). The default value ignored can be changed by placing the System.ComponentModel.DefaultValueAttribute on the property.
IgnoreAndPopulate | Ignore members where the member value is the same as the member's default value when serializing objects and sets members to their default value when deserializing.
Include | Include members where the member value is the same as the member's default value when serializing objects. Included members are written to JSON. Has no effect when deserializing.
Populate | Members with a default value but no JSON will be set to their default value when deserializing.
Example
  • C#

  • C#
    •

Inheritance Hierarchy
System.Object
   System.ValueType
      System.Enum
         Noemax.Newtonsoft.Json.DefaultValueHandling

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Noemax.Newtonsoft.Json Namespace


FloatFormatHandling Enumeration

FloatFormatHandling Enumeration

Noemax.Newtonsoft.Json Namespace : FloatFormatHandling Enumeration
Specifies float format handling options when writing special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity with JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FloatFormatHandling
   Inherits System.Enum
'Usage

Dim instance As FloatFormatHandling
public enum FloatFormatHandling : System.Enum
public enum FloatFormatHandling = class(System.Enum)
public enum FloatFormatHandling extends System.Enum
__value public enum FloatFormatHandling : public System.Enum
public enum class FloatFormatHandling : public System.Enum
Members
Member | Description
DefaultValue | Write special floating point values as the property's default value in JSON, e.g. 0.0 for a System.Double property, null for a System.Nullable`1 property.
String | Write special floating point values as strings in JSON, e.g. "NaN", "Infinity", "-Infinity".
Symbol | Write special floating point values as symbols in JSON, e.g. NaN, Infinity, -Infinity. Note that this will produce non-valid JSON.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.FloatFormatHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


FloatParseHandling Enumeration

FloatParseHandling Enumeration

Noemax.Newtonsoft.Json Namespace : FloatParseHandling Enumeration
Specifies how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum FloatParseHandling
   Inherits System.Enum
'Usage

Dim instance As FloatParseHandling
public enum FloatParseHandling : System.Enum
public enum FloatParseHandling = class(System.Enum)
public enum FloatParseHandling extends System.Enum
__value public enum FloatParseHandling : public System.Enum
public enum class FloatParseHandling : public System.Enum
Members
Member | Description
Decimal | Floating point numbers are parsed to Decimal.
Double | Floating point numbers are parsed to Double.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.FloatParseHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


Formatting Enumeration

Formatting Enumeration

Noemax.Newtonsoft.Json Namespace : Formatting Enumeration
Specifies formatting options for the JsonTextWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Formatting
   Inherits System.Enum
'Usage

Dim instance As Formatting
public enum Formatting : System.Enum
public enum Formatting = class(System.Enum)
public enum Formatting extends System.Enum
__value public enum Formatting : public System.Enum
public enum class Formatting : public System.Enum
Members
Member | Description
Indented | Causes child objects to be indented according to the JsonTextWriter.Indentation and JsonTextWriter.IndentChar settings.
None | No special formatting is applied. This is the default.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.Formatting

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


JsonToken Enumeration

JsonToken Enumeration

Noemax.Newtonsoft.Json Namespace : JsonToken Enumeration
Specifies the type of Json token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum JsonToken
   Inherits System.Enum
'Usage

Dim instance As JsonToken
public enum JsonToken : System.Enum
public enum JsonToken = class(System.Enum)
public enum JsonToken extends System.Enum
__value public enum JsonToken : public System.Enum
public enum class JsonToken : public System.Enum
Members
Member | Description
Boolean | A boolean.
Bytes | Byte data.
Comment | A comment.
Date | A Date.
EndArray | An array end token.
EndConstructor | A constructor end token.
EndObject | An object end token.
Float | A float.
Integer | An integer.
None | This is returned by the JsonReader if a JsonReader.Read method has not been called.
Null | A null token.
PropertyName | An object property name.
Raw | Raw JSON.
StartArray | An array start token.
StartConstructor | A constructor start token.
StartObject | An object start token.
String | A string.
Undefined | An undefined token.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.JsonToken

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


MemberSerialization Enumeration

MemberSerialization Enumeration

Noemax.Newtonsoft.Json Namespace : MemberSerialization Enumeration
Specifies the member serialization options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MemberSerialization
   Inherits System.Enum
'Usage

Dim instance As MemberSerialization
public enum MemberSerialization : System.Enum
public enum MemberSerialization = class(System.Enum)
public enum MemberSerialization extends System.Enum
__value public enum MemberSerialization : public System.Enum
public enum class MemberSerialization : public System.Enum
Members
Member | Description
Fields | All public and private fields are serialized. Members can be excluded using JsonIgnoreAttribute or System.NonSerializedAttribute. This member serialization mode can also be set by marking the class with System.SerializableAttribute and setting IgnoreSerializableAttribute on Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver to false.
OptIn | Only members must be marked with JsonPropertyAttribute or System.Runtime.Serialization.DataMemberAttribute are serialized. This member serialization mode can also be set by marking the class with System.Runtime.Serialization.DataContractAttribute.
OptOut | All public members are serialized by default. Members can be excluded using JsonIgnoreAttribute or System.NonSerializedAttribute. This is the default member serialization mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.MemberSerialization

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


MetadataPropertyHandling Enumeration

MetadataPropertyHandling Enumeration

Noemax.Newtonsoft.Json Namespace : MetadataPropertyHandling Enumeration
Specifies metadata property handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MetadataPropertyHandling
   Inherits System.Enum
'Usage

Dim instance As MetadataPropertyHandling
public enum MetadataPropertyHandling : System.Enum
public enum MetadataPropertyHandling = class(System.Enum)
public enum MetadataPropertyHandling extends System.Enum
__value public enum MetadataPropertyHandling : public System.Enum
public enum class MetadataPropertyHandling : public System.Enum
Members
Member | Description
Default | Read metadata properties located at the start of a JSON object.
ReadAhead | Read metadata properties located anywhere in a JSON object. Note that this setting will impact performance.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.MetadataPropertyHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


MissingMemberHandling Enumeration

MissingMemberHandling Enumeration

Noemax.Newtonsoft.Json Namespace : MissingMemberHandling Enumeration
Specifies missing member handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum MissingMemberHandling
   Inherits System.Enum
'Usage

Dim instance As MissingMemberHandling
public enum MissingMemberHandling : System.Enum
public enum MissingMemberHandling = class(System.Enum)
public enum MissingMemberHandling extends System.Enum
__value public enum MissingMemberHandling : public System.Enum
public enum class MissingMemberHandling : public System.Enum
Members
Member | Description
Error | Throw a JsonSerializationException when a missing member is encountered during deserialization.
Ignore | Ignore a missing member and do not attempt to deserialize it.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.MissingMemberHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


NullValueHandling Enumeration

NullValueHandling Enumeration
Example Example

Noemax.Newtonsoft.Json Namespace : NullValueHandling Enumeration
Specifies null value handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum NullValueHandling
   Inherits System.Enum
'Usage

Dim instance As NullValueHandling
public enum NullValueHandling : System.Enum
public enum NullValueHandling = class(System.Enum)
public enum NullValueHandling extends System.Enum
__value public enum NullValueHandling : public System.Enum
public enum class NullValueHandling : public System.Enum
Members
Member | Description
Ignore | Ignore null values when serializing and deserializing objects.
Include | Include null values when serializing and deserializing objects.
Example
  • C#

  • C#
    •

Inheritance Hierarchy
System.Object
   System.ValueType
      System.Enum
         Noemax.Newtonsoft.Json.NullValueHandling

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Noemax.Newtonsoft.Json Namespace


ObjectCreationHandling Enumeration

ObjectCreationHandling Enumeration

Noemax.Newtonsoft.Json Namespace : ObjectCreationHandling Enumeration
Specifies how object creation is handled by the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ObjectCreationHandling
   Inherits System.Enum
'Usage

Dim instance As ObjectCreationHandling
public enum ObjectCreationHandling : System.Enum
public enum ObjectCreationHandling = class(System.Enum)
public enum ObjectCreationHandling extends System.Enum
__value public enum ObjectCreationHandling : public System.Enum
public enum class ObjectCreationHandling : public System.Enum
Members
Member | Description
Auto | Reuse existing objects, create new objects when needed.
Replace | Always create new objects.
Reuse | Only reuse existing objects.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.ObjectCreationHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


PreserveReferencesHandling Enumeration

PreserveReferencesHandling Enumeration
Example Example

Noemax.Newtonsoft.Json Namespace : PreserveReferencesHandling Enumeration
Specifies reference handling options for the JsonSerializer. Note that references cannot be preserved when a value is set via a non-default constructor such as types that implement ISerializable.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.FlagsAttribute()>
Public Enum PreserveReferencesHandling
   Inherits System.Enum
'Usage

Dim instance As PreserveReferencesHandling
[System.Flags()]
public enum PreserveReferencesHandling : System.Enum
public enum PreserveReferencesHandling = class(System.Enum)
System.FlagsAttribute()
public enum PreserveReferencesHandling extends System.Enum
[System.Flags()]
__value public enum PreserveReferencesHandling : public System.Enum
[System.Flags()]
public enum class PreserveReferencesHandling : public System.Enum
Members
Member | Description
All | Preserve references when serializing.
Arrays | Preserve references when serializing into a JSON array structure.
None | Do not preserve references when serializing types.
Objects | Preserve references when serializing into a JSON object structure.
Example
  • C#

Inheritance Hierarchy
System.Object
   System.ValueType
      System.Enum
         Noemax.Newtonsoft.Json.PreserveReferencesHandling

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Noemax.Newtonsoft.Json Namespace


ReferenceLoopHandling Enumeration

ReferenceLoopHandling Enumeration

Noemax.Newtonsoft.Json Namespace : ReferenceLoopHandling Enumeration
Specifies reference loop handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum ReferenceLoopHandling
   Inherits System.Enum
'Usage

Dim instance As ReferenceLoopHandling
public enum ReferenceLoopHandling : System.Enum
public enum ReferenceLoopHandling = class(System.Enum)
public enum ReferenceLoopHandling extends System.Enum
__value public enum ReferenceLoopHandling : public System.Enum
public enum class ReferenceLoopHandling : public System.Enum
Members
Member | Description
Error | Throw a JsonSerializationException when a loop is encountered.
Ignore | Ignore loop references and do not serialize.
Serialize | Serialize loop references.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.ReferenceLoopHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


Required Enumeration

Required Enumeration

Noemax.Newtonsoft.Json Namespace : Required Enumeration
Indicating whether a property is required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum Required
   Inherits System.Enum
'Usage

Dim instance As Required
public enum Required : System.Enum
public enum Required = class(System.Enum)
public enum Required extends System.Enum
__value public enum Required : public System.Enum
public enum class Required : public System.Enum
Members
Member | Description
AllowNull | The property must be defined in JSON but can be a null value.
Always | The property must be defined in JSON and cannot be a null value.
Default | The property is not required. The default state.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.Required

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


StringEscapeHandling Enumeration

StringEscapeHandling Enumeration

Noemax.Newtonsoft.Json Namespace : StringEscapeHandling Enumeration
Specifies how strings are escaped when writing JSON text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum StringEscapeHandling
   Inherits System.Enum
'Usage

Dim instance As StringEscapeHandling
public enum StringEscapeHandling : System.Enum
public enum StringEscapeHandling = class(System.Enum)
public enum StringEscapeHandling extends System.Enum
__value public enum StringEscapeHandling : public System.Enum
public enum class StringEscapeHandling : public System.Enum
Members
Member | Description
Default | Only control characters (e.g. newline) are escaped.
EscapeHtml | HTML (<, >, &, ', ") and control characters (e.g. newline) are escaped.
EscapeNonAscii | All non-ASCII and control characters (e.g. newline) are escaped.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.StringEscapeHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


TypeNameHandling Enumeration

TypeNameHandling Enumeration

Noemax.Newtonsoft.Json Namespace : TypeNameHandling Enumeration
Specifies type name handling options for the JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.FlagsAttribute()>
Public Enum TypeNameHandling
   Inherits System.Enum
'Usage

Dim instance As TypeNameHandling
[System.Flags()]
public enum TypeNameHandling : System.Enum
public enum TypeNameHandling = class(System.Enum)
System.FlagsAttribute()
public enum TypeNameHandling extends System.Enum
[System.Flags()]
__value public enum TypeNameHandling : public System.Enum
[System.Flags()]
public enum class TypeNameHandling : public System.Enum
Members
Member | Description
All | Always include the .NET type name when serializing.
Arrays | Include the .NET type name when serializing into a JSON array structure.
Auto | Include the .NET type name when the type of the object being serialized is not the same as its declared type.
None | Do not include the .NET type name when serializing types.
Objects | Include the .NET type name when serializing into a JSON object structure.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.TypeNameHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


WriteState Enumeration

WriteState Enumeration

Noemax.Newtonsoft.Json Namespace : WriteState Enumeration
Specifies the state of the JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum WriteState
   Inherits System.Enum
'Usage

Dim instance As WriteState
public enum WriteState : System.Enum
public enum WriteState = class(System.Enum)
public enum WriteState extends System.Enum
__value public enum WriteState : public System.Enum
public enum class WriteState : public System.Enum
Members
Member | Description
Array | A array is being written.
Closed | The JsonWriter.Close method has been called.
Constructor | A constructor is being written.
Error | An exception has been thrown, which has left the JsonWriter in an invalid state. You may call the JsonWriter.Close method to put the JsonWriter in the Closed state. Any other JsonWriter method calls results in an System.InvalidOperationException being thrown.
Object | An object is being written.
Property | A property is being written.
Start | A write method has not been called.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.WriteState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json Namespace


IJsonLineInfo Interface

IJsonLineInfo Interface
Members

Noemax.Newtonsoft.Json Namespace : IJsonLineInfo Interface
Provides an interface to enable a class to return line and position information.
Object Model
IJsonLineInfo Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IJsonLineInfo
'Usage

Dim instance As IJsonLineInfo
public interface IJsonLineInfo
public interface IJsonLineInfo
public interface IJsonLineInfo
public __gc __interface IJsonLineInfo
public interface class IJsonLineInfo
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJsonLineInfo Members
Noemax.Newtonsoft.Json Namespace


IJsonLineInfo Interface Members

IJsonLineInfo Interface Members
Properties Methods

Noemax.Newtonsoft.Json Namespace : IJsonLineInfo Interface

The following tables list the members exposed by IJsonLineInfo.

Public Properties
 | Name | Description
Property | LineNumber | Gets the current line number.
Property | LinePosition | Gets the current line position.
Top
Public Methods
 | Name | Description
Method | HasLineInfo | Gets a value indicating whether the class can return line information.
Top
See Also

Reference

IJsonLineInfo Interface
Noemax.Newtonsoft.Json Namespace


IJsonLineInfo Interface Methods

IJsonLineInfo Interface Methods

Noemax.Newtonsoft.Json Namespace : IJsonLineInfo Interface

For a list of all members of this type, see IJsonLineInfo members.

Public Methods
 | Name | Description
Method | HasLineInfo | Gets a value indicating whether the class can return line information.
Top
See Also

Reference

IJsonLineInfo Interface
Noemax.Newtonsoft.Json Namespace


HasLineInfo Method (IJsonLineInfo)

HasLineInfo Method (IJsonLineInfo)

Noemax.Newtonsoft.Json Namespace > IJsonLineInfo Interface : HasLineInfo Method
Gets a value indicating whether the class can return line information.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function HasLineInfo() As System.Boolean
'Usage

Dim instance As IJsonLineInfo
Dim value As System.Boolean

value = instance.HasLineInfo()
System.bool HasLineInfo()
function HasLineInfo(): System.Boolean;
function HasLineInfo() : System.boolean;
System.bool HasLineInfo();
System.bool HasLineInfo();

Return Value

true if LineNumber and LinePosition can be provided; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJsonLineInfo Interface
IJsonLineInfo Members


IJsonLineInfo Interface Properties

IJsonLineInfo Interface Properties

Noemax.Newtonsoft.Json Namespace : IJsonLineInfo Interface

For a list of all members of this type, see IJsonLineInfo members.

Public Properties
 | Name | Description
Property | LineNumber | Gets the current line number.
Property | LinePosition | Gets the current line position.
Top
See Also

Reference

IJsonLineInfo Interface
Noemax.Newtonsoft.Json Namespace


LineNumber Property (IJsonLineInfo)

LineNumber Property (IJsonLineInfo)

Noemax.Newtonsoft.Json Namespace > IJsonLineInfo Interface : LineNumber Property
Gets the current line number.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property LineNumber As System.Integer
'Usage

Dim instance As IJsonLineInfo
Dim value As System.Integer

value = instance.LineNumber
System.int LineNumber {get;}
read-only property LineNumber: System.Integer;
function get LineNumber : System.int
__property System.int get_LineNumber();
property System.int LineNumber {
   System.int get();
}

Property Value

The current line number or 0 if no line information is available (for example, HasLineInfo returns false).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJsonLineInfo Interface
IJsonLineInfo Members


LinePosition Property (IJsonLineInfo)

LinePosition Property (IJsonLineInfo)

Noemax.Newtonsoft.Json Namespace > IJsonLineInfo Interface : LinePosition Property
Gets the current line position.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property LinePosition As System.Integer
'Usage

Dim instance As IJsonLineInfo
Dim value As System.Integer

value = instance.LinePosition
System.int LinePosition {get;}
read-only property LinePosition: System.Integer;
function get LinePosition : System.int
__property System.int get_LinePosition();
property System.int LinePosition {
   System.int get();
}

Property Value

The current line position or 0 if no line information is available (for example, HasLineInfo returns false).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJsonLineInfo Interface
IJsonLineInfo Members


Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BsonObjectId | Represents a BSON Oid (object id).
Class | BsonReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | BsonWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating JSON data.
See Also

Reference

Noemax.WebSockets Assembly


BsonObjectId Class

BsonObjectId Class
Members

Noemax.Newtonsoft.Json.Bson Namespace : BsonObjectId Class
Represents a BSON Oid (object id).
Object Model
BsonObjectId Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BsonObjectId
'Usage

Dim instance As BsonObjectId
public class BsonObjectId
public class BsonObjectId
public class BsonObjectId
public __gc class BsonObjectId
public ref class BsonObjectId
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Bson.BsonObjectId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectId Members
Noemax.Newtonsoft.Json.Bson Namespace


BsonObjectId Class Members

BsonObjectId Class Members
Properties

Noemax.Newtonsoft.Json.Bson Namespace : BsonObjectId Class

The following tables list the members exposed by BsonObjectId.

Public Constructors
 | Name | Description
Public Constructor | BsonObjectId Constructor | Initializes a new instance of the BsonObjectId class.
Top
Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value of the Oid.
Top
See Also

Reference

BsonObjectId Class
Noemax.Newtonsoft.Json.Bson Namespace


BsonObjectId Constructor

BsonObjectId Constructor

Noemax.Newtonsoft.Json.Bson Namespace > BsonObjectId Class : BsonObjectId Constructor
The Oid value.
Initializes a new instance of the BsonObjectId class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value() As System.Byte _
)
'Usage

Dim value() As System.Byte

Dim instance As New BsonObjectId(value)
public BsonObjectId(
   System.byte[] value
)
public BsonObjectId(
    value: System.Bytearray of
);
public function BsonObjectId(
   value : System.byte[]
);
public: BsonObjectId(
   System.byte[]* value
)
public:
BsonObjectId(
   System.array<byte>^ value
)

Parameters

value
The Oid value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectId Class
BsonObjectId Members


BsonObjectId Class Properties

BsonObjectId Class Properties

Noemax.Newtonsoft.Json.Bson Namespace : BsonObjectId Class

For a list of all members of this type, see BsonObjectId members.

Public Properties
 | Name | Description
Public Property | Value | Gets or sets the value of the Oid.
Top
See Also

Reference

BsonObjectId Class
Noemax.Newtonsoft.Json.Bson Namespace


Value Property (BsonObjectId)

Value Property (BsonObjectId)

Noemax.Newtonsoft.Json.Bson Namespace > BsonObjectId Class : Value Property
Gets or sets the value of the Oid.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As System.Byte()
'Usage

Dim instance As BsonObjectId
Dim value() As System.Byte

value = instance.Value
public System.byte[] Value {get;}
public read-only property Value: System.array of Byte;
public function get Value : System.byte[]
public: __property System.byte[]* get_Value();
public:
property System.array<byte>^ Value {
   System.array<byte>^ get();
}

Property Value

The value of the Oid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectId Class
BsonObjectId Members


BsonReader Class

BsonReader Class
Members

Noemax.Newtonsoft.Json.Bson Namespace : BsonReader Class
Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Object Model
BsonReader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BsonReader
   Inherits Noemax.Newtonsoft.Json.JsonReader
'Usage

Dim instance As BsonReader
public class BsonReader : Noemax.Newtonsoft.Json.JsonReader
public class BsonReader = class(Noemax.Newtonsoft.Json.JsonReader)
public class BsonReader extends Noemax.Newtonsoft.Json.JsonReader
public __gc class BsonReader : public Noemax.Newtonsoft.Json.JsonReader
public ref class BsonReader : public Noemax.Newtonsoft.Json.JsonReader
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Members
Noemax.Newtonsoft.Json.Bson Namespace


BsonReader Class Members

BsonReader Class Members
Properties Methods

Noemax.Newtonsoft.Json.Bson Namespace : BsonReader Class

The following tables list the members exposed by BsonReader.

Public Constructors
 | Name | Description
Public Constructor | BsonReader Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeKindHandling | Gets or sets the System.DateTimeKind used when reading System.DateTime values from BSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | JsonNet35BinaryCompatibility | Gets or sets a value indicating whether binary data reading should compatible with incorrect Json.NET 3.5 written binary.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a Noemax.Newtonsoft.Json.JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Gets the path of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ReadRootValueAsArray | Gets or sets a value indicating whether the root object will be read as a JSON array.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Changes the Noemax.Newtonsoft.Json.JsonReader.State to Closed.
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

BsonReader Class
Noemax.Newtonsoft.Json.Bson Namespace


BsonReader Constructor

BsonReader Constructor

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : BsonReader Constructor
Overload List
Overload | Description
BsonReader Constructor(Stream) | Initializes a new instance of the BsonReader class.
BsonReader Constructor(BinaryReader) | Initializes a new instance of the BsonReader class.
BsonReader Constructor(Stream,Boolean,DateTimeKind) | Initializes a new instance of the BsonReader class.
BsonReader Constructor(BinaryReader,Boolean,DateTimeKind) | Initializes a new instance of the BsonReader class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members


BsonReader Constructor(Stream)

BsonReader Constructor(Stream)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class > BsonReader Constructor : BsonReader Constructor(Stream)
The stream.
Initializes a new instance of the BsonReader class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim stream As System.IO.Stream

Dim instance As New BsonReader(stream)
public BsonReader(
   System.IO.Stream stream
)
public BsonReader(
    stream: System.IO.Stream
);
public function BsonReader(
   stream : System.IO.Stream
);
public: BsonReader(
   System.IO.Stream* stream
)
public:
BsonReader(
   System.IO.Stream^ stream
)

Parameters

stream
The stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Overload List


BsonReader Constructor(BinaryReader)

BsonReader Constructor(BinaryReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class > BsonReader Constructor : BsonReader Constructor(BinaryReader)
The reader.
Initializes a new instance of the BsonReader class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal reader As System.IO.BinaryReader _
)
'Usage

Dim reader As System.IO.BinaryReader

Dim instance As New BsonReader(reader)
public BsonReader(
   System.IO.BinaryReader reader
)
public BsonReader(
    reader: System.IO.BinaryReader
);
public function BsonReader(
   reader : System.IO.BinaryReader
);
public: BsonReader(
   System.IO.BinaryReader* reader
)
public:
BsonReader(
   System.IO.BinaryReader^ reader
)

Parameters

reader
The reader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Overload List


BsonReader Constructor(Stream,Boolean,DateTimeKind)

BsonReader Constructor(Stream,Boolean,DateTimeKind)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class > BsonReader Constructor : BsonReader Constructor(Stream,Boolean,DateTimeKind)
The stream.
if set to true the root object will be read as a JSON array.
The System.DateTimeKind used when reading System.DateTime values from BSON.
Initializes a new instance of the BsonReader class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As System.IO.Stream, _
   ByVal readRootValueAsArray As System.Boolean, _
   ByVal dateTimeKindHandling As System.DateTimeKind _
)
'Usage

Dim stream As System.IO.Stream
Dim readRootValueAsArray As System.Boolean
Dim dateTimeKindHandling As System.DateTimeKind

Dim instance As New BsonReader(stream, readRootValueAsArray, dateTimeKindHandling)
public BsonReader(
   System.IO.Stream stream,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)
public BsonReader(
    stream: System.IO.Stream;
    readRootValueAsArray: System.Boolean;
    dateTimeKindHandling: System.DateTimeKind
);
public function BsonReader(
   stream : System.IO.Stream,
   readRootValueAsArray : System.boolean,
   dateTimeKindHandling : System.DateTimeKind
);
public: BsonReader(
   System.IO.Stream* stream,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)
public:
BsonReader(
   System.IO.Stream^ stream,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)

Parameters

stream
The stream.
readRootValueAsArray
if set to true the root object will be read as a JSON array.
dateTimeKindHandling
The System.DateTimeKind used when reading System.DateTime values from BSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Overload List


BsonReader Constructor(BinaryReader,Boolean,DateTimeKind)

BsonReader Constructor(BinaryReader,Boolean,DateTimeKind)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class > BsonReader Constructor : BsonReader Constructor(BinaryReader,Boolean,DateTimeKind)
The reader.
if set to true the root object will be read as a JSON array.
The System.DateTimeKind used when reading System.DateTime values from BSON.
Initializes a new instance of the BsonReader class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal reader As System.IO.BinaryReader, _
   ByVal readRootValueAsArray As System.Boolean, _
   ByVal dateTimeKindHandling As System.DateTimeKind _
)
'Usage

Dim reader As System.IO.BinaryReader
Dim readRootValueAsArray As System.Boolean
Dim dateTimeKindHandling As System.DateTimeKind

Dim instance As New BsonReader(reader, readRootValueAsArray, dateTimeKindHandling)
public BsonReader(
   System.IO.BinaryReader reader,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)
public BsonReader(
    reader: System.IO.BinaryReader;
    readRootValueAsArray: System.Boolean;
    dateTimeKindHandling: System.DateTimeKind
);
public function BsonReader(
   reader : System.IO.BinaryReader,
   readRootValueAsArray : System.boolean,
   dateTimeKindHandling : System.DateTimeKind
);
public: BsonReader(
   System.IO.BinaryReader* reader,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)
public:
BsonReader(
   System.IO.BinaryReader^ reader,
   System.bool readRootValueAsArray,
   System.DateTimeKind dateTimeKindHandling
)

Parameters

reader
The reader.
readRootValueAsArray
if set to true the root object will be read as a JSON array.
dateTimeKindHandling
The System.DateTimeKind used when reading System.DateTime values from BSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Overload List


BsonReader Class Methods

BsonReader Class Methods

Noemax.Newtonsoft.Json.Bson Namespace : BsonReader Class

For a list of all members of this type, see BsonReader members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Changes the Noemax.Newtonsoft.Json.JsonReader.State to Closed.
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

BsonReader Class
Noemax.Newtonsoft.Json.Bson Namespace


Close Method (BsonReader)

Close Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : Close Method
Changes the Noemax.Newtonsoft.Json.JsonReader.State to Closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As BsonReader

instance.Close()
public override void Close()
public procedure Close(); override;
public override function Close();
public: void Close(); override
public:
void Close(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in Close


Read Method (BsonReader)

Read Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : Read Method
Reads the next JSON token from the stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Read() As System.Boolean
'Usage

Dim instance As BsonReader
Dim value As System.Boolean

value = instance.Read()
public override System.bool Read()
public function Read(): System.Boolean; override;
public override function Read() : System.boolean;
public: System.bool Read(); override
public:
System.bool Read(); override

Return Value

true if the next token was read successfully; false if there are no more tokens to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in Read


ReadAsBytes Method (BsonReader)

ReadAsBytes Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsBytes Method
Reads the next JSON token from the stream as a Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsBytes() As System.Byte()
'Usage

Dim instance As BsonReader
Dim value() As System.Byte

value = instance.ReadAsBytes()
public override System.byte[] ReadAsBytes()
public function ReadAsBytes(): System.array of Byte; override;
public override function ReadAsBytes() : System.byte[];
public: System.byte[]* ReadAsBytes(); override
public:
System.array<byte>^ ReadAsBytes(); override

Return Value

A Byte[] or a null reference if the next JSON token is null. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsBytes


ReadAsDateTime Method (BsonReader)

ReadAsDateTime Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsDateTime Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTime() As System.Nullable(Of Date)
'Usage

Dim instance As BsonReader
Dim value As System.Nullable(Of Date)

value = instance.ReadAsDateTime()
public override System.Nullable<DateTime> ReadAsDateTime()
public function ReadAsDateTime(): System.Nullable; override;
public override function ReadAsDateTime() : System.Nullable;
public: System.Nullable<DateTime> ReadAsDateTime(); override
public:
System.Nullable<DateTime> ReadAsDateTime(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsDateTime


ReadAsDateTimeOffset Method (BsonReader)

ReadAsDateTimeOffset Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsDateTimeOffset Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTimeOffset() As System.Nullable(Of DateTimeOffset)
'Usage

Dim instance As BsonReader
Dim value As System.Nullable(Of DateTimeOffset)

value = instance.ReadAsDateTimeOffset()
public override System.Nullable<DateTimeOffset> ReadAsDateTimeOffset()
public function ReadAsDateTimeOffset(): System.Nullable; override;
public override function ReadAsDateTimeOffset() : System.Nullable;
public: System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override
public:
System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsDateTimeOffset


ReadAsDecimal Method (BsonReader)

ReadAsDecimal Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsDecimal Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDecimal() As System.Nullable(Of Decimal)
'Usage

Dim instance As BsonReader
Dim value As System.Nullable(Of Decimal)

value = instance.ReadAsDecimal()
public override System.Nullable<decimal> ReadAsDecimal()
public function ReadAsDecimal(): System.Nullable; override;
public override function ReadAsDecimal() : System.Nullable;
public: System.Nullable<decimal> ReadAsDecimal(); override
public:
System.Nullable<decimal> ReadAsDecimal(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsDecimal


ReadAsInt32 Method (BsonReader)

ReadAsInt32 Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsInt32 Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsInt32() As System.Nullable(Of Integer)
'Usage

Dim instance As BsonReader
Dim value As System.Nullable(Of Integer)

value = instance.ReadAsInt32()
public override System.Nullable<int> ReadAsInt32()
public function ReadAsInt32(): System.Nullable; override;
public override function ReadAsInt32() : System.Nullable;
public: System.Nullable<int> ReadAsInt32(); override
public:
System.Nullable<int> ReadAsInt32(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsInt32


ReadAsString Method (BsonReader)

ReadAsString Method (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadAsString Method
Reads the next JSON token from the stream as a System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsString() As System.String
'Usage

Dim instance As BsonReader
Dim value As System.String

value = instance.ReadAsString()
public override System.string ReadAsString()
public function ReadAsString(): System.String; override;
public override function ReadAsString() : System.String;
public: System.string* ReadAsString(); override
public:
System.String^ ReadAsString(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members
Base Implementation in ReadAsString


BsonReader Class Properties

BsonReader Class Properties

Noemax.Newtonsoft.Json.Bson Namespace : BsonReader Class

For a list of all members of this type, see BsonReader members.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeKindHandling | Gets or sets the System.DateTimeKind used when reading System.DateTime values from BSON.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | JsonNet35BinaryCompatibility | Gets or sets a value indicating whether binary data reading should compatible with incorrect Json.NET 3.5 written binary.
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a Noemax.Newtonsoft.Json.JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Gets the path of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ReadRootValueAsArray | Gets or sets a value indicating whether the root object will be read as a JSON array.
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

BsonReader Class
Noemax.Newtonsoft.Json.Bson Namespace


DateTimeKindHandling Property (BsonReader)

DateTimeKindHandling Property (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : DateTimeKindHandling Property
Gets or sets the System.DateTimeKind used when reading System.DateTime values from BSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeKindHandling As System.DateTimeKind
'Usage

Dim instance As BsonReader
Dim value As System.DateTimeKind

instance.DateTimeKindHandling = value

value = instance.DateTimeKindHandling
public System.DateTimeKind DateTimeKindHandling {get; set;}
public read-write property DateTimeKindHandling: System.DateTimeKind;
public function get,set DateTimeKindHandling : System.DateTimeKind
public: __property System.DateTimeKind get_DateTimeKindHandling();
public: __property void set_DateTimeKindHandling(
   System.DateTimeKind value
);
public:
property System.DateTimeKind DateTimeKindHandling {
   System.DateTimeKind get();
   void set (    System.DateTimeKind value);
}

Property Value

The System.DateTimeKind used when reading System.DateTime values from BSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members


JsonNet35BinaryCompatibility Property (BsonReader)

JsonNet35BinaryCompatibility Property (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : JsonNet35BinaryCompatibility Property
Gets or sets a value indicating whether binary data reading should compatible with incorrect Json.NET 3.5 written binary.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("JsonNet35BinaryCompatibility will be removed in a future version of Json.NET.")>
Public Property JsonNet35BinaryCompatibility As System.Boolean
'Usage

Dim instance As BsonReader
Dim value As System.Boolean

instance.JsonNet35BinaryCompatibility = value

value = instance.JsonNet35BinaryCompatibility
[System.Obsolete("JsonNet35BinaryCompatibility will be removed in a future version of Json.NET.")]
public System.bool JsonNet35BinaryCompatibility {get; set;}
public read-write property JsonNet35BinaryCompatibility: System.Boolean;
System.ObsoleteAttribute("JsonNet35BinaryCompatibility will be removed in a future version of Json.NET.")
public function get,set JsonNet35BinaryCompatibility : System.boolean
[System.Obsolete("JsonNet35BinaryCompatibility will be removed in a future version of Json.NET.")]
public: __property System.bool get_JsonNet35BinaryCompatibility();
public: __property void set_JsonNet35BinaryCompatibility(
   System.bool value
);
[System.Obsolete("JsonNet35BinaryCompatibility will be removed in a future version of Json.NET.")]
public:
property System.bool JsonNet35BinaryCompatibility {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if binary data reading will be compatible with incorrect Json.NET 3.5 written binary; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members


ReadRootValueAsArray Property (BsonReader)

ReadRootValueAsArray Property (BsonReader)

Noemax.Newtonsoft.Json.Bson Namespace > BsonReader Class : ReadRootValueAsArray Property
Gets or sets a value indicating whether the root object will be read as a JSON array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReadRootValueAsArray As System.Boolean
'Usage

Dim instance As BsonReader
Dim value As System.Boolean

instance.ReadRootValueAsArray = value

value = instance.ReadRootValueAsArray
public System.bool ReadRootValueAsArray {get; set;}
public read-write property ReadRootValueAsArray: System.Boolean;
public function get,set ReadRootValueAsArray : System.boolean
public: __property System.bool get_ReadRootValueAsArray();
public: __property void set_ReadRootValueAsArray(
   System.bool value
);
public:
property System.bool ReadRootValueAsArray {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the root object will be read as a JSON array; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonReader Class
BsonReader Members


BsonWriter Class

BsonWriter Class
Members

Noemax.Newtonsoft.Json.Bson Namespace : BsonWriter Class
Represents a writer that provides a fast, non-cached, forward-only way of generating JSON data.
Object Model
BsonWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BsonWriter
   Inherits Noemax.Newtonsoft.Json.JsonWriter
'Usage

Dim instance As BsonWriter
public class BsonWriter : Noemax.Newtonsoft.Json.JsonWriter
public class BsonWriter = class(Noemax.Newtonsoft.Json.JsonWriter)
public class BsonWriter extends Noemax.Newtonsoft.Json.JsonWriter
public __gc class BsonWriter : public Noemax.Newtonsoft.Json.JsonWriter
public ref class BsonWriter : public Noemax.Newtonsoft.Json.JsonWriter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Members
Noemax.Newtonsoft.Json.Bson Namespace


BsonWriter Class Members

BsonWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Bson Namespace : BsonWriter Class

The following tables list the members exposed by BsonWriter.

Public Constructors
 | Name | Description
Public Constructor | BsonWriter Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeKindHandling | Gets or sets the System.DateTimeKind used when writing System.DateTime values to BSON. When set to System.DateTimeKind.Unspecified no conversion will occur.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the end.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WriteObjectId | Writes a Byte[] value that represents a BSON object id.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Overridden. Writes raw JSON where a value is expected and updates the writer's state.
Public Method | WriteRegex | Writes a BSON regex.
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current Noemax.Newtonsoft.Json.JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Writes out the given white space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Writes indent characters. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndentSpace | Writes an indent space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

BsonWriter Class
Noemax.Newtonsoft.Json.Bson Namespace


BsonWriter Constructor

BsonWriter Constructor

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : BsonWriter Constructor
Overload List
Overload | Description
BsonWriter Constructor(Stream) | Initializes a new instance of the BsonWriter class.
BsonWriter Constructor(BinaryWriter) | Initializes a new instance of the BsonWriter class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members


BsonWriter Constructor(Stream)

BsonWriter Constructor(Stream)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > BsonWriter Constructor : BsonWriter Constructor(Stream)
The stream.
Initializes a new instance of the BsonWriter class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal stream As System.IO.Stream _
)
'Usage

Dim stream As System.IO.Stream

Dim instance As New BsonWriter(stream)
public BsonWriter(
   System.IO.Stream stream
)
public BsonWriter(
    stream: System.IO.Stream
);
public function BsonWriter(
   stream : System.IO.Stream
);
public: BsonWriter(
   System.IO.Stream* stream
)
public:
BsonWriter(
   System.IO.Stream^ stream
)

Parameters

stream
The stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List


BsonWriter Constructor(BinaryWriter)

BsonWriter Constructor(BinaryWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > BsonWriter Constructor : BsonWriter Constructor(BinaryWriter)
The writer.
Initializes a new instance of the BsonWriter class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal writer As System.IO.BinaryWriter _
)
'Usage

Dim writer As System.IO.BinaryWriter

Dim instance As New BsonWriter(writer)
public BsonWriter(
   System.IO.BinaryWriter writer
)
public BsonWriter(
    writer: System.IO.BinaryWriter
);
public function BsonWriter(
   writer : System.IO.BinaryWriter
);
public: BsonWriter(
   System.IO.BinaryWriter* writer
)
public:
BsonWriter(
   System.IO.BinaryWriter^ writer
)

Parameters

writer
The writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List


BsonWriter Class Methods

BsonWriter Class Methods

Noemax.Newtonsoft.Json.Bson Namespace : BsonWriter Class

For a list of all members of this type, see BsonWriter members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the end.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WriteObjectId | Writes a Byte[] value that represents a BSON object id.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Overridden. Writes raw JSON where a value is expected and updates the writer's state.
Public Method | WriteRegex | Writes a BSON regex.
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current Noemax.Newtonsoft.Json.JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Writes out the given white space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Writes indent characters. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndentSpace | Writes an indent space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

BsonWriter Class
Noemax.Newtonsoft.Json.Bson Namespace


Close Method (BsonWriter)

Close Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : Close Method
Closes this stream and the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As BsonWriter

instance.Close()
public override void Close()
public procedure Close(); override;
public override function Close();
public: void Close(); override
public:
void Close(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in Close


Flush Method (BsonWriter)

Flush Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : Flush Method
Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flush()
'Usage

Dim instance As BsonWriter

instance.Flush()
public override void Flush()
public procedure Flush(); override;
public override function Flush();
public: void Flush(); override
public:
void Flush(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in Flush


WriteComment Method (BsonWriter)

WriteComment Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteComment Method
Text to place inside the comment.
Writes out a comment /*...*/ containing the specified text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteComment( _
   ByVal text As System.String _
)
'Usage

Dim instance As BsonWriter
Dim text As System.String

instance.WriteComment(text)
public override void WriteComment(
   System.string text
)
public procedure WriteComment(
    text: System.String
); override;
public override function WriteComment(
   text : System.String
);
public: void WriteComment(
   System.string* text
) override
public:
void WriteComment(
   System.String^ text
) override

Parameters

text
Text to place inside the comment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteComment


WriteEnd Method (BsonWriter)

WriteEnd Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteEnd Method
Writes the end.
Overload List
Overload | Description
WriteEnd(JsonToken) | Writes the end.
WriteEnd() | Writes the end of the current Json object or array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteEnd


WriteEnd(JsonToken) Method

WriteEnd(JsonToken) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteEnd Method : WriteEnd(JsonToken) Method
The token.
Writes the end.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub WriteEnd( _
   ByVal token As JsonToken _
)
'Usage

Dim instance As BsonWriter
Dim token As JsonToken

instance.WriteEnd(token)
protected override void WriteEnd(
   JsonToken token
)
protected procedure WriteEnd(
    token: JsonToken
); override;
protected override function WriteEnd(
   token : JsonToken
);
protected: void WriteEnd(
   JsonToken token
) override
protected:
void WriteEnd(
   JsonToken token
) override

Parameters

token
The token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteEnd(JsonToken)


WriteNull Method (BsonWriter)

WriteNull Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteNull Method
Writes a null value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteNull()
'Usage

Dim instance As BsonWriter

instance.WriteNull()
public override void WriteNull()
public procedure WriteNull(); override;
public override function WriteNull();
public: void WriteNull(); override
public:
void WriteNull(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteNull


WriteObjectId Method (BsonWriter)

WriteObjectId Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteObjectId Method
The Object ID value to write.
Writes a Byte[] value that represents a BSON object id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub WriteObjectId( _
   ByVal value() As System.Byte _
)
'Usage

Dim instance As BsonWriter
Dim value() As System.Byte

instance.WriteObjectId(value)
public void WriteObjectId(
   System.byte[] value
)
public procedure WriteObjectId(
    value: System.Bytearray of
);
public function WriteObjectId(
   value : System.byte[]
);
public: void WriteObjectId(
   System.byte[]* value
)
public:
void WriteObjectId(
   System.array<byte>^ value
)

Parameters

value
The Object ID value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members


WritePropertyName Method (BsonWriter)

WritePropertyName Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WritePropertyName Method
Writes the property name of a name/value pair on a Json object.
Overload List
Overload | Description
WritePropertyName(String) | Writes the property name of a name/value pair on a Json object.
WritePropertyName(String,Boolean) | Writes the property name of a name/value pair on a JSON object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WritePropertyName


WritePropertyName(String) Method

WritePropertyName(String) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WritePropertyName Method : WritePropertyName(String) Method
The name of the property.
Writes the property name of a name/value pair on a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WritePropertyName( _
   ByVal name As System.String _
)
'Usage

Dim instance As BsonWriter
Dim name As System.String

instance.WritePropertyName(name)
public override void WritePropertyName(
   System.string name
)
public procedure WritePropertyName(
    name: System.String
); override;
public override function WritePropertyName(
   name : System.String
);
public: void WritePropertyName(
   System.string* name
) override
public:
void WritePropertyName(
   System.String^ name
) override

Parameters

name
The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WritePropertyName(String)


WriteRaw Method (BsonWriter)

WriteRaw Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteRaw Method
The raw JSON to write.
Writes raw JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteRaw( _
   ByVal json As System.String _
)
'Usage

Dim instance As BsonWriter
Dim json As System.String

instance.WriteRaw(json)
public override void WriteRaw(
   System.string json
)
public procedure WriteRaw(
    json: System.String
); override;
public override function WriteRaw(
   json : System.String
);
public: void WriteRaw(
   System.string* json
) override
public:
void WriteRaw(
   System.String^ json
) override

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteRaw


WriteRawValue Method (BsonWriter)

WriteRawValue Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteRawValue Method
The raw JSON to write.
Writes raw JSON where a value is expected and updates the writer's state.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteRawValue( _
   ByVal json As System.String _
)
'Usage

Dim instance As BsonWriter
Dim json As System.String

instance.WriteRawValue(json)
public override void WriteRawValue(
   System.string json
)
public procedure WriteRawValue(
    json: System.String
); override;
public override function WriteRawValue(
   json : System.String
);
public: void WriteRawValue(
   System.string* json
) override
public:
void WriteRawValue(
   System.String^ json
) override

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteRawValue


WriteRegex Method (BsonWriter)

WriteRegex Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteRegex Method
The regex pattern.
The regex options.
Writes a BSON regex.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub WriteRegex( _
   ByVal pattern As System.String, _
   ByVal options As System.String _
)
'Usage

Dim instance As BsonWriter
Dim pattern As System.String
Dim options As System.String

instance.WriteRegex(pattern, options)
public void WriteRegex(
   System.string pattern,
   System.string options
)
public procedure WriteRegex(
    pattern: System.String;
    options: System.String
);
public function WriteRegex(
   pattern : System.String,
   options : System.String
);
public: void WriteRegex(
   System.string* pattern,
   System.string* options
)
public:
void WriteRegex(
   System.String^ pattern,
   System.String^ options
)

Parameters

pattern
The regex pattern.
options
The regex options.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members


WriteStartArray Method (BsonWriter)

WriteStartArray Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteStartArray Method
Writes the beginning of a Json array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartArray()
'Usage

Dim instance As BsonWriter

instance.WriteStartArray()
public override void WriteStartArray()
public procedure WriteStartArray(); override;
public override function WriteStartArray();
public: void WriteStartArray(); override
public:
void WriteStartArray(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteStartArray


WriteStartConstructor Method (BsonWriter)

WriteStartConstructor Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteStartConstructor Method
The name of the constructor.
Writes the start of a constructor with the given name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartConstructor( _
   ByVal name As System.String _
)
'Usage

Dim instance As BsonWriter
Dim name As System.String

instance.WriteStartConstructor(name)
public override void WriteStartConstructor(
   System.string name
)
public procedure WriteStartConstructor(
    name: System.String
); override;
public override function WriteStartConstructor(
   name : System.String
);
public: void WriteStartConstructor(
   System.string* name
) override
public:
void WriteStartConstructor(
   System.String^ name
) override

Parameters

name
The name of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteStartConstructor


WriteStartObject Method (BsonWriter)

WriteStartObject Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteStartObject Method
Writes the beginning of a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartObject()
'Usage

Dim instance As BsonWriter

instance.WriteStartObject()
public override void WriteStartObject()
public procedure WriteStartObject(); override;
public override function WriteStartObject();
public: void WriteStartObject(); override
public:
void WriteStartObject(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteStartObject


WriteUndefined Method (BsonWriter)

WriteUndefined Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteUndefined Method
Writes an undefined value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteUndefined()
'Usage

Dim instance As BsonWriter

instance.WriteUndefined()
public override void WriteUndefined()
public procedure WriteUndefined(); override;
public override function WriteUndefined();
public: void WriteUndefined(); override
public:
void WriteUndefined(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteUndefined


WriteValue Method (BsonWriter)

WriteValue Method (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : WriteValue Method
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Overload List
Overload | Description
WriteValue(Object) | Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
WriteValue(String) | Writes a System.String value.
WriteValue(Int32) | Writes a System.Int32 value.
WriteValue(UInt32) | Writes a System.UInt32 value.
WriteValue(Int64) | Writes a System.Int64 value.
WriteValue(UInt64) | Writes a System.UInt64 value.
WriteValue(Single) | Writes a System.Single value.
WriteValue(Double) | Writes a System.Double value.
WriteValue(Boolean) | Writes a System.Boolean value.
WriteValue(Int16) | Writes a System.Int16 value.
WriteValue(UInt16) | Writes a System.UInt16 value.
WriteValue(Char) | Writes a System.Char value.
WriteValue(Byte) | Writes a System.Byte value.
WriteValue(SByte) | Writes a System.SByte value.
WriteValue(Decimal) | Writes a System.Decimal value.
WriteValue(DateTime) | Writes a System.DateTime value.
WriteValue(DateTimeOffset) | Writes a System.DateTimeOffset value.
WriteValue(Byte[]) | Writes a Byte[] value.
WriteValue(Guid) | Writes a System.Guid value.
WriteValue(TimeSpan) | Writes a System.TimeSpan value.
WriteValue(Uri) | Writes a System.Uri value.
WriteValue(Nullable<Int32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Single>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Double>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Boolean>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Char>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Byte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<SByte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Decimal>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTime>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTimeOffset>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Guid>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<TimeSpan>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Base Implementation in WriteValue


WriteValue(Object) Method

WriteValue(Object) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Object) Method
The System.Object value to write.
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Object _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Object

instance.WriteValue(value)
public override void WriteValue(
   System.object value
)
public procedure WriteValue(
    value: System.TObject
); override;
public override function WriteValue(
   value : System.Object
);
public: void WriteValue(
   System.Object* value
) override
public:
void WriteValue(
   System.Object^ value
) override

Parameters

value
The System.Object value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Object)


WriteValue(String) Method

WriteValue(String) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(String) Method
The System.String value to write.
Writes a System.String value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.String _
)
'Usage

Dim instance As BsonWriter
Dim value As System.String

instance.WriteValue(value)
public override void WriteValue(
   System.string value
)
public procedure WriteValue(
    value: System.String
); override;
public override function WriteValue(
   value : System.String
);
public: void WriteValue(
   System.string* value
) override
public:
void WriteValue(
   System.String^ value
) override

Parameters

value
The System.String value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(String)


WriteValue(Int32) Method

WriteValue(Int32) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Int32) Method
The System.Int32 value to write.
Writes a System.Int32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Integer _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Integer

instance.WriteValue(value)
public override void WriteValue(
   System.int value
)
public procedure WriteValue(
    value: System.Integer
); override;
public override function WriteValue(
   value : System.int
);
public: void WriteValue(
   System.int value
) override
public:
void WriteValue(
   System.int value
) override

Parameters

value
The System.Int32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Int32)


WriteValue(UInt32) Method

WriteValue(UInt32) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(UInt32) Method
The System.UInt32 value to write.
Writes a System.UInt32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UInteger _
)
'Usage

Dim instance As BsonWriter
Dim value As System.UInteger

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.uint value
)
public procedure WriteValue(
    value: System.LongWord
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.uint
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.uint value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.uint value
) override

Parameters

value
The System.UInt32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(UInt32)


WriteValue(Int64) Method

WriteValue(Int64) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Int64) Method
The System.Int64 value to write.
Writes a System.Int64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Long _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Long

instance.WriteValue(value)
public override void WriteValue(
   System.long value
)
public procedure WriteValue(
    value: System.Int64
); override;
public override function WriteValue(
   value : System.long
);
public: void WriteValue(
   System.long value
) override
public:
void WriteValue(
   System.int64 value
) override

Parameters

value
The System.Int64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Int64)


WriteValue(UInt64) Method

WriteValue(UInt64) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(UInt64) Method
The System.UInt64 value to write.
Writes a System.UInt64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.ULong _
)
'Usage

Dim instance As BsonWriter
Dim value As System.ULong

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ulong value
)
public procedure WriteValue(
    value: System.UInt64
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ulong
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ulong value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ulong value
) override

Parameters

value
The System.UInt64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(UInt64)


WriteValue(Single) Method

WriteValue(Single) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Single) Method
The System.Single value to write.
Writes a System.Single value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Single _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Single

instance.WriteValue(value)
public override void WriteValue(
   System.float value
)
public procedure WriteValue(
    value: System.Single
); override;
public override function WriteValue(
   value : System.float
);
public: void WriteValue(
   System.float value
) override
public:
void WriteValue(
   System.float value
) override

Parameters

value
The System.Single value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Single)


WriteValue(Double) Method

WriteValue(Double) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Double) Method
The System.Double value to write.
Writes a System.Double value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Double _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Double

instance.WriteValue(value)
public override void WriteValue(
   System.double value
)
public procedure WriteValue(
    value: System.Double
); override;
public override function WriteValue(
   value : System.double
);
public: void WriteValue(
   System.double value
) override
public:
void WriteValue(
   System.double value
) override

Parameters

value
The System.Double value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Double)


WriteValue(Boolean) Method

WriteValue(Boolean) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Boolean) Method
The System.Boolean value to write.
Writes a System.Boolean value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Boolean _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Boolean

instance.WriteValue(value)
public override void WriteValue(
   System.bool value
)
public procedure WriteValue(
    value: System.Boolean
); override;
public override function WriteValue(
   value : System.boolean
);
public: void WriteValue(
   System.bool value
) override
public:
void WriteValue(
   System.bool value
) override

Parameters

value
The System.Boolean value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Boolean)


WriteValue(Int16) Method

WriteValue(Int16) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Int16) Method
The System.Int16 value to write.
Writes a System.Int16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Short _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Short

instance.WriteValue(value)
public override void WriteValue(
   System.short value
)
public procedure WriteValue(
    value: System.Int16
); override;
public override function WriteValue(
   value : System.short
);
public: void WriteValue(
   System.short value
) override
public:
void WriteValue(
   System.short value
) override

Parameters

value
The System.Int16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Int16)


WriteValue(UInt16) Method

WriteValue(UInt16) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(UInt16) Method
The System.UInt16 value to write.
Writes a System.UInt16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UShort _
)
'Usage

Dim instance As BsonWriter
Dim value As System.UShort

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ushort value
)
public procedure WriteValue(
    value: System.Word
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ushort
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ushort value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ushort value
) override

Parameters

value
The System.UInt16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(UInt16)


WriteValue(Char) Method

WriteValue(Char) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Char) Method
The System.Char value to write.
Writes a System.Char value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Char _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Char

instance.WriteValue(value)
public override void WriteValue(
   System.char value
)
public procedure WriteValue(
    value: System.Char
); override;
public override function WriteValue(
   value : System.char
);
public: void WriteValue(
   System.char value
) override
public:
void WriteValue(
   System.char value
) override

Parameters

value
The System.Char value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Char)


WriteValue(Byte) Method

WriteValue(Byte) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Byte) Method
The System.Byte value to write.
Writes a System.Byte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Byte _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte value
)
public procedure WriteValue(
    value: System.Byte
); override;
public override function WriteValue(
   value : System.byte
);
public: void WriteValue(
   System.byte value
) override
public:
void WriteValue(
   System.byte value
) override

Parameters

value
The System.Byte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Byte)


WriteValue(SByte) Method

WriteValue(SByte) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(SByte) Method
The System.SByte value to write.
Writes a System.SByte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.SByte _
)
'Usage

Dim instance As BsonWriter
Dim value As System.SByte

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.sbyte value
)
public procedure WriteValue(
    value: System.ShortInt
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.sbyte
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.sbyte value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.sbyte value
) override

Parameters

value
The System.SByte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(SByte)


WriteValue(Decimal) Method

WriteValue(Decimal) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Decimal) Method
The System.Decimal value to write.
Writes a System.Decimal value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Decimal _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Decimal

instance.WriteValue(value)
public override void WriteValue(
   System.decimal value
)
public procedure WriteValue(
    value: System.Currency
); override;
public override function WriteValue(
   value : System.decimal
);
public: void WriteValue(
   System.decimal value
) override
public:
void WriteValue(
   System.decimal value
) override

Parameters

value
The System.Decimal value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Decimal)


WriteValue(DateTime) Method

WriteValue(DateTime) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(DateTime) Method
The System.DateTime value to write.
Writes a System.DateTime value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Date _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Date

instance.WriteValue(value)
public override void WriteValue(
   System.DateTime value
)
public procedure WriteValue(
    value: System.DateTime
); override;
public override function WriteValue(
   value : System.DateTime
);
public: void WriteValue(
   System.DateTime value
) override
public:
void WriteValue(
   System.DateTime value
) override

Parameters

value
The System.DateTime value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(DateTime)


WriteValue(DateTimeOffset) Method

WriteValue(DateTimeOffset) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(DateTimeOffset) Method
The System.DateTimeOffset value to write.
Writes a System.DateTimeOffset value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.DateTimeOffset _
)
'Usage

Dim instance As BsonWriter
Dim value As System.DateTimeOffset

instance.WriteValue(value)
public override void WriteValue(
   System.DateTimeOffset value
)
public procedure WriteValue(
    value: System.DateTimeOffset
); override;
public override function WriteValue(
   value : System.DateTimeOffset
);
public: void WriteValue(
   System.DateTimeOffset value
) override
public:
void WriteValue(
   System.DateTimeOffset value
) override

Parameters

value
The System.DateTimeOffset value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(DateTimeOffset)


WriteValue(Byte[]) Method

WriteValue(Byte[]) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Byte[]) Method
The Byte[] value to write.
Writes a Byte[] value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value() As System.Byte _
)
'Usage

Dim instance As BsonWriter
Dim value() As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte[] value
)
public procedure WriteValue(
    value: System.Bytearray of
); override;
public override function WriteValue(
   value : System.byte[]
);
public: void WriteValue(
   System.byte[]* value
) override
public:
void WriteValue(
   System.array<byte>^ value
) override

Parameters

value
The Byte[] value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Byte[])


WriteValue(Guid) Method

WriteValue(Guid) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Guid) Method
The System.Guid value to write.
Writes a System.Guid value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Guid _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Guid

instance.WriteValue(value)
public override void WriteValue(
   System.Guid value
)
public procedure WriteValue(
    value: System.Guid
); override;
public override function WriteValue(
   value : System.Guid
);
public: void WriteValue(
   System.Guid value
) override
public:
void WriteValue(
   System.Guid value
) override

Parameters

value
The System.Guid value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Guid)


WriteValue(TimeSpan) Method

WriteValue(TimeSpan) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(TimeSpan) Method
The System.TimeSpan value to write.
Writes a System.TimeSpan value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.TimeSpan _
)
'Usage

Dim instance As BsonWriter
Dim value As System.TimeSpan

instance.WriteValue(value)
public override void WriteValue(
   System.TimeSpan value
)
public procedure WriteValue(
    value: System.TimeSpan
); override;
public override function WriteValue(
   value : System.TimeSpan
);
public: void WriteValue(
   System.TimeSpan value
) override
public:
void WriteValue(
   System.TimeSpan value
) override

Parameters

value
The System.TimeSpan value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(TimeSpan)


WriteValue(Uri) Method

WriteValue(Uri) Method

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class > WriteValue Method : WriteValue(Uri) Method
The System.Uri value to write.
Writes a System.Uri value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Uri _
)
'Usage

Dim instance As BsonWriter
Dim value As System.Uri

instance.WriteValue(value)
public override void WriteValue(
   System.Uri value
)
public procedure WriteValue(
    value: System.Uri
); override;
public override function WriteValue(
   value : System.Uri
);
public: void WriteValue(
   System.Uri* value
) override
public:
void WriteValue(
   System.Uri^ value
) override

Parameters

value
The System.Uri value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members
Overload List
Base Implementation in WriteValue(Uri)


BsonWriter Class Properties

BsonWriter Class Properties

Noemax.Newtonsoft.Json.Bson Namespace : BsonWriter Class

For a list of all members of this type, see BsonWriter members.

Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeKindHandling | Gets or sets the System.DateTimeKind used when writing System.DateTime values to BSON. When set to System.DateTimeKind.Unspecified no conversion will occur.
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

BsonWriter Class
Noemax.Newtonsoft.Json.Bson Namespace


DateTimeKindHandling Property (BsonWriter)

DateTimeKindHandling Property (BsonWriter)

Noemax.Newtonsoft.Json.Bson Namespace > BsonWriter Class : DateTimeKindHandling Property
Gets or sets the System.DateTimeKind used when writing System.DateTime values to BSON. When set to System.DateTimeKind.Unspecified no conversion will occur.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeKindHandling As System.DateTimeKind
'Usage

Dim instance As BsonWriter
Dim value As System.DateTimeKind

instance.DateTimeKindHandling = value

value = instance.DateTimeKindHandling
public System.DateTimeKind DateTimeKindHandling {get; set;}
public read-write property DateTimeKindHandling: System.DateTimeKind;
public function get,set DateTimeKindHandling : System.DateTimeKind
public: __property System.DateTimeKind get_DateTimeKindHandling();
public: __property void set_DateTimeKindHandling(
   System.DateTimeKind value
);
public:
property System.DateTimeKind DateTimeKindHandling {
   System.DateTimeKind get();
   void set (    System.DateTimeKind value);
}

Property Value

The System.DateTimeKind used when writing System.DateTime values to BSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonWriter Class
BsonWriter Members


Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BinaryConverter | Converts a binary value to and from a base 64 string value.
Class | BsonObjectIdConverter | Converts a Noemax.Newtonsoft.Json.Bson.BsonObjectId to and from JSON and BSON.
Class | CustomCreationConverter<T> | Create a custom object
Class | DataSetConverter | Converts a System.Data.DataSet to and from JSON.
Class | DataTableConverter | Converts a System.Data.DataTable to and from JSON.
Class | DateTimeConverterBase | Provides a base class for converting a System.DateTime to and from JSON.
Class | EntityKeyMemberConverter | Converts an Entity Framework EntityKey to and from JSON.
Class | IsoDateTimeConverter | Converts a System.DateTime to and from the ISO 8601 date format (e.g. 2008-04-12T12:53Z).
Class | JavaScriptDateTimeConverter | Converts a System.DateTime to and from a JavaScript date constructor (e.g. new Date(52231943)).
Class | KeyValuePairConverter | Converts a System.Collections.Generic.KeyValuePair`2 to and from JSON.
Class | RegexConverter | Converts a System.Text.RegularExpressions.Regex to and from JSON and BSON.
Class | StringEnumConverter | Converts an System.Enum to and from its name string value.
Class | VersionConverter | Converts a System.Version to and from a string (e.g. "1.2.3.4").
Class | XmlNodeConverter | Converts XML to and from JSON.
See Also

Reference

Noemax.WebSockets Assembly


BinaryConverter Class

BinaryConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : BinaryConverter Class
Converts a binary value to and from a base 64 string value.
Object Model
BinaryConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BinaryConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As BinaryConverter
public class BinaryConverter : Noemax.Newtonsoft.Json.JsonConverter
public class BinaryConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class BinaryConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class BinaryConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class BinaryConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


BinaryConverter Class Members

BinaryConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : BinaryConverter Class

The following tables list the members exposed by BinaryConverter.

Public Constructors
 | Name | Description
Public Constructor | BinaryConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

BinaryConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


BinaryConverter Constructor

BinaryConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > BinaryConverter Class : BinaryConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New BinaryConverter()
public BinaryConverter()
public BinaryConverter();
public function BinaryConverter();
public: BinaryConverter();
public:
BinaryConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryConverter Class
BinaryConverter Members


BinaryConverter Class Methods

BinaryConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : BinaryConverter Class

For a list of all members of this type, see BinaryConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

BinaryConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (BinaryConverter)

CanConvert Method (BinaryConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BinaryConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As BinaryConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryConverter Class
BinaryConverter Members
Base Implementation in CanConvert


ReadJson Method (BinaryConverter)

ReadJson Method (BinaryConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BinaryConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As BinaryConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryConverter Class
BinaryConverter Members
Base Implementation in ReadJson


WriteJson Method (BinaryConverter)

WriteJson Method (BinaryConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BinaryConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As BinaryConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BinaryConverter Class
BinaryConverter Members
Base Implementation in WriteJson


BsonObjectIdConverter Class

BsonObjectIdConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : BsonObjectIdConverter Class
Converts a Noemax.Newtonsoft.Json.Bson.BsonObjectId to and from JSON and BSON.
Object Model
BsonObjectIdConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BsonObjectIdConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As BsonObjectIdConverter
public class BsonObjectIdConverter : Noemax.Newtonsoft.Json.JsonConverter
public class BsonObjectIdConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class BsonObjectIdConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class BsonObjectIdConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class BsonObjectIdConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectIdConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


BsonObjectIdConverter Class Members

BsonObjectIdConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : BsonObjectIdConverter Class

The following tables list the members exposed by BsonObjectIdConverter.

Public Constructors
 | Name | Description
Public Constructor | BsonObjectIdConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

BsonObjectIdConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


BsonObjectIdConverter Constructor

BsonObjectIdConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > BsonObjectIdConverter Class : BsonObjectIdConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New BsonObjectIdConverter()
public BsonObjectIdConverter()
public BsonObjectIdConverter();
public function BsonObjectIdConverter();
public: BsonObjectIdConverter();
public:
BsonObjectIdConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectIdConverter Class
BsonObjectIdConverter Members


BsonObjectIdConverter Class Methods

BsonObjectIdConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : BsonObjectIdConverter Class

For a list of all members of this type, see BsonObjectIdConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

BsonObjectIdConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (BsonObjectIdConverter)

CanConvert Method (BsonObjectIdConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BsonObjectIdConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As BsonObjectIdConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectIdConverter Class
BsonObjectIdConverter Members
Base Implementation in CanConvert


ReadJson Method (BsonObjectIdConverter)

ReadJson Method (BsonObjectIdConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BsonObjectIdConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As BsonObjectIdConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectIdConverter Class
BsonObjectIdConverter Members
Base Implementation in ReadJson


WriteJson Method (BsonObjectIdConverter)

WriteJson Method (BsonObjectIdConverter)

Noemax.Newtonsoft.Json.Converters Namespace > BsonObjectIdConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As BsonObjectIdConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BsonObjectIdConverter Class
BsonObjectIdConverter Members
Base Implementation in WriteJson


CustomCreationConverter<T> Class

CustomCreationConverter<T> Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : CustomCreationConverter<T> Class
The object type to convert.
Create a custom object
Object Model
CustomCreationConverter<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class CustomCreationConverter(Of T)
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As CustomCreationConverter(Of T)
public abstract class CustomCreationConverter<T> : Noemax.Newtonsoft.Json.JsonConverter
public class CustomCreationConverter = class(Noemax.Newtonsoft.Json.JsonConverter)abstract;
JScript does not support Generics.
public __gc abstract class CustomCreationConverter<T> : public Noemax.Newtonsoft.Json.JsonConverter
generic<typename T>
public ref class CustomCreationConverter abstract : public Noemax.Newtonsoft.Json.JsonConverter
Type Parameters
T
The object type to convert.
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Members
Noemax.Newtonsoft.Json.Converters Namespace


CustomCreationConverter<T> Class Members

CustomCreationConverter<T> Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : CustomCreationConverter<T> Class

The following tables list the members exposed by CustomCreationConverter<T>.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Overridden. Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | Create | Creates an object which will then be populated by the serializer.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

CustomCreationConverter<T> Class
Noemax.Newtonsoft.Json.Converters Namespace


CustomCreationConverter<T> Class Methods

CustomCreationConverter<T> Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : CustomCreationConverter<T> Class

For a list of all members of this type, see CustomCreationConverter<T> members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | Create | Creates an object which will then be populated by the serializer.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

CustomCreationConverter<T> Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (CustomCreationConverter<T>)

CanConvert Method (CustomCreationConverter<T>)

Noemax.Newtonsoft.Json.Converters Namespace > CustomCreationConverter<T> Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As CustomCreationConverter(Of T)
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Class
CustomCreationConverter<T> Members
Base Implementation in CanConvert


Create Method (CustomCreationConverter<T>)

Create Method (CustomCreationConverter<T>)

Noemax.Newtonsoft.Json.Converters Namespace > CustomCreationConverter<T> Class : Create Method
Type of the object.
Creates an object which will then be populated by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function Create( _
   ByVal objectType As System.Type _
) As T
'Usage

Dim instance As CustomCreationConverter(Of T)
Dim objectType As System.Type
Dim value As T

value = instance.Create(objectType)
public abstract T Create(
   System.Type objectType
)
public function Create(
    objectType: System.Type
): T; abstract;
public __abstract function Create(
   objectType : System.Type
) : T;
public: abstract T* Create(
   System.Type* objectType
)
public:
abstract T^ Create(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

The created object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Class
CustomCreationConverter<T> Members


ReadJson Method (CustomCreationConverter<T>)

ReadJson Method (CustomCreationConverter<T>)

Noemax.Newtonsoft.Json.Converters Namespace > CustomCreationConverter<T> Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As CustomCreationConverter(Of T)
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Class
CustomCreationConverter<T> Members
Base Implementation in ReadJson


WriteJson Method (CustomCreationConverter<T>)

WriteJson Method (CustomCreationConverter<T>)

Noemax.Newtonsoft.Json.Converters Namespace > CustomCreationConverter<T> Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As CustomCreationConverter(Of T)
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Class
CustomCreationConverter<T> Members
Base Implementation in WriteJson


CustomCreationConverter<T> Class Properties

CustomCreationConverter<T> Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : CustomCreationConverter<T> Class

For a list of all members of this type, see CustomCreationConverter<T> members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Overridden. Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Top
See Also

Reference

CustomCreationConverter<T> Class
Noemax.Newtonsoft.Json.Converters Namespace


CanWrite Property (CustomCreationConverter<T>)

CanWrite Property (CustomCreationConverter<T>)

Noemax.Newtonsoft.Json.Converters Namespace > CustomCreationConverter<T> Class : CanWrite Property
Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property CanWrite As System.Boolean
'Usage

Dim instance As CustomCreationConverter(Of T)
Dim value As System.Boolean

value = instance.CanWrite
public override System.bool CanWrite {get;}
public read-only property CanWrite: System.Boolean; override;
public override function get CanWrite : System.boolean
public: __property System.bool get_CanWrite() override;
public:
property System.bool CanWrite {
   System.bool get() override;
}

Property Value

true if this Noemax.Newtonsoft.Json.JsonConverter can write JSON; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CustomCreationConverter<T> Class
CustomCreationConverter<T> Members
Base Implementation in CanWrite


DataSetConverter Class

DataSetConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : DataSetConverter Class
Converts a System.Data.DataSet to and from JSON.
Object Model
DataSetConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DataSetConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As DataSetConverter
public class DataSetConverter : Noemax.Newtonsoft.Json.JsonConverter
public class DataSetConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class DataSetConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class DataSetConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class DataSetConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DataSetConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


DataSetConverter Class Members

DataSetConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : DataSetConverter Class

The following tables list the members exposed by DataSetConverter.

Public Constructors
 | Name | Description
Public Constructor | DataSetConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DataSetConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DataSetConverter Constructor

DataSetConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > DataSetConverter Class : DataSetConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DataSetConverter()
public DataSetConverter()
public DataSetConverter();
public function DataSetConverter();
public: DataSetConverter();
public:
DataSetConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetConverter Class
DataSetConverter Members


DataSetConverter Class Methods

DataSetConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : DataSetConverter Class

For a list of all members of this type, see DataSetConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DataSetConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (DataSetConverter)

CanConvert Method (DataSetConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataSetConverter Class : CanConvert Method
Type of the value.
Determines whether this instance can convert the specified value type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal valueType As System.Type _
) As System.Boolean
'Usage

Dim instance As DataSetConverter
Dim valueType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(valueType)
public override System.bool CanConvert(
   System.Type valueType
)
public function CanConvert(
    valueType: System.Type
): System.Boolean; override;
public override function CanConvert(
   valueType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* valueType
) override
public:
System.bool CanConvert(
   System.Type^ valueType
) override

Parameters

valueType
Type of the value.

Return Value

true if this instance can convert the specified value type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetConverter Class
DataSetConverter Members
Base Implementation in CanConvert


ReadJson Method (DataSetConverter)

ReadJson Method (DataSetConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataSetConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As DataSetConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetConverter Class
DataSetConverter Members
Base Implementation in ReadJson


WriteJson Method (DataSetConverter)

WriteJson Method (DataSetConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataSetConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As DataSetConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSetConverter Class
DataSetConverter Members
Base Implementation in WriteJson


DataTableConverter Class

DataTableConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : DataTableConverter Class
Converts a System.Data.DataTable to and from JSON.
Object Model
DataTableConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DataTableConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As DataTableConverter
public class DataTableConverter : Noemax.Newtonsoft.Json.JsonConverter
public class DataTableConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class DataTableConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class DataTableConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class DataTableConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTableConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


DataTableConverter Class Members

DataTableConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : DataTableConverter Class

The following tables list the members exposed by DataTableConverter.

Public Constructors
 | Name | Description
Public Constructor | DataTableConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DataTableConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DataTableConverter Constructor

DataTableConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > DataTableConverter Class : DataTableConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DataTableConverter()
public DataTableConverter()
public DataTableConverter();
public function DataTableConverter();
public: DataTableConverter();
public:
DataTableConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTableConverter Class
DataTableConverter Members


DataTableConverter Class Methods

DataTableConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : DataTableConverter Class

For a list of all members of this type, see DataTableConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DataTableConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (DataTableConverter)

CanConvert Method (DataTableConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataTableConverter Class : CanConvert Method
Type of the value.
Determines whether this instance can convert the specified value type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal valueType As System.Type _
) As System.Boolean
'Usage

Dim instance As DataTableConverter
Dim valueType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(valueType)
public override System.bool CanConvert(
   System.Type valueType
)
public function CanConvert(
    valueType: System.Type
): System.Boolean; override;
public override function CanConvert(
   valueType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* valueType
) override
public:
System.bool CanConvert(
   System.Type^ valueType
) override

Parameters

valueType
Type of the value.

Return Value

true if this instance can convert the specified value type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTableConverter Class
DataTableConverter Members
Base Implementation in CanConvert


ReadJson Method (DataTableConverter)

ReadJson Method (DataTableConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataTableConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As DataTableConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTableConverter Class
DataTableConverter Members
Base Implementation in ReadJson


WriteJson Method (DataTableConverter)

WriteJson Method (DataTableConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DataTableConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As DataTableConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataTableConverter Class
DataTableConverter Members
Base Implementation in WriteJson


DateTimeConverterBase Class

DateTimeConverterBase Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : DateTimeConverterBase Class
Provides a base class for converting a System.DateTime to and from JSON.
Object Model
DateTimeConverterBase Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class DateTimeConverterBase
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As DateTimeConverterBase
public abstract class DateTimeConverterBase : Noemax.Newtonsoft.Json.JsonConverter
public class DateTimeConverterBase = class(Noemax.Newtonsoft.Json.JsonConverter)abstract;
public abstract class DateTimeConverterBase extends Noemax.Newtonsoft.Json.JsonConverter
public __gc abstract class DateTimeConverterBase : public Noemax.Newtonsoft.Json.JsonConverter
public ref class DateTimeConverterBase abstract : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverterBase Members
Noemax.Newtonsoft.Json.Converters Namespace


DateTimeConverterBase Class Members

DateTimeConverterBase Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : DateTimeConverterBase Class

The following tables list the members exposed by DateTimeConverterBase.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Reads the JSON representation of the object. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | WriteJson | Writes the JSON representation of the object. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DateTimeConverterBase Class
Noemax.Newtonsoft.Json.Converters Namespace


DateTimeConverterBase Class Methods

DateTimeConverterBase Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : DateTimeConverterBase Class

For a list of all members of this type, see DateTimeConverterBase members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Reads the JSON representation of the object. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | WriteJson | Writes the JSON representation of the object. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DateTimeConverterBase Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (DateTimeConverterBase)

CanConvert Method (DateTimeConverterBase)

Noemax.Newtonsoft.Json.Converters Namespace > DateTimeConverterBase Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As DateTimeConverterBase
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DateTimeConverterBase Class
DateTimeConverterBase Members
Base Implementation in CanConvert


EntityKeyMemberConverter Class

EntityKeyMemberConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : EntityKeyMemberConverter Class
Converts an Entity Framework EntityKey to and from JSON.
Object Model
EntityKeyMemberConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class EntityKeyMemberConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As EntityKeyMemberConverter
public class EntityKeyMemberConverter : Noemax.Newtonsoft.Json.JsonConverter
public class EntityKeyMemberConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class EntityKeyMemberConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class EntityKeyMemberConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class EntityKeyMemberConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EntityKeyMemberConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


EntityKeyMemberConverter Class Members

EntityKeyMemberConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : EntityKeyMemberConverter Class

The following tables list the members exposed by EntityKeyMemberConverter.

Public Constructors
 | Name | Description
Public Constructor | EntityKeyMemberConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

EntityKeyMemberConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


EntityKeyMemberConverter Constructor

EntityKeyMemberConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > EntityKeyMemberConverter Class : EntityKeyMemberConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New EntityKeyMemberConverter()
public EntityKeyMemberConverter()
public EntityKeyMemberConverter();
public function EntityKeyMemberConverter();
public: EntityKeyMemberConverter();
public:
EntityKeyMemberConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EntityKeyMemberConverter Class
EntityKeyMemberConverter Members


EntityKeyMemberConverter Class Methods

EntityKeyMemberConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : EntityKeyMemberConverter Class

For a list of all members of this type, see EntityKeyMemberConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

EntityKeyMemberConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (EntityKeyMemberConverter)

CanConvert Method (EntityKeyMemberConverter)

Noemax.Newtonsoft.Json.Converters Namespace > EntityKeyMemberConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As EntityKeyMemberConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EntityKeyMemberConverter Class
EntityKeyMemberConverter Members
Base Implementation in CanConvert


ReadJson Method (EntityKeyMemberConverter)

ReadJson Method (EntityKeyMemberConverter)

Noemax.Newtonsoft.Json.Converters Namespace > EntityKeyMemberConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As EntityKeyMemberConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EntityKeyMemberConverter Class
EntityKeyMemberConverter Members
Base Implementation in ReadJson


WriteJson Method (EntityKeyMemberConverter)

WriteJson Method (EntityKeyMemberConverter)

Noemax.Newtonsoft.Json.Converters Namespace > EntityKeyMemberConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As EntityKeyMemberConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EntityKeyMemberConverter Class
EntityKeyMemberConverter Members
Base Implementation in WriteJson


IsoDateTimeConverter Class

IsoDateTimeConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : IsoDateTimeConverter Class
Converts a System.DateTime to and from the ISO 8601 date format (e.g. 2008-04-12T12:53Z).
Object Model
IsoDateTimeConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class IsoDateTimeConverter
   Inherits DateTimeConverterBase
'Usage

Dim instance As IsoDateTimeConverter
public class IsoDateTimeConverter : DateTimeConverterBase
public class IsoDateTimeConverter = class(DateTimeConverterBase)
public class IsoDateTimeConverter extends DateTimeConverterBase
public __gc class IsoDateTimeConverter : public DateTimeConverterBase
public ref class IsoDateTimeConverter : public DateTimeConverterBase
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


IsoDateTimeConverter Class Members

IsoDateTimeConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : IsoDateTimeConverter Class

The following tables list the members exposed by IsoDateTimeConverter.

Public Constructors
 | Name | Description
Public Constructor | IsoDateTimeConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | Culture | Gets or sets the culture used when converting a date to and from JSON.
Public Property | DateTimeFormat | Gets or sets the date time format used when converting a date to and from JSON.
Public Property | DateTimeStyles | Gets or sets the date time styles used when converting a date to and from JSON.
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type. (Inherited from Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase)
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

IsoDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


IsoDateTimeConverter Constructor

IsoDateTimeConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : IsoDateTimeConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New IsoDateTimeConverter()
public IsoDateTimeConverter()
public IsoDateTimeConverter();
public function IsoDateTimeConverter();
public: IsoDateTimeConverter();
public:
IsoDateTimeConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members


IsoDateTimeConverter Class Methods

IsoDateTimeConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : IsoDateTimeConverter Class

For a list of all members of this type, see IsoDateTimeConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type. (Inherited from Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase)
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

IsoDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


ReadJson Method (IsoDateTimeConverter)

ReadJson Method (IsoDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As IsoDateTimeConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members
Base Implementation in ReadJson


WriteJson Method (IsoDateTimeConverter)

WriteJson Method (IsoDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As IsoDateTimeConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members
Base Implementation in WriteJson


IsoDateTimeConverter Class Properties

IsoDateTimeConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : IsoDateTimeConverter Class

For a list of all members of this type, see IsoDateTimeConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | Culture | Gets or sets the culture used when converting a date to and from JSON.
Public Property | DateTimeFormat | Gets or sets the date time format used when converting a date to and from JSON.
Public Property | DateTimeStyles | Gets or sets the date time styles used when converting a date to and from JSON.
Top
See Also

Reference

IsoDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


Culture Property (IsoDateTimeConverter)

Culture Property (IsoDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : Culture Property
Gets or sets the culture used when converting a date to and from JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Culture As System.Globalization.CultureInfo
'Usage

Dim instance As IsoDateTimeConverter
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
public System.Globalization.CultureInfo Culture {get; set;}
public read-write property Culture: System.Globalization.CultureInfo;
public function get,set Culture : System.Globalization.CultureInfo
public: __property System.Globalization.CultureInfo* get_Culture();
public: __property void set_Culture(
   System.Globalization.CultureInfo* value
);
public:
property System.Globalization.CultureInfo^ Culture {
   System.Globalization.CultureInfo^ get();
   void set (    System.Globalization.CultureInfo^ value);
}

Property Value

The culture used when converting a date to and from JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members


DateTimeFormat Property (IsoDateTimeConverter)

DateTimeFormat Property (IsoDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : DateTimeFormat Property
Gets or sets the date time format used when converting a date to and from JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeFormat As System.String
'Usage

Dim instance As IsoDateTimeConverter
Dim value As System.String

instance.DateTimeFormat = value

value = instance.DateTimeFormat
public System.string DateTimeFormat {get; set;}
public read-write property DateTimeFormat: System.String;
public function get,set DateTimeFormat : System.String
public: __property System.string* get_DateTimeFormat();
public: __property void set_DateTimeFormat(
   System.string* value
);
public:
property System.String^ DateTimeFormat {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The date time format used when converting a date to and from JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members


DateTimeStyles Property (IsoDateTimeConverter)

DateTimeStyles Property (IsoDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > IsoDateTimeConverter Class : DateTimeStyles Property
Gets or sets the date time styles used when converting a date to and from JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DateTimeStyles As System.Globalization.DateTimeStyles
'Usage

Dim instance As IsoDateTimeConverter
Dim value As System.Globalization.DateTimeStyles

instance.DateTimeStyles = value

value = instance.DateTimeStyles
public System.Globalization.DateTimeStyles DateTimeStyles {get; set;}
public read-write property DateTimeStyles: System.Globalization.DateTimeStyles;
public function get,set DateTimeStyles : System.Globalization.DateTimeStyles
public: __property System.Globalization.DateTimeStyles get_DateTimeStyles();
public: __property void set_DateTimeStyles(
   System.Globalization.DateTimeStyles value
);
public:
property System.Globalization.DateTimeStyles DateTimeStyles {
   System.Globalization.DateTimeStyles get();
   void set (    System.Globalization.DateTimeStyles value);
}

Property Value

The date time styles used when converting a date to and from JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IsoDateTimeConverter Class
IsoDateTimeConverter Members


JavaScriptDateTimeConverter Class

JavaScriptDateTimeConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : JavaScriptDateTimeConverter Class
Converts a System.DateTime to and from a JavaScript date constructor (e.g. new Date(52231943)).
Object Model
JavaScriptDateTimeConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JavaScriptDateTimeConverter
   Inherits DateTimeConverterBase
'Usage

Dim instance As JavaScriptDateTimeConverter
public class JavaScriptDateTimeConverter : DateTimeConverterBase
public class JavaScriptDateTimeConverter = class(DateTimeConverterBase)
public class JavaScriptDateTimeConverter extends DateTimeConverterBase
public __gc class JavaScriptDateTimeConverter : public DateTimeConverterBase
public ref class JavaScriptDateTimeConverter : public DateTimeConverterBase
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JavaScriptDateTimeConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


JavaScriptDateTimeConverter Class Members

JavaScriptDateTimeConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : JavaScriptDateTimeConverter Class

The following tables list the members exposed by JavaScriptDateTimeConverter.

Public Constructors
 | Name | Description
Public Constructor | JavaScriptDateTimeConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type. (Inherited from Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase)
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

JavaScriptDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


JavaScriptDateTimeConverter Constructor

JavaScriptDateTimeConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > JavaScriptDateTimeConverter Class : JavaScriptDateTimeConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JavaScriptDateTimeConverter()
public JavaScriptDateTimeConverter()
public JavaScriptDateTimeConverter();
public function JavaScriptDateTimeConverter();
public: JavaScriptDateTimeConverter();
public:
JavaScriptDateTimeConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JavaScriptDateTimeConverter Class
JavaScriptDateTimeConverter Members


JavaScriptDateTimeConverter Class Methods

JavaScriptDateTimeConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : JavaScriptDateTimeConverter Class

For a list of all members of this type, see JavaScriptDateTimeConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Determines whether this instance can convert the specified object type. (Inherited from Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase)
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

JavaScriptDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


ReadJson Method (JavaScriptDateTimeConverter)

ReadJson Method (JavaScriptDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > JavaScriptDateTimeConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing property value of the JSON that is being converted.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As JavaScriptDateTimeConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing property value of the JSON that is being converted.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JavaScriptDateTimeConverter Class
JavaScriptDateTimeConverter Members
Base Implementation in ReadJson


WriteJson Method (JavaScriptDateTimeConverter)

WriteJson Method (JavaScriptDateTimeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > JavaScriptDateTimeConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As JavaScriptDateTimeConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JavaScriptDateTimeConverter Class
JavaScriptDateTimeConverter Members
Base Implementation in WriteJson


KeyValuePairConverter Class

KeyValuePairConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : KeyValuePairConverter Class
Converts a System.Collections.Generic.KeyValuePair`2 to and from JSON.
Object Model
KeyValuePairConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class KeyValuePairConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As KeyValuePairConverter
public class KeyValuePairConverter : Noemax.Newtonsoft.Json.JsonConverter
public class KeyValuePairConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class KeyValuePairConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class KeyValuePairConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class KeyValuePairConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePairConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


KeyValuePairConverter Class Members

KeyValuePairConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : KeyValuePairConverter Class

The following tables list the members exposed by KeyValuePairConverter.

Public Constructors
 | Name | Description
Public Constructor | KeyValuePairConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

KeyValuePairConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


KeyValuePairConverter Constructor

KeyValuePairConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > KeyValuePairConverter Class : KeyValuePairConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New KeyValuePairConverter()
public KeyValuePairConverter()
public KeyValuePairConverter();
public function KeyValuePairConverter();
public: KeyValuePairConverter();
public:
KeyValuePairConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePairConverter Class
KeyValuePairConverter Members


KeyValuePairConverter Class Methods

KeyValuePairConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : KeyValuePairConverter Class

For a list of all members of this type, see KeyValuePairConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

KeyValuePairConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (KeyValuePairConverter)

CanConvert Method (KeyValuePairConverter)

Noemax.Newtonsoft.Json.Converters Namespace > KeyValuePairConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As KeyValuePairConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePairConverter Class
KeyValuePairConverter Members
Base Implementation in CanConvert


ReadJson Method (KeyValuePairConverter)

ReadJson Method (KeyValuePairConverter)

Noemax.Newtonsoft.Json.Converters Namespace > KeyValuePairConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As KeyValuePairConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePairConverter Class
KeyValuePairConverter Members
Base Implementation in ReadJson


WriteJson Method (KeyValuePairConverter)

WriteJson Method (KeyValuePairConverter)

Noemax.Newtonsoft.Json.Converters Namespace > KeyValuePairConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As KeyValuePairConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

KeyValuePairConverter Class
KeyValuePairConverter Members
Base Implementation in WriteJson


RegexConverter Class

RegexConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : RegexConverter Class
Converts a System.Text.RegularExpressions.Regex to and from JSON and BSON.
Object Model
RegexConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RegexConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As RegexConverter
public class RegexConverter : Noemax.Newtonsoft.Json.JsonConverter
public class RegexConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class RegexConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class RegexConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class RegexConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


RegexConverter Class Members

RegexConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : RegexConverter Class

The following tables list the members exposed by RegexConverter.

Public Constructors
 | Name | Description
Public Constructor | RegexConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

RegexConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


RegexConverter Constructor

RegexConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > RegexConverter Class : RegexConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New RegexConverter()
public RegexConverter()
public RegexConverter();
public function RegexConverter();
public: RegexConverter();
public:
RegexConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Class
RegexConverter Members


RegexConverter Class Methods

RegexConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : RegexConverter Class

For a list of all members of this type, see RegexConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

RegexConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (RegexConverter)

CanConvert Method (RegexConverter)

Noemax.Newtonsoft.Json.Converters Namespace > RegexConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As RegexConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Class
RegexConverter Members
Base Implementation in CanConvert


ReadJson Method (RegexConverter)

ReadJson Method (RegexConverter)

Noemax.Newtonsoft.Json.Converters Namespace > RegexConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As RegexConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Class
RegexConverter Members
Base Implementation in ReadJson


WriteJson(JsonWriter,Object,JsonSerializer) Method

WriteJson(JsonWriter,Object,JsonSerializer) Method

Noemax.Newtonsoft.Json.Converters Namespace > RegexConverter Class : WriteJson(JsonWriter,Object,JsonSerializer) Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As RegexConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Class
RegexConverter Members
Base Implementation in WriteJson


StringEnumConverter Class

StringEnumConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : StringEnumConverter Class
Converts an System.Enum to and from its name string value.
Object Model
StringEnumConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class StringEnumConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As StringEnumConverter
public class StringEnumConverter : Noemax.Newtonsoft.Json.JsonConverter
public class StringEnumConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class StringEnumConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class StringEnumConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class StringEnumConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


StringEnumConverter Class Members

StringEnumConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : StringEnumConverter Class

The following tables list the members exposed by StringEnumConverter.

Public Constructors
 | Name | Description
Public Constructor | StringEnumConverter Constructor | Initializes a new instance of the StringEnumConverter class.
Top
Public Properties
 | Name | Description
Public Property | AllowIntegerValues | Gets or sets a value indicating whether integer values are allowed.
Public Property | CamelCaseText | Gets or sets a value indicating whether the written enum text should be camel case.
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

StringEnumConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


StringEnumConverter Constructor

StringEnumConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : StringEnumConverter Constructor
Initializes a new instance of the StringEnumConverter class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New StringEnumConverter()
public StringEnumConverter()
public StringEnumConverter();
public function StringEnumConverter();
public: StringEnumConverter();
public:
StringEnumConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members


StringEnumConverter Class Methods

StringEnumConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : StringEnumConverter Class

For a list of all members of this type, see StringEnumConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

StringEnumConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (StringEnumConverter)

CanConvert Method (StringEnumConverter)

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As StringEnumConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members
Base Implementation in CanConvert


ReadJson Method (StringEnumConverter)

ReadJson Method (StringEnumConverter)

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As StringEnumConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members
Base Implementation in ReadJson


WriteJson Method (StringEnumConverter)

WriteJson Method (StringEnumConverter)

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As StringEnumConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members
Base Implementation in WriteJson


StringEnumConverter Class Properties

StringEnumConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : StringEnumConverter Class

For a list of all members of this type, see StringEnumConverter members.

Public Properties
 | Name | Description
Public Property | AllowIntegerValues | Gets or sets a value indicating whether integer values are allowed.
Public Property | CamelCaseText | Gets or sets a value indicating whether the written enum text should be camel case.
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

StringEnumConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


AllowIntegerValues Property (StringEnumConverter)

AllowIntegerValues Property (StringEnumConverter)

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : AllowIntegerValues Property
Gets or sets a value indicating whether integer values are allowed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowIntegerValues As System.Boolean
'Usage

Dim instance As StringEnumConverter
Dim value As System.Boolean

instance.AllowIntegerValues = value

value = instance.AllowIntegerValues
public System.bool AllowIntegerValues {get; set;}
public read-write property AllowIntegerValues: System.Boolean;
public function get,set AllowIntegerValues : System.boolean
public: __property System.bool get_AllowIntegerValues();
public: __property void set_AllowIntegerValues(
   System.bool value
);
public:
property System.bool AllowIntegerValues {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if integers are allowed; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members


CamelCaseText Property (StringEnumConverter)

CamelCaseText Property (StringEnumConverter)

Noemax.Newtonsoft.Json.Converters Namespace > StringEnumConverter Class : CamelCaseText Property
Gets or sets a value indicating whether the written enum text should be camel case.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CamelCaseText As System.Boolean
'Usage

Dim instance As StringEnumConverter
Dim value As System.Boolean

instance.CamelCaseText = value

value = instance.CamelCaseText
public System.bool CamelCaseText {get; set;}
public read-write property CamelCaseText: System.Boolean;
public function get,set CamelCaseText : System.boolean
public: __property System.bool get_CamelCaseText();
public: __property void set_CamelCaseText(
   System.bool value
);
public:
property System.bool CamelCaseText {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the written enum text will be camel case; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StringEnumConverter Class
StringEnumConverter Members


VersionConverter Class

VersionConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : VersionConverter Class
Converts a System.Version to and from a string (e.g. "1.2.3.4").
Object Model
VersionConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class VersionConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As VersionConverter
public class VersionConverter : Noemax.Newtonsoft.Json.JsonConverter
public class VersionConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class VersionConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class VersionConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class VersionConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


VersionConverter Class Members

VersionConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : VersionConverter Class

The following tables list the members exposed by VersionConverter.

Public Constructors
 | Name | Description
Public Constructor | VersionConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

VersionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


VersionConverter Constructor

VersionConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > VersionConverter Class : VersionConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New VersionConverter()
public VersionConverter()
public VersionConverter();
public function VersionConverter();
public: VersionConverter();
public:
VersionConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionConverter Class
VersionConverter Members


VersionConverter Class Methods

VersionConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : VersionConverter Class

For a list of all members of this type, see VersionConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

VersionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (VersionConverter)

CanConvert Method (VersionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > VersionConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As VersionConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionConverter Class
VersionConverter Members
Base Implementation in CanConvert


ReadJson Method (VersionConverter)

ReadJson Method (VersionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > VersionConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing property value of the JSON that is being converted.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As VersionConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing property value of the JSON that is being converted.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionConverter Class
VersionConverter Members
Base Implementation in ReadJson


WriteJson Method (VersionConverter)

WriteJson Method (VersionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > VersionConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As VersionConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VersionConverter Class
VersionConverter Members
Base Implementation in WriteJson


XmlNodeConverter Class

XmlNodeConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : XmlNodeConverter Class
Converts XML to and from JSON.
Object Model
XmlNodeConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XmlNodeConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As XmlNodeConverter
public class XmlNodeConverter : Noemax.Newtonsoft.Json.JsonConverter
public class XmlNodeConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class XmlNodeConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class XmlNodeConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class XmlNodeConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


XmlNodeConverter Class Members

XmlNodeConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : XmlNodeConverter Class

The following tables list the members exposed by XmlNodeConverter.

Public Constructors
 | Name | Description
Public Constructor | XmlNodeConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | DeserializeRootElementName | Gets or sets the name of the root element to insert when deserializing to XML if the JSON structure has produces multiple root elements.
Public Property | OmitRootObject | Gets or sets a value indicating whether to write the root JSON object.
Public Property | WriteArrayAttribute | Gets or sets a flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

XmlNodeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


XmlNodeConverter Constructor

XmlNodeConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : XmlNodeConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New XmlNodeConverter()
public XmlNodeConverter()
public XmlNodeConverter();
public function XmlNodeConverter();
public: XmlNodeConverter();
public:
XmlNodeConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members


XmlNodeConverter Class Methods

XmlNodeConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : XmlNodeConverter Class

For a list of all members of this type, see XmlNodeConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified value type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

XmlNodeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (XmlNodeConverter)

CanConvert Method (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : CanConvert Method
Type of the value.
Determines whether this instance can convert the specified value type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal valueType As System.Type _
) As System.Boolean
'Usage

Dim instance As XmlNodeConverter
Dim valueType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(valueType)
public override System.bool CanConvert(
   System.Type valueType
)
public function CanConvert(
    valueType: System.Type
): System.Boolean; override;
public override function CanConvert(
   valueType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* valueType
) override
public:
System.bool CanConvert(
   System.Type^ valueType
) override

Parameters

valueType
Type of the value.

Return Value

true if this instance can convert the specified value type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members
Base Implementation in CanConvert


ReadJson Method (XmlNodeConverter)

ReadJson Method (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As XmlNodeConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members
Base Implementation in ReadJson


WriteJson Method (XmlNodeConverter)

WriteJson Method (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As XmlNodeConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members
Base Implementation in WriteJson


XmlNodeConverter Class Properties

XmlNodeConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : XmlNodeConverter Class

For a list of all members of this type, see XmlNodeConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | DeserializeRootElementName | Gets or sets the name of the root element to insert when deserializing to XML if the JSON structure has produces multiple root elements.
Public Property | OmitRootObject | Gets or sets a value indicating whether to write the root JSON object.
Public Property | WriteArrayAttribute | Gets or sets a flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.
Top
See Also

Reference

XmlNodeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DeserializeRootElementName Property (XmlNodeConverter)

DeserializeRootElementName Property (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : DeserializeRootElementName Property
Gets or sets the name of the root element to insert when deserializing to XML if the JSON structure has produces multiple root elements.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeserializeRootElementName As System.String
'Usage

Dim instance As XmlNodeConverter
Dim value As System.String

instance.DeserializeRootElementName = value

value = instance.DeserializeRootElementName
public System.string DeserializeRootElementName {get; set;}
public read-write property DeserializeRootElementName: System.String;
public function get,set DeserializeRootElementName : System.String
public: __property System.string* get_DeserializeRootElementName();
public: __property void set_DeserializeRootElementName(
   System.string* value
);
public:
property System.String^ DeserializeRootElementName {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The name of the deserialize root element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members


OmitRootObject Property (XmlNodeConverter)

OmitRootObject Property (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : OmitRootObject Property
Gets or sets a value indicating whether to write the root JSON object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OmitRootObject As System.Boolean
'Usage

Dim instance As XmlNodeConverter
Dim value As System.Boolean

instance.OmitRootObject = value

value = instance.OmitRootObject
public System.bool OmitRootObject {get; set;}
public read-write property OmitRootObject: System.Boolean;
public function get,set OmitRootObject : System.boolean
public: __property System.bool get_OmitRootObject();
public: __property void set_OmitRootObject(
   System.bool value
);
public:
property System.bool OmitRootObject {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the JSON root object is omitted; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members


WriteArrayAttribute Property (XmlNodeConverter)

WriteArrayAttribute Property (XmlNodeConverter)

Noemax.Newtonsoft.Json.Converters Namespace > XmlNodeConverter Class : WriteArrayAttribute Property
Gets or sets a flag to indicate whether to write the Json.NET array attribute. This attribute helps preserve arrays when converting the written XML back to JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WriteArrayAttribute As System.Boolean
'Usage

Dim instance As XmlNodeConverter
Dim value As System.Boolean

instance.WriteArrayAttribute = value

value = instance.WriteArrayAttribute
public System.bool WriteArrayAttribute {get; set;}
public read-write property WriteArrayAttribute: System.Boolean;
public function get,set WriteArrayAttribute : System.boolean
public: __property System.bool get_WriteArrayAttribute();
public: __property void set_WriteArrayAttribute(
   System.bool value
);
public:
property System.bool WriteArrayAttribute {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the array attibute is written to the XML; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlNodeConverter Class
XmlNodeConverter Members


Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | Extensions | Contains the LINQ to JSON extension methods.
Class | JArray | Represents a JSON array.
Class | JConstructor | Represents a JSON constructor.
Class | JContainer | Represents a token that can contain other tokens.
Class | JObject | Represents a JSON object.
Class | JProperty | Represents a JSON property.
Class | JPropertyDescriptor | Represents a view of a JProperty.
Class | JRaw | Represents a raw JSON string.
Class | JToken | Represents an abstract JSON token.
Class | JTokenEqualityComparer | Compares tokens to determine whether they are equal.
Class | JTokenReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | JTokenWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JValue | Represents a value in JSON (string, integer, date, etc).
Interfaces
 | Interface | Description
Interface | IJEnumerable<T> | Represents a collection of JToken objects.
Structures
 | Structure | Description
Structure | JEnumerable<T> | Represents a collection of JToken objects.
Enumerations
 | Enumeration | Description
Enumeration | JTokenType | Specifies the type of token.
See Also

Reference

Noemax.WebSockets Assembly


Extensions Class

Extensions Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : Extensions Class
Contains the LINQ to JSON extension methods.
Object Model
Extensions Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public MustInherit NotInheritable Class Extensions
'Usage

Dim instance As Extensions
[System.Runtime.CompilerServices.Extension()]
public static class Extensions
public class Extensions abstract; sealed;
System.Runtime.CompilerServices.ExtensionAttribute()
public abstract sealed class Extensions
[System.Runtime.CompilerServices.Extension()]
public __gc abstract __sealed class Extensions
[System.Runtime.CompilerServices.Extension()]
public ref class Extensions abstract sealed
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.Extensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Members
Noemax.Newtonsoft.Json.Linq Namespace


Extensions Class Members

Extensions Class Members
Methods

Noemax.Newtonsoft.Json.Linq Namespace : Extensions Class

The following tables list the members exposed by Extensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Ancestors<T> | Returns a collection of tokens that contains the ancestors of every token in the source collection.
static (Shared in Visual Basic) | AsJEnumerable | Overloaded. Returns the input typed as IJEnumerable<T>.
static (Shared in Visual Basic) | Children | Overloaded. Returns a collection of child tokens of every array in the source collection.
static (Shared in Visual Basic) | Descendants<T> | Returns a collection of tokens that contains the descendants of every token in the source collection.
static (Shared in Visual Basic) | Properties | Returns a collection of child properties of every object in the source collection.
static (Shared in Visual Basic) | Value | Overloaded. Converts the value.
static (Shared in Visual Basic) | Values | Overloaded. Returns a collection of child values of every object in the source collection with the given key.
Top
See Also

Reference

Extensions Class
Noemax.Newtonsoft.Json.Linq Namespace


Extensions Class Methods

Extensions Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : Extensions Class

For a list of all members of this type, see Extensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Ancestors<T> | Returns a collection of tokens that contains the ancestors of every token in the source collection.
static (Shared in Visual Basic) | AsJEnumerable | Overloaded. Returns the input typed as IJEnumerable<T>.
static (Shared in Visual Basic) | Children | Overloaded. Returns a collection of child tokens of every array in the source collection.
static (Shared in Visual Basic) | Descendants<T> | Returns a collection of tokens that contains the descendants of every token in the source collection.
static (Shared in Visual Basic) | Properties | Returns a collection of child properties of every object in the source collection.
static (Shared in Visual Basic) | Value | Overloaded. Converts the value.
static (Shared in Visual Basic) | Values | Overloaded. Returns a collection of child values of every object in the source collection with the given key.
Top
See Also

Reference

Extensions Class
Noemax.Newtonsoft.Json.Linq Namespace


Ancestors<T> Method (Extensions)

Ancestors<T> Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Ancestors<T> Method
The type of the objects in source, constrained to JToken.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of tokens that contains the ancestors of every token in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Shared Function Ancestors(Of T As JToken)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of T)
Dim value As IJEnumerable(Of JToken)

value = Extensions.Ancestors(Of T)(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> Ancestors<T>(
   System.Collections.Generic.IEnumerable<T> source
)
where T: JToken
public function Ancestors(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Ancestors(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* Ancestors<T>(
   System.Collections.Generic.IEnumerable<T*>* source
)
where T: JToken
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ Ancestorsgeneric<typename T>
(
   System.Collections.Generic.IEnumerable<T^>^ source
)
where T: JToken

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

T
The type of the objects in source, constrained to JToken.

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken that contains the ancestors of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


AsJEnumerable Method (Extensions)

AsJEnumerable Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : AsJEnumerable Method
Returns the input typed as IJEnumerable<T>.
Overload List
Overload | Description
AsJEnumerable(IEnumerable<JToken>) | Returns the input typed as IJEnumerable<T>.
AsJEnumerable<T>(IEnumerable<T>) | Returns the input typed as IJEnumerable<T>.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


AsJEnumerable(IEnumerable<JToken>) Method

AsJEnumerable(IEnumerable<JToken>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > AsJEnumerable Method : AsJEnumerable(IEnumerable<JToken>) Method
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns the input typed as IJEnumerable<T>.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function AsJEnumerable( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JToken) _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JToken)
Dim value As IJEnumerable(Of JToken)

value = Extensions.AsJEnumerable(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> AsJEnumerable(
   System.Collections.Generic.IEnumerable<JToken> source
)
public function AsJEnumerable(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function AsJEnumerable(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* AsJEnumerable(
   System.Collections.Generic.IEnumerable<JToken*>* source
)
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ AsJEnumerable(
   System.Collections.Generic.IEnumerable<JToken^>^ source
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Return Value

The input typed as IJEnumerable<T>.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


AsJEnumerable<T>(IEnumerable<T>) Method

AsJEnumerable<T>(IEnumerable<T>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > AsJEnumerable Method : AsJEnumerable<T>(IEnumerable<T>) Method
The source collection type.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns the input typed as IJEnumerable<T>.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function AsJEnumerable(Of T As JToken)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As IJEnumerable(Of T)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of T)
Dim value As IJEnumerable(Of T)

value = Extensions.AsJEnumerable(Of T)(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<T> AsJEnumerable<T>(
   System.Collections.Generic.IEnumerable<T> source
)
where T: JToken
public function AsJEnumerable(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function AsJEnumerable(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<T*>* AsJEnumerable<T>(
   System.Collections.Generic.IEnumerable<T*>* source
)
where T: JToken
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<T^>^ AsJEnumerablegeneric<typename T>
(
   System.Collections.Generic.IEnumerable<T^>^ source
)
where T: JToken

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

T
The source collection type.

Return Value

The input typed as IJEnumerable<T>.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Children Method (Extensions)

Children Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Children Method
Returns a collection of child tokens of every array in the source collection.
Overload List
Overload | Description
Children<T>(IEnumerable<T>) | Returns a collection of child tokens of every array in the source collection.
Children<T,U>(IEnumerable<T>) | Returns a collection of converted child tokens of every array in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Children<T>(IEnumerable<T>) Method

Children<T>(IEnumerable<T>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Children Method : Children<T>(IEnumerable<T>) Method
The source collection type.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of child tokens of every array in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Children(Of T As JToken)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of T)
Dim value As IJEnumerable(Of JToken)

value = Extensions.Children(Of T)(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> Children<T>(
   System.Collections.Generic.IEnumerable<T> source
)
where T: JToken
public function Children(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Children(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* Children<T>(
   System.Collections.Generic.IEnumerable<T*>* source
)
where T: JToken
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ Childrengeneric<typename T>
(
   System.Collections.Generic.IEnumerable<T^>^ source
)
where T: JToken

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

T
The source collection type.

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken that contains the values of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Children<T,U>(IEnumerable<T>) Method

Children<T,U>(IEnumerable<T>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Children Method : Children<T,U>(IEnumerable<T>) Method
The source collection type.
The type to convert the values to.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of converted child tokens of every array in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Children
    (Of T As JToken,
     U)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As System.Collections.Generic.IEnumerable(Of U)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of T)
Dim value As System.Collections.Generic.IEnumerable(Of U)

value = Extensions.Children(Of T, U)(source)
[System.Runtime.CompilerServices.Extension()]
public static System.Collections.Generic.IEnumerable<U> Children<T,U>(
   System.Collections.Generic.IEnumerable<T> source
)
where T: JToken
public function Children(
    source: System.Collections.Generic.IEnumerable
): System.Collections.Generic.IEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Children(
   source : System.Collections.Generic.IEnumerable
) : System.Collections.Generic.IEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static System.Collections.Generic.IEnumerable<U*>* Children<T,U>(
   System.Collections.Generic.IEnumerable<T*>* source
)
where T: JToken
[System.Runtime.CompilerServices.Extension()]
public:
static System.Collections.Generic.IEnumerable<U^>^ Childrengeneric<typename T>
generic<typename U>
(
   System.Collections.Generic.IEnumerable<T^>^ source
)
where T: JToken

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

T
The source collection type.
U
The type to convert the values to.

Return Value

An System.Collections.Generic.IEnumerable`1 that contains the converted values of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Descendants<T> Method (Extensions)

Descendants<T> Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Descendants<T> Method
The type of the objects in source, constrained to JContainer.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of tokens that contains the descendants of every token in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Shared Function Descendants(Of T As JContainer)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of T)
Dim value As IJEnumerable(Of JToken)

value = Extensions.Descendants(Of T)(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> Descendants<T>(
   System.Collections.Generic.IEnumerable<T> source
)
where T: JContainer
public function Descendants(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Descendants(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* Descendants<T>(
   System.Collections.Generic.IEnumerable<T*>* source
)
where T: JContainer
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ Descendantsgeneric<typename T>
(
   System.Collections.Generic.IEnumerable<T^>^ source
)
where T: JContainer

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

T
The type of the objects in source, constrained to JContainer.

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken that contains the descendants of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Properties Method (Extensions)

Properties Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Properties Method
An System.Collections.Generic.IEnumerable`1 of JObject that contains the source collection.
Returns a collection of child properties of every object in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Shared Function Properties( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JObject) _
) As IJEnumerable(Of JProperty)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JObject)
Dim value As IJEnumerable(Of JProperty)

value = Extensions.Properties(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JProperty> Properties(
   System.Collections.Generic.IEnumerable<JObject> source
)
public function Properties(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Properties(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JProperty*>* Properties(
   System.Collections.Generic.IEnumerable<JObject*>* source
)
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JProperty^>^ Properties(
   System.Collections.Generic.IEnumerable<JObject^>^ source
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JObject that contains the source collection.

Return Value

An System.Collections.Generic.IEnumerable`1 of JProperty that contains the properties of every object in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Value Method (Extensions)

Value Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Value Method
Converts the value.
Overload List
Overload | Description
Value<U>(IEnumerable<JToken>) | Converts the value.
Value<T,U>(IEnumerable<T>) | Converts the value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Value<U>(IEnumerable<JToken>) Method

Value<U>(IEnumerable<JToken>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Value Method : Value<U>(IEnumerable<JToken>) Method
The type to convert the value to.
A JToken cast as a System.Collections.Generic.IEnumerable`1 of JToken.
Converts the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Value(Of U)( _
   ByVal value As System.Collections.Generic.IEnumerable(Of JToken) _
) As U
'Usage

Dim value As System.Collections.Generic.IEnumerable(Of JToken)
Dim value As U

value = Extensions.Value(Of U)(value)
[System.Runtime.CompilerServices.Extension()]
public static U Value<U>(
   System.Collections.Generic.IEnumerable<JToken> value
)
public function Value(
    value: System.Collections.Generic.IEnumerable
): U; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Value(
   value : System.Collections.Generic.IEnumerable
) : U;
[System.Runtime.CompilerServices.Extension()]
public: static U* Value<U>(
   System.Collections.Generic.IEnumerable<JToken*>* value
)
[System.Runtime.CompilerServices.Extension()]
public:
static U^ Valuegeneric<typename U>
(
   System.Collections.Generic.IEnumerable<JToken^>^ value
)

Parameters

value
A JToken cast as a System.Collections.Generic.IEnumerable`1 of JToken.

Type Parameters

U
The type to convert the value to.

Return Value

A converted value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Value<T,U>(IEnumerable<T>) Method

Value<T,U>(IEnumerable<T>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Value Method : Value<T,U>(IEnumerable<T>) Method
The source collection type.
The type to convert the value to.
A JToken cast as a System.Collections.Generic.IEnumerable`1 of JToken.
Converts the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Value
    (Of T As JToken,
     U)( _
   ByVal value As System.Collections.Generic.IEnumerable(Of T) _
) As U
'Usage

Dim value As System.Collections.Generic.IEnumerable(Of T)
Dim value As U

value = Extensions.Value(Of T, U)(value)
[System.Runtime.CompilerServices.Extension()]
public static U Value<T,U>(
   System.Collections.Generic.IEnumerable<T> value
)
where T: JToken
public function Value(
    value: System.Collections.Generic.IEnumerable
): U; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Value(
   value : System.Collections.Generic.IEnumerable
) : U;
[System.Runtime.CompilerServices.Extension()]
public: static U* Value<T,U>(
   System.Collections.Generic.IEnumerable<T*>* value
)
where T: JToken
[System.Runtime.CompilerServices.Extension()]
public:
static U^ Valuegeneric<typename T>
generic<typename U>
(
   System.Collections.Generic.IEnumerable<T^>^ value
)
where T: JToken

Parameters

value
A JToken cast as a System.Collections.Generic.IEnumerable`1 of JToken.

Type Parameters

T
The source collection type.
U
The type to convert the value to.

Return Value

A converted value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Values Method (Extensions)

Values Method (Extensions)

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class : Values Method
Returns a collection of child values of every object in the source collection with the given key.
Overload List
Overload | Description
Values(IEnumerable<JToken>,Object) | Returns a collection of child values of every object in the source collection with the given key.
Values(IEnumerable<JToken>) | Returns a collection of child values of every object in the source collection.
Values<U>(IEnumerable<JToken>,Object) | Returns a collection of converted child values of every object in the source collection with the given key.
Values<U>(IEnumerable<JToken>) | Returns a collection of converted child values of every object in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Values(IEnumerable<JToken>,Object) Method

Values(IEnumerable<JToken>,Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Values Method : Values(IEnumerable<JToken>,Object) Method
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
The token key.
Returns a collection of child values of every object in the source collection with the given key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Values( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JToken), _
   ByVal key As System.Object _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JToken)
Dim key As System.Object
Dim value As IJEnumerable(Of JToken)

value = Extensions.Values(source, key)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> Values(
   System.Collections.Generic.IEnumerable<JToken> source,
   System.object key
)
public function Values(
    source: System.Collections.Generic.IEnumerable;
    key: System.TObject
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Values(
   source : System.Collections.Generic.IEnumerable,
   key : System.Object
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* Values(
   System.Collections.Generic.IEnumerable<JToken*>* source,
   System.Object* key
)
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ Values(
   System.Collections.Generic.IEnumerable<JToken^>^ source,
   System.Object^ key
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
key
The token key.

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken that contains the values of every node in the source collection with the given key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Values(IEnumerable<JToken>) Method

Values(IEnumerable<JToken>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Values Method : Values(IEnumerable<JToken>) Method
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of child values of every object in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Values( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JToken) _
) As IJEnumerable(Of JToken)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JToken)
Dim value As IJEnumerable(Of JToken)

value = Extensions.Values(source)
[System.Runtime.CompilerServices.Extension()]
public static IJEnumerable<JToken> Values(
   System.Collections.Generic.IEnumerable<JToken> source
)
public function Values(
    source: System.Collections.Generic.IEnumerable
): IJEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Values(
   source : System.Collections.Generic.IEnumerable
) : IJEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static IJEnumerable<JToken*>* Values(
   System.Collections.Generic.IEnumerable<JToken*>* source
)
[System.Runtime.CompilerServices.Extension()]
public:
static IJEnumerable<JToken^>^ Values(
   System.Collections.Generic.IEnumerable<JToken^>^ source
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken that contains the values of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Values<U>(IEnumerable<JToken>,Object) Method

Values<U>(IEnumerable<JToken>,Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Values Method : Values<U>(IEnumerable<JToken>,Object) Method
The type to convert the values to.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
The token key.
Returns a collection of converted child values of every object in the source collection with the given key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Values(Of U)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JToken), _
   ByVal key As System.Object _
) As System.Collections.Generic.IEnumerable(Of U)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JToken)
Dim key As System.Object
Dim value As System.Collections.Generic.IEnumerable(Of U)

value = Extensions.Values(Of U)(source, key)
[System.Runtime.CompilerServices.Extension()]
public static System.Collections.Generic.IEnumerable<U> Values<U>(
   System.Collections.Generic.IEnumerable<JToken> source,
   System.object key
)
public function Values(
    source: System.Collections.Generic.IEnumerable;
    key: System.TObject
): System.Collections.Generic.IEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Values(
   source : System.Collections.Generic.IEnumerable,
   key : System.Object
) : System.Collections.Generic.IEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static System.Collections.Generic.IEnumerable<U*>* Values<U>(
   System.Collections.Generic.IEnumerable<JToken*>* source,
   System.Object* key
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Collections.Generic.IEnumerable<U^>^ Valuesgeneric<typename U>
(
   System.Collections.Generic.IEnumerable<JToken^>^ source,
   System.Object^ key
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
key
The token key.

Type Parameters

U
The type to convert the values to.

Return Value

An System.Collections.Generic.IEnumerable`1 that contains the converted values of every node in the source collection with the given key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Values<U>(IEnumerable<JToken>) Method

Values<U>(IEnumerable<JToken>) Method

Noemax.Newtonsoft.Json.Linq Namespace > Extensions Class > Values Method : Values<U>(IEnumerable<JToken>) Method
The type to convert the values to.
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.
Returns a collection of converted child values of every object in the source collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Values(Of U)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of JToken) _
) As System.Collections.Generic.IEnumerable(Of U)
'Usage

Dim source As System.Collections.Generic.IEnumerable(Of JToken)
Dim value As System.Collections.Generic.IEnumerable(Of U)

value = Extensions.Values(Of U)(source)
[System.Runtime.CompilerServices.Extension()]
public static System.Collections.Generic.IEnumerable<U> Values<U>(
   System.Collections.Generic.IEnumerable<JToken> source
)
public function Values(
    source: System.Collections.Generic.IEnumerable
): System.Collections.Generic.IEnumerable; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Values(
   source : System.Collections.Generic.IEnumerable
) : System.Collections.Generic.IEnumerable;
[System.Runtime.CompilerServices.Extension()]
public: static System.Collections.Generic.IEnumerable<U*>* Values<U>(
   System.Collections.Generic.IEnumerable<JToken*>* source
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Collections.Generic.IEnumerable<U^>^ Valuesgeneric<typename U>
(
   System.Collections.Generic.IEnumerable<JToken^>^ source
)

Parameters

source
An System.Collections.Generic.IEnumerable`1 of JToken that contains the source collection.

Type Parameters

U
The type to convert the values to.

Return Value

An System.Collections.Generic.IEnumerable`1 that contains the converted values of every node in the source collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


JArray Class

JArray Class
Members Example

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class
Represents a JSON array.
Object Model
JArray Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Class JArray
   Inherits JContainer
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JArray
[System.Reflection.DefaultMember("Item")]
public class JArray : JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JArray = class(JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
System.Reflection.DefaultMemberAttribute("Item")
public class JArray extends JContainer implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
[System.Reflection.DefaultMember("Item")]
public __gc class JArray : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
[System.Reflection.DefaultMember("Item")]
public ref class JArray : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Example
  • C#

Inheritance Hierarchy
System.Object
   Noemax.Newtonsoft.Json.Linq.JToken
      Noemax.Newtonsoft.Json.Linq.JContainer
         Noemax.Newtonsoft.Json.Linq.JArray

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
JArray Members

Noemax.Newtonsoft.Json.Linq Namespace


JArray Class Members

JArray Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

The following tables list the members exposed by JArray.

Public Constructors
 | Name | Description
Public Constructor | JArray Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | IsReadOnly | Gets a value indicating whether the System.Collections.Generic.ICollection`1 is read-only.
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an item to the System.Collections.Generic.ICollection`1.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Clear | Removes all items from the System.Collections.Generic.ICollection`1.
Public Method | Contains | Determines whether the System.Collections.Generic.ICollection`1 contains a specific value.
Public Method | CopyTo | Copies to.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JArray from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.Generic.IList`1.
Public Method | Insert | Inserts an item to the System.Collections.Generic.IList`1 at the specified index.
static (Shared in Visual Basic) | Load | Loads an JArray from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JArray from a string that contains JSON.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | RemoveAt | Removes the System.Collections.Generic.IList`1 item at the specified index.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the JContainer.AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the JContainer.ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


JArray Constructor

JArray Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : JArray Constructor
Overload List
Overload | Description
JArray Constructor() | Initializes a new instance of the JArray class.
JArray Constructor(JArray) | Initializes a new instance of the JArray class from another JArray object.
JArray Constructor(Object[]) | Initializes a new instance of the JArray class with the specified content.
JArray Constructor(Object) | Initializes a new instance of the JArray class with the specified content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


JArray Constructor()

JArray Constructor()

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > JArray Constructor : JArray Constructor()
Initializes a new instance of the JArray class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JArray()
public JArray()
public JArray();
public function JArray();
public: JArray();
public:
JArray();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


JArray Constructor(JArray)

JArray Constructor(JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > JArray Constructor : JArray Constructor(JArray)
A JArray object to copy from.
Initializes a new instance of the JArray class from another JArray object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JArray _
)
'Usage

Dim other As JArray

Dim instance As New JArray(other)
public JArray(
   JArray other
)
public JArray(
    other: JArray
);
public function JArray(
   other : JArray
);
public: JArray(
   JArray* other
)
public:
JArray(
   JArray^ other
)

Parameters

other
A JArray object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


JArray Constructor(Object[])

JArray Constructor(Object[])

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > JArray Constructor : JArray Constructor(Object[])
The contents of the array.
Initializes a new instance of the JArray class with the specified content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ParamArray content() As System.Object _
)
'Usage

Dim content() As System.Object

Dim instance As New JArray(content)
public JArray(
   params System.object[] content
)
public JArray(
   params  content: System.TObjectarray of
);
public function JArray(
   content : System.Object[]
);
public: JArray(
   params System.Object*[]* content
)
public:
JArray(
   ... System.array<Object^>^ content
)

Parameters

content
The contents of the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


JArray Constructor(Object)

JArray Constructor(Object)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > JArray Constructor : JArray Constructor(Object)
The contents of the array.
Initializes a new instance of the JArray class with the specified content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As System.Object _
)
'Usage

Dim content As System.Object

Dim instance As New JArray(content)
public JArray(
   System.object content
)
public JArray(
    content: System.TObject
);
public function JArray(
   content : System.Object
);
public: JArray(
   System.Object* content
)
public:
JArray(
   System.Object^ content
)

Parameters

content
The contents of the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


JArray Class Methods

JArray Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

For a list of all members of this type, see JArray members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an item to the System.Collections.Generic.ICollection`1.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Clear | Removes all items from the System.Collections.Generic.ICollection`1.
Public Method | Contains | Determines whether the System.Collections.Generic.ICollection`1 contains a specific value.
Public Method | CopyTo | Copies to.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JArray from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.Generic.IList`1.
Public Method | Insert | Inserts an item to the System.Collections.Generic.IList`1 at the specified index.
static (Shared in Visual Basic) | Load | Loads an JArray from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JArray from a string that contains JSON.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | RemoveAt | Removes the System.Collections.Generic.IList`1 item at the specified index.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the JContainer.AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the JContainer.ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


Add Method (JArray)

Add Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Add Method
Adds an item to the System.Collections.Generic.ICollection`1.
Overload List
Overload | Description
Add(JToken) | Adds an item to the System.Collections.Generic.ICollection`1.
Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Add(JToken) Method

Add(JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > Add Method : Add(JToken) Method
The object to add to the System.Collections.Generic.ICollection`1.
Adds an item to the System.Collections.Generic.ICollection`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal item As JToken _
)
'Usage

Dim instance As JArray
Dim item As JToken

instance.Add(item)
public void Add(
   JToken item
)
public procedure Add(
    item: JToken
);
public function Add(
   item : JToken
);
public: void Add(
   JToken* item
)
public:
void Add(
   JToken^ item
)

Parameters

item
The object to add to the System.Collections.Generic.ICollection`1.
Exceptions
Exception | Description
System.NotSupportedException | The System.Collections.Generic.ICollection`1 is read-only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


Clear Method (JArray)

Clear Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Clear Method
Removes all items from the System.Collections.Generic.ICollection`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As JArray

instance.Clear()
public void Clear()
public procedure Clear();
public function Clear();
public: void Clear();
public:
void Clear();
Exceptions
Exception | Description
System.NotSupportedException | The System.Collections.Generic.ICollection`1 is read-only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Contains Method (JArray)

Contains Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Contains Method
The object to locate in the System.Collections.Generic.ICollection`1.
Determines whether the System.Collections.Generic.ICollection`1 contains a specific value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Contains( _
   ByVal item As JToken _
) As System.Boolean
'Usage

Dim instance As JArray
Dim item As JToken
Dim value As System.Boolean

value = instance.Contains(item)
public System.bool Contains(
   JToken item
)
public function Contains(
    item: JToken
): System.Boolean;
public function Contains(
   item : JToken
) : System.boolean;
public: System.bool Contains(
   JToken* item
)
public:
System.bool Contains(
   JToken^ item
)

Parameters

item
The object to locate in the System.Collections.Generic.ICollection`1.

Return Value

true if item is found in the System.Collections.Generic.ICollection`1; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


CopyTo Method (JArray)

CopyTo Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : CopyTo Method
The array.
Index of the array.
Copies to.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As JToken, _
   ByVal arrayIndex As System.Integer _
)
'Usage

Dim instance As JArray
Dim array() As JToken
Dim arrayIndex As System.Integer

instance.CopyTo(array, arrayIndex)
public void CopyTo(
   JToken[] array,
   System.int arrayIndex
)
public procedure CopyTo(
    array: JTokenarray of;
    arrayIndex: System.Integer
);
public function CopyTo(
   array : JToken[],
   arrayIndex : System.int
);
public: void CopyTo(
   JToken*[]* array,
   System.int arrayIndex
)
public:
void CopyTo(
   array<JToken^>^ array,
   System.int arrayIndex
)

Parameters

array
The array.
arrayIndex
Index of the array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


FromObject Method (JArray)

FromObject Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : FromObject Method
Creates a JArray from an object.
Overload List
Overload | Description
FromObject(Object) | Creates a JArray from an object.
FromObject(Object,JsonSerializer) | Creates a JArray from an object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


FromObject(Object) Method

FromObject(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > FromObject Method : FromObject(Object) Method
The object that will be used to create JArray.
Creates a JArray from an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object _
) As JArray
'Usage

Dim o As System.Object
Dim value As JArray

value = JArray.FromObject(o)
public static JArray FromObject(
   System.object o
)
public function FromObject(
    o: System.TObject
): JArray; static;
public static function FromObject(
   o : System.Object
) : JArray;
public: static JArray* FromObject(
   System.Object* o
)
public:
static JArray^ FromObject(
   System.Object^ o
)

Parameters

o
The object that will be used to create JArray.

Return Value

A JArray with the values of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


FromObject(Object,JsonSerializer) Method

FromObject(Object,JsonSerializer) Method

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > FromObject Method : FromObject(Object,JsonSerializer) Method
The object that will be used to create JArray.
The Noemax.Newtonsoft.Json.JsonSerializer that will be used to read the object.
Creates a JArray from an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object, _
   ByVal jsonSerializer As JsonSerializer _
) As JArray
'Usage

Dim o As System.Object
Dim jsonSerializer As JsonSerializer
Dim value As JArray

value = JArray.FromObject(o, jsonSerializer)
public static JArray FromObject(
   System.object o,
   JsonSerializer jsonSerializer
)
public function FromObject(
    o: System.TObject;
    jsonSerializer: JsonSerializer
): JArray; static;
public static function FromObject(
   o : System.Object,
   jsonSerializer : JsonSerializer
) : JArray;
public: static JArray* FromObject(
   System.Object* o,
   JsonSerializer* jsonSerializer
)
public:
static JArray^ FromObject(
   System.Object^ o,
   JsonSerializer^ jsonSerializer
)

Parameters

o
The object that will be used to create JArray.
jsonSerializer
The Noemax.Newtonsoft.Json.JsonSerializer that will be used to read the object.

Return Value

A JArray with the values of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


GetEnumerator Method (JArray)

GetEnumerator Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : GetEnumerator Method
Returns an enumerator that iterates through the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of JToken)
'Usage

Dim instance As JArray
Dim value As System.Collections.Generic.IEnumerator(Of JToken)

value = instance.GetEnumerator()
public System.Collections.Generic.IEnumerator<JToken> GetEnumerator()
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
public: System.Collections.Generic.IEnumerator<JToken*>* GetEnumerator();
public:
System.Collections.Generic.IEnumerator<JToken^>^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator`1 that can be used to iterate through the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


IndexOf Method (JArray)

IndexOf Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : IndexOf Method
The object to locate in the System.Collections.Generic.IList`1.
Determines the index of a specific item in the System.Collections.Generic.IList`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IndexOf( _
   ByVal item As JToken _
) As System.Integer
'Usage

Dim instance As JArray
Dim item As JToken
Dim value As System.Integer

value = instance.IndexOf(item)
public System.int IndexOf(
   JToken item
)
public function IndexOf(
    item: JToken
): System.Integer;
public function IndexOf(
   item : JToken
) : System.int;
public: System.int IndexOf(
   JToken* item
)
public:
System.int IndexOf(
   JToken^ item
)

Parameters

item
The object to locate in the System.Collections.Generic.IList`1.

Return Value

The index of item if found in the list; otherwise, -1.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Insert Method (JArray)

Insert Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Insert Method
The zero-based index at which item should be inserted.
The object to insert into the System.Collections.Generic.IList`1.
Inserts an item to the System.Collections.Generic.IList`1 at the specified index.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As JToken _
)
'Usage

Dim instance As JArray
Dim index As System.Integer
Dim item As JToken

instance.Insert(index, item)
public void Insert(
   System.int index,
   JToken item
)
public procedure Insert(
    index: System.Integer;
    item: JToken
);
public function Insert(
   index : System.int,
   item : JToken
);
public: void Insert(
   System.int index,
   JToken* item
)
public:
void Insert(
   System.int index,
   JToken^ item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert into the System.Collections.Generic.IList`1.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is not a valid index in the System.Collections.Generic.IList`1.
System.NotSupportedException | The System.Collections.Generic.IList`1 is read-only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Load Method (JArray)

Load Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Load Method
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JArray.
Loads an JArray from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Load( _
   ByVal reader As JsonReader _
) As JArray
'Usage

Dim reader As JsonReader
Dim value As JArray

value = JArray.Load(reader)
public static JArray Load(
   JsonReader reader
)
public function Load(
    reader: JsonReader
): JArray; static;
public static function Load(
   reader : JsonReader
) : JArray;
public: static JArray* Load(
   JsonReader* reader
)
public:
static JArray^ Load(
   JsonReader^ reader
)

Parameters

reader
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JArray.

Return Value

A JArray that contains the JSON that was read from the specified Noemax.Newtonsoft.Json.JsonReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Parse Method (JArray)

Parse Method (JArray)
Example

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Parse Method
A System.String that contains JSON.
Load a JArray from a string that contains JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Parse( _
   ByVal json As System.String _
) As JArray
'Usage

Dim json As System.String
Dim value As JArray

value = JArray.Parse(json)
public static JArray Parse(
   System.string json
)
public function Parse(
    json: System.String
): JArray; static;
public static function Parse(
   json : System.String
) : JArray;
public: static JArray* Parse(
   System.string* json
)
public:
static JArray^ Parse(
   System.String^ json
)

Parameters

json
A System.String that contains JSON.

Return Value

A JArray populated from the string that contains JSON.
Example
  • C#

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
JArray Class

JArray Members


Remove Method (JArray)

Remove Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Remove Method
Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Overload List
Overload | Description
Remove(JToken) | Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Remove(JToken) Method

Remove(JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class > Remove Method : Remove(JToken) Method
The object to remove from the System.Collections.Generic.ICollection`1.
Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal item As JToken _
) As System.Boolean
'Usage

Dim instance As JArray
Dim item As JToken
Dim value As System.Boolean

value = instance.Remove(item)
public System.bool Remove(
   JToken item
)
public function Remove(
    item: JToken
): System.Boolean;
public function Remove(
   item : JToken
) : System.boolean;
public: System.bool Remove(
   JToken* item
)
public:
System.bool Remove(
   JToken^ item
)

Parameters

item
The object to remove from the System.Collections.Generic.ICollection`1.

Return Value

true if item was successfully removed from the System.Collections.Generic.ICollection`1; otherwise, false. This method also returns false if item is not found in the original System.Collections.Generic.ICollection`1.
Exceptions
Exception | Description
System.NotSupportedException | The System.Collections.Generic.ICollection`1 is read-only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Overload List


RemoveAt Method (JArray)

RemoveAt Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : RemoveAt Method
The zero-based index of the item to remove.
Removes the System.Collections.Generic.IList`1 item at the specified index.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JArray
Dim index As System.Integer

instance.RemoveAt(index)
public void RemoveAt(
   System.int index
)
public procedure RemoveAt(
    index: System.Integer
);
public function RemoveAt(
   index : System.int
);
public: void RemoveAt(
   System.int index
)
public:
void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the item to remove.
Exceptions
Exception | Description
System.ArgumentOutOfRangeException | index is not a valid index in the System.Collections.Generic.IList`1.
System.NotSupportedException | The System.Collections.Generic.IList`1 is read-only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


WriteTo Method (JArray)

WriteTo Method (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JArray
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public override void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); override;
public override function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
) override
public:
void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
) override

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Base Implementation in WriteTo


JArray Class Properties

JArray Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

For a list of all members of this type, see JArray members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | IsReadOnly | Gets a value indicating whether the System.Collections.Generic.ICollection`1 is read-only.
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


ChildrenTokens Property (JArray)

ChildrenTokens Property (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : ChildrenTokens Property
Gets the container's children tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ChildrenTokens As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JArray
Dim value As System.Collections.Generic.IList(Of JToken)

value = instance.ChildrenTokens
protected override System.Collections.Generic.IList<JToken> ChildrenTokens {get;}
protected read-only property ChildrenTokens: System.Collections.Generic.IList; override;
protected override function get ChildrenTokens : System.Collections.Generic.IList
protected: __property System.Collections.Generic.IList<JToken*>* get_ChildrenTokens() override;
protected:
property System.Collections.Generic.IList<JToken^>^ ChildrenTokens {
   System.Collections.Generic.IList<JToken^>^ get() override;
}

Property Value

The container's children tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Base Implementation in ChildrenTokens


IsReadOnly Property (JArray)

IsReadOnly Property (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : IsReadOnly Property
Gets a value indicating whether the System.Collections.Generic.ICollection`1 is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
'Usage

Dim instance As JArray
Dim value As System.Boolean

value = instance.IsReadOnly
public System.bool IsReadOnly {get;}
public read-only property IsReadOnly: System.Boolean;
public function get IsReadOnly : System.boolean
public: __property System.bool get_IsReadOnly();
public:
property System.bool IsReadOnly {
   System.bool get();
}

Property Value

true if the System.Collections.Generic.ICollection`1 is read-only; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members


Item Property (JArray)

Item Property (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Item Property
Gets the JToken with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Default Property Item( _
   ByVal key As System.Object _
) As JToken
'Usage

Dim instance As JArray
Dim key As System.Object
Dim value As JToken

instance.Item(key) = value

value = instance.Item(key)
public override JToken this[
   System.object key
]; {get; set;}
public  this: : JToken;[
    key: System.TObject
];override;  read-write
public override  this[
   key : System.Object
] get,set : JToken
public: __property JToken* get_Item   System.Object* key
 override;
public: __property void set_Item   System.Object* key,
   JToken* value
 override;
public:
property JToken^ default [Object^] override {
   JToken^ get(System.Object^ key) override;
   void set (System.Object^ key, JToken^ value) override;
}

Parameters

key

Property Value

The JToken with the specified key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Base Implementation in Item


Type Property (JArray)

Type Property (JArray)

Noemax.Newtonsoft.Json.Linq Namespace > JArray Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As JTokenType
'Usage

Dim instance As JArray
Dim value As JTokenType

value = instance.Type
public override JTokenType Type {get;}
public read-only property Type: JTokenType; override;
public override function get Type : JTokenType
public: __property JTokenType get_Type() override;
public:
property JTokenType Type {
   JTokenType get() override;
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JArray Class
JArray Members
Base Implementation in Type


JConstructor Class

JConstructor Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class
Represents a JSON constructor.
Object Model
JConstructor Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Class JConstructor
   Inherits JContainer
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JConstructor
[System.Reflection.DefaultMember("Item")]
public class JConstructor : JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JConstructor = class(JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
System.Reflection.DefaultMemberAttribute("Item")
public class JConstructor extends JContainer implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
[System.Reflection.DefaultMember("Item")]
public __gc class JConstructor : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
[System.Reflection.DefaultMember("Item")]
public ref class JConstructor : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JConstructor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Members
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Class Members

JConstructor Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

The following tables list the members exposed by JConstructor.

Public Constructors
 | Name | Description
Public Constructor | JConstructor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets or sets the name of this constructor.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JConstructor from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the JContainer.AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the JContainer.ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Constructor

JConstructor Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : JConstructor Constructor
Overload List
Overload | Description
JConstructor Constructor() | Initializes a new instance of the JConstructor class.
JConstructor Constructor(JConstructor) | Initializes a new instance of the JConstructor class from another JConstructor object.
JConstructor Constructor(String,Object[]) | Initializes a new instance of the JConstructor class with the specified name and content.
JConstructor Constructor(String,Object) | Initializes a new instance of the JConstructor class with the specified name and content.
JConstructor Constructor(String) | Initializes a new instance of the JConstructor class with the specified name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members


JConstructor Constructor()

JConstructor Constructor()

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class > JConstructor Constructor : JConstructor Constructor()
Initializes a new instance of the JConstructor class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JConstructor()
public JConstructor()
public JConstructor();
public function JConstructor();
public: JConstructor();
public:
JConstructor();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Overload List


JConstructor Constructor(JConstructor)

JConstructor Constructor(JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class > JConstructor Constructor : JConstructor Constructor(JConstructor)
A JConstructor object to copy from.
Initializes a new instance of the JConstructor class from another JConstructor object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JConstructor _
)
'Usage

Dim other As JConstructor

Dim instance As New JConstructor(other)
public JConstructor(
   JConstructor other
)
public JConstructor(
    other: JConstructor
);
public function JConstructor(
   other : JConstructor
);
public: JConstructor(
   JConstructor* other
)
public:
JConstructor(
   JConstructor^ other
)

Parameters

other
A JConstructor object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Overload List


JConstructor Constructor(String,Object[])

JConstructor Constructor(String,Object[])

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class > JConstructor Constructor : JConstructor Constructor(String,Object[])
The constructor name.
The contents of the constructor.
Initializes a new instance of the JConstructor class with the specified name and content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal ParamArray content() As System.Object _
)
'Usage

Dim name As System.String
Dim content() As System.Object

Dim instance As New JConstructor(name, content)
public JConstructor(
   System.string name,
   params System.object[] content
)
public JConstructor(
    name: System.String;
   params  content: System.TObjectarray of
);
public function JConstructor(
   name : System.String,
   content : System.Object[]
);
public: JConstructor(
   System.string* name,
   params System.Object*[]* content
)
public:
JConstructor(
   System.String^ name,
   ... System.array<Object^>^ content
)

Parameters

name
The constructor name.
content
The contents of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Overload List


JConstructor Constructor(String,Object)

JConstructor Constructor(String,Object)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class > JConstructor Constructor : JConstructor Constructor(String,Object)
The constructor name.
The contents of the constructor.
Initializes a new instance of the JConstructor class with the specified name and content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal content As System.Object _
)
'Usage

Dim name As System.String
Dim content As System.Object

Dim instance As New JConstructor(name, content)
public JConstructor(
   System.string name,
   System.object content
)
public JConstructor(
    name: System.String;
    content: System.TObject
);
public function JConstructor(
   name : System.String,
   content : System.Object
);
public: JConstructor(
   System.string* name,
   System.Object* content
)
public:
JConstructor(
   System.String^ name,
   System.Object^ content
)

Parameters

name
The constructor name.
content
The contents of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Overload List


JConstructor Constructor(String)

JConstructor Constructor(String)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class > JConstructor Constructor : JConstructor Constructor(String)
The constructor name.
Initializes a new instance of the JConstructor class with the specified name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String _
)
'Usage

Dim name As System.String

Dim instance As New JConstructor(name)
public JConstructor(
   System.string name
)
public JConstructor(
    name: System.String
);
public function JConstructor(
   name : System.String
);
public: JConstructor(
   System.string* name
)
public:
JConstructor(
   System.String^ name
)

Parameters

name
The constructor name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Overload List


JConstructor Class Methods

JConstructor Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

For a list of all members of this type, see JConstructor members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JConstructor from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the JContainer.AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the JContainer.ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


Load Method (JConstructor)

Load Method (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : Load Method
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JConstructor.
Loads an JConstructor from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Load( _
   ByVal reader As JsonReader _
) As JConstructor
'Usage

Dim reader As JsonReader
Dim value As JConstructor

value = JConstructor.Load(reader)
public static JConstructor Load(
   JsonReader reader
)
public function Load(
    reader: JsonReader
): JConstructor; static;
public static function Load(
   reader : JsonReader
) : JConstructor;
public: static JConstructor* Load(
   JsonReader* reader
)
public:
static JConstructor^ Load(
   JsonReader^ reader
)

Parameters

reader
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JConstructor.

Return Value

A JConstructor that contains the JSON that was read from the specified Noemax.Newtonsoft.Json.JsonReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members


WriteTo Method (JConstructor)

WriteTo Method (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JConstructor
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public override void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); override;
public override function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
) override
public:
void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
) override

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Base Implementation in WriteTo


JConstructor Class Properties

JConstructor Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

For a list of all members of this type, see JConstructor members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets or sets the name of this constructor.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


ChildrenTokens Property (JConstructor)

ChildrenTokens Property (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : ChildrenTokens Property
Gets the container's children tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ChildrenTokens As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JConstructor
Dim value As System.Collections.Generic.IList(Of JToken)

value = instance.ChildrenTokens
protected override System.Collections.Generic.IList<JToken> ChildrenTokens {get;}
protected read-only property ChildrenTokens: System.Collections.Generic.IList; override;
protected override function get ChildrenTokens : System.Collections.Generic.IList
protected: __property System.Collections.Generic.IList<JToken*>* get_ChildrenTokens() override;
protected:
property System.Collections.Generic.IList<JToken^>^ ChildrenTokens {
   System.Collections.Generic.IList<JToken^>^ get() override;
}

Property Value

The container's children tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Base Implementation in ChildrenTokens


Item Property (JConstructor)

Item Property (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : Item Property
Gets the JToken with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Default Property Item( _
   ByVal key As System.Object _
) As JToken
'Usage

Dim instance As JConstructor
Dim key As System.Object
Dim value As JToken

instance.Item(key) = value

value = instance.Item(key)
public override JToken this[
   System.object key
]; {get; set;}
public  this: : JToken;[
    key: System.TObject
];override;  read-write
public override  this[
   key : System.Object
] get,set : JToken
public: __property JToken* get_Item   System.Object* key
 override;
public: __property void set_Item   System.Object* key,
   JToken* value
 override;
public:
property JToken^ default [Object^] override {
   JToken^ get(System.Object^ key) override;
   void set (System.Object^ key, JToken^ value) override;
}

Parameters

key

Property Value

The JToken with the specified key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Base Implementation in Item


Name Property (JConstructor)

Name Property (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : Name Property
Gets or sets the name of this constructor.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Name As System.String
'Usage

Dim instance As JConstructor
Dim value As System.String

instance.Name = value

value = instance.Name
public System.string Name {get; set;}
public read-write property Name: System.String;
public function get,set Name : System.String
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
public:
property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The constructor name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members


Type Property (JConstructor)

Type Property (JConstructor)

Noemax.Newtonsoft.Json.Linq Namespace > JConstructor Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As JTokenType
'Usage

Dim instance As JConstructor
Dim value As JTokenType

value = instance.Type
public override JTokenType Type {get;}
public read-only property Type: JTokenType; override;
public override function get Type : JTokenType
public: __property JTokenType get_Type() override;
public:
property JTokenType Type {
   JTokenType get() override;
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JConstructor Class
JConstructor Members
Base Implementation in Type


JContainer Class

JContainer Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class
Represents a token that can contain other tokens.
Object Model
JContainer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class JContainer
   Inherits JToken
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JContainer
public abstract class JContainer : JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JContainer = class(JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)abstract;
public abstract class JContainer extends JToken implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
public __gc abstract class JContainer : public JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public ref class JContainer abstract : public JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JArray
Noemax.Newtonsoft.Json.Linq.JConstructor
Noemax.Newtonsoft.Json.Linq.JObject
Noemax.Newtonsoft.Json.Linq.JProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Members
Noemax.Newtonsoft.Json.Linq Namespace


JContainer Class Members

JContainer Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

The following tables list the members exposed by JContainer.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens.
Public Property | First | Overridden. Get the first child token of this token.
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Overridden. Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Overridden. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Overridden. Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event.
Protected Method | OnListChanged | Raises the ListChanged event.
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


JContainer Class Methods

JContainer Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

For a list of all members of this type, see JContainer members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Overridden. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Overridden. Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event.
Protected Method | OnListChanged | Raises the ListChanged event.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


Add Method (JContainer)

Add Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Add Method
The content to be added.
Adds the specified content as children of this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Add( _
   ByVal content As System.Object _
)
'Usage

Dim instance As JContainer
Dim content As System.Object

instance.Add(content)
public virtual void Add(
   System.object content
)
public procedure Add(
    content: System.TObject
); virtual;
public function Add(
   content : System.Object
);
public: virtual void Add(
   System.Object* content
)
public:
virtual void Add(
   System.Object^ content
)

Parameters

content
The content to be added.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


AddFirst Method (JContainer)

AddFirst Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : AddFirst Method
The content to be added.
Adds the specified content as the first children of this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddFirst( _
   ByVal content As System.Object _
)
'Usage

Dim instance As JContainer
Dim content As System.Object

instance.AddFirst(content)
public void AddFirst(
   System.object content
)
public procedure AddFirst(
    content: System.TObject
);
public function AddFirst(
   content : System.Object
);
public: void AddFirst(
   System.Object* content
)
public:
void AddFirst(
   System.Object^ content
)

Parameters

content
The content to be added.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


Children Method (JContainer)

Children Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Children Method
Returns a collection of the child tokens of this token, in document order.
Overload List
Overload | Description
Children() | Returns a collection of the child tokens of this token, in document order.
Children<T>() | Returns a collection of the child tokens of this token, in document order, filtered by the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Base Implementation in Children


Children() Method

Children() Method

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class > Children Method : Children() Method
Returns a collection of the child tokens of this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Children() As JEnumerable(Of JToken)
'Usage

Dim instance As JContainer
Dim value As JEnumerable(Of JToken)

value = instance.Children()
public override JEnumerable<JToken> Children()
public function Children(): JEnumerable; override;
public override function Children() : JEnumerable;
public: JEnumerable<JToken*> Children(); override
public:
JEnumerable<JToken^> Children(); override

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken containing the child tokens of this JToken, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Overload List
Base Implementation in Children()


CreateWriter Method (JContainer)

CreateWriter Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : CreateWriter Method
Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateWriter() As JsonWriter
'Usage

Dim instance As JContainer
Dim value As JsonWriter

value = instance.CreateWriter()
public JsonWriter CreateWriter()
public function CreateWriter(): JsonWriter;
public function CreateWriter() : JsonWriter;
public: JsonWriter* CreateWriter();
public:
JsonWriter^ CreateWriter();

Return Value

An Noemax.Newtonsoft.Json.JsonWriter that is ready to have content written to it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


Descendants Method (JContainer)

Descendants Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Descendants Method
Returns a collection of the descendant tokens for this token in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Descendants() As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JContainer
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.Descendants()
public System.Collections.Generic.IEnumerable<JToken> Descendants()
public function Descendants(): System.Collections.Generic.IEnumerable;
public function Descendants() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* Descendants();
public:
System.Collections.Generic.IEnumerable<JToken^>^ Descendants();

Return Value

An System.Collections.Generic.IEnumerable`1 containing the descendant tokens of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


OnAddingNew Method (JContainer)

OnAddingNew Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : OnAddingNew Method
The System.ComponentModel.AddingNewEventArgs instance containing the event data.
Raises the AddingNew event.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnAddingNew( _
   ByVal e As System.ComponentModel.AddingNewEventArgs _
)
'Usage

Dim instance As JContainer
Dim e As System.ComponentModel.AddingNewEventArgs

instance.OnAddingNew(e)
protected virtual void OnAddingNew(
   System.ComponentModel.AddingNewEventArgs e
)
protected procedure OnAddingNew(
    e: System.ComponentModel.AddingNewEventArgs
); virtual;
protected function OnAddingNew(
   e : System.ComponentModel.AddingNewEventArgs
);
protected: virtual void OnAddingNew(
   System.ComponentModel.AddingNewEventArgs* e
)
protected:
virtual void OnAddingNew(
   System.ComponentModel.AddingNewEventArgs^ e
)

Parameters

e
The System.ComponentModel.AddingNewEventArgs instance containing the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


OnListChanged Method (JContainer)

OnListChanged Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : OnListChanged Method
The System.ComponentModel.ListChangedEventArgs instance containing the event data.
Raises the ListChanged event.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnListChanged( _
   ByVal e As System.ComponentModel.ListChangedEventArgs _
)
'Usage

Dim instance As JContainer
Dim e As System.ComponentModel.ListChangedEventArgs

instance.OnListChanged(e)
protected virtual void OnListChanged(
   System.ComponentModel.ListChangedEventArgs e
)
protected procedure OnListChanged(
    e: System.ComponentModel.ListChangedEventArgs
); virtual;
protected function OnListChanged(
   e : System.ComponentModel.ListChangedEventArgs
);
protected: virtual void OnListChanged(
   System.ComponentModel.ListChangedEventArgs* e
)
protected:
virtual void OnListChanged(
   System.ComponentModel.ListChangedEventArgs^ e
)

Parameters

e
The System.ComponentModel.ListChangedEventArgs instance containing the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


RemoveAll Method (JContainer)

RemoveAll Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : RemoveAll Method
Removes the child nodes from this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveAll()
'Usage

Dim instance As JContainer

instance.RemoveAll()
public void RemoveAll()
public procedure RemoveAll();
public function RemoveAll();
public: void RemoveAll();
public:
void RemoveAll();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


ReplaceAll Method (JContainer)

ReplaceAll Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : ReplaceAll Method
The content.
Replaces the children nodes of this token with the specified content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub ReplaceAll( _
   ByVal content As System.Object _
)
'Usage

Dim instance As JContainer
Dim content As System.Object

instance.ReplaceAll(content)
public void ReplaceAll(
   System.object content
)
public procedure ReplaceAll(
    content: System.TObject
);
public function ReplaceAll(
   content : System.Object
);
public: void ReplaceAll(
   System.Object* content
)
public:
void ReplaceAll(
   System.Object^ content
)

Parameters

content
The content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


Values<T> Method (JContainer)

Values<T> Method (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Values<T> Method
The type to convert the values to.
Returns a collection of the child values of this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Values(Of T)() As System.Collections.Generic.IEnumerable(Of T)
'Usage

Dim instance As JContainer
Dim value As System.Collections.Generic.IEnumerable(Of T)

value = instance.Values(Of T)()
public override System.Collections.Generic.IEnumerable<T> Values<T>()
public function Values(): System.Collections.Generic.IEnumerable; override;
public override function Values() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<T*>* Values<T>(); override
public:
System.Collections.Generic.IEnumerable<T^>^ Valuesgeneric<typename T>
(); override

Type Parameters

T
The type to convert the values to.

Return Value

A System.Collections.Generic.IEnumerable`1 containing the child values of this JToken, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Base Implementation in Values<T>


JContainer Class Properties

JContainer Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

For a list of all members of this type, see JContainer members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens.
Public Property | First | Overridden. Get the first child token of this token.
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Overridden. Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Gets the container's children tokens.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


ChildrenTokens Property (JContainer)

ChildrenTokens Property (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : ChildrenTokens Property
Gets the container's children tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride ReadOnly Property ChildrenTokens As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JContainer
Dim value As System.Collections.Generic.IList(Of JToken)

value = instance.ChildrenTokens
protected abstract System.Collections.Generic.IList<JToken> ChildrenTokens {get;}
protected read-only property ChildrenTokens: System.Collections.Generic.IList; abstract;
protected __abstract function get ChildrenTokens : System.Collections.Generic.IList
protected: __property abstract System.Collections.Generic.IList<JToken*>* get_ChildrenTokens();
protected:
abstract property System.Collections.Generic.IList<JToken^>^ ChildrenTokens {
   System.Collections.Generic.IList<JToken^>^ get();
}

Property Value

The container's children tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


Count Property (JContainer)

Count Property (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Count Property
Gets the count of child JSON tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As JContainer
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public read-only property Count: System.Integer;
public function get Count : System.int
public: __property System.int get_Count();
public:
property System.int Count {
   System.int get();
}

Property Value

The count of child JSON tokens
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


First Property (JContainer)

First Property (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : First Property
Get the first child token of this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property First As JToken
'Usage

Dim instance As JContainer
Dim value As JToken

value = instance.First
public override JToken First {get;}
public read-only property First: JToken; override;
public override function get First : JToken
public: __property JToken* get_First() override;
public:
property JToken^ First {
   JToken^ get() override;
}

Property Value

A JToken containing the first child token of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Base Implementation in First


HasValues Property (JContainer)

HasValues Property (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : HasValues Property
Gets a value indicating whether this token has child tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property HasValues As System.Boolean
'Usage

Dim instance As JContainer
Dim value As System.Boolean

value = instance.HasValues
public override System.bool HasValues {get;}
public read-only property HasValues: System.Boolean; override;
public override function get HasValues : System.boolean
public: __property System.bool get_HasValues() override;
public:
property System.bool HasValues {
   System.bool get() override;
}

Property Value

true if this token has child values; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Base Implementation in HasValues


Last Property (JContainer)

Last Property (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : Last Property
Get the last child token of this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Last As JToken
'Usage

Dim instance As JContainer
Dim value As JToken

value = instance.Last
public override JToken Last {get;}
public read-only property Last: JToken; override;
public override function get Last : JToken
public: __property JToken* get_Last() override;
public:
property JToken^ Last {
   JToken^ get() override;
}

Property Value

A JToken containing the last child token of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members
Base Implementation in Last


JContainer Class Events

JContainer Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

For a list of all members of this type, see JContainer members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


AddingNew Event (JContainer)

AddingNew Event (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : AddingNew Event
Occurs before an item is added to the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event AddingNew As System.ComponentModel.AddingNewEventHandler
'Usage

Dim instance As JContainer
Dim handler As System.ComponentModel.AddingNewEventHandler

AddHandler instance.AddingNew, handler
public event System.ComponentModel.AddingNewEventHandler AddingNew
public event AddingNew: System.ComponentModel.AddingNewEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.ComponentModel.AddingNewEventHandler* AddingNew
public:
event System.ComponentModel.AddingNewEventHandler^ AddingNew
Event Data

The event handler receives an argument of type System.ComponentModel.AddingNewEventArgs containing data related to this event. The following AddingNewEventArgs properties provide information specific to this event.

Property | Description
NewObject |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


ListChanged Event (JContainer)

ListChanged Event (JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : ListChanged Event
Occurs when the list changes or an item in the list changes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ListChanged As System.ComponentModel.ListChangedEventHandler
'Usage

Dim instance As JContainer
Dim handler As System.ComponentModel.ListChangedEventHandler

AddHandler instance.ListChanged, handler
public event System.ComponentModel.ListChangedEventHandler ListChanged
public event ListChanged: System.ComponentModel.ListChangedEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.ComponentModel.ListChangedEventHandler* ListChanged
public:
event System.ComponentModel.ListChangedEventHandler^ ListChanged
Event Data

The event handler receives an argument of type System.ComponentModel.ListChangedEventArgs containing data related to this event. The following ListChangedEventArgs properties provide information specific to this event.

Property | Description
ListChangedType |
NewIndex |
OldIndex |
PropertyDescriptor |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


JObject Class

JObject Class
Members Example

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class
Represents a JSON object.
Object Model
JObject Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Class JObject
   Inherits JContainer
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JObject
[System.Reflection.DefaultMember("Item")]
public class JObject : JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JObject = class(JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
System.Reflection.DefaultMemberAttribute("Item")
public class JObject extends JContainer implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
[System.Reflection.DefaultMember("Item")]
public __gc class JObject : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
[System.Reflection.DefaultMember("Item")]
public ref class JObject : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Example
  • C#

Inheritance Hierarchy
System.Object
   Noemax.Newtonsoft.Json.Linq.JToken
      Noemax.Newtonsoft.Json.Linq.JContainer
         Noemax.Newtonsoft.Json.Linq.JObject

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
JObject Members

Noemax.Newtonsoft.Json.Linq Namespace


JObject Class Members

JObject Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

The following tables list the members exposed by JObject.

Public Constructors
 | Name | Description
Public Constructor | JObject Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified property name.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JObject from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetValue | Overloaded. Gets the JToken with the specified property name.
static (Shared in Visual Basic) | Load | Loads an JObject from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JObject from a string that contains JSON.
Public Method | Properties | Gets an System.Collections.Generic.IEnumerable`1 of this object's properties.
Public Method | Property | Gets a JProperty the specified name.
Public Method | PropertyValues | Gets an JEnumerable<T> of this object's property values.
Public Method | Remove | Overloaded. Removes the property with the specified name.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | TryGetValue | Overloaded. Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Protected Method | OnPropertyChanging | Raises the PropertyChanging event with the provided arguments.
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | PropertyChanging | Occurs when a property value is changing.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


JObject Constructor

JObject Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : JObject Constructor
Overload List
Overload | Description
JObject Constructor() | Initializes a new instance of the JObject class.
JObject Constructor(JObject) | Initializes a new instance of the JObject class from another JObject object.
JObject Constructor(Object[]) | Initializes a new instance of the JObject class with the specified content.
JObject Constructor(Object) | Initializes a new instance of the JObject class with the specified content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


JObject Constructor()

JObject Constructor()

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > JObject Constructor : JObject Constructor()
Initializes a new instance of the JObject class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JObject()
public JObject()
public JObject();
public function JObject();
public: JObject();
public:
JObject();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


JObject Constructor(JObject)

JObject Constructor(JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > JObject Constructor : JObject Constructor(JObject)
A JObject object to copy from.
Initializes a new instance of the JObject class from another JObject object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JObject _
)
'Usage

Dim other As JObject

Dim instance As New JObject(other)
public JObject(
   JObject other
)
public JObject(
    other: JObject
);
public function JObject(
   other : JObject
);
public: JObject(
   JObject* other
)
public:
JObject(
   JObject^ other
)

Parameters

other
A JObject object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


JObject Constructor(Object[])

JObject Constructor(Object[])

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > JObject Constructor : JObject Constructor(Object[])
The contents of the object.
Initializes a new instance of the JObject class with the specified content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal ParamArray content() As System.Object _
)
'Usage

Dim content() As System.Object

Dim instance As New JObject(content)
public JObject(
   params System.object[] content
)
public JObject(
   params  content: System.TObjectarray of
);
public function JObject(
   content : System.Object[]
);
public: JObject(
   params System.Object*[]* content
)
public:
JObject(
   ... System.array<Object^>^ content
)

Parameters

content
The contents of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


JObject Constructor(Object)

JObject Constructor(Object)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > JObject Constructor : JObject Constructor(Object)
The contents of the object.
Initializes a new instance of the JObject class with the specified content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal content As System.Object _
)
'Usage

Dim content As System.Object

Dim instance As New JObject(content)
public JObject(
   System.object content
)
public JObject(
    content: System.TObject
);
public function JObject(
   content : System.Object
);
public: JObject(
   System.Object* content
)
public:
JObject(
   System.Object^ content
)

Parameters

content
The contents of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


JObject Class Methods

JObject Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

For a list of all members of this type, see JObject members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified property name.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JObject from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetValue | Overloaded. Gets the JToken with the specified property name.
static (Shared in Visual Basic) | Load | Loads an JObject from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JObject from a string that contains JSON.
Public Method | Properties | Gets an System.Collections.Generic.IEnumerable`1 of this object's properties.
Public Method | Property | Gets a JProperty the specified name.
Public Method | PropertyValues | Gets an JEnumerable<T> of this object's property values.
Public Method | Remove | Overloaded. Removes the property with the specified name.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | TryGetValue | Overloaded. Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Protected Method | OnPropertyChanging | Raises the PropertyChanging event with the provided arguments.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


Add Method (JObject)

Add Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Add Method
Adds the specified property name.
Overload List
Overload | Description
Add(String,JToken) | Adds the specified property name.
Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


Add(String,JToken) Method

Add(String,JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > Add Method : Add(String,JToken) Method
Name of the property.
The value.
Adds the specified property name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal propertyName As System.String, _
   ByVal value As JToken _
)
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim value As JToken

instance.Add(propertyName, value)
public void Add(
   System.string propertyName,
   JToken value
)
public procedure Add(
    propertyName: System.String;
    value: JToken
);
public function Add(
   propertyName : System.String,
   value : JToken
);
public: void Add(
   System.string* propertyName,
   JToken* value
)
public:
void Add(
   System.String^ propertyName,
   JToken^ value
)

Parameters

propertyName
Name of the property.
value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


FromObject Method (JObject)

FromObject Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : FromObject Method
Creates a JObject from an object.
Overload List
Overload | Description
FromObject(Object) | Creates a JObject from an object.
FromObject(Object,JsonSerializer) | Creates a JArray from an object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


FromObject(Object) Method

FromObject(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > FromObject Method : FromObject(Object) Method
The object that will be used to create JObject.
Creates a JObject from an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object _
) As JObject
'Usage

Dim o As System.Object
Dim value As JObject

value = JObject.FromObject(o)
public static JObject FromObject(
   System.object o
)
public function FromObject(
    o: System.TObject
): JObject; static;
public static function FromObject(
   o : System.Object
) : JObject;
public: static JObject* FromObject(
   System.Object* o
)
public:
static JObject^ FromObject(
   System.Object^ o
)

Parameters

o
The object that will be used to create JObject.

Return Value

A JObject with the values of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


FromObject(Object,JsonSerializer) Method

FromObject(Object,JsonSerializer) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > FromObject Method : FromObject(Object,JsonSerializer) Method
The object that will be used to create JArray.
The Noemax.Newtonsoft.Json.JsonSerializer that will be used to read the object.
Creates a JArray from an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object, _
   ByVal jsonSerializer As JsonSerializer _
) As JObject
'Usage

Dim o As System.Object
Dim jsonSerializer As JsonSerializer
Dim value As JObject

value = JObject.FromObject(o, jsonSerializer)
public static JObject FromObject(
   System.object o,
   JsonSerializer jsonSerializer
)
public function FromObject(
    o: System.TObject;
    jsonSerializer: JsonSerializer
): JObject; static;
public static function FromObject(
   o : System.Object,
   jsonSerializer : JsonSerializer
) : JObject;
public: static JObject* FromObject(
   System.Object* o,
   JsonSerializer* jsonSerializer
)
public:
static JObject^ FromObject(
   System.Object^ o,
   JsonSerializer^ jsonSerializer
)

Parameters

o
The object that will be used to create JArray.
jsonSerializer
The Noemax.Newtonsoft.Json.JsonSerializer that will be used to read the object.

Return Value

A JArray with the values of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


GetEnumerator Method (JObject)

GetEnumerator Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : GetEnumerator Method
Returns an enumerator that iterates through the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of KeyValuePair(Of String,JToken))
'Usage

Dim instance As JObject
Dim value As System.Collections.Generic.IEnumerator(Of KeyValuePair(Of String,JToken))

value = instance.GetEnumerator()
public System.Collections.Generic.IEnumerator<KeyValuePair<string,JToken>> GetEnumerator()
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
public: System.Collections.Generic.IEnumerator<KeyValuePair<string*,JToken*>>* GetEnumerator();
public:
System.Collections.Generic.IEnumerator<KeyValuePair<String^,JToken^>>^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator`1 that can be used to iterate through the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


GetValue Method (JObject)

GetValue Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : GetValue Method
Gets the JToken with the specified property name.
Overload List
Overload | Description
GetValue(String) | Gets the JToken with the specified property name.
GetValue(String,StringComparison) | Gets the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


GetValue(String) Method

GetValue(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > GetValue Method : GetValue(String) Method
Name of the property.
Gets the JToken with the specified property name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetValue( _
   ByVal propertyName As System.String _
) As JToken
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim value As JToken

value = instance.GetValue(propertyName)
public JToken GetValue(
   System.string propertyName
)
public function GetValue(
    propertyName: System.String
): JToken;
public function GetValue(
   propertyName : System.String
) : JToken;
public: JToken* GetValue(
   System.string* propertyName
)
public:
JToken^ GetValue(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.

Return Value

The JToken with the specified property name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


GetValue(String,StringComparison) Method

GetValue(String,StringComparison) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > GetValue Method : GetValue(String,StringComparison) Method
Name of the property.
One of the enumeration values that specifies how the strings will be compared.
Gets the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetValue( _
   ByVal propertyName As System.String, _
   ByVal comparison As System.StringComparison _
) As JToken
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim comparison As System.StringComparison
Dim value As JToken

value = instance.GetValue(propertyName, comparison)
public JToken GetValue(
   System.string propertyName,
   System.StringComparison comparison
)
public function GetValue(
    propertyName: System.String;
    comparison: System.StringComparison
): JToken;
public function GetValue(
   propertyName : System.String,
   comparison : System.StringComparison
) : JToken;
public: JToken* GetValue(
   System.string* propertyName,
   System.StringComparison comparison
)
public:
JToken^ GetValue(
   System.String^ propertyName,
   System.StringComparison comparison
)

Parameters

propertyName
Name of the property.
comparison
One of the enumeration values that specifies how the strings will be compared.

Return Value

The JToken with the specified property name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


Load Method (JObject)

Load Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Load Method
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JObject.
Loads an JObject from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Load( _
   ByVal reader As JsonReader _
) As JObject
'Usage

Dim reader As JsonReader
Dim value As JObject

value = JObject.Load(reader)
public static JObject Load(
   JsonReader reader
)
public function Load(
    reader: JsonReader
): JObject; static;
public static function Load(
   reader : JsonReader
) : JObject;
public: static JObject* Load(
   JsonReader* reader
)
public:
static JObject^ Load(
   JsonReader^ reader
)

Parameters

reader
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JObject.

Return Value

A JObject that contains the JSON that was read from the specified Noemax.Newtonsoft.Json.JsonReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


OnPropertyChanged Method (JObject)

OnPropertyChanged Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : OnPropertyChanged Method
Name of the property.
Raises the PropertyChanged event with the provided arguments.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnPropertyChanged( _
   ByVal propertyName As System.String _
)
'Usage

Dim instance As JObject
Dim propertyName As System.String

instance.OnPropertyChanged(propertyName)
protected virtual void OnPropertyChanged(
   System.string propertyName
)
protected procedure OnPropertyChanged(
    propertyName: System.String
); virtual;
protected function OnPropertyChanged(
   propertyName : System.String
);
protected: virtual void OnPropertyChanged(
   System.string* propertyName
)
protected:
virtual void OnPropertyChanged(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


OnPropertyChanging Method (JObject)

OnPropertyChanging Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : OnPropertyChanging Method
Name of the property.
Raises the PropertyChanging event with the provided arguments.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnPropertyChanging( _
   ByVal propertyName As System.String _
)
'Usage

Dim instance As JObject
Dim propertyName As System.String

instance.OnPropertyChanging(propertyName)
protected virtual void OnPropertyChanging(
   System.string propertyName
)
protected procedure OnPropertyChanging(
    propertyName: System.String
); virtual;
protected function OnPropertyChanging(
   propertyName : System.String
);
protected: virtual void OnPropertyChanging(
   System.string* propertyName
)
protected:
virtual void OnPropertyChanging(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


Parse Method (JObject)

Parse Method (JObject)
Example

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Parse Method
A System.String that contains JSON.
Load a JObject from a string that contains JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Parse( _
   ByVal json As System.String _
) As JObject
'Usage

Dim json As System.String
Dim value As JObject

value = JObject.Parse(json)
public static JObject Parse(
   System.string json
)
public function Parse(
    json: System.String
): JObject; static;
public static function Parse(
   json : System.String
) : JObject;
public: static JObject* Parse(
   System.string* json
)
public:
static JObject^ Parse(
   System.String^ json
)

Parameters

json
A System.String that contains JSON.

Return Value

A JObject populated from the string that contains JSON.
Example
  • C#

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
JObject Class

JObject Members


Properties Method (JObject)

Properties Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Properties Method
Gets an System.Collections.Generic.IEnumerable`1 of this object's properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Properties() As System.Collections.Generic.IEnumerable(Of JProperty)
'Usage

Dim instance As JObject
Dim value As System.Collections.Generic.IEnumerable(Of JProperty)

value = instance.Properties()
public System.Collections.Generic.IEnumerable<JProperty> Properties()
public function Properties(): System.Collections.Generic.IEnumerable;
public function Properties() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JProperty*>* Properties();
public:
System.Collections.Generic.IEnumerable<JProperty^>^ Properties();

Return Value

An System.Collections.Generic.IEnumerable`1 of this object's properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


Property Method (JObject)

Property Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Property Method
The property name.
Gets a JProperty the specified name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Property( _
   ByVal name As System.String _
) As JProperty
'Usage

Dim instance As JObject
Dim name As System.String
Dim value As JProperty

value = instance.Property(name)
public JProperty Property(
   System.string name
)
public function Property(
    name: System.String
): JProperty;
public function Property(
   name : System.String
) : JProperty;
public: JProperty* Property(
   System.string* name
)
public:
JProperty^ Property(
   System.String^ name
)

Parameters

name
The property name.

Return Value

A JProperty with the specified name or null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


PropertyValues Method (JObject)

PropertyValues Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : PropertyValues Method
Gets an JEnumerable<T> of this object's property values.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function PropertyValues() As JEnumerable(Of JToken)
'Usage

Dim instance As JObject
Dim value As JEnumerable(Of JToken)

value = instance.PropertyValues()
public JEnumerable<JToken> PropertyValues()
public function PropertyValues(): JEnumerable;
public function PropertyValues() : JEnumerable;
public: JEnumerable<JToken*> PropertyValues();
public:
JEnumerable<JToken^> PropertyValues();

Return Value

An JEnumerable<T> of this object's property values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


Remove Method (JObject)

Remove Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Remove Method
Removes the property with the specified name.
Overload List
Overload | Description
Remove(String) | Removes the property with the specified name.
Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


Remove(String) Method

Remove(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > Remove Method : Remove(String) Method
Name of the property.
Removes the property with the specified name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal propertyName As System.String _
) As System.Boolean
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim value As System.Boolean

value = instance.Remove(propertyName)
public System.bool Remove(
   System.string propertyName
)
public function Remove(
    propertyName: System.String
): System.Boolean;
public function Remove(
   propertyName : System.String
) : System.boolean;
public: System.bool Remove(
   System.string* propertyName
)
public:
System.bool Remove(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.

Return Value

true if item was successfully removed; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


TryGetValue Method (JObject)

TryGetValue Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : TryGetValue Method
Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Overload List
Overload | Description
TryGetValue(String,StringComparison,JToken) | Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
TryGetValue(String,JToken) | Tries the get value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


TryGetValue(String,StringComparison,JToken) Method

TryGetValue(String,StringComparison,JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > TryGetValue Method : TryGetValue(String,StringComparison,JToken) Method
Name of the property.
One of the enumeration values that specifies how the strings will be compared.
The value.
Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TryGetValue( _
   ByVal propertyName As System.String, _
   ByVal comparison As System.StringComparison, _
   ByRef value As JToken _
) As System.Boolean
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim comparison As System.StringComparison
Dim value As JToken
Dim value As System.Boolean

value = instance.TryGetValue(propertyName, comparison, value)
public System.bool TryGetValue(
   System.string propertyName,
   System.StringComparison comparison,
   out JToken value
)
public function TryGetValue(
    propertyName: System.String;
    comparison: System.StringComparison;
   Out  value: JToken
): System.Boolean;
public function TryGetValue(
   propertyName : System.String,
   comparison : System.StringComparison,
   value : JToken
) : System.boolean;
public: System.bool TryGetValue(
   System.string* propertyName,
   System.StringComparison comparison,
   [PARAMFLAG::Out] JToken* value
)
public:
System.bool TryGetValue(
   System.String^ propertyName,
   System.StringComparison comparison,
   [Out] JToken^ value
)

Parameters

propertyName
Name of the property.
comparison
One of the enumeration values that specifies how the strings will be compared.
value
The value.

Return Value

true if a value was successfully retrieved; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


TryGetValue(String,JToken) Method

TryGetValue(String,JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class > TryGetValue Method : TryGetValue(String,JToken) Method
Name of the property.
The value.
Tries the get value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function TryGetValue( _
   ByVal propertyName As System.String, _
   ByRef value As JToken _
) As System.Boolean
'Usage

Dim instance As JObject
Dim propertyName As System.String
Dim value As JToken
Dim value As System.Boolean

value = instance.TryGetValue(propertyName, value)
public System.bool TryGetValue(
   System.string propertyName,
   out JToken value
)
public function TryGetValue(
    propertyName: System.String;
   Out  value: JToken
): System.Boolean;
public function TryGetValue(
   propertyName : System.String,
   value : JToken
) : System.boolean;
public: System.bool TryGetValue(
   System.string* propertyName,
   [PARAMFLAG::Out] JToken* value
)
public:
System.bool TryGetValue(
   System.String^ propertyName,
   [Out] JToken^ value
)

Parameters

propertyName
Name of the property.
value
The value.

Return Value

true if a value was successfully retrieved; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Overload List


WriteTo Method (JObject)

WriteTo Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JObject
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public override void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); override;
public override function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
) override
public:
void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
) override

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Base Implementation in WriteTo


JObject Class Properties

JObject Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

For a list of all members of this type, see JObject members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


ChildrenTokens Property (JObject)

ChildrenTokens Property (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : ChildrenTokens Property
Gets the container's children tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ChildrenTokens As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JObject
Dim value As System.Collections.Generic.IList(Of JToken)

value = instance.ChildrenTokens
protected override System.Collections.Generic.IList<JToken> ChildrenTokens {get;}
protected read-only property ChildrenTokens: System.Collections.Generic.IList; override;
protected override function get ChildrenTokens : System.Collections.Generic.IList
protected: __property System.Collections.Generic.IList<JToken*>* get_ChildrenTokens() override;
protected:
property System.Collections.Generic.IList<JToken^>^ ChildrenTokens {
   System.Collections.Generic.IList<JToken^>^ get() override;
}

Property Value

The container's children tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Base Implementation in ChildrenTokens


Item Property (JObject)

Item Property (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Item Property
Gets the JToken with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Default Property Item( _
   ByVal key As System.Object _
) As JToken
'Usage

Dim instance As JObject
Dim key As System.Object
Dim value As JToken

instance.Item(key) = value

value = instance.Item(key)
public override JToken this[
   System.object key
]; {get; set;}
public  this: : JToken;[
    key: System.TObject
];override;  read-write
public override  this[
   key : System.Object
] get,set : JToken
public: __property JToken* get_Item   System.Object* key
 override;
public: __property void set_Item   System.Object* key,
   JToken* value
 override;
public:
property JToken^ default [Object^] override {
   JToken^ get(System.Object^ key) override;
   void set (System.Object^ key, JToken^ value) override;
}

Parameters

key

Property Value

The JToken with the specified key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Base Implementation in Item


Type Property (JObject)

Type Property (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As JTokenType
'Usage

Dim instance As JObject
Dim value As JTokenType

value = instance.Type
public override JTokenType Type {get;}
public read-only property Type: JTokenType; override;
public override function get Type : JTokenType
public: __property JTokenType get_Type() override;
public:
property JTokenType Type {
   JTokenType get() override;
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Base Implementation in Type


JObject Class Events

JObject Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

For a list of all members of this type, see JObject members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | PropertyChanging | Occurs when a property value is changing.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


PropertyChanged Event (JObject)

PropertyChanged Event (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanged As System.ComponentModel.PropertyChangedEventHandler
'Usage

Dim instance As JObject
Dim handler As System.ComponentModel.PropertyChangedEventHandler

AddHandler instance.PropertyChanged, handler
public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged
public event PropertyChanged: System.ComponentModel.PropertyChangedEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.ComponentModel.PropertyChangedEventHandler* PropertyChanged
public:
event System.ComponentModel.PropertyChangedEventHandler^ PropertyChanged
Event Data

The event handler receives an argument of type System.ComponentModel.PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


PropertyChanging Event (JObject)

PropertyChanging Event (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : PropertyChanging Event
Occurs when a property value is changing.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event PropertyChanging As System.ComponentModel.PropertyChangingEventHandler
'Usage

Dim instance As JObject
Dim handler As System.ComponentModel.PropertyChangingEventHandler

AddHandler instance.PropertyChanging, handler
public event System.ComponentModel.PropertyChangingEventHandler PropertyChanging
public event PropertyChanging: System.ComponentModel.PropertyChangingEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.ComponentModel.PropertyChangingEventHandler* PropertyChanging
public:
event System.ComponentModel.PropertyChangingEventHandler^ PropertyChanging
Event Data

The event handler receives an argument of type System.ComponentModel.PropertyChangingEventArgs containing data related to this event. The following PropertyChangingEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members


JProperty Class

JProperty Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class
Represents a JSON property.
Object Model
JProperty Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JProperty
   Inherits JContainer
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JProperty
public class JProperty : JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JProperty = class(JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
public class JProperty extends JContainer implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
public __gc class JProperty : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public ref class JProperty : public JContainer, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Members
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Class Members

JProperty Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

The following tables list the members exposed by JProperty.

Public Constructors
 | Name | Description
Public Constructor | JProperty Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets the property name.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value<T> | Gets or sets the property value.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JProperty from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets or sets the property value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Constructor

JProperty Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : JProperty Constructor
Overload List
Overload | Description
JProperty Constructor(JProperty) | Initializes a new instance of the JProperty class from another JProperty object.
JProperty Constructor(String,Object[]) | Initializes a new instance of the JProperty class.
JProperty Constructor(String,Object) | Initializes a new instance of the JProperty class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members


JProperty Constructor(JProperty)

JProperty Constructor(JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class > JProperty Constructor : JProperty Constructor(JProperty)
A JProperty object to copy from.
Initializes a new instance of the JProperty class from another JProperty object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JProperty _
)
'Usage

Dim other As JProperty

Dim instance As New JProperty(other)
public JProperty(
   JProperty other
)
public JProperty(
    other: JProperty
);
public function JProperty(
   other : JProperty
);
public: JProperty(
   JProperty* other
)
public:
JProperty(
   JProperty^ other
)

Parameters

other
A JProperty object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Overload List


JProperty Constructor(String,Object[])

JProperty Constructor(String,Object[])

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class > JProperty Constructor : JProperty Constructor(String,Object[])
The property name.
The property content.
Initializes a new instance of the JProperty class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal ParamArray content() As System.Object _
)
'Usage

Dim name As System.String
Dim content() As System.Object

Dim instance As New JProperty(name, content)
public JProperty(
   System.string name,
   params System.object[] content
)
public JProperty(
    name: System.String;
   params  content: System.TObjectarray of
);
public function JProperty(
   name : System.String,
   content : System.Object[]
);
public: JProperty(
   System.string* name,
   params System.Object*[]* content
)
public:
JProperty(
   System.String^ name,
   ... System.array<Object^>^ content
)

Parameters

name
The property name.
content
The property content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Overload List


JProperty Constructor(String,Object)

JProperty Constructor(String,Object)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class > JProperty Constructor : JProperty Constructor(String,Object)
The property name.
The property content.
Initializes a new instance of the JProperty class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal content As System.Object _
)
'Usage

Dim name As System.String
Dim content As System.Object

Dim instance As New JProperty(name, content)
public JProperty(
   System.string name,
   System.object content
)
public JProperty(
    name: System.String;
    content: System.TObject
);
public function JProperty(
   name : System.String,
   content : System.Object
);
public: JProperty(
   System.string* name,
   System.Object* content
)
public:
JProperty(
   System.String^ name,
   System.Object^ content
)

Parameters

name
The property name.
content
The property content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Overload List


JProperty Class Methods

JProperty Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

For a list of all members of this type, see JProperty members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JProperty from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets or sets the property value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


Load Method (JProperty)

Load Method (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : Load Method
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JProperty.
Loads an JProperty from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Load( _
   ByVal reader As JsonReader _
) As JProperty
'Usage

Dim reader As JsonReader
Dim value As JProperty

value = JProperty.Load(reader)
public static JProperty Load(
   JsonReader reader
)
public function Load(
    reader: JsonReader
): JProperty; static;
public static function Load(
   reader : JsonReader
) : JProperty;
public: static JProperty* Load(
   JsonReader* reader
)
public:
static JProperty^ Load(
   JsonReader^ reader
)

Parameters

reader
A Noemax.Newtonsoft.Json.JsonReader that will be read for the content of the JProperty.

Return Value

A JProperty that contains the JSON that was read from the specified Noemax.Newtonsoft.Json.JsonReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members


WriteTo Method (JProperty)

WriteTo Method (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JProperty
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public override void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); override;
public override function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
) override
public:
void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
) override

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Base Implementation in WriteTo


JProperty Class Properties

JProperty Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

For a list of all members of this type, see JProperty members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets the property name.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value<T> | Gets or sets the property value.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


ChildrenTokens Property (JProperty)

ChildrenTokens Property (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : ChildrenTokens Property
Gets the container's children tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property ChildrenTokens As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JProperty
Dim value As System.Collections.Generic.IList(Of JToken)

value = instance.ChildrenTokens
protected override System.Collections.Generic.IList<JToken> ChildrenTokens {get;}
protected read-only property ChildrenTokens: System.Collections.Generic.IList; override;
protected override function get ChildrenTokens : System.Collections.Generic.IList
protected: __property System.Collections.Generic.IList<JToken*>* get_ChildrenTokens() override;
protected:
property System.Collections.Generic.IList<JToken^>^ ChildrenTokens {
   System.Collections.Generic.IList<JToken^>^ get() override;
}

Property Value

The container's children tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Base Implementation in ChildrenTokens


Name Property (JProperty)

Name Property (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : Name Property
Gets the property name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As System.String
'Usage

Dim instance As JProperty
Dim value As System.String

value = instance.Name
public System.string Name {get;}
public read-only property Name: System.String;
public function get Name : System.String
public: __property System.string* get_Name();
public:
property System.String^ Name {
   System.String^ get();
}

Property Value

The property name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members


Type Property (JProperty)

Type Property (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As JTokenType
'Usage

Dim instance As JProperty
Dim value As JTokenType

value = instance.Type
public override JTokenType Type {get;}
public read-only property Type: JTokenType; override;
public override function get Type : JTokenType
public: __property JTokenType get_Type() override;
public:
property JTokenType Type {
   JTokenType get() override;
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members
Base Implementation in Type


Value Property (JProperty)

Value Property (JProperty)

Noemax.Newtonsoft.Json.Linq Namespace > JProperty Class : Value Property
Gets or sets the property value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As JToken
'Usage

Dim instance As JProperty
Dim value As JToken

instance.Value = value

value = instance.Value
public JToken Value {get; set;}
public read-write property Value: JToken;
public function get,set Value : JToken
public: __property JToken* get_Value();
public: __property void set_Value(
   JToken* value
);
public:
property JToken^ Value {
   JToken^ get();
   void set (    JToken^ value);
}

Property Value

The property value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JProperty Class
JProperty Members


JPropertyDescriptor Class

JPropertyDescriptor Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JPropertyDescriptor Class
Represents a view of a JProperty.
Object Model
JPropertyDescriptor Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JPropertyDescriptor
   Inherits System.ComponentModel.PropertyDescriptor
'Usage

Dim instance As JPropertyDescriptor
public class JPropertyDescriptor : System.ComponentModel.PropertyDescriptor
public class JPropertyDescriptor = class(System.ComponentModel.PropertyDescriptor)
public class JPropertyDescriptor extends System.ComponentModel.PropertyDescriptor
public __gc class JPropertyDescriptor : public System.ComponentModel.PropertyDescriptor
public ref class JPropertyDescriptor : public System.ComponentModel.PropertyDescriptor
Inheritance Hierarchy

System.Object
System.ComponentModel.MemberDescriptor
System.ComponentModel.PropertyDescriptor
Noemax.Newtonsoft.Json.Linq.JPropertyDescriptor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Members
Noemax.Newtonsoft.Json.Linq Namespace


JPropertyDescriptor Class Members

JPropertyDescriptor Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JPropertyDescriptor Class

The following tables list the members exposed by JPropertyDescriptor.

Public Constructors
 | Name | Description
Public Constructor | JPropertyDescriptor Constructor | Initializes a new instance of the JPropertyDescriptor class.
Top
Public Properties
 | Name | Description
Public Property | Attributes | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | Category | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | ComponentType | Overridden. When overridden in a derived class, gets the type of the component this property is bound to.
Public Property | Converter | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | Description | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | DesignTimeOnly | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | DisplayName | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | IsBrowsable | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | IsLocalizable | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | IsReadOnly | Overridden. When overridden in a derived class, gets a value indicating whether this property is read-only.
Public Property | Name | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | PropertyType | Overridden. When overridden in a derived class, gets the type of the property.
Public Property | SerializationVisibility | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | SupportsChangeEvents | (Inherited from System.ComponentModel.PropertyDescriptor)
Top
Protected Properties
 | Name | Description
Protected Property | AttributeArray | (Inherited from System.ComponentModel.MemberDescriptor)
Protected Property | NameHashCode | Overridden. Gets the hash code for the name of the member.
Top
Public Methods
 | Name | Description
Public Method | AddValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | CanResetValue | Overridden. When overridden in a derived class, returns whether resetting an object changes its value.
Public Method | Equals | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetChildProperties | Overloaded. (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetEditor | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetHashCode | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetValue | Overridden. When overridden in a derived class, gets the current value of the property on a component.
Public Method | RemoveValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | ResetValue | Overridden. When overridden in a derived class, resets the value for this property of the component to the default value.
Public Method | SetValue | Overridden. When overridden in a derived class, sets the value of the component to a different value.
Public Method | ShouldSerializeValue | Overridden. When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted.
Top
Protected Methods
 | Name | Description
Protected Method | CreateAttributeCollection | (Inherited from System.ComponentModel.MemberDescriptor)
Protected Method | CreateInstance | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | FillAttributes | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | GetInvocationTarget | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | GetTypeFromName | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | OnValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Top
See Also

Reference

JPropertyDescriptor Class
Noemax.Newtonsoft.Json.Linq Namespace


JPropertyDescriptor Constructor

JPropertyDescriptor Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : JPropertyDescriptor Constructor
The name.
Initializes a new instance of the JPropertyDescriptor class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String _
)
'Usage

Dim name As System.String

Dim instance As New JPropertyDescriptor(name)
public JPropertyDescriptor(
   System.string name
)
public JPropertyDescriptor(
    name: System.String
);
public function JPropertyDescriptor(
   name : System.String
);
public: JPropertyDescriptor(
   System.string* name
)
public:
JPropertyDescriptor(
   System.String^ name
)

Parameters

name
The name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


JPropertyDescriptor Class Methods

JPropertyDescriptor Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JPropertyDescriptor Class

For a list of all members of this type, see JPropertyDescriptor members.

Public Methods
 | Name | Description
Public Method | AddValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | CanResetValue | Overridden. When overridden in a derived class, returns whether resetting an object changes its value.
Public Method | Equals | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetChildProperties | Overloaded. (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetEditor | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetHashCode | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | GetValue | Overridden. When overridden in a derived class, gets the current value of the property on a component.
Public Method | RemoveValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Method | ResetValue | Overridden. When overridden in a derived class, resets the value for this property of the component to the default value.
Public Method | SetValue | Overridden. When overridden in a derived class, sets the value of the component to a different value.
Public Method | ShouldSerializeValue | Overridden. When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted.
Top
Protected Methods
 | Name | Description
Protected Method | CreateAttributeCollection | (Inherited from System.ComponentModel.MemberDescriptor)
Protected Method | CreateInstance | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | FillAttributes | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | GetInvocationTarget | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | GetTypeFromName | (Inherited from System.ComponentModel.PropertyDescriptor)
Protected Method | OnValueChanged | (Inherited from System.ComponentModel.PropertyDescriptor)
Top
See Also

Reference

JPropertyDescriptor Class
Noemax.Newtonsoft.Json.Linq Namespace


CanResetValue Method (JPropertyDescriptor)

CanResetValue Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : CanResetValue Method
The component to test for reset capability.
When overridden in a derived class, returns whether resetting an object changes its value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanResetValue( _
   ByVal component As System.Object _
) As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim value As System.Boolean

value = instance.CanResetValue(component)
public override System.bool CanResetValue(
   System.object component
)
public function CanResetValue(
    component: System.TObject
): System.Boolean; override;
public override function CanResetValue(
   component : System.Object
) : System.boolean;
public: System.bool CanResetValue(
   System.Object* component
) override
public:
System.bool CanResetValue(
   System.Object^ component
) override

Parameters

component
The component to test for reset capability.

Return Value

true if resetting the component changes its value; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in CanResetValue


GetValue Method (JPropertyDescriptor)

GetValue Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetValue Method
The component with the property for which to retrieve the value.
When overridden in a derived class, gets the current value of the property on a component.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetValue( _
   ByVal component As System.Object _
) As System.Object
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim value As System.Object

value = instance.GetValue(component)
public override System.object GetValue(
   System.object component
)
public function GetValue(
    component: System.TObject
): System.TObject; override;
public override function GetValue(
   component : System.Object
) : System.Object;
public: System.Object* GetValue(
   System.Object* component
) override
public:
System.Object^ GetValue(
   System.Object^ component
) override

Parameters

component
The component with the property for which to retrieve the value.

Return Value

The value of a property for a given component.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in GetValue


ResetValue Method (JPropertyDescriptor)

ResetValue Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : ResetValue Method
The component with the property value that is to be reset to the default value.
When overridden in a derived class, resets the value for this property of the component to the default value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub ResetValue( _
   ByVal component As System.Object _
)
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object

instance.ResetValue(component)
public override void ResetValue(
   System.object component
)
public procedure ResetValue(
    component: System.TObject
); override;
public override function ResetValue(
   component : System.Object
);
public: void ResetValue(
   System.Object* component
) override
public:
void ResetValue(
   System.Object^ component
) override

Parameters

component
The component with the property value that is to be reset to the default value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in ResetValue


SetValue Method (JPropertyDescriptor)

SetValue Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : SetValue Method
The component with the property value that is to be set.
The new value.
When overridden in a derived class, sets the value of the component to a different value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub SetValue( _
   ByVal component As System.Object, _
   ByVal value As System.Object _
)
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim value As System.Object

instance.SetValue(component, value)
public override void SetValue(
   System.object component,
   System.object value
)
public procedure SetValue(
    component: System.TObject;
    value: System.TObject
); override;
public override function SetValue(
   component : System.Object,
   value : System.Object
);
public: void SetValue(
   System.Object* component,
   System.Object* value
) override
public:
void SetValue(
   System.Object^ component,
   System.Object^ value
) override

Parameters

component
The component with the property value that is to be set.
value
The new value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in SetValue


ShouldSerializeValue Method (JPropertyDescriptor)

ShouldSerializeValue Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : ShouldSerializeValue Method
The component with the property to be examined for persistence.
When overridden in a derived class, determines a value indicating whether the value of this property needs to be persisted.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ShouldSerializeValue( _
   ByVal component As System.Object _
) As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim value As System.Boolean

value = instance.ShouldSerializeValue(component)
public override System.bool ShouldSerializeValue(
   System.object component
)
public function ShouldSerializeValue(
    component: System.TObject
): System.Boolean; override;
public override function ShouldSerializeValue(
   component : System.Object
) : System.boolean;
public: System.bool ShouldSerializeValue(
   System.Object* component
) override
public:
System.bool ShouldSerializeValue(
   System.Object^ component
) override

Parameters

component
The component with the property to be examined for persistence.

Return Value

true if the property should be persisted; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in ShouldSerializeValue


JPropertyDescriptor Class Properties

JPropertyDescriptor Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JPropertyDescriptor Class

For a list of all members of this type, see JPropertyDescriptor members.

Public Properties
 | Name | Description
Public Property | Attributes | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | Category | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | ComponentType | Overridden. When overridden in a derived class, gets the type of the component this property is bound to.
Public Property | Converter | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | Description | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | DesignTimeOnly | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | DisplayName | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | IsBrowsable | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | IsLocalizable | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | IsReadOnly | Overridden. When overridden in a derived class, gets a value indicating whether this property is read-only.
Public Property | Name | (Inherited from System.ComponentModel.MemberDescriptor)
Public Property | PropertyType | Overridden. When overridden in a derived class, gets the type of the property.
Public Property | SerializationVisibility | (Inherited from System.ComponentModel.PropertyDescriptor)
Public Property | SupportsChangeEvents | (Inherited from System.ComponentModel.PropertyDescriptor)
Top
Protected Properties
 | Name | Description
Protected Property | AttributeArray | (Inherited from System.ComponentModel.MemberDescriptor)
Protected Property | NameHashCode | Overridden. Gets the hash code for the name of the member.
Top
See Also

Reference

JPropertyDescriptor Class
Noemax.Newtonsoft.Json.Linq Namespace


ComponentType Property (JPropertyDescriptor)

ComponentType Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : ComponentType Property
When overridden in a derived class, gets the type of the component this property is bound to.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property ComponentType As System.Type
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Type

value = instance.ComponentType
public override System.Type ComponentType {get;}
public read-only property ComponentType: System.Type; override;
public override function get ComponentType : System.Type
public: __property System.Type* get_ComponentType() override;
public:
property System.Type^ ComponentType {
   System.Type^ get() override;
}

Property Value

A System.Type that represents the type of component this property is bound to. When the System.ComponentModel.PropertyDescriptor.GetValue(System.Object) or System.ComponentModel.PropertyDescriptor.SetValue(System.Object,System.Object) methods are invoked, the object specified might be an instance of this type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in ComponentType


IsReadOnly Property (JPropertyDescriptor)

IsReadOnly Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : IsReadOnly Property
When overridden in a derived class, gets a value indicating whether this property is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property IsReadOnly As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Boolean

value = instance.IsReadOnly
public override System.bool IsReadOnly {get;}
public read-only property IsReadOnly: System.Boolean; override;
public override function get IsReadOnly : System.boolean
public: __property System.bool get_IsReadOnly() override;
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Property Value

true if the property is read-only; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in IsReadOnly


NameHashCode Property (JPropertyDescriptor)

NameHashCode Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : NameHashCode Property
Gets the hash code for the name of the member.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides ReadOnly Property NameHashCode As System.Integer
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Integer

value = instance.NameHashCode
protected override System.int NameHashCode {get;}
protected read-only property NameHashCode: System.Integer; override;
protected override function get NameHashCode : System.int
protected: __property System.int get_NameHashCode() override;
protected:
property System.int NameHashCode {
   System.int get() override;
}

Property Value

The hash code for the name of the member.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in NameHashCode


PropertyType Property (JPropertyDescriptor)

PropertyType Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : PropertyType Property
When overridden in a derived class, gets the type of the property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property PropertyType As System.Type
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Type

value = instance.PropertyType
public override System.Type PropertyType {get;}
public read-only property PropertyType: System.Type; override;
public override function get PropertyType : System.Type
public: __property System.Type* get_PropertyType() override;
public:
property System.Type^ PropertyType {
   System.Type^ get() override;
}

Property Value

A System.Type that represents the type of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Base Implementation in PropertyType


JRaw Class

JRaw Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class
Represents a raw JSON string.
Object Model
JRaw Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JRaw
   Inherits JValue
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JRaw
public class JRaw : JValue, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JRaw = class(JValue, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
public class JRaw extends JValue implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
public __gc class JRaw : public JValue, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public ref class JRaw : public JValue, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JValue
Noemax.Newtonsoft.Json.Linq.JRaw

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JRaw Members
Noemax.Newtonsoft.Json.Linq Namespace


JRaw Class Members

JRaw Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class

The following tables list the members exposed by JRaw.

Public Constructors
 | Name | Description
Public Constructor | JRaw Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
static (Shared in Visual Basic) | Create | Creates an instance of JRaw with the content of the reader's current token.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Value | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
See Also

Reference

JRaw Class
Noemax.Newtonsoft.Json.Linq Namespace


JRaw Constructor

JRaw Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JRaw Class : JRaw Constructor
Overload List
Overload | Description
JRaw Constructor(JRaw) | Initializes a new instance of the JRaw class from another JRaw object.
JRaw Constructor(Object) | Initializes a new instance of the JRaw class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JRaw Class
JRaw Members


JRaw Constructor(JRaw)

JRaw Constructor(JRaw)

Noemax.Newtonsoft.Json.Linq Namespace > JRaw Class > JRaw Constructor : JRaw Constructor(JRaw)
A JRaw object to copy from.
Initializes a new instance of the JRaw class from another JRaw object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JRaw _
)
'Usage

Dim other As JRaw

Dim instance As New JRaw(other)
public JRaw(
   JRaw other
)
public JRaw(
    other: JRaw
);
public function JRaw(
   other : JRaw
);
public: JRaw(
   JRaw* other
)
public:
JRaw(
   JRaw^ other
)

Parameters

other
A JRaw object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JRaw Class
JRaw Members
Overload List


JRaw Constructor(Object)

JRaw Constructor(Object)

Noemax.Newtonsoft.Json.Linq Namespace > JRaw Class > JRaw Constructor : JRaw Constructor(Object)
The raw json.
Initializes a new instance of the JRaw class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal rawJson As System.Object _
)
'Usage

Dim rawJson As System.Object

Dim instance As New JRaw(rawJson)
public JRaw(
   System.object rawJson
)
public JRaw(
    rawJson: System.TObject
);
public function JRaw(
   rawJson : System.Object
);
public: JRaw(
   System.Object* rawJson
)
public:
JRaw(
   System.Object^ rawJson
)

Parameters

rawJson
The raw json.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JRaw Class
JRaw Members
Overload List


JRaw Class Methods

JRaw Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class

For a list of all members of this type, see JRaw members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
static (Shared in Visual Basic) | Create | Creates an instance of JRaw with the content of the reader's current token.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Value | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
See Also

Reference

JRaw Class
Noemax.Newtonsoft.Json.Linq Namespace


Create Method (JRaw)

Create Method (JRaw)

Noemax.Newtonsoft.Json.Linq Namespace > JRaw Class : Create Method
The reader.
Creates an instance of JRaw with the content of the reader's current token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Create( _
   ByVal reader As JsonReader _
) As JRaw
'Usage

Dim reader As JsonReader
Dim value As JRaw

value = JRaw.Create(reader)
public static JRaw Create(
   JsonReader reader
)
public function Create(
    reader: JsonReader
): JRaw; static;
public static function Create(
   reader : JsonReader
) : JRaw;
public: static JRaw* Create(
   JsonReader* reader
)
public:
static JRaw^ Create(
   JsonReader^ reader
)

Parameters

reader
The reader.

Return Value

An instance of JRaw with the content of the reader's current token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JRaw Class
JRaw Members


JToken Class

JToken Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class
Represents an abstract JSON token.
Object Model
JToken Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public MustInherit Class JToken
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JToken
[System.Reflection.DefaultMember("Item")]
public abstract class JToken : Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JToken = class(Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)abstract;
System.Reflection.DefaultMemberAttribute("Item")
public abstract class JToken implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
[System.Reflection.DefaultMember("Item")]
public __gc abstract class JToken : public Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
[System.Reflection.DefaultMember("Item")]
public ref class JToken abstract : public Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Members
Noemax.Newtonsoft.Json.Linq Namespace


JToken Class Members

JToken Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class

The following tables list the members exposed by JToken.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | EqualityComparer | Gets a comparer that can compare two tokens for value equality.
Public Property | First | Get the first child token of this token.
Public Property | HasValues | Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node.
Public Property | Parent | Gets or sets the parent.
Public Property | Path | Gets the path of the JSON token.
Public Property | Previous | Gets the previous sibling token of this node.
Public Property | Root | Gets the root JToken of this JToken.
Public Property | Type | Gets the node type for this JToken.
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token.
Public Method | AddBeforeSelf | Adds the specified content immediately before this token.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order.
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token.
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order.
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned.
static (Shared in Visual Basic) | DeepEquals | Compares the values of two tokens, including the values of all descendant tokens.
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JToken from an object.
static (Shared in Visual Basic) | Load | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JToken from a string that contains JSON.
static (Shared in Visual Basic) | ReadFrom | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent.
Public Method | Replace | Replaces this token with the specified token.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path.
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression.
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken.
Public Method | ToString | Overloaded. Returns the indented JSON for this token.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type.
Public Method | Values<T> | Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Public Operators
public Operator Explicit Type Conversion | Overloaded. Performs an explicit conversion from JToken to System.Boolean.
public Operator Implicit Type Conversion | Overloaded. Performs an implicit conversion from System.Int32 to JToken.
Top
See Also

Reference

JToken Class
Noemax.Newtonsoft.Json.Linq Namespace


JToken Class Methods

JToken Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class

For a list of all members of this type, see JToken members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token.
Public Method | AddBeforeSelf | Adds the specified content immediately before this token.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order.
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token.
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order.
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned.
static (Shared in Visual Basic) | DeepEquals | Compares the values of two tokens, including the values of all descendant tokens.
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JToken from an object.
static (Shared in Visual Basic) | Load | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JToken from a string that contains JSON.
static (Shared in Visual Basic) | ReadFrom | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent.
Public Method | Replace | Replaces this token with the specified token.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path.
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression.
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken.
Public Method | ToString | Overloaded. Returns the indented JSON for this token.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type.
Public Method | Values<T> | Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
See Also

Reference

JToken Class
Noemax.Newtonsoft.Json.Linq Namespace


AddAfterSelf Method (JToken)

AddAfterSelf Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : AddAfterSelf Method
A content object that contains simple content or a collection of content objects to be added after this token.
Adds the specified content immediately after this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddAfterSelf( _
   ByVal content As System.Object _
)
'Usage

Dim instance As JToken
Dim content As System.Object

instance.AddAfterSelf(content)
public void AddAfterSelf(
   System.object content
)
public procedure AddAfterSelf(
    content: System.TObject
);
public function AddAfterSelf(
   content : System.Object
);
public: void AddAfterSelf(
   System.Object* content
)
public:
void AddAfterSelf(
   System.Object^ content
)

Parameters

content
A content object that contains simple content or a collection of content objects to be added after this token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


AddBeforeSelf Method (JToken)

AddBeforeSelf Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : AddBeforeSelf Method
A content object that contains simple content or a collection of content objects to be added before this token.
Adds the specified content immediately before this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddBeforeSelf( _
   ByVal content As System.Object _
)
'Usage

Dim instance As JToken
Dim content As System.Object

instance.AddBeforeSelf(content)
public void AddBeforeSelf(
   System.object content
)
public procedure AddBeforeSelf(
    content: System.TObject
);
public function AddBeforeSelf(
   content : System.Object
);
public: void AddBeforeSelf(
   System.Object* content
)
public:
void AddBeforeSelf(
   System.Object^ content
)

Parameters

content
A content object that contains simple content or a collection of content objects to be added before this token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


AfterSelf Method (JToken)

AfterSelf Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : AfterSelf Method
Returns a collection of the sibling tokens after this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AfterSelf() As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.AfterSelf()
public System.Collections.Generic.IEnumerable<JToken> AfterSelf()
public function AfterSelf(): System.Collections.Generic.IEnumerable;
public function AfterSelf() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* AfterSelf();
public:
System.Collections.Generic.IEnumerable<JToken^>^ AfterSelf();

Return Value

A collection of the sibling tokens after this tokens, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Ancestors Method (JToken)

Ancestors Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Ancestors Method
Returns a collection of the ancestor tokens of this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Ancestors() As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.Ancestors()
public System.Collections.Generic.IEnumerable<JToken> Ancestors()
public function Ancestors(): System.Collections.Generic.IEnumerable;
public function Ancestors() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* Ancestors();
public:
System.Collections.Generic.IEnumerable<JToken^>^ Ancestors();

Return Value

A collection of the ancestor tokens of this token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


BeforeSelf Method (JToken)

BeforeSelf Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : BeforeSelf Method
Returns a collection of the sibling tokens before this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeforeSelf() As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.BeforeSelf()
public System.Collections.Generic.IEnumerable<JToken> BeforeSelf()
public function BeforeSelf(): System.Collections.Generic.IEnumerable;
public function BeforeSelf() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* BeforeSelf();
public:
System.Collections.Generic.IEnumerable<JToken^>^ BeforeSelf();

Return Value

A collection of the sibling tokens before this token, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Children Method (JToken)

Children Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Children Method
Returns a collection of the child tokens of this token, in document order.
Overload List
Overload | Description
Children() | Returns a collection of the child tokens of this token, in document order.
Children<T>() | Returns a collection of the child tokens of this token, in document order, filtered by the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Children() Method

Children() Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Children Method : Children() Method
Returns a collection of the child tokens of this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function Children() As JEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim value As JEnumerable(Of JToken)

value = instance.Children()
public virtual JEnumerable<JToken> Children()
public function Children(): JEnumerable; virtual;
public function Children() : JEnumerable;
public: virtual JEnumerable<JToken*> Children();
public:
virtual JEnumerable<JToken^> Children();

Return Value

An System.Collections.Generic.IEnumerable`1 of JToken containing the child tokens of this JToken, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Children<T>() Method

Children<T>() Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Children Method : Children<T>() Method
The type to filter the child tokens on.
Returns a collection of the child tokens of this token, in document order, filtered by the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Children(Of T As JToken)() As JEnumerable(Of T)
'Usage

Dim instance As JToken
Dim value As JEnumerable(Of T)

value = instance.Children(Of T)()
public JEnumerable<T> Children<T>()
where T: JToken
public function Children(): JEnumerable;
public function Children() : JEnumerable;
public: JEnumerable<T*> Children<T>();
where T: JToken
public:
JEnumerable<T^> Childrengeneric<typename T>
();
where T: JToken

Type Parameters

T
The type to filter the child tokens on.

Return Value

A JEnumerable<T> containing the child tokens of this JToken, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


CreateReader Method (JToken)

CreateReader Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : CreateReader Method
Creates an Noemax.Newtonsoft.Json.JsonReader for this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CreateReader() As JsonReader
'Usage

Dim instance As JToken
Dim value As JsonReader

value = instance.CreateReader()
public JsonReader CreateReader()
public function CreateReader(): JsonReader;
public function CreateReader() : JsonReader;
public: JsonReader* CreateReader();
public:
JsonReader^ CreateReader();

Return Value

An Noemax.Newtonsoft.Json.JsonReader that can be used to read this token and its descendants.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


DeepClone Method (JToken)

DeepClone Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : DeepClone Method
Creates a new instance of the JToken. All child tokens are recursively cloned.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function DeepClone() As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.DeepClone()
public JToken DeepClone()
public function DeepClone(): JToken;
public function DeepClone() : JToken;
public: JToken* DeepClone();
public:
JToken^ DeepClone();

Return Value

A new instance of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


DeepEquals(JToken,JToken) Method

DeepEquals(JToken,JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : DeepEquals(JToken,JToken) Method
The first JToken to compare.
The second JToken to compare.
Compares the values of two tokens, including the values of all descendant tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function DeepEquals( _
   ByVal t1 As JToken, _
   ByVal t2 As JToken _
) As System.Boolean
'Usage

Dim t1 As JToken
Dim t2 As JToken
Dim value As System.Boolean

value = JToken.DeepEquals(t1, t2)
public static System.bool DeepEquals(
   JToken t1,
   JToken t2
)
public function DeepEquals(
    t1: JToken;
    t2: JToken
): System.Boolean; static;
public static function DeepEquals(
   t1 : JToken,
   t2 : JToken
) : System.boolean;
public: static System.bool DeepEquals(
   JToken* t1,
   JToken* t2
)
public:
static System.bool DeepEquals(
   JToken^ t1,
   JToken^ t2
)

Parameters

t1
The first JToken to compare.
t2
The second JToken to compare.

Return Value

true if the tokens are equal; otherwise false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


FromObject Method (JToken)

FromObject Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : FromObject Method
Creates a JToken from an object.
Overload List
Overload | Description
FromObject(Object) | Creates a JToken from an object.
FromObject(Object,JsonSerializer) | Creates a JToken from an object using the specified Noemax.Newtonsoft.Json.JsonSerializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


FromObject(Object) Method

FromObject(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > FromObject Method : FromObject(Object) Method
The object that will be used to create JToken.
Creates a JToken from an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object _
) As JToken
'Usage

Dim o As System.Object
Dim value As JToken

value = JToken.FromObject(o)
public static JToken FromObject(
   System.object o
)
public function FromObject(
    o: System.TObject
): JToken; static;
public static function FromObject(
   o : System.Object
) : JToken;
public: static JToken* FromObject(
   System.Object* o
)
public:
static JToken^ FromObject(
   System.Object^ o
)

Parameters

o
The object that will be used to create JToken.

Return Value

A JToken with the value of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


FromObject(Object,JsonSerializer) Method

FromObject(Object,JsonSerializer) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > FromObject Method : FromObject(Object,JsonSerializer) Method
The object that will be used to create JToken.
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when reading the object.
Creates a JToken from an object using the specified Noemax.Newtonsoft.Json.JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function FromObject( _
   ByVal o As System.Object, _
   ByVal jsonSerializer As JsonSerializer _
) As JToken
'Usage

Dim o As System.Object
Dim jsonSerializer As JsonSerializer
Dim value As JToken

value = JToken.FromObject(o, jsonSerializer)
public static JToken FromObject(
   System.object o,
   JsonSerializer jsonSerializer
)
public function FromObject(
    o: System.TObject;
    jsonSerializer: JsonSerializer
): JToken; static;
public static function FromObject(
   o : System.Object,
   jsonSerializer : JsonSerializer
) : JToken;
public: static JToken* FromObject(
   System.Object* o,
   JsonSerializer* jsonSerializer
)
public:
static JToken^ FromObject(
   System.Object^ o,
   JsonSerializer^ jsonSerializer
)

Parameters

o
The object that will be used to create JToken.
jsonSerializer
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when reading the object.

Return Value

A JToken with the value of the specified object
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Load Method (JToken)

Load Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Load Method
An Noemax.Newtonsoft.Json.JsonReader positioned at the token to read into this JToken.
Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Load( _
   ByVal reader As JsonReader _
) As JToken
'Usage

Dim reader As JsonReader
Dim value As JToken

value = JToken.Load(reader)
public static JToken Load(
   JsonReader reader
)
public function Load(
    reader: JsonReader
): JToken; static;
public static function Load(
   reader : JsonReader
) : JToken;
public: static JToken* Load(
   JsonReader* reader
)
public:
static JToken^ Load(
   JsonReader^ reader
)

Parameters

reader
An Noemax.Newtonsoft.Json.JsonReader positioned at the token to read into this JToken.

Return Value

An JToken that contains the token and its descendant tokens that were read from the reader. The runtime type of the token is determined by the token type of the first token encountered in the reader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Parse Method (JToken)

Parse Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Parse Method
A System.String that contains JSON.
Load a JToken from a string that contains JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function Parse( _
   ByVal json As System.String _
) As JToken
'Usage

Dim json As System.String
Dim value As JToken

value = JToken.Parse(json)
public static JToken Parse(
   System.string json
)
public function Parse(
    json: System.String
): JToken; static;
public static function Parse(
   json : System.String
) : JToken;
public: static JToken* Parse(
   System.string* json
)
public:
static JToken^ Parse(
   System.String^ json
)

Parameters

json
A System.String that contains JSON.

Return Value

A JToken populated from the string that contains JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


ReadFrom Method (JToken)

ReadFrom Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : ReadFrom Method
An Noemax.Newtonsoft.Json.JsonReader positioned at the token to read into this JToken.
Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function ReadFrom( _
   ByVal reader As JsonReader _
) As JToken
'Usage

Dim reader As JsonReader
Dim value As JToken

value = JToken.ReadFrom(reader)
public static JToken ReadFrom(
   JsonReader reader
)
public function ReadFrom(
    reader: JsonReader
): JToken; static;
public static function ReadFrom(
   reader : JsonReader
) : JToken;
public: static JToken* ReadFrom(
   JsonReader* reader
)
public:
static JToken^ ReadFrom(
   JsonReader^ reader
)

Parameters

reader
An Noemax.Newtonsoft.Json.JsonReader positioned at the token to read into this JToken.

Return Value

An JToken that contains the token and its descendant tokens that were read from the reader. The runtime type of the token is determined by the token type of the first token encountered in the reader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Remove Method (JToken)

Remove Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Remove Method
Removes this token from its parent.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Remove()
'Usage

Dim instance As JToken

instance.Remove()
public void Remove()
public procedure Remove();
public function Remove();
public: void Remove();
public:
void Remove();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Replace Method (JToken)

Replace Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Replace Method
The value.
Replaces this token with the specified token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Replace( _
   ByVal value As JToken _
)
'Usage

Dim instance As JToken
Dim value As JToken

instance.Replace(value)
public void Replace(
   JToken value
)
public procedure Replace(
    value: JToken
);
public function Replace(
   value : JToken
);
public: void Replace(
   JToken* value
)
public:
void Replace(
   JToken^ value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


SelectToken Method (JToken)

SelectToken Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : SelectToken Method
Selects a JToken using a JPath expression. Selects the token that matches the object path.
Overload List
Overload | Description
SelectToken(String) | Selects a JToken using a JPath expression. Selects the token that matches the object path.
SelectToken(String,Boolean) | Selects a JToken using a JPath expression. Selects the token that matches the object path.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


SelectToken(String) Method

SelectToken(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > SelectToken Method : SelectToken(String) Method
A System.String that contains a JPath expression.
Selects a JToken using a JPath expression. Selects the token that matches the object path.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SelectToken( _
   ByVal path As System.String _
) As JToken
'Usage

Dim instance As JToken
Dim path As System.String
Dim value As JToken

value = instance.SelectToken(path)
public JToken SelectToken(
   System.string path
)
public function SelectToken(
    path: System.String
): JToken;
public function SelectToken(
   path : System.String
) : JToken;
public: JToken* SelectToken(
   System.string* path
)
public:
JToken^ SelectToken(
   System.String^ path
)

Parameters

path
A System.String that contains a JPath expression.

Return Value

A JToken, or null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


SelectToken(String,Boolean) Method

SelectToken(String,Boolean) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > SelectToken Method : SelectToken(String,Boolean) Method
A System.String that contains a JPath expression.
A flag to indicate whether an error should be thrown if no tokens are found when evaluating part of the expression.
Selects a JToken using a JPath expression. Selects the token that matches the object path.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SelectToken( _
   ByVal path As System.String, _
   ByVal errorWhenNoMatch As System.Boolean _
) As JToken
'Usage

Dim instance As JToken
Dim path As System.String
Dim errorWhenNoMatch As System.Boolean
Dim value As JToken

value = instance.SelectToken(path, errorWhenNoMatch)
public JToken SelectToken(
   System.string path,
   System.bool errorWhenNoMatch
)
public function SelectToken(
    path: System.String;
    errorWhenNoMatch: System.Boolean
): JToken;
public function SelectToken(
   path : System.String,
   errorWhenNoMatch : System.boolean
) : JToken;
public: JToken* SelectToken(
   System.string* path,
   System.bool errorWhenNoMatch
)
public:
JToken^ SelectToken(
   System.String^ path,
   System.bool errorWhenNoMatch
)

Parameters

path
A System.String that contains a JPath expression.
errorWhenNoMatch
A flag to indicate whether an error should be thrown if no tokens are found when evaluating part of the expression.

Return Value

A JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


SelectTokens Method (JToken)

SelectTokens Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : SelectTokens Method
Selects a collection of elements using a JPath expression.
Overload List
Overload | Description
SelectTokens(String) | Selects a collection of elements using a JPath expression.
SelectTokens(String,Boolean) | Selects a collection of elements using a JPath expression.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


SelectTokens(String) Method

SelectTokens(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > SelectTokens Method : SelectTokens(String) Method
A System.String that contains a JPath expression.
Selects a collection of elements using a JPath expression.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SelectTokens( _
   ByVal path As System.String _
) As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim path As System.String
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.SelectTokens(path)
public System.Collections.Generic.IEnumerable<JToken> SelectTokens(
   System.string path
)
public function SelectTokens(
    path: System.String
): System.Collections.Generic.IEnumerable;
public function SelectTokens(
   path : System.String
) : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* SelectTokens(
   System.string* path
)
public:
System.Collections.Generic.IEnumerable<JToken^>^ SelectTokens(
   System.String^ path
)

Parameters

path
A System.String that contains a JPath expression.

Return Value

An System.Collections.Generic.IEnumerable`1 that contains the selected elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


SelectTokens(String,Boolean) Method

SelectTokens(String,Boolean) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > SelectTokens Method : SelectTokens(String,Boolean) Method
A System.String that contains a JPath expression.
A flag to indicate whether an error should be thrown if no tokens are found when evaluating part of the expression.
Selects a collection of elements using a JPath expression.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SelectTokens( _
   ByVal path As System.String, _
   ByVal errorWhenNoMatch As System.Boolean _
) As System.Collections.Generic.IEnumerable(Of JToken)
'Usage

Dim instance As JToken
Dim path As System.String
Dim errorWhenNoMatch As System.Boolean
Dim value As System.Collections.Generic.IEnumerable(Of JToken)

value = instance.SelectTokens(path, errorWhenNoMatch)
public System.Collections.Generic.IEnumerable<JToken> SelectTokens(
   System.string path,
   System.bool errorWhenNoMatch
)
public function SelectTokens(
    path: System.String;
    errorWhenNoMatch: System.Boolean
): System.Collections.Generic.IEnumerable;
public function SelectTokens(
   path : System.String,
   errorWhenNoMatch : System.boolean
) : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<JToken*>* SelectTokens(
   System.string* path,
   System.bool errorWhenNoMatch
)
public:
System.Collections.Generic.IEnumerable<JToken^>^ SelectTokens(
   System.String^ path,
   System.bool errorWhenNoMatch
)

Parameters

path
A System.String that contains a JPath expression.
errorWhenNoMatch
A flag to indicate whether an error should be thrown if no tokens are found when evaluating part of the expression.

Return Value

An System.Collections.Generic.IEnumerable`1 that contains the selected elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


ToObject Method (JToken)

ToObject Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : ToObject Method
Creates the specified .NET type from the JToken.
Overload List
Overload | Description
ToObject<T>() | Creates the specified .NET type from the JToken.
ToObject(Type) | Creates the specified .NET type from the JToken.
ToObject<T>(JsonSerializer) | Creates the specified .NET type from the JToken using the specified Noemax.Newtonsoft.Json.JsonSerializer.
ToObject(Type,JsonSerializer) | Creates the specified .NET type from the JToken using the specified Noemax.Newtonsoft.Json.JsonSerializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


ToObject<T>() Method

ToObject<T>() Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToObject Method : ToObject<T>() Method
The object type that the token will be deserialized to.
Creates the specified .NET type from the JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToObject(Of T)() As T
'Usage

Dim instance As JToken
Dim value As T

value = instance.ToObject(Of T)()
public T ToObject<T>()
public function ToObject(): T;
public function ToObject() : T;
public: T* ToObject<T>();
public:
T^ ToObjectgeneric<typename T>
();

Type Parameters

T
The object type that the token will be deserialized to.

Return Value

The new object created from the JSON value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


ToObject(Type) Method

ToObject(Type) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToObject Method : ToObject(Type) Method
The object type that the token will be deserialized to.
Creates the specified .NET type from the JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToObject( _
   ByVal objectType As System.Type _
) As System.Object
'Usage

Dim instance As JToken
Dim objectType As System.Type
Dim value As System.Object

value = instance.ToObject(objectType)
public System.object ToObject(
   System.Type objectType
)
public function ToObject(
    objectType: System.Type
): System.TObject;
public function ToObject(
   objectType : System.Type
) : System.Object;
public: System.Object* ToObject(
   System.Type* objectType
)
public:
System.Object^ ToObject(
   System.Type^ objectType
)

Parameters

objectType
The object type that the token will be deserialized to.

Return Value

The new object created from the JSON value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


ToObject<T>(JsonSerializer) Method

ToObject<T>(JsonSerializer) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToObject Method : ToObject<T>(JsonSerializer) Method
The object type that the token will be deserialized to.
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when creating the object.
Creates the specified .NET type from the JToken using the specified Noemax.Newtonsoft.Json.JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToObject(Of T)( _
   ByVal jsonSerializer As JsonSerializer _
) As T
'Usage

Dim instance As JToken
Dim jsonSerializer As JsonSerializer
Dim value As T

value = instance.ToObject(Of T)(jsonSerializer)
public T ToObject<T>(
   JsonSerializer jsonSerializer
)
public function ToObject(
    jsonSerializer: JsonSerializer
): T;
public function ToObject(
   jsonSerializer : JsonSerializer
) : T;
public: T* ToObject<T>(
   JsonSerializer* jsonSerializer
)
public:
T^ ToObjectgeneric<typename T>
(
   JsonSerializer^ jsonSerializer
)

Parameters

jsonSerializer
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when creating the object.

Type Parameters

T
The object type that the token will be deserialized to.

Return Value

The new object created from the JSON value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


ToObject(Type,JsonSerializer) Method

ToObject(Type,JsonSerializer) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToObject Method : ToObject(Type,JsonSerializer) Method
The object type that the token will be deserialized to.
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when creating the object.
Creates the specified .NET type from the JToken using the specified Noemax.Newtonsoft.Json.JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToObject( _
   ByVal objectType As System.Type, _
   ByVal jsonSerializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As JToken
Dim objectType As System.Type
Dim jsonSerializer As JsonSerializer
Dim value As System.Object

value = instance.ToObject(objectType, jsonSerializer)
public System.object ToObject(
   System.Type objectType,
   JsonSerializer jsonSerializer
)
public function ToObject(
    objectType: System.Type;
    jsonSerializer: JsonSerializer
): System.TObject;
public function ToObject(
   objectType : System.Type,
   jsonSerializer : JsonSerializer
) : System.Object;
public: System.Object* ToObject(
   System.Type* objectType,
   JsonSerializer* jsonSerializer
)
public:
System.Object^ ToObject(
   System.Type^ objectType,
   JsonSerializer^ jsonSerializer
)

Parameters

objectType
The object type that the token will be deserialized to.
jsonSerializer
The Noemax.Newtonsoft.Json.JsonSerializer that will be used when creating the object.

Return Value

The new object created from the JSON value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


ToString Method (JToken)

ToString Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : ToString Method
Returns the indented JSON for this token.
Overload List
Overload | Description
ToString() | Returns the indented JSON for this token.
ToString(Formatting,JsonConverter[]) | Returns the JSON for this token using the given formatting and converters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Base Implementation in ToString


ToString() Method

ToString() Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToString Method : ToString() Method
Returns the indented JSON for this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ToString() As System.String
'Usage

Dim instance As JToken
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public function ToString(): System.String; override;
public override function ToString() : System.String;
public: System.string* ToString(); override
public:
System.String^ ToString(); override

Return Value

The indented JSON for this token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List
Base Implementation in ToString


ToString(Formatting,JsonConverter[]) Method

ToString(Formatting,JsonConverter[]) Method

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > ToString Method : ToString(Formatting,JsonConverter[]) Method
Indicates how the output is formatted.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Returns the JSON for this token using the given formatting and converters.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToString( _
   ByVal formatting As Formatting, _
   ByVal ParamArray converters() As JsonConverter _
) As System.String
'Usage

Dim instance As JToken
Dim formatting As Formatting
Dim converters() As JsonConverter
Dim value As System.String

value = instance.ToString(formatting, converters)
public System.string ToString(
   Formatting formatting,
   params JsonConverter[] converters
)
public function ToString(
    formatting: Formatting;
   params  converters: JsonConverterarray of
): System.String;
public function ToString(
   formatting : Formatting,
   converters : JsonConverter[]
) : System.String;
public: System.string* ToString(
   Formatting formatting,
   params JsonConverter*[]* converters
)
public:
System.String^ ToString(
   Formatting formatting,
   ... array<JsonConverter^>^ converters
)

Parameters

formatting
Indicates how the output is formatted.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.

Return Value

The JSON for this token using the given formatting and converters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Value<T> Method (JToken)

Value<T> Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Value<T> Method
The type to convert the token to.
The token key.
Gets the JToken with the specified key converted to the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Value(Of T)( _
   ByVal key As System.Object _
) As T
'Usage

Dim instance As JToken
Dim key As System.Object
Dim value As T

value = instance.Value(Of T)(key)
public virtual T Value<T>(
   System.object key
)
public function Value(
    key: System.TObject
): T; virtual;
public function Value(
   key : System.Object
) : T;
public: virtual T* Value<T>(
   System.Object* key
)
public:
virtual T^ Valuegeneric<typename T>
(
   System.Object^ key
)

Parameters

key
The token key.

Type Parameters

T
The type to convert the token to.

Return Value

The converted token value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Values<T> Method (JToken)

Values<T> Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Values<T> Method
The type to convert the values to.
Returns a collection of the child values of this token, in document order.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Values(Of T)() As System.Collections.Generic.IEnumerable(Of T)
'Usage

Dim instance As JToken
Dim value As System.Collections.Generic.IEnumerable(Of T)

value = instance.Values(Of T)()
public virtual System.Collections.Generic.IEnumerable<T> Values<T>()
public function Values(): System.Collections.Generic.IEnumerable; virtual;
public function Values() : System.Collections.Generic.IEnumerable;
public: virtual System.Collections.Generic.IEnumerable<T*>* Values<T>();
public:
virtual System.Collections.Generic.IEnumerable<T^>^ Valuesgeneric<typename T>
();

Type Parameters

T
The type to convert the values to.

Return Value

A System.Collections.Generic.IEnumerable`1 containing the child values of this JToken, in document order.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


WriteTo Method (JToken)

WriteTo Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JToken
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public abstract void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); abstract;
public __abstract function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: abstract void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
)
public:
abstract void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
)

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


JToken Class Properties

JToken Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class

For a list of all members of this type, see JToken members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | EqualityComparer | Gets a comparer that can compare two tokens for value equality.
Public Property | First | Get the first child token of this token.
Public Property | HasValues | Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node.
Public Property | Parent | Gets or sets the parent.
Public Property | Path | Gets the path of the JSON token.
Public Property | Previous | Gets the previous sibling token of this node.
Public Property | Root | Gets the root JToken of this JToken.
Public Property | Type | Gets the node type for this JToken.
Top
See Also

Reference

JToken Class
Noemax.Newtonsoft.Json.Linq Namespace


EqualityComparer Property (JToken)

EqualityComparer Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : EqualityComparer Property
Gets a comparer that can compare two tokens for value equality.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Property EqualityComparer As JTokenEqualityComparer
'Usage

Dim value As JTokenEqualityComparer

value = JToken.EqualityComparer
public static JTokenEqualityComparer EqualityComparer {get;}
public read-only property EqualityComparer: JTokenEqualityComparer; static;
public static function get EqualityComparer : JTokenEqualityComparer
public: __property static JTokenEqualityComparer* get_EqualityComparer();
public:
static property JTokenEqualityComparer^ EqualityComparer {
   JTokenEqualityComparer^ get();
}

Property Value

A JTokenEqualityComparer that can compare two nodes for value equality.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


First Property (JToken)

First Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : First Property
Get the first child token of this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property First As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.First
public virtual JToken First {get;}
public read-only property First: JToken; virtual;
public function get First : JToken
public: __property virtual JToken* get_First();
public:
virtual property JToken^ First {
   JToken^ get();
}

Property Value

A JToken containing the first child token of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


HasValues Property (JToken)

HasValues Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : HasValues Property
Gets a value indicating whether this token has child tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property HasValues As System.Boolean
'Usage

Dim instance As JToken
Dim value As System.Boolean

value = instance.HasValues
public abstract System.bool HasValues {get;}
public read-only property HasValues: System.Boolean; abstract;
public __abstract function get HasValues : System.boolean
public: __property abstract System.bool get_HasValues();
public:
abstract property System.bool HasValues {
   System.bool get();
}

Property Value

true if this token has child values; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Item Property (JToken)

Item Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Item Property
Gets the JToken with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Default Property Item( _
   ByVal key As System.Object _
) As JToken
'Usage

Dim instance As JToken
Dim key As System.Object
Dim value As JToken

instance.Item(key) = value

value = instance.Item(key)
public virtual JToken this[
   System.object key
]; {get; set;}
public  this: : JToken;[
    key: System.TObject
];virtual;  read-write
public  this[
   key : System.Object
] get,set : JToken
public: __property virtual JToken* get_Item   System.Object* key
;
public: __property virtual void set_Item   System.Object* key,
   JToken* value
;
public:
virtual property JToken^ default [Object^] {
   JToken^ get(System.Object^ key);
   void set (System.Object^ key, JToken^ value);
}

Parameters

key

Property Value

The JToken with the specified key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Last Property (JToken)

Last Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Last Property
Get the last child token of this token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Last As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.Last
public virtual JToken Last {get;}
public read-only property Last: JToken; virtual;
public function get Last : JToken
public: __property virtual JToken* get_Last();
public:
virtual property JToken^ Last {
   JToken^ get();
}

Property Value

A JToken containing the last child token of the JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Next Property (JToken)

Next Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Next Property
Gets the next sibling token of this node.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Next As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.Next
public JToken Next {get;}
public read-only property Next: JToken;
public function get Next : JToken
public: __property JToken* get_Next();
public:
property JToken^ Next {
   JToken^ get();
}

Property Value

The JToken that contains the next sibling token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Parent Property (JToken)

Parent Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Parent Property
Gets or sets the parent.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Parent As JContainer
'Usage

Dim instance As JToken
Dim value As JContainer

value = instance.Parent
public JContainer Parent {get;}
public read-only property Parent: JContainer;
public function get Parent : JContainer
public: __property JContainer* get_Parent();
public:
property JContainer^ Parent {
   JContainer^ get();
}

Property Value

The parent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Path Property (JToken)

Path Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Path Property
Gets the path of the JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As JToken
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Previous Property (JToken)

Previous Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Previous Property
Gets the previous sibling token of this node.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Previous As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.Previous
public JToken Previous {get;}
public read-only property Previous: JToken;
public function get Previous : JToken
public: __property JToken* get_Previous();
public:
property JToken^ Previous {
   JToken^ get();
}

Property Value

The JToken that contains the previous sibling token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Root Property (JToken)

Root Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Root Property
Gets the root JToken of this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Root As JToken
'Usage

Dim instance As JToken
Dim value As JToken

value = instance.Root
public JToken Root {get;}
public read-only property Root: JToken;
public function get Root : JToken
public: __property JToken* get_Root();
public:
property JToken^ Root {
   JToken^ get();
}

Property Value

The root JToken of this JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Type Property (JToken)

Type Property (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Type As JTokenType
'Usage

Dim instance As JToken
Dim value As JTokenType

value = instance.Type
public abstract JTokenType Type {get;}
public read-only property Type: JTokenType; abstract;
public __abstract function get Type : JTokenType
public: __property abstract JTokenType get_Type();
public:
abstract property JTokenType Type {
   JTokenType get();
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Explicit Type Conversion Operator (JToken)

Explicit Type Conversion Operator (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Explicit Type Conversion Operator
Performs an explicit conversion from JToken to System.Boolean.
Overload List
Overload | Description
Explicit Type Conversion(Boolean,JToken) | Performs an explicit conversion from JToken to System.Boolean.
Explicit Type Conversion(DateTimeOffset,JToken) | Performs an explicit conversion from JToken to System.DateTimeOffset.
Explicit Type Conversion(Nullable<Boolean>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Int64,JToken) | Performs an explicit conversion from JToken to System.Int64.
Explicit Type Conversion(Nullable<DateTime>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<DateTimeOffset>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Decimal>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Double>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Char>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Int32,JToken) | Performs an explicit conversion from JToken to System.Int32.
Explicit Type Conversion(Int16,JToken) | Performs an explicit conversion from JToken to System.Int16.
Explicit Type Conversion(UInt16,JToken) | Performs an explicit conversion from JToken to System.UInt16.
Explicit Type Conversion(Char,JToken) | Performs an explicit conversion from JToken to System.Char.
Explicit Type Conversion(Byte,JToken) | Performs an explicit conversion from JToken to System.Byte.
Explicit Type Conversion(SByte,JToken) | Performs an explicit conversion from JToken to System.SByte.
Explicit Type Conversion(Nullable<Int32>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Int16>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<UInt16>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Byte>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<SByte>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(DateTime,JToken) | Performs an explicit conversion from JToken to System.DateTime.
Explicit Type Conversion(Nullable<Int64>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<Single>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Decimal,JToken) | Performs an explicit conversion from JToken to System.Decimal.
Explicit Type Conversion(Nullable<UInt32>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Nullable<UInt64>,JToken) | Performs an explicit conversion from JToken to System.Nullable`1.
Explicit Type Conversion(Double,JToken) | Performs an explicit conversion from JToken to System.Double.
Explicit Type Conversion(Single,JToken) | Performs an explicit conversion from JToken to System.Single.
Explicit Type Conversion(String,JToken) | Performs an explicit conversion from JToken to System.String.
Explicit Type Conversion(UInt32,JToken) | Performs an explicit conversion from JToken to System.UInt32.
Explicit Type Conversion(UInt64,JToken) | Performs an explicit conversion from JToken to System.UInt64.
Explicit Type Conversion(Byte[],JToken) | Performs an explicit conversion from JToken to System.Byte[].
Explicit Type Conversion(Guid,JToken) | Performs an explicit conversion from JToken to System.Guid.
Explicit Type Conversion(Nullable<Guid>,JToken) | Performs an explicit conversion from JToken to System.Guid.
Explicit Type Conversion(TimeSpan,JToken) | Performs an explicit conversion from JToken to System.TimeSpan.
Explicit Type Conversion(Nullable<TimeSpan>,JToken) | Performs an explicit conversion from JToken to System.TimeSpan.
Explicit Type Conversion(Uri,JToken) | Performs an explicit conversion from JToken to System.Uri.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Implicit Type Conversion Operator (JToken)

Implicit Type Conversion Operator (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Implicit Type Conversion Operator
Performs an implicit conversion from System.Int32 to JToken.
Overload List
Overload | Description
Implicit Type Conversion(JToken,Int32) | Performs an implicit conversion from System.Int32 to JToken.
Implicit Type Conversion(JToken,Nullable<Int32>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,DateTime) | Performs an implicit conversion from System.DateTime to JToken.
Implicit Type Conversion(JToken,Nullable<Int64>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Single>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Decimal) | Performs an implicit conversion from System.Decimal to JToken.
Implicit Type Conversion(JToken,Nullable<Int16>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt16>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt32>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt64>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Double) | Performs an implicit conversion from System.Double to JToken.
Implicit Type Conversion(JToken,Single) | Performs an implicit conversion from System.Single to JToken.
Implicit Type Conversion(JToken,String) | Performs an implicit conversion from System.String to JToken.
Implicit Type Conversion(JToken,UInt32) | Performs an implicit conversion from System.UInt32 to JToken.
Implicit Type Conversion(JToken,UInt64) | Performs an implicit conversion from System.UInt64 to JToken.
Implicit Type Conversion(JToken,Byte[]) | Performs an implicit conversion from System.Byte[] to JToken.
Implicit Type Conversion(JToken,Uri) | Performs an implicit conversion from System._uri to JToken.
Implicit Type Conversion(JToken,TimeSpan) | Performs an implicit conversion from System.TimeSpan to JToken.
Implicit Type Conversion(JToken,Nullable<TimeSpan>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Guid) | Performs an implicit conversion from System.Guid to JToken.
Implicit Type Conversion(JToken,Nullable<Guid>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Boolean) | Performs an implicit conversion from System.Boolean to JToken.
Implicit Type Conversion(JToken,DateTimeOffset) | Performs an implicit conversion from System.DateTimeOffset to JToken.
Implicit Type Conversion(JToken,Byte) | Performs an implicit conversion from System.Byte to JToken.
Implicit Type Conversion(JToken,Nullable<Byte>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,SByte) | Performs an implicit conversion from System.SByte to JToken.
Implicit Type Conversion(JToken,Nullable<SByte>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Boolean>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Int64) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<DateTime>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<DateTimeOffset>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Decimal>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Double>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Int16) | Performs an implicit conversion from System.Int16 to JToken.
Implicit Type Conversion(JToken,UInt16) | Performs an implicit conversion from System.UInt16 to JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


JTokenEqualityComparer Class

JTokenEqualityComparer Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JTokenEqualityComparer Class
Compares tokens to determine whether they are equal.
Object Model
JTokenEqualityComparer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JTokenEqualityComparer
'Usage

Dim instance As JTokenEqualityComparer
public class JTokenEqualityComparer
public class JTokenEqualityComparer
public class JTokenEqualityComparer
public __gc class JTokenEqualityComparer
public ref class JTokenEqualityComparer
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JTokenEqualityComparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Members
Noemax.Newtonsoft.Json.Linq Namespace


JTokenEqualityComparer Class Members

JTokenEqualityComparer Class Members
Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenEqualityComparer Class

The following tables list the members exposed by JTokenEqualityComparer.

Public Constructors
 | Name | Description
Public Constructor | JTokenEqualityComparer Constructor |
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified objects are equal.
Public Method | GetHashCode | Overloaded. Returns a hash code for the specified object.
Top
See Also

Reference

JTokenEqualityComparer Class
Noemax.Newtonsoft.Json.Linq Namespace


JTokenEqualityComparer Constructor

JTokenEqualityComparer Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JTokenEqualityComparer Class : JTokenEqualityComparer Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JTokenEqualityComparer()
public JTokenEqualityComparer()
public JTokenEqualityComparer();
public function JTokenEqualityComparer();
public: JTokenEqualityComparer();
public:
JTokenEqualityComparer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Class
JTokenEqualityComparer Members


JTokenEqualityComparer Class Methods

JTokenEqualityComparer Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenEqualityComparer Class

For a list of all members of this type, see JTokenEqualityComparer members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified objects are equal.
Public Method | GetHashCode | Overloaded. Returns a hash code for the specified object.
Top
See Also

Reference

JTokenEqualityComparer Class
Noemax.Newtonsoft.Json.Linq Namespace


Equals Method (JTokenEqualityComparer)

Equals Method (JTokenEqualityComparer)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenEqualityComparer Class : Equals Method
Determines whether the specified objects are equal.
Overload List
Overload | Description
Equals(JToken,JToken) | Determines whether the specified objects are equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Class
JTokenEqualityComparer Members


Equals(JToken,JToken) Method

Equals(JToken,JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenEqualityComparer Class > Equals Method : Equals(JToken,JToken) Method
The first object of type JToken to compare.
The second object of type JToken to compare.
Determines whether the specified objects are equal.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Equals( _
   ByVal x As JToken, _
   ByVal y As JToken _
) As System.Boolean
'Usage

Dim instance As JTokenEqualityComparer
Dim x As JToken
Dim y As JToken
Dim value As System.Boolean

value = instance.Equals(x, y)
public System.bool Equals(
   JToken x,
   JToken y
)
public function Equals(
    x: JToken;
    y: JToken
): System.Boolean;
public function Equals(
   x : JToken,
   y : JToken
) : System.boolean;
public: System.bool Equals(
   JToken* x,
   JToken* y
)
public:
System.bool Equals(
   JToken^ x,
   JToken^ y
)

Parameters

x
The first object of type JToken to compare.
y
The second object of type JToken to compare.

Return Value

true if the specified objects are equal; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Class
JTokenEqualityComparer Members
Overload List


GetHashCode Method (JTokenEqualityComparer)

GetHashCode Method (JTokenEqualityComparer)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenEqualityComparer Class : GetHashCode Method
Returns a hash code for the specified object.
Overload List
Overload | Description
GetHashCode(JToken) | Returns a hash code for the specified object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Class
JTokenEqualityComparer Members


GetHashCode(JToken) Method

GetHashCode(JToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenEqualityComparer Class > GetHashCode Method : GetHashCode(JToken) Method
The System.Object for which a hash code is to be returned.
Returns a hash code for the specified object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function GetHashCode( _
   ByVal obj As JToken _
) As System.Integer
'Usage

Dim instance As JTokenEqualityComparer
Dim obj As JToken
Dim value As System.Integer

value = instance.GetHashCode(obj)
public System.int GetHashCode(
   JToken obj
)
public function GetHashCode(
    obj: JToken
): System.Integer;
public function GetHashCode(
   obj : JToken
) : System.int;
public: System.int GetHashCode(
   JToken* obj
)
public:
System.int GetHashCode(
   JToken^ obj
)

Parameters

obj
The System.Object for which a hash code is to be returned.

Return Value

A hash code for the specified object.
Exceptions
Exception | Description
System.ArgumentNullException | The type of obj is a reference type and obj is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenEqualityComparer Class
JTokenEqualityComparer Members
Overload List


JTokenReader Class

JTokenReader Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JTokenReader Class
Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Object Model
JTokenReader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JTokenReader
   Inherits Noemax.Newtonsoft.Json.JsonReader
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo
'Usage

Dim instance As JTokenReader
public class JTokenReader : Noemax.Newtonsoft.Json.JsonReader, Noemax.Newtonsoft.Json.IJsonLineInfo
public class JTokenReader = class(Noemax.Newtonsoft.Json.JsonReader, Noemax.Newtonsoft.Json.IJsonLineInfo)
public class JTokenReader extends Noemax.Newtonsoft.Json.JsonReader implements Noemax.Newtonsoft.Json.IJsonLineInfo
public __gc class JTokenReader : public Noemax.Newtonsoft.Json.JsonReader, Noemax.Newtonsoft.Json.IJsonLineInfo
public ref class JTokenReader : public Noemax.Newtonsoft.Json.JsonReader, Noemax.Newtonsoft.Json.IJsonLineInfo
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Linq.JTokenReader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Members
Noemax.Newtonsoft.Json.Linq Namespace


JTokenReader Class Members

JTokenReader Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenReader Class

The following tables list the members exposed by JTokenReader.

Public Constructors
 | Name | Description
Public Constructor | JTokenReader Constructor | Initializes a new instance of the JTokenReader class.
Top
Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a Noemax.Newtonsoft.Json.JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Overridden. Gets the path of the current JSON token.
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Public Methods
 | Name | Description
Public Method | Close | Changes the Noemax.Newtonsoft.Json.JsonReader.State to Closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token.
Top
See Also

Reference

JTokenReader Class
Noemax.Newtonsoft.Json.Linq Namespace


JTokenReader Constructor

JTokenReader Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : JTokenReader Constructor
The token to read from.
Initializes a new instance of the JTokenReader class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal token As JToken _
)
'Usage

Dim token As JToken

Dim instance As New JTokenReader(token)
public JTokenReader(
   JToken token
)
public JTokenReader(
    token: JToken
);
public function JTokenReader(
   token : JToken
);
public: JTokenReader(
   JToken* token
)
public:
JTokenReader(
   JToken^ token
)

Parameters

token
The token to read from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members


JTokenReader Class Methods

JTokenReader Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenReader Class

For a list of all members of this type, see JTokenReader members.

Public Methods
 | Name | Description
Public Method | Close | Changes the Noemax.Newtonsoft.Json.JsonReader.State to Closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Method | Read | Overridden. Reads the next JSON token from the stream.
Public Method | ReadAsBytes | Overridden. Reads the next JSON token from the stream as a Byte[].
Public Method | ReadAsDateTime | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDateTimeOffset | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsDecimal | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsInt32 | Overridden. Reads the next JSON token from the stream as a System.Nullable`1.
Public Method | ReadAsString | Overridden. Reads the next JSON token from the stream as a System.String.
Public Method | Skip | Skips the children of the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Methods
 | Name | Description
Protected Method | Dispose | Releases unmanaged and - optionally - managed resources (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetStateBasedOnCurrent | Sets the state based on current token type. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Protected Method | SetToken | Overloaded. Sets the current token.
Top
See Also

Reference

JTokenReader Class
Noemax.Newtonsoft.Json.Linq Namespace


Read Method (JTokenReader)

Read Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : Read Method
Reads the next JSON token from the stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Read() As System.Boolean
'Usage

Dim instance As JTokenReader
Dim value As System.Boolean

value = instance.Read()
public override System.bool Read()
public function Read(): System.Boolean; override;
public override function Read() : System.boolean;
public: System.bool Read(); override
public:
System.bool Read(); override

Return Value

true if the next token was read successfully; false if there are no more tokens to read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in Read


ReadAsBytes Method (JTokenReader)

ReadAsBytes Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsBytes Method
Reads the next JSON token from the stream as a Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsBytes() As System.Byte()
'Usage

Dim instance As JTokenReader
Dim value() As System.Byte

value = instance.ReadAsBytes()
public override System.byte[] ReadAsBytes()
public function ReadAsBytes(): System.array of Byte; override;
public override function ReadAsBytes() : System.byte[];
public: System.byte[]* ReadAsBytes(); override
public:
System.array<byte>^ ReadAsBytes(); override

Return Value

A Byte[] or a null reference if the next JSON token is null. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsBytes


ReadAsDateTime Method (JTokenReader)

ReadAsDateTime Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsDateTime Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTime() As System.Nullable(Of Date)
'Usage

Dim instance As JTokenReader
Dim value As System.Nullable(Of Date)

value = instance.ReadAsDateTime()
public override System.Nullable<DateTime> ReadAsDateTime()
public function ReadAsDateTime(): System.Nullable; override;
public override function ReadAsDateTime() : System.Nullable;
public: System.Nullable<DateTime> ReadAsDateTime(); override
public:
System.Nullable<DateTime> ReadAsDateTime(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsDateTime


ReadAsDateTimeOffset Method (JTokenReader)

ReadAsDateTimeOffset Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsDateTimeOffset Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDateTimeOffset() As System.Nullable(Of DateTimeOffset)
'Usage

Dim instance As JTokenReader
Dim value As System.Nullable(Of DateTimeOffset)

value = instance.ReadAsDateTimeOffset()
public override System.Nullable<DateTimeOffset> ReadAsDateTimeOffset()
public function ReadAsDateTimeOffset(): System.Nullable; override;
public override function ReadAsDateTimeOffset() : System.Nullable;
public: System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override
public:
System.Nullable<DateTimeOffset> ReadAsDateTimeOffset(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsDateTimeOffset


ReadAsDecimal Method (JTokenReader)

ReadAsDecimal Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsDecimal Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsDecimal() As System.Nullable(Of Decimal)
'Usage

Dim instance As JTokenReader
Dim value As System.Nullable(Of Decimal)

value = instance.ReadAsDecimal()
public override System.Nullable<decimal> ReadAsDecimal()
public function ReadAsDecimal(): System.Nullable; override;
public override function ReadAsDecimal() : System.Nullable;
public: System.Nullable<decimal> ReadAsDecimal(); override
public:
System.Nullable<decimal> ReadAsDecimal(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsDecimal


ReadAsInt32 Method (JTokenReader)

ReadAsInt32 Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsInt32 Method
Reads the next JSON token from the stream as a System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsInt32() As System.Nullable(Of Integer)
'Usage

Dim instance As JTokenReader
Dim value As System.Nullable(Of Integer)

value = instance.ReadAsInt32()
public override System.Nullable<int> ReadAsInt32()
public function ReadAsInt32(): System.Nullable; override;
public override function ReadAsInt32() : System.Nullable;
public: System.Nullable<int> ReadAsInt32(); override
public:
System.Nullable<int> ReadAsInt32(); override

Return Value

A System.Nullable`1. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsInt32


ReadAsString Method (JTokenReader)

ReadAsString Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : ReadAsString Method
Reads the next JSON token from the stream as a System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadAsString() As System.String
'Usage

Dim instance As JTokenReader
Dim value As System.String

value = instance.ReadAsString()
public override System.string ReadAsString()
public function ReadAsString(): System.String; override;
public override function ReadAsString() : System.String;
public: System.string* ReadAsString(); override
public:
System.String^ ReadAsString(); override

Return Value

A System.String. This method will return null at the end of an array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in ReadAsString


JTokenReader Class Properties

JTokenReader Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JTokenReader Class

For a list of all members of this type, see JTokenReader members.

Public Properties
 | Name | Description
Public Property | CloseInput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the reader is closed. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Culture | Gets or sets the culture used when reading JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateFormatString | Get or set how custom date formatted strings are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateParseHandling | Get or set how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when reading JSON. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Depth | Gets the depth of the current token in the JSON document. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | FloatParseHandling | Get or set how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | MaxDepth | Gets or sets the maximum depth allowed when reading JSON. Reading past this depth will throw a Noemax.Newtonsoft.Json.JsonReaderException. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Path | Overridden. Gets the path of the current JSON token.
Public Property | QuoteChar | Gets the quotation mark character used to enclose the value of a string. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | SupportMultipleContent | Gets or sets a value indicating whether multiple pieces of JSON content can be read from a continuous stream without erroring. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | TokenType | Gets the type of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | Value | Gets the text value of the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Public Property | ValueType | Gets The Common Language Runtime (CLR) type for the current JSON token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
Protected Properties
 | Name | Description
Protected Property | CurrentState | Gets the current reader state. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Top
See Also

Reference

JTokenReader Class
Noemax.Newtonsoft.Json.Linq Namespace


Path Property (JTokenReader)

Path Property (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : Path Property
Gets the path of the current JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Path As System.String
'Usage

Dim instance As JTokenReader
Dim value As System.String

value = instance.Path
public override System.string Path {get;}
public read-only property Path: System.String; override;
public override function get Path : System.String
public: __property System.string* get_Path() override;
public:
property System.String^ Path {
   System.String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members
Base Implementation in Path


JTokenWriter Class

JTokenWriter Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JTokenWriter Class
Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Object Model
JTokenWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JTokenWriter
   Inherits Noemax.Newtonsoft.Json.JsonWriter
'Usage

Dim instance As JTokenWriter
public class JTokenWriter : Noemax.Newtonsoft.Json.JsonWriter
public class JTokenWriter = class(Noemax.Newtonsoft.Json.JsonWriter)
public class JTokenWriter extends Noemax.Newtonsoft.Json.JsonWriter
public __gc class JTokenWriter : public Noemax.Newtonsoft.Json.JsonWriter
public ref class JTokenWriter : public Noemax.Newtonsoft.Json.JsonWriter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Members
Noemax.Newtonsoft.Json.Linq Namespace


JTokenWriter Class Members

JTokenWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenWriter Class

The following tables list the members exposed by JTokenWriter.

Public Constructors
 | Name | Description
Public Constructor | JTokenWriter Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Token | Gets the token being writen.
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the end.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current Noemax.Newtonsoft.Json.JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Writes out the given white space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Writes indent characters. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndentSpace | Writes an indent space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

JTokenWriter Class
Noemax.Newtonsoft.Json.Linq Namespace


JTokenWriter Constructor

JTokenWriter Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : JTokenWriter Constructor
Overload List
Overload | Description
JTokenWriter Constructor(JContainer) | Initializes a new instance of the JTokenWriter class writing to the given JContainer.
JTokenWriter Constructor() | Initializes a new instance of the JTokenWriter class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members


JTokenWriter Constructor(JContainer)

JTokenWriter Constructor(JContainer)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > JTokenWriter Constructor : JTokenWriter Constructor(JContainer)
The container being written to.
Initializes a new instance of the JTokenWriter class writing to the given JContainer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal container As JContainer _
)
'Usage

Dim container As JContainer

Dim instance As New JTokenWriter(container)
public JTokenWriter(
   JContainer container
)
public JTokenWriter(
    container: JContainer
);
public function JTokenWriter(
   container : JContainer
);
public: JTokenWriter(
   JContainer* container
)
public:
JTokenWriter(
   JContainer^ container
)

Parameters

container
The container being written to.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List


JTokenWriter Constructor()

JTokenWriter Constructor()

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > JTokenWriter Constructor : JTokenWriter Constructor()
Initializes a new instance of the JTokenWriter class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JTokenWriter()
public JTokenWriter()
public JTokenWriter();
public function JTokenWriter();
public: JTokenWriter();
public:
JTokenWriter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List


JTokenWriter Class Methods

JTokenWriter Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JTokenWriter Class

For a list of all members of this type, see JTokenWriter members.

Public Methods
 | Name | Description
Public Method | Close | Overridden. Closes this stream and the underlying stream.
Public Method | Flush | Overridden. Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Public Method | WriteComment | Overridden. Writes out a comment /*...*/ containing the specified text.
Public Method | WriteEnd | Overloaded. Overridden. Writes the end.
Public Method | WriteEndArray | Writes the end of an array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndConstructor | Writes the end constructor. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteEndObject | Writes the end of a Json object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteNull | Overridden. Writes a null value.
Public Method | WritePropertyName | Overloaded. Overridden. Writes the property name of a name/value pair on a Json object.
Public Method | WriteRaw | Overridden. Writes raw JSON.
Public Method | WriteRawValue | Writes raw JSON where a value is expected and updates the writer's state. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteStartArray | Overridden. Writes the beginning of a Json array.
Public Method | WriteStartConstructor | Overridden. Writes the start of a constructor with the given name.
Public Method | WriteStartObject | Overridden. Writes the beginning of a Json object.
Public Method | WriteToken | Overloaded. Writes the current Noemax.Newtonsoft.Json.JsonReader token and its children. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Method | WriteUndefined | Overridden. Writes an undefined value.
Public Method | WriteValue | Overloaded. Overridden. Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Public Method | WriteWhitespace | Writes out the given white space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
Protected Methods
 | Name | Description
Protected Method | SetWriteState | Sets the state of the JsonWriter, (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndent | Writes indent characters. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteIndentSpace | Writes an indent space. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Protected Method | WriteValueDelimiter | Writes the JSON value delimiter. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

JTokenWriter Class
Noemax.Newtonsoft.Json.Linq Namespace


Close Method (JTokenWriter)

Close Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : Close Method
Closes this stream and the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Close()
'Usage

Dim instance As JTokenWriter

instance.Close()
public override void Close()
public procedure Close(); override;
public override function Close();
public: void Close(); override
public:
void Close(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in Close


Flush Method (JTokenWriter)

Flush Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : Flush Method
Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Flush()
'Usage

Dim instance As JTokenWriter

instance.Flush()
public override void Flush()
public procedure Flush(); override;
public override function Flush();
public: void Flush(); override
public:
void Flush(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in Flush


WriteComment Method (JTokenWriter)

WriteComment Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteComment Method
Text to place inside the comment.
Writes out a comment /*...*/ containing the specified text.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteComment( _
   ByVal text As System.String _
)
'Usage

Dim instance As JTokenWriter
Dim text As System.String

instance.WriteComment(text)
public override void WriteComment(
   System.string text
)
public procedure WriteComment(
    text: System.String
); override;
public override function WriteComment(
   text : System.String
);
public: void WriteComment(
   System.string* text
) override
public:
void WriteComment(
   System.String^ text
) override

Parameters

text
Text to place inside the comment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteComment


WriteEnd Method (JTokenWriter)

WriteEnd Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteEnd Method
Writes the end.
Overload List
Overload | Description
WriteEnd(JsonToken) | Writes the end.
WriteEnd() | Writes the end of the current Json object or array. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteEnd


WriteEnd(JsonToken) Method

WriteEnd(JsonToken) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteEnd Method : WriteEnd(JsonToken) Method
The token.
Writes the end.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Sub WriteEnd( _
   ByVal token As JsonToken _
)
'Usage

Dim instance As JTokenWriter
Dim token As JsonToken

instance.WriteEnd(token)
protected override void WriteEnd(
   JsonToken token
)
protected procedure WriteEnd(
    token: JsonToken
); override;
protected override function WriteEnd(
   token : JsonToken
);
protected: void WriteEnd(
   JsonToken token
) override
protected:
void WriteEnd(
   JsonToken token
) override

Parameters

token
The token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteEnd(JsonToken)


WriteNull Method (JTokenWriter)

WriteNull Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteNull Method
Writes a null value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteNull()
'Usage

Dim instance As JTokenWriter

instance.WriteNull()
public override void WriteNull()
public procedure WriteNull(); override;
public override function WriteNull();
public: void WriteNull(); override
public:
void WriteNull(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteNull


WritePropertyName Method (JTokenWriter)

WritePropertyName Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WritePropertyName Method
Writes the property name of a name/value pair on a Json object.
Overload List
Overload | Description
WritePropertyName(String) | Writes the property name of a name/value pair on a Json object.
WritePropertyName(String,Boolean) | Writes the property name of a name/value pair on a JSON object. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WritePropertyName


WritePropertyName(String) Method

WritePropertyName(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WritePropertyName Method : WritePropertyName(String) Method
The name of the property.
Writes the property name of a name/value pair on a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WritePropertyName( _
   ByVal name As System.String _
)
'Usage

Dim instance As JTokenWriter
Dim name As System.String

instance.WritePropertyName(name)
public override void WritePropertyName(
   System.string name
)
public procedure WritePropertyName(
    name: System.String
); override;
public override function WritePropertyName(
   name : System.String
);
public: void WritePropertyName(
   System.string* name
) override
public:
void WritePropertyName(
   System.String^ name
) override

Parameters

name
The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WritePropertyName(String)


WriteRaw Method (JTokenWriter)

WriteRaw Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteRaw Method
The raw JSON to write.
Writes raw JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteRaw( _
   ByVal json As System.String _
)
'Usage

Dim instance As JTokenWriter
Dim json As System.String

instance.WriteRaw(json)
public override void WriteRaw(
   System.string json
)
public procedure WriteRaw(
    json: System.String
); override;
public override function WriteRaw(
   json : System.String
);
public: void WriteRaw(
   System.string* json
) override
public:
void WriteRaw(
   System.String^ json
) override

Parameters

json
The raw JSON to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteRaw


WriteStartArray Method (JTokenWriter)

WriteStartArray Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteStartArray Method
Writes the beginning of a Json array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartArray()
'Usage

Dim instance As JTokenWriter

instance.WriteStartArray()
public override void WriteStartArray()
public procedure WriteStartArray(); override;
public override function WriteStartArray();
public: void WriteStartArray(); override
public:
void WriteStartArray(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteStartArray


WriteStartConstructor Method (JTokenWriter)

WriteStartConstructor Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteStartConstructor Method
The name of the constructor.
Writes the start of a constructor with the given name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartConstructor( _
   ByVal name As System.String _
)
'Usage

Dim instance As JTokenWriter
Dim name As System.String

instance.WriteStartConstructor(name)
public override void WriteStartConstructor(
   System.string name
)
public procedure WriteStartConstructor(
    name: System.String
); override;
public override function WriteStartConstructor(
   name : System.String
);
public: void WriteStartConstructor(
   System.string* name
) override
public:
void WriteStartConstructor(
   System.String^ name
) override

Parameters

name
The name of the constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteStartConstructor


WriteStartObject Method (JTokenWriter)

WriteStartObject Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteStartObject Method
Writes the beginning of a Json object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteStartObject()
'Usage

Dim instance As JTokenWriter

instance.WriteStartObject()
public override void WriteStartObject()
public procedure WriteStartObject(); override;
public override function WriteStartObject();
public: void WriteStartObject(); override
public:
void WriteStartObject(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteStartObject


WriteUndefined Method (JTokenWriter)

WriteUndefined Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteUndefined Method
Writes an undefined value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteUndefined()
'Usage

Dim instance As JTokenWriter

instance.WriteUndefined()
public override void WriteUndefined()
public procedure WriteUndefined(); override;
public override function WriteUndefined();
public: void WriteUndefined(); override
public:
void WriteUndefined(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteUndefined


WriteValue Method (JTokenWriter)

WriteValue Method (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : WriteValue Method
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Overload List
Overload | Description
WriteValue(Object) | Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
WriteValue(String) | Writes a System.String value.
WriteValue(Int32) | Writes a System.Int32 value.
WriteValue(UInt32) | Writes a System.UInt32 value.
WriteValue(Int64) | Writes a System.Int64 value.
WriteValue(UInt64) | Writes a System.UInt64 value.
WriteValue(Single) | Writes a System.Single value.
WriteValue(Double) | Writes a System.Double value.
WriteValue(Boolean) | Writes a System.Boolean value.
WriteValue(Int16) | Writes a System.Int16 value.
WriteValue(UInt16) | Writes a System.UInt16 value.
WriteValue(Char) | Writes a System.Char value.
WriteValue(Byte) | Writes a System.Byte value.
WriteValue(SByte) | Writes a System.SByte value.
WriteValue(Decimal) | Writes a System.Decimal value.
WriteValue(DateTime) | Writes a System.DateTime value.
WriteValue(DateTimeOffset) | Writes a System.DateTimeOffset value.
WriteValue(Byte[]) | Writes a Byte[] value.
WriteValue(TimeSpan) | Writes a System.TimeSpan value.
WriteValue(Guid) | Writes a System.Guid value.
WriteValue(Uri) | Writes a System.Uri value.
WriteValue(Nullable<Int32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt32>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt64>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Single>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Double>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Boolean>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Int16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<UInt16>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Char>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Byte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<SByte>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Decimal>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTime>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<DateTimeOffset>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<Guid>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
WriteValue(Nullable<TimeSpan>) | Writes a System.Nullable`1 value. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Base Implementation in WriteValue


WriteValue(Object) Method

WriteValue(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Object) Method
The System.Object value to write.
Writes a System.Object value. An error will raised if the value cannot be written as a single JSON token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Object _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Object

instance.WriteValue(value)
public override void WriteValue(
   System.object value
)
public procedure WriteValue(
    value: System.TObject
); override;
public override function WriteValue(
   value : System.Object
);
public: void WriteValue(
   System.Object* value
) override
public:
void WriteValue(
   System.Object^ value
) override

Parameters

value
The System.Object value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Object)


WriteValue(String) Method

WriteValue(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(String) Method
The System.String value to write.
Writes a System.String value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.String _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.String

instance.WriteValue(value)
public override void WriteValue(
   System.string value
)
public procedure WriteValue(
    value: System.String
); override;
public override function WriteValue(
   value : System.String
);
public: void WriteValue(
   System.string* value
) override
public:
void WriteValue(
   System.String^ value
) override

Parameters

value
The System.String value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(String)


WriteValue(Int32) Method

WriteValue(Int32) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Int32) Method
The System.Int32 value to write.
Writes a System.Int32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Integer _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Integer

instance.WriteValue(value)
public override void WriteValue(
   System.int value
)
public procedure WriteValue(
    value: System.Integer
); override;
public override function WriteValue(
   value : System.int
);
public: void WriteValue(
   System.int value
) override
public:
void WriteValue(
   System.int value
) override

Parameters

value
The System.Int32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Int32)


WriteValue(UInt32) Method

WriteValue(UInt32) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(UInt32) Method
The System.UInt32 value to write.
Writes a System.UInt32 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UInteger _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.UInteger

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.uint value
)
public procedure WriteValue(
    value: System.LongWord
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.uint
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.uint value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.uint value
) override

Parameters

value
The System.UInt32 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(UInt32)


WriteValue(Int64) Method

WriteValue(Int64) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Int64) Method
The System.Int64 value to write.
Writes a System.Int64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Long _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Long

instance.WriteValue(value)
public override void WriteValue(
   System.long value
)
public procedure WriteValue(
    value: System.Int64
); override;
public override function WriteValue(
   value : System.long
);
public: void WriteValue(
   System.long value
) override
public:
void WriteValue(
   System.int64 value
) override

Parameters

value
The System.Int64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Int64)


WriteValue(UInt64) Method

WriteValue(UInt64) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(UInt64) Method
The System.UInt64 value to write.
Writes a System.UInt64 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.ULong _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.ULong

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ulong value
)
public procedure WriteValue(
    value: System.UInt64
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ulong
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ulong value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ulong value
) override

Parameters

value
The System.UInt64 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(UInt64)


WriteValue(Single) Method

WriteValue(Single) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Single) Method
The System.Single value to write.
Writes a System.Single value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Single _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Single

instance.WriteValue(value)
public override void WriteValue(
   System.float value
)
public procedure WriteValue(
    value: System.Single
); override;
public override function WriteValue(
   value : System.float
);
public: void WriteValue(
   System.float value
) override
public:
void WriteValue(
   System.float value
) override

Parameters

value
The System.Single value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Single)


WriteValue(Double) Method

WriteValue(Double) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Double) Method
The System.Double value to write.
Writes a System.Double value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Double _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Double

instance.WriteValue(value)
public override void WriteValue(
   System.double value
)
public procedure WriteValue(
    value: System.Double
); override;
public override function WriteValue(
   value : System.double
);
public: void WriteValue(
   System.double value
) override
public:
void WriteValue(
   System.double value
) override

Parameters

value
The System.Double value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Double)


WriteValue(Boolean) Method

WriteValue(Boolean) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Boolean) Method
The System.Boolean value to write.
Writes a System.Boolean value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Boolean _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Boolean

instance.WriteValue(value)
public override void WriteValue(
   System.bool value
)
public procedure WriteValue(
    value: System.Boolean
); override;
public override function WriteValue(
   value : System.boolean
);
public: void WriteValue(
   System.bool value
) override
public:
void WriteValue(
   System.bool value
) override

Parameters

value
The System.Boolean value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Boolean)


WriteValue(Int16) Method

WriteValue(Int16) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Int16) Method
The System.Int16 value to write.
Writes a System.Int16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Short _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Short

instance.WriteValue(value)
public override void WriteValue(
   System.short value
)
public procedure WriteValue(
    value: System.Int16
); override;
public override function WriteValue(
   value : System.short
);
public: void WriteValue(
   System.short value
) override
public:
void WriteValue(
   System.short value
) override

Parameters

value
The System.Int16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Int16)


WriteValue(UInt16) Method

WriteValue(UInt16) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(UInt16) Method
The System.UInt16 value to write.
Writes a System.UInt16 value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.UShort _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.UShort

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.ushort value
)
public procedure WriteValue(
    value: System.Word
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.ushort
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.ushort value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.ushort value
) override

Parameters

value
The System.UInt16 value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(UInt16)


WriteValue(Char) Method

WriteValue(Char) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Char) Method
The System.Char value to write.
Writes a System.Char value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Char _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Char

instance.WriteValue(value)
public override void WriteValue(
   System.char value
)
public procedure WriteValue(
    value: System.Char
); override;
public override function WriteValue(
   value : System.char
);
public: void WriteValue(
   System.char value
) override
public:
void WriteValue(
   System.char value
) override

Parameters

value
The System.Char value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Char)


WriteValue(Byte) Method

WriteValue(Byte) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Byte) Method
The System.Byte value to write.
Writes a System.Byte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Byte _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte value
)
public procedure WriteValue(
    value: System.Byte
); override;
public override function WriteValue(
   value : System.byte
);
public: void WriteValue(
   System.byte value
) override
public:
void WriteValue(
   System.byte value
) override

Parameters

value
The System.Byte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Byte)


WriteValue(SByte) Method

WriteValue(SByte) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(SByte) Method
The System.SByte value to write.
Writes a System.SByte value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.SByte _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.SByte

instance.WriteValue(value)
[System.CLSCompliant(false)]
public override void WriteValue(
   System.sbyte value
)
public procedure WriteValue(
    value: System.ShortInt
); override;
System.CLSCompliantAttribute()
public override function WriteValue(
   value : System.sbyte
);
[System.CLSCompliant(false)]
public: void WriteValue(
   System.sbyte value
) override
[System.CLSCompliant(false)]
public:
void WriteValue(
   System.sbyte value
) override

Parameters

value
The System.SByte value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(SByte)


WriteValue(Decimal) Method

WriteValue(Decimal) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Decimal) Method
The System.Decimal value to write.
Writes a System.Decimal value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Decimal _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Decimal

instance.WriteValue(value)
public override void WriteValue(
   System.decimal value
)
public procedure WriteValue(
    value: System.Currency
); override;
public override function WriteValue(
   value : System.decimal
);
public: void WriteValue(
   System.decimal value
) override
public:
void WriteValue(
   System.decimal value
) override

Parameters

value
The System.Decimal value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Decimal)


WriteValue(DateTime) Method

WriteValue(DateTime) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(DateTime) Method
The System.DateTime value to write.
Writes a System.DateTime value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Date _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Date

instance.WriteValue(value)
public override void WriteValue(
   System.DateTime value
)
public procedure WriteValue(
    value: System.DateTime
); override;
public override function WriteValue(
   value : System.DateTime
);
public: void WriteValue(
   System.DateTime value
) override
public:
void WriteValue(
   System.DateTime value
) override

Parameters

value
The System.DateTime value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(DateTime)


WriteValue(DateTimeOffset) Method

WriteValue(DateTimeOffset) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(DateTimeOffset) Method
The System.DateTimeOffset value to write.
Writes a System.DateTimeOffset value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.DateTimeOffset _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.DateTimeOffset

instance.WriteValue(value)
public override void WriteValue(
   System.DateTimeOffset value
)
public procedure WriteValue(
    value: System.DateTimeOffset
); override;
public override function WriteValue(
   value : System.DateTimeOffset
);
public: void WriteValue(
   System.DateTimeOffset value
) override
public:
void WriteValue(
   System.DateTimeOffset value
) override

Parameters

value
The System.DateTimeOffset value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(DateTimeOffset)


WriteValue(Byte[]) Method

WriteValue(Byte[]) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Byte[]) Method
The Byte[] value to write.
Writes a Byte[] value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value() As System.Byte _
)
'Usage

Dim instance As JTokenWriter
Dim value() As System.Byte

instance.WriteValue(value)
public override void WriteValue(
   System.byte[] value
)
public procedure WriteValue(
    value: System.Bytearray of
); override;
public override function WriteValue(
   value : System.byte[]
);
public: void WriteValue(
   System.byte[]* value
) override
public:
void WriteValue(
   System.array<byte>^ value
) override

Parameters

value
The Byte[] value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Byte[])


WriteValue(TimeSpan) Method

WriteValue(TimeSpan) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(TimeSpan) Method
The System.TimeSpan value to write.
Writes a System.TimeSpan value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.TimeSpan _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.TimeSpan

instance.WriteValue(value)
public override void WriteValue(
   System.TimeSpan value
)
public procedure WriteValue(
    value: System.TimeSpan
); override;
public override function WriteValue(
   value : System.TimeSpan
);
public: void WriteValue(
   System.TimeSpan value
) override
public:
void WriteValue(
   System.TimeSpan value
) override

Parameters

value
The System.TimeSpan value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(TimeSpan)


WriteValue(Guid) Method

WriteValue(Guid) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Guid) Method
The System.Guid value to write.
Writes a System.Guid value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Guid _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Guid

instance.WriteValue(value)
public override void WriteValue(
   System.Guid value
)
public procedure WriteValue(
    value: System.Guid
); override;
public override function WriteValue(
   value : System.Guid
);
public: void WriteValue(
   System.Guid value
) override
public:
void WriteValue(
   System.Guid value
) override

Parameters

value
The System.Guid value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Guid)


WriteValue(Uri) Method

WriteValue(Uri) Method

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class > WriteValue Method : WriteValue(Uri) Method
The System.Uri value to write.
Writes a System.Uri value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub WriteValue( _
   ByVal value As System.Uri _
)
'Usage

Dim instance As JTokenWriter
Dim value As System.Uri

instance.WriteValue(value)
public override void WriteValue(
   System.Uri value
)
public procedure WriteValue(
    value: System.Uri
); override;
public override function WriteValue(
   value : System.Uri
);
public: void WriteValue(
   System.Uri* value
) override
public:
void WriteValue(
   System.Uri^ value
) override

Parameters

value
The System.Uri value to write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members
Overload List
Base Implementation in WriteValue(Uri)


JTokenWriter Class Properties

JTokenWriter Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JTokenWriter Class

For a list of all members of this type, see JTokenWriter members.

Public Properties
 | Name | Description
Public Property | CloseOutput | Gets or sets a value indicating whether the underlying stream or System.IO.TextReader should be closed when the writer is closed. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Culture | Gets or sets the culture used when writing JSON. Defaults to System.Globalization.CultureInfo.InvariantCulture. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatHandling | Get or set how dates are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateFormatString | Get or set how DateTime and DateTimeOffset values are formatting when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | DateTimeZoneHandling | Get or set how System.DateTime time zones are handling when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | FloatFormatHandling | Get or set how special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity, are written to JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Formatting | Indicates how JSON text output is formatted. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Path | Gets the path of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | StringEscapeHandling | Get or set how strings are escaped when writing JSON text. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Public Property | Token | Gets the token being writen.
Public Property | WriteState | Gets the state of the writer. (Inherited from Noemax.Newtonsoft.Json.JsonWriter)
Top
See Also

Reference

JTokenWriter Class
Noemax.Newtonsoft.Json.Linq Namespace


Token Property (JTokenWriter)

Token Property (JTokenWriter)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenWriter Class : Token Property
Gets the token being writen.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Token As JToken
'Usage

Dim instance As JTokenWriter
Dim value As JToken

value = instance.Token
public JToken Token {get;}
public read-only property Token: JToken;
public function get Token : JToken
public: __property JToken* get_Token();
public:
property JToken^ Token {
   JToken^ get();
}

Property Value

The token being writen.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenWriter Class
JTokenWriter Members


JValue Class

JValue Class
Members

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class
Represents a value in JSON (string, integer, date, etc).
Object Model
JValue Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JValue
   Inherits JToken
   Implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable(Of JToken)
'Usage

Dim instance As JValue
public class JValue : JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public class JValue = class(JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable)
public class JValue extends JToken implements Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable
public __gc class JValue : public JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
public ref class JValue : public JToken, Noemax.Newtonsoft.Json.IJsonLineInfo, Noemax.Newtonsoft.Json.Linq.IJEnumerable<JToken>
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JValue
Noemax.Newtonsoft.Json.Linq.JRaw

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Members
Noemax.Newtonsoft.Json.Linq Namespace


JValue Class Members

JValue Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class

The following tables list the members exposed by JValue.

Public Constructors
 | Name | Description
Public Constructor | JValue Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value | Gets or sets the underlying token value.
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
static (Shared in Visual Basic) | CreateComment | Creates a JValue comment with the given value.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
static (Shared in Visual Basic) | CreateString | Creates a JValue string with the given value.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance.
Public Method | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
See Also

Reference

JValue Class
Noemax.Newtonsoft.Json.Linq Namespace


JValue Constructor

JValue Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : JValue Constructor
Overload List
Overload | Description
JValue Constructor(JValue) | Initializes a new instance of the JValue class from another JValue object.
JValue Constructor(Int64) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Decimal) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Char) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(UInt64) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Double) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Single) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(DateTime) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(DateTimeOffset) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Boolean) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(String) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Guid) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Uri) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(TimeSpan) | Initializes a new instance of the JValue class with the given value.
JValue Constructor(Object) | Initializes a new instance of the JValue class with the given value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


JValue Constructor(JValue)

JValue Constructor(JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(JValue)
A JValue object to copy from.
Initializes a new instance of the JValue class from another JValue object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal other As JValue _
)
'Usage

Dim other As JValue

Dim instance As New JValue(other)
public JValue(
   JValue other
)
public JValue(
    other: JValue
);
public function JValue(
   other : JValue
);
public: JValue(
   JValue* other
)
public:
JValue(
   JValue^ other
)

Parameters

other
A JValue object to copy from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Int64)

JValue Constructor(Int64)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Int64)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Long _
)
'Usage

Dim value As System.Long

Dim instance As New JValue(value)
public JValue(
   System.long value
)
public JValue(
    value: System.Int64
);
public function JValue(
   value : System.long
);
public: JValue(
   System.long value
)
public:
JValue(
   System.int64 value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Decimal)

JValue Constructor(Decimal)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Decimal)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Decimal _
)
'Usage

Dim value As System.Decimal

Dim instance As New JValue(value)
public JValue(
   System.decimal value
)
public JValue(
    value: System.Currency
);
public function JValue(
   value : System.decimal
);
public: JValue(
   System.decimal value
)
public:
JValue(
   System.decimal value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Char)

JValue Constructor(Char)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Char)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Char _
)
'Usage

Dim value As System.Char

Dim instance As New JValue(value)
public JValue(
   System.char value
)
public JValue(
    value: System.Char
);
public function JValue(
   value : System.char
);
public: JValue(
   System.char value
)
public:
JValue(
   System.char value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(UInt64)

JValue Constructor(UInt64)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(UInt64)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Public Function New( _
   ByVal value As System.ULong _
)
'Usage

Dim value As System.ULong

Dim instance As New JValue(value)
[System.CLSCompliant(false)]
public JValue(
   System.ulong value
)
public JValue(
    value: System.UInt64
);
System.CLSCompliantAttribute()
public function JValue(
   value : System.ulong
);
[System.CLSCompliant(false)]
public: JValue(
   System.ulong value
)
[System.CLSCompliant(false)]
public:
JValue(
   System.ulong value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Double)

JValue Constructor(Double)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Double)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Double _
)
'Usage

Dim value As System.Double

Dim instance As New JValue(value)
public JValue(
   System.double value
)
public JValue(
    value: System.Double
);
public function JValue(
   value : System.double
);
public: JValue(
   System.double value
)
public:
JValue(
   System.double value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Single)

JValue Constructor(Single)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Single)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Single _
)
'Usage

Dim value As System.Single

Dim instance As New JValue(value)
public JValue(
   System.float value
)
public JValue(
    value: System.Single
);
public function JValue(
   value : System.float
);
public: JValue(
   System.float value
)
public:
JValue(
   System.float value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(DateTime)

JValue Constructor(DateTime)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(DateTime)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Date _
)
'Usage

Dim value As System.Date

Dim instance As New JValue(value)
public JValue(
   System.DateTime value
)
public JValue(
    value: System.DateTime
);
public function JValue(
   value : System.DateTime
);
public: JValue(
   System.DateTime value
)
public:
JValue(
   System.DateTime value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(DateTimeOffset)

JValue Constructor(DateTimeOffset)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(DateTimeOffset)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.DateTimeOffset _
)
'Usage

Dim value As System.DateTimeOffset

Dim instance As New JValue(value)
public JValue(
   System.DateTimeOffset value
)
public JValue(
    value: System.DateTimeOffset
);
public function JValue(
   value : System.DateTimeOffset
);
public: JValue(
   System.DateTimeOffset value
)
public:
JValue(
   System.DateTimeOffset value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Boolean)

JValue Constructor(Boolean)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Boolean)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Boolean _
)
'Usage

Dim value As System.Boolean

Dim instance As New JValue(value)
public JValue(
   System.bool value
)
public JValue(
    value: System.Boolean
);
public function JValue(
   value : System.boolean
);
public: JValue(
   System.bool value
)
public:
JValue(
   System.bool value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(String)

JValue Constructor(String)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(String)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.String _
)
'Usage

Dim value As System.String

Dim instance As New JValue(value)
public JValue(
   System.string value
)
public JValue(
    value: System.String
);
public function JValue(
   value : System.String
);
public: JValue(
   System.string* value
)
public:
JValue(
   System.String^ value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Guid)

JValue Constructor(Guid)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Guid)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Guid _
)
'Usage

Dim value As System.Guid

Dim instance As New JValue(value)
public JValue(
   System.Guid value
)
public JValue(
    value: System.Guid
);
public function JValue(
   value : System.Guid
);
public: JValue(
   System.Guid value
)
public:
JValue(
   System.Guid value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Uri)

JValue Constructor(Uri)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Uri)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Uri _
)
'Usage

Dim value As System.Uri

Dim instance As New JValue(value)
public JValue(
   System.Uri value
)
public JValue(
    value: System.Uri
);
public function JValue(
   value : System.Uri
);
public: JValue(
   System.Uri* value
)
public:
JValue(
   System.Uri^ value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(TimeSpan)

JValue Constructor(TimeSpan)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(TimeSpan)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.TimeSpan _
)
'Usage

Dim value As System.TimeSpan

Dim instance As New JValue(value)
public JValue(
   System.TimeSpan value
)
public JValue(
    value: System.TimeSpan
);
public function JValue(
   value : System.TimeSpan
);
public: JValue(
   System.TimeSpan value
)
public:
JValue(
   System.TimeSpan value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Constructor(Object)

JValue Constructor(Object)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > JValue Constructor : JValue Constructor(Object)
The value.
Initializes a new instance of the JValue class with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal value As System.Object _
)
'Usage

Dim value As System.Object

Dim instance As New JValue(value)
public JValue(
   System.object value
)
public JValue(
    value: System.TObject
);
public function JValue(
   value : System.Object
);
public: JValue(
   System.Object* value
)
public:
JValue(
   System.Object^ value
)

Parameters

value
The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


JValue Class Methods

JValue Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class

For a list of all members of this type, see JValue members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
static (Shared in Visual Basic) | CreateComment | Creates a JValue comment with the given value.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
static (Shared in Visual Basic) | CreateString | Creates a JValue string with the given value.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance.
Public Method | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
See Also

Reference

JValue Class
Noemax.Newtonsoft.Json.Linq Namespace


CompareTo Method (JValue)

CompareTo Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : CompareTo Method
An object to compare with this instance.
Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CompareTo( _
   ByVal obj As JValue _
) As System.Integer
'Usage

Dim instance As JValue
Dim obj As JValue
Dim value As System.Integer

value = instance.CompareTo(obj)
public System.int CompareTo(
   JValue obj
)
public function CompareTo(
    obj: JValue
): System.Integer;
public function CompareTo(
   obj : JValue
) : System.int;
public: System.int CompareTo(
   JValue* obj
)
public:
System.int CompareTo(
   JValue^ obj
)

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.
Exceptions
Exception | Description
System.ArgumentException | obj is not the same type as this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


CreateComment Method (JValue)

CreateComment Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : CreateComment Method
The value.
Creates a JValue comment with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateComment( _
   ByVal value As System.String _
) As JValue
'Usage

Dim value As System.String
Dim value As JValue

value = JValue.CreateComment(value)
public static JValue CreateComment(
   System.string value
)
public function CreateComment(
    value: System.String
): JValue; static;
public static function CreateComment(
   value : System.String
) : JValue;
public: static JValue* CreateComment(
   System.string* value
)
public:
static JValue^ CreateComment(
   System.String^ value
)

Parameters

value
The value.

Return Value

A JValue comment with the given value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


CreateString Method (JValue)

CreateString Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : CreateString Method
The value.
Creates a JValue string with the given value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function CreateString( _
   ByVal value As System.String _
) As JValue
'Usage

Dim value As System.String
Dim value As JValue

value = JValue.CreateString(value)
public static JValue CreateString(
   System.string value
)
public function CreateString(
    value: System.String
): JValue; static;
public static function CreateString(
   value : System.String
) : JValue;
public: static JValue* CreateString(
   System.string* value
)
public:
static JValue^ CreateString(
   System.String^ value
)

Parameters

value
The value.

Return Value

A JValue string with the given value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


Equals Method (JValue)

Equals Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : Equals Method
Indicates whether the current object is equal to another object of the same type.
Overload List
Overload | Description
Equals(JValue) | Indicates whether the current object is equal to another object of the same type.
Equals(Object) | Determines whether the specified System.Object is equal to the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


Equals(JValue) Method

Equals(JValue) Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > Equals Method : Equals(JValue) Method
An object to compare with this object.
Indicates whether the current object is equal to another object of the same type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Equals( _
   ByVal other As JValue _
) As System.Boolean
'Usage

Dim instance As JValue
Dim other As JValue
Dim value As System.Boolean

value = instance.Equals(other)
public System.bool Equals(
   JValue other
)
public function Equals(
    other: JValue
): System.Boolean;
public function Equals(
   other : JValue
) : System.boolean;
public: System.bool Equals(
   JValue* other
)
public:
System.bool Equals(
   JValue^ other
)

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


Equals(Object) Method

Equals(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > Equals Method : Equals(Object) Method
The System.Object to compare with the current System.Object.
Determines whether the specified System.Object is equal to the current System.Object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JValue
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
public override System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; override;
public override function Equals(
   obj : System.Object
) : System.boolean;
public: System.bool Equals(
   System.Object* obj
) override
public:
System.bool Equals(
   System.Object^ obj
) override

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to the current System.Object; otherwise, false.
Exceptions
Exception | Description
System.NullReferenceException | The obj parameter is null.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List
Base Implementation in Equals(Object)


GetHashCode Method (JValue)

GetHashCode Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : GetHashCode Method
Serves as a hash function for a particular type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As System.Integer
'Usage

Dim instance As JValue
Dim value As System.Integer

value = instance.GetHashCode()
public override System.int GetHashCode()
public function GetHashCode(): System.Integer; override;
public override function GetHashCode() : System.int;
public: System.int GetHashCode(); override
public:
System.int GetHashCode(); override

Return Value

A hash code for the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in GetHashCode


ToString Method (JValue)

ToString Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : ToString Method
Returns a System.String that represents this instance.
Overload List
Overload | Description
ToString() | Returns a System.String that represents this instance.
ToString(String) | Returns a System.String that represents this instance.
ToString(IFormatProvider) | Returns a System.String that represents this instance.
ToString(String,IFormatProvider) | Returns a System.String that represents this instance.
ToString(Formatting,JsonConverter[]) | Returns a System.String that represents this instance. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in ToString


ToString() Method

ToString() Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > ToString Method : ToString() Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function ToString() As System.String
'Usage

Dim instance As JValue
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public function ToString(): System.String; override;
public override function ToString() : System.String;
public: System.string* ToString(); override
public:
System.String^ ToString(); override

Return Value

A System.String that represents this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List
Base Implementation in ToString


ToString(String) Method

ToString(String) Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > ToString Method : ToString(String) Method
The format.
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToString( _
   ByVal format As System.String _
) As System.String
'Usage

Dim instance As JValue
Dim format As System.String
Dim value As System.String

value = instance.ToString(format)
public System.string ToString(
   System.string format
)
public function ToString(
    format: System.String
): System.String;
public function ToString(
   format : System.String
) : System.String;
public: System.string* ToString(
   System.string* format
)
public:
System.String^ ToString(
   System.String^ format
)

Parameters

format
The format.

Return Value

A System.String that represents this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


ToString(IFormatProvider) Method

ToString(IFormatProvider) Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > ToString Method : ToString(IFormatProvider) Method
The format provider.
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToString( _
   ByVal formatProvider As System.IFormatProvider _
) As System.String
'Usage

Dim instance As JValue
Dim formatProvider As System.IFormatProvider
Dim value As System.String

value = instance.ToString(formatProvider)
public System.string ToString(
   System.IFormatProvider formatProvider
)
public function ToString(
    formatProvider: System.IFormatProvider
): System.String;
public function ToString(
   formatProvider : System.IFormatProvider
) : System.String;
public: System.string* ToString(
   System.IFormatProvider* formatProvider
)
public:
System.String^ ToString(
   System.IFormatProvider^ formatProvider
)

Parameters

formatProvider
The format provider.

Return Value

A System.String that represents this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


ToString(String,IFormatProvider) Method

ToString(String,IFormatProvider) Method

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class > ToString Method : ToString(String,IFormatProvider) Method
The format.
The format provider.
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ToString( _
   ByVal format As System.String, _
   ByVal formatProvider As System.IFormatProvider _
) As System.String
'Usage

Dim instance As JValue
Dim format As System.String
Dim formatProvider As System.IFormatProvider
Dim value As System.String

value = instance.ToString(format, formatProvider)
public System.string ToString(
   System.string format,
   System.IFormatProvider formatProvider
)
public function ToString(
    format: System.String;
    formatProvider: System.IFormatProvider
): System.String;
public function ToString(
   format : System.String,
   formatProvider : System.IFormatProvider
) : System.String;
public: System.string* ToString(
   System.string* format,
   System.IFormatProvider* formatProvider
)
public:
System.String^ ToString(
   System.String^ format,
   System.IFormatProvider^ formatProvider
)

Parameters

format
The format.
formatProvider
The format provider.

Return Value

A System.String that represents this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Overload List


WriteTo Method (JValue)

WriteTo Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : WriteTo Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal ParamArray converters() As JsonConverter _
)
'Usage

Dim instance As JValue
Dim writer As JsonWriter
Dim converters() As JsonConverter

instance.WriteTo(writer, converters)
public override void WriteTo(
   JsonWriter writer,
   params JsonConverter[] converters
)
public procedure WriteTo(
    writer: JsonWriter;
   params  converters: JsonConverterarray of
); override;
public override function WriteTo(
   writer : JsonWriter,
   converters : JsonConverter[]
);
public: void WriteTo(
   JsonWriter* writer,
   params JsonConverter*[]* converters
) override
public:
void WriteTo(
   JsonWriter^ writer,
   ... array<JsonConverter^>^ converters
) override

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
converters
A collection of Noemax.Newtonsoft.Json.JsonConverter which will be used when writing the token.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in WriteTo


JValue Class Properties

JValue Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class

For a list of all members of this type, see JValue members.

Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value | Gets or sets the underlying token value.
Top
See Also

Reference

JValue Class
Noemax.Newtonsoft.Json.Linq Namespace


HasValues Property (JValue)

HasValues Property (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : HasValues Property
Gets a value indicating whether this token has child tokens.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property HasValues As System.Boolean
'Usage

Dim instance As JValue
Dim value As System.Boolean

value = instance.HasValues
public override System.bool HasValues {get;}
public read-only property HasValues: System.Boolean; override;
public override function get HasValues : System.boolean
public: __property System.bool get_HasValues() override;
public:
property System.bool HasValues {
   System.bool get() override;
}

Property Value

true if this token has child values; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in HasValues


Type Property (JValue)

Type Property (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : Type Property
Gets the node type for this JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Type As JTokenType
'Usage

Dim instance As JValue
Dim value As JTokenType

value = instance.Type
public override JTokenType Type {get;}
public read-only property Type: JTokenType; override;
public override function get Type : JTokenType
public: __property JTokenType get_Type() override;
public:
property JTokenType Type {
   JTokenType get() override;
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in Type


Value Property (JValue)

Value Property (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : Value Property
Gets or sets the underlying token value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Value As System.Object
'Usage

Dim instance As JValue
Dim value As System.Object

instance.Value = value

value = instance.Value
public System.object Value {get; set;}
public read-write property Value: System.TObject;
public function get,set Value : System.Object
public: __property System.Object* get_Value();
public: __property void set_Value(
   System.Object* value
);
public:
property System.Object^ Value {
   System.Object^ get();
   void set (    System.Object^ value);
}

Property Value

The underlying token value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members


JTokenType Enumeration

JTokenType Enumeration

Noemax.Newtonsoft.Json.Linq Namespace : JTokenType Enumeration
Specifies the type of token.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum JTokenType
   Inherits System.Enum
'Usage

Dim instance As JTokenType
public enum JTokenType : System.Enum
public enum JTokenType = class(System.Enum)
public enum JTokenType extends System.Enum
__value public enum JTokenType : public System.Enum
public enum class JTokenType : public System.Enum
Members
Member | Description
Array | A JSON array.
Boolean | A boolean value.
Bytes | A collection of bytes value.
Comment | A comment.
Constructor | A JSON constructor.
Date | A date value.
Float | A float value.
Guid | A Guid value.
Integer | An integer value.
None | No token type has been set.
Null | A null value.
Object | A JSON object.
Property | A JSON object property.
Raw | A raw JSON value.
String | A string value.
TimeSpan | A TimeSpan value.
Undefined | An undefined value.
Uri | A _uri value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.Linq.JTokenType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json.Linq Namespace


JEnumerable<T> Structure

JEnumerable<T> Structure
Members

Noemax.Newtonsoft.Json.Linq Namespace : JEnumerable<T> Structure
The type of token
Represents a collection of JToken objects.
Object Model
JEnumerable<T> Structure
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Structure JEnumerable(Of T As JToken)
   Inherits System.ValueType
   Implements IJEnumerable(Of T)
'Usage

Dim instance As JEnumerable(Of T)
[System.Reflection.DefaultMember("Item")]
public struct JEnumerable<T> : System.ValueType, IJEnumerable<T>
where T: JToken
public type JEnumerable = class(System.ValueType, IJEnumerable)
JScript does not support Generics.
[System.Reflection.DefaultMember("Item")]
public __value struct JEnumerable<T> : public System.ValueType, IJEnumerable<T>
[System.Reflection.DefaultMember("Item")]
generic<typename T>
public value class JEnumerable : public System.ValueType, IJEnumerable<T>
where T: JToken
Type Parameters
T
The type of token
Inheritance Hierarchy

System.Object
System.ValueType
Noemax.Newtonsoft.Json.Linq.JEnumerable<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Members
Noemax.Newtonsoft.Json.Linq Namespace


JEnumerable<T> Structure Members

JEnumerable<T> Structure Members
Fields Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JEnumerable<T> Structure

The following tables list the members exposed by JEnumerable<T>.

Public Constructors
 | Name | Description
Public Constructor | JEnumerable<T> Constructor | Initializes a new instance of the JEnumerable<T> struct.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | An empty collection of JToken objects.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets the IJEnumerable<T> with the specified key.
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetHashCode | Returns a hash code for this instance.
Top
See Also

Reference

JEnumerable<T> Structure
Noemax.Newtonsoft.Json.Linq Namespace


JEnumerable<T> Constructor

JEnumerable<T> Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : JEnumerable<T> Constructor
The enumerable.
Initializes a new instance of the JEnumerable<T> struct.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal enumerable As System.Collections.Generic.IEnumerable(Of T) _
)
'Usage

Dim enumerable As System.Collections.Generic.IEnumerable(Of T)

Dim instance As New JEnumerable(Of T)(enumerable)
public JEnumerable<T>(
   System.Collections.Generic.IEnumerable<T> enumerable
)
public JEnumerable<T>(
    enumerable: System.Collections.Generic.IEnumerable
);
public function JEnumerable<T>(
   enumerable : System.Collections.Generic.IEnumerable
);
public: JEnumerable<T>(
   System.Collections.Generic.IEnumerable<T*>* enumerable
)
public:
JEnumerable<T>(
   System.Collections.Generic.IEnumerable<T^>^ enumerable
)

Parameters

enumerable
The enumerable.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members


JEnumerable<T> Structure Methods

JEnumerable<T> Structure Methods

Noemax.Newtonsoft.Json.Linq Namespace : JEnumerable<T> Structure

For a list of all members of this type, see JEnumerable<T> members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetHashCode | Returns a hash code for this instance.
Top
See Also

Reference

JEnumerable<T> Structure
Noemax.Newtonsoft.Json.Linq Namespace


Equals Method (JEnumerable<T>)

Equals Method (JEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : Equals Method
The System.Object to compare with this instance.
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JEnumerable(Of T)
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
public override System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; override;
public override function Equals(
   obj : System.Object
) : System.boolean;
public: System.bool Equals(
   System.Object* obj
) override
public:
System.bool Equals(
   System.Object^ obj
) override

Parameters

obj
The System.Object to compare with this instance.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members
Base Implementation in Equals


GetEnumerator Method (JEnumerable<T>)

GetEnumerator Method (JEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : GetEnumerator Method
Returns an enumerator that iterates through the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of T)
'Usage

Dim instance As JEnumerable(Of T)
Dim value As System.Collections.Generic.IEnumerator(Of T)

value = instance.GetEnumerator()
public System.Collections.Generic.IEnumerator<T> GetEnumerator()
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
public: System.Collections.Generic.IEnumerator<T*>* GetEnumerator();
public:
System.Collections.Generic.IEnumerator<T^>^ GetEnumerator();

Return Value

A System.Collections.Generic.IEnumerator`1 that can be used to iterate through the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members


GetHashCode Method (JEnumerable<T>)

GetHashCode Method (JEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetHashCode() As System.Integer
'Usage

Dim instance As JEnumerable(Of T)
Dim value As System.Integer

value = instance.GetHashCode()
public override System.int GetHashCode()
public function GetHashCode(): System.Integer; override;
public override function GetHashCode() : System.int;
public: System.int GetHashCode(); override
public:
System.int GetHashCode(); override

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members
Base Implementation in GetHashCode


JEnumerable<T> Structure Properties

JEnumerable<T> Structure Properties

Noemax.Newtonsoft.Json.Linq Namespace : JEnumerable<T> Structure

For a list of all members of this type, see JEnumerable<T> members.

Public Properties
 | Name | Description
Public Property | Item | Gets the IJEnumerable<T> with the specified key.
Top
See Also

Reference

JEnumerable<T> Structure
Noemax.Newtonsoft.Json.Linq Namespace


Item Property (JEnumerable<T>)

Item Property (JEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : Item Property
Gets the IJEnumerable<T> with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Default Property Item( _
   ByVal key As System.Object _
) As IJEnumerable(Of JToken)
'Usage

Dim instance As JEnumerable(Of T)
Dim key As System.Object
Dim value As IJEnumerable(Of JToken)

value = instance.Item(key)
public IJEnumerable<JToken> this[
   System.object key
]; {get;}
public  this: : IJEnumerable;[
    key: System.TObject
]; read-only
public  this[
   key : System.Object
] get : IJEnumerable
public: __property IJEnumerable<JToken*>* get_Item   System.Object* key
;
public:
property IJEnumerable<JToken^>^ default [Object^] {
   IJEnumerable<JToken^>^ get(System.Object^ key);
}

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members


JEnumerable<T> Structure Fields

JEnumerable<T> Structure Fields

Noemax.Newtonsoft.Json.Linq Namespace : JEnumerable<T> Structure

For a list of all members of this type, see JEnumerable<T> members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | An empty collection of JToken objects.
Top
See Also

Reference

JEnumerable<T> Structure
Noemax.Newtonsoft.Json.Linq Namespace


Empty Field (JEnumerable<T>)

Empty Field (JEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > JEnumerable<T> Structure : Empty Field
An empty collection of JToken objects.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared ReadOnly Empty As JEnumerable(Of T)
'Usage

Dim value As JEnumerable(Of T)

value = JEnumerable(Of T).Empty
public static readonly JEnumerable<T> Empty
public field Empty: JEnumerable; static; readonly
public static var Empty : JEnumerable;
public: static readonly JEnumerable<T*> Empty
public:
static readonly JEnumerable<T^> Empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JEnumerable<T> Structure
JEnumerable<T> Members


IJEnumerable<T> Interface

IJEnumerable<T> Interface
Members

Noemax.Newtonsoft.Json.Linq Namespace : IJEnumerable<T> Interface
The type of token
Represents a collection of JToken objects.
Object Model
IJEnumerable<T> Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Interface IJEnumerable(Of T As JToken)
'Usage

Dim instance As IJEnumerable(Of T)
[System.Reflection.DefaultMember("Item")]
public interface IJEnumerable<T>
where T: JToken
public interface IJEnumerable
JScript does not support Generics.
[System.Reflection.DefaultMember("Item")]
public __gc __interface IJEnumerable<T>
where T: JToken
[System.Reflection.DefaultMember("Item")]
generic<typename T>
public interface class IJEnumerable
where T: JToken
Type Parameters
T
The type of token
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJEnumerable<T> Members
Noemax.Newtonsoft.Json.Linq Namespace


IJEnumerable<T> Interface Members

IJEnumerable<T> Interface Members
Properties

Noemax.Newtonsoft.Json.Linq Namespace : IJEnumerable<T> Interface

The following tables list the members exposed by IJEnumerable<T>.

Public Properties
 | Name | Description
Property | Item | Gets the IJEnumerable<T> with the specified key.
Top
See Also

Reference

IJEnumerable<T> Interface
Noemax.Newtonsoft.Json.Linq Namespace


IJEnumerable<T> Interface Properties

IJEnumerable<T> Interface Properties

Noemax.Newtonsoft.Json.Linq Namespace : IJEnumerable<T> Interface

For a list of all members of this type, see IJEnumerable<T> members.

Public Properties
 | Name | Description
Property | Item | Gets the IJEnumerable<T> with the specified key.
Top
See Also

Reference

IJEnumerable<T> Interface
Noemax.Newtonsoft.Json.Linq Namespace


Item Property (IJEnumerable<T>)

Item Property (IJEnumerable<T>)

Noemax.Newtonsoft.Json.Linq Namespace > IJEnumerable<T> Interface : Item Property
Gets the IJEnumerable<T> with the specified key.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Default Property Item( _
   ByVal key As System.Object _
) As IJEnumerable(Of JToken)
'Usage

Dim instance As IJEnumerable(Of T)
Dim key As System.Object
Dim value As IJEnumerable(Of JToken)

value = instance.Item(key)
IJEnumerable<JToken> this[
   System.object key
]; {get;}
 this: : IJEnumerable;[
    key: System.TObject
]; read-only
 this[
   key : System.Object
] get : IJEnumerable
__property IJEnumerable<JToken*>* get_Item   System.Object* key
;
property IJEnumerable<JToken^>^ default [Object^] {
   IJEnumerable<JToken^>^ get(System.Object^ key);
}

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IJEnumerable<T> Interface
IJEnumerable<T> Members


Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets)
Inheritance Hierarchy
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | Extensions | Contains the JSON schema extension methods.
Class | JsonSchema | An in-memory representation of a JSON Schema.
Class | JsonSchemaException | Returns detailed information about the schema exception.
Class | JsonSchemaGenerator | Generates a JsonSchema from a specified System.Type.
Class | JsonSchemaResolver | Resolves JsonSchema from an id.
Class | ValidationEventArgs | Returns detailed information related to the ValidationEventHandler.
Delegates
 | Delegate | Description
Delegate | ValidationEventHandler | Represents the callback method that will handle JSON schema validation events and the ValidationEventArgs.
Enumerations
 | Enumeration | Description
Enumeration | JsonSchemaType | The value types allowed by the JsonSchema.
Enumeration | UndefinedSchemaIdHandling | Specifies undefined schema Id handling options for the JsonSchemaGenerator.
See Also

Reference

Noemax.WebSockets Assembly


Extensions Class

Extensions Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : Extensions Class
Contains the JSON schema extension methods.
Object Model
Extensions Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public MustInherit NotInheritable Class Extensions
'Usage

Dim instance As Extensions
[System.Runtime.CompilerServices.Extension()]
public static class Extensions
public class Extensions abstract; sealed;
System.Runtime.CompilerServices.ExtensionAttribute()
public abstract sealed class Extensions
[System.Runtime.CompilerServices.Extension()]
public __gc abstract __sealed class Extensions
[System.Runtime.CompilerServices.Extension()]
public ref class Extensions abstract sealed
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Schema.Extensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Members
Noemax.Newtonsoft.Json.Schema Namespace


Extensions Class Members

Extensions Class Members
Methods

Noemax.Newtonsoft.Json.Schema Namespace : Extensions Class

The following tables list the members exposed by Extensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | IsValid | Overloaded. Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
static (Shared in Visual Basic) | Validate | Overloaded. Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Top
See Also

Reference

Extensions Class
Noemax.Newtonsoft.Json.Schema Namespace


Extensions Class Methods

Extensions Class Methods

Noemax.Newtonsoft.Json.Schema Namespace : Extensions Class

For a list of all members of this type, see Extensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | IsValid | Overloaded. Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
static (Shared in Visual Basic) | Validate | Overloaded. Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Top
See Also

Reference

Extensions Class
Noemax.Newtonsoft.Json.Schema Namespace


IsValid Method (Extensions)

IsValid Method (Extensions)

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class : IsValid Method
Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
Overload List
Overload | Description
IsValid(JToken,JsonSchema) | Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
IsValid(JToken,JsonSchema,IList<String>) | Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


IsValid(JToken,JsonSchema) Method

IsValid(JToken,JsonSchema) Method

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class > IsValid Method : IsValid(JToken,JsonSchema) Method
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
The schema to test with.
Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function IsValid( _
   ByVal source As JToken, _
   ByVal schema As JsonSchema _
) As System.Boolean
'Usage

Dim source As JToken
Dim schema As JsonSchema
Dim value As System.Boolean

value = Extensions.IsValid(source, schema)
[System.Runtime.CompilerServices.Extension()]
public static System.bool IsValid(
   JToken source,
   JsonSchema schema
)
public function IsValid(
    source: JToken;
    schema: JsonSchema
): System.Boolean; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function IsValid(
   source : JToken,
   schema : JsonSchema
) : System.boolean;
[System.Runtime.CompilerServices.Extension()]
public: static System.bool IsValid(
   JToken* source,
   JsonSchema* schema
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.bool IsValid(
   JToken^ source,
   JsonSchema^ schema
)

Parameters

source
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
schema
The schema to test with.

Return Value

true if the specified Noemax.Newtonsoft.Json.Linq.JToken is valid; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


IsValid(JToken,JsonSchema,IList<String>) Method

IsValid(JToken,JsonSchema,IList<String>) Method

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class > IsValid Method : IsValid(JToken,JsonSchema,IList<String>) Method
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
The schema to test with.
When this method returns, contains any error messages generated while validating.
Determines whether the Noemax.Newtonsoft.Json.Linq.JToken is valid.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function IsValid( _
   ByVal source As JToken, _
   ByVal schema As JsonSchema, _
   ByRef errorMessages As System.Collections.Generic.IList(Of String) _
) As System.Boolean
'Usage

Dim source As JToken
Dim schema As JsonSchema
Dim errorMessages As System.Collections.Generic.IList(Of String)
Dim value As System.Boolean

value = Extensions.IsValid(source, schema, errorMessages)
[System.Runtime.CompilerServices.Extension()]
public static System.bool IsValid(
   JToken source,
   JsonSchema schema,
   out System.Collections.Generic.IList<string> errorMessages
)
public function IsValid(
    source: JToken;
    schema: JsonSchema;
   Out  errorMessages: System.Collections.Generic.IList
): System.Boolean; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function IsValid(
   source : JToken,
   schema : JsonSchema,
   errorMessages : System.Collections.Generic.IList
) : System.boolean;
[System.Runtime.CompilerServices.Extension()]
public: static System.bool IsValid(
   JToken* source,
   JsonSchema* schema,
   [PARAMFLAG::Out] System.Collections.Generic.IList<string*>* errorMessages
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.bool IsValid(
   JToken^ source,
   JsonSchema^ schema,
   [Out] System.Collections.Generic.IList<String^>^ errorMessages
)

Parameters

source
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
schema
The schema to test with.
errorMessages
When this method returns, contains any error messages generated while validating.

Return Value

true if the specified Noemax.Newtonsoft.Json.Linq.JToken is valid; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Validate Method (Extensions)

Validate Method (Extensions)

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class : Validate Method
Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Overload List
Overload | Description
Validate(JToken,JsonSchema) | Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Validate(JToken,JsonSchema,ValidationEventHandler) | Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members


Validate(JToken,JsonSchema) Method

Validate(JToken,JsonSchema) Method

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class > Validate Method : Validate(JToken,JsonSchema) Method
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
The schema to test with.
Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Validate( _
   ByVal source As JToken, _
   ByVal schema As JsonSchema _
)
'Usage

Dim source As JToken
Dim schema As JsonSchema

Extensions.Validate(source, schema)
[System.Runtime.CompilerServices.Extension()]
public static void Validate(
   JToken source,
   JsonSchema schema
)
public procedure Validate(
    source: JToken;
    schema: JsonSchema
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Validate(
   source : JToken,
   schema : JsonSchema
);
[System.Runtime.CompilerServices.Extension()]
public: static void Validate(
   JToken* source,
   JsonSchema* schema
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Validate(
   JToken^ source,
   JsonSchema^ schema
)

Parameters

source
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
schema
The schema to test with.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


Validate(JToken,JsonSchema,ValidationEventHandler) Method

Validate(JToken,JsonSchema,ValidationEventHandler) Method

Noemax.Newtonsoft.Json.Schema Namespace > Extensions Class > Validate Method : Validate(JToken,JsonSchema,ValidationEventHandler) Method
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
The schema to test with.
The validation event handler.
Validates the specified Noemax.Newtonsoft.Json.Linq.JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Validate( _
   ByVal source As JToken, _
   ByVal schema As JsonSchema, _
   ByVal validationEventHandler As ValidationEventHandler _
)
'Usage

Dim source As JToken
Dim schema As JsonSchema
Dim validationEventHandler As ValidationEventHandler

Extensions.Validate(source, schema, validationEventHandler)
[System.Runtime.CompilerServices.Extension()]
public static void Validate(
   JToken source,
   JsonSchema schema,
   ValidationEventHandler validationEventHandler
)
public procedure Validate(
    source: JToken;
    schema: JsonSchema;
    validationEventHandler: ValidationEventHandler
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Validate(
   source : JToken,
   schema : JsonSchema,
   validationEventHandler : ValidationEventHandler
);
[System.Runtime.CompilerServices.Extension()]
public: static void Validate(
   JToken* source,
   JsonSchema* schema,
   ValidationEventHandler* validationEventHandler
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Validate(
   JToken^ source,
   JsonSchema^ schema,
   ValidationEventHandler^ validationEventHandler
)

Parameters

source
The source Noemax.Newtonsoft.Json.Linq.JToken to test.
schema
The schema to test with.
validationEventHandler
The validation event handler.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Extensions Class
Extensions Members
Overload List


JsonSchema Class

JsonSchema Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchema Class
An in-memory representation of a JSON Schema.
Object Model
JsonSchema Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonSchema
'Usage

Dim instance As JsonSchema
public class JsonSchema
public class JsonSchema
public class JsonSchema
public __gc class JsonSchema
public ref class JsonSchema
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Schema.JsonSchema

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Members
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchema Class Members

JsonSchema Class Members
Properties Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchema Class

The following tables list the members exposed by JsonSchema.

Public Constructors
 | Name | Description
Public Constructor | JsonSchema Constructor | Initializes a new instance of the JsonSchema class.
Top
Public Properties
 | Name | Description
Public Property | AdditionalItems | Gets or sets the JsonSchema of additional items.
Public Property | AdditionalProperties | Gets or sets the JsonSchema of additional properties.
Public Property | AllowAdditionalItems | Gets or sets a value indicating whether additional items are allowed.
Public Property | AllowAdditionalProperties | Gets or sets a value indicating whether additional properties are allowed.
Public Property | Default | Gets or sets the default value.
Public Property | Description | Gets or sets the description of the object.
Public Property | Disallow | Gets or sets disallowed types.
Public Property | DivisibleBy | Gets or sets a number that the value should be divisble by.
Public Property | Enum | Gets or sets the a collection of valid enum values allowed.
Public Property | ExclusiveMaximum | Gets or sets a flag indicating whether the value can not equal the number defined by the "maximum" attribute.
Public Property | ExclusiveMinimum | Gets or sets a flag indicating whether the value can not equal the number defined by the "minimum" attribute.
Public Property | Extends | Gets or sets the collection of JsonSchema that this schema extends.
Public Property | Format | Gets or sets the format.
Public Property | Hidden | Gets or sets whether the object is visible to users.
Public Property | Id | Gets or sets the id.
Public Property | Items | Gets or sets the JsonSchema of items.
Public Property | Maximum | Gets or sets the maximum.
Public Property | MaximumItems | Gets or sets the maximum number of items.
Public Property | MaximumLength | Gets or sets the maximum length.
Public Property | Minimum | Gets or sets the minimum.
Public Property | MinimumItems | Gets or sets the minimum number of items.
Public Property | MinimumLength | Gets or sets the minimum length.
Public Property | Pattern | Gets or sets the pattern.
Public Property | PatternProperties | Gets or sets the pattern properties.
Public Property | PositionalItemsValidation | Gets or sets a value indicating whether items in an array are validated using the JsonSchema instance at their array position from Items.
Public Property | Properties | Gets or sets the JsonSchema of properties.
Public Property | ReadOnly | Gets or sets whether the object is read only.
Public Property | Required | Gets or sets whether the object is required.
Public Property | Requires | Gets or sets the required property if this property is present.
Public Property | Title | Gets or sets the title.
Public Property | Transient | Gets or sets whether the object is transient.
Public Property | Type | Gets or sets the types of values allowed by the object.
Public Property | UniqueItems | Gets or sets whether the array items must be unique.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Parse | Overloaded. Load a JsonSchema from a string that contains schema JSON.
static (Shared in Visual Basic) | Read | Overloaded. Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Public Method | WriteTo | Overloaded. Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter.
Top
See Also

Reference

JsonSchema Class
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchema Constructor

JsonSchema Constructor

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : JsonSchema Constructor
Initializes a new instance of the JsonSchema class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSchema()
public JsonSchema()
public JsonSchema();
public function JsonSchema();
public: JsonSchema();
public:
JsonSchema();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


JsonSchema Class Methods

JsonSchema Class Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchema Class

For a list of all members of this type, see JsonSchema members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Parse | Overloaded. Load a JsonSchema from a string that contains schema JSON.
static (Shared in Visual Basic) | Read | Overloaded. Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Public Method | WriteTo | Overloaded. Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter.
Top
See Also

Reference

JsonSchema Class
Noemax.Newtonsoft.Json.Schema Namespace


Parse Method (JsonSchema)

Parse Method (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Parse Method
Load a JsonSchema from a string that contains schema JSON.
Overload List
Overload | Description
Parse(String) | Load a JsonSchema from a string that contains schema JSON.
Parse(String,JsonSchemaResolver) | Parses the specified json.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Parse(String) Method

Parse(String) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > Parse Method : Parse(String) Method
A System.String that contains JSON.
Load a JsonSchema from a string that contains schema JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Parse( _
   ByVal json As System.String _
) As JsonSchema
'Usage

Dim json As System.String
Dim value As JsonSchema

value = JsonSchema.Parse(json)
public static JsonSchema Parse(
   System.string json
)
public function Parse(
    json: System.String
): JsonSchema; static;
public static function Parse(
   json : System.String
) : JsonSchema;
public: static JsonSchema* Parse(
   System.string* json
)
public:
static JsonSchema^ Parse(
   System.String^ json
)

Parameters

json
A System.String that contains JSON.

Return Value

A JsonSchema populated from the string that contains JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


Parse(String,JsonSchemaResolver) Method

Parse(String,JsonSchemaResolver) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > Parse Method : Parse(String,JsonSchemaResolver) Method
The json.
The resolver.
Parses the specified json.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Parse( _
   ByVal json As System.String, _
   ByVal resolver As JsonSchemaResolver _
) As JsonSchema
'Usage

Dim json As System.String
Dim resolver As JsonSchemaResolver
Dim value As JsonSchema

value = JsonSchema.Parse(json, resolver)
public static JsonSchema Parse(
   System.string json,
   JsonSchemaResolver resolver
)
public function Parse(
    json: System.String;
    resolver: JsonSchemaResolver
): JsonSchema; static;
public static function Parse(
   json : System.String,
   resolver : JsonSchemaResolver
) : JsonSchema;
public: static JsonSchema* Parse(
   System.string* json,
   JsonSchemaResolver* resolver
)
public:
static JsonSchema^ Parse(
   System.String^ json,
   JsonSchemaResolver^ resolver
)

Parameters

json
The json.
resolver
The resolver.

Return Value

A JsonSchema populated from the string that contains JSON.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


Read Method (JsonSchema)

Read Method (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Read Method
Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Overload List
Overload | Description
Read(JsonReader) | Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Read(JsonReader,JsonSchemaResolver) | Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Read(JsonReader) Method

Read(JsonReader) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > Read Method : Read(JsonReader) Method
The Noemax.Newtonsoft.Json.JsonReader containing the JSON Schema to read.
Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Read( _
   ByVal reader As JsonReader _
) As JsonSchema
'Usage

Dim reader As JsonReader
Dim value As JsonSchema

value = JsonSchema.Read(reader)
public static JsonSchema Read(
   JsonReader reader
)
public function Read(
    reader: JsonReader
): JsonSchema; static;
public static function Read(
   reader : JsonReader
) : JsonSchema;
public: static JsonSchema* Read(
   JsonReader* reader
)
public:
static JsonSchema^ Read(
   JsonReader^ reader
)

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader containing the JSON Schema to read.

Return Value

The JsonSchema object representing the JSON Schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


Read(JsonReader,JsonSchemaResolver) Method

Read(JsonReader,JsonSchemaResolver) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > Read Method : Read(JsonReader,JsonSchemaResolver) Method
The Noemax.Newtonsoft.Json.JsonReader containing the JSON Schema to read.
The JsonSchemaResolver to use when resolving schema references.
Reads a JsonSchema from the specified Noemax.Newtonsoft.Json.JsonReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Read( _
   ByVal reader As JsonReader, _
   ByVal resolver As JsonSchemaResolver _
) As JsonSchema
'Usage

Dim reader As JsonReader
Dim resolver As JsonSchemaResolver
Dim value As JsonSchema

value = JsonSchema.Read(reader, resolver)
public static JsonSchema Read(
   JsonReader reader,
   JsonSchemaResolver resolver
)
public function Read(
    reader: JsonReader;
    resolver: JsonSchemaResolver
): JsonSchema; static;
public static function Read(
   reader : JsonReader,
   resolver : JsonSchemaResolver
) : JsonSchema;
public: static JsonSchema* Read(
   JsonReader* reader,
   JsonSchemaResolver* resolver
)
public:
static JsonSchema^ Read(
   JsonReader^ reader,
   JsonSchemaResolver^ resolver
)

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader containing the JSON Schema to read.
resolver
The JsonSchemaResolver to use when resolving schema references.

Return Value

The JsonSchema object representing the JSON Schema.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


ToString Method (JsonSchema)

ToString Method (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public function ToString(): System.String; override;
public override function ToString() : System.String;
public: System.string* ToString(); override
public:
System.String^ ToString(); override

Return Value

A System.String that represents the current System.Object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Base Implementation in ToString


WriteTo Method (JsonSchema)

WriteTo Method (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : WriteTo Method
Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter.
Overload List
Overload | Description
WriteTo(JsonWriter) | Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter.
WriteTo(JsonWriter,JsonSchemaResolver) | Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter using the specified JsonSchemaResolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


WriteTo(JsonWriter) Method

WriteTo(JsonWriter) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > WriteTo Method : WriteTo(JsonWriter) Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteTo( _
   ByVal writer As JsonWriter _
)
'Usage

Dim instance As JsonSchema
Dim writer As JsonWriter

instance.WriteTo(writer)
public void WriteTo(
   JsonWriter writer
)
public procedure WriteTo(
    writer: JsonWriter
);
public function WriteTo(
   writer : JsonWriter
);
public: void WriteTo(
   JsonWriter* writer
)
public:
void WriteTo(
   JsonWriter^ writer
)

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


WriteTo(JsonWriter,JsonSchemaResolver) Method

WriteTo(JsonWriter,JsonSchemaResolver) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class > WriteTo Method : WriteTo(JsonWriter,JsonSchemaResolver) Method
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
The resolver used.
Writes this schema to a Noemax.Newtonsoft.Json.JsonWriter using the specified JsonSchemaResolver.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub WriteTo( _
   ByVal writer As JsonWriter, _
   ByVal resolver As JsonSchemaResolver _
)
'Usage

Dim instance As JsonSchema
Dim writer As JsonWriter
Dim resolver As JsonSchemaResolver

instance.WriteTo(writer, resolver)
public void WriteTo(
   JsonWriter writer,
   JsonSchemaResolver resolver
)
public procedure WriteTo(
    writer: JsonWriter;
    resolver: JsonSchemaResolver
);
public function WriteTo(
   writer : JsonWriter,
   resolver : JsonSchemaResolver
);
public: void WriteTo(
   JsonWriter* writer,
   JsonSchemaResolver* resolver
)
public:
void WriteTo(
   JsonWriter^ writer,
   JsonSchemaResolver^ resolver
)

Parameters

writer
A Noemax.Newtonsoft.Json.JsonWriter into which this method will write.
resolver
The resolver used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members
Overload List


JsonSchema Class Properties

JsonSchema Class Properties

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchema Class

For a list of all members of this type, see JsonSchema members.

Public Properties
 | Name | Description
Public Property | AdditionalItems | Gets or sets the JsonSchema of additional items.
Public Property | AdditionalProperties | Gets or sets the JsonSchema of additional properties.
Public Property | AllowAdditionalItems | Gets or sets a value indicating whether additional items are allowed.
Public Property | AllowAdditionalProperties | Gets or sets a value indicating whether additional properties are allowed.
Public Property | Default | Gets or sets the default value.
Public Property | Description | Gets or sets the description of the object.
Public Property | Disallow | Gets or sets disallowed types.
Public Property | DivisibleBy | Gets or sets a number that the value should be divisble by.
Public Property | Enum | Gets or sets the a collection of valid enum values allowed.
Public Property | ExclusiveMaximum | Gets or sets a flag indicating whether the value can not equal the number defined by the "maximum" attribute.
Public Property | ExclusiveMinimum | Gets or sets a flag indicating whether the value can not equal the number defined by the "minimum" attribute.
Public Property | Extends | Gets or sets the collection of JsonSchema that this schema extends.
Public Property | Format | Gets or sets the format.
Public Property | Hidden | Gets or sets whether the object is visible to users.
Public Property | Id | Gets or sets the id.
Public Property | Items | Gets or sets the JsonSchema of items.
Public Property | Maximum | Gets or sets the maximum.
Public Property | MaximumItems | Gets or sets the maximum number of items.
Public Property | MaximumLength | Gets or sets the maximum length.
Public Property | Minimum | Gets or sets the minimum.
Public Property | MinimumItems | Gets or sets the minimum number of items.
Public Property | MinimumLength | Gets or sets the minimum length.
Public Property | Pattern | Gets or sets the pattern.
Public Property | PatternProperties | Gets or sets the pattern properties.
Public Property | PositionalItemsValidation | Gets or sets a value indicating whether items in an array are validated using the JsonSchema instance at their array position from Items.
Public Property | Properties | Gets or sets the JsonSchema of properties.
Public Property | ReadOnly | Gets or sets whether the object is read only.
Public Property | Required | Gets or sets whether the object is required.
Public Property | Requires | Gets or sets the required property if this property is present.
Public Property | Title | Gets or sets the title.
Public Property | Transient | Gets or sets whether the object is transient.
Public Property | Type | Gets or sets the types of values allowed by the object.
Public Property | UniqueItems | Gets or sets whether the array items must be unique.
Top
See Also

Reference

JsonSchema Class
Noemax.Newtonsoft.Json.Schema Namespace


AdditionalItems Property (JsonSchema)

AdditionalItems Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : AdditionalItems Property
Gets or sets the JsonSchema of additional items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AdditionalItems As JsonSchema
'Usage

Dim instance As JsonSchema
Dim value As JsonSchema

instance.AdditionalItems = value

value = instance.AdditionalItems
public JsonSchema AdditionalItems {get; set;}
public read-write property AdditionalItems: JsonSchema;
public function get,set AdditionalItems : JsonSchema
public: __property JsonSchema* get_AdditionalItems();
public: __property void set_AdditionalItems(
   JsonSchema* value
);
public:
property JsonSchema^ AdditionalItems {
   JsonSchema^ get();
   void set (    JsonSchema^ value);
}

Property Value

The JsonSchema of additional items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


AdditionalProperties Property (JsonSchema)

AdditionalProperties Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : AdditionalProperties Property
Gets or sets the JsonSchema of additional properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AdditionalProperties As JsonSchema
'Usage

Dim instance As JsonSchema
Dim value As JsonSchema

instance.AdditionalProperties = value

value = instance.AdditionalProperties
public JsonSchema AdditionalProperties {get; set;}
public read-write property AdditionalProperties: JsonSchema;
public function get,set AdditionalProperties : JsonSchema
public: __property JsonSchema* get_AdditionalProperties();
public: __property void set_AdditionalProperties(
   JsonSchema* value
);
public:
property JsonSchema^ AdditionalProperties {
   JsonSchema^ get();
   void set (    JsonSchema^ value);
}

Property Value

The JsonSchema of additional properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


AllowAdditionalItems Property (JsonSchema)

AllowAdditionalItems Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : AllowAdditionalItems Property
Gets or sets a value indicating whether additional items are allowed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAdditionalItems As System.Boolean
'Usage

Dim instance As JsonSchema
Dim value As System.Boolean

instance.AllowAdditionalItems = value

value = instance.AllowAdditionalItems
public System.bool AllowAdditionalItems {get; set;}
public read-write property AllowAdditionalItems: System.Boolean;
public function get,set AllowAdditionalItems : System.boolean
public: __property System.bool get_AllowAdditionalItems();
public: __property void set_AllowAdditionalItems(
   System.bool value
);
public:
property System.bool AllowAdditionalItems {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if additional items are allowed; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


AllowAdditionalProperties Property (JsonSchema)

AllowAdditionalProperties Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : AllowAdditionalProperties Property
Gets or sets a value indicating whether additional properties are allowed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AllowAdditionalProperties As System.Boolean
'Usage

Dim instance As JsonSchema
Dim value As System.Boolean

instance.AllowAdditionalProperties = value

value = instance.AllowAdditionalProperties
public System.bool AllowAdditionalProperties {get; set;}
public read-write property AllowAdditionalProperties: System.Boolean;
public function get,set AllowAdditionalProperties : System.boolean
public: __property System.bool get_AllowAdditionalProperties();
public: __property void set_AllowAdditionalProperties(
   System.bool value
);
public:
property System.bool AllowAdditionalProperties {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if additional properties are allowed; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Default Property (JsonSchema)

Default Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Default Property
Gets or sets the default value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Default As JToken
'Usage

Dim instance As JsonSchema
Dim value As JToken

instance.Default = value

value = instance.Default
public JToken Default {get; set;}
public read-write property Default: JToken;
public function get,set Default : JToken
public: __property JToken* get_Default();
public: __property void set_Default(
   JToken* value
);
public:
property JToken^ Default {
   JToken^ get();
   void set (    JToken^ value);
}

Property Value

The default value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Description Property (JsonSchema)

Description Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Description Property
Gets or sets the description of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Description As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Description = value

value = instance.Description
public System.string Description {get; set;}
public read-write property Description: System.String;
public function get,set Description : System.String
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Disallow Property (JsonSchema)

Disallow Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Disallow Property
Gets or sets disallowed types.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Disallow As System.Nullable(Of JsonSchemaType)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of JsonSchemaType)

instance.Disallow = value

value = instance.Disallow
public System.Nullable<JsonSchemaType> Disallow {get; set;}
public read-write property Disallow: System.Nullable;
public function get,set Disallow : System.Nullable
public: __property System.Nullable<JsonSchemaType> get_Disallow();
public: __property void set_Disallow(
   System.Nullable<JsonSchemaType> value
);
public:
property System.Nullable<JsonSchemaType> Disallow {
   System.Nullable<JsonSchemaType> get();
   void set (    System.Nullable<JsonSchemaType> value);
}

Property Value

The disallow types.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


DivisibleBy Property (JsonSchema)

DivisibleBy Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : DivisibleBy Property
Gets or sets a number that the value should be divisble by.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DivisibleBy As System.Nullable(Of Double)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Double)

instance.DivisibleBy = value

value = instance.DivisibleBy
public System.Nullable<double> DivisibleBy {get; set;}
public read-write property DivisibleBy: System.Nullable;
public function get,set DivisibleBy : System.Nullable
public: __property System.Nullable<double> get_DivisibleBy();
public: __property void set_DivisibleBy(
   System.Nullable<double> value
);
public:
property System.Nullable<double> DivisibleBy {
   System.Nullable<double> get();
   void set (    System.Nullable<double> value);
}

Property Value

A number that the value should be divisble by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Enum Property (JsonSchema)

Enum Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Enum Property
Gets or sets the a collection of valid enum values allowed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Enum As System.Collections.Generic.IList(Of JToken)
'Usage

Dim instance As JsonSchema
Dim value As System.Collections.Generic.IList(Of JToken)

instance.Enum = value

value = instance.Enum
public System.Collections.Generic.IList<JToken> Enum {get; set;}
public read-write property Enum: System.Collections.Generic.IList;
public function get,set Enum : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<JToken*>* get_Enum();
public: __property void set_Enum(
   System.Collections.Generic.IList<JToken*>* value
);
public:
property System.Collections.Generic.IList<JToken^>^ Enum {
   System.Collections.Generic.IList<JToken^>^ get();
   void set (    System.Collections.Generic.IList<JToken^>^ value);
}

Property Value

A collection of valid enum values allowed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


ExclusiveMaximum Property (JsonSchema)

ExclusiveMaximum Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : ExclusiveMaximum Property
Gets or sets a flag indicating whether the value can not equal the number defined by the "maximum" attribute.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExclusiveMaximum As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.ExclusiveMaximum = value

value = instance.ExclusiveMaximum
public System.Nullable<bool> ExclusiveMaximum {get; set;}
public read-write property ExclusiveMaximum: System.Nullable;
public function get,set ExclusiveMaximum : System.Nullable
public: __property System.Nullable<bool> get_ExclusiveMaximum();
public: __property void set_ExclusiveMaximum(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> ExclusiveMaximum {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

A flag indicating whether the value can not equal the number defined by the "maximum" attribute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


ExclusiveMinimum Property (JsonSchema)

ExclusiveMinimum Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : ExclusiveMinimum Property
Gets or sets a flag indicating whether the value can not equal the number defined by the "minimum" attribute.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExclusiveMinimum As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.ExclusiveMinimum = value

value = instance.ExclusiveMinimum
public System.Nullable<bool> ExclusiveMinimum {get; set;}
public read-write property ExclusiveMinimum: System.Nullable;
public function get,set ExclusiveMinimum : System.Nullable
public: __property System.Nullable<bool> get_ExclusiveMinimum();
public: __property void set_ExclusiveMinimum(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> ExclusiveMinimum {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

A flag indicating whether the value can not equal the number defined by the "minimum" attribute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Extends Property (JsonSchema)

Extends Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Extends Property
Gets or sets the collection of JsonSchema that this schema extends.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extends As System.Collections.Generic.IList(Of JsonSchema)
'Usage

Dim instance As JsonSchema
Dim value As System.Collections.Generic.IList(Of JsonSchema)

instance.Extends = value

value = instance.Extends
public System.Collections.Generic.IList<JsonSchema> Extends {get; set;}
public read-write property Extends: System.Collections.Generic.IList;
public function get,set Extends : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<JsonSchema*>* get_Extends();
public: __property void set_Extends(
   System.Collections.Generic.IList<JsonSchema*>* value
);
public:
property System.Collections.Generic.IList<JsonSchema^>^ Extends {
   System.Collections.Generic.IList<JsonSchema^>^ get();
   void set (    System.Collections.Generic.IList<JsonSchema^>^ value);
}

Property Value

The collection of JsonSchema that this schema extends.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Format Property (JsonSchema)

Format Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Format Property
Gets or sets the format.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Format As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Format = value

value = instance.Format
public System.string Format {get; set;}
public read-write property Format: System.String;
public function get,set Format : System.String
public: __property System.string* get_Format();
public: __property void set_Format(
   System.string* value
);
public:
property System.String^ Format {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The format.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Hidden Property (JsonSchema)

Hidden Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Hidden Property
Gets or sets whether the object is visible to users.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Hidden As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.Hidden = value

value = instance.Hidden
public System.Nullable<bool> Hidden {get; set;}
public read-write property Hidden: System.Nullable;
public function get,set Hidden : System.Nullable
public: __property System.Nullable<bool> get_Hidden();
public: __property void set_Hidden(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> Hidden {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Id Property (JsonSchema)

Id Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Id Property
Gets or sets the id.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Id As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Id = value

value = instance.Id
public System.string Id {get; set;}
public read-write property Id: System.String;
public function get,set Id : System.String
public: __property System.string* get_Id();
public: __property void set_Id(
   System.string* value
);
public:
property System.String^ Id {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Items Property (JsonSchema)

Items Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Items Property
Gets or sets the JsonSchema of items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Items As System.Collections.Generic.IList(Of JsonSchema)
'Usage

Dim instance As JsonSchema
Dim value As System.Collections.Generic.IList(Of JsonSchema)

instance.Items = value

value = instance.Items
public System.Collections.Generic.IList<JsonSchema> Items {get; set;}
public read-write property Items: System.Collections.Generic.IList;
public function get,set Items : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<JsonSchema*>* get_Items();
public: __property void set_Items(
   System.Collections.Generic.IList<JsonSchema*>* value
);
public:
property System.Collections.Generic.IList<JsonSchema^>^ Items {
   System.Collections.Generic.IList<JsonSchema^>^ get();
   void set (    System.Collections.Generic.IList<JsonSchema^>^ value);
}

Property Value

The JsonSchema of items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Maximum Property (JsonSchema)

Maximum Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Maximum Property
Gets or sets the maximum.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Maximum As System.Nullable(Of Double)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Double)

instance.Maximum = value

value = instance.Maximum
public System.Nullable<double> Maximum {get; set;}
public read-write property Maximum: System.Nullable;
public function get,set Maximum : System.Nullable
public: __property System.Nullable<double> get_Maximum();
public: __property void set_Maximum(
   System.Nullable<double> value
);
public:
property System.Nullable<double> Maximum {
   System.Nullable<double> get();
   void set (    System.Nullable<double> value);
}

Property Value

The maximum.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


MaximumItems Property (JsonSchema)

MaximumItems Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : MaximumItems Property
Gets or sets the maximum number of items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumItems As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Integer)

instance.MaximumItems = value

value = instance.MaximumItems
public System.Nullable<int> MaximumItems {get; set;}
public read-write property MaximumItems: System.Nullable;
public function get,set MaximumItems : System.Nullable
public: __property System.Nullable<int> get_MaximumItems();
public: __property void set_MaximumItems(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MaximumItems {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}

Property Value

The maximum number of items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


MaximumLength Property (JsonSchema)

MaximumLength Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : MaximumLength Property
Gets or sets the maximum length.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaximumLength As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Integer)

instance.MaximumLength = value

value = instance.MaximumLength
public System.Nullable<int> MaximumLength {get; set;}
public read-write property MaximumLength: System.Nullable;
public function get,set MaximumLength : System.Nullable
public: __property System.Nullable<int> get_MaximumLength();
public: __property void set_MaximumLength(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MaximumLength {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}

Property Value

The maximum length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Minimum Property (JsonSchema)

Minimum Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Minimum Property
Gets or sets the minimum.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Minimum As System.Nullable(Of Double)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Double)

instance.Minimum = value

value = instance.Minimum
public System.Nullable<double> Minimum {get; set;}
public read-write property Minimum: System.Nullable;
public function get,set Minimum : System.Nullable
public: __property System.Nullable<double> get_Minimum();
public: __property void set_Minimum(
   System.Nullable<double> value
);
public:
property System.Nullable<double> Minimum {
   System.Nullable<double> get();
   void set (    System.Nullable<double> value);
}

Property Value

The minimum.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


MinimumItems Property (JsonSchema)

MinimumItems Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : MinimumItems Property
Gets or sets the minimum number of items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumItems As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Integer)

instance.MinimumItems = value

value = instance.MinimumItems
public System.Nullable<int> MinimumItems {get; set;}
public read-write property MinimumItems: System.Nullable;
public function get,set MinimumItems : System.Nullable
public: __property System.Nullable<int> get_MinimumItems();
public: __property void set_MinimumItems(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MinimumItems {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}

Property Value

The minimum number of items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


MinimumLength Property (JsonSchema)

MinimumLength Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : MinimumLength Property
Gets or sets the minimum length.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MinimumLength As System.Nullable(Of Integer)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Integer)

instance.MinimumLength = value

value = instance.MinimumLength
public System.Nullable<int> MinimumLength {get; set;}
public read-write property MinimumLength: System.Nullable;
public function get,set MinimumLength : System.Nullable
public: __property System.Nullable<int> get_MinimumLength();
public: __property void set_MinimumLength(
   System.Nullable<int> value
);
public:
property System.Nullable<int> MinimumLength {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}

Property Value

The minimum length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Pattern Property (JsonSchema)

Pattern Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Pattern Property
Gets or sets the pattern.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Pattern As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Pattern = value

value = instance.Pattern
public System.string Pattern {get; set;}
public read-write property Pattern: System.String;
public function get,set Pattern : System.String
public: __property System.string* get_Pattern();
public: __property void set_Pattern(
   System.string* value
);
public:
property System.String^ Pattern {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


PatternProperties Property (JsonSchema)

PatternProperties Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : PatternProperties Property
Gets or sets the pattern properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PatternProperties As System.Collections.Generic.IDictionary(Of String,JsonSchema)
'Usage

Dim instance As JsonSchema
Dim value As System.Collections.Generic.IDictionary(Of String,JsonSchema)

instance.PatternProperties = value

value = instance.PatternProperties
public System.Collections.Generic.IDictionary<string,JsonSchema> PatternProperties {get; set;}
public read-write property PatternProperties: System.Collections.Generic.IDictionary;
public function get,set PatternProperties : System.Collections.Generic.IDictionary
public: __property System.Collections.Generic.IDictionary<string*,JsonSchema*>* get_PatternProperties();
public: __property void set_PatternProperties(
   System.Collections.Generic.IDictionary<string*,JsonSchema*>* value
);
public:
property System.Collections.Generic.IDictionary<String^,JsonSchema^>^ PatternProperties {
   System.Collections.Generic.IDictionary<String^,JsonSchema^>^ get();
   void set (    System.Collections.Generic.IDictionary<String^,JsonSchema^>^ value);
}

Property Value

The pattern properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


PositionalItemsValidation Property (JsonSchema)

PositionalItemsValidation Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : PositionalItemsValidation Property
Gets or sets a value indicating whether items in an array are validated using the JsonSchema instance at their array position from Items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PositionalItemsValidation As System.Boolean
'Usage

Dim instance As JsonSchema
Dim value As System.Boolean

instance.PositionalItemsValidation = value

value = instance.PositionalItemsValidation
public System.bool PositionalItemsValidation {get; set;}
public read-write property PositionalItemsValidation: System.Boolean;
public function get,set PositionalItemsValidation : System.boolean
public: __property System.bool get_PositionalItemsValidation();
public: __property void set_PositionalItemsValidation(
   System.bool value
);
public:
property System.bool PositionalItemsValidation {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if items are validated using their array position; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Properties Property (JsonSchema)

Properties Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Properties Property
Gets or sets the JsonSchema of properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Properties As System.Collections.Generic.IDictionary(Of String,JsonSchema)
'Usage

Dim instance As JsonSchema
Dim value As System.Collections.Generic.IDictionary(Of String,JsonSchema)

instance.Properties = value

value = instance.Properties
public System.Collections.Generic.IDictionary<string,JsonSchema> Properties {get; set;}
public read-write property Properties: System.Collections.Generic.IDictionary;
public function get,set Properties : System.Collections.Generic.IDictionary
public: __property System.Collections.Generic.IDictionary<string*,JsonSchema*>* get_Properties();
public: __property void set_Properties(
   System.Collections.Generic.IDictionary<string*,JsonSchema*>* value
);
public:
property System.Collections.Generic.IDictionary<String^,JsonSchema^>^ Properties {
   System.Collections.Generic.IDictionary<String^,JsonSchema^>^ get();
   void set (    System.Collections.Generic.IDictionary<String^,JsonSchema^>^ value);
}

Property Value

The JsonSchema of properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


ReadOnly Property (JsonSchema)

ReadOnly Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : ReadOnly Property
Gets or sets whether the object is read only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReadOnly As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.ReadOnly = value

value = instance.ReadOnly
public System.Nullable<bool> ReadOnly {get; set;}
public read-write property ReadOnly: System.Nullable;
public function get,set ReadOnly : System.Nullable
public: __property System.Nullable<bool> get_ReadOnly();
public: __property void set_ReadOnly(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> ReadOnly {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Required Property (JsonSchema)

Required Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Required Property
Gets or sets whether the object is required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.Required = value

value = instance.Required
public System.Nullable<bool> Required {get; set;}
public read-write property Required: System.Nullable;
public function get,set Required : System.Nullable
public: __property System.Nullable<bool> get_Required();
public: __property void set_Required(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> Required {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Requires Property (JsonSchema)

Requires Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Requires Property
Gets or sets the required property if this property is present.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Requires As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Requires = value

value = instance.Requires
public System.string Requires {get; set;}
public read-write property Requires: System.String;
public function get,set Requires : System.String
public: __property System.string* get_Requires();
public: __property void set_Requires(
   System.string* value
);
public:
property System.String^ Requires {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The required property if this property is present.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Title Property (JsonSchema)

Title Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Title Property
Gets or sets the title.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Title As System.String
'Usage

Dim instance As JsonSchema
Dim value As System.String

instance.Title = value

value = instance.Title
public System.string Title {get; set;}
public read-write property Title: System.String;
public function get,set Title : System.String
public: __property System.string* get_Title();
public: __property void set_Title(
   System.string* value
);
public:
property System.String^ Title {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Transient Property (JsonSchema)

Transient Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Transient Property
Gets or sets whether the object is transient.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Transient As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of Boolean)

instance.Transient = value

value = instance.Transient
public System.Nullable<bool> Transient {get; set;}
public read-write property Transient: System.Nullable;
public function get,set Transient : System.Nullable
public: __property System.Nullable<bool> get_Transient();
public: __property void set_Transient(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> Transient {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


Type Property (JsonSchema)

Type Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : Type Property
Gets or sets the types of values allowed by the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As System.Nullable(Of JsonSchemaType)
'Usage

Dim instance As JsonSchema
Dim value As System.Nullable(Of JsonSchemaType)

instance.Type = value

value = instance.Type
public System.Nullable<JsonSchemaType> Type {get; set;}
public read-write property Type: System.Nullable;
public function get,set Type : System.Nullable
public: __property System.Nullable<JsonSchemaType> get_Type();
public: __property void set_Type(
   System.Nullable<JsonSchemaType> value
);
public:
property System.Nullable<JsonSchemaType> Type {
   System.Nullable<JsonSchemaType> get();
   void set (    System.Nullable<JsonSchemaType> value);
}

Property Value

The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


UniqueItems Property (JsonSchema)

UniqueItems Property (JsonSchema)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchema Class : UniqueItems Property
Gets or sets whether the array items must be unique.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UniqueItems As System.Boolean
'Usage

Dim instance As JsonSchema
Dim value As System.Boolean

instance.UniqueItems = value

value = instance.UniqueItems
public System.bool UniqueItems {get; set;}
public read-write property UniqueItems: System.Boolean;
public function get,set UniqueItems : System.boolean
public: __property System.bool get_UniqueItems();
public: __property void set_UniqueItems(
   System.bool value
);
public:
property System.bool UniqueItems {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchema Class
JsonSchema Members


JsonSchemaException Class

JsonSchemaException Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaException Class
Returns detailed information about the schema exception.
Object Model
JsonSchemaException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.SerializableAttribute()>
Public Class JsonSchemaException
   Inherits Noemax.Newtonsoft.Json.JsonException
'Usage

Dim instance As JsonSchemaException
[System.Serializable()]
public class JsonSchemaException : Noemax.Newtonsoft.Json.JsonException
public class JsonSchemaException = class(Noemax.Newtonsoft.Json.JsonException)
System.SerializableAttribute()
public class JsonSchemaException extends Noemax.Newtonsoft.Json.JsonException
[System.Serializable()]
public __gc class JsonSchemaException : public Noemax.Newtonsoft.Json.JsonException
[System.Serializable()]
public ref class JsonSchemaException : public Noemax.Newtonsoft.Json.JsonException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Members
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaException Class Members

JsonSchemaException Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaException Class

The following tables list the members exposed by JsonSchemaException.

Public Constructors
 | Name | Description
Public Constructor | JsonSchemaException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | LineNumber | Gets the line number indicating where the error occurred.
Public Property | LinePosition | Gets the line position indicating where the error occurred.
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonSchemaException Class
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaException Constructor

JsonSchemaException Constructor

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : JsonSchemaException Constructor
Overload List
Overload | Description
JsonSchemaException Constructor() | Initializes a new instance of the JsonSchemaException class.
JsonSchemaException Constructor(String) | Initializes a new instance of the JsonSchemaException class with a specified error message.
JsonSchemaException Constructor(String,Exception) | Initializes a new instance of the JsonSchemaException class with a specified error message and a reference to the inner exception that is the cause of this exception.
JsonSchemaException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the JsonSchemaException class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


JsonSchemaException Constructor()

JsonSchemaException Constructor()

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class > JsonSchemaException Constructor : JsonSchemaException Constructor()
Initializes a new instance of the JsonSchemaException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSchemaException()
public JsonSchemaException()
public JsonSchemaException();
public function JsonSchemaException();
public: JsonSchemaException();
public:
JsonSchemaException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members
Overload List


JsonSchemaException Constructor(String)

JsonSchemaException Constructor(String)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class > JsonSchemaException Constructor : JsonSchemaException Constructor(String)
The error message that explains the reason for the exception.
Initializes a new instance of the JsonSchemaException class with a specified error message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New JsonSchemaException(message)
public JsonSchemaException(
   System.string message
)
public JsonSchemaException(
    message: System.String
);
public function JsonSchemaException(
   message : System.String
);
public: JsonSchemaException(
   System.string* message
)
public:
JsonSchemaException(
   System.String^ message
)

Parameters

message
The error message that explains the reason for the exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members
Overload List


JsonSchemaException Constructor(String,Exception)

JsonSchemaException Constructor(String,Exception)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class > JsonSchemaException Constructor : JsonSchemaException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Initializes a new instance of the JsonSchemaException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
'Usage

Dim message As System.String
Dim innerException As System.Exception

Dim instance As New JsonSchemaException(message, innerException)
public JsonSchemaException(
   System.string message,
   System.Exception innerException
)
public JsonSchemaException(
    message: System.String;
    innerException: System.Exception
);
public function JsonSchemaException(
   message : System.String,
   innerException : System.Exception
);
public: JsonSchemaException(
   System.string* message,
   System.Exception* innerException
)
public:
JsonSchemaException(
   System.String^ message,
   System.Exception^ innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members
Overload List


JsonSchemaException Constructor(SerializationInfo,StreamingContext)

JsonSchemaException Constructor(SerializationInfo,StreamingContext)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class > JsonSchemaException Constructor : JsonSchemaException Constructor(SerializationInfo,StreamingContext)
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Initializes a new instance of the JsonSchemaException class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New JsonSchemaException(info, context)
public JsonSchemaException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public JsonSchemaException(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
public function JsonSchemaException(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
public: JsonSchemaException(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
public:
JsonSchemaException(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The System.Runtime.Serialization.SerializationInfo that holds the serialized object data about the exception being thrown.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Exceptions
Exception | Description
System.ArgumentNullException | The info parameter is null.
System.Runtime.Serialization.SerializationException | The class name is null or System.Exception.HResult is zero (0).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members
Overload List


JsonSchemaException Class Properties

JsonSchemaException Class Properties

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaException Class

For a list of all members of this type, see JsonSchemaException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | LineNumber | Gets the line number indicating where the error occurred.
Public Property | LinePosition | Gets the line position indicating where the error occurred.
Public Property | Message | (Inherited from System.Exception)
Public Property | Path | Gets the path to the JSON where the error occurred.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

JsonSchemaException Class
Noemax.Newtonsoft.Json.Schema Namespace


LineNumber Property (JsonSchemaException)

LineNumber Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : LineNumber Property
Gets the line number indicating where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LineNumber As System.Integer
'Usage

Dim instance As JsonSchemaException
Dim value As System.Integer

value = instance.LineNumber
public System.int LineNumber {get;}
public read-only property LineNumber: System.Integer;
public function get LineNumber : System.int
public: __property System.int get_LineNumber();
public:
property System.int LineNumber {
   System.int get();
}

Property Value

The line number indicating where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


LinePosition Property (JsonSchemaException)

LinePosition Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : LinePosition Property
Gets the line position indicating where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LinePosition As System.Integer
'Usage

Dim instance As JsonSchemaException
Dim value As System.Integer

value = instance.LinePosition
public System.int LinePosition {get;}
public read-only property LinePosition: System.Integer;
public function get LinePosition : System.int
public: __property System.int get_LinePosition();
public:
property System.int LinePosition {
   System.int get();
}

Property Value

The line position indicating where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


Path Property (JsonSchemaException)

Path Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : Path Property
Gets the path to the JSON where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}

Property Value

The path to the JSON where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


JsonSchemaGenerator Class

JsonSchemaGenerator Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaGenerator Class
Generates a JsonSchema from a specified System.Type.
Object Model
JsonSchemaGenerator Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonSchemaGenerator
'Usage

Dim instance As JsonSchemaGenerator
public class JsonSchemaGenerator
public class JsonSchemaGenerator
public class JsonSchemaGenerator
public __gc class JsonSchemaGenerator
public ref class JsonSchemaGenerator
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Schema.JsonSchemaGenerator

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Members
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaGenerator Class Members

JsonSchemaGenerator Class Members
Properties Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaGenerator Class

The following tables list the members exposed by JsonSchemaGenerator.

Public Constructors
 | Name | Description
Public Constructor | JsonSchemaGenerator Constructor |
Top
Public Properties
 | Name | Description
Public Property | ContractResolver | Gets or sets the contract resolver.
Public Property | UndefinedSchemaIdHandling | Gets or sets how undefined schemas are handled by the serializer.
Top
Public Methods
 | Name | Description
Public Method | Generate | Overloaded. Generate a JsonSchema from the specified type.
Top
See Also

Reference

JsonSchemaGenerator Class
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaGenerator Constructor

JsonSchemaGenerator Constructor

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class : JsonSchemaGenerator Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSchemaGenerator()
public JsonSchemaGenerator()
public JsonSchemaGenerator();
public function JsonSchemaGenerator();
public: JsonSchemaGenerator();
public:
JsonSchemaGenerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members


JsonSchemaGenerator Class Methods

JsonSchemaGenerator Class Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaGenerator Class

For a list of all members of this type, see JsonSchemaGenerator members.

Public Methods
 | Name | Description
Public Method | Generate | Overloaded. Generate a JsonSchema from the specified type.
Top
See Also

Reference

JsonSchemaGenerator Class
Noemax.Newtonsoft.Json.Schema Namespace


Generate Method (JsonSchemaGenerator)

Generate Method (JsonSchemaGenerator)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class : Generate Method
Generate a JsonSchema from the specified type.
Overload List
Overload | Description
Generate(Type) | Generate a JsonSchema from the specified type.
Generate(Type,JsonSchemaResolver) | Generate a JsonSchema from the specified type.
Generate(Type,Boolean) | Generate a JsonSchema from the specified type.
Generate(Type,JsonSchemaResolver,Boolean) | Generate a JsonSchema from the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members


Generate(Type) Method

Generate(Type) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class > Generate Method : Generate(Type) Method
The type to generate a JsonSchema from.
Generate a JsonSchema from the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Generate( _
   ByVal type As System.Type _
) As JsonSchema
'Usage

Dim instance As JsonSchemaGenerator
Dim type As System.Type
Dim value As JsonSchema

value = instance.Generate(type)
public JsonSchema Generate(
   System.Type type
)
public function Generate(
    type: System.Type
): JsonSchema;
public function Generate(
   type : System.Type
) : JsonSchema;
public: JsonSchema* Generate(
   System.Type* type
)
public:
JsonSchema^ Generate(
   System.Type^ type
)

Parameters

type
The type to generate a JsonSchema from.

Return Value

A JsonSchema generated from the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members
Overload List


Generate(Type,JsonSchemaResolver) Method

Generate(Type,JsonSchemaResolver) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class > Generate Method : Generate(Type,JsonSchemaResolver) Method
The type to generate a JsonSchema from.
The JsonSchemaResolver used to resolve schema references.
Generate a JsonSchema from the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Generate( _
   ByVal type As System.Type, _
   ByVal resolver As JsonSchemaResolver _
) As JsonSchema
'Usage

Dim instance As JsonSchemaGenerator
Dim type As System.Type
Dim resolver As JsonSchemaResolver
Dim value As JsonSchema

value = instance.Generate(type, resolver)
public JsonSchema Generate(
   System.Type type,
   JsonSchemaResolver resolver
)
public function Generate(
    type: System.Type;
    resolver: JsonSchemaResolver
): JsonSchema;
public function Generate(
   type : System.Type,
   resolver : JsonSchemaResolver
) : JsonSchema;
public: JsonSchema* Generate(
   System.Type* type,
   JsonSchemaResolver* resolver
)
public:
JsonSchema^ Generate(
   System.Type^ type,
   JsonSchemaResolver^ resolver
)

Parameters

type
The type to generate a JsonSchema from.
resolver
The JsonSchemaResolver used to resolve schema references.

Return Value

A JsonSchema generated from the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members
Overload List


Generate(Type,Boolean) Method

Generate(Type,Boolean) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class > Generate Method : Generate(Type,Boolean) Method
The type to generate a JsonSchema from.
Specify whether the generated root JsonSchema will be nullable.
Generate a JsonSchema from the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Generate( _
   ByVal type As System.Type, _
   ByVal rootSchemaNullable As System.Boolean _
) As JsonSchema
'Usage

Dim instance As JsonSchemaGenerator
Dim type As System.Type
Dim rootSchemaNullable As System.Boolean
Dim value As JsonSchema

value = instance.Generate(type, rootSchemaNullable)
public JsonSchema Generate(
   System.Type type,
   System.bool rootSchemaNullable
)
public function Generate(
    type: System.Type;
    rootSchemaNullable: System.Boolean
): JsonSchema;
public function Generate(
   type : System.Type,
   rootSchemaNullable : System.boolean
) : JsonSchema;
public: JsonSchema* Generate(
   System.Type* type,
   System.bool rootSchemaNullable
)
public:
JsonSchema^ Generate(
   System.Type^ type,
   System.bool rootSchemaNullable
)

Parameters

type
The type to generate a JsonSchema from.
rootSchemaNullable
Specify whether the generated root JsonSchema will be nullable.

Return Value

A JsonSchema generated from the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members
Overload List


Generate(Type,JsonSchemaResolver,Boolean) Method

Generate(Type,JsonSchemaResolver,Boolean) Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class > Generate Method : Generate(Type,JsonSchemaResolver,Boolean) Method
The type to generate a JsonSchema from.
The JsonSchemaResolver used to resolve schema references.
Specify whether the generated root JsonSchema will be nullable.
Generate a JsonSchema from the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Generate( _
   ByVal type As System.Type, _
   ByVal resolver As JsonSchemaResolver, _
   ByVal rootSchemaNullable As System.Boolean _
) As JsonSchema
'Usage

Dim instance As JsonSchemaGenerator
Dim type As System.Type
Dim resolver As JsonSchemaResolver
Dim rootSchemaNullable As System.Boolean
Dim value As JsonSchema

value = instance.Generate(type, resolver, rootSchemaNullable)
public JsonSchema Generate(
   System.Type type,
   JsonSchemaResolver resolver,
   System.bool rootSchemaNullable
)
public function Generate(
    type: System.Type;
    resolver: JsonSchemaResolver;
    rootSchemaNullable: System.Boolean
): JsonSchema;
public function Generate(
   type : System.Type,
   resolver : JsonSchemaResolver,
   rootSchemaNullable : System.boolean
) : JsonSchema;
public: JsonSchema* Generate(
   System.Type* type,
   JsonSchemaResolver* resolver,
   System.bool rootSchemaNullable
)
public:
JsonSchema^ Generate(
   System.Type^ type,
   JsonSchemaResolver^ resolver,
   System.bool rootSchemaNullable
)

Parameters

type
The type to generate a JsonSchema from.
resolver
The JsonSchemaResolver used to resolve schema references.
rootSchemaNullable
Specify whether the generated root JsonSchema will be nullable.

Return Value

A JsonSchema generated from the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members
Overload List


JsonSchemaGenerator Class Properties

JsonSchemaGenerator Class Properties

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaGenerator Class

For a list of all members of this type, see JsonSchemaGenerator members.

Public Properties
 | Name | Description
Public Property | ContractResolver | Gets or sets the contract resolver.
Public Property | UndefinedSchemaIdHandling | Gets or sets how undefined schemas are handled by the serializer.
Top
See Also

Reference

JsonSchemaGenerator Class
Noemax.Newtonsoft.Json.Schema Namespace


ContractResolver Property (JsonSchemaGenerator)

ContractResolver Property (JsonSchemaGenerator)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class : ContractResolver Property
Gets or sets the contract resolver.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ContractResolver As IContractResolver
'Usage

Dim instance As JsonSchemaGenerator
Dim value As IContractResolver

instance.ContractResolver = value

value = instance.ContractResolver
public IContractResolver ContractResolver {get; set;}
public read-write property ContractResolver: IContractResolver;
public function get,set ContractResolver : IContractResolver
public: __property IContractResolver* get_ContractResolver();
public: __property void set_ContractResolver(
   IContractResolver* value
);
public:
property IContractResolver^ ContractResolver {
   IContractResolver^ get();
   void set (    IContractResolver^ value);
}

Property Value

The contract resolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members


UndefinedSchemaIdHandling Property (JsonSchemaGenerator)

UndefinedSchemaIdHandling Property (JsonSchemaGenerator)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaGenerator Class : UndefinedSchemaIdHandling Property
Gets or sets how undefined schemas are handled by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UndefinedSchemaIdHandling As UndefinedSchemaIdHandling
'Usage

Dim instance As JsonSchemaGenerator
Dim value As UndefinedSchemaIdHandling

instance.UndefinedSchemaIdHandling = value

value = instance.UndefinedSchemaIdHandling
public UndefinedSchemaIdHandling UndefinedSchemaIdHandling {get; set;}
public read-write property UndefinedSchemaIdHandling: UndefinedSchemaIdHandling;
public function get,set UndefinedSchemaIdHandling : UndefinedSchemaIdHandling
public: __property UndefinedSchemaIdHandling get_UndefinedSchemaIdHandling();
public: __property void set_UndefinedSchemaIdHandling(
   UndefinedSchemaIdHandling value
);
public:
property UndefinedSchemaIdHandling UndefinedSchemaIdHandling {
   UndefinedSchemaIdHandling get();
   void set (    UndefinedSchemaIdHandling value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaGenerator Class
JsonSchemaGenerator Members


JsonSchemaResolver Class

JsonSchemaResolver Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaResolver Class
Resolves JsonSchema from an id.
Object Model
JsonSchemaResolver Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonSchemaResolver
'Usage

Dim instance As JsonSchemaResolver
public class JsonSchemaResolver
public class JsonSchemaResolver
public class JsonSchemaResolver
public __gc class JsonSchemaResolver
public ref class JsonSchemaResolver
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Schema.JsonSchemaResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaResolver Members
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaResolver Class Members

JsonSchemaResolver Class Members
Properties Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaResolver Class

The following tables list the members exposed by JsonSchemaResolver.

Public Constructors
 | Name | Description
Public Constructor | JsonSchemaResolver Constructor | Initializes a new instance of the JsonSchemaResolver class.
Top
Public Properties
 | Name | Description
Public Property | LoadedSchemas | Gets or sets the loaded schemas.
Top
Public Methods
 | Name | Description
Public Method | GetSchema | Gets a JsonSchema for the specified reference.
Top
See Also

Reference

JsonSchemaResolver Class
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaResolver Constructor

JsonSchemaResolver Constructor

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaResolver Class : JsonSchemaResolver Constructor
Initializes a new instance of the JsonSchemaResolver class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonSchemaResolver()
public JsonSchemaResolver()
public JsonSchemaResolver();
public function JsonSchemaResolver();
public: JsonSchemaResolver();
public:
JsonSchemaResolver();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaResolver Class
JsonSchemaResolver Members


JsonSchemaResolver Class Methods

JsonSchemaResolver Class Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaResolver Class

For a list of all members of this type, see JsonSchemaResolver members.

Public Methods
 | Name | Description
Public Method | GetSchema | Gets a JsonSchema for the specified reference.
Top
See Also

Reference

JsonSchemaResolver Class
Noemax.Newtonsoft.Json.Schema Namespace


GetSchema Method (JsonSchemaResolver)

GetSchema Method (JsonSchemaResolver)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaResolver Class : GetSchema Method
The id.
Gets a JsonSchema for the specified reference.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetSchema( _
   ByVal reference As System.String _
) As JsonSchema
'Usage

Dim instance As JsonSchemaResolver
Dim reference As System.String
Dim value As JsonSchema

value = instance.GetSchema(reference)
public virtual JsonSchema GetSchema(
   System.string reference
)
public function GetSchema(
    reference: System.String
): JsonSchema; virtual;
public function GetSchema(
   reference : System.String
) : JsonSchema;
public: virtual JsonSchema* GetSchema(
   System.string* reference
)
public:
virtual JsonSchema^ GetSchema(
   System.String^ reference
)

Parameters

reference
The id.

Return Value

A JsonSchema for the specified reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaResolver Class
JsonSchemaResolver Members


JsonSchemaResolver Class Properties

JsonSchemaResolver Class Properties

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaResolver Class

For a list of all members of this type, see JsonSchemaResolver members.

Public Properties
 | Name | Description
Public Property | LoadedSchemas | Gets or sets the loaded schemas.
Top
See Also

Reference

JsonSchemaResolver Class
Noemax.Newtonsoft.Json.Schema Namespace


LoadedSchemas Property (JsonSchemaResolver)

LoadedSchemas Property (JsonSchemaResolver)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaResolver Class : LoadedSchemas Property
Gets or sets the loaded schemas.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property LoadedSchemas As System.Collections.Generic.IList(Of JsonSchema)
'Usage

Dim instance As JsonSchemaResolver
Dim value As System.Collections.Generic.IList(Of JsonSchema)

value = instance.LoadedSchemas
public System.Collections.Generic.IList<JsonSchema> LoadedSchemas {get;}
public read-only property LoadedSchemas: System.Collections.Generic.IList;
public function get LoadedSchemas : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<JsonSchema*>* get_LoadedSchemas();
public:
property System.Collections.Generic.IList<JsonSchema^>^ LoadedSchemas {
   System.Collections.Generic.IList<JsonSchema^>^ get();
}

Property Value

The loaded schemas.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaResolver Class
JsonSchemaResolver Members


ValidationEventArgs Class

ValidationEventArgs Class
Members

Noemax.Newtonsoft.Json.Schema Namespace : ValidationEventArgs Class
Returns detailed information related to the ValidationEventHandler.
Object Model
ValidationEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ValidationEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ValidationEventArgs
public class ValidationEventArgs : System.EventArgs
public class ValidationEventArgs = class(System.EventArgs)
public class ValidationEventArgs extends System.EventArgs
public __gc class ValidationEventArgs : public System.EventArgs
public ref class ValidationEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.Newtonsoft.Json.Schema.ValidationEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEventArgs Members
Noemax.Newtonsoft.Json.Schema Namespace


ValidationEventArgs Class Members

ValidationEventArgs Class Members
Properties

Noemax.Newtonsoft.Json.Schema Namespace : ValidationEventArgs Class

The following tables list the members exposed by ValidationEventArgs.

Public Properties
 | Name | Description
Public Property | Exception | Gets the JsonSchemaException associated with the validation error.
Public Property | Message | Gets the text description corresponding to the validation error.
Public Property | Path | Gets the path of the JSON location where the validation error occurred.
Top
See Also

Reference

ValidationEventArgs Class
Noemax.Newtonsoft.Json.Schema Namespace


ValidationEventArgs Class Properties

ValidationEventArgs Class Properties

Noemax.Newtonsoft.Json.Schema Namespace : ValidationEventArgs Class

For a list of all members of this type, see ValidationEventArgs members.

Public Properties
 | Name | Description
Public Property | Exception | Gets the JsonSchemaException associated with the validation error.
Public Property | Message | Gets the text description corresponding to the validation error.
Public Property | Path | Gets the path of the JSON location where the validation error occurred.
Top
See Also

Reference

ValidationEventArgs Class
Noemax.Newtonsoft.Json.Schema Namespace


Exception Property (ValidationEventArgs)

Exception Property (ValidationEventArgs)

Noemax.Newtonsoft.Json.Schema Namespace > ValidationEventArgs Class : Exception Property
Gets the JsonSchemaException associated with the validation error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Exception As JsonSchemaException
'Usage

Dim instance As ValidationEventArgs
Dim value As JsonSchemaException

value = instance.Exception
public JsonSchemaException Exception {get;}
public read-only property Exception: JsonSchemaException;
public function get Exception : JsonSchemaException
public: __property JsonSchemaException* get_Exception();
public:
property JsonSchemaException^ Exception {
   JsonSchemaException^ get();
}

Property Value

The JsonSchemaException associated with the validation error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEventArgs Class
ValidationEventArgs Members


Message Property (ValidationEventArgs)

Message Property (ValidationEventArgs)

Noemax.Newtonsoft.Json.Schema Namespace > ValidationEventArgs Class : Message Property
Gets the text description corresponding to the validation error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Message As System.String
'Usage

Dim instance As ValidationEventArgs
Dim value As System.String

value = instance.Message
public System.string Message {get;}
public read-only property Message: System.String;
public function get Message : System.String
public: __property System.string* get_Message();
public:
property System.String^ Message {
   System.String^ get();
}

Property Value

The text description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEventArgs Class
ValidationEventArgs Members


Path Property (ValidationEventArgs)

Path Property (ValidationEventArgs)

Noemax.Newtonsoft.Json.Schema Namespace > ValidationEventArgs Class : Path Property
Gets the path of the JSON location where the validation error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As ValidationEventArgs
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}

Property Value

The path of the JSON location where the validation error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEventArgs Class
ValidationEventArgs Members


JsonSchemaType Enumeration

JsonSchemaType Enumeration

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaType Enumeration
The value types allowed by the JsonSchema.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.FlagsAttribute()>
Public Enum JsonSchemaType
   Inherits System.Enum
'Usage

Dim instance As JsonSchemaType
[System.Flags()]
public enum JsonSchemaType : System.Enum
public enum JsonSchemaType = class(System.Enum)
System.FlagsAttribute()
public enum JsonSchemaType extends System.Enum
[System.Flags()]
__value public enum JsonSchemaType : public System.Enum
[System.Flags()]
public enum class JsonSchemaType : public System.Enum
Members
Member | Description
Any | Any type.
Array | Array type.
Boolean | Boolean type.
Float | Float type.
Integer | Integer type.
None | No type specified.
Null | Null type.
Object | Object type.
String | String type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.Schema.JsonSchemaType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json.Schema Namespace


UndefinedSchemaIdHandling Enumeration

UndefinedSchemaIdHandling Enumeration

Noemax.Newtonsoft.Json.Schema Namespace : UndefinedSchemaIdHandling Enumeration
Specifies undefined schema Id handling options for the JsonSchemaGenerator.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum UndefinedSchemaIdHandling
   Inherits System.Enum
'Usage

Dim instance As UndefinedSchemaIdHandling
public enum UndefinedSchemaIdHandling : System.Enum
public enum UndefinedSchemaIdHandling = class(System.Enum)
public enum UndefinedSchemaIdHandling extends System.Enum
__value public enum UndefinedSchemaIdHandling : public System.Enum
public enum class UndefinedSchemaIdHandling : public System.Enum
Members
Member | Description
None | Do not infer a schema Id.
UseAssemblyQualifiedName | Use the assembly qualified .NET type name as the schema Id.
UseTypeName | Use the .NET type name as the schema Id.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.Newtonsoft.Json.Schema.UndefinedSchemaIdHandling

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.Newtonsoft.Json.Schema Namespace


ValidationEventHandler Delegate

ValidationEventHandler Delegate

Noemax.Newtonsoft.Json.Schema Namespace : ValidationEventHandler Delegate
Represents the callback method that will handle JSON schema validation events and the ValidationEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ValidationEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ValidationEventArgs _
)
'Usage

Dim instance As New ValidationEventHandler(AddressOf HandlerMethod)
public delegate void ValidationEventHandler(
   System.object sender,
   ValidationEventArgs e
)
public delegate ValidationEventHandler(
    sender: System.TObject;
    e: ValidationEventArgs
);
public delegate ValidationEventHandler(
   sender : System.Object,
   e : ValidationEventArgs
)
public: __gc __delegate void ValidationEventHandler(
   System.Object* sender,
   ValidationEventArgs* e
)
public delegate void ValidationEventHandler(
   System.Object^ sender,
   ValidationEventArgs^ e
)

Parameters

sender
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidationEventHandler Members
Noemax.Newtonsoft.Json.Schema Namespace


Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | CamelCasePropertyNamesContractResolver | Resolves member mappings for a type, camel casing property names.
Class | DefaultContractResolver | Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Class | DefaultSerializationBinder | The default serialization binder used when resolving and loading classes from type names.
Class | DiagnosticsTraceWriter | Represents a trace writer that writes to the application's System.Diagnostics.TraceListener instances.
Class | DynamicValueProvider | Get and set values for a System.Reflection.MemberInfo using dynamic methods.
Class | ErrorContext | Provides information surrounding an error.
Class | ErrorEventArgs | Provides data for the Error event.
Class | FlexibleSerializationBinder | Alternative serialization binder used for resolving the classes from type name and assemly name.
Class | JsonArrayContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonContainerContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonDictionaryContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonISerializableContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonLinqContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonObjectContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonPrimitiveContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonProperty | Maps a JSON property to a .NET member or constructor parameter.
Class | JsonPropertyCollection | A collection of JsonProperty objects.
Class | JsonStringContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | MemoryTraceWriter | Represents a trace writer that writes to memory. When the trace message limit is reached then old trace messages will be removed as new messages are added.
Class | OnErrorAttribute | When applied to a method, specifies that the method is called when an error occurs serializing an object.
Class | ReflectionValueProvider | Get and set values for a System.Reflection.MemberInfo using reflection.
Interfaces
 | Interface | Description
Interface | IContractResolver | Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Interface | IReferenceResolver | Used to resolve references when serializing and deserializing JSON by the Noemax.Newtonsoft.Json.JsonSerializer.
Interface | ITraceWriter | Represents a trace writer.
Interface | IValueProvider | Provides methods to get and set values.
Delegates
 | Delegate | Description
Delegate | ExtensionDataGetter | Gets extension data for an object during serialization.
Delegate | ExtensionDataSetter | Sets extension data for an object during deserialization.
Delegate | ObjectConstructor<T> | Represents a method that constructs an object.
Delegate | SerializationCallback | Handles Noemax.Newtonsoft.Json.JsonSerializer serialization callback events.
Delegate | SerializationErrorCallback | Handles Noemax.Newtonsoft.Json.JsonSerializer serialization error callback events.
See Also

Reference

Noemax.WebSockets Assembly


CamelCasePropertyNamesContractResolver Class

CamelCasePropertyNamesContractResolver Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class
Resolves member mappings for a type, camel casing property names.
Object Model
CamelCasePropertyNamesContractResolver Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CamelCasePropertyNamesContractResolver
   Inherits DefaultContractResolver
   Implements IContractResolver
'Usage

Dim instance As CamelCasePropertyNamesContractResolver
public class CamelCasePropertyNamesContractResolver : DefaultContractResolver, IContractResolver
public class CamelCasePropertyNamesContractResolver = class(DefaultContractResolver, IContractResolver)
public class CamelCasePropertyNamesContractResolver extends DefaultContractResolver implements IContractResolver
public __gc class CamelCasePropertyNamesContractResolver : public DefaultContractResolver, IContractResolver
public ref class CamelCasePropertyNamesContractResolver : public DefaultContractResolver, IContractResolver
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver
Noemax.Newtonsoft.Json.Serialization.CamelCasePropertyNamesContractResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CamelCasePropertyNamesContractResolver Members
Noemax.Newtonsoft.Json.Serialization Namespace


CamelCasePropertyNamesContractResolver Class Members

CamelCasePropertyNamesContractResolver Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class

The following tables list the members exposed by CamelCasePropertyNamesContractResolver.

Public Constructors
 | Name | Description
Public Constructor | CamelCasePropertyNamesContractResolver Constructor | Initializes a new instance of the CamelCasePropertyNamesContractResolver class.
Top
Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Method | ResolveContract | Resolves the contract for a given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateConstructorParameters | Creates the constructor parameters. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateContract | Determines which contract type is created for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperties | Creates properties for the given JsonContract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | GetSerializableMembers | Gets the serializable members for the type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
See Also

Reference

CamelCasePropertyNamesContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


CamelCasePropertyNamesContractResolver Constructor

CamelCasePropertyNamesContractResolver Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > CamelCasePropertyNamesContractResolver Class : CamelCasePropertyNamesContractResolver Constructor
Initializes a new instance of the CamelCasePropertyNamesContractResolver class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CamelCasePropertyNamesContractResolver()
public CamelCasePropertyNamesContractResolver()
public CamelCasePropertyNamesContractResolver();
public function CamelCasePropertyNamesContractResolver();
public: CamelCasePropertyNamesContractResolver();
public:
CamelCasePropertyNamesContractResolver();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CamelCasePropertyNamesContractResolver Class
CamelCasePropertyNamesContractResolver Members


DefaultContractResolver Class

DefaultContractResolver Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class
Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Object Model
DefaultContractResolver Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DefaultContractResolver
   Implements IContractResolver
'Usage

Dim instance As DefaultContractResolver
public class DefaultContractResolver : IContractResolver
public class DefaultContractResolver = class(IContractResolver)
public class DefaultContractResolver implements IContractResolver
public __gc class DefaultContractResolver : public IContractResolver
public ref class DefaultContractResolver : public IContractResolver
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver
Noemax.Newtonsoft.Json.Serialization.CamelCasePropertyNamesContractResolver

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Members
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultContractResolver Class Members

DefaultContractResolver Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class

The following tables list the members exposed by DefaultContractResolver.

Public Constructors
 | Name | Description
Public Constructor | DefaultContractResolver Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags.
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available.
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types.
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types.
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized.
Top
Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property.
Public Method | ResolveContract | Resolves the contract for a given type.
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type.
Protected Method | CreateConstructorParameters | Creates the constructor parameters.
Protected Method | CreateContract | Determines which contract type is created for the given type.
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type.
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type.
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type.
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member.
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type.
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type.
Protected Method | CreateProperties | Creates properties for the given JsonContract.
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo.
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo.
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type.
Protected Method | GetSerializableMembers | Gets the serializable members for the type.
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract.
Top
See Also

Reference

DefaultContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultContractResolver Constructor

DefaultContractResolver Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : DefaultContractResolver Constructor
Overload List
Overload | Description
DefaultContractResolver Constructor() | Initializes a new instance of the DefaultContractResolver class.
DefaultContractResolver Constructor(Boolean) | Initializes a new instance of the DefaultContractResolver class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


DefaultContractResolver Constructor()

DefaultContractResolver Constructor()

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class > DefaultContractResolver Constructor : DefaultContractResolver Constructor()
Initializes a new instance of the DefaultContractResolver class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DefaultContractResolver()
public DefaultContractResolver()
public DefaultContractResolver();
public function DefaultContractResolver();
public: DefaultContractResolver();
public:
DefaultContractResolver();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members
Overload List


DefaultContractResolver Constructor(Boolean)

DefaultContractResolver Constructor(Boolean)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class > DefaultContractResolver Constructor : DefaultContractResolver Constructor(Boolean)
If set to true the DefaultContractResolver will use a cached shared with other resolvers of the same type. Sharing the cache will significantly performance because expensive reflection will only happen once but could cause unexpected behavior if different instances of the resolver are suppose to produce different results. When set to false it is highly recommended to reuse DefaultContractResolver instances with the Noemax.Newtonsoft.Json.JsonSerializer.
Initializes a new instance of the DefaultContractResolver class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal shareCache As System.Boolean _
)
'Usage

Dim shareCache As System.Boolean

Dim instance As New DefaultContractResolver(shareCache)
public DefaultContractResolver(
   System.bool shareCache
)
public DefaultContractResolver(
    shareCache: System.Boolean
);
public function DefaultContractResolver(
   shareCache : System.boolean
);
public: DefaultContractResolver(
   System.bool shareCache
)
public:
DefaultContractResolver(
   System.bool shareCache
)

Parameters

shareCache
If set to true the DefaultContractResolver will use a cached shared with other resolvers of the same type. Sharing the cache will significantly performance because expensive reflection will only happen once but could cause unexpected behavior if different instances of the resolver are suppose to produce different results. When set to false it is highly recommended to reuse DefaultContractResolver instances with the Noemax.Newtonsoft.Json.JsonSerializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members
Overload List


DefaultContractResolver Class Methods

DefaultContractResolver Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class

For a list of all members of this type, see DefaultContractResolver members.

Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property.
Public Method | ResolveContract | Resolves the contract for a given type.
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type.
Protected Method | CreateConstructorParameters | Creates the constructor parameters.
Protected Method | CreateContract | Determines which contract type is created for the given type.
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type.
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type.
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type.
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member.
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type.
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type.
Protected Method | CreateProperties | Creates properties for the given JsonContract.
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo.
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo.
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type.
Protected Method | GetSerializableMembers | Gets the serializable members for the type.
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract.
Top
See Also

Reference

DefaultContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


CreateArrayContract Method (DefaultContractResolver)

CreateArrayContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateArrayContract Method
Type of the object.
Creates a JsonArrayContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateArrayContract( _
   ByVal objectType As System.Type _
) As JsonArrayContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonArrayContract

value = instance.CreateArrayContract(objectType)
protected virtual JsonArrayContract CreateArrayContract(
   System.Type objectType
)
protected function CreateArrayContract(
    objectType: System.Type
): JsonArrayContract; virtual;
protected function CreateArrayContract(
   objectType : System.Type
) : JsonArrayContract;
protected: virtual JsonArrayContract* CreateArrayContract(
   System.Type* objectType
)
protected:
virtual JsonArrayContract^ CreateArrayContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonArrayContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateConstructorParameters Method (DefaultContractResolver)

CreateConstructorParameters Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateConstructorParameters Method
The constructor to create properties for.
The type's member properties.
Creates the constructor parameters.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateConstructorParameters( _
   ByVal constructor As System.Reflection.ConstructorInfo, _
   ByVal memberProperties As JsonPropertyCollection _
) As System.Collections.Generic.IList(Of JsonProperty)
'Usage

Dim instance As DefaultContractResolver
Dim constructor As System.Reflection.ConstructorInfo
Dim memberProperties As JsonPropertyCollection
Dim value As System.Collections.Generic.IList(Of JsonProperty)

value = instance.CreateConstructorParameters(constructor, memberProperties)
protected virtual System.Collections.Generic.IList<JsonProperty> CreateConstructorParameters(
   System.Reflection.ConstructorInfo constructor,
   JsonPropertyCollection memberProperties
)
protected function CreateConstructorParameters(
    constructor: System.Reflection.ConstructorInfo;
    memberProperties: JsonPropertyCollection
): System.Collections.Generic.IList; virtual;
protected function CreateConstructorParameters(
   constructor : System.Reflection.ConstructorInfo,
   memberProperties : JsonPropertyCollection
) : System.Collections.Generic.IList;
protected: virtual System.Collections.Generic.IList<JsonProperty*>* CreateConstructorParameters(
   System.Reflection.ConstructorInfo* constructor,
   JsonPropertyCollection* memberProperties
)
protected:
virtual System.Collections.Generic.IList<JsonProperty^>^ CreateConstructorParameters(
   System.Reflection.ConstructorInfo^ constructor,
   JsonPropertyCollection^ memberProperties
)

Parameters

constructor
The constructor to create properties for.
memberProperties
The type's member properties.

Return Value

Properties for the given System.Reflection.ConstructorInfo.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateContract Method (DefaultContractResolver)

CreateContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateContract Method
Type of the object.
Determines which contract type is created for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateContract( _
   ByVal objectType As System.Type _
) As JsonContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonContract

value = instance.CreateContract(objectType)
protected virtual JsonContract CreateContract(
   System.Type objectType
)
protected function CreateContract(
    objectType: System.Type
): JsonContract; virtual;
protected function CreateContract(
   objectType : System.Type
) : JsonContract;
protected: virtual JsonContract* CreateContract(
   System.Type* objectType
)
protected:
virtual JsonContract^ CreateContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateDictionaryContract Method (DefaultContractResolver)

CreateDictionaryContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateDictionaryContract Method
Type of the object.
Creates a JsonDictionaryContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateDictionaryContract( _
   ByVal objectType As System.Type _
) As JsonDictionaryContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonDictionaryContract

value = instance.CreateDictionaryContract(objectType)
protected virtual JsonDictionaryContract CreateDictionaryContract(
   System.Type objectType
)
protected function CreateDictionaryContract(
    objectType: System.Type
): JsonDictionaryContract; virtual;
protected function CreateDictionaryContract(
   objectType : System.Type
) : JsonDictionaryContract;
protected: virtual JsonDictionaryContract* CreateDictionaryContract(
   System.Type* objectType
)
protected:
virtual JsonDictionaryContract^ CreateDictionaryContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonDictionaryContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateISerializableContract Method (DefaultContractResolver)

CreateISerializableContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateISerializableContract Method
Type of the object.
Creates a JsonISerializableContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateISerializableContract( _
   ByVal objectType As System.Type _
) As JsonISerializableContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonISerializableContract

value = instance.CreateISerializableContract(objectType)
protected virtual JsonISerializableContract CreateISerializableContract(
   System.Type objectType
)
protected function CreateISerializableContract(
    objectType: System.Type
): JsonISerializableContract; virtual;
protected function CreateISerializableContract(
   objectType : System.Type
) : JsonISerializableContract;
protected: virtual JsonISerializableContract* CreateISerializableContract(
   System.Type* objectType
)
protected:
virtual JsonISerializableContract^ CreateISerializableContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonISerializableContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateLinqContract Method (DefaultContractResolver)

CreateLinqContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateLinqContract Method
Type of the object.
Creates a JsonLinqContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateLinqContract( _
   ByVal objectType As System.Type _
) As JsonLinqContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonLinqContract

value = instance.CreateLinqContract(objectType)
protected virtual JsonLinqContract CreateLinqContract(
   System.Type objectType
)
protected function CreateLinqContract(
    objectType: System.Type
): JsonLinqContract; virtual;
protected function CreateLinqContract(
   objectType : System.Type
) : JsonLinqContract;
protected: virtual JsonLinqContract* CreateLinqContract(
   System.Type* objectType
)
protected:
virtual JsonLinqContract^ CreateLinqContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonLinqContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateMemberValueProvider Method (DefaultContractResolver)

CreateMemberValueProvider Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateMemberValueProvider Method
The member.
Creates the IValueProvider used by the serializer to get and set values from a member.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateMemberValueProvider( _
   ByVal member As System.Reflection.MemberInfo _
) As IValueProvider
'Usage

Dim instance As DefaultContractResolver
Dim member As System.Reflection.MemberInfo
Dim value As IValueProvider

value = instance.CreateMemberValueProvider(member)
protected virtual IValueProvider CreateMemberValueProvider(
   System.Reflection.MemberInfo member
)
protected function CreateMemberValueProvider(
    member: System.Reflection.MemberInfo
): IValueProvider; virtual;
protected function CreateMemberValueProvider(
   member : System.Reflection.MemberInfo
) : IValueProvider;
protected: virtual IValueProvider* CreateMemberValueProvider(
   System.Reflection.MemberInfo* member
)
protected:
virtual IValueProvider^ CreateMemberValueProvider(
   System.Reflection.MemberInfo^ member
)

Parameters

member
The member.

Return Value

The IValueProvider used by the serializer to get and set values from a member.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateObjectContract Method (DefaultContractResolver)

CreateObjectContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateObjectContract Method
Type of the object.
Creates a JsonObjectContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateObjectContract( _
   ByVal objectType As System.Type _
) As JsonObjectContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonObjectContract

value = instance.CreateObjectContract(objectType)
protected virtual JsonObjectContract CreateObjectContract(
   System.Type objectType
)
protected function CreateObjectContract(
    objectType: System.Type
): JsonObjectContract; virtual;
protected function CreateObjectContract(
   objectType : System.Type
) : JsonObjectContract;
protected: virtual JsonObjectContract* CreateObjectContract(
   System.Type* objectType
)
protected:
virtual JsonObjectContract^ CreateObjectContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonObjectContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreatePrimitiveContract Method (DefaultContractResolver)

CreatePrimitiveContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreatePrimitiveContract Method
Type of the object.
Creates a JsonPrimitiveContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreatePrimitiveContract( _
   ByVal objectType As System.Type _
) As JsonPrimitiveContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonPrimitiveContract

value = instance.CreatePrimitiveContract(objectType)
protected virtual JsonPrimitiveContract CreatePrimitiveContract(
   System.Type objectType
)
protected function CreatePrimitiveContract(
    objectType: System.Type
): JsonPrimitiveContract; virtual;
protected function CreatePrimitiveContract(
   objectType : System.Type
) : JsonPrimitiveContract;
protected: virtual JsonPrimitiveContract* CreatePrimitiveContract(
   System.Type* objectType
)
protected:
virtual JsonPrimitiveContract^ CreatePrimitiveContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonPrimitiveContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateProperties Method (DefaultContractResolver)

CreateProperties Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateProperties Method
The type to create properties for.
The member serialization mode for the type.
Creates properties for the given JsonContract.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateProperties( _
   ByVal type As System.Type, _
   ByVal memberSerialization As MemberSerialization _
) As System.Collections.Generic.IList(Of JsonProperty)
'Usage

Dim instance As DefaultContractResolver
Dim type As System.Type
Dim memberSerialization As MemberSerialization
Dim value As System.Collections.Generic.IList(Of JsonProperty)

value = instance.CreateProperties(type, memberSerialization)
protected virtual System.Collections.Generic.IList<JsonProperty> CreateProperties(
   System.Type type,
   MemberSerialization memberSerialization
)
protected function CreateProperties(
    type: System.Type;
    memberSerialization: MemberSerialization
): System.Collections.Generic.IList; virtual;
protected function CreateProperties(
   type : System.Type,
   memberSerialization : MemberSerialization
) : System.Collections.Generic.IList;
protected: virtual System.Collections.Generic.IList<JsonProperty*>* CreateProperties(
   System.Type* type,
   MemberSerialization memberSerialization
)
protected:
virtual System.Collections.Generic.IList<JsonProperty^>^ CreateProperties(
   System.Type^ type,
   MemberSerialization memberSerialization
)

Parameters

type
The type to create properties for.
memberSerialization
The member serialization mode for the type.

Return Value

Properties for the given JsonContract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateProperty Method (DefaultContractResolver)

CreateProperty Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateProperty Method
The member to create a JsonProperty for.
The member's parent Noemax.Newtonsoft.Json.MemberSerialization.
Creates a JsonProperty for the given System.Reflection.MemberInfo.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateProperty( _
   ByVal member As System.Reflection.MemberInfo, _
   ByVal memberSerialization As MemberSerialization _
) As JsonProperty
'Usage

Dim instance As DefaultContractResolver
Dim member As System.Reflection.MemberInfo
Dim memberSerialization As MemberSerialization
Dim value As JsonProperty

value = instance.CreateProperty(member, memberSerialization)
protected virtual JsonProperty CreateProperty(
   System.Reflection.MemberInfo member,
   MemberSerialization memberSerialization
)
protected function CreateProperty(
    member: System.Reflection.MemberInfo;
    memberSerialization: MemberSerialization
): JsonProperty; virtual;
protected function CreateProperty(
   member : System.Reflection.MemberInfo,
   memberSerialization : MemberSerialization
) : JsonProperty;
protected: virtual JsonProperty* CreateProperty(
   System.Reflection.MemberInfo* member,
   MemberSerialization memberSerialization
)
protected:
virtual JsonProperty^ CreateProperty(
   System.Reflection.MemberInfo^ member,
   MemberSerialization memberSerialization
)

Parameters

member
The member to create a JsonProperty for.
memberSerialization
The member's parent Noemax.Newtonsoft.Json.MemberSerialization.

Return Value

A created JsonProperty for the given System.Reflection.MemberInfo.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreatePropertyFromConstructorParameter Method (DefaultContractResolver)

CreatePropertyFromConstructorParameter Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreatePropertyFromConstructorParameter Method
The matching member property.
The constructor parameter.
Creates a JsonProperty for the given System.Reflection.ParameterInfo.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreatePropertyFromConstructorParameter( _
   ByVal matchingMemberProperty As JsonProperty, _
   ByVal parameterInfo As System.Reflection.ParameterInfo _
) As JsonProperty
'Usage

Dim instance As DefaultContractResolver
Dim matchingMemberProperty As JsonProperty
Dim parameterInfo As System.Reflection.ParameterInfo
Dim value As JsonProperty

value = instance.CreatePropertyFromConstructorParameter(matchingMemberProperty, parameterInfo)
protected virtual JsonProperty CreatePropertyFromConstructorParameter(
   JsonProperty matchingMemberProperty,
   System.Reflection.ParameterInfo parameterInfo
)
protected function CreatePropertyFromConstructorParameter(
    matchingMemberProperty: JsonProperty;
    parameterInfo: System.Reflection.ParameterInfo
): JsonProperty; virtual;
protected function CreatePropertyFromConstructorParameter(
   matchingMemberProperty : JsonProperty,
   parameterInfo : System.Reflection.ParameterInfo
) : JsonProperty;
protected: virtual JsonProperty* CreatePropertyFromConstructorParameter(
   JsonProperty* matchingMemberProperty,
   System.Reflection.ParameterInfo* parameterInfo
)
protected:
virtual JsonProperty^ CreatePropertyFromConstructorParameter(
   JsonProperty^ matchingMemberProperty,
   System.Reflection.ParameterInfo^ parameterInfo
)

Parameters

matchingMemberProperty
The matching member property.
parameterInfo
The constructor parameter.

Return Value

A created JsonProperty for the given System.Reflection.ParameterInfo.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


CreateStringContract Method (DefaultContractResolver)

CreateStringContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateStringContract Method
Type of the object.
Creates a JsonStringContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateStringContract( _
   ByVal objectType As System.Type _
) As JsonStringContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonStringContract

value = instance.CreateStringContract(objectType)
protected virtual JsonStringContract CreateStringContract(
   System.Type objectType
)
protected function CreateStringContract(
    objectType: System.Type
): JsonStringContract; virtual;
protected function CreateStringContract(
   objectType : System.Type
) : JsonStringContract;
protected: virtual JsonStringContract* CreateStringContract(
   System.Type* objectType
)
protected:
virtual JsonStringContract^ CreateStringContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonStringContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


GetResolvedPropertyName Method (DefaultContractResolver)

GetResolvedPropertyName Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : GetResolvedPropertyName Method
Name of the property.
Gets the resolved name of the property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetResolvedPropertyName( _
   ByVal propertyName As System.String _
) As System.String
'Usage

Dim instance As DefaultContractResolver
Dim propertyName As System.String
Dim value As System.String

value = instance.GetResolvedPropertyName(propertyName)
public System.string GetResolvedPropertyName(
   System.string propertyName
)
public function GetResolvedPropertyName(
    propertyName: System.String
): System.String;
public function GetResolvedPropertyName(
   propertyName : System.String
) : System.String;
public: System.string* GetResolvedPropertyName(
   System.string* propertyName
)
public:
System.String^ GetResolvedPropertyName(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.

Return Value

Name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


GetSerializableMembers Method (DefaultContractResolver)

GetSerializableMembers Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : GetSerializableMembers Method
The type to get serializable members for.
Gets the serializable members for the type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function GetSerializableMembers( _
   ByVal objectType As System.Type _
) As System.Collections.Generic.List(Of MemberInfo)
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As System.Collections.Generic.List(Of MemberInfo)

value = instance.GetSerializableMembers(objectType)
protected virtual System.Collections.Generic.List<MemberInfo> GetSerializableMembers(
   System.Type objectType
)
protected function GetSerializableMembers(
    objectType: System.Type
): System.Collections.Generic.List; virtual;
protected function GetSerializableMembers(
   objectType : System.Type
) : System.Collections.Generic.List;
protected: virtual System.Collections.Generic.List<MemberInfo*>* GetSerializableMembers(
   System.Type* objectType
)
protected:
virtual System.Collections.Generic.List<MemberInfo^>^ GetSerializableMembers(
   System.Type^ objectType
)

Parameters

objectType
The type to get serializable members for.

Return Value

The serializable members for the type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


ResolveContract Method (DefaultContractResolver)

ResolveContract Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : ResolveContract Method
The type to resolve a contract for.
Resolves the contract for a given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function ResolveContract( _
   ByVal type As System.Type _
) As JsonContract
'Usage

Dim instance As DefaultContractResolver
Dim type As System.Type
Dim value As JsonContract

value = instance.ResolveContract(type)
public virtual JsonContract ResolveContract(
   System.Type type
)
public function ResolveContract(
    type: System.Type
): JsonContract; virtual;
public function ResolveContract(
   type : System.Type
) : JsonContract;
public: virtual JsonContract* ResolveContract(
   System.Type* type
)
public:
virtual JsonContract^ ResolveContract(
   System.Type^ type
)

Parameters

type
The type to resolve a contract for.

Return Value

The contract for a given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


ResolveContractConverter Method (DefaultContractResolver)

ResolveContractConverter Method (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : ResolveContractConverter Method
Type of the object.
Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function ResolveContractConverter( _
   ByVal objectType As System.Type _
) As JsonConverter
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonConverter

value = instance.ResolveContractConverter(objectType)
protected virtual JsonConverter ResolveContractConverter(
   System.Type objectType
)
protected function ResolveContractConverter(
    objectType: System.Type
): JsonConverter; virtual;
protected function ResolveContractConverter(
   objectType : System.Type
) : JsonConverter;
protected: virtual JsonConverter* ResolveContractConverter(
   System.Type* objectType
)
protected:
virtual JsonConverter^ ResolveContractConverter(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

The contract's default Noemax.Newtonsoft.Json.JsonConverter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


DefaultContractResolver Class Properties

DefaultContractResolver Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class

For a list of all members of this type, see DefaultContractResolver members.

Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags.
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available.
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types.
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types.
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized.
Top
See Also

Reference

DefaultContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultMembersSearchFlags Property (DefaultContractResolver)

DefaultMembersSearchFlags Property (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : DefaultMembersSearchFlags Property
Gets or sets the default members search flags.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("DefaultMembersSearchFlags is obsolete. To modify the members serialized inherit from DefaultContractResolver and override the GetSerializableMembers method instead.")>
Public Property DefaultMembersSearchFlags As System.Reflection.BindingFlags
'Usage

Dim instance As DefaultContractResolver
Dim value As System.Reflection.BindingFlags

instance.DefaultMembersSearchFlags = value

value = instance.DefaultMembersSearchFlags
[System.Obsolete("DefaultMembersSearchFlags is obsolete. To modify the members serialized inherit from DefaultContractResolver and override the GetSerializableMembers method instead.")]
public System.Reflection.BindingFlags DefaultMembersSearchFlags {get; set;}
public read-write property DefaultMembersSearchFlags: System.Reflection.BindingFlags;
System.ObsoleteAttribute("DefaultMembersSearchFlags is obsolete. To modify the members serialized inherit from DefaultContractResolver and override the GetSerializableMembers method instead.")
public function get,set DefaultMembersSearchFlags : System.Reflection.BindingFlags
[System.Obsolete("DefaultMembersSearchFlags is obsolete. To modify the members serialized inherit from DefaultContractResolver and override the GetSerializableMembers method instead.")]
public: __property System.Reflection.BindingFlags get_DefaultMembersSearchFlags();
public: __property void set_DefaultMembersSearchFlags(
   System.Reflection.BindingFlags value
);
[System.Obsolete("DefaultMembersSearchFlags is obsolete. To modify the members serialized inherit from DefaultContractResolver and override the GetSerializableMembers method instead.")]
public:
property System.Reflection.BindingFlags DefaultMembersSearchFlags {
   System.Reflection.BindingFlags get();
   void set (    System.Reflection.BindingFlags value);
}

Property Value

The default members search flags.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


DynamicCodeGeneration Property (DefaultContractResolver)

DynamicCodeGeneration Property (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : DynamicCodeGeneration Property
Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DynamicCodeGeneration As System.Boolean
'Usage

Dim instance As DefaultContractResolver
Dim value As System.Boolean

value = instance.DynamicCodeGeneration
public System.bool DynamicCodeGeneration {get;}
public read-only property DynamicCodeGeneration: System.Boolean;
public function get DynamicCodeGeneration : System.boolean
public: __property System.bool get_DynamicCodeGeneration();
public:
property System.bool DynamicCodeGeneration {
   System.bool get();
}

Property Value

true if using dynamic code generation; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


IgnoreSerializableAttribute Property (DefaultContractResolver)

IgnoreSerializableAttribute Property (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : IgnoreSerializableAttribute Property
Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreSerializableAttribute As System.Boolean
'Usage

Dim instance As DefaultContractResolver
Dim value As System.Boolean

instance.IgnoreSerializableAttribute = value

value = instance.IgnoreSerializableAttribute
public System.bool IgnoreSerializableAttribute {get; set;}
public read-write property IgnoreSerializableAttribute: System.Boolean;
public function get,set IgnoreSerializableAttribute : System.boolean
public: __property System.bool get_IgnoreSerializableAttribute();
public: __property void set_IgnoreSerializableAttribute(
   System.bool value
);
public:
property System.bool IgnoreSerializableAttribute {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the System.SerializableAttribute attribute will be ignored when serializing and deserializing types; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


IgnoreSerializableInterface Property (DefaultContractResolver)

IgnoreSerializableInterface Property (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : IgnoreSerializableInterface Property
Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IgnoreSerializableInterface As System.Boolean
'Usage

Dim instance As DefaultContractResolver
Dim value As System.Boolean

instance.IgnoreSerializableInterface = value

value = instance.IgnoreSerializableInterface
public System.bool IgnoreSerializableInterface {get; set;}
public read-write property IgnoreSerializableInterface: System.Boolean;
public function get,set IgnoreSerializableInterface : System.boolean
public: __property System.bool get_IgnoreSerializableInterface();
public: __property void set_IgnoreSerializableInterface(
   System.bool value
);
public:
property System.bool IgnoreSerializableInterface {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the System.Runtime.Serialization.ISerializable interface will be ignored when serializing and deserializing types; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


SerializeCompilerGeneratedMembers Property (DefaultContractResolver)

SerializeCompilerGeneratedMembers Property (DefaultContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : SerializeCompilerGeneratedMembers Property
Gets or sets a value indicating whether compiler generated members should be serialized.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SerializeCompilerGeneratedMembers As System.Boolean
'Usage

Dim instance As DefaultContractResolver
Dim value As System.Boolean

instance.SerializeCompilerGeneratedMembers = value

value = instance.SerializeCompilerGeneratedMembers
public System.bool SerializeCompilerGeneratedMembers {get; set;}
public read-write property SerializeCompilerGeneratedMembers: System.Boolean;
public function get,set SerializeCompilerGeneratedMembers : System.boolean
public: __property System.bool get_SerializeCompilerGeneratedMembers();
public: __property void set_SerializeCompilerGeneratedMembers(
   System.bool value
);
public:
property System.bool SerializeCompilerGeneratedMembers {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if serialized compiler generated members; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


DefaultSerializationBinder Class

DefaultSerializationBinder Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultSerializationBinder Class
The default serialization binder used when resolving and loading classes from type names.
Object Model
DefaultSerializationBinder Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DefaultSerializationBinder
   Inherits System.Runtime.Serialization.SerializationBinder
'Usage

Dim instance As DefaultSerializationBinder
public class DefaultSerializationBinder : System.Runtime.Serialization.SerializationBinder
public class DefaultSerializationBinder = class(System.Runtime.Serialization.SerializationBinder)
public class DefaultSerializationBinder extends System.Runtime.Serialization.SerializationBinder
public __gc class DefaultSerializationBinder : public System.Runtime.Serialization.SerializationBinder
public ref class DefaultSerializationBinder : public System.Runtime.Serialization.SerializationBinder
Inheritance Hierarchy

System.Object
System.Runtime.Serialization.SerializationBinder
Noemax.Newtonsoft.Json.Serialization.DefaultSerializationBinder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSerializationBinder Members
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultSerializationBinder Class Members

DefaultSerializationBinder Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultSerializationBinder Class

The following tables list the members exposed by DefaultSerializationBinder.

Public Constructors
 | Name | Description
Public Constructor | DefaultSerializationBinder Constructor |
Top
Public Methods
 | Name | Description
Public Method | BindToName | (Inherited from System.Runtime.Serialization.SerializationBinder)
Public Method | BindToType | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Top
See Also

Reference

DefaultSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultSerializationBinder Constructor

DefaultSerializationBinder Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultSerializationBinder Class : DefaultSerializationBinder Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DefaultSerializationBinder()
public DefaultSerializationBinder()
public DefaultSerializationBinder();
public function DefaultSerializationBinder();
public: DefaultSerializationBinder();
public:
DefaultSerializationBinder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSerializationBinder Class
DefaultSerializationBinder Members


DefaultSerializationBinder Class Methods

DefaultSerializationBinder Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultSerializationBinder Class

For a list of all members of this type, see DefaultSerializationBinder members.

Public Methods
 | Name | Description
Public Method | BindToName | (Inherited from System.Runtime.Serialization.SerializationBinder)
Public Method | BindToType | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Top
See Also

Reference

DefaultSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


BindToType Method (DefaultSerializationBinder)

BindToType Method (DefaultSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultSerializationBinder Class : BindToType Method
Specifies the System.Reflection.Assembly name of the serialized object.
Specifies the System.Type name of the serialized object.
When overridden in a derived class, controls the binding of a serialized object to a type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function BindToType( _
   ByVal assemblyName As System.String, _
   ByVal typeName As System.String _
) As System.Type
'Usage

Dim instance As DefaultSerializationBinder
Dim assemblyName As System.String
Dim typeName As System.String
Dim value As System.Type

value = instance.BindToType(assemblyName, typeName)
public override System.Type BindToType(
   System.string assemblyName,
   System.string typeName
)
public function BindToType(
    assemblyName: System.String;
    typeName: System.String
): System.Type; override;
public override function BindToType(
   assemblyName : System.String,
   typeName : System.String
) : System.Type;
public: System.Type* BindToType(
   System.string* assemblyName,
   System.string* typeName
) override
public:
System.Type^ BindToType(
   System.String^ assemblyName,
   System.String^ typeName
) override

Parameters

assemblyName
Specifies the System.Reflection.Assembly name of the serialized object.
typeName
Specifies the System.Type name of the serialized object.

Return Value

The type of the object the formatter creates a new instance of.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSerializationBinder Class
DefaultSerializationBinder Members
Base Implementation in BindToType


DiagnosticsTraceWriter Class

DiagnosticsTraceWriter Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : DiagnosticsTraceWriter Class
Represents a trace writer that writes to the application's System.Diagnostics.TraceListener instances.
Object Model
DiagnosticsTraceWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DiagnosticsTraceWriter
   Implements ITraceWriter
'Usage

Dim instance As DiagnosticsTraceWriter
public class DiagnosticsTraceWriter : ITraceWriter
public class DiagnosticsTraceWriter = class(ITraceWriter)
public class DiagnosticsTraceWriter implements ITraceWriter
public __gc class DiagnosticsTraceWriter : public ITraceWriter
public ref class DiagnosticsTraceWriter : public ITraceWriter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.DiagnosticsTraceWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiagnosticsTraceWriter Members
Noemax.Newtonsoft.Json.Serialization Namespace


DiagnosticsTraceWriter Class Members

DiagnosticsTraceWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DiagnosticsTraceWriter Class

The following tables list the members exposed by DiagnosticsTraceWriter.

Public Constructors
 | Name | Description
Public Constructor | DiagnosticsTraceWriter Constructor |
Top
Public Properties
 | Name | Description
Public Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
Public Methods
 | Name | Description
Public Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

DiagnosticsTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


DiagnosticsTraceWriter Constructor

DiagnosticsTraceWriter Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > DiagnosticsTraceWriter Class : DiagnosticsTraceWriter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DiagnosticsTraceWriter()
public DiagnosticsTraceWriter()
public DiagnosticsTraceWriter();
public function DiagnosticsTraceWriter();
public: DiagnosticsTraceWriter();
public:
DiagnosticsTraceWriter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiagnosticsTraceWriter Class
DiagnosticsTraceWriter Members


DiagnosticsTraceWriter Class Methods

DiagnosticsTraceWriter Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DiagnosticsTraceWriter Class

For a list of all members of this type, see DiagnosticsTraceWriter members.

Public Methods
 | Name | Description
Public Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

DiagnosticsTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


Trace Method (DiagnosticsTraceWriter)

Trace Method (DiagnosticsTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > DiagnosticsTraceWriter Class : Trace Method
The System.Diagnostics.TraceLevel at which to write this trace.
The trace message.
The trace exception. This parameter is optional.
Writes the specified trace level, message and optional exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Trace( _
   ByVal level As System.Diagnostics.TraceLevel, _
   ByVal message As System.String, _
   ByVal ex As System.Exception _
)
'Usage

Dim instance As DiagnosticsTraceWriter
Dim level As System.Diagnostics.TraceLevel
Dim message As System.String
Dim ex As System.Exception

instance.Trace(level, message, ex)
public void Trace(
   System.Diagnostics.TraceLevel level,
   System.string message,
   System.Exception ex
)
public procedure Trace(
    level: System.Diagnostics.TraceLevel;
    message: System.String;
    ex: System.Exception
);
public function Trace(
   level : System.Diagnostics.TraceLevel,
   message : System.String,
   ex : System.Exception
);
public: void Trace(
   System.Diagnostics.TraceLevel level,
   System.string* message,
   System.Exception* ex
)
public:
void Trace(
   System.Diagnostics.TraceLevel level,
   System.String^ message,
   System.Exception^ ex
)

Parameters

level
The System.Diagnostics.TraceLevel at which to write this trace.
message
The trace message.
ex
The trace exception. This parameter is optional.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiagnosticsTraceWriter Class
DiagnosticsTraceWriter Members


DiagnosticsTraceWriter Class Properties

DiagnosticsTraceWriter Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : DiagnosticsTraceWriter Class

For a list of all members of this type, see DiagnosticsTraceWriter members.

Public Properties
 | Name | Description
Public Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
See Also

Reference

DiagnosticsTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


LevelFilter Property (DiagnosticsTraceWriter)

LevelFilter Property (DiagnosticsTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > DiagnosticsTraceWriter Class : LevelFilter Property
Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LevelFilter As System.Diagnostics.TraceLevel
'Usage

Dim instance As DiagnosticsTraceWriter
Dim value As System.Diagnostics.TraceLevel

instance.LevelFilter = value

value = instance.LevelFilter
public System.Diagnostics.TraceLevel LevelFilter {get; set;}
public read-write property LevelFilter: System.Diagnostics.TraceLevel;
public function get,set LevelFilter : System.Diagnostics.TraceLevel
public: __property System.Diagnostics.TraceLevel get_LevelFilter();
public: __property void set_LevelFilter(
   System.Diagnostics.TraceLevel value
);
public:
property System.Diagnostics.TraceLevel LevelFilter {
   System.Diagnostics.TraceLevel get();
   void set (    System.Diagnostics.TraceLevel value);
}

Property Value

The System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiagnosticsTraceWriter Class
DiagnosticsTraceWriter Members


DynamicValueProvider Class

DynamicValueProvider Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : DynamicValueProvider Class
Get and set values for a System.Reflection.MemberInfo using dynamic methods.
Object Model
DynamicValueProvider Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DynamicValueProvider
   Implements IValueProvider
'Usage

Dim instance As DynamicValueProvider
public class DynamicValueProvider : IValueProvider
public class DynamicValueProvider = class(IValueProvider)
public class DynamicValueProvider implements IValueProvider
public __gc class DynamicValueProvider : public IValueProvider
public ref class DynamicValueProvider : public IValueProvider
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.DynamicValueProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicValueProvider Members
Noemax.Newtonsoft.Json.Serialization Namespace


DynamicValueProvider Class Members

DynamicValueProvider Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DynamicValueProvider Class

The following tables list the members exposed by DynamicValueProvider.

Public Constructors
 | Name | Description
Public Constructor | DynamicValueProvider Constructor | Initializes a new instance of the DynamicValueProvider class.
Top
Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

DynamicValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


DynamicValueProvider Constructor

DynamicValueProvider Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > DynamicValueProvider Class : DynamicValueProvider Constructor
The member info.
Initializes a new instance of the DynamicValueProvider class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal memberInfo As System.Reflection.MemberInfo _
)
'Usage

Dim memberInfo As System.Reflection.MemberInfo

Dim instance As New DynamicValueProvider(memberInfo)
public DynamicValueProvider(
   System.Reflection.MemberInfo memberInfo
)
public DynamicValueProvider(
    memberInfo: System.Reflection.MemberInfo
);
public function DynamicValueProvider(
   memberInfo : System.Reflection.MemberInfo
);
public: DynamicValueProvider(
   System.Reflection.MemberInfo* memberInfo
)
public:
DynamicValueProvider(
   System.Reflection.MemberInfo^ memberInfo
)

Parameters

memberInfo
The member info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicValueProvider Class
DynamicValueProvider Members


DynamicValueProvider Class Methods

DynamicValueProvider Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DynamicValueProvider Class

For a list of all members of this type, see DynamicValueProvider members.

Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

DynamicValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


GetValue Method (DynamicValueProvider)

GetValue Method (DynamicValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > DynamicValueProvider Class : GetValue Method
The target to get the value from.
Gets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValue( _
   ByVal target As System.Object _
) As System.Object
'Usage

Dim instance As DynamicValueProvider
Dim target As System.Object
Dim value As System.Object

value = instance.GetValue(target)
public System.object GetValue(
   System.object target
)
public function GetValue(
    target: System.TObject
): System.TObject;
public function GetValue(
   target : System.Object
) : System.Object;
public: System.Object* GetValue(
   System.Object* target
)
public:
System.Object^ GetValue(
   System.Object^ target
)

Parameters

target
The target to get the value from.

Return Value

The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicValueProvider Class
DynamicValueProvider Members


SetValue Method (DynamicValueProvider)

SetValue Method (DynamicValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > DynamicValueProvider Class : SetValue Method
The target to set the value on.
The value to set on the target.
Sets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetValue( _
   ByVal target As System.Object, _
   ByVal value As System.Object _
)
'Usage

Dim instance As DynamicValueProvider
Dim target As System.Object
Dim value As System.Object

instance.SetValue(target, value)
public void SetValue(
   System.object target,
   System.object value
)
public procedure SetValue(
    target: System.TObject;
    value: System.TObject
);
public function SetValue(
   target : System.Object,
   value : System.Object
);
public: void SetValue(
   System.Object* target,
   System.Object* value
)
public:
void SetValue(
   System.Object^ target,
   System.Object^ value
)

Parameters

target
The target to set the value on.
value
The value to set on the target.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DynamicValueProvider Class
DynamicValueProvider Members


ErrorContext Class

ErrorContext Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorContext Class
Provides information surrounding an error.
Object Model
ErrorContext Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ErrorContext
'Usage

Dim instance As ErrorContext
public class ErrorContext
public class ErrorContext
public class ErrorContext
public __gc class ErrorContext
public ref class ErrorContext
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.ErrorContext

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Members
Noemax.Newtonsoft.Json.Serialization Namespace


ErrorContext Class Members

ErrorContext Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorContext Class

The following tables list the members exposed by ErrorContext.

Public Properties
 | Name | Description
Public Property | Error | Gets the error.
Public Property | Handled | Gets or sets a value indicating whether this ErrorContext is handled.
Public Property | Member | Gets the member that caused the error.
Public Property | OriginalObject | Gets the original object that caused the error.
Public Property | Path | Gets the path of the JSON location where the error occurred.
Top
See Also

Reference

ErrorContext Class
Noemax.Newtonsoft.Json.Serialization Namespace


ErrorContext Class Properties

ErrorContext Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorContext Class

For a list of all members of this type, see ErrorContext members.

Public Properties
 | Name | Description
Public Property | Error | Gets the error.
Public Property | Handled | Gets or sets a value indicating whether this ErrorContext is handled.
Public Property | Member | Gets the member that caused the error.
Public Property | OriginalObject | Gets the original object that caused the error.
Public Property | Path | Gets the path of the JSON location where the error occurred.
Top
See Also

Reference

ErrorContext Class
Noemax.Newtonsoft.Json.Serialization Namespace


Error Property (ErrorContext)

Error Property (ErrorContext)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorContext Class : Error Property
Gets the error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Error As System.Exception
'Usage

Dim instance As ErrorContext
Dim value As System.Exception

value = instance.Error
public System.Exception Error {get;}
public read-only property Error: System.Exception;
public function get Error : System.Exception
public: __property System.Exception* get_Error();
public:
property System.Exception^ Error {
   System.Exception^ get();
}

Property Value

The error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Class
ErrorContext Members


Handled Property (ErrorContext)

Handled Property (ErrorContext)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorContext Class : Handled Property
Gets or sets a value indicating whether this ErrorContext is handled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Handled As System.Boolean
'Usage

Dim instance As ErrorContext
Dim value As System.Boolean

instance.Handled = value

value = instance.Handled
public System.bool Handled {get; set;}
public read-write property Handled: System.Boolean;
public function get,set Handled : System.boolean
public: __property System.bool get_Handled();
public: __property void set_Handled(
   System.bool value
);
public:
property System.bool Handled {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if handled; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Class
ErrorContext Members


Member Property (ErrorContext)

Member Property (ErrorContext)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorContext Class : Member Property
Gets the member that caused the error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Member As System.Object
'Usage

Dim instance As ErrorContext
Dim value As System.Object

value = instance.Member
public System.object Member {get;}
public read-only property Member: System.TObject;
public function get Member : System.Object
public: __property System.Object* get_Member();
public:
property System.Object^ Member {
   System.Object^ get();
}

Property Value

The member that caused the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Class
ErrorContext Members


OriginalObject Property (ErrorContext)

OriginalObject Property (ErrorContext)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorContext Class : OriginalObject Property
Gets the original object that caused the error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OriginalObject As System.Object
'Usage

Dim instance As ErrorContext
Dim value As System.Object

value = instance.OriginalObject
public System.object OriginalObject {get;}
public read-only property OriginalObject: System.TObject;
public function get OriginalObject : System.Object
public: __property System.Object* get_OriginalObject();
public:
property System.Object^ OriginalObject {
   System.Object^ get();
}

Property Value

The original object that caused the error.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Class
ErrorContext Members


Path Property (ErrorContext)

Path Property (ErrorContext)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorContext Class : Path Property
Gets the path of the JSON location where the error occurred.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Path As System.String
'Usage

Dim instance As ErrorContext
Dim value As System.String

value = instance.Path
public System.string Path {get;}
public read-only property Path: System.String;
public function get Path : System.String
public: __property System.string* get_Path();
public:
property System.String^ Path {
   System.String^ get();
}

Property Value

The path of the JSON location where the error occurred.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorContext Class
ErrorContext Members


ErrorEventArgs Class

ErrorEventArgs Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorEventArgs Class
Provides data for the Error event.
Object Model
ErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ErrorEventArgs
public class ErrorEventArgs : System.EventArgs
public class ErrorEventArgs = class(System.EventArgs)
public class ErrorEventArgs extends System.EventArgs
public __gc class ErrorEventArgs : public System.EventArgs
public ref class ErrorEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.Newtonsoft.Json.Serialization.ErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Members
Noemax.Newtonsoft.Json.Serialization Namespace


ErrorEventArgs Class Members

ErrorEventArgs Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorEventArgs Class

The following tables list the members exposed by ErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ErrorEventArgs Constructor | Initializes a new instance of the ErrorEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | CurrentObject | Gets the current object the error event is being raised against.
Public Property | ErrorContext | Gets the error context.
Top
See Also

Reference

ErrorEventArgs Class
Noemax.Newtonsoft.Json.Serialization Namespace


ErrorEventArgs Constructor

ErrorEventArgs Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorEventArgs Class : ErrorEventArgs Constructor
The current object.
The error context.
Initializes a new instance of the ErrorEventArgs class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal currentObject As System.Object, _
   ByVal errorContext As ErrorContext _
)
'Usage

Dim currentObject As System.Object
Dim errorContext As ErrorContext

Dim instance As New ErrorEventArgs(currentObject, errorContext)
public ErrorEventArgs(
   System.object currentObject,
   ErrorContext errorContext
)
public ErrorEventArgs(
    currentObject: System.TObject;
    errorContext: ErrorContext
);
public function ErrorEventArgs(
   currentObject : System.Object,
   errorContext : ErrorContext
);
public: ErrorEventArgs(
   System.Object* currentObject,
   ErrorContext* errorContext
)
public:
ErrorEventArgs(
   System.Object^ currentObject,
   ErrorContext^ errorContext
)

Parameters

currentObject
The current object.
errorContext
The error context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


ErrorEventArgs Class Properties

ErrorEventArgs Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : ErrorEventArgs Class

For a list of all members of this type, see ErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | CurrentObject | Gets the current object the error event is being raised against.
Public Property | ErrorContext | Gets the error context.
Top
See Also

Reference

ErrorEventArgs Class
Noemax.Newtonsoft.Json.Serialization Namespace


CurrentObject Property (ErrorEventArgs)

CurrentObject Property (ErrorEventArgs)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorEventArgs Class : CurrentObject Property
Gets the current object the error event is being raised against.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CurrentObject As System.Object
'Usage

Dim instance As ErrorEventArgs
Dim value As System.Object

value = instance.CurrentObject
public System.object CurrentObject {get;}
public read-only property CurrentObject: System.TObject;
public function get CurrentObject : System.Object
public: __property System.Object* get_CurrentObject();
public:
property System.Object^ CurrentObject {
   System.Object^ get();
}

Property Value

The current object the error event is being raised against.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


ErrorContext Property (ErrorEventArgs)

ErrorContext Property (ErrorEventArgs)

Noemax.Newtonsoft.Json.Serialization Namespace > ErrorEventArgs Class : ErrorContext Property
Gets the error context.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ErrorContext As ErrorContext
'Usage

Dim instance As ErrorEventArgs
Dim value As ErrorContext

value = instance.ErrorContext
public ErrorContext ErrorContext {get;}
public read-only property ErrorContext: ErrorContext;
public function get ErrorContext : ErrorContext
public: __property ErrorContext* get_ErrorContext();
public:
property ErrorContext^ ErrorContext {
   ErrorContext^ get();
}

Property Value

The error context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


FlexibleSerializationBinder Class

FlexibleSerializationBinder Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : FlexibleSerializationBinder Class
Alternative serialization binder used for resolving the classes from type name and assemly name.
Object Model
FlexibleSerializationBinder Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class FlexibleSerializationBinder
   Inherits System.Runtime.Serialization.SerializationBinder
'Usage

Dim instance As FlexibleSerializationBinder
public class FlexibleSerializationBinder : System.Runtime.Serialization.SerializationBinder
public class FlexibleSerializationBinder = class(System.Runtime.Serialization.SerializationBinder)
public class FlexibleSerializationBinder extends System.Runtime.Serialization.SerializationBinder
public __gc class FlexibleSerializationBinder : public System.Runtime.Serialization.SerializationBinder
public ref class FlexibleSerializationBinder : public System.Runtime.Serialization.SerializationBinder
Inheritance Hierarchy

System.Object
System.Runtime.Serialization.SerializationBinder
Noemax.Newtonsoft.Json.Serialization.FlexibleSerializationBinder

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Members
Noemax.Newtonsoft.Json.Serialization Namespace


FlexibleSerializationBinder Class Members

FlexibleSerializationBinder Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : FlexibleSerializationBinder Class

The following tables list the members exposed by FlexibleSerializationBinder.

Public Constructors
 | Name | Description
Public Constructor | FlexibleSerializationBinder Constructor |
Top
Public Methods
 | Name | Description
Public Method | BindToName | (Inherited from System.Runtime.Serialization.SerializationBinder)
Public Method | BindToType | Overridden. Resolves the assembly name and type name to the type.
static (Shared in Visual Basic) | RegisterType | Registers type with the serialization binder so that it can be resolved faster from the type name.
Top
See Also

Reference

FlexibleSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


FlexibleSerializationBinder Constructor

FlexibleSerializationBinder Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > FlexibleSerializationBinder Class : FlexibleSerializationBinder Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FlexibleSerializationBinder()
public FlexibleSerializationBinder()
public FlexibleSerializationBinder();
public function FlexibleSerializationBinder();
public: FlexibleSerializationBinder();
public:
FlexibleSerializationBinder();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Class
FlexibleSerializationBinder Members


FlexibleSerializationBinder Class Methods

FlexibleSerializationBinder Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : FlexibleSerializationBinder Class

For a list of all members of this type, see FlexibleSerializationBinder members.

Public Methods
 | Name | Description
Public Method | BindToName | (Inherited from System.Runtime.Serialization.SerializationBinder)
Public Method | BindToType | Overridden. Resolves the assembly name and type name to the type.
static (Shared in Visual Basic) | RegisterType | Registers type with the serialization binder so that it can be resolved faster from the type name.
Top
See Also

Reference

FlexibleSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


BindToType Method (FlexibleSerializationBinder)

BindToType Method (FlexibleSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > FlexibleSerializationBinder Class : BindToType Method
The name of assembly containing the type. Can be String.Empty.
The full name of the type.
Resolves the assembly name and type name to the type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function BindToType( _
   ByVal assemblyName As System.String, _
   ByVal typeName As System.String _
) As System.Type
'Usage

Dim instance As FlexibleSerializationBinder
Dim assemblyName As System.String
Dim typeName As System.String
Dim value As System.Type

value = instance.BindToType(assemblyName, typeName)
public override System.Type BindToType(
   System.string assemblyName,
   System.string typeName
)
public function BindToType(
    assemblyName: System.String;
    typeName: System.String
): System.Type; override;
public override function BindToType(
   assemblyName : System.String,
   typeName : System.String
) : System.Type;
public: System.Type* BindToType(
   System.string* assemblyName,
   System.string* typeName
) override
public:
System.Type^ BindToType(
   System.String^ assemblyName,
   System.String^ typeName
) override

Parameters

assemblyName
The name of assembly containing the type. Can be String.Empty.
typeName
The full name of the type.

Return Value

The type resolved from its name and name of assembly.
Remarks
In cases when name of assembly is ommited or when the specified assembly cannot be found, attempts to load the type from the currently executing assembly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Class
FlexibleSerializationBinder Members
Base Implementation in BindToType


RegisterType Method (FlexibleSerializationBinder)

RegisterType Method (FlexibleSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > FlexibleSerializationBinder Class : RegisterType Method
The type being registered.
Registers type with the serialization binder so that it can be resolved faster from the type name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterType( _
   ByVal type As System.Type _
)
'Usage

Dim type As System.Type

FlexibleSerializationBinder.RegisterType(type)
public static void RegisterType(
   System.Type type
)
public procedure RegisterType(
    type: System.Type
); static;
public static function RegisterType(
   type : System.Type
);
public: static void RegisterType(
   System.Type* type
)
public:
static void RegisterType(
   System.Type^ type
)

Parameters

type
The type being registered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Class
FlexibleSerializationBinder Members


JsonArrayContract Class

JsonArrayContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonArrayContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonArrayContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonArrayContract
   Inherits JsonContainerContract
'Usage

Dim instance As JsonArrayContract
public class JsonArrayContract : JsonContainerContract
public class JsonArrayContract = class(JsonContainerContract)
public class JsonArrayContract extends JsonContainerContract
public __gc class JsonArrayContract : public JsonContainerContract
public ref class JsonArrayContract : public JsonContainerContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonArrayContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonArrayContract Class Members

JsonArrayContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonArrayContract Class

The following tables list the members exposed by JsonArrayContract.

Public Constructors
 | Name | Description
Public Constructor | JsonArrayContract Constructor | Initializes a new instance of the JsonArrayContract class.
Top
Public Properties
 | Name | Description
Public Property | CollectionItemType | Gets the System.Type of the collection items.
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsMultidimensionalArray | Gets a value indicating whether the collection type is a multidimensional array.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonArrayContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonArrayContract Constructor

JsonArrayContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonArrayContract Class : JsonArrayContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonArrayContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonArrayContract(underlyingType)
public JsonArrayContract(
   System.Type underlyingType
)
public JsonArrayContract(
    underlyingType: System.Type
);
public function JsonArrayContract(
   underlyingType : System.Type
);
public: JsonArrayContract(
   System.Type* underlyingType
)
public:
JsonArrayContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayContract Class
JsonArrayContract Members


JsonArrayContract Class Properties

JsonArrayContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonArrayContract Class

For a list of all members of this type, see JsonArrayContract members.

Public Properties
 | Name | Description
Public Property | CollectionItemType | Gets the System.Type of the collection items.
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsMultidimensionalArray | Gets a value indicating whether the collection type is a multidimensional array.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonArrayContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


CollectionItemType Property (JsonArrayContract)

CollectionItemType Property (JsonArrayContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonArrayContract Class : CollectionItemType Property
Gets the System.Type of the collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CollectionItemType As System.Type
'Usage

Dim instance As JsonArrayContract
Dim value As System.Type

value = instance.CollectionItemType
public System.Type CollectionItemType {get;}
public read-only property CollectionItemType: System.Type;
public function get CollectionItemType : System.Type
public: __property System.Type* get_CollectionItemType();
public:
property System.Type^ CollectionItemType {
   System.Type^ get();
}

Property Value

The System.Type of the collection items.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayContract Class
JsonArrayContract Members


IsMultidimensionalArray Property (JsonArrayContract)

IsMultidimensionalArray Property (JsonArrayContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonArrayContract Class : IsMultidimensionalArray Property
Gets a value indicating whether the collection type is a multidimensional array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsMultidimensionalArray As System.Boolean
'Usage

Dim instance As JsonArrayContract
Dim value As System.Boolean

value = instance.IsMultidimensionalArray
public System.bool IsMultidimensionalArray {get;}
public read-only property IsMultidimensionalArray: System.Boolean;
public function get IsMultidimensionalArray : System.boolean
public: __property System.bool get_IsMultidimensionalArray();
public:
property System.bool IsMultidimensionalArray {
   System.bool get();
}

Property Value

true if the collection type is a multidimensional array; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayContract Class
JsonArrayContract Members


JsonContainerContract Class

JsonContainerContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContainerContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonContainerContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonContainerContract
   Inherits JsonContract
'Usage

Dim instance As JsonContainerContract
public class JsonContainerContract : JsonContract
public class JsonContainerContract = class(JsonContract)
public class JsonContainerContract extends JsonContract
public __gc class JsonContainerContract : public JsonContract
public ref class JsonContainerContract : public JsonContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonArrayContract
Noemax.Newtonsoft.Json.Serialization.JsonDictionaryContract
Noemax.Newtonsoft.Json.Serialization.JsonDynamicContract
Noemax.Newtonsoft.Json.Serialization.JsonISerializableContract
Noemax.Newtonsoft.Json.Serialization.JsonObjectContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonContainerContract Class Members

JsonContainerContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContainerContract Class

The following tables list the members exposed by JsonContainerContract.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter.
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references.
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling.
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonContainerContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonContainerContract Class Properties

JsonContainerContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContainerContract Class

For a list of all members of this type, see JsonContainerContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter.
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references.
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling.
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonContainerContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


ItemConverter Property (JsonContainerContract)

ItemConverter Property (JsonContainerContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContainerContract Class : ItemConverter Property
Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemConverter As JsonConverter
'Usage

Dim instance As JsonContainerContract
Dim value As JsonConverter

instance.ItemConverter = value

value = instance.ItemConverter
public JsonConverter ItemConverter {get; set;}
public read-write property ItemConverter: JsonConverter;
public function get,set ItemConverter : JsonConverter
public: __property JsonConverter* get_ItemConverter();
public: __property void set_ItemConverter(
   JsonConverter* value
);
public:
property JsonConverter^ ItemConverter {
   JsonConverter^ get();
   void set (    JsonConverter^ value);
}

Property Value

The converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerContract Class
JsonContainerContract Members


ItemIsReference Property (JsonContainerContract)

ItemIsReference Property (JsonContainerContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContainerContract Class : ItemIsReference Property
Gets or sets a value indicating whether the collection items preserve object references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemIsReference As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonContainerContract
Dim value As System.Nullable(Of Boolean)

instance.ItemIsReference = value

value = instance.ItemIsReference
public System.Nullable<bool> ItemIsReference {get; set;}
public read-write property ItemIsReference: System.Nullable;
public function get,set ItemIsReference : System.Nullable
public: __property System.Nullable<bool> get_ItemIsReference();
public: __property void set_ItemIsReference(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> ItemIsReference {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

true if collection items preserve object references; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerContract Class
JsonContainerContract Members


ItemReferenceLoopHandling Property (JsonContainerContract)

ItemReferenceLoopHandling Property (JsonContainerContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContainerContract Class : ItemReferenceLoopHandling Property
Gets or sets the collection item reference loop handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemReferenceLoopHandling As System.Nullable(Of ReferenceLoopHandling)
'Usage

Dim instance As JsonContainerContract
Dim value As System.Nullable(Of ReferenceLoopHandling)

instance.ItemReferenceLoopHandling = value

value = instance.ItemReferenceLoopHandling
public System.Nullable<ReferenceLoopHandling> ItemReferenceLoopHandling {get; set;}
public read-write property ItemReferenceLoopHandling: System.Nullable;
public function get,set ItemReferenceLoopHandling : System.Nullable
public: __property System.Nullable<ReferenceLoopHandling> get_ItemReferenceLoopHandling();
public: __property void set_ItemReferenceLoopHandling(
   System.Nullable<ReferenceLoopHandling> value
);
public:
property System.Nullable<ReferenceLoopHandling> ItemReferenceLoopHandling {
   System.Nullable<ReferenceLoopHandling> get();
   void set (    System.Nullable<ReferenceLoopHandling> value);
}

Property Value

The reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerContract Class
JsonContainerContract Members


ItemTypeNameHandling Property (JsonContainerContract)

ItemTypeNameHandling Property (JsonContainerContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContainerContract Class : ItemTypeNameHandling Property
Gets or sets the collection item type name handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemTypeNameHandling As System.Nullable(Of TypeNameHandling)
'Usage

Dim instance As JsonContainerContract
Dim value As System.Nullable(Of TypeNameHandling)

instance.ItemTypeNameHandling = value

value = instance.ItemTypeNameHandling
public System.Nullable<TypeNameHandling> ItemTypeNameHandling {get; set;}
public read-write property ItemTypeNameHandling: System.Nullable;
public function get,set ItemTypeNameHandling : System.Nullable
public: __property System.Nullable<TypeNameHandling> get_ItemTypeNameHandling();
public: __property void set_ItemTypeNameHandling(
   System.Nullable<TypeNameHandling> value
);
public:
property System.Nullable<TypeNameHandling> ItemTypeNameHandling {
   System.Nullable<TypeNameHandling> get();
   void set (    System.Nullable<TypeNameHandling> value);
}

Property Value

The type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerContract Class
JsonContainerContract Members


JsonContract Class

JsonContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class JsonContract
'Usage

Dim instance As JsonContract
public abstract class JsonContract
public class JsonContract abstract;
public abstract class JsonContract
public __gc abstract class JsonContract
public ref class JsonContract abstract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonLinqContract
Noemax.Newtonsoft.Json.Serialization.JsonPrimitiveContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonContract Class Members

JsonContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContract Class

The following tables list the members exposed by JsonContract.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract.
Public Property | CreatedType | Gets or sets the type created during deserialization.
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object.
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object.
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object.
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object.
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object.
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object.
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object.
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph.
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph.
Public Property | OnSerializing | Gets or sets the method called before serialization of the object.
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object.
Public Property | UnderlyingType | Gets the underlying type for the contract.
Top
See Also

Reference

JsonContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonContract Class Properties

JsonContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonContract Class

For a list of all members of this type, see JsonContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract.
Public Property | CreatedType | Gets or sets the type created during deserialization.
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object.
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object.
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object.
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object.
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object.
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object.
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object.
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph.
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph.
Public Property | OnSerializing | Gets or sets the method called before serialization of the object.
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object.
Public Property | UnderlyingType | Gets the underlying type for the contract.
Top
See Also

Reference

JsonContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


Converter Property (JsonContract)

Converter Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : Converter Property
Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Converter As JsonConverter
'Usage

Dim instance As JsonContract
Dim value As JsonConverter

instance.Converter = value

value = instance.Converter
public JsonConverter Converter {get; set;}
public read-write property Converter: JsonConverter;
public function get,set Converter : JsonConverter
public: __property JsonConverter* get_Converter();
public: __property void set_Converter(
   JsonConverter* value
);
public:
property JsonConverter^ Converter {
   JsonConverter^ get();
   void set (    JsonConverter^ value);
}

Property Value

The converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


CreatedType Property (JsonContract)

CreatedType Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : CreatedType Property
Gets or sets the type created during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CreatedType As System.Type
'Usage

Dim instance As JsonContract
Dim value As System.Type

instance.CreatedType = value

value = instance.CreatedType
public System.Type CreatedType {get; set;}
public read-write property CreatedType: System.Type;
public function get,set CreatedType : System.Type
public: __property System.Type* get_CreatedType();
public: __property void set_CreatedType(
   System.Type* value
);
public:
property System.Type^ CreatedType {
   System.Type^ get();
   void set (    System.Type^ value);
}

Property Value

The type created during deserialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


DefaultCreator Property (JsonContract)

DefaultCreator Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : DefaultCreator Property
Gets or sets the default creator method used to create the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultCreator As System.Func(Of Object)
'Usage

Dim instance As JsonContract
Dim value As System.Func(Of Object)

instance.DefaultCreator = value

value = instance.DefaultCreator
public System.Func<object> DefaultCreator {get; set;}
public read-write property DefaultCreator: System.Func;
public function get,set DefaultCreator : System.Func
public: __property System.Func<Object*>* get_DefaultCreator();
public: __property void set_DefaultCreator(
   System.Func<Object*>* value
);
public:
property System.Func<Object^>^ DefaultCreator {
   System.Func<Object^>^ get();
   void set (    System.Func<Object^>^ value);
}

Property Value

The default creator method used to create the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


DefaultCreatorNonPublic Property (JsonContract)

DefaultCreatorNonPublic Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : DefaultCreatorNonPublic Property
Gets or sets a value indicating whether the default creator is non public.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultCreatorNonPublic As System.Boolean
'Usage

Dim instance As JsonContract
Dim value As System.Boolean

instance.DefaultCreatorNonPublic = value

value = instance.DefaultCreatorNonPublic
public System.bool DefaultCreatorNonPublic {get; set;}
public read-write property DefaultCreatorNonPublic: System.Boolean;
public function get,set DefaultCreatorNonPublic : System.boolean
public: __property System.bool get_DefaultCreatorNonPublic();
public: __property void set_DefaultCreatorNonPublic(
   System.bool value
);
public:
property System.bool DefaultCreatorNonPublic {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if the default object creator is non-public; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


IsReference Property (JsonContract)

IsReference Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : IsReference Property
Gets or sets whether this type contract is serialized as a reference.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsReference As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonContract
Dim value As System.Nullable(Of Boolean)

instance.IsReference = value

value = instance.IsReference
public System.Nullable<bool> IsReference {get; set;}
public read-write property IsReference: System.Nullable;
public function get,set IsReference : System.Nullable
public: __property System.Nullable<bool> get_IsReference();
public: __property void set_IsReference(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> IsReference {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

Whether this type contract is serialized as a reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnDeserialized Property (JsonContract)

OnDeserialized Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnDeserialized Property
Gets or sets the method called immediately after deserialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnDeserializedCallbacks collection.")>
Public Property OnDeserialized As System.Reflection.MethodInfo
'Usage

Dim instance As JsonContract
Dim value As System.Reflection.MethodInfo

instance.OnDeserialized = value

value = instance.OnDeserialized
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializedCallbacks collection.")]
public System.Reflection.MethodInfo OnDeserialized {get; set;}
public read-write property OnDeserialized: System.Reflection.MethodInfo;
System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnDeserializedCallbacks collection.")
public function get,set OnDeserialized : System.Reflection.MethodInfo
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializedCallbacks collection.")]
public: __property System.Reflection.MethodInfo* get_OnDeserialized();
public: __property void set_OnDeserialized(
   System.Reflection.MethodInfo* value
);
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializedCallbacks collection.")]
public:
property System.Reflection.MethodInfo^ OnDeserialized {
   System.Reflection.MethodInfo^ get();
   void set (    System.Reflection.MethodInfo^ value);
}

Property Value

The method called immediately after deserialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnDeserializedCallbacks Property (JsonContract)

OnDeserializedCallbacks Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnDeserializedCallbacks Property
Gets or sets all methods called immediately after deserialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OnDeserializedCallbacks As System.Collections.Generic.IList(Of SerializationCallback)
'Usage

Dim instance As JsonContract
Dim value As System.Collections.Generic.IList(Of SerializationCallback)

value = instance.OnDeserializedCallbacks
public System.Collections.Generic.IList<SerializationCallback> OnDeserializedCallbacks {get;}
public read-only property OnDeserializedCallbacks: System.Collections.Generic.IList;
public function get OnDeserializedCallbacks : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<SerializationCallback*>* get_OnDeserializedCallbacks();
public:
property System.Collections.Generic.IList<SerializationCallback^>^ OnDeserializedCallbacks {
   System.Collections.Generic.IList<SerializationCallback^>^ get();
}

Property Value

The methods called immediately after deserialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnDeserializing Property (JsonContract)

OnDeserializing Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnDeserializing Property
Gets or sets the method called during deserialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnDeserializingCallbacks collection.")>
Public Property OnDeserializing As System.Reflection.MethodInfo
'Usage

Dim instance As JsonContract
Dim value As System.Reflection.MethodInfo

instance.OnDeserializing = value

value = instance.OnDeserializing
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializingCallbacks collection.")]
public System.Reflection.MethodInfo OnDeserializing {get; set;}
public read-write property OnDeserializing: System.Reflection.MethodInfo;
System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnDeserializingCallbacks collection.")
public function get,set OnDeserializing : System.Reflection.MethodInfo
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializingCallbacks collection.")]
public: __property System.Reflection.MethodInfo* get_OnDeserializing();
public: __property void set_OnDeserializing(
   System.Reflection.MethodInfo* value
);
[System.Obsolete("This property is obsolete and has been replaced by the OnDeserializingCallbacks collection.")]
public:
property System.Reflection.MethodInfo^ OnDeserializing {
   System.Reflection.MethodInfo^ get();
   void set (    System.Reflection.MethodInfo^ value);
}

Property Value

The method called during deserialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnDeserializingCallbacks Property (JsonContract)

OnDeserializingCallbacks Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnDeserializingCallbacks Property
Gets or sets all methods called during deserialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OnDeserializingCallbacks As System.Collections.Generic.IList(Of SerializationCallback)
'Usage

Dim instance As JsonContract
Dim value As System.Collections.Generic.IList(Of SerializationCallback)

value = instance.OnDeserializingCallbacks
public System.Collections.Generic.IList<SerializationCallback> OnDeserializingCallbacks {get;}
public read-only property OnDeserializingCallbacks: System.Collections.Generic.IList;
public function get OnDeserializingCallbacks : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<SerializationCallback*>* get_OnDeserializingCallbacks();
public:
property System.Collections.Generic.IList<SerializationCallback^>^ OnDeserializingCallbacks {
   System.Collections.Generic.IList<SerializationCallback^>^ get();
}

Property Value

The methods called during deserialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnError Property (JsonContract)

OnError Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnError Property
Gets or sets the method called when an error is thrown during the serialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnErrorCallbacks collection.")>
Public Property OnError As System.Reflection.MethodInfo
'Usage

Dim instance As JsonContract
Dim value As System.Reflection.MethodInfo

instance.OnError = value

value = instance.OnError
[System.Obsolete("This property is obsolete and has been replaced by the OnErrorCallbacks collection.")]
public System.Reflection.MethodInfo OnError {get; set;}
public read-write property OnError: System.Reflection.MethodInfo;
System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnErrorCallbacks collection.")
public function get,set OnError : System.Reflection.MethodInfo
[System.Obsolete("This property is obsolete and has been replaced by the OnErrorCallbacks collection.")]
public: __property System.Reflection.MethodInfo* get_OnError();
public: __property void set_OnError(
   System.Reflection.MethodInfo* value
);
[System.Obsolete("This property is obsolete and has been replaced by the OnErrorCallbacks collection.")]
public:
property System.Reflection.MethodInfo^ OnError {
   System.Reflection.MethodInfo^ get();
   void set (    System.Reflection.MethodInfo^ value);
}

Property Value

The method called when an error is thrown during the serialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnErrorCallbacks Property (JsonContract)

OnErrorCallbacks Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnErrorCallbacks Property
Gets or sets all method called when an error is thrown during the serialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OnErrorCallbacks As System.Collections.Generic.IList(Of SerializationErrorCallback)
'Usage

Dim instance As JsonContract
Dim value As System.Collections.Generic.IList(Of SerializationErrorCallback)

value = instance.OnErrorCallbacks
public System.Collections.Generic.IList<SerializationErrorCallback> OnErrorCallbacks {get;}
public read-only property OnErrorCallbacks: System.Collections.Generic.IList;
public function get OnErrorCallbacks : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<SerializationErrorCallback*>* get_OnErrorCallbacks();
public:
property System.Collections.Generic.IList<SerializationErrorCallback^>^ OnErrorCallbacks {
   System.Collections.Generic.IList<SerializationErrorCallback^>^ get();
}

Property Value

The methods called when an error is thrown during the serialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnSerialized Property (JsonContract)

OnSerialized Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnSerialized Property
Gets or sets the method called after serialization of the object graph.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnSerializedCallbacks collection.")>
Public Property OnSerialized As System.Reflection.MethodInfo
'Usage

Dim instance As JsonContract
Dim value As System.Reflection.MethodInfo

instance.OnSerialized = value

value = instance.OnSerialized
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializedCallbacks collection.")]
public System.Reflection.MethodInfo OnSerialized {get; set;}
public read-write property OnSerialized: System.Reflection.MethodInfo;
System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnSerializedCallbacks collection.")
public function get,set OnSerialized : System.Reflection.MethodInfo
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializedCallbacks collection.")]
public: __property System.Reflection.MethodInfo* get_OnSerialized();
public: __property void set_OnSerialized(
   System.Reflection.MethodInfo* value
);
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializedCallbacks collection.")]
public:
property System.Reflection.MethodInfo^ OnSerialized {
   System.Reflection.MethodInfo^ get();
   void set (    System.Reflection.MethodInfo^ value);
}

Property Value

The method called after serialization of the object graph.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnSerializedCallbacks Property (JsonContract)

OnSerializedCallbacks Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnSerializedCallbacks Property
Gets or sets all methods called after serialization of the object graph.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OnSerializedCallbacks As System.Collections.Generic.IList(Of SerializationCallback)
'Usage

Dim instance As JsonContract
Dim value As System.Collections.Generic.IList(Of SerializationCallback)

value = instance.OnSerializedCallbacks
public System.Collections.Generic.IList<SerializationCallback> OnSerializedCallbacks {get;}
public read-only property OnSerializedCallbacks: System.Collections.Generic.IList;
public function get OnSerializedCallbacks : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<SerializationCallback*>* get_OnSerializedCallbacks();
public:
property System.Collections.Generic.IList<SerializationCallback^>^ OnSerializedCallbacks {
   System.Collections.Generic.IList<SerializationCallback^>^ get();
}

Property Value

The methods called after serialization of the object graph.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnSerializing Property (JsonContract)

OnSerializing Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnSerializing Property
Gets or sets the method called before serialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnSerializingCallbacks collection.")>
Public Property OnSerializing As System.Reflection.MethodInfo
'Usage

Dim instance As JsonContract
Dim value As System.Reflection.MethodInfo

instance.OnSerializing = value

value = instance.OnSerializing
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializingCallbacks collection.")]
public System.Reflection.MethodInfo OnSerializing {get; set;}
public read-write property OnSerializing: System.Reflection.MethodInfo;
System.ObsoleteAttribute("This property is obsolete and has been replaced by the OnSerializingCallbacks collection.")
public function get,set OnSerializing : System.Reflection.MethodInfo
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializingCallbacks collection.")]
public: __property System.Reflection.MethodInfo* get_OnSerializing();
public: __property void set_OnSerializing(
   System.Reflection.MethodInfo* value
);
[System.Obsolete("This property is obsolete and has been replaced by the OnSerializingCallbacks collection.")]
public:
property System.Reflection.MethodInfo^ OnSerializing {
   System.Reflection.MethodInfo^ get();
   void set (    System.Reflection.MethodInfo^ value);
}

Property Value

The method called before serialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


OnSerializingCallbacks Property (JsonContract)

OnSerializingCallbacks Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : OnSerializingCallbacks Property
Gets or sets all methods called before serialization of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OnSerializingCallbacks As System.Collections.Generic.IList(Of SerializationCallback)
'Usage

Dim instance As JsonContract
Dim value As System.Collections.Generic.IList(Of SerializationCallback)

value = instance.OnSerializingCallbacks
public System.Collections.Generic.IList<SerializationCallback> OnSerializingCallbacks {get;}
public read-only property OnSerializingCallbacks: System.Collections.Generic.IList;
public function get OnSerializingCallbacks : System.Collections.Generic.IList
public: __property System.Collections.Generic.IList<SerializationCallback*>* get_OnSerializingCallbacks();
public:
property System.Collections.Generic.IList<SerializationCallback^>^ OnSerializingCallbacks {
   System.Collections.Generic.IList<SerializationCallback^>^ get();
}

Property Value

The methods called before serialization of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


UnderlyingType Property (JsonContract)

UnderlyingType Property (JsonContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonContract Class : UnderlyingType Property
Gets the underlying type for the contract.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property UnderlyingType As System.Type
'Usage

Dim instance As JsonContract
Dim value As System.Type

value = instance.UnderlyingType
public System.Type UnderlyingType {get;}
public read-only property UnderlyingType: System.Type;
public function get UnderlyingType : System.Type
public: __property System.Type* get_UnderlyingType();
public:
property System.Type^ UnderlyingType {
   System.Type^ get();
}

Property Value

The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContract Class
JsonContract Members


JsonDictionaryContract Class

JsonDictionaryContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDictionaryContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonDictionaryContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonDictionaryContract
   Inherits JsonContainerContract
'Usage

Dim instance As JsonDictionaryContract
public class JsonDictionaryContract : JsonContainerContract
public class JsonDictionaryContract = class(JsonContainerContract)
public class JsonDictionaryContract extends JsonContainerContract
public __gc class JsonDictionaryContract : public JsonContainerContract
public ref class JsonDictionaryContract : public JsonContainerContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonDictionaryContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonDictionaryContract Class Members

JsonDictionaryContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDictionaryContract Class

The following tables list the members exposed by JsonDictionaryContract.

Public Constructors
 | Name | Description
Public Constructor | JsonDictionaryContract Constructor | Initializes a new instance of the JsonDictionaryContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DictionaryKeyType | Gets the System.Type of the dictionary keys.
Public Property | DictionaryValueType | Gets the System.Type of the dictionary values.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | PropertyNameResolver | Gets or sets the property name resolver.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonDictionaryContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonDictionaryContract Constructor

JsonDictionaryContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDictionaryContract Class : JsonDictionaryContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonDictionaryContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonDictionaryContract(underlyingType)
public JsonDictionaryContract(
   System.Type underlyingType
)
public JsonDictionaryContract(
    underlyingType: System.Type
);
public function JsonDictionaryContract(
   underlyingType : System.Type
);
public: JsonDictionaryContract(
   System.Type* underlyingType
)
public:
JsonDictionaryContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryContract Class
JsonDictionaryContract Members


JsonDictionaryContract Class Properties

JsonDictionaryContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDictionaryContract Class

For a list of all members of this type, see JsonDictionaryContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DictionaryKeyType | Gets the System.Type of the dictionary keys.
Public Property | DictionaryValueType | Gets the System.Type of the dictionary values.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | PropertyNameResolver | Gets or sets the property name resolver.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonDictionaryContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


DictionaryKeyType Property (JsonDictionaryContract)

DictionaryKeyType Property (JsonDictionaryContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDictionaryContract Class : DictionaryKeyType Property
Gets the System.Type of the dictionary keys.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DictionaryKeyType As System.Type
'Usage

Dim instance As JsonDictionaryContract
Dim value As System.Type

value = instance.DictionaryKeyType
public System.Type DictionaryKeyType {get;}
public read-only property DictionaryKeyType: System.Type;
public function get DictionaryKeyType : System.Type
public: __property System.Type* get_DictionaryKeyType();
public:
property System.Type^ DictionaryKeyType {
   System.Type^ get();
}

Property Value

The System.Type of the dictionary keys.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryContract Class
JsonDictionaryContract Members


DictionaryValueType Property (JsonDictionaryContract)

DictionaryValueType Property (JsonDictionaryContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDictionaryContract Class : DictionaryValueType Property
Gets the System.Type of the dictionary values.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property DictionaryValueType As System.Type
'Usage

Dim instance As JsonDictionaryContract
Dim value As System.Type

value = instance.DictionaryValueType
public System.Type DictionaryValueType {get;}
public read-only property DictionaryValueType: System.Type;
public function get DictionaryValueType : System.Type
public: __property System.Type* get_DictionaryValueType();
public:
property System.Type^ DictionaryValueType {
   System.Type^ get();
}

Property Value

The System.Type of the dictionary values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryContract Class
JsonDictionaryContract Members


PropertyNameResolver Property (JsonDictionaryContract)

PropertyNameResolver Property (JsonDictionaryContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDictionaryContract Class : PropertyNameResolver Property
Gets or sets the property name resolver.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PropertyNameResolver As System.Func(Of String,String)
'Usage

Dim instance As JsonDictionaryContract
Dim value As System.Func(Of String,String)

instance.PropertyNameResolver = value

value = instance.PropertyNameResolver
public System.Func<string,string> PropertyNameResolver {get; set;}
public read-write property PropertyNameResolver: System.Func;
public function get,set PropertyNameResolver : System.Func
public: __property System.Func<string*,string*>* get_PropertyNameResolver();
public: __property void set_PropertyNameResolver(
   System.Func<string*,string*>* value
);
public:
property System.Func<String^,String^>^ PropertyNameResolver {
   System.Func<String^,String^>^ get();
   void set (    System.Func<String^,String^>^ value);
}

Property Value

The property name resolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryContract Class
JsonDictionaryContract Members


JsonISerializableContract Class

JsonISerializableContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonISerializableContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonISerializableContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonISerializableContract
   Inherits JsonContainerContract
'Usage

Dim instance As JsonISerializableContract
public class JsonISerializableContract : JsonContainerContract
public class JsonISerializableContract = class(JsonContainerContract)
public class JsonISerializableContract extends JsonContainerContract
public __gc class JsonISerializableContract : public JsonContainerContract
public ref class JsonISerializableContract : public JsonContainerContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonISerializableContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonISerializableContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonISerializableContract Class Members

JsonISerializableContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonISerializableContract Class

The following tables list the members exposed by JsonISerializableContract.

Public Constructors
 | Name | Description
Public Constructor | JsonISerializableContract Constructor | Initializes a new instance of the JsonISerializableContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ISerializableCreator | Gets or sets the ISerializable object constructor.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonISerializableContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonISerializableContract Constructor

JsonISerializableContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonISerializableContract Class : JsonISerializableContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonISerializableContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonISerializableContract(underlyingType)
public JsonISerializableContract(
   System.Type underlyingType
)
public JsonISerializableContract(
    underlyingType: System.Type
);
public function JsonISerializableContract(
   underlyingType : System.Type
);
public: JsonISerializableContract(
   System.Type* underlyingType
)
public:
JsonISerializableContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonISerializableContract Class
JsonISerializableContract Members


JsonISerializableContract Class Properties

JsonISerializableContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonISerializableContract Class

For a list of all members of this type, see JsonISerializableContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ISerializableCreator | Gets or sets the ISerializable object constructor.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonISerializableContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


ISerializableCreator Property (JsonISerializableContract)

ISerializableCreator Property (JsonISerializableContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonISerializableContract Class : ISerializableCreator Property
Gets or sets the ISerializable object constructor.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ISerializableCreator As Noemax.Newtonsoft.Json.Serialization.ObjectConstructor(Of Object)
'Usage

Dim instance As JsonISerializableContract
Dim value As Noemax.Newtonsoft.Json.Serialization.ObjectConstructor(Of Object)

instance.ISerializableCreator = value

value = instance.ISerializableCreator
public Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<object> ISerializableCreator {get; set;}
public read-write property ISerializableCreator: Noemax.Newtonsoft.Json.Serialization.ObjectConstructor;
public function get,set ISerializableCreator : Noemax.Newtonsoft.Json.Serialization.ObjectConstructor
public: __property Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<Object*>* get_ISerializableCreator();
public: __property void set_ISerializableCreator(
   Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<Object*>* value
);
public:
property Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<Object^>^ ISerializableCreator {
   Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<Object^>^ get();
   void set (    Noemax.Newtonsoft.Json.Serialization.ObjectConstructor<Object^>^ value);
}

Property Value

The ISerializable object constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonISerializableContract Class
JsonISerializableContract Members


JsonLinqContract Class

JsonLinqContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonLinqContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonLinqContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonLinqContract
   Inherits JsonContract
'Usage

Dim instance As JsonLinqContract
public class JsonLinqContract : JsonContract
public class JsonLinqContract = class(JsonContract)
public class JsonLinqContract extends JsonContract
public __gc class JsonLinqContract : public JsonContract
public ref class JsonLinqContract : public JsonContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonLinqContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonLinqContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonLinqContract Class Members

JsonLinqContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonLinqContract Class

The following tables list the members exposed by JsonLinqContract.

Public Constructors
 | Name | Description
Public Constructor | JsonLinqContract Constructor | Initializes a new instance of the JsonLinqContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonLinqContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonLinqContract Constructor

JsonLinqContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonLinqContract Class : JsonLinqContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonLinqContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonLinqContract(underlyingType)
public JsonLinqContract(
   System.Type underlyingType
)
public JsonLinqContract(
    underlyingType: System.Type
);
public function JsonLinqContract(
   underlyingType : System.Type
);
public: JsonLinqContract(
   System.Type* underlyingType
)
public:
JsonLinqContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonLinqContract Class
JsonLinqContract Members


JsonObjectContract Class

JsonObjectContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonObjectContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonObjectContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonObjectContract
   Inherits JsonContainerContract
'Usage

Dim instance As JsonObjectContract
public class JsonObjectContract : JsonContainerContract
public class JsonObjectContract = class(JsonContainerContract)
public class JsonObjectContract extends JsonContainerContract
public __gc class JsonObjectContract : public JsonContainerContract
public ref class JsonObjectContract : public JsonContainerContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonObjectContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonObjectContract Class Members

JsonObjectContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonObjectContract Class

The following tables list the members exposed by JsonObjectContract.

Public Constructors
 | Name | Description
Public Constructor | JsonObjectContract Constructor | Initializes a new instance of the JsonObjectContract class.
Top
Public Properties
 | Name | Description
Public Property | ConstructorParameters | Gets the constructor parameters required for any non-default constructor
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ExtensionDataGetter | Gets or sets the extension data getter.
Public Property | ExtensionDataSetter | Gets or sets the extension data setter.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemRequired | Gets or sets a value that indicates whether the object's properties are required.
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | MemberSerialization | Gets or sets the object member serialization.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OverrideConstructor | Gets or sets the override constructor used to create the object. This is set when a constructor is marked up using the JsonConstructor attribute.
Public Property | ParametrizedConstructor | Gets or sets the parametrized constructor used to create the object.
Public Property | Properties | Gets the object's properties.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonObjectContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonObjectContract Constructor

JsonObjectContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : JsonObjectContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonObjectContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonObjectContract(underlyingType)
public JsonObjectContract(
   System.Type underlyingType
)
public JsonObjectContract(
    underlyingType: System.Type
);
public function JsonObjectContract(
   underlyingType : System.Type
);
public: JsonObjectContract(
   System.Type* underlyingType
)
public:
JsonObjectContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


JsonObjectContract Class Properties

JsonObjectContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonObjectContract Class

For a list of all members of this type, see JsonObjectContract members.

Public Properties
 | Name | Description
Public Property | ConstructorParameters | Gets the constructor parameters required for any non-default constructor
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ExtensionDataGetter | Gets or sets the extension data getter.
Public Property | ExtensionDataSetter | Gets or sets the extension data setter.
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemRequired | Gets or sets a value that indicates whether the object's properties are required.
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | MemberSerialization | Gets or sets the object member serialization.
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OverrideConstructor | Gets or sets the override constructor used to create the object. This is set when a constructor is marked up using the JsonConstructor attribute.
Public Property | ParametrizedConstructor | Gets or sets the parametrized constructor used to create the object.
Public Property | Properties | Gets the object's properties.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonObjectContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


ConstructorParameters Property (JsonObjectContract)

ConstructorParameters Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : ConstructorParameters Property
Gets the constructor parameters required for any non-default constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ConstructorParameters As JsonPropertyCollection
'Usage

Dim instance As JsonObjectContract
Dim value As JsonPropertyCollection

value = instance.ConstructorParameters
public JsonPropertyCollection ConstructorParameters {get;}
public read-only property ConstructorParameters: JsonPropertyCollection;
public function get ConstructorParameters : JsonPropertyCollection
public: __property JsonPropertyCollection* get_ConstructorParameters();
public:
property JsonPropertyCollection^ ConstructorParameters {
   JsonPropertyCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


ExtensionDataGetter Property (JsonObjectContract)

ExtensionDataGetter Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : ExtensionDataGetter Property
Gets or sets the extension data getter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtensionDataGetter As ExtensionDataGetter
'Usage

Dim instance As JsonObjectContract
Dim value As ExtensionDataGetter

instance.ExtensionDataGetter = value

value = instance.ExtensionDataGetter
public ExtensionDataGetter ExtensionDataGetter {get; set;}
public read-write property ExtensionDataGetter: ExtensionDataGetter;
public function get,set ExtensionDataGetter : ExtensionDataGetter
public: __property ExtensionDataGetter* get_ExtensionDataGetter();
public: __property void set_ExtensionDataGetter(
   ExtensionDataGetter* value
);
public:
property ExtensionDataGetter^ ExtensionDataGetter {
   ExtensionDataGetter^ get();
   void set (    ExtensionDataGetter^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


ExtensionDataSetter Property (JsonObjectContract)

ExtensionDataSetter Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : ExtensionDataSetter Property
Gets or sets the extension data setter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ExtensionDataSetter As ExtensionDataSetter
'Usage

Dim instance As JsonObjectContract
Dim value As ExtensionDataSetter

instance.ExtensionDataSetter = value

value = instance.ExtensionDataSetter
public ExtensionDataSetter ExtensionDataSetter {get; set;}
public read-write property ExtensionDataSetter: ExtensionDataSetter;
public function get,set ExtensionDataSetter : ExtensionDataSetter
public: __property ExtensionDataSetter* get_ExtensionDataSetter();
public: __property void set_ExtensionDataSetter(
   ExtensionDataSetter* value
);
public:
property ExtensionDataSetter^ ExtensionDataSetter {
   ExtensionDataSetter^ get();
   void set (    ExtensionDataSetter^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


ItemRequired Property (JsonObjectContract)

ItemRequired Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : ItemRequired Property
Gets or sets a value that indicates whether the object's properties are required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemRequired As System.Nullable(Of Required)
'Usage

Dim instance As JsonObjectContract
Dim value As System.Nullable(Of Required)

instance.ItemRequired = value

value = instance.ItemRequired
public System.Nullable<Required> ItemRequired {get; set;}
public read-write property ItemRequired: System.Nullable;
public function get,set ItemRequired : System.Nullable
public: __property System.Nullable<Required> get_ItemRequired();
public: __property void set_ItemRequired(
   System.Nullable<Required> value
);
public:
property System.Nullable<Required> ItemRequired {
   System.Nullable<Required> get();
   void set (    System.Nullable<Required> value);
}

Property Value

A value indicating whether the object's properties are required.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


MemberSerialization Property (JsonObjectContract)

MemberSerialization Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : MemberSerialization Property
Gets or sets the object member serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MemberSerialization As MemberSerialization
'Usage

Dim instance As JsonObjectContract
Dim value As MemberSerialization

instance.MemberSerialization = value

value = instance.MemberSerialization
public MemberSerialization MemberSerialization {get; set;}
public read-write property MemberSerialization: MemberSerialization;
public function get,set MemberSerialization : MemberSerialization
public: __property MemberSerialization get_MemberSerialization();
public: __property void set_MemberSerialization(
   MemberSerialization value
);
public:
property MemberSerialization MemberSerialization {
   MemberSerialization get();
   void set (    MemberSerialization value);
}

Property Value

The member object serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


OverrideConstructor Property (JsonObjectContract)

OverrideConstructor Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : OverrideConstructor Property
Gets or sets the override constructor used to create the object. This is set when a constructor is marked up using the JsonConstructor attribute.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property OverrideConstructor As System.Reflection.ConstructorInfo
'Usage

Dim instance As JsonObjectContract
Dim value As System.Reflection.ConstructorInfo

instance.OverrideConstructor = value

value = instance.OverrideConstructor
public System.Reflection.ConstructorInfo OverrideConstructor {get; set;}
public read-write property OverrideConstructor: System.Reflection.ConstructorInfo;
public function get,set OverrideConstructor : System.Reflection.ConstructorInfo
public: __property System.Reflection.ConstructorInfo* get_OverrideConstructor();
public: __property void set_OverrideConstructor(
   System.Reflection.ConstructorInfo* value
);
public:
property System.Reflection.ConstructorInfo^ OverrideConstructor {
   System.Reflection.ConstructorInfo^ get();
   void set (    System.Reflection.ConstructorInfo^ value);
}

Property Value

The override constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


ParametrizedConstructor Property (JsonObjectContract)

ParametrizedConstructor Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : ParametrizedConstructor Property
Gets or sets the parametrized constructor used to create the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ParametrizedConstructor As System.Reflection.ConstructorInfo
'Usage

Dim instance As JsonObjectContract
Dim value As System.Reflection.ConstructorInfo

instance.ParametrizedConstructor = value

value = instance.ParametrizedConstructor
public System.Reflection.ConstructorInfo ParametrizedConstructor {get; set;}
public read-write property ParametrizedConstructor: System.Reflection.ConstructorInfo;
public function get,set ParametrizedConstructor : System.Reflection.ConstructorInfo
public: __property System.Reflection.ConstructorInfo* get_ParametrizedConstructor();
public: __property void set_ParametrizedConstructor(
   System.Reflection.ConstructorInfo* value
);
public:
property System.Reflection.ConstructorInfo^ ParametrizedConstructor {
   System.Reflection.ConstructorInfo^ get();
   void set (    System.Reflection.ConstructorInfo^ value);
}

Property Value

The parametrized constructor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


Properties Property (JsonObjectContract)

Properties Property (JsonObjectContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonObjectContract Class : Properties Property
Gets the object's properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Properties As JsonPropertyCollection
'Usage

Dim instance As JsonObjectContract
Dim value As JsonPropertyCollection

value = instance.Properties
public JsonPropertyCollection Properties {get;}
public read-only property Properties: JsonPropertyCollection;
public function get Properties : JsonPropertyCollection
public: __property JsonPropertyCollection* get_Properties();
public:
property JsonPropertyCollection^ Properties {
   JsonPropertyCollection^ get();
}

Property Value

The object's properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectContract Class
JsonObjectContract Members


JsonPrimitiveContract Class

JsonPrimitiveContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPrimitiveContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonPrimitiveContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonPrimitiveContract
   Inherits JsonContract
'Usage

Dim instance As JsonPrimitiveContract
public class JsonPrimitiveContract : JsonContract
public class JsonPrimitiveContract = class(JsonContract)
public class JsonPrimitiveContract extends JsonContract
public __gc class JsonPrimitiveContract : public JsonContract
public ref class JsonPrimitiveContract : public JsonContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonPrimitiveContract
Noemax.Newtonsoft.Json.Serialization.JsonStringContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPrimitiveContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPrimitiveContract Class Members

JsonPrimitiveContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPrimitiveContract Class

The following tables list the members exposed by JsonPrimitiveContract.

Public Constructors
 | Name | Description
Public Constructor | JsonPrimitiveContract Constructor | Initializes a new instance of the JsonPrimitiveContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonPrimitiveContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPrimitiveContract Constructor

JsonPrimitiveContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPrimitiveContract Class : JsonPrimitiveContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonPrimitiveContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonPrimitiveContract(underlyingType)
public JsonPrimitiveContract(
   System.Type underlyingType
)
public JsonPrimitiveContract(
    underlyingType: System.Type
);
public function JsonPrimitiveContract(
   underlyingType : System.Type
);
public: JsonPrimitiveContract(
   System.Type* underlyingType
)
public:
JsonPrimitiveContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPrimitiveContract Class
JsonPrimitiveContract Members


JsonProperty Class

JsonProperty Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonProperty Class
Maps a JSON property to a .NET member or constructor parameter.
Object Model
JsonProperty Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonProperty
'Usage

Dim instance As JsonProperty
public class JsonProperty
public class JsonProperty
public class JsonProperty
public __gc class JsonProperty
public ref class JsonProperty
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonProperty Class Members

JsonProperty Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : JsonProperty Class

The following tables list the members exposed by JsonProperty.

Public Constructors
 | Name | Description
Public Constructor | JsonProperty Constructor |
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the Noemax.Newtonsoft.Json.JsonConverter for the property. If set this converter takes presidence over the contract converter for the property type.
Public Property | DeclaringType | Gets or sets the type that declared this property.
Public Property | DefaultValue | Gets the default value.
Public Property | DefaultValueHandling | Gets or sets the property default value handling.
Public Property | GetIsSpecified | Gets or sets a predicate used to determine whether the property should be serialized.
Public Property | HasMemberAttribute | Gets or sets a value indicating whether this JsonProperty has a member attribute.
Public Property | Ignored | Gets or sets a value indicating whether this JsonProperty is ignored.
Public Property | IsReference | Gets or sets a value indicating whether this property preserves object references.
Public Property | ItemConverter | Gets or sets the converter used when serializing the property's collection items.
Public Property | ItemIsReference | Gets or sets whether this property's collection items are serialized as a reference.
Public Property | ItemReferenceLoopHandling | Gets or sets the the reference loop handling used when serializing the property's collection items.
Public Property | ItemTypeNameHandling | Gets or sets the the type name handling used when serializing the property's collection items.
Public Property | MemberConverter | Gets or sets the member converter.
Public Property | NullValueHandling | Gets or sets the property null value handling.
Public Property | ObjectCreationHandling | Gets or sets the property object creation handling.
Public Property | Order | Gets or sets the order of serialization and deserialization of a member.
Public Property | PropertyName | Gets or sets the name of the property.
Public Property | PropertyType | Gets or sets the type of the property.
Public Property | Readable | Gets or sets a value indicating whether this JsonProperty is readable.
Public Property | ReferenceLoopHandling | Gets or sets the property reference loop handling.
Public Property | Required | Gets or sets a value indicating whether this JsonProperty is required.
Public Property | SetIsSpecified | Gets or sets an action used to set whether the property has been deserialized.
Public Property | ShouldSerialize | Gets or sets a predicate used to determine whether the property should be serialize.
Public Property | TypeNameHandling | Gets or sets or sets the type name handling.
Public Property | UnderlyingName | Gets or sets the name of the underlying member or parameter.
Public Property | ValueProvider | Gets the IValueProvider that will get and set the JsonProperty during serialization.
Public Property | Writable | Gets or sets a value indicating whether this JsonProperty is writable.
Top
Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

JsonProperty Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonProperty Constructor

JsonProperty Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : JsonProperty Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonProperty()
public JsonProperty()
public JsonProperty();
public function JsonProperty();
public: JsonProperty();
public:
JsonProperty();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


JsonProperty Class Methods

JsonProperty Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : JsonProperty Class

For a list of all members of this type, see JsonProperty members.

Public Methods
 | Name | Description
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

JsonProperty Class
Noemax.Newtonsoft.Json.Serialization Namespace


ToString Method (JsonProperty)

ToString Method (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As System.String
'Usage

Dim instance As JsonProperty
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public function ToString(): System.String; override;
public override function ToString() : System.String;
public: System.string* ToString(); override
public:
System.String^ ToString(); override

Return Value

A System.String that represents this instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members
Base Implementation in ToString


JsonProperty Class Properties

JsonProperty Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonProperty Class

For a list of all members of this type, see JsonProperty members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the Noemax.Newtonsoft.Json.JsonConverter for the property. If set this converter takes presidence over the contract converter for the property type.
Public Property | DeclaringType | Gets or sets the type that declared this property.
Public Property | DefaultValue | Gets the default value.
Public Property | DefaultValueHandling | Gets or sets the property default value handling.
Public Property | GetIsSpecified | Gets or sets a predicate used to determine whether the property should be serialized.
Public Property | HasMemberAttribute | Gets or sets a value indicating whether this JsonProperty has a member attribute.
Public Property | Ignored | Gets or sets a value indicating whether this JsonProperty is ignored.
Public Property | IsReference | Gets or sets a value indicating whether this property preserves object references.
Public Property | ItemConverter | Gets or sets the converter used when serializing the property's collection items.
Public Property | ItemIsReference | Gets or sets whether this property's collection items are serialized as a reference.
Public Property | ItemReferenceLoopHandling | Gets or sets the the reference loop handling used when serializing the property's collection items.
Public Property | ItemTypeNameHandling | Gets or sets the the type name handling used when serializing the property's collection items.
Public Property | MemberConverter | Gets or sets the member converter.
Public Property | NullValueHandling | Gets or sets the property null value handling.
Public Property | ObjectCreationHandling | Gets or sets the property object creation handling.
Public Property | Order | Gets or sets the order of serialization and deserialization of a member.
Public Property | PropertyName | Gets or sets the name of the property.
Public Property | PropertyType | Gets or sets the type of the property.
Public Property | Readable | Gets or sets a value indicating whether this JsonProperty is readable.
Public Property | ReferenceLoopHandling | Gets or sets the property reference loop handling.
Public Property | Required | Gets or sets a value indicating whether this JsonProperty is required.
Public Property | SetIsSpecified | Gets or sets an action used to set whether the property has been deserialized.
Public Property | ShouldSerialize | Gets or sets a predicate used to determine whether the property should be serialize.
Public Property | TypeNameHandling | Gets or sets or sets the type name handling.
Public Property | UnderlyingName | Gets or sets the name of the underlying member or parameter.
Public Property | ValueProvider | Gets the IValueProvider that will get and set the JsonProperty during serialization.
Public Property | Writable | Gets or sets a value indicating whether this JsonProperty is writable.
Top
See Also

Reference

JsonProperty Class
Noemax.Newtonsoft.Json.Serialization Namespace


Converter Property (JsonProperty)

Converter Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Converter Property
Gets or sets the Noemax.Newtonsoft.Json.JsonConverter for the property. If set this converter takes presidence over the contract converter for the property type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Converter As JsonConverter
'Usage

Dim instance As JsonProperty
Dim value As JsonConverter

instance.Converter = value

value = instance.Converter
public JsonConverter Converter {get; set;}
public read-write property Converter: JsonConverter;
public function get,set Converter : JsonConverter
public: __property JsonConverter* get_Converter();
public: __property void set_Converter(
   JsonConverter* value
);
public:
property JsonConverter^ Converter {
   JsonConverter^ get();
   void set (    JsonConverter^ value);
}

Property Value

The converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


DeclaringType Property (JsonProperty)

DeclaringType Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : DeclaringType Property
Gets or sets the type that declared this property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DeclaringType As System.Type
'Usage

Dim instance As JsonProperty
Dim value As System.Type

instance.DeclaringType = value

value = instance.DeclaringType
public System.Type DeclaringType {get; set;}
public read-write property DeclaringType: System.Type;
public function get,set DeclaringType : System.Type
public: __property System.Type* get_DeclaringType();
public: __property void set_DeclaringType(
   System.Type* value
);
public:
property System.Type^ DeclaringType {
   System.Type^ get();
   void set (    System.Type^ value);
}

Property Value

The type that declared this property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


DefaultValue Property (JsonProperty)

DefaultValue Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : DefaultValue Property
Gets the default value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValue As System.Object
'Usage

Dim instance As JsonProperty
Dim value As System.Object

instance.DefaultValue = value

value = instance.DefaultValue
public System.object DefaultValue {get; set;}
public read-write property DefaultValue: System.TObject;
public function get,set DefaultValue : System.Object
public: __property System.Object* get_DefaultValue();
public: __property void set_DefaultValue(
   System.Object* value
);
public:
property System.Object^ DefaultValue {
   System.Object^ get();
   void set (    System.Object^ value);
}

Property Value

The default value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


DefaultValueHandling Property (JsonProperty)

DefaultValueHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : DefaultValueHandling Property
Gets or sets the property default value handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultValueHandling As System.Nullable(Of DefaultValueHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of DefaultValueHandling)

instance.DefaultValueHandling = value

value = instance.DefaultValueHandling
public System.Nullable<DefaultValueHandling> DefaultValueHandling {get; set;}
public read-write property DefaultValueHandling: System.Nullable;
public function get,set DefaultValueHandling : System.Nullable
public: __property System.Nullable<DefaultValueHandling> get_DefaultValueHandling();
public: __property void set_DefaultValueHandling(
   System.Nullable<DefaultValueHandling> value
);
public:
property System.Nullable<DefaultValueHandling> DefaultValueHandling {
   System.Nullable<DefaultValueHandling> get();
   void set (    System.Nullable<DefaultValueHandling> value);
}

Property Value

The default value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


GetIsSpecified Property (JsonProperty)

GetIsSpecified Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : GetIsSpecified Property
Gets or sets a predicate used to determine whether the property should be serialized.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property GetIsSpecified As System.Predicate(Of Object)
'Usage

Dim instance As JsonProperty
Dim value As System.Predicate(Of Object)

instance.GetIsSpecified = value

value = instance.GetIsSpecified
public System.Predicate<object> GetIsSpecified {get; set;}
public read-write property GetIsSpecified: System.Predicate;
public function get,set GetIsSpecified : System.Predicate
public: __property System.Predicate<Object*>* get_GetIsSpecified();
public: __property void set_GetIsSpecified(
   System.Predicate<Object*>* value
);
public:
property System.Predicate<Object^>^ GetIsSpecified {
   System.Predicate<Object^>^ get();
   void set (    System.Predicate<Object^>^ value);
}

Property Value

A predicate used to determine whether the property should be serialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


HasMemberAttribute Property (JsonProperty)

HasMemberAttribute Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : HasMemberAttribute Property
Gets or sets a value indicating whether this JsonProperty has a member attribute.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property HasMemberAttribute As System.Boolean
'Usage

Dim instance As JsonProperty
Dim value As System.Boolean

instance.HasMemberAttribute = value

value = instance.HasMemberAttribute
public System.bool HasMemberAttribute {get; set;}
public read-write property HasMemberAttribute: System.Boolean;
public function get,set HasMemberAttribute : System.boolean
public: __property System.bool get_HasMemberAttribute();
public: __property void set_HasMemberAttribute(
   System.bool value
);
public:
property System.bool HasMemberAttribute {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if has a member attribute; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


Ignored Property (JsonProperty)

Ignored Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Ignored Property
Gets or sets a value indicating whether this JsonProperty is ignored.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Ignored As System.Boolean
'Usage

Dim instance As JsonProperty
Dim value As System.Boolean

instance.Ignored = value

value = instance.Ignored
public System.bool Ignored {get; set;}
public read-write property Ignored: System.Boolean;
public function get,set Ignored : System.boolean
public: __property System.bool get_Ignored();
public: __property void set_Ignored(
   System.bool value
);
public:
property System.bool Ignored {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if ignored; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


IsReference Property (JsonProperty)

IsReference Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : IsReference Property
Gets or sets a value indicating whether this property preserves object references.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IsReference As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of Boolean)

instance.IsReference = value

value = instance.IsReference
public System.Nullable<bool> IsReference {get; set;}
public read-write property IsReference: System.Nullable;
public function get,set IsReference : System.Nullable
public: __property System.Nullable<bool> get_IsReference();
public: __property void set_IsReference(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> IsReference {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

true if this instance is reference; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ItemConverter Property (JsonProperty)

ItemConverter Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ItemConverter Property
Gets or sets the converter used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemConverter As JsonConverter
'Usage

Dim instance As JsonProperty
Dim value As JsonConverter

instance.ItemConverter = value

value = instance.ItemConverter
public JsonConverter ItemConverter {get; set;}
public read-write property ItemConverter: JsonConverter;
public function get,set ItemConverter : JsonConverter
public: __property JsonConverter* get_ItemConverter();
public: __property void set_ItemConverter(
   JsonConverter* value
);
public:
property JsonConverter^ ItemConverter {
   JsonConverter^ get();
   void set (    JsonConverter^ value);
}

Property Value

The collection's items converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ItemIsReference Property (JsonProperty)

ItemIsReference Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ItemIsReference Property
Gets or sets whether this property's collection items are serialized as a reference.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemIsReference As System.Nullable(Of Boolean)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of Boolean)

instance.ItemIsReference = value

value = instance.ItemIsReference
public System.Nullable<bool> ItemIsReference {get; set;}
public read-write property ItemIsReference: System.Nullable;
public function get,set ItemIsReference : System.Nullable
public: __property System.Nullable<bool> get_ItemIsReference();
public: __property void set_ItemIsReference(
   System.Nullable<bool> value
);
public:
property System.Nullable<bool> ItemIsReference {
   System.Nullable<bool> get();
   void set (    System.Nullable<bool> value);
}

Property Value

Whether this property's collection items are serialized as a reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ItemReferenceLoopHandling Property (JsonProperty)

ItemReferenceLoopHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ItemReferenceLoopHandling Property
Gets or sets the the reference loop handling used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemReferenceLoopHandling As System.Nullable(Of ReferenceLoopHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of ReferenceLoopHandling)

instance.ItemReferenceLoopHandling = value

value = instance.ItemReferenceLoopHandling
public System.Nullable<ReferenceLoopHandling> ItemReferenceLoopHandling {get; set;}
public read-write property ItemReferenceLoopHandling: System.Nullable;
public function get,set ItemReferenceLoopHandling : System.Nullable
public: __property System.Nullable<ReferenceLoopHandling> get_ItemReferenceLoopHandling();
public: __property void set_ItemReferenceLoopHandling(
   System.Nullable<ReferenceLoopHandling> value
);
public:
property System.Nullable<ReferenceLoopHandling> ItemReferenceLoopHandling {
   System.Nullable<ReferenceLoopHandling> get();
   void set (    System.Nullable<ReferenceLoopHandling> value);
}

Property Value

The collection's items reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ItemTypeNameHandling Property (JsonProperty)

ItemTypeNameHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ItemTypeNameHandling Property
Gets or sets the the type name handling used when serializing the property's collection items.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ItemTypeNameHandling As System.Nullable(Of TypeNameHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of TypeNameHandling)

instance.ItemTypeNameHandling = value

value = instance.ItemTypeNameHandling
public System.Nullable<TypeNameHandling> ItemTypeNameHandling {get; set;}
public read-write property ItemTypeNameHandling: System.Nullable;
public function get,set ItemTypeNameHandling : System.Nullable
public: __property System.Nullable<TypeNameHandling> get_ItemTypeNameHandling();
public: __property void set_ItemTypeNameHandling(
   System.Nullable<TypeNameHandling> value
);
public:
property System.Nullable<TypeNameHandling> ItemTypeNameHandling {
   System.Nullable<TypeNameHandling> get();
   void set (    System.Nullable<TypeNameHandling> value);
}

Property Value

The collection's items type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


MemberConverter Property (JsonProperty)

MemberConverter Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : MemberConverter Property
Gets or sets the member converter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MemberConverter As JsonConverter
'Usage

Dim instance As JsonProperty
Dim value As JsonConverter

instance.MemberConverter = value

value = instance.MemberConverter
public JsonConverter MemberConverter {get; set;}
public read-write property MemberConverter: JsonConverter;
public function get,set MemberConverter : JsonConverter
public: __property JsonConverter* get_MemberConverter();
public: __property void set_MemberConverter(
   JsonConverter* value
);
public:
property JsonConverter^ MemberConverter {
   JsonConverter^ get();
   void set (    JsonConverter^ value);
}

Property Value

The member converter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


NullValueHandling Property (JsonProperty)

NullValueHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : NullValueHandling Property
Gets or sets the property null value handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NullValueHandling As System.Nullable(Of NullValueHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of NullValueHandling)

instance.NullValueHandling = value

value = instance.NullValueHandling
public System.Nullable<NullValueHandling> NullValueHandling {get; set;}
public read-write property NullValueHandling: System.Nullable;
public function get,set NullValueHandling : System.Nullable
public: __property System.Nullable<NullValueHandling> get_NullValueHandling();
public: __property void set_NullValueHandling(
   System.Nullable<NullValueHandling> value
);
public:
property System.Nullable<NullValueHandling> NullValueHandling {
   System.Nullable<NullValueHandling> get();
   void set (    System.Nullable<NullValueHandling> value);
}

Property Value

The null value handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ObjectCreationHandling Property (JsonProperty)

ObjectCreationHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ObjectCreationHandling Property
Gets or sets the property object creation handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ObjectCreationHandling As System.Nullable(Of ObjectCreationHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of ObjectCreationHandling)

instance.ObjectCreationHandling = value

value = instance.ObjectCreationHandling
public System.Nullable<ObjectCreationHandling> ObjectCreationHandling {get; set;}
public read-write property ObjectCreationHandling: System.Nullable;
public function get,set ObjectCreationHandling : System.Nullable
public: __property System.Nullable<ObjectCreationHandling> get_ObjectCreationHandling();
public: __property void set_ObjectCreationHandling(
   System.Nullable<ObjectCreationHandling> value
);
public:
property System.Nullable<ObjectCreationHandling> ObjectCreationHandling {
   System.Nullable<ObjectCreationHandling> get();
   void set (    System.Nullable<ObjectCreationHandling> value);
}

Property Value

The object creation handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


Order Property (JsonProperty)

Order Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Order Property
Gets or sets the order of serialization and deserialization of a member.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Order As System.Nullable(Of Integer)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of Integer)

instance.Order = value

value = instance.Order
public System.Nullable<int> Order {get; set;}
public read-write property Order: System.Nullable;
public function get,set Order : System.Nullable
public: __property System.Nullable<int> get_Order();
public: __property void set_Order(
   System.Nullable<int> value
);
public:
property System.Nullable<int> Order {
   System.Nullable<int> get();
   void set (    System.Nullable<int> value);
}

Property Value

The numeric order of serialization or deserialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


PropertyName Property (JsonProperty)

PropertyName Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : PropertyName Property
Gets or sets the name of the property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PropertyName As System.String
'Usage

Dim instance As JsonProperty
Dim value As System.String

instance.PropertyName = value

value = instance.PropertyName
public System.string PropertyName {get; set;}
public read-write property PropertyName: System.String;
public function get,set PropertyName : System.String
public: __property System.string* get_PropertyName();
public: __property void set_PropertyName(
   System.string* value
);
public:
property System.String^ PropertyName {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The name of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


PropertyType Property (JsonProperty)

PropertyType Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : PropertyType Property
Gets or sets the type of the property.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PropertyType As System.Type
'Usage

Dim instance As JsonProperty
Dim value As System.Type

instance.PropertyType = value

value = instance.PropertyType
public System.Type PropertyType {get; set;}
public read-write property PropertyType: System.Type;
public function get,set PropertyType : System.Type
public: __property System.Type* get_PropertyType();
public: __property void set_PropertyType(
   System.Type* value
);
public:
property System.Type^ PropertyType {
   System.Type^ get();
   void set (    System.Type^ value);
}

Property Value

The type of the property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


Readable Property (JsonProperty)

Readable Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Readable Property
Gets or sets a value indicating whether this JsonProperty is readable.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Readable As System.Boolean
'Usage

Dim instance As JsonProperty
Dim value As System.Boolean

instance.Readable = value

value = instance.Readable
public System.bool Readable {get; set;}
public read-write property Readable: System.Boolean;
public function get,set Readable : System.boolean
public: __property System.bool get_Readable();
public: __property void set_Readable(
   System.bool value
);
public:
property System.bool Readable {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if readable; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ReferenceLoopHandling Property (JsonProperty)

ReferenceLoopHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ReferenceLoopHandling Property
Gets or sets the property reference loop handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ReferenceLoopHandling As System.Nullable(Of ReferenceLoopHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of ReferenceLoopHandling)

instance.ReferenceLoopHandling = value

value = instance.ReferenceLoopHandling
public System.Nullable<ReferenceLoopHandling> ReferenceLoopHandling {get; set;}
public read-write property ReferenceLoopHandling: System.Nullable;
public function get,set ReferenceLoopHandling : System.Nullable
public: __property System.Nullable<ReferenceLoopHandling> get_ReferenceLoopHandling();
public: __property void set_ReferenceLoopHandling(
   System.Nullable<ReferenceLoopHandling> value
);
public:
property System.Nullable<ReferenceLoopHandling> ReferenceLoopHandling {
   System.Nullable<ReferenceLoopHandling> get();
   void set (    System.Nullable<ReferenceLoopHandling> value);
}

Property Value

The reference loop handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


Required Property (JsonProperty)

Required Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Required Property
Gets or sets a value indicating whether this JsonProperty is required.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As Required
'Usage

Dim instance As JsonProperty
Dim value As Required

instance.Required = value

value = instance.Required
public Required Required {get; set;}
public read-write property Required: Required;
public function get,set Required : Required
public: __property Required get_Required();
public: __property void set_Required(
   Required value
);
public:
property Required Required {
   Required get();
   void set (    Required value);
}

Property Value

A value indicating whether this JsonProperty is required.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


SetIsSpecified Property (JsonProperty)

SetIsSpecified Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : SetIsSpecified Property
Gets or sets an action used to set whether the property has been deserialized.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property SetIsSpecified As System.Action(Of Object,Object)
'Usage

Dim instance As JsonProperty
Dim value As System.Action(Of Object,Object)

instance.SetIsSpecified = value

value = instance.SetIsSpecified
public System.Action<object,object> SetIsSpecified {get; set;}
public read-write property SetIsSpecified: System.Action;
public function get,set SetIsSpecified : System.Action
public: __property System.Action<Object*,Object*>* get_SetIsSpecified();
public: __property void set_SetIsSpecified(
   System.Action<Object*,Object*>* value
);
public:
property System.Action<Object^,Object^>^ SetIsSpecified {
   System.Action<Object^,Object^>^ get();
   void set (    System.Action<Object^,Object^>^ value);
}

Property Value

An action used to set whether the property has been deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ShouldSerialize Property (JsonProperty)

ShouldSerialize Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ShouldSerialize Property
Gets or sets a predicate used to determine whether the property should be serialize.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ShouldSerialize As System.Predicate(Of Object)
'Usage

Dim instance As JsonProperty
Dim value As System.Predicate(Of Object)

instance.ShouldSerialize = value

value = instance.ShouldSerialize
public System.Predicate<object> ShouldSerialize {get; set;}
public read-write property ShouldSerialize: System.Predicate;
public function get,set ShouldSerialize : System.Predicate
public: __property System.Predicate<Object*>* get_ShouldSerialize();
public: __property void set_ShouldSerialize(
   System.Predicate<Object*>* value
);
public:
property System.Predicate<Object^>^ ShouldSerialize {
   System.Predicate<Object^>^ get();
   void set (    System.Predicate<Object^>^ value);
}

Property Value

A predicate used to determine whether the property should be serialize.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


TypeNameHandling Property (JsonProperty)

TypeNameHandling Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : TypeNameHandling Property
Gets or sets or sets the type name handling.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TypeNameHandling As System.Nullable(Of TypeNameHandling)
'Usage

Dim instance As JsonProperty
Dim value As System.Nullable(Of TypeNameHandling)

instance.TypeNameHandling = value

value = instance.TypeNameHandling
public System.Nullable<TypeNameHandling> TypeNameHandling {get; set;}
public read-write property TypeNameHandling: System.Nullable;
public function get,set TypeNameHandling : System.Nullable
public: __property System.Nullable<TypeNameHandling> get_TypeNameHandling();
public: __property void set_TypeNameHandling(
   System.Nullable<TypeNameHandling> value
);
public:
property System.Nullable<TypeNameHandling> TypeNameHandling {
   System.Nullable<TypeNameHandling> get();
   void set (    System.Nullable<TypeNameHandling> value);
}

Property Value

The type name handling.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


UnderlyingName Property (JsonProperty)

UnderlyingName Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : UnderlyingName Property
Gets or sets the name of the underlying member or parameter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UnderlyingName As System.String
'Usage

Dim instance As JsonProperty
Dim value As System.String

instance.UnderlyingName = value

value = instance.UnderlyingName
public System.string UnderlyingName {get; set;}
public read-write property UnderlyingName: System.String;
public function get,set UnderlyingName : System.String
public: __property System.string* get_UnderlyingName();
public: __property void set_UnderlyingName(
   System.string* value
);
public:
property System.String^ UnderlyingName {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The name of the underlying member or parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


ValueProvider Property (JsonProperty)

ValueProvider Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : ValueProvider Property
Gets the IValueProvider that will get and set the JsonProperty during serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ValueProvider As IValueProvider
'Usage

Dim instance As JsonProperty
Dim value As IValueProvider

instance.ValueProvider = value

value = instance.ValueProvider
public IValueProvider ValueProvider {get; set;}
public read-write property ValueProvider: IValueProvider;
public function get,set ValueProvider : IValueProvider
public: __property IValueProvider* get_ValueProvider();
public: __property void set_ValueProvider(
   IValueProvider* value
);
public:
property IValueProvider^ ValueProvider {
   IValueProvider^ get();
   void set (    IValueProvider^ value);
}

Property Value

The IValueProvider that will get and set the JsonProperty during serialization.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


Writable Property (JsonProperty)

Writable Property (JsonProperty)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonProperty Class : Writable Property
Gets or sets a value indicating whether this JsonProperty is writable.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Writable As System.Boolean
'Usage

Dim instance As JsonProperty
Dim value As System.Boolean

instance.Writable = value

value = instance.Writable
public System.bool Writable {get; set;}
public read-write property Writable: System.Boolean;
public function get,set Writable : System.boolean
public: __property System.bool get_Writable();
public: __property void set_Writable(
   System.bool value
);
public:
property System.bool Writable {
   System.bool get();
   void set (    System.bool value);
}

Property Value

true if writable; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonProperty Class
JsonProperty Members


JsonPropertyCollection Class

JsonPropertyCollection Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPropertyCollection Class
A collection of JsonProperty objects.
Object Model
JsonPropertyCollection Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonPropertyCollection
   Inherits System.Collections.ObjectModel.KeyedCollection(Of String,JsonProperty)
'Usage

Dim instance As JsonPropertyCollection
public class JsonPropertyCollection : System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>
public class JsonPropertyCollection = class(System.Collections.ObjectModel.KeyedCollection)
public class JsonPropertyCollection extends System.Collections.ObjectModel.KeyedCollection
public __gc class JsonPropertyCollection : public System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>
public ref class JsonPropertyCollection : public System.Collections.ObjectModel.KeyedCollection<String,JsonProperty>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
Noemax.Newtonsoft.Json.Serialization.JsonPropertyCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPropertyCollection Class Members

JsonPropertyCollection Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPropertyCollection Class

The following tables list the members exposed by JsonPropertyCollection.

Public Constructors
 | Name | Description
Public Constructor | JsonPropertyCollection Constructor | Initializes a new instance of the JsonPropertyCollection class.
Top
Public Properties
 | Name | Description
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Top
Protected Properties
 | Name | Description
Protected Property | Dictionary | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | AddProperty | Adds a JsonProperty object.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | GetClosestMatchProperty | Gets the closest matching JsonProperty object. First attempts to get an exact case match of propertyName and then a case insensitive match.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | GetProperty | Gets a property by property name.
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Top
Protected Methods
 | Name | Description
Protected Method | ChangeItemKey | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | GetKeyForItem | Overridden. When implemented in a derived class, extracts the key from the specified element.
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Top
See Also

Reference

JsonPropertyCollection Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPropertyCollection Constructor

JsonPropertyCollection Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : JsonPropertyCollection Constructor
The type.
Initializes a new instance of the JsonPropertyCollection class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As System.Type _
)
'Usage

Dim type As System.Type

Dim instance As New JsonPropertyCollection(type)
public JsonPropertyCollection(
   System.Type type
)
public JsonPropertyCollection(
    type: System.Type
);
public function JsonPropertyCollection(
   type : System.Type
);
public: JsonPropertyCollection(
   System.Type* type
)
public:
JsonPropertyCollection(
   System.Type^ type
)

Parameters

type
The type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


JsonPropertyCollection Class Methods

JsonPropertyCollection Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPropertyCollection Class

For a list of all members of this type, see JsonPropertyCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | AddProperty | Adds a JsonProperty object.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Contains | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | GetClosestMatchProperty | Gets the closest matching JsonProperty object. First attempts to get an exact case match of propertyName and then a case insensitive match.
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | GetProperty | Gets a property by property name.
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Method | Remove | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Top
Protected Methods
 | Name | Description
Protected Method | ChangeItemKey | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | GetKeyForItem | Overridden. When implemented in a derived class, extracts the key from the specified element.
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Top
See Also

Reference

JsonPropertyCollection Class
Noemax.Newtonsoft.Json.Serialization Namespace


AddProperty Method (JsonPropertyCollection)

AddProperty Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : AddProperty Method
The property to add to the collection.
Adds a JsonProperty object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddProperty( _
   ByVal property As JsonProperty _
)
'Usage

Dim instance As JsonPropertyCollection
Dim property As JsonProperty

instance.AddProperty(property)
public void AddProperty(
   JsonProperty property
)
public procedure AddProperty(
    property: JsonProperty
);
public function AddProperty(
   property : JsonProperty
);
public: void AddProperty(
   JsonProperty* property
)
public:
void AddProperty(
   JsonProperty^ property
)

Parameters

property
The property to add to the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


GetClosestMatchProperty Method (JsonPropertyCollection)

GetClosestMatchProperty Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : GetClosestMatchProperty Method
Name of the property.
Gets the closest matching JsonProperty object. First attempts to get an exact case match of propertyName and then a case insensitive match.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetClosestMatchProperty( _
   ByVal propertyName As System.String _
) As JsonProperty
'Usage

Dim instance As JsonPropertyCollection
Dim propertyName As System.String
Dim value As JsonProperty

value = instance.GetClosestMatchProperty(propertyName)
public JsonProperty GetClosestMatchProperty(
   System.string propertyName
)
public function GetClosestMatchProperty(
    propertyName: System.String
): JsonProperty;
public function GetClosestMatchProperty(
   propertyName : System.String
) : JsonProperty;
public: JsonProperty* GetClosestMatchProperty(
   System.string* propertyName
)
public:
JsonProperty^ GetClosestMatchProperty(
   System.String^ propertyName
)

Parameters

propertyName
Name of the property.

Return Value

A matching property if found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


GetKeyForItem Method (JsonPropertyCollection)

GetKeyForItem Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : GetKeyForItem Method
The element from which to extract the key.
When implemented in a derived class, extracts the key from the specified element.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function GetKeyForItem( _
   ByVal item As JsonProperty _
) As System.String
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty
Dim value As System.String

value = instance.GetKeyForItem(item)
protected override System.string GetKeyForItem(
   JsonProperty item
)
protected function GetKeyForItem(
    item: JsonProperty
): System.String; override;
protected override function GetKeyForItem(
   item : JsonProperty
) : System.String;
protected: System.string* GetKeyForItem(
   JsonProperty* item
) override
protected:
System.String^ GetKeyForItem(
   JsonProperty^ item
) override

Parameters

item
The element from which to extract the key.

Return Value

The key for the specified element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Base Implementation in GetKeyForItem


GetProperty Method (JsonPropertyCollection)

GetProperty Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : GetProperty Method
The name of the property to get.
Type property name string comparison.
Gets a property by property name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetProperty( _
   ByVal propertyName As System.String, _
   ByVal comparisonType As System.StringComparison _
) As JsonProperty
'Usage

Dim instance As JsonPropertyCollection
Dim propertyName As System.String
Dim comparisonType As System.StringComparison
Dim value As JsonProperty

value = instance.GetProperty(propertyName, comparisonType)
public JsonProperty GetProperty(
   System.string propertyName,
   System.StringComparison comparisonType
)
public function GetProperty(
    propertyName: System.String;
    comparisonType: System.StringComparison
): JsonProperty;
public function GetProperty(
   propertyName : System.String,
   comparisonType : System.StringComparison
) : JsonProperty;
public: JsonProperty* GetProperty(
   System.string* propertyName,
   System.StringComparison comparisonType
)
public:
JsonProperty^ GetProperty(
   System.String^ propertyName,
   System.StringComparison comparisonType
)

Parameters

propertyName
The name of the property to get.
comparisonType
Type property name string comparison.

Return Value

A matching property if found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


JsonStringContract Class

JsonStringContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonStringContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonStringContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonStringContract
   Inherits JsonPrimitiveContract
'Usage

Dim instance As JsonStringContract
public class JsonStringContract : JsonPrimitiveContract
public class JsonStringContract = class(JsonPrimitiveContract)
public class JsonStringContract extends JsonPrimitiveContract
public __gc class JsonStringContract : public JsonPrimitiveContract
public ref class JsonStringContract : public JsonPrimitiveContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonPrimitiveContract
Noemax.Newtonsoft.Json.Serialization.JsonStringContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonStringContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonStringContract Class Members

JsonStringContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonStringContract Class

The following tables list the members exposed by JsonStringContract.

Public Constructors
 | Name | Description
Public Constructor | JsonStringContract Constructor | Initializes a new instance of the JsonStringContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonStringContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonStringContract Constructor

JsonStringContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonStringContract Class : JsonStringContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonStringContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonStringContract(underlyingType)
public JsonStringContract(
   System.Type underlyingType
)
public JsonStringContract(
    underlyingType: System.Type
);
public function JsonStringContract(
   underlyingType : System.Type
);
public: JsonStringContract(
   System.Type* underlyingType
)
public:
JsonStringContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonStringContract Class
JsonStringContract Members


MemoryTraceWriter Class

MemoryTraceWriter Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : MemoryTraceWriter Class
Represents a trace writer that writes to memory. When the trace message limit is reached then old trace messages will be removed as new messages are added.
Object Model
MemoryTraceWriter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class MemoryTraceWriter
   Implements ITraceWriter
'Usage

Dim instance As MemoryTraceWriter
public class MemoryTraceWriter : ITraceWriter
public class MemoryTraceWriter = class(ITraceWriter)
public class MemoryTraceWriter implements ITraceWriter
public __gc class MemoryTraceWriter : public ITraceWriter
public ref class MemoryTraceWriter : public ITraceWriter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.MemoryTraceWriter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Members
Noemax.Newtonsoft.Json.Serialization Namespace


MemoryTraceWriter Class Members

MemoryTraceWriter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : MemoryTraceWriter Class

The following tables list the members exposed by MemoryTraceWriter.

Public Constructors
 | Name | Description
Public Constructor | MemoryTraceWriter Constructor | Initializes a new instance of the MemoryTraceWriter class.
Top
Public Properties
 | Name | Description
Public Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
Public Methods
 | Name | Description
Public Method | GetTraceMessages | Returns an enumeration of the most recent trace messages.
Public Method | ToString | Returns a System.String of the most recent trace messages.
Public Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

MemoryTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


MemoryTraceWriter Constructor

MemoryTraceWriter Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > MemoryTraceWriter Class : MemoryTraceWriter Constructor
Initializes a new instance of the MemoryTraceWriter class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New MemoryTraceWriter()
public MemoryTraceWriter()
public MemoryTraceWriter();
public function MemoryTraceWriter();
public: MemoryTraceWriter();
public:
MemoryTraceWriter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Class
MemoryTraceWriter Members


MemoryTraceWriter Class Methods

MemoryTraceWriter Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : MemoryTraceWriter Class

For a list of all members of this type, see MemoryTraceWriter members.

Public Methods
 | Name | Description
Public Method | GetTraceMessages | Returns an enumeration of the most recent trace messages.
Public Method | ToString | Returns a System.String of the most recent trace messages.
Public Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

MemoryTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


GetTraceMessages Method (MemoryTraceWriter)

GetTraceMessages Method (MemoryTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > MemoryTraceWriter Class : GetTraceMessages Method
Returns an enumeration of the most recent trace messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetTraceMessages() As System.Collections.Generic.IEnumerable(Of String)
'Usage

Dim instance As MemoryTraceWriter
Dim value As System.Collections.Generic.IEnumerable(Of String)

value = instance.GetTraceMessages()
public System.Collections.Generic.IEnumerable<string> GetTraceMessages()
public function GetTraceMessages(): System.Collections.Generic.IEnumerable;
public function GetTraceMessages() : System.Collections.Generic.IEnumerable;
public: System.Collections.Generic.IEnumerable<string*>* GetTraceMessages();
public:
System.Collections.Generic.IEnumerable<String^>^ GetTraceMessages();

Return Value

An enumeration of the most recent trace messages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Class
MemoryTraceWriter Members


ToString Method (MemoryTraceWriter)

ToString Method (MemoryTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > MemoryTraceWriter Class : ToString Method
Returns a System.String of the most recent trace messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ToString() As System.String
'Usage

Dim instance As MemoryTraceWriter
Dim value As System.String

value = instance.ToString()
public override System.string ToString()
public function ToString(): System.String; override;
public override function ToString() : System.String;
public: System.string* ToString(); override
public:
System.String^ ToString(); override

Return Value

A System.String of the most recent trace messages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Class
MemoryTraceWriter Members
Base Implementation in ToString


Trace Method (MemoryTraceWriter)

Trace Method (MemoryTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > MemoryTraceWriter Class : Trace Method
The System.Diagnostics.TraceLevel at which to write this trace.
The trace message.
The trace exception. This parameter is optional.
Writes the specified trace level, message and optional exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Trace( _
   ByVal level As System.Diagnostics.TraceLevel, _
   ByVal message As System.String, _
   ByVal ex As System.Exception _
)
'Usage

Dim instance As MemoryTraceWriter
Dim level As System.Diagnostics.TraceLevel
Dim message As System.String
Dim ex As System.Exception

instance.Trace(level, message, ex)
public void Trace(
   System.Diagnostics.TraceLevel level,
   System.string message,
   System.Exception ex
)
public procedure Trace(
    level: System.Diagnostics.TraceLevel;
    message: System.String;
    ex: System.Exception
);
public function Trace(
   level : System.Diagnostics.TraceLevel,
   message : System.String,
   ex : System.Exception
);
public: void Trace(
   System.Diagnostics.TraceLevel level,
   System.string* message,
   System.Exception* ex
)
public:
void Trace(
   System.Diagnostics.TraceLevel level,
   System.String^ message,
   System.Exception^ ex
)

Parameters

level
The System.Diagnostics.TraceLevel at which to write this trace.
message
The trace message.
ex
The trace exception. This parameter is optional.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Class
MemoryTraceWriter Members


MemoryTraceWriter Class Properties

MemoryTraceWriter Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : MemoryTraceWriter Class

For a list of all members of this type, see MemoryTraceWriter members.

Public Properties
 | Name | Description
Public Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
See Also

Reference

MemoryTraceWriter Class
Noemax.Newtonsoft.Json.Serialization Namespace


LevelFilter Property (MemoryTraceWriter)

LevelFilter Property (MemoryTraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > MemoryTraceWriter Class : LevelFilter Property
Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property LevelFilter As System.Diagnostics.TraceLevel
'Usage

Dim instance As MemoryTraceWriter
Dim value As System.Diagnostics.TraceLevel

instance.LevelFilter = value

value = instance.LevelFilter
public System.Diagnostics.TraceLevel LevelFilter {get; set;}
public read-write property LevelFilter: System.Diagnostics.TraceLevel;
public function get,set LevelFilter : System.Diagnostics.TraceLevel
public: __property System.Diagnostics.TraceLevel get_LevelFilter();
public: __property void set_LevelFilter(
   System.Diagnostics.TraceLevel value
);
public:
property System.Diagnostics.TraceLevel LevelFilter {
   System.Diagnostics.TraceLevel get();
   void set (    System.Diagnostics.TraceLevel value);
}

Property Value

The System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MemoryTraceWriter Class
MemoryTraceWriter Members


OnErrorAttribute Class

OnErrorAttribute Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : OnErrorAttribute Class
When applied to a method, specifies that the method is called when an error occurs serializing an object.
Object Model
OnErrorAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=False)>
Public NotInheritable Class OnErrorAttribute
   Inherits System.Attribute
'Usage

Dim instance As OnErrorAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=false)]
public sealed class OnErrorAttribute : System.Attribute
public class OnErrorAttribute = class(System.Attribute)sealed;
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=,
   Inherited=)
public sealed class OnErrorAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=false)]
public __gc __sealed class OnErrorAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=false)]
public ref class OnErrorAttribute sealed : public System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.Newtonsoft.Json.Serialization.OnErrorAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Members
Noemax.Newtonsoft.Json.Serialization Namespace


OnErrorAttribute Class Members

OnErrorAttribute Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : OnErrorAttribute Class

The following tables list the members exposed by OnErrorAttribute.

Public Constructors
 | Name | Description
Public Constructor | OnErrorAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

OnErrorAttribute Class
Noemax.Newtonsoft.Json.Serialization Namespace


OnErrorAttribute Constructor

OnErrorAttribute Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : OnErrorAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New OnErrorAttribute()
public OnErrorAttribute()
public OnErrorAttribute();
public function OnErrorAttribute();
public: OnErrorAttribute();
public:
OnErrorAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


ReflectionValueProvider Class

ReflectionValueProvider Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : ReflectionValueProvider Class
Get and set values for a System.Reflection.MemberInfo using reflection.
Object Model
ReflectionValueProvider Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ReflectionValueProvider
   Implements IValueProvider
'Usage

Dim instance As ReflectionValueProvider
public class ReflectionValueProvider : IValueProvider
public class ReflectionValueProvider = class(IValueProvider)
public class ReflectionValueProvider implements IValueProvider
public __gc class ReflectionValueProvider : public IValueProvider
public ref class ReflectionValueProvider : public IValueProvider
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.ReflectionValueProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionValueProvider Members
Noemax.Newtonsoft.Json.Serialization Namespace


ReflectionValueProvider Class Members

ReflectionValueProvider Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ReflectionValueProvider Class

The following tables list the members exposed by ReflectionValueProvider.

Public Constructors
 | Name | Description
Public Constructor | ReflectionValueProvider Constructor | Initializes a new instance of the ReflectionValueProvider class.
Top
Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

ReflectionValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


ReflectionValueProvider Constructor

ReflectionValueProvider Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > ReflectionValueProvider Class : ReflectionValueProvider Constructor
The member info.
Initializes a new instance of the ReflectionValueProvider class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal memberInfo As System.Reflection.MemberInfo _
)
'Usage

Dim memberInfo As System.Reflection.MemberInfo

Dim instance As New ReflectionValueProvider(memberInfo)
public ReflectionValueProvider(
   System.Reflection.MemberInfo memberInfo
)
public ReflectionValueProvider(
    memberInfo: System.Reflection.MemberInfo
);
public function ReflectionValueProvider(
   memberInfo : System.Reflection.MemberInfo
);
public: ReflectionValueProvider(
   System.Reflection.MemberInfo* memberInfo
)
public:
ReflectionValueProvider(
   System.Reflection.MemberInfo^ memberInfo
)

Parameters

memberInfo
The member info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionValueProvider Class
ReflectionValueProvider Members


ReflectionValueProvider Class Methods

ReflectionValueProvider Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ReflectionValueProvider Class

For a list of all members of this type, see ReflectionValueProvider members.

Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

ReflectionValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


GetValue Method (ReflectionValueProvider)

GetValue Method (ReflectionValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > ReflectionValueProvider Class : GetValue Method
The target to get the value from.
Gets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValue( _
   ByVal target As System.Object _
) As System.Object
'Usage

Dim instance As ReflectionValueProvider
Dim target As System.Object
Dim value As System.Object

value = instance.GetValue(target)
public System.object GetValue(
   System.object target
)
public function GetValue(
    target: System.TObject
): System.TObject;
public function GetValue(
   target : System.Object
) : System.Object;
public: System.Object* GetValue(
   System.Object* target
)
public:
System.Object^ GetValue(
   System.Object^ target
)

Parameters

target
The target to get the value from.

Return Value

The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionValueProvider Class
ReflectionValueProvider Members


SetValue Method (ReflectionValueProvider)

SetValue Method (ReflectionValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > ReflectionValueProvider Class : SetValue Method
The target to set the value on.
The value to set on the target.
Sets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetValue( _
   ByVal target As System.Object, _
   ByVal value As System.Object _
)
'Usage

Dim instance As ReflectionValueProvider
Dim target As System.Object
Dim value As System.Object

instance.SetValue(target, value)
public void SetValue(
   System.object target,
   System.object value
)
public procedure SetValue(
    target: System.TObject;
    value: System.TObject
);
public function SetValue(
   target : System.Object,
   value : System.Object
);
public: void SetValue(
   System.Object* target,
   System.Object* value
)
public:
void SetValue(
   System.Object^ target,
   System.Object^ value
)

Parameters

target
The target to set the value on.
value
The value to set on the target.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionValueProvider Class
ReflectionValueProvider Members


IContractResolver Interface

IContractResolver Interface
Members Example

Noemax.Newtonsoft.Json.Serialization Namespace : IContractResolver Interface
Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Object Model
IContractResolver Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IContractResolver
'Usage

Dim instance As IContractResolver
public interface IContractResolver
public interface IContractResolver
public interface IContractResolver
public __gc __interface IContractResolver
public interface class IContractResolver
Example
  • C#

  • C#
    •

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
IContractResolver Members

Noemax.Newtonsoft.Json.Serialization Namespace


IContractResolver Interface Members

IContractResolver Interface Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IContractResolver Interface

The following tables list the members exposed by IContractResolver.

Public Methods
 | Name | Description
Method | ResolveContract | Resolves the contract for a given type.
Top
See Also

Reference

IContractResolver Interface
Noemax.Newtonsoft.Json.Serialization Namespace


IContractResolver Interface Methods

IContractResolver Interface Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IContractResolver Interface

For a list of all members of this type, see IContractResolver members.

Public Methods
 | Name | Description
Method | ResolveContract | Resolves the contract for a given type.
Top
See Also

Reference

IContractResolver Interface
Noemax.Newtonsoft.Json.Serialization Namespace


ResolveContract Method (IContractResolver)

ResolveContract Method (IContractResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > IContractResolver Interface : ResolveContract Method
The type to resolve a contract for.
Resolves the contract for a given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function ResolveContract( _
   ByVal type As System.Type _
) As JsonContract
'Usage

Dim instance As IContractResolver
Dim type As System.Type
Dim value As JsonContract

value = instance.ResolveContract(type)
JsonContract ResolveContract(
   System.Type type
)
function ResolveContract(
    type: System.Type
): JsonContract;
function ResolveContract(
   type : System.Type
) : JsonContract;
JsonContract* ResolveContract(
   System.Type* type
)
JsonContract^ ResolveContract(
   System.Type^ type
)

Parameters

type
The type to resolve a contract for.

Return Value

The contract for a given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IContractResolver Interface
IContractResolver Members


IReferenceResolver Interface

IReferenceResolver Interface
Members

Noemax.Newtonsoft.Json.Serialization Namespace : IReferenceResolver Interface
Used to resolve references when serializing and deserializing JSON by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
IReferenceResolver Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IReferenceResolver
'Usage

Dim instance As IReferenceResolver
public interface IReferenceResolver
public interface IReferenceResolver
public interface IReferenceResolver
public __gc __interface IReferenceResolver
public interface class IReferenceResolver
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceResolver Members
Noemax.Newtonsoft.Json.Serialization Namespace


IReferenceResolver Interface Members

IReferenceResolver Interface Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IReferenceResolver Interface

The following tables list the members exposed by IReferenceResolver.

Public Methods
 | Name | Description
Method | AddReference | Adds a reference to the specified object.
Method | GetReference | Gets the reference for the sepecified object.
Method | IsReferenced | Determines whether the specified object is referenced.
Method | ResolveReference | Resolves a reference to its object.
Top
See Also

Reference

IReferenceResolver Interface
Noemax.Newtonsoft.Json.Serialization Namespace


IReferenceResolver Interface Methods

IReferenceResolver Interface Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IReferenceResolver Interface

For a list of all members of this type, see IReferenceResolver members.

Public Methods
 | Name | Description
Method | AddReference | Adds a reference to the specified object.
Method | GetReference | Gets the reference for the sepecified object.
Method | IsReferenced | Determines whether the specified object is referenced.
Method | ResolveReference | Resolves a reference to its object.
Top
See Also

Reference

IReferenceResolver Interface
Noemax.Newtonsoft.Json.Serialization Namespace


AddReference Method (IReferenceResolver)

AddReference Method (IReferenceResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > IReferenceResolver Interface : AddReference Method
The serialization context.
The reference.
The object to reference.
Adds a reference to the specified object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub AddReference( _
   ByVal context As System.Object, _
   ByVal reference As System.String, _
   ByVal value As System.Object _
)
'Usage

Dim instance As IReferenceResolver
Dim context As System.Object
Dim reference As System.String
Dim value As System.Object

instance.AddReference(context, reference, value)
void AddReference(
   System.object context,
   System.string reference,
   System.object value
)
procedure AddReference(
    context: System.TObject;
    reference: System.String;
    value: System.TObject
);
function AddReference(
   context : System.Object,
   reference : System.String,
   value : System.Object
);
void AddReference(
   System.Object* context,
   System.string* reference,
   System.Object* value
)
void AddReference(
   System.Object^ context,
   System.String^ reference,
   System.Object^ value
)

Parameters

context
The serialization context.
reference
The reference.
value
The object to reference.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceResolver Interface
IReferenceResolver Members


GetReference Method (IReferenceResolver)

GetReference Method (IReferenceResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > IReferenceResolver Interface : GetReference Method
The serialization context.
The object to get a reference for.
Gets the reference for the sepecified object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetReference( _
   ByVal context As System.Object, _
   ByVal value As System.Object _
) As System.String
'Usage

Dim instance As IReferenceResolver
Dim context As System.Object
Dim value As System.Object
Dim value As System.String

value = instance.GetReference(context, value)
System.string GetReference(
   System.object context,
   System.object value
)
function GetReference(
    context: System.TObject;
    value: System.TObject
): System.String;
function GetReference(
   context : System.Object,
   value : System.Object
) : System.String;
System.string* GetReference(
   System.Object* context,
   System.Object* value
)
System.String^ GetReference(
   System.Object^ context,
   System.Object^ value
)

Parameters

context
The serialization context.
value
The object to get a reference for.

Return Value

The reference to the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceResolver Interface
IReferenceResolver Members


IsReferenced Method (IReferenceResolver)

IsReferenced Method (IReferenceResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > IReferenceResolver Interface : IsReferenced Method
The serialization context.
The object to test for a reference.
Determines whether the specified object is referenced.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function IsReferenced( _
   ByVal context As System.Object, _
   ByVal value As System.Object _
) As System.Boolean
'Usage

Dim instance As IReferenceResolver
Dim context As System.Object
Dim value As System.Object
Dim value As System.Boolean

value = instance.IsReferenced(context, value)
System.bool IsReferenced(
   System.object context,
   System.object value
)
function IsReferenced(
    context: System.TObject;
    value: System.TObject
): System.Boolean;
function IsReferenced(
   context : System.Object,
   value : System.Object
) : System.boolean;
System.bool IsReferenced(
   System.Object* context,
   System.Object* value
)
System.bool IsReferenced(
   System.Object^ context,
   System.Object^ value
)

Parameters

context
The serialization context.
value
The object to test for a reference.

Return Value

true if the specified object is referenced; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceResolver Interface
IReferenceResolver Members


ResolveReference Method (IReferenceResolver)

ResolveReference Method (IReferenceResolver)

Noemax.Newtonsoft.Json.Serialization Namespace > IReferenceResolver Interface : ResolveReference Method
The serialization context.
The reference to resolve.
Resolves a reference to its object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function ResolveReference( _
   ByVal context As System.Object, _
   ByVal reference As System.String _
) As System.Object
'Usage

Dim instance As IReferenceResolver
Dim context As System.Object
Dim reference As System.String
Dim value As System.Object

value = instance.ResolveReference(context, reference)
System.object ResolveReference(
   System.object context,
   System.string reference
)
function ResolveReference(
    context: System.TObject;
    reference: System.String
): System.TObject;
function ResolveReference(
   context : System.Object,
   reference : System.String
) : System.Object;
System.Object* ResolveReference(
   System.Object* context,
   System.string* reference
)
System.Object^ ResolveReference(
   System.Object^ context,
   System.String^ reference
)

Parameters

context
The serialization context.
reference
The reference to resolve.

Return Value

The object that
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IReferenceResolver Interface
IReferenceResolver Members


ITraceWriter Interface

ITraceWriter Interface
Members

Noemax.Newtonsoft.Json.Serialization Namespace : ITraceWriter Interface
Represents a trace writer.
Object Model
ITraceWriter Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface ITraceWriter
'Usage

Dim instance As ITraceWriter
public interface ITraceWriter
public interface ITraceWriter
public interface ITraceWriter
public __gc __interface ITraceWriter
public interface class ITraceWriter
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITraceWriter Members
Noemax.Newtonsoft.Json.Serialization Namespace


ITraceWriter Interface Members

ITraceWriter Interface Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ITraceWriter Interface

The following tables list the members exposed by ITraceWriter.

Public Properties
 | Name | Description
Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
Public Methods
 | Name | Description
Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

ITraceWriter Interface
Noemax.Newtonsoft.Json.Serialization Namespace


ITraceWriter Interface Methods

ITraceWriter Interface Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ITraceWriter Interface

For a list of all members of this type, see ITraceWriter members.

Public Methods
 | Name | Description
Method | Trace | Writes the specified trace level, message and optional exception.
Top
See Also

Reference

ITraceWriter Interface
Noemax.Newtonsoft.Json.Serialization Namespace


Trace Method (ITraceWriter)

Trace Method (ITraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > ITraceWriter Interface : Trace Method
The System.Diagnostics.TraceLevel at which to write this trace.
The trace message.
The trace exception. This parameter is optional.
Writes the specified trace level, message and optional exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub Trace( _
   ByVal level As System.Diagnostics.TraceLevel, _
   ByVal message As System.String, _
   ByVal ex As System.Exception _
)
'Usage

Dim instance As ITraceWriter
Dim level As System.Diagnostics.TraceLevel
Dim message As System.String
Dim ex As System.Exception

instance.Trace(level, message, ex)
void Trace(
   System.Diagnostics.TraceLevel level,
   System.string message,
   System.Exception ex
)
procedure Trace(
    level: System.Diagnostics.TraceLevel;
    message: System.String;
    ex: System.Exception
);
function Trace(
   level : System.Diagnostics.TraceLevel,
   message : System.String,
   ex : System.Exception
);
void Trace(
   System.Diagnostics.TraceLevel level,
   System.string* message,
   System.Exception* ex
)
void Trace(
   System.Diagnostics.TraceLevel level,
   System.String^ message,
   System.Exception^ ex
)

Parameters

level
The System.Diagnostics.TraceLevel at which to write this trace.
message
The trace message.
ex
The trace exception. This parameter is optional.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITraceWriter Interface
ITraceWriter Members


ITraceWriter Interface Properties

ITraceWriter Interface Properties

Noemax.Newtonsoft.Json.Serialization Namespace : ITraceWriter Interface

For a list of all members of this type, see ITraceWriter members.

Public Properties
 | Name | Description
Property | LevelFilter | Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Top
See Also

Reference

ITraceWriter Interface
Noemax.Newtonsoft.Json.Serialization Namespace


LevelFilter Property (ITraceWriter)

LevelFilter Property (ITraceWriter)

Noemax.Newtonsoft.Json.Serialization Namespace > ITraceWriter Interface : LevelFilter Property
Gets the System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer. For example a filter level of Info will exclude Verbose messages and include Info, Warning and Error messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

ReadOnly Property LevelFilter As System.Diagnostics.TraceLevel
'Usage

Dim instance As ITraceWriter
Dim value As System.Diagnostics.TraceLevel

value = instance.LevelFilter
System.Diagnostics.TraceLevel LevelFilter {get;}
read-only property LevelFilter: System.Diagnostics.TraceLevel;
function get LevelFilter : System.Diagnostics.TraceLevel
__property System.Diagnostics.TraceLevel get_LevelFilter();
property System.Diagnostics.TraceLevel LevelFilter {
   System.Diagnostics.TraceLevel get();
}

Property Value

The System.Diagnostics.TraceLevel that will be used to filter the trace messages passed to the writer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ITraceWriter Interface
ITraceWriter Members


IValueProvider Interface

IValueProvider Interface
Members

Noemax.Newtonsoft.Json.Serialization Namespace : IValueProvider Interface
Provides methods to get and set values.
Object Model
IValueProvider Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IValueProvider
'Usage

Dim instance As IValueProvider
public interface IValueProvider
public interface IValueProvider
public interface IValueProvider
public __gc __interface IValueProvider
public interface class IValueProvider
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValueProvider Members
Noemax.Newtonsoft.Json.Serialization Namespace


IValueProvider Interface Members

IValueProvider Interface Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IValueProvider Interface

The following tables list the members exposed by IValueProvider.

Public Methods
 | Name | Description
Method | GetValue | Gets the value.
Method | SetValue | Sets the value.
Top
See Also

Reference

IValueProvider Interface
Noemax.Newtonsoft.Json.Serialization Namespace


IValueProvider Interface Methods

IValueProvider Interface Methods

Noemax.Newtonsoft.Json.Serialization Namespace : IValueProvider Interface

For a list of all members of this type, see IValueProvider members.

Public Methods
 | Name | Description
Method | GetValue | Gets the value.
Method | SetValue | Sets the value.
Top
See Also

Reference

IValueProvider Interface
Noemax.Newtonsoft.Json.Serialization Namespace


GetValue Method (IValueProvider)

GetValue Method (IValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > IValueProvider Interface : GetValue Method
The target to get the value from.
Gets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetValue( _
   ByVal target As System.Object _
) As System.Object
'Usage

Dim instance As IValueProvider
Dim target As System.Object
Dim value As System.Object

value = instance.GetValue(target)
System.object GetValue(
   System.object target
)
function GetValue(
    target: System.TObject
): System.TObject;
function GetValue(
   target : System.Object
) : System.Object;
System.Object* GetValue(
   System.Object* target
)
System.Object^ GetValue(
   System.Object^ target
)

Parameters

target
The target to get the value from.

Return Value

The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValueProvider Interface
IValueProvider Members


SetValue Method (IValueProvider)

SetValue Method (IValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > IValueProvider Interface : SetValue Method
The target to set the value on.
The value to set on the target.
Sets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub SetValue( _
   ByVal target As System.Object, _
   ByVal value As System.Object _
)
'Usage

Dim instance As IValueProvider
Dim target As System.Object
Dim value As System.Object

instance.SetValue(target, value)
void SetValue(
   System.object target,
   System.object value
)
procedure SetValue(
    target: System.TObject;
    value: System.TObject
);
function SetValue(
   target : System.Object,
   value : System.Object
);
void SetValue(
   System.Object* target,
   System.Object* value
)
void SetValue(
   System.Object^ target,
   System.Object^ value
)

Parameters

target
The target to set the value on.
value
The value to set on the target.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IValueProvider Interface
IValueProvider Members


ExtensionDataGetter Delegate

ExtensionDataGetter Delegate

Noemax.Newtonsoft.Json.Serialization Namespace : ExtensionDataGetter Delegate
The object to set extension data on.
Gets extension data for an object during serialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ExtensionDataGetter( _
   ByVal o As System.Object _
) As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of Object,Object))
'Usage

Dim instance As New ExtensionDataGetter(AddressOf HandlerMethod)
public delegate System.Collections.Generic.IEnumerable<KeyValuePair<object,object>> ExtensionDataGetter(
   System.object o
)
public delegate ExtensionDataGetter(
    o: System.TObject
);
public delegate ExtensionDataGetter(
   o : System.Object
) : System.Collections.Generic.IEnumerable
public: __gc __delegate System.Collections.Generic.IEnumerable<KeyValuePair<Object*,Object*>>* ExtensionDataGetter(
   System.Object* o
)
public delegate System.Collections.Generic.IEnumerable<KeyValuePair<Object^,Object^>>^ ExtensionDataGetter(
   System.Object^ o
)

Parameters

o
The object to set extension data on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExtensionDataGetter Members
Noemax.Newtonsoft.Json.Serialization Namespace


ExtensionDataSetter Delegate

ExtensionDataSetter Delegate

Noemax.Newtonsoft.Json.Serialization Namespace : ExtensionDataSetter Delegate
The object to set extension data on.
The extension data key.
The extension data value.
Sets extension data for an object during deserialization.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub ExtensionDataSetter( _
   ByVal o As System.Object, _
   ByVal key As System.String, _
   ByVal value As System.Object _
)
'Usage

Dim instance As New ExtensionDataSetter(AddressOf HandlerMethod)
public delegate void ExtensionDataSetter(
   System.object o,
   System.string key,
   System.object value
)
public delegate ExtensionDataSetter(
    o: System.TObject;
    key: System.String;
    value: System.TObject
);
public delegate ExtensionDataSetter(
   o : System.Object,
   key : System.String,
   value : System.Object
)
public: __gc __delegate void ExtensionDataSetter(
   System.Object* o,
   System.string* key,
   System.Object* value
)
public delegate void ExtensionDataSetter(
   System.Object^ o,
   System.String^ key,
   System.Object^ value
)

Parameters

o
The object to set extension data on.
key
The extension data key.
value
The extension data value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExtensionDataSetter Members
Noemax.Newtonsoft.Json.Serialization Namespace


ObjectConstructor<T> Delegate

ObjectConstructor<T> Delegate

Noemax.Newtonsoft.Json.Serialization Namespace : ObjectConstructor<T> Delegate
The object type to create.
Represents a method that constructs an object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Function ObjectConstructor(Of T)( _
   ByVal ParamArray args() As System.Object _
) As System.Object
'Usage

Dim instance As New ObjectConstructor(Of T)(AddressOf HandlerMethod)
public delegate System.object ObjectConstructor<T>(
   params System.object[] args
)
public delegate ObjectConstructor(
   params  args: System.TObjectarray of
);
JScript does not support Generics.
public: __gc __delegate System.Object* ObjectConstructor<T>(
   params System.Object*[]* args
)
generic<typename T>
public delegate System.Object^ ObjectConstructor(
   ... System.array<Object^>^ args
)

Parameters

args

Type Parameters

T
The object type to create.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ObjectConstructor<T> Members
Noemax.Newtonsoft.Json.Serialization Namespace


SerializationCallback Delegate

SerializationCallback Delegate

Noemax.Newtonsoft.Json.Serialization Namespace : SerializationCallback Delegate
The object that raised the callback event.
The streaming context.
Handles Noemax.Newtonsoft.Json.JsonSerializer serialization callback events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub SerializationCallback( _
   ByVal o As System.Object, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As New SerializationCallback(AddressOf HandlerMethod)
public delegate void SerializationCallback(
   System.object o,
   System.Runtime.Serialization.StreamingContext context
)
public delegate SerializationCallback(
    o: System.TObject;
    context: System.Runtime.Serialization.StreamingContext
);
public delegate SerializationCallback(
   o : System.Object,
   context : System.Runtime.Serialization.StreamingContext
)
public: __gc __delegate void SerializationCallback(
   System.Object* o,
   System.Runtime.Serialization.StreamingContext context
)
public delegate void SerializationCallback(
   System.Object^ o,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

o
The object that raised the callback event.
context
The streaming context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializationCallback Members
Noemax.Newtonsoft.Json.Serialization Namespace


SerializationErrorCallback Delegate

SerializationErrorCallback Delegate

Noemax.Newtonsoft.Json.Serialization Namespace : SerializationErrorCallback Delegate
The object that raised the callback event.
The streaming context.
The error context.
Handles Noemax.Newtonsoft.Json.JsonSerializer serialization error callback events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub SerializationErrorCallback( _
   ByVal o As System.Object, _
   ByVal context As System.Runtime.Serialization.StreamingContext, _
   ByVal errorContext As ErrorContext _
)
'Usage

Dim instance As New SerializationErrorCallback(AddressOf HandlerMethod)
public delegate void SerializationErrorCallback(
   System.object o,
   System.Runtime.Serialization.StreamingContext context,
   ErrorContext errorContext
)
public delegate SerializationErrorCallback(
    o: System.TObject;
    context: System.Runtime.Serialization.StreamingContext;
    errorContext: ErrorContext
);
public delegate SerializationErrorCallback(
   o : System.Object,
   context : System.Runtime.Serialization.StreamingContext,
   errorContext : ErrorContext
)
public: __gc __delegate void SerializationErrorCallback(
   System.Object* o,
   System.Runtime.Serialization.StreamingContext context,
   ErrorContext* errorContext
)
public delegate void SerializationErrorCallback(
   System.Object^ o,
   System.Runtime.Serialization.StreamingContext context,
   ErrorContext^ errorContext
)

Parameters

o
The object that raised the callback event.
context
The streaming context.
errorContext
The error context.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializationErrorCallback Members
Noemax.Newtonsoft.Json.Serialization Namespace


Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets)

Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets)
Inheritance Hierarchy
See Also

Reference

Noemax.WebSockets Assembly


Noemax.WebSockets Namespace (Noemax.WebSockets)

Noemax.WebSockets Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BasicWebSocketClient | Provides the simplified WebSocket client.
Class | CompressionSettings | Provides configuration properties for WebSocket transport compression.
Class | WebSocketChannel | Defines the WebSocket channel interface.
Class | WebSocketClient | Provides the WebSocket protocol client connection.
Class | WebSocketClient<TService> | Provides the WebSocket protocol client connection.
Class | WebSocketClosedException | Provides the exception raised during WebSocket communications.
Class | WebSocketConnectionChannel | Provides methods and properties for exchanging messages over WebSocket connection.
Class | WebSocketEndpoint | Provides methods and properties of WebSocket endpoint.
Class | WebSocketEventArgs | Provides the arguments of the event triggered by the BasicWebSocketClient class.
Class | WebSocketException | Provides the exception raised during WebSocket communications.
Class | WebSocketHandshake | Provides method and properties for evaluating the WebSocket handshake prior it is accepted by the local side.
Class | WebSocketHandshakeHeader | Represents a handshake header to be exchanged among with standard WebSocket headers during the handshake.
Class | WebSocketHandshakeHeaderCollection | Provides the methods and property for managing collection of WebSocketHandshakeHeader.
Class | WebSocketInboundMessage | Represents the inbound message received through WebSocket connection. Provides methods and properties for processing inbound message.
Class | WebSocketProtocolException | Provides the exception thrown when connection is being closed due to violation of WebSocket protocol by remote side.
Class | WebSocketQueueSizeException | Provides the exception thrown when the size of outbound message queue, exceeds the maximum size.
Class | WebSocketServer | Provides the WebSocket protocol server.
Class | WebSocketServer<TService> | Provides the WebSocket protocol server.
Class | WebSocketServerSecurity | Provides the WebSocket server security settings that are applied when SSL/TLS transport security is enabled.
Class | WebSocketService | Provides the base class implementation for IWebSockets interface.
Class | WebSocketUsernamePasswordCredentials | Credentials used for basic client authentication using user-name and password.
Interfaces
 | Interface | Description
Interface | IWebSockets | Defines the contract that a service must implement in order to receive message and manage connections.
Structures
 | Structure | Description
Structure | WebSocketOutboundMessage | Represents the buffered message to be sent though WebSocket connection.
Delegates
 | Delegate | Description
Delegate | WebSocketHandshakeEventHandler | Represents a method handing the WebSocket handshake event.
Enumerations
 | Enumeration | Description
Enumeration | CompressionScheme | Specifies the compression scheme to be used by WebSocket.
Enumeration | WebSocketHandshakeAction | Defines the action to take as outcome of WebSocketHandshake.
Enumeration | WebSocketMessageState | Specifies the state of the WebSocket message.
Enumeration | WebSocketMessageType | Specifies the type of the WebSocket message content.
Enumeration | WebSocketState | Defines the states of WebSocket connection.
See Also

Reference

Noemax.WebSockets Assembly


BasicWebSocketClient Class

BasicWebSocketClient Class
Members

Noemax.WebSockets Namespace : BasicWebSocketClient Class
Provides the simplified WebSocket client.
Object Model
BasicWebSocketClient Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class BasicWebSocketClient
   Inherits WebSocketChannel
'Usage

Dim instance As BasicWebSocketClient
public class BasicWebSocketClient : WebSocketChannel
public class BasicWebSocketClient = class(WebSocketChannel)
public class BasicWebSocketClient extends WebSocketChannel
public __gc class BasicWebSocketClient : public WebSocketChannel
public ref class BasicWebSocketClient : public WebSocketChannel
Remarks
The WebSocket class is the simple client that handles all WebSocket events through the event handlers.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.BasicWebSocketClient

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Members
Noemax.WebSockets Namespace


BasicWebSocketClient Class Members

BasicWebSocketClient Class Members
Properties Methods Events

Noemax.WebSockets Namespace : BasicWebSocketClient Class

The following tables list the members exposed by BasicWebSocketClient.

Public Constructors
 | Name | Description
Public Constructor | BasicWebSocketClient Constructor | Creates a new instance of the WebSocket class with specified target URI.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the client is connected.
Public Property | Context | Overridden.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DispatchSynchronizationContext | Used for posting events to UI thread.
Public Property | ID | Overridden.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of the outbound message queue.
Public Property | MaxOutboundQueueSize | Overridden.
Public Property | Origin | Overridden.
Public Property | OutboundQueueSize | Overridden.
Public Property | PayloadMasking | Overridden. Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Overridden.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden.
Public Property | State | Overridden.
Public Property | Via | Overridden.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Aborts the WebSocket connection with the specified status code and description
Public Method | AddProperty<T> | Overridden.
Public Method | BeginSendMessage | Overridden.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete and closes the network connection.
Public Method | EndSendMessage | Overridden.
Public Method | GetProperty<T> | Overridden.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded.
Public Method | Send | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Overridden. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden.
Public Method | SendTextMessage | Overloaded.
Public Method | WaitForOutboundQueue | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | OnClose |
Public Event | OnError |
Public Event | OnMessage |
Public Event | OnOpen |
Public Event | OnPing |
Public Event | OnPong |
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


BasicWebSocketClient Constructor

BasicWebSocketClient Constructor

Noemax.WebSockets Namespace > BasicWebSocketClient Class : BasicWebSocketClient Constructor
The URI of the target service endpoint.
Creates a new instance of the WebSocket class with specified target URI.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri _
)
'Usage

Dim uri As System.Uri

Dim instance As New BasicWebSocketClient(uri)
public BasicWebSocketClient(
   System.Uri uri
)
public BasicWebSocketClient(
    uri: System.Uri
);
public function BasicWebSocketClient(
   uri : System.Uri
);
public: BasicWebSocketClient(
   System.Uri* uri
)
public:
BasicWebSocketClient(
   System.Uri^ uri
)

Parameters

uri
The URI of the target service endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


BasicWebSocketClient Class Methods

BasicWebSocketClient Class Methods

Noemax.WebSockets Namespace : BasicWebSocketClient Class

For a list of all members of this type, see BasicWebSocketClient members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Aborts the WebSocket connection with the specified status code and description
Public Method | AddProperty<T> | Overridden.
Public Method | BeginSendMessage | Overridden.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete and closes the network connection.
Public Method | EndSendMessage | Overridden.
Public Method | GetProperty<T> | Overridden.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded.
Public Method | Send | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Overridden. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden.
Public Method | SendTextMessage | Overloaded.
Public Method | WaitForOutboundQueue | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


Abort Method (BasicWebSocketClient)

Abort Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Abort Method
Aborts the WebSocket connection with the specified status code and description
Overload List
Overload | Description
Abort(Int32,String) | Aborts the WebSocket connection with the specified status code and description
Abort() |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Abort


Abort(Int32,String) Method

Abort(Int32,String) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Abort Method : Abort(Int32,String) Method
The status code to send to the remote endpoint with the close frame.
The text description to send to the remote endpoint with the close frame.
Aborts the WebSocket connection with the specified status code and description
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Abort( _
   ByVal status As System.Integer, _
   ByVal description As System.String _
)
'Usage

Dim instance As BasicWebSocketClient
Dim status As System.Integer
Dim description As System.String

instance.Abort(status, description)
public override void Abort(
   System.int status,
   System.string description
)
public procedure Abort(
    status: System.Integer;
    description: System.String
); override;
public override function Abort(
   status : System.int,
   description : System.String
);
public: void Abort(
   System.int status,
   System.string* description
) override
public:
void Abort(
   System.int status,
   System.String^ description
) override

Parameters

status
The status code to send to the remote endpoint with the close frame.
description
The text description to send to the remote endpoint with the close frame.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Abort(Int32,String)


Abort() Method

Abort() Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Abort Method : Abort() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Abort()
'Usage

Dim instance As BasicWebSocketClient

instance.Abort()
public override void Abort()
public procedure Abort(); override;
public override function Abort();
public: void Abort(); override
public:
void Abort(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Abort()


AddProperty<T> Method (BasicWebSocketClient)

AddProperty<T> Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : AddProperty<T> Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub AddProperty(Of T)( _
   ByVal obj As T _
)
'Usage

Dim instance As BasicWebSocketClient
Dim obj As T

instance.AddProperty(Of T)(obj)
public override void AddProperty<T>(
   T obj
)
public procedure AddProperty(
    obj: T
); override;
public override function AddProperty(
   obj : T
);
public: void AddProperty<T>(
   T* obj
) override
public:
void AddPropertygeneric<typename T>
(
   T^ obj
) override

Parameters

obj

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in AddProperty<T>


BeginSendMessage Method (BasicWebSocketClient)

BeginSendMessage Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : BeginSendMessage Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function BeginSendMessage( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As BasicWebSocketClient
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(message, timeout, callback, state)
public override System.IAsyncResult BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; override;
public override function BeginSendMessage(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
) override
public:
System.IAsyncResult^ BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
) override

Parameters

message
timeout
callback
state
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in BeginSendMessage


Close Method (BasicWebSocketClient)

Close Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Close Method
Wait for ongoing operation to be complete and closes the network connection.
Overload List
Overload | Description
Close(TimeSpan) |
Close() | Wait for ongoing operation to be complete and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Close


Close(TimeSpan) Method

Close(TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Close Method : Close(TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Close( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim timeout As System.TimeSpan

instance.Close(timeout)
public override void Close(
   System.TimeSpan timeout
)
public procedure Close(
    timeout: System.TimeSpan
); override;
public override function Close(
   timeout : System.TimeSpan
);
public: void Close(
   System.TimeSpan timeout
) override
public:
void Close(
   System.TimeSpan timeout
) override

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Close(TimeSpan)


EndSendMessage Method (BasicWebSocketClient)

EndSendMessage Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : EndSendMessage Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub EndSendMessage( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As BasicWebSocketClient
Dim result As System.IAsyncResult

instance.EndSendMessage(result)
public override void EndSendMessage(
   System.IAsyncResult result
)
public procedure EndSendMessage(
    result: System.IAsyncResult
); override;
public override function EndSendMessage(
   result : System.IAsyncResult
);
public: void EndSendMessage(
   System.IAsyncResult* result
) override
public:
void EndSendMessage(
   System.IAsyncResult^ result
) override

Parameters

result
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in EndSendMessage


GetProperty<T> Method (BasicWebSocketClient)

GetProperty<T> Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : GetProperty<T> Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetProperty(Of T)() As T
'Usage

Dim instance As BasicWebSocketClient
Dim value As T

value = instance.GetProperty(Of T)()
public override T GetProperty<T>()
public function GetProperty(): T; override;
public override function GetProperty() : T;
public: T* GetProperty<T>(); override
public:
T^ GetPropertygeneric<typename T>
(); override

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in GetProperty<T>


Open Method (BasicWebSocketClient)

Open Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Open Method
Overload List
Overload | Description
Open() |
Open(TimeSpan) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


Open() Method

Open() Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Open Method : Open() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Open()
'Usage

Dim instance As BasicWebSocketClient

instance.Open()
public void Open()
public procedure Open();
public function Open();
public: void Open();
public:
void Open();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List


Open(TimeSpan) Method

Open(TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Open Method : Open(TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Open( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim timeout As System.TimeSpan

instance.Open(timeout)
public void Open(
   System.TimeSpan timeout
)
public procedure Open(
    timeout: System.TimeSpan
);
public function Open(
   timeout : System.TimeSpan
);
public: void Open(
   System.TimeSpan timeout
)
public:
void Open(
   System.TimeSpan timeout
)

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List


Send Method (BasicWebSocketClient)

Send Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Send Method
Sends the message asynchronously.
Overload List
Overload | Description
Send(WebSocketOutboundMessage,TimeSpan) |
Send(Byte[],Int32,Int32,TimeSpan) |
Send(String,TimeSpan) |
Send(WebSocketOutboundMessage) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>,TimeSpan) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[]) | Sends a binary message with a specified array of bytes as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[],Int32,Int32) | Sends a binary message with a specified segment of array as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(String) | Sends a text message with a specified string as a payload within a specified interval of time. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Send


Send(WebSocketOutboundMessage,TimeSpan) Method

Send(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Send Method : Send(WebSocketOutboundMessage,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.Send(message, timeout)
public override void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure Send(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function Send(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Send(WebSocketOutboundMessage,TimeSpan)


Send(Byte[],Int32,Int32,TimeSpan) Method

Send(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Send Method : Send(Byte[],Int32,Int32,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.Send(buffer, offset, count, timeout)
public override void Send(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure Send(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function Send(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void Send(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void Send(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
offset
count
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Send(Byte[],Int32,Int32,TimeSpan)


Send(String,TimeSpan) Method

Send(String,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > Send Method : Send(String,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim text As System.String
Dim timeout As System.TimeSpan

instance.Send(text, timeout)
public override void Send(
   System.string text,
   System.TimeSpan timeout
)
public procedure Send(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function Send(
   text : System.String,
   timeout : System.TimeSpan
);
public: void Send(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void Send(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in Send(String,TimeSpan)


SendAsync Method (BasicWebSocketClient)

SendAsync Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendAsync Method
Sends a message within a specified interval of time asynchronously.
Overload List
Overload | Description
SendAsync(WebSocketOutboundMessage,TimeSpan) |
SendAsync(Byte[],Int32,Int32,TimeSpan) |
SendAsync(String,TimeSpan) |
SendAsync(WebSocketOutboundMessage) | Sends a message within a specified interval of time asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(Byte[],Int32,Int32) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(String) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in SendAsync


SendAsync(WebSocketOutboundMessage,TimeSpan) Method

SendAsync(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendAsync Method : SendAsync(WebSocketOutboundMessage,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendAsync(message, timeout)
public override void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendAsync(WebSocketOutboundMessage,TimeSpan)


SendAsync(Byte[],Int32,Int32,TimeSpan) Method

SendAsync(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendAsync Method : SendAsync(Byte[],Int32,Int32,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.SendAsync(buffer, offset, count, timeout)
public override void SendAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure SendAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
offset
count
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendAsync(Byte[],Int32,Int32,TimeSpan)


SendAsync(String,TimeSpan) Method

SendAsync(String,TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendAsync Method : SendAsync(String,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim text As System.String
Dim timeout As System.TimeSpan

instance.SendAsync(text, timeout)
public override void SendAsync(
   System.string text,
   System.TimeSpan timeout
)
public procedure SendAsync(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   text : System.String,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendAsync(String,TimeSpan)


SendBatchAsync Method (BasicWebSocketClient)

SendBatchAsync Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendBatchAsync Method
Sends the batch of the messages asynchronously.
Overload List
Overload | Description
SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) |
SendBatchAsync(WebSocketOutboundMessage[]) | Sends the batch of the messages asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in SendBatchAsync


SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim messages() As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendBatchAsync(messages, timeout)
public override void SendBatchAsync(
   WebSocketOutboundMessage[] messages,
   System.TimeSpan timeout
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of;
    timeout: System.TimeSpan
); override;
public override function SendBatchAsync(
   messages : WebSocketOutboundMessage[],
   timeout : System.TimeSpan
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* messages,
   System.TimeSpan timeout
) override
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages,
   System.TimeSpan timeout
) override

Parameters

messages
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendBatchAsync(WebSocketOutboundMessage[],TimeSpan)


SendClose Method (BasicWebSocketClient)

SendClose Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendClose Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub SendClose( _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As BasicWebSocketClient
Dim statusCode As System.Short
Dim reason As System.String
Dim timeout As System.TimeSpan

instance.SendClose(statusCode, reason, timeout)
public override void SendClose(
   System.short statusCode,
   System.string reason,
   System.TimeSpan timeout
)
public procedure SendClose(
    statusCode: System.Int16;
    reason: System.String;
    timeout: System.TimeSpan
); override;
public override function SendClose(
   statusCode : System.short,
   reason : System.String,
   timeout : System.TimeSpan
);
public: void SendClose(
   System.short statusCode,
   System.string* reason,
   System.TimeSpan timeout
) override
public:
void SendClose(
   System.short statusCode,
   System.String^ reason,
   System.TimeSpan timeout
) override

Parameters

statusCode
reason
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in SendClose


SendMessage Method (BasicWebSocketClient)

SendMessage Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendMessage Method
Streams the binary message to the remote side.
Overload List
Overload | Description
SendMessage(TimeSpan) |
SendMessage() | Streams the binary message to the remote side. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in SendMessage


SendMessage(TimeSpan) Method

SendMessage(TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendMessage Method : SendMessage(TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As BasicWebSocketClient
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.SendMessage(timeout)
public override System.IO.Stream SendMessage(
   System.TimeSpan timeout
)
public function SendMessage(
    timeout: System.TimeSpan
): System.IO.Stream; override;
public override function SendMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: System.IO.Stream* SendMessage(
   System.TimeSpan timeout
) override
public:
System.IO.Stream^ SendMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendMessage(TimeSpan)


SendPing Method (BasicWebSocketClient)

SendPing Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendPing Method
Overload List
Overload | Description
SendPing() |
SendPing(Byte[]) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in SendPing


SendPing() Method

SendPing() Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendPing Method : SendPing() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing()
'Usage

Dim instance As BasicWebSocketClient

instance.SendPing()
public override void SendPing()
public procedure SendPing(); override;
public override function SendPing();
public: void SendPing(); override
public:
void SendPing(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendPing()


SendPing(Byte[]) Method

SendPing(Byte[]) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendPing Method : SendPing(Byte[]) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing( _
   ByVal payload() As System.Byte _
)
'Usage

Dim instance As BasicWebSocketClient
Dim payload() As System.Byte

instance.SendPing(payload)
public override void SendPing(
   System.byte[] payload
)
public procedure SendPing(
    payload: System.Bytearray of
); override;
public override function SendPing(
   payload : System.byte[]
);
public: void SendPing(
   System.byte[]* payload
) override
public:
void SendPing(
   System.array<byte>^ payload
) override

Parameters

payload
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendPing(Byte[])


SendTextMessage Method (BasicWebSocketClient)

SendTextMessage Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : SendTextMessage Method
Overload List
Overload | Description
SendTextMessage() |
SendTextMessage(TimeSpan) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


SendTextMessage() Method

SendTextMessage() Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendTextMessage Method : SendTextMessage() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendTextMessage() As System.IO.TextWriter
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.IO.TextWriter

value = instance.SendTextMessage()
public System.IO.TextWriter SendTextMessage()
public function SendTextMessage(): System.IO.TextWriter;
public function SendTextMessage() : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage();
public:
System.IO.TextWriter^ SendTextMessage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List


SendTextMessage(TimeSpan) Method

SendTextMessage(TimeSpan) Method

Noemax.WebSockets Namespace > BasicWebSocketClient Class > SendTextMessage Method : SendTextMessage(TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendTextMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.TextWriter
'Usage

Dim instance As BasicWebSocketClient
Dim timeout As System.TimeSpan
Dim value As System.IO.TextWriter

value = instance.SendTextMessage(timeout)
public override System.IO.TextWriter SendTextMessage(
   System.TimeSpan timeout
)
public function SendTextMessage(
    timeout: System.TimeSpan
): System.IO.TextWriter; override;
public override function SendTextMessage(
   timeout : System.TimeSpan
) : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage(
   System.TimeSpan timeout
) override
public:
System.IO.TextWriter^ SendTextMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Overload List
Base Implementation in SendTextMessage


WaitForOutboundQueue Method (BasicWebSocketClient)

WaitForOutboundQueue Method (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : WaitForOutboundQueue Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function WaitForOutboundQueue( _
   ByVal queueSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As BasicWebSocketClient
Dim queueSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(queueSize, timeout)
public override System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    queueSize: System.Int64;
    timeout: System.TimeSpan
): System.Boolean; override;
public override function WaitForOutboundQueue(
   queueSize : System.long,
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
) override
public:
System.bool WaitForOutboundQueue(
   System.int64 queueSize,
   System.TimeSpan timeout
) override

Parameters

queueSize
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in WaitForOutboundQueue


BasicWebSocketClient Class Properties

BasicWebSocketClient Class Properties

Noemax.WebSockets Namespace : BasicWebSocketClient Class

For a list of all members of this type, see BasicWebSocketClient members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the client is connected.
Public Property | Context | Overridden.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DispatchSynchronizationContext | Used for posting events to UI thread.
Public Property | ID | Overridden.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of the outbound message queue.
Public Property | MaxOutboundQueueSize | Overridden.
Public Property | Origin | Overridden.
Public Property | OutboundQueueSize | Overridden.
Public Property | PayloadMasking | Overridden. Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Overridden.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden.
Public Property | State | Overridden.
Public Property | Via | Overridden.
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


AuthenticationContext Property (BasicWebSocketClient)

AuthenticationContext Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : AuthenticationContext Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property AuthenticationContext As System.Object
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Object

value = instance.AuthenticationContext
public override System.object AuthenticationContext {get;}
public read-only property AuthenticationContext: System.TObject; override;
public override function get AuthenticationContext : System.Object
public: __property System.Object* get_AuthenticationContext() override;
public:
property System.Object^ AuthenticationContext {
   System.Object^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in AuthenticationContext


AutoPingInterval Property (BasicWebSocketClient)

AutoPingInterval Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : AutoPingInterval Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property AutoPingInterval As System.TimeSpan
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.TimeSpan

instance.AutoPingInterval = value

value = instance.AutoPingInterval
public override System.TimeSpan AutoPingInterval {get; set;}
public read-write property AutoPingInterval: System.TimeSpan; override;
public override function get,set AutoPingInterval : System.TimeSpan
public: __property System.TimeSpan get_AutoPingInterval() override;
public: __property void set_AutoPingInterval(
   System.TimeSpan value
) override;
public:
property System.TimeSpan AutoPingInterval {
   System.TimeSpan get() override;
   void set (    System.TimeSpan value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in AutoPingInterval


Connected Property (BasicWebSocketClient)

Connected Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Connected Property
Gets whether the client is connected.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Connected As System.Boolean
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Boolean

value = instance.Connected
public override System.bool Connected {get;}
public read-only property Connected: System.Boolean; override;
public override function get Connected : System.boolean
public: __property System.bool get_Connected() override;
public:
property System.bool Connected {
   System.bool get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Connected


Context Property (BasicWebSocketClient)

Context Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Context Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Context As System.Object
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Object

instance.Context = value

value = instance.Context
public override System.object Context {get; set;}
public read-write property Context: System.TObject; override;
public override function get,set Context : System.Object
public: __property System.Object* get_Context() override;
public: __property void set_Context(
   System.Object* value
) override;
public:
property System.Object^ Context {
   System.Object^ get() override;
   void set (    System.Object^ value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Context


DispatchSynchronizationContext Property (BasicWebSocketClient)

DispatchSynchronizationContext Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : DispatchSynchronizationContext Property
Used for posting events to UI thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DispatchSynchronizationContext As System.Threading.SynchronizationContext
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Threading.SynchronizationContext

instance.DispatchSynchronizationContext = value

value = instance.DispatchSynchronizationContext
public System.Threading.SynchronizationContext DispatchSynchronizationContext {get; set;}
public read-write property DispatchSynchronizationContext: System.Threading.SynchronizationContext;
public function get,set DispatchSynchronizationContext : System.Threading.SynchronizationContext
public: __property System.Threading.SynchronizationContext* get_DispatchSynchronizationContext();
public: __property void set_DispatchSynchronizationContext(
   System.Threading.SynchronizationContext* value
);
public:
property System.Threading.SynchronizationContext^ DispatchSynchronizationContext {
   System.Threading.SynchronizationContext^ get();
   void set (    System.Threading.SynchronizationContext^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


ID Property (BasicWebSocketClient)

ID Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : ID Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property ID As System.String
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.String

instance.ID = value

value = instance.ID
public override System.string ID {get; set;}
public read-write property ID: System.String; override;
public override function get,set ID : System.String
public: __property System.string* get_ID() override;
public: __property void set_ID(
   System.string* value
) override;
public:
property System.String^ ID {
   System.String^ get() override;
   void set (    System.String^ value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in ID


MaxOutboundFrameSize Property (BasicWebSocketClient)

MaxOutboundFrameSize Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : MaxOutboundFrameSize Property
Gets and sets the maximum size of the outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxOutboundFrameSize As System.Long
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Long

instance.MaxOutboundFrameSize = value

value = instance.MaxOutboundFrameSize
public System.long MaxOutboundFrameSize {get; set;}
public read-write property MaxOutboundFrameSize: System.Int64;
public function get,set MaxOutboundFrameSize : System.long
public: __property System.long get_MaxOutboundFrameSize();
public: __property void set_MaxOutboundFrameSize(
   System.long value
);
public:
property System.int64 MaxOutboundFrameSize {
   System.int64 get();
   void set (    System.int64 value);
}
Remarks

If asynchronous send operations would result in outbound queue size exceeding the specified limit, it fails with WebSocketQueueSizeException thrown.

Synchronous send operations does not use outbound message queue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


MaxOutboundQueueSize Property (BasicWebSocketClient)

MaxOutboundQueueSize Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : MaxOutboundQueueSize Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property MaxOutboundQueueSize As System.Long
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Long

instance.MaxOutboundQueueSize = value

value = instance.MaxOutboundQueueSize
public override System.long MaxOutboundQueueSize {get; set;}
public read-write property MaxOutboundQueueSize: System.Int64; override;
public override function get,set MaxOutboundQueueSize : System.long
public: __property System.long get_MaxOutboundQueueSize() override;
public: __property void set_MaxOutboundQueueSize(
   System.long value
) override;
public:
property System.int64 MaxOutboundQueueSize {
   System.int64 get() override;
   void set (    System.int64 value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in MaxOutboundQueueSize


Origin Property (BasicWebSocketClient)

Origin Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Origin Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Origin As System.String
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.String

value = instance.Origin
public override System.string Origin {get;}
public read-only property Origin: System.String; override;
public override function get Origin : System.String
public: __property System.string* get_Origin() override;
public:
property System.String^ Origin {
   System.String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Origin


OutboundQueueSize Property (BasicWebSocketClient)

OutboundQueueSize Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OutboundQueueSize Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutboundQueueSize As System.Long
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Long

value = instance.OutboundQueueSize
public override System.long OutboundQueueSize {get;}
public read-only property OutboundQueueSize: System.Int64; override;
public override function get OutboundQueueSize : System.long
public: __property System.long get_OutboundQueueSize() override;
public:
property System.int64 OutboundQueueSize {
   System.int64 get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in OutboundQueueSize


PayloadMasking Property (BasicWebSocketClient)

PayloadMasking Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : PayloadMasking Property
Get or sets whether payload of outbound messages is masked.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PayloadMasking As System.Boolean
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public override System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean; override;
public override function get,set PayloadMasking : System.boolean
public: __property System.bool get_PayloadMasking() override;
public: __property void set_PayloadMasking(
   System.bool value
) override;
public:
property System.bool PayloadMasking {
   System.bool get() override;
   void set (    System.bool value) override;
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking by setting this property, but strict WebSocket implementations will drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in PayloadMasking


Protocol Property (BasicWebSocketClient)

Protocol Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Protocol Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Protocol As System.String
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.String

value = instance.Protocol
public override System.string Protocol {get;}
public read-only property Protocol: System.String; override;
public override function get Protocol : System.String
public: __property System.string* get_Protocol() override;
public:
property System.String^ Protocol {
   System.String^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Protocol


ServiceInstance Property (BasicWebSocketClient)

ServiceInstance Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : ServiceInstance Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property ServiceInstance As IWebSockets
'Usage

Dim instance As BasicWebSocketClient
Dim value As IWebSockets

instance.ServiceInstance = value

value = instance.ServiceInstance
public override IWebSockets ServiceInstance {get; set;}
public read-write property ServiceInstance: IWebSockets; override;
public override function get,set ServiceInstance : IWebSockets
public: __property IWebSockets* get_ServiceInstance() override;
public: __property void set_ServiceInstance(
   IWebSockets* value
) override;
public:
property IWebSockets^ ServiceInstance {
   IWebSockets^ get() override;
   void set (    IWebSockets^ value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in ServiceInstance


State Property (BasicWebSocketClient)

State Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : State Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property State As WebSocketState
'Usage

Dim instance As BasicWebSocketClient
Dim value As WebSocketState

value = instance.State
public override WebSocketState State {get;}
public read-only property State: WebSocketState; override;
public override function get State : WebSocketState
public: __property WebSocketState get_State() override;
public:
property WebSocketState State {
   WebSocketState get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in State


Via Property (BasicWebSocketClient)

Via Property (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : Via Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Via As System.Uri
'Usage

Dim instance As BasicWebSocketClient
Dim value As System.Uri

value = instance.Via
public override System.Uri Via {get;}
public read-only property Via: System.Uri; override;
public override function get Via : System.Uri
public: __property System.Uri* get_Via() override;
public:
property System.Uri^ Via {
   System.Uri^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members
Base Implementation in Via


BasicWebSocketClient Class Events

BasicWebSocketClient Class Events

Noemax.WebSockets Namespace : BasicWebSocketClient Class

For a list of all members of this type, see BasicWebSocketClient members.

Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | OnClose |
Public Event | OnError |
Public Event | OnMessage |
Public Event | OnOpen |
Public Event | OnPing |
Public Event | OnPong |
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


OnClose Event (BasicWebSocketClient)

OnClose Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnClose Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnClose As System.EventHandler(Of EventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of EventArgs)

AddHandler instance.OnClose, handler
public event System.EventHandler<EventArgs> OnClose
public event OnClose: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<EventArgs*>* OnClose
public:
event System.EventHandler<EventArgs^>^ OnClose
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


OnError Event (BasicWebSocketClient)

OnError Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnError Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnError As System.EventHandler(Of WebSocketEventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of WebSocketEventArgs)

AddHandler instance.OnError, handler
public event System.EventHandler<WebSocketEventArgs> OnError
public event OnError: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketEventArgs*>* OnError
public:
event System.EventHandler<WebSocketEventArgs^>^ OnError
Event Data

The event handler receives an argument of type WebSocketEventArgs containing data related to this event. The following WebSocketEventArgs properties provide information specific to this event.

Property | Description
BinaryData | The payload of the binary message.
Exception | Exception thrown during WebSocket operation.
Message | The WebSocketInboundMessage object associated to the message.
TextData | The payload of the text message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


OnMessage Event (BasicWebSocketClient)

OnMessage Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnMessage Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnMessage As System.EventHandler(Of WebSocketEventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of WebSocketEventArgs)

AddHandler instance.OnMessage, handler
public event System.EventHandler<WebSocketEventArgs> OnMessage
public event OnMessage: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketEventArgs*>* OnMessage
public:
event System.EventHandler<WebSocketEventArgs^>^ OnMessage
Event Data

The event handler receives an argument of type WebSocketEventArgs containing data related to this event. The following WebSocketEventArgs properties provide information specific to this event.

Property | Description
BinaryData | The payload of the binary message.
Exception | Exception thrown during WebSocket operation.
Message | The WebSocketInboundMessage object associated to the message.
TextData | The payload of the text message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


OnOpen Event (BasicWebSocketClient)

OnOpen Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnOpen Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnOpen As System.EventHandler(Of EventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of EventArgs)

AddHandler instance.OnOpen, handler
public event System.EventHandler<EventArgs> OnOpen
public event OnOpen: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<EventArgs*>* OnOpen
public:
event System.EventHandler<EventArgs^>^ OnOpen
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


OnPing Event (BasicWebSocketClient)

OnPing Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnPing Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnPing As System.EventHandler(Of WebSocketEventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of WebSocketEventArgs)

AddHandler instance.OnPing, handler
public event System.EventHandler<WebSocketEventArgs> OnPing
public event OnPing: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketEventArgs*>* OnPing
public:
event System.EventHandler<WebSocketEventArgs^>^ OnPing
Event Data

The event handler receives an argument of type WebSocketEventArgs containing data related to this event. The following WebSocketEventArgs properties provide information specific to this event.

Property | Description
BinaryData | The payload of the binary message.
Exception | Exception thrown during WebSocket operation.
Message | The WebSocketInboundMessage object associated to the message.
TextData | The payload of the text message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


OnPong Event (BasicWebSocketClient)

OnPong Event (BasicWebSocketClient)

Noemax.WebSockets Namespace > BasicWebSocketClient Class : OnPong Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnPong As System.EventHandler(Of WebSocketEventArgs)
'Usage

Dim instance As BasicWebSocketClient
Dim handler As System.EventHandler(Of WebSocketEventArgs)

AddHandler instance.OnPong, handler
public event System.EventHandler<WebSocketEventArgs> OnPong
public event OnPong: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketEventArgs*>* OnPong
public:
event System.EventHandler<WebSocketEventArgs^>^ OnPong
Event Data

The event handler receives an argument of type WebSocketEventArgs containing data related to this event. The following WebSocketEventArgs properties provide information specific to this event.

Property | Description
BinaryData | The payload of the binary message.
Exception | Exception thrown during WebSocket operation.
Message | The WebSocketInboundMessage object associated to the message.
TextData | The payload of the text message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BasicWebSocketClient Class
BasicWebSocketClient Members


CompressionSettings Class

CompressionSettings Class
Members

Noemax.WebSockets Namespace : CompressionSettings Class
Provides configuration properties for WebSocket transport compression.
Object Model
CompressionSettings Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CompressionSettings
'Usage

Dim instance As CompressionSettings
public class CompressionSettings
public class CompressionSettings
public class CompressionSettings
public __gc class CompressionSettings
public ref class CompressionSettings
Inheritance Hierarchy

System.Object
Noemax.WebSockets.CompressionSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Members
Noemax.WebSockets Namespace


CompressionSettings Class Members

CompressionSettings Class Members
Properties Methods

Noemax.WebSockets Namespace : CompressionSettings Class

The following tables list the members exposed by CompressionSettings.

Public Constructors
 | Name | Description
Public Constructor | CompressionSettings Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CompressionLevel | Gets and set the compression level to be used by the transport compression.
Public Property | CompressionScheme | Specifies the compression scheme to be used by WebSocket connections.
Public Property | NoContextTakeover | Gets and sets whether compression should takeover compression context between messages.
Top
Public Methods
 | Name | Description
Public Method | CopyFrom | Copies all properties from another instance.
Public Method | CopyTo | Copies all properties to another instance of CompressionSettings.
Top
See Also

Reference

CompressionSettings Class
Noemax.WebSockets Namespace


CompressionSettings Constructor

CompressionSettings Constructor

Noemax.WebSockets Namespace > CompressionSettings Class : CompressionSettings Constructor
Overload List
Overload | Description
CompressionSettings Constructor() | Initialize a new instance of CompressionSettings.
CompressionSettings Constructor(CompressionSettings) | Initialize a new instance of CompressionSettings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


CompressionSettings Constructor()

CompressionSettings Constructor()

Noemax.WebSockets Namespace > CompressionSettings Class > CompressionSettings Constructor : CompressionSettings Constructor()
Initialize a new instance of CompressionSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New CompressionSettings()
public CompressionSettings()
public CompressionSettings();
public function CompressionSettings();
public: CompressionSettings();
public:
CompressionSettings();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members
Overload List


CompressionSettings Constructor(CompressionSettings)

CompressionSettings Constructor(CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class > CompressionSettings Constructor : CompressionSettings Constructor(CompressionSettings)
The compression settings to use with a new instance.
Initialize a new instance of CompressionSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal settings As CompressionSettings _
)
'Usage

Dim settings As CompressionSettings

Dim instance As New CompressionSettings(settings)
public CompressionSettings(
   CompressionSettings settings
)
public CompressionSettings(
    settings: CompressionSettings
);
public function CompressionSettings(
   settings : CompressionSettings
);
public: CompressionSettings(
   CompressionSettings* settings
)
public:
CompressionSettings(
   CompressionSettings^ settings
)

Parameters

settings
The compression settings to use with a new instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members
Overload List


CompressionSettings Class Methods

CompressionSettings Class Methods

Noemax.WebSockets Namespace : CompressionSettings Class

For a list of all members of this type, see CompressionSettings members.

Public Methods
 | Name | Description
Public Method | CopyFrom | Copies all properties from another instance.
Public Method | CopyTo | Copies all properties to another instance of CompressionSettings.
Top
See Also

Reference

CompressionSettings Class
Noemax.WebSockets Namespace


CopyFrom Method (CompressionSettings)

CopyFrom Method (CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class : CopyFrom Method
The instance to copy all properties from.
Copies all properties from another instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyFrom( _
   ByVal settings As CompressionSettings _
)
'Usage

Dim instance As CompressionSettings
Dim settings As CompressionSettings

instance.CopyFrom(settings)
public void CopyFrom(
   CompressionSettings settings
)
public procedure CopyFrom(
    settings: CompressionSettings
);
public function CopyFrom(
   settings : CompressionSettings
);
public: void CopyFrom(
   CompressionSettings* settings
)
public:
void CopyFrom(
   CompressionSettings^ settings
)

Parameters

settings
The instance to copy all properties from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


CopyTo Method (CompressionSettings)

CopyTo Method (CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class : CopyTo Method
The instance to copy all properties too.
Copies all properties to another instance of CompressionSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal settings As CompressionSettings _
)
'Usage

Dim instance As CompressionSettings
Dim settings As CompressionSettings

instance.CopyTo(settings)
public void CopyTo(
   CompressionSettings settings
)
public procedure CopyTo(
    settings: CompressionSettings
);
public function CopyTo(
   settings : CompressionSettings
);
public: void CopyTo(
   CompressionSettings* settings
)
public:
void CopyTo(
   CompressionSettings^ settings
)

Parameters

settings
The instance to copy all properties too.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


CompressionSettings Class Properties

CompressionSettings Class Properties

Noemax.WebSockets Namespace : CompressionSettings Class

For a list of all members of this type, see CompressionSettings members.

Public Properties
 | Name | Description
Public Property | CompressionLevel | Gets and set the compression level to be used by the transport compression.
Public Property | CompressionScheme | Specifies the compression scheme to be used by WebSocket connections.
Public Property | NoContextTakeover | Gets and sets whether compression should takeover compression context between messages.
Top
See Also

Reference

CompressionSettings Class
Noemax.WebSockets Namespace


CompressionLevel Property (CompressionSettings)

CompressionLevel Property (CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class : CompressionLevel Property
Gets and set the compression level to be used by the transport compression.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressionLevel As System.Integer
'Usage

Dim instance As CompressionSettings
Dim value As System.Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
public System.int CompressionLevel {get; set;}
public read-write property CompressionLevel: System.Integer;
public function get,set CompressionLevel : System.int
public: __property System.int get_CompressionLevel();
public: __property void set_CompressionLevel(
   System.int value
);
public:
property System.int CompressionLevel {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


CompressionScheme Property (CompressionSettings)

CompressionScheme Property (CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class : CompressionScheme Property
Specifies the compression scheme to be used by WebSocket connections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressionScheme As CompressionScheme
'Usage

Dim instance As CompressionSettings
Dim value As CompressionScheme

instance.CompressionScheme = value

value = instance.CompressionScheme
public CompressionScheme CompressionScheme {get; set;}
public read-write property CompressionScheme: CompressionScheme;
public function get,set CompressionScheme : CompressionScheme
public: __property CompressionScheme get_CompressionScheme();
public: __property void set_CompressionScheme(
   CompressionScheme value
);
public:
property CompressionScheme CompressionScheme {
   CompressionScheme get();
   void set (    CompressionScheme value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


NoContextTakeover Property (CompressionSettings)

NoContextTakeover Property (CompressionSettings)

Noemax.WebSockets Namespace > CompressionSettings Class : NoContextTakeover Property
Gets and sets whether compression should takeover compression context between messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property NoContextTakeover As System.Boolean
'Usage

Dim instance As CompressionSettings
Dim value As System.Boolean

instance.NoContextTakeover = value

value = instance.NoContextTakeover
public System.bool NoContextTakeover {get; set;}
public read-write property NoContextTakeover: System.Boolean;
public function get,set NoContextTakeover : System.boolean
public: __property System.bool get_NoContextTakeover();
public: __property void set_NoContextTakeover(
   System.bool value
);
public:
property System.bool NoContextTakeover {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressionSettings Class
CompressionSettings Members


WebSocketChannel Class

WebSocketChannel Class
Members

Noemax.WebSockets Namespace : WebSocketChannel Class
Defines the WebSocket channel interface.
Object Model
WebSocketChannel Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class WebSocketChannel
'Usage

Dim instance As WebSocketChannel
public abstract class WebSocketChannel
public class WebSocketChannel abstract;
public abstract class WebSocketChannel
public __gc abstract class WebSocketChannel
public ref class WebSocketChannel abstract
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.BasicWebSocketClient
Noemax.WebSockets.WebSocketConnectionChannel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Members
Noemax.WebSockets Namespace


WebSocketChannel Class Members

WebSocketChannel Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketChannel Class

The following tables list the members exposed by WebSocketChannel.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets authentication context assigned to the channel when it was authenticated by the server endpoint.
Public Property | AutoPingInterval | Gets and sets the interval of time for sending Ping messages automatically.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses.
Public Property | Connected | Gets whether the channel connection is considered being alive.
Public Property | Context | The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages.
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages.
Public Property | ID | Gets and sets the string identifier of the channel.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum number of bytes pending to be sent in outbound message queue.
Public Property | Origin | Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Gets the number of bytes pending to be sent in outbound message queue.
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the list of Sub-Protocols used by the channel.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages.
Public Property | ServiceInstance | The instance of the IWebSocket handling inbound messages.
Public Property | State | Gets and sets the states of WebSocket connection.
Public Property | Via | Gets the URI to which this channel was established.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects.
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Wait for ongoing operation to be complete and closes the network connection.
Public Method | EndSendMessage | Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel.
Public Method | Send | Overloaded. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Sends the batch of the messages asynchronously.
Public Method | SendClose | Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Sends the ping message.
Public Method | SendTextMessage | Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Waits for outbound message queue size in bytes decrease below a specified limit within a specified interval of time.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed |
Protected Method | NotifyError |
Protected Method | NotifyPing |
Protected Method | NotifyPong |
Top
Public Events
 | Name | Description
Public Event | Closed |
Public Event | Error |
Public Event | Ping |
Public Event | Pong |
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


WebSocketChannel Class Methods

WebSocketChannel Class Methods

Noemax.WebSockets Namespace : WebSocketChannel Class

For a list of all members of this type, see WebSocketChannel members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects.
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Wait for ongoing operation to be complete and closes the network connection.
Public Method | EndSendMessage | Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel.
Public Method | Send | Overloaded. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Sends the batch of the messages asynchronously.
Public Method | SendClose | Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Sends the ping message.
Public Method | SendTextMessage | Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Waits for outbound message queue size in bytes decrease below a specified limit within a specified interval of time.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed |
Protected Method | NotifyError |
Protected Method | NotifyPing |
Protected Method | NotifyPong |
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


Abort Method (WebSocketChannel)

Abort Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Abort Method
Interrupt all ongoing operation and closes the network connection.
Overload List
Overload | Description
Abort() | Interrupt all ongoing operation and closes the network connection.
Abort(Int32,String) | Interrupt all ongoing operation and closes the network connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Abort() Method

Abort() Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Abort Method : Abort() Method
Interrupt all ongoing operation and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Abort()
'Usage

Dim instance As WebSocketChannel

instance.Abort()
public abstract void Abort()
public procedure Abort(); abstract;
public __abstract function Abort();
public: abstract void Abort();
public:
abstract void Abort();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Abort(Int32,String) Method

Abort(Int32,String) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Abort Method : Abort(Int32,String) Method
Interrupt all ongoing operation and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Abort( _
   ByVal status As System.Integer, _
   ByVal description As System.String _
)
'Usage

Dim instance As WebSocketChannel
Dim status As System.Integer
Dim description As System.String

instance.Abort(status, description)
public abstract void Abort(
   System.int status,
   System.string description
)
public procedure Abort(
    status: System.Integer;
    description: System.String
); abstract;
public __abstract function Abort(
   status : System.int,
   description : System.String
);
public: abstract void Abort(
   System.int status,
   System.string* description
)
public:
abstract void Abort(
   System.int status,
   System.String^ description
)

Parameters

status
description
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


AddProperty<T> Method (WebSocketChannel)

AddProperty<T> Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : AddProperty<T> Method
The type of the object being added.
The object of the specified type.
Adds the object of the specified type to the collection of associated objects.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub AddProperty(Of T)( _
   ByVal obj As T _
)
'Usage

Dim instance As WebSocketChannel
Dim obj As T

instance.AddProperty(Of T)(obj)
public virtual void AddProperty<T>(
   T obj
)
public procedure AddProperty(
    obj: T
); virtual;
public function AddProperty(
   obj : T
);
public: virtual void AddProperty<T>(
   T* obj
)
public:
virtual void AddPropertygeneric<typename T>
(
   T^ obj
)

Parameters

obj
The object of the specified type.

Type Parameters

T
The type of the object being added.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


BeginSendMessage Method (WebSocketChannel)

BeginSendMessage Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : BeginSendMessage Method
The string identifying the operation to which the message is getting sent.
The period of time during which operation must be completed or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to the asynchronous operation.
Begins an asynchronous operation to send a message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function BeginSendMessage( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(message, timeout, callback, state)
public abstract System.IAsyncResult BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; abstract;
public __abstract function BeginSendMessage(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: abstract System.IAsyncResult* BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
abstract System.IAsyncResult^ BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

message
The string identifying the operation to which the message is getting sent.
timeout
The period of time during which operation must be completed or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to the asynchronous operation.

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Close Method (WebSocketChannel)

Close Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Close Method
Wait for ongoing operation to be complete and closes the network connection.
Overload List
Overload | Description
Close() | Wait for ongoing operation to be complete and closes the network connection.
Close(TimeSpan) | Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Close() Method

Close() Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Close Method : Close() Method
Wait for ongoing operation to be complete and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Close()
'Usage

Dim instance As WebSocketChannel

instance.Close()
public void Close()
public procedure Close();
public function Close();
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Close(TimeSpan) Method

Close(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Close Method : Close(TimeSpan) Method
The interval of time to wait for ongoing operations to be completed, prior closing the connection.
Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Close( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim timeout As System.TimeSpan

instance.Close(timeout)
public abstract void Close(
   System.TimeSpan timeout
)
public procedure Close(
    timeout: System.TimeSpan
); abstract;
public __abstract function Close(
   timeout : System.TimeSpan
);
public: abstract void Close(
   System.TimeSpan timeout
)
public:
abstract void Close(
   System.TimeSpan timeout
)

Parameters

timeout
The interval of time to wait for ongoing operations to be completed, prior closing the connection.
Remarks
Prior connection is closed, WebSocketChannel waits for ongoing inbound and outbound transfers to be completed for specified period of time. Once timeout expire or all ongoing transfers are complete, connection is getting closed and all associated resources are released.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


EndSendMessage Method (WebSocketChannel)

EndSendMessage Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : EndSendMessage Method
The IAsyncResult that references the asynchronous request operation.
Completes an asynchronous send operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub EndSendMessage( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As WebSocketChannel
Dim result As System.IAsyncResult

instance.EndSendMessage(result)
public abstract void EndSendMessage(
   System.IAsyncResult result
)
public procedure EndSendMessage(
    result: System.IAsyncResult
); abstract;
public __abstract function EndSendMessage(
   result : System.IAsyncResult
);
public: abstract void EndSendMessage(
   System.IAsyncResult* result
)
public:
abstract void EndSendMessage(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


GetProperty<T> Method (WebSocketChannel)

GetProperty<T> Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : GetProperty<T> Method
The type of the object to get.
Returns the object of specified type associated to the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetProperty(Of T)() As T
'Usage

Dim instance As WebSocketChannel
Dim value As T

value = instance.GetProperty(Of T)()
public virtual T GetProperty<T>()
public function GetProperty(): T; virtual;
public function GetProperty() : T;
public: virtual T* GetProperty<T>();
public:
virtual T^ GetPropertygeneric<typename T>
();

Type Parameters

T
The type of the object to get.

Return Value

The object of specified type or null if object of the specified type was not found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


GetServiceInstance Method (WebSocketChannel)

GetServiceInstance Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : GetServiceInstance Method
When overridden returns an IWebSockets instance to handle messages received by the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetServiceInstance() As IWebSockets
'Usage

Dim instance As WebSocketChannel
Dim value As IWebSockets

value = instance.GetServiceInstance()
public virtual IWebSockets GetServiceInstance()
public function GetServiceInstance(): IWebSockets; virtual;
public function GetServiceInstance() : IWebSockets;
public: virtual IWebSockets* GetServiceInstance();
public:
virtual IWebSockets^ GetServiceInstance();

Return Value

Returns an instance of IWebSocket service to handle message received by the channel.
Remarks
Overriding this methods allows inherited class to initialize a new instance of the service in case if it was not set by application code. E.g. WebSocketClient<TService> can automatically initialize the instance of the class using default constructor of typed parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


NotifyClosed Method (WebSocketChannel)

NotifyClosed Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : NotifyClosed Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub NotifyClosed( _
   ByVal args As WebSocketCloseEventArgs _
)
'Usage

Dim instance As WebSocketChannel
Dim args As WebSocketCloseEventArgs

instance.NotifyClosed(args)
protected void NotifyClosed(
   WebSocketCloseEventArgs args
)
protected procedure NotifyClosed(
    args: WebSocketCloseEventArgs
);
protected function NotifyClosed(
   args : WebSocketCloseEventArgs
);
protected: void NotifyClosed(
   WebSocketCloseEventArgs* args
)
protected:
void NotifyClosed(
   WebSocketCloseEventArgs^ args
)

Parameters

args
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


NotifyError Method (WebSocketChannel)

NotifyError Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : NotifyError Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub NotifyError( _
   ByVal e As System.Exception _
)
'Usage

Dim instance As WebSocketChannel
Dim e As System.Exception

instance.NotifyError(e)
protected void NotifyError(
   System.Exception e
)
protected procedure NotifyError(
    e: System.Exception
);
protected function NotifyError(
   e : System.Exception
);
protected: void NotifyError(
   System.Exception* e
)
protected:
void NotifyError(
   System.Exception^ e
)

Parameters

e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


NotifyPing Method (WebSocketChannel)

NotifyPing Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : NotifyPing Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub NotifyPing( _
   ByVal args As WebSocketPingOrPongEventArgs _
)
'Usage

Dim instance As WebSocketChannel
Dim args As WebSocketPingOrPongEventArgs

instance.NotifyPing(args)
protected void NotifyPing(
   WebSocketPingOrPongEventArgs args
)
protected procedure NotifyPing(
    args: WebSocketPingOrPongEventArgs
);
protected function NotifyPing(
   args : WebSocketPingOrPongEventArgs
);
protected: void NotifyPing(
   WebSocketPingOrPongEventArgs* args
)
protected:
void NotifyPing(
   WebSocketPingOrPongEventArgs^ args
)

Parameters

args
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


NotifyPong Method (WebSocketChannel)

NotifyPong Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : NotifyPong Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Sub NotifyPong( _
   ByVal args As WebSocketPingOrPongEventArgs _
)
'Usage

Dim instance As WebSocketChannel
Dim args As WebSocketPingOrPongEventArgs

instance.NotifyPong(args)
protected void NotifyPong(
   WebSocketPingOrPongEventArgs args
)
protected procedure NotifyPong(
    args: WebSocketPingOrPongEventArgs
);
protected function NotifyPong(
   args : WebSocketPingOrPongEventArgs
);
protected: void NotifyPong(
   WebSocketPingOrPongEventArgs* args
)
protected:
void NotifyPong(
   WebSocketPingOrPongEventArgs^ args
)

Parameters

args
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Send Method (WebSocketChannel)

Send Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Send Method
Sends the message asynchronously.
Overload List
Overload | Description
Send(WebSocketOutboundMessage) | Sends the message asynchronously.
Send(WebSocketOutboundMessage,TimeSpan) | Sends the message asynchronously.
Send(ArraySegment<Byte>) | Sends a binary message with a specified array segment as a payload.
Send(ArraySegment<Byte>,TimeSpan) | Sends a binary message with a specified array segment as a payload.
Send(Byte[]) | Sends a binary message with a specified array of bytes as a payload.
Send(Byte[],Int32,Int32) | Sends a binary message with a specified segment of array as a payload.
Send(Byte[],Int32,Int32,TimeSpan) | Sends a binary message with a specified segment of array as a payload within specified interval of time.
Send(String) | Sends a text message with a specified string as a payload within a specified interval of time.
Send(String,TimeSpan) | Sends a text message with a specified string as a payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Send(WebSocketOutboundMessage) Method

Send(WebSocketOutboundMessage) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(WebSocketOutboundMessage) Method
WebSocketOutboundMessage value containing the message.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketChannel
Dim message As WebSocketOutboundMessage

instance.Send(message)
public void Send(
   WebSocketOutboundMessage message
)
public procedure Send(
    message: WebSocketOutboundMessage
);
public function Send(
   message : WebSocketOutboundMessage
);
public: void Send(
   WebSocketOutboundMessage message
)
public:
void Send(
   WebSocketOutboundMessage message
)

Parameters

message
WebSocketOutboundMessage value containing the message.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(WebSocketOutboundMessage,TimeSpan) Method

Send(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(WebSocketOutboundMessage,TimeSpan) Method
WebSocketOutboundMessage value containing the message.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Send( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.Send(message, timeout)
public abstract void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure Send(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); abstract;
public __abstract function Send(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: abstract void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public:
abstract void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)

Parameters

message
WebSocketOutboundMessage value containing the message.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(ArraySegment<Byte>) Method

Send(ArraySegment<Byte>) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(ArraySegment<Byte>) Method
The segment of array being sent as a payload.
Sends a binary message with a specified array segment as a payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal message As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocketChannel
Dim message As System.ArraySegment(Of Byte)

instance.Send(message)
public void Send(
   System.ArraySegment<byte> message
)
public procedure Send(
    message: System.ArraySegment
);
public function Send(
   message : System.ArraySegment
);
public: void Send(
   System.ArraySegment<byte> message
)
public:
void Send(
   System.ArraySegment<byte> message
)

Parameters

message
The segment of array being sent as a payload.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(ArraySegment<Byte>,TimeSpan) Method

Send(ArraySegment<Byte>,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(ArraySegment<Byte>,TimeSpan) Method
The segment of array being sent as a payload.
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Sends a binary message with a specified array segment as a payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal message As System.ArraySegment(Of Byte), _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim message As System.ArraySegment(Of Byte)
Dim timeout As System.TimeSpan

instance.Send(message, timeout)
public void Send(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)
public procedure Send(
    message: System.ArraySegment;
    timeout: System.TimeSpan
);
public function Send(
   message : System.ArraySegment,
   timeout : System.TimeSpan
);
public: void Send(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)
public:
void Send(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)

Parameters

message
The segment of array being sent as a payload.
timeout
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(Byte[]) Method

Send(Byte[]) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(Byte[]) Method
The byte array being sent as a payload.
Sends a binary message with a specified array of bytes as a payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal buffer() As System.Byte _
)
'Usage

Dim instance As WebSocketChannel
Dim buffer() As System.Byte

instance.Send(buffer)
public void Send(
   System.byte[] buffer
)
public procedure Send(
    buffer: System.Bytearray of
);
public function Send(
   buffer : System.byte[]
);
public: void Send(
   System.byte[]* buffer
)
public:
void Send(
   System.array<byte>^ buffer
)

Parameters

buffer
The byte array being sent as a payload.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(Byte[],Int32,Int32) Method

Send(Byte[],Int32,Int32) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(Byte[],Int32,Int32) Method
The array with bytes being sent.
The offset of bytes being sent in a specified array.
The number of bytes to send.
Sends a binary message with a specified segment of array as a payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim instance As WebSocketChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

instance.Send(buffer, offset, count)
public void Send(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public procedure Send(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function Send(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: void Send(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
void Send(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
The array with bytes being sent.
offset
The offset of bytes being sent in a specified array.
count
The number of bytes to send.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(Byte[],Int32,Int32,TimeSpan) Method

Send(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(Byte[],Int32,Int32,TimeSpan) Method
The array containing the bytes being sent.
The offset of bytes being sent in a specified array.
The number of bytes to send.
The interval of time during which the operation have to complete before timing out.
Sends a binary message with a specified segment of array as a payload within specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Send( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.Send(buffer, offset, count, timeout)
public abstract void Send(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure Send(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); abstract;
public __abstract function Send(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: abstract void Send(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public:
abstract void Send(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)

Parameters

buffer
The array containing the bytes being sent.
offset
The offset of bytes being sent in a specified array.
count
The number of bytes to send.
timeout
The interval of time during which the operation have to complete before timing out.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(String) Method

Send(String) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(String) Method
The text payload of the message.
Sends a text message with a specified string as a payload within a specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Send( _
   ByVal text As System.String _
)
'Usage

Dim instance As WebSocketChannel
Dim text As System.String

instance.Send(text)
public void Send(
   System.string text
)
public procedure Send(
    text: System.String
);
public function Send(
   text : System.String
);
public: void Send(
   System.string* text
)
public:
void Send(
   System.String^ text
)

Parameters

text
The text payload of the message.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


Send(String,TimeSpan) Method

Send(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > Send Method : Send(String,TimeSpan) Method
The string being sent as a payload.
The interval of time during which the operation have to complete before timing out.
Sends a text message with a specified string as a payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub Send( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim text As System.String
Dim timeout As System.TimeSpan

instance.Send(text, timeout)
public abstract void Send(
   System.string text,
   System.TimeSpan timeout
)
public procedure Send(
    text: System.String;
    timeout: System.TimeSpan
); abstract;
public __abstract function Send(
   text : System.String,
   timeout : System.TimeSpan
);
public: abstract void Send(
   System.string* text,
   System.TimeSpan timeout
)
public:
abstract void Send(
   System.String^ text,
   System.TimeSpan timeout
)

Parameters

text
The string being sent as a payload.
timeout
The interval of time during which the operation have to complete before timing out.
Remarks
This methods does not always send message a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync Method (WebSocketChannel)

SendAsync Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendAsync Method
Sends a message within a specified interval of time asynchronously.
Overload List
Overload | Description
SendAsync(WebSocketOutboundMessage) | Sends a message within a specified interval of time asynchronously.
SendAsync(WebSocketOutboundMessage,TimeSpan) | Sends the message asynchronously.
SendAsync(Byte[],Int32,Int32) | Sends the message asynchronously.
SendAsync(Byte[],Int32,Int32,TimeSpan) | Sends the message asynchronously.
SendAsync(String) | Sends the message asynchronously.
SendAsync(String,TimeSpan) | Sends the message asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


SendAsync(WebSocketOutboundMessage) Method

SendAsync(WebSocketOutboundMessage) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(WebSocketOutboundMessage) Method
The message being sent.
Sends a message within a specified interval of time asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendAsync( _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketChannel
Dim message As WebSocketOutboundMessage

instance.SendAsync(message)
public void SendAsync(
   WebSocketOutboundMessage message
)
public procedure SendAsync(
    message: WebSocketOutboundMessage
);
public function SendAsync(
   message : WebSocketOutboundMessage
);
public: void SendAsync(
   WebSocketOutboundMessage message
)
public:
void SendAsync(
   WebSocketOutboundMessage message
)

Parameters

message
The message being sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync(WebSocketOutboundMessage,TimeSpan) Method

SendAsync(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(WebSocketOutboundMessage,TimeSpan) Method
The outbound message to send.
The interval of time during which the operation have to complete before timing out.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendAsync(message, timeout)
public abstract void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); abstract;
public __abstract function SendAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: abstract void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public:
abstract void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)

Parameters

message
The outbound message to send.
timeout
The interval of time during which the operation have to complete before timing out.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync(Byte[],Int32,Int32) Method

SendAsync(Byte[],Int32,Int32) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(Byte[],Int32,Int32) Method
The buffer containing the message payload.
The index in the buffer where message payload starts.
The length of the message payload in bytes.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim instance As WebSocketChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

instance.SendAsync(buffer, offset, count)
public void SendAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public procedure SendAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function SendAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: void SendAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
void SendAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
The buffer containing the message payload.
offset
The index in the buffer where message payload starts.
count
The length of the message payload in bytes.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync(Byte[],Int32,Int32,TimeSpan) Method

SendAsync(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(Byte[],Int32,Int32,TimeSpan) Method
The buffer containing the message payload.
The index in the buffer where message payload starts.
The length of the message payload in bytes.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.SendAsync(buffer, offset, count, timeout)
public abstract void SendAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure SendAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); abstract;
public __abstract function SendAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: abstract void SendAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public:
abstract void SendAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)

Parameters

buffer
The buffer containing the message payload.
offset
The index in the buffer where message payload starts.
count
The length of the message payload in bytes.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync(String) Method

SendAsync(String) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(String) Method
The text payload of the message.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendAsync( _
   ByVal text As System.String _
)
'Usage

Dim instance As WebSocketChannel
Dim text As System.String

instance.SendAsync(text)
public void SendAsync(
   System.string text
)
public procedure SendAsync(
    text: System.String
);
public function SendAsync(
   text : System.String
);
public: void SendAsync(
   System.string* text
)
public:
void SendAsync(
   System.String^ text
)

Parameters

text
The text payload of the message.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendAsync(String,TimeSpan) Method

SendAsync(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendAsync Method : SendAsync(String,TimeSpan) Method
The text payload of the message.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendAsync( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim text As System.String
Dim timeout As System.TimeSpan

instance.SendAsync(text, timeout)
public abstract void SendAsync(
   System.string text,
   System.TimeSpan timeout
)
public procedure SendAsync(
    text: System.String;
    timeout: System.TimeSpan
); abstract;
public __abstract function SendAsync(
   text : System.String,
   timeout : System.TimeSpan
);
public: abstract void SendAsync(
   System.string* text,
   System.TimeSpan timeout
)
public:
abstract void SendAsync(
   System.String^ text,
   System.TimeSpan timeout
)

Parameters

text
The text payload of the message.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendBatchAsync Method (WebSocketChannel)

SendBatchAsync Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendBatchAsync Method
Sends the batch of the messages asynchronously.
Overload List
Overload | Description
SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) | Sends the batch of the messages asynchronously.
SendBatchAsync(WebSocketOutboundMessage[]) | Sends the batch of the messages asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method
The batch of messages to be sent.
The amount of time during which to wait for messages to be sent. TimeoutException will be thrown if messages is not completely sent within the specified period of the time.
Sends the batch of the messages asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim messages() As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendBatchAsync(messages, timeout)
public abstract void SendBatchAsync(
   WebSocketOutboundMessage[] messages,
   System.TimeSpan timeout
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of;
    timeout: System.TimeSpan
); abstract;
public __abstract function SendBatchAsync(
   messages : WebSocketOutboundMessage[],
   timeout : System.TimeSpan
);
public: abstract void SendBatchAsync(
   WebSocketOutboundMessage[]* messages,
   System.TimeSpan timeout
)
public:
abstract void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages,
   System.TimeSpan timeout
)

Parameters

messages
The batch of messages to be sent.
timeout
The amount of time during which to wait for messages to be sent. TimeoutException will be thrown if messages is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it's first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendBatchAsync(WebSocketOutboundMessage[]) Method

SendBatchAsync(WebSocketOutboundMessage[]) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[]) Method
The batch of messages to be sent.
Sends the batch of the messages asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketChannel
Dim messages() As WebSocketOutboundMessage

instance.SendBatchAsync(messages)
public void SendBatchAsync(
   WebSocketOutboundMessage[] messages
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of
);
public function SendBatchAsync(
   messages : WebSocketOutboundMessage[]
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* messages
)
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages
)

Parameters

messages
The batch of messages to be sent.
Remarks

When message is sent asynchronously it's first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendClose Method (WebSocketChannel)

SendClose Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendClose Method
The status code in range of 1000-4999 that specifies the reason why connection is being closed.
The string description of the status. Not required to be human readable but UTF-8 representation of the string should not exceed 125 bytes.
The amount of time to wait for CLOSE frame to be sent, prior TimeoutException is thrown.
Sends the CLOSE control frame with specified statusCode and reason string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub SendClose( _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketChannel
Dim statusCode As System.Short
Dim reason As System.String
Dim timeout As System.TimeSpan

instance.SendClose(statusCode, reason, timeout)
public abstract void SendClose(
   System.short statusCode,
   System.string reason,
   System.TimeSpan timeout
)
public procedure SendClose(
    statusCode: System.Int16;
    reason: System.String;
    timeout: System.TimeSpan
); abstract;
public __abstract function SendClose(
   statusCode : System.short,
   reason : System.String,
   timeout : System.TimeSpan
);
public: abstract void SendClose(
   System.short statusCode,
   System.string* reason,
   System.TimeSpan timeout
)
public:
abstract void SendClose(
   System.short statusCode,
   System.String^ reason,
   System.TimeSpan timeout
)

Parameters

statusCode
The status code in range of 1000-4999 that specifies the reason why connection is being closed.
reason
The string description of the status. Not required to be human readable but UTF-8 representation of the string should not exceed 125 bytes.
timeout
The amount of time to wait for CLOSE frame to be sent, prior TimeoutException is thrown.
Remarks
When CLOSE frame is sent to remote side, no more messages or fragments can be sent though the connection. Local side can continue receiving pending messages until connection is closed by remote side. SendClose() does not close the connection, Close(TimeSpan) method need to be called to close connection and release all associated resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


SendMessage Method (WebSocketChannel)

SendMessage Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendMessage Method
Streams the binary message to the remote side.
Overload List
Overload | Description
SendMessage() | Streams the binary message to the remote side.
SendMessage(TimeSpan) | Streams the binary message to the remote side.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


SendMessage() Method

SendMessage() Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendMessage Method : SendMessage() Method
Streams the binary message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendMessage() As System.IO.Stream
'Usage

Dim instance As WebSocketChannel
Dim value As System.IO.Stream

value = instance.SendMessage()
public System.IO.Stream SendMessage()
public function SendMessage(): System.IO.Stream;
public function SendMessage() : System.IO.Stream;
public: System.IO.Stream* SendMessage();
public:
System.IO.Stream^ SendMessage();

Return Value

The input to write the outbound message payload into.
Remarks

This method is part of the streaming API, it allows to input messages of arbitrary size to remote side and avoid buffering entire message in the memory.

The input returned by this methods, writes the message payload directly into WebSocket connection.

Fragmentation and buffering are performed automatically. As soon as input buffer have to be flushed, buffered bytes are sent as a message fragment and become available on remote side.

If amount of bytes being written in single write operation is more than the size of input buffer, then these bytes are getting combined with bytes already buffered and sent as a single fragment.

You can force input to send buffered bytes by calling Flush() method.

You can input any amount of data as payload of the message until you decide to close it. Closing the input concludes the outbound message and final fragment frame is sent to remote side to indicate the end of the message.

The flow control is performed by TCP layer. The writing side is getting blocked if remote side input buffers are full. As faster remote side reads data, as faster the local side can continue sending.

Note: WebSocket connection cannot input more than one message concurrently.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendMessage(TimeSpan) Method

SendMessage(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendMessage Method : SendMessage(TimeSpan) Method
The interval of time during which the operation have to complete before timing out.
Streams the binary message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function SendMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As WebSocketChannel
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.SendMessage(timeout)
public abstract System.IO.Stream SendMessage(
   System.TimeSpan timeout
)
public function SendMessage(
    timeout: System.TimeSpan
): System.IO.Stream; abstract;
public __abstract function SendMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: abstract System.IO.Stream* SendMessage(
   System.TimeSpan timeout
)
public:
abstract System.IO.Stream^ SendMessage(
   System.TimeSpan timeout
)

Parameters

timeout
The interval of time during which the operation have to complete before timing out.

Return Value

The input to write the outbound message payload into.
Remarks

This method is part of the streaming API, it allows to input messages of arbitrary size to remote side and avoid buffering entire message in the memory.

The input returned by this methods, writes the message payload directly into WebSocket connection.

Fragmentation and buffering are performed automatically. As soon as input buffer have to be flushed, buffered bytes are sent as a message fragment and become available on remote side.

If amount of bytes being written in single write operation is more than the size of input buffer, then these bytes are getting combined with bytes already buffered and sent as a single fragment.

You can force input to send buffered bytes by calling Flush() method.

You can input any amount of data as payload of the message until you decide to close it. Closing the input concludes the outbound message and final fragment frame is sent to remote side to indicate the end of the message.

The flow control is performed by TCP layer. The writing side is getting blocked if remote side input buffers are full. As faster remote side reads data, as faster the local side can continue sending.

Note: WebSocket connection cannot input more than one message concurrently.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendPing Method (WebSocketChannel)

SendPing Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendPing Method
Sends the ping message.
Overload List
Overload | Description
SendPing() | Sends the ping message.
SendPing(Byte[]) | Sends the ping message with a specified binary payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


SendPing() Method

SendPing() Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendPing Method : SendPing() Method
Sends the ping message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendPing()
'Usage

Dim instance As WebSocketChannel

instance.SendPing()
public abstract void SendPing()
public procedure SendPing(); abstract;
public __abstract function SendPing();
public: abstract void SendPing();
public:
abstract void SendPing();
Remarks
The pong message is sent automatically when ping message is received. The IWebSockets.OnPong method of associated service will be called, upon receiving the pong reply to the ping message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendPing(Byte[]) Method

SendPing(Byte[]) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > SendPing Method : SendPing(Byte[]) Method
The array of bytes being sent as payload of the ping message.
Sends the ping message with a specified binary payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Sub SendPing( _
   ByVal payload() As System.Byte _
)
'Usage

Dim instance As WebSocketChannel
Dim payload() As System.Byte

instance.SendPing(payload)
public abstract void SendPing(
   System.byte[] payload
)
public procedure SendPing(
    payload: System.Bytearray of
); abstract;
public __abstract function SendPing(
   payload : System.byte[]
);
public: abstract void SendPing(
   System.byte[]* payload
)
public:
abstract void SendPing(
   System.array<byte>^ payload
)

Parameters

payload
The array of bytes being sent as payload of the ping message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


SendTextMessage Method (WebSocketChannel)

SendTextMessage Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : SendTextMessage Method
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.
Streams the text message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function SendTextMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.TextWriter
'Usage

Dim instance As WebSocketChannel
Dim timeout As System.TimeSpan
Dim value As System.IO.TextWriter

value = instance.SendTextMessage(timeout)
public abstract System.IO.TextWriter SendTextMessage(
   System.TimeSpan timeout
)
public function SendTextMessage(
    timeout: System.TimeSpan
): System.IO.TextWriter; abstract;
public __abstract function SendTextMessage(
   timeout : System.TimeSpan
) : System.IO.TextWriter;
public: abstract System.IO.TextWriter* SendTextMessage(
   System.TimeSpan timeout
)
public:
abstract System.IO.TextWriter^ SendTextMessage(
   System.TimeSpan timeout
)

Parameters

timeout
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.

Return Value

The text writer to write the outbound message payload into.
Remarks
Streams fragmented text message to remote side using the input provided by SendMessage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


WaitForOutboundQueue Method (WebSocketChannel)

WaitForOutboundQueue Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : WaitForOutboundQueue Method
The number of bytes below which the queue size is expected decrease within the specified interval of time.
The interval of time to wait for the queue size to decrease below the specified limit.
Waits for outbound message queue size in bytes decrease below a specified limit within a specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function WaitForOutboundQueue( _
   ByVal queueSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocketChannel
Dim queueSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(queueSize, timeout)
public abstract System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    queueSize: System.Int64;
    timeout: System.TimeSpan
): System.Boolean; abstract;
public __abstract function WaitForOutboundQueue(
   queueSize : System.long,
   timeout : System.TimeSpan
) : System.boolean;
public: abstract System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public:
abstract System.bool WaitForOutboundQueue(
   System.int64 queueSize,
   System.TimeSpan timeout
)

Parameters

queueSize
The number of bytes below which the queue size is expected decrease within the specified interval of time.
timeout
The interval of time to wait for the queue size to decrease below the specified limit.

Return Value

Returns true if the queue size had decreased below specified; false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


WebSocketChannel Class Properties

WebSocketChannel Class Properties

Noemax.WebSockets Namespace : WebSocketChannel Class

For a list of all members of this type, see WebSocketChannel members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets authentication context assigned to the channel when it was authenticated by the server endpoint.
Public Property | AutoPingInterval | Gets and sets the interval of time for sending Ping messages automatically.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses.
Public Property | Connected | Gets whether the channel connection is considered being alive.
Public Property | Context | The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages.
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages.
Public Property | ID | Gets and sets the string identifier of the channel.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum number of bytes pending to be sent in outbound message queue.
Public Property | Origin | Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Gets the number of bytes pending to be sent in outbound message queue.
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the list of Sub-Protocols used by the channel.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages.
Public Property | ServiceInstance | The instance of the IWebSocket handling inbound messages.
Public Property | State | Gets and sets the states of WebSocket connection.
Public Property | Via | Gets the URI to which this channel was established.
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


AuthenticationContext Property (WebSocketChannel)

AuthenticationContext Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : AuthenticationContext Property
Gets authentication context assigned to the channel when it was authenticated by the server endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property AuthenticationContext As System.Object
'Usage

Dim instance As WebSocketChannel
Dim value As System.Object

value = instance.AuthenticationContext
public abstract System.object AuthenticationContext {get;}
public read-only property AuthenticationContext: System.TObject; abstract;
public __abstract function get AuthenticationContext : System.Object
public: __property abstract System.Object* get_AuthenticationContext();
public:
abstract property System.Object^ AuthenticationContext {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


AutoPingInterval Property (WebSocketChannel)

AutoPingInterval Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : AutoPingInterval Property
Gets and sets the interval of time for sending Ping messages automatically.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property AutoPingInterval As System.TimeSpan
'Usage

Dim instance As WebSocketChannel
Dim value As System.TimeSpan

instance.AutoPingInterval = value

value = instance.AutoPingInterval
public abstract System.TimeSpan AutoPingInterval {get; set;}
public read-write property AutoPingInterval: System.TimeSpan; abstract;
public __abstract function get,set AutoPingInterval : System.TimeSpan
public: __property abstract System.TimeSpan get_AutoPingInterval();
public: __property abstract void set_AutoPingInterval(
   System.TimeSpan value
);
public:
abstract property System.TimeSpan AutoPingInterval {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


ClientDispatcher Property (WebSocketChannel)

ClientDispatcher Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : ClientDispatcher Property
Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClientDispatcher As IClientDispatcher
'Usage

Dim instance As WebSocketChannel
Dim value As IClientDispatcher

instance.ClientDispatcher = value

value = instance.ClientDispatcher
public IClientDispatcher ClientDispatcher {get; set;}
public read-write property ClientDispatcher: IClientDispatcher;
public function get,set ClientDispatcher : IClientDispatcher
public: __property IClientDispatcher* get_ClientDispatcher();
public: __property void set_ClientDispatcher(
   IClientDispatcher* value
);
public:
property IClientDispatcher^ ClientDispatcher {
   IClientDispatcher^ get();
   void set (    IClientDispatcher^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Connected Property (WebSocketChannel)

Connected Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Connected Property
Gets whether the channel connection is considered being alive.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Connected As System.Boolean
'Usage

Dim instance As WebSocketChannel
Dim value As System.Boolean

value = instance.Connected
public abstract System.bool Connected {get;}
public read-only property Connected: System.Boolean; abstract;
public __abstract function get Connected : System.boolean
public: __property abstract System.bool get_Connected();
public:
abstract property System.bool Connected {
   System.bool get();
}
Remarks

This property reports the last operation state of the channel rather than performs the actual TCP connectivity checks.

When this property value is true, it indicates that channel is not being closed and last send/receive operations where completed successfully.

When this property value is false, it indicates that channel is either being closed or closed. This does not exclude the possibility that channel is in transition state and may still be able to send or receive messages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Context Property (WebSocketChannel)

Context Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Context Property
The context object associated to the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property Context As System.Object
'Usage

Dim instance As WebSocketChannel
Dim value As System.Object

instance.Context = value

value = instance.Context
public abstract System.object Context {get; set;}
public read-write property Context: System.TObject; abstract;
public __abstract function get,set Context : System.Object
public: __property abstract System.Object* get_Context();
public: __property abstract void set_Context(
   System.Object* value
);
public:
abstract property System.Object^ Context {
   System.Object^ get();
   void set (    System.Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


DefaultReceiveTimeout Property (WebSocketChannel)

DefaultReceiveTimeout Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : DefaultReceiveTimeout Property
Gets and sets the default timeout interval, to be used when receiving messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultReceiveTimeout As System.TimeSpan
'Usage

Dim instance As WebSocketChannel
Dim value As System.TimeSpan

instance.DefaultReceiveTimeout = value

value = instance.DefaultReceiveTimeout
public System.TimeSpan DefaultReceiveTimeout {get; set;}
public read-write property DefaultReceiveTimeout: System.TimeSpan;
public function get,set DefaultReceiveTimeout : System.TimeSpan
public: __property System.TimeSpan get_DefaultReceiveTimeout();
public: __property void set_DefaultReceiveTimeout(
   System.TimeSpan value
);
public:
property System.TimeSpan DefaultReceiveTimeout {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


DefaultSendTimeout Property (WebSocketChannel)

DefaultSendTimeout Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : DefaultSendTimeout Property
Gets and sets the default timeout interval, to be used when sending messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultSendTimeout As System.TimeSpan
'Usage

Dim instance As WebSocketChannel
Dim value As System.TimeSpan

instance.DefaultSendTimeout = value

value = instance.DefaultSendTimeout
public System.TimeSpan DefaultSendTimeout {get; set;}
public read-write property DefaultSendTimeout: System.TimeSpan;
public function get,set DefaultSendTimeout : System.TimeSpan
public: __property System.TimeSpan get_DefaultSendTimeout();
public: __property void set_DefaultSendTimeout(
   System.TimeSpan value
);
public:
property System.TimeSpan DefaultSendTimeout {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


ID Property (WebSocketChannel)

ID Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : ID Property
Gets and sets the string identifier of the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property ID As System.String
'Usage

Dim instance As WebSocketChannel
Dim value As System.String

instance.ID = value

value = instance.ID
public abstract System.string ID {get; set;}
public read-write property ID: System.String; abstract;
public __abstract function get,set ID : System.String
public: __property abstract System.string* get_ID();
public: __property abstract void set_ID(
   System.string* value
);
public:
abstract property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
By default this property is set to a GUID assigned by WebSocketService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


MaxOutboundQueueSize Property (WebSocketChannel)

MaxOutboundQueueSize Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : MaxOutboundQueueSize Property
Gets and sets the maximum number of bytes pending to be sent in outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property MaxOutboundQueueSize As System.Long
'Usage

Dim instance As WebSocketChannel
Dim value As System.Long

instance.MaxOutboundQueueSize = value

value = instance.MaxOutboundQueueSize
public abstract System.long MaxOutboundQueueSize {get; set;}
public read-write property MaxOutboundQueueSize: System.Int64; abstract;
public __abstract function get,set MaxOutboundQueueSize : System.long
public: __property abstract System.long get_MaxOutboundQueueSize();
public: __property abstract void set_MaxOutboundQueueSize(
   System.long value
);
public:
abstract property System.int64 MaxOutboundQueueSize {
   System.int64 get();
   void set (    System.int64 value);
}
Remarks
When the number of bytes pending to be sent grows over the specified number, WebSocketQueueSizeException is thrown upon attempt to send more messages. WebSocket can continue sending messages once OutboundQueueSize number goes below the specified number.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Origin Property (WebSocketChannel)

Origin Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Origin Property
Gets origin string negotiated during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Origin As System.String
'Usage

Dim instance As WebSocketChannel
Dim value As System.String

value = instance.Origin
public abstract System.string Origin {get;}
public read-only property Origin: System.String; abstract;
public __abstract function get Origin : System.String
public: __property abstract System.string* get_Origin();
public:
abstract property System.String^ Origin {
   System.String^ get();
}
Remarks
The Origin string may be required by WebSocket server to identify the script that runs on the client side when WebSocket is used by a browser client. This optional header is exchanged during the WebSocket handshake, both the server and the client may drop a connection if the value of the Origin string does not match their expectation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


OutboundQueueSize Property (WebSocketChannel)

OutboundQueueSize Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : OutboundQueueSize Property
Gets the number of bytes pending to be sent in outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property OutboundQueueSize As System.Long
'Usage

Dim instance As WebSocketChannel
Dim value As System.Long

value = instance.OutboundQueueSize
public abstract System.long OutboundQueueSize {get;}
public read-only property OutboundQueueSize: System.Int64; abstract;
public __abstract function get OutboundQueueSize : System.long
public: __property abstract System.long get_OutboundQueueSize();
public:
abstract property System.int64 OutboundQueueSize {
   System.int64 get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


PayloadMasking Property (WebSocketChannel)

PayloadMasking Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : PayloadMasking Property
Gets and sets whether the payload of outbound messages is masked.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property PayloadMasking As System.Boolean
'Usage

Dim instance As WebSocketChannel
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public abstract System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean; abstract;
public __abstract function get,set PayloadMasking : System.boolean
public: __property abstract System.bool get_PayloadMasking();
public: __property abstract void set_PayloadMasking(
   System.bool value
);
public:
abstract property System.bool PayloadMasking {
   System.bool get();
   void set (    System.bool value);
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking by setting this property, but strict WebSocket implementations will drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Protocol Property (WebSocketChannel)

Protocol Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Protocol Property
Gets and sets the list of Sub-Protocols used by the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Protocol As System.String
'Usage

Dim instance As WebSocketChannel
Dim value As System.String

value = instance.Protocol
public abstract System.string Protocol {get;}
public read-only property Protocol: System.String; abstract;
public __abstract function get Protocol : System.String
public: __property abstract System.string* get_Protocol();
public:
abstract property System.String^ Protocol {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Serializer Property (WebSocketChannel)

Serializer Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Serializer Property
Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Serializer As IMessageSerializer
'Usage

Dim instance As WebSocketChannel
Dim value As IMessageSerializer

instance.Serializer = value

value = instance.Serializer
public IMessageSerializer Serializer {get; set;}
public read-write property Serializer: IMessageSerializer;
public function get,set Serializer : IMessageSerializer
public: __property IMessageSerializer* get_Serializer();
public: __property void set_Serializer(
   IMessageSerializer* value
);
public:
property IMessageSerializer^ Serializer {
   IMessageSerializer^ get();
   void set (    IMessageSerializer^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


ServiceInstance Property (WebSocketChannel)

ServiceInstance Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : ServiceInstance Property
The instance of the IWebSocket handling inbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property ServiceInstance As IWebSockets
'Usage

Dim instance As WebSocketChannel
Dim value As IWebSockets

instance.ServiceInstance = value

value = instance.ServiceInstance
public abstract IWebSockets ServiceInstance {get; set;}
public read-write property ServiceInstance: IWebSockets; abstract;
public __abstract function get,set ServiceInstance : IWebSockets
public: __property abstract IWebSockets* get_ServiceInstance();
public: __property abstract void set_ServiceInstance(
   IWebSockets* value
);
public:
abstract property IWebSockets^ ServiceInstance {
   IWebSockets^ get();
   void set (    IWebSockets^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


State Property (WebSocketChannel)

State Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : State Property
Gets and sets the states of WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property State As WebSocketState
'Usage

Dim instance As WebSocketChannel
Dim value As WebSocketState

value = instance.State
public abstract WebSocketState State {get;}
public read-only property State: WebSocketState; abstract;
public __abstract function get State : WebSocketState
public: __property abstract WebSocketState get_State();
public:
abstract property WebSocketState State {
   WebSocketState get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Via Property (WebSocketChannel)

Via Property (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Via Property
Gets the URI to which this channel was established.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Via As System.Uri
'Usage

Dim instance As WebSocketChannel
Dim value As System.Uri

value = instance.Via
public abstract System.Uri Via {get;}
public read-only property Via: System.Uri; abstract;
public __abstract function get Via : System.Uri
public: __property abstract System.Uri* get_Via();
public:
abstract property System.Uri^ Via {
   System.Uri^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


WebSocketChannel Class Events

WebSocketChannel Class Events

Noemax.WebSockets Namespace : WebSocketChannel Class

For a list of all members of this type, see WebSocketChannel members.

Public Events
 | Name | Description
Public Event | Closed |
Public Event | Error |
Public Event | Ping |
Public Event | Pong |
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


Closed Event (WebSocketChannel)

Closed Event (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Closed Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Closed As System.EventHandler(Of WebSocketCloseEventArgs)
'Usage

Dim instance As WebSocketChannel
Dim handler As System.EventHandler(Of WebSocketCloseEventArgs)

AddHandler instance.Closed, handler
public event System.EventHandler<WebSocketCloseEventArgs> Closed
public event Closed: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketCloseEventArgs*>* Closed
public:
event System.EventHandler<WebSocketCloseEventArgs^>^ Closed
Event Data

The event handler receives an argument of type WebSocketCloseEventArgs containing data related to this event. The following WebSocketCloseEventArgs properties provide information specific to this event.

Property | Description
Description | The description of the status with which the connection is being closed.
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
StatusCode | The status code with which the connection is being closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Error Event (WebSocketChannel)

Error Event (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Error Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Error As System.EventHandler(Of WebSocketErrorEventArgs)
'Usage

Dim instance As WebSocketChannel
Dim handler As System.EventHandler(Of WebSocketErrorEventArgs)

AddHandler instance.Error, handler
public event System.EventHandler<WebSocketErrorEventArgs> Error
public event Error: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketErrorEventArgs*>* Error
public:
event System.EventHandler<WebSocketErrorEventArgs^>^ Error
Event Data

The event handler receives an argument of type WebSocketErrorEventArgs containing data related to this event. The following WebSocketErrorEventArgs properties provide information specific to this event.

Property | Description
Error | The error encountered by the WebSocket instance of the service that handles the connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Ping Event (WebSocketChannel)

Ping Event (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Ping Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Ping As System.EventHandler(Of WebSocketPingOrPongEventArgs)
'Usage

Dim instance As WebSocketChannel
Dim handler As System.EventHandler(Of WebSocketPingOrPongEventArgs)

AddHandler instance.Ping, handler
public event System.EventHandler<WebSocketPingOrPongEventArgs> Ping
public event Ping: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketPingOrPongEventArgs*>* Ping
public:
event System.EventHandler<WebSocketPingOrPongEventArgs^>^ Ping
Event Data

The event handler receives an argument of type WebSocketPingOrPongEventArgs containing data related to this event. The following WebSocketPingOrPongEventArgs properties provide information specific to this event.

Property | Description
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


Pong Event (WebSocketChannel)

Pong Event (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : Pong Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Pong As System.EventHandler(Of WebSocketPingOrPongEventArgs)
'Usage

Dim instance As WebSocketChannel
Dim handler As System.EventHandler(Of WebSocketPingOrPongEventArgs)

AddHandler instance.Pong, handler
public event System.EventHandler<WebSocketPingOrPongEventArgs> Pong
public event Pong: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketPingOrPongEventArgs*>* Pong
public:
event System.EventHandler<WebSocketPingOrPongEventArgs^>^ Pong
Event Data

The event handler receives an argument of type WebSocketPingOrPongEventArgs containing data related to this event. The following WebSocketPingOrPongEventArgs properties provide information specific to this event.

Property | Description
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


WebSocketClient Class

WebSocketClient Class
Members

Noemax.WebSockets Namespace : WebSocketClient Class
Provides the WebSocket protocol client connection.
Object Model
WebSocketClient Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketClient
   Inherits WebSocketConnectionChannel
'Usage

Dim instance As WebSocketClient
public class WebSocketClient : WebSocketConnectionChannel
public class WebSocketClient = class(WebSocketConnectionChannel)
public class WebSocketClient extends WebSocketConnectionChannel
public __gc class WebSocketClient : public WebSocketConnectionChannel
public ref class WebSocketClient : public WebSocketConnectionChannel
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.WebSocketConnectionChannel
Noemax.WebSockets.WebSocketClient
Noemax.WebSockets.WebSocketClient<TService>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Members
Noemax.WebSockets Namespace


WebSocketClient Class Members

WebSocketClient Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketClient Class

The following tables list the members exposed by WebSocketClient.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClient Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client.
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies.
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection.
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0.
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side.
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake.
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Public Property | Security | Provides properties for the WebSocket connection security.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events.
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection.
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Overridden. Closes the to the client connection and releases associated resources.
static (Shared in Visual Basic) | Create | Overloaded. Initializes the new instance of the class.
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded. Opens the client connection to the server endpoint.
Public Method | Send | Overloaded. Overridden. Sends a binary message to the remote endpoint.
Public Method | SendAsync | Overloaded. Overridden. Sends the binary message to the remote endpoint.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of outbound messages to the remote endpoint asynchronously.
Public Method | SendClose | Overridden. Sends the close frame to the remote endpoint to initiate the closure of connection.
Public Method | SendMessage | Overloaded. Overridden. Initiates a streamed message to the remote endpoint.
Public Method | SendPing | Overloaded. Overridden. Sends Ping to the remote endpoint.
Public Method | SendTextMessage | Overloaded. Overridden. Initiate the outbound streamed text message.
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


WebSocketClient Constructor

WebSocketClient Constructor

Noemax.WebSockets Namespace > WebSocketClient Class : WebSocketClient Constructor
Overload List
Overload | Description
WebSocketClient Constructor(String,IWebSockets) | Initializes a new instance of the class.
WebSocketClient Constructor(Uri,IWebSockets) | Initializes a new instance of the class.
WebSocketClient Constructor(Uri,String,String,IWebSockets) | Initializes the new instance of the class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


WebSocketClient Constructor(String,IWebSockets)

WebSocketClient Constructor(String,IWebSockets)

Noemax.WebSockets Namespace > WebSocketClient Class > WebSocketClient Constructor : WebSocketClient Constructor(String,IWebSockets)
The JRI of the target WebSocket server.
The instance of the IWebSockets implementation.
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.String, _
   ByVal instance As IWebSockets _
)
'Usage

Dim uri As System.String
Dim instance As IWebSockets

Dim instance As New WebSocketClient(uri, instance)
public WebSocketClient(
   System.string uri,
   IWebSockets instance
)
public WebSocketClient(
    uri: System.String;
    instance: IWebSockets
);
public function WebSocketClient(
   uri : System.String,
   instance : IWebSockets
);
public: WebSocketClient(
   System.string* uri,
   IWebSockets* instance
)
public:
WebSocketClient(
   System.String^ uri,
   IWebSockets^ instance
)

Parameters

uri
The JRI of the target WebSocket server.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


WebSocketClient Constructor(Uri,IWebSockets)

WebSocketClient Constructor(Uri,IWebSockets)

Noemax.WebSockets Namespace > WebSocketClient Class > WebSocketClient Constructor : WebSocketClient Constructor(Uri,IWebSockets)
The URI of the target WebSocket server.
The instance of the IWebSockets implementation.
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri, _
   ByVal instance As IWebSockets _
)
'Usage

Dim uri As System.Uri
Dim instance As IWebSockets

Dim instance As New WebSocketClient(uri, instance)
public WebSocketClient(
   System.Uri uri,
   IWebSockets instance
)
public WebSocketClient(
    uri: System.Uri;
    instance: IWebSockets
);
public function WebSocketClient(
   uri : System.Uri,
   instance : IWebSockets
);
public: WebSocketClient(
   System.Uri* uri,
   IWebSockets* instance
)
public:
WebSocketClient(
   System.Uri^ uri,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


WebSocketClient Constructor(Uri,String,String,IWebSockets)

WebSocketClient Constructor(Uri,String,String,IWebSockets)

Noemax.WebSockets Namespace > WebSocketClient Class > WebSocketClient Constructor : WebSocketClient Constructor(Uri,String,String,IWebSockets)
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
The instance of the IWebSockets implementation.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri, _
   ByVal origin As System.String, _
   ByVal protocol As System.String, _
   ByVal instance As IWebSockets _
)
'Usage

Dim uri As System.Uri
Dim origin As System.String
Dim protocol As System.String
Dim instance As IWebSockets

Dim instance As New WebSocketClient(uri, origin, protocol, instance)
public WebSocketClient(
   System.Uri uri,
   System.string origin,
   System.string protocol,
   IWebSockets instance
)
public WebSocketClient(
    uri: System.Uri;
    origin: System.String;
    protocol: System.String;
    instance: IWebSockets
);
public function WebSocketClient(
   uri : System.Uri,
   origin : System.String,
   protocol : System.String,
   instance : IWebSockets
);
public: WebSocketClient(
   System.Uri* uri,
   System.string* origin,
   System.string* protocol,
   IWebSockets* instance
)
public:
WebSocketClient(
   System.Uri^ uri,
   System.String^ origin,
   System.String^ protocol,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


WebSocketClient Class Methods

WebSocketClient Class Methods

Noemax.WebSockets Namespace : WebSocketClient Class

For a list of all members of this type, see WebSocketClient members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Overridden. Closes the to the client connection and releases associated resources.
static (Shared in Visual Basic) | Create | Overloaded. Initializes the new instance of the class.
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded. Opens the client connection to the server endpoint.
Public Method | Send | Overloaded. Overridden. Sends a binary message to the remote endpoint.
Public Method | SendAsync | Overloaded. Overridden. Sends the binary message to the remote endpoint.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of outbound messages to the remote endpoint asynchronously.
Public Method | SendClose | Overridden. Sends the close frame to the remote endpoint to initiate the closure of connection.
Public Method | SendMessage | Overloaded. Overridden. Initiates a streamed message to the remote endpoint.
Public Method | SendPing | Overloaded. Overridden. Sends Ping to the remote endpoint.
Public Method | SendTextMessage | Overloaded. Overridden. Initiate the outbound streamed text message.
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


Close Method (WebSocketClient)

Close Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Close Method
Closes the to the client connection and releases associated resources.
Overload List
Overload | Description
Close(TimeSpan) | Closes the to the client connection and releases associated resources.
Close() | Wait for ongoing operation to be complete and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in Close


Close(TimeSpan) Method

Close(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Close Method : Close(TimeSpan) Method
The timeout to wait for ongoing transfer to be complete prior connection is terminated.
Closes the to the client connection and releases associated resources.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Close( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim timeout As System.TimeSpan

instance.Close(timeout)
public override void Close(
   System.TimeSpan timeout
)
public procedure Close(
    timeout: System.TimeSpan
); override;
public override function Close(
   timeout : System.TimeSpan
);
public: void Close(
   System.TimeSpan timeout
) override
public:
void Close(
   System.TimeSpan timeout
) override

Parameters

timeout
The timeout to wait for ongoing transfer to be complete prior connection is terminated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in Close(TimeSpan)


Create Method (WebSocketClient)

Create Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Create Method
Initializes the new instance of the class.
Overload List
Overload | Description
Create<TService>(Uri) | Initializes the new instance of the class.
Create<TService>(String) | Initializes the new instance of the class.
Create<TService>(Uri,String,String) | Initializes the new instance of the class.
Create<TService>(String,String,String) | Initializes the new instance of the class.
Create(Uri,IWebSockets) | Initializes a new instance of the class.
Create(String,IWebSockets) | Initializes a new instance of the class.
Create(Uri,String,String,IWebSockets) | Initializes the new instance of the class.
Create(String,String,String,IWebSockets) | Initializes the new instance of the class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Create<TService>(Uri) Method

Create<TService>(Uri) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create<TService>(Uri) Method
The URI of the target WebSocket server.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.Uri _
) As WebSocketClient
'Usage

Dim uri As System.Uri
Dim value As WebSocketClient

value = WebSocketClient.Create(Of TService)(uri)
public static WebSocketClient Create<TService>(
   System.Uri uri
)
where TService: class, new(), IWebSockets
public function Create(
    uri: System.Uri
): WebSocketClient; static;
public static function Create(
   uri : System.Uri
) : WebSocketClient;
public: static WebSocketClient* Create<TService>(
   System.Uri* uri
)
where TService: ref class, gcnew(), IWebSockets
public:
static WebSocketClient^ Creategeneric<typename TService>
(
   System.Uri^ uri
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the target WebSocket server.

Type Parameters

TService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create<TService>(String) Method

Create<TService>(String) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create<TService>(String) Method
The URI of the target WebSocket server.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.String _
) As WebSocketClient
'Usage

Dim uri As System.String
Dim value As WebSocketClient

value = WebSocketClient.Create(Of TService)(uri)
public static WebSocketClient Create<TService>(
   System.string uri
)
where TService: class, new(), IWebSockets
public function Create(
    uri: System.String
): WebSocketClient; static;
public static function Create(
   uri : System.String
) : WebSocketClient;
public: static WebSocketClient* Create<TService>(
   System.string* uri
)
where TService: ref class, gcnew(), IWebSockets
public:
static WebSocketClient^ Creategeneric<typename TService>
(
   System.String^ uri
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the target WebSocket server.

Type Parameters

TService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create<TService>(Uri,String,String) Method

Create<TService>(Uri,String,String) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create<TService>(Uri,String,String) Method
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.Uri, _
   ByVal origin As System.String, _
   ByVal protocol As System.String _
) As WebSocketClient
'Usage

Dim uri As System.Uri
Dim origin As System.String
Dim protocol As System.String
Dim value As WebSocketClient

value = WebSocketClient.Create(Of TService)(uri, origin, protocol)
public static WebSocketClient Create<TService>(
   System.Uri uri,
   System.string origin,
   System.string protocol
)
where TService: class, new(), IWebSockets
public function Create(
    uri: System.Uri;
    origin: System.String;
    protocol: System.String
): WebSocketClient; static;
public static function Create(
   uri : System.Uri,
   origin : System.String,
   protocol : System.String
) : WebSocketClient;
public: static WebSocketClient* Create<TService>(
   System.Uri* uri,
   System.string* origin,
   System.string* protocol
)
where TService: ref class, gcnew(), IWebSockets
public:
static WebSocketClient^ Creategeneric<typename TService>
(
   System.Uri^ uri,
   System.String^ origin,
   System.String^ protocol
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.

Type Parameters

TService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create<TService>(String,String,String) Method

Create<TService>(String,String,String) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create<TService>(String,String,String) Method
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.String, _
   ByVal origin As System.String, _
   ByVal protocol As System.String _
) As WebSocketClient
'Usage

Dim uri As System.String
Dim origin As System.String
Dim protocol As System.String
Dim value As WebSocketClient

value = WebSocketClient.Create(Of TService)(uri, origin, protocol)
public static WebSocketClient Create<TService>(
   System.string uri,
   System.string origin,
   System.string protocol
)
where TService: class, new(), IWebSockets
public function Create(
    uri: System.String;
    origin: System.String;
    protocol: System.String
): WebSocketClient; static;
public static function Create(
   uri : System.String,
   origin : System.String,
   protocol : System.String
) : WebSocketClient;
public: static WebSocketClient* Create<TService>(
   System.string* uri,
   System.string* origin,
   System.string* protocol
)
where TService: ref class, gcnew(), IWebSockets
public:
static WebSocketClient^ Creategeneric<typename TService>
(
   System.String^ uri,
   System.String^ origin,
   System.String^ protocol
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.

Type Parameters

TService
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create(Uri,IWebSockets) Method

Create(Uri,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create(Uri,IWebSockets) Method
The URI of the target WebSocket server.
The instance of the IWebSockets implementation.
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal uri As System.Uri, _
   ByVal instance As IWebSockets _
) As WebSocketClient
'Usage

Dim uri As System.Uri
Dim instance As IWebSockets
Dim value As WebSocketClient

value = WebSocketClient.Create(uri, instance)
public static WebSocketClient Create(
   System.Uri uri,
   IWebSockets instance
)
public function Create(
    uri: System.Uri;
    instance: IWebSockets
): WebSocketClient; static;
public static function Create(
   uri : System.Uri,
   instance : IWebSockets
) : WebSocketClient;
public: static WebSocketClient* Create(
   System.Uri* uri,
   IWebSockets* instance
)
public:
static WebSocketClient^ Create(
   System.Uri^ uri,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create(String,IWebSockets) Method

Create(String,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create(String,IWebSockets) Method
The URI of the target WebSocket server.
The instance of the IWebSockets implementation.
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal uri As System.String, _
   ByVal instance As IWebSockets _
) As WebSocketClient
'Usage

Dim uri As System.String
Dim instance As IWebSockets
Dim value As WebSocketClient

value = WebSocketClient.Create(uri, instance)
public static WebSocketClient Create(
   System.string uri,
   IWebSockets instance
)
public function Create(
    uri: System.String;
    instance: IWebSockets
): WebSocketClient; static;
public static function Create(
   uri : System.String,
   instance : IWebSockets
) : WebSocketClient;
public: static WebSocketClient* Create(
   System.string* uri,
   IWebSockets* instance
)
public:
static WebSocketClient^ Create(
   System.String^ uri,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create(Uri,String,String,IWebSockets) Method

Create(Uri,String,String,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create(Uri,String,String,IWebSockets) Method
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
The instance of the IWebSockets implementation.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal uri As System.Uri, _
   ByVal origin As System.String, _
   ByVal protocol As System.String, _
   ByVal instance As IWebSockets _
) As WebSocketClient
'Usage

Dim uri As System.Uri
Dim origin As System.String
Dim protocol As System.String
Dim instance As IWebSockets
Dim value As WebSocketClient

value = WebSocketClient.Create(uri, origin, protocol, instance)
public static WebSocketClient Create(
   System.Uri uri,
   System.string origin,
   System.string protocol,
   IWebSockets instance
)
public function Create(
    uri: System.Uri;
    origin: System.String;
    protocol: System.String;
    instance: IWebSockets
): WebSocketClient; static;
public static function Create(
   uri : System.Uri,
   origin : System.String,
   protocol : System.String,
   instance : IWebSockets
) : WebSocketClient;
public: static WebSocketClient* Create(
   System.Uri* uri,
   System.string* origin,
   System.string* protocol,
   IWebSockets* instance
)
public:
static WebSocketClient^ Create(
   System.Uri^ uri,
   System.String^ origin,
   System.String^ protocol,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Create(String,String,String,IWebSockets) Method

Create(String,String,String,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Create Method : Create(String,String,String,IWebSockets) Method
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
The instance of the IWebSockets implementation.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shared Function Create( _
   ByVal uri As System.String, _
   ByVal origin As System.String, _
   ByVal protocol As System.String, _
   ByVal instance As IWebSockets _
) As WebSocketClient
'Usage

Dim uri As System.String
Dim origin As System.String
Dim protocol As System.String
Dim instance As IWebSockets
Dim value As WebSocketClient

value = WebSocketClient.Create(uri, origin, protocol, instance)
public static WebSocketClient Create(
   System.string uri,
   System.string origin,
   System.string protocol,
   IWebSockets instance
)
public function Create(
    uri: System.String;
    origin: System.String;
    protocol: System.String;
    instance: IWebSockets
): WebSocketClient; static;
public static function Create(
   uri : System.String,
   origin : System.String,
   protocol : System.String,
   instance : IWebSockets
) : WebSocketClient;
public: static WebSocketClient* Create(
   System.string* uri,
   System.string* origin,
   System.string* protocol,
   IWebSockets* instance
)
public:
static WebSocketClient^ Create(
   System.String^ uri,
   System.String^ origin,
   System.String^ protocol,
   IWebSockets^ instance
)

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.
instance
The instance of the IWebSockets implementation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Open Method (WebSocketClient)

Open Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Open Method
Opens the client connection to the server endpoint.
Overload List
Overload | Description
Open() | Opens the client connection to the server endpoint.
Open(TimeSpan) | Opens the client connection to the server endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Open() Method

Open() Method

Noemax.WebSockets Namespace > WebSocketClient Class > Open Method : Open() Method
Opens the client connection to the server endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Open()
'Usage

Dim instance As WebSocketClient

instance.Open()
public void Open()
public procedure Open();
public function Open();
public: void Open();
public:
void Open();
Remarks
Once client connection to the server endpoint is established, IWebSockets.OnOpen of associated TService instance is called and client is ready to receive messages from server side.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Open(TimeSpan) Method

Open(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Open Method : Open(TimeSpan) Method
The period of time during which client is expected to connect to the server.
Opens the client connection to the server endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub Open( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim timeout As System.TimeSpan

instance.Open(timeout)
public virtual void Open(
   System.TimeSpan timeout
)
public procedure Open(
    timeout: System.TimeSpan
); virtual;
public function Open(
   timeout : System.TimeSpan
);
public: virtual void Open(
   System.TimeSpan timeout
)
public:
virtual void Open(
   System.TimeSpan timeout
)

Parameters

timeout
The period of time during which client is expected to connect to the server.
Remarks

If connection cannot be established within specified timeout, TimeoutException is thrown.

Once client connection to the server endpoint is established, IWebSockets.OnOpen of associated TService instance is called and client is ready to receive messages from server side.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


Send Method (WebSocketClient)

Send Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Send Method
Sends a binary message to the remote endpoint.
Overload List
Overload | Description
Send(Byte[],Int32,Int32,TimeSpan) | Sends a binary message to the remote endpoint.
Send(String,TimeSpan) | Sends a text message to the remote endpoint.
Send(WebSocketOutboundMessage,TimeSpan) | Sends the message to the remote endpoint.
Send(WebSocketOutboundMessage) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>,TimeSpan) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[]) | Sends a binary message with a specified array of bytes as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[],Int32,Int32) | Sends a binary message with a specified segment of array as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(String) | Sends a text message with a specified string as a payload within a specified interval of time. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in Send


Send(Byte[],Int32,Int32,TimeSpan) Method

Send(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Send Method : Send(Byte[],Int32,Int32,TimeSpan) Method
An array of type Byte that contains the data to send.
The zero-based position in the buffer parameter at which to begin sending data.
The number of bytes to send.
The timeout for the send operation.
Sends a binary message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.Send(buffer, offset, count, timeout)
public override void Send(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure Send(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function Send(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void Send(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void Send(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
An array of type Byte that contains the data to send.
offset
The zero-based position in the buffer parameter at which to begin sending data.
count
The number of bytes to send.
timeout
The timeout for the send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in Send(Byte[],Int32,Int32,TimeSpan)


Send(String,TimeSpan) Method

Send(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Send Method : Send(String,TimeSpan) Method
The text to send.
The timeout for the send opeation.
Sends a text message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim text As System.String
Dim timeout As System.TimeSpan

instance.Send(text, timeout)
public override void Send(
   System.string text,
   System.TimeSpan timeout
)
public procedure Send(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function Send(
   text : System.String,
   timeout : System.TimeSpan
);
public: void Send(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void Send(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
The text to send.
timeout
The timeout for the send opeation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in Send(String,TimeSpan)


Send(WebSocketOutboundMessage,TimeSpan) Method

Send(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > Send Method : Send(WebSocketOutboundMessage,TimeSpan) Method
The message to send to the remote endpoint.
The timeout for send operation.
Sends the message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.Send(message, timeout)
public override void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure Send(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function Send(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
The message to send to the remote endpoint.
timeout
The timeout for send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in Send(WebSocketOutboundMessage,TimeSpan)


SendAsync Method (WebSocketClient)

SendAsync Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendAsync Method
Sends the binary message to the remote endpoint.
Overload List
Overload | Description
SendAsync(Byte[],Int32,Int32,TimeSpan) | Sends the binary message to the remote endpoint.
SendAsync(String,TimeSpan) | Sends the text message to the remote endpoint.
SendAsync(WebSocketOutboundMessage,TimeSpan) | Send the message to the remote endpoint.
SendAsync(WebSocketOutboundMessage) | Sends a message within a specified interval of time asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(Byte[],Int32,Int32) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(String) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendAsync


SendAsync(Byte[],Int32,Int32,TimeSpan) Method

SendAsync(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendAsync Method : SendAsync(Byte[],Int32,Int32,TimeSpan) Method
An array of type Byte that contains the data to send.
The zero-based position in the buffer parameter at which to begin sending data.
The number of bytes to send.
The timeout for the send operation.
Sends the binary message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.SendAsync(buffer, offset, count, timeout)
public override void SendAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure SendAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
An array of type Byte that contains the data to send.
offset
The zero-based position in the buffer parameter at which to begin sending data.
count
The number of bytes to send.
timeout
The timeout for the send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendAsync(Byte[],Int32,Int32,TimeSpan)


SendAsync(String,TimeSpan) Method

SendAsync(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendAsync Method : SendAsync(String,TimeSpan) Method
The text message to send.
The timeout for the send operation.
Sends the text message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim text As System.String
Dim timeout As System.TimeSpan

instance.SendAsync(text, timeout)
public override void SendAsync(
   System.string text,
   System.TimeSpan timeout
)
public procedure SendAsync(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   text : System.String,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
The text message to send.
timeout
The timeout for the send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendAsync(String,TimeSpan)


SendAsync(WebSocketOutboundMessage,TimeSpan) Method

SendAsync(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendAsync Method : SendAsync(WebSocketOutboundMessage,TimeSpan) Method
The message to send to the remote endpoint.
The timeout for the send operation.
Send the message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendAsync(message, timeout)
public override void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
The message to send to the remote endpoint.
timeout
The timeout for the send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendAsync(WebSocketOutboundMessage,TimeSpan)


SendBatchAsync Method (WebSocketClient)

SendBatchAsync Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendBatchAsync Method
Sends the batch of outbound messages to the remote endpoint asynchronously.
Overload List
Overload | Description
SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) | Sends the batch of outbound messages to the remote endpoint asynchronously.
SendBatchAsync(WebSocketOutboundMessage[]) | Sends the batch of the messages asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendBatchAsync


SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method
The messages to send to the remote endpoint.
The period of time during which operation must complete or timeout.
Sends the batch of outbound messages to the remote endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim messages() As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendBatchAsync(messages, timeout)
public override void SendBatchAsync(
   WebSocketOutboundMessage[] messages,
   System.TimeSpan timeout
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of;
    timeout: System.TimeSpan
); override;
public override function SendBatchAsync(
   messages : WebSocketOutboundMessage[],
   timeout : System.TimeSpan
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* messages,
   System.TimeSpan timeout
) override
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages,
   System.TimeSpan timeout
) override

Parameters

messages
The messages to send to the remote endpoint.
timeout
The period of time during which operation must complete or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendBatchAsync(WebSocketOutboundMessage[],TimeSpan)


SendClose Method (WebSocketClient)

SendClose Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendClose Method
The status code identifying the reason for closing the connection.
The string describing the reason for closing the connection.
The period of time during which the close frame must be sent or operation would timeout.
Sends the close frame to the remote endpoint to initiate the closure of connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub SendClose( _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketClient
Dim statusCode As System.Short
Dim reason As System.String
Dim timeout As System.TimeSpan

instance.SendClose(statusCode, reason, timeout)
public override void SendClose(
   System.short statusCode,
   System.string reason,
   System.TimeSpan timeout
)
public procedure SendClose(
    statusCode: System.Int16;
    reason: System.String;
    timeout: System.TimeSpan
); override;
public override function SendClose(
   statusCode : System.short,
   reason : System.String,
   timeout : System.TimeSpan
);
public: void SendClose(
   System.short statusCode,
   System.string* reason,
   System.TimeSpan timeout
) override
public:
void SendClose(
   System.short statusCode,
   System.String^ reason,
   System.TimeSpan timeout
) override

Parameters

statusCode
The status code identifying the reason for closing the connection.
reason
The string describing the reason for closing the connection.
timeout
The period of time during which the close frame must be sent or operation would timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendClose


SendMessage Method (WebSocketClient)

SendMessage Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendMessage Method
Initiates a streamed message to the remote endpoint.
Overload List
Overload | Description
SendMessage(TimeSpan) | Initiates a streamed message to the remote endpoint.
SendMessage() | Streams the binary message to the remote side. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendMessage


SendMessage(TimeSpan) Method

SendMessage(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendMessage Method : SendMessage(TimeSpan) Method
The timeout for the send operation.
Initiates a streamed message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As WebSocketClient
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.SendMessage(timeout)
public override System.IO.Stream SendMessage(
   System.TimeSpan timeout
)
public function SendMessage(
    timeout: System.TimeSpan
): System.IO.Stream; override;
public override function SendMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: System.IO.Stream* SendMessage(
   System.TimeSpan timeout
) override
public:
System.IO.Stream^ SendMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
The timeout for the send operation.

Return Value

The stream to write the outbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendMessage(TimeSpan)


SendPing Method (WebSocketClient)

SendPing Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendPing Method
Sends Ping to the remote endpoint.
Overload List
Overload | Description
SendPing() | Sends Ping to the remote endpoint.
SendPing(Byte[]) | Sends Ping with specified payload to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendPing


SendPing() Method

SendPing() Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendPing Method : SendPing() Method
Sends Ping to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing()
'Usage

Dim instance As WebSocketClient

instance.SendPing()
public override void SendPing()
public procedure SendPing(); override;
public override function SendPing();
public: void SendPing(); override
public:
void SendPing(); override
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendPing()


SendPing(Byte[]) Method

SendPing(Byte[]) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendPing Method : SendPing(Byte[]) Method
The payload to be sent.
Sends Ping with specified payload to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing( _
   ByVal payload() As System.Byte _
)
'Usage

Dim instance As WebSocketClient
Dim payload() As System.Byte

instance.SendPing(payload)
public override void SendPing(
   System.byte[] payload
)
public procedure SendPing(
    payload: System.Bytearray of
); override;
public override function SendPing(
   payload : System.byte[]
);
public: void SendPing(
   System.byte[]* payload
) override
public:
void SendPing(
   System.array<byte>^ payload
) override

Parameters

payload
The payload to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendPing(Byte[])


SendTextMessage Method (WebSocketClient)

SendTextMessage Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : SendTextMessage Method
Initiate the outbound streamed text message.
Overload List
Overload | Description
SendTextMessage(TimeSpan) | Initiate the outbound streamed text message.
SendTextMessage() | Streams the text message to the remote side. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Base Implementation in SendTextMessage


SendTextMessage(TimeSpan) Method

SendTextMessage(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > SendTextMessage Method : SendTextMessage(TimeSpan) Method
The timeout for the send operation.
Initiate the outbound streamed text message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendTextMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.TextWriter
'Usage

Dim instance As WebSocketClient
Dim timeout As System.TimeSpan
Dim value As System.IO.TextWriter

value = instance.SendTextMessage(timeout)
public override System.IO.TextWriter SendTextMessage(
   System.TimeSpan timeout
)
public function SendTextMessage(
    timeout: System.TimeSpan
): System.IO.TextWriter; override;
public override function SendTextMessage(
   timeout : System.TimeSpan
) : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage(
   System.TimeSpan timeout
) override
public:
System.IO.TextWriter^ SendTextMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
The timeout for the send operation.

Return Value

The TextWriter to write the outbound text message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List
Base Implementation in SendTextMessage


WebSocketClient Class Properties

WebSocketClient Class Properties

Noemax.WebSockets Namespace : WebSocketClient Class

For a list of all members of this type, see WebSocketClient members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client.
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies.
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection.
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0.
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side.
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake.
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Public Property | Security | Provides properties for the WebSocket connection security.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events.
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection.
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


Compression Property (WebSocketClient)

Compression Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Compression Property
Gets and sets the transport compression scheme to be used by the client.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Compression As CompressionSettings
'Usage

Dim instance As WebSocketClient
Dim value As CompressionSettings

instance.Compression = value

value = instance.Compression
public CompressionSettings Compression {get; set;}
public read-write property Compression: CompressionSettings;
public function get,set Compression : CompressionSettings
public: __property CompressionSettings* get_Compression();
public: __property void set_Compression(
   CompressionSettings* value
);
public:
property CompressionSettings^ Compression {
   CompressionSettings^ get();
   void set (    CompressionSettings^ value);
}
Remarks
The transport compression scheme will apply only in case if the server supports specified compression extension, otherwise the value of this property will not have any impact on communication.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


CookieContainer Property (WebSocketClient)

CookieContainer Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : CookieContainer Property
Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CookieContainer As System.Net.CookieContainer
'Usage

Dim instance As WebSocketClient
Dim value As System.Net.CookieContainer

instance.CookieContainer = value

value = instance.CookieContainer
public System.Net.CookieContainer CookieContainer {get; set;}
public read-write property CookieContainer: System.Net.CookieContainer;
public function get,set CookieContainer : System.Net.CookieContainer
public: __property System.Net.CookieContainer* get_CookieContainer();
public: __property void set_CookieContainer(
   System.Net.CookieContainer* value
);
public:
property System.Net.CookieContainer^ CookieContainer {
   System.Net.CookieContainer^ get();
   void set (    System.Net.CookieContainer^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Cookies Property (WebSocketClient)

Cookies Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Cookies Property
Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Cookies As System.Net.CookieCollection
'Usage

Dim instance As WebSocketClient
Dim value As System.Net.CookieCollection

value = instance.Cookies
public System.Net.CookieCollection Cookies {get;}
public read-only property Cookies: System.Net.CookieCollection;
public function get Cookies : System.Net.CookieCollection
public: __property System.Net.CookieCollection* get_Cookies();
public:
property System.Net.CookieCollection^ Cookies {
   System.Net.CookieCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Extensions Property (WebSocketClient)

Extensions Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Extensions Property
Gets and sets the list of extensions for be negotiated by WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extensions As System.Collections.Generic.IEnumerable(Of String)
'Usage

Dim instance As WebSocketClient
Dim value As System.Collections.Generic.IEnumerable(Of String)

instance.Extensions = value

value = instance.Extensions
public System.Collections.Generic.IEnumerable<string> Extensions {get; set;}
public read-write property Extensions: System.Collections.Generic.IEnumerable;
public function get,set Extensions : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<string*>* get_Extensions();
public: __property void set_Extensions(
   System.Collections.Generic.IEnumerable<string*>* value
);
public:
property System.Collections.Generic.IEnumerable<String^>^ Extensions {
   System.Collections.Generic.IEnumerable<String^>^ get();
   void set (    System.Collections.Generic.IEnumerable<String^>^ value);
}
Remarks

WebSocketClient automatically negotiates supported extensions during the WebSocketHandshake, buy using this property you can override the extension configuration and extension parameters that would be used by the WebSocketClient. When this property is set, WebSocketClient will be using the value of this property rather than automatically generated Sec-WebSocket-Extension header.

You don't need to use this property unless you have to provide custom extension configuration.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


InboundHandshakeHeaders Property (WebSocketClient)

InboundHandshakeHeaders Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : InboundHandshakeHeaders Property
Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InboundHandshakeHeaders As WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketClient
Dim value As WebSocketHandshakeHeaderCollection

value = instance.InboundHandshakeHeaders
public WebSocketHandshakeHeaderCollection InboundHandshakeHeaders {get;}
public read-only property InboundHandshakeHeaders: WebSocketHandshakeHeaderCollection;
public function get InboundHandshakeHeaders : WebSocketHandshakeHeaderCollection
public: __property WebSocketHandshakeHeaderCollection* get_InboundHandshakeHeaders();
public:
property WebSocketHandshakeHeaderCollection^ InboundHandshakeHeaders {
   WebSocketHandshakeHeaderCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


MaxRedirects Property (WebSocketClient)

MaxRedirects Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : MaxRedirects Property
Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxRedirects As System.Integer
'Usage

Dim instance As WebSocketClient
Dim value As System.Integer

instance.MaxRedirects = value

value = instance.MaxRedirects
public System.int MaxRedirects {get; set;}
public read-write property MaxRedirects: System.Integer;
public function get,set MaxRedirects : System.int
public: __property System.int get_MaxRedirects();
public: __property void set_MaxRedirects(
   System.int value
);
public:
property System.int MaxRedirects {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Origin Property (WebSocketClient)

Origin Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Origin Property
Gets and sets the Origin string that identifies the origin of the script running on the client side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property Origin As System.String
'Usage

Dim instance As WebSocketClient
Dim value As System.String

instance.Origin = value

value = instance.Origin
public new System.string Origin {get; set;}
public read-write property Origin: System.String;
public hide function get,set Origin : System.String
public: __property new System.string* get_Origin();
public: __property new void set_Origin(
   System.string* value
);
public:
new property System.String^ Origin {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
The Origin string might be required by the WebSocket server that also handle connections from the scripts running on the brower clients.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


OutboundHandshakeHeaders Property (WebSocketClient)

OutboundHandshakeHeaders Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : OutboundHandshakeHeaders Property
Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutboundHandshakeHeaders As WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketClient
Dim value As WebSocketHandshakeHeaderCollection

value = instance.OutboundHandshakeHeaders
public WebSocketHandshakeHeaderCollection OutboundHandshakeHeaders {get;}
public read-only property OutboundHandshakeHeaders: WebSocketHandshakeHeaderCollection;
public function get OutboundHandshakeHeaders : WebSocketHandshakeHeaderCollection
public: __property WebSocketHandshakeHeaderCollection* get_OutboundHandshakeHeaders();
public:
property WebSocketHandshakeHeaderCollection^ OutboundHandshakeHeaders {
   WebSocketHandshakeHeaderCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


PayloadMasking Property (WebSocketClient)

PayloadMasking Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : PayloadMasking Property
Gets and sets whether the payload of outbound messages is masked.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property PayloadMasking As System.Boolean
'Usage

Dim instance As WebSocketClient
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public new System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean;
public hide function get,set PayloadMasking : System.boolean
public: __property new System.bool get_PayloadMasking();
public: __property new void set_PayloadMasking(
   System.bool value
);
public:
new property System.bool PayloadMasking {
   System.bool get();
   void set (    System.bool value);
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking by setting this property, but strict WebSocket implementations will drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Protocol Property (WebSocketClient)

Protocol Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Protocol Property
Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shadows Property Protocol As System.String
'Usage

Dim instance As WebSocketClient
Dim value As System.String

instance.Protocol = value

value = instance.Protocol
public new System.string Protocol {get; set;}
public read-write property Protocol: System.String;
public hide function get,set Protocol : System.String
public: __property new System.string* get_Protocol();
public: __property new void set_Protocol(
   System.string* value
);
public:
new property System.String^ Protocol {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


Security Property (WebSocketClient)

Security Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Security Property
Provides properties for the WebSocket connection security.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Security As WebSocketClientSecurity
'Usage

Dim instance As WebSocketClient
Dim value As WebSocketClientSecurity

value = instance.Security
public WebSocketClientSecurity Security {get;}
public read-only property Security: WebSocketClientSecurity;
public function get Security : WebSocketClientSecurity
public: __property WebSocketClientSecurity* get_Security();
public:
property WebSocketClientSecurity^ Security {
   WebSocketClientSecurity^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


TraceSource Property (WebSocketClient)

TraceSource Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : TraceSource Property
Gets and sets TraceSource for tracing events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketClient
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


UseDefaultWebProxy Property (WebSocketClient)

UseDefaultWebProxy Property (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : UseDefaultWebProxy Property
Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseDefaultWebProxy As System.Boolean
'Usage

Dim instance As WebSocketClient
Dim value As System.Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
public System.bool UseDefaultWebProxy {get; set;}
public read-write property UseDefaultWebProxy: System.Boolean;
public function get,set UseDefaultWebProxy : System.boolean
public: __property System.bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   System.bool value
);
public:
property System.bool UseDefaultWebProxy {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


WebSocketClient Class Events

WebSocketClient Class Events

Noemax.WebSockets Namespace : WebSocketClient Class

For a list of all members of this type, see WebSocketClient members.

Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


Handshake Event (WebSocketClient)

Handshake Event (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : Handshake Event
Event triggered when the WebSocket handshake is performed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Handshake As WebSocketHandshakeEventHandler
'Usage

Dim instance As WebSocketClient
Dim handler As WebSocketHandshakeEventHandler

AddHandler instance.Handshake, handler
public event WebSocketHandshakeEventHandler Handshake
public event Handshake: WebSocketHandshakeEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event WebSocketHandshakeEventHandler* Handshake
public:
event WebSocketHandshakeEventHandler^ Handshake
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


WebSocketClient<TService> Class

WebSocketClient<TService> Class
Members

Noemax.WebSockets Namespace : WebSocketClient<TService> Class
The IWebSockets implementation providing the application logic for handling connections and messages.
Provides the WebSocket protocol client connection.
Object Model
WebSocketClient<TService> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketClient(Of TService As {Class, New, IWebSockets})
   Inherits WebSocketClient
'Usage

Dim instance As WebSocketClient(Of TService)
public class WebSocketClient<TService> : WebSocketClient
where TService: class, new(), IWebSockets
public class WebSocketClient = class(WebSocketClient)
    TService is class, has constructor, IWebSockets
JScript does not support Generics.
public __gc class WebSocketClient<TService> : public WebSocketClient
where TService: ref class, gcnew(), IWebSockets
generic<typename TService>
public ref class WebSocketClient : public WebSocketClient
where TService: ref class, gcnew(), IWebSockets
Type Parameters
TService
The IWebSockets implementation providing the application logic for handling connections and messages.
Remarks

The instance of TService class must implement IWebSockets interface to handle messages received from the server side.

The TService instance will be created and initialized automatically unless already existing instance is provided to WebSocketClient constructor. When already existing instance is shared between multiple WebSocketClient objects, it can be used for broadcasting messages through multiple client connections.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.WebSocketConnectionChannel
Noemax.WebSockets.WebSocketClient
Noemax.WebSockets.WebSocketClient<TService>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Members
Noemax.WebSockets Namespace


WebSocketClient<TService> Class Members

WebSocketClient<TService> Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

The following tables list the members exposed by WebSocketClient<TService>.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClient<TService> Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Security | Provides properties for the WebSocket connection security. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Closes the to the client connection and releases associated resources. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | Overridden. Returns an new instance of IWebSocket to handle messages received by the channel.
Public Method | Open | Overloaded. Opens the client connection to the server endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | Send | Overloaded. Sends a binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendAsync | Overloaded. Sends the binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendBatchAsync | Overloaded. Sends the batch of outbound messages to the remote endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendClose | Sends the close frame to the remote endpoint to initiate the closure of connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendMessage | Overloaded. Initiates a streamed message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendPing | Overloaded. Sends Ping to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendTextMessage | Overloaded. Initiate the outbound streamed text message. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


WebSocketClient<TService> Constructor

WebSocketClient<TService> Constructor

Noemax.WebSockets Namespace > WebSocketClient<TService> Class : WebSocketClient<TService> Constructor
Overload List
Overload | Description
WebSocketClient<TService> Constructor(Uri) | Initializes the new instance of the class.
WebSocketClient<TService> Constructor(String) | Initializes the new instance of the class.
WebSocketClient<TService> Constructor(Uri,String,String) | Initializes the new instance of the class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Class
WebSocketClient<TService> Members


WebSocketClient<TService> Constructor(Uri)

WebSocketClient<TService> Constructor(Uri)

Noemax.WebSockets Namespace > WebSocketClient<TService> Class > WebSocketClient<TService> Constructor : WebSocketClient<TService> Constructor(Uri)
The URI of the target WebSocket server.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri _
)
'Usage

Dim uri As System.Uri

Dim instance As New WebSocketClient(Of TService)(uri)
public WebSocketClient<TService>(
   System.Uri uri
)
public WebSocketClient<TService>(
    uri: System.Uri
);
public function WebSocketClient<TService>(
   uri : System.Uri
);
public: WebSocketClient<TService>(
   System.Uri* uri
)
public:
WebSocketClient<TService>(
   System.Uri^ uri
)

Parameters

uri
The URI of the target WebSocket server.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Class
WebSocketClient<TService> Members
Overload List


WebSocketClient<TService> Constructor(String)

WebSocketClient<TService> Constructor(String)

Noemax.WebSockets Namespace > WebSocketClient<TService> Class > WebSocketClient<TService> Constructor : WebSocketClient<TService> Constructor(String)
The URI of the target WebSocket server.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.String _
)
'Usage

Dim uri As System.String

Dim instance As New WebSocketClient(Of TService)(uri)
public WebSocketClient<TService>(
   System.string uri
)
public WebSocketClient<TService>(
    uri: System.String
);
public function WebSocketClient<TService>(
   uri : System.String
);
public: WebSocketClient<TService>(
   System.string* uri
)
public:
WebSocketClient<TService>(
   System.String^ uri
)

Parameters

uri
The URI of the target WebSocket server.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Class
WebSocketClient<TService> Members
Overload List


WebSocketClient<TService> Constructor(Uri,String,String)

WebSocketClient<TService> Constructor(Uri,String,String)

Noemax.WebSockets Namespace > WebSocketClient<TService> Class > WebSocketClient<TService> Constructor : WebSocketClient<TService> Constructor(Uri,String,String)
The URI of the target WebSocket server.
The string identifying the origin of the client.
The string specifying the sub-protocol used by the client.
Initializes the new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri, _
   ByVal origin As System.String, _
   ByVal protocol As System.String _
)
'Usage

Dim uri As System.Uri
Dim origin As System.String
Dim protocol As System.String

Dim instance As New WebSocketClient(Of TService)(uri, origin, protocol)
public WebSocketClient<TService>(
   System.Uri uri,
   System.string origin,
   System.string protocol
)
public WebSocketClient<TService>(
    uri: System.Uri;
    origin: System.String;
    protocol: System.String
);
public function WebSocketClient<TService>(
   uri : System.Uri,
   origin : System.String,
   protocol : System.String
);
public: WebSocketClient<TService>(
   System.Uri* uri,
   System.string* origin,
   System.string* protocol
)
public:
WebSocketClient<TService>(
   System.Uri^ uri,
   System.String^ origin,
   System.String^ protocol
)

Parameters

uri
The URI of the target WebSocket server.
origin
The string identifying the origin of the client.
protocol
The string specifying the sub-protocol used by the client.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Class
WebSocketClient<TService> Members
Overload List


WebSocketClient<TService> Class Methods

WebSocketClient<TService> Class Methods

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

For a list of all members of this type, see WebSocketClient<TService> members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Closes the to the client connection and releases associated resources. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | Overridden. Returns an new instance of IWebSocket to handle messages received by the channel.
Public Method | Open | Overloaded. Opens the client connection to the server endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | Send | Overloaded. Sends a binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendAsync | Overloaded. Sends the binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendBatchAsync | Overloaded. Sends the batch of outbound messages to the remote endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendClose | Sends the close frame to the remote endpoint to initiate the closure of connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendMessage | Overloaded. Initiates a streamed message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendPing | Overloaded. Sends Ping to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendTextMessage | Overloaded. Initiate the outbound streamed text message. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


GetServiceInstance Method (WebSocketClient<TService>)

GetServiceInstance Method (WebSocketClient<TService>)

Noemax.WebSockets Namespace > WebSocketClient<TService> Class : GetServiceInstance Method
Returns an new instance of IWebSocket to handle messages received by the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetServiceInstance() As IWebSockets
'Usage

Dim instance As WebSocketClient(Of TService)
Dim value As IWebSockets

value = instance.GetServiceInstance()
public override IWebSockets GetServiceInstance()
public function GetServiceInstance(): IWebSockets; override;
public override function GetServiceInstance() : IWebSockets;
public: IWebSockets* GetServiceInstance(); override
public:
IWebSockets^ GetServiceInstance(); override

Return Value

An instance of IWebSocket.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient<TService> Class
WebSocketClient<TService> Members
Base Implementation in GetServiceInstance


WebSocketClosedException Class

WebSocketClosedException Class
Members

Noemax.WebSockets Namespace : WebSocketClosedException Class
Provides the exception raised during WebSocket communications.
Object Model
WebSocketClosedException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketClosedException
   Inherits System.Exception
'Usage

Dim instance As WebSocketClosedException
public class WebSocketClosedException : System.Exception
public class WebSocketClosedException = class(System.Exception)
public class WebSocketClosedException extends System.Exception
public __gc class WebSocketClosedException : public System.Exception
public ref class WebSocketClosedException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.WebSocketClosedException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Members
Noemax.WebSockets Namespace


WebSocketClosedException Class Members

WebSocketClosedException Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketClosedException Class

The following tables list the members exposed by WebSocketClosedException.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClosedException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any.
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketClosedException Class
Noemax.WebSockets Namespace


WebSocketClosedException Constructor

WebSocketClosedException Constructor

Noemax.WebSockets Namespace > WebSocketClosedException Class : WebSocketClosedException Constructor
Overload List
Overload | Description
WebSocketClosedException Constructor(Int32) | Initializes a new instance of WebSocketException.
WebSocketClosedException Constructor(Int32,String) | Initializes a new instance of WebSocketException.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


WebSocketClosedException Constructor(Int32)

WebSocketClosedException Constructor(Int32)

Noemax.WebSockets Namespace > WebSocketClosedException Class > WebSocketClosedException Constructor : WebSocketClosedException Constructor(Int32)
The status code with which connection was closed.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal status As System.Integer _
)
'Usage

Dim status As System.Integer

Dim instance As New WebSocketClosedException(status)
public WebSocketClosedException(
   System.int status
)
public WebSocketClosedException(
    status: System.Integer
);
public function WebSocketClosedException(
   status : System.int
);
public: WebSocketClosedException(
   System.int status
)
public:
WebSocketClosedException(
   System.int status
)

Parameters

status
The status code with which connection was closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members
Overload List


WebSocketClosedException Constructor(Int32,String)

WebSocketClosedException Constructor(Int32,String)

Noemax.WebSockets Namespace > WebSocketClosedException Class > WebSocketClosedException Constructor : WebSocketClosedException Constructor(Int32,String)
The status code with which connection was closed.
The text describing the status with which connection was closed.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal status As System.Integer, _
   ByVal description As System.String _
)
'Usage

Dim status As System.Integer
Dim description As System.String

Dim instance As New WebSocketClosedException(status, description)
public WebSocketClosedException(
   System.int status,
   System.string description
)
public WebSocketClosedException(
    status: System.Integer;
    description: System.String
);
public function WebSocketClosedException(
   status : System.int,
   description : System.String
);
public: WebSocketClosedException(
   System.int status,
   System.string* description
)
public:
WebSocketClosedException(
   System.int status,
   System.String^ description
)

Parameters

status
The status code with which connection was closed.
description
The text describing the status with which connection was closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members
Overload List


WebSocketClosedException Class Properties

WebSocketClosedException Class Properties

Noemax.WebSockets Namespace : WebSocketClosedException Class

For a list of all members of this type, see WebSocketClosedException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any.
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketClosedException Class
Noemax.WebSockets Namespace


StatusCode Property (WebSocketClosedException)

StatusCode Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : StatusCode Property
Gets and sets the corresponding close frame status code, if any.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StatusCode As System.Integer
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Integer

instance.StatusCode = value

value = instance.StatusCode
public System.int StatusCode {get; set;}
public read-write property StatusCode: System.Integer;
public function get,set StatusCode : System.int
public: __property System.int get_StatusCode();
public: __property void set_StatusCode(
   System.int value
);
public:
property System.int StatusCode {
   System.int get();
   void set (    System.int value);
}
Remarks
Is sent to remote side prior connection is closed and provides description of the problem that resulted in connection being closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


WebSocketConnectionChannel Class

WebSocketConnectionChannel Class
Members

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class
Provides methods and properties for exchanging messages over WebSocket connection.
Object Model
WebSocketConnectionChannel Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketConnectionChannel
   Inherits WebSocketChannel
'Usage

Dim instance As WebSocketConnectionChannel
public class WebSocketConnectionChannel : WebSocketChannel
public class WebSocketConnectionChannel = class(WebSocketChannel)
public class WebSocketConnectionChannel extends WebSocketChannel
public __gc class WebSocketConnectionChannel : public WebSocketChannel
public ref class WebSocketConnectionChannel : public WebSocketChannel
Remarks

WebSocketChannel provides methods and properties for sending messages through the WebSocket connection. The messages received through the channel are dispatched by the ServiceInstance instance associated to the channel.

This class is used on both ends of WebSocket connection and provides truly duplex communication between client and server.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.WebSocketConnectionChannel
Noemax.WebSockets.WebSocketClient

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Members
Noemax.WebSockets Namespace


WebSocketConnectionChannel Class Members

WebSocketConnectionChannel Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

The following tables list the members exposed by WebSocketConnectionChannel.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden. Gets the instance of the object that is associated to the connection during authentication.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the channel connection is considered being alive.
Public Property | Context | Overridden. The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ID | Overridden. Gets and sets the string identifier of the channel.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame.
Public Property | MaxOutboundQueueSize | Overridden. Gets and sets the maximum size of the outbound message queue.
Public Property | Origin | Overridden. Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Overridden. Gets the current size of the outbound message queue in bytes.
Public Property | PayloadMasking | Overridden. Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Overridden. Gets the protocol negotiated during the WebSocket handshake.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden. Gets and sets the instance of IWebSockets to perform dispatching of inbound messages.
Public Property | State | Overridden. Gets and sets the states of WebSocket connection.
Public Property | Via | Overridden. Gets the URI via which the channel was established.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Overridden. Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Public Method | EndSendMessage | Overridden. Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Send | Overloaded. Overridden. Sends a binary message with a specified array segment as a payload within a specified interval of time.
Public Method | SendAsync | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden. Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden. Sends the ping message.
Public Method | SendTextMessage | Overloaded. Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Overridden. Waits until outbound queue decrease below specified limit.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


WebSocketConnectionChannel Class Methods

WebSocketConnectionChannel Class Methods

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

For a list of all members of this type, see WebSocketConnectionChannel members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Overridden. Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Public Method | EndSendMessage | Overridden. Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Send | Overloaded. Overridden. Sends a binary message with a specified array segment as a payload within a specified interval of time.
Public Method | SendAsync | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden. Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden. Sends the ping message.
Public Method | SendTextMessage | Overloaded. Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Overridden. Waits until outbound queue decrease below specified limit.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


Abort Method (WebSocketConnectionChannel)

Abort Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Abort Method
Interrupt all ongoing operation and closes the network connection.
Overload List
Overload | Description
Abort() | Interrupt all ongoing operation and closes the network connection.
Abort(Int32,String) | Aborts the connection and also sent the close frame with the specified status code and text description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Abort


Abort() Method

Abort() Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Abort Method : Abort() Method
Interrupt all ongoing operation and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Abort()
'Usage

Dim instance As WebSocketConnectionChannel

instance.Abort()
public override void Abort()
public procedure Abort(); override;
public override function Abort();
public: void Abort(); override
public:
void Abort(); override
Remarks
Works the same way as Close(TimeSpan) method but does not wait for ongoing operations to be completed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Abort()


Abort(Int32,String) Method

Abort(Int32,String) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Abort Method : Abort(Int32,String) Method
The status code to send to the remote endpoint.
The text description to send to the remote endpoint.
Aborts the connection and also sent the close frame with the specified status code and text description.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Abort( _
   ByVal status As System.Integer, _
   ByVal description As System.String _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim status As System.Integer
Dim description As System.String

instance.Abort(status, description)
public override void Abort(
   System.int status,
   System.string description
)
public procedure Abort(
    status: System.Integer;
    description: System.String
); override;
public override function Abort(
   status : System.int,
   description : System.String
);
public: void Abort(
   System.int status,
   System.string* description
) override
public:
void Abort(
   System.int status,
   System.String^ description
) override

Parameters

status
The status code to send to the remote endpoint.
description
The text description to send to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Abort(Int32,String)


BeginSendMessage Method (WebSocketConnectionChannel)

BeginSendMessage Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : BeginSendMessage Method
The string identifying the operation to which the message is getting sent.
The period of time during which operation must be completed or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to the asynchronous operation.
Begins an asynchronous operation to send a message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function BeginSendMessage( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketConnectionChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(message, timeout, callback, state)
public override System.IAsyncResult BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; override;
public override function BeginSendMessage(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
) override
public:
System.IAsyncResult^ BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
) override

Parameters

message
The string identifying the operation to which the message is getting sent.
timeout
The period of time during which operation must be completed or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to the asynchronous operation.

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in BeginSendMessage


Close Method (WebSocketConnectionChannel)

Close Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Close Method
Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Overload List
Overload | Description
Close(TimeSpan) | Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Close() | Wait for ongoing operation to be complete and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Close


Close(TimeSpan) Method

Close(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Close Method : Close(TimeSpan) Method
The interval of time to wait for ongoing operations to be completed, prior closing the connection.
Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Close( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim timeout As System.TimeSpan

instance.Close(timeout)
public override void Close(
   System.TimeSpan timeout
)
public procedure Close(
    timeout: System.TimeSpan
); override;
public override function Close(
   timeout : System.TimeSpan
);
public: void Close(
   System.TimeSpan timeout
) override
public:
void Close(
   System.TimeSpan timeout
) override

Parameters

timeout
The interval of time to wait for ongoing operations to be completed, prior closing the connection.
Remarks
Prior connection is closed, WebSocketChannel waits for ongoing inbound and outbound transfers to be completed for specified period of time. Once timeout expire or all ongoing transfers are complete, connection is getting closed and all associated resources are released.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Close(TimeSpan)


EndSendMessage Method (WebSocketConnectionChannel)

EndSendMessage Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : EndSendMessage Method
The IAsyncResult that references the asynchronous request operation.
Completes an asynchronous send operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub EndSendMessage( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim result As System.IAsyncResult

instance.EndSendMessage(result)
public override void EndSendMessage(
   System.IAsyncResult result
)
public procedure EndSendMessage(
    result: System.IAsyncResult
); override;
public override function EndSendMessage(
   result : System.IAsyncResult
);
public: void EndSendMessage(
   System.IAsyncResult* result
) override
public:
void EndSendMessage(
   System.IAsyncResult^ result
) override

Parameters

result
The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in EndSendMessage


Send Method (WebSocketConnectionChannel)

Send Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Send Method
Sends a binary message with a specified array segment as a payload within a specified interval of time.
Overload List
Overload | Description
Send(Byte[],Int32,Int32,TimeSpan) | Sends a binary message with a specified array segment as a payload within a specified interval of time.
Send(String,TimeSpan) | Sends a text message with a specified string as a payload within a specified interval of time.
Send(WebSocketOutboundMessage,TimeSpan) | Sends a message within a specified interval of time.
Send(WebSocketOutboundMessage) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(ArraySegment<Byte>,TimeSpan) | Sends a binary message with a specified array segment as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[]) | Sends a binary message with a specified array of bytes as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(Byte[],Int32,Int32) | Sends a binary message with a specified segment of array as a payload. (Inherited from Noemax.WebSockets.WebSocketChannel)
Send(String) | Sends a text message with a specified string as a payload within a specified interval of time. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Send


Send(Byte[],Int32,Int32,TimeSpan) Method

Send(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Send Method : Send(Byte[],Int32,Int32,TimeSpan) Method
The buffer containing the message payload.
The index in the buffer when message payload starts.
The length of the message payload in bytes.
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Sends a binary message with a specified array segment as a payload within a specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.Send(buffer, offset, count, timeout)
public override void Send(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure Send(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function Send(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void Send(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void Send(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
The buffer containing the message payload.
offset
The index in the buffer when message payload starts.
count
The length of the message payload in bytes.
timeout
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Remarks
Using this methods does not always guaranty that the message is going to be sent as a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Send(Byte[],Int32,Int32,TimeSpan)


Send(String,TimeSpan) Method

Send(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Send Method : Send(String,TimeSpan) Method
The text payload of the message.
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Sends a text message with a specified string as a payload within a specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim text As System.String
Dim timeout As System.TimeSpan

instance.Send(text, timeout)
public override void Send(
   System.string text,
   System.TimeSpan timeout
)
public procedure Send(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function Send(
   text : System.String,
   timeout : System.TimeSpan
);
public: void Send(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void Send(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
The text payload of the message.
timeout
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of the time.
Remarks
Using this methods does not always guaranty that the message is going to be sent as a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Send(String,TimeSpan)


Send(WebSocketOutboundMessage,TimeSpan) Method

Send(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > Send Method : Send(WebSocketOutboundMessage,TimeSpan) Method
WebSocketOutboundMessage value containing the message.
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.
Sends a message within a specified interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub Send( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.Send(message, timeout)
public override void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure Send(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function Send(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void Send(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
WebSocketOutboundMessage value containing the message.
timeout
The interval of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.
Remarks
Using this methods does not always guaranty that the message is going to be sent as a single fragment. For example, when compression extensions are used, message may have to be fragmented due to extension requirements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in Send(WebSocketOutboundMessage,TimeSpan)


SendAsync Method (WebSocketConnectionChannel)

SendAsync Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendAsync Method
Sends the message asynchronously.
Overload List
Overload | Description
SendAsync(Byte[],Int32,Int32,TimeSpan) | Sends the message asynchronously.
SendAsync(String,TimeSpan) | Sends the message asynchronously.
SendAsync(WebSocketOutboundMessage,TimeSpan) | Sends the message asynchronously.
SendAsync(WebSocketOutboundMessage) | Sends a message within a specified interval of time asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(Byte[],Int32,Int32) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
SendAsync(String) | Sends the message asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in SendAsync


SendAsync(Byte[],Int32,Int32,TimeSpan) Method

SendAsync(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendAsync Method : SendAsync(Byte[],Int32,Int32,TimeSpan) Method
The buffer containing the message payload.
The index in the buffer when message payload starts.
The length of the message payload in bytes.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.SendAsync(buffer, offset, count, timeout)
public override void SendAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure SendAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
) override

Parameters

buffer
The buffer containing the message payload.
offset
The index in the buffer when message payload starts.
count
The length of the message payload in bytes.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendAsync(Byte[],Int32,Int32,TimeSpan)


SendAsync(String,TimeSpan) Method

SendAsync(String,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendAsync Method : SendAsync(String,TimeSpan) Method
The text payload of the message.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim text As System.String
Dim timeout As System.TimeSpan

instance.SendAsync(text, timeout)
public override void SendAsync(
   System.string text,
   System.TimeSpan timeout
)
public procedure SendAsync(
    text: System.String;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   text : System.String,
   timeout : System.TimeSpan
);
public: void SendAsync(
   System.string* text,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   System.String^ text,
   System.TimeSpan timeout
) override

Parameters

text
The text payload of the message.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendAsync(String,TimeSpan)


SendAsync(WebSocketOutboundMessage,TimeSpan) Method

SendAsync(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendAsync Method : SendAsync(WebSocketOutboundMessage,TimeSpan) Method
WebSocketOutboundMessage value containing the message.
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Sends the message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendAsync(message, timeout)
public override void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
); override;
public override function SendAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override
public:
void SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
) override

Parameters

message
WebSocketOutboundMessage value containing the message.
timeout
The amount of time during which to wait for message to be sent. TimeoutException will be thrown if message is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it is first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread-safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendAsync(WebSocketOutboundMessage,TimeSpan)


SendBatchAsync Method (WebSocketConnectionChannel)

SendBatchAsync Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendBatchAsync Method
Sends the batch of the messages asynchronously.
Overload List
Overload | Description
SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) | Sends the batch of the messages asynchronously.
SendBatchAsync(WebSocketOutboundMessage[]) | Sends the batch of the messages asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in SendBatchAsync


SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[],TimeSpan) Method
The batch of messages to be sent.
The amount of time during which to wait for messages to be sent. TimeoutException will be thrown if messages is not completely sent within the specified period of the time.
Sends the batch of the messages asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim messages() As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendBatchAsync(messages, timeout)
public override void SendBatchAsync(
   WebSocketOutboundMessage[] messages,
   System.TimeSpan timeout
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of;
    timeout: System.TimeSpan
); override;
public override function SendBatchAsync(
   messages : WebSocketOutboundMessage[],
   timeout : System.TimeSpan
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* messages,
   System.TimeSpan timeout
) override
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages,
   System.TimeSpan timeout
) override

Parameters

messages
The batch of messages to be sent.
timeout
The amount of time during which to wait for messages to be sent. TimeoutException will be thrown if messages is not completely sent within the specified period of the time.
Remarks

When message is sent asynchronously it's first getting added into the outbound message queue. If another asynchronous send operation is currently in progress, then the messages in the outbound queue are sent once ongoing send operation is complete.

This method is thread safe and can be called by multiple working threads concurrently.

You can control the size of the outbound message queue by using the OutboundQueueSize and MaxOutboundQueueSize properties.

If outbound queue size exceed the limit specified by MaxOutboundQueueSize, WebSocketQueueSizeException is thrown. Messages bigger than the MaxOutboundQueueSize limit, cannot be sent asynchronously, unless MaxOutboundQueueSize value is increased to required size.

Warning: Application must not use synchronous and asynchronous send methods concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendBatchAsync(WebSocketOutboundMessage[],TimeSpan)


SendClose Method (WebSocketConnectionChannel)

SendClose Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendClose Method
The status code in range of 1000-4999 that specifies the reason why connection is being closed.
The string description of the status. Not required to be human readable but UTF-8 representation of the string should not exceed 125 bytes.
The amount of time to wait for CLOSE frame to be sent, prior TimeoutException is thrown.
Sends the CLOSE control frame with specified statusCode and reason string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub SendClose( _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim statusCode As System.Short
Dim reason As System.String
Dim timeout As System.TimeSpan

instance.SendClose(statusCode, reason, timeout)
public override void SendClose(
   System.short statusCode,
   System.string reason,
   System.TimeSpan timeout
)
public procedure SendClose(
    statusCode: System.Int16;
    reason: System.String;
    timeout: System.TimeSpan
); override;
public override function SendClose(
   statusCode : System.short,
   reason : System.String,
   timeout : System.TimeSpan
);
public: void SendClose(
   System.short statusCode,
   System.string* reason,
   System.TimeSpan timeout
) override
public:
void SendClose(
   System.short statusCode,
   System.String^ reason,
   System.TimeSpan timeout
) override

Parameters

statusCode
The status code in range of 1000-4999 that specifies the reason why connection is being closed.
reason
The string description of the status. Not required to be human readable but UTF-8 representation of the string should not exceed 125 bytes.
timeout
The amount of time to wait for CLOSE frame to be sent, prior TimeoutException is thrown.
Remarks
When CLOSE frame is sent to remote side, no more messages or fragments can be sent though the connection. Local side can continue receiving pending messages until connection is closed by remote side. SendClose() does not close the connection, Close(TimeSpan) method need to be called to close connection and release all associated resources.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in SendClose


SendMessage Method (WebSocketConnectionChannel)

SendMessage Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendMessage Method
Streams the binary message to the remote side.
Overload List
Overload | Description
SendMessage(TimeSpan) | Streams the binary message to the remote side.
SendMessage() | Streams the binary message to the remote side. (Inherited from Noemax.WebSockets.WebSocketChannel)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in SendMessage


SendMessage(TimeSpan) Method

SendMessage(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendMessage Method : SendMessage(TimeSpan) Method
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.
Streams the binary message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As WebSocketConnectionChannel
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.SendMessage(timeout)
public override System.IO.Stream SendMessage(
   System.TimeSpan timeout
)
public function SendMessage(
    timeout: System.TimeSpan
): System.IO.Stream; override;
public override function SendMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: System.IO.Stream* SendMessage(
   System.TimeSpan timeout
) override
public:
System.IO.Stream^ SendMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.

Return Value

The input to write the outbound message payload into.
Remarks

This method is part of the streaming API, it allows to input messages of arbitrary size to remote side and avoid buffering entire message in the memory.

The input returned by this methods, writes the message payload directly into WebSocket connection.

Fragmentation and buffering are performed automatically. As soon as input buffer have to be flushed, buffered bytes are sent as a message fragment and become available on remote side.

If amount of bytes being written in single write operation is more than the size of input buffer, then these bytes are getting combined with bytes already buffered and sent as a single fragment.

You can force input to send buffered bytes by calling Flush() method.

You can input any amount of data as payload of the message until you decide to close it. Closing the input concludes the outbound message and final fragment frame is sent to remote side to indicate the end of the message.

The flow control is performed by TCP layer. The writing side is getting blocked if remote side input buffers are full. As faster remote side reads data, as faster the local side can continue sending.

Note: WebSocket connection cannot input more than one message concurrently.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendMessage(TimeSpan)


SendPing Method (WebSocketConnectionChannel)

SendPing Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendPing Method
Sends the ping message.
Overload List
Overload | Description
SendPing() | Sends the ping message.
SendPing(Byte[]) | Sends the ping message with a specified binary payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in SendPing


SendPing() Method

SendPing() Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendPing Method : SendPing() Method
Sends the ping message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing()
'Usage

Dim instance As WebSocketConnectionChannel

instance.SendPing()
public override void SendPing()
public procedure SendPing(); override;
public override function SendPing();
public: void SendPing(); override
public:
void SendPing(); override
Remarks
The PONG message is sent automatically when PING message is received. The IWebSockets.OnPong method of associated service will be called, upon receiving the PONG reply to the ping message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendPing()


SendPing(Byte[]) Method

SendPing(Byte[]) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendPing Method : SendPing(Byte[]) Method
The array of bytes being sent as payload of the ping message.
Sends the ping message with a specified binary payload.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub SendPing( _
   ByVal payload() As System.Byte _
)
'Usage

Dim instance As WebSocketConnectionChannel
Dim payload() As System.Byte

instance.SendPing(payload)
public override void SendPing(
   System.byte[] payload
)
public procedure SendPing(
    payload: System.Bytearray of
); override;
public override function SendPing(
   payload : System.byte[]
);
public: void SendPing(
   System.byte[]* payload
) override
public:
void SendPing(
   System.array<byte>^ payload
) override

Parameters

payload
The array of bytes being sent as payload of the ping message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendPing(Byte[])


SendTextMessage Method (WebSocketConnectionChannel)

SendTextMessage Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : SendTextMessage Method
Streams the text message to the remote side.
Overload List
Overload | Description
SendTextMessage() | Streams the text message to the remote side.
SendTextMessage(TimeSpan) | Streams the text message to the remote side.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members


SendTextMessage() Method

SendTextMessage() Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendTextMessage Method : SendTextMessage() Method
Streams the text message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendTextMessage() As System.IO.TextWriter
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.IO.TextWriter

value = instance.SendTextMessage()
public System.IO.TextWriter SendTextMessage()
public function SendTextMessage(): System.IO.TextWriter;
public function SendTextMessage() : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage();
public:
System.IO.TextWriter^ SendTextMessage();

Return Value

The text writer to write the outbound message payload into.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List


SendTextMessage(TimeSpan) Method

SendTextMessage(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class > SendTextMessage Method : SendTextMessage(TimeSpan) Method
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.
Streams the text message to the remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function SendTextMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.TextWriter
'Usage

Dim instance As WebSocketConnectionChannel
Dim timeout As System.TimeSpan
Dim value As System.IO.TextWriter

value = instance.SendTextMessage(timeout)
public override System.IO.TextWriter SendTextMessage(
   System.TimeSpan timeout
)
public function SendTextMessage(
    timeout: System.TimeSpan
): System.IO.TextWriter; override;
public override function SendTextMessage(
   timeout : System.TimeSpan
) : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage(
   System.TimeSpan timeout
) override
public:
System.IO.TextWriter^ SendTextMessage(
   System.TimeSpan timeout
) override

Parameters

timeout
The interval of time during which the message is expected to be sent. TimeoutException will be thrown if message is not completely sent within the specified interval of time.

Return Value

The text writer to write the outbound message payload into.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Overload List
Base Implementation in SendTextMessage


WaitForOutboundQueue Method (WebSocketConnectionChannel)

WaitForOutboundQueue Method (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : WaitForOutboundQueue Method
The limit below which the queue size is expected to decrease.
The amount of time to wait for queue to decrease below specified limit.
Waits until outbound queue decrease below specified limit.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function WaitForOutboundQueue( _
   ByVal queueSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocketConnectionChannel
Dim queueSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(queueSize, timeout)
public override System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    queueSize: System.Int64;
    timeout: System.TimeSpan
): System.Boolean; override;
public override function WaitForOutboundQueue(
   queueSize : System.long,
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
) override
public:
System.bool WaitForOutboundQueue(
   System.int64 queueSize,
   System.TimeSpan timeout
) override

Parameters

queueSize
The limit below which the queue size is expected to decrease.
timeout
The amount of time to wait for queue to decrease below specified limit.

Return Value

true if the queue decreased below specified limit; false otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in WaitForOutboundQueue


WebSocketConnectionChannel Class Properties

WebSocketConnectionChannel Class Properties

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

For a list of all members of this type, see WebSocketConnectionChannel members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden. Gets the instance of the object that is associated to the connection during authentication.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the channel connection is considered being alive.
Public Property | Context | Overridden. The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ID | Overridden. Gets and sets the string identifier of the channel.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame.
Public Property | MaxOutboundQueueSize | Overridden. Gets and sets the maximum size of the outbound message queue.
Public Property | Origin | Overridden. Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Overridden. Gets the current size of the outbound message queue in bytes.
Public Property | PayloadMasking | Overridden. Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Overridden. Gets the protocol negotiated during the WebSocket handshake.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden. Gets and sets the instance of IWebSockets to perform dispatching of inbound messages.
Public Property | State | Overridden. Gets and sets the states of WebSocket connection.
Public Property | Via | Overridden. Gets the URI via which the channel was established.
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


AuthenticationContext Property (WebSocketConnectionChannel)

AuthenticationContext Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : AuthenticationContext Property
Gets the instance of the object that is associated to the connection during authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property AuthenticationContext As System.Object
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Object

value = instance.AuthenticationContext
public override System.object AuthenticationContext {get;}
public read-only property AuthenticationContext: System.TObject; override;
public override function get AuthenticationContext : System.Object
public: __property System.Object* get_AuthenticationContext() override;
public:
property System.Object^ AuthenticationContext {
   System.Object^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in AuthenticationContext


AutoPingInterval Property (WebSocketConnectionChannel)

AutoPingInterval Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : AutoPingInterval Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property AutoPingInterval As System.TimeSpan
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.TimeSpan

instance.AutoPingInterval = value

value = instance.AutoPingInterval
public override System.TimeSpan AutoPingInterval {get; set;}
public read-write property AutoPingInterval: System.TimeSpan; override;
public override function get,set AutoPingInterval : System.TimeSpan
public: __property System.TimeSpan get_AutoPingInterval() override;
public: __property void set_AutoPingInterval(
   System.TimeSpan value
) override;
public:
property System.TimeSpan AutoPingInterval {
   System.TimeSpan get() override;
   void set (    System.TimeSpan value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in AutoPingInterval


Connected Property (WebSocketConnectionChannel)

Connected Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Connected Property
Gets whether the channel connection is considered being alive.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Connected As System.Boolean
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Boolean

value = instance.Connected
public override System.bool Connected {get;}
public read-only property Connected: System.Boolean; override;
public override function get Connected : System.boolean
public: __property System.bool get_Connected() override;
public:
property System.bool Connected {
   System.bool get() override;
}
Remarks

This property reports the last operation state of the channel rather than performs the actually TCP connectivity checks.

When this property value is true, it indicates that channel is not being closed and last send/receive operations where completed successfully.

When this property value is false, it indicates that channel is either being closed or closed. This does not exclude the possibility that channel is in transition state and may still be able to send or receive messages.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Connected


Context Property (WebSocketConnectionChannel)

Context Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Context Property
The context object associated to the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property Context As System.Object
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Object

instance.Context = value

value = instance.Context
public override System.object Context {get; set;}
public read-write property Context: System.TObject; override;
public override function get,set Context : System.Object
public: __property System.Object* get_Context() override;
public: __property void set_Context(
   System.Object* value
) override;
public:
property System.Object^ Context {
   System.Object^ get() override;
   void set (    System.Object^ value) override;
}
Remarks
This property allows to associate any application specific object to the channel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Context


ID Property (WebSocketConnectionChannel)

ID Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : ID Property
Gets and sets the string identifier of the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property ID As System.String
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.String

instance.ID = value

value = instance.ID
public override System.string ID {get; set;}
public read-write property ID: System.String; override;
public override function get,set ID : System.String
public: __property System.string* get_ID() override;
public: __property void set_ID(
   System.string* value
) override;
public:
property System.String^ ID {
   System.String^ get() override;
   void set (    System.String^ value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in ID


MaxOutboundFrameSize Property (WebSocketConnectionChannel)

MaxOutboundFrameSize Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : MaxOutboundFrameSize Property
Gets and sets the maximum size limit for outbound data frame.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxOutboundFrameSize As System.Long
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Long

instance.MaxOutboundFrameSize = value

value = instance.MaxOutboundFrameSize
public System.long MaxOutboundFrameSize {get; set;}
public read-write property MaxOutboundFrameSize: System.Int64;
public function get,set MaxOutboundFrameSize : System.long
public: __property System.long get_MaxOutboundFrameSize();
public: __property void set_MaxOutboundFrameSize(
   System.long value
);
public:
property System.int64 MaxOutboundFrameSize {
   System.int64 get();
   void set (    System.int64 value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members


MaxOutboundQueueSize Property (WebSocketConnectionChannel)

MaxOutboundQueueSize Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : MaxOutboundQueueSize Property
Gets and sets the maximum size of the outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property MaxOutboundQueueSize As System.Long
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Long

instance.MaxOutboundQueueSize = value

value = instance.MaxOutboundQueueSize
public override System.long MaxOutboundQueueSize {get; set;}
public read-write property MaxOutboundQueueSize: System.Int64; override;
public override function get,set MaxOutboundQueueSize : System.long
public: __property System.long get_MaxOutboundQueueSize() override;
public: __property void set_MaxOutboundQueueSize(
   System.long value
) override;
public:
property System.int64 MaxOutboundQueueSize {
   System.int64 get() override;
   void set (    System.int64 value) override;
}
Remarks

If asynchronous send operations would result in outbound queue size exceeding the specified limit, it fails with WebSocketQueueSizeException thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in MaxOutboundQueueSize


Origin Property (WebSocketConnectionChannel)

Origin Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Origin Property
Gets origin string negotiated during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Origin As System.String
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.String

value = instance.Origin
public override System.string Origin {get;}
public read-only property Origin: System.String; override;
public override function get Origin : System.String
public: __property System.string* get_Origin() override;
public:
property System.String^ Origin {
   System.String^ get() override;
}
Remarks
The Origin string may be required by WebSocket server to identify the script that runs on the client side when WebSocket is used by a browser client. This optional header is exchanged during the WebSocket handshake, both the server and the client may drop a connection if the value of the Origin string does not match their expectation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Origin


OutboundQueueSize Property (WebSocketConnectionChannel)

OutboundQueueSize Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : OutboundQueueSize Property
Gets the current size of the outbound message queue in bytes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property OutboundQueueSize As System.Long
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Long

value = instance.OutboundQueueSize
public override System.long OutboundQueueSize {get;}
public read-only property OutboundQueueSize: System.Int64; override;
public override function get OutboundQueueSize : System.long
public: __property System.long get_OutboundQueueSize() override;
public:
property System.int64 OutboundQueueSize {
   System.int64 get() override;
}
Remarks

The size of outbound queue does not indicate an amount of memory used by the queue, but it represents the number of bytes that is pending to be sent.

When message is added to the queue, it's payload is not getting copied, but referenced until the message is sent, so corresponding buffers should not be modified during asynchronous send operation.

Only messages that are being sent asynchronously getting stored in the outbound queue.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in OutboundQueueSize


PayloadMasking Property (WebSocketConnectionChannel)

PayloadMasking Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : PayloadMasking Property
Gets and sets whether the payload of outbound messages is masked.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property PayloadMasking As System.Boolean
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public override System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean; override;
public override function get,set PayloadMasking : System.boolean
public: __property System.bool get_PayloadMasking() override;
public: __property void set_PayloadMasking(
   System.bool value
) override;
public:
property System.bool PayloadMasking {
   System.bool get() override;
   void set (    System.bool value) override;
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking my setting this property, but strict WebSocket implementations may drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in PayloadMasking


Protocol Property (WebSocketConnectionChannel)

Protocol Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Protocol Property
Gets the protocol negotiated during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Protocol As System.String
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.String

value = instance.Protocol
public override System.string Protocol {get;}
public read-only property Protocol: System.String; override;
public override function get Protocol : System.String
public: __property System.string* get_Protocol() override;
public:
property System.String^ Protocol {
   System.String^ get() override;
}
Remarks
Protocol string value is getting exchanged during the WebSocket handshake. Applications can use this value to negotiate the type of the protocol that is going to be used during communication e.g. 'chat', 'echo', 'atom' e.t.c.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Protocol


ServiceInstance Property (WebSocketConnectionChannel)

ServiceInstance Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : ServiceInstance Property
Gets and sets the instance of IWebSockets to perform dispatching of inbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property ServiceInstance As IWebSockets
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As IWebSockets

instance.ServiceInstance = value

value = instance.ServiceInstance
public override IWebSockets ServiceInstance {get; set;}
public read-write property ServiceInstance: IWebSockets; override;
public override function get,set ServiceInstance : IWebSockets
public: __property IWebSockets* get_ServiceInstance() override;
public: __property void set_ServiceInstance(
   IWebSockets* value
) override;
public:
property IWebSockets^ ServiceInstance {
   IWebSockets^ get() override;
   void set (    IWebSockets^ value) override;
}
Remarks

Using this property a you can change the instance of IWebSockets that dispatches inbound message at any moment during communication.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in ServiceInstance


State Property (WebSocketConnectionChannel)

State Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : State Property
Gets and sets the states of WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property State As WebSocketState
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As WebSocketState

value = instance.State
public override WebSocketState State {get;}
public read-only property State: WebSocketState; override;
public override function get State : WebSocketState
public: __property WebSocketState get_State() override;
public:
property WebSocketState State {
   WebSocketState get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in State


Via Property (WebSocketConnectionChannel)

Via Property (WebSocketConnectionChannel)

Noemax.WebSockets Namespace > WebSocketConnectionChannel Class : Via Property
Gets the URI via which the channel was established.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property Via As System.Uri
'Usage

Dim instance As WebSocketConnectionChannel
Dim value As System.Uri

value = instance.Via
public override System.Uri Via {get;}
public read-only property Via: System.Uri; override;
public override function get Via : System.Uri
public: __property System.Uri* get_Via() override;
public:
property System.Uri^ Via {
   System.Uri^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketConnectionChannel Class
WebSocketConnectionChannel Members
Base Implementation in Via


WebSocketEndpoint Class

WebSocketEndpoint Class
Members

Noemax.WebSockets Namespace : WebSocketEndpoint Class
Provides methods and properties of WebSocket endpoint.
Object Model
WebSocketEndpoint Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class WebSocketEndpoint
'Usage

Dim instance As WebSocketEndpoint
public sealed class WebSocketEndpoint
public class WebSocketEndpoint sealed;
public sealed class WebSocketEndpoint
public __gc __sealed class WebSocketEndpoint
public ref class WebSocketEndpoint sealed
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketEndpoint

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEndpoint Members
Noemax.WebSockets Namespace


WebSocketEndpoint Class Members

WebSocketEndpoint Class Members
Properties Methods

Noemax.WebSockets Namespace : WebSocketEndpoint Class

The following tables list the members exposed by WebSocketEndpoint.

Public Properties
 | Name | Description
Public Property | Listener | Returns the WebSocketListener instance that accepts client connections.
Public Property | TraceSource |
Top
Public Methods
 | Name | Description
Public Method | Close | Close WebSocket endpoint and stops accepting client connections.
Public Method | Open | Opens WebSocket endpoint and starts accepting client connections.
Top
See Also

Reference

WebSocketEndpoint Class
Noemax.WebSockets Namespace


WebSocketEndpoint Class Methods

WebSocketEndpoint Class Methods

Noemax.WebSockets Namespace : WebSocketEndpoint Class

For a list of all members of this type, see WebSocketEndpoint members.

Public Methods
 | Name | Description
Public Method | Close | Close WebSocket endpoint and stops accepting client connections.
Public Method | Open | Opens WebSocket endpoint and starts accepting client connections.
Top
See Also

Reference

WebSocketEndpoint Class
Noemax.WebSockets Namespace


Close Method (WebSocketEndpoint)

Close Method (WebSocketEndpoint)

Noemax.WebSockets Namespace > WebSocketEndpoint Class : Close Method
Close WebSocket endpoint and stops accepting client connections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As WebSocketEndpoint

instance.Close()
public void Close()
public procedure Close();
public function Close();
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEndpoint Class
WebSocketEndpoint Members


Open Method (WebSocketEndpoint)

Open Method (WebSocketEndpoint)

Noemax.WebSockets Namespace > WebSocketEndpoint Class : Open Method
Opens WebSocket endpoint and starts accepting client connections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Open()
'Usage

Dim instance As WebSocketEndpoint

instance.Open()
public void Open()
public procedure Open();
public function Open();
public: void Open();
public:
void Open();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEndpoint Class
WebSocketEndpoint Members


WebSocketEndpoint Class Properties

WebSocketEndpoint Class Properties

Noemax.WebSockets Namespace : WebSocketEndpoint Class

For a list of all members of this type, see WebSocketEndpoint members.

Public Properties
 | Name | Description
Public Property | Listener | Returns the WebSocketListener instance that accepts client connections.
Public Property | TraceSource |
Top
See Also

Reference

WebSocketEndpoint Class
Noemax.WebSockets Namespace


Listener Property (WebSocketEndpoint)

Listener Property (WebSocketEndpoint)

Noemax.WebSockets Namespace > WebSocketEndpoint Class : Listener Property
Returns the WebSocketListener instance that accepts client connections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Listener As WebSocketListener
'Usage

Dim instance As WebSocketEndpoint
Dim value As WebSocketListener

value = instance.Listener
public WebSocketListener Listener {get;}
public read-only property Listener: WebSocketListener;
public function get Listener : WebSocketListener
public: __property WebSocketListener* get_Listener();
public:
property WebSocketListener^ Listener {
   WebSocketListener^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEndpoint Class
WebSocketEndpoint Members


TraceSource Property (WebSocketEndpoint)

TraceSource Property (WebSocketEndpoint)

Noemax.WebSockets Namespace > WebSocketEndpoint Class : TraceSource Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketEndpoint
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEndpoint Class
WebSocketEndpoint Members


WebSocketEventArgs Class

WebSocketEventArgs Class
Members

Noemax.WebSockets Namespace : WebSocketEventArgs Class
Provides the arguments of the event triggered by the BasicWebSocketClient class.
Object Model
WebSocketEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As WebSocketEventArgs
public class WebSocketEventArgs : System.EventArgs
public class WebSocketEventArgs = class(System.EventArgs)
public class WebSocketEventArgs extends System.EventArgs
public __gc class WebSocketEventArgs : public System.EventArgs
public ref class WebSocketEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.WebSocketEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Members
Noemax.WebSockets Namespace


WebSocketEventArgs Class Members

WebSocketEventArgs Class Members
Properties

Noemax.WebSockets Namespace : WebSocketEventArgs Class

The following tables list the members exposed by WebSocketEventArgs.

Public Constructors
 | Name | Description
Public Constructor | WebSocketEventArgs Constructor |
Top
Public Properties
 | Name | Description
Public Property | BinaryData | The payload of the binary message.
Public Property | Exception | Exception thrown during WebSocket operation.
Public Property | Message | The WebSocketInboundMessage object associated to the message.
Public Property | TextData | The payload of the text message.
Top
See Also

Reference

WebSocketEventArgs Class
Noemax.WebSockets Namespace


WebSocketEventArgs Constructor

WebSocketEventArgs Constructor

Noemax.WebSockets Namespace > WebSocketEventArgs Class : WebSocketEventArgs Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketEventArgs()
public WebSocketEventArgs()
public WebSocketEventArgs();
public function WebSocketEventArgs();
public: WebSocketEventArgs();
public:
WebSocketEventArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Class
WebSocketEventArgs Members


WebSocketEventArgs Class Properties

WebSocketEventArgs Class Properties

Noemax.WebSockets Namespace : WebSocketEventArgs Class

For a list of all members of this type, see WebSocketEventArgs members.

Public Properties
 | Name | Description
Public Property | BinaryData | The payload of the binary message.
Public Property | Exception | Exception thrown during WebSocket operation.
Public Property | Message | The WebSocketInboundMessage object associated to the message.
Public Property | TextData | The payload of the text message.
Top
See Also

Reference

WebSocketEventArgs Class
Noemax.WebSockets Namespace


BinaryData Property (WebSocketEventArgs)

BinaryData Property (WebSocketEventArgs)

Noemax.WebSockets Namespace > WebSocketEventArgs Class : BinaryData Property
The payload of the binary message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BinaryData As System.Byte()
'Usage

Dim instance As WebSocketEventArgs
Dim value() As System.Byte

instance.BinaryData = value

value = instance.BinaryData
public System.byte[] BinaryData {get; set;}
public read-write property BinaryData: System.array of Byte;
public function get,set BinaryData : System.byte[]
public: __property System.byte[]* get_BinaryData();
public: __property void set_BinaryData(
   System.byte[]* value
);
public:
property System.array<byte>^ BinaryData {
   System.array<byte>^ get();
   void set (    System.array<byte>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Class
WebSocketEventArgs Members


Exception Property (WebSocketEventArgs)

Exception Property (WebSocketEventArgs)

Noemax.WebSockets Namespace > WebSocketEventArgs Class : Exception Property
Exception thrown during WebSocket operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Exception As System.Exception
'Usage

Dim instance As WebSocketEventArgs
Dim value As System.Exception

instance.Exception = value

value = instance.Exception
public System.Exception Exception {get; set;}
public read-write property Exception: System.Exception;
public function get,set Exception : System.Exception
public: __property System.Exception* get_Exception();
public: __property void set_Exception(
   System.Exception* value
);
public:
property System.Exception^ Exception {
   System.Exception^ get();
   void set (    System.Exception^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Class
WebSocketEventArgs Members


Message Property (WebSocketEventArgs)

Message Property (WebSocketEventArgs)

Noemax.WebSockets Namespace > WebSocketEventArgs Class : Message Property
The WebSocketInboundMessage object associated to the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Message As WebSocketInboundMessage
'Usage

Dim instance As WebSocketEventArgs
Dim value As WebSocketInboundMessage

instance.Message = value

value = instance.Message
public WebSocketInboundMessage Message {get; set;}
public read-write property Message: WebSocketInboundMessage;
public function get,set Message : WebSocketInboundMessage
public: __property WebSocketInboundMessage* get_Message();
public: __property void set_Message(
   WebSocketInboundMessage* value
);
public:
property WebSocketInboundMessage^ Message {
   WebSocketInboundMessage^ get();
   void set (    WebSocketInboundMessage^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Class
WebSocketEventArgs Members


TextData Property (WebSocketEventArgs)

TextData Property (WebSocketEventArgs)

Noemax.WebSockets Namespace > WebSocketEventArgs Class : TextData Property
The payload of the text message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TextData As System.String
'Usage

Dim instance As WebSocketEventArgs
Dim value As System.String

instance.TextData = value

value = instance.TextData
public System.string TextData {get; set;}
public read-write property TextData: System.String;
public function get,set TextData : System.String
public: __property System.string* get_TextData();
public: __property void set_TextData(
   System.string* value
);
public:
property System.String^ TextData {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketEventArgs Class
WebSocketEventArgs Members


WebSocketException Class

WebSocketException Class
Members

Noemax.WebSockets Namespace : WebSocketException Class
Provides the exception raised during WebSocket communications.
Object Model
WebSocketException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketException
   Inherits System.Exception
'Usage

Dim instance As WebSocketException
public class WebSocketException : System.Exception
public class WebSocketException = class(System.Exception)
public class WebSocketException extends System.Exception
public __gc class WebSocketException : public System.Exception
public ref class WebSocketException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.WebSocketException
Noemax.WebSockets.WebSocketProtocolException
Noemax.WebSockets.WebSocketQueueSizeException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Members
Noemax.WebSockets Namespace


WebSocketException Class Members

WebSocketException Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketException Class

The following tables list the members exposed by WebSocketException.

Public Constructors
 | Name | Description
Public Constructor | WebSocketException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any.
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketException Class
Noemax.WebSockets Namespace


WebSocketException Constructor

WebSocketException Constructor

Noemax.WebSockets Namespace > WebSocketException Class : WebSocketException Constructor
Overload List
Overload | Description
WebSocketException Constructor(String) | Initializes a new instance of WebSocketException.
WebSocketException Constructor(Int32,String) | Initializes a new instance of WebSocketException.
WebSocketException Constructor(String,Exception) | Initializes a new instance of WebSocketException.
WebSocketException Constructor(Int32,String,Exception) | Initializes a new instance of WebSocketException.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


WebSocketException Constructor(String)

WebSocketException Constructor(String)

Noemax.WebSockets Namespace > WebSocketException Class > WebSocketException Constructor : WebSocketException Constructor(String)
The text message of exception.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String _
)
'Usage

Dim message As System.String

Dim instance As New WebSocketException(message)
public WebSocketException(
   System.string message
)
public WebSocketException(
    message: System.String
);
public function WebSocketException(
   message : System.String
);
public: WebSocketException(
   System.string* message
)
public:
WebSocketException(
   System.String^ message
)

Parameters

message
The text message of exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members
Overload List


WebSocketException Constructor(Int32,String)

WebSocketException Constructor(Int32,String)

Noemax.WebSockets Namespace > WebSocketException Class > WebSocketException Constructor : WebSocketException Constructor(Int32,String)
The integer status code associated with exception.
The text message of exception.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal status As System.Integer, _
   ByVal message As System.String _
)
'Usage

Dim status As System.Integer
Dim message As System.String

Dim instance As New WebSocketException(status, message)
public WebSocketException(
   System.int status,
   System.string message
)
public WebSocketException(
    status: System.Integer;
    message: System.String
);
public function WebSocketException(
   status : System.int,
   message : System.String
);
public: WebSocketException(
   System.int status,
   System.string* message
)
public:
WebSocketException(
   System.int status,
   System.String^ message
)

Parameters

status
The integer status code associated with exception.
message
The text message of exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members
Overload List


WebSocketException Constructor(String,Exception)

WebSocketException Constructor(String,Exception)

Noemax.WebSockets Namespace > WebSocketException Class > WebSocketException Constructor : WebSocketException Constructor(String,Exception)
The text message of exception.
The inner exception related to this exception.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal inner As System.Exception _
)
'Usage

Dim message As System.String
Dim inner As System.Exception

Dim instance As New WebSocketException(message, inner)
public WebSocketException(
   System.string message,
   System.Exception inner
)
public WebSocketException(
    message: System.String;
    inner: System.Exception
);
public function WebSocketException(
   message : System.String,
   inner : System.Exception
);
public: WebSocketException(
   System.string* message,
   System.Exception* inner
)
public:
WebSocketException(
   System.String^ message,
   System.Exception^ inner
)

Parameters

message
The text message of exception.
inner
The inner exception related to this exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members
Overload List


WebSocketException Constructor(Int32,String,Exception)

WebSocketException Constructor(Int32,String,Exception)

Noemax.WebSockets Namespace > WebSocketException Class > WebSocketException Constructor : WebSocketException Constructor(Int32,String,Exception)
The integer status code associated with exception.
The text message of exception.
The inner exception related to this exception.
Initializes a new instance of WebSocketException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal status As System.Integer, _
   ByVal message As System.String, _
   ByVal inner As System.Exception _
)
'Usage

Dim status As System.Integer
Dim message As System.String
Dim inner As System.Exception

Dim instance As New WebSocketException(status, message, inner)
public WebSocketException(
   System.int status,
   System.string message,
   System.Exception inner
)
public WebSocketException(
    status: System.Integer;
    message: System.String;
    inner: System.Exception
);
public function WebSocketException(
   status : System.int,
   message : System.String,
   inner : System.Exception
);
public: WebSocketException(
   System.int status,
   System.string* message,
   System.Exception* inner
)
public:
WebSocketException(
   System.int status,
   System.String^ message,
   System.Exception^ inner
)

Parameters

status
The integer status code associated with exception.
message
The text message of exception.
inner
The inner exception related to this exception.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members
Overload List


WebSocketException Class Properties

WebSocketException Class Properties

Noemax.WebSockets Namespace : WebSocketException Class

For a list of all members of this type, see WebSocketException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any.
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketException Class
Noemax.WebSockets Namespace


StatusCode Property (WebSocketException)

StatusCode Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : StatusCode Property
Gets and sets the corresponding close frame status code, if any.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StatusCode As System.Integer
'Usage

Dim instance As WebSocketException
Dim value As System.Integer

instance.StatusCode = value

value = instance.StatusCode
public System.int StatusCode {get; set;}
public read-write property StatusCode: System.Integer;
public function get,set StatusCode : System.int
public: __property System.int get_StatusCode();
public: __property void set_StatusCode(
   System.int value
);
public:
property System.int StatusCode {
   System.int get();
   void set (    System.int value);
}
Remarks
Is sent to remote side prior connection is closed and provides description of the problem that resulted in connection being closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


WebSocketHandshake Class

WebSocketHandshake Class
Members

Noemax.WebSockets Namespace : WebSocketHandshake Class
Provides method and properties for evaluating the WebSocket handshake prior it is accepted by the local side.
Object Model
WebSocketHandshake Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketHandshake
   Inherits System.EventArgs
'Usage

Dim instance As WebSocketHandshake
public class WebSocketHandshake : System.EventArgs
public class WebSocketHandshake = class(System.EventArgs)
public class WebSocketHandshake extends System.EventArgs
public __gc class WebSocketHandshake : public System.EventArgs
public ref class WebSocketHandshake : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.WebSocketHandshake

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Members
Noemax.WebSockets Namespace


WebSocketHandshake Class Members

WebSocketHandshake Class Members
Properties Methods

Noemax.WebSockets Namespace : WebSocketHandshake Class

The following tables list the members exposed by WebSocketHandshake.

Public Constructors
 | Name | Description
Public Constructor | WebSocketHandshake Constructor | Initializes a new instance of the WebSocketHandshake class.
Top
Public Properties
 | Name | Description
Public Property | Context | Gets and sets the context object that should be assigned to the channel at the end of the handshake. This value will be saved into the WebSocketChannel.Context property when channel is created.
Public Property | Cookies | Gets the list of cookies exchanged between client and server during the WebSocket handshake.
Public Property | Extensions | Gets and sets extensions exchanged during the WebSocket handshake.
Public Property | HasExtension | Gets whether the WebSocket handshake includes Sec-WebSocket-Extension header.
Public Property | HasProtocol | Gets whether the WebSocket handshake includes Sec-WebSocket-Protocol header.
Public Property | InboundHeaders | The collection of the headers received during the WebSocket handshake.
Public Property | IsServerSide | Gets whether this handshake is being performed by a server endpoint.
Public Property | Origin | Gets and sets the Origin value exchanged during WebSocket handshake.
Public Property | OutboundHeaders | The collection of the headers to be sent during the WebSocket handshake.
Public Property | Protocol | Gets and sets the sub-protocol header exchanged during WebSocket handshake.
Public Property | RedirectLocation | Gets and sets the location to which client is getting redirected when HandshakeAction is set to HttpRedirect or HttpTemporaryRedirect.
Public Property | ResultAction | Gets and sets whether the WebSocket handshake is accepted by the local side.
Public Property | Via | The _uri of the WebSocket endpoint which performs the WebSocket handshake.
Top
Public Methods
 | Name | Description
Public Method | SetCookie | Sets the HTTP cookie to be sent to the client during WebSocket handshake.
Top
See Also

Reference

WebSocketHandshake Class
Noemax.WebSockets Namespace


WebSocketHandshake Constructor

WebSocketHandshake Constructor

Noemax.WebSockets Namespace > WebSocketHandshake Class : WebSocketHandshake Constructor
Initializes a new instance of the WebSocketHandshake class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal uri As System.Uri, _
   ByVal inboundHeaders As WebSocketHandshakeHeaderCollection, _
   ByVal isServer As System.Boolean _
)
'Usage

Dim uri As System.Uri
Dim inboundHeaders As WebSocketHandshakeHeaderCollection
Dim isServer As System.Boolean

Dim instance As New WebSocketHandshake(uri, inboundHeaders, isServer)
public WebSocketHandshake(
   System.Uri uri,
   WebSocketHandshakeHeaderCollection inboundHeaders,
   System.bool isServer
)
public WebSocketHandshake(
    uri: System.Uri;
    inboundHeaders: WebSocketHandshakeHeaderCollection;
    isServer: System.Boolean
);
public function WebSocketHandshake(
   uri : System.Uri,
   inboundHeaders : WebSocketHandshakeHeaderCollection,
   isServer : System.boolean
);
public: WebSocketHandshake(
   System.Uri* uri,
   WebSocketHandshakeHeaderCollection* inboundHeaders,
   System.bool isServer
)
public:
WebSocketHandshake(
   System.Uri^ uri,
   WebSocketHandshakeHeaderCollection^ inboundHeaders,
   System.bool isServer
)

Parameters

uri
inboundHeaders
isServer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


WebSocketHandshake Class Methods

WebSocketHandshake Class Methods

Noemax.WebSockets Namespace : WebSocketHandshake Class

For a list of all members of this type, see WebSocketHandshake members.

Public Methods
 | Name | Description
Public Method | SetCookie | Sets the HTTP cookie to be sent to the client during WebSocket handshake.
Top
See Also

Reference

WebSocketHandshake Class
Noemax.WebSockets Namespace


SetCookie Method (WebSocketHandshake)

SetCookie Method (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : SetCookie Method
The HTTP cookie to be sent to the client.
Sets the HTTP cookie to be sent to the client during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetCookie( _
   ByVal cookie As System.Net.Cookie _
)
'Usage

Dim instance As WebSocketHandshake
Dim cookie As System.Net.Cookie

instance.SetCookie(cookie)
public void SetCookie(
   System.Net.Cookie cookie
)
public procedure SetCookie(
    cookie: System.Net.Cookie
);
public function SetCookie(
   cookie : System.Net.Cookie
);
public: void SetCookie(
   System.Net.Cookie* cookie
)
public:
void SetCookie(
   System.Net.Cookie^ cookie
)

Parameters

cookie
The HTTP cookie to be sent to the client.
Remarks
This method can be used only the server side during WebSocket handshake to send client a cookie.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


WebSocketHandshake Class Properties

WebSocketHandshake Class Properties

Noemax.WebSockets Namespace : WebSocketHandshake Class

For a list of all members of this type, see WebSocketHandshake members.

Public Properties
 | Name | Description
Public Property | Context | Gets and sets the context object that should be assigned to the channel at the end of the handshake. This value will be saved into the WebSocketChannel.Context property when channel is created.
Public Property | Cookies | Gets the list of cookies exchanged between client and server during the WebSocket handshake.
Public Property | Extensions | Gets and sets extensions exchanged during the WebSocket handshake.
Public Property | HasExtension | Gets whether the WebSocket handshake includes Sec-WebSocket-Extension header.
Public Property | HasProtocol | Gets whether the WebSocket handshake includes Sec-WebSocket-Protocol header.
Public Property | InboundHeaders | The collection of the headers received during the WebSocket handshake.
Public Property | IsServerSide | Gets whether this handshake is being performed by a server endpoint.
Public Property | Origin | Gets and sets the Origin value exchanged during WebSocket handshake.
Public Property | OutboundHeaders | The collection of the headers to be sent during the WebSocket handshake.
Public Property | Protocol | Gets and sets the sub-protocol header exchanged during WebSocket handshake.
Public Property | RedirectLocation | Gets and sets the location to which client is getting redirected when HandshakeAction is set to HttpRedirect or HttpTemporaryRedirect.
Public Property | ResultAction | Gets and sets whether the WebSocket handshake is accepted by the local side.
Public Property | Via | The _uri of the WebSocket endpoint which performs the WebSocket handshake.
Top
See Also

Reference

WebSocketHandshake Class
Noemax.WebSockets Namespace


Context Property (WebSocketHandshake)

Context Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Context Property
Gets and sets the context object that should be assigned to the channel at the end of the handshake. This value will be saved into the WebSocketChannel.Context property when channel is created.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Context As System.Object
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Object

instance.Context = value

value = instance.Context
public System.object Context {get; set;}
public read-write property Context: System.TObject;
public function get,set Context : System.Object
public: __property System.Object* get_Context();
public: __property void set_Context(
   System.Object* value
);
public:
property System.Object^ Context {
   System.Object^ get();
   void set (    System.Object^ value);
}
Remarks
Context property can be used to store any information associated to the channel during the handshake or later on in channel lifetime, e.g. it can store the reference on client credentials or session ids assigned to the channel by the application e.c.t.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


Cookies Property (WebSocketHandshake)

Cookies Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Cookies Property
Gets the list of cookies exchanged between client and server during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Cookies As System.Net.CookieCollection
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Net.CookieCollection

value = instance.Cookies
public System.Net.CookieCollection Cookies {get;}
public read-only property Cookies: System.Net.CookieCollection;
public function get Cookies : System.Net.CookieCollection
public: __property System.Net.CookieCollection* get_Cookies();
public:
property System.Net.CookieCollection^ Cookies {
   System.Net.CookieCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


Extensions Property (WebSocketHandshake)

Extensions Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Extensions Property
Gets and sets extensions exchanged during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extensions As System.Collections.Generic.IEnumerable(Of String)
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Collections.Generic.IEnumerable(Of String)

instance.Extensions = value

value = instance.Extensions
public System.Collections.Generic.IEnumerable<string> Extensions {get; set;}
public read-write property Extensions: System.Collections.Generic.IEnumerable;
public function get,set Extensions : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<string*>* get_Extensions();
public: __property void set_Extensions(
   System.Collections.Generic.IEnumerable<string*>* value
);
public:
property System.Collections.Generic.IEnumerable<String^>^ Extensions {
   System.Collections.Generic.IEnumerable<String^>^ get();
   void set (    System.Collections.Generic.IEnumerable<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


HasExtension Property (WebSocketHandshake)

HasExtension Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : HasExtension Property
Gets whether the WebSocket handshake includes Sec-WebSocket-Extension header.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasExtension As System.Boolean
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Boolean

value = instance.HasExtension
public System.bool HasExtension {get;}
public read-only property HasExtension: System.Boolean;
public function get HasExtension : System.boolean
public: __property System.bool get_HasExtension();
public:
property System.bool HasExtension {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


HasProtocol Property (WebSocketHandshake)

HasProtocol Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : HasProtocol Property
Gets whether the WebSocket handshake includes Sec-WebSocket-Protocol header.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property HasProtocol As System.Boolean
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Boolean

value = instance.HasProtocol
public System.bool HasProtocol {get;}
public read-only property HasProtocol: System.Boolean;
public function get HasProtocol : System.boolean
public: __property System.bool get_HasProtocol();
public:
property System.bool HasProtocol {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


InboundHeaders Property (WebSocketHandshake)

InboundHeaders Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : InboundHeaders Property
The collection of the headers received during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property InboundHeaders As WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketHandshake
Dim value As WebSocketHandshakeHeaderCollection

value = instance.InboundHeaders
public WebSocketHandshakeHeaderCollection InboundHeaders {get;}
public read-only property InboundHeaders: WebSocketHandshakeHeaderCollection;
public function get InboundHeaders : WebSocketHandshakeHeaderCollection
public: __property WebSocketHandshakeHeaderCollection* get_InboundHeaders();
public:
property WebSocketHandshakeHeaderCollection^ InboundHeaders {
   WebSocketHandshakeHeaderCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


IsServerSide Property (WebSocketHandshake)

IsServerSide Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : IsServerSide Property
Gets whether this handshake is being performed by a server endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsServerSide As System.Boolean
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Boolean

value = instance.IsServerSide
public System.bool IsServerSide {get;}
public read-only property IsServerSide: System.Boolean;
public function get IsServerSide : System.boolean
public: __property System.bool get_IsServerSide();
public:
property System.bool IsServerSide {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


Origin Property (WebSocketHandshake)

Origin Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Origin Property
Gets and sets the Origin value exchanged during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Origin As System.String
'Usage

Dim instance As WebSocketHandshake
Dim value As System.String

instance.Origin = value

value = instance.Origin
public System.string Origin {get; set;}
public read-write property Origin: System.String;
public function get,set Origin : System.String
public: __property System.string* get_Origin();
public: __property void set_Origin(
   System.string* value
);
public:
property System.String^ Origin {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


OutboundHeaders Property (WebSocketHandshake)

OutboundHeaders Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : OutboundHeaders Property
The collection of the headers to be sent during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutboundHeaders As WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketHandshake
Dim value As WebSocketHandshakeHeaderCollection

value = instance.OutboundHeaders
public WebSocketHandshakeHeaderCollection OutboundHeaders {get;}
public read-only property OutboundHeaders: WebSocketHandshakeHeaderCollection;
public function get OutboundHeaders : WebSocketHandshakeHeaderCollection
public: __property WebSocketHandshakeHeaderCollection* get_OutboundHeaders();
public:
property WebSocketHandshakeHeaderCollection^ OutboundHeaders {
   WebSocketHandshakeHeaderCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


Protocol Property (WebSocketHandshake)

Protocol Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Protocol Property
Gets and sets the sub-protocol header exchanged during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protocol As System.String
'Usage

Dim instance As WebSocketHandshake
Dim value As System.String

instance.Protocol = value

value = instance.Protocol
public System.string Protocol {get; set;}
public read-write property Protocol: System.String;
public function get,set Protocol : System.String
public: __property System.string* get_Protocol();
public: __property void set_Protocol(
   System.string* value
);
public:
property System.String^ Protocol {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


RedirectLocation Property (WebSocketHandshake)

RedirectLocation Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : RedirectLocation Property
Gets and sets the location to which client is getting redirected when HandshakeAction is set to HttpRedirect or HttpTemporaryRedirect.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RedirectLocation As System.String
'Usage

Dim instance As WebSocketHandshake
Dim value As System.String

instance.RedirectLocation = value

value = instance.RedirectLocation
public System.string RedirectLocation {get; set;}
public read-write property RedirectLocation: System.String;
public function get,set RedirectLocation : System.String
public: __property System.string* get_RedirectLocation();
public: __property void set_RedirectLocation(
   System.string* value
);
public:
property System.String^ RedirectLocation {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


ResultAction Property (WebSocketHandshake)

ResultAction Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : ResultAction Property
Gets and sets whether the WebSocket handshake is accepted by the local side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ResultAction As WebSocketHandshakeAction
'Usage

Dim instance As WebSocketHandshake
Dim value As WebSocketHandshakeAction

instance.ResultAction = value

value = instance.ResultAction
public WebSocketHandshakeAction ResultAction {get; set;}
public read-write property ResultAction: WebSocketHandshakeAction;
public function get,set ResultAction : WebSocketHandshakeAction
public: __property WebSocketHandshakeAction get_ResultAction();
public: __property void set_ResultAction(
   WebSocketHandshakeAction value
);
public:
property WebSocketHandshakeAction ResultAction {
   WebSocketHandshakeAction get();
   void set (    WebSocketHandshakeAction value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


Via Property (WebSocketHandshake)

Via Property (WebSocketHandshake)

Noemax.WebSockets Namespace > WebSocketHandshake Class : Via Property
The _uri of the WebSocket endpoint which performs the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Via As System.Uri
'Usage

Dim instance As WebSocketHandshake
Dim value As System.Uri

value = instance.Via
public System.Uri Via {get;}
public read-only property Via: System.Uri;
public function get Via : System.Uri
public: __property System.Uri* get_Via();
public:
property System.Uri^ Via {
   System.Uri^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshake Class
WebSocketHandshake Members


WebSocketHandshakeHeader Class

WebSocketHandshakeHeader Class
Members

Noemax.WebSockets Namespace : WebSocketHandshakeHeader Class
Represents a handshake header to be exchanged among with standard WebSocket headers during the handshake.
Object Model
WebSocketHandshakeHeader Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketHandshakeHeader
'Usage

Dim instance As WebSocketHandshakeHeader
public class WebSocketHandshakeHeader
public class WebSocketHandshakeHeader
public class WebSocketHandshakeHeader
public __gc class WebSocketHandshakeHeader
public ref class WebSocketHandshakeHeader
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketHandshakeHeader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeader Members
Noemax.WebSockets Namespace


WebSocketHandshakeHeader Class Members

WebSocketHandshakeHeader Class Members
Properties

Noemax.WebSockets Namespace : WebSocketHandshakeHeader Class

The following tables list the members exposed by WebSocketHandshakeHeader.

Public Constructors
 | Name | Description
Public Constructor | WebSocketHandshakeHeader Constructor | Initializes a new instance of WebSocketHandshakeHeader from the strings representing its name and value.
Top
Public Properties
 | Name | Description
Public Property | Name | The name of the header.
Public Property | Value | The value of the header.
Top
See Also

Reference

WebSocketHandshakeHeader Class
Noemax.WebSockets Namespace


WebSocketHandshakeHeader Constructor

WebSocketHandshakeHeader Constructor

Noemax.WebSockets Namespace > WebSocketHandshakeHeader Class : WebSocketHandshakeHeader Constructor
The name of the header.
The value of the header.
Initializes a new instance of WebSocketHandshakeHeader from the strings representing its name and value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal value As System.String _
)
'Usage

Dim name As System.String
Dim value As System.String

Dim instance As New WebSocketHandshakeHeader(name, value)
public WebSocketHandshakeHeader(
   System.string name,
   System.string value
)
public WebSocketHandshakeHeader(
    name: System.String;
    value: System.String
);
public function WebSocketHandshakeHeader(
   name : System.String,
   value : System.String
);
public: WebSocketHandshakeHeader(
   System.string* name,
   System.string* value
)
public:
WebSocketHandshakeHeader(
   System.String^ name,
   System.String^ value
)

Parameters

name
The name of the header.
value
The value of the header.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeader Class
WebSocketHandshakeHeader Members


WebSocketHandshakeHeader Class Properties

WebSocketHandshakeHeader Class Properties

Noemax.WebSockets Namespace : WebSocketHandshakeHeader Class

For a list of all members of this type, see WebSocketHandshakeHeader members.

Public Properties
 | Name | Description
Public Property | Name | The name of the header.
Public Property | Value | The value of the header.
Top
See Also

Reference

WebSocketHandshakeHeader Class
Noemax.WebSockets Namespace


Name Property (WebSocketHandshakeHeader)

Name Property (WebSocketHandshakeHeader)

Noemax.WebSockets Namespace > WebSocketHandshakeHeader Class : Name Property
The name of the header.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Name As System.String
'Usage

Dim instance As WebSocketHandshakeHeader
Dim value As System.String

value = instance.Name
public System.string Name {get;}
public read-only property Name: System.String;
public function get Name : System.String
public: __property System.string* get_Name();
public:
property System.String^ Name {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeader Class
WebSocketHandshakeHeader Members


Value Property (WebSocketHandshakeHeader)

Value Property (WebSocketHandshakeHeader)

Noemax.WebSockets Namespace > WebSocketHandshakeHeader Class : Value Property
The value of the header.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Value As System.String
'Usage

Dim instance As WebSocketHandshakeHeader
Dim value As System.String

value = instance.Value
public System.string Value {get;}
public read-only property Value: System.String;
public function get Value : System.String
public: __property System.string* get_Value();
public:
property System.String^ Value {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeader Class
WebSocketHandshakeHeader Members


WebSocketHandshakeHeaderCollection Class

WebSocketHandshakeHeaderCollection Class
Members

Noemax.WebSockets Namespace : WebSocketHandshakeHeaderCollection Class
Provides the methods and property for managing collection of WebSocketHandshakeHeader.
Object Model
WebSocketHandshakeHeaderCollection Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Reflection.DefaultMemberAttribute("Item")>
Public Class WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
[System.Reflection.DefaultMember("Item")]
public class WebSocketHandshakeHeaderCollection
public class WebSocketHandshakeHeaderCollection
System.Reflection.DefaultMemberAttribute("Item")
public class WebSocketHandshakeHeaderCollection
[System.Reflection.DefaultMember("Item")]
public __gc class WebSocketHandshakeHeaderCollection
[System.Reflection.DefaultMember("Item")]
public ref class WebSocketHandshakeHeaderCollection
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketHandshakeHeaderCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Members
Noemax.WebSockets Namespace


WebSocketHandshakeHeaderCollection Class Members

WebSocketHandshakeHeaderCollection Class Members
Properties Methods

Noemax.WebSockets Namespace : WebSocketHandshakeHeaderCollection Class

The following tables list the members exposed by WebSocketHandshakeHeaderCollection.

Public Constructors
 | Name | Description
Public Constructor | WebSocketHandshakeHeaderCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of the headers in the collection.
Public Property | IsReadOnly | Gets whether this collection is read-only.
Public Property | Item | Gets and sets the value of the header specified by its name.
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side.
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Public Property | WcfContentType | Gets and set the content type header that is exchanged during the handshake. This header is required to be provided by the WCF WebSocket endpoints.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new header to the collection.
Public Method | Clear | Removes all contained headers from the collection.
Public Method | CopyTo | Copies all headers into the specified possion in array.
Public Method | Get | Gets the header with the specified name.
Public Method | GetValue | Returns the value of the specified header if found in the collection.
Public Method | Remove | Overloaded. Removes the header from the collection.
Top
See Also

Reference

WebSocketHandshakeHeaderCollection Class
Noemax.WebSockets Namespace


WebSocketHandshakeHeaderCollection Constructor

WebSocketHandshakeHeaderCollection Constructor

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : WebSocketHandshakeHeaderCollection Constructor
Overload List
Overload | Description
WebSocketHandshakeHeaderCollection Constructor() | Initialize a new instance of WebSocketHandshakeHeaderCollection.
WebSocketHandshakeHeaderCollection Constructor(IDictionary<String,String>) | Initialize a new instance of WebSocketHandshakeHeaderCollection from the collection of key value pairs.
WebSocketHandshakeHeaderCollection Constructor(IEnumerable<WebSocketHandshakeHeader>) | Initialize a new instance of WebSocketHandshakeHeaderCollection from the collection of WebSocketHandshakeHeader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


WebSocketHandshakeHeaderCollection Constructor()

WebSocketHandshakeHeaderCollection Constructor()

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > WebSocketHandshakeHeaderCollection Constructor : WebSocketHandshakeHeaderCollection Constructor()
Initialize a new instance of WebSocketHandshakeHeaderCollection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketHandshakeHeaderCollection()
public WebSocketHandshakeHeaderCollection()
public WebSocketHandshakeHeaderCollection();
public function WebSocketHandshakeHeaderCollection();
public: WebSocketHandshakeHeaderCollection();
public:
WebSocketHandshakeHeaderCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


WebSocketHandshakeHeaderCollection Constructor(IDictionary<String,String>)

WebSocketHandshakeHeaderCollection Constructor(IDictionary<String,String>)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > WebSocketHandshakeHeaderCollection Constructor : WebSocketHandshakeHeaderCollection Constructor(IDictionary<String,String>)
Initialize a new instance of WebSocketHandshakeHeaderCollection from the collection of key value pairs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal headers As System.Collections.Generic.IDictionary(Of String,String) _
)
'Usage

Dim headers As System.Collections.Generic.IDictionary(Of String,String)

Dim instance As New WebSocketHandshakeHeaderCollection(headers)
public WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IDictionary<string,string> headers
)
public WebSocketHandshakeHeaderCollection(
    headers: System.Collections.Generic.IDictionary
);
public function WebSocketHandshakeHeaderCollection(
   headers : System.Collections.Generic.IDictionary
);
public: WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IDictionary<string*,string*>* headers
)
public:
WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IDictionary<String^,String^>^ headers
)

Parameters

headers
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


WebSocketHandshakeHeaderCollection Constructor(IEnumerable<WebSocketHandshakeHeader>)

WebSocketHandshakeHeaderCollection Constructor(IEnumerable<WebSocketHandshakeHeader>)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > WebSocketHandshakeHeaderCollection Constructor : WebSocketHandshakeHeaderCollection Constructor(IEnumerable<WebSocketHandshakeHeader>)
Initialize a new instance of WebSocketHandshakeHeaderCollection from the collection of WebSocketHandshakeHeader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal headers As System.Collections.Generic.IEnumerable(Of WebSocketHandshakeHeader) _
)
'Usage

Dim headers As System.Collections.Generic.IEnumerable(Of WebSocketHandshakeHeader)

Dim instance As New WebSocketHandshakeHeaderCollection(headers)
public WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader> headers
)
public WebSocketHandshakeHeaderCollection(
    headers: System.Collections.Generic.IEnumerable
);
public function WebSocketHandshakeHeaderCollection(
   headers : System.Collections.Generic.IEnumerable
);
public: WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader*>* headers
)
public:
WebSocketHandshakeHeaderCollection(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader^>^ headers
)

Parameters

headers
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


WebSocketHandshakeHeaderCollection Class Methods

WebSocketHandshakeHeaderCollection Class Methods

Noemax.WebSockets Namespace : WebSocketHandshakeHeaderCollection Class

For a list of all members of this type, see WebSocketHandshakeHeaderCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new header to the collection.
Public Method | Clear | Removes all contained headers from the collection.
Public Method | CopyTo | Copies all headers into the specified possion in array.
Public Method | Get | Gets the header with the specified name.
Public Method | GetValue | Returns the value of the specified header if found in the collection.
Public Method | Remove | Overloaded. Removes the header from the collection.
Top
See Also

Reference

WebSocketHandshakeHeaderCollection Class
Noemax.WebSockets Namespace


Add Method (WebSocketHandshakeHeaderCollection)

Add Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Add Method
Adds a new header to the collection.
Overload List
Overload | Description
Add(String,String) | Adds a new header to the collection.
Add(WebSocketHandshakeHeader) | Adds a header to the collection.
Add(IEnumerable<WebSocketHandshakeHeader>) | Adds the enumeration of WebSocketHandshakeHeader to the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Add(String,String) Method

Add(String,String) Method

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > Add Method : Add(String,String) Method
The name of the header.
The value of the header.
Adds a new header to the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal name As System.String, _
   ByVal value As System.String _
)
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim name As System.String
Dim value As System.String

instance.Add(name, value)
public void Add(
   System.string name,
   System.string value
)
public procedure Add(
    name: System.String;
    value: System.String
);
public function Add(
   name : System.String,
   value : System.String
);
public: void Add(
   System.string* name,
   System.string* value
)
public:
void Add(
   System.String^ name,
   System.String^ value
)

Parameters

name
The name of the header.
value
The value of the header.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


Add(WebSocketHandshakeHeader) Method

Add(WebSocketHandshakeHeader) Method

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > Add Method : Add(WebSocketHandshakeHeader) Method
Adds a header to the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal item As WebSocketHandshakeHeader _
)
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim item As WebSocketHandshakeHeader

instance.Add(item)
public void Add(
   WebSocketHandshakeHeader item
)
public procedure Add(
    item: WebSocketHandshakeHeader
);
public function Add(
   item : WebSocketHandshakeHeader
);
public: void Add(
   WebSocketHandshakeHeader* item
)
public:
void Add(
   WebSocketHandshakeHeader^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


Add(IEnumerable<WebSocketHandshakeHeader>) Method

Add(IEnumerable<WebSocketHandshakeHeader>) Method

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > Add Method : Add(IEnumerable<WebSocketHandshakeHeader>) Method
The enumeration of WebSocket handshake headers.
Adds the enumeration of WebSocketHandshakeHeader to the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Add( _
   ByVal headers As System.Collections.Generic.IEnumerable(Of WebSocketHandshakeHeader) _
)
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim headers As System.Collections.Generic.IEnumerable(Of WebSocketHandshakeHeader)

instance.Add(headers)
public void Add(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader> headers
)
public procedure Add(
    headers: System.Collections.Generic.IEnumerable
);
public function Add(
   headers : System.Collections.Generic.IEnumerable
);
public: void Add(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader*>* headers
)
public:
void Add(
   System.Collections.Generic.IEnumerable<WebSocketHandshakeHeader^>^ headers
)

Parameters

headers
The enumeration of WebSocket handshake headers.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


Clear Method (WebSocketHandshakeHeaderCollection)

Clear Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Clear Method
Removes all contained headers from the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Clear()
'Usage

Dim instance As WebSocketHandshakeHeaderCollection

instance.Clear()
public void Clear()
public procedure Clear();
public function Clear();
public: void Clear();
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


CopyTo Method (WebSocketHandshakeHeaderCollection)

CopyTo Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : CopyTo Method
The array of WebSocketHandshakeHeader where to copy all contained headers.
The index in the array where to copy all contained headers.
Copies all headers into the specified possion in array.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub CopyTo( _
   ByVal array() As WebSocketHandshakeHeader, _
   ByVal arrayIndex As System.Integer _
)
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim array() As WebSocketHandshakeHeader
Dim arrayIndex As System.Integer

instance.CopyTo(array, arrayIndex)
public void CopyTo(
   WebSocketHandshakeHeader[] array,
   System.int arrayIndex
)
public procedure CopyTo(
    array: WebSocketHandshakeHeaderarray of;
    arrayIndex: System.Integer
);
public function CopyTo(
   array : WebSocketHandshakeHeader[],
   arrayIndex : System.int
);
public: void CopyTo(
   WebSocketHandshakeHeader*[]* array,
   System.int arrayIndex
)
public:
void CopyTo(
   array<WebSocketHandshakeHeader^>^ array,
   System.int arrayIndex
)

Parameters

array
The array of WebSocketHandshakeHeader where to copy all contained headers.
arrayIndex
The index in the array where to copy all contained headers.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Get Method (WebSocketHandshakeHeaderCollection)

Get Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Get Method
The name of the header to get.
Gets the header with the specified name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Get( _
   ByVal name As System.String _
) As WebSocketHandshakeHeader
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim name As System.String
Dim value As WebSocketHandshakeHeader

value = instance.Get(name)
public WebSocketHandshakeHeader Get(
   System.string name
)
public function Get(
    name: System.String
): WebSocketHandshakeHeader;
public function Get(
   name : System.String
) : WebSocketHandshakeHeader;
public: WebSocketHandshakeHeader* Get(
   System.string* name
)
public:
WebSocketHandshakeHeader^ Get(
   System.String^ name
)

Parameters

name
The name of the header to get.

Return Value

The header with the specified name; Null if header with the specified name was not found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


GetValue Method (WebSocketHandshakeHeaderCollection)

GetValue Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : GetValue Method
The name of the header.
Returns the value of the specified header if found in the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValue( _
   ByVal name As System.String _
) As System.String
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim name As System.String
Dim value As System.String

value = instance.GetValue(name)
public System.string GetValue(
   System.string name
)
public function GetValue(
    name: System.String
): System.String;
public function GetValue(
   name : System.String
) : System.String;
public: System.string* GetValue(
   System.string* name
)
public:
System.String^ GetValue(
   System.String^ name
)

Parameters

name
The name of the header.

Return Value

The string value of the header.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Remove Method (WebSocketHandshakeHeaderCollection)

Remove Method (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Remove Method
Removes the header from the collection.
Overload List
Overload | Description
Remove(WebSocketHandshakeHeader) | Removes the header from the collection.
Remove(String) | Removes the header with specified name from the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Remove(WebSocketHandshakeHeader) Method

Remove(WebSocketHandshakeHeader) Method

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > Remove Method : Remove(WebSocketHandshakeHeader) Method
The header to be removed from the collection.
Removes the header from the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal item As WebSocketHandshakeHeader _
) As System.Boolean
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim item As WebSocketHandshakeHeader
Dim value As System.Boolean

value = instance.Remove(item)
public System.bool Remove(
   WebSocketHandshakeHeader item
)
public function Remove(
    item: WebSocketHandshakeHeader
): System.Boolean;
public function Remove(
   item : WebSocketHandshakeHeader
) : System.boolean;
public: System.bool Remove(
   WebSocketHandshakeHeader* item
)
public:
System.bool Remove(
   WebSocketHandshakeHeader^ item
)

Parameters

item
The header to be removed from the collection.

Return Value

True if header was found in the collection and removed; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


Remove(String) Method

Remove(String) Method

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class > Remove Method : Remove(String) Method
The name of the header to be removed
Removes the header with specified name from the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Remove( _
   ByVal name As System.String _
) As System.Boolean
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Remove(name)
public System.bool Remove(
   System.string name
)
public function Remove(
    name: System.String
): System.Boolean;
public function Remove(
   name : System.String
) : System.boolean;
public: System.bool Remove(
   System.string* name
)
public:
System.bool Remove(
   System.String^ name
)

Parameters

name
The name of the header to be removed

Return Value

True if the header was found in the collection and removed; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members
Overload List


WebSocketHandshakeHeaderCollection Class Properties

WebSocketHandshakeHeaderCollection Class Properties

Noemax.WebSockets Namespace : WebSocketHandshakeHeaderCollection Class

For a list of all members of this type, see WebSocketHandshakeHeaderCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of the headers in the collection.
Public Property | IsReadOnly | Gets whether this collection is read-only.
Public Property | Item | Gets and sets the value of the header specified by its name.
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side.
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Public Property | WcfContentType | Gets and set the content type header that is exchanged during the handshake. This header is required to be provided by the WCF WebSocket endpoints.
Top
See Also

Reference

WebSocketHandshakeHeaderCollection Class
Noemax.WebSockets Namespace


Count Property (WebSocketHandshakeHeaderCollection)

Count Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Count Property
Gets the number of the headers in the collection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public read-only property Count: System.Integer;
public function get Count : System.int
public: __property System.int get_Count();
public:
property System.int Count {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


IsReadOnly Property (WebSocketHandshakeHeaderCollection)

IsReadOnly Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : IsReadOnly Property
Gets whether this collection is read-only.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim value As System.Boolean

value = instance.IsReadOnly
public System.bool IsReadOnly {get;}
public read-only property IsReadOnly: System.Boolean;
public function get IsReadOnly : System.boolean
public: __property System.bool get_IsReadOnly();
public:
property System.bool IsReadOnly {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Item Property (WebSocketHandshakeHeaderCollection)

Item Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Item Property
The name of the header to get or set.
Gets and sets the value of the header specified by its name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Default Property Item( _
   ByVal name As System.String _
) As System.String
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim name As System.String
Dim value As System.String

instance.Item(name) = value

value = instance.Item(name)
public System.string this[
   System.string name
]; {get; set;}
public  this: : System.String;[
    name: System.String
]; read-write
public  this[
   name : System.String
] get,set : System.String
public: __property System.string* get_Item   System.string* name
;
public: __property void set_Item   System.string* name,
   System.string* value
;
public:
property System.String^ default [String^] {
   System.String^ get(System.String^ name);
   void set (System.String^ name, System.String^ value);
}

Parameters

name
The name of the header to get or set.

Property Value

The value of the header.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Origin Property (WebSocketHandshakeHeaderCollection)

Origin Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Origin Property
Gets and sets the Origin string that identifies the origin of the script running on the client side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Origin As System.String
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim value As System.String

instance.Origin = value

value = instance.Origin
public System.string Origin {get; set;}
public read-write property Origin: System.String;
public function get,set Origin : System.String
public: __property System.string* get_Origin();
public: __property void set_Origin(
   System.string* value
);
public:
property System.String^ Origin {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
The Origin string might be required by the WebSocket server that also handle connections from the scripts running on the brower clients.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


Protocol Property (WebSocketHandshakeHeaderCollection)

Protocol Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : Protocol Property
Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protocol As System.String
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim value As System.String

instance.Protocol = value

value = instance.Protocol
public System.string Protocol {get; set;}
public read-write property Protocol: System.String;
public function get,set Protocol : System.String
public: __property System.string* get_Protocol();
public: __property void set_Protocol(
   System.string* value
);
public:
property System.String^ Protocol {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


WcfContentType Property (WebSocketHandshakeHeaderCollection)

WcfContentType Property (WebSocketHandshakeHeaderCollection)

Noemax.WebSockets Namespace > WebSocketHandshakeHeaderCollection Class : WcfContentType Property
Gets and set the content type header that is exchanged during the handshake. This header is required to be provided by the WCF WebSocket endpoints.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property WcfContentType As System.String
'Usage

Dim instance As WebSocketHandshakeHeaderCollection
Dim value As System.String

instance.WcfContentType = value

value = instance.WcfContentType
public System.string WcfContentType {get; set;}
public read-write property WcfContentType: System.String;
public function get,set WcfContentType : System.String
public: __property System.string* get_WcfContentType();
public: __property void set_WcfContentType(
   System.string* value
);
public:
property System.String^ WcfContentType {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
WCF endpoint requires the client side to specify the content type of the message content during the WebSocket handshake. Set this property in order to insure that the WCF WebSocket endpoint accepts client connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeHeaderCollection Class
WebSocketHandshakeHeaderCollection Members


WebSocketInboundMessage Class

WebSocketInboundMessage Class
Members

Noemax.WebSockets Namespace : WebSocketInboundMessage Class
Represents the inbound message received through WebSocket connection. Provides methods and properties for processing inbound message.
Object Model
WebSocketInboundMessage Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class WebSocketInboundMessage
'Usage

Dim instance As WebSocketInboundMessage
public abstract class WebSocketInboundMessage
public class WebSocketInboundMessage abstract;
public abstract class WebSocketInboundMessage
public __gc abstract class WebSocketInboundMessage
public ref class WebSocketInboundMessage abstract
Remarks
This is the abstract base class that is extended by internal WebSocketInboundMessage implementations.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketInboundMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Members
Noemax.WebSockets Namespace


WebSocketInboundMessage Class Members

WebSocketInboundMessage Class Members
Properties Methods

Noemax.WebSockets Namespace : WebSocketInboundMessage Class

The following tables list the members exposed by WebSocketInboundMessage.

Public Properties
 | Name | Description
Public Property | Context | Gets and set the object associated with a message.
Public Property | Fragmented | Gets the value which indicates whether the message was received fragmented.
Public Property | IsBuffered | Gets whether the the inbound message is buffered.
Public Property | State | Gets the state of the WebSocketMessage object.
Public Property | Type | Gets the WebSocketMessageType associated to the message content.
Top
Public Methods
 | Name | Description
Public Method | BeginBuffering | Begins asynchronously buffering the message until the final frame of the message is buffered.
Public Method | Close | Closes the message and releases all associated resources.
Public Method | EndBuffering | Completed asynchronously buffering message, waiting by the final frame to be buffered.
Public Method | ReadAsBytes | Buffers the entire message and returns it as an array of bytes.
Public Method | ReadAsOutbound | Buffers entire message payload in the buffer and represents it as outbound message that can be sent through the same or another connection."/>.
Public Method | ReadAsStream | Returns the content of the message as input of bytes, which allows to read the message as it's getting received without buffering entire content in the memory.
Public Method | ReadAsString | Overloaded. Buffers entire message in memory and decode it as UTF-8 encoded string.
Public Method | ReadAsText | Overloaded. Returns the text reader for reading message as text without ever buffering entire message in memory.
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. Provides implicit conversion that represents an inbound message as Stream object.
Top
See Also

Reference

WebSocketInboundMessage Class
Noemax.WebSockets Namespace


WebSocketInboundMessage Class Methods

WebSocketInboundMessage Class Methods

Noemax.WebSockets Namespace : WebSocketInboundMessage Class

For a list of all members of this type, see WebSocketInboundMessage members.

Public Methods
 | Name | Description
Public Method | BeginBuffering | Begins asynchronously buffering the message until the final frame of the message is buffered.
Public Method | Close | Closes the message and releases all associated resources.
Public Method | EndBuffering | Completed asynchronously buffering message, waiting by the final frame to be buffered.
Public Method | ReadAsBytes | Buffers the entire message and returns it as an array of bytes.
Public Method | ReadAsOutbound | Buffers entire message payload in the buffer and represents it as outbound message that can be sent through the same or another connection."/>.
Public Method | ReadAsStream | Returns the content of the message as input of bytes, which allows to read the message as it's getting received without buffering entire content in the memory.
Public Method | ReadAsString | Overloaded. Buffers entire message in memory and decode it as UTF-8 encoded string.
Public Method | ReadAsText | Overloaded. Returns the text reader for reading message as text without ever buffering entire message in memory.
Top
See Also

Reference

WebSocketInboundMessage Class
Noemax.WebSockets Namespace


BeginBuffering Method (WebSocketInboundMessage)

BeginBuffering Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : BeginBuffering Method
The maximum number of bytes to buffer. If message exceeds the specified size the exception is thrown.
The callback to call when message is fully buffered.
The object to associated with asynchronous operation.
Begins asynchronously buffering the message until the final frame of the message is buffered.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function BeginBuffering( _
   ByVal maxMessageSize As System.Long, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketInboundMessage
Dim maxMessageSize As System.Long
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginBuffering(maxMessageSize, callback, state)
public abstract System.IAsyncResult BeginBuffering(
   System.long maxMessageSize,
   System.AsyncCallback callback,
   System.object state
)
public function BeginBuffering(
    maxMessageSize: System.Int64;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; abstract;
public __abstract function BeginBuffering(
   maxMessageSize : System.long,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: abstract System.IAsyncResult* BeginBuffering(
   System.long maxMessageSize,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
abstract System.IAsyncResult^ BeginBuffering(
   System.int64 maxMessageSize,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

maxMessageSize
The maximum number of bytes to buffer. If message exceeds the specified size the exception is thrown.
callback
The callback to call when message is fully buffered.
state
The object to associated with asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


Close Method (WebSocketInboundMessage)

Close Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : Close Method
Closes the message and releases all associated resources.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Close()
'Usage

Dim instance As WebSocketInboundMessage

instance.Close()
public abstract void Close()
public procedure Close(); abstract;
public __abstract function Close();
public: abstract void Close();
public:
abstract void Close();
Remarks
If message is fragmented and there are more frames of the same message to be read from the WebSocket connection, the call to this method would block reading all remaining frames from the channel until they are read or channel is closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


EndBuffering Method (WebSocketInboundMessage)

EndBuffering Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : EndBuffering Method
IAsyncResult object associated to the operation.
Completed asynchronously buffering message, waiting by the final frame to be buffered.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub EndBuffering( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As WebSocketInboundMessage
Dim result As System.IAsyncResult

instance.EndBuffering(result)
public abstract void EndBuffering(
   System.IAsyncResult result
)
public procedure EndBuffering(
    result: System.IAsyncResult
); abstract;
public __abstract function EndBuffering(
   result : System.IAsyncResult
);
public: abstract void EndBuffering(
   System.IAsyncResult* result
)
public:
abstract void EndBuffering(
   System.IAsyncResult^ result
)

Parameters

result
IAsyncResult object associated to the operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsBytes Method (WebSocketInboundMessage)

ReadAsBytes Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : ReadAsBytes Method
The maximum size of the buffer to allocated.
Buffers the entire message and returns it as an array of bytes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsBytes( _
   ByVal maxSize As System.Long _
) As System.Byte()
'Usage

Dim instance As WebSocketInboundMessage
Dim maxSize As System.Long
Dim value() As System.Byte

value = instance.ReadAsBytes(maxSize)
public abstract System.byte[] ReadAsBytes(
   System.long maxSize
)
public function ReadAsBytes(
    maxSize: System.Int64
): System.array of Byte; abstract;
public __abstract function ReadAsBytes(
   maxSize : System.long
) : System.byte[];
public: abstract System.byte[]* ReadAsBytes(
   System.long maxSize
)
public:
abstract System.array<byte>^ ReadAsBytes(
   System.int64 maxSize
)

Parameters

maxSize
The maximum size of the buffer to allocated.

Return Value

Returns the array of bytes representing the content of entire message.
Remarks
Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsOutbound Method (WebSocketInboundMessage)

ReadAsOutbound Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : ReadAsOutbound Method
The maximum number of bytes to buffer.
Buffers entire message payload in the buffer and represents it as outbound message that can be sent through the same or another connection."/>.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsOutbound( _
   ByVal maxSize As System.Integer _
) As WebSocketOutboundMessage
'Usage

Dim instance As WebSocketInboundMessage
Dim maxSize As System.Integer
Dim value As WebSocketOutboundMessage

value = instance.ReadAsOutbound(maxSize)
public abstract WebSocketOutboundMessage ReadAsOutbound(
   System.int maxSize
)
public function ReadAsOutbound(
    maxSize: System.Integer
): WebSocketOutboundMessage; abstract;
public __abstract function ReadAsOutbound(
   maxSize : System.int
) : WebSocketOutboundMessage;
public: abstract WebSocketOutboundMessage ReadAsOutbound(
   System.int maxSize
)
public:
abstract WebSocketOutboundMessage ReadAsOutbound(
   System.int maxSize
)

Parameters

maxSize
The maximum number of bytes to buffer.

Return Value

The WebSocketOutboundMessage value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsStream Method (WebSocketInboundMessage)

ReadAsStream Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : ReadAsStream Method
Returns the content of the message as input of bytes, which allows to read the message as it's getting received without buffering entire content in the memory.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function ReadAsStream() As WebSocketMessageInputStream
'Usage

Dim instance As WebSocketInboundMessage
Dim value As WebSocketMessageInputStream

value = instance.ReadAsStream()
public abstract WebSocketMessageInputStream ReadAsStream()
public function ReadAsStream(): WebSocketMessageInputStream; abstract;
public __abstract function ReadAsStream() : WebSocketMessageInputStream;
public: abstract WebSocketMessageInputStream* ReadAsStream();
public:
abstract WebSocketMessageInputStream^ ReadAsStream();

Return Value

The input to read the message content.
Remarks

This method is part of the streaming API. Using the input returned by this method you can consume large messages without ever loading entire message into memory. Only the part of the message is initially buffered.

As the application consumes data using the input the underlying channel will continue reading directly from TCP connection employing native flow control provided by TCP. This means that remote side blocks when local side input buffer is full and it resumes as soon as local side reads the data from the input buffers. As faster you read from the input as faster remote side is allowed to send data.

In case if message is fragmented, subsequent frames will be received and handled automatically as application reads from the input, until the final frame consumed. Once end of the message is reached the read operation will return 0 bytes.

Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsString Method (WebSocketInboundMessage)

ReadAsString Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : ReadAsString Method
Buffers entire message in memory and decode it as UTF-8 encoded string.
Overload List
Overload | Description
ReadAsString(Int64) | Buffers entire message in memory and decode it as UTF-8 encoded string.
ReadAsString(Encoding,Int64) | Buffers entire message in memory and decode it as a string using specified encoding.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsString(Int64) Method

ReadAsString(Int64) Method

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > ReadAsString Method : ReadAsString(Int64) Method
The maximum number to buffer while receiving the message.
Buffers entire message in memory and decode it as UTF-8 encoded string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReadAsString( _
   ByVal maxReceivedMessageSize As System.Long _
) As System.String
'Usage

Dim instance As WebSocketInboundMessage
Dim maxReceivedMessageSize As System.Long
Dim value As System.String

value = instance.ReadAsString(maxReceivedMessageSize)
public System.string ReadAsString(
   System.long maxReceivedMessageSize
)
public function ReadAsString(
    maxReceivedMessageSize: System.Int64
): System.String;
public function ReadAsString(
   maxReceivedMessageSize : System.long
) : System.String;
public: System.string* ReadAsString(
   System.long maxReceivedMessageSize
)
public:
System.String^ ReadAsString(
   System.int64 maxReceivedMessageSize
)

Parameters

maxReceivedMessageSize
The maximum number to buffer while receiving the message.

Return Value

The string decoded from the message content.
Remarks
Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


ReadAsString(Encoding,Int64) Method

ReadAsString(Encoding,Int64) Method

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > ReadAsString Method : ReadAsString(Encoding,Int64) Method
The encoding to be used to decode the payload as a string.
The maximum number to buffer while receiving the message.
Buffers entire message in memory and decode it as a string using specified encoding.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function ReadAsString( _
   ByVal encoding As System.Text.Encoding, _
   ByVal maxReceivedMessageSize As System.Long _
) As System.String
'Usage

Dim instance As WebSocketInboundMessage
Dim encoding As System.Text.Encoding
Dim maxReceivedMessageSize As System.Long
Dim value As System.String

value = instance.ReadAsString(encoding, maxReceivedMessageSize)
public abstract System.string ReadAsString(
   System.Text.Encoding encoding,
   System.long maxReceivedMessageSize
)
public function ReadAsString(
    encoding: System.Text.Encoding;
    maxReceivedMessageSize: System.Int64
): System.String; abstract;
public __abstract function ReadAsString(
   encoding : System.Text.Encoding,
   maxReceivedMessageSize : System.long
) : System.String;
public: abstract System.string* ReadAsString(
   System.Text.Encoding* encoding,
   System.long maxReceivedMessageSize
)
public:
abstract System.String^ ReadAsString(
   System.Text.Encoding^ encoding,
   System.int64 maxReceivedMessageSize
)

Parameters

encoding
The encoding to be used to decode the payload as a string.
maxReceivedMessageSize
The maximum number to buffer while receiving the message.

Return Value

The string decoded from the message content.
Remarks
Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


ReadAsText Method (WebSocketInboundMessage)

ReadAsText Method (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : ReadAsText Method
Returns the text reader for reading message as text without ever buffering entire message in memory.
Overload List
Overload | Description
ReadAsText() | Returns the text reader for reading message as text without ever buffering entire message in memory.
ReadAsText(Encoding) | Returns the text reader for reading message as text without ever buffering entire message in memory.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


ReadAsText() Method

ReadAsText() Method

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > ReadAsText Method : ReadAsText() Method
Returns the text reader for reading message as text without ever buffering entire message in memory.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReadAsText() As System.IO.TextReader
'Usage

Dim instance As WebSocketInboundMessage
Dim value As System.IO.TextReader

value = instance.ReadAsText()
public System.IO.TextReader ReadAsText()
public function ReadAsText(): System.IO.TextReader;
public function ReadAsText() : System.IO.TextReader;
public: System.IO.TextReader* ReadAsText();
public:
System.IO.TextReader^ ReadAsText();

Return Value

Returns the TextReader for decoding the content of the message.
Remarks

This method is part of the streaming API. Using the reader returned by this method you can consume large messages without ever loading entire message into memory. Only the part of the message is initially buffered.

As the application consumes data using the input the underlying channel will continue reading directly from TCP connection employing native flow control provided by TCP. This means that remote side blocks when local side input buffer is full and it resumes as soon as local side reads the data from the input buffers. As faster you read from the input as faster remote side will be able to send more data.

In case if message is fragmented, subsequent frames will be received and handled automatically as application reads from the input, until the final frame consumed. Once end of the message is reached the read operation will return 0 bytes.

Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


ReadAsText(Encoding) Method

ReadAsText(Encoding) Method

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > ReadAsText Method : ReadAsText(Encoding) Method
The instance of Encoding to be used for converting the payload to the text.
Returns the text reader for reading message as text without ever buffering entire message in memory.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function ReadAsText( _
   ByVal encoding As System.Text.Encoding _
) As System.IO.TextReader
'Usage

Dim instance As WebSocketInboundMessage
Dim encoding As System.Text.Encoding
Dim value As System.IO.TextReader

value = instance.ReadAsText(encoding)
public abstract System.IO.TextReader ReadAsText(
   System.Text.Encoding encoding
)
public function ReadAsText(
    encoding: System.Text.Encoding
): System.IO.TextReader; abstract;
public __abstract function ReadAsText(
   encoding : System.Text.Encoding
) : System.IO.TextReader;
public: abstract System.IO.TextReader* ReadAsText(
   System.Text.Encoding* encoding
)
public:
abstract System.IO.TextReader^ ReadAsText(
   System.Text.Encoding^ encoding
)

Parameters

encoding
The instance of Encoding to be used for converting the payload to the text.

Return Value

Returns the TextReader for decoding the content of the message.
Remarks

This method is part of the streaming API. Using the reader returned by this method you can consume large messages without ever loading entire message into memory. Only the part of the message is initially buffered.

As the application consumes data using the input the underlying channel will continue reading directly from TCP connection employing native flow control provided by TCP. This means that remote side blocks when local side input buffer is full and it resumes as soon as local side reads the data from the input buffers. As faster you read from the input as faster remote side will be able to send more data.

In case if message is fragmented, subsequent frames will be received and handled automatically as application reads from the input, until the final frame consumed. Once end of the message is reached the read operation will return 0 bytes.

Since forward only streaming API is used to read the message, this method can be called only once. Subsequent calls to this method would result in InvalidOperationException thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


WebSocketInboundMessage Class Properties

WebSocketInboundMessage Class Properties

Noemax.WebSockets Namespace : WebSocketInboundMessage Class

For a list of all members of this type, see WebSocketInboundMessage members.

Public Properties
 | Name | Description
Public Property | Context | Gets and set the object associated with a message.
Public Property | Fragmented | Gets the value which indicates whether the message was received fragmented.
Public Property | IsBuffered | Gets whether the the inbound message is buffered.
Public Property | State | Gets the state of the WebSocketMessage object.
Public Property | Type | Gets the WebSocketMessageType associated to the message content.
Top
See Also

Reference

WebSocketInboundMessage Class
Noemax.WebSockets Namespace


Context Property (WebSocketInboundMessage)

Context Property (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : Context Property
Gets and set the object associated with a message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Context As System.Object
'Usage

Dim instance As WebSocketInboundMessage
Dim value As System.Object

instance.Context = value

value = instance.Context
public System.object Context {get; set;}
public read-write property Context: System.TObject;
public function get,set Context : System.Object
public: __property System.Object* get_Context();
public: __property void set_Context(
   System.Object* value
);
public:
property System.Object^ Context {
   System.Object^ get();
   void set (    System.Object^ value);
}
Remarks
Application code dispatching the message can set this property to any value that need to be associated with the message while it is being processed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


Fragmented Property (WebSocketInboundMessage)

Fragmented Property (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : Fragmented Property
Gets the value which indicates whether the message was received fragmented.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Fragmented As System.Boolean
'Usage

Dim instance As WebSocketInboundMessage
Dim value As System.Boolean

value = instance.Fragmented
public abstract System.bool Fragmented {get;}
public read-only property Fragmented: System.Boolean; abstract;
public __abstract function get Fragmented : System.boolean
public: __property abstract System.bool get_Fragmented();
public:
abstract property System.bool Fragmented {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


IsBuffered Property (WebSocketInboundMessage)

IsBuffered Property (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : IsBuffered Property
Gets whether the the inbound message is buffered.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property IsBuffered As System.Boolean
'Usage

Dim instance As WebSocketInboundMessage
Dim value As System.Boolean

value = instance.IsBuffered
public abstract System.bool IsBuffered {get;}
public read-only property IsBuffered: System.Boolean; abstract;
public __abstract function get IsBuffered : System.boolean
public: __property abstract System.bool get_IsBuffered();
public:
abstract property System.bool IsBuffered {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


State Property (WebSocketInboundMessage)

State Property (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : State Property
Gets the state of the WebSocketMessage object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property State As WebSocketMessageState
'Usage

Dim instance As WebSocketInboundMessage
Dim value As WebSocketMessageState

value = instance.State
public abstract WebSocketMessageState State {get;}
public read-only property State: WebSocketMessageState; abstract;
public __abstract function get State : WebSocketMessageState
public: __property abstract WebSocketMessageState get_State();
public:
abstract property WebSocketMessageState State {
   WebSocketMessageState get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


Type Property (WebSocketInboundMessage)

Type Property (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : Type Property
Gets the WebSocketMessageType associated to the message content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Type As WebSocketMessageType
'Usage

Dim instance As WebSocketInboundMessage
Dim value As WebSocketMessageType

value = instance.Type
public abstract WebSocketMessageType Type {get;}
public read-only property Type: WebSocketMessageType; abstract;
public __abstract function get Type : WebSocketMessageType
public: __property abstract WebSocketMessageType get_Type();
public:
abstract property WebSocketMessageType Type {
   WebSocketMessageType get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


Implicit Type Conversion Operator (WebSocketInboundMessage)

Implicit Type Conversion Operator (WebSocketInboundMessage)

Noemax.WebSockets Namespace > WebSocketInboundMessage Class : Implicit Type Conversion Operator
Provides implicit conversion that represents an inbound message as Stream object.
Overload List
Overload | Description
Implicit Type Conversion(Stream,WebSocketInboundMessage) | Provides implicit conversion that represents an inbound message as Stream object.
Implicit Type Conversion(TextReader,WebSocketInboundMessage) | Provides implicit conversion that represents an inbound message as TextReader.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members


WebSocketProtocolException Class

WebSocketProtocolException Class
Members

Noemax.WebSockets Namespace : WebSocketProtocolException Class
Provides the exception thrown when connection is being closed due to violation of WebSocket protocol by remote side.
Object Model
WebSocketProtocolException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class WebSocketProtocolException
   Inherits WebSocketException
'Usage

Dim instance As WebSocketProtocolException
public sealed class WebSocketProtocolException : WebSocketException
public class WebSocketProtocolException = class(WebSocketException)sealed;
public sealed class WebSocketProtocolException extends WebSocketException
public __gc __sealed class WebSocketProtocolException : public WebSocketException
public ref class WebSocketProtocolException sealed : public WebSocketException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.WebSocketException
Noemax.WebSockets.WebSocketProtocolException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Members
Noemax.WebSockets Namespace


WebSocketProtocolException Class Members

WebSocketProtocolException Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketProtocolException Class

The following tables list the members exposed by WebSocketProtocolException.

Public Constructors
 | Name | Description
Public Constructor | WebSocketProtocolException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any. (Inherited from Noemax.WebSockets.WebSocketException)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketProtocolException Class
Noemax.WebSockets Namespace


WebSocketProtocolException Constructor

WebSocketProtocolException Constructor

Noemax.WebSockets Namespace > WebSocketProtocolException Class : WebSocketProtocolException Constructor
Overload List
Overload | Description
WebSocketProtocolException Constructor() | Initializes a new instance of WebSocketProtocol.
WebSocketProtocolException Constructor(Exception) | Initializes a new instance of WebSocketProtocol.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


WebSocketProtocolException Constructor()

WebSocketProtocolException Constructor()

Noemax.WebSockets Namespace > WebSocketProtocolException Class > WebSocketProtocolException Constructor : WebSocketProtocolException Constructor()
Initializes a new instance of WebSocketProtocol.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketProtocolException()
public WebSocketProtocolException()
public WebSocketProtocolException();
public function WebSocketProtocolException();
public: WebSocketProtocolException();
public:
WebSocketProtocolException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members
Overload List


WebSocketProtocolException Constructor(Exception)

WebSocketProtocolException Constructor(Exception)

Noemax.WebSockets Namespace > WebSocketProtocolException Class > WebSocketProtocolException Constructor : WebSocketProtocolException Constructor(Exception)
The inner exception that caused this exception to be raised.
Initializes a new instance of WebSocketProtocol.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal inner As System.Exception _
)
'Usage

Dim inner As System.Exception

Dim instance As New WebSocketProtocolException(inner)
public WebSocketProtocolException(
   System.Exception inner
)
public WebSocketProtocolException(
    inner: System.Exception
);
public function WebSocketProtocolException(
   inner : System.Exception
);
public: WebSocketProtocolException(
   System.Exception* inner
)
public:
WebSocketProtocolException(
   System.Exception^ inner
)

Parameters

inner
The inner exception that caused this exception to be raised.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members
Overload List


WebSocketQueueSizeException Class

WebSocketQueueSizeException Class
Members

Noemax.WebSockets Namespace : WebSocketQueueSizeException Class
Provides the exception thrown when the size of outbound message queue, exceeds the maximum size.
Object Model
WebSocketQueueSizeException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public NotInheritable Class WebSocketQueueSizeException
   Inherits WebSocketException
'Usage

Dim instance As WebSocketQueueSizeException
public sealed class WebSocketQueueSizeException : WebSocketException
public class WebSocketQueueSizeException = class(WebSocketException)sealed;
public sealed class WebSocketQueueSizeException extends WebSocketException
public __gc __sealed class WebSocketQueueSizeException : public WebSocketException
public ref class WebSocketQueueSizeException sealed : public WebSocketException
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.WebSocketException
Noemax.WebSockets.WebSocketQueueSizeException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Members
Noemax.WebSockets Namespace


WebSocketQueueSizeException Class Members

WebSocketQueueSizeException Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketQueueSizeException Class

The following tables list the members exposed by WebSocketQueueSizeException.

Public Constructors
 | Name | Description
Public Constructor | WebSocketQueueSizeException Constructor | Initializes a new instance of WebSocketQueueSizeException.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | MaxOutboundQueueSize | The queue size limit in bytes that was exceeded and caused exception.
Public Property | Message | (Inherited from System.Exception)
Public Property | OutboundQueueSizeWouldHave | Gets the size of message queue that would be reached if exception would not be thrown.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any. (Inherited from Noemax.WebSockets.WebSocketException)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketQueueSizeException Class
Noemax.WebSockets Namespace


WebSocketQueueSizeException Constructor

WebSocketQueueSizeException Constructor

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : WebSocketQueueSizeException Constructor
The queue size limit in bytes that was exceeded and caused exception.
The size of message queue that would be reached if exception would not be thrown.
Initializes a new instance of WebSocketQueueSizeException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal maxOutboundQueueSize As System.Long, _
   ByVal outboundQueueSizeWouldHave As System.Long _
)
'Usage

Dim maxOutboundQueueSize As System.Long
Dim outboundQueueSizeWouldHave As System.Long

Dim instance As New WebSocketQueueSizeException(maxOutboundQueueSize, outboundQueueSizeWouldHave)
public WebSocketQueueSizeException(
   System.long maxOutboundQueueSize,
   System.long outboundQueueSizeWouldHave
)
public WebSocketQueueSizeException(
    maxOutboundQueueSize: System.Int64;
    outboundQueueSizeWouldHave: System.Int64
);
public function WebSocketQueueSizeException(
   maxOutboundQueueSize : System.long,
   outboundQueueSizeWouldHave : System.long
);
public: WebSocketQueueSizeException(
   System.long maxOutboundQueueSize,
   System.long outboundQueueSizeWouldHave
)
public:
WebSocketQueueSizeException(
   System.int64 maxOutboundQueueSize,
   System.int64 outboundQueueSizeWouldHave
)

Parameters

maxOutboundQueueSize
The queue size limit in bytes that was exceeded and caused exception.
outboundQueueSizeWouldHave
The size of message queue that would be reached if exception would not be thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


WebSocketQueueSizeException Class Properties

WebSocketQueueSizeException Class Properties

Noemax.WebSockets Namespace : WebSocketQueueSizeException Class

For a list of all members of this type, see WebSocketQueueSizeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | MaxOutboundQueueSize | The queue size limit in bytes that was exceeded and caused exception.
Public Property | Message | (Inherited from System.Exception)
Public Property | OutboundQueueSizeWouldHave | Gets the size of message queue that would be reached if exception would not be thrown.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any. (Inherited from Noemax.WebSockets.WebSocketException)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketQueueSizeException Class
Noemax.WebSockets Namespace


MaxOutboundQueueSize Property (WebSocketQueueSizeException)

MaxOutboundQueueSize Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : MaxOutboundQueueSize Property
The queue size limit in bytes that was exceeded and caused exception.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property MaxOutboundQueueSize As System.Long
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Long

value = instance.MaxOutboundQueueSize
public System.long MaxOutboundQueueSize {get;}
public read-only property MaxOutboundQueueSize: System.Int64;
public function get MaxOutboundQueueSize : System.long
public: __property System.long get_MaxOutboundQueueSize();
public:
property System.int64 MaxOutboundQueueSize {
   System.int64 get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


OutboundQueueSizeWouldHave Property (WebSocketQueueSizeException)

OutboundQueueSizeWouldHave Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : OutboundQueueSizeWouldHave Property
Gets the size of message queue that would be reached if exception would not be thrown.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutboundQueueSizeWouldHave As System.Long
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Long

value = instance.OutboundQueueSizeWouldHave
public System.long OutboundQueueSizeWouldHave {get;}
public read-only property OutboundQueueSizeWouldHave: System.Int64;
public function get OutboundQueueSizeWouldHave : System.long
public: __property System.long get_OutboundQueueSizeWouldHave();
public:
property System.int64 OutboundQueueSizeWouldHave {
   System.int64 get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


WebSocketServer Class

WebSocketServer Class
Members

Noemax.WebSockets Namespace : WebSocketServer Class
Provides the WebSocket protocol server.
Object Model
WebSocketServer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketServer
'Usage

Dim instance As WebSocketServer
public class WebSocketServer
public class WebSocketServer
public class WebSocketServer
public __gc class WebSocketServer
public ref class WebSocketServer
Remarks

The WebSocketServer class provides methods and properties for hosting on one or more WebSocket service endpoints.

Use AddEndpoint<TService>(Uri) and AddEndpoint(Uri,IWebSockets) to add endpoints to the server.

Open starts listening on all endpoints.

Close closes all endpoints and release all associated resources.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketServer
Noemax.WebSockets.WebSocketServer<TService>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Members
Noemax.WebSockets Namespace


WebSocketServer Class Members

WebSocketServer Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketServer Class

The following tables list the members exposed by WebSocketServer.

Public Constructors
 | Name | Description
Public Constructor | WebSocketServer Constructor | Initializes a new instance of the class.
Top
Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression scheme being used for compressing the payload sent through the WebSocket connection.
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Public Property | Security | Gets the server security settings.
Public Property | TraceSource | Gets and sets TraceSource for tracing events generated by the server and underlying components.
Top
Public Methods
 | Name | Description
Public Method | AddEndpoint | Overloaded. Adds a new endpoint with specified URI and specified IWebSockets implementation.
Public Method | Close | Closes all the server endpoints and releases all associated resources.
Public Method | Open | Opens the server and start listening for client connections on all endpoints.
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Top
See Also

Reference

WebSocketServer Class
Noemax.WebSockets Namespace


WebSocketServer Constructor

WebSocketServer Constructor

Noemax.WebSockets Namespace > WebSocketServer Class : WebSocketServer Constructor
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketServer()
public WebSocketServer()
public WebSocketServer();
public function WebSocketServer();
public: WebSocketServer();
public:
WebSocketServer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


WebSocketServer Class Methods

WebSocketServer Class Methods

Noemax.WebSockets Namespace : WebSocketServer Class

For a list of all members of this type, see WebSocketServer members.

Public Methods
 | Name | Description
Public Method | AddEndpoint | Overloaded. Adds a new endpoint with specified URI and specified IWebSockets implementation.
Public Method | Close | Closes all the server endpoints and releases all associated resources.
Public Method | Open | Opens the server and start listening for client connections on all endpoints.
Top
See Also

Reference

WebSocketServer Class
Noemax.WebSockets Namespace


AddEndpoint Method (WebSocketServer)

AddEndpoint Method (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : AddEndpoint Method
Adds a new endpoint with specified URI and specified IWebSockets implementation.
Overload List
Overload | Description
AddEndpoint<TService>(Uri) | Adds a new endpoint with specified URI and specified IWebSockets implementation.
AddEndpoint<TService>(String) | Adds a new endpoint with specified URI and specified IWebSockets implementation.
AddEndpoint(Uri,IWebSockets) | Adds a new endpoint with specified URI and specified IWebSockets instance.
AddEndpoint(String,IWebSockets) | Adds a new endpoint with specified URI and specified IWebSockets instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


AddEndpoint<TService>(Uri) Method

AddEndpoint<TService>(Uri) Method

Noemax.WebSockets Namespace > WebSocketServer Class > AddEndpoint Method : AddEndpoint<TService>(Uri) Method
The type that must implement the IWebSockets interface.
The URI of the new endpoint.
Adds a new endpoint with specified URI and specified IWebSockets implementation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function AddEndpoint(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.Uri _
) As WebSocketEndpoint
'Usage

Dim instance As WebSocketServer
Dim uri As System.Uri
Dim value As WebSocketEndpoint

value = instance.AddEndpoint(Of TService)(uri)
public virtual WebSocketEndpoint AddEndpoint<TService>(
   System.Uri uri
)
where TService: class, new(), IWebSockets
public function AddEndpoint(
    uri: System.Uri
): WebSocketEndpoint; virtual;
public function AddEndpoint(
   uri : System.Uri
) : WebSocketEndpoint;
public: virtual WebSocketEndpoint* AddEndpoint<TService>(
   System.Uri* uri
)
where TService: ref class, gcnew(), IWebSockets
public:
virtual WebSocketEndpoint^ AddEndpointgeneric<typename TService>
(
   System.Uri^ uri
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the new endpoint.

Type Parameters

TService
The type that must implement the IWebSockets interface.
Remarks
An new instance of TService is initialized automatically once the first client connection is accepted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members
Overload List


AddEndpoint<TService>(String) Method

AddEndpoint<TService>(String) Method

Noemax.WebSockets Namespace > WebSocketServer Class > AddEndpoint Method : AddEndpoint<TService>(String) Method
The type that must implement the IWebSockets interface.
The URI of the new endpoint.
Adds a new endpoint with specified URI and specified IWebSockets implementation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddEndpoint(Of TService As {Class, New, IWebSockets})( _
   ByVal uri As System.String _
) As WebSocketEndpoint
'Usage

Dim instance As WebSocketServer
Dim uri As System.String
Dim value As WebSocketEndpoint

value = instance.AddEndpoint(Of TService)(uri)
public WebSocketEndpoint AddEndpoint<TService>(
   System.string uri
)
where TService: class, new(), IWebSockets
public function AddEndpoint(
    uri: System.String
): WebSocketEndpoint;
public function AddEndpoint(
   uri : System.String
) : WebSocketEndpoint;
public: WebSocketEndpoint* AddEndpoint<TService>(
   System.string* uri
)
where TService: ref class, gcnew(), IWebSockets
public:
WebSocketEndpoint^ AddEndpointgeneric<typename TService>
(
   System.String^ uri
)
where TService: ref class, gcnew(), IWebSockets

Parameters

uri
The URI of the new endpoint.

Type Parameters

TService
The type that must implement the IWebSockets interface.
Remarks
An new instance of TService is initialized automatically once the first client connection is accepted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members
Overload List


AddEndpoint(Uri,IWebSockets) Method

AddEndpoint(Uri,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketServer Class > AddEndpoint Method : AddEndpoint(Uri,IWebSockets) Method
The URI of the new endpoint.
The instance of IWebSockets for the endpoint.
Adds a new endpoint with specified URI and specified IWebSockets instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function AddEndpoint( _
   ByVal uri As System.Uri, _
   ByVal instance As IWebSockets _
) As WebSocketEndpoint
'Usage

Dim instance As WebSocketServer
Dim uri As System.Uri
Dim instance As IWebSockets
Dim value As WebSocketEndpoint

value = instance.AddEndpoint(uri, instance)
public virtual WebSocketEndpoint AddEndpoint(
   System.Uri uri,
   IWebSockets instance
)
public function AddEndpoint(
    uri: System.Uri;
    instance: IWebSockets
): WebSocketEndpoint; virtual;
public function AddEndpoint(
   uri : System.Uri,
   instance : IWebSockets
) : WebSocketEndpoint;
public: virtual WebSocketEndpoint* AddEndpoint(
   System.Uri* uri,
   IWebSockets* instance
)
public:
virtual WebSocketEndpoint^ AddEndpoint(
   System.Uri^ uri,
   IWebSockets^ instance
)

Parameters

uri
The URI of the new endpoint.
instance
The instance of IWebSockets for the endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members
Overload List


AddEndpoint(String,IWebSockets) Method

AddEndpoint(String,IWebSockets) Method

Noemax.WebSockets Namespace > WebSocketServer Class > AddEndpoint Method : AddEndpoint(String,IWebSockets) Method
The URI of the new endpoint.
The instance of IWebSockets for the endpoint.
Adds a new endpoint with specified URI and specified IWebSockets instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function AddEndpoint( _
   ByVal uri As System.String, _
   ByVal instance As IWebSockets _
) As WebSocketEndpoint
'Usage

Dim instance As WebSocketServer
Dim uri As System.String
Dim instance As IWebSockets
Dim value As WebSocketEndpoint

value = instance.AddEndpoint(uri, instance)
public WebSocketEndpoint AddEndpoint(
   System.string uri,
   IWebSockets instance
)
public function AddEndpoint(
    uri: System.String;
    instance: IWebSockets
): WebSocketEndpoint;
public function AddEndpoint(
   uri : System.String,
   instance : IWebSockets
) : WebSocketEndpoint;
public: WebSocketEndpoint* AddEndpoint(
   System.string* uri,
   IWebSockets* instance
)
public:
WebSocketEndpoint^ AddEndpoint(
   System.String^ uri,
   IWebSockets^ instance
)

Parameters

uri
The URI of the new endpoint.
instance
The instance of IWebSockets for the endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members
Overload List


Close Method (WebSocketServer)

Close Method (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : Close Method
Closes all the server endpoints and releases all associated resources.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As WebSocketServer

instance.Close()
public void Close()
public procedure Close();
public function Close();
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


Open Method (WebSocketServer)

Open Method (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : Open Method
Opens the server and start listening for client connections on all endpoints.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Open()
'Usage

Dim instance As WebSocketServer

instance.Open()
public void Open()
public procedure Open();
public function Open();
public: void Open();
public:
void Open();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


WebSocketServer Class Properties

WebSocketServer Class Properties

Noemax.WebSockets Namespace : WebSocketServer Class

For a list of all members of this type, see WebSocketServer members.

Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression scheme being used for compressing the payload sent through the WebSocket connection.
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Public Property | Security | Gets the server security settings.
Public Property | TraceSource | Gets and sets TraceSource for tracing events generated by the server and underlying components.
Top
See Also

Reference

WebSocketServer Class
Noemax.WebSockets Namespace


Compression Property (WebSocketServer)

Compression Property (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : Compression Property
Gets and sets the compression scheme being used for compressing the payload sent through the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Compression As CompressionSettings
'Usage

Dim instance As WebSocketServer
Dim value As CompressionSettings

value = instance.Compression
public CompressionSettings Compression {get;}
public read-only property Compression: CompressionSettings;
public function get Compression : CompressionSettings
public: __property CompressionSettings* get_Compression();
public:
property CompressionSettings^ Compression {
   CompressionSettings^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


PortSharing Property (WebSocketServer)

PortSharing Property (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : PortSharing Property
Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortSharing As System.Boolean
'Usage

Dim instance As WebSocketServer
Dim value As System.Boolean

instance.PortSharing = value

value = instance.PortSharing
public System.bool PortSharing {get; set;}
public read-write property PortSharing: System.Boolean;
public function get,set PortSharing : System.boolean
public: __property System.bool get_PortSharing();
public: __property void set_PortSharing(
   System.bool value
);
public:
property System.bool PortSharing {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


Security Property (WebSocketServer)

Security Property (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : Security Property
Gets the server security settings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Security As WebSocketServerSecurity
'Usage

Dim instance As WebSocketServer
Dim value As WebSocketServerSecurity

value = instance.Security
public WebSocketServerSecurity Security {get;}
public read-only property Security: WebSocketServerSecurity;
public function get Security : WebSocketServerSecurity
public: __property WebSocketServerSecurity* get_Security();
public:
property WebSocketServerSecurity^ Security {
   WebSocketServerSecurity^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


TraceSource Property (WebSocketServer)

TraceSource Property (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : TraceSource Property
Gets and sets TraceSource for tracing events generated by the server and underlying components.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketServer
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


WebSocketServer Class Events

WebSocketServer Class Events

Noemax.WebSockets Namespace : WebSocketServer Class

For a list of all members of this type, see WebSocketServer members.

Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Top
See Also

Reference

WebSocketServer Class
Noemax.WebSockets Namespace


Handshake Event (WebSocketServer)

Handshake Event (WebSocketServer)

Noemax.WebSockets Namespace > WebSocketServer Class : Handshake Event
Event triggered when the WebSocket handshake is performed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Handshake As WebSocketHandshakeEventHandler
'Usage

Dim instance As WebSocketServer
Dim handler As WebSocketHandshakeEventHandler

AddHandler instance.Handshake, handler
public event WebSocketHandshakeEventHandler Handshake
public event Handshake: WebSocketHandshakeEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event WebSocketHandshakeEventHandler* Handshake
public:
event WebSocketHandshakeEventHandler^ Handshake
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer Class
WebSocketServer Members


WebSocketServer<TService> Class

WebSocketServer<TService> Class
Members

Noemax.WebSockets Namespace : WebSocketServer<TService> Class
The IWebSockets implementation providing the logic for handling connections and incoming messages.
Provides the WebSocket protocol server.
Object Model
WebSocketServer<TService> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketServer(Of TService As {Class, New, IWebSockets})
   Inherits WebSocketServer
'Usage

Dim instance As WebSocketServer(Of TService)
public class WebSocketServer<TService> : WebSocketServer
where TService: class, new(), IWebSockets
public class WebSocketServer = class(WebSocketServer)
    TService is class, has constructor, IWebSockets
JScript does not support Generics.
public __gc class WebSocketServer<TService> : public WebSocketServer
where TService: ref class, gcnew(), IWebSockets
generic<typename TService>
public ref class WebSocketServer : public WebSocketServer
where TService: ref class, gcnew(), IWebSockets
Type Parameters
TService
The IWebSockets implementation providing the logic for handling connections and incoming messages.
Remarks

The WebSocketServer class provides methods and properties for hosting on one or more WebSocket service endpoints. TService class must implement the IWebSockets interface to provide the application specific functionality.

AddEndpoint(_uri) method can be used to create the endpoint with a specified URI. If TService instance is not provided, it is created automatically once the first client connection is accepted. You can use AddEndpoint(_uri,TService) overload to create a endpoint for already created instance of TService.

Open starts listening on all endpoints.

Close closes all endpoints and release all associated resources.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketServer
Noemax.WebSockets.WebSocketServer<TService>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer<TService> Members
Noemax.WebSockets Namespace


WebSocketServer<TService> Class Members

WebSocketServer<TService> Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketServer<TService> Class

The following tables list the members exposed by WebSocketServer<TService>.

Public Constructors
 | Name | Description
Public Constructor | WebSocketServer<TService> Constructor |
Top
Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression scheme being used for compressing the payload sent through the WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | Security | Gets the server security settings. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | TraceSource | Gets and sets TraceSource for tracing events generated by the server and underlying components. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
Public Methods
 | Name | Description
Public Method | AddEndpoint | Overloaded. Adds a new endpoint with specified URI and specified TService instance.
Public Method | Close | Closes all the server endpoints and releases all associated resources. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Method | Open | Opens the server and start listening for client connections on all endpoints. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
See Also

Reference

WebSocketServer<TService> Class
Noemax.WebSockets Namespace


WebSocketServer<TService> Constructor

WebSocketServer<TService> Constructor

Noemax.WebSockets Namespace > WebSocketServer<TService> Class : WebSocketServer<TService> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketServer(Of TService)()
public WebSocketServer<TService>()
public WebSocketServer<TService>();
public function WebSocketServer<TService>();
public: WebSocketServer<TService>();
public:
WebSocketServer<TService>();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer<TService> Class
WebSocketServer<TService> Members


WebSocketServer<TService> Class Methods

WebSocketServer<TService> Class Methods

Noemax.WebSockets Namespace : WebSocketServer<TService> Class

For a list of all members of this type, see WebSocketServer<TService> members.

Public Methods
 | Name | Description
Public Method | AddEndpoint | Overloaded. Adds a new endpoint with specified URI and specified TService instance.
Public Method | Close | Closes all the server endpoints and releases all associated resources. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Method | Open | Opens the server and start listening for client connections on all endpoints. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
See Also

Reference

WebSocketServer<TService> Class
Noemax.WebSockets Namespace


AddEndpoint Method (WebSocketServer<TService>)

AddEndpoint Method (WebSocketServer<TService>)

Noemax.WebSockets Namespace > WebSocketServer<TService> Class : AddEndpoint Method
Adds a new endpoint with specified URI and specified TService instance.
Overload List
Overload | Description
AddEndpoint(Uri) | Adds a new endpoint with specified URI and specified TService instance.
AddEndpoint(String) | Adds a new endpoint with specified URI and specified TService instance.
AddEndpoint<TService>(Uri) | Adds a new endpoint with specified URI and specified IWebSockets implementation. (Inherited from Noemax.WebSockets.WebSocketServer)
AddEndpoint<TService>(String) | Adds a new endpoint with specified URI and specified IWebSockets implementation. (Inherited from Noemax.WebSockets.WebSocketServer)
AddEndpoint(Uri,IWebSockets) | Adds a new endpoint with specified URI and specified IWebSockets instance. (Inherited from Noemax.WebSockets.WebSocketServer)
AddEndpoint(String,IWebSockets) | Adds a new endpoint with specified URI and specified IWebSockets instance. (Inherited from Noemax.WebSockets.WebSocketServer)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer<TService> Class
WebSocketServer<TService> Members


AddEndpoint(Uri) Method

AddEndpoint(Uri) Method

Noemax.WebSockets Namespace > WebSocketServer<TService> Class > AddEndpoint Method : AddEndpoint(Uri) Method
The URI of the new endpoint.
Adds a new endpoint with specified URI and specified TService instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shadows Sub AddEndpoint( _
   ByVal uri As System.Uri _
)
'Usage

Dim instance As WebSocketServer(Of TService)
Dim uri As System.Uri

instance.AddEndpoint(uri)
public new void AddEndpoint(
   System.Uri uri
)
public procedure AddEndpoint(
    uri: System.Uri
);
public hide function AddEndpoint(
   uri : System.Uri
);
public: new void AddEndpoint(
   System.Uri* uri
)
public:
new void AddEndpoint(
   System.Uri^ uri
)

Parameters

uri
The URI of the new endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer<TService> Class
WebSocketServer<TService> Members
Overload List


AddEndpoint(String) Method

AddEndpoint(String) Method

Noemax.WebSockets Namespace > WebSocketServer<TService> Class > AddEndpoint Method : AddEndpoint(String) Method
The URI of the new endpoint.
Adds a new endpoint with specified URI and specified TService instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Shadows Sub AddEndpoint( _
   ByVal uri As System.String _
)
'Usage

Dim instance As WebSocketServer(Of TService)
Dim uri As System.String

instance.AddEndpoint(uri)
public new void AddEndpoint(
   System.string uri
)
public procedure AddEndpoint(
    uri: System.String
);
public hide function AddEndpoint(
   uri : System.String
);
public: new void AddEndpoint(
   System.string* uri
)
public:
new void AddEndpoint(
   System.String^ uri
)

Parameters

uri
The URI of the new endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServer<TService> Class
WebSocketServer<TService> Members
Overload List


WebSocketServerSecurity Class

WebSocketServerSecurity Class
Members

Noemax.WebSockets Namespace : WebSocketServerSecurity Class
Provides the WebSocket server security settings that are applied when SSL/TLS transport security is enabled.
Object Model
WebSocketServerSecurity Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketServerSecurity
'Usage

Dim instance As WebSocketServerSecurity
public class WebSocketServerSecurity
public class WebSocketServerSecurity
public class WebSocketServerSecurity
public __gc class WebSocketServerSecurity
public ref class WebSocketServerSecurity
Remarks
SSL/TLS security is enabled Required property is set to true or when the service endpoint URI includes 'wss' or 'https' schema. It's recommended to use Required property rather than relly on the URI, to make sure that security is forced on all endpoints. If SSL/TLS security is enabled the ServerCertificate must be set to the valid X509 certificate, otherwise server with fail to start and System.InvalidOperationException will be thrown.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketServerSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Members
Noemax.WebSockets Namespace


WebSocketServerSecurity Class Members

WebSocketServerSecurity Class Members
Properties Events

Noemax.WebSockets Namespace : WebSocketServerSecurity Class

The following tables list the members exposed by WebSocketServerSecurity.

Public Constructors
 | Name | Description
Public Constructor | WebSocketServerSecurity Constructor | Initializes a new instance of the class.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationScheme | Gets or sets the authentication scheme to be used by the server endpoints.
Public Property | CheckCertificateRevocation | Gets and sets whether the server should check the client certificate chain for revocation.
Public Property | RequireClientCertificate | Gets and sets whether the server should require clients to provide the their certificate for authentication.
Public Property | Required | Gets and sets whether the SSL/TLS security is enabled for all endpoints.
Public Property | ServerCertificate | Gets and sets the certificate to be used by the server.
Top
Public Events
 | Name | Description
Public Event | UsernamePasswordAuthenticate | Event trigger when basic HTTP authentication is performed.
Public Event | ValidateCertificate | Occurs when a client certificate validation is being validated by the server. Provide an the event handler to perform an additional custom certificate validation.
Top
See Also

Reference

WebSocketServerSecurity Class
Noemax.WebSockets Namespace


WebSocketServerSecurity Constructor

WebSocketServerSecurity Constructor

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : WebSocketServerSecurity Constructor
The object owning the security settings.
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal owner As System.Object _
)
'Usage

Dim owner As System.Object

Dim instance As New WebSocketServerSecurity(owner)
public WebSocketServerSecurity(
   System.object owner
)
public WebSocketServerSecurity(
    owner: System.TObject
);
public function WebSocketServerSecurity(
   owner : System.Object
);
public: WebSocketServerSecurity(
   System.Object* owner
)
public:
WebSocketServerSecurity(
   System.Object^ owner
)

Parameters

owner
The object owning the security settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


WebSocketServerSecurity Class Properties

WebSocketServerSecurity Class Properties

Noemax.WebSockets Namespace : WebSocketServerSecurity Class

For a list of all members of this type, see WebSocketServerSecurity members.

Public Properties
 | Name | Description
Public Property | AuthenticationScheme | Gets or sets the authentication scheme to be used by the server endpoints.
Public Property | CheckCertificateRevocation | Gets and sets whether the server should check the client certificate chain for revocation.
Public Property | RequireClientCertificate | Gets and sets whether the server should require clients to provide the their certificate for authentication.
Public Property | Required | Gets and sets whether the SSL/TLS security is enabled for all endpoints.
Public Property | ServerCertificate | Gets and sets the certificate to be used by the server.
Top
See Also

Reference

WebSocketServerSecurity Class
Noemax.WebSockets Namespace


AuthenticationScheme Property (WebSocketServerSecurity)

AuthenticationScheme Property (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : AuthenticationScheme Property
Gets or sets the authentication scheme to be used by the server endpoints.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AuthenticationScheme As System.Net.AuthenticationSchemes
'Usage

Dim instance As WebSocketServerSecurity
Dim value As System.Net.AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
public System.Net.AuthenticationSchemes AuthenticationScheme {get; set;}
public read-write property AuthenticationScheme: System.Net.AuthenticationSchemes;
public function get,set AuthenticationScheme : System.Net.AuthenticationSchemes
public: __property System.Net.AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   System.Net.AuthenticationSchemes value
);
public:
property System.Net.AuthenticationSchemes AuthenticationScheme {
   System.Net.AuthenticationSchemes get();
   void set (    System.Net.AuthenticationSchemes value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


CheckCertificateRevocation Property (WebSocketServerSecurity)

CheckCertificateRevocation Property (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : CheckCertificateRevocation Property
Gets and sets whether the server should check the client certificate chain for revocation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckCertificateRevocation As System.Boolean
'Usage

Dim instance As WebSocketServerSecurity
Dim value As System.Boolean

instance.CheckCertificateRevocation = value

value = instance.CheckCertificateRevocation
public System.bool CheckCertificateRevocation {get; set;}
public read-write property CheckCertificateRevocation: System.Boolean;
public function get,set CheckCertificateRevocation : System.boolean
public: __property System.bool get_CheckCertificateRevocation();
public: __property void set_CheckCertificateRevocation(
   System.bool value
);
public:
property System.bool CheckCertificateRevocation {
   System.bool get();
   void set (    System.bool value);
}
Remarks
Note: the self-signed certificates will fail the revocation check. When using self-signed certificates, set this property to false,
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


RequireClientCertificate Property (WebSocketServerSecurity)

RequireClientCertificate Property (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : RequireClientCertificate Property
Gets and sets whether the server should require clients to provide the their certificate for authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property RequireClientCertificate As System.Boolean
'Usage

Dim instance As WebSocketServerSecurity
Dim value As System.Boolean

instance.RequireClientCertificate = value

value = instance.RequireClientCertificate
public System.bool RequireClientCertificate {get; set;}
public read-write property RequireClientCertificate: System.Boolean;
public function get,set RequireClientCertificate : System.boolean
public: __property System.bool get_RequireClientCertificate();
public: __property void set_RequireClientCertificate(
   System.bool value
);
public:
property System.bool RequireClientCertificate {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


Required Property (WebSocketServerSecurity)

Required Property (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : Required Property
Gets and sets whether the SSL/TLS security is enabled for all endpoints.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Required As System.Boolean
'Usage

Dim instance As WebSocketServerSecurity
Dim value As System.Boolean

instance.Required = value

value = instance.Required
public System.bool Required {get; set;}
public read-write property Required: System.Boolean;
public function get,set Required : System.boolean
public: __property System.bool get_Required();
public: __property void set_Required(
   System.bool value
);
public:
property System.bool Required {
   System.bool get();
   void set (    System.bool value);
}
Remarks
Setting this property to true ensures that security is getting enabled for all endpoints defined for the server. If this property is set to false then only endpoints that have "wss" schema e.g. 'wss://www.myserver.com' will have transport security enabled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


ServerCertificate Property (WebSocketServerSecurity)

ServerCertificate Property (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : ServerCertificate Property
Gets and sets the certificate to be used by the server.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ServerCertificate As System.Security.Cryptography.X509Certificates.X509Certificate2
'Usage

Dim instance As WebSocketServerSecurity
Dim value As System.Security.Cryptography.X509Certificates.X509Certificate2

instance.ServerCertificate = value

value = instance.ServerCertificate
public System.Security.Cryptography.X509Certificates.X509Certificate2 ServerCertificate {get; set;}
public read-write property ServerCertificate: System.Security.Cryptography.X509Certificates.X509Certificate2;
public function get,set ServerCertificate : System.Security.Cryptography.X509Certificates.X509Certificate2
public: __property System.Security.Cryptography.X509Certificates.X509Certificate2* get_ServerCertificate();
public: __property void set_ServerCertificate(
   System.Security.Cryptography.X509Certificates.X509Certificate2* value
);
public:
property System.Security.Cryptography.X509Certificates.X509Certificate2^ ServerCertificate {
   System.Security.Cryptography.X509Certificates.X509Certificate2^ get();
   void set (    System.Security.Cryptography.X509Certificates.X509Certificate2^ value);
}
Remarks
This property MUST be set to the valid X509Certificate when SSL/TLS security is enabled, otherwise InvalidOperationException exception will be thrown.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


WebSocketServerSecurity Class Events

WebSocketServerSecurity Class Events

Noemax.WebSockets Namespace : WebSocketServerSecurity Class

For a list of all members of this type, see WebSocketServerSecurity members.

Public Events
 | Name | Description
Public Event | UsernamePasswordAuthenticate | Event trigger when basic HTTP authentication is performed.
Public Event | ValidateCertificate | Occurs when a client certificate validation is being validated by the server. Provide an the event handler to perform an additional custom certificate validation.
Top
See Also

Reference

WebSocketServerSecurity Class
Noemax.WebSockets Namespace


UsernamePasswordAuthenticate Event (WebSocketServerSecurity)

UsernamePasswordAuthenticate Event (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : UsernamePasswordAuthenticate Event
Event trigger when basic HTTP authentication is performed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event UsernamePasswordAuthenticate As UsernamePasswordAuthenticateEventHandler
'Usage

Dim instance As WebSocketServerSecurity
Dim handler As UsernamePasswordAuthenticateEventHandler

AddHandler instance.UsernamePasswordAuthenticate, handler
public event UsernamePasswordAuthenticateEventHandler UsernamePasswordAuthenticate
public event UsernamePasswordAuthenticate: UsernamePasswordAuthenticateEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event UsernamePasswordAuthenticateEventHandler* UsernamePasswordAuthenticate
public:
event UsernamePasswordAuthenticateEventHandler^ UsernamePasswordAuthenticate
Event Data

The event handler receives an argument of type UsernamePasswordAuthenticateEventArgs containing data related to this event. The following UsernamePasswordAuthenticateEventArgs properties provide information specific to this event.

Property | Description
AuthenticationContext | The object representing the context assigned to the WebSocket connection during authentication.
Password | The password presented by remote endpoint.
Username | The username presented by the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


ValidateCertificate Event (WebSocketServerSecurity)

ValidateCertificate Event (WebSocketServerSecurity)

Noemax.WebSockets Namespace > WebSocketServerSecurity Class : ValidateCertificate Event
Occurs when a client certificate validation is being validated by the server. Provide an the event handler to perform an additional custom certificate validation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event ValidateCertificate As X509CertificateValidationCallback
'Usage

Dim instance As WebSocketServerSecurity
Dim handler As X509CertificateValidationCallback

AddHandler instance.ValidateCertificate, handler
public event X509CertificateValidationCallback ValidateCertificate
public event ValidateCertificate: X509CertificateValidationCallback;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event X509CertificateValidationCallback* ValidateCertificate
public:
event X509CertificateValidationCallback^ ValidateCertificate
Remarks

The event handler is expected to throw an exception if client certificate is not valid; otherwise the it is considered being valid.

Note prior this event occurs, WebSocketServer validates certificate according to its security settings. Please check the CheckCertificateRevocation properties for more details.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketServerSecurity Class
WebSocketServerSecurity Members


WebSocketService Class

WebSocketService Class
Members

Noemax.WebSockets Namespace : WebSocketService Class
Provides the base class implementation for IWebSockets interface.
Object Model
WebSocketService Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketService
   Implements IWebSockets
'Usage

Dim instance As WebSocketService
public class WebSocketService : IWebSockets
public class WebSocketService = class(IWebSockets)
public class WebSocketService implements IWebSockets
public __gc class WebSocketService : public IWebSockets
public ref class WebSocketService : public IWebSockets
Remarks

WebSocketService is recommended to use as the base class for the IWebSockets service implementations. It provides methods and properties for managing the list of associated WebSocketChannel, sending and receiving messages through all connected channels and message broadcasting.

This class should be extended to provide application specific logic.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService
Noemax.WebSockets.Messaging.WebSocketMessagingService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Members
Noemax.WebSockets Namespace


WebSocketService Class Members

WebSocketService Class Members
Properties Methods

Noemax.WebSockets Namespace : WebSocketService Class

The following tables list the members exposed by WebSocketService.

Public Constructors
 | Name | Description
Public Constructor | WebSocketService Constructor | Initializes a new instance of WebSocketService.
Top
Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance.
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages.
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages.
Public Property | TraceSource | Gets and sets TraceSource for tracing events.
Top
Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance.
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance.
Public Method | Broadcast | Broadcasts the message to all channels associated to the service instance.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance.
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance.
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service.
Public Method | GetChannels | Returns the list of the channels associated to the service instance.
Public Method | GetProperty<T> | Gets the the object of the specified type associated to the service instance.
Public Method | OnClose | This method is called when a channel is being closed.
Public Method | OnError | Handles a error occurred in a specified channel.
Public Method | OnHandshake | The method is called during the WebSocket handshake, override this method to accept or to decline it.
Public Method | OnMessage | Overloaded. Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API.
Public Method | OnOpen | Handles the event triggered when a new channel is being open and associated to the service instance.
Public Method | OnPing | This method is called when a PING frame received from a specified channel.
Public Method | OnPong | This method is called when a PONG frame received from a specified channel.
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance.
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance.
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance.
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance.
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance.
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires.
Top
See Also

Reference

WebSocketService Class
Noemax.WebSockets Namespace


WebSocketService Constructor

WebSocketService Constructor

Noemax.WebSockets Namespace > WebSocketService Class : WebSocketService Constructor
Initializes a new instance of WebSocketService.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketService()
public WebSocketService()
public WebSocketService();
public function WebSocketService();
public: WebSocketService();
public:
WebSocketService();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


WebSocketService Class Methods

WebSocketService Class Methods

Noemax.WebSockets Namespace : WebSocketService Class

For a list of all members of this type, see WebSocketService members.

Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance.
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance.
Public Method | Broadcast | Broadcasts the message to all channels associated to the service instance.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance.
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance.
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service.
Public Method | GetChannels | Returns the list of the channels associated to the service instance.
Public Method | GetProperty<T> | Gets the the object of the specified type associated to the service instance.
Public Method | OnClose | This method is called when a channel is being closed.
Public Method | OnError | Handles a error occurred in a specified channel.
Public Method | OnHandshake | The method is called during the WebSocket handshake, override this method to accept or to decline it.
Public Method | OnMessage | Overloaded. Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API.
Public Method | OnOpen | Handles the event triggered when a new channel is being open and associated to the service instance.
Public Method | OnPing | This method is called when a PING frame received from a specified channel.
Public Method | OnPong | This method is called when a PONG frame received from a specified channel.
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance.
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance.
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance.
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance.
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance.
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires.
Top
See Also

Reference

WebSocketService Class
Noemax.WebSockets Namespace


AddChannel Method (WebSocketService)

AddChannel Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : AddChannel Method
The channel to associate with the service instance.
Adds the channel to the list of channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddChannel( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel

instance.AddChannel(channel)
public void AddChannel(
   WebSocketChannel channel
)
public procedure AddChannel(
    channel: WebSocketChannel
);
public function AddChannel(
   channel : WebSocketChannel
);
public: void AddChannel(
   WebSocketChannel* channel
)
public:
void AddChannel(
   WebSocketChannel^ channel
)

Parameters

channel
The channel to associate with the service instance.
Remarks

All channels accepted by the service instance through are transparently added to the list of associated channels .

AddChannel can be used to associated the channel to a different service instances. For example chat client channel can be moved from one chat root into another. In order to implement this you can call RemoveChannel on the instance representing the current chat room and call AddChannel of another instance.

The same applies to the client side, you can add multiple client channels to the already exiting service instance and use it for broadcasting messages to multiple servers.

Note if channel is added to more than one instance of WebSocketService, all instances will be broadcasting messages to the channel. But only the instance specified by WebSocketChannel.ServiceInstance will be handling inbound messages. Channel can be removed from the list by using RemoveChannel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


AddProperty<T> Method (WebSocketService)

AddProperty<T> Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : AddProperty<T> Method
The type of the object to add.
Adds or replaces the the object of the specified type from the properties of the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function AddProperty(Of T)( _
   ByVal obj As T _
) As T
'Usage

Dim instance As WebSocketService
Dim obj As T
Dim value As T

value = instance.AddProperty(Of T)(obj)
public virtual T AddProperty<T>(
   T obj
)
public function AddProperty(
    obj: T
): T; virtual;
public function AddProperty(
   obj : T
) : T;
public: virtual T* AddProperty<T>(
   T* obj
)
public:
virtual T^ AddPropertygeneric<typename T>
(
   T^ obj
)

Parameters

obj

Type Parameters

T
The type of the object to add.

Return Value

The object of the specified type that was associated to the service instance prior the call if any..
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


Broadcast Method (WebSocketService)

Broadcast Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : Broadcast Method
The message to broadcast.
Broadcasts the message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Broadcast( _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim message As WebSocketOutboundMessage

instance.Broadcast(message)
public void Broadcast(
   WebSocketOutboundMessage message
)
public procedure Broadcast(
    message: WebSocketOutboundMessage
);
public function Broadcast(
   message : WebSocketOutboundMessage
);
public: void Broadcast(
   WebSocketOutboundMessage message
)
public:
void Broadcast(
   WebSocketOutboundMessage message
)

Parameters

message
The message to broadcast.
Remarks
Broadcast() performs message broadcasting to all connected channels in most efficient manner. Instead of sending message into each channel sequentially as SendMessage(), Broadcast() broadcasts messages asynchronously to all channels and also preforms grouping of messages into batches whenever possible. This method is thread safe and can be called by multiple working threads concurrently. Calling this method from multiple threads concurrently does not block those threads until current batch is sent, but helps to group messages into batches and improves the throughput. No artificial delay is used to group messages into batches, in high throughput environment they are formed while previous batch is being broadcasted without delaying transfer. Read SendBatchAsync for more details.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


CalcTotalOutboundQueueSize Method (WebSocketService)

CalcTotalOutboundQueueSize Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : CalcTotalOutboundQueueSize Method
Gets the total sizes of all outbound message queues associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CalcTotalOutboundQueueSize() As System.Long
'Usage

Dim instance As WebSocketService
Dim value As System.Long

value = instance.CalcTotalOutboundQueueSize()
public System.long CalcTotalOutboundQueueSize()
public function CalcTotalOutboundQueueSize(): System.Int64;
public function CalcTotalOutboundQueueSize() : System.long;
public: System.long CalcTotalOutboundQueueSize();
public:
System.int64 CalcTotalOutboundQueueSize();
Remarks

Calling this method calculate the sum of all outbound queue sizes, this involves thread synchronization and can be processing intensive.

The size of outbound message queue does not indicate the size of memory being used by message in the queue, but amount of data to be sent.

The outbound queue size equal 0, doesn't indicate all messages have been delivered to remote side, last asynchronous send operation can still be in progress and last batch of messages being sent.

This method is intended to be used for reporting the status of the service instance rather than flow control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


CloseChannels Method (WebSocketService)

CloseChannels Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : CloseChannels Method
Closes all channels associated to the service instance.
Overload List
Overload | Description
CloseChannels() | Closes all channels associated to the service instance.
CloseChannels(TimeSpan) | Closes all channels associated to the service instance within specification interval of time.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


CloseChannels() Method

CloseChannels() Method

Noemax.WebSockets Namespace > WebSocketService Class > CloseChannels Method : CloseChannels() Method
Closes all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CloseChannels()
'Usage

Dim instance As WebSocketService

instance.CloseChannels()
public void CloseChannels()
public procedure CloseChannels();
public function CloseChannels();
public: void CloseChannels();
public:
void CloseChannels();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


CloseChannels(TimeSpan) Method

CloseChannels(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketService Class > CloseChannels Method : CloseChannels(TimeSpan) Method
The maximum amount of time to wait for graceful disconnection.
Closes all channels associated to the service instance within specification interval of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub CloseChannels( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocketService
Dim timeout As System.TimeSpan

instance.CloseChannels(timeout)
public void CloseChannels(
   System.TimeSpan timeout
)
public procedure CloseChannels(
    timeout: System.TimeSpan
);
public function CloseChannels(
   timeout : System.TimeSpan
);
public: void CloseChannels(
   System.TimeSpan timeout
)
public:
void CloseChannels(
   System.TimeSpan timeout
)

Parameters

timeout
The maximum amount of time to wait for graceful disconnection.
Remarks
If service fails to disconnect all channels gracefully in specified interval of time, it will close remaining channels without performing final close handshake, or waiting for ongoing operations to complete.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


CreateClient Method (WebSocketService)

CreateClient Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : CreateClient Method
Creates a client channel associated to the service.
Overload List
Overload | Description
CreateClient(Uri) | Creates a client channel associated to the service.
CreateClient(Uri,String,String) | Creates a client channel associated to the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


CreateClient(Uri) Method

CreateClient(Uri) Method

Noemax.WebSockets Namespace > WebSocketService Class > CreateClient Method : CreateClient(Uri) Method
The URI of the target server endpoint.
Creates a client channel associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CreateClient( _
   ByVal uri As System.Uri _
) As WebSocketClient
'Usage

Dim instance As WebSocketService
Dim uri As System.Uri
Dim value As WebSocketClient

value = instance.CreateClient(uri)
public WebSocketClient CreateClient(
   System.Uri uri
)
public function CreateClient(
    uri: System.Uri
): WebSocketClient;
public function CreateClient(
   uri : System.Uri
) : WebSocketClient;
public: WebSocketClient* CreateClient(
   System.Uri* uri
)
public:
WebSocketClient^ CreateClient(
   System.Uri^ uri
)

Parameters

uri
The URI of the target server endpoint.

Return Value

Returns a channel connecting the service instance to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


CreateClient(Uri,String,String) Method

CreateClient(Uri,String,String) Method

Noemax.WebSockets Namespace > WebSocketService Class > CreateClient Method : CreateClient(Uri,String,String) Method
The URI of the target server endpoint.
The origin header to be used during WebSocket handshake.
The protocol header to be used during WebSocket handshake
Creates a client channel associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CreateClient( _
   ByVal uri As System.Uri, _
   ByVal origin As System.String, _
   ByVal protocol As System.String _
) As WebSocketClient
'Usage

Dim instance As WebSocketService
Dim uri As System.Uri
Dim origin As System.String
Dim protocol As System.String
Dim value As WebSocketClient

value = instance.CreateClient(uri, origin, protocol)
public WebSocketClient CreateClient(
   System.Uri uri,
   System.string origin,
   System.string protocol
)
public function CreateClient(
    uri: System.Uri;
    origin: System.String;
    protocol: System.String
): WebSocketClient;
public function CreateClient(
   uri : System.Uri,
   origin : System.String,
   protocol : System.String
) : WebSocketClient;
public: WebSocketClient* CreateClient(
   System.Uri* uri,
   System.string* origin,
   System.string* protocol
)
public:
WebSocketClient^ CreateClient(
   System.Uri^ uri,
   System.String^ origin,
   System.String^ protocol
)

Parameters

uri
The URI of the target server endpoint.
origin
The origin header to be used during WebSocket handshake.
protocol
The protocol header to be used during WebSocket handshake

Return Value

The new instance of WebSocketClient.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


GetChannels Method (WebSocketService)

GetChannels Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : GetChannels Method
Returns the list of the channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetChannels() As WebSocketChannel()
'Usage

Dim instance As WebSocketService
Dim value() As WebSocketChannel

value = instance.GetChannels()
public WebSocketChannel[] GetChannels()
public function GetChannels(): array of WebSocketChannel;
public function GetChannels() : WebSocketChannel[];
public: WebSocketChannel*[]* GetChannels();
public:
array<WebSocketChannel^>^ GetChannels();

Return Value

An array of WebSocketChannel objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


GetProperty<T> Method (WebSocketService)

GetProperty<T> Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : GetProperty<T> Method
The type of the object to get.
Gets the the object of the specified type associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetProperty(Of T)() As T
'Usage

Dim instance As WebSocketService
Dim value As T

value = instance.GetProperty(Of T)()
public virtual T GetProperty<T>()
public function GetProperty(): T; virtual;
public function GetProperty() : T;
public: virtual T* GetProperty<T>();
public:
virtual T^ GetPropertygeneric<typename T>
();

Type Parameters

T
The type of the object to get.

Return Value

The object of the specified type or null if object of the specified type was not found.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnClose Method (WebSocketService)

OnClose Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnClose Method
The channel being closed.
The status code provided by the remote side to identify the reason for closing the connection.
The text description of the status code.
This method is called when a channel is being closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnClose( _
   ByVal channel As WebSocketChannel, _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim statusCode As System.Short
Dim reason As System.String

instance.OnClose(channel, statusCode, reason)
public virtual void OnClose(
   WebSocketChannel channel,
   System.short statusCode,
   System.string reason
)
public procedure OnClose(
    channel: WebSocketChannel;
    statusCode: System.Int16;
    reason: System.String
); virtual;
public function OnClose(
   channel : WebSocketChannel,
   statusCode : System.short,
   reason : System.String
);
public: virtual void OnClose(
   WebSocketChannel* channel,
   System.short statusCode,
   System.string* reason
)
public:
virtual void OnClose(
   WebSocketChannel^ channel,
   System.short statusCode,
   System.String^ reason
)

Parameters

channel
The channel being closed.
statusCode
The status code provided by the remote side to identify the reason for closing the connection.
reason
The text description of the status code.
Remarks

If the connection is being closed due to receiving a CLOSE control frame from the remote side, the statusCode and reason parameters may contain information provided by the remote side to identify the reason for closing the connection.

When this method is called, messages might still be sent successfully to the remote side for a short period of time. However, no more messages are expected to be received from the remote side.

When this method is called the base implementation is removes the channel from the list of associated channels.

You can override this method to provide alternative functionallity.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnError Method (WebSocketService)

OnError Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnError Method
The channel that encounters the error..
The exception related to the error.
Handles a error occurred in a specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnError( _
   ByVal channel As WebSocketChannel, _
   ByVal e As System.Exception _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim e As System.Exception

instance.OnError(channel, e)
public virtual void OnError(
   WebSocketChannel channel,
   System.Exception e
)
public procedure OnError(
    channel: WebSocketChannel;
    e: System.Exception
); virtual;
public function OnError(
   channel : WebSocketChannel,
   e : System.Exception
);
public: virtual void OnError(
   WebSocketChannel* channel,
   System.Exception* e
)
public:
virtual void OnError(
   WebSocketChannel^ channel,
   System.Exception^ e
)

Parameters

channel
The channel that encounters the error..
e
The exception related to the error.
Remarks

All errors encountered by the channel during sending/receiving/dispatching messages are reported through this method. The channel that encountered the error is not necessary disconnected or closed, use the WebSocketChannel.Connected property to determine the status of the channel.

The base implementation calls WebSocketChannel.Abort which drops the channel connection and then removes the channel from the list of associated channels using RemoveChannel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnHandshake Method (WebSocketService)

OnHandshake Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnHandshake Method
The initiator of event that performs WebSocket handshake on local endpoint.
The WebSocketHandshake instance.
The method is called during the WebSocket handshake, override this method to accept or to decline it.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnHandshake( _
   ByVal sender As System.Object, _
   ByVal handshake As WebSocketHandshake _
)
'Usage

Dim instance As WebSocketService
Dim sender As System.Object
Dim handshake As WebSocketHandshake

instance.OnHandshake(sender, handshake)
public virtual void OnHandshake(
   System.object sender,
   WebSocketHandshake handshake
)
public procedure OnHandshake(
    sender: System.TObject;
    handshake: WebSocketHandshake
); virtual;
public function OnHandshake(
   sender : System.Object,
   handshake : WebSocketHandshake
);
public: virtual void OnHandshake(
   System.Object* sender,
   WebSocketHandshake* handshake
)
public:
virtual void OnHandshake(
   System.Object^ sender,
   WebSocketHandshake^ handshake
)

Parameters

sender
The initiator of event that performs WebSocket handshake on local endpoint.
handshake
The WebSocketHandshake instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnMessage Method (WebSocketService)

OnMessage Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnMessage Method
Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API.
Overload List
Overload | Description
OnMessage(WebSocketChannel,WebSocketInboundMessage) | Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API.
OnMessage(WebSocketChannel,String) | Handles a text message received from a specified channel.
OnMessage(WebSocketChannel,ArraySegment<Byte>) | Handles a binary message received from a specified channel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnMessage(WebSocketChannel,WebSocketInboundMessage) Method

OnMessage(WebSocketChannel,WebSocketInboundMessage) Method

Noemax.WebSockets Namespace > WebSocketService Class > OnMessage Method : OnMessage(WebSocketChannel,WebSocketInboundMessage) Method
The channel through which the message is being received.
The message being received.
Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub OnMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal message As WebSocketInboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim message As WebSocketInboundMessage

instance.OnMessage(channel, message)
public virtual void OnMessage(
   WebSocketChannel channel,
   WebSocketInboundMessage message
)
public procedure OnMessage(
    channel: WebSocketChannel;
    message: WebSocketInboundMessage
); virtual;
public function OnMessage(
   channel : WebSocketChannel,
   message : WebSocketInboundMessage
);
public: virtual void OnMessage(
   WebSocketChannel* channel,
   WebSocketInboundMessage* message
)
public:
virtual void OnMessage(
   WebSocketChannel^ channel,
   WebSocketInboundMessage^ message
)

Parameters

channel
The channel through which the message is being received.
message
The message being received.
Remarks

The base implementation of this method evaluates the type of the data being received in the message payload by reading the opcode in the first frame. If message is fragmented it's getting buffered and interpreted as text or the binary byte array depending on whether this message is text or binary. Then the message is dispatched to OnMessage(WebSocketChannel,String) or OnMessage(WebSocketChannel,ArraySegment<Byte>) depending on the type of the message.

Overriding this method allows the use of alternative message processing using the streaming API exposed by the WebSocketInboundMessage class.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


OnMessage(WebSocketChannel,String) Method

OnMessage(WebSocketChannel,String) Method

Noemax.WebSockets Namespace > WebSocketService Class > OnMessage Method : OnMessage(WebSocketChannel,String) Method
The channel through which the message was received.
The text payload of the message.
Handles a text message received from a specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub OnMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal text As System.String _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim text As System.String

instance.OnMessage(channel, text)
public virtual void OnMessage(
   WebSocketChannel channel,
   System.string text
)
public procedure OnMessage(
    channel: WebSocketChannel;
    text: System.String
); virtual;
public function OnMessage(
   channel : WebSocketChannel,
   text : System.String
);
public: virtual void OnMessage(
   WebSocketChannel* channel,
   System.string* text
)
public:
virtual void OnMessage(
   WebSocketChannel^ channel,
   System.String^ text
)

Parameters

channel
The channel through which the message was received.
text
The text payload of the message.
Remarks
This method does nothing and should to be override to provide application specific functionality.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


OnMessage(WebSocketChannel,ArraySegment<Byte>) Method

OnMessage(WebSocketChannel,ArraySegment<Byte>) Method

Noemax.WebSockets Namespace > WebSocketService Class > OnMessage Method : OnMessage(WebSocketChannel,ArraySegment<Byte>) Method
The channel through which the message was received.
The binary payload of the message.
Handles a binary message received from a specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub OnMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal buffer As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim buffer As System.ArraySegment(Of Byte)

instance.OnMessage(channel, buffer)
public virtual void OnMessage(
   WebSocketChannel channel,
   System.ArraySegment<byte> buffer
)
public procedure OnMessage(
    channel: WebSocketChannel;
    buffer: System.ArraySegment
); virtual;
public function OnMessage(
   channel : WebSocketChannel,
   buffer : System.ArraySegment
);
public: virtual void OnMessage(
   WebSocketChannel* channel,
   System.ArraySegment<byte> buffer
)
public:
virtual void OnMessage(
   WebSocketChannel^ channel,
   System.ArraySegment<byte> buffer
)

Parameters

channel
The channel through which the message was received.
buffer
The binary payload of the message.
Remarks
This method does nothing and should to be override to provide application specific functionality.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


OnOpen Method (WebSocketService)

OnOpen Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnOpen Method
The channel being open and associated to the service instance.
Handles the event triggered when a new channel is being open and associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnOpen( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel

instance.OnOpen(channel)
public virtual void OnOpen(
   WebSocketChannel channel
)
public procedure OnOpen(
    channel: WebSocketChannel
); virtual;
public function OnOpen(
   channel : WebSocketChannel
);
public: virtual void OnOpen(
   WebSocketChannel* channel
)
public:
virtual void OnOpen(
   WebSocketChannel^ channel
)

Parameters

channel
The channel being open and associated to the service instance.
Remarks

The base implementation adds the channel to the list of associated channels and sets WebSocketChannel.ID to a random literal GUID string.

When overriding this method you can provide additional application specific logic. For example, you can instantiate a new instance of the service and pass the channel to this instance by calling its OnOpen method, instead of OnOpen of the base class. This way you can control the number of channels handled by each instance of the service or group channels and service instances by any other criteria.

Adding the channel to more than one service instances is also possible, if channel is associated to more than one instance of WebSocketService, all service instances will be broadcasting messages to the channel. But only one instance specified by WebSocketChannel.ServiceInstance will be handling inbound messages.

Channel can be removed from the list of associated channels using the RemoveChannel method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnPing Method (WebSocketService)

OnPing Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnPing Method
The channel through which the PING frame was received.
The payload of the PING frame.
This method is called when a PING frame received from a specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnPing( _
   ByVal channel As WebSocketChannel, _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim payload As System.ArraySegment(Of Byte)

instance.OnPing(channel, payload)
public virtual void OnPing(
   WebSocketChannel channel,
   System.ArraySegment<byte> payload
)
public procedure OnPing(
    channel: WebSocketChannel;
    payload: System.ArraySegment
); virtual;
public function OnPing(
   channel : WebSocketChannel,
   payload : System.ArraySegment
);
public: virtual void OnPing(
   WebSocketChannel* channel,
   System.ArraySegment<byte> payload
)
public:
virtual void OnPing(
   WebSocketChannel^ channel,
   System.ArraySegment<byte> payload
)

Parameters

channel
The channel through which the PING frame was received.
payload
The payload of the PING frame.
Remarks

The PONG response to the PING message is sent automatically, unless the channel is closed within OnPing method implementation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


OnPong Method (WebSocketService)

OnPong Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : OnPong Method
The channel through which PONG frame was received.
The payload of the PONG frame.
This method is called when a PONG frame received from a specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub OnPong( _
   ByVal channel As WebSocketChannel, _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel
Dim payload As System.ArraySegment(Of Byte)

instance.OnPong(channel, payload)
public virtual void OnPong(
   WebSocketChannel channel,
   System.ArraySegment<byte> payload
)
public procedure OnPong(
    channel: WebSocketChannel;
    payload: System.ArraySegment
); virtual;
public function OnPong(
   channel : WebSocketChannel,
   payload : System.ArraySegment
);
public: virtual void OnPong(
   WebSocketChannel* channel,
   System.ArraySegment<byte> payload
)
public:
virtual void OnPong(
   WebSocketChannel^ channel,
   System.ArraySegment<byte> payload
)

Parameters

channel
The channel through which PONG frame was received.
payload
The payload of the PONG frame.
Remarks
This method can be overrides if alternative functionality is needed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


RemoveChannel Method (WebSocketService)

RemoveChannel Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : RemoveChannel Method
The channel to associate with the service instance.
Removes the channel from the list of channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub RemoveChannel( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As WebSocketService
Dim channel As WebSocketChannel

instance.RemoveChannel(channel)
public void RemoveChannel(
   WebSocketChannel channel
)
public procedure RemoveChannel(
    channel: WebSocketChannel
);
public function RemoveChannel(
   channel : WebSocketChannel
);
public: void RemoveChannel(
   WebSocketChannel* channel
)
public:
void RemoveChannel(
   WebSocketChannel^ channel
)

Parameters

channel
The channel to associate with the service instance.
Remarks

All channels accepted by the service instance through the call to OnOpen method are getting added to the list of associated channels automatically.

RemoveChannel can be used to transfer accepted channels between different service instances.

For example:

Chat client channel can be moved from one chat root into another. In order to implement this you can call RemoveChannel on the instance representing one chat room and call AddChannel of the instance representing another chat room.

The same applies to the client side, you can add established client channels to the already exiting service instance, in order to use it for broadcasting messages to multiple servers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


RemoveProperty<T> Method (WebSocketService)

RemoveProperty<T> Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : RemoveProperty<T> Method
The type of the object to remove.
The object to remove.
Removes the object of specified type from the properties of the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function RemoveProperty(Of T)( _
   ByVal obj As T _
) As System.Boolean
'Usage

Dim instance As WebSocketService
Dim obj As T
Dim value As System.Boolean

value = instance.RemoveProperty(Of T)(obj)
public virtual System.bool RemoveProperty<T>(
   T obj
)
public function RemoveProperty(
    obj: T
): System.Boolean; virtual;
public function RemoveProperty(
   obj : T
) : System.boolean;
public: virtual System.bool RemoveProperty<T>(
   T* obj
)
public:
virtual System.bool RemovePropertygeneric<typename T>
(
   T^ obj
)

Parameters

obj
The object to remove.

Type Parameters

T
The type of the object to remove.

Return Value

The object removed from the service properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


SendBatchAsync Method (WebSocketService)

SendBatchAsync Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : SendBatchAsync Method
Sends the batch of messages to the list of channels asynchronously.
Overload List
Overload | Description
SendBatchAsync(WebSocketChannel[],WebSocketOutboundMessage[]) | Sends the batch of messages to the list of channels asynchronously.
SendBatchAsync(WebSocketOutboundMessage[]) | Sends the batch of messages to all associated channels asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


SendBatchAsync(WebSocketChannel[],WebSocketOutboundMessage[]) Method

SendBatchAsync(WebSocketChannel[],WebSocketOutboundMessage[]) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendBatchAsync Method : SendBatchAsync(WebSocketChannel[],WebSocketOutboundMessage[]) Method
The list of channels to send messages too.
The batch of messages to be send.
Sends the batch of messages to the list of channels asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendBatchAsync( _
   ByVal channels() As WebSocketChannel, _
   ByVal messages() As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim channels() As WebSocketChannel
Dim messages() As WebSocketOutboundMessage

instance.SendBatchAsync(channels, messages)
public void SendBatchAsync(
   WebSocketChannel[] channels,
   WebSocketOutboundMessage[] messages
)
public procedure SendBatchAsync(
    channels: WebSocketChannelarray of;
    messages: WebSocketOutboundMessagearray of
);
public function SendBatchAsync(
   channels : WebSocketChannel[],
   messages : WebSocketOutboundMessage[]
);
public: void SendBatchAsync(
   WebSocketChannel*[]* channels,
   WebSocketOutboundMessage[]* messages
)
public:
void SendBatchAsync(
   array<WebSocketChannel^>^ channels,
   array<WebSocketOutboundMessage>^ messages
)

Parameters

channels
The list of channels to send messages too.
messages
The batch of messages to be send.
Remarks

The batch of messages is getting enqueued into each channel outbound message queue and does not block the calling thread until the batch is sent. Once channel is ready to send next batch of messages entire outbound queue is treated as single batch and sent asynchronously.

Application can control the size of outbound queues by reading the WebSocketChannel.OutboundQueueSize property or setting the WebSocketChannel.MaxOutboundQueueSize property. This method is thread safe and can be called by multiple threads concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendBatchAsync(WebSocketOutboundMessage[]) Method

SendBatchAsync(WebSocketOutboundMessage[]) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendBatchAsync Method : SendBatchAsync(WebSocketOutboundMessage[]) Method
The batch of messages to be send.
Sends the batch of messages to all associated channels asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendBatchAsync( _
   ByVal messages() As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim messages() As WebSocketOutboundMessage

instance.SendBatchAsync(messages)
public void SendBatchAsync(
   WebSocketOutboundMessage[] messages
)
public procedure SendBatchAsync(
    messages: WebSocketOutboundMessagearray of
);
public function SendBatchAsync(
   messages : WebSocketOutboundMessage[]
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* messages
)
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ messages
)

Parameters

messages
The batch of messages to be send.
Remarks
The batch of messages is getting enqueued into each channel outbound message queue and does not block the calling thread until the batch is sent. Once channel is ready to send next batch of messages entire outbound queue is treated as single batch and sent asynchronously. Application can control the size of outbound queues by reading the WebSocketChannel.OutboundQueueSize property or setting the WebSocketChannel.MaxOutboundQueueSize property. This method is thread safe and can be called by multiple threads concurrently.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendPing Method (WebSocketService)

SendPing Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : SendPing Method
Sends the PING message to all channels associated to the service instance.
Overload List
Overload | Description
SendPing() | Sends the PING message to all channels associated to the service instance.
SendPing(IEnumerable<WebSocketChannel>) | Sends the PING message to the specified list of channels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


SendPing() Method

SendPing() Method

Noemax.WebSockets Namespace > WebSocketService Class > SendPing Method : SendPing() Method
Sends the PING message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendPing()
'Usage

Dim instance As WebSocketService

instance.SendPing()
public void SendPing()
public procedure SendPing();
public function SendPing();
public: void SendPing();
public:
void SendPing();
Remarks

Once PING messages are sent, OnPong method will be called for each PONG reply received.

This method does not block while PING frame is sent, all PING frames are sent asynchronously.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendPing(IEnumerable<WebSocketChannel>) Method

SendPing(IEnumerable<WebSocketChannel>) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendPing Method : SendPing(IEnumerable<WebSocketChannel>) Method
Sends the PING message to the specified list of channels.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendPing( _
   ByVal channels As System.Collections.Generic.IEnumerable(Of WebSocketChannel) _
)
'Usage

Dim instance As WebSocketService
Dim channels As System.Collections.Generic.IEnumerable(Of WebSocketChannel)

instance.SendPing(channels)
public void SendPing(
   System.Collections.Generic.IEnumerable<WebSocketChannel> channels
)
public procedure SendPing(
    channels: System.Collections.Generic.IEnumerable
);
public function SendPing(
   channels : System.Collections.Generic.IEnumerable
);
public: void SendPing(
   System.Collections.Generic.IEnumerable<WebSocketChannel*>* channels
)
public:
void SendPing(
   System.Collections.Generic.IEnumerable<WebSocketChannel^>^ channels
)

Parameters

channels
Remarks

Once PING messages are sent, OnPong method will be called for each PONG reply received.

This method does not block while PING frame is sent, all PING frames are sent asynchronously.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendTo Method (WebSocketService)

SendTo Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : SendTo Method
The list of channels to send message too.
The WebSocketOutboundMessage object representing the message.
Sends the message to the list of specified channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendTo( _
   ByVal channels As System.Collections.Generic.IEnumerable(Of WebSocketChannel), _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim channels As System.Collections.Generic.IEnumerable(Of WebSocketChannel)
Dim message As WebSocketOutboundMessage

instance.SendTo(channels, message)
public void SendTo(
   System.Collections.Generic.IEnumerable<WebSocketChannel> channels,
   WebSocketOutboundMessage message
)
public procedure SendTo(
    channels: System.Collections.Generic.IEnumerable;
    message: WebSocketOutboundMessage
);
public function SendTo(
   channels : System.Collections.Generic.IEnumerable,
   message : WebSocketOutboundMessage
);
public: void SendTo(
   System.Collections.Generic.IEnumerable<WebSocketChannel*>* channels,
   WebSocketOutboundMessage message
)
public:
void SendTo(
   System.Collections.Generic.IEnumerable<WebSocketChannel^>^ channels,
   WebSocketOutboundMessage message
)

Parameters

channels
The list of channels to send message too.
message
The WebSocketOutboundMessage object representing the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


SendToAll Method (WebSocketService)

SendToAll Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : SendToAll Method
Sends the text message to all channels associated to the service instance.
Overload List
Overload | Description
SendToAll(String) | Sends the text message to all channels associated to the service instance.
SendToAll(ArraySegment<Byte>) | Sends the binary message to all channels associated to the service instance.
SendToAll(Byte[],Int32,Int32) | Sends the binary message to all channels associated to the service instance.
SendToAll(WebSocketOutboundMessage) | Sends the message to all channels associated to the service instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


SendToAll(String) Method

SendToAll(String) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendToAll Method : SendToAll(String) Method
The text message to send.
Sends the text message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendToAll( _
   ByVal text As System.String _
)
'Usage

Dim instance As WebSocketService
Dim text As System.String

instance.SendToAll(text)
public void SendToAll(
   System.string text
)
public procedure SendToAll(
    text: System.String
);
public function SendToAll(
   text : System.String
);
public: void SendToAll(
   System.string* text
)
public:
void SendToAll(
   System.String^ text
)

Parameters

text
The text message to send.
Remarks

The message is sent synchronously by iterating the list of associated channels sequentially.

This method is not effective for broadcasting messages to large number of channels, where slow channels will delay the broadcasting.

Use this method in order to send message synchronously in cases when service instance handles a single channel or very few channels.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendToAll(ArraySegment<Byte>) Method

SendToAll(ArraySegment<Byte>) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendToAll Method : SendToAll(ArraySegment<Byte>) Method
The segment of array of bytes referencing the bytes to be sent.
Sends the binary message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendToAll( _
   ByVal message As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocketService
Dim message As System.ArraySegment(Of Byte)

instance.SendToAll(message)
public void SendToAll(
   System.ArraySegment<byte> message
)
public procedure SendToAll(
    message: System.ArraySegment
);
public function SendToAll(
   message : System.ArraySegment
);
public: void SendToAll(
   System.ArraySegment<byte> message
)
public:
void SendToAll(
   System.ArraySegment<byte> message
)

Parameters

message
The segment of array of bytes referencing the bytes to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendToAll(Byte[],Int32,Int32) Method

SendToAll(Byte[],Int32,Int32) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendToAll Method : SendToAll(Byte[],Int32,Int32) Method
The array containing message to be sent.
The offset in the array where the binary message starts.
The number of bytes in the binary message.
Sends the binary message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendToAll( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim instance As WebSocketService
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

instance.SendToAll(buffer, offset, count)
public void SendToAll(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public procedure SendToAll(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function SendToAll(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: void SendToAll(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
void SendToAll(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
The array containing message to be sent.
offset
The offset in the array where the binary message starts.
count
The number of bytes in the binary message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


SendToAll(WebSocketOutboundMessage) Method

SendToAll(WebSocketOutboundMessage) Method

Noemax.WebSockets Namespace > WebSocketService Class > SendToAll Method : SendToAll(WebSocketOutboundMessage) Method
The WebSocketOutboundMessage object representing the message.
Sends the message to all channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendToAll( _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocketService
Dim message As WebSocketOutboundMessage

instance.SendToAll(message)
public void SendToAll(
   WebSocketOutboundMessage message
)
public procedure SendToAll(
    message: WebSocketOutboundMessage
);
public function SendToAll(
   message : WebSocketOutboundMessage
);
public: void SendToAll(
   WebSocketOutboundMessage message
)
public:
void SendToAll(
   WebSocketOutboundMessage message
)

Parameters

message
The WebSocketOutboundMessage object representing the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


WaitForOutboundQueue Method (WebSocketService)

WaitForOutboundQueue Method (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : WaitForOutboundQueue Method
Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires.
Overload List
Overload | Description
WaitForOutboundQueue(TimeSpan) | Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires.
WaitForOutboundQueue(Int64,TimeSpan) | Blocks the current thread until outbound queues of each associated channel to decrease bellow specified size limit, or timeout expires.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


WaitForOutboundQueue(TimeSpan) Method

WaitForOutboundQueue(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketService Class > WaitForOutboundQueue Method : WaitForOutboundQueue(TimeSpan) Method
The amount of time to wait for outbound queues to decrease.
Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function WaitForOutboundQueue( _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocketService
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(timeout)
public System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    timeout: System.TimeSpan
): System.Boolean;
public function WaitForOutboundQueue(
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)
public:
System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)

Parameters

timeout
The amount of time to wait for outbound queues to decrease.

Return Value

True if outbound queues met the specified size limit within specified period of time.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


WaitForOutboundQueue(Int64,TimeSpan) Method

WaitForOutboundQueue(Int64,TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketService Class > WaitForOutboundQueue Method : WaitForOutboundQueue(Int64,TimeSpan) Method
The size the queue is expected to have at the end of the wait operation.
The amount of time to way for outbound queues to decrease.
Blocks the current thread until outbound queues of each associated channel to decrease bellow specified size limit, or timeout expires.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function WaitForOutboundQueue( _
   ByVal queueSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocketService
Dim queueSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(queueSize, timeout)
public System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    queueSize: System.Int64;
    timeout: System.TimeSpan
): System.Boolean;
public function WaitForOutboundQueue(
   queueSize : System.long,
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public:
System.bool WaitForOutboundQueue(
   System.int64 queueSize,
   System.TimeSpan timeout
)

Parameters

queueSize
The size the queue is expected to have at the end of the wait operation.
timeout
The amount of time to way for outbound queues to decrease.

Return Value

True if outbound queues met the specified size limit within specified period of time.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members
Overload List


WebSocketService Class Properties

WebSocketService Class Properties

Noemax.WebSockets Namespace : WebSocketService Class

For a list of all members of this type, see WebSocketService members.

Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance.
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages.
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages.
Public Property | TraceSource | Gets and sets TraceSource for tracing events.
Top
See Also

Reference

WebSocketService Class
Noemax.WebSockets Namespace


ChannelCount Property (WebSocketService)

ChannelCount Property (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : ChannelCount Property
Gets the number of channels associated to the service instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property ChannelCount As System.Integer
'Usage

Dim instance As WebSocketService
Dim value As System.Integer

value = instance.ChannelCount
public System.int ChannelCount {get;}
public read-only property ChannelCount: System.Integer;
public function get ChannelCount : System.int
public: __property System.int get_ChannelCount();
public:
property System.int ChannelCount {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


Encoding Property (WebSocketService)

Encoding Property (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : Encoding Property
Gets and sets the Encoding instance that is used for decoding text messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Encoding As System.Text.Encoding
'Usage

Dim instance As WebSocketService
Dim value As System.Text.Encoding

instance.Encoding = value

value = instance.Encoding
public System.Text.Encoding Encoding {get; set;}
public read-write property Encoding: System.Text.Encoding;
public function get,set Encoding : System.Text.Encoding
public: __property System.Text.Encoding* get_Encoding();
public: __property void set_Encoding(
   System.Text.Encoding* value
);
public:
property System.Text.Encoding^ Encoding {
   System.Text.Encoding^ get();
   void set (    System.Text.Encoding^ value);
}
Remarks
You can set this property your own Encoding if you want to change default UTF-8 decoding settings. By default this property is set to the static Encoding.UTF8 property value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


MaxReceivedMessageSize Property (WebSocketService)

MaxReceivedMessageSize Property (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : MaxReceivedMessageSize Property
Gets and sets the maximum message size limit for inbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxReceivedMessageSize As System.Long
'Usage

Dim instance As WebSocketService
Dim value As System.Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
public System.long MaxReceivedMessageSize {get; set;}
public read-write property MaxReceivedMessageSize: System.Int64;
public function get,set MaxReceivedMessageSize : System.long
public: __property System.long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   System.long value
);
public:
property System.int64 MaxReceivedMessageSize {
   System.int64 get();
   void set (    System.int64 value);
}
Remarks

This value applies to inbound messages when WebSocketService has to buffer message prior processing it, e.g. when messages is dispatched to OnMessage(WebSocketChannel,String) or OnMessage(WebSocketChannel,ArraySegment<Byte>) methods.

If message size exceeds the specified limit the error is reported through OnError while connection is closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


TraceSource Property (WebSocketService)

TraceSource Property (WebSocketService)

Noemax.WebSockets Namespace > WebSocketService Class : TraceSource Property
Gets and sets TraceSource for tracing events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketService
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketService Class
WebSocketService Members


WebSocketUsernamePasswordCredentials Class

WebSocketUsernamePasswordCredentials Class
Members

Noemax.WebSockets Namespace : WebSocketUsernamePasswordCredentials Class
Credentials used for basic client authentication using user-name and password.
Object Model
WebSocketUsernamePasswordCredentials Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketUsernamePasswordCredentials
'Usage

Dim instance As WebSocketUsernamePasswordCredentials
public class WebSocketUsernamePasswordCredentials
public class WebSocketUsernamePasswordCredentials
public class WebSocketUsernamePasswordCredentials
public __gc class WebSocketUsernamePasswordCredentials
public ref class WebSocketUsernamePasswordCredentials
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketUsernamePasswordCredentials

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketUsernamePasswordCredentials Members
Noemax.WebSockets Namespace


WebSocketUsernamePasswordCredentials Class Members

WebSocketUsernamePasswordCredentials Class Members
Properties

Noemax.WebSockets Namespace : WebSocketUsernamePasswordCredentials Class

The following tables list the members exposed by WebSocketUsernamePasswordCredentials.

Public Constructors
 | Name | Description
Public Constructor | WebSocketUsernamePasswordCredentials Constructor |
Top
Public Properties
 | Name | Description
Public Property | Password | The password associated to the user name.
Public Property | Username | The user name.
Top
See Also

Reference

WebSocketUsernamePasswordCredentials Class
Noemax.WebSockets Namespace


WebSocketUsernamePasswordCredentials Constructor

WebSocketUsernamePasswordCredentials Constructor

Noemax.WebSockets Namespace > WebSocketUsernamePasswordCredentials Class : WebSocketUsernamePasswordCredentials Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketUsernamePasswordCredentials()
public WebSocketUsernamePasswordCredentials()
public WebSocketUsernamePasswordCredentials();
public function WebSocketUsernamePasswordCredentials();
public: WebSocketUsernamePasswordCredentials();
public:
WebSocketUsernamePasswordCredentials();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketUsernamePasswordCredentials Class
WebSocketUsernamePasswordCredentials Members


WebSocketUsernamePasswordCredentials Class Properties

WebSocketUsernamePasswordCredentials Class Properties

Noemax.WebSockets Namespace : WebSocketUsernamePasswordCredentials Class

For a list of all members of this type, see WebSocketUsernamePasswordCredentials members.

Public Properties
 | Name | Description
Public Property | Password | The password associated to the user name.
Public Property | Username | The user name.
Top
See Also

Reference

WebSocketUsernamePasswordCredentials Class
Noemax.WebSockets Namespace


Password Property (WebSocketUsernamePasswordCredentials)

Password Property (WebSocketUsernamePasswordCredentials)

Noemax.WebSockets Namespace > WebSocketUsernamePasswordCredentials Class : Password Property
The password associated to the user name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Password As System.String
'Usage

Dim instance As WebSocketUsernamePasswordCredentials
Dim value As System.String

instance.Password = value

value = instance.Password
public System.string Password {get; set;}
public read-write property Password: System.String;
public function get,set Password : System.String
public: __property System.string* get_Password();
public: __property void set_Password(
   System.string* value
);
public:
property System.String^ Password {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketUsernamePasswordCredentials Class
WebSocketUsernamePasswordCredentials Members


Username Property (WebSocketUsernamePasswordCredentials)

Username Property (WebSocketUsernamePasswordCredentials)

Noemax.WebSockets Namespace > WebSocketUsernamePasswordCredentials Class : Username Property
The user name.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Username As System.String
'Usage

Dim instance As WebSocketUsernamePasswordCredentials
Dim value As System.String

instance.Username = value

value = instance.Username
public System.string Username {get; set;}
public read-write property Username: System.String;
public function get,set Username : System.String
public: __property System.string* get_Username();
public: __property void set_Username(
   System.string* value
);
public:
property System.String^ Username {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketUsernamePasswordCredentials Class
WebSocketUsernamePasswordCredentials Members


CompressionScheme Enumeration

CompressionScheme Enumeration

Noemax.WebSockets Namespace : CompressionScheme Enumeration
Specifies the compression scheme to be used by WebSocket.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CompressionScheme
   Inherits System.Enum
'Usage

Dim instance As CompressionScheme
public enum CompressionScheme : System.Enum
public enum CompressionScheme = class(System.Enum)
public enum CompressionScheme extends System.Enum
__value public enum CompressionScheme : public System.Enum
public enum class CompressionScheme : public System.Enum
Members
Member | Description
Auto | This compression scheme specifies that compression is to be negotiated with remote side automatically. Compression schemes that actually applied during communication will depend on local and remote side preferences. If remote side does not support any of available compression schemes, compression not will be used.
Deflate | DEFLATE compression method is applied only on the frame payload leaving frame headers uncompressed. This compression scheme is getting applied prior payload is masked and does not suffer from client to server payload masking, but benefit from the reusing compression state between frames.
Lzf4 | LZF4 compression method is applied only on the frame payload leaving frame headers uncompressed. This compression scheme is getting applied prior payload is masked and does not suffer from client to server payload masking, but benefit from the reusing compression state between frames.
None | No compression.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.CompressionScheme

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets Namespace


WebSocketHandshakeAction Enumeration

WebSocketHandshakeAction Enumeration

Noemax.WebSockets Namespace : WebSocketHandshakeAction Enumeration
Defines the action to take as outcome of WebSocketHandshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum WebSocketHandshakeAction
   Inherits System.Enum
'Usage

Dim instance As WebSocketHandshakeAction
public enum WebSocketHandshakeAction : System.Enum
public enum WebSocketHandshakeAction = class(System.Enum)
public enum WebSocketHandshakeAction extends System.Enum
__value public enum WebSocketHandshakeAction : public System.Enum
public enum class WebSocketHandshakeAction : public System.Enum
Members
Member | Description
Accept | Accept WebSocket handshake and proceed with WebSocket communication.
Drop | Refuse WebSocket handshake by dropping the Network connection.
HttpBadRequest | Refuse the handshake by sending the HTTP status code 400 "Bad Request". Applicable only on the server side.
HttpForbidden | Refuse the handshake by sending the HTTP status code 403 "Forbidden". Applicable only on the server side.
HttpGone | Refuse the handshake by sending the HTTP status code 410 Gone. Applicable only on the server side.
HttpNotFound | Refuse the handshake by sending the HTTP status code 404 "Not Found". Applicable only on the server side.
HttpRedirect | Redirect client connection to alternative address using HTTP status code 301 "Moved Permanently". Applicable only on the server side.
HttpServiceUnavailable | Refuse the handshake by sending the HTTP status code 503 "Service Unavailable". Applicable only on the server side.
HttpTemporaryRedirect | Redirect inbound connection to alternative address using HTTP status code 302 "Found". Applicable only on the server side.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.WebSocketHandshakeAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets Namespace


WebSocketMessageState Enumeration

WebSocketMessageState Enumeration

Noemax.WebSockets Namespace : WebSocketMessageState Enumeration
Specifies the state of the WebSocket message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum WebSocketMessageState
   Inherits System.Enum
'Usage

Dim instance As WebSocketMessageState
public enum WebSocketMessageState : System.Enum
public enum WebSocketMessageState = class(System.Enum)
public enum WebSocketMessageState extends System.Enum
__value public enum WebSocketMessageState : public System.Enum
public enum class WebSocketMessageState : public System.Enum
Members
Member | Description
Closed | Message is closed and should not be used anymore.
Created | Message was created but not yet sent.
Read | Message was read but not yet closed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.WebSocketMessageState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets Namespace


WebSocketMessageType Enumeration

WebSocketMessageType Enumeration

Noemax.WebSockets Namespace : WebSocketMessageType Enumeration
Specifies the type of the WebSocket message content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum WebSocketMessageType
   Inherits System.Enum
'Usage

Dim instance As WebSocketMessageType
public enum WebSocketMessageType : System.Enum
public enum WebSocketMessageType = class(System.Enum)
public enum WebSocketMessageType extends System.Enum
__value public enum WebSocketMessageType : public System.Enum
public enum class WebSocketMessageType : public System.Enum
Members
Member | Description
Binary | The content of the message is binary octets.
Text | The content of the message is UTF-8 encoded text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.WebSocketMessageType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets Namespace


WebSocketState Enumeration

WebSocketState Enumeration

Noemax.WebSockets Namespace : WebSocketState Enumeration
Defines the states of WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.FlagsAttribute()>
Public Enum WebSocketState
   Inherits System.Enum
'Usage

Dim instance As WebSocketState
[System.Flags()]
public enum WebSocketState : System.Enum
public enum WebSocketState = class(System.Enum)
System.FlagsAttribute()
public enum WebSocketState extends System.Enum
[System.Flags()]
__value public enum WebSocketState : public System.Enum
[System.Flags()]
public enum class WebSocketState : public System.Enum
Members
Member | Description
Connected | WebSocket is connected and can send and receive message.
Error | WebSocket connection closed due to error.
Initial | WebSocket is created but not connected to any endpoint yet.
InputClosed | WebSocket is connected but does not receive messages because it received the close frame from remote endpoint.
OutputClosed | WebSocket is connected but cannot send messages because close frame was already sent to remote endpoint.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.WebSocketState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets Namespace


WebSocketOutboundMessage Structure

WebSocketOutboundMessage Structure
Members

Noemax.WebSockets Namespace : WebSocketOutboundMessage Structure
Represents the buffered message to be sent though WebSocket connection.
Object Model
WebSocketOutboundMessage Structure
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Structure WebSocketOutboundMessage
   Inherits System.ValueType
'Usage

Dim instance As WebSocketOutboundMessage
public struct WebSocketOutboundMessage : System.ValueType
public type WebSocketOutboundMessage = class(System.ValueType)
In JScript, you can use structures in other assemblies, but you cannot define your own.
public __value struct WebSocketOutboundMessage : public System.ValueType
public value class WebSocketOutboundMessage : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
Noemax.WebSockets.WebSocketOutboundMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Members
Noemax.WebSockets Namespace


WebSocketOutboundMessage Structure Members

WebSocketOutboundMessage Structure Members
Properties

Noemax.WebSockets Namespace : WebSocketOutboundMessage Structure

The following tables list the members exposed by WebSocketOutboundMessage.

Public Constructors
 | Name | Description
Public Constructor | WebSocketOutboundMessage Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Buffer | Gets the buffer representing the payload of the message.
Public Property | Count | Gets or sets the size of the message payload in bytes.
Public Property | Offset | Gets the index on the first byte of the message payload in the buffer.
Public Property | Type | Gets and sets the WebSocketMessageType of the message.
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. Performs an implicit conversion from System.String to WebSocketOutboundMessage.
Top
See Also

Reference

WebSocketOutboundMessage Structure
Noemax.WebSockets Namespace


WebSocketOutboundMessage Constructor

WebSocketOutboundMessage Constructor

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : WebSocketOutboundMessage Constructor
Overload List
Overload | Description
WebSocketOutboundMessage Constructor(WebSocketInboundMessage,Int32) | Initializes a new instance of the WebSocketOutboundMessage from the instance of WebSocketInboundMessage.
WebSocketOutboundMessage Constructor(String) | Initializes a new instance of the WebSocketOutboundMessage struck.
WebSocketOutboundMessage Constructor(Byte[]) | Initializes a new instance of the WebSocketOutboundMessage struck.
WebSocketOutboundMessage Constructor(ArraySegment<Byte>) | Initializes a new instance of the WebSocketOutboundMessage struck.
WebSocketOutboundMessage Constructor(Byte[],Int32,Int32) | Initializes a new instance of the WebSocketOutboundMessage struck.
WebSocketOutboundMessage Constructor(WebSocketMessageType,Byte[],Int32,Int32) | Initialize a new instance of the WebSocketOutboundMessage either with binary or with text message opCode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


WebSocketOutboundMessage Constructor(WebSocketInboundMessage,Int32)

WebSocketOutboundMessage Constructor(WebSocketInboundMessage,Int32)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(WebSocketInboundMessage,Int32)
The inbound message.
The maximum number of inbound byte to receive when producing outbound message.
Initializes a new instance of the WebSocketOutboundMessage from the instance of WebSocketInboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal inboundMessage As WebSocketInboundMessage, _
   ByVal maxReceivedMessageSize As System.Integer _
)
'Usage

Dim inboundMessage As WebSocketInboundMessage
Dim maxReceivedMessageSize As System.Integer

Dim instance As New WebSocketOutboundMessage(inboundMessage, maxReceivedMessageSize)
public WebSocketOutboundMessage(
   WebSocketInboundMessage inboundMessage,
   System.int maxReceivedMessageSize
)
public WebSocketOutboundMessage(
    inboundMessage: WebSocketInboundMessage;
    maxReceivedMessageSize: System.Integer
);
public function WebSocketOutboundMessage(
   inboundMessage : WebSocketInboundMessage,
   maxReceivedMessageSize : System.int
);
public: WebSocketOutboundMessage(
   WebSocketInboundMessage* inboundMessage,
   System.int maxReceivedMessageSize
)
public:
WebSocketOutboundMessage(
   WebSocketInboundMessage^ inboundMessage,
   System.int maxReceivedMessageSize
)

Parameters

inboundMessage
The inbound message.
maxReceivedMessageSize
The maximum number of inbound byte to receive when producing outbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Constructor(String)

WebSocketOutboundMessage Constructor(String)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(String)
The text.
Initializes a new instance of the WebSocketOutboundMessage struck.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal text As System.String _
)
'Usage

Dim text As System.String

Dim instance As New WebSocketOutboundMessage(text)
public WebSocketOutboundMessage(
   System.string text
)
public WebSocketOutboundMessage(
    text: System.String
);
public function WebSocketOutboundMessage(
   text : System.String
);
public: WebSocketOutboundMessage(
   System.string* text
)
public:
WebSocketOutboundMessage(
   System.String^ text
)

Parameters

text
The text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Constructor(Byte[])

WebSocketOutboundMessage Constructor(Byte[])

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(Byte[])
The buffer.
Initializes a new instance of the WebSocketOutboundMessage struck.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal buffer() As System.Byte _
)
'Usage

Dim buffer() As System.Byte

Dim instance As New WebSocketOutboundMessage(buffer)
public WebSocketOutboundMessage(
   System.byte[] buffer
)
public WebSocketOutboundMessage(
    buffer: System.Bytearray of
);
public function WebSocketOutboundMessage(
   buffer : System.byte[]
);
public: WebSocketOutboundMessage(
   System.byte[]* buffer
)
public:
WebSocketOutboundMessage(
   System.array<byte>^ buffer
)

Parameters

buffer
The buffer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Constructor(ArraySegment<Byte>)

WebSocketOutboundMessage Constructor(ArraySegment<Byte>)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(ArraySegment<Byte>)
The buffer.
Initializes a new instance of the WebSocketOutboundMessage struck.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal buffer As System.ArraySegment(Of Byte) _
)
'Usage

Dim buffer As System.ArraySegment(Of Byte)

Dim instance As New WebSocketOutboundMessage(buffer)
public WebSocketOutboundMessage(
   System.ArraySegment<byte> buffer
)
public WebSocketOutboundMessage(
    buffer: System.ArraySegment
);
public function WebSocketOutboundMessage(
   buffer : System.ArraySegment
);
public: WebSocketOutboundMessage(
   System.ArraySegment<byte> buffer
)
public:
WebSocketOutboundMessage(
   System.ArraySegment<byte> buffer
)

Parameters

buffer
The buffer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Constructor(Byte[],Int32,Int32)

WebSocketOutboundMessage Constructor(Byte[],Int32,Int32)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(Byte[],Int32,Int32)
The buffer.
The offset.
The count.
Initializes a new instance of the WebSocketOutboundMessage struck.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

Dim instance As New WebSocketOutboundMessage(buffer, offset, count)
public WebSocketOutboundMessage(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public WebSocketOutboundMessage(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function WebSocketOutboundMessage(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: WebSocketOutboundMessage(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
WebSocketOutboundMessage(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
The buffer.
offset
The offset.
count
The count.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Constructor(WebSocketMessageType,Byte[],Int32,Int32)

WebSocketOutboundMessage Constructor(WebSocketMessageType,Byte[],Int32,Int32)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > WebSocketOutboundMessage Constructor : WebSocketOutboundMessage Constructor(WebSocketMessageType,Byte[],Int32,Int32)
The WebSocketMessageType indicating the binary or text message.
The array containing bytes of the message payload.
The offset in array where message payload starts.
The number of bytes that represent a message payload.
Initialize a new instance of the WebSocketOutboundMessage either with binary or with text message opCode.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal type As WebSocketMessageType, _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim type As WebSocketMessageType
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

Dim instance As New WebSocketOutboundMessage(type, buffer, offset, count)
public WebSocketOutboundMessage(
   WebSocketMessageType type,
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public WebSocketOutboundMessage(
    type: WebSocketMessageType;
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function WebSocketOutboundMessage(
   type : WebSocketMessageType,
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: WebSocketOutboundMessage(
   WebSocketMessageType type,
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
WebSocketOutboundMessage(
   WebSocketMessageType type,
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

type
The WebSocketMessageType indicating the binary or text message.
buffer
The array containing bytes of the message payload.
offset
The offset in array where message payload starts.
count
The number of bytes that represent a message payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketOutboundMessage Structure Properties

WebSocketOutboundMessage Structure Properties

Noemax.WebSockets Namespace : WebSocketOutboundMessage Structure

For a list of all members of this type, see WebSocketOutboundMessage members.

Public Properties
 | Name | Description
Public Property | Buffer | Gets the buffer representing the payload of the message.
Public Property | Count | Gets or sets the size of the message payload in bytes.
Public Property | Offset | Gets the index on the first byte of the message payload in the buffer.
Public Property | Type | Gets and sets the WebSocketMessageType of the message.
Top
See Also

Reference

WebSocketOutboundMessage Structure
Noemax.WebSockets Namespace


Buffer Property (WebSocketOutboundMessage)

Buffer Property (WebSocketOutboundMessage)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : Buffer Property
Gets the buffer representing the payload of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Buffer As System.Byte()
'Usage

Dim instance As WebSocketOutboundMessage
Dim value() As System.Byte

value = instance.Buffer
public System.byte[] Buffer {get;}
public read-only property Buffer: System.array of Byte;
public function get Buffer : System.byte[]
public: __property System.byte[]* get_Buffer();
public:
property System.array<byte>^ Buffer {
   System.array<byte>^ get();
}

Property Value

The array of bytes containing the payload of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


Count Property (WebSocketOutboundMessage)

Count Property (WebSocketOutboundMessage)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : Count Property
Gets or sets the size of the message payload in bytes.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As WebSocketOutboundMessage
Dim value As System.Integer

value = instance.Count
public System.int Count {get;}
public read-only property Count: System.Integer;
public function get Count : System.int
public: __property System.int get_Count();
public:
property System.int Count {
   System.int get();
}

Property Value

The size of the message payload in bytes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


Offset Property (WebSocketOutboundMessage)

Offset Property (WebSocketOutboundMessage)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : Offset Property
Gets the index on the first byte of the message payload in the buffer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Offset As System.Integer
'Usage

Dim instance As WebSocketOutboundMessage
Dim value As System.Integer

value = instance.Offset
public System.int Offset {get;}
public read-only property Offset: System.Integer;
public function get Offset : System.int
public: __property System.int get_Offset();
public:
property System.int Offset {
   System.int get();
}

Property Value

The index of the first byte of the message payload in the buffer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


Type Property (WebSocketOutboundMessage)

Type Property (WebSocketOutboundMessage)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : Type Property
Gets and sets the WebSocketMessageType of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Type As WebSocketMessageType
'Usage

Dim instance As WebSocketOutboundMessage
Dim value As WebSocketMessageType

instance.Type = value

value = instance.Type
public WebSocketMessageType Type {get; set;}
public read-write property Type: WebSocketMessageType;
public function get,set Type : WebSocketMessageType
public: __property WebSocketMessageType get_Type();
public: __property void set_Type(
   WebSocketMessageType value
);
public:
property WebSocketMessageType Type {
   WebSocketMessageType get();
   void set (    WebSocketMessageType value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


Implicit Type Conversion Operator (WebSocketOutboundMessage)

Implicit Type Conversion Operator (WebSocketOutboundMessage)

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure : Implicit Type Conversion Operator
Performs an implicit conversion from System.String to WebSocketOutboundMessage.
Overload List
Overload | Description
Implicit Type Conversion(WebSocketOutboundMessage,String) | Performs an implicit conversion from System.String to WebSocketOutboundMessage.
Implicit Type Conversion(WebSocketOutboundMessage,Byte[]) | Performs an implicit conversion from array of bytes to WebSocketOutboundMessage.
Implicit Type Conversion(WebSocketOutboundMessage,ArraySegment<Byte>) | Performs an implicit conversion from array of bytes to WebSocketOutboundMessage.
Implicit Type Conversion(WebSocketOutboundMessage,WebSocketInboundMessage) | Performs an implicit conversion from WebSocketInboundMessage to WebSocketOutboundMessage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members


IWebSockets Interface

IWebSockets Interface
Members

Noemax.WebSockets Namespace : IWebSockets Interface
Defines the contract that a service must implement in order to receive message and manage connections.
Object Model
IWebSockets Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IWebSockets
'Usage

Dim instance As IWebSockets
public interface IWebSockets
public interface IWebSockets
public interface IWebSockets
public __gc __interface IWebSockets
public interface class IWebSockets
Remarks

It preferable to use WebSocketService as the base class for service implementation, rather than implementing the IWebSockets interface, WebSocketService implements most of the methods defined by IWebSockets and provides most of required functionality. You need to implemented IWebSockets interface only if have to provide completely custom message processing, dispatching and connection management.

Methods of IWebSocket are being called by working threads that handle inbound messages and connections. It should be expected that multiple threads can call a same instance of IWebSockets concurrently.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Members
Noemax.WebSockets Namespace


IWebSockets Interface Members

IWebSockets Interface Members
Methods

Noemax.WebSockets Namespace : IWebSockets Interface

The following tables list the members exposed by IWebSockets.

Public Methods
 | Name | Description
Method | GetProperty<T> |
Method | OnClose | This method is called when a channel is being closed.
Method | OnError | This method is called when a channel encounters an error.
Method | OnHandshake | The method is called during the WebSocket handshake.
Method | OnMessage | This method is called when an inbound message is being received.
Method | OnOpen | This method is called when a new channel being open.
Method | OnPing | This method is called when an inbound PING frame is received.
Method | OnPong | This method is called when an inbound PONG frame is received.
Top
See Also

Reference

IWebSockets Interface
Noemax.WebSockets Namespace


IWebSockets Interface Methods

IWebSockets Interface Methods

Noemax.WebSockets Namespace : IWebSockets Interface

For a list of all members of this type, see IWebSockets members.

Public Methods
 | Name | Description
Method | GetProperty<T> |
Method | OnClose | This method is called when a channel is being closed.
Method | OnError | This method is called when a channel encounters an error.
Method | OnHandshake | The method is called during the WebSocket handshake.
Method | OnMessage | This method is called when an inbound message is being received.
Method | OnOpen | This method is called when a new channel being open.
Method | OnPing | This method is called when an inbound PING frame is received.
Method | OnPong | This method is called when an inbound PONG frame is received.
Top
See Also

Reference

IWebSockets Interface
Noemax.WebSockets Namespace


GetProperty<T> Method (IWebSockets)

GetProperty<T> Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : GetProperty<T> Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function GetProperty(Of T)() As T
'Usage

Dim instance As IWebSockets
Dim value As T

value = instance.GetProperty(Of T)()
T GetProperty<T>()
function GetProperty(): T;
function GetProperty() : T;
T* GetProperty<T>();
T^ GetPropertygeneric<typename T>
();

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnClose Method (IWebSockets)

OnClose Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnClose Method
The channel being closed.
The status code provided by the remote side to identify the reason for closing the connection.
The text description of the status code.
This method is called when a channel is being closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnClose( _
   ByVal channel As WebSocketChannel, _
   ByVal statusCode As System.Short, _
   ByVal reason As System.String _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel
Dim statusCode As System.Short
Dim reason As System.String

instance.OnClose(channel, statusCode, reason)
void OnClose(
   WebSocketChannel channel,
   System.short statusCode,
   System.string reason
)
procedure OnClose(
    channel: WebSocketChannel;
    statusCode: System.Int16;
    reason: System.String
);
function OnClose(
   channel : WebSocketChannel,
   statusCode : System.short,
   reason : System.String
);
void OnClose(
   WebSocketChannel* channel,
   System.short statusCode,
   System.string* reason
)
void OnClose(
   WebSocketChannel^ channel,
   System.short statusCode,
   System.String^ reason
)

Parameters

channel
The channel being closed.
statusCode
The status code provided by the remote side to identify the reason for closing the connection.
reason
The text description of the status code.
Remarks

If the connection is being closed due to receiving a CLOSE control frame from the remote side, the statusCode and reason parameters may contain information provided by the remote side to identify the reason for closing the connection.

When this method is called, messages might still be sent successfully to the remote side for a short period of time. However, no more messages are expected to be received from the remote side.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnError Method (IWebSockets)

OnError Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnError Method
The channel that encounters the error.
The exception related to the error.
This method is called when a channel encounters an error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnError( _
   ByVal channel As WebSocketChannel, _
   ByVal e As System.Exception _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel
Dim e As System.Exception

instance.OnError(channel, e)
void OnError(
   WebSocketChannel channel,
   System.Exception e
)
procedure OnError(
    channel: WebSocketChannel;
    e: System.Exception
);
function OnError(
   channel : WebSocketChannel,
   e : System.Exception
);
void OnError(
   WebSocketChannel* channel,
   System.Exception* e
)
void OnError(
   WebSocketChannel^ channel,
   System.Exception^ e
)

Parameters

channel
The channel that encounters the error.
e
The exception related to the error.
Remarks
All errors encountered by the channel during sending/receiving/dispatching messages are reported through this method. The channel that encountered the error is not necessary disconnected or closed, use the WebSocketChannel.Connected property to determine the status of the channel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnHandshake Method (IWebSockets)

OnHandshake Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnHandshake Method
The initiator of event that performs WebSocket handshake on local endpoint.
The WebSocketHandshake instance.
The method is called during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnHandshake( _
   ByVal sender As System.Object, _
   ByVal handshake As WebSocketHandshake _
)
'Usage

Dim instance As IWebSockets
Dim sender As System.Object
Dim handshake As WebSocketHandshake

instance.OnHandshake(sender, handshake)
void OnHandshake(
   System.object sender,
   WebSocketHandshake handshake
)
procedure OnHandshake(
    sender: System.TObject;
    handshake: WebSocketHandshake
);
function OnHandshake(
   sender : System.Object,
   handshake : WebSocketHandshake
);
void OnHandshake(
   System.Object* sender,
   WebSocketHandshake* handshake
)
void OnHandshake(
   System.Object^ sender,
   WebSocketHandshake^ handshake
)

Parameters

sender
The initiator of event that performs WebSocket handshake on local endpoint.
handshake
The WebSocketHandshake instance.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnMessage Method (IWebSockets)

OnMessage Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnMessage Method
The channel through which the inbound message is being received.
The inbound message being received.
This method is called when an inbound message is being received.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal message As WebSocketInboundMessage _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel
Dim message As WebSocketInboundMessage

instance.OnMessage(channel, message)
void OnMessage(
   WebSocketChannel channel,
   WebSocketInboundMessage message
)
procedure OnMessage(
    channel: WebSocketChannel;
    message: WebSocketInboundMessage
);
function OnMessage(
   channel : WebSocketChannel,
   message : WebSocketInboundMessage
);
void OnMessage(
   WebSocketChannel* channel,
   WebSocketInboundMessage* message
)
void OnMessage(
   WebSocketChannel^ channel,
   WebSocketInboundMessage^ message
)

Parameters

channel
The channel through which the inbound message is being received.
message
The inbound message being received.
Remarks
WebSocket working thread does not buffer entire message prior calling this method, WebSocketInboundMessage provides the methods to either buffer the message prior consuming it or to consume it as a input.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnOpen Method (IWebSockets)

OnOpen Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnOpen Method
The channel being open.
This method is called when a new channel being open.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnOpen( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel

instance.OnOpen(channel)
void OnOpen(
   WebSocketChannel channel
)
procedure OnOpen(
    channel: WebSocketChannel
);
function OnOpen(
   channel : WebSocketChannel
);
void OnOpen(
   WebSocketChannel* channel
)
void OnOpen(
   WebSocketChannel^ channel
)

Parameters

channel
The channel being open.
Remarks
Both on the server and on the client side this method is called when connection from the client to the server is established and WebSocket handshake is complete.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnPing Method (IWebSockets)

OnPing Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnPing Method
The channel through which the inbound PING frame was received.
The payload of the PING frame.
This method is called when an inbound PING frame is received.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnPing( _
   ByVal channel As WebSocketChannel, _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel
Dim payload As System.ArraySegment(Of Byte)

instance.OnPing(channel, payload)
void OnPing(
   WebSocketChannel channel,
   System.ArraySegment<byte> payload
)
procedure OnPing(
    channel: WebSocketChannel;
    payload: System.ArraySegment
);
function OnPing(
   channel : WebSocketChannel,
   payload : System.ArraySegment
);
void OnPing(
   WebSocketChannel* channel,
   System.ArraySegment<byte> payload
)
void OnPing(
   WebSocketChannel^ channel,
   System.ArraySegment<byte> payload
)

Parameters

channel
The channel through which the inbound PING frame was received.
payload
The payload of the PING frame.
Remarks
PONG reply is sent automatically unless connection is closed during the call to the OnPing method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


OnPong Method (IWebSockets)

OnPong Method (IWebSockets)

Noemax.WebSockets Namespace > IWebSockets Interface : OnPong Method
The channel through which the inbound PONG frame was received.
The payload of the PONG frame.
This method is called when an inbound PONG frame is received.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub OnPong( _
   ByVal channel As WebSocketChannel, _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As IWebSockets
Dim channel As WebSocketChannel
Dim payload As System.ArraySegment(Of Byte)

instance.OnPong(channel, payload)
void OnPong(
   WebSocketChannel channel,
   System.ArraySegment<byte> payload
)
procedure OnPong(
    channel: WebSocketChannel;
    payload: System.ArraySegment
);
function OnPong(
   channel : WebSocketChannel,
   payload : System.ArraySegment
);
void OnPong(
   WebSocketChannel* channel,
   System.ArraySegment<byte> payload
)
void OnPong(
   WebSocketChannel^ channel,
   System.ArraySegment<byte> payload
)

Parameters

channel
The channel through which the inbound PONG frame was received.
payload
The payload of the PONG frame.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IWebSockets Interface
IWebSockets Members


WebSocketHandshakeEventHandler Delegate

WebSocketHandshakeEventHandler Delegate

Noemax.WebSockets Namespace : WebSocketHandshakeEventHandler Delegate
The sender of event.
WebSocketHandshake representing event data.
Represents a method handing the WebSocket handshake event.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub WebSocketHandshakeEventHandler( _
   ByVal sender As System.Object, _
   ByVal args As WebSocketHandshake _
)
'Usage

Dim instance As New WebSocketHandshakeEventHandler(AddressOf HandlerMethod)
public delegate void WebSocketHandshakeEventHandler(
   System.object sender,
   WebSocketHandshake args
)
public delegate WebSocketHandshakeEventHandler(
    sender: System.TObject;
    args: WebSocketHandshake
);
public delegate WebSocketHandshakeEventHandler(
   sender : System.Object,
   args : WebSocketHandshake
)
public: __gc __delegate void WebSocketHandshakeEventHandler(
   System.Object* sender,
   WebSocketHandshake* args
)
public delegate void WebSocketHandshakeEventHandler(
   System.Object^ sender,
   WebSocketHandshake^ args
)

Parameters

sender
The sender of event.
args
WebSocketHandshake representing event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketHandshakeEventHandler Members
Noemax.WebSockets Namespace


Noemax.WebSockets.Core Namespace (Noemax.WebSockets)

Noemax.WebSockets.Core Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | ControlFrameEventArgs | The event argument used by control frame related events of WebSocket.
Class | UsernamePasswordAuthenticateEventArgs | Argument for event generated during Basic HTTP authentication.
Class | WebSocket | Provides methods and properties for sending and receiving messages through WebSocket connection.
Class | WebSocketClientSecurity | Provides properties that apply when SSL/TLS transport security is enabled.
Class | WebSocketCloseCodes | Defines the constants to be used with for sending the WebSocket close frame status code that define the reason for closing the connection.
Class | WebSocketCloseEventArgs | Provides methods and properties for the close event arguments.
Class | WebSocketErrorEventArgs | Provides methods and properties for error event arguments.
Class | WebSocketFactory | Creates and manages client WebSocket connections.
Class | WebSocketListener | Listens on WebSockets endpoints, accepts and manages WebSocket connections.
Class | WebSocketMessageInputStream | Expose a WebSocket message as a input and provides methods and properties for streaming WebSocket messages.
Class | WebSocketPingOrPongEventArgs | Provides methods and properties for Pong event handler arguments.
Delegates
 | Delegate | Description
Delegate | UsernamePasswordAuthenticateEventHandler | Represents a methods that will be handling the username/password authentication.
Delegate | X509CertificateValidationCallback | The callback delegate providing the remote X509 certificate validation.
Enumerations
 | Enumeration | Description
Enumeration | KeepaliveMode |
See Also

Reference

Noemax.WebSockets Assembly


ControlFrameEventArgs Class

ControlFrameEventArgs Class
Members

Noemax.WebSockets.Core Namespace : ControlFrameEventArgs Class
The event argument used by control frame related events of WebSocket.
Object Model
ControlFrameEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ControlFrameEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As ControlFrameEventArgs
public class ControlFrameEventArgs : System.EventArgs
public class ControlFrameEventArgs = class(System.EventArgs)
public class ControlFrameEventArgs extends System.EventArgs
public __gc class ControlFrameEventArgs : public System.EventArgs
public ref class ControlFrameEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.Core.ControlFrameEventArgs
Noemax.WebSockets.Core.WebSocketCloseEventArgs
Noemax.WebSockets.Core.WebSocketPingOrPongEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Members
Noemax.WebSockets.Core Namespace


ControlFrameEventArgs Class Members

ControlFrameEventArgs Class Members
Properties

Noemax.WebSockets.Core Namespace : ControlFrameEventArgs Class

The following tables list the members exposed by ControlFrameEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ControlFrameEventArgs Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | OpCode | Gets the OpCode associated to the control frame.
Public Property | Payload | Get the payload associated to the control frame.
Top
See Also

Reference

ControlFrameEventArgs Class
Noemax.WebSockets.Core Namespace


ControlFrameEventArgs Constructor

ControlFrameEventArgs Constructor

Noemax.WebSockets.Core Namespace > ControlFrameEventArgs Class : ControlFrameEventArgs Constructor
Overload List
Overload | Description
ControlFrameEventArgs Constructor() | Initialize a new instance of ControlFrameEventArgs.
ControlFrameEventArgs Constructor(WebSocket,Byte,ArraySegment<Byte>) | Initialize a new instance of ControlFrameEventArgs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Class
ControlFrameEventArgs Members


ControlFrameEventArgs Constructor()

ControlFrameEventArgs Constructor()

Noemax.WebSockets.Core Namespace > ControlFrameEventArgs Class > ControlFrameEventArgs Constructor : ControlFrameEventArgs Constructor()
Initialize a new instance of ControlFrameEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ControlFrameEventArgs()
public ControlFrameEventArgs()
public ControlFrameEventArgs();
public function ControlFrameEventArgs();
public: ControlFrameEventArgs();
public:
ControlFrameEventArgs();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Class
ControlFrameEventArgs Members
Overload List


ControlFrameEventArgs Constructor(WebSocket,Byte,ArraySegment<Byte>)

ControlFrameEventArgs Constructor(WebSocket,Byte,ArraySegment<Byte>)

Noemax.WebSockets.Core Namespace > ControlFrameEventArgs Class > ControlFrameEventArgs Constructor : ControlFrameEventArgs Constructor(WebSocket,Byte,ArraySegment<Byte>)
The WebSocket that received the control frame.
The opcode value in the control frame header.
Initialize a new instance of ControlFrameEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function New( _
   ByVal socket As WebSocket, _
   ByVal opcode As System.Byte, _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim socket As WebSocket
Dim opcode As System.Byte
Dim payload As System.ArraySegment(Of Byte)

Dim instance As New ControlFrameEventArgs(socket, opcode, payload)
protected ControlFrameEventArgs(
   WebSocket socket,
   System.byte opcode,
   System.ArraySegment<byte> payload
)
protected ControlFrameEventArgs(
    socket: WebSocket;
    opcode: System.Byte;
    payload: System.ArraySegment
);
protected function ControlFrameEventArgs(
   socket : WebSocket,
   opcode : System.byte,
   payload : System.ArraySegment
);
protected: ControlFrameEventArgs(
   WebSocket* socket,
   System.byte opcode,
   System.ArraySegment<byte> payload
)
protected:
ControlFrameEventArgs(
   WebSocket^ socket,
   System.byte opcode,
   System.ArraySegment<byte> payload
)

Parameters

socket
The WebSocket that received the control frame.
opcode
The opcode value in the control frame header.
payload
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Class
ControlFrameEventArgs Members
Overload List


ControlFrameEventArgs Class Properties

ControlFrameEventArgs Class Properties

Noemax.WebSockets.Core Namespace : ControlFrameEventArgs Class

For a list of all members of this type, see ControlFrameEventArgs members.

Public Properties
 | Name | Description
Public Property | OpCode | Gets the OpCode associated to the control frame.
Public Property | Payload | Get the payload associated to the control frame.
Top
See Also

Reference

ControlFrameEventArgs Class
Noemax.WebSockets.Core Namespace


OpCode Property (ControlFrameEventArgs)

OpCode Property (ControlFrameEventArgs)

Noemax.WebSockets.Core Namespace > ControlFrameEventArgs Class : OpCode Property
Gets the OpCode associated to the control frame.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OpCode As System.Byte
'Usage

Dim instance As ControlFrameEventArgs
Dim value As System.Byte

value = instance.OpCode
public System.byte OpCode {get;}
public read-only property OpCode: System.Byte;
public function get OpCode : System.byte
public: __property System.byte get_OpCode();
public:
property System.byte OpCode {
   System.byte get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Class
ControlFrameEventArgs Members


Payload Property (ControlFrameEventArgs)

Payload Property (ControlFrameEventArgs)

Noemax.WebSockets.Core Namespace > ControlFrameEventArgs Class : Payload Property
Get the payload associated to the control frame.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Payload As System.ArraySegment(Of Byte)
'Usage

Dim instance As ControlFrameEventArgs
Dim value As System.ArraySegment(Of Byte)

value = instance.Payload
public System.ArraySegment<byte> Payload {get;}
public read-only property Payload: System.ArraySegment;
public function get Payload : System.ArraySegment
public: __property System.ArraySegment<byte> get_Payload();
public:
property System.ArraySegment<byte> Payload {
   System.ArraySegment<byte> get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ControlFrameEventArgs Class
ControlFrameEventArgs Members


UsernamePasswordAuthenticateEventArgs Class

UsernamePasswordAuthenticateEventArgs Class
Members

Noemax.WebSockets.Core Namespace : UsernamePasswordAuthenticateEventArgs Class
Argument for event generated during Basic HTTP authentication.
Object Model
UsernamePasswordAuthenticateEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class UsernamePasswordAuthenticateEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs
public class UsernamePasswordAuthenticateEventArgs : System.EventArgs
public class UsernamePasswordAuthenticateEventArgs = class(System.EventArgs)
public class UsernamePasswordAuthenticateEventArgs extends System.EventArgs
public __gc class UsernamePasswordAuthenticateEventArgs : public System.EventArgs
public ref class UsernamePasswordAuthenticateEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.Core.UsernamePasswordAuthenticateEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Members
Noemax.WebSockets.Core Namespace


UsernamePasswordAuthenticateEventArgs Class Members

UsernamePasswordAuthenticateEventArgs Class Members
Properties Methods

Noemax.WebSockets.Core Namespace : UsernamePasswordAuthenticateEventArgs Class

The following tables list the members exposed by UsernamePasswordAuthenticateEventArgs.

Public Constructors
 | Name | Description
Public Constructor | UsernamePasswordAuthenticateEventArgs Constructor | Creates a new instance of UsernamePasswordAuthenticateEventArgs.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | The object representing the context assigned to the WebSocket connection during authentication.
Public Property | Password | The password presented by remote endpoint.
Public Property | Username | The username presented by the remote endpoint.
Top
Public Methods
 | Name | Description
Public Method | Accept | Accepts the Username/Password credentials provided by the client connection.
Public Method | Fail | Fails Username/Password authentication and throws SecurityTokenException.
Top
See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
Noemax.WebSockets.Core Namespace


UsernamePasswordAuthenticateEventArgs Constructor

UsernamePasswordAuthenticateEventArgs Constructor

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : UsernamePasswordAuthenticateEventArgs Constructor
The username.
The password.
Creates a new instance of UsernamePasswordAuthenticateEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal username As System.String, _
   ByVal password As System.String _
)
'Usage

Dim username As System.String
Dim password As System.String

Dim instance As New UsernamePasswordAuthenticateEventArgs(username, password)
public UsernamePasswordAuthenticateEventArgs(
   System.string username,
   System.string password
)
public UsernamePasswordAuthenticateEventArgs(
    username: System.String;
    password: System.String
);
public function UsernamePasswordAuthenticateEventArgs(
   username : System.String,
   password : System.String
);
public: UsernamePasswordAuthenticateEventArgs(
   System.string* username,
   System.string* password
)
public:
UsernamePasswordAuthenticateEventArgs(
   System.String^ username,
   System.String^ password
)

Parameters

username
The username.
password
The password.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


UsernamePasswordAuthenticateEventArgs Class Methods

UsernamePasswordAuthenticateEventArgs Class Methods

Noemax.WebSockets.Core Namespace : UsernamePasswordAuthenticateEventArgs Class

For a list of all members of this type, see UsernamePasswordAuthenticateEventArgs members.

Public Methods
 | Name | Description
Public Method | Accept | Accepts the Username/Password credentials provided by the client connection.
Public Method | Fail | Fails Username/Password authentication and throws SecurityTokenException.
Top
See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
Noemax.WebSockets.Core Namespace


Accept Method (UsernamePasswordAuthenticateEventArgs)

Accept Method (UsernamePasswordAuthenticateEventArgs)

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : Accept Method
Accepts the Username/Password credentials provided by the client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Accept()
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs

instance.Accept()
public void Accept()
public procedure Accept();
public function Accept();
public: void Accept();
public:
void Accept();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


Fail Method (UsernamePasswordAuthenticateEventArgs)

Fail Method (UsernamePasswordAuthenticateEventArgs)

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : Fail Method
Fails Username/Password authentication and throws SecurityTokenException.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Fail()
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs

instance.Fail()
public void Fail()
public procedure Fail();
public function Fail();
public: void Fail();
public:
void Fail();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


UsernamePasswordAuthenticateEventArgs Class Properties

UsernamePasswordAuthenticateEventArgs Class Properties

Noemax.WebSockets.Core Namespace : UsernamePasswordAuthenticateEventArgs Class

For a list of all members of this type, see UsernamePasswordAuthenticateEventArgs members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | The object representing the context assigned to the WebSocket connection during authentication.
Public Property | Password | The password presented by remote endpoint.
Public Property | Username | The username presented by the remote endpoint.
Top
See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
Noemax.WebSockets.Core Namespace


AuthenticationContext Property (UsernamePasswordAuthenticateEventArgs)

AuthenticationContext Property (UsernamePasswordAuthenticateEventArgs)

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : AuthenticationContext Property
The object representing the context assigned to the WebSocket connection during authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property AuthenticationContext As System.Object
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs
Dim value As System.Object

instance.AuthenticationContext = value

value = instance.AuthenticationContext
public System.object AuthenticationContext {get; set;}
public read-write property AuthenticationContext: System.TObject;
public function get,set AuthenticationContext : System.Object
public: __property System.Object* get_AuthenticationContext();
public: __property void set_AuthenticationContext(
   System.Object* value
);
public:
property System.Object^ AuthenticationContext {
   System.Object^ get();
   void set (    System.Object^ value);
}
Remarks
You can set this property to the context value that you want to associate to the connection once it authenticated. For example you can set this property to the Username string or any other state object that is geting established during authentication.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


Password Property (UsernamePasswordAuthenticateEventArgs)

Password Property (UsernamePasswordAuthenticateEventArgs)

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : Password Property
The password presented by remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Password As System.String
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs
Dim value As System.String

value = instance.Password
public System.string Password {get;}
public read-only property Password: System.String;
public function get Password : System.String
public: __property System.string* get_Password();
public:
property System.String^ Password {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


Username Property (UsernamePasswordAuthenticateEventArgs)

Username Property (UsernamePasswordAuthenticateEventArgs)

Noemax.WebSockets.Core Namespace > UsernamePasswordAuthenticateEventArgs Class : Username Property
The username presented by the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Username As System.String
'Usage

Dim instance As UsernamePasswordAuthenticateEventArgs
Dim value As System.String

value = instance.Username
public System.string Username {get;}
public read-only property Username: System.String;
public function get Username : System.String
public: __property System.string* get_Username();
public:
property System.String^ Username {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventArgs Class
UsernamePasswordAuthenticateEventArgs Members


WebSocket Class

WebSocket Class
Members

Noemax.WebSockets.Core Namespace : WebSocket Class
Provides methods and properties for sending and receiving messages through WebSocket connection.
Object Model
WebSocket Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class WebSocket
'Usage

Dim instance As WebSocket
public abstract class WebSocket
public class WebSocket abstract;
public abstract class WebSocket
public __gc abstract class WebSocket
public ref class WebSocket abstract
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Core.WebSocket

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Members
Noemax.WebSockets.Core Namespace


WebSocket Class Members

WebSocket Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocket Class

The following tables list the members exposed by WebSocket.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the context object created during authentication of the WebSocket connection.
Public Property | CanReceive | Gets the value that indicate whether WebSocket is expected to receive messages.
Public Property | CanSend | Gets the value that indicate whether WebSocket is able to send messages.
Public Property | Connected | Gets the value that indicate whether the WebSocket is connected.
Public Property | Context | Gets and sets the object that associated to the context of the WebSocket instance.
Public Property | DefaultReceiveTimeout | Gets and sets a default timeout to be used when receiving incoming messages.
Public Property | DefaultSendTimeout | Gets and sets a default timeout to be used when sending outgoing messages.
Public Property | Extensions | Gets a Sec-WebSocket-Extensions header string negotiated during the WebSocket handshake.
Public Property | IsServerSide | Gets whether the WebSocket connection is on the server side and managed by the WebSocket listener.
Public Property | KeepaliveMode |
Public Property | KeepaliveResponseThrottlingInterval |
Public Property | KeepaliveRoundtripRequired |
Public Property | KeepaliveSendInterval |
Public Property | KeepaliveTimeout |
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of outbound frame produced by the WebSocket.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of outbound message queue.
Public Property | Origin | Gets a string that defines an Origin of this WebSocket connection.
Public Property | OutboundQueueSize | Gets and sets the current size of outbound message queue.
Public Property | PayloadMasking | Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Gets a string that defines a Sub-Protocol used by this WebSocket connection.
Public Property | State | Gets the state of the WebSocket connection.
Public Property | TraceSource | Gets and sets the TraceSource to be used by the WebSocket instance for tracing events.
Public Property | Via | Gets the _uri of remote endpoint.
Top
Protected Properties
 | Name | Description
Protected Property | IsFailed | Returns True if WebSocket connection is failed due to error.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Public Method | BeginReceiveMessage | Overloaded. Begins an asynchronous operation to receive a message that has a state object associated with it.
Public Method | BeginSendMessage | Overloaded. Begins asynchronous operation to sends message.
Public Method | Close | Overloaded. Attempts a graceful shutdown of WebSocket connection and closes the socket.
Public Method | EndReceiveMessage | Overloaded. Completes an asynchronous operation to receive a message
Public Method | EndSendMessage | Completes asynchronous send operation.
Public Method | Receive | /R eceives a message from the WebSocket connection.
Public Method | ReceiveMessage | Overloaded. Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Public Method | SendBatchAsync | Sends a batch of the messages asynchronously.
Public Method | SendClose | Sends the close frame with a status code and text specifying the reason for closing connection.
Public Method | SendMessage | Overloaded. Initiates a new outgoing message and returns a Stream that write the message into connection.
Public Method | SendMessageAsync | Sends message asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to the remote endpoint.
Public Method | SendPong | Sends the Pong message to remote endpoint.
Public Method | SendTextMessage | Overloaded. Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Public Method | WaitForOutboundQueue | Overloaded. Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Public Method | WriteMessage | Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Top
Protected Methods
 | Name | Description
Protected Method | IsWaitingInboundMessage | Returns whether the WebSocket is waiting for inbound messages.
Top
Public Events
 | Name | Description
Public Event | OnCloseFrame | Notifies the event handlers when Close frame was received from the remote endpoint.
Public Event | OnPing | Notifies the event handlers when Ping frame was received from the remote endpoint.
Public Event | OnPong | Notifies the event handlers when Pong frame was received from the remote endpoint.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


WebSocket Class Methods

WebSocket Class Methods

Noemax.WebSockets.Core Namespace : WebSocket Class

For a list of all members of this type, see WebSocket members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Public Method | BeginReceiveMessage | Overloaded. Begins an asynchronous operation to receive a message that has a state object associated with it.
Public Method | BeginSendMessage | Overloaded. Begins asynchronous operation to sends message.
Public Method | Close | Overloaded. Attempts a graceful shutdown of WebSocket connection and closes the socket.
Public Method | EndReceiveMessage | Overloaded. Completes an asynchronous operation to receive a message
Public Method | EndSendMessage | Completes asynchronous send operation.
Public Method | Receive | /R eceives a message from the WebSocket connection.
Public Method | ReceiveMessage | Overloaded. Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Public Method | SendBatchAsync | Sends a batch of the messages asynchronously.
Public Method | SendClose | Sends the close frame with a status code and text specifying the reason for closing connection.
Public Method | SendMessage | Overloaded. Initiates a new outgoing message and returns a Stream that write the message into connection.
Public Method | SendMessageAsync | Sends message asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to the remote endpoint.
Public Method | SendPong | Sends the Pong message to remote endpoint.
Public Method | SendTextMessage | Overloaded. Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Public Method | WaitForOutboundQueue | Overloaded. Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Public Method | WriteMessage | Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Top
Protected Methods
 | Name | Description
Protected Method | IsWaitingInboundMessage | Returns whether the WebSocket is waiting for inbound messages.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


Abort Method (WebSocket)

Abort Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Abort Method
Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Overload List
Overload | Description
Abort() | Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Abort(Int32,String) | Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Abort() Method

Abort() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > Abort Method : Abort() Method
Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Abort()
'Usage

Dim instance As WebSocket

instance.Abort()
public void Abort()
public procedure Abort();
public function Abort();
public: void Abort();
public:
void Abort();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


Abort(Int32,String) Method

Abort(Int32,String) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > Abort Method : Abort(Int32,String) Method
The status code to send to the remote endpoint.
The text description of the status code. This value should not exceed 120 characters.
Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub Abort( _
   ByVal statusCode As System.Integer, _
   ByVal statusText As System.String _
)
'Usage

Dim instance As WebSocket
Dim statusCode As System.Integer
Dim statusText As System.String

instance.Abort(statusCode, statusText)
public virtual void Abort(
   System.int statusCode,
   System.string statusText
)
public procedure Abort(
    statusCode: System.Integer;
    statusText: System.String
); virtual;
public function Abort(
   statusCode : System.int,
   statusText : System.String
);
public: virtual void Abort(
   System.int statusCode,
   System.string* statusText
)
public:
virtual void Abort(
   System.int statusCode,
   System.String^ statusText
)

Parameters

statusCode
The status code to send to the remote endpoint.
statusText
The text description of the status code. This value should not exceed 120 characters.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginReceiveMessage Method (WebSocket)

BeginReceiveMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : BeginReceiveMessage Method
Begins an asynchronous operation to receive a message that has a state object associated with it.
Overload List
Overload | Description
BeginReceiveMessage(AsyncCallback,Object) | Begins an asynchronous operation to receive a message that has a state object associated with it.
BeginReceiveMessage(TimeSpan,AsyncCallback,Object) | Begins an asynchronous operation to receive a message that has a specified time out and state object associated with it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


BeginReceiveMessage(AsyncCallback,Object) Method

BeginReceiveMessage(AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginReceiveMessage Method : BeginReceiveMessage(AsyncCallback,Object) Method
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
An object, specified by the application, that contains state information associated with the asynchronous operation.
Begins an asynchronous operation to receive a message that has a state object associated with it.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginReceiveMessage( _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginReceiveMessage(callback, state)
public System.IAsyncResult BeginReceiveMessage(
   System.AsyncCallback callback,
   System.object state
)
public function BeginReceiveMessage(
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginReceiveMessage(
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginReceiveMessage(
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginReceiveMessage(
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

callback
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
state
An object, specified by the application, that contains state information associated with the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginReceiveMessage(TimeSpan,AsyncCallback,Object) Method

BeginReceiveMessage(TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginReceiveMessage Method : BeginReceiveMessage(TimeSpan,AsyncCallback,Object) Method
The Timespan that specifies the interval of time to wait for a message to become available.
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
An object, specified by the application, that contains state information associated with the asynchronous operation.
Begins an asynchronous operation to receive a message that has a specified time out and state object associated with it.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginReceiveMessage( _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginReceiveMessage(timeout, callback, state)
public System.IAsyncResult BeginReceiveMessage(
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginReceiveMessage(
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginReceiveMessage(
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginReceiveMessage(
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginReceiveMessage(
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

timeout
The Timespan that specifies the interval of time to wait for a message to become available.
callback
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
state
An object, specified by the application, that contains state information associated with the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginSendMessage Method (WebSocket)

BeginSendMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : BeginSendMessage Method
Begins asynchronous operation to sends message.
Overload List
Overload | Description
BeginSendMessage(String,TimeSpan,AsyncCallback,Object) | Begins asynchronous operation to sends message.
BeginSendMessage(Byte[],Int32,Int32,TimeSpan,AsyncCallback,Object) | Begins asynchronous operation to sends message.
BeginSendMessage(ArraySegment<Byte>,TimeSpan,AsyncCallback,Object) | Begins asynchronous operation to sends message.
BeginSendMessage(WebSocketOutboundMessage,TimeSpan,AsyncCallback,Object) | Begins asynchronous operation to sends message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


BeginSendMessage(String,TimeSpan,AsyncCallback,Object) Method

BeginSendMessage(String,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginSendMessage Method : BeginSendMessage(String,TimeSpan,AsyncCallback,Object) Method
The text message to be sent asynchronously.
The Timespan that specifies how long the send operation has to complete before timing out.
The callback that receives the notification when the operation is complete.
The object that contains the state information associated to the operation.
Begins asynchronous operation to sends message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginSendMessage( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim text As System.String
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(text, timeout, callback, state)
public System.IAsyncResult BeginSendMessage(
   System.string text,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    text: System.String;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginSendMessage(
   text : System.String,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   System.string* text,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginSendMessage(
   System.String^ text,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

text
The text message to be sent asynchronously.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
callback
The callback that receives the notification when the operation is complete.
state
The object that contains the state information associated to the operation.

Return Value

The IAsyncResult that references the asynchronous send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginSendMessage(Byte[],Int32,Int32,TimeSpan,AsyncCallback,Object) Method

BeginSendMessage(Byte[],Int32,Int32,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginSendMessage Method : BeginSendMessage(Byte[],Int32,Int32,TimeSpan,AsyncCallback,Object) Method
The buffer that contains bytes of message to send.
The offset in the buffer where bytes of message start.
The length of the message in bytes.
The Timespan that specifies how long the send operation has to complete before timing out.
The callback that receives the notification when the operation is complete.
The object that contains the state information associated to the operation.
Begins asynchronous operation to sends message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginSendMessage( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(buffer, offset, count, timeout, callback, state)
public System.IAsyncResult BeginSendMessage(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginSendMessage(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginSendMessage(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

buffer
The buffer that contains bytes of message to send.
offset
The offset in the buffer where bytes of message start.
count
The length of the message in bytes.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
callback
The callback that receives the notification when the operation is complete.
state
The object that contains the state information associated to the operation.

Return Value

The IAsyncResult that references the asynchronous send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginSendMessage(ArraySegment<Byte>,TimeSpan,AsyncCallback,Object) Method

BeginSendMessage(ArraySegment<Byte>,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginSendMessage Method : BeginSendMessage(ArraySegment<Byte>,TimeSpan,AsyncCallback,Object) Method
The segment of an array of containing payload of the message to send.
The Timespan that specifies how long the send operation has to complete before timing out.
The callback that receives the notification when the operation is complete.
The object that contains the state information associated to the operation.
Begins asynchronous operation to sends message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginSendMessage( _
   ByVal bufferedMessage As System.ArraySegment(Of Byte), _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim bufferedMessage As System.ArraySegment(Of Byte)
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(bufferedMessage, timeout, callback, state)
public System.IAsyncResult BeginSendMessage(
   System.ArraySegment<byte> bufferedMessage,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    bufferedMessage: System.ArraySegment;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginSendMessage(
   bufferedMessage : System.ArraySegment,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   System.ArraySegment<byte> bufferedMessage,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginSendMessage(
   System.ArraySegment<byte> bufferedMessage,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

bufferedMessage
The segment of an array of containing payload of the message to send.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
callback
The callback that receives the notification when the operation is complete.
state
The object that contains the state information associated to the operation.

Return Value

The IAsyncResult that references the asynchronous send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


BeginSendMessage(WebSocketOutboundMessage,TimeSpan,AsyncCallback,Object) Method

BeginSendMessage(WebSocketOutboundMessage,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > BeginSendMessage Method : BeginSendMessage(WebSocketOutboundMessage,TimeSpan,AsyncCallback,Object) Method
The outbound message to send.
The Timespan that specifies how long the send operation has to complete before timing out.
The callback that receives the notification when the operation is complete.
The object that contains the state information associated to the operation.
Begins asynchronous operation to sends message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function BeginSendMessage( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocket
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSendMessage(message, timeout, callback, state)
public System.IAsyncResult BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
public function BeginSendMessage(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginSendMessage(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginSendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

message
The outbound message to send.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
callback
The callback that receives the notification when the operation is complete.
state
The object that contains the state information associated to the operation.

Return Value

The IAsyncResult that references the asynchronous send operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


Close Method (WebSocket)

Close Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Close Method
Attempts a graceful shutdown of WebSocket connection and closes the socket.
Overload List
Overload | Description
Close() | Attempts a graceful shutdown of WebSocket connection and closes the socket.
Close(TimeSpan) | Attempts a graceful shutdown of WebSocket connection within specified period of time and closes the socket.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Close() Method

Close() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > Close Method : Close() Method
Attempts a graceful shutdown of WebSocket connection and closes the socket.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Close()
'Usage

Dim instance As WebSocket

instance.Close()
public void Close()
public procedure Close();
public function Close();
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


Close(TimeSpan) Method

Close(TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > Close Method : Close(TimeSpan) Method
Attempts a graceful shutdown of WebSocket connection within specified period of time and closes the socket.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Sub Close( _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan

instance.Close(timeout)
public virtual void Close(
   System.TimeSpan timeout
)
public procedure Close(
    timeout: System.TimeSpan
); virtual;
public function Close(
   timeout : System.TimeSpan
);
public: virtual void Close(
   System.TimeSpan timeout
)
public:
virtual void Close(
   System.TimeSpan timeout
)

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


EndReceiveMessage Method (WebSocket)

EndReceiveMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : EndReceiveMessage Method
Completes an asynchronous operation to receive a message
Overload List
Overload | Description
EndReceiveMessage(IAsyncResult,Stream) | Completes an asynchronous operation to receive a message
EndReceiveMessage(IAsyncResult) | Completes an asynchronous operation to receive a message
EndReceiveMessage(IAsyncResult,BufferManager,Int64,ArraySegment<Byte>) | Completes an asynchronous operation to receive a message and present it as byte array segment.
EndReceiveMessage(IAsyncResult,String) | Completes an asynchronous operation to receive a message and decodes it as UTF-8 string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


EndReceiveMessage(IAsyncResult,Stream) Method

EndReceiveMessage(IAsyncResult,Stream) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > EndReceiveMessage Method : EndReceiveMessage(IAsyncResult,Stream) Method
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
The input that reads data from the payload of inbound message.
Completes an asynchronous operation to receive a message
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function EndReceiveMessage( _
   ByVal result As System.IAsyncResult, _
   ByRef stream As System.IO.Stream _
) As System.Boolean
'Usage

Dim instance As WebSocket
Dim result As System.IAsyncResult
Dim stream As System.IO.Stream
Dim value As System.Boolean

value = instance.EndReceiveMessage(result, stream)
public System.bool EndReceiveMessage(
   System.IAsyncResult result,
   out System.IO.Stream stream
)
public function EndReceiveMessage(
    result: System.IAsyncResult;
   Out  stream: System.IO.Stream
): System.Boolean;
public function EndReceiveMessage(
   result : System.IAsyncResult,
   stream : System.IO.Stream
) : System.boolean;
public: System.bool EndReceiveMessage(
   System.IAsyncResult* result,
   [PARAMFLAG::Out] System.IO.Stream* stream
)
public:
System.bool EndReceiveMessage(
   System.IAsyncResult^ result,
   [Out] System.IO.Stream^ stream
)

Parameters

result
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
stream
The input that reads data from the payload of inbound message.

Return Value

True if message was successfully received; False if connection being closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


EndReceiveMessage(IAsyncResult) Method

EndReceiveMessage(IAsyncResult) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > EndReceiveMessage Method : EndReceiveMessage(IAsyncResult) Method
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
Completes an asynchronous operation to receive a message
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function EndReceiveMessage( _
   ByVal result As System.IAsyncResult _
) As WebSocketInboundMessage
'Usage

Dim instance As WebSocket
Dim result As System.IAsyncResult
Dim value As WebSocketInboundMessage

value = instance.EndReceiveMessage(result)
public WebSocketInboundMessage EndReceiveMessage(
   System.IAsyncResult result
)
public function EndReceiveMessage(
    result: System.IAsyncResult
): WebSocketInboundMessage;
public function EndReceiveMessage(
   result : System.IAsyncResult
) : WebSocketInboundMessage;
public: WebSocketInboundMessage* EndReceiveMessage(
   System.IAsyncResult* result
)
public:
WebSocketInboundMessage^ EndReceiveMessage(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult returned by a call to one of the BeginReadMessage methods.

Return Value

The instance of WebSocketInboundMessage that represent the inbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


EndReceiveMessage(IAsyncResult,BufferManager,Int64,ArraySegment<Byte>) Method

EndReceiveMessage(IAsyncResult,BufferManager,Int64,ArraySegment<Byte>) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > EndReceiveMessage Method : EndReceiveMessage(IAsyncResult,BufferManager,Int64,ArraySegment<Byte>) Method
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
The buffer manager to provide buffers while receiving the message.
The maximum size limit for message being read.
The segment of array of bytes containing the message bytes.
Completes an asynchronous operation to receive a message and present it as byte array segment.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function EndReceiveMessage( _
   ByVal result As System.IAsyncResult, _
   ByVal bufferManager As System.ServiceModel.Channels.BufferManager, _
   ByVal maxMessageSize As System.Long, _
   ByRef message As System.ArraySegment(Of Byte) _
) As System.Boolean
'Usage

Dim instance As WebSocket
Dim result As System.IAsyncResult
Dim bufferManager As System.ServiceModel.Channels.BufferManager
Dim maxMessageSize As System.Long
Dim message As System.ArraySegment(Of Byte)
Dim value As System.Boolean

value = instance.EndReceiveMessage(result, bufferManager, maxMessageSize, message)
public System.bool EndReceiveMessage(
   System.IAsyncResult result,
   System.ServiceModel.Channels.BufferManager bufferManager,
   System.long maxMessageSize,
   out System.ArraySegment<byte> message
)
public function EndReceiveMessage(
    result: System.IAsyncResult;
    bufferManager: System.ServiceModel.Channels.BufferManager;
    maxMessageSize: System.Int64;
   Out  message: System.ArraySegment
): System.Boolean;
public function EndReceiveMessage(
   result : System.IAsyncResult,
   bufferManager : System.ServiceModel.Channels.BufferManager,
   maxMessageSize : System.long,
   message : System.ArraySegment
) : System.boolean;
public: System.bool EndReceiveMessage(
   System.IAsyncResult* result,
   System.ServiceModel.Channels.BufferManager* bufferManager,
   System.long maxMessageSize,
   [PARAMFLAG::Out] System.ArraySegment<byte> message
)
public:
System.bool EndReceiveMessage(
   System.IAsyncResult^ result,
   System.ServiceModel.Channels.BufferManager^ bufferManager,
   System.int64 maxMessageSize,
   [Out] System.ArraySegment<byte> message
)

Parameters

result
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
bufferManager
The buffer manager to provide buffers while receiving the message.
maxMessageSize
The maximum size limit for message being read.
message
The segment of array of bytes containing the message bytes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


EndReceiveMessage(IAsyncResult,String) Method

EndReceiveMessage(IAsyncResult,String) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > EndReceiveMessage Method : EndReceiveMessage(IAsyncResult,String) Method
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
The the message decoded as UTF-8 a string.
Completes an asynchronous operation to receive a message and decodes it as UTF-8 string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function EndReceiveMessage( _
   ByVal result As System.IAsyncResult, _
   ByRef text As System.String _
) As System.Boolean
'Usage

Dim instance As WebSocket
Dim result As System.IAsyncResult
Dim text As System.String
Dim value As System.Boolean

value = instance.EndReceiveMessage(result, text)
public System.bool EndReceiveMessage(
   System.IAsyncResult result,
   out System.string text
)
public function EndReceiveMessage(
    result: System.IAsyncResult;
   Out  text: System.String
): System.Boolean;
public function EndReceiveMessage(
   result : System.IAsyncResult,
   text : System.String
) : System.boolean;
public: System.bool EndReceiveMessage(
   System.IAsyncResult* result,
   [PARAMFLAG::Out] System.string* text
)
public:
System.bool EndReceiveMessage(
   System.IAsyncResult^ result,
   [Out] System.String^ text
)

Parameters

result
The IAsyncResult returned by a call to one of the BeginReadMessage methods.
text
The the message decoded as UTF-8 a string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


EndSendMessage Method (WebSocket)

EndSendMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : EndSendMessage Method
The IAsyncResult returned by a call to the BeginSendMessage method.
Completes asynchronous send operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EndSendMessage( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As WebSocket
Dim result As System.IAsyncResult

instance.EndSendMessage(result)
public void EndSendMessage(
   System.IAsyncResult result
)
public procedure EndSendMessage(
    result: System.IAsyncResult
);
public function EndSendMessage(
   result : System.IAsyncResult
);
public: void EndSendMessage(
   System.IAsyncResult* result
)
public:
void EndSendMessage(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult returned by a call to the BeginSendMessage method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


IsWaitingInboundMessage Method (WebSocket)

IsWaitingInboundMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : IsWaitingInboundMessage Method
Returns whether the WebSocket is waiting for inbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function IsWaitingInboundMessage() As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.IsWaitingInboundMessage()
protected System.bool IsWaitingInboundMessage()
protected function IsWaitingInboundMessage(): System.Boolean;
protected function IsWaitingInboundMessage() : System.boolean;
protected: System.bool IsWaitingInboundMessage();
protected:
System.bool IsWaitingInboundMessage();

Return Value

Returns True if the WebSocket waiting to receive the message. When there is no receive operations pending returns False.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Receive Method (WebSocket)

Receive Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Receive Method
The period of time during which operation must complete or timeout.
/R eceives a message from the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Receive( _
   ByVal timeout As System.TimeSpan _
) As WebSocketInboundMessage
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As WebSocketInboundMessage

value = instance.Receive(timeout)
public WebSocketInboundMessage Receive(
   System.TimeSpan timeout
)
public function Receive(
    timeout: System.TimeSpan
): WebSocketInboundMessage;
public function Receive(
   timeout : System.TimeSpan
) : WebSocketInboundMessage;
public: WebSocketInboundMessage* Receive(
   System.TimeSpan timeout
)
public:
WebSocketInboundMessage^ Receive(
   System.TimeSpan timeout
)

Parameters

timeout
The period of time during which operation must complete or timeout.

Return Value

The inbound message received.
Remarks
After call to Receive is compelte the message is not necessary completelly received, only header of the first fragment is guaranteed to be received. Application can continue receiving message using methods provided by Noemax.WebSockets.WebSocketInboundMessage. When message is consumed application must call Noemax.WebSockets.WebSocketInboundMessage.Close in other to release the message and allow subsequent message to be received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


ReceiveMessage Method (WebSocket)

ReceiveMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : ReceiveMessage Method
Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Overload List
Overload | Description
ReceiveMessage(Int32) | Receives a message from the WebSocket connection.
ReceiveMessage(Int32,TimeSpan) | Receives a message from the WebSocket connection.
ReceiveMessage(BufferManager,Int64) | Receives a complete message from the WebSocket connection.
ReceiveMessage(BufferManager,Int64,TimeSpan) | Receives a message from the WebSocket connection.
ReceiveMessage() | Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
ReceiveMessage(TimeSpan) | Reads the message from the WebSocket connection and represents it as System.IO.Stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


ReceiveMessage(Int32) Method

ReceiveMessage(Int32) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage(Int32) Method
The maximum size limit for message being received.
Receives a message from the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage( _
   ByVal maxMessageSize As System.Integer _
) As System.ArraySegment(Of Byte)
'Usage

Dim instance As WebSocket
Dim maxMessageSize As System.Integer
Dim value As System.ArraySegment(Of Byte)

value = instance.ReceiveMessage(maxMessageSize)
public System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize
)
public function ReceiveMessage(
    maxMessageSize: System.Integer
): System.ArraySegment;
public function ReceiveMessage(
   maxMessageSize : System.int
) : System.ArraySegment;
public: System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize
)
public:
System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize
)

Parameters

maxMessageSize
The maximum size limit for message being received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


ReceiveMessage(Int32,TimeSpan) Method

ReceiveMessage(Int32,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage(Int32,TimeSpan) Method
The maximum size limit for message being read.
The timeout during which the message is expected to be completely received.
Receives a message from the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage( _
   ByVal maxMessageSize As System.Integer, _
   ByVal timeout As System.TimeSpan _
) As System.ArraySegment(Of Byte)
'Usage

Dim instance As WebSocket
Dim maxMessageSize As System.Integer
Dim timeout As System.TimeSpan
Dim value As System.ArraySegment(Of Byte)

value = instance.ReceiveMessage(maxMessageSize, timeout)
public System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize,
   System.TimeSpan timeout
)
public function ReceiveMessage(
    maxMessageSize: System.Integer;
    timeout: System.TimeSpan
): System.ArraySegment;
public function ReceiveMessage(
   maxMessageSize : System.int,
   timeout : System.TimeSpan
) : System.ArraySegment;
public: System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize,
   System.TimeSpan timeout
)
public:
System.ArraySegment<byte> ReceiveMessage(
   System.int maxMessageSize,
   System.TimeSpan timeout
)

Parameters

maxMessageSize
The maximum size limit for message being read.
timeout
The timeout during which the message is expected to be completely received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


ReceiveMessage(BufferManager,Int64) Method

ReceiveMessage(BufferManager,Int64) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage(BufferManager,Int64) Method
The buffer manager to provide buffers while receiving the message.
The maximum size limit for message being read.
Receives a complete message from the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage( _
   ByVal bufferManager As System.ServiceModel.Channels.BufferManager, _
   ByVal maxMessageSize As System.Long _
) As System.ArraySegment(Of Byte)
'Usage

Dim instance As WebSocket
Dim bufferManager As System.ServiceModel.Channels.BufferManager
Dim maxMessageSize As System.Long
Dim value As System.ArraySegment(Of Byte)

value = instance.ReceiveMessage(bufferManager, maxMessageSize)
public System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager bufferManager,
   System.long maxMessageSize
)
public function ReceiveMessage(
    bufferManager: System.ServiceModel.Channels.BufferManager;
    maxMessageSize: System.Int64
): System.ArraySegment;
public function ReceiveMessage(
   bufferManager : System.ServiceModel.Channels.BufferManager,
   maxMessageSize : System.long
) : System.ArraySegment;
public: System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager* bufferManager,
   System.long maxMessageSize
)
public:
System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager^ bufferManager,
   System.int64 maxMessageSize
)

Parameters

bufferManager
The buffer manager to provide buffers while receiving the message.
maxMessageSize
The maximum size limit for message being read.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


ReceiveMessage(BufferManager,Int64,TimeSpan) Method

ReceiveMessage(BufferManager,Int64,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage(BufferManager,Int64,TimeSpan) Method
The buffer manager to provide buffers while receiving the message.
The maximum size limit for message being read.
The timeout during which the message is expected to be completely received.
Receives a message from the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage( _
   ByVal bufferManager As System.ServiceModel.Channels.BufferManager, _
   ByVal maxMessageSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.ArraySegment(Of Byte)
'Usage

Dim instance As WebSocket
Dim bufferManager As System.ServiceModel.Channels.BufferManager
Dim maxMessageSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.ArraySegment(Of Byte)

value = instance.ReceiveMessage(bufferManager, maxMessageSize, timeout)
public System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager bufferManager,
   System.long maxMessageSize,
   System.TimeSpan timeout
)
public function ReceiveMessage(
    bufferManager: System.ServiceModel.Channels.BufferManager;
    maxMessageSize: System.Int64;
    timeout: System.TimeSpan
): System.ArraySegment;
public function ReceiveMessage(
   bufferManager : System.ServiceModel.Channels.BufferManager,
   maxMessageSize : System.long,
   timeout : System.TimeSpan
) : System.ArraySegment;
public: System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager* bufferManager,
   System.long maxMessageSize,
   System.TimeSpan timeout
)
public:
System.ArraySegment<byte> ReceiveMessage(
   System.ServiceModel.Channels.BufferManager^ bufferManager,
   System.int64 maxMessageSize,
   System.TimeSpan timeout
)

Parameters

bufferManager
The buffer manager to provide buffers while receiving the message.
maxMessageSize
The maximum size limit for message being read.
timeout
The timeout during which the message is expected to be completely received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


ReceiveMessage() Method

ReceiveMessage() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage() Method
Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage() As System.IO.Stream
'Usage

Dim instance As WebSocket
Dim value As System.IO.Stream

value = instance.ReceiveMessage()
public System.IO.Stream ReceiveMessage()
public function ReceiveMessage(): System.IO.Stream;
public function ReceiveMessage() : System.IO.Stream;
public: System.IO.Stream* ReceiveMessage();
public:
System.IO.Stream^ ReceiveMessage();
Remarks
After call to Receive is complete the message is not necessary completelly received, only header of the first fragment is guaranteed to be received. Application can continue receiving the message using the System.IO.Stream returned by this method. When message is consumed application must close the input to allow subsequent messages to be received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


ReceiveMessage(TimeSpan) Method

ReceiveMessage(TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > ReceiveMessage Method : ReceiveMessage(TimeSpan) Method
The timeout during which the message is expected to be completely received.
Reads the message from the WebSocket connection and represents it as System.IO.Stream.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function ReceiveMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.ReceiveMessage(timeout)
public System.IO.Stream ReceiveMessage(
   System.TimeSpan timeout
)
public function ReceiveMessage(
    timeout: System.TimeSpan
): System.IO.Stream;
public function ReceiveMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: System.IO.Stream* ReceiveMessage(
   System.TimeSpan timeout
)
public:
System.IO.Stream^ ReceiveMessage(
   System.TimeSpan timeout
)

Parameters

timeout
The timeout during which the message is expected to be completely received.
Remarks
After call to Receive is complete the message is not necessary completelly received, only header of the first fragment is guaranteed to be received. Application can continue receiving the message using the System.IO.Stream returned by this method. When message is consumed application must close the input to allow subsequent messages to be received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendBatchAsync Method (WebSocket)

SendBatchAsync Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendBatchAsync Method
The batch of messages to send.
The Timespan that specifies how long the send operation has to complete before timing out.
Sends a batch of the messages asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendBatchAsync( _
   ByVal batch() As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim batch() As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendBatchAsync(batch, timeout)
public void SendBatchAsync(
   WebSocketOutboundMessage[] batch,
   System.TimeSpan timeout
)
public procedure SendBatchAsync(
    batch: WebSocketOutboundMessagearray of;
    timeout: System.TimeSpan
);
public function SendBatchAsync(
   batch : WebSocketOutboundMessage[],
   timeout : System.TimeSpan
);
public: void SendBatchAsync(
   WebSocketOutboundMessage[]* batch,
   System.TimeSpan timeout
)
public:
void SendBatchAsync(
   array<WebSocketOutboundMessage>^ batch,
   System.TimeSpan timeout
)

Parameters

batch
The batch of messages to send.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
Remarks

This methods sends batch of messages in fire-and-forget mode, without waiting for completion. If send operation failed than subsequent send or receive operation will return error and connection is closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendClose Method (WebSocket)

SendClose Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendClose Method
The status code describing the reason for closing the connection.
The text description associated to the status code.
The period of time during which the send operation should complete or timeout.
Sends the close frame with a status code and text specifying the reason for closing connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendClose( _
   ByVal code As System.Short, _
   ByVal reason As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim code As System.Short
Dim reason As System.String
Dim timeout As System.TimeSpan

instance.SendClose(code, reason, timeout)
public void SendClose(
   System.short code,
   System.string reason,
   System.TimeSpan timeout
)
public procedure SendClose(
    code: System.Int16;
    reason: System.String;
    timeout: System.TimeSpan
);
public function SendClose(
   code : System.short,
   reason : System.String,
   timeout : System.TimeSpan
);
public: void SendClose(
   System.short code,
   System.string* reason,
   System.TimeSpan timeout
)
public:
void SendClose(
   System.short code,
   System.String^ reason,
   System.TimeSpan timeout
)

Parameters

code
The status code describing the reason for closing the connection.
reason
The text description associated to the status code.
timeout
The period of time during which the send operation should complete or timeout.
Remarks
Once close sent is sent by local endpoint it cannot send more messages to remote side. Sending close frame does not result in connection being closed right away. Local endpoint can still receive messages until remote side closes the connection/
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendMessage Method (WebSocket)

SendMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendMessage Method
Initiates a new outgoing message and returns a Stream that write the message into connection.
Overload List
Overload | Description
SendMessage() | Initiates a new outgoing message and returns a Stream that write the message into connection.
SendMessage(TimeSpan) | Initiates the message and returns a Stream that writes message into connection.
SendMessage(Byte[],Int32,Int32) | Sends byte array as binary message.
SendMessage(ArraySegment<Byte>,TimeSpan) | Sends byte array as binary message.
SendMessage(Byte[],Int32,Int32,TimeSpan) | Sends byte array as binary message.
SendMessage(String) | Sends string of text as UTF-8 encoded text message.
SendMessage(String,TimeSpan) | Sends string of text as UTF-8 encoded text message.
SendMessage(WebSocketOutboundMessage,TimeSpan) | Sends an outbound message.
SendMessage(WebSocketOutboundMessage) | Sends an outbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendMessage() Method

SendMessage() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage() Method
Initiates a new outgoing message and returns a Stream that write the message into connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendMessage() As System.IO.Stream
'Usage

Dim instance As WebSocket
Dim value As System.IO.Stream

value = instance.SendMessage()
public System.IO.Stream SendMessage()
public function SendMessage(): System.IO.Stream;
public function SendMessage() : System.IO.Stream;
public: System.IO.Stream* SendMessage();
public:
System.IO.Stream^ SendMessage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(TimeSpan) Method

SendMessage(TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(TimeSpan) Method
An TimeSpan that specifies the interval of time to wait for message to be sent.
Initiates the message and returns a Stream that writes message into connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.SendMessage(timeout)
public System.IO.Stream SendMessage(
   System.TimeSpan timeout
)
public function SendMessage(
    timeout: System.TimeSpan
): System.IO.Stream;
public function SendMessage(
   timeout : System.TimeSpan
) : System.IO.Stream;
public: System.IO.Stream* SendMessage(
   System.TimeSpan timeout
)
public:
System.IO.Stream^ SendMessage(
   System.TimeSpan timeout
)

Parameters

timeout
An TimeSpan that specifies the interval of time to wait for message to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(Byte[],Int32,Int32) Method

SendMessage(Byte[],Int32,Int32) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(Byte[],Int32,Int32) Method
Sends byte array as binary message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim instance As WebSocket
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

instance.SendMessage(buffer, offset, count)
public void SendMessage(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public procedure SendMessage(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
);
public function SendMessage(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
public: void SendMessage(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
public:
void SendMessage(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
offset
count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(ArraySegment<Byte>,TimeSpan) Method

SendMessage(ArraySegment<Byte>,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(ArraySegment<Byte>,TimeSpan) Method
Sends byte array as binary message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal message As System.ArraySegment(Of Byte), _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim message As System.ArraySegment(Of Byte)
Dim timeout As System.TimeSpan

instance.SendMessage(message, timeout)
public void SendMessage(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)
public procedure SendMessage(
    message: System.ArraySegment;
    timeout: System.TimeSpan
);
public function SendMessage(
   message : System.ArraySegment,
   timeout : System.TimeSpan
);
public: void SendMessage(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)
public:
void SendMessage(
   System.ArraySegment<byte> message,
   System.TimeSpan timeout
)

Parameters

message
timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(Byte[],Int32,Int32,TimeSpan) Method

SendMessage(Byte[],Int32,Int32,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(Byte[],Int32,Int32,TimeSpan) Method
The array containing the bytes of the message to be sent.
The offset in the array where message to be sent starts.
The number of bytes starting from the offset until the end of the message.
An TimeSpan that specifies the interval of time to wait for message to be sent.
Sends byte array as binary message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim timeout As System.TimeSpan

instance.SendMessage(buffer, offset, count, timeout)
public void SendMessage(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public procedure SendMessage(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    timeout: System.TimeSpan
);
public function SendMessage(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   timeout : System.TimeSpan
);
public: void SendMessage(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)
public:
void SendMessage(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.TimeSpan timeout
)

Parameters

buffer
The array containing the bytes of the message to be sent.
offset
The offset in the array where message to be sent starts.
count
The number of bytes starting from the offset until the end of the message.
timeout
An TimeSpan that specifies the interval of time to wait for message to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(String) Method

SendMessage(String) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(String) Method
Sends string of text as UTF-8 encoded text message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal text As System.String _
)
'Usage

Dim instance As WebSocket
Dim text As System.String

instance.SendMessage(text)
public void SendMessage(
   System.string text
)
public procedure SendMessage(
    text: System.String
);
public function SendMessage(
   text : System.String
);
public: void SendMessage(
   System.string* text
)
public:
void SendMessage(
   System.String^ text
)

Parameters

text
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(String,TimeSpan) Method

SendMessage(String,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(String,TimeSpan) Method
The text to send as UTF-8 encoded WebSocket message.
An TimeSpan that specifies the interval of time to wait for message to be sent.
Sends string of text as UTF-8 encoded text message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal text As System.String, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim text As System.String
Dim timeout As System.TimeSpan

instance.SendMessage(text, timeout)
public void SendMessage(
   System.string text,
   System.TimeSpan timeout
)
public procedure SendMessage(
    text: System.String;
    timeout: System.TimeSpan
);
public function SendMessage(
   text : System.String,
   timeout : System.TimeSpan
);
public: void SendMessage(
   System.string* text,
   System.TimeSpan timeout
)
public:
void SendMessage(
   System.String^ text,
   System.TimeSpan timeout
)

Parameters

text
The text to send as UTF-8 encoded WebSocket message.
timeout
An TimeSpan that specifies the interval of time to wait for message to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(WebSocketOutboundMessage,TimeSpan) Method

SendMessage(WebSocketOutboundMessage,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(WebSocketOutboundMessage,TimeSpan) Method
The message to send.
The period of time to wait for message to be sent. If message is not sent within specified timeout, TimeoutException is raised by this method.
Sends an outbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendMessage(message, timeout)
public void SendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendMessage(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
);
public function SendMessage(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void SendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public:
void SendMessage(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)

Parameters

message
The message to send.
timeout
The period of time to wait for message to be sent. If message is not sent within specified timeout, TimeoutException is raised by this method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessage(WebSocketOutboundMessage) Method

SendMessage(WebSocketOutboundMessage) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendMessage Method : SendMessage(WebSocketOutboundMessage) Method
The message to send.
Sends an outbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendMessage( _
   ByVal message As WebSocketOutboundMessage _
)
'Usage

Dim instance As WebSocket
Dim message As WebSocketOutboundMessage

instance.SendMessage(message)
public void SendMessage(
   WebSocketOutboundMessage message
)
public procedure SendMessage(
    message: WebSocketOutboundMessage
);
public function SendMessage(
   message : WebSocketOutboundMessage
);
public: void SendMessage(
   WebSocketOutboundMessage message
)
public:
void SendMessage(
   WebSocketOutboundMessage message
)

Parameters

message
The message to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendMessageAsync Method (WebSocket)

SendMessageAsync Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendMessageAsync Method
The message to send asynchronously.
The Timespan that specifies how long the send operation has to complete before timing out.
Sends message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendMessageAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As WebSocket
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan

instance.SendMessageAsync(message, timeout)
public void SendMessageAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public procedure SendMessageAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
);
public function SendMessageAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
);
public: void SendMessageAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public:
void SendMessageAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)

Parameters

message
The message to send asynchronously.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendPing Method (WebSocket)

SendPing Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendPing Method
Sends the PING message to the remote endpoint.
Overload List
Overload | Description
SendPing() | Sends the PING message to the remote endpoint.
SendPing(Byte[]) | Sends the PING message to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendPing() Method

SendPing() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendPing Method : SendPing() Method
Sends the PING message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendPing()
'Usage

Dim instance As WebSocket

instance.SendPing()
public void SendPing()
public procedure SendPing();
public function SendPing();
public: void SendPing();
public:
void SendPing();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendPing(Byte[]) Method

SendPing(Byte[]) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendPing Method : SendPing(Byte[]) Method
Sends the PING message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SendPing( _
   ByVal payload() As System.Byte _
)
'Usage

Dim instance As WebSocket
Dim payload() As System.Byte

instance.SendPing(payload)
public void SendPing(
   System.byte[] payload
)
public procedure SendPing(
    payload: System.Bytearray of
);
public function SendPing(
   payload : System.byte[]
);
public: void SendPing(
   System.byte[]* payload
)
public:
void SendPing(
   System.array<byte>^ payload
)

Parameters

payload
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendPong Method (WebSocket)

SendPong Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendPong Method
The bytes to sent as the payload of the pong message. The size of the payload should not exceed 125 bytes.
Sends the Pong message to remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SendPong( _
   ByVal payload As System.ArraySegment(Of Byte) _
)
'Usage

Dim instance As WebSocket
Dim payload As System.ArraySegment(Of Byte)

instance.SendPong(payload)
public void SendPong(
   System.ArraySegment<byte> payload
)
public procedure SendPong(
    payload: System.ArraySegment
);
public function SendPong(
   payload : System.ArraySegment
);
public: void SendPong(
   System.ArraySegment<byte> payload
)
public:
void SendPong(
   System.ArraySegment<byte> payload
)

Parameters

payload
The bytes to sent as the payload of the pong message. The size of the payload should not exceed 125 bytes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendTextMessage Method (WebSocket)

SendTextMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendTextMessage Method
Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Overload List
Overload | Description
SendTextMessage() | Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
SendTextMessage(TimeSpan) | Initiates the message and returns a StreamWriter that writes message into connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendTextMessage() Method

SendTextMessage() Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendTextMessage Method : SendTextMessage() Method
Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendTextMessage() As System.IO.TextWriter
'Usage

Dim instance As WebSocket
Dim value As System.IO.TextWriter

value = instance.SendTextMessage()
public System.IO.TextWriter SendTextMessage()
public function SendTextMessage(): System.IO.TextWriter;
public function SendTextMessage() : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage();
public:
System.IO.TextWriter^ SendTextMessage();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


SendTextMessage(TimeSpan) Method

SendTextMessage(TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > SendTextMessage Method : SendTextMessage(TimeSpan) Method
An TimeSpan that specifies the interval of time to wait for message to be sent.
Initiates the message and returns a StreamWriter that writes message into connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function SendTextMessage( _
   ByVal timeout As System.TimeSpan _
) As System.IO.TextWriter
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As System.IO.TextWriter

value = instance.SendTextMessage(timeout)
public System.IO.TextWriter SendTextMessage(
   System.TimeSpan timeout
)
public function SendTextMessage(
    timeout: System.TimeSpan
): System.IO.TextWriter;
public function SendTextMessage(
   timeout : System.TimeSpan
) : System.IO.TextWriter;
public: System.IO.TextWriter* SendTextMessage(
   System.TimeSpan timeout
)
public:
System.IO.TextWriter^ SendTextMessage(
   System.TimeSpan timeout
)

Parameters

timeout
An TimeSpan that specifies the interval of time to wait for message to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List


WaitForOutboundQueue Method (WebSocket)

WaitForOutboundQueue Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : WaitForOutboundQueue Method
Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Overload List
Overload | Description
WaitForOutboundQueue(Int64,TimeSpan) | Waits for outbound message queue size to decrease to a specified value for a specified period of time.
WaitForOutboundQueue(TimeSpan) | Waits for all outbound messages in the message queue to be sent for specified period of time.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


WaitForOutboundQueue(Int64,TimeSpan) Method

WaitForOutboundQueue(Int64,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > WaitForOutboundQueue Method : WaitForOutboundQueue(Int64,TimeSpan) Method
The target outbound queue size.
The period of time to wait for the outbound queue to decrease to given size.
Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function WaitForOutboundQueue( _
   ByVal queueSize As System.Long, _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocket
Dim queueSize As System.Long
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(queueSize, timeout)
public System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    queueSize: System.Int64;
    timeout: System.TimeSpan
): System.Boolean;
public function WaitForOutboundQueue(
   queueSize : System.long,
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.long queueSize,
   System.TimeSpan timeout
)
public:
System.bool WaitForOutboundQueue(
   System.int64 queueSize,
   System.TimeSpan timeout
)

Parameters

queueSize
The target outbound queue size.
timeout
The period of time to wait for the outbound queue to decrease to given size.

Return Value

True if the queue decreased to specified size during the specified period of time; otherwise False.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List
OutboundQueueSize Property
MaxOutboundQueueSize Property


WaitForOutboundQueue(TimeSpan) Method

WaitForOutboundQueue(TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocket Class > WaitForOutboundQueue Method : WaitForOutboundQueue(TimeSpan) Method
The period of time to wait for all outbound messages to be sent.
Waits for all outbound messages in the message queue to be sent for specified period of time.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function WaitForOutboundQueue( _
   ByVal timeout As System.TimeSpan _
) As System.Boolean
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As System.Boolean

value = instance.WaitForOutboundQueue(timeout)
public System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)
public function WaitForOutboundQueue(
    timeout: System.TimeSpan
): System.Boolean;
public function WaitForOutboundQueue(
   timeout : System.TimeSpan
) : System.boolean;
public: System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)
public:
System.bool WaitForOutboundQueue(
   System.TimeSpan timeout
)

Parameters

timeout
The period of time to wait for all outbound messages to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
Overload List
OutboundQueueSize Property
MaxOutboundQueueSize Property


WriteMessage(MessageEndCallback,Object) Method

WriteMessage(MessageEndCallback,Object) Method

Noemax.WebSockets.Core Namespace > WebSocket Class : WriteMessage(MessageEndCallback,Object) Method
Callback being called when message input is closed and message is fully sent.
The state associated to the outbound message.
Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function WriteMessage( _
   ByVal callback As MessageEndCallback, _
   ByVal state As System.Object _
) As System.IO.Stream
'Usage

Dim instance As WebSocket
Dim callback As MessageEndCallback
Dim state As System.Object
Dim value As System.IO.Stream

value = instance.WriteMessage(callback, state)
public System.IO.Stream WriteMessage(
   MessageEndCallback callback,
   System.object state
)
public function WriteMessage(
    callback: MessageEndCallback;
    state: System.TObject
): System.IO.Stream;
public function WriteMessage(
   callback : MessageEndCallback,
   state : System.Object
) : System.IO.Stream;
public: System.IO.Stream* WriteMessage(
   MessageEndCallback* callback,
   System.Object* state
)
public:
System.IO.Stream^ WriteMessage(
   MessageEndCallback^ callback,
   System.Object^ state
)

Parameters

callback
Callback being called when message input is closed and message is fully sent.
state
The state associated to the outbound message.

Return Value

The input for writing outbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


WebSocket Class Properties

WebSocket Class Properties

Noemax.WebSockets.Core Namespace : WebSocket Class

For a list of all members of this type, see WebSocket members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the context object created during authentication of the WebSocket connection.
Public Property | CanReceive | Gets the value that indicate whether WebSocket is expected to receive messages.
Public Property | CanSend | Gets the value that indicate whether WebSocket is able to send messages.
Public Property | Connected | Gets the value that indicate whether the WebSocket is connected.
Public Property | Context | Gets and sets the object that associated to the context of the WebSocket instance.
Public Property | DefaultReceiveTimeout | Gets and sets a default timeout to be used when receiving incoming messages.
Public Property | DefaultSendTimeout | Gets and sets a default timeout to be used when sending outgoing messages.
Public Property | Extensions | Gets a Sec-WebSocket-Extensions header string negotiated during the WebSocket handshake.
Public Property | IsServerSide | Gets whether the WebSocket connection is on the server side and managed by the WebSocket listener.
Public Property | KeepaliveMode |
Public Property | KeepaliveResponseThrottlingInterval |
Public Property | KeepaliveRoundtripRequired |
Public Property | KeepaliveSendInterval |
Public Property | KeepaliveTimeout |
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of outbound frame produced by the WebSocket.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of outbound message queue.
Public Property | Origin | Gets a string that defines an Origin of this WebSocket connection.
Public Property | OutboundQueueSize | Gets and sets the current size of outbound message queue.
Public Property | PayloadMasking | Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Gets a string that defines a Sub-Protocol used by this WebSocket connection.
Public Property | State | Gets the state of the WebSocket connection.
Public Property | TraceSource | Gets and sets the TraceSource to be used by the WebSocket instance for tracing events.
Public Property | Via | Gets the _uri of remote endpoint.
Top
Protected Properties
 | Name | Description
Protected Property | IsFailed | Returns True if WebSocket connection is failed due to error.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


AuthenticationContext Property (WebSocket)

AuthenticationContext Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : AuthenticationContext Property
Gets the context object created during authentication of the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property AuthenticationContext As System.Object
'Usage

Dim instance As WebSocket
Dim value As System.Object

value = instance.AuthenticationContext
public System.object AuthenticationContext {get;}
public read-only property AuthenticationContext: System.TObject;
public function get AuthenticationContext : System.Object
public: __property System.Object* get_AuthenticationContext();
public:
property System.Object^ AuthenticationContext {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


CanReceive Property (WebSocket)

CanReceive Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : CanReceive Property
Gets the value that indicate whether WebSocket is expected to receive messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CanReceive As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.CanReceive
public System.bool CanReceive {get;}
public read-only property CanReceive: System.Boolean;
public function get CanReceive : System.boolean
public: __property System.bool get_CanReceive();
public:
property System.bool CanReceive {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


CanSend Property (WebSocket)

CanSend Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : CanSend Property
Gets the value that indicate whether WebSocket is able to send messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property CanSend As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.CanSend
public System.bool CanSend {get;}
public read-only property CanSend: System.Boolean;
public function get CanSend : System.boolean
public: __property System.bool get_CanSend();
public:
property System.bool CanSend {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Connected Property (WebSocket)

Connected Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Connected Property
Gets the value that indicate whether the WebSocket is connected.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Connected As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.Connected
public System.bool Connected {get;}
public read-only property Connected: System.Boolean;
public function get Connected : System.boolean
public: __property System.bool get_Connected();
public:
property System.bool Connected {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Context Property (WebSocket)

Context Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Context Property
Gets and sets the object that associated to the context of the WebSocket instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Context As System.Object
'Usage

Dim instance As WebSocket
Dim value As System.Object

instance.Context = value

value = instance.Context
public System.object Context {get; set;}
public read-write property Context: System.TObject;
public function get,set Context : System.Object
public: __property System.Object* get_Context();
public: __property void set_Context(
   System.Object* value
);
public:
property System.Object^ Context {
   System.Object^ get();
   void set (    System.Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


DefaultReceiveTimeout Property (WebSocket)

DefaultReceiveTimeout Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : DefaultReceiveTimeout Property
Gets and sets a default timeout to be used when receiving incoming messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultReceiveTimeout As System.TimeSpan
'Usage

Dim instance As WebSocket
Dim value As System.TimeSpan

instance.DefaultReceiveTimeout = value

value = instance.DefaultReceiveTimeout
public System.TimeSpan DefaultReceiveTimeout {get; set;}
public read-write property DefaultReceiveTimeout: System.TimeSpan;
public function get,set DefaultReceiveTimeout : System.TimeSpan
public: __property System.TimeSpan get_DefaultReceiveTimeout();
public: __property void set_DefaultReceiveTimeout(
   System.TimeSpan value
);
public:
property System.TimeSpan DefaultReceiveTimeout {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


DefaultSendTimeout Property (WebSocket)

DefaultSendTimeout Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : DefaultSendTimeout Property
Gets and sets a default timeout to be used when sending outgoing messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property DefaultSendTimeout As System.TimeSpan
'Usage

Dim instance As WebSocket
Dim value As System.TimeSpan

instance.DefaultSendTimeout = value

value = instance.DefaultSendTimeout
public System.TimeSpan DefaultSendTimeout {get; set;}
public read-write property DefaultSendTimeout: System.TimeSpan;
public function get,set DefaultSendTimeout : System.TimeSpan
public: __property System.TimeSpan get_DefaultSendTimeout();
public: __property void set_DefaultSendTimeout(
   System.TimeSpan value
);
public:
property System.TimeSpan DefaultSendTimeout {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Extensions Property (WebSocket)

Extensions Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Extensions Property
Gets a Sec-WebSocket-Extensions header string negotiated during the WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Extensions As System.Collections.Generic.IEnumerable(Of String)
'Usage

Dim instance As WebSocket
Dim value As System.Collections.Generic.IEnumerable(Of String)

value = instance.Extensions
public System.Collections.Generic.IEnumerable<string> Extensions {get;}
public read-only property Extensions: System.Collections.Generic.IEnumerable;
public function get Extensions : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<string*>* get_Extensions();
public:
property System.Collections.Generic.IEnumerable<String^>^ Extensions {
   System.Collections.Generic.IEnumerable<String^>^ get();
}
Remarks
This string specifies the set of extensions that were agreed to be used during communication by both the server and the client side.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


IsFailed Property (WebSocket)

IsFailed Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : IsFailed Property
Returns True if WebSocket connection is failed due to error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected ReadOnly Property IsFailed As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.IsFailed
protected System.bool IsFailed {get;}
protected read-only property IsFailed: System.Boolean;
protected function get IsFailed : System.boolean
protected: __property System.bool get_IsFailed();
protected:
property System.bool IsFailed {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


IsServerSide Property (WebSocket)

IsServerSide Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : IsServerSide Property
Gets whether the WebSocket connection is on the server side and managed by the WebSocket listener.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property IsServerSide As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

value = instance.IsServerSide
public abstract System.bool IsServerSide {get;}
public read-only property IsServerSide: System.Boolean; abstract;
public __abstract function get IsServerSide : System.boolean
public: __property abstract System.bool get_IsServerSide();
public:
abstract property System.bool IsServerSide {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


KeepaliveMode Property (WebSocket)

KeepaliveMode Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : KeepaliveMode Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeepaliveMode As KeepaliveMode
'Usage

Dim instance As WebSocket
Dim value As KeepaliveMode

instance.KeepaliveMode = value

value = instance.KeepaliveMode
public KeepaliveMode KeepaliveMode {get; set;}
public read-write property KeepaliveMode: KeepaliveMode;
public function get,set KeepaliveMode : KeepaliveMode
public: __property KeepaliveMode get_KeepaliveMode();
public: __property void set_KeepaliveMode(
   KeepaliveMode value
);
public:
property KeepaliveMode KeepaliveMode {
   KeepaliveMode get();
   void set (    KeepaliveMode value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


KeepaliveResponseThrottlingInterval Property (WebSocket)

KeepaliveResponseThrottlingInterval Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : KeepaliveResponseThrottlingInterval Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeepaliveResponseThrottlingInterval As System.TimeSpan
'Usage

Dim instance As WebSocket
Dim value As System.TimeSpan

instance.KeepaliveResponseThrottlingInterval = value

value = instance.KeepaliveResponseThrottlingInterval
public System.TimeSpan KeepaliveResponseThrottlingInterval {get; set;}
public read-write property KeepaliveResponseThrottlingInterval: System.TimeSpan;
public function get,set KeepaliveResponseThrottlingInterval : System.TimeSpan
public: __property System.TimeSpan get_KeepaliveResponseThrottlingInterval();
public: __property void set_KeepaliveResponseThrottlingInterval(
   System.TimeSpan value
);
public:
property System.TimeSpan KeepaliveResponseThrottlingInterval {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


KeepaliveRoundtripRequired Property (WebSocket)

KeepaliveRoundtripRequired Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : KeepaliveRoundtripRequired Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property KeepaliveRoundtripRequired As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

instance.KeepaliveRoundtripRequired = value

value = instance.KeepaliveRoundtripRequired
public System.bool KeepaliveRoundtripRequired {get; set;}
public read-write property KeepaliveRoundtripRequired: System.Boolean;
public function get,set KeepaliveRoundtripRequired : System.boolean
public: __property System.bool get_KeepaliveRoundtripRequired();
public: __property void set_KeepaliveRoundtripRequired(
   System.bool value
);
public:
property System.bool KeepaliveRoundtripRequired {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


KeepaliveSendInterval Property (WebSocket)

KeepaliveSendInterval Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : KeepaliveSendInterval Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property KeepaliveSendInterval As System.TimeSpan
'Usage

Dim instance As WebSocket
Dim value As System.TimeSpan

instance.KeepaliveSendInterval = value

value = instance.KeepaliveSendInterval
public abstract System.TimeSpan KeepaliveSendInterval {get; set;}
public read-write property KeepaliveSendInterval: System.TimeSpan; abstract;
public __abstract function get,set KeepaliveSendInterval : System.TimeSpan
public: __property abstract System.TimeSpan get_KeepaliveSendInterval();
public: __property abstract void set_KeepaliveSendInterval(
   System.TimeSpan value
);
public:
abstract property System.TimeSpan KeepaliveSendInterval {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


KeepaliveTimeout Property (WebSocket)

KeepaliveTimeout Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : KeepaliveTimeout Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property KeepaliveTimeout As System.TimeSpan
'Usage

Dim instance As WebSocket
Dim value As System.TimeSpan

instance.KeepaliveTimeout = value

value = instance.KeepaliveTimeout
public abstract System.TimeSpan KeepaliveTimeout {get; set;}
public read-write property KeepaliveTimeout: System.TimeSpan; abstract;
public __abstract function get,set KeepaliveTimeout : System.TimeSpan
public: __property abstract System.TimeSpan get_KeepaliveTimeout();
public: __property abstract void set_KeepaliveTimeout(
   System.TimeSpan value
);
public:
abstract property System.TimeSpan KeepaliveTimeout {
   System.TimeSpan get();
   void set (    System.TimeSpan value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


MaxOutboundFrameSize Property (WebSocket)

MaxOutboundFrameSize Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : MaxOutboundFrameSize Property
Gets and sets the maximum size of outbound frame produced by the WebSocket.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxOutboundFrameSize As System.Long
'Usage

Dim instance As WebSocket
Dim value As System.Long

instance.MaxOutboundFrameSize = value

value = instance.MaxOutboundFrameSize
public System.long MaxOutboundFrameSize {get; set;}
public read-write property MaxOutboundFrameSize: System.Int64;
public function get,set MaxOutboundFrameSize : System.long
public: __property System.long get_MaxOutboundFrameSize();
public: __property void set_MaxOutboundFrameSize(
   System.long value
);
public:
property System.int64 MaxOutboundFrameSize {
   System.int64 get();
   void set (    System.int64 value);
}

Property Value

The maximum size of outbound message frame in bytes.
Remarks

The property controls the message fragmentation which is transparently performed by the WebSocket whenever necessary. If message is greater than the value specified by this property, it will be fragmented on frames that are smaller than specified value in bytes.

Note: When WebSocket framing extensions like compression are used by the channel, the final size of the frame may not necessary adhere to limit set by this property.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


MaxOutboundQueueSize Property (WebSocket)

MaxOutboundQueueSize Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : MaxOutboundQueueSize Property
Gets and sets the maximum size of outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxOutboundQueueSize As System.Long
'Usage

Dim instance As WebSocket
Dim value As System.Long

instance.MaxOutboundQueueSize = value

value = instance.MaxOutboundQueueSize
public System.long MaxOutboundQueueSize {get; set;}
public read-write property MaxOutboundQueueSize: System.Int64;
public function get,set MaxOutboundQueueSize : System.long
public: __property System.long get_MaxOutboundQueueSize();
public: __property void set_MaxOutboundQueueSize(
   System.long value
);
public:
property System.int64 MaxOutboundQueueSize {
   System.int64 get();
   void set (    System.int64 value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members
OutboundQueueSize Property


Origin Property (WebSocket)

Origin Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Origin Property
Gets a string that defines an Origin of this WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Origin As System.String
'Usage

Dim instance As WebSocket
Dim value As System.String

value = instance.Origin
public System.string Origin {get;}
public read-only property Origin: System.String;
public function get Origin : System.String
public: __property System.string* get_Origin();
public:
property System.String^ Origin {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


OutboundQueueSize Property (WebSocket)

OutboundQueueSize Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : OutboundQueueSize Property
Gets and sets the current size of outbound message queue.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutboundQueueSize As System.Long
'Usage

Dim instance As WebSocket
Dim value As System.Long

value = instance.OutboundQueueSize
public System.long OutboundQueueSize {get;}
public read-only property OutboundQueueSize: System.Int64;
public function get OutboundQueueSize : System.long
public: __property System.long get_OutboundQueueSize();
public:
property System.int64 OutboundQueueSize {
   System.int64 get();
}
Remarks
The size of outbound message queue reflects a amount of bytes pending to be sent asynchronously. It does not always reflect an amount of memory used by the outbound message queue per WebSocket connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


PayloadMasking Property (WebSocket)

PayloadMasking Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : PayloadMasking Property
Get or sets whether payload of outbound messages is masked.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PayloadMasking As System.Boolean
'Usage

Dim instance As WebSocket
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean;
public function get,set PayloadMasking : System.boolean
public: __property System.bool get_PayloadMasking();
public: __property void set_PayloadMasking(
   System.bool value
);
public:
property System.bool PayloadMasking {
   System.bool get();
   void set (    System.bool value);
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking by setting this property, but strict WebSocket implementations will drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Protocol Property (WebSocket)

Protocol Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Protocol Property
Gets a string that defines a Sub-Protocol used by this WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Protocol As System.String
'Usage

Dim instance As WebSocket
Dim value As System.String

value = instance.Protocol
public System.string Protocol {get;}
public read-only property Protocol: System.String;
public function get Protocol : System.String
public: __property System.string* get_Protocol();
public:
property System.String^ Protocol {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


State Property (WebSocket)

State Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : State Property
Gets the state of the WebSocket connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property State As WebSocketState
'Usage

Dim instance As WebSocket
Dim value As WebSocketState

value = instance.State
public WebSocketState State {get;}
public read-only property State: WebSocketState;
public function get State : WebSocketState
public: __property WebSocketState get_State();
public:
property WebSocketState State {
   WebSocketState get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


TraceSource Property (WebSocket)

TraceSource Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : TraceSource Property
Gets and sets the TraceSource to be used by the WebSocket instance for tracing events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocket
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Via Property (WebSocket)

Via Property (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : Via Property
Gets the _uri of remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Via As System.Uri
'Usage

Dim instance As WebSocket
Dim value As System.Uri

value = instance.Via
public System.Uri Via {get;}
public read-only property Via: System.Uri;
public function get Via : System.Uri
public: __property System.Uri* get_Via();
public:
property System.Uri^ Via {
   System.Uri^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


WebSocket Class Events

WebSocket Class Events

Noemax.WebSockets.Core Namespace : WebSocket Class

For a list of all members of this type, see WebSocket members.

Public Events
 | Name | Description
Public Event | OnCloseFrame | Notifies the event handlers when Close frame was received from the remote endpoint.
Public Event | OnPing | Notifies the event handlers when Ping frame was received from the remote endpoint.
Public Event | OnPong | Notifies the event handlers when Pong frame was received from the remote endpoint.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


OnCloseFrame Event (WebSocket)

OnCloseFrame Event (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : OnCloseFrame Event
Notifies the event handlers when Close frame was received from the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnCloseFrame As System.EventHandler(Of WebSocketCloseEventArgs)
'Usage

Dim instance As WebSocket
Dim handler As System.EventHandler(Of WebSocketCloseEventArgs)

AddHandler instance.OnCloseFrame, handler
public event System.EventHandler<WebSocketCloseEventArgs> OnCloseFrame
public event OnCloseFrame: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketCloseEventArgs*>* OnCloseFrame
public:
event System.EventHandler<WebSocketCloseEventArgs^>^ OnCloseFrame
Event Data

The event handler receives an argument of type WebSocketCloseEventArgs containing data related to this event. The following WebSocketCloseEventArgs properties provide information specific to this event.

Property | Description
Description | The description of the status with which the connection is being closed.
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
StatusCode | The status code with which the connection is being closed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


OnPing Event (WebSocket)

OnPing Event (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : OnPing Event
Notifies the event handlers when Ping frame was received from the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnPing As System.EventHandler(Of WebSocketPingOrPongEventArgs)
'Usage

Dim instance As WebSocket
Dim handler As System.EventHandler(Of WebSocketPingOrPongEventArgs)

AddHandler instance.OnPing, handler
public event System.EventHandler<WebSocketPingOrPongEventArgs> OnPing
public event OnPing: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketPingOrPongEventArgs*>* OnPing
public:
event System.EventHandler<WebSocketPingOrPongEventArgs^>^ OnPing
Event Data

The event handler receives an argument of type WebSocketPingOrPongEventArgs containing data related to this event. The following WebSocketPingOrPongEventArgs properties provide information specific to this event.

Property | Description
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


OnPong Event (WebSocket)

OnPong Event (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : OnPong Event
Notifies the event handlers when Pong frame was received from the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnPong As System.EventHandler(Of WebSocketPingOrPongEventArgs)
'Usage

Dim instance As WebSocket
Dim handler As System.EventHandler(Of WebSocketPingOrPongEventArgs)

AddHandler instance.OnPong, handler
public event System.EventHandler<WebSocketPingOrPongEventArgs> OnPong
public event OnPong: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.EventHandler<WebSocketPingOrPongEventArgs*>* OnPong
public:
event System.EventHandler<WebSocketPingOrPongEventArgs^>^ OnPong
Event Data

The event handler receives an argument of type WebSocketPingOrPongEventArgs containing data related to this event. The following WebSocketPingOrPongEventArgs properties provide information specific to this event.

Property | Description
OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


WebSocketClientSecurity Class

WebSocketClientSecurity Class
Members

Noemax.WebSockets.Core Namespace : WebSocketClientSecurity Class
Provides properties that apply when SSL/TLS transport security is enabled.
Object Model
WebSocketClientSecurity Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketClientSecurity
'Usage

Dim instance As WebSocketClientSecurity
public class WebSocketClientSecurity
public class WebSocketClientSecurity
public class WebSocketClientSecurity
public __gc class WebSocketClientSecurity
public ref class WebSocketClientSecurity
Remarks

If the URI of the target WebSocket server includes 'wss' or 'https' schema, SSL/TLS transport security is enabled automatically and server is expected to perform SSL/TLS handshake and provide server certificate. Communication would fail with AuthenticationException in cases when the target server does not support SSL/TLS transport security.

Note this class and all associated properties are not included into cryptography free versions of assemblies.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.Core.WebSocketClientSecurity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Members
Noemax.WebSockets.Core Namespace


WebSocketClientSecurity Class Members

WebSocketClientSecurity Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocketClientSecurity Class

The following tables list the members exposed by WebSocketClientSecurity.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClientSecurity Constructor | Initializes a new instance of the class.
Top
Public Properties
 | Name | Description
Public Property | CheckCertificateRevocation | Gets and sets whether the client should check the server certificate chain for revocation.
Public Property | ClientCertificate | Gets and sets the client certificate to be used when client authentication is required by remote side.
Public Property | ServerCertificate | Gets and sets the certificate that the target server is expected to provide during server authentication.
Public Property | TargetHost | Gets and sets the string identifying the host the remote server certificate expected to specify in the the Subject field of certificate e.g. 'CN=www.myhost.com'.
Public Property | UsernameForProxy | Gets and sets a credentials to be used to authenticated with HTTP proxy.
Public Property | UsernameForServer | Gets and sets a credentials to be used to authenticate with WebSocket server if it requires HTTP authentication.
Top
Public Methods
 | Name | Description
Public Method | SetClientCertificate | Overloaded. Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Top
Public Events
 | Name | Description
Public Event | OnValidateCertificate | Event occurs during server certificate validation. Provide an event handler to perform an additional custom certificate validation.
Top
See Also

Reference

WebSocketClientSecurity Class
Noemax.WebSockets.Core Namespace


WebSocketClientSecurity Constructor

WebSocketClientSecurity Constructor

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : WebSocketClientSecurity Constructor
Initializes a new instance of the class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketClientSecurity()
public WebSocketClientSecurity()
public WebSocketClientSecurity();
public function WebSocketClientSecurity();
public: WebSocketClientSecurity();
public:
WebSocketClientSecurity();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


WebSocketClientSecurity Class Methods

WebSocketClientSecurity Class Methods

Noemax.WebSockets.Core Namespace : WebSocketClientSecurity Class

For a list of all members of this type, see WebSocketClientSecurity members.

Public Methods
 | Name | Description
Public Method | SetClientCertificate | Overloaded. Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Top
See Also

Reference

WebSocketClientSecurity Class
Noemax.WebSockets.Core Namespace


SetClientCertificate Method (WebSocketClientSecurity)

SetClientCertificate Method (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : SetClientCertificate Method
Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Overload List
Overload | Description
SetClientCertificate(Byte[],Char[]) | Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
SetClientCertificate(Byte[],String) | Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


SetClientCertificate(Byte[],Char[]) Method

SetClientCertificate(Byte[],Char[]) Method

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class > SetClientCertificate Method : SetClientCertificate(Byte[],Char[]) Method
The array of bytes containing the PKCS#12 storage.
The password for PKCS#12 storage.
Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetClientCertificate( _
   ByVal pkcs12() As System.Byte, _
   ByVal password() As System.Char _
)
'Usage

Dim instance As WebSocketClientSecurity
Dim pkcs12() As System.Byte
Dim password() As System.Char

instance.SetClientCertificate(pkcs12, password)
public void SetClientCertificate(
   System.byte[] pkcs12,
   System.char[] password
)
public procedure SetClientCertificate(
    pkcs12: System.Bytearray of;
    password: System.Chararray of
);
public function SetClientCertificate(
   pkcs12 : System.byte[],
   password : System.char[]
);
public: void SetClientCertificate(
   System.byte[]* pkcs12,
   System.char[]* password
)
public:
void SetClientCertificate(
   System.array<byte>^ pkcs12,
   System.array<char>^ password
)

Parameters

pkcs12
The array of bytes containing the PKCS#12 storage.
password
The password for PKCS#12 storage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members
Overload List


SetClientCertificate(Byte[],String) Method

SetClientCertificate(Byte[],String) Method

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class > SetClientCertificate Method : SetClientCertificate(Byte[],String) Method
The array of bytes containing the PKCS#12 storage.
The password for PKCS#12 storage.
Sets the certificate loaded from the specified PKCS12 storage to be used by the client for TLS authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub SetClientCertificate( _
   ByVal pkcs12() As System.Byte, _
   ByVal password As System.String _
)
'Usage

Dim instance As WebSocketClientSecurity
Dim pkcs12() As System.Byte
Dim password As System.String

instance.SetClientCertificate(pkcs12, password)
public void SetClientCertificate(
   System.byte[] pkcs12,
   System.string password
)
public procedure SetClientCertificate(
    pkcs12: System.Bytearray of;
    password: System.String
);
public function SetClientCertificate(
   pkcs12 : System.byte[],
   password : System.String
);
public: void SetClientCertificate(
   System.byte[]* pkcs12,
   System.string* password
)
public:
void SetClientCertificate(
   System.array<byte>^ pkcs12,
   System.String^ password
)

Parameters

pkcs12
The array of bytes containing the PKCS#12 storage.
password
The password for PKCS#12 storage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members
Overload List


WebSocketClientSecurity Class Properties

WebSocketClientSecurity Class Properties

Noemax.WebSockets.Core Namespace : WebSocketClientSecurity Class

For a list of all members of this type, see WebSocketClientSecurity members.

Public Properties
 | Name | Description
Public Property | CheckCertificateRevocation | Gets and sets whether the client should check the server certificate chain for revocation.
Public Property | ClientCertificate | Gets and sets the client certificate to be used when client authentication is required by remote side.
Public Property | ServerCertificate | Gets and sets the certificate that the target server is expected to provide during server authentication.
Public Property | TargetHost | Gets and sets the string identifying the host the remote server certificate expected to specify in the the Subject field of certificate e.g. 'CN=www.myhost.com'.
Public Property | UsernameForProxy | Gets and sets a credentials to be used to authenticated with HTTP proxy.
Public Property | UsernameForServer | Gets and sets a credentials to be used to authenticate with WebSocket server if it requires HTTP authentication.
Top
See Also

Reference

WebSocketClientSecurity Class
Noemax.WebSockets.Core Namespace


CheckCertificateRevocation Property (WebSocketClientSecurity)

CheckCertificateRevocation Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : CheckCertificateRevocation Property
Gets and sets whether the client should check the server certificate chain for revocation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CheckCertificateRevocation As System.Boolean
'Usage

Dim instance As WebSocketClientSecurity
Dim value As System.Boolean

instance.CheckCertificateRevocation = value

value = instance.CheckCertificateRevocation
public System.bool CheckCertificateRevocation {get; set;}
public read-write property CheckCertificateRevocation: System.Boolean;
public function get,set CheckCertificateRevocation : System.boolean
public: __property System.bool get_CheckCertificateRevocation();
public: __property void set_CheckCertificateRevocation(
   System.bool value
);
public:
property System.bool CheckCertificateRevocation {
   System.bool get();
   void set (    System.bool value);
}
Remarks
Note: the self-signed certificates will fail the revocation check, so set this property to false. When using self-signed certificate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


ClientCertificate Property (WebSocketClientSecurity)

ClientCertificate Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : ClientCertificate Property
Gets and sets the client certificate to be used when client authentication is required by remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClientCertificate As System.Security.Cryptography.X509Certificates.X509Certificate
'Usage

Dim instance As WebSocketClientSecurity
Dim value As System.Security.Cryptography.X509Certificates.X509Certificate

instance.ClientCertificate = value

value = instance.ClientCertificate
public System.Security.Cryptography.X509Certificates.X509Certificate ClientCertificate {get; set;}
public read-write property ClientCertificate: System.Security.Cryptography.X509Certificates.X509Certificate;
public function get,set ClientCertificate : System.Security.Cryptography.X509Certificates.X509Certificate
public: __property System.Security.Cryptography.X509Certificates.X509Certificate* get_ClientCertificate();
public: __property void set_ClientCertificate(
   System.Security.Cryptography.X509Certificates.X509Certificate* value
);
public:
property System.Security.Cryptography.X509Certificates.X509Certificate^ ClientCertificate {
   System.Security.Cryptography.X509Certificates.X509Certificate^ get();
   void set (    System.Security.Cryptography.X509Certificates.X509Certificate^ value);
}
Remarks
Client certificate is used for client authentication and presented to the server side during SSL/TLS handshake. In order to use client certificate for client authentication, application should have an access the private key associated to the client certificate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


ServerCertificate Property (WebSocketClientSecurity)

ServerCertificate Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : ServerCertificate Property
Gets and sets the certificate that the target server is expected to provide during server authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ServerCertificate As System.Security.Cryptography.X509Certificates.X509Certificate
'Usage

Dim instance As WebSocketClientSecurity
Dim value As System.Security.Cryptography.X509Certificates.X509Certificate

instance.ServerCertificate = value

value = instance.ServerCertificate
public System.Security.Cryptography.X509Certificates.X509Certificate ServerCertificate {get; set;}
public read-write property ServerCertificate: System.Security.Cryptography.X509Certificates.X509Certificate;
public function get,set ServerCertificate : System.Security.Cryptography.X509Certificates.X509Certificate
public: __property System.Security.Cryptography.X509Certificates.X509Certificate* get_ServerCertificate();
public: __property void set_ServerCertificate(
   System.Security.Cryptography.X509Certificates.X509Certificate* value
);
public:
property System.Security.Cryptography.X509Certificates.X509Certificate^ ServerCertificate {
   System.Security.Cryptography.X509Certificates.X509Certificate^ get();
   void set (    System.Security.Cryptography.X509Certificates.X509Certificate^ value);
}

Property Value

ServerCertificate
Remarks

Default value is Null. If this property is not Null, the certificate specified by this property is getting compared to the server certificate provided by remote side during the SSL/TLS authentication. If they do not match each other, than server authentication fails and AuthenticationException is thrown.

If ServerCertificate does match the certificate provided by remote side, then the remote side certificate is accepted as valid. This type of authentication is useful when remote side is using self signed certificate and cannot be validated by certification authority.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


TargetHost Property (WebSocketClientSecurity)

TargetHost Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : TargetHost Property
Gets and sets the string identifying the host the remote server certificate expected to specify in the the Subject field of certificate e.g. 'CN=www.myhost.com'.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TargetHost As System.String
'Usage

Dim instance As WebSocketClientSecurity
Dim value As System.String

instance.TargetHost = value

value = instance.TargetHost
public System.string TargetHost {get; set;}
public read-write property TargetHost: System.String;
public function get,set TargetHost : System.String
public: __property System.string* get_TargetHost();
public: __property void set_TargetHost(
   System.string* value
);
public:
property System.String^ TargetHost {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
Set this property to the common name of the X09Certificate used by the destination endpoint. If the common name of the certificate does not match neither the TargetHost property value nor the host specified in the URI of destination endpoint, the server certificate validation fails.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


UsernameForProxy Property (WebSocketClientSecurity)

UsernameForProxy Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : UsernameForProxy Property
Gets and sets a credentials to be used to authenticated with HTTP proxy.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UsernameForProxy As WebSocketUsernamePasswordCredentials
'Usage

Dim instance As WebSocketClientSecurity
Dim value As WebSocketUsernamePasswordCredentials

instance.UsernameForProxy = value

value = instance.UsernameForProxy
public WebSocketUsernamePasswordCredentials UsernameForProxy {get; set;}
public read-write property UsernameForProxy: WebSocketUsernamePasswordCredentials;
public function get,set UsernameForProxy : WebSocketUsernamePasswordCredentials
public: __property WebSocketUsernamePasswordCredentials* get_UsernameForProxy();
public: __property void set_UsernameForProxy(
   WebSocketUsernamePasswordCredentials* value
);
public:
property WebSocketUsernamePasswordCredentials^ UsernameForProxy {
   WebSocketUsernamePasswordCredentials^ get();
   void set (    WebSocketUsernamePasswordCredentials^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


UsernameForServer Property (WebSocketClientSecurity)

UsernameForServer Property (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : UsernameForServer Property
Gets and sets a credentials to be used to authenticate with WebSocket server if it requires HTTP authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UsernameForServer As WebSocketUsernamePasswordCredentials
'Usage

Dim instance As WebSocketClientSecurity
Dim value As WebSocketUsernamePasswordCredentials

instance.UsernameForServer = value

value = instance.UsernameForServer
public WebSocketUsernamePasswordCredentials UsernameForServer {get; set;}
public read-write property UsernameForServer: WebSocketUsernamePasswordCredentials;
public function get,set UsernameForServer : WebSocketUsernamePasswordCredentials
public: __property WebSocketUsernamePasswordCredentials* get_UsernameForServer();
public: __property void set_UsernameForServer(
   WebSocketUsernamePasswordCredentials* value
);
public:
property WebSocketUsernamePasswordCredentials^ UsernameForServer {
   WebSocketUsernamePasswordCredentials^ get();
   void set (    WebSocketUsernamePasswordCredentials^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


WebSocketClientSecurity Class Events

WebSocketClientSecurity Class Events

Noemax.WebSockets.Core Namespace : WebSocketClientSecurity Class

For a list of all members of this type, see WebSocketClientSecurity members.

Public Events
 | Name | Description
Public Event | OnValidateCertificate | Event occurs during server certificate validation. Provide an event handler to perform an additional custom certificate validation.
Top
See Also

Reference

WebSocketClientSecurity Class
Noemax.WebSockets.Core Namespace


OnValidateCertificate Event (WebSocketClientSecurity)

OnValidateCertificate Event (WebSocketClientSecurity)

Noemax.WebSockets.Core Namespace > WebSocketClientSecurity Class : OnValidateCertificate Event
Event occurs during server certificate validation. Provide an event handler to perform an additional custom certificate validation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event OnValidateCertificate As X509CertificateValidationCallback
'Usage

Dim instance As WebSocketClientSecurity
Dim handler As X509CertificateValidationCallback

AddHandler instance.OnValidateCertificate, handler
public event X509CertificateValidationCallback OnValidateCertificate
public event OnValidateCertificate: X509CertificateValidationCallback;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event X509CertificateValidationCallback* OnValidateCertificate
public:
event X509CertificateValidationCallback^ OnValidateCertificate
Remarks

The event handler is expected to throw an exception if a remote certificate is not valid; otherwise the it is considered being valid.

Note prior this event occurs, WebSocketClient performs internal certificate validation according to its security settings.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClientSecurity Class
WebSocketClientSecurity Members


WebSocketCloseCodes Class

WebSocketCloseCodes Class
Members

Noemax.WebSockets.Core Namespace : WebSocketCloseCodes Class
Defines the constants to be used with for sending the WebSocket close frame status code that define the reason for closing the connection.
Object Model
WebSocketCloseCodes Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit NotInheritable Class WebSocketCloseCodes
'Usage

Dim instance As WebSocketCloseCodes
public static class WebSocketCloseCodes
public class WebSocketCloseCodes abstract; sealed;
public abstract sealed class WebSocketCloseCodes
public __gc abstract __sealed class WebSocketCloseCodes
public ref class WebSocketCloseCodes abstract sealed
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Core.WebSocketCloseCodes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Members
Noemax.WebSockets.Core Namespace


WebSocketCloseCodes Class Members

WebSocketCloseCodes Class Members
Fields

Noemax.WebSockets.Core Namespace : WebSocketCloseCodes Class

The following tables list the members exposed by WebSocketCloseCodes.

Public Fields
 | Name | Description
Public Field | ExtensionRequired | 1010 indicates that an endpoint (client) is terminating the connection because it has expected the server to negotiate one or more extension, but the server didn't return them in the response message of the WebSocket handshake. The list of extensions that are needed SHOULD appear in the /reason/ part of the Close frame. Note that this status code is not used by the server, because it can fail the WebSocket handshake instead.
Public Field | GoingAway | 1001 indicates that an endpoint is "going away", such as a server going down or a browser having navigated away from a page.
Public Field | InconsistentData | 1007 indicates that an endpoint is terminating the connection because it has received data within a message that was not consistent with the type of the message (e.g., non-UTF-8 [RFC3629] data within a text message).
Public Field | MessageToBig | 1009 indicates that an endpoint is terminating the connection because it has received a message that is too big for it to process.
Public Field | MessageViolatesPolicy | 1008 indicates that an endpoint is terminating the connection because it has received a message that violates its policy. This is a generic status code that can be returned when there is no other more suitable status code (e.g., 1003 or 1009) or if there is a need to hide specific details about the policy.
Public Field | Normal | 1000 indicates a normal closure, meaning that the purpose for which the connection was established has been fulfilled.
Public Field | ProtocolError | 1002 indicates that an endpoint is terminating the connection due to a protocol error.
Public Field | UnexpectedFailure | 1011 indicates that a endpoint is terminating the connection because it encountered an unexpected condition that prevented it from processing the message.
Public Field | UnsupportedPayloadType | 1003 indicates that an endpoint is terminating the connection because it has received a type of data it cannot accept (e.g., an endpoint that understands only text data MAY send this if it receives a binary message).
Top
See Also

Reference

WebSocketCloseCodes Class
Noemax.WebSockets.Core Namespace


WebSocketCloseCodes Class Fields

WebSocketCloseCodes Class Fields

Noemax.WebSockets.Core Namespace : WebSocketCloseCodes Class

For a list of all members of this type, see WebSocketCloseCodes members.

Public Fields
 | Name | Description
Public Field | ExtensionRequired | 1010 indicates that an endpoint (client) is terminating the connection because it has expected the server to negotiate one or more extension, but the server didn't return them in the response message of the WebSocket handshake. The list of extensions that are needed SHOULD appear in the /reason/ part of the Close frame. Note that this status code is not used by the server, because it can fail the WebSocket handshake instead.
Public Field | GoingAway | 1001 indicates that an endpoint is "going away", such as a server going down or a browser having navigated away from a page.
Public Field | InconsistentData | 1007 indicates that an endpoint is terminating the connection because it has received data within a message that was not consistent with the type of the message (e.g., non-UTF-8 [RFC3629] data within a text message).
Public Field | MessageToBig | 1009 indicates that an endpoint is terminating the connection because it has received a message that is too big for it to process.
Public Field | MessageViolatesPolicy | 1008 indicates that an endpoint is terminating the connection because it has received a message that violates its policy. This is a generic status code that can be returned when there is no other more suitable status code (e.g., 1003 or 1009) or if there is a need to hide specific details about the policy.
Public Field | Normal | 1000 indicates a normal closure, meaning that the purpose for which the connection was established has been fulfilled.
Public Field | ProtocolError | 1002 indicates that an endpoint is terminating the connection due to a protocol error.
Public Field | UnexpectedFailure | 1011 indicates that a endpoint is terminating the connection because it encountered an unexpected condition that prevented it from processing the message.
Public Field | UnsupportedPayloadType | 1003 indicates that an endpoint is terminating the connection because it has received a type of data it cannot accept (e.g., an endpoint that understands only text data MAY send this if it receives a binary message).
Top
See Also

Reference

WebSocketCloseCodes Class
Noemax.WebSockets.Core Namespace


ExtensionRequired Field (WebSocketCloseCodes)

ExtensionRequired Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : ExtensionRequired Field
1010 indicates that an endpoint (client) is terminating the connection because it has expected the server to negotiate one or more extension, but the server didn't return them in the response message of the WebSocket handshake. The list of extensions that are needed SHOULD appear in the /reason/ part of the Close frame. Note that this status code is not used by the server, because it can fail the WebSocket handshake instead.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const ExtensionRequired As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.ExtensionRequired
public const System.int ExtensionRequired
public field ExtensionRequired: System.Integer; Const
public constvar ExtensionRequired : System.int;
public: const System.int ExtensionRequired
public:
const System.int ExtensionRequired
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


GoingAway Field (WebSocketCloseCodes)

GoingAway Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : GoingAway Field
1001 indicates that an endpoint is "going away", such as a server going down or a browser having navigated away from a page.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const GoingAway As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.GoingAway
public const System.int GoingAway
public field GoingAway: System.Integer; Const
public constvar GoingAway : System.int;
public: const System.int GoingAway
public:
const System.int GoingAway
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


InconsistentData Field (WebSocketCloseCodes)

InconsistentData Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : InconsistentData Field
1007 indicates that an endpoint is terminating the connection because it has received data within a message that was not consistent with the type of the message (e.g., non-UTF-8 [RFC3629] data within a text message).
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const InconsistentData As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.InconsistentData
public const System.int InconsistentData
public field InconsistentData: System.Integer; Const
public constvar InconsistentData : System.int;
public: const System.int InconsistentData
public:
const System.int InconsistentData
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


MessageToBig Field (WebSocketCloseCodes)

MessageToBig Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : MessageToBig Field
1009 indicates that an endpoint is terminating the connection because it has received a message that is too big for it to process.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const MessageToBig As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.MessageToBig
public const System.int MessageToBig
public field MessageToBig: System.Integer; Const
public constvar MessageToBig : System.int;
public: const System.int MessageToBig
public:
const System.int MessageToBig
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


MessageViolatesPolicy Field (WebSocketCloseCodes)

MessageViolatesPolicy Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : MessageViolatesPolicy Field
1008 indicates that an endpoint is terminating the connection because it has received a message that violates its policy. This is a generic status code that can be returned when there is no other more suitable status code (e.g., 1003 or 1009) or if there is a need to hide specific details about the policy.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const MessageViolatesPolicy As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.MessageViolatesPolicy
public const System.int MessageViolatesPolicy
public field MessageViolatesPolicy: System.Integer; Const
public constvar MessageViolatesPolicy : System.int;
public: const System.int MessageViolatesPolicy
public:
const System.int MessageViolatesPolicy
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


Normal Field (WebSocketCloseCodes)

Normal Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : Normal Field
1000 indicates a normal closure, meaning that the purpose for which the connection was established has been fulfilled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const Normal As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.Normal
public const System.int Normal
public field Normal: System.Integer; Const
public constvar Normal : System.int;
public: const System.int Normal
public:
const System.int Normal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


ProtocolError Field (WebSocketCloseCodes)

ProtocolError Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : ProtocolError Field
1002 indicates that an endpoint is terminating the connection due to a protocol error.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const ProtocolError As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.ProtocolError
public const System.int ProtocolError
public field ProtocolError: System.Integer; Const
public constvar ProtocolError : System.int;
public: const System.int ProtocolError
public:
const System.int ProtocolError
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


UnexpectedFailure Field (WebSocketCloseCodes)

UnexpectedFailure Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : UnexpectedFailure Field
1011 indicates that a endpoint is terminating the connection because it encountered an unexpected condition that prevented it from processing the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const UnexpectedFailure As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.UnexpectedFailure
public const System.int UnexpectedFailure
public field UnexpectedFailure: System.Integer; Const
public constvar UnexpectedFailure : System.int;
public: const System.int UnexpectedFailure
public:
const System.int UnexpectedFailure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


UnsupportedPayloadType Field (WebSocketCloseCodes)

UnsupportedPayloadType Field (WebSocketCloseCodes)

Noemax.WebSockets.Core Namespace > WebSocketCloseCodes Class : UnsupportedPayloadType Field
1003 indicates that an endpoint is terminating the connection because it has received a type of data it cannot accept (e.g., an endpoint that understands only text data MAY send this if it receives a binary message).
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Const UnsupportedPayloadType As System.Integer
'Usage

Dim value As System.Integer

value = WebSocketCloseCodes.UnsupportedPayloadType
public const System.int UnsupportedPayloadType
public field UnsupportedPayloadType: System.Integer; Const
public constvar UnsupportedPayloadType : System.int;
public: const System.int UnsupportedPayloadType
public:
const System.int UnsupportedPayloadType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseCodes Class
WebSocketCloseCodes Members


WebSocketCloseEventArgs Class

WebSocketCloseEventArgs Class
Members

Noemax.WebSockets.Core Namespace : WebSocketCloseEventArgs Class
Provides methods and properties for the close event arguments.
Object Model
WebSocketCloseEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketCloseEventArgs
   Inherits ControlFrameEventArgs
'Usage

Dim instance As WebSocketCloseEventArgs
public class WebSocketCloseEventArgs : ControlFrameEventArgs
public class WebSocketCloseEventArgs = class(ControlFrameEventArgs)
public class WebSocketCloseEventArgs extends ControlFrameEventArgs
public __gc class WebSocketCloseEventArgs : public ControlFrameEventArgs
public ref class WebSocketCloseEventArgs : public ControlFrameEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.Core.ControlFrameEventArgs
Noemax.WebSockets.Core.WebSocketCloseEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseEventArgs Members
Noemax.WebSockets.Core Namespace


WebSocketCloseEventArgs Class Members

WebSocketCloseEventArgs Class Members
Properties

Noemax.WebSockets.Core Namespace : WebSocketCloseEventArgs Class

The following tables list the members exposed by WebSocketCloseEventArgs.

Public Constructors
 | Name | Description
Public Constructor | WebSocketCloseEventArgs Constructor | Creates a new instance of WebSocketCloseEventArgs.
Top
Public Properties
 | Name | Description
Public Property | Description | The description of the status with which the connection is being closed.
Public Property | OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | StatusCode | The status code with which the connection is being closed.
Top
See Also

Reference

WebSocketCloseEventArgs Class
Noemax.WebSockets.Core Namespace


WebSocketCloseEventArgs Constructor

WebSocketCloseEventArgs Constructor

Noemax.WebSockets.Core Namespace > WebSocketCloseEventArgs Class : WebSocketCloseEventArgs Constructor
The WebSocket instance.
The close status code.
The description of the close event status.
Creates a new instance of WebSocketCloseEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal socket As WebSocket, _
   ByVal statusCode As System.Short, _
   ByVal description As System.String _
)
'Usage

Dim socket As WebSocket
Dim statusCode As System.Short
Dim description As System.String

Dim instance As New WebSocketCloseEventArgs(socket, statusCode, description)
public WebSocketCloseEventArgs(
   WebSocket socket,
   System.short statusCode,
   System.string description
)
public WebSocketCloseEventArgs(
    socket: WebSocket;
    statusCode: System.Int16;
    description: System.String
);
public function WebSocketCloseEventArgs(
   socket : WebSocket,
   statusCode : System.short,
   description : System.String
);
public: WebSocketCloseEventArgs(
   WebSocket* socket,
   System.short statusCode,
   System.string* description
)
public:
WebSocketCloseEventArgs(
   WebSocket^ socket,
   System.short statusCode,
   System.String^ description
)

Parameters

socket
The WebSocket instance.
statusCode
The close status code.
description
The description of the close event status.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseEventArgs Class
WebSocketCloseEventArgs Members


WebSocketCloseEventArgs Class Properties

WebSocketCloseEventArgs Class Properties

Noemax.WebSockets.Core Namespace : WebSocketCloseEventArgs Class

For a list of all members of this type, see WebSocketCloseEventArgs members.

Public Properties
 | Name | Description
Public Property | Description | The description of the status with which the connection is being closed.
Public Property | OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | StatusCode | The status code with which the connection is being closed.
Top
See Also

Reference

WebSocketCloseEventArgs Class
Noemax.WebSockets.Core Namespace


Description Property (WebSocketCloseEventArgs)

Description Property (WebSocketCloseEventArgs)

Noemax.WebSockets.Core Namespace > WebSocketCloseEventArgs Class : Description Property
The description of the status with which the connection is being closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Description As System.String
'Usage

Dim instance As WebSocketCloseEventArgs
Dim value As System.String

value = instance.Description
public System.string Description {get;}
public read-only property Description: System.String;
public function get Description : System.String
public: __property System.string* get_Description();
public:
property System.String^ Description {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseEventArgs Class
WebSocketCloseEventArgs Members


StatusCode Property (WebSocketCloseEventArgs)

StatusCode Property (WebSocketCloseEventArgs)

Noemax.WebSockets.Core Namespace > WebSocketCloseEventArgs Class : StatusCode Property
The status code with which the connection is being closed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property StatusCode As System.Short
'Usage

Dim instance As WebSocketCloseEventArgs
Dim value As System.Short

value = instance.StatusCode
public System.short StatusCode {get;}
public read-only property StatusCode: System.Int16;
public function get StatusCode : System.short
public: __property System.short get_StatusCode();
public:
property System.short StatusCode {
   System.short get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseEventArgs Class
WebSocketCloseEventArgs Members


WebSocketErrorEventArgs Class

WebSocketErrorEventArgs Class
Members

Noemax.WebSockets.Core Namespace : WebSocketErrorEventArgs Class
Provides methods and properties for error event arguments.
Object Model
WebSocketErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketErrorEventArgs
   Inherits System.EventArgs
'Usage

Dim instance As WebSocketErrorEventArgs
public class WebSocketErrorEventArgs : System.EventArgs
public class WebSocketErrorEventArgs = class(System.EventArgs)
public class WebSocketErrorEventArgs extends System.EventArgs
public __gc class WebSocketErrorEventArgs : public System.EventArgs
public ref class WebSocketErrorEventArgs : public System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.Core.WebSocketErrorEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketErrorEventArgs Members
Noemax.WebSockets.Core Namespace


WebSocketErrorEventArgs Class Members

WebSocketErrorEventArgs Class Members
Properties

Noemax.WebSockets.Core Namespace : WebSocketErrorEventArgs Class

The following tables list the members exposed by WebSocketErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | WebSocketErrorEventArgs Constructor | Initializes a new instance of WebSocketErrorEventArgs.
Top
Public Properties
 | Name | Description
Public Property | Error | The error encountered by the WebSocket instance of the service that handles the connection.
Top
See Also

Reference

WebSocketErrorEventArgs Class
Noemax.WebSockets.Core Namespace


WebSocketErrorEventArgs Constructor

WebSocketErrorEventArgs Constructor

Noemax.WebSockets.Core Namespace > WebSocketErrorEventArgs Class : WebSocketErrorEventArgs Constructor
Initializes a new instance of WebSocketErrorEventArgs.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal exception As System.Exception _
)
'Usage

Dim exception As System.Exception

Dim instance As New WebSocketErrorEventArgs(exception)
public WebSocketErrorEventArgs(
   System.Exception exception
)
public WebSocketErrorEventArgs(
    exception: System.Exception
);
public function WebSocketErrorEventArgs(
   exception : System.Exception
);
public: WebSocketErrorEventArgs(
   System.Exception* exception
)
public:
WebSocketErrorEventArgs(
   System.Exception^ exception
)

Parameters

exception
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketErrorEventArgs Class
WebSocketErrorEventArgs Members


WebSocketErrorEventArgs Class Properties

WebSocketErrorEventArgs Class Properties

Noemax.WebSockets.Core Namespace : WebSocketErrorEventArgs Class

For a list of all members of this type, see WebSocketErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | Error | The error encountered by the WebSocket instance of the service that handles the connection.
Top
See Also

Reference

WebSocketErrorEventArgs Class
Noemax.WebSockets.Core Namespace


Error Property (WebSocketErrorEventArgs)

Error Property (WebSocketErrorEventArgs)

Noemax.WebSockets.Core Namespace > WebSocketErrorEventArgs Class : Error Property
The error encountered by the WebSocket instance of the service that handles the connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Error As System.Exception
'Usage

Dim instance As WebSocketErrorEventArgs
Dim value As System.Exception

value = instance.Error
public System.Exception Error {get;}
public read-only property Error: System.Exception;
public function get Error : System.Exception
public: __property System.Exception* get_Error();
public:
property System.Exception^ Error {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketErrorEventArgs Class
WebSocketErrorEventArgs Members


WebSocketFactory Class

WebSocketFactory Class
Members

Noemax.WebSockets.Core Namespace : WebSocketFactory Class
Creates and manages client WebSocket connections.
Object Model
WebSocketFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketFactory
'Usage

Dim instance As WebSocketFactory
public class WebSocketFactory
public class WebSocketFactory
public class WebSocketFactory
public __gc class WebSocketFactory
public ref class WebSocketFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Core.WebSocketFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Members
Noemax.WebSockets.Core Namespace


WebSocketFactory Class Members

WebSocketFactory Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

The following tables list the members exposed by WebSocketFactory.

Public Constructors
 | Name | Description
Public Constructor | WebSocketFactory Constructor | Initialize a new instance of WebSocketFactory.
Top
Public Properties
 | Name | Description
Public Property | BypassProxyOnLocal | Gets and sets whether the factory should bypass local proxies when establishing a client connection.
Public Property | Compression | Gets and set whether the transport compression should be applied and what compression method to use for compressing the traffic.
Public Property | CookieContainer | Gets and sets CookieContainer used by the WebSocketFactory instance.
Public Property | Extensions | Gets and sets the string specifying extensions supported by the WebSocket client.
Public Property | MaxRedirects | Gets and sets the maximum number of times the remote endpoints can redirect the client connection during WebSocket handshake.
Public Property | Origin | Gets and sets the string identifying the origin of WebSocket client.
Public Property | OutboundHandshakeHeaders | Gets the collection of handshake headers to be sent to remote endpoint during the WebSocket handshake;
Public Property | PayloadMasking | Gets and sets whether the WebSocket instances created by this factory should mask payload sent to the server.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocket client.
Public Property | ProxyAddress | Gets and sets the address of the web proxy to be used by the factory when establishing connection.
Public Property | Security | Provides properties that apply when the SSL/TLS transport security is enabled.
Public Property | StreamUpgradeProvider | Gets and set the WCF StreamUpgradeProvider to be upgrade the input of established connections.
Public Property | TraceSource | Gets and sets the trace source to be used for tracing WebSocket activities.
Public Property | UseDefaultWebProxy | Gets and sets whether the factory should use default web proxy when establishing a client connection.
Top
Public Methods
 | Name | Description
Public Method | Connect | Overloaded. Creates a new WebSocket connection to the specified destination URI string.
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered during WebSocket handshake.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


WebSocketFactory Constructor

WebSocketFactory Constructor

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : WebSocketFactory Constructor
Initialize a new instance of WebSocketFactory.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketFactory()
public WebSocketFactory()
public WebSocketFactory();
public function WebSocketFactory();
public: WebSocketFactory();
public:
WebSocketFactory();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


WebSocketFactory Class Methods

WebSocketFactory Class Methods

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

For a list of all members of this type, see WebSocketFactory members.

Public Methods
 | Name | Description
Public Method | Connect | Overloaded. Creates a new WebSocket connection to the specified destination URI string.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


Connect Method (WebSocketFactory)

Connect Method (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Connect Method
Creates a new WebSocket connection to the specified destination URI string.
Overload List
Overload | Description
Connect(String) | Creates a new WebSocket connection to the specified destination URI string.
Connect(String,TimeSpan) | Creates a new WebSocket connection to the specified destination URI string.
Connect(Uri) | Create a new WebSocket connection to the specified destination URI.
Connect(Uri,TimeSpan) | Create a new WebSocket connection to the specified destination URI.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Connect(String) Method

Connect(String) Method

Noemax.WebSockets.Core Namespace > WebSocketFactory Class > Connect Method : Connect(String) Method
The URI to the WebSocket endpoint.
Creates a new WebSocket connection to the specified destination URI string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Connect( _
   ByVal uri As System.String _
) As WebSocket
'Usage

Dim instance As WebSocketFactory
Dim uri As System.String
Dim value As WebSocket

value = instance.Connect(uri)
public WebSocket Connect(
   System.string uri
)
public function Connect(
    uri: System.String
): WebSocket;
public function Connect(
   uri : System.String
) : WebSocket;
public: WebSocket* Connect(
   System.string* uri
)
public:
WebSocket^ Connect(
   System.String^ uri
)

Parameters

uri
The URI to the WebSocket endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members
Overload List


Connect(String,TimeSpan) Method

Connect(String,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocketFactory Class > Connect Method : Connect(String,TimeSpan) Method
The URI to the WebSocket endpoint.
The period of time during which operation is to be complete or timeout.
Creates a new WebSocket connection to the specified destination URI string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Connect( _
   ByVal uri As System.String, _
   ByVal timeout As System.TimeSpan _
) As WebSocket
'Usage

Dim instance As WebSocketFactory
Dim uri As System.String
Dim timeout As System.TimeSpan
Dim value As WebSocket

value = instance.Connect(uri, timeout)
public WebSocket Connect(
   System.string uri,
   System.TimeSpan timeout
)
public function Connect(
    uri: System.String;
    timeout: System.TimeSpan
): WebSocket;
public function Connect(
   uri : System.String,
   timeout : System.TimeSpan
) : WebSocket;
public: WebSocket* Connect(
   System.string* uri,
   System.TimeSpan timeout
)
public:
WebSocket^ Connect(
   System.String^ uri,
   System.TimeSpan timeout
)

Parameters

uri
The URI to the WebSocket endpoint.
timeout
The period of time during which operation is to be complete or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members
Overload List


Connect(Uri) Method

Connect(Uri) Method

Noemax.WebSockets.Core Namespace > WebSocketFactory Class > Connect Method : Connect(Uri) Method
The URI to the WebSocket endpoint.
Create a new WebSocket connection to the specified destination URI.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Connect( _
   ByVal uri As System.Uri _
) As WebSocket
'Usage

Dim instance As WebSocketFactory
Dim uri As System.Uri
Dim value As WebSocket

value = instance.Connect(uri)
public WebSocket Connect(
   System.Uri uri
)
public function Connect(
    uri: System.Uri
): WebSocket;
public function Connect(
   uri : System.Uri
) : WebSocket;
public: WebSocket* Connect(
   System.Uri* uri
)
public:
WebSocket^ Connect(
   System.Uri^ uri
)

Parameters

uri
The URI to the WebSocket endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members
Overload List


Connect(Uri,TimeSpan) Method

Connect(Uri,TimeSpan) Method

Noemax.WebSockets.Core Namespace > WebSocketFactory Class > Connect Method : Connect(Uri,TimeSpan) Method
The URI to the WebSocket endpoint.
The period of time during which operation is to be complete or timeout.
Create a new WebSocket connection to the specified destination URI.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Connect( _
   ByVal uri As System.Uri, _
   ByVal timeout As System.TimeSpan _
) As WebSocket
'Usage

Dim instance As WebSocketFactory
Dim uri As System.Uri
Dim timeout As System.TimeSpan
Dim value As WebSocket

value = instance.Connect(uri, timeout)
public WebSocket Connect(
   System.Uri uri,
   System.TimeSpan timeout
)
public function Connect(
    uri: System.Uri;
    timeout: System.TimeSpan
): WebSocket;
public function Connect(
   uri : System.Uri,
   timeout : System.TimeSpan
) : WebSocket;
public: WebSocket* Connect(
   System.Uri* uri,
   System.TimeSpan timeout
)
public:
WebSocket^ Connect(
   System.Uri^ uri,
   System.TimeSpan timeout
)

Parameters

uri
The URI to the WebSocket endpoint.
timeout
The period of time during which operation is to be complete or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members
Overload List


WebSocketFactory Class Properties

WebSocketFactory Class Properties

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

For a list of all members of this type, see WebSocketFactory members.

Public Properties
 | Name | Description
Public Property | BypassProxyOnLocal | Gets and sets whether the factory should bypass local proxies when establishing a client connection.
Public Property | Compression | Gets and set whether the transport compression should be applied and what compression method to use for compressing the traffic.
Public Property | CookieContainer | Gets and sets CookieContainer used by the WebSocketFactory instance.
Public Property | Extensions | Gets and sets the string specifying extensions supported by the WebSocket client.
Public Property | MaxRedirects | Gets and sets the maximum number of times the remote endpoints can redirect the client connection during WebSocket handshake.
Public Property | Origin | Gets and sets the string identifying the origin of WebSocket client.
Public Property | OutboundHandshakeHeaders | Gets the collection of handshake headers to be sent to remote endpoint during the WebSocket handshake;
Public Property | PayloadMasking | Gets and sets whether the WebSocket instances created by this factory should mask payload sent to the server.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocket client.
Public Property | ProxyAddress | Gets and sets the address of the web proxy to be used by the factory when establishing connection.
Public Property | Security | Provides properties that apply when the SSL/TLS transport security is enabled.
Public Property | StreamUpgradeProvider | Gets and set the WCF StreamUpgradeProvider to be upgrade the input of established connections.
Public Property | TraceSource | Gets and sets the trace source to be used for tracing WebSocket activities.
Public Property | UseDefaultWebProxy | Gets and sets whether the factory should use default web proxy when establishing a client connection.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


BypassProxyOnLocal Property (WebSocketFactory)

BypassProxyOnLocal Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : BypassProxyOnLocal Property
Gets and sets whether the factory should bypass local proxies when establishing a client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property BypassProxyOnLocal As System.Boolean
'Usage

Dim instance As WebSocketFactory
Dim value As System.Boolean

instance.BypassProxyOnLocal = value

value = instance.BypassProxyOnLocal
public System.bool BypassProxyOnLocal {get; set;}
public read-write property BypassProxyOnLocal: System.Boolean;
public function get,set BypassProxyOnLocal : System.boolean
public: __property System.bool get_BypassProxyOnLocal();
public: __property void set_BypassProxyOnLocal(
   System.bool value
);
public:
property System.bool BypassProxyOnLocal {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Compression Property (WebSocketFactory)

Compression Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Compression Property
Gets and set whether the transport compression should be applied and what compression method to use for compressing the traffic.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Compression As CompressionSettings
'Usage

Dim instance As WebSocketFactory
Dim value As CompressionSettings

value = instance.Compression
public CompressionSettings Compression {get;}
public read-only property Compression: CompressionSettings;
public function get Compression : CompressionSettings
public: __property CompressionSettings* get_Compression();
public:
property CompressionSettings^ Compression {
   CompressionSettings^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


CookieContainer Property (WebSocketFactory)

CookieContainer Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : CookieContainer Property
Gets and sets CookieContainer used by the WebSocketFactory instance.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CookieContainer As System.Net.CookieContainer
'Usage

Dim instance As WebSocketFactory
Dim value As System.Net.CookieContainer

instance.CookieContainer = value

value = instance.CookieContainer
public System.Net.CookieContainer CookieContainer {get; set;}
public read-write property CookieContainer: System.Net.CookieContainer;
public function get,set CookieContainer : System.Net.CookieContainer
public: __property System.Net.CookieContainer* get_CookieContainer();
public: __property void set_CookieContainer(
   System.Net.CookieContainer* value
);
public:
property System.Net.CookieContainer^ CookieContainer {
   System.Net.CookieContainer^ get();
   void set (    System.Net.CookieContainer^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Extensions Property (WebSocketFactory)

Extensions Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Extensions Property
Gets and sets the string specifying extensions supported by the WebSocket client.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Extensions As System.Collections.Generic.IEnumerable(Of String)
'Usage

Dim instance As WebSocketFactory
Dim value As System.Collections.Generic.IEnumerable(Of String)

instance.Extensions = value

value = instance.Extensions
public System.Collections.Generic.IEnumerable<string> Extensions {get; set;}
public read-write property Extensions: System.Collections.Generic.IEnumerable;
public function get,set Extensions : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<string*>* get_Extensions();
public: __property void set_Extensions(
   System.Collections.Generic.IEnumerable<string*>* value
);
public:
property System.Collections.Generic.IEnumerable<String^>^ Extensions {
   System.Collections.Generic.IEnumerable<String^>^ get();
   void set (    System.Collections.Generic.IEnumerable<String^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


MaxRedirects Property (WebSocketFactory)

MaxRedirects Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : MaxRedirects Property
Gets and sets the maximum number of times the remote endpoints can redirect the client connection during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MaxRedirects As System.Integer
'Usage

Dim instance As WebSocketFactory
Dim value As System.Integer

instance.MaxRedirects = value

value = instance.MaxRedirects
public System.int MaxRedirects {get; set;}
public read-write property MaxRedirects: System.Integer;
public function get,set MaxRedirects : System.int
public: __property System.int get_MaxRedirects();
public: __property void set_MaxRedirects(
   System.int value
);
public:
property System.int MaxRedirects {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Origin Property (WebSocketFactory)

Origin Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Origin Property
Gets and sets the string identifying the origin of WebSocket client.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Origin As System.String
'Usage

Dim instance As WebSocketFactory
Dim value As System.String

instance.Origin = value

value = instance.Origin
public System.string Origin {get; set;}
public read-write property Origin: System.String;
public function get,set Origin : System.String
public: __property System.string* get_Origin();
public: __property void set_Origin(
   System.string* value
);
public:
property System.String^ Origin {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


OutboundHandshakeHeaders Property (WebSocketFactory)

OutboundHandshakeHeaders Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : OutboundHandshakeHeaders Property
Gets the collection of handshake headers to be sent to remote endpoint during the WebSocket handshake;
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property OutboundHandshakeHeaders As WebSocketHandshakeHeaderCollection
'Usage

Dim instance As WebSocketFactory
Dim value As WebSocketHandshakeHeaderCollection

value = instance.OutboundHandshakeHeaders
public WebSocketHandshakeHeaderCollection OutboundHandshakeHeaders {get;}
public read-only property OutboundHandshakeHeaders: WebSocketHandshakeHeaderCollection;
public function get OutboundHandshakeHeaders : WebSocketHandshakeHeaderCollection
public: __property WebSocketHandshakeHeaderCollection* get_OutboundHandshakeHeaders();
public:
property WebSocketHandshakeHeaderCollection^ OutboundHandshakeHeaders {
   WebSocketHandshakeHeaderCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


PayloadMasking Property (WebSocketFactory)

PayloadMasking Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : PayloadMasking Property
Gets and sets whether the WebSocket instances created by this factory should mask payload sent to the server.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PayloadMasking As System.Boolean
'Usage

Dim instance As WebSocketFactory
Dim value As System.Boolean

instance.PayloadMasking = value

value = instance.PayloadMasking
public System.bool PayloadMasking {get; set;}
public read-write property PayloadMasking: System.Boolean;
public function get,set PayloadMasking : System.boolean
public: __property System.bool get_PayloadMasking();
public: __property void set_PayloadMasking(
   System.bool value
);
public:
property System.bool PayloadMasking {
   System.bool get();
   void set (    System.bool value);
}
Remarks

By default all messages from the client to the server are masked, while all messages from the server to the client are not masked, as required by the WebSocket protocol specification.

You can disable or enable masking by setting this property, but strict WebSocket implementations will drop the connection if masking requirements are not followed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Protocol Property (WebSocketFactory)

Protocol Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Protocol Property
Gets and sets the string identifying the sub-protocol used WebSocket client.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protocol As System.String
'Usage

Dim instance As WebSocketFactory
Dim value As System.String

instance.Protocol = value

value = instance.Protocol
public System.string Protocol {get; set;}
public read-write property Protocol: System.String;
public function get,set Protocol : System.String
public: __property System.string* get_Protocol();
public: __property void set_Protocol(
   System.string* value
);
public:
property System.String^ Protocol {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


ProxyAddress Property (WebSocketFactory)

ProxyAddress Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : ProxyAddress Property
Gets and sets the address of the web proxy to be used by the factory when establishing connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ProxyAddress As System.Uri
'Usage

Dim instance As WebSocketFactory
Dim value As System.Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
public System.Uri ProxyAddress {get; set;}
public read-write property ProxyAddress: System.Uri;
public function get,set ProxyAddress : System.Uri
public: __property System.Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   System.Uri* value
);
public:
property System.Uri^ ProxyAddress {
   System.Uri^ get();
   void set (    System.Uri^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


Security Property (WebSocketFactory)

Security Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Security Property
Provides properties that apply when the SSL/TLS transport security is enabled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Security As WebSocketClientSecurity
'Usage

Dim instance As WebSocketFactory
Dim value As WebSocketClientSecurity

value = instance.Security
public WebSocketClientSecurity Security {get;}
public read-only property Security: WebSocketClientSecurity;
public function get Security : WebSocketClientSecurity
public: __property WebSocketClientSecurity* get_Security();
public:
property WebSocketClientSecurity^ Security {
   WebSocketClientSecurity^ get();
}
Remarks

SSL/TLS transport security is getting enabled automatically when the target server URI has the "wss" schema e.g "wss://myservice.com".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


StreamUpgradeProvider Property (WebSocketFactory)

StreamUpgradeProvider Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : StreamUpgradeProvider Property
Gets and set the WCF StreamUpgradeProvider to be upgrade the input of established connections.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property StreamUpgradeProvider As System.ServiceModel.Channels.StreamUpgradeProvider
'Usage

Dim instance As WebSocketFactory
Dim value As System.ServiceModel.Channels.StreamUpgradeProvider

instance.StreamUpgradeProvider = value

value = instance.StreamUpgradeProvider
public System.ServiceModel.Channels.StreamUpgradeProvider StreamUpgradeProvider {get; set;}
public read-write property StreamUpgradeProvider: System.ServiceModel.Channels.StreamUpgradeProvider;
public function get,set StreamUpgradeProvider : System.ServiceModel.Channels.StreamUpgradeProvider
public: __property System.ServiceModel.Channels.StreamUpgradeProvider* get_StreamUpgradeProvider();
public: __property void set_StreamUpgradeProvider(
   System.ServiceModel.Channels.StreamUpgradeProvider* value
);
public:
property System.ServiceModel.Channels.StreamUpgradeProvider^ StreamUpgradeProvider {
   System.ServiceModel.Channels.StreamUpgradeProvider^ get();
   void set (    System.ServiceModel.Channels.StreamUpgradeProvider^ value);
}
Remarks
Using the StreamUpgradeProvider.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


TraceSource Property (WebSocketFactory)

TraceSource Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : TraceSource Property
Gets and sets the trace source to be used for tracing WebSocket activities.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketFactory
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


UseDefaultWebProxy Property (WebSocketFactory)

UseDefaultWebProxy Property (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : UseDefaultWebProxy Property
Gets and sets whether the factory should use default web proxy when establishing a client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property UseDefaultWebProxy As System.Boolean
'Usage

Dim instance As WebSocketFactory
Dim value As System.Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
public System.bool UseDefaultWebProxy {get; set;}
public read-write property UseDefaultWebProxy: System.Boolean;
public function get,set UseDefaultWebProxy : System.boolean
public: __property System.bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   System.bool value
);
public:
property System.bool UseDefaultWebProxy {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


WebSocketFactory Class Events

WebSocketFactory Class Events

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

For a list of all members of this type, see WebSocketFactory members.

Public Events
 | Name | Description
Public Event | Handshake | Event triggered during WebSocket handshake.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


Handshake Event (WebSocketFactory)

Handshake Event (WebSocketFactory)

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : Handshake Event
Event triggered during WebSocket handshake.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Handshake As WebSocketHandshakeEventHandler
'Usage

Dim instance As WebSocketFactory
Dim handler As WebSocketHandshakeEventHandler

AddHandler instance.Handshake, handler
public event WebSocketHandshakeEventHandler Handshake
public event Handshake: WebSocketHandshakeEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event WebSocketHandshakeEventHandler* Handshake
public:
event WebSocketHandshakeEventHandler^ Handshake
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


WebSocketListener Class

WebSocketListener Class
Members

Noemax.WebSockets.Core Namespace : WebSocketListener Class
Listens on WebSockets endpoints, accepts and manages WebSocket connections.
Object Model
WebSocketListener Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketListener
'Usage

Dim instance As WebSocketListener
public class WebSocketListener
public class WebSocketListener
public class WebSocketListener
public __gc class WebSocketListener
public ref class WebSocketListener
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Core.WebSocketListener

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Members
Noemax.WebSockets.Core Namespace


WebSocketListener Class Members

WebSocketListener Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocketListener Class

The following tables list the members exposed by WebSocketListener.

Public Constructors
 | Name | Description
Public Constructor | WebSocketListener Constructor | Initializes a new WebSocketListener instance with specified endpoint URI.
Top
Public Properties
 | Name | Description
Public Property | Compression | Gets the compression settings to be used for the payload compression.
Public Property | IsOpen | Gets the value the specify whether the listener is open.
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocketListener.
Public Property | Security | Gets the server security settings that are applied when SSL/TLS security is enabled.
Public Property | TraceSource | Gets and sets TraceSource used for tracing the WebSocket events.
Public Property | Uri | Gets the URI WebSocket endpoint associated to the listener.
Top
Public Methods
 | Name | Description
Public Method | Accept | Accepts client connection from associated endpoint.
Public Method | BeginAccept | Begin asynchronous operation to accept client connection.
Public Method | Close | Stops accepting the client connections and closes the associated WebSocket endpoint.
Public Method | EndAccept | Concludes asynchronous operation to accept client connection.
Public Method | Open | Opens the WebSocket endpoint and starts waiting for client connection to accept.
Top
Protected Methods
 | Name | Description
Protected Method | DispatchChannel | Dispatches accepted WebSocket instance to the pending Accept operation or puts it into queue to be accepted later.
Protected Method | ReadCookies | Reads cookies from the HTTP header value.
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


WebSocketListener Constructor

WebSocketListener Constructor

Noemax.WebSockets.Core Namespace > WebSocketListener Class : WebSocketListener Constructor
The URI of the endpoint to listen for client connections.
Initializes a new WebSocketListener instance with specified endpoint URI.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal listenUri As System.Uri _
)
'Usage

Dim listenUri As System.Uri

Dim instance As New WebSocketListener(listenUri)
public WebSocketListener(
   System.Uri listenUri
)
public WebSocketListener(
    listenUri: System.Uri
);
public function WebSocketListener(
   listenUri : System.Uri
);
public: WebSocketListener(
   System.Uri* listenUri
)
public:
WebSocketListener(
   System.Uri^ listenUri
)

Parameters

listenUri
The URI of the endpoint to listen for client connections.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


WebSocketListener Class Methods

WebSocketListener Class Methods

Noemax.WebSockets.Core Namespace : WebSocketListener Class

For a list of all members of this type, see WebSocketListener members.

Public Methods
 | Name | Description
Public Method | Accept | Accepts client connection from associated endpoint.
Public Method | BeginAccept | Begin asynchronous operation to accept client connection.
Public Method | Close | Stops accepting the client connections and closes the associated WebSocket endpoint.
Public Method | EndAccept | Concludes asynchronous operation to accept client connection.
Public Method | Open | Opens the WebSocket endpoint and starts waiting for client connection to accept.
Top
Protected Methods
 | Name | Description
Protected Method | DispatchChannel | Dispatches accepted WebSocket instance to the pending Accept operation or puts it into queue to be accepted later.
Protected Method | ReadCookies | Reads cookies from the HTTP header value.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


Accept Method (WebSocketListener)

Accept Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Accept Method
Accepts client connection from associated endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Accept() As WebSocket
'Usage

Dim instance As WebSocketListener
Dim value As WebSocket

value = instance.Accept()
public WebSocket Accept()
public function Accept(): WebSocket;
public function Accept() : WebSocket;
public: WebSocket* Accept();
public:
WebSocket^ Accept();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


BeginAccept Method (WebSocketListener)

BeginAccept Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : BeginAccept Method
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
An object, specified by the application, that contains state information associated with the asynchronous operation.
Begin asynchronous operation to accept client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function BeginAccept( _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketListener
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginAccept(callback, state)
public System.IAsyncResult BeginAccept(
   System.AsyncCallback callback,
   System.object state
)
public function BeginAccept(
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
public function BeginAccept(
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
public: System.IAsyncResult* BeginAccept(
   System.AsyncCallback* callback,
   System.Object* state
)
public:
System.IAsyncResult^ BeginAccept(
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

callback
The AsyncCallback delegate that receives the notification of the asynchronous operation completion.
state
An object, specified by the application, that contains state information associated with the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Close Method (WebSocketListener)

Close Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Close Method
Stops accepting the client connections and closes the associated WebSocket endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Close()
'Usage

Dim instance As WebSocketListener

instance.Close()
public void Close()
public procedure Close();
public function Close();
public: void Close();
public:
void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


DispatchChannel Method (WebSocketListener)

DispatchChannel Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : DispatchChannel Method
The socket to be accepted.
Dispatches accepted WebSocket instance to the pending Accept operation or puts it into queue to be accepted later.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function DispatchChannel( _
   ByVal socket As WebSocket _
) As System.Boolean
'Usage

Dim instance As WebSocketListener
Dim socket As WebSocket
Dim value As System.Boolean

value = instance.DispatchChannel(socket)
protected System.bool DispatchChannel(
   WebSocket socket
)
protected function DispatchChannel(
    socket: WebSocket
): System.Boolean;
protected function DispatchChannel(
   socket : WebSocket
) : System.boolean;
protected: System.bool DispatchChannel(
   WebSocket* socket
)
protected:
System.bool DispatchChannel(
   WebSocket^ socket
)

Parameters

socket
The socket to be accepted.

Return Value

True if socket was accepted; False if listener refused the socket.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


EndAccept Method (WebSocketListener)

EndAccept Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : EndAccept Method
The IAsyncResult returned by a call to the BeginAccept method.
Concludes asynchronous operation to accept client connection.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function EndAccept( _
   ByVal result As System.IAsyncResult _
) As WebSocket
'Usage

Dim instance As WebSocketListener
Dim result As System.IAsyncResult
Dim value As WebSocket

value = instance.EndAccept(result)
public WebSocket EndAccept(
   System.IAsyncResult result
)
public function EndAccept(
    result: System.IAsyncResult
): WebSocket;
public function EndAccept(
   result : System.IAsyncResult
) : WebSocket;
public: WebSocket* EndAccept(
   System.IAsyncResult* result
)
public:
WebSocket^ EndAccept(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult returned by a call to the BeginAccept method.

Return Value

An accepted client connection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Open Method (WebSocketListener)

Open Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Open Method
Opens the WebSocket endpoint and starts waiting for client connection to accept.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Open()
'Usage

Dim instance As WebSocketListener

instance.Open()
public void Open()
public procedure Open();
public function Open();
public: void Open();
public:
void Open();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


ReadCookies Method (WebSocketListener)

ReadCookies Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : ReadCookies Method
The value of HTTP header.
Reads cookies from the HTTP header value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function ReadCookies( _
   ByVal cookie As System.String _
) As System.Net.CookieCollection
'Usage

Dim instance As WebSocketListener
Dim cookie As System.String
Dim value As System.Net.CookieCollection

value = instance.ReadCookies(cookie)
protected System.Net.CookieCollection ReadCookies(
   System.string cookie
)
protected function ReadCookies(
    cookie: System.String
): System.Net.CookieCollection;
protected function ReadCookies(
   cookie : System.String
) : System.Net.CookieCollection;
protected: System.Net.CookieCollection* ReadCookies(
   System.string* cookie
)
protected:
System.Net.CookieCollection^ ReadCookies(
   System.String^ cookie
)

Parameters

cookie
The value of HTTP header.

Return Value

A collection of cookies read from the header.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


WebSocketListener Class Properties

WebSocketListener Class Properties

Noemax.WebSockets.Core Namespace : WebSocketListener Class

For a list of all members of this type, see WebSocketListener members.

Public Properties
 | Name | Description
Public Property | Compression | Gets the compression settings to be used for the payload compression.
Public Property | IsOpen | Gets the value the specify whether the listener is open.
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocketListener.
Public Property | Security | Gets the server security settings that are applied when SSL/TLS security is enabled.
Public Property | TraceSource | Gets and sets TraceSource used for tracing the WebSocket events.
Public Property | Uri | Gets the URI WebSocket endpoint associated to the listener.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


Compression Property (WebSocketListener)

Compression Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Compression Property
Gets the compression settings to be used for the payload compression.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Compression As CompressionSettings
'Usage

Dim instance As WebSocketListener
Dim value As CompressionSettings

value = instance.Compression
public CompressionSettings Compression {get;}
public read-only property Compression: CompressionSettings;
public function get Compression : CompressionSettings
public: __property CompressionSettings* get_Compression();
public:
property CompressionSettings^ Compression {
   CompressionSettings^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


IsOpen Property (WebSocketListener)

IsOpen Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : IsOpen Property
Gets the value the specify whether the listener is open.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property IsOpen As System.Boolean
'Usage

Dim instance As WebSocketListener
Dim value As System.Boolean

value = instance.IsOpen
public System.bool IsOpen {get;}
public read-only property IsOpen: System.Boolean;
public function get IsOpen : System.boolean
public: __property System.bool get_IsOpen();
public:
property System.bool IsOpen {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


PortSharing Property (WebSocketListener)

PortSharing Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : PortSharing Property
Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PortSharing As System.Boolean
'Usage

Dim instance As WebSocketListener
Dim value As System.Boolean

instance.PortSharing = value

value = instance.PortSharing
public System.bool PortSharing {get; set;}
public read-write property PortSharing: System.Boolean;
public function get,set PortSharing : System.boolean
public: __property System.bool get_PortSharing();
public: __property void set_PortSharing(
   System.bool value
);
public:
property System.bool PortSharing {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Protocol Property (WebSocketListener)

Protocol Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Protocol Property
Gets and sets the string identifying the sub-protocol used WebSocketListener.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Protocol As System.String
'Usage

Dim instance As WebSocketListener
Dim value As System.String

instance.Protocol = value

value = instance.Protocol
public System.string Protocol {get; set;}
public read-write property Protocol: System.String;
public function get,set Protocol : System.String
public: __property System.string* get_Protocol();
public: __property void set_Protocol(
   System.string* value
);
public:
property System.String^ Protocol {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Security Property (WebSocketListener)

Security Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Security Property
Gets the server security settings that are applied when SSL/TLS security is enabled.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Security As WebSocketServerSecurity
'Usage

Dim instance As WebSocketListener
Dim value As WebSocketServerSecurity

value = instance.Security
public WebSocketServerSecurity Security {get;}
public read-only property Security: WebSocketServerSecurity;
public function get Security : WebSocketServerSecurity
public: __property WebSocketServerSecurity* get_Security();
public:
property WebSocketServerSecurity^ Security {
   WebSocketServerSecurity^ get();
}
Remarks

SSL/TLS security is enabled WebSocketServerSecurity.Required property is set to true or when the service endpoint URI includes 'wss' or 'https' schema. It's recommended to use WebSocketServerSecurity. Required property rather than relly on the URI, to make sure that security is forced on all endpoints.

If SSL/TLS security is enabled the WebSocketServerSecurity.ServerCertificate must be set to the valid X509 certificate, otherwise server with fail to start and System.InvalidOperationException will be thrown.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


TraceSource Property (WebSocketListener)

TraceSource Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : TraceSource Property
Gets and sets TraceSource used for tracing the WebSocket events.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property TraceSource As System.Diagnostics.TraceSource
'Usage

Dim instance As WebSocketListener
Dim value As System.Diagnostics.TraceSource

instance.TraceSource = value

value = instance.TraceSource
public System.Diagnostics.TraceSource TraceSource {get; set;}
public read-write property TraceSource: System.Diagnostics.TraceSource;
public function get,set TraceSource : System.Diagnostics.TraceSource
public: __property System.Diagnostics.TraceSource* get_TraceSource();
public: __property void set_TraceSource(
   System.Diagnostics.TraceSource* value
);
public:
property System.Diagnostics.TraceSource^ TraceSource {
   System.Diagnostics.TraceSource^ get();
   void set (    System.Diagnostics.TraceSource^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Uri Property (WebSocketListener)

Uri Property (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Uri Property
Gets the URI WebSocket endpoint associated to the listener.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Uri As System.Uri
'Usage

Dim instance As WebSocketListener
Dim value As System.Uri

value = instance.Uri
public System.Uri Uri {get;}
public read-only property Uri: System.Uri;
public function get Uri : System.Uri
public: __property System.Uri* get_Uri();
public:
property System.Uri^ Uri {
   System.Uri^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


WebSocketListener Class Events

WebSocketListener Class Events

Noemax.WebSockets.Core Namespace : WebSocketListener Class

For a list of all members of this type, see WebSocketListener members.

Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


Handshake Event (WebSocketListener)

Handshake Event (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : Handshake Event
Event triggered when the WebSocket handshake is performed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event Handshake As WebSocketHandshakeEventHandler
'Usage

Dim instance As WebSocketListener
Dim handler As WebSocketHandshakeEventHandler

AddHandler instance.Handshake, handler
public event WebSocketHandshakeEventHandler Handshake
public event Handshake: WebSocketHandshakeEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event WebSocketHandshakeEventHandler* Handshake
public:
event WebSocketHandshakeEventHandler^ Handshake
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


WebSocketMessageInputStream Class

WebSocketMessageInputStream Class
Members

Noemax.WebSockets.Core Namespace : WebSocketMessageInputStream Class
Expose a WebSocket message as a input and provides methods and properties for streaming WebSocket messages.
Object Model
WebSocketMessageInputStream Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class WebSocketMessageInputStream
   Inherits System.IO.Stream
'Usage

Dim instance As WebSocketMessageInputStream
public abstract class WebSocketMessageInputStream : System.IO.Stream
public class WebSocketMessageInputStream = class(System.IO.Stream)abstract;
public abstract class WebSocketMessageInputStream extends System.IO.Stream
public __gc abstract class WebSocketMessageInputStream : public System.IO.Stream
public ref class WebSocketMessageInputStream abstract : public System.IO.Stream
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.WebSockets.Core.WebSocketMessageInputStream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Members
Noemax.WebSockets.Core Namespace


WebSocketMessageInputStream Class Members

WebSocketMessageInputStream Class Members
Properties Methods

Noemax.WebSockets.Core Namespace : WebSocketMessageInputStream Class

The following tables list the members exposed by WebSocketMessageInputStream.

Public Properties
 | Name | Description
Public Property | BytesBuffered | Gets the number of bytes buffered in the input buffer.
Public Property | CanRead | (Inherited from System.IO.Stream)
Public Property | CanSeek | (Inherited from System.IO.Stream)
Public Property | CanTimeout | (Inherited from System.IO.Stream)
Public Property | CanWrite | (Inherited from System.IO.Stream)
Public Property | DrainWhenMessageClosed | Gets and sets whether this stream should be drained when message is closed. Default value is True.
Public Property | FrameBytesRemaining | Gets the number of bytes remaining to be read until the end of the current frame.
Public Property | IsFrameFinal | Gets whether the current message frame is final.
Public Property | Length | (Inherited from System.IO.Stream)
Public Property | Position | (Inherited from System.IO.Stream)
Public Property | ReadTimeout | (Inherited from System.IO.Stream)
Public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top
Public Methods
 | Name | Description
Public Method | BeginRead | (Inherited from System.IO.Stream)
Public Method | BeginWrite | (Inherited from System.IO.Stream)
Public Method | Close | (Inherited from System.IO.Stream)
Public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
Public Method | CopyToAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
Public Method | EndRead | (Inherited from System.IO.Stream)
Public Method | EndWrite | (Inherited from System.IO.Stream)
Public Method | Flush | (Inherited from System.IO.Stream)
Public Method | FlushAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Read | (Inherited from System.IO.Stream)
Public Method | ReadAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | ReadByte | (Inherited from System.IO.Stream)
Public Method | ReadToFrameEnd | Reads an entire frame or remaining bytes of the frame, depending on current input position.
Public Method | Seek | (Inherited from System.IO.Stream)
Public Method | SetLength | (Inherited from System.IO.Stream)
Public Method | Write | (Inherited from System.IO.Stream)
Public Method | WriteAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | WriteByte | (Inherited from System.IO.Stream)
Top
Protected Methods
 | Name | Description
Protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top
See Also

Reference

WebSocketMessageInputStream Class
Noemax.WebSockets.Core Namespace


WebSocketMessageInputStream Class Methods

WebSocketMessageInputStream Class Methods

Noemax.WebSockets.Core Namespace : WebSocketMessageInputStream Class

For a list of all members of this type, see WebSocketMessageInputStream members.

Public Methods
 | Name | Description
Public Method | BeginRead | (Inherited from System.IO.Stream)
Public Method | BeginWrite | (Inherited from System.IO.Stream)
Public Method | Close | (Inherited from System.IO.Stream)
Public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
Public Method | CopyToAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
Public Method | EndRead | (Inherited from System.IO.Stream)
Public Method | EndWrite | (Inherited from System.IO.Stream)
Public Method | Flush | (Inherited from System.IO.Stream)
Public Method | FlushAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Read | (Inherited from System.IO.Stream)
Public Method | ReadAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | ReadByte | (Inherited from System.IO.Stream)
Public Method | ReadToFrameEnd | Reads an entire frame or remaining bytes of the frame, depending on current input position.
Public Method | Seek | (Inherited from System.IO.Stream)
Public Method | SetLength | (Inherited from System.IO.Stream)
Public Method | Write | (Inherited from System.IO.Stream)
Public Method | WriteAsync | Overloaded. (Inherited from System.IO.Stream)
Public Method | WriteByte | (Inherited from System.IO.Stream)
Top
Protected Methods
 | Name | Description
Protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top
See Also

Reference

WebSocketMessageInputStream Class
Noemax.WebSockets.Core Namespace


ReadToFrameEnd Method (WebSocketMessageInputStream)

ReadToFrameEnd Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : ReadToFrameEnd Method
Reads an entire frame or remaining bytes of the frame, depending on current input position.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ReadToFrameEnd() As System.Byte()
'Usage

Dim instance As WebSocketMessageInputStream
Dim value() As System.Byte

value = instance.ReadToFrameEnd()
public System.byte[] ReadToFrameEnd()
public function ReadToFrameEnd(): System.array of Byte;
public function ReadToFrameEnd() : System.byte[];
public: System.byte[]* ReadToFrameEnd();
public:
System.array<byte>^ ReadToFrameEnd();

Return Value

The bytes of the frame payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WebSocketMessageInputStream Class Properties

WebSocketMessageInputStream Class Properties

Noemax.WebSockets.Core Namespace : WebSocketMessageInputStream Class

For a list of all members of this type, see WebSocketMessageInputStream members.

Public Properties
 | Name | Description
Public Property | BytesBuffered | Gets the number of bytes buffered in the input buffer.
Public Property | CanRead | (Inherited from System.IO.Stream)
Public Property | CanSeek | (Inherited from System.IO.Stream)
Public Property | CanTimeout | (Inherited from System.IO.Stream)
Public Property | CanWrite | (Inherited from System.IO.Stream)
Public Property | DrainWhenMessageClosed | Gets and sets whether this stream should be drained when message is closed. Default value is True.
Public Property | FrameBytesRemaining | Gets the number of bytes remaining to be read until the end of the current frame.
Public Property | IsFrameFinal | Gets whether the current message frame is final.
Public Property | Length | (Inherited from System.IO.Stream)
Public Property | Position | (Inherited from System.IO.Stream)
Public Property | ReadTimeout | (Inherited from System.IO.Stream)
Public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top
See Also

Reference

WebSocketMessageInputStream Class
Noemax.WebSockets.Core Namespace


BytesBuffered Property (WebSocketMessageInputStream)

BytesBuffered Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : BytesBuffered Property
Gets the number of bytes buffered in the input buffer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property BytesBuffered As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Integer

value = instance.BytesBuffered
public abstract System.int BytesBuffered {get;}
public read-only property BytesBuffered: System.Integer; abstract;
public __abstract function get BytesBuffered : System.int
public: __property abstract System.int get_BytesBuffered();
public:
abstract property System.int BytesBuffered {
   System.int get();
}
Remarks
WebSocketMessageInputStream does not buffer entire frame, its internal buffer is fixed, so it may contain a part of the frame or multiple frames depending on the frame size.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


DrainWhenMessageClosed Property (WebSocketMessageInputStream)

DrainWhenMessageClosed Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : DrainWhenMessageClosed Property
Gets and sets whether this stream should be drained when message is closed. Default value is True.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Property DrainWhenMessageClosed As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

instance.DrainWhenMessageClosed = value

value = instance.DrainWhenMessageClosed
public virtual System.bool DrainWhenMessageClosed {get; set;}
public read-write property DrainWhenMessageClosed: System.Boolean; virtual;
public function get,set DrainWhenMessageClosed : System.boolean
public: __property virtual System.bool get_DrainWhenMessageClosed();
public: __property virtual void set_DrainWhenMessageClosed(
   System.bool value
);
public:
virtual property System.bool DrainWhenMessageClosed {
   System.bool get();
   void set (    System.bool value);
}
Remarks
Noemax.WebSockets.WebSocketInboundMessage automatically reads the stream to the end when message is being closed after it was processed by application. This needed to insure message is completely read from network connection, so that next message can be received. Sometimes application needs defer processing of the stream later. In this case it can set the DrainWhenMessageClosed to False. However, no new messages will be received until the message stream is completely consumed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


FrameBytesRemaining Property (WebSocketMessageInputStream)

FrameBytesRemaining Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : FrameBytesRemaining Property
Gets the number of bytes remaining to be read until the end of the current frame.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property FrameBytesRemaining As System.Long
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Long

value = instance.FrameBytesRemaining
public abstract System.long FrameBytesRemaining {get;}
public read-only property FrameBytesRemaining: System.Int64; abstract;
public __abstract function get FrameBytesRemaining : System.long
public: __property abstract System.long get_FrameBytesRemaining();
public:
abstract property System.int64 FrameBytesRemaining {
   System.int64 get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


IsFrameFinal Property (WebSocketMessageInputStream)

IsFrameFinal Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : IsFrameFinal Property
Gets whether the current message frame is final.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property IsFrameFinal As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

value = instance.IsFrameFinal
public abstract System.bool IsFrameFinal {get;}
public read-only property IsFrameFinal: System.Boolean; abstract;
public __abstract function get IsFrameFinal : System.boolean
public: __property abstract System.bool get_IsFrameFinal();
public:
abstract property System.bool IsFrameFinal {
   System.bool get();
}

Property Value

Returns true if current frame is final; otherwise returns false.
Remarks
When message is not fragmented its first and only frame is final.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WebSocketPingOrPongEventArgs Class

WebSocketPingOrPongEventArgs Class
Members

Noemax.WebSockets.Core Namespace : WebSocketPingOrPongEventArgs Class
Provides methods and properties for Pong event handler arguments.
Object Model
WebSocketPingOrPongEventArgs Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketPingOrPongEventArgs
   Inherits ControlFrameEventArgs
'Usage

Dim instance As WebSocketPingOrPongEventArgs
public class WebSocketPingOrPongEventArgs : ControlFrameEventArgs
public class WebSocketPingOrPongEventArgs = class(ControlFrameEventArgs)
public class WebSocketPingOrPongEventArgs extends ControlFrameEventArgs
public __gc class WebSocketPingOrPongEventArgs : public ControlFrameEventArgs
public ref class WebSocketPingOrPongEventArgs : public ControlFrameEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
Noemax.WebSockets.Core.ControlFrameEventArgs
Noemax.WebSockets.Core.WebSocketPingOrPongEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketPingOrPongEventArgs Members
Noemax.WebSockets.Core Namespace


WebSocketPingOrPongEventArgs Class Members

WebSocketPingOrPongEventArgs Class Members
Properties

Noemax.WebSockets.Core Namespace : WebSocketPingOrPongEventArgs Class

The following tables list the members exposed by WebSocketPingOrPongEventArgs.

Public Properties
 | Name | Description
Public Property | OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Top
See Also

Reference

WebSocketPingOrPongEventArgs Class
Noemax.WebSockets.Core Namespace


KeepaliveMode Enumeration

KeepaliveMode Enumeration

Noemax.WebSockets.Core Namespace : KeepaliveMode Enumeration
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum KeepaliveMode
   Inherits System.Enum
'Usage

Dim instance As KeepaliveMode
public enum KeepaliveMode : System.Enum
public enum KeepaliveMode = class(System.Enum)
public enum KeepaliveMode extends System.Enum
__value public enum KeepaliveMode : public System.Enum
public enum class KeepaliveMode : public System.Enum
Members
Member | Description
Default |
Message |
PingPong |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.Core.KeepaliveMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets.Core Namespace


UsernamePasswordAuthenticateEventHandler Delegate

UsernamePasswordAuthenticateEventHandler Delegate

Noemax.WebSockets.Core Namespace : UsernamePasswordAuthenticateEventHandler Delegate
The source of event.
UsernamePasswordAuthenticateEventArgs containing the event data.
Represents a methods that will be handling the username/password authentication.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub UsernamePasswordAuthenticateEventHandler( _
   ByVal sender As System.Object, _
   ByVal args As UsernamePasswordAuthenticateEventArgs _
)
'Usage

Dim instance As New UsernamePasswordAuthenticateEventHandler(AddressOf HandlerMethod)
public delegate void UsernamePasswordAuthenticateEventHandler(
   System.object sender,
   UsernamePasswordAuthenticateEventArgs args
)
public delegate UsernamePasswordAuthenticateEventHandler(
    sender: System.TObject;
    args: UsernamePasswordAuthenticateEventArgs
);
public delegate UsernamePasswordAuthenticateEventHandler(
   sender : System.Object,
   args : UsernamePasswordAuthenticateEventArgs
)
public: __gc __delegate void UsernamePasswordAuthenticateEventHandler(
   System.Object* sender,
   UsernamePasswordAuthenticateEventArgs* args
)
public delegate void UsernamePasswordAuthenticateEventHandler(
   System.Object^ sender,
   UsernamePasswordAuthenticateEventArgs^ args
)

Parameters

sender
The source of event.
args
UsernamePasswordAuthenticateEventArgs containing the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UsernamePasswordAuthenticateEventHandler Members
Noemax.WebSockets.Core Namespace


X509CertificateValidationCallback Delegate

X509CertificateValidationCallback Delegate

Noemax.WebSockets.Core Namespace : X509CertificateValidationCallback Delegate
The X509Certificate to validate.
The callback delegate providing the remote X509 certificate validation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Delegate Sub X509CertificateValidationCallback( _
   ByVal certificate As System.Security.Cryptography.X509Certificates.X509Certificate2 _
)
'Usage

Dim instance As New X509CertificateValidationCallback(AddressOf HandlerMethod)
public delegate void X509CertificateValidationCallback(
   System.Security.Cryptography.X509Certificates.X509Certificate2 certificate
)
public delegate X509CertificateValidationCallback(
    certificate: System.Security.Cryptography.X509Certificates.X509Certificate2
);
public delegate X509CertificateValidationCallback(
   certificate : System.Security.Cryptography.X509Certificates.X509Certificate2
)
public: __gc __delegate void X509CertificateValidationCallback(
   System.Security.Cryptography.X509Certificates.X509Certificate2* certificate
)
public delegate void X509CertificateValidationCallback(
   System.Security.Cryptography.X509Certificates.X509Certificate2^ certificate
)

Parameters

certificate
The X509Certificate to validate.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

X509CertificateValidationCallback Members
Noemax.WebSockets.Core Namespace


Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets)

Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | ActionInvoker | The invoker for operations that does not return any result.
Class | ActionInvoker<T> | The invoker providing one way operations.
Class | ActionInvokerFactory | The factory creating ActionInvoker<T> instances.
Class | ActionOperation1Invoker |
Class | ActionOperation1Invoker<T> |
Class | ActionOperationInvoker |
Class | ActionOperationInvoker<T> |
Class | CompressedMessageSerializer | Provides a serializer which transparently compress outbound messages and decompress inbound messages.
Class | ConversationMessage | Represents an envelope providing additional metadata for dispatching the message.
Class | DefaultClientDispatcher | Provides methods and properties for sending request messages and dispatching response messages on the Noemax.WebSockets.WebSocketChannel connection.
Class | DefaultMessageDispatcher | Dispatches the messages based on the action string or the data type deserialized from the message payload.
Class | EnvelopedMessage | The base class for all messages sent by PowerWebSockets RPC.
Class | FuncInvoker<TResult,TRequest> | The invoker providing request/response operations.
Class | FuncInvokerFactory | The factory producing FuncInvoker<TResult,TRequest> instances.
Class | FuncOperation1Invoker<TResult,T> |
Class | FuncOperationInvoker<TResult,T> |
Class | Invoker | Abstract based class for invoker that process inbound message by invoking the method of the service and passing deserialized message as parameter.
Class | InvokerFactory | The factory producing Invoker instances.
Class | JsonClientProxyProvider | Provides WebSocketMessagingService with a JavaScript client proxy file based on defined messanging operations.
Class | JsonMessageSerializer | Provides serialization of data into WebSocket text messages using JSON format.
Class | MessageDispatcher | Provides methods and properties for dispatching WebSocket messages to message operations.
Class | MessageOperationAttribute | Indicates that a method defines an operation that is part of a service contract.
Class | MessageOperationDescription | Defines the properties of message dispatching operation.
Class | MessageSerializerBase | Provides the base class for serializing objects into WebSocket messages.
Class | MessagingContractAttribute | Indicates that an interface or a class defines a service contract.
Class | MultiFormatMessagingService | The base class for the service that dispatches inbound messages based on the type of the objects deserialized from the message content. This service is capable to use different format per each associated channel.
Class | PlainMessage | Represents a simple message without any message envelope that contains a message body and can have a streamed attachment.
Class | ReflectionInvoker | Provides invoker for calling the message operation that multiple parameters.
Class | RequestInvoker |
Class | RpcFaultException | The exception providing a FaultInfo.
Class | VoidInputInvoker<TResult> | Provides invoker for calling functions that does not take parameters.
Class | VoidInputInvokerFactory | Provides VoidInputInvoker<TResult> invokers./>
Class | VoidInputOperationInvoker<TResult> |
Class | VoidInputOperationInvoker1<TResult> |
Class | WebSocketChannelExtensions | Provides extension methods for WebSocketChannel class.
Class | WebSocketMessagingService | The base class for the service that performs dispatching of the inbound messages based of the type of the object deserialized from the the message content and the action string provided by inbound message.
Class | XmlMessageSerializer | Provides XML serialization for WebSocket messaging services.
Interfaces
 | Interface | Description
Interface | IClientDispatcher | Defines the interface that provides methods and properties for dispatching messages on the client side.
Interface | ICriteria | Represents the criteria based on which MessageDispatcher dispatches messages.
Interface | IMessageSerializer | Defines the interface for implementation that provides serialization of the objects through the WebSocket channels.
Structures
 | Structure | Description
Structure | FaultInfo | Provides information on the fault returned by remote side as response to request message.
Delegates
 | Delegate | Description
Delegate | ActionOperation |
Delegate | ActionOperation1 |
Delegate | ActionOperation1<T> |
Delegate | FuncOperation<TResult,T> |
Delegate | FuncOperation1<TResult,T> |
Delegate | VoidInputOperation<TResult> | Defines the signature of the message operation that does not take any input but returns data.
Delegate | VoidInputOperation1<TResult> | Defines the signature of the message operation that does not take any input but returns data.
Enumerations
 | Enumeration | Description
Enumeration | CompressedMessageFormat | The compression format to use for compressing the outbound messages.
See Also

Reference

Noemax.WebSockets Assembly


ActionInvoker Class

ActionInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : ActionInvoker Class
The invoker for operations that does not return any result.
Object Model
ActionInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public MustInherit Class ActionInvoker
   Inherits RequestInvoker
'Usage

Dim instance As ActionInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public abstract class ActionInvoker : RequestInvoker
public class ActionInvoker = class(RequestInvoker)abstract;
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public abstract class ActionInvoker extends RequestInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc abstract class ActionInvoker : public RequestInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public ref class ActionInvoker abstract : public RequestInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker
Noemax.WebSockets.Messaging.ActionOperationInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Members
Noemax.WebSockets.Messaging Namespace


ActionInvoker Class Members

ActionInvoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionInvoker Class

The following tables list the members exposed by ActionInvoker.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the local message operation handler.
Top
See Also

Reference

ActionInvoker Class
Noemax.WebSockets.Messaging Namespace


ActionInvoker Class Methods

ActionInvoker Class Methods

Noemax.WebSockets.Messaging Namespace : ActionInvoker Class

For a list of all members of this type, see ActionInvoker members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the local message operation handler.
Top
See Also

Reference

ActionInvoker Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ActionInvoker)

OnInvoke Method (ActionInvoker)

Noemax.WebSockets.Messaging Namespace > ActionInvoker Class : OnInvoke Method
Invokes the local message operation handler.
Overload List
Overload | Description
OnInvoke(ConversationMessage,WebSocketChannel) |
OnInvoke(Object,WebSocketChannel) | Invokes the local message operation handler.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Class
ActionInvoker Members
Base Implementation in OnInvoke


OnInvoke(ConversationMessage,WebSocketChannel) Method

OnInvoke(ConversationMessage,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionInvoker Class > OnInvoke Method : OnInvoke(ConversationMessage,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function OnInvoke( _
   ByVal requestMessage As ConversationMessage, _
   ByVal channel As WebSocketChannel _
) As ConversationMessage
'Usage

Dim instance As ActionInvoker
Dim requestMessage As ConversationMessage
Dim channel As WebSocketChannel
Dim value As ConversationMessage

value = instance.OnInvoke(requestMessage, channel)
protected override ConversationMessage OnInvoke(
   ConversationMessage requestMessage,
   WebSocketChannel channel
)
protected function OnInvoke(
    requestMessage: ConversationMessage;
    channel: WebSocketChannel
): ConversationMessage; override;
protected override function OnInvoke(
   requestMessage : ConversationMessage,
   channel : WebSocketChannel
) : ConversationMessage;
protected: ConversationMessage* OnInvoke(
   ConversationMessage* requestMessage,
   WebSocketChannel* channel
) override
protected:
ConversationMessage^ OnInvoke(
   ConversationMessage^ requestMessage,
   WebSocketChannel^ channel
) override

Parameters

requestMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Class
ActionInvoker Members
Overload List
Base Implementation in OnInvoke


OnInvoke(Object,WebSocketChannel) Method

OnInvoke(Object,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionInvoker Class > OnInvoke Method : OnInvoke(Object,WebSocketChannel) Method
The parameter.
The channel through which the inbound message was received.
Invokes the local message operation handler.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Sub OnInvoke( _
   ByVal parameter As System.Object, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As ActionInvoker
Dim parameter As System.Object
Dim channel As WebSocketChannel

instance.OnInvoke(parameter, channel)
protected abstract void OnInvoke(
   System.object parameter,
   WebSocketChannel channel
)
protected procedure OnInvoke(
    parameter: System.TObject;
    channel: WebSocketChannel
); abstract;
protected __abstract function OnInvoke(
   parameter : System.Object,
   channel : WebSocketChannel
);
protected: abstract void OnInvoke(
   System.Object* parameter,
   WebSocketChannel* channel
)
protected:
abstract void OnInvoke(
   System.Object^ parameter,
   WebSocketChannel^ channel
)

Parameters

parameter
The parameter.
channel
The channel through which the inbound message was received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Class
ActionInvoker Members
Overload List


ActionInvoker Class Properties

ActionInvoker Class Properties

Noemax.WebSockets.Messaging Namespace : ActionInvoker Class

For a list of all members of this type, see ActionInvoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

ActionInvoker Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (ActionInvoker)

InputTypes Property (ActionInvoker)

Noemax.WebSockets.Messaging Namespace > ActionInvoker Class : InputTypes Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As ActionInvoker
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Class
ActionInvoker Members
Base Implementation in InputTypes


ActionInvoker<T> Class

ActionInvoker<T> Class
Members

Noemax.WebSockets.Messaging Namespace : ActionInvoker<T> Class
The type of the input parameter accepted by Invoker.
The invoker providing one way operations.
Object Model
ActionInvoker<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public MustInherit Class ActionInvoker(Of T)
   Inherits ActionInvoker
'Usage

Dim instance As ActionInvoker(Of T)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public abstract class ActionInvoker<T> : ActionInvoker
public class ActionInvoker = class(ActionInvoker)abstract;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc abstract class ActionInvoker<T> : public ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename T>
public ref class ActionInvoker abstract : public ActionInvoker
Type Parameters
T
The type of the input parameter accepted by Invoker.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker<T>
Noemax.WebSockets.Messaging.ActionOperationInvoker<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker<T> Members
Noemax.WebSockets.Messaging Namespace


ActionInvoker<T> Class Members

ActionInvoker<T> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionInvoker<T> Class

The following tables list the members exposed by ActionInvoker<T>.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets the type list of types accepted by invoker.
Public Property | KnownTypes | Overridden. Gets the list of types that must be known by the serializer.
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Invokes the local message operation handler. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Top
See Also

Reference

ActionInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


ActionInvoker<T> Class Properties

ActionInvoker<T> Class Properties

Noemax.WebSockets.Messaging Namespace : ActionInvoker<T> Class

For a list of all members of this type, see ActionInvoker<T> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets the type list of types accepted by invoker.
Public Property | KnownTypes | Overridden. Gets the list of types that must be known by the serializer.
Top
See Also

Reference

ActionInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (ActionInvoker<T>)

InputTypes Property (ActionInvoker<T>)

Noemax.WebSockets.Messaging Namespace > ActionInvoker<T> Class : InputTypes Property
Gets the type list of types accepted by invoker.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As ActionInvoker(Of T)
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}

Property Value

Returns the type of [T].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker<T> Class
ActionInvoker<T> Members
Base Implementation in InputTypes


KnownTypes Property (ActionInvoker<T>)

KnownTypes Property (ActionInvoker<T>)

Noemax.WebSockets.Messaging Namespace > ActionInvoker<T> Class : KnownTypes Property
Gets the list of types that must be known by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As ActionInvoker(Of T)
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public override System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; override;
public override function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes() override;
public:
property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get() override;
}

Property Value

Returns the type of [T].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker<T> Class
ActionInvoker<T> Members
Base Implementation in KnownTypes


ActionInvokerFactory Class

ActionInvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : ActionInvokerFactory Class
The factory creating ActionInvoker<T> instances.
Object Model
ActionInvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class ActionInvokerFactory
   Inherits InvokerFactory
'Usage

Dim instance As ActionInvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public class ActionInvokerFactory : InvokerFactory
public class ActionInvokerFactory = class(InvokerFactory)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public class ActionInvokerFactory extends InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc class ActionInvokerFactory : public InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public ref class ActionInvokerFactory : public InvokerFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.ActionInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvokerFactory Members
Noemax.WebSockets.Messaging Namespace


ActionInvokerFactory Class Members

ActionInvokerFactory Class Members
Methods

Noemax.WebSockets.Messaging Namespace : ActionInvokerFactory Class

The following tables list the members exposed by ActionInvokerFactory.

Public Constructors
 | Name | Description
Public Constructor | ActionInvokerFactory Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Overridden. Creates Invoker for the specified method.
Top
See Also

Reference

ActionInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


ActionInvokerFactory Constructor

ActionInvokerFactory Constructor

Noemax.WebSockets.Messaging Namespace > ActionInvokerFactory Class : ActionInvokerFactory Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ActionInvokerFactory()
public ActionInvokerFactory()
public ActionInvokerFactory();
public function ActionInvokerFactory();
public: ActionInvokerFactory();
public:
ActionInvokerFactory();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvokerFactory Class
ActionInvokerFactory Members


ActionInvokerFactory Class Methods

ActionInvokerFactory Class Methods

Noemax.WebSockets.Messaging Namespace : ActionInvokerFactory Class

For a list of all members of this type, see ActionInvokerFactory members.

Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Overridden. Creates Invoker for the specified method.
Top
See Also

Reference

ActionInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


CanCreateInvoker Method (ActionInvokerFactory)

CanCreateInvoker Method (ActionInvokerFactory)

Noemax.WebSockets.Messaging Namespace > ActionInvokerFactory Class : CanCreateInvoker Method
The to check for compatibility with Invoker factory.
Determines whether the factory can create an Invoker for specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateInvoker( _
   ByVal methodInfo As System.Reflection.MethodInfo _
) As System.Boolean
'Usage

Dim instance As ActionInvokerFactory
Dim methodInfo As System.Reflection.MethodInfo
Dim value As System.Boolean

value = instance.CanCreateInvoker(methodInfo)
public override System.bool CanCreateInvoker(
   System.Reflection.MethodInfo methodInfo
)
public function CanCreateInvoker(
    methodInfo: System.Reflection.MethodInfo
): System.Boolean; override;
public override function CanCreateInvoker(
   methodInfo : System.Reflection.MethodInfo
) : System.boolean;
public: System.bool CanCreateInvoker(
   System.Reflection.MethodInfo* methodInfo
) override
public:
System.bool CanCreateInvoker(
   System.Reflection.MethodInfo^ methodInfo
) override

Parameters

methodInfo
The to check for compatibility with Invoker factory.

Return Value

True if factory can create invoker for the method; otherwise False.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvokerFactory Class
ActionInvokerFactory Members
Base Implementation in CanCreateInvoker


CreateInvoker Method (ActionInvokerFactory)

CreateInvoker Method (ActionInvokerFactory)

Noemax.WebSockets.Messaging Namespace > ActionInvokerFactory Class : CreateInvoker Method
The description of the method.
The instance of the class providing the method.
Creates Invoker for the specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CreateInvoker( _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim instance As ActionInvokerFactory
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = instance.CreateInvoker(info, instance)
public override Invoker CreateInvoker(
   System.Reflection.MethodInfo info,
   System.object instance
)
public function CreateInvoker(
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; override;
public override function CreateInvoker(
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
public: Invoker* CreateInvoker(
   System.Reflection.MethodInfo* info,
   System.Object* instance
) override
public:
Invoker^ CreateInvoker(
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
) override

Parameters

info
The description of the method.
instance
The instance of the class providing the method.

Return Value

The Invoker that dispatches the messages to the specified method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvokerFactory Class
ActionInvokerFactory Members
Base Implementation in CreateInvoker


ActionOperation1Invoker Class

ActionOperation1Invoker Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker Class
Object Model
ActionOperation1Invoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class ActionOperation1Invoker
   Inherits ActionInvoker
'Usage

Dim instance As ActionOperation1Invoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class ActionOperation1Invoker : ActionInvoker
public class ActionOperation1Invoker = class(ActionInvoker)sealed;
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public sealed class ActionOperation1Invoker extends ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class ActionOperation1Invoker : public ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public ref class ActionOperation1Invoker sealed : public ActionInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionOperation1Invoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker Class Members

ActionOperation1Invoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker Class

The following tables list the members exposed by ActionOperation1Invoker.

Public Constructors
 | Name | Description
Public Constructor | ActionOperation1Invoker Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperation1Invoker Class
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker Constructor

ActionOperation1Invoker Constructor

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker Class : ActionOperation1Invoker Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As ActionOperation1 _
)
'Usage

Dim func As ActionOperation1

Dim instance As New ActionOperation1Invoker(func)
public ActionOperation1Invoker(
   ActionOperation1 func
)
public ActionOperation1Invoker(
    func: ActionOperation1
);
public function ActionOperation1Invoker(
   func : ActionOperation1
);
public: ActionOperation1Invoker(
   ActionOperation1* func
)
public:
ActionOperation1Invoker(
   ActionOperation1^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker Class
ActionOperation1Invoker Members


ActionOperation1Invoker Class Methods

ActionOperation1Invoker Class Methods

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker Class

For a list of all members of this type, see ActionOperation1Invoker members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperation1Invoker Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ActionOperation1Invoker)

OnInvoke Method (ActionOperation1Invoker)

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(Object,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker Class
ActionOperation1Invoker Members
Base Implementation in OnInvoke


OnInvoke(Object,WebSocketChannel) Method

OnInvoke(Object,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker Class > OnInvoke Method : OnInvoke(Object,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Sub OnInvoke( _
   ByVal rpcMessage As System.Object, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As ActionOperation1Invoker
Dim rpcMessage As System.Object
Dim channel As WebSocketChannel

instance.OnInvoke(rpcMessage, channel)
protected override void OnInvoke(
   System.object rpcMessage,
   WebSocketChannel channel
)
protected procedure OnInvoke(
    rpcMessage: System.TObject;
    channel: WebSocketChannel
); override;
protected override function OnInvoke(
   rpcMessage : System.Object,
   channel : WebSocketChannel
);
protected: void OnInvoke(
   System.Object* rpcMessage,
   WebSocketChannel* channel
) override
protected:
void OnInvoke(
   System.Object^ rpcMessage,
   WebSocketChannel^ channel
) override

Parameters

rpcMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker Class
ActionOperation1Invoker Members
Overload List
Base Implementation in OnInvoke(Object,WebSocketChannel)


ActionOperation1Invoker Class Properties

ActionOperation1Invoker Class Properties

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker Class

For a list of all members of this type, see ActionOperation1Invoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

ActionOperation1Invoker Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (ActionOperation1Invoker)

InputTypes Property (ActionOperation1Invoker)

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker Class : InputTypes Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As ActionOperation1Invoker
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker Class
ActionOperation1Invoker Members
Base Implementation in InputTypes


ActionOperation1Invoker<T> Class

ActionOperation1Invoker<T> Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker<T> Class
Object Model
ActionOperation1Invoker<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class ActionOperation1Invoker(Of T)
   Inherits ActionInvoker(Of T)
'Usage

Dim instance As ActionOperation1Invoker(Of T)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class ActionOperation1Invoker<T> : ActionInvoker<T>
public class ActionOperation1Invoker = class(ActionInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class ActionOperation1Invoker<T> : public ActionInvoker<T>
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename T>
public ref class ActionOperation1Invoker sealed : public ActionInvoker<T>
Type Parameters
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker<T> Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker<T> Class Members

ActionOperation1Invoker<T> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker<T> Class

The following tables list the members exposed by ActionOperation1Invoker<T>.

Public Constructors
 | Name | Description
Public Constructor | ActionOperation1Invoker<T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Gets the type list of types accepted by invoker. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Public Property | KnownTypes | Gets the list of types that must be known by the serializer. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperation1Invoker<T> Class
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker<T> Constructor

ActionOperation1Invoker<T> Constructor

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker<T> Class : ActionOperation1Invoker<T> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As Noemax.WebSockets.Messaging.ActionOperation1(Of T) _
)
'Usage

Dim func As Noemax.WebSockets.Messaging.ActionOperation1(Of T)

Dim instance As New ActionOperation1Invoker(Of T)(func)
public ActionOperation1Invoker<T>(
   Noemax.WebSockets.Messaging.ActionOperation1<T> func
)
public ActionOperation1Invoker<T>(
    func: Noemax.WebSockets.Messaging.ActionOperation1
);
public function ActionOperation1Invoker<T>(
   func : Noemax.WebSockets.Messaging.ActionOperation1
);
public: ActionOperation1Invoker<T>(
   Noemax.WebSockets.Messaging.ActionOperation1<T*>* func
)
public:
ActionOperation1Invoker<T>(
   Noemax.WebSockets.Messaging.ActionOperation1<T^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker<T> Class
ActionOperation1Invoker<T> Members


ActionOperation1Invoker<T> Class Methods

ActionOperation1Invoker<T> Class Methods

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker<T> Class

For a list of all members of this type, see ActionOperation1Invoker<T> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperation1Invoker<T> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ActionOperation1Invoker<T>)

OnInvoke Method (ActionOperation1Invoker<T>)

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker<T> Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(Object,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker<T> Class
ActionOperation1Invoker<T> Members
Base Implementation in OnInvoke


OnInvoke(Object,WebSocketChannel) Method

OnInvoke(Object,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionOperation1Invoker<T> Class > OnInvoke Method : OnInvoke(Object,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Sub OnInvoke( _
   ByVal rpcMessage As System.Object, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As ActionOperation1Invoker(Of T)
Dim rpcMessage As System.Object
Dim channel As WebSocketChannel

instance.OnInvoke(rpcMessage, channel)
protected override void OnInvoke(
   System.object rpcMessage,
   WebSocketChannel channel
)
protected procedure OnInvoke(
    rpcMessage: System.TObject;
    channel: WebSocketChannel
); override;
protected override function OnInvoke(
   rpcMessage : System.Object,
   channel : WebSocketChannel
);
protected: void OnInvoke(
   System.Object* rpcMessage,
   WebSocketChannel* channel
) override
protected:
void OnInvoke(
   System.Object^ rpcMessage,
   WebSocketChannel^ channel
) override

Parameters

rpcMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker<T> Class
ActionOperation1Invoker<T> Members
Overload List
Base Implementation in OnInvoke(Object,WebSocketChannel)


ActionOperationInvoker Class

ActionOperationInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker Class
Object Model
ActionOperationInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class ActionOperationInvoker
   Inherits ActionInvoker
'Usage

Dim instance As ActionOperationInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class ActionOperationInvoker : ActionInvoker
public class ActionOperationInvoker = class(ActionInvoker)sealed;
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public sealed class ActionOperationInvoker extends ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class ActionOperationInvoker : public ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public ref class ActionOperationInvoker sealed : public ActionInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionOperationInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Members
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker Class Members

ActionOperationInvoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker Class

The following tables list the members exposed by ActionOperationInvoker.

Public Constructors
 | Name | Description
Public Constructor | ActionOperationInvoker Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperationInvoker Class
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker Constructor

ActionOperationInvoker Constructor

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker Class : ActionOperationInvoker Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As ActionOperation _
)
'Usage

Dim func As ActionOperation

Dim instance As New ActionOperationInvoker(func)
public ActionOperationInvoker(
   ActionOperation func
)
public ActionOperationInvoker(
    func: ActionOperation
);
public function ActionOperationInvoker(
   func : ActionOperation
);
public: ActionOperationInvoker(
   ActionOperation* func
)
public:
ActionOperationInvoker(
   ActionOperation^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Class
ActionOperationInvoker Members


ActionOperationInvoker Class Methods

ActionOperationInvoker Class Methods

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker Class

For a list of all members of this type, see ActionOperationInvoker members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperationInvoker Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ActionOperationInvoker)

OnInvoke Method (ActionOperationInvoker)

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(Object,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Class
ActionOperationInvoker Members
Base Implementation in OnInvoke


OnInvoke(Object,WebSocketChannel) Method

OnInvoke(Object,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker Class > OnInvoke Method : OnInvoke(Object,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Sub OnInvoke( _
   ByVal rpcMessage As System.Object, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As ActionOperationInvoker
Dim rpcMessage As System.Object
Dim channel As WebSocketChannel

instance.OnInvoke(rpcMessage, channel)
protected override void OnInvoke(
   System.object rpcMessage,
   WebSocketChannel channel
)
protected procedure OnInvoke(
    rpcMessage: System.TObject;
    channel: WebSocketChannel
); override;
protected override function OnInvoke(
   rpcMessage : System.Object,
   channel : WebSocketChannel
);
protected: void OnInvoke(
   System.Object* rpcMessage,
   WebSocketChannel* channel
) override
protected:
void OnInvoke(
   System.Object^ rpcMessage,
   WebSocketChannel^ channel
) override

Parameters

rpcMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Class
ActionOperationInvoker Members
Overload List
Base Implementation in OnInvoke(Object,WebSocketChannel)


ActionOperationInvoker Class Properties

ActionOperationInvoker Class Properties

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker Class

For a list of all members of this type, see ActionOperationInvoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

ActionOperationInvoker Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (ActionOperationInvoker)

InputTypes Property (ActionOperationInvoker)

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker Class : InputTypes Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As ActionOperationInvoker
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Class
ActionOperationInvoker Members
Base Implementation in InputTypes


ActionOperationInvoker<T> Class

ActionOperationInvoker<T> Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker<T> Class
Object Model
ActionOperationInvoker<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class ActionOperationInvoker(Of T)
   Inherits ActionInvoker(Of T)
'Usage

Dim instance As ActionOperationInvoker(Of T)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class ActionOperationInvoker<T> : ActionInvoker<T>
public class ActionOperationInvoker = class(ActionInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class ActionOperationInvoker<T> : public ActionInvoker<T>
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename T>
public ref class ActionOperationInvoker sealed : public ActionInvoker<T>
Type Parameters
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperationInvoker<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker<T> Members
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker<T> Class Members

ActionOperationInvoker<T> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker<T> Class

The following tables list the members exposed by ActionOperationInvoker<T>.

Public Constructors
 | Name | Description
Public Constructor | ActionOperationInvoker<T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Gets the type list of types accepted by invoker. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Public Property | KnownTypes | Gets the list of types that must be known by the serializer. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperationInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker<T> Constructor

ActionOperationInvoker<T> Constructor

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker<T> Class : ActionOperationInvoker<T> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As System.Action(Of T) _
)
'Usage

Dim func As System.Action(Of T)

Dim instance As New ActionOperationInvoker(Of T)(func)
public ActionOperationInvoker<T>(
   System.Action<T> func
)
public ActionOperationInvoker<T>(
    func: System.Action
);
public function ActionOperationInvoker<T>(
   func : System.Action
);
public: ActionOperationInvoker<T>(
   System.Action<T*>* func
)
public:
ActionOperationInvoker<T>(
   System.Action<T^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker<T> Class
ActionOperationInvoker<T> Members


ActionOperationInvoker<T> Class Methods

ActionOperationInvoker<T> Class Methods

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker<T> Class

For a list of all members of this type, see ActionOperationInvoker<T> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

ActionOperationInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ActionOperationInvoker<T>)

OnInvoke Method (ActionOperationInvoker<T>)

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker<T> Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(Object,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker<T> Class
ActionOperationInvoker<T> Members
Base Implementation in OnInvoke


OnInvoke(Object,WebSocketChannel) Method

OnInvoke(Object,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > ActionOperationInvoker<T> Class > OnInvoke Method : OnInvoke(Object,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Sub OnInvoke( _
   ByVal rpcMessage As System.Object, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As ActionOperationInvoker(Of T)
Dim rpcMessage As System.Object
Dim channel As WebSocketChannel

instance.OnInvoke(rpcMessage, channel)
protected override void OnInvoke(
   System.object rpcMessage,
   WebSocketChannel channel
)
protected procedure OnInvoke(
    rpcMessage: System.TObject;
    channel: WebSocketChannel
); override;
protected override function OnInvoke(
   rpcMessage : System.Object,
   channel : WebSocketChannel
);
protected: void OnInvoke(
   System.Object* rpcMessage,
   WebSocketChannel* channel
) override
protected:
void OnInvoke(
   System.Object^ rpcMessage,
   WebSocketChannel^ channel
) override

Parameters

rpcMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker<T> Class
ActionOperationInvoker<T> Members
Overload List
Base Implementation in OnInvoke(Object,WebSocketChannel)


CompressedMessageSerializer Class

CompressedMessageSerializer Class
Members

Noemax.WebSockets.Messaging Namespace : CompressedMessageSerializer Class
Provides a serializer which transparently compress outbound messages and decompress inbound messages.
Object Model
CompressedMessageSerializer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class CompressedMessageSerializer
   Implements IMessageSerializer
'Usage

Dim instance As CompressedMessageSerializer
public class CompressedMessageSerializer : IMessageSerializer
public class CompressedMessageSerializer = class(IMessageSerializer)
public class CompressedMessageSerializer implements IMessageSerializer
public __gc class CompressedMessageSerializer : public IMessageSerializer
public ref class CompressedMessageSerializer : public IMessageSerializer
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.CompressedMessageSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Members
Noemax.WebSockets.Messaging Namespace


CompressedMessageSerializer Class Members

CompressedMessageSerializer Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : CompressedMessageSerializer Class

The following tables list the members exposed by CompressedMessageSerializer.

Public Constructors
 | Name | Description
Public Constructor | CompressedMessageSerializer Constructor |
Top
Public Properties
 | Name | Description
Public Property | CompressedMessageFormat | Gets and sets the compression format to use for compressing the outbound messages.
Public Property | CompressionLevel | The compression level to be applied when messages are compressed.
Public Property | CompressionThreshold | Gets and sets the minimum size the message to be compressed.
Top
Public Methods
 | Name | Description
Public Method | Deserialize |
Public Method | EnsureKnownTypes |
Public Method | Serialize | Overloaded.
Top
See Also

Reference

CompressedMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


CompressedMessageSerializer Constructor

CompressedMessageSerializer Constructor

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : CompressedMessageSerializer Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal serializer As IMessageSerializer _
)
'Usage

Dim serializer As IMessageSerializer

Dim instance As New CompressedMessageSerializer(serializer)
public CompressedMessageSerializer(
   IMessageSerializer serializer
)
public CompressedMessageSerializer(
    serializer: IMessageSerializer
);
public function CompressedMessageSerializer(
   serializer : IMessageSerializer
);
public: CompressedMessageSerializer(
   IMessageSerializer* serializer
)
public:
CompressedMessageSerializer(
   IMessageSerializer^ serializer
)

Parameters

serializer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


CompressedMessageSerializer Class Methods

CompressedMessageSerializer Class Methods

Noemax.WebSockets.Messaging Namespace : CompressedMessageSerializer Class

For a list of all members of this type, see CompressedMessageSerializer members.

Public Methods
 | Name | Description
Public Method | Deserialize |
Public Method | EnsureKnownTypes |
Public Method | Serialize | Overloaded.
Top
See Also

Reference

CompressedMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


Deserialize Method (CompressedMessageSerializer)

Deserialize Method (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : Deserialize Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Deserialize( _
   ByVal message As WebSocketInboundMessage, _
   ByVal channel As WebSocketChannel, _
   ByVal messageDispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As CompressedMessageSerializer
Dim message As WebSocketInboundMessage
Dim channel As WebSocketChannel
Dim messageDispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(message, channel, messageDispatcher)
public System.object Deserialize(
   WebSocketInboundMessage message,
   WebSocketChannel channel,
   MessageDispatcher messageDispatcher
)
public function Deserialize(
    message: WebSocketInboundMessage;
    channel: WebSocketChannel;
    messageDispatcher: MessageDispatcher
): System.TObject;
public function Deserialize(
   message : WebSocketInboundMessage,
   channel : WebSocketChannel,
   messageDispatcher : MessageDispatcher
) : System.Object;
public: System.Object* Deserialize(
   WebSocketInboundMessage* message,
   WebSocketChannel* channel,
   MessageDispatcher* messageDispatcher
)
public:
System.Object^ Deserialize(
   WebSocketInboundMessage^ message,
   WebSocketChannel^ channel,
   MessageDispatcher^ messageDispatcher
)

Parameters

message
channel
messageDispatcher
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


EnsureKnownTypes Method (CompressedMessageSerializer)

EnsureKnownTypes Method (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : EnsureKnownTypes Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub EnsureKnownTypes( _
   ByVal ParamArray types() As System.Type _
)
'Usage

Dim instance As CompressedMessageSerializer
Dim types() As System.Type

instance.EnsureKnownTypes(types)
public void EnsureKnownTypes(
   params System.Type[] types
)
public procedure EnsureKnownTypes(
   params  types: System.Typearray of
);
public function EnsureKnownTypes(
   types : System.Type[]
);
public: void EnsureKnownTypes(
   params System.Type*[]* types
)
public:
void EnsureKnownTypes(
   ... System.array<Type^>^ types
)

Parameters

types
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


Serialize Method (CompressedMessageSerializer)

Serialize Method (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : Serialize Method
Overload List
Overload | Description
Serialize(Object) |
Serialize(Stream,Object) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


Serialize(Object) Method

Serialize(Object) Method

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class > Serialize Method : Serialize(Object) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Serialize( _
   ByVal obj As System.Object _
) As WebSocketOutboundMessage
'Usage

Dim instance As CompressedMessageSerializer
Dim obj As System.Object
Dim value As WebSocketOutboundMessage

value = instance.Serialize(obj)
public WebSocketOutboundMessage Serialize(
   System.object obj
)
public function Serialize(
    obj: System.TObject
): WebSocketOutboundMessage;
public function Serialize(
   obj : System.Object
) : WebSocketOutboundMessage;
public: WebSocketOutboundMessage Serialize(
   System.Object* obj
)
public:
WebSocketOutboundMessage Serialize(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members
Overload List


Serialize(Stream,Object) Method

Serialize(Stream,Object) Method

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class > Serialize Method : Serialize(Stream,Object) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function Serialize( _
   ByVal output As System.IO.Stream, _
   ByVal obj As System.Object _
) As System.IO.Stream
'Usage

Dim instance As CompressedMessageSerializer
Dim output As System.IO.Stream
Dim obj As System.Object
Dim value As System.IO.Stream

value = instance.Serialize(output, obj)
public System.IO.Stream Serialize(
   System.IO.Stream output,
   System.object obj
)
public function Serialize(
    output: System.IO.Stream;
    obj: System.TObject
): System.IO.Stream;
public function Serialize(
   output : System.IO.Stream,
   obj : System.Object
) : System.IO.Stream;
public: System.IO.Stream* Serialize(
   System.IO.Stream* output,
   System.Object* obj
)
public:
System.IO.Stream^ Serialize(
   System.IO.Stream^ output,
   System.Object^ obj
)

Parameters

output
obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members
Overload List


CompressedMessageSerializer Class Properties

CompressedMessageSerializer Class Properties

Noemax.WebSockets.Messaging Namespace : CompressedMessageSerializer Class

For a list of all members of this type, see CompressedMessageSerializer members.

Public Properties
 | Name | Description
Public Property | CompressedMessageFormat | Gets and sets the compression format to use for compressing the outbound messages.
Public Property | CompressionLevel | The compression level to be applied when messages are compressed.
Public Property | CompressionThreshold | Gets and sets the minimum size the message to be compressed.
Top
See Also

Reference

CompressedMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


CompressedMessageFormat Property (CompressedMessageSerializer)

CompressedMessageFormat Property (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : CompressedMessageFormat Property
Gets and sets the compression format to use for compressing the outbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressedMessageFormat As CompressedMessageFormat
'Usage

Dim instance As CompressedMessageSerializer
Dim value As CompressedMessageFormat

instance.CompressedMessageFormat = value

value = instance.CompressedMessageFormat
public CompressedMessageFormat CompressedMessageFormat {get; set;}
public read-write property CompressedMessageFormat: CompressedMessageFormat;
public function get,set CompressedMessageFormat : CompressedMessageFormat
public: __property CompressedMessageFormat get_CompressedMessageFormat();
public: __property void set_CompressedMessageFormat(
   CompressedMessageFormat value
);
public:
property CompressedMessageFormat CompressedMessageFormat {
   CompressedMessageFormat get();
   void set (    CompressedMessageFormat value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


CompressionLevel Property (CompressedMessageSerializer)

CompressionLevel Property (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : CompressionLevel Property
The compression level to be applied when messages are compressed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressionLevel As System.Integer
'Usage

Dim instance As CompressedMessageSerializer
Dim value As System.Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
public System.int CompressionLevel {get; set;}
public read-write property CompressionLevel: System.Integer;
public function get,set CompressionLevel : System.int
public: __property System.int get_CompressionLevel();
public: __property void set_CompressionLevel(
   System.int value
);
public:
property System.int CompressionLevel {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


CompressionThreshold Property (CompressedMessageSerializer)

CompressionThreshold Property (CompressedMessageSerializer)

Noemax.WebSockets.Messaging Namespace > CompressedMessageSerializer Class : CompressionThreshold Property
Gets and sets the minimum size the message to be compressed.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property CompressionThreshold As System.Integer
'Usage

Dim instance As CompressedMessageSerializer
Dim value As System.Integer

instance.CompressionThreshold = value

value = instance.CompressionThreshold
public System.int CompressionThreshold {get; set;}
public read-write property CompressionThreshold: System.Integer;
public function get,set CompressionThreshold : System.int
public: __property System.int get_CompressionThreshold();
public: __property void set_CompressionThreshold(
   System.int value
);
public:
property System.int CompressionThreshold {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CompressedMessageSerializer Class
CompressedMessageSerializer Members


ConversationMessage Class

ConversationMessage Class
Members

Noemax.WebSockets.Messaging Namespace : ConversationMessage Class
Represents an envelope providing additional metadata for dispatching the message.
Object Model
ConversationMessage Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataContractAttribute()>
Public MustInherit Class ConversationMessage
   Inherits EnvelopedMessage
'Usage

Dim instance As ConversationMessage
[System.Runtime.Serialization.DataContract()]
public abstract class ConversationMessage : EnvelopedMessage
public class ConversationMessage = class(EnvelopedMessage)abstract;
System.Runtime.Serialization.DataContractAttribute()
public abstract class ConversationMessage extends EnvelopedMessage
[System.Runtime.Serialization.DataContract()]
public __gc abstract class ConversationMessage : public EnvelopedMessage
[System.Runtime.Serialization.DataContract()]
public ref class ConversationMessage abstract : public EnvelopedMessage
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.EnvelopedMessage
Noemax.WebSockets.Messaging.ConversationMessage
Noemax.WebSockets.Messaging.PlainMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConversationMessage Members
Noemax.WebSockets.Messaging Namespace


ConversationMessage Class Members

ConversationMessage Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ConversationMessage Class

The following tables list the members exposed by ConversationMessage.

Public Properties
 | Name | Description
Public Property | Attachment | (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Body | The body of the enveloped message. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Id | Gets the number identifying the request to the service.
Public Property | IsFault | Gets the value that indicate that the message is fault message.
Public Property | IsResponse | Gets the value that indicates that message is response to previously sent request message.
Top
Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Top
See Also

Reference

ConversationMessage Class
Noemax.WebSockets.Messaging Namespace


ConversationMessage Class Properties

ConversationMessage Class Properties

Noemax.WebSockets.Messaging Namespace : ConversationMessage Class

For a list of all members of this type, see ConversationMessage members.

Public Properties
 | Name | Description
Public Property | Attachment | (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Body | The body of the enveloped message. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Id | Gets the number identifying the request to the service.
Public Property | IsFault | Gets the value that indicate that the message is fault message.
Public Property | IsResponse | Gets the value that indicates that message is response to previously sent request message.
Top
See Also

Reference

ConversationMessage Class
Noemax.WebSockets.Messaging Namespace


Id Property (ConversationMessage)

Id Property (ConversationMessage)

Noemax.WebSockets.Messaging Namespace > ConversationMessage Class : Id Property
Gets the number identifying the request to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataMemberAttribute(Name="id",
   Order=0,
   EmitDefaultValue=False)>
<JsonPropertyAttribute("id")>
Public Property Id As System.Nullable(Of Long)
'Usage

Dim instance As ConversationMessage
Dim value As System.Nullable(Of Long)

instance.Id = value

value = instance.Id
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
[JsonProperty("id")]
public System.Nullable<long> Id {get; set;}
public read-write property Id: System.Nullable;
System.Runtime.Serialization.DataMemberAttribute(Name="id",
   Order=0,
   EmitDefaultValue=)
JsonPropertyAttribute("id")
public function get,set Id : System.Nullable
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
[JsonProperty("id")]
public: __property System.Nullable<long> get_Id();
public: __property void set_Id(
   System.Nullable<long> value
);
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
[JsonProperty("id")]
public:
property System.Nullable<int64> Id {
   System.Nullable<int64> get();
   void set (    System.Nullable<int64> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConversationMessage Class
ConversationMessage Members


IsFault Property (ConversationMessage)

IsFault Property (ConversationMessage)

Noemax.WebSockets.Messaging Namespace > ConversationMessage Class : IsFault Property
Gets the value that indicate that the message is fault message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<JsonIgnoreAttribute()>
Public MustOverride ReadOnly Property IsFault As System.Boolean
'Usage

Dim instance As ConversationMessage
Dim value As System.Boolean

value = instance.IsFault
[JsonIgnore()]
public abstract System.bool IsFault {get;}
public read-only property IsFault: System.Boolean; abstract;
JsonIgnoreAttribute()
public __abstract function get IsFault : System.boolean
[JsonIgnore()]
public: __property abstract System.bool get_IsFault();
[JsonIgnore()]
public:
abstract property System.bool IsFault {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConversationMessage Class
ConversationMessage Members


IsResponse Property (ConversationMessage)

IsResponse Property (ConversationMessage)

Noemax.WebSockets.Messaging Namespace > ConversationMessage Class : IsResponse Property
Gets the value that indicates that message is response to previously sent request message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<JsonIgnoreAttribute()>
Public MustOverride ReadOnly Property IsResponse As System.Boolean
'Usage

Dim instance As ConversationMessage
Dim value As System.Boolean

value = instance.IsResponse
[JsonIgnore()]
public abstract System.bool IsResponse {get;}
public read-only property IsResponse: System.Boolean; abstract;
JsonIgnoreAttribute()
public __abstract function get IsResponse : System.boolean
[JsonIgnore()]
public: __property abstract System.bool get_IsResponse();
[JsonIgnore()]
public:
abstract property System.bool IsResponse {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConversationMessage Class
ConversationMessage Members


DefaultClientDispatcher Class

DefaultClientDispatcher Class
Members

Noemax.WebSockets.Messaging Namespace : DefaultClientDispatcher Class
Provides methods and properties for sending request messages and dispatching response messages on the Noemax.WebSockets.WebSocketChannel connection.
Object Model
DefaultClientDispatcher Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DefaultClientDispatcher
   Implements IClientDispatcher
'Usage

Dim instance As DefaultClientDispatcher
public class DefaultClientDispatcher : IClientDispatcher
public class DefaultClientDispatcher = class(IClientDispatcher)
public class DefaultClientDispatcher implements IClientDispatcher
public __gc class DefaultClientDispatcher : public IClientDispatcher
public ref class DefaultClientDispatcher : public IClientDispatcher
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.DefaultClientDispatcher

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultClientDispatcher Members
Noemax.WebSockets.Messaging Namespace


DefaultClientDispatcher Class Members

DefaultClientDispatcher Class Members
Methods

Noemax.WebSockets.Messaging Namespace : DefaultClientDispatcher Class

The following tables list the members exposed by DefaultClientDispatcher.

Public Constructors
 | Name | Description
Public Constructor | DefaultClientDispatcher Constructor | Initializes a new instance of DefaultClientDispatcher.
Top
Public Methods
 | Name | Description
Public Method | Dispatch | Dispatchers inbound messages to the local message operation.
Top
See Also

Reference

DefaultClientDispatcher Class
Noemax.WebSockets.Messaging Namespace


DefaultClientDispatcher Constructor

DefaultClientDispatcher Constructor

Noemax.WebSockets.Messaging Namespace > DefaultClientDispatcher Class : DefaultClientDispatcher Constructor
Initializes a new instance of DefaultClientDispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim channel As WebSocketChannel

Dim instance As New DefaultClientDispatcher(channel)
public DefaultClientDispatcher(
   WebSocketChannel channel
)
public DefaultClientDispatcher(
    channel: WebSocketChannel
);
public function DefaultClientDispatcher(
   channel : WebSocketChannel
);
public: DefaultClientDispatcher(
   WebSocketChannel* channel
)
public:
DefaultClientDispatcher(
   WebSocketChannel^ channel
)

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultClientDispatcher Class
DefaultClientDispatcher Members


DefaultClientDispatcher Class Methods

DefaultClientDispatcher Class Methods

Noemax.WebSockets.Messaging Namespace : DefaultClientDispatcher Class

For a list of all members of this type, see DefaultClientDispatcher members.

Public Methods
 | Name | Description
Public Method | Dispatch | Dispatchers inbound messages to the local message operation.
Top
See Also

Reference

DefaultClientDispatcher Class
Noemax.WebSockets.Messaging Namespace


Dispatch Method (DefaultClientDispatcher)

Dispatch Method (DefaultClientDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultClientDispatcher Class : Dispatch Method
The message received from remote endpoint.
The channel through which message is received.
Dispatchers inbound messages to the local message operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Dispatch( _
   ByVal inboundMessage As ConversationMessage, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As DefaultClientDispatcher
Dim inboundMessage As ConversationMessage
Dim channel As WebSocketChannel

instance.Dispatch(inboundMessage, channel)
public void Dispatch(
   ConversationMessage inboundMessage,
   WebSocketChannel channel
)
public procedure Dispatch(
    inboundMessage: ConversationMessage;
    channel: WebSocketChannel
);
public function Dispatch(
   inboundMessage : ConversationMessage,
   channel : WebSocketChannel
);
public: void Dispatch(
   ConversationMessage* inboundMessage,
   WebSocketChannel* channel
)
public:
void Dispatch(
   ConversationMessage^ inboundMessage,
   WebSocketChannel^ channel
)

Parameters

inboundMessage
The message received from remote endpoint.
channel
The channel through which message is received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultClientDispatcher Class
DefaultClientDispatcher Members


DefaultMessageDispatcher Class

DefaultMessageDispatcher Class
Members

Noemax.WebSockets.Messaging Namespace : DefaultMessageDispatcher Class
Dispatches the messages based on the action string or the data type deserialized from the message payload.
Object Model
DefaultMessageDispatcher Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DefaultMessageDispatcher
   Inherits MessageDispatcher
'Usage

Dim instance As DefaultMessageDispatcher
public class DefaultMessageDispatcher : MessageDispatcher
public class DefaultMessageDispatcher = class(MessageDispatcher)
public class DefaultMessageDispatcher extends MessageDispatcher
public __gc class DefaultMessageDispatcher : public MessageDispatcher
public ref class DefaultMessageDispatcher : public MessageDispatcher
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageDispatcher
Noemax.WebSockets.Messaging.DefaultMessageDispatcher

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Members
Noemax.WebSockets.Messaging Namespace


DefaultMessageDispatcher Class Members

DefaultMessageDispatcher Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : DefaultMessageDispatcher Class

The following tables list the members exposed by DefaultMessageDispatcher.

Public Constructors
 | Name | Description
Public Constructor | DefaultMessageDispatcher Constructor | Initialize a new instance of MessageDispatcher.
Top
Public Properties
 | Name | Description
Public Property | DefaultSerializer | Overridden. Gets and sets the IMessageSerializer used by the dispatcher.
Public Property | KnownTypes | Overridden. The list of the types known to dispatcher.
Public Property | Operations | Gets the list of operations being dispatched by the dispatcher. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
Top
Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
Public Method | CreateClientDispatcher | Overridden. Create an instance of IClientDispatcher associated to the specified channel.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
static (Shared in Visual Basic) | ExportKnownTypes | Exports the known-types and actions used by the dispatcher for dispatching messages.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
static (Shared in Visual Basic) | RegisterInvokerFactory | Registers InvokerFactory to be used when constructing Invoker for messaging operation.
Public Method | TryGetOperation | Overridden. Tries to resolve the operation to which the message is to be dispatched.
Top
Protected Methods
 | Name | Description
Protected Method | GenerateOperationsFromType | Generates the collection of MessageOperationDescription from the methods provided by the specified type.
Protected Method | TryCreateInvoker | Attempts to allocate invoker for the specified method using the collection of InvokerFactory.
Top
See Also

Reference

DefaultMessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


DefaultMessageDispatcher Constructor

DefaultMessageDispatcher Constructor

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : DefaultMessageDispatcher Constructor
The instance providing operations to which messages are dispatched.
Initialize a new instance of MessageDispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal instance As System.Object _
)
'Usage

Dim instance As System.Object

Dim instance As New DefaultMessageDispatcher(instance)
public DefaultMessageDispatcher(
   System.object instance
)
public DefaultMessageDispatcher(
    instance: System.TObject
);
public function DefaultMessageDispatcher(
   instance : System.Object
);
public: DefaultMessageDispatcher(
   System.Object* instance
)
public:
DefaultMessageDispatcher(
   System.Object^ instance
)

Parameters

instance
The instance providing operations to which messages are dispatched.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members


DefaultMessageDispatcher Class Methods

DefaultMessageDispatcher Class Methods

Noemax.WebSockets.Messaging Namespace : DefaultMessageDispatcher Class

For a list of all members of this type, see DefaultMessageDispatcher members.

Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
Public Method | CreateClientDispatcher | Overridden. Create an instance of IClientDispatcher associated to the specified channel.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
static (Shared in Visual Basic) | ExportKnownTypes | Exports the known-types and actions used by the dispatcher for dispatching messages.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
static (Shared in Visual Basic) | RegisterInvokerFactory | Registers InvokerFactory to be used when constructing Invoker for messaging operation.
Public Method | TryGetOperation | Overridden. Tries to resolve the operation to which the message is to be dispatched.
Top
Protected Methods
 | Name | Description
Protected Method | GenerateOperationsFromType | Generates the collection of MessageOperationDescription from the methods provided by the specified type.
Protected Method | TryCreateInvoker | Attempts to allocate invoker for the specified method using the collection of InvokerFactory.
Top
See Also

Reference

DefaultMessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


CreateClientDispatcher Method (DefaultMessageDispatcher)

CreateClientDispatcher Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : CreateClientDispatcher Method
The channel to which created client dispatcher is being associated.
Create an instance of IClientDispatcher associated to the specified channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CreateClientDispatcher( _
   ByVal channel As WebSocketChannel _
) As IClientDispatcher
'Usage

Dim instance As DefaultMessageDispatcher
Dim channel As WebSocketChannel
Dim value As IClientDispatcher

value = instance.CreateClientDispatcher(channel)
public override IClientDispatcher CreateClientDispatcher(
   WebSocketChannel channel
)
public function CreateClientDispatcher(
    channel: WebSocketChannel
): IClientDispatcher; override;
public override function CreateClientDispatcher(
   channel : WebSocketChannel
) : IClientDispatcher;
public: IClientDispatcher* CreateClientDispatcher(
   WebSocketChannel* channel
) override
public:
IClientDispatcher^ CreateClientDispatcher(
   WebSocketChannel^ channel
) override

Parameters

channel
The channel to which created client dispatcher is being associated.

Return Value

The new instance of the IClientDispatcher.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members
Base Implementation in CreateClientDispatcher


ExportKnownTypes Method (DefaultMessageDispatcher)

ExportKnownTypes Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : ExportKnownTypes Method
The type of the service providing the messaging operations.
The list of types known to the dispatcher.
The actions used by the dispatcher.
Exports the known-types and actions used by the dispatcher for dispatching messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub ExportKnownTypes( _
   ByVal handlerType As System.Type, _
   ByRef knownTypes As System.Type(), _
   ByRef actions As System.String() _
)
'Usage

Dim handlerType As System.Type
Dim knownTypes As System.Type()
Dim actions As System.String()

DefaultMessageDispatcher.ExportKnownTypes(handlerType, knownTypes, actions)
public static void ExportKnownTypes(
   System.Type handlerType,
   out System.Type[] knownTypes,
   out System.string[] actions
)
public procedure ExportKnownTypes(
    handlerType: System.Type;
   Out  knownTypes: System.array of Type;
   Out  actions: System.array of String
); static;
public static function ExportKnownTypes(
   handlerType : System.Type,
   knownTypes : System.Type[],
   actions : System.String[]
);
public: static void ExportKnownTypes(
   System.Type* handlerType,
   [PARAMFLAG::Out] System.Type*[] knownTypes,
   [PARAMFLAG::Out] System.string*[] actions
)
public:
static void ExportKnownTypes(
   System.Type^ handlerType,
   [Out] System.array<Type^> knownTypes,
   [Out] System.array<String^> actions
)

Parameters

handlerType
The type of the service providing the messaging operations.
knownTypes
The list of types known to the dispatcher.
actions
The actions used by the dispatcher.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members


GenerateOperationsFromType Method (DefaultMessageDispatcher)

GenerateOperationsFromType Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : GenerateOperationsFromType Method
The type to scan for message operations.
The instance to handle the message operations.
A collection of InvokerFactories to used for allocating an Invoker.
The collection to populate with generated MessageOperation objects.
Generates the collection of MessageOperationDescription from the methods provided by the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub GenerateOperationsFromType( _
   ByVal handlerType As System.Type, _
   ByVal instance As System.Object, _
   ByVal invokerFactories As System.Collections.Generic.ICollection(Of InvokerFactory), _
   ByVal operations As System.Collections.Generic.ICollection(Of MessageOperationDescription) _
)
'Usage

Dim instance As DefaultMessageDispatcher
Dim handlerType As System.Type
Dim instance As System.Object
Dim invokerFactories As System.Collections.Generic.ICollection(Of InvokerFactory)
Dim operations As System.Collections.Generic.ICollection(Of MessageOperationDescription)

instance.GenerateOperationsFromType(handlerType, instance, invokerFactories, operations)
protected virtual void GenerateOperationsFromType(
   System.Type handlerType,
   System.object instance,
   System.Collections.Generic.ICollection<InvokerFactory> invokerFactories,
   System.Collections.Generic.ICollection<MessageOperationDescription> operations
)
protected procedure GenerateOperationsFromType(
    handlerType: System.Type;
    instance: System.TObject;
    invokerFactories: System.Collections.Generic.ICollection;
    operations: System.Collections.Generic.ICollection
); virtual;
protected function GenerateOperationsFromType(
   handlerType : System.Type,
   instance : System.Object,
   invokerFactories : System.Collections.Generic.ICollection,
   operations : System.Collections.Generic.ICollection
);
protected: virtual void GenerateOperationsFromType(
   System.Type* handlerType,
   System.Object* instance,
   System.Collections.Generic.ICollection<InvokerFactory*>* invokerFactories,
   System.Collections.Generic.ICollection<MessageOperationDescription*>* operations
)
protected:
virtual void GenerateOperationsFromType(
   System.Type^ handlerType,
   System.Object^ instance,
   System.Collections.Generic.ICollection<InvokerFactory^>^ invokerFactories,
   System.Collections.Generic.ICollection<MessageOperationDescription^>^ operations
)

Parameters

handlerType
The type to scan for message operations.
instance
The instance to handle the message operations.
invokerFactories
A collection of InvokerFactories to used for allocating an Invoker.
operations
The collection to populate with generated MessageOperation objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members


RegisterInvokerFactory Method (DefaultMessageDispatcher)

RegisterInvokerFactory Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : RegisterInvokerFactory Method
The InvokerFactory to be registered.
Registers InvokerFactory to be used when constructing Invoker for messaging operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Sub RegisterInvokerFactory( _
   ByVal factory As InvokerFactory _
)
'Usage

Dim factory As InvokerFactory

DefaultMessageDispatcher.RegisterInvokerFactory(factory)
public static void RegisterInvokerFactory(
   InvokerFactory factory
)
public procedure RegisterInvokerFactory(
    factory: InvokerFactory
); static;
public static function RegisterInvokerFactory(
   factory : InvokerFactory
);
public: static void RegisterInvokerFactory(
   InvokerFactory* factory
)
public:
static void RegisterInvokerFactory(
   InvokerFactory^ factory
)

Parameters

factory
The InvokerFactory to be registered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members


TryCreateInvoker Method (DefaultMessageDispatcher)

TryCreateInvoker Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : TryCreateInvoker Method
The method to allocate Invoker for.
The instance of the object implementing the method.
The collection of InvokerFactory.
The invoker allocated for the method.
Attempts to allocate invoker for the specified method using the collection of InvokerFactory.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function TryCreateInvoker( _
   ByVal method As System.Reflection.MethodInfo, _
   ByVal instance As System.Object, _
   ByVal invokerFactories As System.Collections.Generic.ICollection(Of InvokerFactory), _
   ByRef invoker As Invoker _
) As System.Boolean
'Usage

Dim instance As DefaultMessageDispatcher
Dim method As System.Reflection.MethodInfo
Dim instance As System.Object
Dim invokerFactories As System.Collections.Generic.ICollection(Of InvokerFactory)
Dim invoker As Invoker
Dim value As System.Boolean

value = instance.TryCreateInvoker(method, instance, invokerFactories, invoker)
protected virtual System.bool TryCreateInvoker(
   System.Reflection.MethodInfo method,
   System.object instance,
   System.Collections.Generic.ICollection<InvokerFactory> invokerFactories,
   out Invoker invoker
)
protected function TryCreateInvoker(
    method: System.Reflection.MethodInfo;
    instance: System.TObject;
    invokerFactories: System.Collections.Generic.ICollection;
   Out  invoker: Invoker
): System.Boolean; virtual;
protected function TryCreateInvoker(
   method : System.Reflection.MethodInfo,
   instance : System.Object,
   invokerFactories : System.Collections.Generic.ICollection,
   invoker : Invoker
) : System.boolean;
protected: virtual System.bool TryCreateInvoker(
   System.Reflection.MethodInfo* method,
   System.Object* instance,
   System.Collections.Generic.ICollection<InvokerFactory*>* invokerFactories,
   [PARAMFLAG::Out] Invoker* invoker
)
protected:
virtual System.bool TryCreateInvoker(
   System.Reflection.MethodInfo^ method,
   System.Object^ instance,
   System.Collections.Generic.ICollection<InvokerFactory^>^ invokerFactories,
   [Out] Invoker^ invoker
)

Parameters

method
The method to allocate Invoker for.
instance
The instance of the object implementing the method.
invokerFactories
The collection of InvokerFactory.
invoker
The invoker allocated for the method.

Return Value

True if Invoker was allocated; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members


TryGetOperation Method (DefaultMessageDispatcher)

TryGetOperation Method (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : TryGetOperation Method
The message to be dispatched.
The channel through which the message was received.
The operation to which message is to be dispatched.
Tries to resolve the operation to which the message is to be dispatched.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function TryGetOperation( _
   ByVal message As System.Object, _
   ByVal channel As WebSocketChannel, _
   ByRef operation As MessageOperationDescription _
) As System.Boolean
'Usage

Dim instance As DefaultMessageDispatcher
Dim message As System.Object
Dim channel As WebSocketChannel
Dim operation As MessageOperationDescription
Dim value As System.Boolean

value = instance.TryGetOperation(message, channel, operation)
public override System.bool TryGetOperation(
   System.object message,
   WebSocketChannel channel,
   out MessageOperationDescription operation
)
public function TryGetOperation(
    message: System.TObject;
    channel: WebSocketChannel;
   Out  operation: MessageOperationDescription
): System.Boolean; override;
public override function TryGetOperation(
   message : System.Object,
   channel : WebSocketChannel,
   operation : MessageOperationDescription
) : System.boolean;
public: System.bool TryGetOperation(
   System.Object* message,
   WebSocketChannel* channel,
   [PARAMFLAG::Out] MessageOperationDescription* operation
) override
public:
System.bool TryGetOperation(
   System.Object^ message,
   WebSocketChannel^ channel,
   [Out] MessageOperationDescription^ operation
) override

Parameters

message
The message to be dispatched.
channel
The channel through which the message was received.
operation
The operation to which message is to be dispatched.

Return Value

True if operation was resolved; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members
Base Implementation in TryGetOperation


DefaultMessageDispatcher Class Properties

DefaultMessageDispatcher Class Properties

Noemax.WebSockets.Messaging Namespace : DefaultMessageDispatcher Class

For a list of all members of this type, see DefaultMessageDispatcher members.

Public Properties
 | Name | Description
Public Property | DefaultSerializer | Overridden. Gets and sets the IMessageSerializer used by the dispatcher.
Public Property | KnownTypes | Overridden. The list of the types known to dispatcher.
Public Property | Operations | Gets the list of operations being dispatched by the dispatcher. (Inherited from Noemax.WebSockets.Messaging.MessageDispatcher)
Top
See Also

Reference

DefaultMessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


DefaultSerializer Property (DefaultMessageDispatcher)

DefaultSerializer Property (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : DefaultSerializer Property
Gets and sets the IMessageSerializer used by the dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Property DefaultSerializer As IMessageSerializer
'Usage

Dim instance As DefaultMessageDispatcher
Dim value As IMessageSerializer

instance.DefaultSerializer = value

value = instance.DefaultSerializer
public override IMessageSerializer DefaultSerializer {get; set;}
public read-write property DefaultSerializer: IMessageSerializer; override;
public override function get,set DefaultSerializer : IMessageSerializer
public: __property IMessageSerializer* get_DefaultSerializer() override;
public: __property void set_DefaultSerializer(
   IMessageSerializer* value
) override;
public:
property IMessageSerializer^ DefaultSerializer {
   IMessageSerializer^ get() override;
   void set (    IMessageSerializer^ value) override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members
Base Implementation in DefaultSerializer


KnownTypes Property (DefaultMessageDispatcher)

KnownTypes Property (DefaultMessageDispatcher)

Noemax.WebSockets.Messaging Namespace > DefaultMessageDispatcher Class : KnownTypes Property
The list of the types known to dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As DefaultMessageDispatcher
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public override System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; override;
public override function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes() override;
public:
property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultMessageDispatcher Class
DefaultMessageDispatcher Members
Base Implementation in KnownTypes


EnvelopedMessage Class

EnvelopedMessage Class
Members

Noemax.WebSockets.Messaging Namespace : EnvelopedMessage Class
The base class for all messages sent by PowerWebSockets RPC.
Object Model
EnvelopedMessage Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataContractAttribute()>
Public MustInherit Class EnvelopedMessage
'Usage

Dim instance As EnvelopedMessage
[System.Runtime.Serialization.DataContract()]
public abstract class EnvelopedMessage
public class EnvelopedMessage abstract;
System.Runtime.Serialization.DataContractAttribute()
public abstract class EnvelopedMessage
[System.Runtime.Serialization.DataContract()]
public __gc abstract class EnvelopedMessage
[System.Runtime.Serialization.DataContract()]
public ref class EnvelopedMessage abstract
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.EnvelopedMessage
Noemax.WebSockets.Messaging.ConversationMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnvelopedMessage Members
Noemax.WebSockets.Messaging Namespace


EnvelopedMessage Class Members

EnvelopedMessage Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : EnvelopedMessage Class

The following tables list the members exposed by EnvelopedMessage.

Public Properties
 | Name | Description
Public Property | Attachment |
Public Property | Body | The body of the enveloped message.
Top
Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type.
Top
See Also

Reference

EnvelopedMessage Class
Noemax.WebSockets.Messaging Namespace


EnvelopedMessage Class Methods

EnvelopedMessage Class Methods

Noemax.WebSockets.Messaging Namespace : EnvelopedMessage Class

For a list of all members of this type, see EnvelopedMessage members.

Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type.
Top
See Also

Reference

EnvelopedMessage Class
Noemax.WebSockets.Messaging Namespace


GetBody<T> Method (EnvelopedMessage)

GetBody<T> Method (EnvelopedMessage)

Noemax.WebSockets.Messaging Namespace > EnvelopedMessage Class : GetBody<T> Method
The type to which to convert the body of the message.
Gets the body of the message and convert it to the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetBody(Of T)() As T
'Usage

Dim instance As EnvelopedMessage
Dim value As T

value = instance.GetBody(Of T)()
public virtual T GetBody<T>()
public function GetBody(): T; virtual;
public function GetBody() : T;
public: virtual T* GetBody<T>();
public:
virtual T^ GetBodygeneric<typename T>
();

Type Parameters

T
The type to which to convert the body of the message.

Return Value

The body of the message converted to the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnvelopedMessage Class
EnvelopedMessage Members


EnvelopedMessage Class Properties

EnvelopedMessage Class Properties

Noemax.WebSockets.Messaging Namespace : EnvelopedMessage Class

For a list of all members of this type, see EnvelopedMessage members.

Public Properties
 | Name | Description
Public Property | Attachment |
Public Property | Body | The body of the enveloped message.
Top
See Also

Reference

EnvelopedMessage Class
Noemax.WebSockets.Messaging Namespace


Attachment Property (EnvelopedMessage)

Attachment Property (EnvelopedMessage)

Noemax.WebSockets.Messaging Namespace > EnvelopedMessage Class : Attachment Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.IgnoreDataMemberAttribute()>
<JsonIgnoreAttribute()>
Public Overridable Property Attachment As System.IO.Stream
'Usage

Dim instance As EnvelopedMessage
Dim value As System.IO.Stream

instance.Attachment = value

value = instance.Attachment
[System.Runtime.Serialization.IgnoreDataMember()]
[JsonIgnore()]
public virtual System.IO.Stream Attachment {get; set;}
public read-write property Attachment: System.IO.Stream; virtual;
System.Runtime.Serialization.IgnoreDataMemberAttribute()
JsonIgnoreAttribute()
public function get,set Attachment : System.IO.Stream
[System.Runtime.Serialization.IgnoreDataMember()]
[JsonIgnore()]
public: __property virtual System.IO.Stream* get_Attachment();
public: __property virtual void set_Attachment(
   System.IO.Stream* value
);
[System.Runtime.Serialization.IgnoreDataMember()]
[JsonIgnore()]
public:
virtual property System.IO.Stream^ Attachment {
   System.IO.Stream^ get();
   void set (    System.IO.Stream^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnvelopedMessage Class
EnvelopedMessage Members


Body Property (EnvelopedMessage)

Body Property (EnvelopedMessage)

Noemax.WebSockets.Messaging Namespace > EnvelopedMessage Class : Body Property
The body of the enveloped message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property Body As System.Object
'Usage

Dim instance As EnvelopedMessage
Dim value As System.Object

value = instance.Body
public abstract System.object Body {get;}
public read-only property Body: System.TObject; abstract;
public __abstract function get Body : System.Object
public: __property abstract System.Object* get_Body();
public:
abstract property System.Object^ Body {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnvelopedMessage Class
EnvelopedMessage Members


FuncInvoker<TResult,TRequest> Class

FuncInvoker<TResult,TRequest> Class
Members

Noemax.WebSockets.Messaging Namespace : FuncInvoker<TResult,TRequest> Class
The type returned by the target method.
The type used by the target method as parameter.
The invoker providing request/response operations.
Object Model
FuncInvoker<TResult,TRequest> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class FuncInvoker
    (Of TResult,TRequest)
   Inherits RequestInvoker
'Usage

Dim instance As FuncInvoker(Of TResult,TRequest)
public abstract class FuncInvoker<TResult,TRequest> : RequestInvoker
public class FuncInvoker = class(RequestInvoker)abstract;
JScript does not support Generics.
public __gc abstract class FuncInvoker<TResult,TRequest> : public RequestInvoker
generic<typename TResult>
generic<typename TRequest>
public ref class FuncInvoker abstract : public RequestInvoker
Type Parameters
TResult
The type returned by the target method.
TRequest
The type used by the target method as parameter.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.FuncOperation1Invoker<TResult,T>
Noemax.WebSockets.Messaging.FuncOperationInvoker<TResult,T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Members
Noemax.WebSockets.Messaging Namespace


FuncInvoker<TResult,TRequest> Class Members

FuncInvoker<TResult,TRequest> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : FuncInvoker<TResult,TRequest> Class

The following tables list the members exposed by FuncInvoker<TResult,TRequest>.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets the list of the types accepted by Invoker as parameters for calling the target method.
Public Property | KnownTypes | Overridden. Gets a list of known types that must be registered with IMessageSerializer.
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncInvoker<TResult,TRequest> Class
Noemax.WebSockets.Messaging Namespace


FuncInvoker<TResult,TRequest> Class Methods

FuncInvoker<TResult,TRequest> Class Methods

Noemax.WebSockets.Messaging Namespace : FuncInvoker<TResult,TRequest> Class

For a list of all members of this type, see FuncInvoker<TResult,TRequest> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncInvoker<TResult,TRequest> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (FuncInvoker<TResult,TRequest>)

OnInvoke Method (FuncInvoker<TResult,TRequest>)

Noemax.WebSockets.Messaging Namespace > FuncInvoker<TResult,TRequest> Class : OnInvoke Method
Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Overload List
Overload | Description
OnInvoke(ConversationMessage,WebSocketChannel) | Invokes the target method and sends returned object of [TResult] type as response through the same channel.
OnInvoke(TRequest,WebSocketChannel) | Invokes the target method and returns object of [TResult] type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Class
FuncInvoker<TResult,TRequest> Members
Base Implementation in OnInvoke


OnInvoke(ConversationMessage,WebSocketChannel) Method

OnInvoke(ConversationMessage,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > FuncInvoker<TResult,TRequest> Class > OnInvoke Method : OnInvoke(ConversationMessage,WebSocketChannel) Method
The inbound message.
The channel through which message was received.
Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function OnInvoke( _
   ByVal requestMessage As ConversationMessage, _
   ByVal channel As WebSocketChannel _
) As ConversationMessage
'Usage

Dim instance As FuncInvoker(Of TResult,TRequest)
Dim requestMessage As ConversationMessage
Dim channel As WebSocketChannel
Dim value As ConversationMessage

value = instance.OnInvoke(requestMessage, channel)
protected override ConversationMessage OnInvoke(
   ConversationMessage requestMessage,
   WebSocketChannel channel
)
protected function OnInvoke(
    requestMessage: ConversationMessage;
    channel: WebSocketChannel
): ConversationMessage; override;
protected override function OnInvoke(
   requestMessage : ConversationMessage,
   channel : WebSocketChannel
) : ConversationMessage;
protected: ConversationMessage* OnInvoke(
   ConversationMessage* requestMessage,
   WebSocketChannel* channel
) override
protected:
ConversationMessage^ OnInvoke(
   ConversationMessage^ requestMessage,
   WebSocketChannel^ channel
) override

Parameters

requestMessage
The inbound message.
channel
The channel through which message was received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Class
FuncInvoker<TResult,TRequest> Members
Overload List
Base Implementation in OnInvoke


OnInvoke(TRequest,WebSocketChannel) Method

OnInvoke(TRequest,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > FuncInvoker<TResult,TRequest> Class > OnInvoke Method : OnInvoke(TRequest,WebSocketChannel) Method
The object of type of [T].
The channel through which message was received.
Invokes the target method and returns object of [TResult] type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function OnInvoke( _
   ByVal po As TRequest, _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As FuncInvoker(Of TResult,TRequest)
Dim po As TRequest
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(po, channel)
protected abstract TResult OnInvoke(
   TRequest po,
   WebSocketChannel channel
)
protected function OnInvoke(
    po: TRequest;
    channel: WebSocketChannel
): TResult; abstract;
protected __abstract function OnInvoke(
   po : TRequest,
   channel : WebSocketChannel
) : TResult;
protected: abstract TResult* OnInvoke(
   TRequest* po,
   WebSocketChannel* channel
)
protected:
abstract TResult^ OnInvoke(
   TRequest^ po,
   WebSocketChannel^ channel
)

Parameters

po
The object of type of [T].
channel
The channel through which message was received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Class
FuncInvoker<TResult,TRequest> Members
Overload List


FuncInvoker<TResult,TRequest> Class Properties

FuncInvoker<TResult,TRequest> Class Properties

Noemax.WebSockets.Messaging Namespace : FuncInvoker<TResult,TRequest> Class

For a list of all members of this type, see FuncInvoker<TResult,TRequest> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets the list of the types accepted by Invoker as parameters for calling the target method.
Public Property | KnownTypes | Overridden. Gets a list of known types that must be registered with IMessageSerializer.
Top
See Also

Reference

FuncInvoker<TResult,TRequest> Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (FuncInvoker<TResult,TRequest>)

InputTypes Property (FuncInvoker<TResult,TRequest>)

Noemax.WebSockets.Messaging Namespace > FuncInvoker<TResult,TRequest> Class : InputTypes Property
Gets the list of the types accepted by Invoker as parameters for calling the target method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As FuncInvoker(Of TResult,TRequest)
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}

Property Value

Returns type of [T].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Class
FuncInvoker<TResult,TRequest> Members
Base Implementation in InputTypes


KnownTypes Property (FuncInvoker<TResult,TRequest>)

KnownTypes Property (FuncInvoker<TResult,TRequest>)

Noemax.WebSockets.Messaging Namespace > FuncInvoker<TResult,TRequest> Class : KnownTypes Property
Gets a list of known types that must be registered with IMessageSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As FuncInvoker(Of TResult,TRequest)
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public override System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; override;
public override function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes() override;
public:
property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get() override;
}

Property Value

Returns the list containing the type of [T] and the type of [TResult].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvoker<TResult,TRequest> Class
FuncInvoker<TResult,TRequest> Members
Base Implementation in KnownTypes


FuncInvokerFactory Class

FuncInvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : FuncInvokerFactory Class
The factory producing FuncInvoker<TResult,TRequest> instances.
Object Model
FuncInvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Class FuncInvokerFactory
   Inherits InvokerFactory
'Usage

Dim instance As FuncInvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public class FuncInvokerFactory : InvokerFactory
public class FuncInvokerFactory = class(InvokerFactory)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public class FuncInvokerFactory extends InvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc class FuncInvokerFactory : public InvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public ref class FuncInvokerFactory : public InvokerFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.FuncInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvokerFactory Members
Noemax.WebSockets.Messaging Namespace


FuncInvokerFactory Class Members

FuncInvokerFactory Class Members
Methods

Noemax.WebSockets.Messaging Namespace : FuncInvokerFactory Class

The following tables list the members exposed by FuncInvokerFactory.

Public Constructors
 | Name | Description
Public Constructor | FuncInvokerFactory Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Overridden. Creates Invoker for the specified method.
Top
See Also

Reference

FuncInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


FuncInvokerFactory Constructor

FuncInvokerFactory Constructor

Noemax.WebSockets.Messaging Namespace > FuncInvokerFactory Class : FuncInvokerFactory Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New FuncInvokerFactory()
public FuncInvokerFactory()
public FuncInvokerFactory();
public function FuncInvokerFactory();
public: FuncInvokerFactory();
public:
FuncInvokerFactory();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvokerFactory Class
FuncInvokerFactory Members


FuncInvokerFactory Class Methods

FuncInvokerFactory Class Methods

Noemax.WebSockets.Messaging Namespace : FuncInvokerFactory Class

For a list of all members of this type, see FuncInvokerFactory members.

Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Overridden. Creates Invoker for the specified method.
Top
See Also

Reference

FuncInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


CanCreateInvoker Method (FuncInvokerFactory)

CanCreateInvoker Method (FuncInvokerFactory)

Noemax.WebSockets.Messaging Namespace > FuncInvokerFactory Class : CanCreateInvoker Method
The to check for compatibility with Invoker factory.
Determines whether the factory can create an Invoker for specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanCreateInvoker( _
   ByVal methodInfo As System.Reflection.MethodInfo _
) As System.Boolean
'Usage

Dim instance As FuncInvokerFactory
Dim methodInfo As System.Reflection.MethodInfo
Dim value As System.Boolean

value = instance.CanCreateInvoker(methodInfo)
public override System.bool CanCreateInvoker(
   System.Reflection.MethodInfo methodInfo
)
public function CanCreateInvoker(
    methodInfo: System.Reflection.MethodInfo
): System.Boolean; override;
public override function CanCreateInvoker(
   methodInfo : System.Reflection.MethodInfo
) : System.boolean;
public: System.bool CanCreateInvoker(
   System.Reflection.MethodInfo* methodInfo
) override
public:
System.bool CanCreateInvoker(
   System.Reflection.MethodInfo^ methodInfo
) override

Parameters

methodInfo
The to check for compatibility with Invoker factory.

Return Value

True if factory can create invoker for the method; otherwise False.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvokerFactory Class
FuncInvokerFactory Members
Base Implementation in CanCreateInvoker


CreateInvoker Method (FuncInvokerFactory)

CreateInvoker Method (FuncInvokerFactory)

Noemax.WebSockets.Messaging Namespace > FuncInvokerFactory Class : CreateInvoker Method
The description of the method.
The instance of the class providing the method.
Creates Invoker for the specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CreateInvoker( _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim instance As FuncInvokerFactory
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = instance.CreateInvoker(info, instance)
public override Invoker CreateInvoker(
   System.Reflection.MethodInfo info,
   System.object instance
)
public function CreateInvoker(
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; override;
public override function CreateInvoker(
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
public: Invoker* CreateInvoker(
   System.Reflection.MethodInfo* info,
   System.Object* instance
) override
public:
Invoker^ CreateInvoker(
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
) override

Parameters

info
The description of the method.
instance
The instance of the class providing the method.

Return Value

The Invoker that dispatches the messages to the specified method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvokerFactory Class
FuncInvokerFactory Members
Base Implementation in CreateInvoker


FuncOperation1Invoker<TResult,T> Class

FuncOperation1Invoker<TResult,T> Class
Members

Noemax.WebSockets.Messaging Namespace : FuncOperation1Invoker<TResult,T> Class
Object Model
FuncOperation1Invoker<TResult,T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class FuncOperation1Invoker
    (Of TResult,T)
   Inherits FuncInvoker(Of TResult,T)
'Usage

Dim instance As FuncOperation1Invoker(Of TResult,T)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class FuncOperation1Invoker<TResult,T> : FuncInvoker<TResult,T>
public class FuncOperation1Invoker = class(FuncInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class FuncOperation1Invoker<TResult,T> : public FuncInvoker<TResult,T>
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename TResult>
generic<typename T>
public ref class FuncOperation1Invoker sealed : public FuncInvoker<TResult,T>
Type Parameters
TResult
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.FuncOperation1Invoker<TResult,T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation1Invoker<TResult,T> Members
Noemax.WebSockets.Messaging Namespace


FuncOperation1Invoker<TResult,T> Class Members

FuncOperation1Invoker<TResult,T> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : FuncOperation1Invoker<TResult,T> Class

The following tables list the members exposed by FuncOperation1Invoker<TResult,T>.

Public Constructors
 | Name | Description
Public Constructor | FuncOperation1Invoker<TResult,T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncOperation1Invoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


FuncOperation1Invoker<TResult,T> Constructor

FuncOperation1Invoker<TResult,T> Constructor

Noemax.WebSockets.Messaging Namespace > FuncOperation1Invoker<TResult,T> Class : FuncOperation1Invoker<TResult,T> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As Noemax.WebSockets.Messaging.FuncOperation1(Of TResult,T) _
)
'Usage

Dim func As Noemax.WebSockets.Messaging.FuncOperation1(Of TResult,T)

Dim instance As New FuncOperation1Invoker(Of TResult,T)(func)
public FuncOperation1Invoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation1<TResult,T> func
)
public FuncOperation1Invoker<TResult,T>(
    func: Noemax.WebSockets.Messaging.FuncOperation1
);
public function FuncOperation1Invoker<TResult,T>(
   func : Noemax.WebSockets.Messaging.FuncOperation1
);
public: FuncOperation1Invoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation1<TResult*,T*>* func
)
public:
FuncOperation1Invoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation1<TResult^,T^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation1Invoker<TResult,T> Class
FuncOperation1Invoker<TResult,T> Members


FuncOperation1Invoker<TResult,T> Class Methods

FuncOperation1Invoker<TResult,T> Class Methods

Noemax.WebSockets.Messaging Namespace : FuncOperation1Invoker<TResult,T> Class

For a list of all members of this type, see FuncOperation1Invoker<TResult,T> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncOperation1Invoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (FuncOperation1Invoker<TResult,T>)

OnInvoke Method (FuncOperation1Invoker<TResult,T>)

Noemax.WebSockets.Messaging Namespace > FuncOperation1Invoker<TResult,T> Class : OnInvoke Method
Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Overload List
Overload | Description
OnInvoke(T,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | Invokes the target method and sends returned object of [TResult] type as response through the same channel. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation1Invoker<TResult,T> Class
FuncOperation1Invoker<TResult,T> Members
Base Implementation in OnInvoke


OnInvoke(T,WebSocketChannel) Method

OnInvoke(T,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > FuncOperation1Invoker<TResult,T> Class > OnInvoke Method : OnInvoke(T,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Function OnInvoke( _
   ByVal po As T, _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As FuncOperation1Invoker(Of TResult,T)
Dim po As T
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(po, channel)
protected override TResult OnInvoke(
   T po,
   WebSocketChannel channel
)
protected function OnInvoke(
    po: T;
    channel: WebSocketChannel
): TResult; override;
protected override function OnInvoke(
   po : T,
   channel : WebSocketChannel
) : TResult;
protected: TResult* OnInvoke(
   T* po,
   WebSocketChannel* channel
) override
protected:
TResult^ OnInvoke(
   T^ po,
   WebSocketChannel^ channel
) override

Parameters

po
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation1Invoker<TResult,T> Class
FuncOperation1Invoker<TResult,T> Members
Overload List
Base Implementation in OnInvoke(TRequest,WebSocketChannel)


FuncOperationInvoker<TResult,T> Class

FuncOperationInvoker<TResult,T> Class
Members

Noemax.WebSockets.Messaging Namespace : FuncOperationInvoker<TResult,T> Class
Object Model
FuncOperationInvoker<TResult,T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class FuncOperationInvoker
    (Of TResult,T)
   Inherits FuncInvoker(Of TResult,T)
'Usage

Dim instance As FuncOperationInvoker(Of TResult,T)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class FuncOperationInvoker<TResult,T> : FuncInvoker<TResult,T>
public class FuncOperationInvoker = class(FuncInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class FuncOperationInvoker<TResult,T> : public FuncInvoker<TResult,T>
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename TResult>
generic<typename T>
public ref class FuncOperationInvoker sealed : public FuncInvoker<TResult,T>
Type Parameters
TResult
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.FuncOperationInvoker<TResult,T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperationInvoker<TResult,T> Members
Noemax.WebSockets.Messaging Namespace


FuncOperationInvoker<TResult,T> Class Members

FuncOperationInvoker<TResult,T> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : FuncOperationInvoker<TResult,T> Class

The following tables list the members exposed by FuncOperationInvoker<TResult,T>.

Public Constructors
 | Name | Description
Public Constructor | FuncOperationInvoker<TResult,T> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncOperationInvoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


FuncOperationInvoker<TResult,T> Constructor

FuncOperationInvoker<TResult,T> Constructor

Noemax.WebSockets.Messaging Namespace > FuncOperationInvoker<TResult,T> Class : FuncOperationInvoker<TResult,T> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As Noemax.WebSockets.Messaging.FuncOperation(Of TResult,T) _
)
'Usage

Dim func As Noemax.WebSockets.Messaging.FuncOperation(Of TResult,T)

Dim instance As New FuncOperationInvoker(Of TResult,T)(func)
public FuncOperationInvoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation<TResult,T> func
)
public FuncOperationInvoker<TResult,T>(
    func: Noemax.WebSockets.Messaging.FuncOperation
);
public function FuncOperationInvoker<TResult,T>(
   func : Noemax.WebSockets.Messaging.FuncOperation
);
public: FuncOperationInvoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation<TResult*,T*>* func
)
public:
FuncOperationInvoker<TResult,T>(
   Noemax.WebSockets.Messaging.FuncOperation<TResult^,T^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperationInvoker<TResult,T> Class
FuncOperationInvoker<TResult,T> Members


FuncOperationInvoker<TResult,T> Class Methods

FuncOperationInvoker<TResult,T> Class Methods

Noemax.WebSockets.Messaging Namespace : FuncOperationInvoker<TResult,T> Class

For a list of all members of this type, see FuncOperationInvoker<TResult,T> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden. Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Top
See Also

Reference

FuncOperationInvoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (FuncOperationInvoker<TResult,T>)

OnInvoke Method (FuncOperationInvoker<TResult,T>)

Noemax.WebSockets.Messaging Namespace > FuncOperationInvoker<TResult,T> Class : OnInvoke Method
Invokes the target method and sends returned object of [TResult] type as response through the same channel.
Overload List
Overload | Description
OnInvoke(T,WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | Invokes the target method and sends returned object of [TResult] type as response through the same channel. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperationInvoker<TResult,T> Class
FuncOperationInvoker<TResult,T> Members
Base Implementation in OnInvoke


OnInvoke(T,WebSocketChannel) Method

OnInvoke(T,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > FuncOperationInvoker<TResult,T> Class > OnInvoke Method : OnInvoke(T,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Function OnInvoke( _
   ByVal po As T, _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As FuncOperationInvoker(Of TResult,T)
Dim po As T
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(po, channel)
protected override TResult OnInvoke(
   T po,
   WebSocketChannel channel
)
protected function OnInvoke(
    po: T;
    channel: WebSocketChannel
): TResult; override;
protected override function OnInvoke(
   po : T,
   channel : WebSocketChannel
) : TResult;
protected: TResult* OnInvoke(
   T* po,
   WebSocketChannel* channel
) override
protected:
TResult^ OnInvoke(
   T^ po,
   WebSocketChannel^ channel
) override

Parameters

po
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperationInvoker<TResult,T> Class
FuncOperationInvoker<TResult,T> Members
Overload List
Base Implementation in OnInvoke(TRequest,WebSocketChannel)


Invoker Class

Invoker Class
Members

Noemax.WebSockets.Messaging Namespace : Invoker Class
Abstract based class for invoker that process inbound message by invoking the method of the service and passing deserialized message as parameter.
Object Model
Invoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class Invoker
'Usage

Dim instance As Invoker
public abstract class Invoker
public class Invoker abstract;
public abstract class Invoker
public __gc abstract class Invoker
public ref class Invoker abstract
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Invoker Members
Noemax.WebSockets.Messaging Namespace


Invoker Class Members

Invoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : Invoker Class

The following tables list the members exposed by Invoker.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer.
Top
Public Methods
 | Name | Description
Public Method | Invoke | Invoke the method using the specified message.
Top
See Also

Reference

Invoker Class
Noemax.WebSockets.Messaging Namespace


Invoker Class Methods

Invoker Class Methods

Noemax.WebSockets.Messaging Namespace : Invoker Class

For a list of all members of this type, see Invoker members.

Public Methods
 | Name | Description
Public Method | Invoke | Invoke the method using the specified message.
Top
See Also

Reference

Invoker Class
Noemax.WebSockets.Messaging Namespace


Invoke Method (Invoker)

Invoke Method (Invoker)

Noemax.WebSockets.Messaging Namespace > Invoker Class : Invoke Method
The message that is dispatched to target method.
The channel through which the message was received, optionally provided as the second parameter.
The serializer used to deserialize the message.
Invoke the method using the specified message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub Invoke( _
   ByVal message As EnvelopedMessage, _
   ByVal channel As WebSocketChannel, _
   ByVal serializer As IMessageSerializer _
)
'Usage

Dim instance As Invoker
Dim message As EnvelopedMessage
Dim channel As WebSocketChannel
Dim serializer As IMessageSerializer

instance.Invoke(message, channel, serializer)
public abstract void Invoke(
   EnvelopedMessage message,
   WebSocketChannel channel,
   IMessageSerializer serializer
)
public procedure Invoke(
    message: EnvelopedMessage;
    channel: WebSocketChannel;
    serializer: IMessageSerializer
); abstract;
public __abstract function Invoke(
   message : EnvelopedMessage,
   channel : WebSocketChannel,
   serializer : IMessageSerializer
);
public: abstract void Invoke(
   EnvelopedMessage* message,
   WebSocketChannel* channel,
   IMessageSerializer* serializer
)
public:
abstract void Invoke(
   EnvelopedMessage^ message,
   WebSocketChannel^ channel,
   IMessageSerializer^ serializer
)

Parameters

message
The message that is dispatched to target method.
channel
The channel through which the message was received, optionally provided as the second parameter.
serializer
The serializer used to deserialize the message.
Remarks

The IMessageSerializer provided as serializer parameter, is used to serialize response when necessary. This overload of Invoke method takes EnvelopedMessage as a parameter, so that additional metadata provided by the message can be accessed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Invoker Class
Invoker Members


Invoker Class Properties

Invoker Class Properties

Noemax.WebSockets.Messaging Namespace : Invoker Class

For a list of all members of this type, see Invoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer.
Top
See Also

Reference

Invoker Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (Invoker)

InputTypes Property (Invoker)

Noemax.WebSockets.Messaging Namespace > Invoker Class : InputTypes Property
Gets the list of the types accepted by Invoker as parameters for calling the target method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As Invoker
Dim value() As System.Type

value = instance.InputTypes
public abstract System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; abstract;
public __abstract function get InputTypes : System.Type[]
public: __property abstract System.Type*[]* get_InputTypes();
public:
abstract property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Invoker Class
Invoker Members


KnownTypes Property (Invoker)

KnownTypes Property (Invoker)

Noemax.WebSockets.Messaging Namespace > Invoker Class : KnownTypes Property
Gets a list of known types that must be registered with IMessageSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As Invoker
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public virtual System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; virtual;
public function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property virtual System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes();
public:
virtual property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get();
}
Remarks
This list includes types that should be known to deserializer in order to successfully deserialize inbound message. Usually this includes all InputTypes plus extra types that can be encountered within a message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Invoker Class
Invoker Members


InvokerFactory Class

InvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : InvokerFactory Class
The factory producing Invoker instances.
Object Model
InvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class InvokerFactory
'Usage

Dim instance As InvokerFactory
public abstract class InvokerFactory
public class InvokerFactory abstract;
public abstract class InvokerFactory
public __gc abstract class InvokerFactory
public ref class InvokerFactory abstract
Remarks

The factory is used in combination with MessageDispatcher to create runtime model for dispatching inbound messages to the methods exposed by the service.

CanCreateInvoker determines if the methods have compatible signatures and can be called by invoker produced by the factory.

The Invoker instances produced by the factory can be either predefine generic classes that take suitable number of parameters similar to Action[T,T1,...] delegate or dynamically generated during runtime. Invoker produced by the factory is responsible to perform a call to the target method using the data deserialized from inbound message. It can perform any parameter transformation required and also process result produced by the method.

Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.ActionInvokerFactory
Noemax.WebSockets.Messaging.FuncInvokerFactory
Noemax.WebSockets.Messaging.VoidInputInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Members
Noemax.WebSockets.Messaging Namespace


InvokerFactory Class Members

InvokerFactory Class Members
Methods

Noemax.WebSockets.Messaging Namespace : InvokerFactory Class

The following tables list the members exposed by InvokerFactory.

Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Creates Invoker for the specified method.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | CreateActionInvoker |
static (Shared in Visual Basic) | CreateFuncInvoker |
static (Shared in Visual Basic) | CreateVoidInputInvoker |
Top
See Also

Reference

InvokerFactory Class
Noemax.WebSockets.Messaging Namespace


InvokerFactory Class Methods

InvokerFactory Class Methods

Noemax.WebSockets.Messaging Namespace : InvokerFactory Class

For a list of all members of this type, see InvokerFactory members.

Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Determines whether the factory can create an Invoker for specified method.
Public Method | CreateInvoker | Creates Invoker for the specified method.
Top
Protected Methods
 | Name | Description
static (Shared in Visual Basic) | CreateActionInvoker |
static (Shared in Visual Basic) | CreateFuncInvoker |
static (Shared in Visual Basic) | CreateVoidInputInvoker |
Top
See Also

Reference

InvokerFactory Class
Noemax.WebSockets.Messaging Namespace


CanCreateInvoker Method (InvokerFactory)

CanCreateInvoker Method (InvokerFactory)

Noemax.WebSockets.Messaging Namespace > InvokerFactory Class : CanCreateInvoker Method
The to check for compatibility with Invoker factory.
Determines whether the factory can create an Invoker for specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function CanCreateInvoker( _
   ByVal methodInfo As System.Reflection.MethodInfo _
) As System.Boolean
'Usage

Dim instance As InvokerFactory
Dim methodInfo As System.Reflection.MethodInfo
Dim value As System.Boolean

value = instance.CanCreateInvoker(methodInfo)
public abstract System.bool CanCreateInvoker(
   System.Reflection.MethodInfo methodInfo
)
public function CanCreateInvoker(
    methodInfo: System.Reflection.MethodInfo
): System.Boolean; abstract;
public __abstract function CanCreateInvoker(
   methodInfo : System.Reflection.MethodInfo
) : System.boolean;
public: abstract System.bool CanCreateInvoker(
   System.Reflection.MethodInfo* methodInfo
)
public:
abstract System.bool CanCreateInvoker(
   System.Reflection.MethodInfo^ methodInfo
)

Parameters

methodInfo
The to check for compatibility with Invoker factory.

Return Value

True if factory can create invoker for the method; otherwise False.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Class
InvokerFactory Members


CreateActionInvoker Method (InvokerFactory)

CreateActionInvoker Method (InvokerFactory)

Noemax.WebSockets.Messaging Namespace > InvokerFactory Class : CreateActionInvoker Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Shared Function CreateActionInvoker( _
   ByVal genericFuncType As System.Type, _
   ByVal genericInvokerType As System.Type, _
   ByVal genericParameterType As System.Type, _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim genericFuncType As System.Type
Dim genericInvokerType As System.Type
Dim genericParameterType As System.Type
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = InvokerFactory.CreateActionInvoker(genericFuncType, genericInvokerType, genericParameterType, info, instance)
protected static Invoker CreateActionInvoker(
   System.Type genericFuncType,
   System.Type genericInvokerType,
   System.Type genericParameterType,
   System.Reflection.MethodInfo info,
   System.object instance
)
protected function CreateActionInvoker(
    genericFuncType: System.Type;
    genericInvokerType: System.Type;
    genericParameterType: System.Type;
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; static;
protected static function CreateActionInvoker(
   genericFuncType : System.Type,
   genericInvokerType : System.Type,
   genericParameterType : System.Type,
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
protected: static Invoker* CreateActionInvoker(
   System.Type* genericFuncType,
   System.Type* genericInvokerType,
   System.Type* genericParameterType,
   System.Reflection.MethodInfo* info,
   System.Object* instance
)
protected:
static Invoker^ CreateActionInvoker(
   System.Type^ genericFuncType,
   System.Type^ genericInvokerType,
   System.Type^ genericParameterType,
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
)

Parameters

genericFuncType
genericInvokerType
genericParameterType
info
instance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Class
InvokerFactory Members


CreateFuncInvoker Method (InvokerFactory)

CreateFuncInvoker Method (InvokerFactory)

Noemax.WebSockets.Messaging Namespace > InvokerFactory Class : CreateFuncInvoker Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Shared Function CreateFuncInvoker( _
   ByVal genericFuncType As System.Type, _
   ByVal genericInvokerType As System.Type, _
   ByVal genericParameterType As System.Type, _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim genericFuncType As System.Type
Dim genericInvokerType As System.Type
Dim genericParameterType As System.Type
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = InvokerFactory.CreateFuncInvoker(genericFuncType, genericInvokerType, genericParameterType, info, instance)
protected static Invoker CreateFuncInvoker(
   System.Type genericFuncType,
   System.Type genericInvokerType,
   System.Type genericParameterType,
   System.Reflection.MethodInfo info,
   System.object instance
)
protected function CreateFuncInvoker(
    genericFuncType: System.Type;
    genericInvokerType: System.Type;
    genericParameterType: System.Type;
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; static;
protected static function CreateFuncInvoker(
   genericFuncType : System.Type,
   genericInvokerType : System.Type,
   genericParameterType : System.Type,
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
protected: static Invoker* CreateFuncInvoker(
   System.Type* genericFuncType,
   System.Type* genericInvokerType,
   System.Type* genericParameterType,
   System.Reflection.MethodInfo* info,
   System.Object* instance
)
protected:
static Invoker^ CreateFuncInvoker(
   System.Type^ genericFuncType,
   System.Type^ genericInvokerType,
   System.Type^ genericParameterType,
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
)

Parameters

genericFuncType
genericInvokerType
genericParameterType
info
instance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Class
InvokerFactory Members


CreateInvoker Method (InvokerFactory)

CreateInvoker Method (InvokerFactory)

Noemax.WebSockets.Messaging Namespace > InvokerFactory Class : CreateInvoker Method
The description of the method.
The instance of the class providing the method.
Creates Invoker for the specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function CreateInvoker( _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim instance As InvokerFactory
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = instance.CreateInvoker(info, instance)
public abstract Invoker CreateInvoker(
   System.Reflection.MethodInfo info,
   System.object instance
)
public function CreateInvoker(
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; abstract;
public __abstract function CreateInvoker(
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
public: abstract Invoker* CreateInvoker(
   System.Reflection.MethodInfo* info,
   System.Object* instance
)
public:
abstract Invoker^ CreateInvoker(
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
)

Parameters

info
The description of the method.
instance
The instance of the class providing the method.

Return Value

The Invoker that dispatches the messages to the specified method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Class
InvokerFactory Members


CreateVoidInputInvoker Method (InvokerFactory)

CreateVoidInputInvoker Method (InvokerFactory)

Noemax.WebSockets.Messaging Namespace > InvokerFactory Class : CreateVoidInputInvoker Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Shared Function CreateVoidInputInvoker( _
   ByVal genericFuncType As System.Type, _
   ByVal genericInvokerType As System.Type, _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim genericFuncType As System.Type
Dim genericInvokerType As System.Type
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = InvokerFactory.CreateVoidInputInvoker(genericFuncType, genericInvokerType, info, instance)
protected static Invoker CreateVoidInputInvoker(
   System.Type genericFuncType,
   System.Type genericInvokerType,
   System.Reflection.MethodInfo info,
   System.object instance
)
protected function CreateVoidInputInvoker(
    genericFuncType: System.Type;
    genericInvokerType: System.Type;
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; static;
protected static function CreateVoidInputInvoker(
   genericFuncType : System.Type,
   genericInvokerType : System.Type,
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
protected: static Invoker* CreateVoidInputInvoker(
   System.Type* genericFuncType,
   System.Type* genericInvokerType,
   System.Reflection.MethodInfo* info,
   System.Object* instance
)
protected:
static Invoker^ CreateVoidInputInvoker(
   System.Type^ genericFuncType,
   System.Type^ genericInvokerType,
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
)

Parameters

genericFuncType
genericInvokerType
info
instance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InvokerFactory Class
InvokerFactory Members


JsonClientProxyProvider Class

JsonClientProxyProvider Class
Members

Noemax.WebSockets.Messaging Namespace : JsonClientProxyProvider Class
Provides WebSocketMessagingService with a JavaScript client proxy file based on defined messanging operations.
Object Model
JsonClientProxyProvider Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonClientProxyProvider
'Usage

Dim instance As JsonClientProxyProvider
public class JsonClientProxyProvider
public class JsonClientProxyProvider
public class JsonClientProxyProvider
public __gc class JsonClientProxyProvider
public ref class JsonClientProxyProvider
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.JsonClientProxyProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Members
Noemax.WebSockets.Messaging Namespace


JsonClientProxyProvider Class Members

JsonClientProxyProvider Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : JsonClientProxyProvider Class

The following tables list the members exposed by JsonClientProxyProvider.

Public Constructors
 | Name | Description
Public Constructor | JsonClientProxyProvider Constructor | Create a new instance of JsonClientProxyProvider.
Top
Public Properties
 | Name | Description
Public Property | ClientProxyFileName | Gets and sets the name of the client proxy file to be generated by the Noemax.Newtonsoft.Json.JsonSerializer.
Public Property | JavaScript | Gets and sets JavaScript generated by the JsonClientProxyProvider.
Top
Public Methods
 | Name | Description
Public Method | Publish | Publishes the Non-WebSocket HTTP handler that provides the JavaScript client proxy on the associated service endpoint.
Public Method | Unpublish | Unpublished the Non-WebSocket HTTP handler.
Top
See Also

Reference

JsonClientProxyProvider Class
Noemax.WebSockets.Messaging Namespace


JsonClientProxyProvider Constructor

JsonClientProxyProvider Constructor

Noemax.WebSockets.Messaging Namespace > JsonClientProxyProvider Class : JsonClientProxyProvider Constructor
Create a new instance of JsonClientProxyProvider.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal service As WebSocketMessagingService _
)
'Usage

Dim service As WebSocketMessagingService

Dim instance As New JsonClientProxyProvider(service)
public JsonClientProxyProvider(
   WebSocketMessagingService service
)
public JsonClientProxyProvider(
    service: WebSocketMessagingService
);
public function JsonClientProxyProvider(
   service : WebSocketMessagingService
);
public: JsonClientProxyProvider(
   WebSocketMessagingService* service
)
public:
JsonClientProxyProvider(
   WebSocketMessagingService^ service
)

Parameters

service
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Class
JsonClientProxyProvider Members


JsonClientProxyProvider Class Methods

JsonClientProxyProvider Class Methods

Noemax.WebSockets.Messaging Namespace : JsonClientProxyProvider Class

For a list of all members of this type, see JsonClientProxyProvider members.

Public Methods
 | Name | Description
Public Method | Publish | Publishes the Non-WebSocket HTTP handler that provides the JavaScript client proxy on the associated service endpoint.
Public Method | Unpublish | Unpublished the Non-WebSocket HTTP handler.
Top
See Also

Reference

JsonClientProxyProvider Class
Noemax.WebSockets.Messaging Namespace


Publish Method (JsonClientProxyProvider)

Publish Method (JsonClientProxyProvider)

Noemax.WebSockets.Messaging Namespace > JsonClientProxyProvider Class : Publish Method
Publishes the Non-WebSocket HTTP handler that provides the JavaScript client proxy on the associated service endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Publish()
'Usage

Dim instance As JsonClientProxyProvider

instance.Publish()
public void Publish()
public procedure Publish();
public function Publish();
public: void Publish();
public:
void Publish();
Remarks
Once handler is published in will start providing the JavaScript file with name specified by the ClientProxyFileName property on the associated service endpoints. This file can be reference from the HTTP page e.g. <script src="http://hostname:9998/echo/PowerWSM.js">.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Class
JsonClientProxyProvider Members


Unpublish Method (JsonClientProxyProvider)

Unpublish Method (JsonClientProxyProvider)

Noemax.WebSockets.Messaging Namespace > JsonClientProxyProvider Class : Unpublish Method
Unpublished the Non-WebSocket HTTP handler.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub Unpublish()
'Usage

Dim instance As JsonClientProxyProvider

instance.Unpublish()
public void Unpublish()
public procedure Unpublish();
public function Unpublish();
public: void Unpublish();
public:
void Unpublish();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Class
JsonClientProxyProvider Members


JsonClientProxyProvider Class Properties

JsonClientProxyProvider Class Properties

Noemax.WebSockets.Messaging Namespace : JsonClientProxyProvider Class

For a list of all members of this type, see JsonClientProxyProvider members.

Public Properties
 | Name | Description
Public Property | ClientProxyFileName | Gets and sets the name of the client proxy file to be generated by the Noemax.Newtonsoft.Json.JsonSerializer.
Public Property | JavaScript | Gets and sets JavaScript generated by the JsonClientProxyProvider.
Top
See Also

Reference

JsonClientProxyProvider Class
Noemax.WebSockets.Messaging Namespace


ClientProxyFileName Property (JsonClientProxyProvider)

ClientProxyFileName Property (JsonClientProxyProvider)

Noemax.WebSockets.Messaging Namespace > JsonClientProxyProvider Class : ClientProxyFileName Property
Gets and sets the name of the client proxy file to be generated by the Noemax.Newtonsoft.Json.JsonSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property ClientProxyFileName As System.String
'Usage

Dim instance As JsonClientProxyProvider
Dim value As System.String

instance.ClientProxyFileName = value

value = instance.ClientProxyFileName
public System.string ClientProxyFileName {get; set;}
public read-write property ClientProxyFileName: System.String;
public function get,set ClientProxyFileName : System.String
public: __property System.string* get_ClientProxyFileName();
public: __property void set_ClientProxyFileName(
   System.string* value
);
public:
property System.String^ ClientProxyFileName {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
Browser clients can request the JavaScript proxy file that simplify access to the messaging service by referencing the file from the HTML page e.g. <script src="http://hostname:9998/echo/PowerWSM.js">.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Class
JsonClientProxyProvider Members


JavaScript Property (JsonClientProxyProvider)

JavaScript Property (JsonClientProxyProvider)

Noemax.WebSockets.Messaging Namespace > JsonClientProxyProvider Class : JavaScript Property
Gets and sets JavaScript generated by the JsonClientProxyProvider.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property JavaScript As System.String
'Usage

Dim instance As JsonClientProxyProvider
Dim value As System.String

instance.JavaScript = value

value = instance.JavaScript
public System.string JavaScript {get; set;}
public read-write property JavaScript: System.String;
public function get,set JavaScript : System.String
public: __property System.string* get_JavaScript();
public: __property void set_JavaScript(
   System.string* value
);
public:
property System.String^ JavaScript {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
You can provide your own JavaScript client proxy code by assigned this property. If this property is not assigned then proxy is generated automatically when CreateHandler is called.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonClientProxyProvider Class
JsonClientProxyProvider Members


JsonMessageSerializer Class

JsonMessageSerializer Class
Members

Noemax.WebSockets.Messaging Namespace : JsonMessageSerializer Class
Provides serialization of data into WebSocket text messages using JSON format.
Object Model
JsonMessageSerializer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonMessageSerializer
   Inherits MessageSerializerBase
   Implements IMessageSerializer
'Usage

Dim instance As JsonMessageSerializer
public class JsonMessageSerializer : MessageSerializerBase, IMessageSerializer
public class JsonMessageSerializer = class(MessageSerializerBase, IMessageSerializer)
public class JsonMessageSerializer extends MessageSerializerBase implements IMessageSerializer
public __gc class JsonMessageSerializer : public MessageSerializerBase, IMessageSerializer
public ref class JsonMessageSerializer : public MessageSerializerBase, IMessageSerializer
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageSerializerBase
Noemax.WebSockets.Messaging.JsonMessageSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Members
Noemax.WebSockets.Messaging Namespace


JsonMessageSerializer Class Members

JsonMessageSerializer Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : JsonMessageSerializer Class

The following tables list the members exposed by JsonMessageSerializer.

Public Constructors
 | Name | Description
Public Constructor | JsonMessageSerializer Constructor | Initialize a new instance of JsonMessageSerializer.
Top
Public Properties
 | Name | Description
Public Property | IncludeTypeName | Gets and sets whether the serializer should include .NET type name when serializing objects. Set this property to True to support the object polymorphism.
Top
Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Overridden. Deserializes the data contained in the specified text message content.
Public Method | EnsureKnownTypes | Overridden. Registers a type with the serializer.
static (Shared in Visual Basic) | GenerateClientProxy | Generates a JavaScript client proxy for sending messages to the specified dispatcher.
Public Method | Serialize | Overloaded. Overridden. Serializes an object into the WebSocket message.
Top
See Also

Reference

JsonMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


JsonMessageSerializer Constructor

JsonMessageSerializer Constructor

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : JsonMessageSerializer Constructor
Initialize a new instance of JsonMessageSerializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New JsonMessageSerializer()
public JsonMessageSerializer()
public JsonMessageSerializer();
public function JsonMessageSerializer();
public: JsonMessageSerializer();
public:
JsonMessageSerializer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members


JsonMessageSerializer Class Methods

JsonMessageSerializer Class Methods

Noemax.WebSockets.Messaging Namespace : JsonMessageSerializer Class

For a list of all members of this type, see JsonMessageSerializer members.

Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Overridden. Deserializes the data contained in the specified text message content.
Public Method | EnsureKnownTypes | Overridden. Registers a type with the serializer.
static (Shared in Visual Basic) | GenerateClientProxy | Generates a JavaScript client proxy for sending messages to the specified dispatcher.
Public Method | Serialize | Overloaded. Overridden. Serializes an object into the WebSocket message.
Top
See Also

Reference

JsonMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


Deserialize Method (JsonMessageSerializer)

Deserialize Method (JsonMessageSerializer)

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : Deserialize Method
Deserializes the data contained in the specified text message content.
Overload List
Overload | Description
Deserialize(String,WebSocketChannel,MessageDispatcher) | Deserializes the data contained in the specified text message content.
Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) | Deserializes the data contained in the specified binary message content.
Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) | Deserializes the content of inbound message. (Inherited from Noemax.WebSockets.Messaging.MessageSerializerBase)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Base Implementation in Deserialize


Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class > Deserialize Method : Deserialize(String,WebSocketChannel,MessageDispatcher) Method
The text content to deserialize the data from.
The channel through which the message was received.
The dispatcher being used to dispatch the message.
Deserializes the data contained in the specified text message content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function Deserialize( _
   ByVal text As System.String, _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As JsonMessageSerializer
Dim text As System.String
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(text, channel, dispatcher)
protected override System.object Deserialize(
   System.string text,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
protected function Deserialize(
    text: System.String;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; override;
protected override function Deserialize(
   text : System.String,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
protected: System.Object* Deserialize(
   System.string* text,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
) override
protected:
System.Object^ Deserialize(
   System.String^ text,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
) override

Parameters

text
The text content to deserialize the data from.
channel
The channel through which the message was received.
dispatcher
The dispatcher being used to dispatch the message.

Return Value

The object deserialized from the message content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Overload List
Base Implementation in Deserialize(String,WebSocketChannel,MessageDispatcher)


Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class > Deserialize Method : Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method
The binary content to deserialize the date from.
The channel through which the message was received.
The dispatcher being used to dispatch the message.
Deserializes the data contained in the specified binary message content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function Deserialize( _
   ByVal binary As System.ArraySegment(Of Byte), _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As JsonMessageSerializer
Dim binary As System.ArraySegment(Of Byte)
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(binary, channel, dispatcher)
protected override System.object Deserialize(
   System.ArraySegment<byte> binary,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
protected function Deserialize(
    binary: System.ArraySegment;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; override;
protected override function Deserialize(
   binary : System.ArraySegment,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
protected: System.Object* Deserialize(
   System.ArraySegment<byte> binary,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
) override
protected:
System.Object^ Deserialize(
   System.ArraySegment<byte> binary,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
) override

Parameters

binary
The binary content to deserialize the date from.
channel
The channel through which the message was received.
dispatcher
The dispatcher being used to dispatch the message.

Return Value

The object deserialized from the message content.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Overload List
Base Implementation in Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher)


EnsureKnownTypes Method (JsonMessageSerializer)

EnsureKnownTypes Method (JsonMessageSerializer)

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : EnsureKnownTypes Method
The types to register with the serializer.
Registers a type with the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub EnsureKnownTypes( _
   ByVal ParamArray types() As System.Type _
)
'Usage

Dim instance As JsonMessageSerializer
Dim types() As System.Type

instance.EnsureKnownTypes(types)
public override void EnsureKnownTypes(
   params System.Type[] types
)
public procedure EnsureKnownTypes(
   params  types: System.Typearray of
); override;
public override function EnsureKnownTypes(
   types : System.Type[]
);
public: void EnsureKnownTypes(
   params System.Type*[]* types
) override
public:
void EnsureKnownTypes(
   ... System.array<Type^>^ types
) override

Parameters

types
The types to register with the serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Base Implementation in EnsureKnownTypes


GenerateClientProxy Method (JsonMessageSerializer)

GenerateClientProxy Method (JsonMessageSerializer)

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : GenerateClientProxy Method
The dispatcher for which proxy is too be generated.
Generates a JavaScript client proxy for sending messages to the specified dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Shared Function GenerateClientProxy( _
   ByVal dispatcher As MessageDispatcher _
) As System.String
'Usage

Dim dispatcher As MessageDispatcher
Dim value As System.String

value = JsonMessageSerializer.GenerateClientProxy(dispatcher)
public static System.string GenerateClientProxy(
   MessageDispatcher dispatcher
)
public function GenerateClientProxy(
    dispatcher: MessageDispatcher
): System.String; static;
public static function GenerateClientProxy(
   dispatcher : MessageDispatcher
) : System.String;
public: static System.string* GenerateClientProxy(
   MessageDispatcher* dispatcher
)
public:
static System.String^ GenerateClientProxy(
   MessageDispatcher^ dispatcher
)

Parameters

dispatcher
The dispatcher for which proxy is too be generated.

Return Value

The string containing the proxy code.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members


Serialize Method (JsonMessageSerializer)

Serialize Method (JsonMessageSerializer)

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : Serialize Method
Serializes an object into the WebSocket message.
Overload List
Overload | Description
Serialize(Object) | Serializes an object into the WebSocket message.
Serialize(Stream,Object) | Serializes the object into stream and returns the stream to write attachment to the message. (Inherited from Noemax.WebSockets.Messaging.MessageSerializerBase)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Base Implementation in Serialize


Serialize(Object) Method

Serialize(Object) Method

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class > Serialize Method : Serialize(Object) Method
The object to serialize into the message.
Serializes an object into the WebSocket message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Serialize( _
   ByVal obj As System.Object _
) As WebSocketOutboundMessage
'Usage

Dim instance As JsonMessageSerializer
Dim obj As System.Object
Dim value As WebSocketOutboundMessage

value = instance.Serialize(obj)
public override WebSocketOutboundMessage Serialize(
   System.object obj
)
public function Serialize(
    obj: System.TObject
): WebSocketOutboundMessage; override;
public override function Serialize(
   obj : System.Object
) : WebSocketOutboundMessage;
public: WebSocketOutboundMessage Serialize(
   System.Object* obj
) override
public:
WebSocketOutboundMessage Serialize(
   System.Object^ obj
) override

Parameters

obj
The object to serialize into the message.

Return Value

The instance of WebSocketOutboundMessage containing a serialized object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members
Overload List
Base Implementation in Serialize(Object)


JsonMessageSerializer Class Properties

JsonMessageSerializer Class Properties

Noemax.WebSockets.Messaging Namespace : JsonMessageSerializer Class

For a list of all members of this type, see JsonMessageSerializer members.

Public Properties
 | Name | Description
Public Property | IncludeTypeName | Gets and sets whether the serializer should include .NET type name when serializing objects. Set this property to True to support the object polymorphism.
Top
See Also

Reference

JsonMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


IncludeTypeName Property (JsonMessageSerializer)

IncludeTypeName Property (JsonMessageSerializer)

Noemax.WebSockets.Messaging Namespace > JsonMessageSerializer Class : IncludeTypeName Property
Gets and sets whether the serializer should include .NET type name when serializing objects. Set this property to True to support the object polymorphism.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property IncludeTypeName As System.Boolean
'Usage

Dim instance As JsonMessageSerializer
Dim value As System.Boolean

instance.IncludeTypeName = value

value = instance.IncludeTypeName
public System.bool IncludeTypeName {get; set;}
public read-write property IncludeTypeName: System.Boolean;
public function get,set IncludeTypeName : System.boolean
public: __property System.bool get_IncludeTypeName();
public: __property void set_IncludeTypeName(
   System.bool value
);
public:
property System.bool IncludeTypeName {
   System.bool get();
   void set (    System.bool value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonMessageSerializer Class
JsonMessageSerializer Members


MessageDispatcher Class

MessageDispatcher Class
Members

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class
Provides methods and properties for dispatching WebSocket messages to message operations.
Object Model
MessageDispatcher Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class MessageDispatcher
'Usage

Dim instance As MessageDispatcher
public abstract class MessageDispatcher
public class MessageDispatcher abstract;
public abstract class MessageDispatcher
public __gc abstract class MessageDispatcher
public ref class MessageDispatcher abstract
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageDispatcher
Noemax.WebSockets.Messaging.DefaultMessageDispatcher

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Members
Noemax.WebSockets.Messaging Namespace


MessageDispatcher Class Members

MessageDispatcher Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class

The following tables list the members exposed by MessageDispatcher.

Public Properties
 | Name | Description
Public Property | DefaultSerializer | Gets the default IMessageSerializer instance used by the underlying service.
Public Property | KnownTypes | Gets the list of data types expected to be exchanged by underlying service.
Public Property | Operations | Gets the list of operations being dispatched by the dispatcher.
Top
Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher.
Public Method | CreateClientDispatcher | Creates the instance of the IClientDispatcher facilitating send request and dispatching responses by WebSocketClient.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message.
Public Method | TryGetOperation | Finds the operation with a specified MessageOperationDescription.Action value.
Top
See Also

Reference

MessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


MessageDispatcher Class Methods

MessageDispatcher Class Methods

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class

For a list of all members of this type, see MessageDispatcher members.

Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher.
Public Method | CreateClientDispatcher | Creates the instance of the IClientDispatcher facilitating send request and dispatching responses by WebSocketClient.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message.
Public Method | TryGetOperation | Finds the operation with a specified MessageOperationDescription.Action value.
Top
See Also

Reference

MessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


AddOperation Method (MessageDispatcher)

AddOperation Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : AddOperation Method
Creates and adds the messaging operation to the dispatcher.
Overload List
Overload | Description
AddOperation(ICriteria,Invoker) | Creates and adds the messaging operation to the dispatcher.
AddOperation(MessageOperationDescription) | Adds the message operation to the dispatcher.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


AddOperation(ICriteria,Invoker) Method

AddOperation(ICriteria,Invoker) Method

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class > AddOperation Method : AddOperation(ICriteria,Invoker) Method
The criteria based on which a message is dispatched to the operation.
The invoker being used for invoking the operation.
Creates and adds the messaging operation to the dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AddOperation( _
   ByVal criteria As ICriteria, _
   ByVal invoker As Invoker _
)
'Usage

Dim instance As MessageDispatcher
Dim criteria As ICriteria
Dim invoker As Invoker

instance.AddOperation(criteria, invoker)
public void AddOperation(
   ICriteria criteria,
   Invoker invoker
)
public procedure AddOperation(
    criteria: ICriteria;
    invoker: Invoker
);
public function AddOperation(
   criteria : ICriteria,
   invoker : Invoker
);
public: void AddOperation(
   ICriteria* criteria,
   Invoker* invoker
)
public:
void AddOperation(
   ICriteria^ criteria,
   Invoker^ invoker
)

Parameters

criteria
The criteria based on which a message is dispatched to the operation.
invoker
The invoker being used for invoking the operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members
Overload List


AddOperation(MessageOperationDescription) Method

AddOperation(MessageOperationDescription) Method

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class > AddOperation Method : AddOperation(MessageOperationDescription) Method
The operation to add.
Adds the message operation to the dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub AddOperation( _
   ByVal operation As MessageOperationDescription _
)
'Usage

Dim instance As MessageDispatcher
Dim operation As MessageOperationDescription

instance.AddOperation(operation)
public void AddOperation(
   MessageOperationDescription operation
)
public procedure AddOperation(
    operation: MessageOperationDescription
);
public function AddOperation(
   operation : MessageOperationDescription
);
public: void AddOperation(
   MessageOperationDescription* operation
)
public:
void AddOperation(
   MessageOperationDescription^ operation
)

Parameters

operation
The operation to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members
Overload List


CreateClientDispatcher Method (MessageDispatcher)

CreateClientDispatcher Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : CreateClientDispatcher Method
The channel for which the client dispatcher is getting created.
Creates the instance of the IClientDispatcher facilitating send request and dispatching responses by WebSocketClient.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Function CreateClientDispatcher( _
   ByVal channel As WebSocketChannel _
) As IClientDispatcher
'Usage

Dim instance As MessageDispatcher
Dim channel As WebSocketChannel
Dim value As IClientDispatcher

value = instance.CreateClientDispatcher(channel)
public abstract IClientDispatcher CreateClientDispatcher(
   WebSocketChannel channel
)
public function CreateClientDispatcher(
    channel: WebSocketChannel
): IClientDispatcher; abstract;
public __abstract function CreateClientDispatcher(
   channel : WebSocketChannel
) : IClientDispatcher;
public: abstract IClientDispatcher* CreateClientDispatcher(
   WebSocketChannel* channel
)
public:
abstract IClientDispatcher^ CreateClientDispatcher(
   WebSocketChannel^ channel
)

Parameters

channel
The channel for which the client dispatcher is getting created.

Return Value

The client dispatcher created for the specified channel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


Dispatch Method (MessageDispatcher)

Dispatch Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : Dispatch Method
The message to dispatch.
The channel through which message is received.
Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Dispatch( _
   ByVal message As WebSocketInboundMessage, _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As MessageDispatcher
Dim message As WebSocketInboundMessage
Dim channel As WebSocketChannel

instance.Dispatch(message, channel)
public virtual void Dispatch(
   WebSocketInboundMessage message,
   WebSocketChannel channel
)
public procedure Dispatch(
    message: WebSocketInboundMessage;
    channel: WebSocketChannel
); virtual;
public function Dispatch(
   message : WebSocketInboundMessage,
   channel : WebSocketChannel
);
public: virtual void Dispatch(
   WebSocketInboundMessage* message,
   WebSocketChannel* channel
)
public:
virtual void Dispatch(
   WebSocketInboundMessage^ message,
   WebSocketChannel^ channel
)

Parameters

message
The message to dispatch.
channel
The channel through which message is received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


GetOperation Method (MessageDispatcher)

GetOperation Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : GetOperation Method
The message being dispatched.
The channel through which the message is being received.
Resolves the message to the MessageOperationDescription that can process the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetOperation( _
   ByVal message As System.Object, _
   ByVal channel As WebSocketChannel _
) As MessageOperationDescription
'Usage

Dim instance As MessageDispatcher
Dim message As System.Object
Dim channel As WebSocketChannel
Dim value As MessageOperationDescription

value = instance.GetOperation(message, channel)
public MessageOperationDescription GetOperation(
   System.object message,
   WebSocketChannel channel
)
public function GetOperation(
    message: System.TObject;
    channel: WebSocketChannel
): MessageOperationDescription;
public function GetOperation(
   message : System.Object,
   channel : WebSocketChannel
) : MessageOperationDescription;
public: MessageOperationDescription* GetOperation(
   System.Object* message,
   WebSocketChannel* channel
)
public:
MessageOperationDescription^ GetOperation(
   System.Object^ message,
   WebSocketChannel^ channel
)

Parameters

message
The message being dispatched.
channel
The channel through which the message is being received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


TryGetOperation Method (MessageDispatcher)

TryGetOperation Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : TryGetOperation Method
The object representing partially or fully deserialized inbound message as produced by IMessageSerializer.
The channel through which inbound message was received.
The variable to store the operation if found.
Finds the operation with a specified MessageOperationDescription.Action value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function TryGetOperation( _
   ByVal graph As System.Object, _
   ByVal channel As WebSocketChannel, _
   ByRef operation As MessageOperationDescription _
) As System.Boolean
'Usage

Dim instance As MessageDispatcher
Dim graph As System.Object
Dim channel As WebSocketChannel
Dim operation As MessageOperationDescription
Dim value As System.Boolean

value = instance.TryGetOperation(graph, channel, operation)
public virtual System.bool TryGetOperation(
   System.object graph,
   WebSocketChannel channel,
   out MessageOperationDescription operation
)
public function TryGetOperation(
    graph: System.TObject;
    channel: WebSocketChannel;
   Out  operation: MessageOperationDescription
): System.Boolean; virtual;
public function TryGetOperation(
   graph : System.Object,
   channel : WebSocketChannel,
   operation : MessageOperationDescription
) : System.boolean;
public: virtual System.bool TryGetOperation(
   System.Object* graph,
   WebSocketChannel* channel,
   [PARAMFLAG::Out] MessageOperationDescription* operation
)
public:
virtual System.bool TryGetOperation(
   System.Object^ graph,
   WebSocketChannel^ channel,
   [Out] MessageOperationDescription^ operation
)

Parameters

graph
The object representing partially or fully deserialized inbound message as produced by IMessageSerializer.
channel
The channel through which inbound message was received.
operation
The variable to store the operation if found.

Return Value

True if operation was found; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


MessageDispatcher Class Properties

MessageDispatcher Class Properties

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class

For a list of all members of this type, see MessageDispatcher members.

Public Properties
 | Name | Description
Public Property | DefaultSerializer | Gets the default IMessageSerializer instance used by the underlying service.
Public Property | KnownTypes | Gets the list of data types expected to be exchanged by underlying service.
Public Property | Operations | Gets the list of operations being dispatched by the dispatcher.
Top
See Also

Reference

MessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


DefaultSerializer Property (MessageDispatcher)

DefaultSerializer Property (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : DefaultSerializer Property
Gets the default IMessageSerializer instance used by the underlying service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Property DefaultSerializer As IMessageSerializer
'Usage

Dim instance As MessageDispatcher
Dim value As IMessageSerializer

instance.DefaultSerializer = value

value = instance.DefaultSerializer
public abstract IMessageSerializer DefaultSerializer {get; set;}
public read-write property DefaultSerializer: IMessageSerializer; abstract;
public __abstract function get,set DefaultSerializer : IMessageSerializer
public: __property abstract IMessageSerializer* get_DefaultSerializer();
public: __property abstract void set_DefaultSerializer(
   IMessageSerializer* value
);
public:
abstract property IMessageSerializer^ DefaultSerializer {
   IMessageSerializer^ get();
   void set (    IMessageSerializer^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


KnownTypes Property (MessageDispatcher)

KnownTypes Property (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : KnownTypes Property
Gets the list of data types expected to be exchanged by underlying service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As MessageDispatcher
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public abstract System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; abstract;
public __abstract function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property abstract System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes();
public:
abstract property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


Operations Property (MessageDispatcher)

Operations Property (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : Operations Property
Gets the list of operations being dispatched by the dispatcher.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Operations As System.Collections.Generic.IEnumerable(Of MessageOperationDescription)
'Usage

Dim instance As MessageDispatcher
Dim value As System.Collections.Generic.IEnumerable(Of MessageOperationDescription)

value = instance.Operations
public virtual System.Collections.Generic.IEnumerable<MessageOperationDescription> Operations {get;}
public read-only property Operations: System.Collections.Generic.IEnumerable; virtual;
public function get Operations : System.Collections.Generic.IEnumerable
public: __property virtual System.Collections.Generic.IEnumerable<MessageOperationDescription*>* get_Operations();
public:
virtual property System.Collections.Generic.IEnumerable<MessageOperationDescription^>^ Operations {
   System.Collections.Generic.IEnumerable<MessageOperationDescription^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


MessageOperationAttribute Class

MessageOperationAttribute Class
Members

Noemax.WebSockets.Messaging Namespace : MessageOperationAttribute Class
Indicates that a method defines an operation that is part of a service contract.
Object Model
MessageOperationAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class MessageOperationAttribute
   Inherits System.Attribute
'Usage

Dim instance As MessageOperationAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class MessageOperationAttribute : System.Attribute
public class MessageOperationAttribute = class(System.Attribute)
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=,
   Inherited=)
public class MessageOperationAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public __gc class MessageOperationAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public ref class MessageOperationAttribute : public System.Attribute
Remarks

MessageOperationAttribute is used to specify a method to which inbound messages is dispatched. Criteria for dispatching the message can depend on the type of the service providing the method.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WebSockets.Messaging.MessageOperationAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Members
Noemax.WebSockets.Messaging Namespace


MessageOperationAttribute Class Members

MessageOperationAttribute Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : MessageOperationAttribute Class

The following tables list the members exposed by MessageOperationAttribute.

Public Constructors
 | Name | Description
Public Constructor | MessageOperationAttribute Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets and sets the action string that identifies the operation.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

MessageOperationAttribute Class
Noemax.WebSockets.Messaging Namespace


MessageOperationAttribute Constructor

MessageOperationAttribute Constructor

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : MessageOperationAttribute Constructor
Overload List
Overload | Description
MessageOperationAttribute Constructor(String) | Initialize a new instance of MessageOperationAttribute from the specified action string.
MessageOperationAttribute Constructor() | Initialize a new instance of MessageOperationAttribute.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


MessageOperationAttribute Constructor(String)

MessageOperationAttribute Constructor(String)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class > MessageOperationAttribute Constructor : MessageOperationAttribute Constructor(String)
Initialize a new instance of MessageOperationAttribute from the specified action string.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal action As System.String _
)
'Usage

Dim action As System.String

Dim instance As New MessageOperationAttribute(action)
public MessageOperationAttribute(
   System.string action
)
public MessageOperationAttribute(
    action: System.String
);
public function MessageOperationAttribute(
   action : System.String
);
public: MessageOperationAttribute(
   System.string* action
)
public:
MessageOperationAttribute(
   System.String^ action
)

Parameters

action
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members
Overload List


MessageOperationAttribute Constructor()

MessageOperationAttribute Constructor()

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class > MessageOperationAttribute Constructor : MessageOperationAttribute Constructor()
Initialize a new instance of MessageOperationAttribute.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New MessageOperationAttribute()
public MessageOperationAttribute()
public MessageOperationAttribute();
public function MessageOperationAttribute();
public: MessageOperationAttribute();
public:
MessageOperationAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members
Overload List


MessageOperationAttribute Class Properties

MessageOperationAttribute Class Properties

Noemax.WebSockets.Messaging Namespace : MessageOperationAttribute Class

For a list of all members of this type, see MessageOperationAttribute members.

Public Properties
 | Name | Description
Public Property | Action | Gets and sets the action string that identifies the operation.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

MessageOperationAttribute Class
Noemax.WebSockets.Messaging Namespace


Action Property (MessageOperationAttribute)

Action Property (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : Action Property
Gets and sets the action string that identifies the operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Action As System.String
'Usage

Dim instance As MessageOperationAttribute
Dim value As System.String

value = instance.Action
public System.string Action {get;}
public read-only property Action: System.String;
public function get Action : System.String
public: __property System.string* get_Action();
public:
property System.String^ Action {
   System.String^ get();
}
Remarks
Action strings are used by a dispatcher to dispatch messages to appropriate method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


MessageOperationDescription Class

MessageOperationDescription Class
Members

Noemax.WebSockets.Messaging Namespace : MessageOperationDescription Class
Defines the properties of message dispatching operation.
Object Model
MessageOperationDescription Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class MessageOperationDescription
'Usage

Dim instance As MessageOperationDescription
public class MessageOperationDescription
public class MessageOperationDescription
public class MessageOperationDescription
public __gc class MessageOperationDescription
public ref class MessageOperationDescription
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageOperationDescription

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationDescription Members
Noemax.WebSockets.Messaging Namespace


MessageOperationDescription Class Members

MessageOperationDescription Class Members
Properties

Noemax.WebSockets.Messaging Namespace : MessageOperationDescription Class

The following tables list the members exposed by MessageOperationDescription.

Public Constructors
 | Name | Description
Public Constructor | MessageOperationDescription Constructor | Initialize a new instance of MessageOperationDescription.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets and sets the action string for matching a message.
Public Property | Criteria | Gets Criteria for dispatching a message.
Public Property | Invoker | Gets Invoker that calls the method to which a message is dispatched.
Top
See Also

Reference

MessageOperationDescription Class
Noemax.WebSockets.Messaging Namespace


MessageOperationDescription Constructor

MessageOperationDescription Constructor

Noemax.WebSockets.Messaging Namespace > MessageOperationDescription Class : MessageOperationDescription Constructor
The criteria for dispatching messages to the Invoker.
Invoker that calls the method to which a message is dispatched.
Initialize a new instance of MessageOperationDescription.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal criteria As ICriteria, _
   ByVal invoker As Invoker _
)
'Usage

Dim criteria As ICriteria
Dim invoker As Invoker

Dim instance As New MessageOperationDescription(criteria, invoker)
public MessageOperationDescription(
   ICriteria criteria,
   Invoker invoker
)
public MessageOperationDescription(
    criteria: ICriteria;
    invoker: Invoker
);
public function MessageOperationDescription(
   criteria : ICriteria,
   invoker : Invoker
);
public: MessageOperationDescription(
   ICriteria* criteria,
   Invoker* invoker
)
public:
MessageOperationDescription(
   ICriteria^ criteria,
   Invoker^ invoker
)

Parameters

criteria
The criteria for dispatching messages to the Invoker.
invoker
Invoker that calls the method to which a message is dispatched.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationDescription Class
MessageOperationDescription Members


MessageOperationDescription Class Properties

MessageOperationDescription Class Properties

Noemax.WebSockets.Messaging Namespace : MessageOperationDescription Class

For a list of all members of this type, see MessageOperationDescription members.

Public Properties
 | Name | Description
Public Property | Action | Gets and sets the action string for matching a message.
Public Property | Criteria | Gets Criteria for dispatching a message.
Public Property | Invoker | Gets Invoker that calls the method to which a message is dispatched.
Top
See Also

Reference

MessageOperationDescription Class
Noemax.WebSockets.Messaging Namespace


Action Property (MessageOperationDescription)

Action Property (MessageOperationDescription)

Noemax.WebSockets.Messaging Namespace > MessageOperationDescription Class : Action Property
Gets and sets the action string for matching a message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Action As System.String
'Usage

Dim instance As MessageOperationDescription
Dim value As System.String

instance.Action = value

value = instance.Action
public System.string Action {get; set;}
public read-write property Action: System.String;
public function get,set Action : System.String
public: __property System.string* get_Action();
public: __property void set_Action(
   System.string* value
);
public:
property System.String^ Action {
   System.String^ get();
   void set (    System.String^ value);
}
Remarks
Action is compared with an Action specified by the inbound message, if equal than the Criteria is used to validate whether the inbound message matches operation criteria. If Criteria.Match returns true, than message is getting dispatched to the Invoker specified by this operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationDescription Class
MessageOperationDescription Members


Criteria Property (MessageOperationDescription)

Criteria Property (MessageOperationDescription)

Noemax.WebSockets.Messaging Namespace > MessageOperationDescription Class : Criteria Property
Gets Criteria for dispatching a message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Criteria As ICriteria
'Usage

Dim instance As MessageOperationDescription
Dim value As ICriteria

value = instance.Criteria
public ICriteria Criteria {get;}
public read-only property Criteria: ICriteria;
public function get Criteria : ICriteria
public: __property ICriteria* get_Criteria();
public:
property ICriteria^ Criteria {
   ICriteria^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationDescription Class
MessageOperationDescription Members


Invoker Property (MessageOperationDescription)

Invoker Property (MessageOperationDescription)

Noemax.WebSockets.Messaging Namespace > MessageOperationDescription Class : Invoker Property
Gets Invoker that calls the method to which a message is dispatched.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Invoker As Invoker
'Usage

Dim instance As MessageOperationDescription
Dim value As Invoker

value = instance.Invoker
public Invoker Invoker {get;}
public read-only property Invoker: Invoker;
public function get Invoker : Invoker
public: __property Invoker* get_Invoker();
public:
property Invoker^ Invoker {
   Invoker^ get();
}
Remarks
Performs invocation of the method when an inbound message is dispatched to this operation and conforms to its Action and Criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationDescription Class
MessageOperationDescription Members


MessageSerializerBase Class

MessageSerializerBase Class
Members

Noemax.WebSockets.Messaging Namespace : MessageSerializerBase Class
Provides the base class for serializing objects into WebSocket messages.
Object Model
MessageSerializerBase Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class MessageSerializerBase
   Implements IMessageSerializer
'Usage

Dim instance As MessageSerializerBase
public abstract class MessageSerializerBase : IMessageSerializer
public class MessageSerializerBase = class(IMessageSerializer)abstract;
public abstract class MessageSerializerBase implements IMessageSerializer
public __gc abstract class MessageSerializerBase : public IMessageSerializer
public ref class MessageSerializerBase abstract : public IMessageSerializer
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageSerializerBase
Noemax.WebSockets.Messaging.JsonMessageSerializer
Noemax.WebSockets.Messaging.XmlMessageSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Members
Noemax.WebSockets.Messaging Namespace


MessageSerializerBase Class Members

MessageSerializerBase Class Members
Methods

Noemax.WebSockets.Messaging Namespace : MessageSerializerBase Class

The following tables list the members exposed by MessageSerializerBase.

Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Deserializes the content of inbound message.
Public Method | EnsureKnownTypes | When override ensures that specified collection of types are supported by the serializer.
Public Method | Serialize | Overloaded. Serializes the object into WebSocketOutboundMessage.
Top
See Also

Reference

MessageSerializerBase Class
Noemax.WebSockets.Messaging Namespace


MessageSerializerBase Class Methods

MessageSerializerBase Class Methods

Noemax.WebSockets.Messaging Namespace : MessageSerializerBase Class

For a list of all members of this type, see MessageSerializerBase members.

Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Deserializes the content of inbound message.
Public Method | EnsureKnownTypes | When override ensures that specified collection of types are supported by the serializer.
Public Method | Serialize | Overloaded. Serializes the object into WebSocketOutboundMessage.
Top
See Also

Reference

MessageSerializerBase Class
Noemax.WebSockets.Messaging Namespace


Deserialize Method (MessageSerializerBase)

Deserialize Method (MessageSerializerBase)

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class : Deserialize Method
Deserializes the content of inbound message.
Overload List
Overload | Description
Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) | Deserializes the content of inbound message.
Deserialize(String,WebSocketChannel,MessageDispatcher) | Deserializes the content of inbound message.
Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) | Deserializes the content of inbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members


Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) Method

Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class > Deserialize Method : Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) Method
The message to deserialize.
The channel through which the message was received.
The dispatcher being used for dispatching the message.
Deserializes the content of inbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function Deserialize( _
   ByVal message As WebSocketInboundMessage, _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As MessageSerializerBase
Dim message As WebSocketInboundMessage
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(message, channel, dispatcher)
public virtual System.object Deserialize(
   WebSocketInboundMessage message,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
public function Deserialize(
    message: WebSocketInboundMessage;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; virtual;
public function Deserialize(
   message : WebSocketInboundMessage,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
public: virtual System.Object* Deserialize(
   WebSocketInboundMessage* message,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
)
public:
virtual System.Object^ Deserialize(
   WebSocketInboundMessage^ message,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
)

Parameters

message
The message to deserialize.
channel
The channel through which the message was received.
dispatcher
The dispatcher being used for dispatching the message.

Return Value

The object deserialized from the content of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members
Overload List


Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class > Deserialize Method : Deserialize(String,WebSocketChannel,MessageDispatcher) Method
The text content to deserialize.
The channel through which the message was received.
The dispatcher being used for dispatching the message.
Deserializes the content of inbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function Deserialize( _
   ByVal textContent As System.String, _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As MessageSerializerBase
Dim textContent As System.String
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(textContent, channel, dispatcher)
protected abstract System.object Deserialize(
   System.string textContent,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
protected function Deserialize(
    textContent: System.String;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; abstract;
protected __abstract function Deserialize(
   textContent : System.String,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
protected: abstract System.Object* Deserialize(
   System.string* textContent,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
)
protected:
abstract System.Object^ Deserialize(
   System.String^ textContent,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
)

Parameters

textContent
The text content to deserialize.
channel
The channel through which the message was received.
dispatcher
The dispatcher being used for dispatching the message.

Return Value

The object deserialized from the content of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members
Overload List


Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class > Deserialize Method : Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method
The binary content to deserialize.
The channel through which the message was received.
The dispatcher being used for dispatching the message.
Deserializes the content of inbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function Deserialize( _
   ByVal binaryContent As System.ArraySegment(Of Byte), _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As MessageSerializerBase
Dim binaryContent As System.ArraySegment(Of Byte)
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(binaryContent, channel, dispatcher)
protected abstract System.object Deserialize(
   System.ArraySegment<byte> binaryContent,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
protected function Deserialize(
    binaryContent: System.ArraySegment;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; abstract;
protected __abstract function Deserialize(
   binaryContent : System.ArraySegment,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
protected: abstract System.Object* Deserialize(
   System.ArraySegment<byte> binaryContent,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
)
protected:
abstract System.Object^ Deserialize(
   System.ArraySegment<byte> binaryContent,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
)

Parameters

binaryContent
The binary content to deserialize.
channel
The channel through which the message was received.
dispatcher
The dispatcher being used for dispatching the message.

Return Value

The object deserialized from the content of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members
Overload List


EnsureKnownTypes Method (MessageSerializerBase)

EnsureKnownTypes Method (MessageSerializerBase)

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class : EnsureKnownTypes Method
The collection of types to be supported by the serializer.
When override ensures that specified collection of types are supported by the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustOverride Sub EnsureKnownTypes( _
   ByVal ParamArray type() As System.Type _
)
'Usage

Dim instance As MessageSerializerBase
Dim type() As System.Type

instance.EnsureKnownTypes(type)
public abstract void EnsureKnownTypes(
   params System.Type[] type
)
public procedure EnsureKnownTypes(
   params  type: System.Typearray of
); abstract;
public __abstract function EnsureKnownTypes(
   type : System.Type[]
);
public: abstract void EnsureKnownTypes(
   params System.Type*[]* type
)
public:
abstract void EnsureKnownTypes(
   ... System.array<Type^>^ type
)

Parameters

type
The collection of types to be supported by the serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members


Serialize Method (MessageSerializerBase)

Serialize Method (MessageSerializerBase)

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class : Serialize Method
Serializes the object into WebSocketOutboundMessage.
Overload List
Overload | Description
Serialize(Object) | Serializes the object into WebSocketOutboundMessage.
Serialize(Stream,Object) | Serializes the object into stream and returns the stream to write attachment to the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members


Serialize(Object) Method

Serialize(Object) Method

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class > Serialize Method : Serialize(Object) Method
The object being serialized.
Serializes the object into WebSocketOutboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads MustOverride Function Serialize( _
   ByVal obj As System.Object _
) As WebSocketOutboundMessage
'Usage

Dim instance As MessageSerializerBase
Dim obj As System.Object
Dim value As WebSocketOutboundMessage

value = instance.Serialize(obj)
public abstract WebSocketOutboundMessage Serialize(
   System.object obj
)
public function Serialize(
    obj: System.TObject
): WebSocketOutboundMessage; abstract;
public __abstract function Serialize(
   obj : System.Object
) : WebSocketOutboundMessage;
public: abstract WebSocketOutboundMessage Serialize(
   System.Object* obj
)
public:
abstract WebSocketOutboundMessage Serialize(
   System.Object^ obj
)

Parameters

obj
The object being serialized.

Return Value

The outbound message containing the serialized object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members
Overload List


Serialize(Stream,Object) Method

Serialize(Stream,Object) Method

Noemax.WebSockets.Messaging Namespace > MessageSerializerBase Class > Serialize Method : Serialize(Stream,Object) Method
The stream to write the outbound message.
The object to serialize into the stream.
Serializes the object into stream and returns the stream to write attachment to the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function Serialize( _
   ByVal output As System.IO.Stream, _
   ByVal obj As System.Object _
) As System.IO.Stream
'Usage

Dim instance As MessageSerializerBase
Dim output As System.IO.Stream
Dim obj As System.Object
Dim value As System.IO.Stream

value = instance.Serialize(output, obj)
public virtual System.IO.Stream Serialize(
   System.IO.Stream output,
   System.object obj
)
public function Serialize(
    output: System.IO.Stream;
    obj: System.TObject
): System.IO.Stream; virtual;
public function Serialize(
   output : System.IO.Stream,
   obj : System.Object
) : System.IO.Stream;
public: virtual System.IO.Stream* Serialize(
   System.IO.Stream* output,
   System.Object* obj
)
public:
virtual System.IO.Stream^ Serialize(
   System.IO.Stream^ output,
   System.Object^ obj
)

Parameters

output
The stream to write the outbound message.
obj
The object to serialize into the stream.

Return Value

The stream to which attachment data being written.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageSerializerBase Class
MessageSerializerBase Members
Overload List


MessagingContractAttribute Class

MessagingContractAttribute Class
Members

Noemax.WebSockets.Messaging Namespace : MessagingContractAttribute Class
Indicates that an interface or a class defines a service contract.
Object Model
MessagingContractAttribute Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Interface,
   AllowMultiple=False,
   Inherited=True)>
Public Class MessagingContractAttribute
   Inherits System.Attribute
'Usage

Dim instance As MessagingContractAttribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public class MessagingContractAttribute : System.Attribute
public class MessagingContractAttribute = class(System.Attribute)
System.AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=,
   Inherited=)
public class MessagingContractAttribute extends System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public __gc class MessagingContractAttribute : public System.Attribute
[System.AttributeUsage(ValidOn=AttributeTargets.Class |
    AttributeTargets.Interface,
   AllowMultiple=false,
   Inherited=true)]
public ref class MessagingContractAttribute : public System.Attribute
Remarks
The class marked to the MessagingContractAttribute must include one or more methods marked with MessageOperationAttribute.
Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WebSockets.Messaging.MessagingContractAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Members
Noemax.WebSockets.Messaging Namespace


MessagingContractAttribute Class Members

MessagingContractAttribute Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : MessagingContractAttribute Class

The following tables list the members exposed by MessagingContractAttribute.

Public Constructors
 | Name | Description
Public Constructor | MessagingContractAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

MessagingContractAttribute Class
Noemax.WebSockets.Messaging Namespace


MessagingContractAttribute Constructor

MessagingContractAttribute Constructor

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : MessagingContractAttribute Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New MessagingContractAttribute()
public MessagingContractAttribute()
public MessagingContractAttribute();
public function MessagingContractAttribute();
public: MessagingContractAttribute();
public:
MessagingContractAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


MultiFormatMessagingService Class

MultiFormatMessagingService Class
Members

Noemax.WebSockets.Messaging Namespace : MultiFormatMessagingService Class
The base class for the service that dispatches inbound messages based on the type of the objects deserialized from the message content. This service is capable to use different format per each associated channel.
Object Model
MultiFormatMessagingService Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class MultiFormatMessagingService
   Inherits Noemax.WebSockets.WebSocketService
   Implements Noemax.WebSockets.IWebSockets
'Usage

Dim instance As MultiFormatMessagingService
public class MultiFormatMessagingService : Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
public class MultiFormatMessagingService = class(Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets)
public class MultiFormatMessagingService extends Noemax.WebSockets.WebSocketService implements Noemax.WebSockets.IWebSockets
public __gc class MultiFormatMessagingService : public Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
public ref class MultiFormatMessagingService : public Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Members
Noemax.WebSockets.Messaging Namespace


MultiFormatMessagingService Class Members

MultiFormatMessagingService Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : MultiFormatMessagingService Class

The following tables list the members exposed by MultiFormatMessagingService.

Public Constructors
 | Name | Description
Public Constructor | MultiFormatMessagingService Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketService)
Top
Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | AddMessageSerializer | Associates the IMessageSerializer to the specified Sec-WebSocket-Protocol handshake header value and adds it to the list of supported serializers.
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | Broadcast | Overloaded. Broadcast specified object to the all associated channels.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetChannels | Returns the list of the channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetProperty<T> | Gets the the object of the specified type associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnClose | This method is called when a channel is being closed. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnError | Handles a error occurred in a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnHandshake | Overridden. Provides handshake handling during which the service validate whether the protocol request by connection is one fo the protocols supported by the service.
Public Method | OnMessage | Overloaded. Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnOpen | Overridden. Overrides Noemax.WebSockets.WebSocketService.OnOpen. Determins the serializer required by the specified channel and the channel to the list of assocaited channels.
Public Method | OnPing | This method is called when a PING frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnPong | This method is called when a PONG frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires. (Inherited from Noemax.WebSockets.WebSocketService)
Top
See Also

Reference

MultiFormatMessagingService Class
Noemax.WebSockets.Messaging Namespace


MultiFormatMessagingService Constructor

MultiFormatMessagingService Constructor

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class : MultiFormatMessagingService Constructor
Overload List
Overload | Description
MultiFormatMessagingService Constructor() | Initializes a new instance of MultiFormatMessagingService.
MultiFormatMessagingService Constructor(Object) | Initializes a new instance of MultiFormatMessagingService.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members


MultiFormatMessagingService Constructor()

MultiFormatMessagingService Constructor()

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class > MultiFormatMessagingService Constructor : MultiFormatMessagingService Constructor()
Initializes a new instance of MultiFormatMessagingService.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New MultiFormatMessagingService()
public MultiFormatMessagingService()
public MultiFormatMessagingService();
public function MultiFormatMessagingService();
public: MultiFormatMessagingService();
public:
MultiFormatMessagingService();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Overload List


MultiFormatMessagingService Constructor(Object)

MultiFormatMessagingService Constructor(Object)

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class > MultiFormatMessagingService Constructor : MultiFormatMessagingService Constructor(Object)
The instance of the class providing methods that receive inbound messages.
Initializes a new instance of MultiFormatMessagingService.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal instance As System.Object _
)
'Usage

Dim instance As System.Object

Dim instance As New MultiFormatMessagingService(instance)
public MultiFormatMessagingService(
   System.object instance
)
public MultiFormatMessagingService(
    instance: System.TObject
);
public function MultiFormatMessagingService(
   instance : System.Object
);
public: MultiFormatMessagingService(
   System.Object* instance
)
public:
MultiFormatMessagingService(
   System.Object^ instance
)

Parameters

instance
The instance of the class providing methods that receive inbound messages.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Overload List


MultiFormatMessagingService Class Methods

MultiFormatMessagingService Class Methods

Noemax.WebSockets.Messaging Namespace : MultiFormatMessagingService Class

For a list of all members of this type, see MultiFormatMessagingService members.

Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | AddMessageSerializer | Associates the IMessageSerializer to the specified Sec-WebSocket-Protocol handshake header value and adds it to the list of supported serializers.
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | Broadcast | Overloaded. Broadcast specified object to the all associated channels.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetChannels | Returns the list of the channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetProperty<T> | Gets the the object of the specified type associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnClose | This method is called when a channel is being closed. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnError | Handles a error occurred in a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnHandshake | Overridden. Provides handshake handling during which the service validate whether the protocol request by connection is one fo the protocols supported by the service.
Public Method | OnMessage | Overloaded. Handles the inbound message based on the payload type. Override this method if you need to provide alternative functionality or use the streaming API. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnOpen | Overridden. Overrides Noemax.WebSockets.WebSocketService.OnOpen. Determins the serializer required by the specified channel and the channel to the list of assocaited channels.
Public Method | OnPing | This method is called when a PING frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnPong | This method is called when a PONG frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires. (Inherited from Noemax.WebSockets.WebSocketService)
Top
See Also

Reference

MultiFormatMessagingService Class
Noemax.WebSockets.Messaging Namespace


AddMessageSerializer Method (MultiFormatMessagingService)

AddMessageSerializer Method (MultiFormatMessagingService)

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class : AddMessageSerializer Method
The value of the Sec-WebSocket-Protocol handshake header that would indicate that the specified serializer will be used.
The specializer to be used when the specified Protocol handshake header is encountered during the handshake.
Associates the IMessageSerializer to the specified Sec-WebSocket-Protocol handshake header value and adds it to the list of supported serializers.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub AddMessageSerializer( _
   ByVal protocolName As System.String, _
   ByVal serializer As IMessageSerializer _
)
'Usage

Dim instance As MultiFormatMessagingService
Dim protocolName As System.String
Dim serializer As IMessageSerializer

instance.AddMessageSerializer(protocolName, serializer)
public void AddMessageSerializer(
   System.string protocolName,
   IMessageSerializer serializer
)
public procedure AddMessageSerializer(
    protocolName: System.String;
    serializer: IMessageSerializer
);
public function AddMessageSerializer(
   protocolName : System.String,
   serializer : IMessageSerializer
);
public: void AddMessageSerializer(
   System.string* protocolName,
   IMessageSerializer* serializer
)
public:
void AddMessageSerializer(
   System.String^ protocolName,
   IMessageSerializer^ serializer
)

Parameters

protocolName
The value of the Sec-WebSocket-Protocol handshake header that would indicate that the specified serializer will be used.
serializer
The specializer to be used when the specified Protocol handshake header is encountered during the handshake.
Remarks
Provided IMessageSerializer instance would be used for channels that provided the specified protocolName value in Sec-WebSocket-Protocol header in the handshake.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members


Broadcast Method (MultiFormatMessagingService)

Broadcast Method (MultiFormatMessagingService)

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class : Broadcast Method
Broadcast specified object to the all associated channels.
Overload List
Overload | Description
Broadcast<T>(String,T) | Broadcast specified object to the all associated channels.
Broadcast(String,Object[]) | Broadcasts the object of specified type to all channels associated to the service.
Broadcast | Broadcasts the message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members


Broadcast<T>(String,T) Method

Broadcast<T>(String,T) Method

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class > Broadcast Method : Broadcast<T>(String,T) Method
The type of the object to broadcast.
The action associated to the remote operation.
The object to broadcast.
Broadcast specified object to the all associated channels.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Broadcast(Of T)( _
   ByVal action As System.String, _
   ByVal obj As T _
)
'Usage

Dim instance As MultiFormatMessagingService
Dim action As System.String
Dim obj As T

instance.Broadcast(Of T)(action, obj)
public void Broadcast<T>(
   System.string action,
   T obj
)
public procedure Broadcast(
    action: System.String;
    obj: T
);
public function Broadcast(
   action : System.String,
   obj : T
);
public: void Broadcast<T>(
   System.string* action,
   T* obj
)
public:
void Broadcastgeneric<typename T>
(
   System.String^ action,
   T^ obj
)

Parameters

action
The action associated to the remote operation.
obj
The object to broadcast.

Type Parameters

T
The type of the object to broadcast.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Overload List


Broadcast(String,Object[]) Method

Broadcast(String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class > Broadcast Method : Broadcast(String,Object[]) Method
The action string associated to the remote operation.
The paramaters for RPC call to broadcast.
Broadcasts the object of specified type to all channels associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Broadcast( _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim instance As MultiFormatMessagingService
Dim action As System.String
Dim parameters() As System.Object

instance.Broadcast(action, parameters)
public void Broadcast(
   System.string action,
   params System.object[] parameters
)
public procedure Broadcast(
    action: System.String;
   params  parameters: System.TObjectarray of
);
public function Broadcast(
   action : System.String,
   parameters : System.Object[]
);
public: void Broadcast(
   System.string* action,
   params System.Object*[]* parameters
)
public:
void Broadcast(
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

action
The action string associated to the remote operation.
parameters
The paramaters for RPC call to broadcast.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Overload List


OnHandshake Method (MultiFormatMessagingService)

OnHandshake Method (MultiFormatMessagingService)

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class : OnHandshake Method
The sender associated to the event.
The Noemax.WebSockets.WebSocketHandshake providing methods and properties for handling the WebSocket handshake.
Provides handshake handling during which the service validate whether the protocol request by connection is one fo the protocols supported by the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnHandshake( _
   ByVal sender As System.Object, _
   ByVal handshake As WebSocketHandshake _
)
'Usage

Dim instance As MultiFormatMessagingService
Dim sender As System.Object
Dim handshake As WebSocketHandshake

instance.OnHandshake(sender, handshake)
public override void OnHandshake(
   System.object sender,
   WebSocketHandshake handshake
)
public procedure OnHandshake(
    sender: System.TObject;
    handshake: WebSocketHandshake
); override;
public override function OnHandshake(
   sender : System.Object,
   handshake : WebSocketHandshake
);
public: void OnHandshake(
   System.Object* sender,
   WebSocketHandshake* handshake
) override
public:
void OnHandshake(
   System.Object^ sender,
   WebSocketHandshake^ handshake
) override

Parameters

sender
The sender associated to the event.
handshake
The Noemax.WebSockets.WebSocketHandshake providing methods and properties for handling the WebSocket handshake.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Base Implementation in OnHandshake


OnOpen Method (MultiFormatMessagingService)

OnOpen Method (MultiFormatMessagingService)

Noemax.WebSockets.Messaging Namespace > MultiFormatMessagingService Class : OnOpen Method
The channel being associated to the service.
Overrides Noemax.WebSockets.WebSocketService.OnOpen. Determins the serializer required by the specified channel and the channel to the list of assocaited channels.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnOpen( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As MultiFormatMessagingService
Dim channel As WebSocketChannel

instance.OnOpen(channel)
public override void OnOpen(
   WebSocketChannel channel
)
public procedure OnOpen(
    channel: WebSocketChannel
); override;
public override function OnOpen(
   channel : WebSocketChannel
);
public: void OnOpen(
   WebSocketChannel* channel
) override
public:
void OnOpen(
   WebSocketChannel^ channel
) override

Parameters

channel
The channel being associated to the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MultiFormatMessagingService Class
MultiFormatMessagingService Members
Base Implementation in OnOpen


PlainMessage Class

PlainMessage Class
Members

Noemax.WebSockets.Messaging Namespace : PlainMessage Class
Represents a simple message without any message envelope that contains a message body and can have a streamed attachment.
Object Model
PlainMessage Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataContractAttribute()>
Public NotInheritable Class PlainMessage
   Inherits ConversationMessage
'Usage

Dim instance As PlainMessage
[System.Runtime.Serialization.DataContract()]
public sealed class PlainMessage : ConversationMessage
public class PlainMessage = class(ConversationMessage)sealed;
System.Runtime.Serialization.DataContractAttribute()
public sealed class PlainMessage extends ConversationMessage
[System.Runtime.Serialization.DataContract()]
public __gc __sealed class PlainMessage : public ConversationMessage
[System.Runtime.Serialization.DataContract()]
public ref class PlainMessage sealed : public ConversationMessage
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.EnvelopedMessage
Noemax.WebSockets.Messaging.ConversationMessage
Noemax.WebSockets.Messaging.PlainMessage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Members
Noemax.WebSockets.Messaging Namespace


PlainMessage Class Members

PlainMessage Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : PlainMessage Class

The following tables list the members exposed by PlainMessage.

Public Constructors
 | Name | Description
Public Constructor | PlainMessage Constructor | Initialize a new instance of PlainMessage.
Top
Public Properties
 | Name | Description
Public Property | Attachment | (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Body | Overridden. The object serialized into body of the message.
Public Property | Id | Gets the number identifying the request to the service. (Inherited from Noemax.WebSockets.Messaging.ConversationMessage)
Public Property | IsFault | Overridden. Always returns false.
Public Property | IsResponse | Overridden. Always returns false.
Public Property | Msg | Serialize property to store the body of the message.
Top
Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Top
See Also

Reference

PlainMessage Class
Noemax.WebSockets.Messaging Namespace


PlainMessage Constructor

PlainMessage Constructor

Noemax.WebSockets.Messaging Namespace > PlainMessage Class : PlainMessage Constructor
The object to be set as body of the message.
Initialize a new instance of PlainMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal body As System.Object _
)
'Usage

Dim body As System.Object

Dim instance As New PlainMessage(body)
public PlainMessage(
   System.object body
)
public PlainMessage(
    body: System.TObject
);
public function PlainMessage(
   body : System.Object
);
public: PlainMessage(
   System.Object* body
)
public:
PlainMessage(
   System.Object^ body
)

Parameters

body
The object to be set as body of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Class
PlainMessage Members


PlainMessage Class Properties

PlainMessage Class Properties

Noemax.WebSockets.Messaging Namespace : PlainMessage Class

For a list of all members of this type, see PlainMessage members.

Public Properties
 | Name | Description
Public Property | Attachment | (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Public Property | Body | Overridden. The object serialized into body of the message.
Public Property | Id | Gets the number identifying the request to the service. (Inherited from Noemax.WebSockets.Messaging.ConversationMessage)
Public Property | IsFault | Overridden. Always returns false.
Public Property | IsResponse | Overridden. Always returns false.
Public Property | Msg | Serialize property to store the body of the message.
Top
See Also

Reference

PlainMessage Class
Noemax.WebSockets.Messaging Namespace


Body Property (PlainMessage)

Body Property (PlainMessage)

Noemax.WebSockets.Messaging Namespace > PlainMessage Class : Body Property
The object serialized into body of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property Body As System.Object
'Usage

Dim instance As PlainMessage
Dim value As System.Object

value = instance.Body
public override System.object Body {get;}
public read-only property Body: System.TObject; override;
public override function get Body : System.Object
public: __property System.Object* get_Body() override;
public:
property System.Object^ Body {
   System.Object^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Class
PlainMessage Members
Base Implementation in Body


IsFault Property (PlainMessage)

IsFault Property (PlainMessage)

Noemax.WebSockets.Messaging Namespace > PlainMessage Class : IsFault Property
Always returns false.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property IsFault As System.Boolean
'Usage

Dim instance As PlainMessage
Dim value As System.Boolean

value = instance.IsFault
public override System.bool IsFault {get;}
public read-only property IsFault: System.Boolean; override;
public override function get IsFault : System.boolean
public: __property System.bool get_IsFault() override;
public:
property System.bool IsFault {
   System.bool get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Class
PlainMessage Members
Base Implementation in IsFault


IsResponse Property (PlainMessage)

IsResponse Property (PlainMessage)

Noemax.WebSockets.Messaging Namespace > PlainMessage Class : IsResponse Property
Always returns false.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable ReadOnly Property IsResponse As System.Boolean
'Usage

Dim instance As PlainMessage
Dim value As System.Boolean

value = instance.IsResponse
public override System.bool IsResponse {get;}
public read-only property IsResponse: System.Boolean; override;
public override function get IsResponse : System.boolean
public: __property System.bool get_IsResponse() override;
public:
property System.bool IsResponse {
   System.bool get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Class
PlainMessage Members
Base Implementation in IsResponse


Msg Property (PlainMessage)

Msg Property (PlainMessage)

Noemax.WebSockets.Messaging Namespace > PlainMessage Class : Msg Property
Serialize property to store the body of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataMemberAttribute()>
Public Property Msg As System.Object
'Usage

Dim instance As PlainMessage
Dim value As System.Object

instance.Msg = value

value = instance.Msg
[System.Runtime.Serialization.DataMember()]
public System.object Msg {get; set;}
public read-write property Msg: System.TObject;
System.Runtime.Serialization.DataMemberAttribute()
public function get,set Msg : System.Object
[System.Runtime.Serialization.DataMember()]
public: __property System.Object* get_Msg();
public: __property void set_Msg(
   System.Object* value
);
[System.Runtime.Serialization.DataMember()]
public:
property System.Object^ Msg {
   System.Object^ get();
   void set (    System.Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PlainMessage Class
PlainMessage Members


ReflectionInvoker Class

ReflectionInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : ReflectionInvoker Class
Provides invoker for calling the message operation that multiple parameters.
Object Model
ReflectionInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ReflectionInvoker
   Inherits RequestInvoker
'Usage

Dim instance As ReflectionInvoker
public class ReflectionInvoker : RequestInvoker
public class ReflectionInvoker = class(RequestInvoker)
public class ReflectionInvoker extends RequestInvoker
public __gc class ReflectionInvoker : public RequestInvoker
public ref class ReflectionInvoker : public RequestInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ReflectionInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionInvoker Members
Noemax.WebSockets.Messaging Namespace


ReflectionInvoker Class Members

ReflectionInvoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : ReflectionInvoker Class

The following tables list the members exposed by ReflectionInvoker.

Public Constructors
 | Name | Description
Public Constructor | ReflectionInvoker Constructor | Initializes a new instance of ReflectionInvoker.
Top
Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets types of parameters accepted by the target method.
Public Property | KnownTypes | Overridden. Returns the total list of the types that DefaultSerializer should be able to serialize/deserialize in order to handle the message to the operation.
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overridden. Invokes the target method.
Top
See Also

Reference

ReflectionInvoker Class
Noemax.WebSockets.Messaging Namespace


ReflectionInvoker Constructor

ReflectionInvoker Constructor

Noemax.WebSockets.Messaging Namespace > ReflectionInvoker Class : ReflectionInvoker Constructor
The description of the target method.
The instance of the object providing the target method.
Initializes a new instance of ReflectionInvoker.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
)
'Usage

Dim info As System.Reflection.MethodInfo
Dim instance As System.Object

Dim instance As New ReflectionInvoker(info, instance)
public ReflectionInvoker(
   System.Reflection.MethodInfo info,
   System.object instance
)
public ReflectionInvoker(
    info: System.Reflection.MethodInfo;
    instance: System.TObject
);
public function ReflectionInvoker(
   info : System.Reflection.MethodInfo,
   instance : System.Object
);
public: ReflectionInvoker(
   System.Reflection.MethodInfo* info,
   System.Object* instance
)
public:
ReflectionInvoker(
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
)

Parameters

info
The description of the target method.
instance
The instance of the object providing the target method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionInvoker Class
ReflectionInvoker Members


ReflectionInvoker Class Methods

ReflectionInvoker Class Methods

Noemax.WebSockets.Messaging Namespace : ReflectionInvoker Class

For a list of all members of this type, see ReflectionInvoker members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overridden. Invokes the target method.
Top
See Also

Reference

ReflectionInvoker Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (ReflectionInvoker)

OnInvoke Method (ReflectionInvoker)

Noemax.WebSockets.Messaging Namespace > ReflectionInvoker Class : OnInvoke Method
The message containing the parameters to invoke the target message.
The channel through which the mesasge was received.
Invokes the target method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function OnInvoke( _
   ByVal requestMessage As ConversationMessage, _
   ByVal channel As WebSocketChannel _
) As ConversationMessage
'Usage

Dim instance As ReflectionInvoker
Dim requestMessage As ConversationMessage
Dim channel As WebSocketChannel
Dim value As ConversationMessage

value = instance.OnInvoke(requestMessage, channel)
protected override ConversationMessage OnInvoke(
   ConversationMessage requestMessage,
   WebSocketChannel channel
)
protected function OnInvoke(
    requestMessage: ConversationMessage;
    channel: WebSocketChannel
): ConversationMessage; override;
protected override function OnInvoke(
   requestMessage : ConversationMessage,
   channel : WebSocketChannel
) : ConversationMessage;
protected: ConversationMessage* OnInvoke(
   ConversationMessage* requestMessage,
   WebSocketChannel* channel
) override
protected:
ConversationMessage^ OnInvoke(
   ConversationMessage^ requestMessage,
   WebSocketChannel^ channel
) override

Parameters

requestMessage
The message containing the parameters to invoke the target message.
channel
The channel through which the mesasge was received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionInvoker Class
ReflectionInvoker Members
Base Implementation in OnInvoke


ReflectionInvoker Class Properties

ReflectionInvoker Class Properties

Noemax.WebSockets.Messaging Namespace : ReflectionInvoker Class

For a list of all members of this type, see ReflectionInvoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden. Gets types of parameters accepted by the target method.
Public Property | KnownTypes | Overridden. Returns the total list of the types that DefaultSerializer should be able to serialize/deserialize in order to handle the message to the operation.
Top
See Also

Reference

ReflectionInvoker Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (ReflectionInvoker)

InputTypes Property (ReflectionInvoker)

Noemax.WebSockets.Messaging Namespace > ReflectionInvoker Class : InputTypes Property
Gets types of parameters accepted by the target method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As ReflectionInvoker
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionInvoker Class
ReflectionInvoker Members
Base Implementation in InputTypes


KnownTypes Property (ReflectionInvoker)

KnownTypes Property (ReflectionInvoker)

Noemax.WebSockets.Messaging Namespace > ReflectionInvoker Class : KnownTypes Property
Returns the total list of the types that DefaultSerializer should be able to serialize/deserialize in order to handle the message to the operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property KnownTypes As System.Collections.Generic.IEnumerable(Of Type)
'Usage

Dim instance As ReflectionInvoker
Dim value As System.Collections.Generic.IEnumerable(Of Type)

value = instance.KnownTypes
public override System.Collections.Generic.IEnumerable<Type> KnownTypes {get;}
public read-only property KnownTypes: System.Collections.Generic.IEnumerable; override;
public override function get KnownTypes : System.Collections.Generic.IEnumerable
public: __property System.Collections.Generic.IEnumerable<Type*>* get_KnownTypes() override;
public:
property System.Collections.Generic.IEnumerable<Type^>^ KnownTypes {
   System.Collections.Generic.IEnumerable<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReflectionInvoker Class
ReflectionInvoker Members
Base Implementation in KnownTypes


RequestInvoker Class

RequestInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : RequestInvoker Class
Object Model
RequestInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public MustInherit Class RequestInvoker
   Inherits Invoker
'Usage

Dim instance As RequestInvoker
public abstract class RequestInvoker : Invoker
public class RequestInvoker = class(Invoker)abstract;
public abstract class RequestInvoker extends Invoker
public __gc abstract class RequestInvoker : public Invoker
public ref class RequestInvoker abstract : public Invoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.ReflectionInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInvoker Members
Noemax.WebSockets.Messaging Namespace


RequestInvoker Class Members

RequestInvoker Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : RequestInvoker Class

The following tables list the members exposed by RequestInvoker.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | When override invokes the associated operation using the parameters recieved with the message.
Top
See Also

Reference

RequestInvoker Class
Noemax.WebSockets.Messaging Namespace


RequestInvoker Class Methods

RequestInvoker Class Methods

Noemax.WebSockets.Messaging Namespace : RequestInvoker Class

For a list of all members of this type, see RequestInvoker members.

Public Methods
 | Name | Description
Public Method | Invoke | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | When override invokes the associated operation using the parameters recieved with the message.
Top
See Also

Reference

RequestInvoker Class
Noemax.WebSockets.Messaging Namespace


Invoke Method (RequestInvoker)

Invoke Method (RequestInvoker)

Noemax.WebSockets.Messaging Namespace > RequestInvoker Class : Invoke Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub Invoke( _
   ByVal message As EnvelopedMessage, _
   ByVal channel As WebSocketChannel, _
   ByVal serializer As IMessageSerializer _
)
'Usage

Dim instance As RequestInvoker
Dim message As EnvelopedMessage
Dim channel As WebSocketChannel
Dim serializer As IMessageSerializer

instance.Invoke(message, channel, serializer)
public override void Invoke(
   EnvelopedMessage message,
   WebSocketChannel channel,
   IMessageSerializer serializer
)
public procedure Invoke(
    message: EnvelopedMessage;
    channel: WebSocketChannel;
    serializer: IMessageSerializer
); override;
public override function Invoke(
   message : EnvelopedMessage,
   channel : WebSocketChannel,
   serializer : IMessageSerializer
);
public: void Invoke(
   EnvelopedMessage* message,
   WebSocketChannel* channel,
   IMessageSerializer* serializer
) override
public:
void Invoke(
   EnvelopedMessage^ message,
   WebSocketChannel^ channel,
   IMessageSerializer^ serializer
) override

Parameters

message
channel
serializer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInvoker Class
RequestInvoker Members
Base Implementation in Invoke


OnInvoke Method (RequestInvoker)

OnInvoke Method (RequestInvoker)

Noemax.WebSockets.Messaging Namespace > RequestInvoker Class : OnInvoke Method
The message containing the parameters for invocation.
The channel through which the message was received.
When override invokes the associated operation using the parameters recieved with the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected MustOverride Function OnInvoke( _
   ByVal message As ConversationMessage, _
   ByVal channel As WebSocketChannel _
) As ConversationMessage
'Usage

Dim instance As RequestInvoker
Dim message As ConversationMessage
Dim channel As WebSocketChannel
Dim value As ConversationMessage

value = instance.OnInvoke(message, channel)
protected abstract ConversationMessage OnInvoke(
   ConversationMessage message,
   WebSocketChannel channel
)
protected function OnInvoke(
    message: ConversationMessage;
    channel: WebSocketChannel
): ConversationMessage; abstract;
protected __abstract function OnInvoke(
   message : ConversationMessage,
   channel : WebSocketChannel
) : ConversationMessage;
protected: abstract ConversationMessage* OnInvoke(
   ConversationMessage* message,
   WebSocketChannel* channel
)
protected:
abstract ConversationMessage^ OnInvoke(
   ConversationMessage^ message,
   WebSocketChannel^ channel
)

Parameters

message
The message containing the parameters for invocation.
channel
The channel through which the message was received.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RequestInvoker Class
RequestInvoker Members


RpcFaultException Class

RpcFaultException Class
Members

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class
The exception providing a FaultInfo.
Object Model
RpcFaultException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RpcFaultException
   Inherits System.Exception
'Usage

Dim instance As RpcFaultException
public class RpcFaultException : System.Exception
public class RpcFaultException = class(System.Exception)
public class RpcFaultException extends System.Exception
public __gc class RpcFaultException : public System.Exception
public ref class RpcFaultException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.Messaging.RpcFaultException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Members
Noemax.WebSockets.Messaging Namespace


RpcFaultException Class Members

RpcFaultException Class Members
Properties Methods Events

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class

The following tables list the members exposed by RpcFaultException.

Public Constructors
 | Name | Description
Public Constructor | RpcFaultException Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | FaultInfo | Gets the information on the fault returned by remote side.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

RpcFaultException Class
Noemax.WebSockets.Messaging Namespace


RpcFaultException Constructor

RpcFaultException Constructor

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : RpcFaultException Constructor
Overload List
Overload | Description
RpcFaultException Constructor(Int32,Object,String) |
RpcFaultException Constructor(FaultInfo) | Initialize a new instance of RpcFaultException from the specified fault description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


RpcFaultException Constructor(Int32,Object,String)

RpcFaultException Constructor(Int32,Object,String)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class > RpcFaultException Constructor : RpcFaultException Constructor(Int32,Object,String)
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal code As System.Integer, _
   ByVal data As System.Object, _
   ByVal message As System.String _
)
'Usage

Dim code As System.Integer
Dim data As System.Object
Dim message As System.String

Dim instance As New RpcFaultException(code, data, message)
public RpcFaultException(
   System.int code,
   System.object data,
   System.string message
)
public RpcFaultException(
    code: System.Integer;
    data: System.TObject;
    message: System.String
);
public function RpcFaultException(
   code : System.int,
   data : System.Object,
   message : System.String
);
public: RpcFaultException(
   System.int code,
   System.Object* data,
   System.string* message
)
public:
RpcFaultException(
   System.int code,
   System.Object^ data,
   System.String^ message
)

Parameters

code
data
message
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members
Overload List


RpcFaultException Constructor(FaultInfo)

RpcFaultException Constructor(FaultInfo)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class > RpcFaultException Constructor : RpcFaultException Constructor(FaultInfo)
The fault description.
Initialize a new instance of RpcFaultException from the specified fault description.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal info As FaultInfo _
)
'Usage

Dim info As FaultInfo

Dim instance As New RpcFaultException(info)
public RpcFaultException(
   FaultInfo info
)
public RpcFaultException(
    info: FaultInfo
);
public function RpcFaultException(
   info : FaultInfo
);
public: RpcFaultException(
   FaultInfo info
)
public:
RpcFaultException(
   FaultInfo info
)

Parameters

info
The fault description.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members
Overload List


RpcFaultException Class Properties

RpcFaultException Class Properties

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class

For a list of all members of this type, see RpcFaultException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | FaultInfo | Gets the information on the fault returned by remote side.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

RpcFaultException Class
Noemax.WebSockets.Messaging Namespace


FaultInfo Property (RpcFaultException)

FaultInfo Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : FaultInfo Property
Gets the information on the fault returned by remote side.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property FaultInfo As FaultInfo
'Usage

Dim instance As RpcFaultException
Dim value As FaultInfo

value = instance.FaultInfo
public FaultInfo FaultInfo {get;}
public read-only property FaultInfo: FaultInfo;
public function get FaultInfo : FaultInfo
public: __property FaultInfo get_FaultInfo();
public:
property FaultInfo FaultInfo {
   FaultInfo get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


VoidInputInvoker<TResult> Class

VoidInputInvoker<TResult> Class
Members

Noemax.WebSockets.Messaging Namespace : VoidInputInvoker<TResult> Class
The type of the data returned by the function.
Provides invoker for calling functions that does not take parameters.
Object Model
VoidInputInvoker<TResult> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public MustInherit Class VoidInputInvoker(Of TResult)
   Inherits RequestInvoker
'Usage

Dim instance As VoidInputInvoker(Of TResult)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public abstract class VoidInputInvoker<TResult> : RequestInvoker
public class VoidInputInvoker = class(RequestInvoker)abstract;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc abstract class VoidInputInvoker<TResult> : public RequestInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename TResult>
public ref class VoidInputInvoker abstract : public RequestInvoker
Type Parameters
TResult
The type of the data returned by the function.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker1<TResult>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvoker<TResult> Members
Noemax.WebSockets.Messaging Namespace


VoidInputInvoker<TResult> Class Members

VoidInputInvoker<TResult> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : VoidInputInvoker<TResult> Class

The following tables list the members exposed by VoidInputInvoker<TResult>.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


VoidInputInvoker<TResult> Class Methods

VoidInputInvoker<TResult> Class Methods

Noemax.WebSockets.Messaging Namespace : VoidInputInvoker<TResult> Class

For a list of all members of this type, see VoidInputInvoker<TResult> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (VoidInputInvoker<TResult>)

OnInvoke Method (VoidInputInvoker<TResult>)

Noemax.WebSockets.Messaging Namespace > VoidInputInvoker<TResult> Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(ConversationMessage,WebSocketChannel) |
OnInvoke(WebSocketChannel) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvoker<TResult> Class
VoidInputInvoker<TResult> Members
Base Implementation in OnInvoke


OnInvoke(ConversationMessage,WebSocketChannel) Method

OnInvoke(ConversationMessage,WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > VoidInputInvoker<TResult> Class > OnInvoke Method : OnInvoke(ConversationMessage,WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function OnInvoke( _
   ByVal requestMessage As ConversationMessage, _
   ByVal channel As WebSocketChannel _
) As ConversationMessage
'Usage

Dim instance As VoidInputInvoker(Of TResult)
Dim requestMessage As ConversationMessage
Dim channel As WebSocketChannel
Dim value As ConversationMessage

value = instance.OnInvoke(requestMessage, channel)
protected override ConversationMessage OnInvoke(
   ConversationMessage requestMessage,
   WebSocketChannel channel
)
protected function OnInvoke(
    requestMessage: ConversationMessage;
    channel: WebSocketChannel
): ConversationMessage; override;
protected override function OnInvoke(
   requestMessage : ConversationMessage,
   channel : WebSocketChannel
) : ConversationMessage;
protected: ConversationMessage* OnInvoke(
   ConversationMessage* requestMessage,
   WebSocketChannel* channel
) override
protected:
ConversationMessage^ OnInvoke(
   ConversationMessage^ requestMessage,
   WebSocketChannel^ channel
) override

Parameters

requestMessage
channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvoker<TResult> Class
VoidInputInvoker<TResult> Members
Overload List
Base Implementation in OnInvoke


OnInvoke(WebSocketChannel) Method

OnInvoke(WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > VoidInputInvoker<TResult> Class > OnInvoke Method : OnInvoke(WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads MustOverride Function OnInvoke( _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As VoidInputInvoker(Of TResult)
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(channel)
protected abstract TResult OnInvoke(
   WebSocketChannel channel
)
protected function OnInvoke(
    channel: WebSocketChannel
): TResult; abstract;
protected __abstract function OnInvoke(
   channel : WebSocketChannel
) : TResult;
protected: abstract TResult* OnInvoke(
   WebSocketChannel* channel
)
protected:
abstract TResult^ OnInvoke(
   WebSocketChannel^ channel
)

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvoker<TResult> Class
VoidInputInvoker<TResult> Members
Overload List


VoidInputInvoker<TResult> Class Properties

VoidInputInvoker<TResult> Class Properties

Noemax.WebSockets.Messaging Namespace : VoidInputInvoker<TResult> Class

For a list of all members of this type, see VoidInputInvoker<TResult> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Overridden.
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

VoidInputInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


InputTypes Property (VoidInputInvoker<TResult>)

InputTypes Property (VoidInputInvoker<TResult>)

Noemax.WebSockets.Messaging Namespace > VoidInputInvoker<TResult> Class : InputTypes Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property InputTypes As System.Type()
'Usage

Dim instance As VoidInputInvoker(Of TResult)
Dim value() As System.Type

value = instance.InputTypes
public override System.Type[] InputTypes {get;}
public read-only property InputTypes: System.array of Type; override;
public override function get InputTypes : System.Type[]
public: __property System.Type*[]* get_InputTypes() override;
public:
property System.array<Type^>^ InputTypes {
   System.array<Type^>^ get() override;
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvoker<TResult> Class
VoidInputInvoker<TResult> Members
Base Implementation in InputTypes


VoidInputInvokerFactory Class

VoidInputInvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : VoidInputInvokerFactory Class
Provides VoidInputInvoker<TResult> invokers./>
Object Model
VoidInputInvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class VoidInputInvokerFactory
   Inherits InvokerFactory
'Usage

Dim instance As VoidInputInvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class VoidInputInvokerFactory : InvokerFactory
public class VoidInputInvokerFactory = class(InvokerFactory)sealed;
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public sealed class VoidInputInvokerFactory extends InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class VoidInputInvokerFactory : public InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public ref class VoidInputInvokerFactory sealed : public InvokerFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.VoidInputInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvokerFactory Members
Noemax.WebSockets.Messaging Namespace


VoidInputInvokerFactory Class Members

VoidInputInvokerFactory Class Members
Methods

Noemax.WebSockets.Messaging Namespace : VoidInputInvokerFactory Class

The following tables list the members exposed by VoidInputInvokerFactory.

Public Constructors
 | Name | Description
Public Constructor | VoidInputInvokerFactory Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Returns true if target method is suitable for VoidInputInvoker<TResult>.
Public Method | CreateInvoker | Overridden. Creates an VoidInputInvoker<TResult> for the specified method.
Top
See Also

Reference

VoidInputInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


VoidInputInvokerFactory Constructor

VoidInputInvokerFactory Constructor

Noemax.WebSockets.Messaging Namespace > VoidInputInvokerFactory Class : VoidInputInvokerFactory Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New VoidInputInvokerFactory()
public VoidInputInvokerFactory()
public VoidInputInvokerFactory();
public function VoidInputInvokerFactory();
public: VoidInputInvokerFactory();
public:
VoidInputInvokerFactory();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvokerFactory Class
VoidInputInvokerFactory Members


VoidInputInvokerFactory Class Methods

VoidInputInvokerFactory Class Methods

Noemax.WebSockets.Messaging Namespace : VoidInputInvokerFactory Class

For a list of all members of this type, see VoidInputInvokerFactory members.

Public Methods
 | Name | Description
Public Method | CanCreateInvoker | Overridden. Returns true if target method is suitable for VoidInputInvoker<TResult>.
Public Method | CreateInvoker | Overridden. Creates an VoidInputInvoker<TResult> for the specified method.
Top
See Also

Reference

VoidInputInvokerFactory Class
Noemax.WebSockets.Messaging Namespace


CanCreateInvoker Method (VoidInputInvokerFactory)

CanCreateInvoker Method (VoidInputInvokerFactory)

Noemax.WebSockets.Messaging Namespace > VoidInputInvokerFactory Class : CanCreateInvoker Method
The method to evaluated for suitability.
Returns true if target method is suitable for VoidInputInvoker<TResult>.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function CanCreateInvoker( _
   ByVal methodInfo As System.Reflection.MethodInfo _
) As System.Boolean
'Usage

Dim instance As VoidInputInvokerFactory
Dim methodInfo As System.Reflection.MethodInfo
Dim value As System.Boolean

value = instance.CanCreateInvoker(methodInfo)
public override System.bool CanCreateInvoker(
   System.Reflection.MethodInfo methodInfo
)
public function CanCreateInvoker(
    methodInfo: System.Reflection.MethodInfo
): System.Boolean; override;
public override function CanCreateInvoker(
   methodInfo : System.Reflection.MethodInfo
) : System.boolean;
public: System.bool CanCreateInvoker(
   System.Reflection.MethodInfo* methodInfo
) override
public:
System.bool CanCreateInvoker(
   System.Reflection.MethodInfo^ methodInfo
) override

Parameters

methodInfo
The method to evaluated for suitability.

Return Value

True if target method is suitable for VoidInputInvoker<TResult>; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvokerFactory Class
VoidInputInvokerFactory Members
Base Implementation in CanCreateInvoker


CreateInvoker Method (VoidInputInvokerFactory)

CreateInvoker Method (VoidInputInvokerFactory)

Noemax.WebSockets.Messaging Namespace > VoidInputInvokerFactory Class : CreateInvoker Method
The method for which invoker is to be created.
The instance of the class providing the method.
Creates an VoidInputInvoker<TResult> for the specified method.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides NotOverridable Function CreateInvoker( _
   ByVal info As System.Reflection.MethodInfo, _
   ByVal instance As System.Object _
) As Invoker
'Usage

Dim instance As VoidInputInvokerFactory
Dim info As System.Reflection.MethodInfo
Dim instance As System.Object
Dim value As Invoker

value = instance.CreateInvoker(info, instance)
public override Invoker CreateInvoker(
   System.Reflection.MethodInfo info,
   System.object instance
)
public function CreateInvoker(
    info: System.Reflection.MethodInfo;
    instance: System.TObject
): Invoker; override;
public override function CreateInvoker(
   info : System.Reflection.MethodInfo,
   instance : System.Object
) : Invoker;
public: Invoker* CreateInvoker(
   System.Reflection.MethodInfo* info,
   System.Object* instance
) override
public:
Invoker^ CreateInvoker(
   System.Reflection.MethodInfo^ info,
   System.Object^ instance
) override

Parameters

info
The method for which invoker is to be created.
instance
The instance of the class providing the method.

Return Value

The instance of invoker associated to the specified method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputInvokerFactory Class
VoidInputInvokerFactory Members
Base Implementation in CreateInvoker


VoidInputOperationInvoker<TResult> Class

VoidInputOperationInvoker<TResult> Class
Members

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker<TResult> Class
Object Model
VoidInputOperationInvoker<TResult> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class VoidInputOperationInvoker(Of TResult)
   Inherits VoidInputInvoker(Of TResult)
'Usage

Dim instance As VoidInputOperationInvoker(Of TResult)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class VoidInputOperationInvoker<TResult> : VoidInputInvoker<TResult>
public class VoidInputOperationInvoker = class(VoidInputInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class VoidInputOperationInvoker<TResult> : public VoidInputInvoker<TResult>
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename TResult>
public ref class VoidInputOperationInvoker sealed : public VoidInputInvoker<TResult>
Type Parameters
TResult
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker<TResult>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker<TResult> Members
Noemax.WebSockets.Messaging Namespace


VoidInputOperationInvoker<TResult> Class Members

VoidInputOperationInvoker<TResult> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker<TResult> Class

The following tables list the members exposed by VoidInputOperationInvoker<TResult>.

Public Constructors
 | Name | Description
Public Constructor | VoidInputOperationInvoker<TResult> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputOperationInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


VoidInputOperationInvoker<TResult> Constructor

VoidInputOperationInvoker<TResult> Constructor

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker<TResult> Class : VoidInputOperationInvoker<TResult> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As Noemax.WebSockets.Messaging.VoidInputOperation(Of TResult) _
)
'Usage

Dim func As Noemax.WebSockets.Messaging.VoidInputOperation(Of TResult)

Dim instance As New VoidInputOperationInvoker(Of TResult)(func)
public VoidInputOperationInvoker<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation<TResult> func
)
public VoidInputOperationInvoker<TResult>(
    func: Noemax.WebSockets.Messaging.VoidInputOperation
);
public function VoidInputOperationInvoker<TResult>(
   func : Noemax.WebSockets.Messaging.VoidInputOperation
);
public: VoidInputOperationInvoker<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation<TResult*>* func
)
public:
VoidInputOperationInvoker<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation<TResult^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker<TResult> Class
VoidInputOperationInvoker<TResult> Members


VoidInputOperationInvoker<TResult> Class Methods

VoidInputOperationInvoker<TResult> Class Methods

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker<TResult> Class

For a list of all members of this type, see VoidInputOperationInvoker<TResult> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputOperationInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (VoidInputOperationInvoker<TResult>)

OnInvoke Method (VoidInputOperationInvoker<TResult>)

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker<TResult> Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker<TResult> Class
VoidInputOperationInvoker<TResult> Members
Base Implementation in OnInvoke


OnInvoke(WebSocketChannel) Method

OnInvoke(WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker<TResult> Class > OnInvoke Method : OnInvoke(WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Function OnInvoke( _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As VoidInputOperationInvoker(Of TResult)
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(channel)
protected override TResult OnInvoke(
   WebSocketChannel channel
)
protected function OnInvoke(
    channel: WebSocketChannel
): TResult; override;
protected override function OnInvoke(
   channel : WebSocketChannel
) : TResult;
protected: TResult* OnInvoke(
   WebSocketChannel* channel
) override
protected:
TResult^ OnInvoke(
   WebSocketChannel^ channel
) override

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker<TResult> Class
VoidInputOperationInvoker<TResult> Members
Overload List
Base Implementation in OnInvoke(WebSocketChannel)


VoidInputOperationInvoker1<TResult> Class

VoidInputOperationInvoker1<TResult> Class
Members

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker1<TResult> Class
Object Model
VoidInputOperationInvoker1<TResult> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class VoidInputOperationInvoker1(Of TResult)
   Inherits VoidInputInvoker(Of TResult)
'Usage

Dim instance As VoidInputOperationInvoker1(Of TResult)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class VoidInputOperationInvoker1<TResult> : VoidInputInvoker<TResult>
public class VoidInputOperationInvoker1 = class(VoidInputInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class VoidInputOperationInvoker1<TResult> : public VoidInputInvoker<TResult>
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename TResult>
public ref class VoidInputOperationInvoker1 sealed : public VoidInputInvoker<TResult>
Type Parameters
TResult
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker1<TResult>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker1<TResult> Members
Noemax.WebSockets.Messaging Namespace


VoidInputOperationInvoker1<TResult> Class Members

VoidInputOperationInvoker1<TResult> Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker1<TResult> Class

The following tables list the members exposed by VoidInputOperationInvoker1<TResult>.

Public Constructors
 | Name | Description
Public Constructor | VoidInputOperationInvoker1<TResult> Constructor |
Top
Public Properties
 | Name | Description
Public Property | InputTypes | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputOperationInvoker1<TResult> Class
Noemax.WebSockets.Messaging Namespace


VoidInputOperationInvoker1<TResult> Constructor

VoidInputOperationInvoker1<TResult> Constructor

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker1<TResult> Class : VoidInputOperationInvoker1<TResult> Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal func As Noemax.WebSockets.Messaging.VoidInputOperation1(Of TResult) _
)
'Usage

Dim func As Noemax.WebSockets.Messaging.VoidInputOperation1(Of TResult)

Dim instance As New VoidInputOperationInvoker1(Of TResult)(func)
public VoidInputOperationInvoker1<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation1<TResult> func
)
public VoidInputOperationInvoker1<TResult>(
    func: Noemax.WebSockets.Messaging.VoidInputOperation1
);
public function VoidInputOperationInvoker1<TResult>(
   func : Noemax.WebSockets.Messaging.VoidInputOperation1
);
public: VoidInputOperationInvoker1<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation1<TResult*>* func
)
public:
VoidInputOperationInvoker1<TResult>(
   Noemax.WebSockets.Messaging.VoidInputOperation1<TResult^>^ func
)

Parameters

func
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker1<TResult> Class
VoidInputOperationInvoker1<TResult> Members


VoidInputOperationInvoker1<TResult> Class Methods

VoidInputOperationInvoker1<TResult> Class Methods

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker1<TResult> Class

For a list of all members of this type, see VoidInputOperationInvoker1<TResult> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Overridden.
Top
See Also

Reference

VoidInputOperationInvoker1<TResult> Class
Noemax.WebSockets.Messaging Namespace


OnInvoke Method (VoidInputOperationInvoker1<TResult>)

OnInvoke Method (VoidInputOperationInvoker1<TResult>)

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker1<TResult> Class : OnInvoke Method
Overload List
Overload | Description
OnInvoke(WebSocketChannel) |
OnInvoke(ConversationMessage,WebSocketChannel) | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker1<TResult> Class
VoidInputOperationInvoker1<TResult> Members
Base Implementation in OnInvoke


OnInvoke(WebSocketChannel) Method

OnInvoke(WebSocketChannel) Method

Noemax.WebSockets.Messaging Namespace > VoidInputOperationInvoker1<TResult> Class > OnInvoke Method : OnInvoke(WebSocketChannel) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides NotOverridable Function OnInvoke( _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As VoidInputOperationInvoker1(Of TResult)
Dim channel As WebSocketChannel
Dim value As TResult

value = instance.OnInvoke(channel)
protected override TResult OnInvoke(
   WebSocketChannel channel
)
protected function OnInvoke(
    channel: WebSocketChannel
): TResult; override;
protected override function OnInvoke(
   channel : WebSocketChannel
) : TResult;
protected: TResult* OnInvoke(
   WebSocketChannel* channel
) override
protected:
TResult^ OnInvoke(
   WebSocketChannel^ channel
) override

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperationInvoker1<TResult> Class
VoidInputOperationInvoker1<TResult> Members
Overload List
Base Implementation in OnInvoke(WebSocketChannel)


WebSocketChannelExtensions Class

WebSocketChannelExtensions Class
Members

Noemax.WebSockets.Messaging Namespace : WebSocketChannelExtensions Class
Provides extension methods for WebSocketChannel class.
Object Model
WebSocketChannelExtensions Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public MustInherit NotInheritable Class WebSocketChannelExtensions
'Usage

Dim instance As WebSocketChannelExtensions
[System.Runtime.CompilerServices.Extension()]
public static class WebSocketChannelExtensions
public class WebSocketChannelExtensions abstract; sealed;
System.Runtime.CompilerServices.ExtensionAttribute()
public abstract sealed class WebSocketChannelExtensions
[System.Runtime.CompilerServices.Extension()]
public __gc abstract __sealed class WebSocketChannelExtensions
[System.Runtime.CompilerServices.Extension()]
public ref class WebSocketChannelExtensions abstract sealed
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.WebSocketChannelExtensions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Members
Noemax.WebSockets.Messaging Namespace


WebSocketChannelExtensions Class Members

WebSocketChannelExtensions Class Members
Methods

Noemax.WebSockets.Messaging Namespace : WebSocketChannelExtensions Class

The following tables list the members exposed by WebSocketChannelExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage | Overloaded. Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestStream | Overloaded. Sends the request message and receives a stream as response.
static (Shared in Visual Basic) | RequestWithStream | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | SendMessage | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendMessageAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendOneWay | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendOneWayAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendWithStream | Overloaded. Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Top
See Also

Reference

WebSocketChannelExtensions Class
Noemax.WebSockets.Messaging Namespace


WebSocketChannelExtensions Class Methods

WebSocketChannelExtensions Class Methods

Noemax.WebSockets.Messaging Namespace : WebSocketChannelExtensions Class

For a list of all members of this type, see WebSocketChannelExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage | Overloaded. Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestStream | Overloaded. Sends the request message and receives a stream as response.
static (Shared in Visual Basic) | RequestWithStream | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | SendMessage | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendMessageAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendOneWay | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendOneWayAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendWithStream | Overloaded. Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Top
See Also

Reference

WebSocketChannelExtensions Class
Noemax.WebSockets.Messaging Namespace


CreateStreamedMessage Method (WebSocketChannelExtensions)

CreateStreamedMessage Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : CreateStreamedMessage Method
Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
Overload List
Overload | Description
CreateStreamedMessage(WebSocketChannel,String,TimeSpan,Object[]) | Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
CreateStreamedMessage(WebSocketChannel,String,Object[]) | Initiates outbound one-way messages with parameters and binary stream of arbitrary length as continuation of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


CreateStreamedMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

CreateStreamedMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > CreateStreamedMessage Method : CreateStreamedMessage(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which to send the message.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function CreateStreamedMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
) As System.IO.Stream
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object
Dim value As System.IO.Stream

value = WebSocketChannelExtensions.CreateStreamedMessage(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.IO.Stream CreateStreamedMessage(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public function CreateStreamedMessage(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
): System.IO.Stream; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function CreateStreamedMessage(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
) : System.IO.Stream;
[System.Runtime.CompilerServices.Extension()]
public: static System.IO.Stream* CreateStreamedMessage(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.IO.Stream^ CreateStreamedMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which to send the message.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.

Return Value

The stream to continue writing the streamed part of the message.
Remarks

The stream sent using this method is received by the remote operation a the last parameter or the single parameter in the method signature.

The stream returned by this method writes the continuation of the message performing automating fragmentation of the data you write into the stream. Closing the stream, results in sending the final frame of the message.

You can send a stream of arbitrary length without any maximum length limitation. However, while message is being streamed no other messages can be sent through the same WebSocket channel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


CreateStreamedMessage(WebSocketChannel,String,Object[]) Method

CreateStreamedMessage(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > CreateStreamedMessage Method : CreateStreamedMessage(WebSocketChannel,String,Object[]) Method
The channel through which to send the message.
The action associate with the remote operation to invoke.
The parameters to send to the remote operation.
Initiates outbound one-way messages with parameters and binary stream of arbitrary length as continuation of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function CreateStreamedMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
) As System.IO.Stream
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object
Dim value As System.IO.Stream

value = WebSocketChannelExtensions.CreateStreamedMessage(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.IO.Stream CreateStreamedMessage(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public function CreateStreamedMessage(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
): System.IO.Stream; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function CreateStreamedMessage(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
) : System.IO.Stream;
[System.Runtime.CompilerServices.Extension()]
public: static System.IO.Stream* CreateStreamedMessage(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.IO.Stream^ CreateStreamedMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which to send the message.
action
The action associate with the remote operation to invoke.
parameters
The parameters to send to the remote operation.

Return Value

The input to continue writing the streamed part of the message.
Remarks

The stream sent using this method is received by the remote operation a the last parameter or the single parameter in the method signature.

The stream returned by this method writes the continuation of the message performing automating fragmentation of the data you write into the stream. Closing the stream, results in sending the final frame of the message.

You can send a stream of arbitrary length without any maximum length limitation. However, while message is being streamed no other messages can be sent through the same WebSocket channel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request Method (WebSocketChannelExtensions)

Request Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : Request Method
Sends the request and receives response from to the remote operation.
Overload List
Overload | Description
Request<TResult>(WebSocketChannel,String,TimeSpan,Object[]) | Sends the request and receives response from to the remote operation.
Request<TResult>(WebSocketChannel,String,Object[]) | Sends the request and receives response from to the remote operation.
Request(WebSocketChannel,String,Object[]) | Sends the request and receives response from to the remote operation.
Request<TResult>(WebSocketChannel,String) | Sends the request and receives response from to the remote operation.
Request<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) | Sends the request and receives response from to the remote operation.
Request<TResult,TRequest>(WebSocketChannel,String,TRequest) | Sends the request and receives response from to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


Request<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method

Request<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object
Dim value As TResult

value = WebSocketChannelExtensions.Request(Of TResult)(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public function Request(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request<TResult>(WebSocketChannel,String,Object[]) Method

Request<TResult>(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request<TResult>(WebSocketChannel,String,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object
Dim value As TResult

value = WebSocketChannelExtensions.Request(Of TResult)(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TResult>(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public function Request(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request(WebSocketChannel,String,Object[]) Method

Request(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request(WebSocketChannel,String,Object[]) Method
The channel through which request message will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Request( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.Request(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void Request(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure Request(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void Request(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Request(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request<TResult>(WebSocketChannel,String) Method

Request<TResult>(WebSocketChannel,String) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request<TResult>(WebSocketChannel,String) Method
The type of the result message to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim value As TResult

value = WebSocketChannelExtensions.Request(Of TResult)(channel, action)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TResult>(
   WebSocketChannel channel,
   System.string action
)
public function Request(
    channel: WebSocketChannel;
    action: System.String
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TResult>(
   WebSocketChannel* channel,
   System.string* action
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.

Type Parameters

TResult
The type of the result message to receive from the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method

Request<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method
The type of the result to receive from the remote operation.
The type of the request to send to the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The request object.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TResult,TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal request As TRequest _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim request As TRequest
Dim value As TResult

value = WebSocketChannelExtensions.Request(Of TResult, TRequest)(channel, action, timeout, request)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TResult,TRequest>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   TRequest request
)
public function Request(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    request: TRequest
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   request : TRequest
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TResult,TRequest>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   TRequest* request
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TResult>
generic<typename TRequest>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   TRequest^ request
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
request
The request object.

Type Parameters

TResult
The type of the result to receive from the remote operation.
TRequest
The type of the request to send to the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


Request<TResult,TRequest>(WebSocketChannel,String,TRequest) Method

Request<TResult,TRequest>(WebSocketChannel,String,TRequest) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > Request Method : Request<TResult,TRequest>(WebSocketChannel,String,TRequest) Method
The type of the result to receive from the remote operation.
The type of the request to send to the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TResult,TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameters As TRequest _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters As TRequest
Dim value As TResult

value = WebSocketChannelExtensions.Request(Of TResult, TRequest)(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TResult,TRequest>(
   WebSocketChannel channel,
   System.string action,
   TRequest parameters
)
public function Request(
    channel: WebSocketChannel;
    action: System.String;
    parameters: TRequest
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   action : System.String,
   parameters : TRequest
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TResult,TRequest>(
   WebSocketChannel* channel,
   System.string* action,
   TRequest* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TResult>
generic<typename TRequest>
(
   WebSocketChannel^ channel,
   System.String^ action,
   TRequest^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.
TRequest
The type of the request to send to the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestStream Method (WebSocketChannelExtensions)

RequestStream Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : RequestStream Method
Sends the request message and receives a stream as response.
Overload List
Overload | Description
RequestStream(WebSocketChannel,String,Object[]) | Sends the request message and receives a stream as response.
RequestStream(WebSocketChannel,String,TimeSpan,Object[]) | Sends the request message and receives a stream as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


RequestStream(WebSocketChannel,String,Object[]) Method

RequestStream(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestStream Method : RequestStream(WebSocketChannel,String,Object[]) Method
The channel through which request message will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the request message and receives a stream as response.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
) As System.IO.Stream
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object
Dim value As System.IO.Stream

value = WebSocketChannelExtensions.RequestStream(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.IO.Stream RequestStream(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public function RequestStream(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
): System.IO.Stream; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestStream(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
) : System.IO.Stream;
[System.Runtime.CompilerServices.Extension()]
public: static System.IO.Stream* RequestStream(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.IO.Stream^ RequestStream(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestStream(WebSocketChannel,String,TimeSpan,Object[]) Method

RequestStream(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestStream Method : RequestStream(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the request message will be sent.
The action associated to the remote operation.
The period time for operation to complete or timeout.
The parameters to send to the remote operation.
Sends the request message and receives a stream as response.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
) As System.IO.Stream
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object
Dim value As System.IO.Stream

value = WebSocketChannelExtensions.RequestStream(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.IO.Stream RequestStream(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public function RequestStream(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
): System.IO.Stream; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestStream(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
) : System.IO.Stream;
[System.Runtime.CompilerServices.Extension()]
public: static System.IO.Stream* RequestStream(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.IO.Stream^ RequestStream(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the request message will be sent.
action
The action associated to the remote operation.
timeout
The period time for operation to complete or timeout.
parameters
The parameters to send to the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStream Method (WebSocketChannelExtensions)

RequestWithStream Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : RequestWithStream Method
Sends the request and receives response from to the remote operation.
Overload List
Overload | Description
RequestWithStream<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) | Sends the request and receives response from to the remote operation.
RequestWithStream<TResult>(WebSocketChannel,String,Stream,Object[]) | Sends the request and receives response from to the remote operation.
RequestWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) | Sends the request and receives response from to the remote operation.
RequestWithStream(WebSocketChannel,String,Stream,Object[]) | Sends the request and receives response from to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


RequestWithStream<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

RequestWithStream<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStream Method : RequestWithStream<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestWithStream(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim attachment As System.IO.Stream
Dim parameters() As System.Object
Dim value As TResult

value = WebSocketChannelExtensions.RequestWithStream(Of TResult)(channel, action, timeout, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static TResult RequestWithStream<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public function RequestWithStream(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStream(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   attachment : System.IO.Stream,
   parameters : System.Object[]
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* RequestWithStream<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ RequestWithStreamgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of TResult received as response.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStream<TResult>(WebSocketChannel,String,Stream,Object[]) Method

RequestWithStream<TResult>(WebSocketChannel,String,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStream Method : RequestWithStream<TResult>(WebSocketChannel,String,Stream,Object[]) Method
The type of the response message to receive from remote side.
The channel through which request message will be sent.
The action associated to the remote operation.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestWithStream(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim attachment As System.IO.Stream
Dim parameters() As System.Object
Dim value As TResult

value = WebSocketChannelExtensions.RequestWithStream(Of TResult)(channel, action, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static TResult RequestWithStream<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public function RequestWithStream(
    channel: WebSocketChannel;
    action: System.String;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStream(
   channel : WebSocketChannel,
   action : System.String,
   attachment : System.IO.Stream,
   parameters : System.Object[]
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* RequestWithStream<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ RequestWithStreamgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the response message to receive from remote side.

Return Value

The instance of TResult received as response.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

RequestWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStream Method : RequestWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub RequestWithStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim attachment As System.IO.Stream
Dim parameters() As System.Object

WebSocketChannelExtensions.RequestWithStream(channel, action, timeout, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void RequestWithStream(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public procedure RequestWithStream(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStream(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   attachment : System.IO.Stream,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void RequestWithStream(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void RequestWithStream(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStream(WebSocketChannel,String,Stream,Object[]) Method

RequestWithStream(WebSocketChannel,String,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStream Method : RequestWithStream(WebSocketChannel,String,Stream,Object[]) Method
The channel through which request message will be sent.
The action associated to the remote operation.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub RequestWithStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim attachment As System.IO.Stream
Dim parameters() As System.Object

WebSocketChannelExtensions.RequestWithStream(channel, action, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void RequestWithStream(
   WebSocketChannel channel,
   System.string action,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public procedure RequestWithStream(
    channel: WebSocketChannel;
    action: System.String;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStream(
   channel : WebSocketChannel,
   action : System.String,
   attachment : System.IO.Stream,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void RequestWithStream(
   WebSocketChannel* channel,
   System.string* action,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void RequestWithStream(
   WebSocketChannel^ channel,
   System.String^ action,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage Method (WebSocketChannelExtensions)

SendMessage Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : SendMessage Method
Sends the message with the specified parameters to the remote operation.
Overload List
Overload | Description
SendMessage(WebSocketChannel,String,TimeSpan,Object[]) | Sends the message with the specified parameters to the remote operation.
SendMessage(WebSocketChannel,String,Object[]) | Sends the message with the specified parameters to the remote operation.
SendMessage<T>(WebSocketChannel,String,TimeSpan,T) | Sends the message with the specified parameters to the remote operation.
SendMessage<T>(WebSocketChannel,String,T) | Sends the message with the specified parameters to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
<System.ObsoleteAttribute()>
Public Overloads Shared Sub SendMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessage(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public static void SendMessage(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
System.ObsoleteAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public: static void SendMessage(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public:
static void SendMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage(WebSocketChannel,String,Object[]) Method

SendMessage(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage(WebSocketChannel,String,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
<System.ObsoleteAttribute()>
Public Overloads Shared Sub SendMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessage(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public static void SendMessage(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
System.ObsoleteAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public: static void SendMessage(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public:
static void SendMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage<T>(WebSocketChannel,String,TimeSpan,T) Method

SendMessage<T>(WebSocketChannel,String,TimeSpan,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage<T>(WebSocketChannel,String,TimeSpan,T) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessage(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal parameters As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters As T

WebSocketChannelExtensions.SendMessage(Of T)(channel, action, timeout, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessage<T>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   T parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    parameters: T
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : T
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessage<T>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   T* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessagegeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   T^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage<T>(WebSocketChannel,String,T) Method

SendMessage<T>(WebSocketChannel,String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage<T>(WebSocketChannel,String,T) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessage(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameters As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters As T

WebSocketChannelExtensions.SendMessage(Of T)(channel, action, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessage<T>(
   WebSocketChannel channel,
   System.string action,
   T parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
    parameters: T
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   parameters : T
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessage<T>(
   WebSocketChannel* channel,
   System.string* action,
   T* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessagegeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   T^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessageAsync Method (WebSocketChannelExtensions)

SendMessageAsync Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : SendMessageAsync Method
Sends the message with the specified parameter to the remote operation asynchronously.
Overload List
Overload | Description
SendMessageAsync<T>(WebSocketChannel,String,TimeSpan,T) | Sends the message with the specified parameter to the remote operation asynchronously.
SendMessageAsync(WebSocketChannel,String,TimeSpan,Object[]) | Sends the message with the specified parameter to the remote operation asynchronously.
SendMessageAsync(WebSocketChannel,String,Object[]) | Sends the message with the specified parameter to the remote operation asynchronously.
SendMessageAsync<T>(WebSocketChannel,String,T) | Sends the message with the specified parameter to the remote operation asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


SendMessageAsync<T>(WebSocketChannel,String,TimeSpan,T) Method

SendMessageAsync<T>(WebSocketChannel,String,TimeSpan,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessageAsync Method : SendMessageAsync<T>(WebSocketChannel,String,TimeSpan,T) Method
The type of the object to send.
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessageAsync(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal parameter As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameter As T

WebSocketChannelExtensions.SendMessageAsync(Of T)(channel, action, timeout, parameter)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessageAsync<T>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   T parameter
)
public procedure SendMessageAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    parameter: T
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessageAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameter : T
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessageAsync<T>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   T* parameter
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessageAsyncgeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   T^ parameter
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameter
The object to send.

Type Parameters

T
The type of the object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessageAsync(WebSocketChannel,String,TimeSpan,Object[]) Method

SendMessageAsync(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessageAsync Method : SendMessageAsync(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessageAsync( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessageAsync(channel, action, timeout, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessageAsync(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public procedure SendMessageAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessageAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessageAsync(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessageAsync(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessageAsync(WebSocketChannel,String,Object[]) Method

SendMessageAsync(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessageAsync Method : SendMessageAsync(WebSocketChannel,String,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessageAsync( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessageAsync(channel, action, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessageAsync(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure SendMessageAsync(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessageAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessageAsync(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessageAsync(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessageAsync<T>(WebSocketChannel,String,T) Method

SendMessageAsync<T>(WebSocketChannel,String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessageAsync Method : SendMessageAsync<T>(WebSocketChannel,String,T) Method
The type of the object to send.
The channel through which the object will be sent.
The action associated to the remote operation.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessageAsync(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameter As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameter As T

WebSocketChannelExtensions.SendMessageAsync(Of T)(channel, action, parameter)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessageAsync<T>(
   WebSocketChannel channel,
   System.string action,
   T parameter
)
public procedure SendMessageAsync(
    channel: WebSocketChannel;
    action: System.String;
    parameter: T
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessageAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameter : T
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessageAsync<T>(
   WebSocketChannel* channel,
   System.string* action,
   T* parameter
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessageAsyncgeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   T^ parameter
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameter
The object to send.

Type Parameters

T
The type of the object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWay Method (WebSocketChannelExtensions)

SendOneWay Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : SendOneWay Method
Sends the message with the specified parameters to the remote operation.
Overload List
Overload | Description
SendOneWay(WebSocketChannel,String,TimeSpan,Object[]) | Sends the message with the specified parameters to the remote operation.
SendOneWay(WebSocketChannel,String,Object[]) | Sends the message with the specified parameters to the remote operation.
SendOneWay<T>(WebSocketChannel,String,TimeSpan,T) | Sends the message with the specified parameters to the remote operation.
SendOneWay<T>(WebSocketChannel,String,T) | Sends the message with the specified parameters to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


SendOneWay(WebSocketChannel,String,TimeSpan,Object[]) Method

SendOneWay(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWay Method : SendOneWay(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWay( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object

WebSocketChannelExtensions.SendOneWay(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWay(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public procedure SendOneWay(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWay(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWay(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWay(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWay(WebSocketChannel,String,Object[]) Method

SendOneWay(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWay Method : SendOneWay(WebSocketChannel,String,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWay( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.SendOneWay(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWay(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure SendOneWay(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWay(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWay(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWay(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWay<T>(WebSocketChannel,String,TimeSpan,T) Method

SendOneWay<T>(WebSocketChannel,String,TimeSpan,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWay Method : SendOneWay<T>(WebSocketChannel,String,TimeSpan,T) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWay(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal parameters As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters As T

WebSocketChannelExtensions.SendOneWay(Of T)(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWay<T>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   T parameters
)
public procedure SendOneWay(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    parameters: T
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWay(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : T
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWay<T>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   T* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWaygeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   T^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWay<T>(WebSocketChannel,String,T) Method

SendOneWay<T>(WebSocketChannel,String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWay Method : SendOneWay<T>(WebSocketChannel,String,T) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWay(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameters As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters As T

WebSocketChannelExtensions.SendOneWay(Of T)(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWay<T>(
   WebSocketChannel channel,
   System.string action,
   T parameters
)
public procedure SendOneWay(
    channel: WebSocketChannel;
    action: System.String;
    parameters: T
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWay(
   channel : WebSocketChannel,
   action : System.String,
   parameters : T
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWay<T>(
   WebSocketChannel* channel,
   System.string* action,
   T* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWaygeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   T^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWayAsync Method (WebSocketChannelExtensions)

SendOneWayAsync Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : SendOneWayAsync Method
Sends the message with the specified parameter to the remote operation asynchronously.
Overload List
Overload | Description
SendOneWayAsync<T>(WebSocketChannel,String,TimeSpan,T) | Sends the message with the specified parameter to the remote operation asynchronously.
SendOneWayAsync(WebSocketChannel,String,TimeSpan,Object[]) | Sends the message with the specified parameter to the remote operation asynchronously.
SendOneWayAsync(WebSocketChannel,String,Object[]) | Sends the message with the specified parameter to the remote operation asynchronously.
SendOneWayAsync<T>(WebSocketChannel,String,T) | Sends the message with the specified parameter to the remote operation asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


SendOneWayAsync<T>(WebSocketChannel,String,TimeSpan,T) Method

SendOneWayAsync<T>(WebSocketChannel,String,TimeSpan,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWayAsync Method : SendOneWayAsync<T>(WebSocketChannel,String,TimeSpan,T) Method
The type of the object to send.
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWayAsync(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal parameter As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameter As T

WebSocketChannelExtensions.SendOneWayAsync(Of T)(channel, action, timeout, parameter)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWayAsync<T>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   T parameter
)
public procedure SendOneWayAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    parameter: T
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWayAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameter : T
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWayAsync<T>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   T* parameter
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWayAsyncgeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   T^ parameter
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameter
The object to send.

Type Parameters

T
The type of the object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWayAsync(WebSocketChannel,String,TimeSpan,Object[]) Method

SendOneWayAsync(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWayAsync Method : SendOneWayAsync(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWayAsync( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object

WebSocketChannelExtensions.SendOneWayAsync(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWayAsync(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public procedure SendOneWayAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWayAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWayAsync(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWayAsync(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWayAsync(WebSocketChannel,String,Object[]) Method

SendOneWayAsync(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWayAsync Method : SendOneWayAsync(WebSocketChannel,String,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWayAsync( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.SendOneWayAsync(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWayAsync(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure SendOneWayAsync(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWayAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWayAsync(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWayAsync(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendOneWayAsync<T>(WebSocketChannel,String,T) Method

SendOneWayAsync<T>(WebSocketChannel,String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendOneWayAsync Method : SendOneWayAsync<T>(WebSocketChannel,String,T) Method
The type of the object to send.
The channel through which the object will be sent.
The action associated to the remote operation.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendOneWayAsync(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameter As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameter As T

WebSocketChannelExtensions.SendOneWayAsync(Of T)(channel, action, parameter)
[System.Runtime.CompilerServices.Extension()]
public static void SendOneWayAsync<T>(
   WebSocketChannel channel,
   System.string action,
   T parameter
)
public procedure SendOneWayAsync(
    channel: WebSocketChannel;
    action: System.String;
    parameter: T
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendOneWayAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameter : T
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendOneWayAsync<T>(
   WebSocketChannel* channel,
   System.string* action,
   T* parameter
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendOneWayAsyncgeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   T^ parameter
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameter
The object to send.

Type Parameters

T
The type of the object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendWithStream Method (WebSocketChannelExtensions)

SendWithStream Method (WebSocketChannelExtensions)

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : SendWithStream Method
Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Overload List
Overload | Description
SendWithStream(WebSocketChannel,String,Stream,Object[]) | Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
SendWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) | Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


SendWithStream(WebSocketChannel,String,Stream,Object[]) Method

SendWithStream(WebSocketChannel,String,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendWithStream Method : SendWithStream(WebSocketChannel,String,Stream,Object[]) Method
The channel through which to send the message.
The action associated to the remote operation.
The stream to send as continuation of the message.
The parameters to send to the remote operation.
Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendWithStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim attachment As System.IO.Stream
Dim parameters() As System.Object

WebSocketChannelExtensions.SendWithStream(channel, action, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendWithStream(
   WebSocketChannel channel,
   System.string action,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public procedure SendWithStream(
    channel: WebSocketChannel;
    action: System.String;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendWithStream(
   channel : WebSocketChannel,
   action : System.String,
   attachment : System.IO.Stream,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendWithStream(
   WebSocketChannel* channel,
   System.string* action,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendWithStream(
   WebSocketChannel^ channel,
   System.String^ action,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which to send the message.
action
The action associated to the remote operation.
attachment
The stream to send as continuation of the message.
parameters
The parameters to send to the remote operation.

Return Value

The input to continue writing the streamed part of the message.
Remarks

This method sends the parameters followed by a stream of arbitrary length to remote message operation. The remote message operation is expected to take a stream as the last parameter in the method signature. As soon as initial part of the message containing parameters is received by the remote endpoint, the operation is getting invoked and the streamed part of the message that follows parameters is provided as the final parameter.

You can send/received stream of arbitrary length without any maximum length limitation. However, while message is being streamed no other messages can be sent through the same WebSocket channel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

SendWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendWithStream Method : SendWithStream(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method
The channel through which to send the message.
The action associated to the remote operation.
The timeout for the send operation.
The attachment stream.
The parameters to send to the remote operation.
Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendWithStream( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim attachment As System.IO.Stream
Dim parameters() As System.Object

WebSocketChannelExtensions.SendWithStream(channel, action, timeout, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static void SendWithStream(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public procedure SendWithStream(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendWithStream(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   attachment : System.IO.Stream,
   parameters : System.Object[]
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendWithStream(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendWithStream(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which to send the message.
action
The action associated to the remote operation.
timeout
The timeout for the send operation.
attachment
The attachment stream.
parameters
The parameters to send to the remote operation.

Return Value

The input to continue writing the streamed part of the message.
Remarks

This method sends the parameters followed by a stream of arbitrary length to remote message operation. The remote message operation is expected to take a stream as the last parameter in the method signature. As soon as initial part of the message containing parameters is received by the remote endpoint, the operation is getting invoked and the streamed part of the message that follows parameter is provided as the final parameter. The streamed part of the message is not getting buffered sent and received directly from the WebSocket connection.

You can send/received stream of arbitrary length without any maximum length limitation. However, while message is being streamed no other messages can be sent through the same WebSocket channel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


WebSocketMessagingService Class

WebSocketMessagingService Class
Members

Noemax.WebSockets.Messaging Namespace : WebSocketMessagingService Class
The base class for the service that performs dispatching of the inbound messages based of the type of the object deserialized from the the message content and the action string provided by inbound message.
Object Model
WebSocketMessagingService Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class WebSocketMessagingService
   Inherits Noemax.WebSockets.WebSocketService
   Implements Noemax.WebSockets.IWebSockets
'Usage

Dim instance As WebSocketMessagingService
public class WebSocketMessagingService : Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
public class WebSocketMessagingService = class(Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets)
public class WebSocketMessagingService extends Noemax.WebSockets.WebSocketService implements Noemax.WebSockets.IWebSockets
public __gc class WebSocketMessagingService : public Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
public ref class WebSocketMessagingService : public Noemax.WebSockets.WebSocketService, Noemax.WebSockets.IWebSockets
Remarks
The content of an inbound message is deserialized using the DefaultSerializer, then the deserialized object is dispatched to the method based on its Type and/or Action. The method that receives the object must be marked with MessageOperationAttribute and must be exposed by either the class inherited from the MessagingService or the instance of the class provided as parameter to the MessageService constructor. The last parameters of the method indicates the type of objects it receives, while first optional parameters can be Noemax.WebSockets.WebSocketChannel type. If method takes WebSocketChannel as a first parameter then it will be assigned to the channel that received the message.
Inheritance Hierarchy

System.Object
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.Messaging.WebSocketMessagingService

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Members
Noemax.WebSockets.Messaging Namespace


WebSocketMessagingService Class Members

WebSocketMessagingService Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : WebSocketMessagingService Class

The following tables list the members exposed by WebSocketMessagingService.

Public Constructors
 | Name | Description
Public Constructor | WebSocketMessagingService Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MessageDispatcher | Gets dispatcher used by the service to dispatch inbound message.
Public Property | Serializer | Gets and sets the IMessageSerializer used by the service to deserialize the object from the content of inbound messages. The same serializer is used by all associated channels for serializing objects into content of outbound messages.
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketService)
Top
Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | Broadcast | Overloaded. Broadcasts the message containing the object of specified type to all channels associated to the service.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetChannels | Returns the list of the channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetProperty<T> | Overridden. Returns the object of type T associated to the channel.
Public Method | OnClose | This method is called when a channel is being closed. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnError | Handles a error occurred in a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnHandshake | The method is called during the WebSocket handshake, override this method to accept or to decline it. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnMessage | Overloaded. Overridden. Overrides WebSocketService.OnMessage to perform dispatching of inbound messages based on the type of the object deserialized from the message content and action.
Public Method | OnOpen | Overridden. Overrides WebSocketService.OnOpen, initializes the DefaultSerializer and associates it with accepted WebSocketChannel.
Public Method | OnPing | This method is called when a PING frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnPong | This method is called when a PONG frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires. (Inherited from Noemax.WebSockets.WebSocketService)
Top
Protected Methods
 | Name | Description
Protected Method | OnCreateDispatcher | Initializes a new instance of MessageDispatcher to be used by the WebSocketMessagingService.
Top
See Also

Reference

WebSocketMessagingService Class
Noemax.WebSockets.Messaging Namespace


WebSocketMessagingService Constructor

WebSocketMessagingService Constructor

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : WebSocketMessagingService Constructor
Overload List
Overload | Description
WebSocketMessagingService Constructor() | Initializes a new instance of WebSocketMessagingService.
WebSocketMessagingService Constructor(Object) | Initializes a new instance of WebSocketMessagingService from specified object providing the methods to which the messages will be dispatch.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members


WebSocketMessagingService Constructor()

WebSocketMessagingService Constructor()

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > WebSocketMessagingService Constructor : WebSocketMessagingService Constructor()
Initializes a new instance of WebSocketMessagingService.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New WebSocketMessagingService()
public WebSocketMessagingService()
public WebSocketMessagingService();
public function WebSocketMessagingService();
public: WebSocketMessagingService();
public:
WebSocketMessagingService();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List


WebSocketMessagingService Constructor(Object)

WebSocketMessagingService Constructor(Object)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > WebSocketMessagingService Constructor : WebSocketMessagingService Constructor(Object)
The instance of the class that providing methods that receive inbound messages.
Initializes a new instance of WebSocketMessagingService from specified object providing the methods to which the messages will be dispatch.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal instance As System.Object _
)
'Usage

Dim instance As System.Object

Dim instance As New WebSocketMessagingService(instance)
public WebSocketMessagingService(
   System.object instance
)
public WebSocketMessagingService(
    instance: System.TObject
);
public function WebSocketMessagingService(
   instance : System.Object
);
public: WebSocketMessagingService(
   System.Object* instance
)
public:
WebSocketMessagingService(
   System.Object^ instance
)

Parameters

instance
The instance of the class that providing methods that receive inbound messages.
Remarks
The specified object should define methods marked by MessageOperationAttribute attribute or implement interfaces that define such methods.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List


WebSocketMessagingService Class Methods

WebSocketMessagingService Class Methods

Noemax.WebSockets.Messaging Namespace : WebSocketMessagingService Class

For a list of all members of this type, see WebSocketMessagingService members.

Public Methods
 | Name | Description
Public Method | AddChannel | Adds the channel to the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | AddProperty<T> | Adds or replaces the the object of the specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | Broadcast | Overloaded. Broadcasts the message containing the object of specified type to all channels associated to the service.
Public Method | CalcTotalOutboundQueueSize | Gets the total sizes of all outbound message queues associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CloseChannels | Overloaded. Closes all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | CreateClient | Overloaded. Creates a client channel associated to the service. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetChannels | Returns the list of the channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | GetProperty<T> | Overridden. Returns the object of type T associated to the channel.
Public Method | OnClose | This method is called when a channel is being closed. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnError | Handles a error occurred in a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnHandshake | The method is called during the WebSocket handshake, override this method to accept or to decline it. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnMessage | Overloaded. Overridden. Overrides WebSocketService.OnMessage to perform dispatching of inbound messages based on the type of the object deserialized from the message content and action.
Public Method | OnOpen | Overridden. Overrides WebSocketService.OnOpen, initializes the DefaultSerializer and associates it with accepted WebSocketChannel.
Public Method | OnPing | This method is called when a PING frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | OnPong | This method is called when a PONG frame received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveChannel | Removes the channel from the list of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | RemoveProperty<T> | Removes the object of specified type from the properties of the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendBatchAsync | Overloaded. Sends the batch of messages to the list of channels asynchronously. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendPing | Overloaded. Sends the PING message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendTo | Sends the message to the list of specified channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | SendToAll | Overloaded. Sends the text message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Method | WaitForOutboundQueue | Overloaded. Blocks the current thread until outbound queues of all associated channels are empty, or timeout expires. (Inherited from Noemax.WebSockets.WebSocketService)
Top
Protected Methods
 | Name | Description
Protected Method | OnCreateDispatcher | Initializes a new instance of MessageDispatcher to be used by the WebSocketMessagingService.
Top
See Also

Reference

WebSocketMessagingService Class
Noemax.WebSockets.Messaging Namespace


Broadcast Method (WebSocketMessagingService)

Broadcast Method (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : Broadcast Method
Broadcasts the message containing the object of specified type to all channels associated to the service.
Overload List
Overload | Description
Broadcast<T>(String,T) | Broadcasts the message containing the object of specified type to all channels associated to the service.
Broadcast(String,Object[]) | Broadcasts the RPC message with specified action string and parameters to all channels associated to the service.
Broadcast<T>(T) | Broadcasts the message containing the object of specified type to all channels associated to the service.
Broadcast | Broadcasts the message to all channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members


Broadcast<T>(String,T) Method

Broadcast<T>(String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > Broadcast Method : Broadcast<T>(String,T) Method
The type of the object to broadcast.
The action string associated to the remote operation.
The object to broadcast.
Broadcasts the message containing the object of specified type to all channels associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Broadcast(Of T)( _
   ByVal action As System.String, _
   ByVal obj As T _
)
'Usage

Dim instance As WebSocketMessagingService
Dim action As System.String
Dim obj As T

instance.Broadcast(Of T)(action, obj)
public void Broadcast<T>(
   System.string action,
   T obj
)
public procedure Broadcast(
    action: System.String;
    obj: T
);
public function Broadcast(
   action : System.String,
   obj : T
);
public: void Broadcast<T>(
   System.string* action,
   T* obj
)
public:
void Broadcastgeneric<typename T>
(
   System.String^ action,
   T^ obj
)

Parameters

action
The action string associated to the remote operation.
obj
The object to broadcast.

Type Parameters

T
The type of the object to broadcast.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List


Broadcast(String,Object[]) Method

Broadcast(String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > Broadcast Method : Broadcast(String,Object[]) Method
The action string associated to the remote operation.
The parameters for RPC call to broadcast.
Broadcasts the RPC message with specified action string and parameters to all channels associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Broadcast( _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim instance As WebSocketMessagingService
Dim action As System.String
Dim parameters() As System.Object

instance.Broadcast(action, parameters)
public void Broadcast(
   System.string action,
   params System.object[] parameters
)
public procedure Broadcast(
    action: System.String;
   params  parameters: System.TObjectarray of
);
public function Broadcast(
   action : System.String,
   parameters : System.Object[]
);
public: void Broadcast(
   System.string* action,
   params System.Object*[]* parameters
)
public:
void Broadcast(
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

action
The action string associated to the remote operation.
parameters
The parameters for RPC call to broadcast.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List


Broadcast<T>(T) Method

Broadcast<T>(T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > Broadcast Method : Broadcast<T>(T) Method
The type of the object to broadcast.
The object to broadcast.
Broadcasts the message containing the object of specified type to all channels associated to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Sub Broadcast(Of T)( _
   ByVal obj As T _
)
'Usage

Dim instance As WebSocketMessagingService
Dim obj As T

instance.Broadcast(Of T)(obj)
public void Broadcast<T>(
   T obj
)
public procedure Broadcast(
    obj: T
);
public function Broadcast(
   obj : T
);
public: void Broadcast<T>(
   T* obj
)
public:
void Broadcastgeneric<typename T>
(
   T^ obj
)

Parameters

obj
The object to broadcast.

Type Parameters

T
The type of the object to broadcast.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List


GetProperty<T> Method (WebSocketMessagingService)

GetProperty<T> Method (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : GetProperty<T> Method
The type of object to return.
Returns the object of type T associated to the channel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function GetProperty(Of T)() As T
'Usage

Dim instance As WebSocketMessagingService
Dim value As T

value = instance.GetProperty(Of T)()
public override T GetProperty<T>()
public function GetProperty(): T; override;
public override function GetProperty() : T;
public: T* GetProperty<T>(); override
public:
T^ GetPropertygeneric<typename T>
(); override

Type Parameters

T
The type of object to return.

Return Value

The object of type T associated to the channel.
Remarks
This method is used internally to request MessageDispatcher or IMessageSerializer from the instance of the service.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Base Implementation in GetProperty<T>


OnCreateDispatcher Method (WebSocketMessagingService)

OnCreateDispatcher Method (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : OnCreateDispatcher Method
The instance of the class that is going to dispatch message operation.
Initializes a new instance of MessageDispatcher to be used by the WebSocketMessagingService.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function OnCreateDispatcher( _
   ByVal instance As System.Object _
) As MessageDispatcher
'Usage

Dim instance As WebSocketMessagingService
Dim instance As System.Object
Dim value As MessageDispatcher

value = instance.OnCreateDispatcher(instance)
protected virtual MessageDispatcher OnCreateDispatcher(
   System.object instance
)
protected function OnCreateDispatcher(
    instance: System.TObject
): MessageDispatcher; virtual;
protected function OnCreateDispatcher(
   instance : System.Object
) : MessageDispatcher;
protected: virtual MessageDispatcher* OnCreateDispatcher(
   System.Object* instance
)
protected:
virtual MessageDispatcher^ OnCreateDispatcher(
   System.Object^ instance
)

Parameters

instance
The instance of the class that is going to dispatch message operation.

Return Value

The instance of MessageDispatcher.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members


OnMessage Method (WebSocketMessagingService)

OnMessage Method (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : OnMessage Method
Overrides WebSocketService.OnMessage to perform dispatching of inbound messages based on the type of the object deserialized from the message content and action.
Overload List
Overload | Description
OnMessage(WebSocketChannel,WebSocketInboundMessage) | Overrides WebSocketService.OnMessage to perform dispatching of inbound messages based on the type of the object deserialized from the message content and action.
OnMessage(WebSocketChannel,String) | Handles a text message received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
OnMessage(WebSocketChannel,ArraySegment<Byte>) | Handles a binary message received from a specified channel. (Inherited from Noemax.WebSockets.WebSocketService)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Base Implementation in OnMessage


OnMessage(WebSocketChannel,WebSocketInboundMessage) Method

OnMessage(WebSocketChannel,WebSocketInboundMessage) Method

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class > OnMessage Method : OnMessage(WebSocketChannel,WebSocketInboundMessage) Method
The channel through which the message is being received.
The inbound message.
Overrides WebSocketService.OnMessage to perform dispatching of inbound messages based on the type of the object deserialized from the message content and action.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Sub OnMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal message As WebSocketInboundMessage _
)
'Usage

Dim instance As WebSocketMessagingService
Dim channel As WebSocketChannel
Dim message As WebSocketInboundMessage

instance.OnMessage(channel, message)
public override void OnMessage(
   WebSocketChannel channel,
   WebSocketInboundMessage message
)
public procedure OnMessage(
    channel: WebSocketChannel;
    message: WebSocketInboundMessage
); override;
public override function OnMessage(
   channel : WebSocketChannel,
   message : WebSocketInboundMessage
);
public: void OnMessage(
   WebSocketChannel* channel,
   WebSocketInboundMessage* message
) override
public:
void OnMessage(
   WebSocketChannel^ channel,
   WebSocketInboundMessage^ message
) override

Parameters

channel
The channel through which the message is being received.
message
The inbound message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Overload List
Base Implementation in OnMessage(WebSocketChannel,WebSocketInboundMessage)


OnOpen Method (WebSocketMessagingService)

OnOpen Method (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : OnOpen Method
The channel accepted by the service.
Overrides WebSocketService.OnOpen, initializes the DefaultSerializer and associates it with accepted WebSocketChannel.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub OnOpen( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As WebSocketMessagingService
Dim channel As WebSocketChannel

instance.OnOpen(channel)
public override void OnOpen(
   WebSocketChannel channel
)
public procedure OnOpen(
    channel: WebSocketChannel
); override;
public override function OnOpen(
   channel : WebSocketChannel
);
public: void OnOpen(
   WebSocketChannel* channel
) override
public:
void OnOpen(
   WebSocketChannel^ channel
) override

Parameters

channel
The channel accepted by the service.
Remarks

Once Serializer is associated to the channels, all object being sent through the channel are serialized using specified DefaultSerializer and the content of all message received from the channel is deserialized using specified DefaultSerializer.

DefaultSerializer can be retrieved from the channel context by using Noemax.WebSockets.WebSocketChannel.GetProperty``1 method.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members
Base Implementation in OnOpen


WebSocketMessagingService Class Properties

WebSocketMessagingService Class Properties

Noemax.WebSockets.Messaging Namespace : WebSocketMessagingService Class

For a list of all members of this type, see WebSocketMessagingService members.

Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MessageDispatcher | Gets dispatcher used by the service to dispatch inbound message.
Public Property | Serializer | Gets and sets the IMessageSerializer used by the service to deserialize the object from the content of inbound messages. The same serializer is used by all associated channels for serializing objects into content of outbound messages.
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketService)
Top
See Also

Reference

WebSocketMessagingService Class
Noemax.WebSockets.Messaging Namespace


MessageDispatcher Property (WebSocketMessagingService)

MessageDispatcher Property (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : MessageDispatcher Property
Gets dispatcher used by the service to dispatch inbound message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property MessageDispatcher As MessageDispatcher
'Usage

Dim instance As WebSocketMessagingService
Dim value As MessageDispatcher

instance.MessageDispatcher = value

value = instance.MessageDispatcher
public MessageDispatcher MessageDispatcher {get; set;}
public read-write property MessageDispatcher: MessageDispatcher;
public function get,set MessageDispatcher : MessageDispatcher
public: __property MessageDispatcher* get_MessageDispatcher();
public: __property void set_MessageDispatcher(
   MessageDispatcher* value
);
public:
property MessageDispatcher^ MessageDispatcher {
   MessageDispatcher^ get();
   void set (    MessageDispatcher^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members


Serializer Property (WebSocketMessagingService)

Serializer Property (WebSocketMessagingService)

Noemax.WebSockets.Messaging Namespace > WebSocketMessagingService Class : Serializer Property
Gets and sets the IMessageSerializer used by the service to deserialize the object from the content of inbound messages. The same serializer is used by all associated channels for serializing objects into content of outbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property Serializer As IMessageSerializer
'Usage

Dim instance As WebSocketMessagingService
Dim value As IMessageSerializer

instance.Serializer = value

value = instance.Serializer
public IMessageSerializer Serializer {get; set;}
public read-write property Serializer: IMessageSerializer;
public function get,set Serializer : IMessageSerializer
public: __property IMessageSerializer* get_Serializer();
public: __property void set_Serializer(
   IMessageSerializer* value
);
public:
property IMessageSerializer^ Serializer {
   IMessageSerializer^ get();
   void set (    IMessageSerializer^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessagingService Class
WebSocketMessagingService Members


XmlMessageSerializer Class

XmlMessageSerializer Class
Members

Noemax.WebSockets.Messaging Namespace : XmlMessageSerializer Class
Provides XML serialization for WebSocket messaging services.
Object Model
XmlMessageSerializer Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class XmlMessageSerializer
   Inherits MessageSerializerBase
   Implements IMessageSerializer
'Usage

Dim instance As XmlMessageSerializer
public class XmlMessageSerializer : MessageSerializerBase, IMessageSerializer
public class XmlMessageSerializer = class(MessageSerializerBase, IMessageSerializer)
public class XmlMessageSerializer extends MessageSerializerBase implements IMessageSerializer
public __gc class XmlMessageSerializer : public MessageSerializerBase, IMessageSerializer
public ref class XmlMessageSerializer : public MessageSerializerBase, IMessageSerializer
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.MessageSerializerBase
Noemax.WebSockets.Messaging.XmlMessageSerializer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Members
Noemax.WebSockets.Messaging Namespace


XmlMessageSerializer Class Members

XmlMessageSerializer Class Members
Methods

Noemax.WebSockets.Messaging Namespace : XmlMessageSerializer Class

The following tables list the members exposed by XmlMessageSerializer.

Public Constructors
 | Name | Description
Public Constructor | XmlMessageSerializer Constructor |
Top
Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Overridden. Deserializes the content of the message.
Public Method | EnsureKnownTypes | Overridden. Ensures that the specified types are known to the XML serializer.
Public Method | Serialize | Overloaded. Overridden. Serialize the object into WebSocket outbound message/
Top
See Also

Reference

XmlMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


XmlMessageSerializer Constructor

XmlMessageSerializer Constructor

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class : XmlMessageSerializer Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New XmlMessageSerializer()
public XmlMessageSerializer()
public XmlMessageSerializer();
public function XmlMessageSerializer();
public: XmlMessageSerializer();
public:
XmlMessageSerializer();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members


XmlMessageSerializer Class Methods

XmlMessageSerializer Class Methods

Noemax.WebSockets.Messaging Namespace : XmlMessageSerializer Class

For a list of all members of this type, see XmlMessageSerializer members.

Public Methods
 | Name | Description
Public Method | Deserialize | Overloaded. Overridden. Deserializes the content of the message.
Public Method | EnsureKnownTypes | Overridden. Ensures that the specified types are known to the XML serializer.
Public Method | Serialize | Overloaded. Overridden. Serialize the object into WebSocket outbound message/
Top
See Also

Reference

XmlMessageSerializer Class
Noemax.WebSockets.Messaging Namespace


Deserialize Method (XmlMessageSerializer)

Deserialize Method (XmlMessageSerializer)

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class : Deserialize Method
Deserializes the content of the message.
Overload List
Overload | Description
Deserialize(String,WebSocketChannel,MessageDispatcher) | Deserializes the content of the message.
Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) | Deserializes the content of the message.
Deserialize(WebSocketInboundMessage,WebSocketChannel,MessageDispatcher) | Deserializes the content of inbound message. (Inherited from Noemax.WebSockets.Messaging.MessageSerializerBase)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Base Implementation in Deserialize


Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Deserialize(String,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class > Deserialize Method : Deserialize(String,WebSocketChannel,MessageDispatcher) Method
The text message to deserialize.
The channel from the message was received.
The message dispatcher to resolve the destination operation.
Deserializes the content of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function Deserialize( _
   ByVal textMessage As System.String, _
   ByVal channel As WebSocketChannel, _
   ByVal messageDispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As XmlMessageSerializer
Dim textMessage As System.String
Dim channel As WebSocketChannel
Dim messageDispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(textMessage, channel, messageDispatcher)
protected override System.object Deserialize(
   System.string textMessage,
   WebSocketChannel channel,
   MessageDispatcher messageDispatcher
)
protected function Deserialize(
    textMessage: System.String;
    channel: WebSocketChannel;
    messageDispatcher: MessageDispatcher
): System.TObject; override;
protected override function Deserialize(
   textMessage : System.String,
   channel : WebSocketChannel,
   messageDispatcher : MessageDispatcher
) : System.Object;
protected: System.Object* Deserialize(
   System.string* textMessage,
   WebSocketChannel* channel,
   MessageDispatcher* messageDispatcher
) override
protected:
System.Object^ Deserialize(
   System.String^ textMessage,
   WebSocketChannel^ channel,
   MessageDispatcher^ messageDispatcher
) override

Parameters

textMessage
The text message to deserialize.
channel
The channel from the message was received.
messageDispatcher
The message dispatcher to resolve the destination operation.

Return Value

The object being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Overload List
Base Implementation in Deserialize(String,WebSocketChannel,MessageDispatcher)


Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class > Deserialize Method : Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher) Method
The binary content of the message to deserialize.
The channel from the message was received.
The message dispatcher to resolve the destination operation.
Deserializes the content of the message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Overrides Function Deserialize( _
   ByVal binaryMessage As System.ArraySegment(Of Byte), _
   ByVal channel As WebSocketChannel, _
   ByVal dispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As XmlMessageSerializer
Dim binaryMessage As System.ArraySegment(Of Byte)
Dim channel As WebSocketChannel
Dim dispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(binaryMessage, channel, dispatcher)
protected override System.object Deserialize(
   System.ArraySegment<byte> binaryMessage,
   WebSocketChannel channel,
   MessageDispatcher dispatcher
)
protected function Deserialize(
    binaryMessage: System.ArraySegment;
    channel: WebSocketChannel;
    dispatcher: MessageDispatcher
): System.TObject; override;
protected override function Deserialize(
   binaryMessage : System.ArraySegment,
   channel : WebSocketChannel,
   dispatcher : MessageDispatcher
) : System.Object;
protected: System.Object* Deserialize(
   System.ArraySegment<byte> binaryMessage,
   WebSocketChannel* channel,
   MessageDispatcher* dispatcher
) override
protected:
System.Object^ Deserialize(
   System.ArraySegment<byte> binaryMessage,
   WebSocketChannel^ channel,
   MessageDispatcher^ dispatcher
) override

Parameters

binaryMessage
The binary content of the message to deserialize.
channel
The channel from the message was received.
dispatcher
The message dispatcher to resolve the destination operation.

Return Value

The object being deserialized.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Overload List
Base Implementation in Deserialize(ArraySegment<Byte>,WebSocketChannel,MessageDispatcher)


EnsureKnownTypes Method (XmlMessageSerializer)

EnsureKnownTypes Method (XmlMessageSerializer)

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class : EnsureKnownTypes Method
The types to ensure as known.
Ensures that the specified types are known to the XML serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub EnsureKnownTypes( _
   ByVal ParamArray types() As System.Type _
)
'Usage

Dim instance As XmlMessageSerializer
Dim types() As System.Type

instance.EnsureKnownTypes(types)
public override void EnsureKnownTypes(
   params System.Type[] types
)
public procedure EnsureKnownTypes(
   params  types: System.Typearray of
); override;
public override function EnsureKnownTypes(
   types : System.Type[]
);
public: void EnsureKnownTypes(
   params System.Type*[]* types
) override
public:
void EnsureKnownTypes(
   ... System.array<Type^>^ types
) override

Parameters

types
The types to ensure as known.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Base Implementation in EnsureKnownTypes


Serialize Method (XmlMessageSerializer)

Serialize Method (XmlMessageSerializer)

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class : Serialize Method
Serialize the object into WebSocket outbound message/
Overload List
Overload | Description
Serialize(Object) | Serialize the object into WebSocket outbound message/
Serialize(Stream,Object) | Serializes the object into stream and returns the stream to write attachment to the message. (Inherited from Noemax.WebSockets.Messaging.MessageSerializerBase)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Base Implementation in Serialize


Serialize(Object) Method

Serialize(Object) Method

Noemax.WebSockets.Messaging Namespace > XmlMessageSerializer Class > Serialize Method : Serialize(Object) Method
The object to serialize into the outbound message.
Serialize the object into WebSocket outbound message/
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overrides Function Serialize( _
   ByVal obj As System.Object _
) As WebSocketOutboundMessage
'Usage

Dim instance As XmlMessageSerializer
Dim obj As System.Object
Dim value As WebSocketOutboundMessage

value = instance.Serialize(obj)
public override WebSocketOutboundMessage Serialize(
   System.object obj
)
public function Serialize(
    obj: System.TObject
): WebSocketOutboundMessage; override;
public override function Serialize(
   obj : System.Object
) : WebSocketOutboundMessage;
public: WebSocketOutboundMessage Serialize(
   System.Object* obj
) override
public:
WebSocketOutboundMessage Serialize(
   System.Object^ obj
) override

Parameters

obj
The object to serialize into the outbound message.

Return Value

The outbound message ready to be sent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

XmlMessageSerializer Class
XmlMessageSerializer Members
Overload List
Base Implementation in Serialize(Object)


CompressedMessageFormat Enumeration

CompressedMessageFormat Enumeration

Noemax.WebSockets.Messaging Namespace : CompressedMessageFormat Enumeration
The compression format to use for compressing the outbound messages.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Enum CompressedMessageFormat
   Inherits System.Enum
'Usage

Dim instance As CompressedMessageFormat
public enum CompressedMessageFormat : System.Enum
public enum CompressedMessageFormat = class(System.Enum)
public enum CompressedMessageFormat extends System.Enum
__value public enum CompressedMessageFormat : public System.Enum
public enum class CompressedMessageFormat : public System.Enum
Members
Member | Description
Deflate | DEFLATE
GZip | GZIP
Lzf4 | LZF4
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WebSockets.Messaging.CompressedMessageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Noemax.WebSockets.Messaging Namespace


FaultInfo Structure

FaultInfo Structure
Members

Noemax.WebSockets.Messaging Namespace : FaultInfo Structure
Provides information on the fault returned by remote side as response to request message.
Object Model
FaultInfo Structure
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataContractAttribute()>
Public Structure FaultInfo
   Inherits System.ValueType
'Usage

Dim instance As FaultInfo
[System.Runtime.Serialization.DataContract()]
public struct FaultInfo : System.ValueType
public type FaultInfo = class(System.ValueType)
In JScript, you can use structures in other assemblies, but you cannot define your own.
[System.Runtime.Serialization.DataContract()]
public __value struct FaultInfo : public System.ValueType
[System.Runtime.Serialization.DataContract()]
public value class FaultInfo : public System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
Noemax.WebSockets.Messaging.FaultInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FaultInfo Members
Noemax.WebSockets.Messaging Namespace


FaultInfo Structure Members

FaultInfo Structure Members
Properties

Noemax.WebSockets.Messaging Namespace : FaultInfo Structure

The following tables list the members exposed by FaultInfo.

Public Properties
 | Name | Description
Public Property | Code | The string identifying the type of the fault.
Public Property | Data | The list of the strings provided additional details about the fault.
Public Property | Message | The string containing the message/description of the fault.
Top
See Also

Reference

FaultInfo Structure
Noemax.WebSockets.Messaging Namespace


FaultInfo Structure Properties

FaultInfo Structure Properties

Noemax.WebSockets.Messaging Namespace : FaultInfo Structure

For a list of all members of this type, see FaultInfo members.

Public Properties
 | Name | Description
Public Property | Code | The string identifying the type of the fault.
Public Property | Data | The list of the strings provided additional details about the fault.
Public Property | Message | The string containing the message/description of the fault.
Top
See Also

Reference

FaultInfo Structure
Noemax.WebSockets.Messaging Namespace


Code Property (FaultInfo)

Code Property (FaultInfo)

Noemax.WebSockets.Messaging Namespace > FaultInfo Structure : Code Property
The string identifying the type of the fault.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataMemberAttribute()>
Public Property Code As System.Long
'Usage

Dim instance As FaultInfo
Dim value As System.Long

instance.Code = value

value = instance.Code
[System.Runtime.Serialization.DataMember()]
public System.long Code {get; set;}
public read-write property Code: System.Int64;
System.Runtime.Serialization.DataMemberAttribute()
public function get,set Code : System.long
[System.Runtime.Serialization.DataMember()]
public: __property System.long get_Code();
public: __property void set_Code(
   System.long value
);
[System.Runtime.Serialization.DataMember()]
public:
property System.int64 Code {
   System.int64 get();
   void set (    System.int64 value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FaultInfo Structure
FaultInfo Members


Data Property (FaultInfo)

Data Property (FaultInfo)

Noemax.WebSockets.Messaging Namespace > FaultInfo Structure : Data Property
The list of the strings provided additional details about the fault.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataMemberAttribute()>
Public Property Data As System.Object
'Usage

Dim instance As FaultInfo
Dim value As System.Object

instance.Data = value

value = instance.Data
[System.Runtime.Serialization.DataMember()]
public System.object Data {get; set;}
public read-write property Data: System.TObject;
System.Runtime.Serialization.DataMemberAttribute()
public function get,set Data : System.Object
[System.Runtime.Serialization.DataMember()]
public: __property System.Object* get_Data();
public: __property void set_Data(
   System.Object* value
);
[System.Runtime.Serialization.DataMember()]
public:
property System.Object^ Data {
   System.Object^ get();
   void set (    System.Object^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FaultInfo Structure
FaultInfo Members


Message Property (FaultInfo)

Message Property (FaultInfo)

Noemax.WebSockets.Messaging Namespace > FaultInfo Structure : Message Property
The string containing the message/description of the fault.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.Serialization.DataMemberAttribute()>
Public Property Message As System.String
'Usage

Dim instance As FaultInfo
Dim value As System.String

instance.Message = value

value = instance.Message
[System.Runtime.Serialization.DataMember()]
public System.string Message {get; set;}
public read-write property Message: System.String;
System.Runtime.Serialization.DataMemberAttribute()
public function get,set Message : System.String
[System.Runtime.Serialization.DataMember()]
public: __property System.string* get_Message();
public: __property void set_Message(
   System.string* value
);
[System.Runtime.Serialization.DataMember()]
public:
property System.String^ Message {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FaultInfo Structure
FaultInfo Members


IClientDispatcher Interface

IClientDispatcher Interface
Members

Noemax.WebSockets.Messaging Namespace : IClientDispatcher Interface
Defines the interface that provides methods and properties for dispatching messages on the client side.
Object Model
IClientDispatcher Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IClientDispatcher
'Usage

Dim instance As IClientDispatcher
public interface IClientDispatcher
public interface IClientDispatcher
public interface IClientDispatcher
public __gc __interface IClientDispatcher
public interface class IClientDispatcher
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Members
Noemax.WebSockets.Messaging Namespace


IClientDispatcher Interface Members

IClientDispatcher Interface Members
Methods

Noemax.WebSockets.Messaging Namespace : IClientDispatcher Interface

The following tables list the members exposed by IClientDispatcher.

Public Methods
 | Name | Description
Method | BeginRequest | Overloaded. Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Method | BeginSend | Overloaded. Begins an asynchronous operation to send a message to the remote endpoint.
Method | CreateStreamedMessage | Overloaded. Initiates an outbound message with streamed attachment.
Method | EndRequest | Overloaded. Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Method | EndSend | Completes an asynchronous send operation.
Method | Request | Overloaded. Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Method | Send | Overloaded. Sends an one-way message to the remote endpoint.
Method | SendAsync | Overloaded. Sends a one-way message to the remote endpoint asynchronously.
Top
See Also

Reference

IClientDispatcher Interface
Noemax.WebSockets.Messaging Namespace


IClientDispatcher Interface Methods

IClientDispatcher Interface Methods

Noemax.WebSockets.Messaging Namespace : IClientDispatcher Interface

For a list of all members of this type, see IClientDispatcher members.

Public Methods
 | Name | Description
Method | BeginRequest | Overloaded. Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Method | BeginSend | Overloaded. Begins an asynchronous operation to send a message to the remote endpoint.
Method | CreateStreamedMessage | Overloaded. Initiates an outbound message with streamed attachment.
Method | EndRequest | Overloaded. Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Method | EndSend | Completes an asynchronous send operation.
Method | Request | Overloaded. Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Method | Send | Overloaded. Sends an one-way message to the remote endpoint.
Method | SendAsync | Overloaded. Sends a one-way message to the remote endpoint asynchronously.
Top
See Also

Reference

IClientDispatcher Interface
Noemax.WebSockets.Messaging Namespace


BeginRequest Method (IClientDispatcher)

BeginRequest Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : BeginRequest Method
Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Overload List
Overload | Description
BeginRequest(String,Object[],TimeSpan,AsyncCallback,Object) | Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
BeginRequest<TRequest>(TRequest,TimeSpan,AsyncCallback,Object) | Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


BeginRequest(String,Object[],TimeSpan,AsyncCallback,Object) Method

BeginRequest(String,Object[],TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > BeginRequest Method : BeginRequest(String,Object[],TimeSpan,AsyncCallback,Object) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which request must complete or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to asynchronous operation.
Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function BeginRequest( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginRequest(action, parameters, timeout, callback, state)
System.IAsyncResult BeginRequest(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
function BeginRequest(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
function BeginRequest(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
System.IAsyncResult* BeginRequest(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
System.IAsyncResult^ BeginRequest(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which request must complete or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to asynchronous operation.

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


BeginRequest<TRequest>(TRequest,TimeSpan,AsyncCallback,Object) Method

BeginRequest<TRequest>(TRequest,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > BeginRequest Method : BeginRequest<TRequest>(TRequest,TimeSpan,AsyncCallback,Object) Method
The message to send to the remote endpoint.
The period of time during which request must complete or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to asynchronous operation.
Begins an asynchronous request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function BeginRequest(Of TRequest)( _
   ByVal request As TRequest, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As IClientDispatcher
Dim request As TRequest
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginRequest(Of TRequest)(request, timeout, callback, state)
System.IAsyncResult BeginRequest<TRequest>(
   TRequest request,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
function BeginRequest(
    request: TRequest;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
function BeginRequest(
   request : TRequest,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
System.IAsyncResult* BeginRequest<TRequest>(
   TRequest* request,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
System.IAsyncResult^ BeginRequestgeneric<typename TRequest>
(
   TRequest^ request,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

request
The message to send to the remote endpoint.
timeout
The period of time during which request must complete or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to asynchronous operation.

Type Parameters

TRequest

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


BeginSend Method (IClientDispatcher)

BeginSend Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : BeginSend Method
Begins an asynchronous operation to send a message to the remote endpoint.
Overload List
Overload | Description
BeginSend(String,Object[],TimeSpan,AsyncCallback,Object) | Begins an asynchronous operation to send a message to the remote endpoint.
BeginSend<TMessage>(TMessage,TimeSpan,AsyncCallback,Object) | Begins an asynchronous operation to send a message to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


BeginSend(String,Object[],TimeSpan,AsyncCallback,Object) Method

BeginSend(String,Object[],TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > BeginSend Method : BeginSend(String,Object[],TimeSpan,AsyncCallback,Object) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which operation must be completed or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to the asynchronous operation.
Begins an asynchronous operation to send a message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function BeginSend( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSend(action, parameters, timeout, callback, state)
System.IAsyncResult BeginSend(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
function BeginSend(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
function BeginSend(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
System.IAsyncResult* BeginSend(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
System.IAsyncResult^ BeginSend(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which operation must be completed or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to the asynchronous operation.

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


BeginSend<TMessage>(TMessage,TimeSpan,AsyncCallback,Object) Method

BeginSend<TMessage>(TMessage,TimeSpan,AsyncCallback,Object) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > BeginSend Method : BeginSend<TMessage>(TMessage,TimeSpan,AsyncCallback,Object) Method
The message to be sent.
The period of time during which operation must be completed or timeout.
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
The state associated to the asynchronous operation.
Begins an asynchronous operation to send a message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function BeginSend(Of TMessage)( _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As IClientDispatcher
Dim message As TMessage
Dim timeout As System.TimeSpan
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginSend(Of TMessage)(message, timeout, callback, state)
System.IAsyncResult BeginSend<TMessage>(
   TMessage message,
   System.TimeSpan timeout,
   System.AsyncCallback callback,
   System.object state
)
function BeginSend(
    message: TMessage;
    timeout: System.TimeSpan;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult;
function BeginSend(
   message : TMessage,
   timeout : System.TimeSpan,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
System.IAsyncResult* BeginSend<TMessage>(
   TMessage* message,
   System.TimeSpan timeout,
   System.AsyncCallback* callback,
   System.Object* state
)
System.IAsyncResult^ BeginSendgeneric<typename TMessage>
(
   TMessage^ message,
   System.TimeSpan timeout,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

message
The message to be sent.
timeout
The period of time during which operation must be completed or timeout.
callback
The AsyncCallback delegate that receives the notification of the completion of the asynchronous operation transmitting a request message.
state
The state associated to the asynchronous operation.

Type Parameters

TMessage

Return Value

The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


CreateStreamedMessage Method (IClientDispatcher)

CreateStreamedMessage Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : CreateStreamedMessage Method
Initiates an outbound message with streamed attachment.
Overload List
Overload | Description
CreateStreamedMessage(String,Object[],TimeSpan) | Initiates an outbound message with streamed attachment.
CreateStreamedMessage<TMessage>(TMessage,TimeSpan) | Initiates a streamed message to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


CreateStreamedMessage(String,Object[],TimeSpan) Method

CreateStreamedMessage(String,Object[],TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > CreateStreamedMessage Method : CreateStreamedMessage(String,Object[],TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which operation must be completed or timeout.
Initiates an outbound message with streamed attachment.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function CreateStreamedMessage( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.CreateStreamedMessage(action, parameters, timeout)
System.IO.Stream CreateStreamedMessage(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout
)
function CreateStreamedMessage(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan
): System.IO.Stream;
function CreateStreamedMessage(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan
) : System.IO.Stream;
System.IO.Stream* CreateStreamedMessage(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout
)
System.IO.Stream^ CreateStreamedMessage(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which operation must be completed or timeout.

Return Value

The stream to write attachment to the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


CreateStreamedMessage<TMessage>(TMessage,TimeSpan) Method

CreateStreamedMessage<TMessage>(TMessage,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > CreateStreamedMessage Method : CreateStreamedMessage<TMessage>(TMessage,TimeSpan) Method
The type of the object to be serialized into the message to sent.
The object to be serialized into the message.
The period of time for operation to complete or timeout.
Initiates a streamed message to remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function CreateStreamedMessage(Of TMessage)( _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim instance As IClientDispatcher
Dim message As TMessage
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = instance.CreateStreamedMessage(Of TMessage)(message, timeout)
System.IO.Stream CreateStreamedMessage<TMessage>(
   TMessage message,
   System.TimeSpan timeout
)
function CreateStreamedMessage(
    message: TMessage;
    timeout: System.TimeSpan
): System.IO.Stream;
function CreateStreamedMessage(
   message : TMessage,
   timeout : System.TimeSpan
) : System.IO.Stream;
System.IO.Stream* CreateStreamedMessage<TMessage>(
   TMessage* message,
   System.TimeSpan timeout
)
System.IO.Stream^ CreateStreamedMessagegeneric<typename TMessage>
(
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

message
The object to be serialized into the message.
timeout
The period of time for operation to complete or timeout.

Type Parameters

TMessage
The type of the object to be serialized into the message to sent.

Return Value

The stream to write attachment to the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


EndRequest Method (IClientDispatcher)

EndRequest Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : EndRequest Method
Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Overload List
Overload | Description
EndRequest(IAsyncResult) | Completes an asynchronous request to the remote endpoint and returns the response provided for request.
EndRequest<TResult>(IAsyncResult) | Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


EndRequest(IAsyncResult) Method

EndRequest(IAsyncResult) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > EndRequest Method : EndRequest(IAsyncResult) Method
The IAsyncResult that references the asynchronous request operation.
Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub EndRequest( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As IClientDispatcher
Dim result As System.IAsyncResult

instance.EndRequest(result)
void EndRequest(
   System.IAsyncResult result
)
procedure EndRequest(
    result: System.IAsyncResult
);
function EndRequest(
   result : System.IAsyncResult
);
void EndRequest(
   System.IAsyncResult* result
)
void EndRequest(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult that references the asynchronous request operation.

Return Value

The response provided for request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


EndRequest<TResult>(IAsyncResult) Method

EndRequest<TResult>(IAsyncResult) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > EndRequest Method : EndRequest<TResult>(IAsyncResult) Method
The type of the object to return as response.
The IAsyncResult that references the asynchronous request operation.
Completes an asynchronous request to the remote endpoint and returns the response provided for request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function EndRequest(Of TResult)( _
   ByVal result As System.IAsyncResult _
) As TResult
'Usage

Dim instance As IClientDispatcher
Dim result As System.IAsyncResult
Dim value As TResult

value = instance.EndRequest(Of TResult)(result)
TResult EndRequest<TResult>(
   System.IAsyncResult result
)
function EndRequest(
    result: System.IAsyncResult
): TResult;
function EndRequest(
   result : System.IAsyncResult
) : TResult;
TResult* EndRequest<TResult>(
   System.IAsyncResult* result
)
TResult^ EndRequestgeneric<typename TResult>
(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult that references the asynchronous request operation.

Type Parameters

TResult
The type of the object to return as response.

Return Value

The response provided for request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


EndSend Method (IClientDispatcher)

EndSend Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : EndSend Method
The IAsyncResult that references the asynchronous request operation.
Completes an asynchronous send operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub EndSend( _
   ByVal result As System.IAsyncResult _
)
'Usage

Dim instance As IClientDispatcher
Dim result As System.IAsyncResult

instance.EndSend(result)
void EndSend(
   System.IAsyncResult result
)
procedure EndSend(
    result: System.IAsyncResult
);
function EndSend(
   result : System.IAsyncResult
);
void EndSend(
   System.IAsyncResult* result
)
void EndSend(
   System.IAsyncResult^ result
)

Parameters

result
The IAsyncResult that references the asynchronous request operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


Request Method (IClientDispatcher)

Request Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : Request Method
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Overload List
Overload | Description
Request<TResult>(String,Object[],TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TResult>(String,Object[],Stream,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request(String,Object[],Stream,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest,TResult>(TRequest,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest,TResult>(TRequest,Stream,TimeSpan) |
Request<TRequest>(TRequest,Stream,TimeSpan) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


Request<TResult>(String,Object[],TimeSpan) Method

Request<TResult>(String,Object[],TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request<TResult>(String,Object[],TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Request(Of TResult)( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan
Dim value As TResult

value = instance.Request(Of TResult)(action, parameters, timeout)
TResult Request<TResult>(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout
)
function Request(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan
): TResult;
function Request(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan
) : TResult;
TResult* Request<TResult>(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout
)
TResult^ Requestgeneric<typename TResult>
(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TResult

Return Value

The response provided by remote endpoint or the null if remote operation does not return any data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Request<TResult>(String,Object[],Stream,TimeSpan) Method

Request<TResult>(String,Object[],Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request<TResult>(String,Object[],Stream,TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The stream to be sent as an attachment to outbound message.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Request(Of TResult)( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan
Dim value As TResult

value = instance.Request(Of TResult)(action, parameters, attachment, timeout)
TResult Request<TResult>(
   System.string action,
   System.object[] parameters,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
function Request(
    action: System.String;
    parameters: System.TObjectarray of;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
): TResult;
function Request(
   action : System.String,
   parameters : System.Object[],
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
) : TResult;
TResult* Request<TResult>(
   System.string* action,
   System.Object*[]* parameters,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
TResult^ Requestgeneric<typename TResult>
(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
attachment
The stream to be sent as an attachment to outbound message.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TResult

Return Value

The response provided by remote endpoint or the null if remote operation does not return any data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Request(String,Object[],Stream,TimeSpan) Method

Request(String,Object[],Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request(String,Object[],Stream,TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The stream to be sent as an attachment to a message.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Request( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

instance.Request(action, parameters, attachment, timeout)
void Request(
   System.string action,
   System.object[] parameters,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
procedure Request(
    action: System.String;
    parameters: System.TObjectarray of;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
);
function Request(
   action : System.String,
   parameters : System.Object[],
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
void Request(
   System.string* action,
   System.Object*[]* parameters,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
void Request(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
attachment
The stream to be sent as an attachment to a message.
timeout
The period of time during which request must complete or timeout.

Return Value

The response provided by remote endpoint or the null if remote operation does not return any data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Request<TRequest,TResult>(TRequest,TimeSpan) Method

Request<TRequest,TResult>(TRequest,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request<TRequest,TResult>(TRequest,TimeSpan) Method
The message to send to the remote endpoint.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Request
    (Of TRequest,TResult)( _
   ByVal request As TRequest, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim instance As IClientDispatcher
Dim request As TRequest
Dim timeout As System.TimeSpan
Dim value As TResult

value = instance.Request(Of TRequest, TResult)(request, timeout)
TResult Request<TRequest,TResult>(
   TRequest request,
   System.TimeSpan timeout
)
function Request(
    request: TRequest;
    timeout: System.TimeSpan
): TResult;
function Request(
   request : TRequest,
   timeout : System.TimeSpan
) : TResult;
TResult* Request<TRequest,TResult>(
   TRequest* request,
   System.TimeSpan timeout
)
TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   TRequest^ request,
   System.TimeSpan timeout
)

Parameters

request
The message to send to the remote endpoint.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TRequest
TResult

Return Value

The response provided by remote endpoint or the null if remote operation does not return any data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Request<TRequest,TResult>(TRequest,Stream,TimeSpan) Method

Request<TRequest,TResult>(TRequest,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request<TRequest,TResult>(TRequest,Stream,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Request
    (Of TRequest,TResult)( _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim instance As IClientDispatcher
Dim request As TRequest
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan
Dim value As TResult

value = instance.Request(Of TRequest, TResult)(request, attachment, timeout)
TResult Request<TRequest,TResult>(
   TRequest request,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
function Request(
    request: TRequest;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
): TResult;
function Request(
   request : TRequest,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
) : TResult;
TResult* Request<TRequest,TResult>(
   TRequest* request,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   TRequest^ request,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

request
attachment
timeout

Type Parameters

TRequest
TResult
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Request<TRequest>(TRequest,Stream,TimeSpan) Method

Request<TRequest>(TRequest,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Request Method : Request<TRequest>(TRequest,Stream,TimeSpan) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Request(Of TRequest)( _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim request As TRequest
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

instance.Request(Of TRequest)(request, attachment, timeout)
void Request<TRequest>(
   TRequest request,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
procedure Request(
    request: TRequest;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
);
function Request(
   request : TRequest,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
void Request<TRequest>(
   TRequest* request,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
void Requestgeneric<typename TRequest>
(
   TRequest^ request,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

request
attachment
timeout

Type Parameters

TRequest
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Send Method (IClientDispatcher)

Send Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : Send Method
Sends an one-way message to the remote endpoint.
Overload List
Overload | Description
Send(String,Object[],TimeSpan) | Sends an one-way message to the remote endpoint.
Send(String,Object[],Stream,TimeSpan) | Sends an one-way message to the remote endpoint.
Send<TMessage>(TMessage,TimeSpan) | Sends an one-way message to the remote endpoint.
Send<TMessage>(TMessage,Stream,TimeSpan) | Sends an one-way message to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


Send(String,Object[],TimeSpan) Method

Send(String,Object[],TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Send Method : Send(String,Object[],TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Send( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan

instance.Send(action, parameters, timeout)
void Send(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout
)
procedure Send(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan
);
function Send(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan
);
void Send(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout
)
void Send(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which operation must be completed or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Send(String,Object[],Stream,TimeSpan) Method

Send(String,Object[],Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Send Method : Send(String,Object[],Stream,TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The attachment stream to send along with message.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Send( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

instance.Send(action, parameters, attachment, timeout)
void Send(
   System.string action,
   System.object[] parameters,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
procedure Send(
    action: System.String;
    parameters: System.TObjectarray of;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
);
function Send(
   action : System.String,
   parameters : System.Object[],
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
void Send(
   System.string* action,
   System.Object*[]* parameters,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
void Send(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
attachment
The attachment stream to send along with message.
timeout
The period of time during which operation must be completed or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Send<TMessage>(TMessage,TimeSpan) Method

Send<TMessage>(TMessage,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Send Method : Send<TMessage>(TMessage,TimeSpan) Method
The message to be send.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Send(Of TMessage)( _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim message As TMessage
Dim timeout As System.TimeSpan

instance.Send(Of TMessage)(message, timeout)
void Send<TMessage>(
   TMessage message,
   System.TimeSpan timeout
)
procedure Send(
    message: TMessage;
    timeout: System.TimeSpan
);
function Send(
   message : TMessage,
   timeout : System.TimeSpan
);
void Send<TMessage>(
   TMessage* message,
   System.TimeSpan timeout
)
void Sendgeneric<typename TMessage>
(
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

message
The message to be send.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


Send<TMessage>(TMessage,Stream,TimeSpan) Method

Send<TMessage>(TMessage,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > Send Method : Send<TMessage>(TMessage,Stream,TimeSpan) Method
The message to be send.
The attachment stream to send along with message.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub Send(Of TMessage)( _
   ByVal message As TMessage, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim message As TMessage
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

instance.Send(Of TMessage)(message, attachment, timeout)
void Send<TMessage>(
   TMessage message,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
procedure Send(
    message: TMessage;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
);
function Send(
   message : TMessage,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
void Send<TMessage>(
   TMessage* message,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
void Sendgeneric<typename TMessage>
(
   TMessage^ message,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

message
The message to be send.
attachment
The attachment stream to send along with message.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


SendAsync Method (IClientDispatcher)

SendAsync Method (IClientDispatcher)

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface : SendAsync Method
Sends a one-way message to the remote endpoint asynchronously.
Overload List
Overload | Description
SendAsync(String,Object[],TimeSpan) | Sends a one-way message to the remote endpoint asynchronously.
SendAsync<TMessage>(TMessage,TimeSpan) | Sends a one-way message to the remote endpoint asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members


SendAsync(String,Object[],TimeSpan) Method

SendAsync(String,Object[],TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > SendAsync Method : SendAsync(String,Object[],TimeSpan) Method
The string identifying the operation to which the message is getting sent.
The parameters to be sent with a request.
The period of time during which operation must be completed or timeout.
Sends a one-way message to the remote endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub SendAsync( _
   ByVal action As System.String, _
   ByVal parameters() As System.Object, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim action As System.String
Dim parameters() As System.Object
Dim timeout As System.TimeSpan

instance.SendAsync(action, parameters, timeout)
void SendAsync(
   System.string action,
   System.object[] parameters,
   System.TimeSpan timeout
)
procedure SendAsync(
    action: System.String;
    parameters: System.TObjectarray of;
    timeout: System.TimeSpan
);
function SendAsync(
   action : System.String,
   parameters : System.Object[],
   timeout : System.TimeSpan
);
void SendAsync(
   System.string* action,
   System.Object*[]* parameters,
   System.TimeSpan timeout
)
void SendAsync(
   System.String^ action,
   System.array<Object^>^ parameters,
   System.TimeSpan timeout
)

Parameters

action
The string identifying the operation to which the message is getting sent.
parameters
The parameters to be sent with a request.
timeout
The period of time during which operation must be completed or timeout.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


SendAsync<TMessage>(TMessage,TimeSpan) Method

SendAsync<TMessage>(TMessage,TimeSpan) Method

Noemax.WebSockets.Messaging Namespace > IClientDispatcher Interface > SendAsync Method : SendAsync<TMessage>(TMessage,TimeSpan) Method
The message to be sent.
The period of time during which operation must be completed or timeout.
Sends a one-way message to the remote endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Sub SendAsync(Of TMessage)( _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim instance As IClientDispatcher
Dim message As TMessage
Dim timeout As System.TimeSpan

instance.SendAsync(Of TMessage)(message, timeout)
void SendAsync<TMessage>(
   TMessage message,
   System.TimeSpan timeout
)
procedure SendAsync(
    message: TMessage;
    timeout: System.TimeSpan
);
function SendAsync(
   message : TMessage,
   timeout : System.TimeSpan
);
void SendAsync<TMessage>(
   TMessage* message,
   System.TimeSpan timeout
)
void SendAsyncgeneric<typename TMessage>
(
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

message
The message to be sent.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IClientDispatcher Interface
IClientDispatcher Members
Overload List


ICriteria Interface

ICriteria Interface
Members

Noemax.WebSockets.Messaging Namespace : ICriteria Interface
Represents the criteria based on which MessageDispatcher dispatches messages.
Object Model
ICriteria Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface ICriteria
'Usage

Dim instance As ICriteria
public interface ICriteria
public interface ICriteria
public interface ICriteria
public __gc __interface ICriteria
public interface class ICriteria
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICriteria Members
Noemax.WebSockets.Messaging Namespace


ICriteria Interface Members

ICriteria Interface Members
Methods

Noemax.WebSockets.Messaging Namespace : ICriteria Interface

The following tables list the members exposed by ICriteria.

Public Methods
 | Name | Description
Method | Match | Determines whether inbound message does match the operation represented by the ICriteria.
Top
See Also

Reference

ICriteria Interface
Noemax.WebSockets.Messaging Namespace


ICriteria Interface Methods

ICriteria Interface Methods

Noemax.WebSockets.Messaging Namespace : ICriteria Interface

For a list of all members of this type, see ICriteria members.

Public Methods
 | Name | Description
Method | Match | Determines whether inbound message does match the operation represented by the ICriteria.
Top
See Also

Reference

ICriteria Interface
Noemax.WebSockets.Messaging Namespace


Match Method (ICriteria)

Match Method (ICriteria)

Noemax.WebSockets.Messaging Namespace > ICriteria Interface : Match Method
The message to check against the criteria.
The channel through which message was received.
Determines whether inbound message does match the operation represented by the ICriteria.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Match( _
   ByVal graph As System.Object, _
   ByVal channel As WebSocketChannel _
) As System.Boolean
'Usage

Dim instance As ICriteria
Dim graph As System.Object
Dim channel As WebSocketChannel
Dim value As System.Boolean

value = instance.Match(graph, channel)
System.bool Match(
   System.object graph,
   WebSocketChannel channel
)
function Match(
    graph: System.TObject;
    channel: WebSocketChannel
): System.Boolean;
function Match(
   graph : System.Object,
   channel : WebSocketChannel
) : System.boolean;
System.bool Match(
   System.Object* graph,
   WebSocketChannel* channel
)
System.bool Match(
   System.Object^ graph,
   WebSocketChannel^ channel
)

Parameters

graph
The message to check against the criteria.
channel
The channel through which message was received.

Return Value

True if message can be dispatched to the operation represented by this instance; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ICriteria Interface
ICriteria Members


IMessageSerializer Interface

IMessageSerializer Interface
Members

Noemax.WebSockets.Messaging Namespace : IMessageSerializer Interface
Defines the interface for implementation that provides serialization of the objects through the WebSocket channels.
Object Model
IMessageSerializer Interface
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Interface IMessageSerializer
'Usage

Dim instance As IMessageSerializer
public interface IMessageSerializer
public interface IMessageSerializer
public interface IMessageSerializer
public __gc __interface IMessageSerializer
public interface class IMessageSerializer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Members
Noemax.WebSockets.Messaging Namespace


IMessageSerializer Interface Members

IMessageSerializer Interface Members
Methods

Noemax.WebSockets.Messaging Namespace : IMessageSerializer Interface

The following tables list the members exposed by IMessageSerializer.

Public Methods
 | Name | Description
Method | Deserialize | Deserializes object from Noemax.WebSockets.WebSocketInboundMessage content.
Method | EnsureKnownTypes | Registers that the specified type with the serializer.
Method | Serialize | Overloaded. Serializes an object into the WebSocket message.
Top
See Also

Reference

IMessageSerializer Interface
Noemax.WebSockets.Messaging Namespace


IMessageSerializer Interface Methods

IMessageSerializer Interface Methods

Noemax.WebSockets.Messaging Namespace : IMessageSerializer Interface

For a list of all members of this type, see IMessageSerializer members.

Public Methods
 | Name | Description
Method | Deserialize | Deserializes object from Noemax.WebSockets.WebSocketInboundMessage content.
Method | EnsureKnownTypes | Registers that the specified type with the serializer.
Method | Serialize | Overloaded. Serializes an object into the WebSocket message.
Top
See Also

Reference

IMessageSerializer Interface
Noemax.WebSockets.Messaging Namespace


Deserialize Method (IMessageSerializer)

Deserialize Method (IMessageSerializer)

Noemax.WebSockets.Messaging Namespace > IMessageSerializer Interface : Deserialize Method
The inbound message to deserialize.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message dispatcher involved in dispatching the message.
Deserializes object from Noemax.WebSockets.WebSocketInboundMessage content.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Function Deserialize( _
   ByVal message As WebSocketInboundMessage, _
   ByVal channel As WebSocketChannel, _
   ByVal messageDispatcher As MessageDispatcher _
) As System.Object
'Usage

Dim instance As IMessageSerializer
Dim message As WebSocketInboundMessage
Dim channel As WebSocketChannel
Dim messageDispatcher As MessageDispatcher
Dim value As System.Object

value = instance.Deserialize(message, channel, messageDispatcher)
System.object Deserialize(
   WebSocketInboundMessage message,
   WebSocketChannel channel,
   MessageDispatcher messageDispatcher
)
function Deserialize(
    message: WebSocketInboundMessage;
    channel: WebSocketChannel;
    messageDispatcher: MessageDispatcher
): System.TObject;
function Deserialize(
   message : WebSocketInboundMessage,
   channel : WebSocketChannel,
   messageDispatcher : MessageDispatcher
) : System.Object;
System.Object* Deserialize(
   WebSocketInboundMessage* message,
   WebSocketChannel* channel,
   MessageDispatcher* messageDispatcher
)
System.Object^ Deserialize(
   WebSocketInboundMessage^ message,
   WebSocketChannel^ channel,
   MessageDispatcher^ messageDispatcher
)

Parameters

message
The inbound message to deserialize.
channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
messageDispatcher
The message dispatcher involved in dispatching the message.

Return Value

The deserialized object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Interface
IMessageSerializer Members


EnsureKnownTypes Method (IMessageSerializer)

EnsureKnownTypes Method (IMessageSerializer)

Noemax.WebSockets.Messaging Namespace > IMessageSerializer Interface : EnsureKnownTypes Method
The types to register with the serializer.
Registers that the specified type with the serializer.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Sub EnsureKnownTypes( _
   ByVal ParamArray types() As System.Type _
)
'Usage

Dim instance As IMessageSerializer
Dim types() As System.Type

instance.EnsureKnownTypes(types)
void EnsureKnownTypes(
   params System.Type[] types
)
procedure EnsureKnownTypes(
   params  types: System.Typearray of
);
function EnsureKnownTypes(
   types : System.Type[]
);
void EnsureKnownTypes(
   params System.Type*[]* types
)
void EnsureKnownTypes(
   ... System.array<Type^>^ types
)

Parameters

types
The types to register with the serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Interface
IMessageSerializer Members


Serialize Method (IMessageSerializer)

Serialize Method (IMessageSerializer)

Noemax.WebSockets.Messaging Namespace > IMessageSerializer Interface : Serialize Method
Serializes an object into the WebSocket message.
Overload List
Overload | Description
Serialize(Object) | Serializes an object into the WebSocket message.
Serialize(Stream,Object) | Initiates the outbound message with the streamed attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Interface
IMessageSerializer Members


Serialize(Object) Method

Serialize(Object) Method

Noemax.WebSockets.Messaging Namespace > IMessageSerializer Interface > Serialize Method : Serialize(Object) Method
The object to serialize into the message.
Serializes an object into the WebSocket message.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Serialize( _
   ByVal obj As System.Object _
) As WebSocketOutboundMessage
'Usage

Dim instance As IMessageSerializer
Dim obj As System.Object
Dim value As WebSocketOutboundMessage

value = instance.Serialize(obj)
WebSocketOutboundMessage Serialize(
   System.object obj
)
function Serialize(
    obj: System.TObject
): WebSocketOutboundMessage;
function Serialize(
   obj : System.Object
) : WebSocketOutboundMessage;
WebSocketOutboundMessage Serialize(
   System.Object* obj
)
WebSocketOutboundMessage Serialize(
   System.Object^ obj
)

Parameters

obj
The object to serialize into the message.

Return Value

The instance of WebSocketOutboundMessage containing a serialized object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Interface
IMessageSerializer Members
Overload List


Serialize(Stream,Object) Method

Serialize(Stream,Object) Method

Noemax.WebSockets.Messaging Namespace > IMessageSerializer Interface > Serialize Method : Serialize(Stream,Object) Method
The output stream through which to send the message.
The object to serialize into the method body.
Initiates the outbound message with the streamed attachment.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Function Serialize( _
   ByVal output As System.IO.Stream, _
   ByVal obj As System.Object _
) As System.IO.Stream
'Usage

Dim instance As IMessageSerializer
Dim output As System.IO.Stream
Dim obj As System.Object
Dim value As System.IO.Stream

value = instance.Serialize(output, obj)
System.IO.Stream Serialize(
   System.IO.Stream output,
   System.object obj
)
function Serialize(
    output: System.IO.Stream;
    obj: System.TObject
): System.IO.Stream;
function Serialize(
   output : System.IO.Stream,
   obj : System.Object
) : System.IO.Stream;
System.IO.Stream* Serialize(
   System.IO.Stream* output,
   System.Object* obj
)
System.IO.Stream^ Serialize(
   System.IO.Stream^ output,
   System.Object^ obj
)

Parameters

output
The output stream through which to send the message.
obj
The object to serialize into the method body.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

IMessageSerializer Interface
IMessageSerializer Members
Overload List


ActionOperation Delegate

ActionOperation Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Sub ActionOperation()
'Usage

Dim instance As New ActionOperation(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate void ActionOperation()
public delegate ActionOperation();
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public delegate ActionOperation()
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate void ActionOperation();
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate void ActionOperation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1 Delegate

ActionOperation1 Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation1 Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Delegate Sub ActionOperation1( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As New ActionOperation1(AddressOf HandlerMethod)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate void ActionOperation1(
   WebSocketChannel channel
)
public delegate ActionOperation1(
    channel: WebSocketChannel
);
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public delegate ActionOperation1(
   channel : WebSocketChannel
)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public: __gc __delegate void ActionOperation1(
   WebSocketChannel* channel
)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate void ActionOperation1(
   WebSocketChannel^ channel
)

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1 Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1<T> Delegate

ActionOperation1<T> Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation1<T> Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Delegate Sub ActionOperation1(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal parameter As T _
)
'Usage

Dim instance As New ActionOperation1(Of T)(AddressOf HandlerMethod)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate void ActionOperation1<T>(
   WebSocketChannel channel,
   T parameter
)
public delegate ActionOperation1(
    channel: WebSocketChannel;
    parameter: T
);
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public: __gc __delegate void ActionOperation1<T>(
   WebSocketChannel* channel,
   T* parameter
)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename T>
public delegate void ActionOperation1(
   WebSocketChannel^ channel,
   T^ parameter
)

Parameters

channel
parameter

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1<T> Members
Noemax.WebSockets.Messaging Namespace


FuncOperation<TResult,T> Delegate

FuncOperation<TResult,T> Delegate

Noemax.WebSockets.Messaging Namespace : FuncOperation<TResult,T> Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Function FuncOperation
    (Of TResult,T)( _
   ByVal parameter As T _
) As TResult
'Usage

Dim instance As New FuncOperation(Of TResult,T)(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate TResult FuncOperation<TResult,T>(
   T parameter
)
public delegate FuncOperation(
    parameter: T
);
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate TResult* FuncOperation<TResult,T>(
   T* parameter
)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename TResult>
generic<typename T>
public delegate TResult^ FuncOperation(
   T^ parameter
)

Parameters

parameter

Type Parameters

TResult
T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation<TResult,T> Members
Noemax.WebSockets.Messaging Namespace


FuncOperation1<TResult,T> Delegate

FuncOperation1<TResult,T> Delegate

Noemax.WebSockets.Messaging Namespace : FuncOperation1<TResult,T> Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Delegate Function FuncOperation1
    (Of TResult,T)( _
   ByVal channel As WebSocketChannel, _
   ByVal parameter As T _
) As TResult
'Usage

Dim instance As New FuncOperation1(Of TResult,T)(AddressOf HandlerMethod)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate TResult FuncOperation1<TResult,T>(
   WebSocketChannel channel,
   T parameter
)
public delegate FuncOperation1(
    channel: WebSocketChannel;
    parameter: T
);
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public: __gc __delegate TResult* FuncOperation1<TResult,T>(
   WebSocketChannel* channel,
   T* parameter
)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename TResult>
generic<typename T>
public delegate TResult^ FuncOperation1(
   WebSocketChannel^ channel,
   T^ parameter
)

Parameters

channel
parameter

Type Parameters

TResult
T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncOperation1<TResult,T> Members
Noemax.WebSockets.Messaging Namespace


VoidInputOperation<TResult> Delegate

VoidInputOperation<TResult> Delegate

Noemax.WebSockets.Messaging Namespace : VoidInputOperation<TResult> Delegate
The type of the data returns by message operation.
Defines the signature of the message operation that does not take any input but returns data.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Function VoidInputOperation(Of TResult)() As TResult
'Usage

Dim instance As New VoidInputOperation(Of TResult)(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate TResult VoidInputOperation<TResult>()
public delegate VoidInputOperation();
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate TResult* VoidInputOperation<TResult>();
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename TResult>
public delegate TResult^ VoidInputOperation();

Type Parameters

TResult
The type of the data returns by message operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperation<TResult> Members
Noemax.WebSockets.Messaging Namespace


VoidInputOperation1<TResult> Delegate

VoidInputOperation1<TResult> Delegate

Noemax.WebSockets.Messaging Namespace : VoidInputOperation1<TResult> Delegate
The type of the data returns by message operation.
Defines the signature of the message operation that does not take any input but returns data.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Function VoidInputOperation1(Of TResult)( _
   ByVal channel As WebSocketChannel _
) As TResult
'Usage

Dim instance As New VoidInputOperation1(Of TResult)(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate TResult VoidInputOperation1<TResult>(
   WebSocketChannel channel
)
public delegate VoidInputOperation1(
    channel: WebSocketChannel
);
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate TResult* VoidInputOperation1<TResult>(
   WebSocketChannel* channel
)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename TResult>
public delegate TResult^ VoidInputOperation1(
   WebSocketChannel^ channel
)

Parameters

channel

Type Parameters

TResult
The type of the data returns by message operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

VoidInputOperation1<TResult> Members
Noemax.WebSockets.Messaging Namespace


Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets)

Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets)
Inheritance Hierarchy
Classes
 | Class | Description
Class | WebSocketChannelExtensionsPom | Provides Noemax.WebSockets.WebSocketChannel with extension methods for Plain Object Messaging.
See Also

Reference

Noemax.WebSockets Assembly


WebSocketChannelExtensionsPom Class

WebSocketChannelExtensionsPom Class
Members

Noemax.WebSockets.Messaging.Pom Namespace : WebSocketChannelExtensionsPom Class
Provides Noemax.WebSockets.WebSocketChannel with extension methods for Plain Object Messaging.
Object Model
WebSocketChannelExtensionsPom Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public MustInherit NotInheritable Class WebSocketChannelExtensionsPom
'Usage

Dim instance As WebSocketChannelExtensionsPom
[System.Runtime.CompilerServices.Extension()]
public static class WebSocketChannelExtensionsPom
public class WebSocketChannelExtensionsPom abstract; sealed;
System.Runtime.CompilerServices.ExtensionAttribute()
public abstract sealed class WebSocketChannelExtensionsPom
[System.Runtime.CompilerServices.Extension()]
public __gc abstract __sealed class WebSocketChannelExtensionsPom
[System.Runtime.CompilerServices.Extension()]
public ref class WebSocketChannelExtensionsPom abstract sealed
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Pom.WebSocketChannelExtensionsPom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Members
Noemax.WebSockets.Messaging.Pom Namespace


WebSocketChannelExtensionsPom Class Members

WebSocketChannelExtensionsPom Class Members
Methods

Noemax.WebSockets.Messaging.Pom Namespace : WebSocketChannelExtensionsPom Class

The following tables list the members exposed by WebSocketChannelExtensionsPom.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage<TMessage> | Initiates and outbound message with streamed attachment.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
static (Shared in Visual Basic) | Send | Overloaded. Sends an one-way message to the remote endpoint.
static (Shared in Visual Basic) | SendAsync | Overloaded. Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Top
See Also

Reference

WebSocketChannelExtensionsPom Class
Noemax.WebSockets.Messaging.Pom Namespace


WebSocketChannelExtensionsPom Class Methods

WebSocketChannelExtensionsPom Class Methods

Noemax.WebSockets.Messaging.Pom Namespace : WebSocketChannelExtensionsPom Class

For a list of all members of this type, see WebSocketChannelExtensionsPom members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage<TMessage> | Initiates and outbound message with streamed attachment.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
static (Shared in Visual Basic) | Send | Overloaded. Sends an one-way message to the remote endpoint.
static (Shared in Visual Basic) | SendAsync | Overloaded. Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Top
See Also

Reference

WebSocketChannelExtensionsPom Class
Noemax.WebSockets.Messaging.Pom Namespace


CreateStreamedMessage<TMessage> Method (WebSocketChannelExtensionsPom)

CreateStreamedMessage<TMessage> Method (WebSocketChannelExtensionsPom)

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class : CreateStreamedMessage<TMessage> Method
The type of the message to be sent to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
The interval of time during whech operation is to be complete or fail due to timeout.
Initiates and outbound message with streamed attachment.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Shared Function CreateStreamedMessage(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
) As System.IO.Stream
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage
Dim timeout As System.TimeSpan
Dim value As System.IO.Stream

value = WebSocketChannelExtensionsPom.CreateStreamedMessage(Of TMessage)(channel, message, timeout)
[System.Runtime.CompilerServices.Extension()]
public static System.IO.Stream CreateStreamedMessage<TMessage>(
   WebSocketChannel channel,
   TMessage message,
   System.TimeSpan timeout
)
public function CreateStreamedMessage(
    channel: WebSocketChannel;
    message: TMessage;
    timeout: System.TimeSpan
): System.IO.Stream; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function CreateStreamedMessage(
   channel : WebSocketChannel,
   message : TMessage,
   timeout : System.TimeSpan
) : System.IO.Stream;
[System.Runtime.CompilerServices.Extension()]
public: static System.IO.Stream* CreateStreamedMessage<TMessage>(
   WebSocketChannel* channel,
   TMessage* message,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.IO.Stream^ CreateStreamedMessagegeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.
timeout
The interval of time during whech operation is to be complete or fail due to timeout.

Type Parameters

TMessage
The type of the message to be sent to remote endpoint.

Return Value

The stream to write message attachment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members


Request Method (WebSocketChannelExtensionsPom)

Request Method (WebSocketChannelExtensionsPom)

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class : Request Method
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Overload List
Overload | Description
Request<TRequest,TResult>(WebSocketChannel,TRequest,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest,TResult>(WebSocketChannel,TRequest) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest>(WebSocketChannel,TRequest,Stream,TimeSpan) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Request<TRequest>(WebSocketChannel,TRequest,Stream) | Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members


Request<TRequest,TResult>(WebSocketChannel,TRequest,TimeSpan) Method

Request<TRequest,TResult>(WebSocketChannel,TRequest,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest,TResult>(WebSocketChannel,TRequest,TimeSpan) Method
The type of request data to send to the remote operation.
The type of response expected to be received from the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TRequest,TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim timeout As System.TimeSpan
Dim value As TResult

value = WebSocketChannelExtensionsPom.Request(Of TRequest, TResult)(channel, request, timeout)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TRequest,TResult>(
   WebSocketChannel channel,
   TRequest request,
   System.TimeSpan timeout
)
public function Request(
    channel: WebSocketChannel;
    request: TRequest;
    timeout: System.TimeSpan
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest,
   timeout : System.TimeSpan
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TRequest,TResult>(
   WebSocketChannel* channel,
   TRequest* request,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   WebSocketChannel^ channel,
   TRequest^ request,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TRequest
The type of request data to send to the remote operation.
TResult
The type of response expected to be received from the remote operation.

Return Value

The response provided by the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Request<TRequest,TResult>(WebSocketChannel,TRequest) Method

Request<TRequest,TResult>(WebSocketChannel,TRequest) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest,TResult>(WebSocketChannel,TRequest) Method
The type of request data to send to the remote operation.
The type of response expected to be received from the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TRequest,TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim value As TResult

value = WebSocketChannelExtensionsPom.Request(Of TRequest, TResult)(channel, request)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TRequest,TResult>(
   WebSocketChannel channel,
   TRequest request
)
public function Request(
    channel: WebSocketChannel;
    request: TRequest
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TRequest,TResult>(
   WebSocketChannel* channel,
   TRequest* request
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   WebSocketChannel^ channel,
   TRequest^ request
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.

Type Parameters

TRequest
The type of request data to send to the remote operation.
TResult
The type of response expected to be received from the remote operation.

Return Value

The response provided by the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream,TimeSpan) Method

Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream,TimeSpan) Method
The type of request data to send to the remote operation.
The type of response expected to be received from the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
The stream of bytes to send along with the request message as attachment.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TRequest,TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan
Dim value As TResult

value = WebSocketChannelExtensionsPom.Request(Of TRequest, TResult)(channel, request, attachment, timeout)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TRequest,TResult>(
   WebSocketChannel channel,
   TRequest request,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
public function Request(
    channel: WebSocketChannel;
    request: TRequest;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TRequest,TResult>(
   WebSocketChannel* channel,
   TRequest* request,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   WebSocketChannel^ channel,
   TRequest^ request,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.
attachment
The stream of bytes to send along with the request message as attachment.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TRequest
The type of request data to send to the remote operation.
TResult
The type of response expected to be received from the remote operation.

Return Value

The response provided by the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream) Method

Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest,TResult>(WebSocketChannel,TRequest,Stream) Method
The type of request data to send to the remote operation.
The type of response expected to be received from the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
The stream of bytes to send along with the request message as attachment.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function Request
    (Of TRequest,TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream _
) As TResult
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim attachment As System.IO.Stream
Dim value As TResult

value = WebSocketChannelExtensionsPom.Request(Of TRequest, TResult)(channel, request, attachment)
[System.Runtime.CompilerServices.Extension()]
public static TResult Request<TRequest,TResult>(
   WebSocketChannel channel,
   TRequest request,
   System.IO.Stream attachment
)
public function Request(
    channel: WebSocketChannel;
    request: TRequest;
    attachment: System.IO.Stream
): TResult; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest,
   attachment : System.IO.Stream
) : TResult;
[System.Runtime.CompilerServices.Extension()]
public: static TResult* Request<TRequest,TResult>(
   WebSocketChannel* channel,
   TRequest* request,
   System.IO.Stream* attachment
)
[System.Runtime.CompilerServices.Extension()]
public:
static TResult^ Requestgeneric<typename TRequest>
generic<typename TResult>
(
   WebSocketChannel^ channel,
   TRequest^ request,
   System.IO.Stream^ attachment
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.
attachment
The stream of bytes to send along with the request message as attachment.

Type Parameters

TRequest
The type of request data to send to the remote operation.
TResult
The type of response expected to be received from the remote operation.

Return Value

The response provided by the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Request<TRequest>(WebSocketChannel,TRequest,Stream,TimeSpan) Method

Request<TRequest>(WebSocketChannel,TRequest,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest>(WebSocketChannel,TRequest,Stream,TimeSpan) Method
The type of request data to send to the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
The stream of bytes to send along with the request message as attachment.
The period of time during which request must complete or timeout.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Request(Of TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

WebSocketChannelExtensionsPom.Request(Of TRequest)(channel, request, attachment, timeout)
[System.Runtime.CompilerServices.Extension()]
public static void Request<TRequest>(
   WebSocketChannel channel,
   TRequest request,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
public procedure Request(
    channel: WebSocketChannel;
    request: TRequest;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
[System.Runtime.CompilerServices.Extension()]
public: static void Request<TRequest>(
   WebSocketChannel* channel,
   TRequest* request,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Requestgeneric<typename TRequest>
(
   WebSocketChannel^ channel,
   TRequest^ request,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.
attachment
The stream of bytes to send along with the request message as attachment.
timeout
The period of time during which request must complete or timeout.

Type Parameters

TRequest
The type of request data to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Request<TRequest>(WebSocketChannel,TRequest,Stream) Method

Request<TRequest>(WebSocketChannel,TRequest,Stream) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Request Method : Request<TRequest>(WebSocketChannel,TRequest,Stream) Method
The type of request data to send to the remote operation.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message to send to the remote endpoint.
The stream of bytes to send along with the request message as attachment.
Sends the request to the remote endpoint through the specified channel and returns the response provided for the request.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Request(Of TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal request As TRequest, _
   ByVal attachment As System.IO.Stream _
)
'Usage

Dim channel As WebSocketChannel
Dim request As TRequest
Dim attachment As System.IO.Stream

WebSocketChannelExtensionsPom.Request(Of TRequest)(channel, request, attachment)
[System.Runtime.CompilerServices.Extension()]
public static void Request<TRequest>(
   WebSocketChannel channel,
   TRequest request,
   System.IO.Stream attachment
)
public procedure Request(
    channel: WebSocketChannel;
    request: TRequest;
    attachment: System.IO.Stream
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Request(
   channel : WebSocketChannel,
   request : TRequest,
   attachment : System.IO.Stream
);
[System.Runtime.CompilerServices.Extension()]
public: static void Request<TRequest>(
   WebSocketChannel* channel,
   TRequest* request,
   System.IO.Stream* attachment
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Requestgeneric<typename TRequest>
(
   WebSocketChannel^ channel,
   TRequest^ request,
   System.IO.Stream^ attachment
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
request
The message to send to the remote endpoint.
attachment
The stream of bytes to send along with the request message as attachment.

Type Parameters

TRequest
The type of request data to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Send Method (WebSocketChannelExtensionsPom)

Send Method (WebSocketChannelExtensionsPom)

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class : Send Method
Sends an one-way message to the remote endpoint.
Overload List
Overload | Description
Send<TMessage>(WebSocketChannel,TMessage,TimeSpan) | Sends an one-way message to the remote endpoint.
Send<TMessage>(WebSocketChannel,TMessage) | Sends an one-way message to the remote endpoint.
Send<TMessage>(WebSocketChannel,TMessage,Stream,TimeSpan) | Sends an one-way message to the remote endpoint.
Send<TMessage>(WebSocketChannel,TMessage,Stream) | Sends an one-way message to the remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members


Send<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method

Send<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Send Method : Send<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Send(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage
Dim timeout As System.TimeSpan

WebSocketChannelExtensionsPom.Send(Of TMessage)(channel, message, timeout)
[System.Runtime.CompilerServices.Extension()]
public static void Send<TMessage>(
   WebSocketChannel channel,
   TMessage message,
   System.TimeSpan timeout
)
public procedure Send(
    channel: WebSocketChannel;
    message: TMessage;
    timeout: System.TimeSpan
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Send(
   channel : WebSocketChannel,
   message : TMessage,
   timeout : System.TimeSpan
);
[System.Runtime.CompilerServices.Extension()]
public: static void Send<TMessage>(
   WebSocketChannel* channel,
   TMessage* message,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Sendgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Send<TMessage>(WebSocketChannel,TMessage) Method

Send<TMessage>(WebSocketChannel,TMessage) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Send Method : Send<TMessage>(WebSocketChannel,TMessage) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Send(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage

WebSocketChannelExtensionsPom.Send(Of TMessage)(channel, message)
[System.Runtime.CompilerServices.Extension()]
public static void Send<TMessage>(
   WebSocketChannel channel,
   TMessage message
)
public procedure Send(
    channel: WebSocketChannel;
    message: TMessage
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Send(
   channel : WebSocketChannel,
   message : TMessage
);
[System.Runtime.CompilerServices.Extension()]
public: static void Send<TMessage>(
   WebSocketChannel* channel,
   TMessage* message
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Sendgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Send<TMessage>(WebSocketChannel,TMessage,Stream,TimeSpan) Method

Send<TMessage>(WebSocketChannel,TMessage,Stream,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Send Method : Send<TMessage>(WebSocketChannel,TMessage,Stream,TimeSpan) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
The attachment stream to send along with message.
The period of time during which operation must be completed or timeout.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Send(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage, _
   ByVal attachment As System.IO.Stream, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage
Dim attachment As System.IO.Stream
Dim timeout As System.TimeSpan

WebSocketChannelExtensionsPom.Send(Of TMessage)(channel, message, attachment, timeout)
[System.Runtime.CompilerServices.Extension()]
public static void Send<TMessage>(
   WebSocketChannel channel,
   TMessage message,
   System.IO.Stream attachment,
   System.TimeSpan timeout
)
public procedure Send(
    channel: WebSocketChannel;
    message: TMessage;
    attachment: System.IO.Stream;
    timeout: System.TimeSpan
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Send(
   channel : WebSocketChannel,
   message : TMessage,
   attachment : System.IO.Stream,
   timeout : System.TimeSpan
);
[System.Runtime.CompilerServices.Extension()]
public: static void Send<TMessage>(
   WebSocketChannel* channel,
   TMessage* message,
   System.IO.Stream* attachment,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Sendgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message,
   System.IO.Stream^ attachment,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.
attachment
The attachment stream to send along with message.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Send<TMessage>(WebSocketChannel,TMessage,Stream) Method

Send<TMessage>(WebSocketChannel,TMessage,Stream) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > Send Method : Send<TMessage>(WebSocketChannel,TMessage,Stream) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
The attachment stream to send along with message.
Sends an one-way message to the remote endpoint.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub Send(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage, _
   ByVal attachment As System.IO.Stream _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage
Dim attachment As System.IO.Stream

WebSocketChannelExtensionsPom.Send(Of TMessage)(channel, message, attachment)
[System.Runtime.CompilerServices.Extension()]
public static void Send<TMessage>(
   WebSocketChannel channel,
   TMessage message,
   System.IO.Stream attachment
)
public procedure Send(
    channel: WebSocketChannel;
    message: TMessage;
    attachment: System.IO.Stream
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function Send(
   channel : WebSocketChannel,
   message : TMessage,
   attachment : System.IO.Stream
);
[System.Runtime.CompilerServices.Extension()]
public: static void Send<TMessage>(
   WebSocketChannel* channel,
   TMessage* message,
   System.IO.Stream* attachment
)
[System.Runtime.CompilerServices.Extension()]
public:
static void Sendgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message,
   System.IO.Stream^ attachment
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.
attachment
The attachment stream to send along with message.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


SendAsync Method (WebSocketChannelExtensionsPom)

SendAsync Method (WebSocketChannelExtensionsPom)

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class : SendAsync Method
Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Overload List
Overload | Description
SendAsync<TMessage>(WebSocketChannel,TMessage,TimeSpan) | Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
SendAsync<TMessage>(WebSocketChannel,TMessage) | Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members


SendAsync<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method

SendAsync<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > SendAsync Method : SendAsync<TMessage>(WebSocketChannel,TMessage,TimeSpan) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
The period of time during which operation must be completed or timeout.
Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendAsync(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage, _
   ByVal timeout As System.TimeSpan _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage
Dim timeout As System.TimeSpan

WebSocketChannelExtensionsPom.SendAsync(Of TMessage)(channel, message, timeout)
[System.Runtime.CompilerServices.Extension()]
public static void SendAsync<TMessage>(
   WebSocketChannel channel,
   TMessage message,
   System.TimeSpan timeout
)
public procedure SendAsync(
    channel: WebSocketChannel;
    message: TMessage;
    timeout: System.TimeSpan
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendAsync(
   channel : WebSocketChannel,
   message : TMessage,
   timeout : System.TimeSpan
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendAsync<TMessage>(
   WebSocketChannel* channel,
   TMessage* message,
   System.TimeSpan timeout
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendAsyncgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message,
   System.TimeSpan timeout
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.
timeout
The period of time during which operation must be completed or timeout.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


SendAsync<TMessage>(WebSocketChannel,TMessage) Method

SendAsync<TMessage>(WebSocketChannel,TMessage) Method

Noemax.WebSockets.Messaging.Pom Namespace > WebSocketChannelExtensionsPom Class > SendAsync Method : SendAsync<TMessage>(WebSocketChannel,TMessage) Method
The type of the data to send to remote endpoint.
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
The message being sent.
Sends a one-way mesasge to the remote endpoint asycnhronously without blocking the sending thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendAsync(Of TMessage)( _
   ByVal channel As WebSocketChannel, _
   ByVal message As TMessage _
)
'Usage

Dim channel As WebSocketChannel
Dim message As TMessage

WebSocketChannelExtensionsPom.SendAsync(Of TMessage)(channel, message)
[System.Runtime.CompilerServices.Extension()]
public static void SendAsync<TMessage>(
   WebSocketChannel channel,
   TMessage message
)
public procedure SendAsync(
    channel: WebSocketChannel;
    message: TMessage
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendAsync(
   channel : WebSocketChannel,
   message : TMessage
);
[System.Runtime.CompilerServices.Extension()]
public: static void SendAsync<TMessage>(
   WebSocketChannel* channel,
   TMessage* message
)
[System.Runtime.CompilerServices.Extension()]
public:
static void SendAsyncgeneric<typename TMessage>
(
   WebSocketChannel^ channel,
   TMessage^ message
)

Parameters

channel
The Noemax.WebSockets.WebSocketChannel through which the message is being sent.
message
The message being sent.

Type Parameters

TMessage
The type of the data to send to remote endpoint.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensionsPom Class
WebSocketChannelExtensionsPom Members
Overload List


Noemax.WebSockets.Net4 Assembly

Noemax.WebSockets.Net4 Assembly
Namespaces
Namespace | Description
Noemax.Newtonsoft.Json |
Noemax.Newtonsoft.Json.Bson |
Noemax.Newtonsoft.Json.Converters |
Noemax.Newtonsoft.Json.Linq |
Noemax.Newtonsoft.Json.Linq.JsonPath |
Noemax.Newtonsoft.Json.Schema |
Noemax.Newtonsoft.Json.Serialization |
Noemax.Newtonsoft.Json.Utilities |
Noemax.WebSockets |
Noemax.WebSockets.Core |
Noemax.WebSockets.Messaging |
Noemax.WebSockets.Messaging.Pom |


Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | JsonArrayAttribute | Instructs the JsonSerializer how to serialize the collection.
Class | JsonConstructorAttribute | Instructs the JsonSerializer to use the specified constructor when deserializing that object.
Class | JsonContainerAttribute | Instructs the JsonSerializer how to serialize the object.
Class | JsonConvert | Provides methods for converting between common language runtime types and JSON types.
Class | JsonConverter | Converts an object to and from JSON.
Class | JsonConverterAttribute | Instructs the JsonSerializer to use the specified JsonConverter when serializing the member or class.
Class | JsonConverterCollection | Represents a collection of JsonConverter.
Class | JsonDictionaryAttribute | Instructs the JsonSerializer how to serialize the collection.
Class | JsonException | The exception thrown when an error occurs during Json serialization or deserialization.
Class | JsonExtensionDataAttribute | Instructs the JsonSerializer to deserialize properties with no matching class member into the specified collection and write values during serialization.
Class | JsonIgnoreAttribute | Instructs the JsonSerializer not to serialize the public field or public read/write property value.
Class | JsonObjectAttribute | Instructs the JsonSerializer how to serialize the object.
Class | JsonPropertyAttribute | Instructs the JsonSerializer to always serialize the member with the specified name.
Class | JsonReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | JsonReaderException | The exception thrown when an error occurs while reading Json text.
Class | JsonSerializationException | The exception thrown when an error occurs during Json serialization or deserialization.
Class | JsonSerializer | Serializes and deserializes objects into and from the JSON format. The JsonSerializer enables you to control how objects are encoded into JSON.
Class | JsonSerializerSettings | Specifies the settings on a JsonSerializer object.
Class | JsonTextReader | Represents a reader that provides fast, non-cached, forward-only access to JSON text data.
Class | JsonTextWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JsonValidatingReader | Represents a reader that provides Noemax.Newtonsoft.Json.Schema.JsonSchema validation.
Class | JsonWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JsonWriterException | The exception thrown when an error occurs while reading Json text.
Interfaces
 | Interface | Description
Interface | IJsonLineInfo | Provides an interface to enable a class to return line and position information.
Enumerations
 | Enumeration | Description
Enumeration | ConstructorHandling | Specifies how constructors are used when initializing objects during deserialization by the JsonSerializer.
Enumeration | DateFormatHandling | Specifies how dates are formatted when writing JSON text.
Enumeration | DateParseHandling | Specifies how date formatted strings, e.g. "\/Date(1198908717056)\/" and "2012-03-21T05:40Z", are parsed when reading JSON text.
Enumeration | DateTimeZoneHandling | Specifies how to treat the time value when converting between string and System.DateTime.
Enumeration | DefaultValueHandling | Specifies default value handling options for the JsonSerializer.
Enumeration | FloatFormatHandling | Specifies float format handling options when writing special floating point numbers, e.g. System.Double.NaN, System.Double.PositiveInfinity and System.Double.NegativeInfinity with JsonWriter.
Enumeration | FloatParseHandling | Specifies how floating point numbers, e.g. 1.0 and 9.9, are parsed when reading JSON text.
Enumeration | Formatting | Specifies formatting options for the JsonTextWriter.
Enumeration | JsonToken | Specifies the type of Json token.
Enumeration | MemberSerialization | Specifies the member serialization options for the JsonSerializer.
Enumeration | MetadataPropertyHandling | Specifies metadata property handling options for the JsonSerializer.
Enumeration | MissingMemberHandling | Specifies missing member handling options for the JsonSerializer.
Enumeration | NullValueHandling | Specifies null value handling options for the JsonSerializer.
Enumeration | ObjectCreationHandling | Specifies how object creation is handled by the JsonSerializer.
Enumeration | PreserveReferencesHandling | Specifies reference handling options for the JsonSerializer. Note that references cannot be preserved when a value is set via a non-default constructor such as types that implement ISerializable.
Enumeration | ReferenceLoopHandling | Specifies reference loop handling options for the JsonSerializer.
Enumeration | Required | Indicating whether a property is required.
Enumeration | StringEscapeHandling | Specifies how strings are escaped when writing JSON text.
Enumeration | TypeNameHandling | Specifies type name handling options for the JsonSerializer.
Enumeration | WriteState | Specifies the state of the JsonWriter.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


JsonConvert Class Members

JsonConvert Class Members
Fields Properties Methods

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

The following tables list the members exposed by JsonConvert.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | False | Represents JavaScript's boolean value false as a string. This field is read-only.
static (Shared in Visual Basic) | NaN | Represents JavaScript's NaN as a string. This field is read-only.
static (Shared in Visual Basic) | NegativeInfinity | Represents JavaScript's negative infinity as a string. This field is read-only.
static (Shared in Visual Basic) | Null | Represents JavaScript's null as a string. This field is read-only.
static (Shared in Visual Basic) | PositiveInfinity | Represents JavaScript's positive infinity as a string. This field is read-only.
static (Shared in Visual Basic) | True | Represents JavaScript's boolean value true as a string. This field is read-only.
static (Shared in Visual Basic) | Undefined | Represents JavaScript's undefined as a string. This field is read-only.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | DefaultSettings | Gets or sets a function that creates default JsonSerializerSettings. Default settings are automatically used by serialization methods on JsonConvert, and Noemax.Newtonsoft.Json.Linq.JToken.ToObject``1 and Noemax.Newtonsoft.Json.Linq.JToken.FromObject on Noemax.Newtonsoft.Json.Linq.JToken. To serialize without using any default settings create a JsonSerializer with JsonSerializer.Create.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | DeserializeAnonymousType | Overloaded. Deserializes the JSON to the given anonymous type.
static (Shared in Visual Basic) | DeserializeObject | Overloaded. Deserializes the JSON to a .NET object.
static (Shared in Visual Basic) | DeserializeObjectAsync | Overloaded. Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
static (Shared in Visual Basic) | DeserializeXmlNode | Overloaded. Deserializes the XmlNode from a JSON string.
static (Shared in Visual Basic) | DeserializeXNode | Overloaded. Deserializes the System.Xml.Linq.XNode from a JSON string.
static (Shared in Visual Basic) | PopulateObject | Overloaded. Populates the object with values from the JSON string.
static (Shared in Visual Basic) | PopulateObjectAsync | Asynchronously populates the object with values from the JSON string using JsonSerializerSettings.
static (Shared in Visual Basic) | SerializeObject | Overloaded. Serializes the specified object to a JSON string.
static (Shared in Visual Basic) | SerializeObjectAsync | Overloaded. Asynchronously serializes the specified object to a JSON string. Serialization will happen on a new thread.
static (Shared in Visual Basic) | SerializeXmlNode | Overloaded. Serializes the XML node to a JSON string.
static (Shared in Visual Basic) | SerializeXNode | Overloaded. Serializes the System.Xml.Linq.XNode to a JSON string.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the System.DateTime to its JSON string representation.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


JsonConvert Class Methods

JsonConvert Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConvert Class

For a list of all members of this type, see JsonConvert members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | DeserializeAnonymousType | Overloaded. Deserializes the JSON to the given anonymous type.
static (Shared in Visual Basic) | DeserializeObject | Overloaded. Deserializes the JSON to a .NET object.
static (Shared in Visual Basic) | DeserializeObjectAsync | Overloaded. Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
static (Shared in Visual Basic) | DeserializeXmlNode | Overloaded. Deserializes the XmlNode from a JSON string.
static (Shared in Visual Basic) | DeserializeXNode | Overloaded. Deserializes the System.Xml.Linq.XNode from a JSON string.
static (Shared in Visual Basic) | PopulateObject | Overloaded. Populates the object with values from the JSON string.
static (Shared in Visual Basic) | PopulateObjectAsync | Asynchronously populates the object with values from the JSON string using JsonSerializerSettings.
static (Shared in Visual Basic) | SerializeObject | Overloaded. Serializes the specified object to a JSON string.
static (Shared in Visual Basic) | SerializeObjectAsync | Overloaded. Asynchronously serializes the specified object to a JSON string. Serialization will happen on a new thread.
static (Shared in Visual Basic) | SerializeXmlNode | Overloaded. Serializes the XML node to a JSON string.
static (Shared in Visual Basic) | SerializeXNode | Overloaded. Serializes the System.Xml.Linq.XNode to a JSON string.
static (Shared in Visual Basic) | ToString | Overloaded. Converts the System.DateTime to its JSON string representation.
Top
See Also

Reference

JsonConvert Class
Noemax.Newtonsoft.Json Namespace


DeserializeObjectAsync Method

DeserializeObjectAsync Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : DeserializeObjectAsync Method
Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
Overload List
Overload | Description
DeserializeObjectAsync<T>(String) | Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
DeserializeObjectAsync<T>(String,JsonSerializerSettings) | Asynchronously deserializes the JSON to the specified .NET type using JsonSerializerSettings. Deserialization will happen on a new thread.
DeserializeObjectAsync(String) | Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
DeserializeObjectAsync(String,Type,JsonSerializerSettings) | Asynchronously deserializes the JSON to the specified .NET type using JsonSerializerSettings. Deserialization will happen on a new thread.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


DeserializeObjectAsync<T>(String) Method

DeserializeObjectAsync<T>(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObjectAsync Method : DeserializeObjectAsync<T>(String) Method
The type of the object to deserialize to.
The JSON to deserialize.
Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value))")>
Public Overloads Shared Function DeserializeObjectAsync(Of T)( _
   ByVal value As System.String _
) As System.Threading.Tasks.Task(Of T)
'Usage

Dim value As System.String
Dim value As System.Threading.Tasks.Task(Of T)

value = JsonConvert.DeserializeObjectAsync(Of T)(value)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value))")]
public static System.Threading.Tasks.Task<T> DeserializeObjectAsync<T>(
   System.string value
)
public function DeserializeObjectAsync(
    value: System.String
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value))")
public static function DeserializeObjectAsync(
   value : System.String
) : System.Threading.Tasks.Task;
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value))")]
public: static System.Threading.Tasks.Task<T*>* DeserializeObjectAsync<T>(
   System.string* value
)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value))")]
public:
static System.Threading.Tasks.Task<T^>^ DeserializeObjectAsyncgeneric<typename T>
(
   System.String^ value
)

Parameters

value
The JSON to deserialize.

Type Parameters

T
The type of the object to deserialize to.

Return Value

A task that represents the asynchronous deserialize operation. The value of the TResult parameter contains the deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObjectAsync<T>(String,JsonSerializerSettings) Method

DeserializeObjectAsync<T>(String,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObjectAsync Method : DeserializeObjectAsync<T>(String,JsonSerializerSettings) Method
The type of the object to deserialize to.
The JSON to deserialize.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Asynchronously deserializes the JSON to the specified .NET type using JsonSerializerSettings. Deserialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value, settings))")>
Public Overloads Shared Function DeserializeObjectAsync(Of T)( _
   ByVal value As System.String, _
   ByVal settings As JsonSerializerSettings _
) As System.Threading.Tasks.Task(Of T)
'Usage

Dim value As System.String
Dim settings As JsonSerializerSettings
Dim value As System.Threading.Tasks.Task(Of T)

value = JsonConvert.DeserializeObjectAsync(Of T)(value, settings)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value, settings))")]
public static System.Threading.Tasks.Task<T> DeserializeObjectAsync<T>(
   System.string value,
   JsonSerializerSettings settings
)
public function DeserializeObjectAsync(
    value: System.String;
    settings: JsonSerializerSettings
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value, settings))")
public static function DeserializeObjectAsync(
   value : System.String,
   settings : JsonSerializerSettings
) : System.Threading.Tasks.Task;
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value, settings))")]
public: static System.Threading.Tasks.Task<T*>* DeserializeObjectAsync<T>(
   System.string* value,
   JsonSerializerSettings* settings
)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject<T>(value, settings))")]
public:
static System.Threading.Tasks.Task<T^>^ DeserializeObjectAsyncgeneric<typename T>
(
   System.String^ value,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to deserialize.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Type Parameters

T
The type of the object to deserialize to.

Return Value

A task that represents the asynchronous deserialize operation. The value of the TResult parameter contains the deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObjectAsync(String) Method

DeserializeObjectAsync(String) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObjectAsync Method : DeserializeObjectAsync(String) Method
The JSON to deserialize.
Asynchronously deserializes the JSON to the specified .NET type. Deserialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value))")>
Public Overloads Shared Function DeserializeObjectAsync( _
   ByVal value As System.String _
) As System.Threading.Tasks.Task(Of Object)
'Usage

Dim value As System.String
Dim value As System.Threading.Tasks.Task(Of Object)

value = JsonConvert.DeserializeObjectAsync(value)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value))")]
public static System.Threading.Tasks.Task<object> DeserializeObjectAsync(
   System.string value
)
public function DeserializeObjectAsync(
    value: System.String
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value))")
public static function DeserializeObjectAsync(
   value : System.String
) : System.Threading.Tasks.Task;
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value))")]
public: static System.Threading.Tasks.Task<Object*>* DeserializeObjectAsync(
   System.string* value
)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value))")]
public:
static System.Threading.Tasks.Task<Object^>^ DeserializeObjectAsync(
   System.String^ value
)

Parameters

value
The JSON to deserialize.

Return Value

A task that represents the asynchronous deserialize operation. The value of the TResult parameter contains the deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


DeserializeObjectAsync(String,Type,JsonSerializerSettings) Method

DeserializeObjectAsync(String,Type,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > DeserializeObjectAsync Method : DeserializeObjectAsync(String,Type,JsonSerializerSettings) Method
The JSON to deserialize.
The type of the object to deserialize to.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Asynchronously deserializes the JSON to the specified .NET type using JsonSerializerSettings. Deserialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value, type, settings))")>
Public Overloads Shared Function DeserializeObjectAsync( _
   ByVal value As System.String, _
   ByVal type As System.Type, _
   ByVal settings As JsonSerializerSettings _
) As System.Threading.Tasks.Task(Of Object)
'Usage

Dim value As System.String
Dim type As System.Type
Dim settings As JsonSerializerSettings
Dim value As System.Threading.Tasks.Task(Of Object)

value = JsonConvert.DeserializeObjectAsync(value, type, settings)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value, type, settings))")]
public static System.Threading.Tasks.Task<object> DeserializeObjectAsync(
   System.string value,
   System.Type type,
   JsonSerializerSettings settings
)
public function DeserializeObjectAsync(
    value: System.String;
    type: System.Type;
    settings: JsonSerializerSettings
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value, type, settings))")
public static function DeserializeObjectAsync(
   value : System.String,
   type : System.Type,
   settings : JsonSerializerSettings
) : System.Threading.Tasks.Task;
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value, type, settings))")]
public: static System.Threading.Tasks.Task<Object*>* DeserializeObjectAsync(
   System.string* value,
   System.Type* type,
   JsonSerializerSettings* settings
)
[System.Obsolete("DeserializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to deserialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.DeserializeObject(value, type, settings))")]
public:
static System.Threading.Tasks.Task<Object^>^ DeserializeObjectAsync(
   System.String^ value,
   System.Type^ type,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to deserialize.
type
The type of the object to deserialize to.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Return Value

A task that represents the asynchronous deserialize operation. The value of the TResult parameter contains the deserialized object from the JSON string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


PopulateObjectAsync Method

PopulateObjectAsync Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : PopulateObjectAsync Method
The JSON to populate values from.
The target object to populate values onto.
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.
Asynchronously populates the object with values from the JSON string using JsonSerializerSettings.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("PopulateObjectAsync is obsolete. Use the Task.Factory.StartNew method to populate an object with JSON values asynchronously: Task.Factory.StartNew(() => JsonConvert.PopulateObject(value, target, settings))")>
Public Shared Function PopulateObjectAsync( _
   ByVal value As System.String, _
   ByVal target As System.Object, _
   ByVal settings As JsonSerializerSettings _
) As System.Threading.Tasks.Task
'Usage

Dim value As System.String
Dim target As System.Object
Dim settings As JsonSerializerSettings
Dim value As System.Threading.Tasks.Task

value = JsonConvert.PopulateObjectAsync(value, target, settings)
[System.Obsolete("PopulateObjectAsync is obsolete. Use the Task.Factory.StartNew method to populate an object with JSON values asynchronously: Task.Factory.StartNew(() => JsonConvert.PopulateObject(value, target, settings))")]
public static System.Threading.Tasks.Task PopulateObjectAsync(
   System.string value,
   System.object target,
   JsonSerializerSettings settings
)
public function PopulateObjectAsync(
    value: System.String;
    target: System.TObject;
    settings: JsonSerializerSettings
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("PopulateObjectAsync is obsolete. Use the Task.Factory.StartNew method to populate an object with JSON values asynchronously: Task.Factory.StartNew(() => JsonConvert.PopulateObject(value, target, settings))")
public static function PopulateObjectAsync(
   value : System.String,
   target : System.Object,
   settings : JsonSerializerSettings
) : System.Threading.Tasks.Task;
[System.Obsolete("PopulateObjectAsync is obsolete. Use the Task.Factory.StartNew method to populate an object with JSON values asynchronously: Task.Factory.StartNew(() => JsonConvert.PopulateObject(value, target, settings))")]
public: static System.Threading.Tasks.Task* PopulateObjectAsync(
   System.string* value,
   System.Object* target,
   JsonSerializerSettings* settings
)
[System.Obsolete("PopulateObjectAsync is obsolete. Use the Task.Factory.StartNew method to populate an object with JSON values asynchronously: Task.Factory.StartNew(() => JsonConvert.PopulateObject(value, target, settings))")]
public:
static System.Threading.Tasks.Task^ PopulateObjectAsync(
   System.String^ value,
   System.Object^ target,
   JsonSerializerSettings^ settings
)

Parameters

value
The JSON to populate values from.
target
The target object to populate values onto.
settings
The JsonSerializerSettings used to deserialize the object. If this is null, default serialization settings will be is used.

Return Value

A task that represents the asynchronous populate operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


SerializeObjectAsync Method

SerializeObjectAsync Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class : SerializeObjectAsync Method
Asynchronously serializes the specified object to a JSON string. Serialization will happen on a new thread.
Overload List
Overload | Description
SerializeObjectAsync(Object) | Asynchronously serializes the specified object to a JSON string. Serialization will happen on a new thread.
SerializeObjectAsync(Object,Formatting) | Asynchronously serializes the specified object to a JSON string using formatting. Serialization will happen on a new thread.
SerializeObjectAsync(Object,Formatting,JsonSerializerSettings) | Asynchronously serializes the specified object to a JSON string using formatting and a collection of JsonConverter. Serialization will happen on a new thread.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members


SerializeObjectAsync(Object) Method

SerializeObjectAsync(Object) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObjectAsync Method : SerializeObjectAsync(Object) Method
The object to serialize.
Asynchronously serializes the specified object to a JSON string. Serialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value))")>
Public Overloads Shared Function SerializeObjectAsync( _
   ByVal value As System.Object _
) As System.Threading.Tasks.Task(Of String)
'Usage

Dim value As System.Object
Dim value As System.Threading.Tasks.Task(Of String)

value = JsonConvert.SerializeObjectAsync(value)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value))")]
public static System.Threading.Tasks.Task<string> SerializeObjectAsync(
   System.object value
)
public function SerializeObjectAsync(
    value: System.TObject
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value))")
public static function SerializeObjectAsync(
   value : System.Object
) : System.Threading.Tasks.Task;
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value))")]
public: static System.Threading.Tasks.Task<string*>* SerializeObjectAsync(
   System.Object* value
)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value))")]
public:
static System.Threading.Tasks.Task<String^>^ SerializeObjectAsync(
   System.Object^ value
)

Parameters

value
The object to serialize.

Return Value

A task that represents the asynchronous serialize operation. The value of the TResult parameter contains a JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObjectAsync(Object,Formatting) Method

SerializeObjectAsync(Object,Formatting) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObjectAsync Method : SerializeObjectAsync(Object,Formatting) Method
The object to serialize.
Indicates how the output is formatted.
Asynchronously serializes the specified object to a JSON string using formatting. Serialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting))")>
Public Overloads Shared Function SerializeObjectAsync( _
   ByVal value As System.Object, _
   ByVal formatting As Formatting _
) As System.Threading.Tasks.Task(Of String)
'Usage

Dim value As System.Object
Dim formatting As Formatting
Dim value As System.Threading.Tasks.Task(Of String)

value = JsonConvert.SerializeObjectAsync(value, formatting)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting))")]
public static System.Threading.Tasks.Task<string> SerializeObjectAsync(
   System.object value,
   Formatting formatting
)
public function SerializeObjectAsync(
    value: System.TObject;
    formatting: Formatting
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting))")
public static function SerializeObjectAsync(
   value : System.Object,
   formatting : Formatting
) : System.Threading.Tasks.Task;
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting))")]
public: static System.Threading.Tasks.Task<string*>* SerializeObjectAsync(
   System.Object* value,
   Formatting formatting
)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting))")]
public:
static System.Threading.Tasks.Task<String^>^ SerializeObjectAsync(
   System.Object^ value,
   Formatting formatting
)

Parameters

value
The object to serialize.
formatting
Indicates how the output is formatted.

Return Value

A task that represents the asynchronous serialize operation. The value of the TResult parameter contains a JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


SerializeObjectAsync(Object,Formatting,JsonSerializerSettings) Method

SerializeObjectAsync(Object,Formatting,JsonSerializerSettings) Method

Noemax.Newtonsoft.Json Namespace > JsonConvert Class > SerializeObjectAsync Method : SerializeObjectAsync(Object,Formatting,JsonSerializerSettings) Method
The object to serialize.
Indicates how the output is formatted.
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.
Asynchronously serializes the specified object to a JSON string using formatting and a collection of JsonConverter. Serialization will happen on a new thread.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting, settings))")>
Public Overloads Shared Function SerializeObjectAsync( _
   ByVal value As System.Object, _
   ByVal formatting As Formatting, _
   ByVal settings As JsonSerializerSettings _
) As System.Threading.Tasks.Task(Of String)
'Usage

Dim value As System.Object
Dim formatting As Formatting
Dim settings As JsonSerializerSettings
Dim value As System.Threading.Tasks.Task(Of String)

value = JsonConvert.SerializeObjectAsync(value, formatting, settings)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting, settings))")]
public static System.Threading.Tasks.Task<string> SerializeObjectAsync(
   System.object value,
   Formatting formatting,
   JsonSerializerSettings settings
)
public function SerializeObjectAsync(
    value: System.TObject;
    formatting: Formatting;
    settings: JsonSerializerSettings
): System.Threading.Tasks.Task; static;
System.ObsoleteAttribute("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting, settings))")
public static function SerializeObjectAsync(
   value : System.Object,
   formatting : Formatting,
   settings : JsonSerializerSettings
) : System.Threading.Tasks.Task;
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting, settings))")]
public: static System.Threading.Tasks.Task<string*>* SerializeObjectAsync(
   System.Object* value,
   Formatting formatting,
   JsonSerializerSettings* settings
)
[System.Obsolete("SerializeObjectAsync is obsolete. Use the Task.Factory.StartNew method to serialize JSON asynchronously: Task.Factory.StartNew(() => JsonConvert.SerializeObject(value, formatting, settings))")]
public:
static System.Threading.Tasks.Task<String^>^ SerializeObjectAsync(
   System.Object^ value,
   Formatting formatting,
   JsonSerializerSettings^ settings
)

Parameters

value
The object to serialize.
formatting
Indicates how the output is formatted.
settings
The JsonSerializerSettings used to serialize the object. If this is null, default serialization settings will be is used.

Return Value

A task that represents the asynchronous serialize operation. The value of the TResult parameter contains a JSON string representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConvert Class
JsonConvert Members
Overload List


Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BsonObjectId | Represents a BSON Oid (object id).
Class | BsonReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | BsonWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating JSON data.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BinaryConverter | Converts a binary value to and from a base 64 string value.
Class | BsonObjectIdConverter | Converts a Noemax.Newtonsoft.Json.Bson.BsonObjectId to and from JSON and BSON.
Class | CustomCreationConverter<T> | Create a custom object
Class | DataSetConverter | Converts a System.Data.DataSet to and from JSON.
Class | DataTableConverter | Converts a System.Data.DataTable to and from JSON.
Class | DateTimeConverterBase | Provides a base class for converting a System.DateTime to and from JSON.
Class | DiscriminatedUnionConverter | Converts a F# discriminated union type to and from JSON.
Class | EntityKeyMemberConverter | Converts an Entity Framework EntityKey to and from JSON.
Class | ExpandoObjectConverter | Converts an ExpandoObject to and from JSON.
Class | IsoDateTimeConverter | Converts a System.DateTime to and from the ISO 8601 date format (e.g. 2008-04-12T12:53Z).
Class | JavaScriptDateTimeConverter | Converts a System.DateTime to and from a JavaScript date constructor (e.g. new Date(52231943)).
Class | KeyValuePairConverter | Converts a System.Collections.Generic.KeyValuePair`2 to and from JSON.
Class | RegexConverter | Converts a System.Text.RegularExpressions.Regex to and from JSON and BSON.
Class | StringEnumConverter | Converts an System.Enum to and from its name string value.
Class | VersionConverter | Converts a System.Version to and from a string (e.g. "1.2.3.4").
Class | XmlNodeConverter | Converts XML to and from JSON.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


DiscriminatedUnionConverter Class

DiscriminatedUnionConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : DiscriminatedUnionConverter Class
Converts a F# discriminated union type to and from JSON.
Object Model
DiscriminatedUnionConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class DiscriminatedUnionConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As DiscriminatedUnionConverter
public class DiscriminatedUnionConverter : Noemax.Newtonsoft.Json.JsonConverter
public class DiscriminatedUnionConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class DiscriminatedUnionConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class DiscriminatedUnionConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class DiscriminatedUnionConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.DiscriminatedUnionConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiscriminatedUnionConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


DiscriminatedUnionConverter Class Members

DiscriminatedUnionConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : DiscriminatedUnionConverter Class

The following tables list the members exposed by DiscriminatedUnionConverter.

Public Constructors
 | Name | Description
Public Constructor | DiscriminatedUnionConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DiscriminatedUnionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DiscriminatedUnionConverter Constructor

DiscriminatedUnionConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > DiscriminatedUnionConverter Class : DiscriminatedUnionConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New DiscriminatedUnionConverter()
public DiscriminatedUnionConverter()
public DiscriminatedUnionConverter();
public function DiscriminatedUnionConverter();
public: DiscriminatedUnionConverter();
public:
DiscriminatedUnionConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiscriminatedUnionConverter Class
DiscriminatedUnionConverter Members


DiscriminatedUnionConverter Class Methods

DiscriminatedUnionConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : DiscriminatedUnionConverter Class

For a list of all members of this type, see DiscriminatedUnionConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

DiscriminatedUnionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (DiscriminatedUnionConverter)

CanConvert Method (DiscriminatedUnionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DiscriminatedUnionConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As DiscriminatedUnionConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiscriminatedUnionConverter Class
DiscriminatedUnionConverter Members
Base Implementation in CanConvert


ReadJson Method (DiscriminatedUnionConverter)

ReadJson Method (DiscriminatedUnionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DiscriminatedUnionConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As DiscriminatedUnionConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiscriminatedUnionConverter Class
DiscriminatedUnionConverter Members
Base Implementation in ReadJson


WriteJson Method (DiscriminatedUnionConverter)

WriteJson Method (DiscriminatedUnionConverter)

Noemax.Newtonsoft.Json.Converters Namespace > DiscriminatedUnionConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As DiscriminatedUnionConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DiscriminatedUnionConverter Class
DiscriminatedUnionConverter Members
Base Implementation in WriteJson


ExpandoObjectConverter Class

ExpandoObjectConverter Class
Members

Noemax.Newtonsoft.Json.Converters Namespace : ExpandoObjectConverter Class
Converts an ExpandoObject to and from JSON.
Object Model
ExpandoObjectConverter Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ExpandoObjectConverter
   Inherits Noemax.Newtonsoft.Json.JsonConverter
'Usage

Dim instance As ExpandoObjectConverter
public class ExpandoObjectConverter : Noemax.Newtonsoft.Json.JsonConverter
public class ExpandoObjectConverter = class(Noemax.Newtonsoft.Json.JsonConverter)
public class ExpandoObjectConverter extends Noemax.Newtonsoft.Json.JsonConverter
public __gc class ExpandoObjectConverter : public Noemax.Newtonsoft.Json.JsonConverter
public ref class ExpandoObjectConverter : public Noemax.Newtonsoft.Json.JsonConverter
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.ExpandoObjectConverter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Members
Noemax.Newtonsoft.Json.Converters Namespace


ExpandoObjectConverter Class Members

ExpandoObjectConverter Class Members
Properties Methods

Noemax.Newtonsoft.Json.Converters Namespace : ExpandoObjectConverter Class

The following tables list the members exposed by ExpandoObjectConverter.

Public Constructors
 | Name | Description
Public Constructor | ExpandoObjectConverter Constructor |
Top
Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Overridden. Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Top
Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

ExpandoObjectConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


ExpandoObjectConverter Constructor

ExpandoObjectConverter Constructor

Noemax.Newtonsoft.Json.Converters Namespace > ExpandoObjectConverter Class : ExpandoObjectConverter Constructor
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New()
'Usage

Dim instance As New ExpandoObjectConverter()
public ExpandoObjectConverter()
public ExpandoObjectConverter();
public function ExpandoObjectConverter();
public: ExpandoObjectConverter();
public:
ExpandoObjectConverter();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Class
ExpandoObjectConverter Members


ExpandoObjectConverter Class Methods

ExpandoObjectConverter Class Methods

Noemax.Newtonsoft.Json.Converters Namespace : ExpandoObjectConverter Class

For a list of all members of this type, see ExpandoObjectConverter members.

Public Methods
 | Name | Description
Public Method | CanConvert | Overridden. Determines whether this instance can convert the specified object type.
Public Method | GetSchema | Gets the Noemax.Newtonsoft.Json.Schema.JsonSchema of the JSON produced by the JsonConverter. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Method | ReadJson | Overridden. Reads the JSON representation of the object.
Public Method | WriteJson | Overridden. Writes the JSON representation of the object.
Top
See Also

Reference

ExpandoObjectConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanConvert Method (ExpandoObjectConverter)

CanConvert Method (ExpandoObjectConverter)

Noemax.Newtonsoft.Json.Converters Namespace > ExpandoObjectConverter Class : CanConvert Method
Type of the object.
Determines whether this instance can convert the specified object type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function CanConvert( _
   ByVal objectType As System.Type _
) As System.Boolean
'Usage

Dim instance As ExpandoObjectConverter
Dim objectType As System.Type
Dim value As System.Boolean

value = instance.CanConvert(objectType)
public override System.bool CanConvert(
   System.Type objectType
)
public function CanConvert(
    objectType: System.Type
): System.Boolean; override;
public override function CanConvert(
   objectType : System.Type
) : System.boolean;
public: System.bool CanConvert(
   System.Type* objectType
) override
public:
System.bool CanConvert(
   System.Type^ objectType
) override

Parameters

objectType
Type of the object.

Return Value

true if this instance can convert the specified object type; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Class
ExpandoObjectConverter Members
Base Implementation in CanConvert


ReadJson Method (ExpandoObjectConverter)

ReadJson Method (ExpandoObjectConverter)

Noemax.Newtonsoft.Json.Converters Namespace > ExpandoObjectConverter Class : ReadJson Method
The Noemax.Newtonsoft.Json.JsonReader to read from.
Type of the object.
The existing value of object being read.
The calling serializer.
Reads the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Function ReadJson( _
   ByVal reader As JsonReader, _
   ByVal objectType As System.Type, _
   ByVal existingValue As System.Object, _
   ByVal serializer As JsonSerializer _
) As System.Object
'Usage

Dim instance As ExpandoObjectConverter
Dim reader As JsonReader
Dim objectType As System.Type
Dim existingValue As System.Object
Dim serializer As JsonSerializer
Dim value As System.Object

value = instance.ReadJson(reader, objectType, existingValue, serializer)
public override System.object ReadJson(
   JsonReader reader,
   System.Type objectType,
   System.object existingValue,
   JsonSerializer serializer
)
public function ReadJson(
    reader: JsonReader;
    objectType: System.Type;
    existingValue: System.TObject;
    serializer: JsonSerializer
): System.TObject; override;
public override function ReadJson(
   reader : JsonReader,
   objectType : System.Type,
   existingValue : System.Object,
   serializer : JsonSerializer
) : System.Object;
public: System.Object* ReadJson(
   JsonReader* reader,
   System.Type* objectType,
   System.Object* existingValue,
   JsonSerializer* serializer
) override
public:
System.Object^ ReadJson(
   JsonReader^ reader,
   System.Type^ objectType,
   System.Object^ existingValue,
   JsonSerializer^ serializer
) override

Parameters

reader
The Noemax.Newtonsoft.Json.JsonReader to read from.
objectType
Type of the object.
existingValue
The existing value of object being read.
serializer
The calling serializer.

Return Value

The object value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Class
ExpandoObjectConverter Members
Base Implementation in ReadJson


WriteJson Method (ExpandoObjectConverter)

WriteJson Method (ExpandoObjectConverter)

Noemax.Newtonsoft.Json.Converters Namespace > ExpandoObjectConverter Class : WriteJson Method
The Noemax.Newtonsoft.Json.JsonWriter to write to.
The value.
The calling serializer.
Writes the JSON representation of the object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub WriteJson( _
   ByVal writer As JsonWriter, _
   ByVal value As System.Object, _
   ByVal serializer As JsonSerializer _
)
'Usage

Dim instance As ExpandoObjectConverter
Dim writer As JsonWriter
Dim value As System.Object
Dim serializer As JsonSerializer

instance.WriteJson(writer, value, serializer)
public override void WriteJson(
   JsonWriter writer,
   System.object value,
   JsonSerializer serializer
)
public procedure WriteJson(
    writer: JsonWriter;
    value: System.TObject;
    serializer: JsonSerializer
); override;
public override function WriteJson(
   writer : JsonWriter,
   value : System.Object,
   serializer : JsonSerializer
);
public: void WriteJson(
   JsonWriter* writer,
   System.Object* value,
   JsonSerializer* serializer
) override
public:
void WriteJson(
   JsonWriter^ writer,
   System.Object^ value,
   JsonSerializer^ serializer
) override

Parameters

writer
The Noemax.Newtonsoft.Json.JsonWriter to write to.
value
The value.
serializer
The calling serializer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Class
ExpandoObjectConverter Members
Base Implementation in WriteJson


ExpandoObjectConverter Class Properties

ExpandoObjectConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : ExpandoObjectConverter Class

For a list of all members of this type, see ExpandoObjectConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Overridden. Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Top
See Also

Reference

ExpandoObjectConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


CanWrite Property (ExpandoObjectConverter)

CanWrite Property (ExpandoObjectConverter)

Noemax.Newtonsoft.Json.Converters Namespace > ExpandoObjectConverter Class : CanWrite Property
Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides ReadOnly Property CanWrite As System.Boolean
'Usage

Dim instance As ExpandoObjectConverter
Dim value As System.Boolean

value = instance.CanWrite
public override System.bool CanWrite {get;}
public read-only property CanWrite: System.Boolean; override;
public override function get CanWrite : System.boolean
public: __property System.bool get_CanWrite() override;
public:
property System.bool CanWrite {
   System.bool get() override;
}

Property Value

true if this Noemax.Newtonsoft.Json.JsonConverter can write JSON; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpandoObjectConverter Class
ExpandoObjectConverter Members
Base Implementation in CanWrite


Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | Extensions | Contains the LINQ to JSON extension methods.
Class | JArray | Represents a JSON array.
Class | JConstructor | Represents a JSON constructor.
Class | JContainer | Represents a token that can contain other tokens.
Class | JObject | Represents a JSON object.
Class | JProperty | Represents a JSON property.
Class | JPropertyDescriptor | Represents a view of a JProperty.
Class | JRaw | Represents a raw JSON string.
Class | JToken | Represents an abstract JSON token.
Class | JTokenEqualityComparer | Compares tokens to determine whether they are equal.
Class | JTokenReader | Represents a reader that provides fast, non-cached, forward-only access to serialized Json data.
Class | JTokenWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating Json data.
Class | JValue | Represents a value in JSON (string, integer, date, etc).
Interfaces
 | Interface | Description
Interface | IJEnumerable<T> | Represents a collection of JToken objects.
Structures
 | Structure | Description
Structure | JEnumerable<T> | Represents a collection of JToken objects.
Enumerations
 | Enumeration | Description
Enumeration | JTokenType | Specifies the type of token.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


JArray Class Members

JArray Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

The following tables list the members exposed by JArray.

Public Constructors
 | Name | Description
Public Constructor | JArray Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | IsReadOnly | Gets a value indicating whether the System.Collections.Generic.ICollection`1 is read-only.
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an item to the System.Collections.Generic.ICollection`1.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Clear | Removes all items from the System.Collections.Generic.ICollection`1.
Public Method | Contains | Determines whether the System.Collections.Generic.ICollection`1 contains a specific value.
Public Method | CopyTo | Copies to.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JArray from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.Generic.IList`1.
Public Method | Insert | Inserts an item to the System.Collections.Generic.IList`1 at the specified index.
static (Shared in Visual Basic) | Load | Loads an JArray from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JArray from a string that contains JSON.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | RemoveAt | Removes the System.Collections.Generic.IList`1 item at the specified index.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the JContainer.CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


JArray Class Methods

JArray Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

For a list of all members of this type, see JArray members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an item to the System.Collections.Generic.ICollection`1.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Clear | Removes all items from the System.Collections.Generic.ICollection`1.
Public Method | Contains | Determines whether the System.Collections.Generic.ICollection`1 contains a specific value.
Public Method | CopyTo | Copies to.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JArray from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | IndexOf | Determines the index of a specific item in the System.Collections.Generic.IList`1.
Public Method | Insert | Inserts an item to the System.Collections.Generic.IList`1 at the specified index.
static (Shared in Visual Basic) | Load | Loads an JArray from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JArray from a string that contains JSON.
Public Method | Remove | Overloaded. Removes the first occurrence of a specific object from the System.Collections.Generic.ICollection`1.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | RemoveAt | Removes the System.Collections.Generic.IList`1 item at the specified index.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the JContainer.CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Class Members

JConstructor Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

The following tables list the members exposed by JConstructor.

Public Constructors
 | Name | Description
Public Constructor | JConstructor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets or sets the name of this constructor.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JConstructor from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the JContainer.CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Class Methods

JConstructor Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

For a list of all members of this type, see JConstructor members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JConstructor from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the JContainer.CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


JContainer Class Members

JContainer Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

The following tables list the members exposed by JContainer.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens.
Public Property | First | Overridden. Get the first child token of this token.
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Overridden. Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Overridden. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Overridden. Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | OnListChanged | Raises the ListChanged event.
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection.
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


JContainer Class Methods

JContainer Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

For a list of all members of this type, see JContainer members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Overridden. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token.
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Overridden. Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | OnListChanged | Raises the ListChanged event.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


OnCollectionChanged Method

OnCollectionChanged Method

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : OnCollectionChanged Method
The System.Collections.Specialized.NotifyCollectionChangedEventArgs instance containing the event data.
Raises the CollectionChanged event.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnCollectionChanged( _
   ByVal e As System.Collections.Specialized.NotifyCollectionChangedEventArgs _
)
'Usage

Dim instance As JContainer
Dim e As System.Collections.Specialized.NotifyCollectionChangedEventArgs

instance.OnCollectionChanged(e)
protected virtual void OnCollectionChanged(
   System.Collections.Specialized.NotifyCollectionChangedEventArgs e
)
protected procedure OnCollectionChanged(
    e: System.Collections.Specialized.NotifyCollectionChangedEventArgs
); virtual;
protected function OnCollectionChanged(
   e : System.Collections.Specialized.NotifyCollectionChangedEventArgs
);
protected: virtual void OnCollectionChanged(
   System.Collections.Specialized.NotifyCollectionChangedEventArgs* e
)
protected:
virtual void OnCollectionChanged(
   System.Collections.Specialized.NotifyCollectionChangedEventArgs^ e
)

Parameters

e
The System.Collections.Specialized.NotifyCollectionChangedEventArgs instance containing the event data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


JContainer Class Events

JContainer Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JContainer Class

For a list of all members of this type, see JContainer members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection.
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Top
See Also

Reference

JContainer Class
Noemax.Newtonsoft.Json.Linq Namespace


CollectionChanged Event

CollectionChanged Event

Noemax.Newtonsoft.Json.Linq Namespace > JContainer Class : CollectionChanged Event
Occurs when the items list of the collection has changed, or the collection is reset.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Event CollectionChanged As System.Collections.Specialized.NotifyCollectionChangedEventHandler
'Usage

Dim instance As JContainer
Dim handler As System.Collections.Specialized.NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
public event System.Collections.Specialized.NotifyCollectionChangedEventHandler CollectionChanged
public event CollectionChanged: System.Collections.Specialized.NotifyCollectionChangedEventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
public: __event System.Collections.Specialized.NotifyCollectionChangedEventHandler* CollectionChanged
public:
event System.Collections.Specialized.NotifyCollectionChangedEventHandler^ CollectionChanged
Event Data

The event handler receives an argument of type System.Collections.Specialized.NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JContainer Class
JContainer Members


JObject Class Members

JObject Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

The following tables list the members exposed by JObject.

Public Constructors
 | Name | Description
Public Constructor | JObject Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Overridden. Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified property name.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JObject from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetValue | Overloaded. Gets the JToken with the specified property name.
static (Shared in Visual Basic) | Load | Loads an JObject from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JObject from a string that contains JSON.
Public Method | Properties | Gets an System.Collections.Generic.IEnumerable`1 of this object's properties.
Public Method | Property | Gets a JProperty the specified name.
Public Method | PropertyValues | Gets an JEnumerable<T> of this object's property values.
Public Method | Remove | Overloaded. Removes the property with the specified name.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | TryGetValue | Overloaded. Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Overridden. Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Protected Method | OnPropertyChanging | Raises the PropertyChanging event with the provided arguments.
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | PropertyChanging | Occurs when a property value is changing.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


JObject Class Methods

JObject Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

For a list of all members of this type, see JObject members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified property name.
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JObject from an object.
Public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public Method | GetValue | Overloaded. Gets the JToken with the specified property name.
static (Shared in Visual Basic) | Load | Loads an JObject from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JObject from a string that contains JSON.
Public Method | Properties | Gets an System.Collections.Generic.IEnumerable`1 of this object's properties.
Public Method | Property | Gets a JProperty the specified name.
Public Method | PropertyValues | Gets an JEnumerable<T> of this object's property values.
Public Method | Remove | Overloaded. Removes the property with the specified name.
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | TryGetValue | Overloaded. Tries to get the JToken with the specified property name. The exact property name will be searched for first and if no matching property is found then the System.StringComparison will be used to match a property.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Overridden. Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Protected Method | OnPropertyChanging | Raises the PropertyChanging event with the provided arguments.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


GetMetaObject Method (JObject)

GetMetaObject Method (JObject)

Noemax.Newtonsoft.Json.Linq Namespace > JObject Class : GetMetaObject Method
The expression tree representation of the runtime value.
Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function GetMetaObject( _
   ByVal parameter As System.Linq.Expressions.Expression _
) As System.Dynamic.DynamicMetaObject
'Usage

Dim instance As JObject
Dim parameter As System.Linq.Expressions.Expression
Dim value As System.Dynamic.DynamicMetaObject

value = instance.GetMetaObject(parameter)
protected override System.Dynamic.DynamicMetaObject GetMetaObject(
   System.Linq.Expressions.Expression parameter
)
protected function GetMetaObject(
    parameter: System.Linq.Expressions.Expression
): System.Dynamic.DynamicMetaObject; override;
protected override function GetMetaObject(
   parameter : System.Linq.Expressions.Expression
) : System.Dynamic.DynamicMetaObject;
protected: System.Dynamic.DynamicMetaObject* GetMetaObject(
   System.Linq.Expressions.Expression* parameter
) override
protected:
System.Dynamic.DynamicMetaObject^ GetMetaObject(
   System.Linq.Expressions.Expression^ parameter
) override

Parameters

parameter
The expression tree representation of the runtime value.

Return Value

The System.Dynamic.DynamicMetaObject to bind this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JObject Class
JObject Members
Base Implementation in GetMetaObject


JObject Class Events

JObject Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JObject Class

For a list of all members of this type, see JObject members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | PropertyChanged | Occurs when a property value changes.
Public Event | PropertyChanging | Occurs when a property value is changing.
Top
See Also

Reference

JObject Class
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Class Members

JProperty Class Members
Properties Methods Events

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

The following tables list the members exposed by JProperty.

Public Constructors
 | Name | Description
Public Constructor | JProperty Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the count of child JSON tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Property | Name | Gets the property name.
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value<T> | Gets or sets the property value.
Top
Protected Properties
 | Name | Description
Protected Property | ChildrenTokens | Overridden. Gets the container's children tokens.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JProperty from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets or sets the property value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Class Methods

JProperty Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

For a list of all members of this type, see JProperty members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified content as children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddFirst | Adds the specified content as the first children of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CreateWriter | Creates an Noemax.Newtonsoft.Json.JsonWriter that can be used to add tokens to the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Descendants | Returns a collection of the descendant tokens for this token in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
static (Shared in Visual Basic) | Load | Loads an JProperty from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | RemoveAll | Removes the child nodes from this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ReplaceAll | Replaces the children nodes of this token with the specified content. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns the indented JSON for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Value<T> | Gets or sets the property value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Protected Method | OnAddingNew | Raises the AddingNew event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Protected Method | OnListChanged | Raises the ListChanged event. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


JRaw Class Members

JRaw Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class

The following tables list the members exposed by JRaw.

Public Constructors
 | Name | Description
Public Constructor | JRaw Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
static (Shared in Visual Basic) | Create | Creates an instance of JRaw with the content of the reader's current token.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Value | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
See Also

Reference

JRaw Class
Noemax.Newtonsoft.Json.Linq Namespace


JRaw Class Methods

JRaw Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class

For a list of all members of this type, see JRaw members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
static (Shared in Visual Basic) | Create | Creates an instance of JRaw with the content of the reader's current token.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Method | Value | Gets the JToken with the specified key converted to the specified type. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
See Also

Reference

JRaw Class
Noemax.Newtonsoft.Json.Linq Namespace


JToken Class Members

JToken Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class

The following tables list the members exposed by JToken.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | EqualityComparer | Gets a comparer that can compare two tokens for value equality.
Public Property | First | Get the first child token of this token.
Public Property | HasValues | Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key.
Public Property | Last | Get the last child token of this token.
Public Property | Next | Gets the next sibling token of this node.
Public Property | Parent | Gets or sets the parent.
Public Property | Path | Gets the path of the JSON token.
Public Property | Previous | Gets the previous sibling token of this node.
Public Property | Root | Gets the root JToken of this JToken.
Public Property | Type | Gets the node type for this JToken.
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token.
Public Method | AddBeforeSelf | Adds the specified content immediately before this token.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order.
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token.
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order.
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned.
static (Shared in Visual Basic) | DeepEquals | Compares the values of two tokens, including the values of all descendant tokens.
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JToken from an object.
static (Shared in Visual Basic) | Load | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JToken from a string that contains JSON.
static (Shared in Visual Basic) | ReadFrom | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent.
Public Method | Replace | Replaces this token with the specified token.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path.
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression.
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken.
Public Method | ToString | Overloaded. Returns the indented JSON for this token.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type.
Public Method | Values<T> | Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Top
Public Operators
public Operator Explicit Type Conversion | Overloaded. Performs an explicit conversion from JToken to System.Boolean.
public Operator Implicit Type Conversion | Overloaded. Performs an implicit conversion from System.Int16 to JToken.
Top
See Also

Reference

JToken Class
Noemax.Newtonsoft.Json.Linq Namespace


JToken Class Methods

JToken Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JToken Class

For a list of all members of this type, see JToken members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token.
Public Method | AddBeforeSelf | Adds the specified content immediately before this token.
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order.
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token.
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order.
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned.
static (Shared in Visual Basic) | DeepEquals | Compares the values of two tokens, including the values of all descendant tokens.
static (Shared in Visual Basic) | FromObject | Overloaded. Creates a JToken from an object.
static (Shared in Visual Basic) | Load | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
static (Shared in Visual Basic) | Parse | Load a JToken from a string that contains JSON.
static (Shared in Visual Basic) | ReadFrom | Creates a JToken from a Noemax.Newtonsoft.Json.JsonReader.
Public Method | Remove | Removes this token from its parent.
Public Method | Replace | Replaces this token with the specified token.
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path.
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression.
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken.
Public Method | ToString | Overloaded. Returns the indented JSON for this token.
Public Method | Value<T> | Gets the JToken with the specified key converted to the specified type.
Public Method | Values<T> | Returns a collection of the child values of this token, in document order.
Public Method | WriteTo | Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Top
See Also

Reference

JToken Class
Noemax.Newtonsoft.Json.Linq Namespace


GetMetaObject Method (JToken)

GetMetaObject Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : GetMetaObject Method
The expression tree representation of the runtime value.
Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function GetMetaObject( _
   ByVal parameter As System.Linq.Expressions.Expression _
) As System.Dynamic.DynamicMetaObject
'Usage

Dim instance As JToken
Dim parameter As System.Linq.Expressions.Expression
Dim value As System.Dynamic.DynamicMetaObject

value = instance.GetMetaObject(parameter)
protected virtual System.Dynamic.DynamicMetaObject GetMetaObject(
   System.Linq.Expressions.Expression parameter
)
protected function GetMetaObject(
    parameter: System.Linq.Expressions.Expression
): System.Dynamic.DynamicMetaObject; virtual;
protected function GetMetaObject(
   parameter : System.Linq.Expressions.Expression
) : System.Dynamic.DynamicMetaObject;
protected: virtual System.Dynamic.DynamicMetaObject* GetMetaObject(
   System.Linq.Expressions.Expression* parameter
)
protected:
virtual System.Dynamic.DynamicMetaObject^ GetMetaObject(
   System.Linq.Expressions.Expression^ parameter
)

Parameters

parameter
The expression tree representation of the runtime value.

Return Value

The System.Dynamic.DynamicMetaObject to bind this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Implicit Type Conversion Operator (JToken)

Implicit Type Conversion Operator (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : Implicit Type Conversion Operator
Performs an implicit conversion from System.Int16 to JToken.
Overload List
Overload | Description
Implicit Type Conversion(JToken,Int16) | Performs an implicit conversion from System.Int16 to JToken.
Implicit Type Conversion(JToken,UInt16) | Performs an implicit conversion from System.UInt16 to JToken.
Implicit Type Conversion(JToken,Int32) | Performs an implicit conversion from System.Int32 to JToken.
Implicit Type Conversion(JToken,Nullable<Int32>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,DateTime) | Performs an implicit conversion from System.DateTime to JToken.
Implicit Type Conversion(JToken,Nullable<Int64>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Single>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Decimal) | Performs an implicit conversion from System.Decimal to JToken.
Implicit Type Conversion(JToken,Nullable<Int16>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt16>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt32>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<UInt64>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Double) | Performs an implicit conversion from System.Double to JToken.
Implicit Type Conversion(JToken,Single) | Performs an implicit conversion from System.Single to JToken.
Implicit Type Conversion(JToken,String) | Performs an implicit conversion from System.String to JToken.
Implicit Type Conversion(JToken,UInt32) | Performs an implicit conversion from System.UInt32 to JToken.
Implicit Type Conversion(JToken,UInt64) | Performs an implicit conversion from System.UInt64 to JToken.
Implicit Type Conversion(JToken,Byte[]) | Performs an implicit conversion from System.Byte[] to JToken.
Implicit Type Conversion(JToken,Uri) | Performs an implicit conversion from System._uri to JToken.
Implicit Type Conversion(JToken,TimeSpan) | Performs an implicit conversion from System.TimeSpan to JToken.
Implicit Type Conversion(JToken,Nullable<TimeSpan>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Guid) | Performs an implicit conversion from System.Guid to JToken.
Implicit Type Conversion(JToken,Nullable<Guid>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Boolean) | Performs an implicit conversion from System.Boolean to JToken.
Implicit Type Conversion(JToken,DateTimeOffset) | Performs an implicit conversion from System.DateTimeOffset to JToken.
Implicit Type Conversion(JToken,Byte) | Performs an implicit conversion from System.Byte to JToken.
Implicit Type Conversion(JToken,Nullable<Byte>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,SByte) | Performs an implicit conversion from System.SByte to JToken.
Implicit Type Conversion(JToken,Nullable<SByte>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Boolean>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Int64) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<DateTime>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<DateTimeOffset>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Decimal>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Implicit Type Conversion(JToken,Nullable<Double>) | Performs an implicit conversion from System.Nullable`1 to JToken.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


JValue Class Members

JValue Class Members
Properties Methods

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class

The following tables list the members exposed by JValue.

Public Constructors
 | Name | Description
Public Constructor | JValue Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Overridden. Gets a value indicating whether this token has child tokens.
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Overridden. Gets the node type for this JToken.
Public Property | Value | Gets or sets the underlying token value.
Top
Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
static (Shared in Visual Basic) | CreateComment | Creates a JValue comment with the given value.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
static (Shared in Visual Basic) | CreateString | Creates a JValue string with the given value.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance.
Public Method | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Overridden. Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Top
See Also

Reference

JValue Class
Noemax.Newtonsoft.Json.Linq Namespace


JValue Class Methods

JValue Class Methods

Noemax.Newtonsoft.Json.Linq Namespace : JValue Class

For a list of all members of this type, see JValue members.

Public Methods
 | Name | Description
Public Method | AddAfterSelf | Adds the specified content immediately after this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AddBeforeSelf | Adds the specified content immediately before this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | AfterSelf | Returns a collection of the sibling tokens after this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Ancestors | Returns a collection of the ancestor tokens of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | BeforeSelf | Returns a collection of the sibling tokens before this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Children | Overloaded. Returns a collection of the child tokens of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
static (Shared in Visual Basic) | CreateComment | Creates a JValue comment with the given value.
Public Method | CreateReader | Creates an Noemax.Newtonsoft.Json.JsonReader for this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
static (Shared in Visual Basic) | CreateString | Creates a JValue string with the given value.
Public Method | DeepClone | Creates a new instance of the JToken. All child tokens are recursively cloned. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Public Method | GetHashCode | Serves as a hash function for a particular type.
Public Method | Remove | Removes this token from its parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Replace | Replaces this token with the specified token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectToken | Overloaded. Selects a JToken using a JPath expression. Selects the token that matches the object path. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | SelectTokens | Overloaded. Selects a collection of elements using a JPath expression. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToObject | Overloaded. Creates the specified .NET type from the JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | ToString | Overloaded. Returns a System.String that represents this instance.
Public Method | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | Values<T> | Returns a collection of the child values of this token, in document order. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Method | WriteTo | Overridden. Writes this token to a Noemax.Newtonsoft.Json.JsonWriter.
Top
Protected Methods
 | Name | Description
Protected Method | GetMetaObject | Overridden. Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Top
See Also

Reference

JValue Class
Noemax.Newtonsoft.Json.Linq Namespace


GetMetaObject Method (JValue)

GetMetaObject Method (JValue)

Noemax.Newtonsoft.Json.Linq Namespace > JValue Class : GetMetaObject Method
The expression tree representation of the runtime value.
Returns the System.Dynamic.DynamicMetaObject responsible for binding operations performed on this object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overrides Function GetMetaObject( _
   ByVal parameter As System.Linq.Expressions.Expression _
) As System.Dynamic.DynamicMetaObject
'Usage

Dim instance As JValue
Dim parameter As System.Linq.Expressions.Expression
Dim value As System.Dynamic.DynamicMetaObject

value = instance.GetMetaObject(parameter)
protected override System.Dynamic.DynamicMetaObject GetMetaObject(
   System.Linq.Expressions.Expression parameter
)
protected function GetMetaObject(
    parameter: System.Linq.Expressions.Expression
): System.Dynamic.DynamicMetaObject; override;
protected override function GetMetaObject(
   parameter : System.Linq.Expressions.Expression
) : System.Dynamic.DynamicMetaObject;
protected: System.Dynamic.DynamicMetaObject* GetMetaObject(
   System.Linq.Expressions.Expression* parameter
) override
protected:
System.Dynamic.DynamicMetaObject^ GetMetaObject(
   System.Linq.Expressions.Expression^ parameter
) override

Parameters

parameter
The expression tree representation of the runtime value.

Return Value

The System.Dynamic.DynamicMetaObject to bind this object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JValue Class
JValue Members
Base Implementation in GetMetaObject


Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | Extensions | Contains the JSON schema extension methods.
Class | JsonSchema | An in-memory representation of a JSON Schema.
Class | JsonSchemaException | Returns detailed information about the schema exception.
Class | JsonSchemaGenerator | Generates a JsonSchema from a specified System.Type.
Class | JsonSchemaResolver | Resolves JsonSchema from an id.
Class | ValidationEventArgs | Returns detailed information related to the ValidationEventHandler.
Delegates
 | Delegate | Description
Delegate | ValidationEventHandler | Represents the callback method that will handle JSON schema validation events and the ValidationEventArgs.
Enumerations
 | Enumeration | Description
Enumeration | JsonSchemaType | The value types allowed by the JsonSchema.
Enumeration | UndefinedSchemaIdHandling | Specifies undefined schema Id handling options for the JsonSchemaGenerator.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | CamelCasePropertyNamesContractResolver | Resolves member mappings for a type, camel casing property names.
Class | DefaultContractResolver | Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Class | DefaultSerializationBinder | The default serialization binder used when resolving and loading classes from type names.
Class | DiagnosticsTraceWriter | Represents a trace writer that writes to the application's System.Diagnostics.TraceListener instances.
Class | DynamicValueProvider | Get and set values for a System.Reflection.MemberInfo using dynamic methods.
Class | ErrorContext | Provides information surrounding an error.
Class | ErrorEventArgs | Provides data for the Error event.
Class | ExpressionValueProvider | Get and set values for a System.Reflection.MemberInfo using dynamic methods.
Class | FlexibleSerializationBinder | Alternative serialization binder used for resolving the classes from type name and assemly name.
Class | JsonArrayContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonContainerContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonDictionaryContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonDynamicContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonISerializableContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonLinqContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonObjectContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonPrimitiveContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | JsonProperty | Maps a JSON property to a .NET member or constructor parameter.
Class | JsonPropertyCollection | A collection of JsonProperty objects.
Class | JsonStringContract | Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Class | MemoryTraceWriter | Represents a trace writer that writes to memory. When the trace message limit is reached then old trace messages will be removed as new messages are added.
Class | OnErrorAttribute | When applied to a method, specifies that the method is called when an error occurs serializing an object.
Class | ReflectionValueProvider | Get and set values for a System.Reflection.MemberInfo using reflection.
Interfaces
 | Interface | Description
Interface | IContractResolver | Used by Noemax.Newtonsoft.Json.JsonSerializer to resolves a JsonContract for a given System.Type.
Interface | IReferenceResolver | Used to resolve references when serializing and deserializing JSON by the Noemax.Newtonsoft.Json.JsonSerializer.
Interface | ITraceWriter | Represents a trace writer.
Interface | IValueProvider | Provides methods to get and set values.
Delegates
 | Delegate | Description
Delegate | ExtensionDataGetter | Gets extension data for an object during serialization.
Delegate | ExtensionDataSetter | Sets extension data for an object during deserialization.
Delegate | ObjectConstructor<T> | Represents a method that constructs an object.
Delegate | SerializationCallback | Handles Noemax.Newtonsoft.Json.JsonSerializer serialization callback events.
Delegate | SerializationErrorCallback | Handles Noemax.Newtonsoft.Json.JsonSerializer serialization error callback events.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


CamelCasePropertyNamesContractResolver Class Members

CamelCasePropertyNamesContractResolver Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class

The following tables list the members exposed by CamelCasePropertyNamesContractResolver.

Public Constructors
 | Name | Description
Public Constructor | CamelCasePropertyNamesContractResolver Constructor | Initializes a new instance of the CamelCasePropertyNamesContractResolver class.
Top
Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Method | ResolveContract | Resolves the contract for a given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateConstructorParameters | Creates the constructor parameters. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateContract | Determines which contract type is created for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDynamicContract | Creates a JsonDynamicContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperties | Creates properties for the given JsonContract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | GetSerializableMembers | Gets the serializable members for the type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
See Also

Reference

CamelCasePropertyNamesContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultContractResolver Class Members

DefaultContractResolver Class Members
Properties Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class

The following tables list the members exposed by DefaultContractResolver.

Public Constructors
 | Name | Description
Public Constructor | DefaultContractResolver Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags.
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available.
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types.
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types.
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized.
Top
Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property.
Public Method | ResolveContract | Resolves the contract for a given type.
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type.
Protected Method | CreateConstructorParameters | Creates the constructor parameters.
Protected Method | CreateContract | Determines which contract type is created for the given type.
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type.
Protected Method | CreateDynamicContract | Creates a JsonDynamicContract for the given type.
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type.
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type.
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member.
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type.
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type.
Protected Method | CreateProperties | Creates properties for the given JsonContract.
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo.
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo.
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type.
Protected Method | GetSerializableMembers | Gets the serializable members for the type.
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract.
Top
See Also

Reference

DefaultContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultContractResolver Class Methods

DefaultContractResolver Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultContractResolver Class

For a list of all members of this type, see DefaultContractResolver members.

Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property.
Public Method | ResolveContract | Resolves the contract for a given type.
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type.
Protected Method | CreateConstructorParameters | Creates the constructor parameters.
Protected Method | CreateContract | Determines which contract type is created for the given type.
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type.
Protected Method | CreateDynamicContract | Creates a JsonDynamicContract for the given type.
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type.
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type.
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member.
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type.
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type.
Protected Method | CreateProperties | Creates properties for the given JsonContract.
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo.
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo.
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type.
Protected Method | GetSerializableMembers | Gets the serializable members for the type.
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract.
Top
See Also

Reference

DefaultContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


CreateDynamicContract Method

CreateDynamicContract Method

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultContractResolver Class : CreateDynamicContract Method
Type of the object.
Creates a JsonDynamicContract for the given type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateDynamicContract( _
   ByVal objectType As System.Type _
) As JsonDynamicContract
'Usage

Dim instance As DefaultContractResolver
Dim objectType As System.Type
Dim value As JsonDynamicContract

value = instance.CreateDynamicContract(objectType)
protected virtual JsonDynamicContract CreateDynamicContract(
   System.Type objectType
)
protected function CreateDynamicContract(
    objectType: System.Type
): JsonDynamicContract; virtual;
protected function CreateDynamicContract(
   objectType : System.Type
) : JsonDynamicContract;
protected: virtual JsonDynamicContract* CreateDynamicContract(
   System.Type* objectType
)
protected:
virtual JsonDynamicContract^ CreateDynamicContract(
   System.Type^ objectType
)

Parameters

objectType
Type of the object.

Return Value

A JsonDynamicContract for the given type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultContractResolver Class
DefaultContractResolver Members


DefaultSerializationBinder Class Members

DefaultSerializationBinder Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultSerializationBinder Class

The following tables list the members exposed by DefaultSerializationBinder.

Public Constructors
 | Name | Description
Public Constructor | DefaultSerializationBinder Constructor |
Top
Public Methods
 | Name | Description
Public Method | BindToName | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Public Method | BindToType | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Top
See Also

Reference

DefaultSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


DefaultSerializationBinder Class Methods

DefaultSerializationBinder Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : DefaultSerializationBinder Class

For a list of all members of this type, see DefaultSerializationBinder members.

Public Methods
 | Name | Description
Public Method | BindToName | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Public Method | BindToType | Overridden. When overridden in a derived class, controls the binding of a serialized object to a type.
Top
See Also

Reference

DefaultSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


BindToName Method (DefaultSerializationBinder)

BindToName Method (DefaultSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultSerializationBinder Class : BindToName Method
The type of the object the formatter creates a new instance of.
Specifies the System.Reflection.Assembly name of the serialized object.
Specifies the System.Type name of the serialized object.
When overridden in a derived class, controls the binding of a serialized object to a type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub BindToName( _
   ByVal serializedType As System.Type, _
   ByRef assemblyName As System.String, _
   ByRef typeName As System.String _
)
'Usage

Dim instance As DefaultSerializationBinder
Dim serializedType As System.Type
Dim assemblyName As System.String
Dim typeName As System.String

instance.BindToName(serializedType, assemblyName, typeName)
public override void BindToName(
   System.Type serializedType,
   out System.string assemblyName,
   out System.string typeName
)
public procedure BindToName(
    serializedType: System.Type;
   Out  assemblyName: System.String;
   Out  typeName: System.String
); override;
public override function BindToName(
   serializedType : System.Type,
   assemblyName : System.String,
   typeName : System.String
);
public: void BindToName(
   System.Type* serializedType,
   [PARAMFLAG::Out] System.string* assemblyName,
   [PARAMFLAG::Out] System.string* typeName
) override
public:
void BindToName(
   System.Type^ serializedType,
   [Out] System.String^ assemblyName,
   [Out] System.String^ typeName
) override

Parameters

serializedType
The type of the object the formatter creates a new instance of.
assemblyName
Specifies the System.Reflection.Assembly name of the serialized object.
typeName
Specifies the System.Type name of the serialized object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSerializationBinder Class
DefaultSerializationBinder Members
Base Implementation in BindToName


ExpressionValueProvider Class

ExpressionValueProvider Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : ExpressionValueProvider Class
Get and set values for a System.Reflection.MemberInfo using dynamic methods.
Object Model
ExpressionValueProvider Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class ExpressionValueProvider
   Implements IValueProvider
'Usage

Dim instance As ExpressionValueProvider
public class ExpressionValueProvider : IValueProvider
public class ExpressionValueProvider = class(IValueProvider)
public class ExpressionValueProvider implements IValueProvider
public __gc class ExpressionValueProvider : public IValueProvider
public ref class ExpressionValueProvider : public IValueProvider
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.ExpressionValueProvider

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionValueProvider Members
Noemax.Newtonsoft.Json.Serialization Namespace


ExpressionValueProvider Class Members

ExpressionValueProvider Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ExpressionValueProvider Class

The following tables list the members exposed by ExpressionValueProvider.

Public Constructors
 | Name | Description
Public Constructor | ExpressionValueProvider Constructor | Initializes a new instance of the ExpressionValueProvider class.
Top
Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

ExpressionValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


ExpressionValueProvider Constructor

ExpressionValueProvider Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > ExpressionValueProvider Class : ExpressionValueProvider Constructor
The member info.
Initializes a new instance of the ExpressionValueProvider class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal memberInfo As System.Reflection.MemberInfo _
)
'Usage

Dim memberInfo As System.Reflection.MemberInfo

Dim instance As New ExpressionValueProvider(memberInfo)
public ExpressionValueProvider(
   System.Reflection.MemberInfo memberInfo
)
public ExpressionValueProvider(
    memberInfo: System.Reflection.MemberInfo
);
public function ExpressionValueProvider(
   memberInfo : System.Reflection.MemberInfo
);
public: ExpressionValueProvider(
   System.Reflection.MemberInfo* memberInfo
)
public:
ExpressionValueProvider(
   System.Reflection.MemberInfo^ memberInfo
)

Parameters

memberInfo
The member info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionValueProvider Class
ExpressionValueProvider Members


ExpressionValueProvider Class Methods

ExpressionValueProvider Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : ExpressionValueProvider Class

For a list of all members of this type, see ExpressionValueProvider members.

Public Methods
 | Name | Description
Public Method | GetValue | Gets the value.
Public Method | SetValue | Sets the value.
Top
See Also

Reference

ExpressionValueProvider Class
Noemax.Newtonsoft.Json.Serialization Namespace


GetValue Method (ExpressionValueProvider)

GetValue Method (ExpressionValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > ExpressionValueProvider Class : GetValue Method
The target to get the value from.
Gets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function GetValue( _
   ByVal target As System.Object _
) As System.Object
'Usage

Dim instance As ExpressionValueProvider
Dim target As System.Object
Dim value As System.Object

value = instance.GetValue(target)
public System.object GetValue(
   System.object target
)
public function GetValue(
    target: System.TObject
): System.TObject;
public function GetValue(
   target : System.Object
) : System.Object;
public: System.Object* GetValue(
   System.Object* target
)
public:
System.Object^ GetValue(
   System.Object^ target
)

Parameters

target
The target to get the value from.

Return Value

The value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionValueProvider Class
ExpressionValueProvider Members


SetValue Method (ExpressionValueProvider)

SetValue Method (ExpressionValueProvider)

Noemax.Newtonsoft.Json.Serialization Namespace > ExpressionValueProvider Class : SetValue Method
The target to set the value on.
The value to set on the target.
Sets the value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Sub SetValue( _
   ByVal target As System.Object, _
   ByVal value As System.Object _
)
'Usage

Dim instance As ExpressionValueProvider
Dim target As System.Object
Dim value As System.Object

instance.SetValue(target, value)
public void SetValue(
   System.object target,
   System.object value
)
public procedure SetValue(
    target: System.TObject;
    value: System.TObject
);
public function SetValue(
   target : System.Object,
   value : System.Object
);
public: void SetValue(
   System.Object* target,
   System.Object* value
)
public:
void SetValue(
   System.Object^ target,
   System.Object^ value
)

Parameters

target
The target to set the value on.
value
The value to set on the target.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ExpressionValueProvider Class
ExpressionValueProvider Members


FlexibleSerializationBinder Class Members

FlexibleSerializationBinder Class Members
Methods

Noemax.Newtonsoft.Json.Serialization Namespace : FlexibleSerializationBinder Class

The following tables list the members exposed by FlexibleSerializationBinder.

Public Constructors
 | Name | Description
Public Constructor | FlexibleSerializationBinder Constructor |
Top
Public Methods
 | Name | Description
Public Method | BindToName | Overridden. Resolves the assembly name and the type name from the specified type.
Public Method | BindToType | Overridden. Resolves the assembly name and type name to the type.
static (Shared in Visual Basic) | RegisterType | Registers type with the serialization binder so that it can be resolved faster from the type name.
Top
See Also

Reference

FlexibleSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


FlexibleSerializationBinder Class Methods

FlexibleSerializationBinder Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : FlexibleSerializationBinder Class

For a list of all members of this type, see FlexibleSerializationBinder members.

Public Methods
 | Name | Description
Public Method | BindToName | Overridden. Resolves the assembly name and the type name from the specified type.
Public Method | BindToType | Overridden. Resolves the assembly name and type name to the type.
static (Shared in Visual Basic) | RegisterType | Registers type with the serialization binder so that it can be resolved faster from the type name.
Top
See Also

Reference

FlexibleSerializationBinder Class
Noemax.Newtonsoft.Json.Serialization Namespace


BindToName Method (FlexibleSerializationBinder)

BindToName Method (FlexibleSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > FlexibleSerializationBinder Class : BindToName Method
The type whos assembly name and the type name is to be returned.
The assembly name associated to the type.
The full type name of the type.
Resolves the assembly name and the type name from the specified type.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overrides Sub BindToName( _
   ByVal serializedType As System.Type, _
   ByRef assemblyName As System.String, _
   ByRef typeName As System.String _
)
'Usage

Dim instance As FlexibleSerializationBinder
Dim serializedType As System.Type
Dim assemblyName As System.String
Dim typeName As System.String

instance.BindToName(serializedType, assemblyName, typeName)
public override void BindToName(
   System.Type serializedType,
   out System.string assemblyName,
   out System.string typeName
)
public procedure BindToName(
    serializedType: System.Type;
   Out  assemblyName: System.String;
   Out  typeName: System.String
); override;
public override function BindToName(
   serializedType : System.Type,
   assemblyName : System.String,
   typeName : System.String
);
public: void BindToName(
   System.Type* serializedType,
   [PARAMFLAG::Out] System.string* assemblyName,
   [PARAMFLAG::Out] System.string* typeName
) override
public:
void BindToName(
   System.Type^ serializedType,
   [Out] System.String^ assemblyName,
   [Out] System.String^ typeName
) override

Parameters

serializedType
The type whos assembly name and the type name is to be returned.
assemblyName
The assembly name associated to the type.
typeName
The full type name of the type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Class
FlexibleSerializationBinder Members
Base Implementation in BindToName


JsonDynamicContract Class

JsonDynamicContract Class
Members

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDynamicContract Class
Contract details for a System.Type used by the Noemax.Newtonsoft.Json.JsonSerializer.
Object Model
JsonDynamicContract Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class JsonDynamicContract
   Inherits JsonContainerContract
'Usage

Dim instance As JsonDynamicContract
public class JsonDynamicContract : JsonContainerContract
public class JsonDynamicContract = class(JsonContainerContract)
public class JsonDynamicContract extends JsonContainerContract
public __gc class JsonDynamicContract : public JsonContainerContract
public ref class JsonDynamicContract : public JsonContainerContract
Inheritance Hierarchy

System.Object
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonDynamicContract

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDynamicContract Members
Noemax.Newtonsoft.Json.Serialization Namespace


JsonDynamicContract Class Members

JsonDynamicContract Class Members
Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDynamicContract Class

The following tables list the members exposed by JsonDynamicContract.

Public Constructors
 | Name | Description
Public Constructor | JsonDynamicContract Constructor | Initializes a new instance of the JsonDynamicContract class.
Top
Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | Properties | Gets the object's properties.
Public Property | PropertyNameResolver | Gets or sets the property name resolver.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonDynamicContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonDynamicContract Constructor

JsonDynamicContract Constructor

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDynamicContract Class : JsonDynamicContract Constructor
The underlying type for the contract.
Initializes a new instance of the JsonDynamicContract class.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function New( _
   ByVal underlyingType As System.Type _
)
'Usage

Dim underlyingType As System.Type

Dim instance As New JsonDynamicContract(underlyingType)
public JsonDynamicContract(
   System.Type underlyingType
)
public JsonDynamicContract(
    underlyingType: System.Type
);
public function JsonDynamicContract(
   underlyingType : System.Type
);
public: JsonDynamicContract(
   System.Type* underlyingType
)
public:
JsonDynamicContract(
   System.Type^ underlyingType
)

Parameters

underlyingType
The underlying type for the contract.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDynamicContract Class
JsonDynamicContract Members


JsonDynamicContract Class Properties

JsonDynamicContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonDynamicContract Class

For a list of all members of this type, see JsonDynamicContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | ItemConverter | Gets or sets the default collection items Noemax.Newtonsoft.Json.JsonConverter. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemIsReference | Gets or sets a value indicating whether the collection items preserve object references. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemReferenceLoopHandling | Gets or sets the collection item reference loop handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | ItemTypeNameHandling | Gets or sets the collection item type name handling. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContainerContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | Properties | Gets the object's properties.
Public Property | PropertyNameResolver | Gets or sets the property name resolver.
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonDynamicContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


Properties Property (JsonDynamicContract)

Properties Property (JsonDynamicContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDynamicContract Class : Properties Property
Gets the object's properties.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property Properties As JsonPropertyCollection
'Usage

Dim instance As JsonDynamicContract
Dim value As JsonPropertyCollection

value = instance.Properties
public JsonPropertyCollection Properties {get;}
public read-only property Properties: JsonPropertyCollection;
public function get Properties : JsonPropertyCollection
public: __property JsonPropertyCollection* get_Properties();
public:
property JsonPropertyCollection^ Properties {
   JsonPropertyCollection^ get();
}

Property Value

The object's properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDynamicContract Class
JsonDynamicContract Members


PropertyNameResolver Property (JsonDynamicContract)

PropertyNameResolver Property (JsonDynamicContract)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonDynamicContract Class : PropertyNameResolver Property
Gets or sets the property name resolver.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Property PropertyNameResolver As System.Func(Of String,String)
'Usage

Dim instance As JsonDynamicContract
Dim value As System.Func(Of String,String)

instance.PropertyNameResolver = value

value = instance.PropertyNameResolver
public System.Func<string,string> PropertyNameResolver {get; set;}
public read-write property PropertyNameResolver: System.Func;
public function get,set PropertyNameResolver : System.Func
public: __property System.Func<string*,string*>* get_PropertyNameResolver();
public: __property void set_PropertyNameResolver(
   System.Func<string*,string*>* value
);
public:
property System.Func<String^,String^>^ PropertyNameResolver {
   System.Func<String^,String^>^ get();
   void set (    System.Func<String^,String^>^ value);
}

Property Value

The property name resolver.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDynamicContract Class
JsonDynamicContract Members


Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets.Net4)

Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.WebSockets Namespace (Noemax.WebSockets.Net4)

Noemax.WebSockets Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | BasicWebSocketClient | Provides the simplified WebSocket client.
Class | CompressionSettings | Provides configuration properties for WebSocket transport compression.
Class | WebSocketChannel | Defines the WebSocket channel interface.
Class | WebSocketClient | Provides the WebSocket protocol client connection.
Class | WebSocketClient<TService> | Provides the WebSocket protocol client connection.
Class | WebSocketClosedException | Provides the exception raised during WebSocket communications.
Class | WebSocketConnectionChannel | Provides methods and properties for exchanging messages over WebSocket connection.
Class | WebSocketEndpoint | Provides methods and properties of WebSocket endpoint.
Class | WebSocketEventArgs | Provides the arguments of the event triggered by the BasicWebSocketClient class.
Class | WebSocketException | Provides the exception raised during WebSocket communications.
Class | WebSocketHandshake | Provides method and properties for evaluating the WebSocket handshake prior it is accepted by the local side.
Class | WebSocketHandshakeHeader | Represents a handshake header to be exchanged among with standard WebSocket headers during the handshake.
Class | WebSocketHandshakeHeaderCollection | Provides the methods and property for managing collection of WebSocketHandshakeHeader.
Class | WebSocketInboundMessage | Represents the inbound message received through WebSocket connection. Provides methods and properties for processing inbound message.
Class | WebSocketProtocolException | Provides the exception thrown when connection is being closed due to violation of WebSocket protocol by remote side.
Class | WebSocketQueueSizeException | Provides the exception thrown when the size of outbound message queue, exceeds the maximum size.
Class | WebSocketServer | Provides the WebSocket protocol server.
Class | WebSocketServer<TService> | Provides the WebSocket protocol server.
Class | WebSocketServerSecurity | Provides the WebSocket server security settings that are applied when SSL/TLS transport security is enabled.
Class | WebSocketService | Provides the base class implementation for IWebSockets interface.
Class | WebSocketUsernamePasswordCredentials | Credentials used for basic client authentication using user-name and password.
Interfaces
 | Interface | Description
Interface | IWebSockets | Defines the contract that a service must implement in order to receive message and manage connections.
Structures
 | Structure | Description
Structure | WebSocketOutboundMessage | Represents the buffered message to be sent though WebSocket connection.
Delegates
 | Delegate | Description
Delegate | WebSocketHandshakeEventHandler | Represents a method handing the WebSocket handshake event.
Enumerations
 | Enumeration | Description
Enumeration | CompressionScheme | Specifies the compression scheme to be used by WebSocket.
Enumeration | WebSocketHandshakeAction | Defines the action to take as outcome of WebSocketHandshake.
Enumeration | WebSocketMessageState | Specifies the state of the WebSocket message.
Enumeration | WebSocketMessageType | Specifies the type of the WebSocket message content.
Enumeration | WebSocketState | Defines the states of WebSocket connection.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


BasicWebSocketClient Class Members

BasicWebSocketClient Class Members
Properties Methods Events

Noemax.WebSockets Namespace : BasicWebSocketClient Class

The following tables list the members exposed by BasicWebSocketClient.

Public Constructors
 | Name | Description
Public Constructor | BasicWebSocketClient Constructor | Creates a new instance of the WebSocket class with specified target URI.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the client is connected.
Public Property | Context | Overridden.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DispatchSynchronizationContext | Used for posting events to UI thread.
Public Property | ID | Overridden.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of the outbound message queue.
Public Property | MaxOutboundQueueSize | Overridden.
Public Property | Origin | Overridden.
Public Property | OutboundQueueSize | Overridden.
Public Property | PayloadMasking | Overridden. Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Overridden.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden.
Public Property | State | Overridden.
Public Property | Via | Overridden.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Aborts the WebSocket connection with the specified status code and description
Public Method | AddProperty<T> | Overridden.
Public Method | BeginSendMessage | Overridden.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Overridden.
Public Method | GetProperty<T> | Overridden.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded.
Public Method | Send | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Overridden. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden.
Public Method | SendTextMessage | Overloaded.
Public Method | WaitForOutboundQueue | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | OnClose |
Public Event | OnError |
Public Event | OnMessage |
Public Event | OnOpen |
Public Event | OnPing |
Public Event | OnPong |
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


BasicWebSocketClient Class Methods

BasicWebSocketClient Class Methods

Noemax.WebSockets Namespace : BasicWebSocketClient Class

For a list of all members of this type, see BasicWebSocketClient members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Aborts the WebSocket connection with the specified status code and description
Public Method | AddProperty<T> | Overridden.
Public Method | BeginSendMessage | Overridden.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Overridden.
Public Method | GetProperty<T> | Overridden.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded.
Public Method | Send | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Overridden. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden.
Public Method | SendTextMessage | Overloaded.
Public Method | WaitForOutboundQueue | Overridden.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

BasicWebSocketClient Class
Noemax.WebSockets Namespace


WebSocketChannel Class Members

WebSocketChannel Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketChannel Class

The following tables list the members exposed by WebSocketChannel.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets authentication context assigned to the channel when it was authenticated by the server endpoint.
Public Property | AutoPingInterval | Gets and sets the interval of time for sending Ping messages automatically.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses.
Public Property | Connected | Gets whether the channel connection is considered being alive.
Public Property | Context | The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages.
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages.
Public Property | ID | Gets and sets the string identifier of the channel.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum number of bytes pending to be sent in outbound message queue.
Public Property | Origin | Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Gets the number of bytes pending to be sent in outbound message queue.
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the list of Sub-Protocols used by the channel.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages.
Public Property | ServiceInstance | The instance of the IWebSocket handling inbound messages.
Public Property | State | Gets and sets the states of WebSocket connection.
Public Property | Via | Gets the URI to which this channel was established.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects.
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Wait for ongoing operation to be complete and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously.
Public Method | EndSendMessage | Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel.
Public Method | Send | Overloaded. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Sends the batch of the messages asynchronously.
Public Method | SendClose | Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Sends the ping message.
Public Method | SendTextMessage | Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Waits for outbound message queue size in bytes decrease below a specified limit within a specified interval of time.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed |
Protected Method | NotifyError |
Protected Method | NotifyPing |
Protected Method | NotifyPong |
Top
Public Events
 | Name | Description
Public Event | Closed |
Public Event | Error |
Public Event | Ping |
Public Event | Pong |
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


WebSocketChannel Class Methods

WebSocketChannel Class Methods

Noemax.WebSockets Namespace : WebSocketChannel Class

For a list of all members of this type, see WebSocketChannel members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects.
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Wait for ongoing operation to be complete and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously.
Public Method | EndSendMessage | Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel.
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel.
Public Method | Send | Overloaded. Sends the message asynchronously.
Public Method | SendAsync | Overloaded. Sends a message within a specified interval of time asynchronously.
Public Method | SendBatchAsync | Overloaded. Sends the batch of the messages asynchronously.
Public Method | SendClose | Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Sends the ping message.
Public Method | SendTextMessage | Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Waits for outbound message queue size in bytes decrease below a specified limit within a specified interval of time.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed |
Protected Method | NotifyError |
Protected Method | NotifyPing |
Protected Method | NotifyPong |
Top
See Also

Reference

WebSocketChannel Class
Noemax.WebSockets Namespace


CloseAsync Method (WebSocketChannel)

CloseAsync Method (WebSocketChannel)

Noemax.WebSockets Namespace > WebSocketChannel Class : CloseAsync Method
Closes the WebSocket connection asynchronously.
Overload List
Overload | Description
CloseAsync() | Closes the WebSocket connection asynchronously.
CloseAsync(TimeSpan) | Closes the client connection to the server endpoint asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members


CloseAsync() Method

CloseAsync() Method

Noemax.WebSockets Namespace > WebSocketChannel Class > CloseAsync Method : CloseAsync() Method
Closes the WebSocket connection asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CloseAsync() As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketChannel
Dim value As System.Threading.Tasks.Task

value = instance.CloseAsync()
public System.Threading.Tasks.Task CloseAsync()
public function CloseAsync(): System.Threading.Tasks.Task;
public function CloseAsync() : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* CloseAsync();
public:
System.Threading.Tasks.Task^ CloseAsync();

Return Value

The System.Threading.Tasks.Task associated to the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


CloseAsync(TimeSpan) Method

CloseAsync(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketChannel Class > CloseAsync Method : CloseAsync(TimeSpan) Method
The period of time during which client is expected to connect to the server.
Closes the client connection to the server endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function CloseAsync( _
   ByVal timeout As System.TimeSpan _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketChannel
Dim timeout As System.TimeSpan
Dim value As System.Threading.Tasks.Task

value = instance.CloseAsync(timeout)
public System.Threading.Tasks.Task CloseAsync(
   System.TimeSpan timeout
)
public function CloseAsync(
    timeout: System.TimeSpan
): System.Threading.Tasks.Task;
public function CloseAsync(
   timeout : System.TimeSpan
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* CloseAsync(
   System.TimeSpan timeout
)
public:
System.Threading.Tasks.Task^ CloseAsync(
   System.TimeSpan timeout
)

Parameters

timeout
The period of time during which client is expected to connect to the server.

Return Value

The Task instance representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannel Class
WebSocketChannel Members
Overload List


WebSocketClient Class Members

WebSocketClient Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketClient Class

The following tables list the members exposed by WebSocketClient.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClient Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client.
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies.
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection.
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0.
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side.
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake.
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake.
Public Property | Security | Provides properties for the WebSocket connection security.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events.
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection.
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Overridden. Closes the to the client connection and releases associated resources.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
static (Shared in Visual Basic) | Create | Overloaded. Initializes the new instance of the class.
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded. Opens the client connection to the server endpoint.
Public Method | OpenAsync | Overloaded. Opens the client connection to the server endpoint asynchronously.
Public Method | Send | Overloaded. Overridden. Sends a binary message to the remote endpoint.
Public Method | SendAsync | Overloaded. Overridden. Sends the binary message to the remote endpoint.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of outbound messages to the remote endpoint asynchronously.
Public Method | SendClose | Overridden. Sends the close frame to the remote endpoint to initiate the closure of connection.
Public Method | SendMessage | Overloaded. Overridden. Initiates a streamed message to the remote endpoint.
Public Method | SendPing | Overloaded. Overridden. Sends Ping to the remote endpoint.
Public Method | SendTextMessage | Overloaded. Overridden. Initiate the outbound streamed text message.
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


WebSocketClient Class Methods

WebSocketClient Class Methods

Noemax.WebSockets Namespace : WebSocketClient Class

For a list of all members of this type, see WebSocketClient members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Overridden. Closes the to the client connection and releases associated resources.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
static (Shared in Visual Basic) | Create | Overloaded. Initializes the new instance of the class.
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Open | Overloaded. Opens the client connection to the server endpoint.
Public Method | OpenAsync | Overloaded. Opens the client connection to the server endpoint asynchronously.
Public Method | Send | Overloaded. Overridden. Sends a binary message to the remote endpoint.
Public Method | SendAsync | Overloaded. Overridden. Sends the binary message to the remote endpoint.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of outbound messages to the remote endpoint asynchronously.
Public Method | SendClose | Overridden. Sends the close frame to the remote endpoint to initiate the closure of connection.
Public Method | SendMessage | Overloaded. Overridden. Initiates a streamed message to the remote endpoint.
Public Method | SendPing | Overloaded. Overridden. Sends Ping to the remote endpoint.
Public Method | SendTextMessage | Overloaded. Overridden. Initiate the outbound streamed text message.
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient Class
Noemax.WebSockets Namespace


OpenAsync Method (WebSocketClient)

OpenAsync Method (WebSocketClient)

Noemax.WebSockets Namespace > WebSocketClient Class : OpenAsync Method
Opens the client connection to the server endpoint asynchronously.
Overload List
Overload | Description
OpenAsync(TimeSpan) | Opens the client connection to the server endpoint asynchronously.
OpenAsync() | Opens the client connection to the server endpoint asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members


OpenAsync(TimeSpan) Method

OpenAsync(TimeSpan) Method

Noemax.WebSockets Namespace > WebSocketClient Class > OpenAsync Method : OpenAsync(TimeSpan) Method
The period of time during which client is expected to connect to the server.
Opens the client connection to the server endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function OpenAsync( _
   ByVal timeout As System.TimeSpan _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketClient
Dim timeout As System.TimeSpan
Dim value As System.Threading.Tasks.Task

value = instance.OpenAsync(timeout)
public System.Threading.Tasks.Task OpenAsync(
   System.TimeSpan timeout
)
public function OpenAsync(
    timeout: System.TimeSpan
): System.Threading.Tasks.Task;
public function OpenAsync(
   timeout : System.TimeSpan
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* OpenAsync(
   System.TimeSpan timeout
)
public:
System.Threading.Tasks.Task^ OpenAsync(
   System.TimeSpan timeout
)

Parameters

timeout
The period of time during which client is expected to connect to the server.

Return Value

The Task instance representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


OpenAsync() Method

OpenAsync() Method

Noemax.WebSockets Namespace > WebSocketClient Class > OpenAsync Method : OpenAsync() Method
Opens the client connection to the server endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Function OpenAsync() As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketClient
Dim value As System.Threading.Tasks.Task

value = instance.OpenAsync()
public System.Threading.Tasks.Task OpenAsync()
public function OpenAsync(): System.Threading.Tasks.Task;
public function OpenAsync() : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* OpenAsync();
public:
System.Threading.Tasks.Task^ OpenAsync();

Return Value

The Task instance representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClient Class
WebSocketClient Members
Overload List


WebSocketClient<TService> Class Members

WebSocketClient<TService> Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

The following tables list the members exposed by WebSocketClient<TService>.

Public Constructors
 | Name | Description
Public Constructor | WebSocketClient<TService> Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Security | Provides properties for the WebSocket connection security. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Closes the to the client connection and releases associated resources. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | Overridden. Returns an new instance of IWebSocket to handle messages received by the channel.
Public Method | Open | Overloaded. Opens the client connection to the server endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | OpenAsync | Overloaded. Opens the client connection to the server endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | Send | Overloaded. Sends a binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendAsync | Overloaded. Sends the binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendBatchAsync | Overloaded. Sends the batch of outbound messages to the remote endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendClose | Sends the close frame to the remote endpoint to initiate the closure of connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendMessage | Overloaded. Initiates a streamed message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendPing | Overloaded. Sends Ping to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendTextMessage | Overloaded. Initiate the outbound streamed text message. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


WebSocketClient<TService> Class Methods

WebSocketClient<TService> Class Methods

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

For a list of all members of this type, see WebSocketClient<TService> members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Interrupt all ongoing operation and closes the network connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Begins an asynchronous operation to send a message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | Close | Overloaded. Closes the to the client connection and releases associated resources. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Completes an asynchronous send operation. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | Overridden. Returns an new instance of IWebSocket to handle messages received by the channel.
Public Method | Open | Overloaded. Opens the client connection to the server endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | OpenAsync | Overloaded. Opens the client connection to the server endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | Send | Overloaded. Sends a binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendAsync | Overloaded. Sends the binary message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendBatchAsync | Overloaded. Sends the batch of outbound messages to the remote endpoint asynchronously. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendClose | Sends the close frame to the remote endpoint to initiate the closure of connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendMessage | Overloaded. Initiates a streamed message to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendPing | Overloaded. Sends Ping to the remote endpoint. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | SendTextMessage | Overloaded. Initiate the outbound streamed text message. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Method | WaitForOutboundQueue | Waits until outbound queue decrease below specified limit. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


WebSocketConnectionChannel Class Members

WebSocketConnectionChannel Class Members
Properties Methods Events

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

The following tables list the members exposed by WebSocketConnectionChannel.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Overridden. Gets the instance of the object that is associated to the connection during authentication.
Public Property | AutoPingInterval | Overridden.
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Connected | Overridden. Gets whether the channel connection is considered being alive.
Public Property | Context | Overridden. The context object associated to the channel.
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ID | Overridden. Gets and sets the string identifier of the channel.
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame.
Public Property | MaxOutboundQueueSize | Overridden. Gets and sets the maximum size of the outbound message queue.
Public Property | Origin | Overridden. Gets origin string negotiated during the WebSocket handshake.
Public Property | OutboundQueueSize | Overridden. Gets the current size of the outbound message queue in bytes.
Public Property | PayloadMasking | Overridden. Gets and sets whether the payload of outbound messages is masked.
Public Property | Protocol | Overridden. Gets the protocol negotiated during the WebSocket handshake.
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Overridden. Gets and sets the instance of IWebSockets to perform dispatching of inbound messages.
Public Property | State | Overridden. Gets and sets the states of WebSocket connection.
Public Property | Via | Overridden. Gets the URI via which the channel was established.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Overridden. Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Overridden. Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Send | Overloaded. Overridden. Sends a binary message with a specified array segment as a payload within a specified interval of time.
Public Method | SendAsync | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden. Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden. Sends the ping message.
Public Method | SendTextMessage | Overloaded. Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Overridden. Waits until outbound queue decrease below specified limit.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


WebSocketConnectionChannel Class Methods

WebSocketConnectionChannel Class Methods

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

For a list of all members of this type, see WebSocketConnectionChannel members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Overridden. Interrupt all ongoing operation and closes the network connection.
Public Method | AddProperty<T> | Adds the object of the specified type to the collection of associated objects. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | BeginSendMessage | Overridden. Begins an asynchronous operation to send a message to the remote endpoint.
Public Method | Close | Overloaded. Overridden. Wait for ongoing operation to be complete during specified interval of time and closes the network connection.
Public Method | CloseAsync | Overloaded. Closes the WebSocket connection asynchronously. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | EndSendMessage | Overridden. Completes an asynchronous send operation.
Public Method | GetProperty<T> | Returns the object of specified type associated to the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | GetServiceInstance | When overridden returns an IWebSockets instance to handle messages received by the channel. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Method | Send | Overloaded. Overridden. Sends a binary message with a specified array segment as a payload within a specified interval of time.
Public Method | SendAsync | Overloaded. Overridden. Sends the message asynchronously.
Public Method | SendBatchAsync | Overloaded. Overridden. Sends the batch of the messages asynchronously.
Public Method | SendClose | Overridden. Sends the CLOSE control frame with specified statusCode and reason string.
Public Method | SendMessage | Overloaded. Overridden. Streams the binary message to the remote side.
Public Method | SendPing | Overloaded. Overridden. Sends the ping message.
Public Method | SendTextMessage | Overloaded. Streams the text message to the remote side.
Public Method | WaitForOutboundQueue | Overridden. Waits until outbound queue decrease below specified limit.
Top
Protected Methods
 | Name | Description
Protected Method | NotifyClosed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyError | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPing | (Inherited from Noemax.WebSockets.WebSocketChannel)
Protected Method | NotifyPong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


Noemax.WebSockets.Core Namespace (Noemax.WebSockets.Net4)

Noemax.WebSockets.Core Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | ControlFrameEventArgs | The event argument used by control frame related events of WebSocket.
Class | UsernamePasswordAuthenticateEventArgs | Argument for event generated during Basic HTTP authentication.
Class | WebSocket | Provides methods and properties for sending and receiving messages through WebSocket connection.
Class | WebSocketClientSecurity | Provides properties that apply when SSL/TLS transport security is enabled.
Class | WebSocketCloseCodes | Defines the constants to be used with for sending the WebSocket close frame status code that define the reason for closing the connection.
Class | WebSocketCloseEventArgs | Provides methods and properties for the close event arguments.
Class | WebSocketErrorEventArgs | Provides methods and properties for error event arguments.
Class | WebSocketFactory | Creates and manages client WebSocket connections.
Class | WebSocketListener | Listens on WebSockets endpoints, accepts and manages WebSocket connections.
Class | WebSocketMessageInputStream | Expose a WebSocket message as a input and provides methods and properties for streaming WebSocket messages.
Class | WebSocketPingOrPongEventArgs | Provides methods and properties for Pong event handler arguments.
Delegates
 | Delegate | Description
Delegate | UsernamePasswordAuthenticateEventHandler | Represents a methods that will be handling the username/password authentication.
Delegate | X509CertificateValidationCallback | The callback delegate providing the remote X509 certificate validation.
Enumerations
 | Enumeration | Description
Enumeration | KeepaliveMode |
See Also

Reference

Noemax.WebSockets.Net4 Assembly


WebSocket Class Members

WebSocket Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocket Class

The following tables list the members exposed by WebSocket.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the context object created during authentication of the WebSocket connection.
Public Property | CanReceive | Gets the value that indicate whether WebSocket is expected to receive messages.
Public Property | CanSend | Gets the value that indicate whether WebSocket is able to send messages.
Public Property | Connected | Gets the value that indicate whether the WebSocket is connected.
Public Property | Context | Gets and sets the object that associated to the context of the WebSocket instance.
Public Property | DefaultReceiveTimeout | Gets and sets a default timeout to be used when receiving incoming messages.
Public Property | DefaultSendTimeout | Gets and sets a default timeout to be used when sending outgoing messages.
Public Property | Extensions | Gets a Sec-WebSocket-Extensions header string negotiated during the WebSocket handshake.
Public Property | IsServerSide | Gets whether the WebSocket connection is on the server side and managed by the WebSocket listener.
Public Property | KeepaliveMode |
Public Property | KeepaliveResponseThrottlingInterval |
Public Property | KeepaliveRoundtripRequired |
Public Property | KeepaliveSendInterval |
Public Property | KeepaliveTimeout |
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size of outbound frame produced by the WebSocket.
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of outbound message queue.
Public Property | Origin | Gets a string that defines an Origin of this WebSocket connection.
Public Property | OutboundQueueSize | Gets and sets the current size of outbound message queue.
Public Property | PayloadMasking | Get or sets whether payload of outbound messages is masked.
Public Property | Protocol | Gets a string that defines a Sub-Protocol used by this WebSocket connection.
Public Property | State | Gets the state of the WebSocket connection.
Public Property | TraceSource | Gets and sets the TraceSource to be used by the WebSocket instance for tracing events.
Public Property | Via | Gets the _uri of remote endpoint.
Top
Protected Properties
 | Name | Description
Protected Property | IsFailed | Returns True if WebSocket connection is failed due to error.
Top
Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Public Method | AbortAsync | Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to compelte.
Public Method | BeginReceiveMessage | Overloaded. Begins an asynchronous operation to receive a message that has a state object associated with it.
Public Method | BeginSendMessage | Overloaded. Begins asynchronous operation to sends message.
Public Method | Close | Overloaded. Attempts a graceful shutdown of WebSocket connection and closes the socket.
Public Method | CloseAsync | Attempts to close the WebSocket connection gracefully.
Public Method | EndReceiveMessage | Overloaded. Completes an asynchronous operation to receive a message
Public Method | EndSendMessage | Completes asynchronous send operation.
Public Method | Receive | /R eceives a message from the WebSocket connection.
Public Method | ReceiveAsync |
Public Method | ReceiveMessage | Overloaded. Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Public Method | SendAsync | Sends message asynchronously.
Public Method | SendBatchAsync | Sends a batch of the messages asynchronously.
Public Method | SendClose | Sends the close frame with a status code and text specifying the reason for closing connection.
Public Method | SendMessage | Overloaded. Initiates a new outgoing message and returns a Stream that write the message into connection.
Public Method | SendMessageAsync | Sends message asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to the remote endpoint.
Public Method | SendPong | Sends the Pong message to remote endpoint.
Public Method | SendTextMessage | Overloaded. Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Public Method | WaitForOutboundQueue | Overloaded. Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Public Method | WriteMessage | Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Top
Protected Methods
 | Name | Description
Protected Method | IsWaitingInboundMessage | Returns whether the WebSocket is waiting for inbound messages.
Top
Public Events
 | Name | Description
Public Event | OnCloseFrame | Notifies the event handlers when Close frame was received from the remote endpoint.
Public Event | OnPing | Notifies the event handlers when Ping frame was received from the remote endpoint.
Public Event | OnPong | Notifies the event handlers when Pong frame was received from the remote endpoint.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


WebSocket Class Methods

WebSocket Class Methods

Noemax.WebSockets.Core Namespace : WebSocket Class

For a list of all members of this type, see WebSocket members.

Public Methods
 | Name | Description
Public Method | Abort | Overloaded. Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to complete.
Public Method | AbortAsync | Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to compelte.
Public Method | BeginReceiveMessage | Overloaded. Begins an asynchronous operation to receive a message that has a state object associated with it.
Public Method | BeginSendMessage | Overloaded. Begins asynchronous operation to sends message.
Public Method | Close | Overloaded. Attempts a graceful shutdown of WebSocket connection and closes the socket.
Public Method | CloseAsync | Attempts to close the WebSocket connection gracefully.
Public Method | EndReceiveMessage | Overloaded. Completes an asynchronous operation to receive a message
Public Method | EndSendMessage | Completes asynchronous send operation.
Public Method | Receive | /R eceives a message from the WebSocket connection.
Public Method | ReceiveAsync |
Public Method | ReceiveMessage | Overloaded. Receives the message from the WebSocket connection and returns System.IO.Stream that reads the message.
Public Method | SendAsync | Sends message asynchronously.
Public Method | SendBatchAsync | Sends a batch of the messages asynchronously.
Public Method | SendClose | Sends the close frame with a status code and text specifying the reason for closing connection.
Public Method | SendMessage | Overloaded. Initiates a new outgoing message and returns a Stream that write the message into connection.
Public Method | SendMessageAsync | Sends message asynchronously.
Public Method | SendPing | Overloaded. Sends the PING message to the remote endpoint.
Public Method | SendPong | Sends the Pong message to remote endpoint.
Public Method | SendTextMessage | Overloaded. Initiates a new outgoing message and returns a StreamWriter that write the message into connection.
Public Method | WaitForOutboundQueue | Overloaded. Waits for outbound message queue size to decrease to a specified value for a specified period of time.
Public Method | WriteMessage | Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Top
Protected Methods
 | Name | Description
Protected Method | IsWaitingInboundMessage | Returns whether the WebSocket is waiting for inbound messages.
Top
See Also

Reference

WebSocket Class
Noemax.WebSockets.Core Namespace


AbortAsync Method

AbortAsync Method

Noemax.WebSockets.Core Namespace > WebSocket Class : AbortAsync Method
The status code to send to remote side.
The text description of the status code. This value should not exceed 120 characters.
The cancelation token to check wether asynchronous operation is cancelled.
Aborts connection by sending the close frame to remote side and closing connection without waiting for any other operation to compelte.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AbortAsync( _
   ByVal statusCode As System.Integer, _
   ByVal statusText As System.String, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocket
Dim statusCode As System.Integer
Dim statusText As System.String
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.AbortAsync(statusCode, statusText, cancellationToken)
public System.Threading.Tasks.Task AbortAsync(
   System.int statusCode,
   System.string statusText,
   System.Threading.CancellationToken cancellationToken
)
public function AbortAsync(
    statusCode: System.Integer;
    statusText: System.String;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task;
public function AbortAsync(
   statusCode : System.int,
   statusText : System.String,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* AbortAsync(
   System.int statusCode,
   System.string* statusText,
   System.Threading.CancellationToken cancellationToken
)
public:
System.Threading.Tasks.Task^ AbortAsync(
   System.int statusCode,
   System.String^ statusText,
   System.Threading.CancellationToken cancellationToken
)

Parameters

statusCode
The status code to send to remote side.
statusText
The text description of the status code. This value should not exceed 120 characters.
cancellationToken
The cancelation token to check wether asynchronous operation is cancelled.

Return Value

The Task object that represent asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


CloseAsync Method (WebSocket)

CloseAsync Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : CloseAsync Method
The period of time during which operation is expected to complete or timeout.
The cancellation token to check whether the asynchronous operation is canceled.
Attempts to close the WebSocket connection gracefully.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CloseAsync( _
   ByVal timeout As System.TimeSpan, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.CloseAsync(timeout, cancellationToken)
public System.Threading.Tasks.Task CloseAsync(
   System.TimeSpan timeout,
   System.Threading.CancellationToken cancellationToken
)
public function CloseAsync(
    timeout: System.TimeSpan;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task;
public function CloseAsync(
   timeout : System.TimeSpan,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* CloseAsync(
   System.TimeSpan timeout,
   System.Threading.CancellationToken cancellationToken
)
public:
System.Threading.Tasks.Task^ CloseAsync(
   System.TimeSpan timeout,
   System.Threading.CancellationToken cancellationToken
)

Parameters

timeout
The period of time during which operation is expected to complete or timeout.
cancellationToken
The cancellation token to check whether the asynchronous operation is canceled.

Return Value

The task performing asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


ReceiveAsync Method

ReceiveAsync Method

Noemax.WebSockets.Core Namespace > WebSocket Class : ReceiveAsync Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ReceiveAsync( _
   ByVal timeout As System.TimeSpan _
) As System.Threading.Tasks.Task(Of WebSocketInboundMessage)
'Usage

Dim instance As WebSocket
Dim timeout As System.TimeSpan
Dim value As System.Threading.Tasks.Task(Of WebSocketInboundMessage)

value = instance.ReceiveAsync(timeout)
public System.Threading.Tasks.Task<WebSocketInboundMessage> ReceiveAsync(
   System.TimeSpan timeout
)
public function ReceiveAsync(
    timeout: System.TimeSpan
): System.Threading.Tasks.Task;
public function ReceiveAsync(
   timeout : System.TimeSpan
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task<WebSocketInboundMessage*>* ReceiveAsync(
   System.TimeSpan timeout
)
public:
System.Threading.Tasks.Task<WebSocketInboundMessage^>^ ReceiveAsync(
   System.TimeSpan timeout
)

Parameters

timeout
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


SendAsync Method (WebSocket)

SendAsync Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : SendAsync Method
The message to send asynchrously.
The Timespan that specifies how long the send operation has to complete before timing out.
Sends message asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function SendAsync( _
   ByVal message As WebSocketOutboundMessage, _
   ByVal timeout As System.TimeSpan _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocket
Dim message As WebSocketOutboundMessage
Dim timeout As System.TimeSpan
Dim value As System.Threading.Tasks.Task

value = instance.SendAsync(message, timeout)
public System.Threading.Tasks.Task SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public function SendAsync(
    message: WebSocketOutboundMessage;
    timeout: System.TimeSpan
): System.Threading.Tasks.Task;
public function SendAsync(
   message : WebSocketOutboundMessage,
   timeout : System.TimeSpan
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)
public:
System.Threading.Tasks.Task^ SendAsync(
   WebSocketOutboundMessage message,
   System.TimeSpan timeout
)

Parameters

message
The message to send asynchrously.
timeout
The Timespan that specifies how long the send operation has to complete before timing out.

Return Value

The Task representing asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


WebSocketFactory Class Members

WebSocketFactory Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

The following tables list the members exposed by WebSocketFactory.

Public Constructors
 | Name | Description
Public Constructor | WebSocketFactory Constructor | Initialize a new instance of WebSocketFactory.
Top
Public Properties
 | Name | Description
Public Property | BypassProxyOnLocal | Gets and sets whether the factory should bypass local proxies when establishing a client connection.
Public Property | Compression | Gets and set whether the transport compression should be applied and what compression method to use for compressing the traffic.
Public Property | CookieContainer | Gets and sets CookieContainer used by the WebSocketFactory instance.
Public Property | Extensions | Gets and sets the string specifying extensions supported by the WebSocket client.
Public Property | MaxRedirects | Gets and sets the maximum number of times the remote endpoints can redirect the client connection during WebSocket handshake.
Public Property | Origin | Gets and sets the string identifying the origin of WebSocket client.
Public Property | OutboundHandshakeHeaders | Gets the collection of handshake headers to be sent to remote endpoint during the WebSocket handshake;
Public Property | PayloadMasking | Gets and sets whether the WebSocket instances created by this factory should mask payload sent to the server.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocket client.
Public Property | ProxyAddress | Gets and sets the address of the web proxy to be used by the factory when establishing connection.
Public Property | Security | Provides properties that apply when the SSL/TLS transport security is enabled.
Public Property | StreamUpgradeProvider | Gets and set the WCF StreamUpgradeProvider to be upgrade the input of established connections.
Public Property | TraceSource | Gets and sets the trace source to be used for tracing WebSocket activities.
Public Property | UseDefaultWebProxy | Gets and sets whether the factory should use default web proxy when establishing a client connection.
Top
Public Methods
 | Name | Description
Public Method | Connect | Overloaded. Creates a new WebSocket connection to the specified destination URI string.
Public Method | ConnectAsync | Creates a new WebSocket connection to the specified destination URI asynchronously.
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered during WebSocket handshake.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


WebSocketFactory Class Methods

WebSocketFactory Class Methods

Noemax.WebSockets.Core Namespace : WebSocketFactory Class

For a list of all members of this type, see WebSocketFactory members.

Public Methods
 | Name | Description
Public Method | Connect | Overloaded. Creates a new WebSocket connection to the specified destination URI string.
Public Method | ConnectAsync | Creates a new WebSocket connection to the specified destination URI asynchronously.
Top
See Also

Reference

WebSocketFactory Class
Noemax.WebSockets.Core Namespace


ConnectAsync Method

ConnectAsync Method

Noemax.WebSockets.Core Namespace > WebSocketFactory Class : ConnectAsync Method
The URI to the WebSocket endpoint.
The token that propagates the notification that operations should be canceled.
Creates a new WebSocket connection to the specified destination URI asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function ConnectAsync( _
   ByVal uri As System.Uri, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task(Of WebSocket)
'Usage

Dim instance As WebSocketFactory
Dim uri As System.Uri
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task(Of WebSocket)

value = instance.ConnectAsync(uri, cancellationToken)
public System.Threading.Tasks.Task<WebSocket> ConnectAsync(
   System.Uri uri,
   System.Threading.CancellationToken cancellationToken
)
public function ConnectAsync(
    uri: System.Uri;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task;
public function ConnectAsync(
   uri : System.Uri,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task<WebSocket*>* ConnectAsync(
   System.Uri* uri,
   System.Threading.CancellationToken cancellationToken
)
public:
System.Threading.Tasks.Task<WebSocket^>^ ConnectAsync(
   System.Uri^ uri,
   System.Threading.CancellationToken cancellationToken
)

Parameters

uri
The URI to the WebSocket endpoint.
cancellationToken
The token that propagates the notification that operations should be canceled.

Return Value

The task object representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketFactory Class
WebSocketFactory Members


WebSocketListener Class Members

WebSocketListener Class Members
Properties Methods Events

Noemax.WebSockets.Core Namespace : WebSocketListener Class

The following tables list the members exposed by WebSocketListener.

Public Constructors
 | Name | Description
Public Constructor | WebSocketListener Constructor | Initializes a new WebSocketListener instance with specified endpoint URI.
Top
Public Properties
 | Name | Description
Public Property | Compression | Gets the compression settings to be used for the payload compression.
Public Property | IsOpen | Gets the value the specify whether the listener is open.
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer.
Public Property | Protocol | Gets and sets the string identifying the sub-protocol used WebSocketListener.
Public Property | Security | Gets the server security settings that are applied when SSL/TLS security is enabled.
Public Property | TraceSource | Gets and sets TraceSource used for tracing the WebSocket events.
Public Property | Uri | Gets the URI WebSocket endpoint associated to the listener.
Top
Public Methods
 | Name | Description
Public Method | Accept | Accepts client connection from associated endpoint.
Public Method | AcceptAsync | Waits and accepts WebSocket client connection asynchronously.
Public Method | BeginAccept | Begin asynchronous operation to accept client connection.
Public Method | Close | Stops accepting the client connections and closes the associated WebSocket endpoint.
Public Method | CloseAsync | Stops accepting the client connections and closes the associated WebSocket endpoint asynchronously.
Public Method | EndAccept | Concludes asynchronous operation to accept client connection.
Public Method | Open | Opens the WebSocket endpoint and starts waiting for client connection to accept.
Public Method | OpenAsync | Opens the WebSocket endpoint and start waiting for client connections to accept asynchronously.
Top
Protected Methods
 | Name | Description
Protected Method | DispatchChannel | Dispatches accepted WebSocket instance to the pending Accept operation or puts it into queue to be accepted later.
Protected Method | ReadCookies | Reads cookies from the HTTP header value.
Top
Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


WebSocketListener Class Methods

WebSocketListener Class Methods

Noemax.WebSockets.Core Namespace : WebSocketListener Class

For a list of all members of this type, see WebSocketListener members.

Public Methods
 | Name | Description
Public Method | Accept | Accepts client connection from associated endpoint.
Public Method | AcceptAsync | Waits and accepts WebSocket client connection asynchronously.
Public Method | BeginAccept | Begin asynchronous operation to accept client connection.
Public Method | Close | Stops accepting the client connections and closes the associated WebSocket endpoint.
Public Method | CloseAsync | Stops accepting the client connections and closes the associated WebSocket endpoint asynchronously.
Public Method | EndAccept | Concludes asynchronous operation to accept client connection.
Public Method | Open | Opens the WebSocket endpoint and starts waiting for client connection to accept.
Public Method | OpenAsync | Opens the WebSocket endpoint and start waiting for client connections to accept asynchronously.
Top
Protected Methods
 | Name | Description
Protected Method | DispatchChannel | Dispatches accepted WebSocket instance to the pending Accept operation or puts it into queue to be accepted later.
Protected Method | ReadCookies | Reads cookies from the HTTP header value.
Top
See Also

Reference

WebSocketListener Class
Noemax.WebSockets.Core Namespace


AcceptAsync Method

AcceptAsync Method

Noemax.WebSockets.Core Namespace > WebSocketListener Class : AcceptAsync Method
Waits and accepts WebSocket client connection asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function AcceptAsync() As System.Threading.Tasks.Task(Of WebSocket)
'Usage

Dim instance As WebSocketListener
Dim value As System.Threading.Tasks.Task(Of WebSocket)

value = instance.AcceptAsync()
public System.Threading.Tasks.Task<WebSocket> AcceptAsync()
public function AcceptAsync(): System.Threading.Tasks.Task;
public function AcceptAsync() : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task<WebSocket*>* AcceptAsync();
public:
System.Threading.Tasks.Task<WebSocket^>^ AcceptAsync();

Return Value

The instance of WebSocket accepted.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


CloseAsync Method (WebSocketListener)

CloseAsync Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : CloseAsync Method
The token that propagates the notification that operations should be canceled.
Stops accepting the client connections and closes the associated WebSocket endpoint asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function CloseAsync( _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketListener
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.CloseAsync(cancellationToken)
public System.Threading.Tasks.Task CloseAsync(
   System.Threading.CancellationToken cancellationToken
)
public function CloseAsync(
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task;
public function CloseAsync(
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* CloseAsync(
   System.Threading.CancellationToken cancellationToken
)
public:
System.Threading.Tasks.Task^ CloseAsync(
   System.Threading.CancellationToken cancellationToken
)

Parameters

cancellationToken
The token that propagates the notification that operations should be canceled.

Return Value

The task object representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


OpenAsync Method (WebSocketListener)

OpenAsync Method (WebSocketListener)

Noemax.WebSockets.Core Namespace > WebSocketListener Class : OpenAsync Method
The token that propagates the notification that operations should be canceled.
Opens the WebSocket endpoint and start waiting for client connections to accept asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function OpenAsync( _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketListener
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.OpenAsync(cancellationToken)
public System.Threading.Tasks.Task OpenAsync(
   System.Threading.CancellationToken cancellationToken
)
public function OpenAsync(
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task;
public function OpenAsync(
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
public: System.Threading.Tasks.Task* OpenAsync(
   System.Threading.CancellationToken cancellationToken
)
public:
System.Threading.Tasks.Task^ OpenAsync(
   System.Threading.CancellationToken cancellationToken
)

Parameters

cancellationToken
The token that propagates the notification that operations should be canceled.

Return Value

The task object representing the asynchronous operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketListener Class
WebSocketListener Members


Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets.Net4)

Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | ActionInvoker | The invoker for operations that does not return any result.
Class | ActionInvoker<T> | The invoker providing one way operations.
Class | ActionInvokerFactory | The factory creating ActionInvoker<T> instances.
Class | ActionOperation1Invoker |
Class | ActionOperation1Invoker<T> |
Class | ActionOperationInvoker |
Class | ActionOperationInvoker<T> |
Class | CompressedMessageSerializer | Provides a serializer which transparently compress outbound messages and decompress inbound messages.
Class | ConversationMessage | Represents an envelope providing additional metadata for dispatching the message.
Class | DefaultClientDispatcher | Provides methods and properties for sending request messages and dispatching response messages on the Noemax.WebSockets.WebSocketChannel connection.
Class | DefaultMessageDispatcher | Dispatches the messages based on the action string or the data type deserialized from the message payload.
Class | EnvelopedMessage | The base class for all messages sent by PowerWebSockets RPC.
Class | FuncInvoker<TResult,TRequest> | The invoker providing request/response operations.
Class | FuncInvokerFactory | The factory producing FuncInvoker<TResult,TRequest> instances.
Class | FuncOperation1Invoker<TResult,T> |
Class | FuncOperationInvoker<TResult,T> |
Class | Invoker | Abstract based class for invoker that process inbound message by invoking the method of the service and passing deserialized message as parameter.
Class | InvokerFactory | The factory producing Invoker instances.
Class | JsonClientProxyProvider | Provides WebSocketMessagingService with a JavaScript client proxy file based on defined messanging operations.
Class | JsonMessageSerializer | Provides serialization of data into WebSocket text messages using JSON format.
Class | MessageDispatcher | Provides methods and properties for dispatching WebSocket messages to message operations.
Class | MessageOperationAttribute | Indicates that a method defines an operation that is part of a service contract.
Class | MessageOperationDescription | Defines the properties of message dispatching operation.
Class | MessageSerializerBase | Provides the base class for serializing objects into WebSocket messages.
Class | MessagingContractAttribute | Indicates that an interface or a class defines a service contract.
Class | MultiFormatMessagingService | The base class for the service that dispatches inbound messages based on the type of the objects deserialized from the message content. This service is capable to use different format per each associated channel.
Class | PlainMessage | Represents a simple message without any message envelope that contains a message body and can have a streamed attachment.
Class | ReflectionInvoker | Provides invoker for calling the message operation that multiple parameters.
Class | RequestInvoker |
Class | RpcFaultException | The exception providing a FaultInfo.
Class | VoidInputInvoker<TResult> | Provides invoker for calling functions that does not take parameters.
Class | VoidInputInvokerFactory | Provides VoidInputInvoker<TResult> invokers./>
Class | VoidInputOperationInvoker<TResult> |
Class | VoidInputOperationInvoker1<TResult> |
Class | WebSocketChannelExtensions | Provides extension methods for WebSocketChannel class.
Class | WebSocketMessagingService | The base class for the service that performs dispatching of the inbound messages based of the type of the object deserialized from the the message content and the action string provided by inbound message.
Class | XmlMessageSerializer | Provides XML serialization for WebSocket messaging services.
Interfaces
 | Interface | Description
Interface | IClientDispatcher | Defines the interface that provides methods and properties for dispatching messages on the client side.
Interface | ICriteria | Represents the criteria based on which MessageDispatcher dispatches messages.
Interface | IMessageSerializer | Defines the interface for implementation that provides serialization of the objects through the WebSocket channels.
Structures
 | Structure | Description
Structure | FaultInfo | Provides information on the fault returned by remote side as response to request message.
Delegates
 | Delegate | Description
Delegate | ActionOperation |
Delegate | ActionOperation1 |
Delegate | ActionOperation1<T> |
Delegate | FuncOperation<TResult,T> |
Delegate | FuncOperation1<TResult,T> |
Delegate | VoidInputOperation<TResult> | Defines the signature of the message operation that does not take any input but returns data.
Delegate | VoidInputOperation1<TResult> | Defines the signature of the message operation that does not take any input but returns data.
Enumerations
 | Enumeration | Description
Enumeration | CompressedMessageFormat | The compression format to use for compressing the outbound messages.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


ActionInvoker Class

ActionInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : ActionInvoker Class
The invoker for operations that does not return any result.
Object Model
ActionInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public MustInherit Class ActionInvoker
   Inherits RequestInvoker
'Usage

Dim instance As ActionInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public abstract class ActionInvoker : RequestInvoker
public class ActionInvoker = class(RequestInvoker)abstract;
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public abstract class ActionInvoker extends RequestInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc abstract class ActionInvoker : public RequestInvoker
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public ref class ActionInvoker abstract : public RequestInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker
Noemax.WebSockets.Messaging.ActionOperationInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvoker Members
Noemax.WebSockets.Messaging Namespace


ActionInvokerFactory Class

ActionInvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : ActionInvokerFactory Class
The factory creating ActionInvoker<T> instances.
Object Model
ActionInvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Class ActionInvokerFactory
   Inherits InvokerFactory
'Usage

Dim instance As ActionInvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public class ActionInvokerFactory : InvokerFactory
public class ActionInvokerFactory = class(InvokerFactory)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public class ActionInvokerFactory extends InvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc class ActionInvokerFactory : public InvokerFactory
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public ref class ActionInvokerFactory : public InvokerFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.ActionInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionInvokerFactory Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker<T> Class

ActionOperation1Invoker<T> Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker<T> Class
Object Model
ActionOperation1Invoker<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public NotInheritable Class ActionOperation1Invoker(Of T)
   Inherits ActionInvoker(Of T)
'Usage

Dim instance As ActionOperation1Invoker(Of T)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public sealed class ActionOperation1Invoker<T> : ActionInvoker<T>
public class ActionOperation1Invoker = class(ActionInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public __gc __sealed class ActionOperation1Invoker<T> : public ActionInvoker<T>
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
generic<typename T>
public ref class ActionOperation1Invoker sealed : public ActionInvoker<T>
Type Parameters
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1Invoker<T> Members
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker Class

ActionOperationInvoker Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker Class
Object Model
ActionOperationInvoker Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class ActionOperationInvoker
   Inherits ActionInvoker
'Usage

Dim instance As ActionOperationInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class ActionOperationInvoker : ActionInvoker
public class ActionOperationInvoker = class(ActionInvoker)sealed;
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public sealed class ActionOperationInvoker extends ActionInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class ActionOperationInvoker : public ActionInvoker
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public ref class ActionOperationInvoker sealed : public ActionInvoker
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionOperationInvoker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker Members
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker<T> Class

ActionOperationInvoker<T> Class
Members

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker<T> Class
Object Model
ActionOperationInvoker<T> Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public NotInheritable Class ActionOperationInvoker(Of T)
   Inherits ActionInvoker(Of T)
'Usage

Dim instance As ActionOperationInvoker(Of T)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public sealed class ActionOperationInvoker<T> : ActionInvoker<T>
public class ActionOperationInvoker = class(ActionInvoker)sealed;
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc __sealed class ActionOperationInvoker<T> : public ActionInvoker<T>
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename T>
public ref class ActionOperationInvoker sealed : public ActionInvoker<T>
Type Parameters
T
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperationInvoker<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperationInvoker<T> Members
Noemax.WebSockets.Messaging Namespace


Id Property (ConversationMessage)

Id Property (ConversationMessage)

Noemax.WebSockets.Messaging Namespace > ConversationMessage Class : Id Property
Gets the number identifying the request to the service.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<JsonPropertyAttribute("id")>
<System.Runtime.Serialization.DataMemberAttribute(Name="id",
   Order=0,
   EmitDefaultValue=False)>
Public Property Id As System.Nullable(Of Long)
'Usage

Dim instance As ConversationMessage
Dim value As System.Nullable(Of Long)

instance.Id = value

value = instance.Id
[JsonProperty("id")]
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
public System.Nullable<long> Id {get; set;}
public read-write property Id: System.Nullable;
JsonPropertyAttribute("id")
System.Runtime.Serialization.DataMemberAttribute(Name="id",
   Order=0,
   EmitDefaultValue=)
public function get,set Id : System.Nullable
[JsonProperty("id")]
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
public: __property System.Nullable<long> get_Id();
public: __property void set_Id(
   System.Nullable<long> value
);
[JsonProperty("id")]
[System.Runtime.Serialization.DataMember(Name="id",
   Order=0,
   EmitDefaultValue=false)]
public:
property System.Nullable<int64> Id {
   System.Nullable<int64> get();
   void set (    System.Nullable<int64> value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ConversationMessage Class
ConversationMessage Members


Attachment Property (EnvelopedMessage)

Attachment Property (EnvelopedMessage)

Noemax.WebSockets.Messaging Namespace > EnvelopedMessage Class : Attachment Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<JsonIgnoreAttribute()>
<System.Runtime.Serialization.IgnoreDataMemberAttribute()>
Public Overridable Property Attachment As System.IO.Stream
'Usage

Dim instance As EnvelopedMessage
Dim value As System.IO.Stream

instance.Attachment = value

value = instance.Attachment
[JsonIgnore()]
[System.Runtime.Serialization.IgnoreDataMember()]
public virtual System.IO.Stream Attachment {get; set;}
public read-write property Attachment: System.IO.Stream; virtual;
JsonIgnoreAttribute()
System.Runtime.Serialization.IgnoreDataMemberAttribute()
public function get,set Attachment : System.IO.Stream
[JsonIgnore()]
[System.Runtime.Serialization.IgnoreDataMember()]
public: __property virtual System.IO.Stream* get_Attachment();
public: __property virtual void set_Attachment(
   System.IO.Stream* value
);
[JsonIgnore()]
[System.Runtime.Serialization.IgnoreDataMember()]
public:
virtual property System.IO.Stream^ Attachment {
   System.IO.Stream^ get();
   void set (    System.IO.Stream^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EnvelopedMessage Class
EnvelopedMessage Members


FuncInvokerFactory Class

FuncInvokerFactory Class
Members

Noemax.WebSockets.Messaging Namespace : FuncInvokerFactory Class
The factory producing FuncInvoker<TResult,TRequest> instances.
Object Model
FuncInvokerFactory Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class FuncInvokerFactory
   Inherits InvokerFactory
'Usage

Dim instance As FuncInvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public class FuncInvokerFactory : InvokerFactory
public class FuncInvokerFactory = class(InvokerFactory)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public class FuncInvokerFactory extends InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public __gc class FuncInvokerFactory : public InvokerFactory
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public ref class FuncInvokerFactory : public InvokerFactory
Inheritance Hierarchy

System.Object
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.FuncInvokerFactory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FuncInvokerFactory Members
Noemax.WebSockets.Messaging Namespace


MessageDispatcher Class Members

MessageDispatcher Class Members
Properties Methods

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class

The following tables list the members exposed by MessageDispatcher.

Public Properties
 | Name | Description
Public Property | DefaultSerializer | Gets the default IMessageSerializer instance used by the underlying service.
Public Property | KnownTypes | Gets the list of data types expected to be exchanged by underlying service.
Public Property | Operations | Gets the list of operations being dispatched by the dispatcher.
Top
Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher.
Public Method | CreateClientDispatcher | Creates the instance of the IClientDispatcher facilitating send request and dispatching responses by WebSocketClient.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message.
Public Method | TryGetOperation | Finds the operation with a specified Action value.
Top
See Also

Reference

MessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


MessageDispatcher Class Methods

MessageDispatcher Class Methods

Noemax.WebSockets.Messaging Namespace : MessageDispatcher Class

For a list of all members of this type, see MessageDispatcher members.

Public Methods
 | Name | Description
Public Method | AddOperation | Overloaded. Creates and adds the messaging operation to the dispatcher.
Public Method | CreateClientDispatcher | Creates the instance of the IClientDispatcher facilitating send request and dispatching responses by WebSocketClient.
Public Method | Dispatch | Dispatches the message to the method that matches inbound message action or accepts the object deserialized form the message as parameter.
Public Method | GetOperation | Resolves the message to the MessageOperationDescription that can process the message.
Public Method | TryGetOperation | Finds the operation with a specified Action value.
Top
See Also

Reference

MessageDispatcher Class
Noemax.WebSockets.Messaging Namespace


TryGetOperation Method (MessageDispatcher)

TryGetOperation Method (MessageDispatcher)

Noemax.WebSockets.Messaging Namespace > MessageDispatcher Class : TryGetOperation Method
The object representing partially or fully deserialized inbound message as produced by IMessageSerializer.
The channel through which inbound message was received.
The variable to store the operation if found.
Finds the operation with a specified Action value.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function TryGetOperation( _
   ByVal graph As System.Object, _
   ByVal channel As WebSocketChannel, _
   ByRef operation As MessageOperationDescription _
) As System.Boolean
'Usage

Dim instance As MessageDispatcher
Dim graph As System.Object
Dim channel As WebSocketChannel
Dim operation As MessageOperationDescription
Dim value As System.Boolean

value = instance.TryGetOperation(graph, channel, operation)
public virtual System.bool TryGetOperation(
   System.object graph,
   WebSocketChannel channel,
   out MessageOperationDescription operation
)
public function TryGetOperation(
    graph: System.TObject;
    channel: WebSocketChannel;
   Out  operation: MessageOperationDescription
): System.Boolean; virtual;
public function TryGetOperation(
   graph : System.Object,
   channel : WebSocketChannel,
   operation : MessageOperationDescription
) : System.boolean;
public: virtual System.bool TryGetOperation(
   System.Object* graph,
   WebSocketChannel* channel,
   [PARAMFLAG::Out] MessageOperationDescription* operation
)
public:
virtual System.bool TryGetOperation(
   System.Object^ graph,
   WebSocketChannel^ channel,
   [Out] MessageOperationDescription^ operation
)

Parameters

graph
The object representing partially or fully deserialized inbound message as produced by IMessageSerializer.
channel
The channel through which inbound message was received.
operation
The variable to store the operation if found.

Return Value

True if operation was found; False otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageDispatcher Class
MessageDispatcher Members


RpcFaultException Class

RpcFaultException Class
Members

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class
The exception providing a RpcFaultException.FaultInfo.
Object Model
RpcFaultException Class
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Class RpcFaultException
   Inherits System.Exception
'Usage

Dim instance As RpcFaultException
public class RpcFaultException : System.Exception
public class RpcFaultException = class(System.Exception)
public class RpcFaultException extends System.Exception
public __gc class RpcFaultException : public System.Exception
public ref class RpcFaultException : public System.Exception
Inheritance Hierarchy

System.Object
System.Exception
Noemax.WebSockets.Messaging.RpcFaultException

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Members
Noemax.WebSockets.Messaging Namespace


WebSocketChannelExtensions Class Members

WebSocketChannelExtensions Class Members
Methods

Noemax.WebSockets.Messaging Namespace : WebSocketChannelExtensions Class

The following tables list the members exposed by WebSocketChannelExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage | Overloaded. Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestAsync | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestStream | Overloaded. Sends the request message and receives a stream as response.
static (Shared in Visual Basic) | RequestWithStream | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestWithStreamAsync | Overloaded. Sends the request and receives response from to the remote operation asynchronously.
static (Shared in Visual Basic) | SendMessage | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendMessageAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendOneWay | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendOneWayAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendWithStream | Overloaded. Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Top
See Also

Reference

WebSocketChannelExtensions Class
Noemax.WebSockets.Messaging Namespace


WebSocketChannelExtensions Class Methods

WebSocketChannelExtensions Class Methods

Noemax.WebSockets.Messaging Namespace : WebSocketChannelExtensions Class

For a list of all members of this type, see WebSocketChannelExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateStreamedMessage | Overloaded. Initiates outbound one-way message to remote operation by sending parameters and a stream of arbitrary length as the continuation of the message.
static (Shared in Visual Basic) | Request | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestAsync | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestStream | Overloaded. Sends the request message and receives a stream as response.
static (Shared in Visual Basic) | RequestWithStream | Overloaded. Sends the request and receives response from to the remote operation.
static (Shared in Visual Basic) | RequestWithStreamAsync | Overloaded. Sends the request and receives response from to the remote operation asynchronously.
static (Shared in Visual Basic) | SendMessage | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendMessageAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendOneWay | Overloaded. Sends the message with the specified parameters to the remote operation.
static (Shared in Visual Basic) | SendOneWayAsync | Overloaded. Sends the message with the specified parameter to the remote operation asynchronously.
static (Shared in Visual Basic) | SendWithStream | Overloaded. Sends outbound message with parameters and binary stream of arbitrary length as continuation of the message.
Top
See Also

Reference

WebSocketChannelExtensions Class
Noemax.WebSockets.Messaging Namespace


RequestAsync Method

RequestAsync Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : RequestAsync Method
Sends the request and receives response from to the remote operation.
Overload List
Overload | Description
RequestAsync<TResult>(WebSocketChannel,String,Object[]) | Sends the request and receives response from to the remote operation.
RequestAsync<TResult>(WebSocketChannel,String,TimeSpan,Object[]) | Sends the request and receives response from to the remote operation.
RequestAsync<TResult,TRequest>(WebSocketChannel,String,TRequest) | Sends the request and receives response from to the remote operation.
RequestAsync<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) | Sends the request and receives response from to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


RequestAsync<TResult>(WebSocketChannel,String,Object[]) Method

RequestAsync<TResult>(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestAsync Method : RequestAsync<TResult>(WebSocketChannel,String,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestAsync(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestAsync(Of TResult)(channel, action, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestAsync<TResult>(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public function RequestAsync(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestAsync<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestAsyncgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestAsync<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method

RequestAsync<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestAsync Method : RequestAsync<TResult>(WebSocketChannel,String,TimeSpan,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestAsync(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestAsync(Of TResult)(channel, action, timeout, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestAsync<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public function RequestAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestAsync<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestAsyncgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestAsync<TResult,TRequest>(WebSocketChannel,String,TRequest) Method

RequestAsync<TResult,TRequest>(WebSocketChannel,String,TRequest) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestAsync Method : RequestAsync<TResult,TRequest>(WebSocketChannel,String,TRequest) Method
The type of the response to receive from remote side.
The type of the request to send to remote side.
The channel through which request message will be sent.
The action associated to the remote operation.
The request object.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestAsync
    (Of TResult,TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal request As TRequest _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim request As TRequest
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestAsync(Of TResult, TRequest)(channel, action, request)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestAsync<TResult,TRequest>(
   WebSocketChannel channel,
   System.string action,
   TRequest request
)
public function RequestAsync(
    channel: WebSocketChannel;
    action: System.String;
    request: TRequest
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestAsync(
   channel : WebSocketChannel,
   action : System.String,
   request : TRequest
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestAsync<TResult,TRequest>(
   WebSocketChannel* channel,
   System.string* action,
   TRequest* request
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestAsyncgeneric<typename TResult>
generic<typename TRequest>
(
   WebSocketChannel^ channel,
   System.String^ action,
   TRequest^ request
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
request
The request object.

Type Parameters

TResult
The type of the response to receive from remote side.
TRequest
The type of the request to send to remote side.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestAsync<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method

RequestAsync<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestAsync Method : RequestAsync<TResult,TRequest>(WebSocketChannel,String,TimeSpan,TRequest) Method
The type of the response to receive from remote side.
The type of the request to send to remote side.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The request object.
Sends the request and receives response from to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestAsync
    (Of TResult,TRequest)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal request As TRequest _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim request As TRequest
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestAsync(Of TResult, TRequest)(channel, action, timeout, request)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestAsync<TResult,TRequest>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   TRequest request
)
public function RequestAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    request: TRequest
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   request : TRequest
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestAsync<TResult,TRequest>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   TRequest* request
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestAsyncgeneric<typename TResult>
generic<typename TRequest>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   TRequest^ request
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
request
The request object.

Type Parameters

TResult
The type of the response to receive from remote side.
TRequest
The type of the request to send to remote side.

Return Value

The instance of TResult received as response.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStreamAsync Method

RequestWithStreamAsync Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class : RequestWithStreamAsync Method
Sends the request and receives response from to the remote operation asynchronously.
Overload List
Overload | Description
RequestWithStreamAsync<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) | Sends the request and receives response from to the remote operation asynchronously.
RequestWithStreamAsync<TResult>(WebSocketChannel,String,Stream,Object[]) | Sends the request and receives response from to the remote operation asynchronously.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members


RequestWithStreamAsync<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

RequestWithStreamAsync<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStreamAsync Method : RequestWithStreamAsync<TResult>(WebSocketChannel,String,TimeSpan,Stream,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The period of time during which operation should be complete or timeout.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestWithStreamAsync(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim attachment As System.IO.Stream
Dim parameters() As System.Object
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestWithStreamAsync(Of TResult)(channel, action, timeout, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestWithStreamAsync<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public function RequestWithStreamAsync(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStreamAsync(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   attachment : System.IO.Stream,
   parameters : System.Object[]
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestWithStreamAsync<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestWithStreamAsyncgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which operation should be complete or timeout.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of System.Threading.Tasks.Task`1 that represents asynchronous operation.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


RequestWithStreamAsync<TResult>(WebSocketChannel,String,Stream,Object[]) Method

RequestWithStreamAsync<TResult>(WebSocketChannel,String,Stream,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > RequestWithStreamAsync Method : RequestWithStreamAsync<TResult>(WebSocketChannel,String,Stream,Object[]) Method
The type of the result to receive from the remote operation.
The channel through which request message will be sent.
The action associated to the remote operation.
The stream to send as attachment with request.
The parameters to send to the remote operation.
Sends the request and receives response from to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Function RequestWithStreamAsync(Of TResult)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal attachment As System.IO.Stream, _
   ByVal ParamArray parameters() As System.Object _
) As System.Threading.Tasks.Task(Of TResult)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim attachment As System.IO.Stream
Dim parameters() As System.Object
Dim value As System.Threading.Tasks.Task(Of TResult)

value = WebSocketChannelExtensions.RequestWithStreamAsync(Of TResult)(channel, action, attachment, parameters)
[System.Runtime.CompilerServices.Extension()]
public static System.Threading.Tasks.Task<TResult> RequestWithStreamAsync<TResult>(
   WebSocketChannel channel,
   System.string action,
   System.IO.Stream attachment,
   params System.object[] parameters
)
public function RequestWithStreamAsync(
    channel: WebSocketChannel;
    action: System.String;
    attachment: System.IO.Stream;
   params  parameters: System.TObjectarray of
): System.Threading.Tasks.Task; static;
System.Runtime.CompilerServices.ExtensionAttribute()
public static function RequestWithStreamAsync(
   channel : WebSocketChannel,
   action : System.String,
   attachment : System.IO.Stream,
   parameters : System.Object[]
) : System.Threading.Tasks.Task;
[System.Runtime.CompilerServices.Extension()]
public: static System.Threading.Tasks.Task<TResult*>* RequestWithStreamAsync<TResult>(
   WebSocketChannel* channel,
   System.string* action,
   System.IO.Stream* attachment,
   params System.Object*[]* parameters
)
[System.Runtime.CompilerServices.Extension()]
public:
static System.Threading.Tasks.Task<TResult^>^ RequestWithStreamAsyncgeneric<typename TResult>
(
   WebSocketChannel^ channel,
   System.String^ action,
   System.IO.Stream^ attachment,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which request message will be sent.
action
The action associated to the remote operation.
attachment
The stream to send as attachment with request.
parameters
The parameters to send to the remote operation.

Type Parameters

TResult
The type of the result to receive from the remote operation.

Return Value

The instance of System.Threading.Tasks.Task`1 that represents asynchronous operation.
Remarks
This methods sends request with specified parameters to remote operation along with the stream of arbitrary length. Remote operation is expected to accept the stream as final parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage(WebSocketChannel,String,TimeSpan,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The period of time during which the object should be sent or the operation would timeout.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal timeout As System.TimeSpan, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim timeout As System.TimeSpan
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessage(channel, action, timeout, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessage(
   WebSocketChannel channel,
   System.string action,
   System.TimeSpan timeout,
   params System.object[] parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
    timeout: System.TimeSpan;
   params  parameters: System.TObjectarray of
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   timeout : System.TimeSpan,
   parameters : System.Object[]
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessage(
   WebSocketChannel* channel,
   System.string* action,
   System.TimeSpan timeout,
   params System.Object*[]* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   System.TimeSpan timeout,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
timeout
The period of time during which the object should be sent or the operation would timeout.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessage(WebSocketChannel,String,Object[]) Method

SendMessage(WebSocketChannel,String,Object[]) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessage Method : SendMessage(WebSocketChannel,String,Object[]) Method
The channel through which the object will be sent.
The action associated to the remote operation.
The parameters to send to the remote operation.
Sends the message with the specified parameters to the remote operation.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute()>
<System.Runtime.CompilerServices.ExtensionAttribute()>
Public Overloads Shared Sub SendMessage( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal ParamArray parameters() As System.Object _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameters() As System.Object

WebSocketChannelExtensions.SendMessage(channel, action, parameters)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public static void SendMessage(
   WebSocketChannel channel,
   System.string action,
   params System.object[] parameters
)
public procedure SendMessage(
    channel: WebSocketChannel;
    action: System.String;
   params  parameters: System.TObjectarray of
); static;
System.ObsoleteAttribute()
System.Runtime.CompilerServices.ExtensionAttribute()
public static function SendMessage(
   channel : WebSocketChannel,
   action : System.String,
   parameters : System.Object[]
);
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public: static void SendMessage(
   WebSocketChannel* channel,
   System.string* action,
   params System.Object*[]* parameters
)
[System.Obsolete()]
[System.Runtime.CompilerServices.Extension()]
public:
static void SendMessage(
   WebSocketChannel^ channel,
   System.String^ action,
   ... System.array<Object^>^ parameters
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameters
The parameters to send to the remote operation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


SendMessageAsync<T>(WebSocketChannel,String,T) Method

SendMessageAsync<T>(WebSocketChannel,String,T) Method

Noemax.WebSockets.Messaging Namespace > WebSocketChannelExtensions Class > SendMessageAsync Method : SendMessageAsync<T>(WebSocketChannel,String,T) Method
The type of the object to send.
The channel through which the object will be sent.
The action associated to the remote operation.
The object to send.
Sends the message with the specified parameter to the remote operation asynchronously.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.CompilerServices.ExtensionAttribute()>
<System.ObsoleteAttribute()>
Public Overloads Shared Sub SendMessageAsync(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal action As System.String, _
   ByVal parameter As T _
)
'Usage

Dim channel As WebSocketChannel
Dim action As System.String
Dim parameter As T

WebSocketChannelExtensions.SendMessageAsync(Of T)(channel, action, parameter)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public static void SendMessageAsync<T>(
   WebSocketChannel channel,
   System.string action,
   T parameter
)
public procedure SendMessageAsync(
    channel: WebSocketChannel;
    action: System.String;
    parameter: T
); static;
System.Runtime.CompilerServices.ExtensionAttribute()
System.ObsoleteAttribute()
public static function SendMessageAsync(
   channel : WebSocketChannel,
   action : System.String,
   parameter : T
);
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public: static void SendMessageAsync<T>(
   WebSocketChannel* channel,
   System.string* action,
   T* parameter
)
[System.Runtime.CompilerServices.Extension()]
[System.Obsolete()]
public:
static void SendMessageAsyncgeneric<typename T>
(
   WebSocketChannel^ channel,
   System.String^ action,
   T^ parameter
)

Parameters

channel
The channel through which the object will be sent.
action
The action associated to the remote operation.
parameter
The object to send.

Type Parameters

T
The type of the object to send.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketChannelExtensions Class
WebSocketChannelExtensions Members
Overload List


ActionOperation Delegate

ActionOperation Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Delegate Sub ActionOperation()
'Usage

Dim instance As New ActionOperation(AddressOf HandlerMethod)
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate void ActionOperation()
public delegate ActionOperation();
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
System.ComponentModel.BrowsableAttribute()
public delegate ActionOperation()
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public: __gc __delegate void ActionOperation();
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
[System.ComponentModel.Browsable(false)]
public delegate void ActionOperation();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1 Delegate

ActionOperation1 Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation1 Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Sub ActionOperation1( _
   ByVal channel As WebSocketChannel _
)
'Usage

Dim instance As New ActionOperation1(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate void ActionOperation1(
   WebSocketChannel channel
)
public delegate ActionOperation1(
    channel: WebSocketChannel
);
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)
public delegate ActionOperation1(
   channel : WebSocketChannel
)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate void ActionOperation1(
   WebSocketChannel* channel
)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate void ActionOperation1(
   WebSocketChannel^ channel
)

Parameters

channel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1 Members
Noemax.WebSockets.Messaging Namespace


ActionOperation1<T> Delegate

ActionOperation1<T> Delegate

Noemax.WebSockets.Messaging Namespace : ActionOperation1<T> Delegate
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Delegate Sub ActionOperation1(Of T)( _
   ByVal channel As WebSocketChannel, _
   ByVal parameter As T _
)
'Usage

Dim instance As New ActionOperation1(Of T)(AddressOf HandlerMethod)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public delegate void ActionOperation1<T>(
   WebSocketChannel channel,
   T parameter
)
public delegate ActionOperation1(
    channel: WebSocketChannel;
    parameter: T
);
JScript does not support Generics.
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
public: __gc __delegate void ActionOperation1<T>(
   WebSocketChannel* channel,
   T* parameter
)
[System.ComponentModel.Browsable(false)]
[System.ComponentModel.EditorBrowsable(EditorBrowsableState.Never)]
generic<typename T>
public delegate void ActionOperation1(
   WebSocketChannel^ channel,
   T^ parameter
)

Parameters

channel
parameter

Type Parameters

T
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ActionOperation1<T> Members
Noemax.WebSockets.Messaging Namespace


Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets.Net4)

Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets.Net4)
Inheritance Hierarchy
Classes
 | Class | Description
Class | WebSocketChannelExtensionsPom | Provides Noemax.WebSockets.WebSocketChannel with extension methods for Plain Object Messaging.
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Bson.BsonObjectId
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter
See Also

Reference

Noemax.WebSockets.Net4 Assembly


BinaryConverter Class Properties

BinaryConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : BinaryConverter Class

For a list of all members of this type, see BinaryConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

BinaryConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


BsonObjectIdConverter Class Properties

BsonObjectIdConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : BsonObjectIdConverter Class

For a list of all members of this type, see BsonObjectIdConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

BsonObjectIdConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DataSetConverter Class Properties

DataSetConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : DataSetConverter Class

For a list of all members of this type, see DataSetConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DataSetConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DataTableConverter Class Properties

DataTableConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : DataTableConverter Class

For a list of all members of this type, see DataTableConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DataTableConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


DateTimeConverterBase Class Properties

DateTimeConverterBase Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : DateTimeConverterBase Class

For a list of all members of this type, see DateTimeConverterBase members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DateTimeConverterBase Class
Noemax.Newtonsoft.Json.Converters Namespace


DiscriminatedUnionConverter Class Properties

DiscriminatedUnionConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : DiscriminatedUnionConverter Class

For a list of all members of this type, see DiscriminatedUnionConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

DiscriminatedUnionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


EntityKeyMemberConverter Class Properties

EntityKeyMemberConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : EntityKeyMemberConverter Class

For a list of all members of this type, see EntityKeyMemberConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

EntityKeyMemberConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


JavaScriptDateTimeConverter Class Properties

JavaScriptDateTimeConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : JavaScriptDateTimeConverter Class

For a list of all members of this type, see JavaScriptDateTimeConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

JavaScriptDateTimeConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


KeyValuePairConverter Class Properties

KeyValuePairConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : KeyValuePairConverter Class

For a list of all members of this type, see KeyValuePairConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

KeyValuePairConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


RegexConverter Class Properties

RegexConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : RegexConverter Class

For a list of all members of this type, see RegexConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

RegexConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


WriteJson Method (RegexConverter)

WriteJson Method (RegexConverter)

Noemax.Newtonsoft.Json.Converters Namespace > RegexConverter Class : WriteJson Method
Writes the JSON representation of the object.
Overload List
Overload | Description
WriteJson | Writes the JSON representation of the object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RegexConverter Class
RegexConverter Members
Base Implementation in WriteJson


VersionConverter Class Properties

VersionConverter Class Properties

Noemax.Newtonsoft.Json.Converters Namespace : VersionConverter Class

For a list of all members of this type, see VersionConverter members.

Public Properties
 | Name | Description
Public Property | CanRead | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can read JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Public Property | CanWrite | Gets a value indicating whether this Noemax.Newtonsoft.Json.JsonConverter can write JSON. (Inherited from Noemax.Newtonsoft.Json.JsonConverter)
Top
See Also

Reference

VersionConverter Class
Noemax.Newtonsoft.Json.Converters Namespace


Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>
Noemax.Newtonsoft.Json.Converters.DataSetConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter
Noemax.Newtonsoft.Json.Converters.DiscriminatedUnionConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter
Noemax.Newtonsoft.Json.Converters.ExpandoObjectConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter
See Also

Reference

Noemax.WebSockets.Net4 Assembly


JsonArrayAttribute Class Methods

JsonArrayAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonArrayAttribute Class

For a list of all members of this type, see JsonArrayAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonArrayAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonArrayAttribute)

Equals Method (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonArrayAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


GetHashCode Method (JsonArrayAttribute)

GetHashCode Method (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonArrayAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


IsDefaultAttribute Method (JsonArrayAttribute)

IsDefaultAttribute Method (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonArrayAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


Match Method (JsonArrayAttribute)

Match Method (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonArrayAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


TypeId Property (JsonArrayAttribute)

TypeId Property (JsonArrayAttribute)

Noemax.Newtonsoft.Json Namespace > JsonArrayAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonArrayAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonArrayAttribute Class
JsonArrayAttribute Members


JsonConstructorAttribute Class Methods

JsonConstructorAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConstructorAttribute Class

For a list of all members of this type, see JsonConstructorAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConstructorAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonConstructorAttribute Class Properties

JsonConstructorAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonConstructorAttribute Class

For a list of all members of this type, see JsonConstructorAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConstructorAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonConstructorAttribute)

Equals Method (JsonConstructorAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonConstructorAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


GetHashCode Method (JsonConstructorAttribute)

GetHashCode Method (JsonConstructorAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonConstructorAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


IsDefaultAttribute Method (JsonConstructorAttribute)

IsDefaultAttribute Method (JsonConstructorAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonConstructorAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


Match Method (JsonConstructorAttribute)

Match Method (JsonConstructorAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonConstructorAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


TypeId Property (JsonConstructorAttribute)

TypeId Property (JsonConstructorAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConstructorAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonConstructorAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConstructorAttribute Class
JsonConstructorAttribute Members


JsonContainerAttribute Class Methods

JsonContainerAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonContainerAttribute Class

For a list of all members of this type, see JsonContainerAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonContainerAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonContainerAttribute)

Equals Method (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonContainerAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


GetHashCode Method (JsonContainerAttribute)

GetHashCode Method (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.int GetHashCode()
public function GetHashCode(): System.Integer; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


IsDefaultAttribute Method (JsonContainerAttribute)

IsDefaultAttribute Method (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public virtual System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean; virtual;
public function IsDefaultAttribute() : System.boolean;
public: virtual System.bool IsDefaultAttribute();
public:
virtual System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


Match Method (JsonContainerAttribute)

Match Method (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonContainerAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public virtual System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
public function Match(
   obj : System.Object
) : System.boolean;
public: virtual System.bool Match(
   System.Object* obj
)
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


TypeId Property (JsonContainerAttribute)

TypeId Property (JsonContainerAttribute)

Noemax.Newtonsoft.Json Namespace > JsonContainerAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonContainerAttribute
Dim value As System.Object

value = instance.TypeId
public virtual System.object TypeId {get;}
public read-only property TypeId: System.TObject; virtual;
public function get TypeId : System.Object
public: __property virtual System.Object* get_TypeId();
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonContainerAttribute Class
JsonContainerAttribute Members


JsonConverterAttribute Class Methods

JsonConverterAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConverterAttribute Class

For a list of all members of this type, see JsonConverterAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonConverterAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonConverterAttribute)

Equals Method (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonConverterAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


GetHashCode Method (JsonConverterAttribute)

GetHashCode Method (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonConverterAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


IsDefaultAttribute Method (JsonConverterAttribute)

IsDefaultAttribute Method (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonConverterAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


Match Method (JsonConverterAttribute)

Match Method (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonConverterAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


TypeId Property (JsonConverterAttribute)

TypeId Property (JsonConverterAttribute)

Noemax.Newtonsoft.Json Namespace > JsonConverterAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonConverterAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterAttribute Class
JsonConverterAttribute Members


JsonConverterCollection Class Methods

JsonConverterCollection Class Methods

Noemax.Newtonsoft.Json Namespace : JsonConverterCollection Class

For a list of all members of this type, see JsonConverterCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
Protected Methods
 | Name | Description
Protected Method | ClearItems | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | InsertItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | RemoveItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
See Also

Reference

JsonConverterCollection Class
Noemax.Newtonsoft.Json Namespace


JsonConverterCollection Class Properties

JsonConverterCollection Class Properties

Noemax.Newtonsoft.Json Namespace : JsonConverterCollection Class

For a list of all members of this type, see JsonConverterCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
Protected Properties
 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<JsonConverter>)
Top
See Also

Reference

JsonConverterCollection Class
Noemax.Newtonsoft.Json Namespace


Add Method (JsonConverterCollection)

Add Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Add Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As JsonConverter _
)
'Usage

Dim instance As JsonConverterCollection
Dim item As JsonConverter

instance.Add(item)
[__DynamicallyInvokable()]
public void Add(
   JsonConverter item
)
public procedure Add(
    item: JsonConverter
);
__DynamicallyInvokableAttribute()
public function Add(
   item : JsonConverter
);
[__DynamicallyInvokable()]
public: void Add(
   JsonConverter* item
)
[__DynamicallyInvokable()]
public:
void Add(
   JsonConverter^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Clear Method (JsonConverterCollection)

Clear Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Sub Clear()
'Usage

Dim instance As JsonConverterCollection

instance.Clear()
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public void Clear()
public procedure Clear();
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Clear();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public: void Clear();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


ClearItems Method (JsonConverterCollection)

ClearItems Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : ClearItems Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Protected Overridable Sub ClearItems()
'Usage

Dim instance As JsonConverterCollection

instance.ClearItems()
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
protected virtual void ClearItems()
protected procedure ClearItems(); virtual;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
protected function ClearItems();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
protected: virtual void ClearItems();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
protected:
virtual void ClearItems();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Contains Method (JsonConverterCollection)

Contains Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Contains Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As JsonConverter _
) As System.Boolean
'Usage

Dim instance As JsonConverterCollection
Dim item As JsonConverter
Dim value As System.Boolean

value = instance.Contains(item)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public System.bool Contains(
   JsonConverter item
)
public function Contains(
    item: JsonConverter
): System.Boolean;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : JsonConverter
) : System.boolean;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public: System.bool Contains(
   JsonConverter* item
)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public:
System.bool Contains(
   JsonConverter^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


CopyTo Method (JsonConverterCollection)

CopyTo Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As JsonConverter, _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonConverterCollection
Dim array() As JsonConverter
Dim index As System.Integer

instance.CopyTo(array, index)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   JsonConverter[] array,
   System.int index
)
public procedure CopyTo(
    array: JsonConverterarray of;
    index: System.Integer
);
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : JsonConverter[],
   index : System.int
);
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   JsonConverter*[]* array,
   System.int index
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   array<JsonConverter^>^ array,
   System.int index
)

Parameters

array
index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Count Property (JsonConverterCollection)

Count Property (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As JsonConverterCollection
Dim value As System.Integer

value = instance.Count
[__DynamicallyInvokable()]
public System.int Count {get;}
public read-only property Count: System.Integer;
__DynamicallyInvokableAttribute()
public function get Count : System.int
[__DynamicallyInvokable()]
public: __property System.int get_Count();
[__DynamicallyInvokable()]
public:
property System.int Count {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


GetEnumerator Method (JsonConverterCollection)

GetEnumerator Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : GetEnumerator Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of JsonConverter)
'Usage

Dim instance As JsonConverterCollection
Dim value As System.Collections.Generic.IEnumerator(Of JsonConverter)

value = instance.GetEnumerator()
[__DynamicallyInvokable()]
public System.Collections.Generic.IEnumerator<JsonConverter> GetEnumerator()
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
[__DynamicallyInvokable()]
public: System.Collections.Generic.IEnumerator<JsonConverter*>* GetEnumerator();
[__DynamicallyInvokable()]
public:
System.Collections.Generic.IEnumerator<JsonConverter^>^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


IndexOf Method (JsonConverterCollection)

IndexOf Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function IndexOf( _
   ByVal item As JsonConverter _
) As System.Integer
'Usage

Dim instance As JsonConverterCollection
Dim item As JsonConverter
Dim value As System.Integer

value = instance.IndexOf(item)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public System.int IndexOf(
   JsonConverter item
)
public function IndexOf(
    item: JsonConverter
): System.Integer;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function IndexOf(
   item : JsonConverter
) : System.int;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public: System.int IndexOf(
   JsonConverter* item
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public:
System.int IndexOf(
   JsonConverter^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Insert Method (JsonConverterCollection)

Insert Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Insert Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As JsonConverter _
)
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer
Dim item As JsonConverter

instance.Insert(index, item)
[__DynamicallyInvokable()]
public void Insert(
   System.int index,
   JsonConverter item
)
public procedure Insert(
    index: System.Integer;
    item: JsonConverter
);
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : JsonConverter
);
[__DynamicallyInvokable()]
public: void Insert(
   System.int index,
   JsonConverter* item
)
[__DynamicallyInvokable()]
public:
void Insert(
   System.int index,
   JsonConverter^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


InsertItem Method (JsonConverterCollection)

InsertItem Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : InsertItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As JsonConverter _
)
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer
Dim item As JsonConverter

instance.InsertItem(index, item)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected virtual void InsertItem(
   System.int index,
   JsonConverter item
)
protected procedure InsertItem(
    index: System.Integer;
    item: JsonConverter
); virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function InsertItem(
   index : System.int,
   item : JsonConverter
);
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected: virtual void InsertItem(
   System.int index,
   JsonConverter* item
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected:
virtual void InsertItem(
   System.int index,
   JsonConverter^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Item Property (JsonConverterCollection)

Item Property (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Item Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As JsonConverter
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer
Dim value As JsonConverter

instance.Item(index) = value

value = instance.Item(index)
[__DynamicallyInvokable()]
public JsonConverter this[
   System.int index
]; {get; set;}
public  this: : JsonConverter;[
    index: System.Integer
]; read-write
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : JsonConverter
[__DynamicallyInvokable()]
public: __property JsonConverter* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   JsonConverter* value
;
[__DynamicallyInvokable()]
public:
property JsonConverter^ default [int] {
   JsonConverter^ get(System.int index);
   void set (System.int index, JsonConverter^ value);
}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Items Property (JsonConverterCollection)

Items Property (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Items Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of JsonConverter)
'Usage

Dim instance As JsonConverterCollection
Dim value As System.Collections.Generic.IList(Of JsonConverter)

value = instance.Items
[__DynamicallyInvokable()]
protected System.Collections.Generic.IList<JsonConverter> Items {get;}
protected read-only property Items: System.Collections.Generic.IList;
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
[__DynamicallyInvokable()]
protected: __property System.Collections.Generic.IList<JsonConverter*>* get_Items();
[__DynamicallyInvokable()]
protected:
property System.Collections.Generic.IList<JsonConverter^>^ Items {
   System.Collections.Generic.IList<JsonConverter^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


Remove Method (JsonConverterCollection)

Remove Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : Remove Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As JsonConverter _
) As System.Boolean
'Usage

Dim instance As JsonConverterCollection
Dim item As JsonConverter
Dim value As System.Boolean

value = instance.Remove(item)
[__DynamicallyInvokable()]
public System.bool Remove(
   JsonConverter item
)
public function Remove(
    item: JsonConverter
): System.Boolean;
__DynamicallyInvokableAttribute()
public function Remove(
   item : JsonConverter
) : System.boolean;
[__DynamicallyInvokable()]
public: System.bool Remove(
   JsonConverter* item
)
[__DynamicallyInvokable()]
public:
System.bool Remove(
   JsonConverter^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


RemoveAt Method (JsonConverterCollection)

RemoveAt Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer

instance.RemoveAt(index)
[__DynamicallyInvokable()]
public void RemoveAt(
   System.int index
)
public procedure RemoveAt(
    index: System.Integer
);
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
[__DynamicallyInvokable()]
public: void RemoveAt(
   System.int index
)
[__DynamicallyInvokable()]
public:
void RemoveAt(
   System.int index
)

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


RemoveItem Method (JsonConverterCollection)

RemoveItem Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : RemoveItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer

instance.RemoveItem(index)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected virtual void RemoveItem(
   System.int index
)
protected procedure RemoveItem(
    index: System.Integer
); virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function RemoveItem(
   index : System.int
);
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected: virtual void RemoveItem(
   System.int index
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


SetItem Method (JsonConverterCollection)

SetItem Method (JsonConverterCollection)

Noemax.Newtonsoft.Json Namespace > JsonConverterCollection Class : SetItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As JsonConverter _
)
'Usage

Dim instance As JsonConverterCollection
Dim index As System.Integer
Dim item As JsonConverter

instance.SetItem(index, item)
[__DynamicallyInvokable()]
protected virtual void SetItem(
   System.int index,
   JsonConverter item
)
protected procedure SetItem(
    index: System.Integer;
    item: JsonConverter
); virtual;
__DynamicallyInvokableAttribute()
protected function SetItem(
   index : System.int,
   item : JsonConverter
);
[__DynamicallyInvokable()]
protected: virtual void SetItem(
   System.int index,
   JsonConverter* item
)
[__DynamicallyInvokable()]
protected:
virtual void SetItem(
   System.int index,
   JsonConverter^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonConverterCollection Class
JsonConverterCollection Members


JsonDictionaryAttribute Class Methods

JsonDictionaryAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonDictionaryAttribute Class

For a list of all members of this type, see JsonDictionaryAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonDictionaryAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonDictionaryAttribute Class Properties

JsonDictionaryAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonDictionaryAttribute Class

For a list of all members of this type, see JsonDictionaryAttribute members.

Public Properties
 | Name | Description
Public Property | Description | Gets or sets the description. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Id | Gets or sets the id. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | IsReference | Gets or sets a value that indicates whether to preserve object references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemConverterType | Gets the collection's items converter. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemIsReference | Gets or sets a value that indicates whether to preserve collection's items references. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemReferenceLoopHandling | Gets or sets the reference loop handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | ItemTypeNameHandling | Gets or sets the type name handling used when serializing the collection's items. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | Title | Gets or sets the title. (Inherited from Noemax.Newtonsoft.Json.JsonContainerAttribute)
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonDictionaryAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonDictionaryAttribute)

Equals Method (JsonDictionaryAttribute)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonDictionaryAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


GetHashCode Method (JsonDictionaryAttribute)

GetHashCode Method (JsonDictionaryAttribute)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonDictionaryAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


IsDefaultAttribute Method (JsonDictionaryAttribute)

IsDefaultAttribute Method (JsonDictionaryAttribute)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonDictionaryAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


Match Method (JsonDictionaryAttribute)

Match Method (JsonDictionaryAttribute)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonDictionaryAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


TypeId Property (JsonDictionaryAttribute)

TypeId Property (JsonDictionaryAttribute)

Noemax.Newtonsoft.Json Namespace > JsonDictionaryAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonDictionaryAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonDictionaryAttribute Class
JsonDictionaryAttribute Members


JsonException Class Events

JsonException Class Events

Noemax.Newtonsoft.Json Namespace : JsonException Class

For a list of all members of this type, see JsonException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonException Class
Noemax.Newtonsoft.Json Namespace


JsonException Class Methods

JsonException Class Methods

Noemax.Newtonsoft.Json Namespace : JsonException Class

For a list of all members of this type, see JsonException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

JsonException Class
Noemax.Newtonsoft.Json Namespace


JsonException Class Properties

JsonException Class Properties

Noemax.Newtonsoft.Json Namespace : JsonException Class

For a list of all members of this type, see JsonException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

JsonException Class
Noemax.Newtonsoft.Json Namespace


Data Property (JsonException)

Data Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As JsonException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


GetBaseException Method (JsonException)

GetBaseException Method (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As JsonException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


GetObjectData Method (JsonException)

GetObjectData Method (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As JsonException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


GetType Method (JsonException)

GetType Method (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


GetType() Method

GetType() Method

Noemax.Newtonsoft.Json Namespace > JsonException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As JsonException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


HelpLink Property (JsonException)

HelpLink Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As JsonException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


HResult Property (JsonException)

HResult Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As JsonException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


InnerException Property (JsonException)

InnerException Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As JsonException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


Message Property (JsonException)

Message Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As JsonException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


SerializeObjectState Event (JsonException)

SerializeObjectState Event (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As JsonException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


Source Property (JsonException)

Source Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As JsonException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


StackTrace Property (JsonException)

StackTrace Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As JsonException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


TargetSite Property (JsonException)

TargetSite Property (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As JsonException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


ToString Method (JsonException)

ToString Method (JsonException)

Noemax.Newtonsoft.Json Namespace > JsonException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As JsonException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonException Class
JsonException Members


JsonExtensionDataAttribute Class Methods

JsonExtensionDataAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonExtensionDataAttribute Class

For a list of all members of this type, see JsonExtensionDataAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonExtensionDataAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonExtensionDataAttribute)

Equals Method (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonExtensionDataAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


GetHashCode Method (JsonExtensionDataAttribute)

GetHashCode Method (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonExtensionDataAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.int GetHashCode()
public function GetHashCode(): System.Integer; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


IsDefaultAttribute Method (JsonExtensionDataAttribute)

IsDefaultAttribute Method (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonExtensionDataAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public virtual System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean; virtual;
public function IsDefaultAttribute() : System.boolean;
public: virtual System.bool IsDefaultAttribute();
public:
virtual System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


Match Method (JsonExtensionDataAttribute)

Match Method (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonExtensionDataAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public virtual System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
public function Match(
   obj : System.Object
) : System.boolean;
public: virtual System.bool Match(
   System.Object* obj
)
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


TypeId Property (JsonExtensionDataAttribute)

TypeId Property (JsonExtensionDataAttribute)

Noemax.Newtonsoft.Json Namespace > JsonExtensionDataAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonExtensionDataAttribute
Dim value As System.Object

value = instance.TypeId
public virtual System.object TypeId {get;}
public read-only property TypeId: System.TObject; virtual;
public function get TypeId : System.Object
public: __property virtual System.Object* get_TypeId();
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonExtensionDataAttribute Class
JsonExtensionDataAttribute Members


JsonIgnoreAttribute Class Methods

JsonIgnoreAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonIgnoreAttribute Class

For a list of all members of this type, see JsonIgnoreAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonIgnoreAttribute Class
Noemax.Newtonsoft.Json Namespace


JsonIgnoreAttribute Class Properties

JsonIgnoreAttribute Class Properties

Noemax.Newtonsoft.Json Namespace : JsonIgnoreAttribute Class

For a list of all members of this type, see JsonIgnoreAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

JsonIgnoreAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonIgnoreAttribute)

Equals Method (JsonIgnoreAttribute)

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonIgnoreAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


GetHashCode Method (JsonIgnoreAttribute)

GetHashCode Method (JsonIgnoreAttribute)

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonIgnoreAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


IsDefaultAttribute Method (JsonIgnoreAttribute)

IsDefaultAttribute Method (JsonIgnoreAttribute)

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonIgnoreAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


Match Method (JsonIgnoreAttribute)

Match Method (JsonIgnoreAttribute)

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonIgnoreAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


TypeId Property (JsonIgnoreAttribute)

TypeId Property (JsonIgnoreAttribute)

Noemax.Newtonsoft.Json Namespace > JsonIgnoreAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonIgnoreAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonIgnoreAttribute Class
JsonIgnoreAttribute Members


JsonObjectAttribute Class Methods

JsonObjectAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonObjectAttribute Class

For a list of all members of this type, see JsonObjectAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonObjectAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonObjectAttribute)

Equals Method (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonObjectAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


GetHashCode Method (JsonObjectAttribute)

GetHashCode Method (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonObjectAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


IsDefaultAttribute Method (JsonObjectAttribute)

IsDefaultAttribute Method (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonObjectAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


Match Method (JsonObjectAttribute)

Match Method (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonObjectAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


TypeId Property (JsonObjectAttribute)

TypeId Property (JsonObjectAttribute)

Noemax.Newtonsoft.Json Namespace > JsonObjectAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonObjectAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonObjectAttribute Class
JsonObjectAttribute Members


JsonPropertyAttribute Class Methods

JsonPropertyAttribute Class Methods

Noemax.Newtonsoft.Json Namespace : JsonPropertyAttribute Class

For a list of all members of this type, see JsonPropertyAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

JsonPropertyAttribute Class
Noemax.Newtonsoft.Json Namespace


Equals Method (JsonPropertyAttribute)

Equals Method (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonPropertyAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


GetHashCode Method (JsonPropertyAttribute)

GetHashCode Method (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


IsDefaultAttribute Method (JsonPropertyAttribute)

IsDefaultAttribute Method (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


Match Method (JsonPropertyAttribute)

Match Method (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JsonPropertyAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


TypeId Property (JsonPropertyAttribute)

TypeId Property (JsonPropertyAttribute)

Noemax.Newtonsoft.Json Namespace > JsonPropertyAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As JsonPropertyAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyAttribute Class
JsonPropertyAttribute Members


JsonReaderException Class Events

JsonReaderException Class Events

Noemax.Newtonsoft.Json Namespace : JsonReaderException Class

For a list of all members of this type, see JsonReaderException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonReaderException Class
Noemax.Newtonsoft.Json Namespace


JsonReaderException Class Methods

JsonReaderException Class Methods

Noemax.Newtonsoft.Json Namespace : JsonReaderException Class

For a list of all members of this type, see JsonReaderException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

JsonReaderException Class
Noemax.Newtonsoft.Json Namespace


Data Property (JsonReaderException)

Data Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As JsonReaderException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


GetBaseException Method (JsonReaderException)

GetBaseException Method (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As JsonReaderException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


GetObjectData Method (JsonReaderException)

GetObjectData Method (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As JsonReaderException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


GetType Method (JsonReaderException)

GetType Method (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


GetType() Method

GetType() Method

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As JsonReaderException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


HelpLink Property (JsonReaderException)

HelpLink Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


HResult Property (JsonReaderException)

HResult Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As JsonReaderException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


InnerException Property (JsonReaderException)

InnerException Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As JsonReaderException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


Message Property (JsonReaderException)

Message Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


SerializeObjectState Event (JsonReaderException)

SerializeObjectState Event (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As JsonReaderException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


Source Property (JsonReaderException)

Source Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


StackTrace Property (JsonReaderException)

StackTrace Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


TargetSite Property (JsonReaderException)

TargetSite Property (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As JsonReaderException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


ToString Method (JsonReaderException)

ToString Method (JsonReaderException)

Noemax.Newtonsoft.Json Namespace > JsonReaderException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As JsonReaderException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonReaderException Class
JsonReaderException Members


JsonSerializationException Class Events

JsonSerializationException Class Events

Noemax.Newtonsoft.Json Namespace : JsonSerializationException Class

For a list of all members of this type, see JsonSerializationException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonSerializationException Class
Noemax.Newtonsoft.Json Namespace


JsonSerializationException Class Methods

JsonSerializationException Class Methods

Noemax.Newtonsoft.Json Namespace : JsonSerializationException Class

For a list of all members of this type, see JsonSerializationException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

JsonSerializationException Class
Noemax.Newtonsoft.Json Namespace


JsonSerializationException Class Properties

JsonSerializationException Class Properties

Noemax.Newtonsoft.Json Namespace : JsonSerializationException Class

For a list of all members of this type, see JsonSerializationException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

JsonSerializationException Class
Noemax.Newtonsoft.Json Namespace


Data Property (JsonSerializationException)

Data Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As JsonSerializationException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


GetBaseException Method (JsonSerializationException)

GetBaseException Method (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As JsonSerializationException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


GetObjectData Method (JsonSerializationException)

GetObjectData Method (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As JsonSerializationException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


GetType Method (JsonSerializationException)

GetType Method (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


GetType() Method

GetType() Method

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As JsonSerializationException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


HelpLink Property (JsonSerializationException)

HelpLink Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As JsonSerializationException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


HResult Property (JsonSerializationException)

HResult Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As JsonSerializationException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


InnerException Property (JsonSerializationException)

InnerException Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As JsonSerializationException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


Message Property (JsonSerializationException)

Message Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As JsonSerializationException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


SerializeObjectState Event (JsonSerializationException)

SerializeObjectState Event (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As JsonSerializationException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


Source Property (JsonSerializationException)

Source Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As JsonSerializationException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


StackTrace Property (JsonSerializationException)

StackTrace Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As JsonSerializationException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


TargetSite Property (JsonSerializationException)

TargetSite Property (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As JsonSerializationException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


ToString Method (JsonSerializationException)

ToString Method (JsonSerializationException)

Noemax.Newtonsoft.Json Namespace > JsonSerializationException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As JsonSerializationException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSerializationException Class
JsonSerializationException Members


JsonWriterException Class Events

JsonWriterException Class Events

Noemax.Newtonsoft.Json Namespace : JsonWriterException Class

For a list of all members of this type, see JsonWriterException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonWriterException Class
Noemax.Newtonsoft.Json Namespace


JsonWriterException Class Methods

JsonWriterException Class Methods

Noemax.Newtonsoft.Json Namespace : JsonWriterException Class

For a list of all members of this type, see JsonWriterException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

JsonWriterException Class
Noemax.Newtonsoft.Json Namespace


Data Property (JsonWriterException)

Data Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As JsonWriterException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


GetBaseException Method (JsonWriterException)

GetBaseException Method (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As JsonWriterException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


GetObjectData Method (JsonWriterException)

GetObjectData Method (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As JsonWriterException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


GetType Method (JsonWriterException)

GetType Method (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


GetType() Method

GetType() Method

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As JsonWriterException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


HelpLink Property (JsonWriterException)

HelpLink Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


HResult Property (JsonWriterException)

HResult Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As JsonWriterException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


InnerException Property (JsonWriterException)

InnerException Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As JsonWriterException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


Message Property (JsonWriterException)

Message Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


SerializeObjectState Event (JsonWriterException)

SerializeObjectState Event (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As JsonWriterException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


Source Property (JsonWriterException)

Source Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


StackTrace Property (JsonWriterException)

StackTrace Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


TargetSite Property (JsonWriterException)

TargetSite Property (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As JsonWriterException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


ToString Method (JsonWriterException)

ToString Method (JsonWriterException)

Noemax.Newtonsoft.Json Namespace > JsonWriterException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As JsonWriterException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonWriterException Class
JsonWriterException Members


JArray Class Events

JArray Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

For a list of all members of this type, see JArray members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Class Events

JConstructor Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

For a list of all members of this type, see JConstructor members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Class Events

JProperty Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

For a list of all members of this type, see JProperty members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


AddValueChanged Method (JPropertyDescriptor)

AddValueChanged Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : AddValueChanged Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub AddValueChanged( _
   ByVal component As System.Object, _
   ByVal handler As System.EventHandler _
)
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim handler As System.EventHandler

instance.AddValueChanged(component, handler)
public virtual void AddValueChanged(
   System.object component,
   System.EventHandler handler
)
public procedure AddValueChanged(
    component: System.TObject;
    handler: System.EventHandler
); virtual;
public function AddValueChanged(
   component : System.Object,
   handler : System.EventHandler
);
public: virtual void AddValueChanged(
   System.Object* component,
   System.EventHandler* handler
)
public:
virtual void AddValueChanged(
   System.Object^ component,
   System.EventHandler^ handler
)

Parameters

component
handler
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


AttributeArray Property (JPropertyDescriptor)

AttributeArray Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : AttributeArray Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Property AttributeArray As System.Attribute()
'Usage

Dim instance As JPropertyDescriptor
Dim value() As System.Attribute

instance.AttributeArray = value

value = instance.AttributeArray
protected virtual System.Attribute[] AttributeArray {get; set;}
protected read-write property AttributeArray: System.array of Attribute; virtual;
protected function get,set AttributeArray : System.Attribute[]
protected: __property virtual System.Attribute*[]* get_AttributeArray();
protected: __property virtual void set_AttributeArray(
   System.Attribute*[]* value
);
protected:
virtual property System.array<Attribute^>^ AttributeArray {
   System.array<Attribute^>^ get();
   void set (    System.array<Attribute^>^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Attributes Property (JPropertyDescriptor)

Attributes Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Attributes Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Attributes As System.ComponentModel.AttributeCollection
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.ComponentModel.AttributeCollection

value = instance.Attributes
public virtual System.ComponentModel.AttributeCollection Attributes {get;}
public read-only property Attributes: System.ComponentModel.AttributeCollection; virtual;
public function get Attributes : System.ComponentModel.AttributeCollection
public: __property virtual System.ComponentModel.AttributeCollection* get_Attributes();
public:
virtual property System.ComponentModel.AttributeCollection^ Attributes {
   System.ComponentModel.AttributeCollection^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Category Property (JPropertyDescriptor)

Category Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Category Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Category As System.String
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.String

value = instance.Category
public virtual System.string Category {get;}
public read-only property Category: System.String; virtual;
public function get Category : System.String
public: __property virtual System.string* get_Category();
public:
virtual property System.String^ Category {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Converter Property (JPropertyDescriptor)

Converter Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Converter Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Converter As System.ComponentModel.TypeConverter
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.ComponentModel.TypeConverter

value = instance.Converter
public virtual System.ComponentModel.TypeConverter Converter {get;}
public read-only property Converter: System.ComponentModel.TypeConverter; virtual;
public function get Converter : System.ComponentModel.TypeConverter
public: __property virtual System.ComponentModel.TypeConverter* get_Converter();
public:
virtual property System.ComponentModel.TypeConverter^ Converter {
   System.ComponentModel.TypeConverter^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


CreateAttributeCollection Method (JPropertyDescriptor)

CreateAttributeCollection Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : CreateAttributeCollection Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function CreateAttributeCollection() As System.ComponentModel.AttributeCollection
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.ComponentModel.AttributeCollection

value = instance.CreateAttributeCollection()
protected virtual System.ComponentModel.AttributeCollection CreateAttributeCollection()
protected function CreateAttributeCollection(): System.ComponentModel.AttributeCollection; virtual;
protected function CreateAttributeCollection() : System.ComponentModel.AttributeCollection;
protected: virtual System.ComponentModel.AttributeCollection* CreateAttributeCollection();
protected:
virtual System.ComponentModel.AttributeCollection^ CreateAttributeCollection();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


CreateInstance Method (JPropertyDescriptor)

CreateInstance Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : CreateInstance Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function CreateInstance( _
   ByVal type As System.Type _
) As System.Object
'Usage

Dim instance As JPropertyDescriptor
Dim type As System.Type
Dim value As System.Object

value = instance.CreateInstance(type)
protected System.object CreateInstance(
   System.Type type
)
protected function CreateInstance(
    type: System.Type
): System.TObject;
protected function CreateInstance(
   type : System.Type
) : System.Object;
protected: System.Object* CreateInstance(
   System.Type* type
)
protected:
System.Object^ CreateInstance(
   System.Type^ type
)

Parameters

type
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Description Property (JPropertyDescriptor)

Description Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Description Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Description As System.String
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.String

value = instance.Description
public virtual System.string Description {get;}
public read-only property Description: System.String; virtual;
public function get Description : System.String
public: __property virtual System.string* get_Description();
public:
virtual property System.String^ Description {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


DesignTimeOnly Property (JPropertyDescriptor)

DesignTimeOnly Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : DesignTimeOnly Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property DesignTimeOnly As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Boolean

value = instance.DesignTimeOnly
public virtual System.bool DesignTimeOnly {get;}
public read-only property DesignTimeOnly: System.Boolean; virtual;
public function get DesignTimeOnly : System.boolean
public: __property virtual System.bool get_DesignTimeOnly();
public:
virtual property System.bool DesignTimeOnly {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


DisplayName Property (JPropertyDescriptor)

DisplayName Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : DisplayName Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property DisplayName As System.String
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.String

value = instance.DisplayName
public virtual System.string DisplayName {get;}
public read-only property DisplayName: System.String; virtual;
public function get DisplayName : System.String
public: __property virtual System.string* get_DisplayName();
public:
virtual property System.String^ DisplayName {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Equals Method (JPropertyDescriptor)

Equals Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
public virtual System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
public function Equals(
   obj : System.Object
) : System.boolean;
public: virtual System.bool Equals(
   System.Object* obj
)
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


FillAttributes Method (JPropertyDescriptor)

FillAttributes Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : FillAttributes Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub FillAttributes( _
   ByVal attributeList As System.Collections.IList _
)
'Usage

Dim instance As JPropertyDescriptor
Dim attributeList As System.Collections.IList

instance.FillAttributes(attributeList)
protected virtual void FillAttributes(
   System.Collections.IList attributeList
)
protected procedure FillAttributes(
    attributeList: System.Collections.IList
); virtual;
protected function FillAttributes(
   attributeList : System.Collections.IList
);
protected: virtual void FillAttributes(
   System.Collections.IList* attributeList
)
protected:
virtual void FillAttributes(
   System.Collections.IList^ attributeList
)

Parameters

attributeList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


GetChildProperties Method (JPropertyDescriptor)

GetChildProperties Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetChildProperties Method
Overload List
Overload | Description
GetChildProperties() | (Inherited from System.ComponentModel.PropertyDescriptor)
GetChildProperties(Attribute[]) | (Inherited from System.ComponentModel.PropertyDescriptor)
GetChildProperties(Object) | (Inherited from System.ComponentModel.PropertyDescriptor)
GetChildProperties(Object,Attribute[]) | (Inherited from System.ComponentModel.PropertyDescriptor)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


GetChildProperties() Method

GetChildProperties() Method

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class > GetChildProperties Method : GetChildProperties() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildProperties() As System.ComponentModel.PropertyDescriptorCollection
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetChildProperties()
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public System.ComponentModel.PropertyDescriptorCollection GetChildProperties()
public function GetChildProperties(): System.ComponentModel.PropertyDescriptorCollection;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildProperties() : System.ComponentModel.PropertyDescriptorCollection;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: System.ComponentModel.PropertyDescriptorCollection* GetChildProperties();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.ComponentModel.PropertyDescriptorCollection^ GetChildProperties();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Overload List


GetChildProperties(Attribute[]) Method

GetChildProperties(Attribute[]) Method

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class > GetChildProperties Method : GetChildProperties(Attribute[]) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildProperties( _
   ByVal filter() As System.Attribute _
) As System.ComponentModel.PropertyDescriptorCollection
'Usage

Dim instance As JPropertyDescriptor
Dim filter() As System.Attribute
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetChildProperties(filter)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public System.ComponentModel.PropertyDescriptorCollection GetChildProperties(
   System.Attribute[] filter
)
public function GetChildProperties(
    filter: System.Attributearray of
): System.ComponentModel.PropertyDescriptorCollection;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildProperties(
   filter : System.Attribute[]
) : System.ComponentModel.PropertyDescriptorCollection;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: System.ComponentModel.PropertyDescriptorCollection* GetChildProperties(
   System.Attribute*[]* filter
)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.ComponentModel.PropertyDescriptorCollection^ GetChildProperties(
   System.array<Attribute^>^ filter
)

Parameters

filter
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Overload List


GetChildProperties(Object) Method

GetChildProperties(Object) Method

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class > GetChildProperties Method : GetChildProperties(Object) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildProperties( _
   ByVal instance As System.Object _
) As System.ComponentModel.PropertyDescriptorCollection
'Usage

Dim instance As JPropertyDescriptor
Dim instance As System.Object
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetChildProperties(instance)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public System.ComponentModel.PropertyDescriptorCollection GetChildProperties(
   System.object instance
)
public function GetChildProperties(
    instance: System.TObject
): System.ComponentModel.PropertyDescriptorCollection;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildProperties(
   instance : System.Object
) : System.ComponentModel.PropertyDescriptorCollection;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: System.ComponentModel.PropertyDescriptorCollection* GetChildProperties(
   System.Object* instance
)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.ComponentModel.PropertyDescriptorCollection^ GetChildProperties(
   System.Object^ instance
)

Parameters

instance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Overload List


GetChildProperties(Object,Attribute[]) Method

GetChildProperties(Object,Attribute[]) Method

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class > GetChildProperties Method : GetChildProperties(Object,Attribute[]) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overloads Overridable Function GetChildProperties( _
   ByVal instance As System.Object, _
   ByVal filter() As System.Attribute _
) As System.ComponentModel.PropertyDescriptorCollection
'Usage

Dim instance As JPropertyDescriptor
Dim instance As System.Object
Dim filter() As System.Attribute
Dim value As System.ComponentModel.PropertyDescriptorCollection

value = instance.GetChildProperties(instance, filter)
public virtual System.ComponentModel.PropertyDescriptorCollection GetChildProperties(
   System.object instance,
   System.Attribute[] filter
)
public function GetChildProperties(
    instance: System.TObject;
    filter: System.Attributearray of
): System.ComponentModel.PropertyDescriptorCollection; virtual;
public function GetChildProperties(
   instance : System.Object,
   filter : System.Attribute[]
) : System.ComponentModel.PropertyDescriptorCollection;
public: virtual System.ComponentModel.PropertyDescriptorCollection* GetChildProperties(
   System.Object* instance,
   System.Attribute*[]* filter
)
public:
virtual System.ComponentModel.PropertyDescriptorCollection^ GetChildProperties(
   System.Object^ instance,
   System.array<Attribute^>^ filter
)

Parameters

instance
filter
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members
Overload List


GetEditor Method (JPropertyDescriptor)

GetEditor Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetEditor Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetEditor( _
   ByVal editorBaseType As System.Type _
) As System.Object
'Usage

Dim instance As JPropertyDescriptor
Dim editorBaseType As System.Type
Dim value As System.Object

value = instance.GetEditor(editorBaseType)
public virtual System.object GetEditor(
   System.Type editorBaseType
)
public function GetEditor(
    editorBaseType: System.Type
): System.TObject; virtual;
public function GetEditor(
   editorBaseType : System.Type
) : System.Object;
public: virtual System.Object* GetEditor(
   System.Type* editorBaseType
)
public:
virtual System.Object^ GetEditor(
   System.Type^ editorBaseType
)

Parameters

editorBaseType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


GetHashCode Method (JPropertyDescriptor)

GetHashCode Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function GetHashCode() As System.Integer
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Integer

value = instance.GetHashCode()
public virtual System.int GetHashCode()
public function GetHashCode(): System.Integer; virtual;
public function GetHashCode() : System.int;
public: virtual System.int GetHashCode();
public:
virtual System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


GetInvocationTarget Method (JPropertyDescriptor)

GetInvocationTarget Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetInvocationTarget Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Function GetInvocationTarget( _
   ByVal type As System.Type, _
   ByVal instance As System.Object _
) As System.Object
'Usage

Dim instance As JPropertyDescriptor
Dim type As System.Type
Dim instance As System.Object
Dim value As System.Object

value = instance.GetInvocationTarget(type, instance)
protected virtual System.object GetInvocationTarget(
   System.Type type,
   System.object instance
)
protected function GetInvocationTarget(
    type: System.Type;
    instance: System.TObject
): System.TObject; virtual;
protected function GetInvocationTarget(
   type : System.Type,
   instance : System.Object
) : System.Object;
protected: virtual System.Object* GetInvocationTarget(
   System.Type* type,
   System.Object* instance
)
protected:
virtual System.Object^ GetInvocationTarget(
   System.Type^ type,
   System.Object^ instance
)

Parameters

type
instance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


GetTypeFromName Method (JPropertyDescriptor)

GetTypeFromName Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : GetTypeFromName Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Function GetTypeFromName( _
   ByVal typeName As System.String _
) As System.Type
'Usage

Dim instance As JPropertyDescriptor
Dim typeName As System.String
Dim value As System.Type

value = instance.GetTypeFromName(typeName)
protected System.Type GetTypeFromName(
   System.string typeName
)
protected function GetTypeFromName(
    typeName: System.String
): System.Type;
protected function GetTypeFromName(
   typeName : System.String
) : System.Type;
protected: System.Type* GetTypeFromName(
   System.string* typeName
)
protected:
System.Type^ GetTypeFromName(
   System.String^ typeName
)

Parameters

typeName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


IsBrowsable Property (JPropertyDescriptor)

IsBrowsable Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : IsBrowsable Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property IsBrowsable As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Boolean

value = instance.IsBrowsable
public virtual System.bool IsBrowsable {get;}
public read-only property IsBrowsable: System.Boolean; virtual;
public function get IsBrowsable : System.boolean
public: __property virtual System.bool get_IsBrowsable();
public:
virtual property System.bool IsBrowsable {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


IsLocalizable Property (JPropertyDescriptor)

IsLocalizable Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : IsLocalizable Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property IsLocalizable As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Boolean

value = instance.IsLocalizable
public virtual System.bool IsLocalizable {get;}
public read-only property IsLocalizable: System.Boolean; virtual;
public function get IsLocalizable : System.boolean
public: __property virtual System.bool get_IsLocalizable();
public:
virtual property System.bool IsLocalizable {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


Name Property (JPropertyDescriptor)

Name Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : Name Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property Name As System.String
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.String

value = instance.Name
public virtual System.string Name {get;}
public read-only property Name: System.String; virtual;
public function get Name : System.String
public: __property virtual System.string* get_Name();
public:
virtual property System.String^ Name {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


OnValueChanged Method (JPropertyDescriptor)

OnValueChanged Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : OnValueChanged Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overridable Sub OnValueChanged( _
   ByVal component As System.Object, _
   ByVal e As System.EventArgs _
)
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim e As System.EventArgs

instance.OnValueChanged(component, e)
protected virtual void OnValueChanged(
   System.object component,
   System.EventArgs e
)
protected procedure OnValueChanged(
    component: System.TObject;
    e: System.EventArgs
); virtual;
protected function OnValueChanged(
   component : System.Object,
   e : System.EventArgs
);
protected: virtual void OnValueChanged(
   System.Object* component,
   System.EventArgs* e
)
protected:
virtual void OnValueChanged(
   System.Object^ component,
   System.EventArgs^ e
)

Parameters

component
e
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


RemoveValueChanged Method (JPropertyDescriptor)

RemoveValueChanged Method (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : RemoveValueChanged Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub RemoveValueChanged( _
   ByVal component As System.Object, _
   ByVal handler As System.EventHandler _
)
'Usage

Dim instance As JPropertyDescriptor
Dim component As System.Object
Dim handler As System.EventHandler

instance.RemoveValueChanged(component, handler)
public virtual void RemoveValueChanged(
   System.object component,
   System.EventHandler handler
)
public procedure RemoveValueChanged(
    component: System.TObject;
    handler: System.EventHandler
); virtual;
public function RemoveValueChanged(
   component : System.Object,
   handler : System.EventHandler
);
public: virtual void RemoveValueChanged(
   System.Object* component,
   System.EventHandler* handler
)
public:
virtual void RemoveValueChanged(
   System.Object^ component,
   System.EventHandler^ handler
)

Parameters

component
handler
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


SerializationVisibility Property (JPropertyDescriptor)

SerializationVisibility Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : SerializationVisibility Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property SerializationVisibility As System.ComponentModel.DesignerSerializationVisibility
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.ComponentModel.DesignerSerializationVisibility

value = instance.SerializationVisibility
public System.ComponentModel.DesignerSerializationVisibility SerializationVisibility {get;}
public read-only property SerializationVisibility: System.ComponentModel.DesignerSerializationVisibility;
public function get SerializationVisibility : System.ComponentModel.DesignerSerializationVisibility
public: __property System.ComponentModel.DesignerSerializationVisibility get_SerializationVisibility();
public:
property System.ComponentModel.DesignerSerializationVisibility SerializationVisibility {
   System.ComponentModel.DesignerSerializationVisibility get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


SupportsChangeEvents Property (JPropertyDescriptor)

SupportsChangeEvents Property (JPropertyDescriptor)

Noemax.Newtonsoft.Json.Linq Namespace > JPropertyDescriptor Class : SupportsChangeEvents Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property SupportsChangeEvents As System.Boolean
'Usage

Dim instance As JPropertyDescriptor
Dim value As System.Boolean

value = instance.SupportsChangeEvents
public virtual System.bool SupportsChangeEvents {get;}
public read-only property SupportsChangeEvents: System.Boolean; virtual;
public function get SupportsChangeEvents : System.boolean
public: __property virtual System.bool get_SupportsChangeEvents();
public:
virtual property System.bool SupportsChangeEvents {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JPropertyDescriptor Class
JPropertyDescriptor Members


JRaw Class Properties

JRaw Class Properties

Noemax.Newtonsoft.Json.Linq Namespace : JRaw Class

For a list of all members of this type, see JRaw members.

Public Properties
 | Name | Description
Public Property | First | Get the first child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | HasValues | Gets a value indicating whether this token has child tokens. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Item | Gets the JToken with the specified key. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Last | Get the last child token of this token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Next | Gets the next sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Parent | Gets or sets the parent. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Path | Gets the path of the JSON token. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Previous | Gets the previous sibling token of this node. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Root | Gets the root JToken of this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JToken)
Public Property | Type | Gets the node type for this JToken. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Public Property | Value | Gets or sets the underlying token value. (Inherited from Noemax.Newtonsoft.Json.Linq.JValue)
Top
See Also

Reference

JRaw Class
Noemax.Newtonsoft.Json.Linq Namespace


Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Noemax.WebSockets.Net4 Assembly


JTokenReader Constructor

JTokenReader Constructor

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : JTokenReader Constructor
Overload List
Overload | Description
JTokenReader Constructor | Initializes a new instance of the JTokenReader class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members


SetToken Method (JTokenReader)

SetToken Method (JTokenReader)

Noemax.Newtonsoft.Json.Linq Namespace > JTokenReader Class : SetToken Method
Sets the current token.
Overload List
Overload | Description
SetToken(JsonToken) | Sets the current token. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
SetToken(JsonToken,Object) | Sets the current token and value. (Inherited from Noemax.Newtonsoft.Json.JsonReader)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JTokenReader Class
JTokenReader Members


DeepEquals Method (JToken)

DeepEquals Method (JToken)

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class : DeepEquals Method
Compares the values of two tokens, including the values of all descendant tokens.
Overload List
Overload | Description
DeepEquals | Compares the values of two tokens, including the values of all descendant tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members


Explicit Type Conversion(Boolean,JToken) Operator

Explicit Type Conversion(Boolean,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Boolean,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Boolean.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Boolean
'Usage

public System.bool operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.bool op_Explicit(
   JToken* value
)
public:
System.bool operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Byte,JToken) Operator

Explicit Type Conversion(Byte,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Byte,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Byte.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Byte
'Usage

public System.byte operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.byte op_Explicit(
   JToken* value
)
public:
System.byte operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Byte[],JToken) Operator

Explicit Type Conversion(Byte[],JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Byte[],JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Byte[].
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Byte()
'Usage

public System.byte[] operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.byte[]* op_Explicit(
   JToken* value
)
public:
System.array<byte>^ operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Char,JToken) Operator

Explicit Type Conversion(Char,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Char,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Char.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Char
'Usage

[System.CLSCompliant(false)]
public System.char operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.char op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.char operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(DateTime,JToken) Operator

Explicit Type Conversion(DateTime,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(DateTime,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.DateTime.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Date
'Usage

public System.DateTime operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.DateTime op_Explicit(
   JToken* value
)
public:
System.DateTime operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(DateTimeOffset,JToken) Operator

Explicit Type Conversion(DateTimeOffset,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(DateTimeOffset,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.DateTimeOffset.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.DateTimeOffset
'Usage

public System.DateTimeOffset operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.DateTimeOffset op_Explicit(
   JToken* value
)
public:
System.DateTimeOffset operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Decimal,JToken) Operator

Explicit Type Conversion(Decimal,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Decimal,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Decimal.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Decimal
'Usage

public System.decimal operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.decimal op_Explicit(
   JToken* value
)
public:
System.decimal operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Double,JToken) Operator

Explicit Type Conversion(Double,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Double,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Double.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Double
'Usage

public System.double operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.double op_Explicit(
   JToken* value
)
public:
System.double operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Guid,JToken) Operator

Explicit Type Conversion(Guid,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Guid,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Guid.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Guid
'Usage

public System.Guid operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Guid op_Explicit(
   JToken* value
)
public:
System.Guid operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Int16,JToken) Operator

Explicit Type Conversion(Int16,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Int16,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Int16.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Short
'Usage

public System.short operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.short op_Explicit(
   JToken* value
)
public:
System.short operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Int32,JToken) Operator

Explicit Type Conversion(Int32,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Int32,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Int32.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Integer
'Usage

public System.int operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.int op_Explicit(
   JToken* value
)
public:
System.int operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Int64,JToken) Operator

Explicit Type Conversion(Int64,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Int64,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Int64.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Long
'Usage

public System.long operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.long op_Explicit(
   JToken* value
)
public:
System.int64 operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Boolean>,JToken) Operator

Explicit Type Conversion(Nullable<Boolean>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Boolean>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Boolean)
'Usage

public System.Nullable<bool> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<bool> op_Explicit(
   JToken* value
)
public:
System.Nullable<bool> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Byte>,JToken) Operator

Explicit Type Conversion(Nullable<Byte>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Byte>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Byte)
'Usage

public System.Nullable<byte> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<byte> op_Explicit(
   JToken* value
)
public:
System.Nullable<byte> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Char>,JToken) Operator

Explicit Type Conversion(Nullable<Char>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Char>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Char)
'Usage

public System.Nullable<char> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<char> op_Explicit(
   JToken* value
)
public:
System.Nullable<char> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<DateTimeOffset>,JToken) Operator

Explicit Type Conversion(Nullable<DateTimeOffset>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<DateTimeOffset>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of DateTimeOffset)
'Usage

public System.Nullable<DateTimeOffset> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<DateTimeOffset> op_Explicit(
   JToken* value
)
public:
System.Nullable<DateTimeOffset> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<DateTime>,JToken) Operator

Explicit Type Conversion(Nullable<DateTime>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<DateTime>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Date)
'Usage

public System.Nullable<DateTime> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<DateTime> op_Explicit(
   JToken* value
)
public:
System.Nullable<DateTime> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Decimal>,JToken) Operator

Explicit Type Conversion(Nullable<Decimal>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Decimal>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Decimal)
'Usage

public System.Nullable<decimal> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<decimal> op_Explicit(
   JToken* value
)
public:
System.Nullable<decimal> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Double>,JToken) Operator

Explicit Type Conversion(Nullable<Double>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Double>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Double)
'Usage

public System.Nullable<double> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<double> op_Explicit(
   JToken* value
)
public:
System.Nullable<double> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Guid>,JToken) Operator

Explicit Type Conversion(Nullable<Guid>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Guid>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Guid.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Guid)
'Usage

public System.Nullable<Guid> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<Guid> op_Explicit(
   JToken* value
)
public:
System.Nullable<Guid> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Int16>,JToken) Operator

Explicit Type Conversion(Nullable<Int16>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Int16>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Short)
'Usage

public System.Nullable<short> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<short> op_Explicit(
   JToken* value
)
public:
System.Nullable<short> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Int32>,JToken) Operator

Explicit Type Conversion(Nullable<Int32>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Int32>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Integer)
'Usage

public System.Nullable<int> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<int> op_Explicit(
   JToken* value
)
public:
System.Nullable<int> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Int64>,JToken) Operator

Explicit Type Conversion(Nullable<Int64>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Int64>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Long)
'Usage

public System.Nullable<long> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<long> op_Explicit(
   JToken* value
)
public:
System.Nullable<int64> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<SByte>,JToken) Operator

Explicit Type Conversion(Nullable<SByte>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<SByte>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of SByte)
'Usage

[System.CLSCompliant(false)]
public System.Nullable<sbyte> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.Nullable<sbyte> op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.Nullable<sbyte> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<Single>,JToken) Operator

Explicit Type Conversion(Nullable<Single>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<Single>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of Single)
'Usage

public System.Nullable<float> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<float> op_Explicit(
   JToken* value
)
public:
System.Nullable<float> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<TimeSpan>,JToken) Operator

Explicit Type Conversion(Nullable<TimeSpan>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<TimeSpan>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.TimeSpan.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of TimeSpan)
'Usage

public System.Nullable<TimeSpan> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Nullable<TimeSpan> op_Explicit(
   JToken* value
)
public:
System.Nullable<TimeSpan> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<UInt16>,JToken) Operator

Explicit Type Conversion(Nullable<UInt16>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<UInt16>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of UShort)
'Usage

[System.CLSCompliant(false)]
public System.Nullable<ushort> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.Nullable<ushort> op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.Nullable<ushort> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<UInt32>,JToken) Operator

Explicit Type Conversion(Nullable<UInt32>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<UInt32>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of UInteger)
'Usage

[System.CLSCompliant(false)]
public System.Nullable<uint> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.Nullable<uint> op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.Nullable<uint> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Nullable<UInt64>,JToken) Operator

Explicit Type Conversion(Nullable<UInt64>,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Nullable<UInt64>,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Nullable`1.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Nullable(Of ULong)
'Usage

[System.CLSCompliant(false)]
public System.Nullable<ulong> operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.Nullable<ulong> op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.Nullable<ulong> operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(SByte,JToken) Operator

Explicit Type Conversion(SByte,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(SByte,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.SByte.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.SByte
'Usage

[System.CLSCompliant(false)]
public System.sbyte operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.sbyte op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.sbyte operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Single,JToken) Operator

Explicit Type Conversion(Single,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Single,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Single.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Single
'Usage

public System.float operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.float op_Explicit(
   JToken* value
)
public:
System.float operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(String,JToken) Operator

Explicit Type Conversion(String,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(String,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.String.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.String
'Usage

public System.string operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.string* op_Explicit(
   JToken* value
)
public:
System.String^ operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(TimeSpan,JToken) Operator

Explicit Type Conversion(TimeSpan,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(TimeSpan,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.TimeSpan.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.TimeSpan
'Usage

public System.TimeSpan operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.TimeSpan op_Explicit(
   JToken* value
)
public:
System.TimeSpan operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(UInt16,JToken) Operator

Explicit Type Conversion(UInt16,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(UInt16,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.UInt16.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.UShort
'Usage

[System.CLSCompliant(false)]
public System.ushort operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.ushort op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.ushort operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(UInt32,JToken) Operator

Explicit Type Conversion(UInt32,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(UInt32,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.UInt32.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.UInteger
'Usage

[System.CLSCompliant(false)]
public System.uint operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.uint op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.uint operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(UInt64,JToken) Operator

Explicit Type Conversion(UInt64,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(UInt64,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.UInt64.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.ULong
'Usage

[System.CLSCompliant(false)]
public System.ulong operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: System.ulong op_Explicit(
   JToken* value
)
[System.CLSCompliant(false)]
public:
System.ulong operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Explicit Type Conversion(Uri,JToken) Operator

Explicit Type Conversion(Uri,JToken) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Explicit Type Conversion Operator : Explicit Type Conversion(Uri,JToken) Operator
The value.
Performs an explicit conversion from JToken to System.Uri.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Narrowing CType( _
   ByVal value As JToken _
) As System.Uri
'Usage

public System.Uri operator explicit(
   JToken value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.Uri* op_Explicit(
   JToken* value
)
public:
System.Uri^ operator explicit(
   JToken^ value
)

Parameters

value
The value.

Return Value

The result of the conversion.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Boolean) Operator

Implicit Type Conversion(JToken,Boolean) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Boolean) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Boolean to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Boolean _
) As JToken
'Usage

public JToken operator implicit(
   System.bool value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.bool value
)
public:
operator JToken^ (
   System.bool value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Byte) Operator

Implicit Type Conversion(JToken,Byte) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Byte) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Byte to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Byte _
) As JToken
'Usage

public JToken operator implicit(
   System.byte value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.byte value
)
public:
operator JToken^ (
   System.byte value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Byte[]) Operator

Implicit Type Conversion(JToken,Byte[]) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Byte[]) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Byte[] to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value() As System.Byte _
) As JToken
'Usage

public JToken operator implicit(
   System.byte[] value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.byte[]* value
)
public:
operator JToken^ (
   System.array<byte>^ value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,DateTime) Operator

Implicit Type Conversion(JToken,DateTime) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,DateTime) Operator
The value to create a JValue from.
Performs an implicit conversion from System.DateTime to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Date _
) As JToken
'Usage

public JToken operator implicit(
   System.DateTime value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.DateTime value
)
public:
operator JToken^ (
   System.DateTime value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,DateTimeOffset) Operator

Implicit Type Conversion(JToken,DateTimeOffset) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,DateTimeOffset) Operator
The value to create a JValue from.
Performs an implicit conversion from System.DateTimeOffset to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.DateTimeOffset _
) As JToken
'Usage

public JToken operator implicit(
   System.DateTimeOffset value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.DateTimeOffset value
)
public:
operator JToken^ (
   System.DateTimeOffset value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Decimal) Operator

Implicit Type Conversion(JToken,Decimal) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Decimal) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Decimal to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Decimal _
) As JToken
'Usage

public JToken operator implicit(
   System.decimal value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.decimal value
)
public:
operator JToken^ (
   System.decimal value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Double) Operator

Implicit Type Conversion(JToken,Double) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Double) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Double to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Double _
) As JToken
'Usage

public JToken operator implicit(
   System.double value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.double value
)
public:
operator JToken^ (
   System.double value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Guid) Operator

Implicit Type Conversion(JToken,Guid) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Guid) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Guid to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Guid _
) As JToken
'Usage

public JToken operator implicit(
   System.Guid value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Guid value
)
public:
operator JToken^ (
   System.Guid value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Int16) Operator

Implicit Type Conversion(JToken,Int16) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Int16) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Int16 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Short _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.short value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.short value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.short value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Int32) Operator

Implicit Type Conversion(JToken,Int32) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Int32) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Int32 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Integer _
) As JToken
'Usage

public JToken operator implicit(
   System.int value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.int value
)
public:
operator JToken^ (
   System.int value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Int64) Operator

Implicit Type Conversion(JToken,Int64) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Int64) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Long _
) As JToken
'Usage

public JToken operator implicit(
   System.long value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.long value
)
public:
operator JToken^ (
   System.int64 value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Boolean>) Operator

Implicit Type Conversion(JToken,Nullable<Boolean>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Boolean>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Boolean) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<bool> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<bool> value
)
public:
operator JToken^ (
   System.Nullable<bool> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Byte>) Operator

Implicit Type Conversion(JToken,Nullable<Byte>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Byte>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Byte) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<byte> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<byte> value
)
public:
operator JToken^ (
   System.Nullable<byte> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<DateTimeOffset>) Operator

Implicit Type Conversion(JToken,Nullable<DateTimeOffset>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<DateTimeOffset>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of DateTimeOffset) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<DateTimeOffset> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<DateTimeOffset> value
)
public:
operator JToken^ (
   System.Nullable<DateTimeOffset> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<DateTime>) Operator

Implicit Type Conversion(JToken,Nullable<DateTime>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<DateTime>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Date) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<DateTime> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<DateTime> value
)
public:
operator JToken^ (
   System.Nullable<DateTime> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Decimal>) Operator

Implicit Type Conversion(JToken,Nullable<Decimal>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Decimal>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Decimal) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<decimal> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<decimal> value
)
public:
operator JToken^ (
   System.Nullable<decimal> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Double>) Operator

Implicit Type Conversion(JToken,Nullable<Double>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Double>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Double) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<double> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<double> value
)
public:
operator JToken^ (
   System.Nullable<double> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Guid>) Operator

Implicit Type Conversion(JToken,Nullable<Guid>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Guid>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Guid) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<Guid> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<Guid> value
)
public:
operator JToken^ (
   System.Nullable<Guid> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Int16>) Operator

Implicit Type Conversion(JToken,Nullable<Int16>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Int16>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Short) _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.Nullable<short> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.Nullable<short> value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.Nullable<short> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Int32>) Operator

Implicit Type Conversion(JToken,Nullable<Int32>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Int32>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Integer) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<int> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<int> value
)
public:
operator JToken^ (
   System.Nullable<int> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Int64>) Operator

Implicit Type Conversion(JToken,Nullable<Int64>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Int64>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Long) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<long> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<long> value
)
public:
operator JToken^ (
   System.Nullable<int64> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<SByte>) Operator

Implicit Type Conversion(JToken,Nullable<SByte>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<SByte>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of SByte) _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.Nullable<sbyte> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.Nullable<sbyte> value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.Nullable<sbyte> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<Single>) Operator

Implicit Type Conversion(JToken,Nullable<Single>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<Single>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of Single) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<float> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<float> value
)
public:
operator JToken^ (
   System.Nullable<float> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<TimeSpan>) Operator

Implicit Type Conversion(JToken,Nullable<TimeSpan>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<TimeSpan>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of TimeSpan) _
) As JToken
'Usage

public JToken operator implicit(
   System.Nullable<TimeSpan> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Nullable<TimeSpan> value
)
public:
operator JToken^ (
   System.Nullable<TimeSpan> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<UInt16>) Operator

Implicit Type Conversion(JToken,Nullable<UInt16>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<UInt16>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of UShort) _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.Nullable<ushort> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.Nullable<ushort> value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.Nullable<ushort> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<UInt32>) Operator

Implicit Type Conversion(JToken,Nullable<UInt32>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<UInt32>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of UInteger) _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.Nullable<uint> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.Nullable<uint> value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.Nullable<uint> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Nullable<UInt64>) Operator

Implicit Type Conversion(JToken,Nullable<UInt64>) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Nullable<UInt64>) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Nullable`1 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.Nullable(Of ULong) _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.Nullable<ulong> value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.Nullable<ulong> value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.Nullable<ulong> value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,SByte) Operator

Implicit Type Conversion(JToken,SByte) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,SByte) Operator
The value to create a JValue from.
Performs an implicit conversion from System.SByte to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.SByte _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.sbyte value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.sbyte value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.sbyte value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Single) Operator

Implicit Type Conversion(JToken,Single) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Single) Operator
The value to create a JValue from.
Performs an implicit conversion from System.Single to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Single _
) As JToken
'Usage

public JToken operator implicit(
   System.float value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.float value
)
public:
operator JToken^ (
   System.float value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,String) Operator

Implicit Type Conversion(JToken,String) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,String) Operator
The value to create a JValue from.
Performs an implicit conversion from System.String to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.String _
) As JToken
'Usage

public JToken operator implicit(
   System.string value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.string* value
)
public:
operator JToken^ (
   System.String^ value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,TimeSpan) Operator

Implicit Type Conversion(JToken,TimeSpan) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,TimeSpan) Operator
The value to create a JValue from.
Performs an implicit conversion from System.TimeSpan to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.TimeSpan _
) As JToken
'Usage

public JToken operator implicit(
   System.TimeSpan value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.TimeSpan value
)
public:
operator JToken^ (
   System.TimeSpan value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,UInt16) Operator

Implicit Type Conversion(JToken,UInt16) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,UInt16) Operator
The value to create a JValue from.
Performs an implicit conversion from System.UInt16 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.UShort _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.ushort value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.ushort value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.ushort value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,UInt32) Operator

Implicit Type Conversion(JToken,UInt32) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,UInt32) Operator
The value to create a JValue from.
Performs an implicit conversion from System.UInt32 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.UInteger _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.uint value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.uint value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.uint value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,UInt64) Operator

Implicit Type Conversion(JToken,UInt64) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,UInt64) Operator
The value to create a JValue from.
Performs an implicit conversion from System.UInt64 to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.CLSCompliantAttribute(False)>
Overloads Public Operator Widening CType( _
   ByVal value As System.ULong _
) As JToken
'Usage

[System.CLSCompliant(false)]
public JToken operator implicit(
   System.ulong value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
[System.CLSCompliant(false)]
public: JToken* op_Implicit(
   System.ulong value
)
[System.CLSCompliant(false)]
public:
operator JToken^ (
   System.ulong value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Implicit Type Conversion(JToken,Uri) Operator

Implicit Type Conversion(JToken,Uri) Operator

Noemax.Newtonsoft.Json.Linq Namespace > JToken Class > Implicit Type Conversion Operator : Implicit Type Conversion(JToken,Uri) Operator
The value to create a JValue from.
Performs an implicit conversion from System._uri to JToken.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal value As System.Uri _
) As JToken
'Usage

public JToken operator implicit(
   System.Uri value
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: JToken* op_Implicit(
   System.Uri* value
)
public:
operator JToken^ (
   System.Uri^ value
)

Parameters

value
The value to create a JValue from.

Return Value

The JValue initialized with the specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JToken Class
JToken Members
Overload List


Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Linq.JTokenReader
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter
Noemax.Newtonsoft.Json.Linq.Extensions
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JArray
Noemax.Newtonsoft.Json.Linq.JConstructor
Noemax.Newtonsoft.Json.Linq.JObject
Noemax.Newtonsoft.Json.Linq.JProperty
Noemax.Newtonsoft.Json.Linq.JValue
Noemax.Newtonsoft.Json.Linq.JRaw
Noemax.Newtonsoft.Json.Linq.JTokenEqualityComparer
System.ComponentModel.MemberDescriptor
System.ComponentModel.PropertyDescriptor
Noemax.Newtonsoft.Json.Linq.JPropertyDescriptor
System.ValueType
Noemax.Newtonsoft.Json.Linq.JEnumerable<T>
See Also

Reference

Noemax.WebSockets.Net4 Assembly


JsonSchemaException Class Events

JsonSchemaException Class Events

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaException Class

For a list of all members of this type, see JsonSchemaException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

JsonSchemaException Class
Noemax.Newtonsoft.Json.Schema Namespace


JsonSchemaException Class Methods

JsonSchemaException Class Methods

Noemax.Newtonsoft.Json.Schema Namespace : JsonSchemaException Class

For a list of all members of this type, see JsonSchemaException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

JsonSchemaException Class
Noemax.Newtonsoft.Json.Schema Namespace


Data Property (JsonSchemaException)

Data Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As JsonSchemaException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


GetBaseException Method (JsonSchemaException)

GetBaseException Method (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As JsonSchemaException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


GetObjectData Method (JsonSchemaException)

GetObjectData Method (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As JsonSchemaException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


GetType Method (JsonSchemaException)

GetType Method (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


GetType() Method

GetType() Method

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As JsonSchemaException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


HelpLink Property (JsonSchemaException)

HelpLink Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


HResult Property (JsonSchemaException)

HResult Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As JsonSchemaException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


InnerException Property (JsonSchemaException)

InnerException Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As JsonSchemaException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


Message Property (JsonSchemaException)

Message Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


SerializeObjectState Event (JsonSchemaException)

SerializeObjectState Event (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As JsonSchemaException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


Source Property (JsonSchemaException)

Source Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


StackTrace Property (JsonSchemaException)

StackTrace Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


TargetSite Property (JsonSchemaException)

TargetSite Property (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As JsonSchemaException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


ToString Method (JsonSchemaException)

ToString Method (JsonSchemaException)

Noemax.Newtonsoft.Json.Schema Namespace > JsonSchemaException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As JsonSchemaException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonSchemaException Class
JsonSchemaException Members


Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Schema.Extensions
Noemax.Newtonsoft.Json.Schema.JsonSchema
Noemax.Newtonsoft.Json.Schema.JsonSchemaGenerator
Noemax.Newtonsoft.Json.Schema.JsonSchemaResolver
System.EventArgs
Noemax.Newtonsoft.Json.Schema.ValidationEventArgs
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException
See Also

Reference

Noemax.WebSockets.Net4 Assembly


CamelCasePropertyNamesContractResolver Class Methods

CamelCasePropertyNamesContractResolver Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class

For a list of all members of this type, see CamelCasePropertyNamesContractResolver members.

Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Method | ResolveContract | Resolves the contract for a given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateConstructorParameters | Creates the constructor parameters. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateContract | Determines which contract type is created for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDynamicContract | Creates a JsonDynamicContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperties | Creates properties for the given JsonContract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | GetSerializableMembers | Gets the serializable members for the type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
See Also

Reference

CamelCasePropertyNamesContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


CamelCasePropertyNamesContractResolver Class Properties

CamelCasePropertyNamesContractResolver Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class

For a list of all members of this type, see CamelCasePropertyNamesContractResolver members.

Public Properties
 | Name | Description
Public Property | DefaultMembersSearchFlags | Gets or sets the default members search flags. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | DynamicCodeGeneration | Gets a value indicating whether members are being get and set using dynamic code generation. This value is determined by the runtime permissions available. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableAttribute | Gets or sets a value indicating whether to ignore the System.SerializableAttribute attribute when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | IgnoreSerializableInterface | Gets or sets a value indicating whether to ignore the System.Runtime.Serialization.ISerializable interface when serializing and deserializing types. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Property | SerializeCompilerGeneratedMembers | Gets or sets a value indicating whether compiler generated members should be serialized. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
See Also

Reference

CamelCasePropertyNamesContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonLinqContract Class Properties

JsonLinqContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonLinqContract Class

For a list of all members of this type, see JsonLinqContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonLinqContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPrimitiveContract Class Properties

JsonPrimitiveContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPrimitiveContract Class

For a list of all members of this type, see JsonPrimitiveContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonPrimitiveContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


JsonPropertyCollection Class Properties

JsonPropertyCollection Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonPropertyCollection Class

For a list of all members of this type, see JsonPropertyCollection members.

Public Properties
 | Name | Description
Public Property | Comparer | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Public Property | Item | Overloaded. (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Top
Protected Properties
 | Name | Description
Protected Property | Dictionary | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Top
See Also

Reference

JsonPropertyCollection Class
Noemax.Newtonsoft.Json.Serialization Namespace


Add Method (JsonPropertyCollection)

Add Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Add Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As JsonProperty _
)
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty

instance.Add(item)
[__DynamicallyInvokable()]
public void Add(
   JsonProperty item
)
public procedure Add(
    item: JsonProperty
);
__DynamicallyInvokableAttribute()
public function Add(
   item : JsonProperty
);
[__DynamicallyInvokable()]
public: void Add(
   JsonProperty* item
)
[__DynamicallyInvokable()]
public:
void Add(
   JsonProperty^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


ChangeItemKey Method (JsonPropertyCollection)

ChangeItemKey Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : ChangeItemKey Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Sub ChangeItemKey( _
   ByVal item As JsonProperty, _
   ByVal newKey As System.String _
)
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty
Dim newKey As System.String

instance.ChangeItemKey(item, newKey)
[__DynamicallyInvokable()]
protected void ChangeItemKey(
   JsonProperty item,
   System.string newKey
)
protected procedure ChangeItemKey(
    item: JsonProperty;
    newKey: System.String
);
__DynamicallyInvokableAttribute()
protected function ChangeItemKey(
   item : JsonProperty,
   newKey : System.String
);
[__DynamicallyInvokable()]
protected: void ChangeItemKey(
   JsonProperty* item,
   System.string* newKey
)
[__DynamicallyInvokable()]
protected:
void ChangeItemKey(
   JsonProperty^ item,
   System.String^ newKey
)

Parameters

item
newKey
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Clear Method (JsonPropertyCollection)

Clear Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Sub Clear()
'Usage

Dim instance As JsonPropertyCollection

instance.Clear()
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public void Clear()
public procedure Clear();
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Clear();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public: void Clear();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public:
void Clear();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


ClearItems Method (JsonPropertyCollection)

ClearItems Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : ClearItems Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overridable Sub ClearItems()
'Usage

Dim instance As JsonPropertyCollection

instance.ClearItems()
[__DynamicallyInvokable()]
protected virtual void ClearItems()
protected procedure ClearItems(); virtual;
__DynamicallyInvokableAttribute()
protected function ClearItems();
[__DynamicallyInvokable()]
protected: virtual void ClearItems();
[__DynamicallyInvokable()]
protected:
virtual void ClearItems();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Comparer Property (JsonPropertyCollection)

Comparer Property (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Comparer Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Comparer As System.Collections.Generic.IEqualityComparer(Of String)
'Usage

Dim instance As JsonPropertyCollection
Dim value As System.Collections.Generic.IEqualityComparer(Of String)

value = instance.Comparer
[__DynamicallyInvokable()]
public System.Collections.Generic.IEqualityComparer<string> Comparer {get;}
public read-only property Comparer: System.Collections.Generic.IEqualityComparer;
__DynamicallyInvokableAttribute()
public function get Comparer : System.Collections.Generic.IEqualityComparer
[__DynamicallyInvokable()]
public: __property System.Collections.Generic.IEqualityComparer<string*>* get_Comparer();
[__DynamicallyInvokable()]
public:
property System.Collections.Generic.IEqualityComparer<String^>^ Comparer {
   System.Collections.Generic.IEqualityComparer<String^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Contains Method (JsonPropertyCollection)

Contains Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Contains Method
Overload List
Overload | Description
Contains(String) | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Contains(JsonProperty) | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Contains(JsonProperty) Method

Contains(JsonProperty) Method

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Contains Method : Contains(JsonProperty) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Overloads Function Contains( _
   ByVal item As JsonProperty _
) As System.Boolean
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty
Dim value As System.Boolean

value = instance.Contains(item)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public System.bool Contains(
   JsonProperty item
)
public function Contains(
    item: JsonProperty
): System.Boolean;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : JsonProperty
) : System.boolean;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public: System.bool Contains(
   JsonProperty* item
)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public:
System.bool Contains(
   JsonProperty^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


Contains(String) Method

Contains(String) Method

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Contains Method : Contains(String) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Function Contains( _
   ByVal key As System.String _
) As System.Boolean
'Usage

Dim instance As JsonPropertyCollection
Dim key As System.String
Dim value As System.Boolean

value = instance.Contains(key)
[__DynamicallyInvokable()]
public System.bool Contains(
   System.string key
)
public function Contains(
    key: System.String
): System.Boolean;
__DynamicallyInvokableAttribute()
public function Contains(
   key : System.String
) : System.boolean;
[__DynamicallyInvokable()]
public: System.bool Contains(
   System.string* key
)
[__DynamicallyInvokable()]
public:
System.bool Contains(
   System.String^ key
)

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


CopyTo Method (JsonPropertyCollection)

CopyTo Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As JsonProperty, _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonPropertyCollection
Dim array() As JsonProperty
Dim index As System.Integer

instance.CopyTo(array, index)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   JsonProperty[] array,
   System.int index
)
public procedure CopyTo(
    array: JsonPropertyarray of;
    index: System.Integer
);
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : JsonProperty[],
   index : System.int
);
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   JsonProperty*[]* array,
   System.int index
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   array<JsonProperty^>^ array,
   System.int index
)

Parameters

array
index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Count Property (JsonPropertyCollection)

Count Property (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
'Usage

Dim instance As JsonPropertyCollection
Dim value As System.Integer

value = instance.Count
[__DynamicallyInvokable()]
public System.int Count {get;}
public read-only property Count: System.Integer;
__DynamicallyInvokableAttribute()
public function get Count : System.int
[__DynamicallyInvokable()]
public: __property System.int get_Count();
[__DynamicallyInvokable()]
public:
property System.int Count {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Dictionary Property (JsonPropertyCollection)

Dictionary Property (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Dictionary Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Dictionary As System.Collections.Generic.IDictionary(Of String,JsonProperty)
'Usage

Dim instance As JsonPropertyCollection
Dim value As System.Collections.Generic.IDictionary(Of String,JsonProperty)

value = instance.Dictionary
[__DynamicallyInvokable()]
protected System.Collections.Generic.IDictionary<string,JsonProperty> Dictionary {get;}
protected read-only property Dictionary: System.Collections.Generic.IDictionary;
__DynamicallyInvokableAttribute()
protected function get Dictionary : System.Collections.Generic.IDictionary
[__DynamicallyInvokable()]
protected: __property System.Collections.Generic.IDictionary<string*,JsonProperty*>* get_Dictionary();
[__DynamicallyInvokable()]
protected:
property System.Collections.Generic.IDictionary<String^,JsonProperty^>^ Dictionary {
   System.Collections.Generic.IDictionary<String^,JsonProperty^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


GetEnumerator Method (JsonPropertyCollection)

GetEnumerator Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : GetEnumerator Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of JsonProperty)
'Usage

Dim instance As JsonPropertyCollection
Dim value As System.Collections.Generic.IEnumerator(Of JsonProperty)

value = instance.GetEnumerator()
[__DynamicallyInvokable()]
public System.Collections.Generic.IEnumerator<JsonProperty> GetEnumerator()
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
[__DynamicallyInvokable()]
public: System.Collections.Generic.IEnumerator<JsonProperty*>* GetEnumerator();
[__DynamicallyInvokable()]
public:
System.Collections.Generic.IEnumerator<JsonProperty^>^ GetEnumerator();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


IndexOf Method (JsonPropertyCollection)

IndexOf Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function IndexOf( _
   ByVal item As JsonProperty _
) As System.Integer
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty
Dim value As System.Integer

value = instance.IndexOf(item)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public System.int IndexOf(
   JsonProperty item
)
public function IndexOf(
    item: JsonProperty
): System.Integer;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function IndexOf(
   item : JsonProperty
) : System.int;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public: System.int IndexOf(
   JsonProperty* item
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
public:
System.int IndexOf(
   JsonProperty^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Insert Method (JsonPropertyCollection)

Insert Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Insert Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As JsonProperty _
)
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer
Dim item As JsonProperty

instance.Insert(index, item)
[__DynamicallyInvokable()]
public void Insert(
   System.int index,
   JsonProperty item
)
public procedure Insert(
    index: System.Integer;
    item: JsonProperty
);
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : JsonProperty
);
[__DynamicallyInvokable()]
public: void Insert(
   System.int index,
   JsonProperty* item
)
[__DynamicallyInvokable()]
public:
void Insert(
   System.int index,
   JsonProperty^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


InsertItem Method (JsonPropertyCollection)

InsertItem Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : InsertItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As JsonProperty _
)
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer
Dim item As JsonProperty

instance.InsertItem(index, item)
[__DynamicallyInvokable()]
protected virtual void InsertItem(
   System.int index,
   JsonProperty item
)
protected procedure InsertItem(
    index: System.Integer;
    item: JsonProperty
); virtual;
__DynamicallyInvokableAttribute()
protected function InsertItem(
   index : System.int,
   item : JsonProperty
);
[__DynamicallyInvokable()]
protected: virtual void InsertItem(
   System.int index,
   JsonProperty* item
)
[__DynamicallyInvokable()]
protected:
virtual void InsertItem(
   System.int index,
   JsonProperty^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Item Property (JsonPropertyCollection)

Item Property (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Item Property
Overload List
Overload | Description
Item(String) | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Item(Int32) | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Item(Int32) Property

Item(Int32) Property

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Item Property : Item(Int32) Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Property Item( _
   ByVal index As System.Integer _
) As JsonProperty
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer
Dim value As JsonProperty

instance.Item(index) = value

value = instance.Item(index)
[__DynamicallyInvokable()]
public JsonProperty Item(
   System.int index
) {get; set;}
public read-write property Item(
    index: System.Integer
): JsonProperty;
__DynamicallyInvokableAttribute()
public function get,set Item(
   index : System.int
) : JsonProperty
[__DynamicallyInvokable()]
public: __property JsonProperty* get_Item(
   System.int index
);
public: __property void set_Item(
   System.int index,
   JsonProperty* value
);
[__DynamicallyInvokable()]
public:
property JsonProperty^ Item {
   JsonProperty^ get(System.int index);
   void set (System.int index, JsonProperty^ value);
}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


Item(String) Property

Item(String) Property

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Item Property : Item(String) Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads ReadOnly Property Item( _
   ByVal key As System.String _
) As JsonProperty
'Usage

Dim instance As JsonPropertyCollection
Dim key As System.String
Dim value As JsonProperty

value = instance.Item(key)
[__DynamicallyInvokable()]
public JsonProperty Item(
   System.string key
) {get;}
public read-only property Item(
    key: System.String
): JsonProperty;
__DynamicallyInvokableAttribute()
public function get Item(
   key : System.String
) : JsonProperty
[__DynamicallyInvokable()]
public: __property JsonProperty* get_Item(
   System.string* key
);
[__DynamicallyInvokable()]
public:
property JsonProperty^ Item {
   JsonProperty^ get(System.String^ key);
}

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


Items Property (JsonPropertyCollection)

Items Property (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Items Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of JsonProperty)
'Usage

Dim instance As JsonPropertyCollection
Dim value As System.Collections.Generic.IList(Of JsonProperty)

value = instance.Items
[__DynamicallyInvokable()]
protected System.Collections.Generic.IList<JsonProperty> Items {get;}
protected read-only property Items: System.Collections.Generic.IList;
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
[__DynamicallyInvokable()]
protected: __property System.Collections.Generic.IList<JsonProperty*>* get_Items();
[__DynamicallyInvokable()]
protected:
property System.Collections.Generic.IList<JsonProperty^>^ Items {
   System.Collections.Generic.IList<JsonProperty^>^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Remove Method (JsonPropertyCollection)

Remove Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : Remove Method
Overload List
Overload | Description
Remove(String) | (Inherited from System.Collections.ObjectModel.KeyedCollection<string,JsonProperty>)
Remove(JsonProperty) | (Inherited from System.Collections.ObjectModel.Collection<JsonProperty>)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


Remove(JsonProperty) Method

Remove(JsonProperty) Method

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Remove Method : Remove(JsonProperty) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Function Remove( _
   ByVal item As JsonProperty _
) As System.Boolean
'Usage

Dim instance As JsonPropertyCollection
Dim item As JsonProperty
Dim value As System.Boolean

value = instance.Remove(item)
[__DynamicallyInvokable()]
public System.bool Remove(
   JsonProperty item
)
public function Remove(
    item: JsonProperty
): System.Boolean;
__DynamicallyInvokableAttribute()
public function Remove(
   item : JsonProperty
) : System.boolean;
[__DynamicallyInvokable()]
public: System.bool Remove(
   JsonProperty* item
)
[__DynamicallyInvokable()]
public:
System.bool Remove(
   JsonProperty^ item
)

Parameters

item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


Remove(String) Method

Remove(String) Method

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class > Remove Method : Remove(String) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Function Remove( _
   ByVal key As System.String _
) As System.Boolean
'Usage

Dim instance As JsonPropertyCollection
Dim key As System.String
Dim value As System.Boolean

value = instance.Remove(key)
[__DynamicallyInvokable()]
public System.bool Remove(
   System.string key
)
public function Remove(
    key: System.String
): System.Boolean;
__DynamicallyInvokableAttribute()
public function Remove(
   key : System.String
) : System.boolean;
[__DynamicallyInvokable()]
public: System.bool Remove(
   System.string* key
)
[__DynamicallyInvokable()]
public:
System.bool Remove(
   System.String^ key
)

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members
Overload List


RemoveAt Method (JsonPropertyCollection)

RemoveAt Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer

instance.RemoveAt(index)
[__DynamicallyInvokable()]
public void RemoveAt(
   System.int index
)
public procedure RemoveAt(
    index: System.Integer
);
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
[__DynamicallyInvokable()]
public: void RemoveAt(
   System.int index
)
[__DynamicallyInvokable()]
public:
void RemoveAt(
   System.int index
)

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


RemoveItem Method (JsonPropertyCollection)

RemoveItem Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : RemoveItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer

instance.RemoveItem(index)
[__DynamicallyInvokable()]
protected virtual void RemoveItem(
   System.int index
)
protected procedure RemoveItem(
    index: System.Integer
); virtual;
__DynamicallyInvokableAttribute()
protected function RemoveItem(
   index : System.int
);
[__DynamicallyInvokable()]
protected: virtual void RemoveItem(
   System.int index
)
[__DynamicallyInvokable()]
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


SetItem Method (JsonPropertyCollection)

SetItem Method (JsonPropertyCollection)

Noemax.Newtonsoft.Json.Serialization Namespace > JsonPropertyCollection Class : SetItem Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As JsonProperty _
)
'Usage

Dim instance As JsonPropertyCollection
Dim index As System.Integer
Dim item As JsonProperty

instance.SetItem(index, item)
[__DynamicallyInvokable()]
protected virtual void SetItem(
   System.int index,
   JsonProperty item
)
protected procedure SetItem(
    index: System.Integer;
    item: JsonProperty
); virtual;
__DynamicallyInvokableAttribute()
protected function SetItem(
   index : System.int,
   item : JsonProperty
);
[__DynamicallyInvokable()]
protected: virtual void SetItem(
   System.int index,
   JsonProperty* item
)
[__DynamicallyInvokable()]
protected:
virtual void SetItem(
   System.int index,
   JsonProperty^ item
)

Parameters

index
item
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsonPropertyCollection Class
JsonPropertyCollection Members


JsonStringContract Class Properties

JsonStringContract Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : JsonStringContract Class

For a list of all members of this type, see JsonStringContract members.

Public Properties
 | Name | Description
Public Property | Converter | Gets or sets the default Noemax.Newtonsoft.Json.JsonConverter for this contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | CreatedType | Gets or sets the type created during deserialization. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreator | Gets or sets the default creator method used to create the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | DefaultCreatorNonPublic | Gets or sets a value indicating whether the default creator is non public. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | IsReference | Gets or sets whether this type contract is serialized as a reference. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserialized | Gets or sets the method called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializedCallbacks | Gets or sets all methods called immediately after deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializing | Gets or sets the method called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnDeserializingCallbacks | Gets or sets all methods called during deserialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnError | Gets or sets the method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnErrorCallbacks | Gets or sets all method called when an error is thrown during the serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerialized | Gets or sets the method called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializedCallbacks | Gets or sets all methods called after serialization of the object graph. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializing | Gets or sets the method called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | OnSerializingCallbacks | Gets or sets all methods called before serialization of the object. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Public Property | UnderlyingType | Gets the underlying type for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.JsonContract)
Top
See Also

Reference

JsonStringContract Class
Noemax.Newtonsoft.Json.Serialization Namespace


OnErrorAttribute Class Methods

OnErrorAttribute Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : OnErrorAttribute Class

For a list of all members of this type, see OnErrorAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

OnErrorAttribute Class
Noemax.Newtonsoft.Json.Serialization Namespace


OnErrorAttribute Class Properties

OnErrorAttribute Class Properties

Noemax.Newtonsoft.Json.Serialization Namespace : OnErrorAttribute Class

For a list of all members of this type, see OnErrorAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

OnErrorAttribute Class
Noemax.Newtonsoft.Json.Serialization Namespace


Equals Method (OnErrorAttribute)

Equals Method (OnErrorAttribute)

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As OnErrorAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


GetHashCode Method (OnErrorAttribute)

GetHashCode Method (OnErrorAttribute)

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Function GetHashCode() As System.Integer
'Usage

Dim instance As OnErrorAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public System.int GetHashCode()
public function GetHashCode(): System.Integer;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


IsDefaultAttribute Method (OnErrorAttribute)

IsDefaultAttribute Method (OnErrorAttribute)

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As OnErrorAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean;
public function IsDefaultAttribute() : System.boolean;
public: System.bool IsDefaultAttribute();
public:
System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


Match Method (OnErrorAttribute)

Match Method (OnErrorAttribute)

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As OnErrorAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean;
public function Match(
   obj : System.Object
) : System.boolean;
public: System.bool Match(
   System.Object* obj
)
public:
System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


TypeId Property (OnErrorAttribute)

TypeId Property (OnErrorAttribute)

Noemax.Newtonsoft.Json.Serialization Namespace > OnErrorAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TypeId As System.Object
'Usage

Dim instance As OnErrorAttribute
Dim value As System.Object

value = instance.TypeId
public System.object TypeId {get;}
public read-only property TypeId: System.TObject;
public function get TypeId : System.Object
public: __property System.Object* get_TypeId();
public:
property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

OnErrorAttribute Class
OnErrorAttribute Members


Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver
Noemax.Newtonsoft.Json.Serialization.CamelCasePropertyNamesContractResolver
Noemax.Newtonsoft.Json.Serialization.DiagnosticsTraceWriter
Noemax.Newtonsoft.Json.Serialization.DynamicValueProvider
Noemax.Newtonsoft.Json.Serialization.ErrorContext
Noemax.Newtonsoft.Json.Serialization.ExpressionValueProvider
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonArrayContract
Noemax.Newtonsoft.Json.Serialization.JsonDictionaryContract
Noemax.Newtonsoft.Json.Serialization.JsonDynamicContract
Noemax.Newtonsoft.Json.Serialization.JsonISerializableContract
Noemax.Newtonsoft.Json.Serialization.JsonObjectContract
Noemax.Newtonsoft.Json.Serialization.JsonLinqContract
Noemax.Newtonsoft.Json.Serialization.JsonPrimitiveContract
Noemax.Newtonsoft.Json.Serialization.JsonStringContract
Noemax.Newtonsoft.Json.Serialization.JsonProperty
Noemax.Newtonsoft.Json.Serialization.MemoryTraceWriter
Noemax.Newtonsoft.Json.Serialization.ReflectionValueProvider
System.Attribute
Noemax.Newtonsoft.Json.Serialization.OnErrorAttribute
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
Noemax.Newtonsoft.Json.Serialization.JsonPropertyCollection
System.EventArgs
Noemax.Newtonsoft.Json.Serialization.ErrorEventArgs
System.Runtime.Serialization.SerializationBinder
Noemax.Newtonsoft.Json.Serialization.DefaultSerializationBinder
Noemax.Newtonsoft.Json.Serialization.FlexibleSerializationBinder
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonConvert
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>
Noemax.Newtonsoft.Json.Converters.DataSetConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter
Noemax.Newtonsoft.Json.Converters.DiscriminatedUnionConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter
Noemax.Newtonsoft.Json.Converters.ExpandoObjectConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader
Noemax.Newtonsoft.Json.JsonTextReader
Noemax.Newtonsoft.Json.JsonValidatingReader
Noemax.Newtonsoft.Json.Linq.JTokenReader
Noemax.Newtonsoft.Json.Serialization.TraceJsonReader
Noemax.Newtonsoft.Json.JsonSerializer
Noemax.Newtonsoft.Json.Serialization.JsonSerializerProxy
Noemax.Newtonsoft.Json.JsonSerializerSettings
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter
Noemax.Newtonsoft.Json.JsonTextWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter
Noemax.Newtonsoft.Json.Serialization.TraceJsonWriter
System.Attribute
Noemax.Newtonsoft.Json.JsonConstructorAttribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonArrayAttribute
Noemax.Newtonsoft.Json.JsonDictionaryAttribute
Noemax.Newtonsoft.Json.JsonObjectAttribute
Noemax.Newtonsoft.Json.JsonConverterAttribute
Noemax.Newtonsoft.Json.JsonExtensionDataAttribute
Noemax.Newtonsoft.Json.JsonIgnoreAttribute
Noemax.Newtonsoft.Json.JsonPropertyAttribute
System.Collections.ObjectModel.Collection<T>
Noemax.Newtonsoft.Json.JsonConverterCollection
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonReaderException
Noemax.Newtonsoft.Json.JsonSerializationException
Noemax.Newtonsoft.Json.JsonWriterException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException
See Also

Reference

Noemax.WebSockets.Net4 Assembly


WebSocketCloseEventArgs Constructor

WebSocketCloseEventArgs Constructor

Noemax.WebSockets.Core Namespace > WebSocketCloseEventArgs Class : WebSocketCloseEventArgs Constructor
Overload List
Overload | Description
WebSocketCloseEventArgs Constructor | Creates a new instance of WebSocketCloseEventArgs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketCloseEventArgs Class
WebSocketCloseEventArgs Members


BeginRead Method (WebSocketMessageInputStream)

BeginRead Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : BeginRead Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.IAsyncResult BeginRead(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback callback,
   System.object state
)
public function BeginRead(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.IAsyncResult* BeginRead(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback* callback,
   System.Object* state
)
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.IAsyncResult^ BeginRead(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

buffer
offset
count
callback
state
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


BeginWrite Method (WebSocketMessageInputStream)

BeginWrite Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : BeginWrite Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal callback As System.AsyncCallback, _
   ByVal state As System.Object _
) As System.IAsyncResult
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim callback As System.AsyncCallback
Dim state As System.Object
Dim value As System.IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.IAsyncResult BeginWrite(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback callback,
   System.object state
)
public function BeginWrite(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    callback: System.AsyncCallback;
    state: System.TObject
): System.IAsyncResult; virtual;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   callback : System.AsyncCallback,
   state : System.Object
) : System.IAsyncResult;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.IAsyncResult* BeginWrite(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback* callback,
   System.Object* state
)
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.IAsyncResult^ BeginWrite(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.AsyncCallback^ callback,
   System.Object^ state
)

Parameters

buffer
offset
count
callback
state
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CanRead Property (WebSocketMessageInputStream)

CanRead Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CanRead Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride ReadOnly Property CanRead As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

value = instance.CanRead
[__DynamicallyInvokable()]
public abstract System.bool CanRead {get;}
public read-only property CanRead: System.Boolean; abstract;
__DynamicallyInvokableAttribute()
public __abstract function get CanRead : System.boolean
[__DynamicallyInvokable()]
public: __property abstract System.bool get_CanRead();
[__DynamicallyInvokable()]
public:
abstract property System.bool CanRead {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CanSeek Property (WebSocketMessageInputStream)

CanSeek Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CanSeek Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride ReadOnly Property CanSeek As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

value = instance.CanSeek
[__DynamicallyInvokable()]
public abstract System.bool CanSeek {get;}
public read-only property CanSeek: System.Boolean; abstract;
__DynamicallyInvokableAttribute()
public __abstract function get CanSeek : System.boolean
[__DynamicallyInvokable()]
public: __property abstract System.bool get_CanSeek();
[__DynamicallyInvokable()]
public:
abstract property System.bool CanSeek {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CanTimeout Property (WebSocketMessageInputStream)

CanTimeout Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CanTimeout Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property CanTimeout As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

value = instance.CanTimeout
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public virtual System.bool CanTimeout {get;}
public read-only property CanTimeout: System.Boolean; virtual;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
public function get CanTimeout : System.boolean
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public: __property virtual System.bool get_CanTimeout();
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public:
virtual property System.bool CanTimeout {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CanWrite Property (WebSocketMessageInputStream)

CanWrite Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CanWrite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride ReadOnly Property CanWrite As System.Boolean
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Boolean

value = instance.CanWrite
[__DynamicallyInvokable()]
public abstract System.bool CanWrite {get;}
public read-only property CanWrite: System.Boolean; abstract;
__DynamicallyInvokableAttribute()
public __abstract function get CanWrite : System.boolean
[__DynamicallyInvokable()]
public: __property abstract System.bool get_CanWrite();
[__DynamicallyInvokable()]
public:
abstract property System.bool CanWrite {
   System.bool get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Close Method (WebSocketMessageInputStream)

Close Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Close Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub Close()
'Usage

Dim instance As WebSocketMessageInputStream

instance.Close()
public virtual void Close()
public procedure Close(); virtual;
public function Close();
public: virtual void Close();
public:
virtual void Close();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CopyTo Method (WebSocketMessageInputStream)

CopyTo Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CopyTo Method
Overload List
Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CopyTo(Stream) Method

CopyTo(Stream) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > CopyTo Method : CopyTo(Stream) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Sub CopyTo( _
   ByVal destination As System.IO.Stream _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim destination As System.IO.Stream

instance.CopyTo(destination)
[__DynamicallyInvokable()]
public void CopyTo(
   System.IO.Stream destination
)
public procedure CopyTo(
    destination: System.IO.Stream
);
__DynamicallyInvokableAttribute()
public function CopyTo(
   destination : System.IO.Stream
);
[__DynamicallyInvokable()]
public: void CopyTo(
   System.IO.Stream* destination
)
[__DynamicallyInvokable()]
public:
void CopyTo(
   System.IO.Stream^ destination
)

Parameters

destination
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


CopyTo(Stream,Int32) Method

CopyTo(Stream,Int32) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overloads Sub CopyTo( _
   ByVal destination As System.IO.Stream, _
   ByVal bufferSize As System.Integer _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim destination As System.IO.Stream
Dim bufferSize As System.Integer

instance.CopyTo(destination, bufferSize)
[__DynamicallyInvokable()]
public void CopyTo(
   System.IO.Stream destination,
   System.int bufferSize
)
public procedure CopyTo(
    destination: System.IO.Stream;
    bufferSize: System.Integer
);
__DynamicallyInvokableAttribute()
public function CopyTo(
   destination : System.IO.Stream,
   bufferSize : System.int
);
[__DynamicallyInvokable()]
public: void CopyTo(
   System.IO.Stream* destination,
   System.int bufferSize
)
[__DynamicallyInvokable()]
public:
void CopyTo(
   System.IO.Stream^ destination,
   System.int bufferSize
)

Parameters

destination
bufferSize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


CopyToAsync Method (WebSocketMessageInputStream)

CopyToAsync Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CopyToAsync Method
Overload List
Overload | Description
CopyToAsync(Stream) | (Inherited from System.IO.Stream)
CopyToAsync(Stream,Int32) | (Inherited from System.IO.Stream)
CopyToAsync(Stream,Int32,CancellationToken) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CopyToAsync(Stream) Method

CopyToAsync(Stream) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > CopyToAsync Method : CopyToAsync(Stream) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Function CopyToAsync( _
   ByVal destination As System.IO.Stream _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim destination As System.IO.Stream
Dim value As System.Threading.Tasks.Task

value = instance.CopyToAsync(destination)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public System.Threading.Tasks.Task CopyToAsync(
   System.IO.Stream destination
)
public function CopyToAsync(
    destination: System.IO.Stream
): System.Threading.Tasks.Task;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function CopyToAsync(
   destination : System.IO.Stream
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: System.Threading.Tasks.Task* CopyToAsync(
   System.IO.Stream* destination
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
System.Threading.Tasks.Task^ CopyToAsync(
   System.IO.Stream^ destination
)

Parameters

destination
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


CopyToAsync(Stream,Int32) Method

CopyToAsync(Stream,Int32) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > CopyToAsync Method : CopyToAsync(Stream,Int32) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Function CopyToAsync( _
   ByVal destination As System.IO.Stream, _
   ByVal bufferSize As System.Integer _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim destination As System.IO.Stream
Dim bufferSize As System.Integer
Dim value As System.Threading.Tasks.Task

value = instance.CopyToAsync(destination, bufferSize)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public System.Threading.Tasks.Task CopyToAsync(
   System.IO.Stream destination,
   System.int bufferSize
)
public function CopyToAsync(
    destination: System.IO.Stream;
    bufferSize: System.Integer
): System.Threading.Tasks.Task;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function CopyToAsync(
   destination : System.IO.Stream,
   bufferSize : System.int
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: System.Threading.Tasks.Task* CopyToAsync(
   System.IO.Stream* destination,
   System.int bufferSize
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
System.Threading.Tasks.Task^ CopyToAsync(
   System.IO.Stream^ destination,
   System.int bufferSize
)

Parameters

destination
bufferSize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


CopyToAsync(Stream,Int32,CancellationToken) Method

CopyToAsync(Stream,Int32,CancellationToken) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > CopyToAsync Method : CopyToAsync(Stream,Int32,CancellationToken) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Overridable Function CopyToAsync( _
   ByVal destination As System.IO.Stream, _
   ByVal bufferSize As System.Integer, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim destination As System.IO.Stream
Dim bufferSize As System.Integer
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.CopyToAsync(destination, bufferSize, cancellationToken)
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.Threading.Tasks.Task CopyToAsync(
   System.IO.Stream destination,
   System.int bufferSize,
   System.Threading.CancellationToken cancellationToken
)
public function CopyToAsync(
    destination: System.IO.Stream;
    bufferSize: System.Integer;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.InteropServices.ComVisibleAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function CopyToAsync(
   destination : System.IO.Stream,
   bufferSize : System.int,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.Threading.Tasks.Task* CopyToAsync(
   System.IO.Stream* destination,
   System.int bufferSize,
   System.Threading.CancellationToken cancellationToken
)
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.Threading.Tasks.Task^ CopyToAsync(
   System.IO.Stream^ destination,
   System.int bufferSize,
   System.Threading.CancellationToken cancellationToken
)

Parameters

destination
bufferSize
cancellationToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


CreateObjRef Method (WebSocketMessageInputStream)

CreateObjRef Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
'Usage

Dim instance As WebSocketMessageInputStream
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
[System.Security.SecurityCritical()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
[System.Security.SecurityCritical()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
[System.Security.SecurityCritical()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


CreateWaitHandle Method (WebSocketMessageInputStream)

CreateWaitHandle Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : CreateWaitHandle Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As System.Threading.WaitHandle
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Threading.WaitHandle

value = instance.CreateWaitHandle()
[System.Obsolete("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual System.Threading.WaitHandle CreateWaitHandle()
protected function CreateWaitHandle(): System.Threading.WaitHandle; virtual;
System.ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : System.Threading.WaitHandle;
[System.Obsolete("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual System.Threading.WaitHandle* CreateWaitHandle();
[System.Obsolete("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual System.Threading.WaitHandle^ CreateWaitHandle();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Dispose Method (WebSocketMessageInputStream)

Dispose Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Dispose Method
Overload List
Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Dispose() Method

Dispose() Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > Dispose Method : Dispose() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
'Usage

Dim instance As WebSocketMessageInputStream

instance.Dispose()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
public procedure Dispose();
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


Dispose(Boolean) Method

Dispose(Boolean) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > Dispose Method : Dispose(Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As System.Boolean _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim disposing As System.Boolean

instance.Dispose(disposing)
[__DynamicallyInvokable()]
protected virtual void Dispose(
   System.bool disposing
)
protected procedure Dispose(
    disposing: System.Boolean
); virtual;
__DynamicallyInvokableAttribute()
protected function Dispose(
   disposing : System.boolean
);
[__DynamicallyInvokable()]
protected: virtual void Dispose(
   System.bool disposing
)
[__DynamicallyInvokable()]
protected:
virtual void Dispose(
   System.bool disposing
)

Parameters

disposing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


EndRead Method (WebSocketMessageInputStream)

EndRead Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : EndRead Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function EndRead( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim asyncResult As System.IAsyncResult
Dim value As System.Integer

value = instance.EndRead(asyncResult)
[__DynamicallyInvokable()]
public virtual System.int EndRead(
   System.IAsyncResult asyncResult
)
public function EndRead(
    asyncResult: System.IAsyncResult
): System.Integer; virtual;
__DynamicallyInvokableAttribute()
public function EndRead(
   asyncResult : System.IAsyncResult
) : System.int;
[__DynamicallyInvokable()]
public: virtual System.int EndRead(
   System.IAsyncResult* asyncResult
)
[__DynamicallyInvokable()]
public:
virtual System.int EndRead(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


EndWrite Method (WebSocketMessageInputStream)

EndWrite Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : EndWrite Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Sub EndWrite( _
   ByVal asyncResult As System.IAsyncResult _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim asyncResult As System.IAsyncResult

instance.EndWrite(asyncResult)
[__DynamicallyInvokable()]
public virtual void EndWrite(
   System.IAsyncResult asyncResult
)
public procedure EndWrite(
    asyncResult: System.IAsyncResult
); virtual;
__DynamicallyInvokableAttribute()
public function EndWrite(
   asyncResult : System.IAsyncResult
);
[__DynamicallyInvokable()]
public: virtual void EndWrite(
   System.IAsyncResult* asyncResult
)
[__DynamicallyInvokable()]
public:
virtual void EndWrite(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Flush Method (WebSocketMessageInputStream)

Flush Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Flush Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Sub Flush()
'Usage

Dim instance As WebSocketMessageInputStream

instance.Flush()
[__DynamicallyInvokable()]
public abstract void Flush()
public procedure Flush(); abstract;
__DynamicallyInvokableAttribute()
public __abstract function Flush();
[__DynamicallyInvokable()]
public: abstract void Flush();
[__DynamicallyInvokable()]
public:
abstract void Flush();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


FlushAsync Method (WebSocketMessageInputStream)

FlushAsync Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : FlushAsync Method
Overload List
Overload | Description
FlushAsync() | (Inherited from System.IO.Stream)
FlushAsync(CancellationToken) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


FlushAsync() Method

FlushAsync() Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > FlushAsync Method : FlushAsync() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Function FlushAsync() As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Threading.Tasks.Task

value = instance.FlushAsync()
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public System.Threading.Tasks.Task FlushAsync()
public function FlushAsync(): System.Threading.Tasks.Task;
__DynamicallyInvokableAttribute()
System.Runtime.InteropServices.ComVisibleAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function FlushAsync() : System.Threading.Tasks.Task;
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: System.Threading.Tasks.Task* FlushAsync();
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
System.Threading.Tasks.Task^ FlushAsync();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


FlushAsync(CancellationToken) Method

FlushAsync(CancellationToken) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > FlushAsync Method : FlushAsync(CancellationToken) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Overridable Function FlushAsync( _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.FlushAsync(cancellationToken)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.Threading.Tasks.Task FlushAsync(
   System.Threading.CancellationToken cancellationToken
)
public function FlushAsync(
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task; virtual;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function FlushAsync(
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.Threading.Tasks.Task* FlushAsync(
   System.Threading.CancellationToken cancellationToken
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.Threading.Tasks.Task^ FlushAsync(
   System.Threading.CancellationToken cancellationToken
)

Parameters

cancellationToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


GetLifetimeService Method (WebSocketMessageInputStream)

GetLifetimeService Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Object

value = instance.GetLifetimeService()
[System.Security.SecurityCritical()]
public System.object GetLifetimeService()
public function GetLifetimeService(): System.TObject;
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
[System.Security.SecurityCritical()]
public: System.Object* GetLifetimeService();
[System.Security.SecurityCritical()]
public:
System.Object^ GetLifetimeService();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


InitializeLifetimeService Method (WebSocketMessageInputStream)

InitializeLifetimeService Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Object

value = instance.InitializeLifetimeService()
[System.Security.SecurityCritical()]
public virtual System.object InitializeLifetimeService()
public function InitializeLifetimeService(): System.TObject; virtual;
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
[System.Security.SecurityCritical()]
public: virtual System.Object* InitializeLifetimeService();
[System.Security.SecurityCritical()]
public:
virtual System.Object^ InitializeLifetimeService();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Length Property (WebSocketMessageInputStream)

Length Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Length Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride ReadOnly Property Length As System.Long
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Long

value = instance.Length
[__DynamicallyInvokable()]
public abstract System.long Length {get;}
public read-only property Length: System.Int64; abstract;
__DynamicallyInvokableAttribute()
public __abstract function get Length : System.long
[__DynamicallyInvokable()]
public: __property abstract System.long get_Length();
[__DynamicallyInvokable()]
public:
abstract property System.int64 Length {
   System.int64 get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


MemberwiseClone Method (WebSocketMessageInputStream)

MemberwiseClone Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : MemberwiseClone Method
Overload List
Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


MemberwiseClone(Boolean) Method

MemberwiseClone(Boolean) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As System.Boolean _
) As System.MarshalByRefObject
'Usage

Dim instance As WebSocketMessageInputStream
Dim cloneIdentity As System.Boolean
Dim value As System.MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
protected System.MarshalByRefObject MemberwiseClone(
   System.bool cloneIdentity
)
protected function MemberwiseClone(
    cloneIdentity: System.Boolean
): System.MarshalByRefObject;
protected function MemberwiseClone(
   cloneIdentity : System.boolean
) : System.MarshalByRefObject;
protected: System.MarshalByRefObject* MemberwiseClone(
   System.bool cloneIdentity
)
protected:
System.MarshalByRefObject^ MemberwiseClone(
   System.bool cloneIdentity
)

Parameters

cloneIdentity
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


ObjectInvariant Method (WebSocketMessageInputStream)

ObjectInvariant Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : ObjectInvariant Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.ObsoleteAttribute("Do not call or override this method.")>
Protected Overridable Sub ObjectInvariant()
'Usage

Dim instance As WebSocketMessageInputStream

instance.ObjectInvariant()
[System.Obsolete("Do not call or override this method.")]
protected virtual void ObjectInvariant()
protected procedure ObjectInvariant(); virtual;
System.ObsoleteAttribute("Do not call or override this method.")
protected function ObjectInvariant();
[System.Obsolete("Do not call or override this method.")]
protected: virtual void ObjectInvariant();
[System.Obsolete("Do not call or override this method.")]
protected:
virtual void ObjectInvariant();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Position Property (WebSocketMessageInputStream)

Position Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Position Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Property Position As System.Long
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Long

instance.Position = value

value = instance.Position
[__DynamicallyInvokable()]
public abstract System.long Position {get; set;}
public read-write property Position: System.Int64; abstract;
__DynamicallyInvokableAttribute()
public __abstract function get,set Position : System.long
[__DynamicallyInvokable()]
public: __property abstract System.long get_Position();
public: __property abstract void set_Position(
   System.long value
);
[__DynamicallyInvokable()]
public:
abstract property System.int64 Position {
   System.int64 get();
   void set (    System.int64 value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Read Method (WebSocketMessageInputStream)

Read Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Read Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Function Read( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
) As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim value As System.Integer

value = instance.Read(buffer, offset, count)
[__DynamicallyInvokable()]
public abstract System.int Read(
   out System.byte[] buffer,
   System.int offset,
   System.int count
)
public function Read(
   Out  buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
): System.Integer; abstract;
__DynamicallyInvokableAttribute()
public __abstract function Read(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
) : System.int;
[__DynamicallyInvokable()]
public: abstract System.int Read(
   [PARAMFLAG::Out] System.byte[]* buffer,
   System.int offset,
   System.int count
)
[__DynamicallyInvokable()]
public:
abstract System.int Read(
   [Out] System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
offset
count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


ReadAsync Method (WebSocketMessageInputStream)

ReadAsync Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : ReadAsync Method
Overload List
Overload | Description
ReadAsync(Byte[],Int32,Int32) | (Inherited from System.IO.Stream)
ReadAsync(Byte[],Int32,Int32,CancellationToken) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


ReadAsync(Byte[],Int32,Int32) Method

ReadAsync(Byte[],Int32,Int32) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > ReadAsync Method : ReadAsync(Byte[],Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Function ReadAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
) As System.Threading.Tasks.Task(Of Integer)
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim value As System.Threading.Tasks.Task(Of Integer)

value = instance.ReadAsync(buffer, offset, count)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public System.Threading.Tasks.Task<int> ReadAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public function ReadAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
): System.Threading.Tasks.Task;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function ReadAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: System.Threading.Tasks.Task<int>* ReadAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
System.Threading.Tasks.Task<int>^ ReadAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
offset
count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


ReadAsync(Byte[],Int32,Int32,CancellationToken) Method

ReadAsync(Byte[],Int32,Int32,CancellationToken) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > ReadAsync Method : ReadAsync(Byte[],Int32,Int32,CancellationToken) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Overridable Function ReadAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task(Of Integer)
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task(Of Integer)

value = instance.ReadAsync(buffer, offset, count, cancellationToken)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.Threading.Tasks.Task<int> ReadAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)
public function ReadAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task; virtual;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function ReadAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.Threading.Tasks.Task<int>* ReadAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.Threading.Tasks.Task<int>^ ReadAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)

Parameters

buffer
offset
count
cancellationToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


ReadByte Method (WebSocketMessageInputStream)

ReadByte Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : ReadByte Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Overridable Function ReadByte() As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Integer

value = instance.ReadByte()
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public virtual System.int ReadByte()
public function ReadByte(): System.Integer; virtual;
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function ReadByte() : System.int;
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public: virtual System.int ReadByte();
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokable()]
public:
virtual System.int ReadByte();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


ReadTimeout Property (WebSocketMessageInputStream)

ReadTimeout Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : ReadTimeout Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Overridable Property ReadTimeout As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
public virtual System.int ReadTimeout {get; set;}
public read-write property ReadTimeout: System.Integer; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set ReadTimeout : System.int
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
public: __property virtual System.int get_ReadTimeout();
public: __property virtual void set_ReadTimeout(
   System.int value
);
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
public:
virtual property System.int ReadTimeout {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Seek Method (WebSocketMessageInputStream)

Seek Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Seek Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Function Seek( _
   ByVal offset As System.Long, _
   ByVal origin As System.IO.SeekOrigin _
) As System.Long
'Usage

Dim instance As WebSocketMessageInputStream
Dim offset As System.Long
Dim origin As System.IO.SeekOrigin
Dim value As System.Long

value = instance.Seek(offset, origin)
[__DynamicallyInvokable()]
public abstract System.long Seek(
   System.long offset,
   System.IO.SeekOrigin origin
)
public function Seek(
    offset: System.Int64;
    origin: System.IO.SeekOrigin
): System.Int64; abstract;
__DynamicallyInvokableAttribute()
public __abstract function Seek(
   offset : System.long,
   origin : System.IO.SeekOrigin
) : System.long;
[__DynamicallyInvokable()]
public: abstract System.long Seek(
   System.long offset,
   System.IO.SeekOrigin origin
)
[__DynamicallyInvokable()]
public:
abstract System.int64 Seek(
   System.int64 offset,
   System.IO.SeekOrigin origin
)

Parameters

offset
origin
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


SetLength Method (WebSocketMessageInputStream)

SetLength Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : SetLength Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Sub SetLength( _
   ByVal value As System.Long _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Long

instance.SetLength(value)
[__DynamicallyInvokable()]
public abstract void SetLength(
   System.long value
)
public procedure SetLength(
    value: System.Int64
); abstract;
__DynamicallyInvokableAttribute()
public __abstract function SetLength(
   value : System.long
);
[__DynamicallyInvokable()]
public: abstract void SetLength(
   System.long value
)
[__DynamicallyInvokable()]
public:
abstract void SetLength(
   System.int64 value
)

Parameters

value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


Write Method (WebSocketMessageInputStream)

Write Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : Write Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public MustOverride Sub Write( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer

instance.Write(buffer, offset, count)
[__DynamicallyInvokable()]
public abstract void Write(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public procedure Write(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
); abstract;
__DynamicallyInvokableAttribute()
public __abstract function Write(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
);
[__DynamicallyInvokable()]
public: abstract void Write(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
[__DynamicallyInvokable()]
public:
abstract void Write(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
offset
count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WriteAsync Method (WebSocketMessageInputStream)

WriteAsync Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : WriteAsync Method
Overload List
Overload | Description
WriteAsync(Byte[],Int32,Int32) | (Inherited from System.IO.Stream)
WriteAsync(Byte[],Int32,Int32,CancellationToken) | (Inherited from System.IO.Stream)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WriteAsync(Byte[],Int32,Int32) Method

WriteAsync(Byte[],Int32,Int32) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > WriteAsync Method : WriteAsync(Byte[],Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Function WriteAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim value As System.Threading.Tasks.Task

value = instance.WriteAsync(buffer, offset, count)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public System.Threading.Tasks.Task WriteAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count
)
public function WriteAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer
): System.Threading.Tasks.Task;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function WriteAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int
) : System.Threading.Tasks.Task;
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: System.Threading.Tasks.Task* WriteAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count
)
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
System.Threading.Tasks.Task^ WriteAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count
)

Parameters

buffer
offset
count
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


WriteAsync(Byte[],Int32,Int32,CancellationToken) Method

WriteAsync(Byte[],Int32,Int32,CancellationToken) Method

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class > WriteAsync Method : WriteAsync(Byte[],Int32,Int32,CancellationToken) Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overloads Overridable Function WriteAsync( _
   ByVal buffer() As System.Byte, _
   ByVal offset As System.Integer, _
   ByVal count As System.Integer, _
   ByVal cancellationToken As System.Threading.CancellationToken _
) As System.Threading.Tasks.Task
'Usage

Dim instance As WebSocketMessageInputStream
Dim buffer() As System.Byte
Dim offset As System.Integer
Dim count As System.Integer
Dim cancellationToken As System.Threading.CancellationToken
Dim value As System.Threading.Tasks.Task

value = instance.WriteAsync(buffer, offset, count, cancellationToken)
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual System.Threading.Tasks.Task WriteAsync(
   System.byte[] buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)
public function WriteAsync(
    buffer: System.Bytearray of;
    offset: System.Integer;
    count: System.Integer;
    cancellationToken: System.Threading.CancellationToken
): System.Threading.Tasks.Task; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.InteropServices.ComVisibleAttribute()
System.Security.Permissions.HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function WriteAsync(
   buffer : System.byte[],
   offset : System.int,
   count : System.int,
   cancellationToken : System.Threading.CancellationToken
) : System.Threading.Tasks.Task;
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual System.Threading.Tasks.Task* WriteAsync(
   System.byte[]* buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)
[__DynamicallyInvokable()]
[System.Runtime.InteropServices.ComVisible(false)]
[System.Security.Permissions.HostProtection(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual System.Threading.Tasks.Task^ WriteAsync(
   System.array<byte>^ buffer,
   System.int offset,
   System.int count,
   System.Threading.CancellationToken cancellationToken
)

Parameters

buffer
offset
count
cancellationToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members
Overload List


WriteByte Method (WebSocketMessageInputStream)

WriteByte Method (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : WriteByte Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Sub WriteByte( _
   ByVal value As System.Byte _
)
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Byte

instance.WriteByte(value)
[__DynamicallyInvokable()]
public virtual void WriteByte(
   System.byte value
)
public procedure WriteByte(
    value: System.Byte
); virtual;
__DynamicallyInvokableAttribute()
public function WriteByte(
   value : System.byte
);
[__DynamicallyInvokable()]
public: virtual void WriteByte(
   System.byte value
)
[__DynamicallyInvokable()]
public:
virtual void WriteByte(
   System.byte value
)

Parameters

value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WriteTimeout Property (WebSocketMessageInputStream)

WriteTimeout Property (WebSocketMessageInputStream)

Noemax.WebSockets.Core Namespace > WebSocketMessageInputStream Class : WriteTimeout Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Runtime.InteropServices.ComVisibleAttribute(False)>
<__DynamicallyInvokableAttribute()>
Public Overridable Property WriteTimeout As System.Integer
'Usage

Dim instance As WebSocketMessageInputStream
Dim value As System.Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public virtual System.int WriteTimeout {get; set;}
public read-write property WriteTimeout: System.Integer; virtual;
System.Runtime.InteropServices.ComVisibleAttribute()
__DynamicallyInvokableAttribute()
public function get,set WriteTimeout : System.int
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public: __property virtual System.int get_WriteTimeout();
public: __property virtual void set_WriteTimeout(
   System.int value
);
[System.Runtime.InteropServices.ComVisible(false)]
[__DynamicallyInvokable()]
public:
virtual property System.int WriteTimeout {
   System.int get();
   void set (    System.int value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketMessageInputStream Class
WebSocketMessageInputStream Members


WebSocketPingOrPongEventArgs Class Properties

WebSocketPingOrPongEventArgs Class Properties

Noemax.WebSockets.Core Namespace : WebSocketPingOrPongEventArgs Class

For a list of all members of this type, see WebSocketPingOrPongEventArgs members.

Public Properties
 | Name | Description
Public Property | OpCode | Gets the OpCode associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Public Property | Payload | Get the payload associated to the control frame. (Inherited from Noemax.WebSockets.Core.ControlFrameEventArgs)
Top
See Also

Reference

WebSocketPingOrPongEventArgs Class
Noemax.WebSockets.Core Namespace


WriteMessage Method (WebSocket)

WriteMessage Method (WebSocket)

Noemax.WebSockets.Core Namespace > WebSocket Class : WriteMessage Method
Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Overload List
Overload | Description
WriteMessage | Creates a input writing message payload into WebSocket connection as a sequence of fragment frames.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocket Class
WebSocket Members


Noemax.WebSockets.Core Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.WebSockets.Core Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Core.WebSocket
Noemax.WebSockets.Core.WebSocketImpl
Noemax.WebSockets.Core.WebSocketClientSecurity
Noemax.WebSockets.Core.WebSocketCloseCodes
Noemax.WebSockets.Core.WebSocketFactory
Noemax.WebSockets.Core.WebSocketListener
System.EventArgs
Noemax.WebSockets.Core.ControlFrameEventArgs
Noemax.WebSockets.Core.WebSocketCloseEventArgs
Noemax.WebSockets.Core.WebSocketPingOrPongEventArgs
Noemax.WebSockets.Core.UsernamePasswordAuthenticateEventArgs
Noemax.WebSockets.Core.WebSocketErrorEventArgs
System.MarshalByRefObject
System.IO.Stream
Noemax.WebSockets.Core.WebSocketMessageInputStream
Noemax.WebSockets.Core.WebSocketFrameReader.WebSocketMessageInputStreamImpl
Noemax.WebSockets.Messaging.CompressedMessageSerializer.CompressedInputStream
See Also

Reference

Noemax.WebSockets.Net4 Assembly


ActionInvoker<T> Class Methods

ActionInvoker<T> Class Methods

Noemax.WebSockets.Messaging Namespace : ActionInvoker<T> Class

For a list of all members of this type, see ActionInvoker<T> members.

Public Methods
 | Name | Description
Public Method | Invoke | (Inherited from Noemax.WebSockets.Messaging.RequestInvoker)
Top
Protected Methods
 | Name | Description
Protected Method | OnInvoke | Overloaded. Invokes the local message operation handler. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker)
Top
See Also

Reference

ActionInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


ActionOperation1Invoker<T> Class Properties

ActionOperation1Invoker<T> Class Properties

Noemax.WebSockets.Messaging Namespace : ActionOperation1Invoker<T> Class

For a list of all members of this type, see ActionOperation1Invoker<T> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the type list of types accepted by invoker. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Public Property | KnownTypes | Gets the list of types that must be known by the serializer. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Top
See Also

Reference

ActionOperation1Invoker<T> Class
Noemax.WebSockets.Messaging Namespace


ActionOperationInvoker<T> Class Properties

ActionOperationInvoker<T> Class Properties

Noemax.WebSockets.Messaging Namespace : ActionOperationInvoker<T> Class

For a list of all members of this type, see ActionOperationInvoker<T> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the type list of types accepted by invoker. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Public Property | KnownTypes | Gets the list of types that must be known by the serializer. (Inherited from Noemax.WebSockets.Messaging.ActionInvoker<T>)
Top
See Also

Reference

ActionOperationInvoker<T> Class
Noemax.WebSockets.Messaging Namespace


ConversationMessage Class Methods

ConversationMessage Class Methods

Noemax.WebSockets.Messaging Namespace : ConversationMessage Class

For a list of all members of this type, see ConversationMessage members.

Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Top
See Also

Reference

ConversationMessage Class
Noemax.WebSockets.Messaging Namespace


FuncOperation1Invoker<TResult,T> Class Properties

FuncOperation1Invoker<TResult,T> Class Properties

Noemax.WebSockets.Messaging Namespace : FuncOperation1Invoker<TResult,T> Class

For a list of all members of this type, see FuncOperation1Invoker<TResult,T> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Top
See Also

Reference

FuncOperation1Invoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


FuncOperationInvoker<TResult,T> Class Properties

FuncOperationInvoker<TResult,T> Class Properties

Noemax.WebSockets.Messaging Namespace : FuncOperationInvoker<TResult,T> Class

For a list of all members of this type, see FuncOperationInvoker<TResult,T> members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.FuncInvoker<TResult,T>)
Top
See Also

Reference

FuncOperationInvoker<TResult,T> Class
Noemax.WebSockets.Messaging Namespace


MessageOperationAttribute Class Methods

MessageOperationAttribute Class Methods

Noemax.WebSockets.Messaging Namespace : MessageOperationAttribute Class

For a list of all members of this type, see MessageOperationAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

MessageOperationAttribute Class
Noemax.WebSockets.Messaging Namespace


Equals Method (MessageOperationAttribute)

Equals Method (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As MessageOperationAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


GetHashCode Method (MessageOperationAttribute)

GetHashCode Method (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
'Usage

Dim instance As MessageOperationAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.int GetHashCode()
public function GetHashCode(): System.Integer; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


IsDefaultAttribute Method (MessageOperationAttribute)

IsDefaultAttribute Method (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As MessageOperationAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public virtual System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean; virtual;
public function IsDefaultAttribute() : System.boolean;
public: virtual System.bool IsDefaultAttribute();
public:
virtual System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


Match Method (MessageOperationAttribute)

Match Method (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As MessageOperationAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public virtual System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
public function Match(
   obj : System.Object
) : System.boolean;
public: virtual System.bool Match(
   System.Object* obj
)
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


TypeId Property (MessageOperationAttribute)

TypeId Property (MessageOperationAttribute)

Noemax.WebSockets.Messaging Namespace > MessageOperationAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
'Usage

Dim instance As MessageOperationAttribute
Dim value As System.Object

value = instance.TypeId
public virtual System.object TypeId {get;}
public read-only property TypeId: System.TObject; virtual;
public function get TypeId : System.Object
public: __property virtual System.Object* get_TypeId();
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessageOperationAttribute Class
MessageOperationAttribute Members


MessagingContractAttribute Class Methods

MessagingContractAttribute Class Methods

Noemax.WebSockets.Messaging Namespace : MessagingContractAttribute Class

For a list of all members of this type, see MessagingContractAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

MessagingContractAttribute Class
Noemax.WebSockets.Messaging Namespace


MessagingContractAttribute Class Properties

MessagingContractAttribute Class Properties

Noemax.WebSockets.Messaging Namespace : MessagingContractAttribute Class

For a list of all members of this type, see MessagingContractAttribute members.

Public Properties
 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

MessagingContractAttribute Class
Noemax.WebSockets.Messaging Namespace


Equals Method (MessagingContractAttribute)

Equals Method (MessagingContractAttribute)

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As MessagingContractAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Equals(obj)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.bool Equals(
   System.object obj
)
public function Equals(
    obj: System.TObject
): System.Boolean; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function Equals(
   obj : System.Object
) : System.boolean;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.bool Equals(
   System.Object* obj
)
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.bool Equals(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


GetHashCode Method (MessagingContractAttribute)

GetHashCode Method (MessagingContractAttribute)

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecuritySafeCriticalAttribute()>
<__DynamicallyInvokableAttribute()>
Public Overridable Function GetHashCode() As System.Integer
'Usage

Dim instance As MessagingContractAttribute
Dim value As System.Integer

value = instance.GetHashCode()
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public virtual System.int GetHashCode()
public function GetHashCode(): System.Integer; virtual;
System.Security.SecuritySafeCriticalAttribute()
__DynamicallyInvokableAttribute()
public function GetHashCode() : System.int;
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public: virtual System.int GetHashCode();
[System.Security.SecuritySafeCritical()]
[__DynamicallyInvokable()]
public:
virtual System.int GetHashCode();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


IsDefaultAttribute Method (MessagingContractAttribute)

IsDefaultAttribute Method (MessagingContractAttribute)

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
'Usage

Dim instance As MessagingContractAttribute
Dim value As System.Boolean

value = instance.IsDefaultAttribute()
public virtual System.bool IsDefaultAttribute()
public function IsDefaultAttribute(): System.Boolean; virtual;
public function IsDefaultAttribute() : System.boolean;
public: virtual System.bool IsDefaultAttribute();
public:
virtual System.bool IsDefaultAttribute();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


Match Method (MessagingContractAttribute)

Match Method (MessagingContractAttribute)

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
'Usage

Dim instance As MessagingContractAttribute
Dim obj As System.Object
Dim value As System.Boolean

value = instance.Match(obj)
public virtual System.bool Match(
   System.object obj
)
public function Match(
    obj: System.TObject
): System.Boolean; virtual;
public function Match(
   obj : System.Object
) : System.boolean;
public: virtual System.bool Match(
   System.Object* obj
)
public:
virtual System.bool Match(
   System.Object^ obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


TypeId Property (MessagingContractAttribute)

TypeId Property (MessagingContractAttribute)

Noemax.WebSockets.Messaging Namespace > MessagingContractAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
'Usage

Dim instance As MessagingContractAttribute
Dim value As System.Object

value = instance.TypeId
public virtual System.object TypeId {get;}
public read-only property TypeId: System.TObject; virtual;
public function get TypeId : System.Object
public: __property virtual System.Object* get_TypeId();
public:
virtual property System.Object^ TypeId {
   System.Object^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MessagingContractAttribute Class
MessagingContractAttribute Members


MultiFormatMessagingService Class Properties

MultiFormatMessagingService Class Properties

Noemax.WebSockets.Messaging Namespace : MultiFormatMessagingService Class

For a list of all members of this type, see MultiFormatMessagingService members.

Public Properties
 | Name | Description
Public Property | ChannelCount | Gets the number of channels associated to the service instance. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | Encoding | Gets and sets the Encoding instance that is used for decoding text messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | MaxReceivedMessageSize | Gets and sets the maximum message size limit for inbound messages. (Inherited from Noemax.WebSockets.WebSocketService)
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketService)
Top
See Also

Reference

MultiFormatMessagingService Class
Noemax.WebSockets.Messaging Namespace


PlainMessage Class Methods

PlainMessage Class Methods

Noemax.WebSockets.Messaging Namespace : PlainMessage Class

For a list of all members of this type, see PlainMessage members.

Public Methods
 | Name | Description
Public Method | GetBody<T> | Gets the body of the message and convert it to the specified type. (Inherited from Noemax.WebSockets.Messaging.EnvelopedMessage)
Top
See Also

Reference

PlainMessage Class
Noemax.WebSockets.Messaging Namespace


Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Messaging.Pom.WebSocketChannelExtensionsPom
See Also

Reference

Noemax.WebSockets.Net4 Assembly


RequestInvoker Class Properties

RequestInvoker Class Properties

Noemax.WebSockets.Messaging Namespace : RequestInvoker Class

For a list of all members of this type, see RequestInvoker members.

Public Properties
 | Name | Description
Public Property | InputTypes | Gets the list of the types accepted by Invoker as parameters for calling the target method. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

RequestInvoker Class
Noemax.WebSockets.Messaging Namespace


RpcFaultException Class Events

RpcFaultException Class Events

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class

For a list of all members of this type, see RpcFaultException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

RpcFaultException Class
Noemax.WebSockets.Messaging Namespace


RpcFaultException Class Methods

RpcFaultException Class Methods

Noemax.WebSockets.Messaging Namespace : RpcFaultException Class

For a list of all members of this type, see RpcFaultException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

RpcFaultException Class
Noemax.WebSockets.Messaging Namespace


Data Property (RpcFaultException)

Data Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As RpcFaultException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


GetBaseException Method (RpcFaultException)

GetBaseException Method (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As RpcFaultException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


GetObjectData Method (RpcFaultException)

GetObjectData Method (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As RpcFaultException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


GetType Method (RpcFaultException)

GetType Method (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


GetType() Method

GetType() Method

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As RpcFaultException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


HelpLink Property (RpcFaultException)

HelpLink Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As RpcFaultException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


HResult Property (RpcFaultException)

HResult Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As RpcFaultException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


InnerException Property (RpcFaultException)

InnerException Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As RpcFaultException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


Message Property (RpcFaultException)

Message Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As RpcFaultException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


SerializeObjectState Event (RpcFaultException)

SerializeObjectState Event (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As RpcFaultException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


Source Property (RpcFaultException)

Source Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As RpcFaultException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


StackTrace Property (RpcFaultException)

StackTrace Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As RpcFaultException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


TargetSite Property (RpcFaultException)

TargetSite Property (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As RpcFaultException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


ToString Method (RpcFaultException)

ToString Method (RpcFaultException)

Noemax.WebSockets.Messaging Namespace > RpcFaultException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As RpcFaultException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

RpcFaultException Class
RpcFaultException Members


VoidInputOperationInvoker1<TResult> Class Properties

VoidInputOperationInvoker1<TResult> Class Properties

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker1<TResult> Class

For a list of all members of this type, see VoidInputOperationInvoker1<TResult> members.

Public Properties
 | Name | Description
Public Property | InputTypes | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

VoidInputOperationInvoker1<TResult> Class
Noemax.WebSockets.Messaging Namespace


VoidInputOperationInvoker<TResult> Class Properties

VoidInputOperationInvoker<TResult> Class Properties

Noemax.WebSockets.Messaging Namespace : VoidInputOperationInvoker<TResult> Class

For a list of all members of this type, see VoidInputOperationInvoker<TResult> members.

Public Properties
 | Name | Description
Public Property | InputTypes | (Inherited from Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>)
Public Property | KnownTypes | Gets a list of known types that must be registered with IMessageSerializer. (Inherited from Noemax.WebSockets.Messaging.Invoker)
Top
See Also

Reference

VoidInputOperationInvoker<TResult> Class
Noemax.WebSockets.Messaging Namespace


Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Messaging.CompressedMessageSerializer
Noemax.WebSockets.Messaging.DefaultClientDispatcher
Noemax.WebSockets.Messaging.EnvelopedMessage
Noemax.WebSockets.Messaging.ConversationMessage
Noemax.WebSockets.Messaging.FaultMessage
Noemax.WebSockets.Messaging.PlainMessage
Noemax.WebSockets.Messaging.RequestMessage
Noemax.WebSockets.Messaging.ResponseMessage
Noemax.WebSockets.Messaging.JsonMessageSerializer.JsonResponseMessage
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.DefaultMessageDispatcher.ResponseInvoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker<T>
Noemax.WebSockets.Messaging.ActionOperationInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker
Noemax.WebSockets.Messaging.ActionOperationInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.FuncOperation1Invoker<TResult,T>
Noemax.WebSockets.Messaging.FuncOperationInvoker<TResult,T>
Noemax.WebSockets.Messaging.ReflectionInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker1<TResult>
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.ActionInvokerFactory
Noemax.WebSockets.Messaging.FuncInvokerFactory
Noemax.WebSockets.Messaging.ReflectionInvokerFactory
Noemax.WebSockets.Messaging.VoidInputInvokerFactory
Noemax.WebSockets.Messaging.JsonClientProxyProvider
Noemax.WebSockets.Messaging.MessageDispatcher
Noemax.WebSockets.Messaging.DefaultMessageDispatcher
Noemax.WebSockets.Messaging.MessageOperationDescription
Noemax.WebSockets.Messaging.MessageSerializerBase
Noemax.WebSockets.Messaging.JsonMessageSerializer
Noemax.WebSockets.Messaging.XmlMessageSerializer
Noemax.WebSockets.Messaging.WebSocketChannelExtensions
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService
Noemax.WebSockets.Messaging.WebSocketMessagingService
Noemax.WebSockets.Messaging.MultiFormatMessagingService.HelperMessageService
System.Attribute
Noemax.WebSockets.Messaging.MessageOperationAttribute
Noemax.WebSockets.Messaging.MessagingContractAttribute
System.Exception
Noemax.WebSockets.Messaging.RpcFaultException
System.ValueType
Noemax.WebSockets.Messaging.FaultInfo
See Also

Reference

Noemax.WebSockets.Net4 Assembly


WebSocketClient<TService> Class Events

WebSocketClient<TService> Class Events

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

For a list of all members of this type, see WebSocketClient<TService> members.

Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Handshake | Event triggered when the WebSocket handshake is performed. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


WebSocketClient<TService> Class Properties

WebSocketClient<TService> Class Properties

Noemax.WebSockets Namespace : WebSocketClient<TService> Class

For a list of all members of this type, see WebSocketClient<TService> members.

Public Properties
 | Name | Description
Public Property | AuthenticationContext | Gets the instance of the object that is associated to the connection during authentication. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | AutoPingInterval | (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | ClientDispatcher | Gets the Noemax.WebSockets.Messaging.IClientDispatcher being used for sending request and dispatching responses. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Compression | Gets and sets the transport compression scheme to be used by the client. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Connected | Gets whether the channel connection is considered being alive. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | Context | The context object associated to the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | CookieContainer | Gets and sets the CookieContainer to manage cookies set by the server side. By default this property is set to Nothing and WebSocket client ignores all cookies. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Cookies | Gets the collection of cookies associated to the URI of the client in the CookieContainer. If CookieContainer property is not set, the this property returns nothing. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | DefaultReceiveTimeout | Gets and sets the default timeout interval, to be used when receiving messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | DefaultSendTimeout | Gets and sets the default timeout interval, to be used when sending messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | Extensions | Gets and sets the list of extensions for be negotiated by WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | ID | Gets and sets the string identifier of the channel. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | InboundHandshakeHeaders | Gets the collection of HTTP headers returned by the remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | MaxOutboundFrameSize | Gets and sets the maximum size limit for outbound data frame. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxOutboundQueueSize | Gets and sets the maximum size of the outbound message queue. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | MaxRedirects | Gets and sets the maximum number of time WebSocket client can get redirected while performing WebSocket handshake with destination endpoint. Default value is 0. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Origin | Gets and sets the Origin string that identifies the origin of the script running on the client side. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundHandshakeHeaders | Gets the collection of custom handshake headers to be sent to remote endpoint during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | OutboundQueueSize | Gets the current size of the outbound message queue in bytes. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | PayloadMasking | Gets and sets whether the payload of outbound messages is masked. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Protocol | Gets and sets the Sec-WebSocket-Protocol header value being negotiated by the client during WebSocket handshake. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Security | Provides properties for the WebSocket connection security. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Serializer | Gets and sets the Noemax.WebSockets.Messaging.IMessageSerializer used by the channel to deserialize/serialize objects from/to binary or text messages. (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Property | ServiceInstance | Gets and sets the instance of IWebSockets to perform dispatching of inbound messages. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | State | Gets and sets the states of WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Public Property | TraceSource | Gets and sets TraceSource for tracing events. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | UseDefaultWebProxy | Gets and sets whether WebSocketClient is to use default HTTP proxy when establishing client connection. (Inherited from Noemax.WebSockets.WebSocketClient)
Public Property | Via | Gets the URI via which the channel was established. (Inherited from Noemax.WebSockets.WebSocketConnectionChannel)
Top
See Also

Reference

WebSocketClient<TService> Class
Noemax.WebSockets Namespace


WebSocketClosedException Class Events

WebSocketClosedException Class Events

Noemax.WebSockets Namespace : WebSocketClosedException Class

For a list of all members of this type, see WebSocketClosedException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketClosedException Class
Noemax.WebSockets Namespace


WebSocketClosedException Class Methods

WebSocketClosedException Class Methods

Noemax.WebSockets Namespace : WebSocketClosedException Class

For a list of all members of this type, see WebSocketClosedException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketClosedException Class
Noemax.WebSockets Namespace


Data Property (WebSocketClosedException)

Data Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


GetBaseException Method (WebSocketClosedException)

GetBaseException Method (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


GetObjectData Method (WebSocketClosedException)

GetObjectData Method (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As WebSocketClosedException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


GetType Method (WebSocketClosedException)

GetType Method (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


GetType() Method

GetType() Method

Noemax.WebSockets Namespace > WebSocketClosedException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


HelpLink Property (WebSocketClosedException)

HelpLink Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As WebSocketClosedException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


HResult Property (WebSocketClosedException)

HResult Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


InnerException Property (WebSocketClosedException)

InnerException Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


Message Property (WebSocketClosedException)

Message Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As WebSocketClosedException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


SerializeObjectState Event (WebSocketClosedException)

SerializeObjectState Event (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As WebSocketClosedException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


Source Property (WebSocketClosedException)

Source Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As WebSocketClosedException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


StackTrace Property (WebSocketClosedException)

StackTrace Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As WebSocketClosedException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


TargetSite Property (WebSocketClosedException)

TargetSite Property (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As WebSocketClosedException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


ToString Method (WebSocketClosedException)

ToString Method (WebSocketClosedException)

Noemax.WebSockets Namespace > WebSocketClosedException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As WebSocketClosedException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketClosedException Class
WebSocketClosedException Members


WebSocketConnectionChannel Class Events

WebSocketConnectionChannel Class Events

Noemax.WebSockets Namespace : WebSocketConnectionChannel Class

For a list of all members of this type, see WebSocketConnectionChannel members.

Public Events
 | Name | Description
Public Event | Closed | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Error | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Ping | (Inherited from Noemax.WebSockets.WebSocketChannel)
Public Event | Pong | (Inherited from Noemax.WebSockets.WebSocketChannel)
Top
See Also

Reference

WebSocketConnectionChannel Class
Noemax.WebSockets Namespace


WebSocketException Class Events

WebSocketException Class Events

Noemax.WebSockets Namespace : WebSocketException Class

For a list of all members of this type, see WebSocketException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketException Class
Noemax.WebSockets Namespace


WebSocketException Class Methods

WebSocketException Class Methods

Noemax.WebSockets Namespace : WebSocketException Class

For a list of all members of this type, see WebSocketException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketException Class
Noemax.WebSockets Namespace


Data Property (WebSocketException)

Data Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As WebSocketException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public virtual System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary; virtual;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property virtual System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
virtual property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


GetBaseException Method (WebSocketException)

GetBaseException Method (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Function GetBaseException() As System.Exception
'Usage

Dim instance As WebSocketException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public virtual System.Exception GetBaseException()
public function GetBaseException(): System.Exception; virtual;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: virtual System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
virtual System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


GetObjectData Method (WebSocketException)

GetObjectData Method (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As WebSocketException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


GetType Method (WebSocketException)

GetType Method (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


GetType() Method

GetType() Method

Noemax.WebSockets Namespace > WebSocketException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As WebSocketException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


HelpLink Property (WebSocketException)

HelpLink Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property HelpLink As System.String
'Usage

Dim instance As WebSocketException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public virtual System.string HelpLink {get; set;}
public read-write property HelpLink: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_HelpLink();
public: __property virtual void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


HResult Property (WebSocketException)

HResult Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As WebSocketException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


InnerException Property (WebSocketException)

InnerException Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As WebSocketException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


Message Property (WebSocketException)

Message Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property Message As System.String
'Usage

Dim instance As WebSocketException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public virtual System.string Message {get;}
public read-only property Message: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Message();
[__DynamicallyInvokable()]
public:
virtual property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


SerializeObjectState Event (WebSocketException)

SerializeObjectState Event (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As WebSocketException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


Source Property (WebSocketException)

Source Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable Property Source As System.String
'Usage

Dim instance As WebSocketException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public virtual System.string Source {get; set;}
public read-write property Source: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_Source();
public: __property virtual void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
virtual property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


StackTrace Property (WebSocketException)

StackTrace Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Overridable ReadOnly Property StackTrace As System.String
'Usage

Dim instance As WebSocketException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public virtual System.string StackTrace {get;}
public read-only property StackTrace: System.String; virtual;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property virtual System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
virtual property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


TargetSite Property (WebSocketException)

TargetSite Property (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As WebSocketException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


ToString Method (WebSocketException)

ToString Method (WebSocketException)

Noemax.WebSockets Namespace > WebSocketException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overridable Function ToString() As System.String
'Usage

Dim instance As WebSocketException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.string ToString()
public function ToString(): System.String; virtual;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketException Class
WebSocketException Members


Implicit Type Conversion(Stream,WebSocketInboundMessage) Operator

Implicit Type Conversion(Stream,WebSocketInboundMessage) Operator

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > Implicit Type Conversion Operator : Implicit Type Conversion(Stream,WebSocketInboundMessage) Operator
The message to represent as the input.
Provides implicit conversion that represents an inbound message as Stream object.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal message As WebSocketInboundMessage _
) As System.IO.Stream
'Usage

public System.IO.Stream operator implicit(
   WebSocketInboundMessage message
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.IO.Stream* op_Implicit(
   WebSocketInboundMessage* message
)
public:
operator System.IO.Stream^ (
   WebSocketInboundMessage^ message
)

Parameters

message
The message to represent as the input.

Return Value

The input object to read the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


Implicit Type Conversion(TextReader,WebSocketInboundMessage) Operator

Implicit Type Conversion(TextReader,WebSocketInboundMessage) Operator

Noemax.WebSockets Namespace > WebSocketInboundMessage Class > Implicit Type Conversion Operator : Implicit Type Conversion(TextReader,WebSocketInboundMessage) Operator
The message to represent as TextReader.
Provides implicit conversion that represents an inbound message as TextReader.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal message As WebSocketInboundMessage _
) As System.IO.TextReader
'Usage

public System.IO.TextReader operator implicit(
   WebSocketInboundMessage message
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: System.IO.TextReader* op_Implicit(
   WebSocketInboundMessage* message
)
public:
operator System.IO.TextReader^ (
   WebSocketInboundMessage^ message
)

Parameters

message
The message to represent as TextReader.

Return Value

The TextReader to read the message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketInboundMessage Class
WebSocketInboundMessage Members
Overload List


Implicit Type Conversion(WebSocketOutboundMessage,ArraySegment<Byte>) Operator

Implicit Type Conversion(WebSocketOutboundMessage,ArraySegment<Byte>) Operator

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > Implicit Type Conversion Operator : Implicit Type Conversion(WebSocketOutboundMessage,ArraySegment<Byte>) Operator
The binary data to use as the payload of the message.
Performs an implicit conversion from array of bytes to WebSocketOutboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal segment As System.ArraySegment(Of Byte) _
) As WebSocketOutboundMessage
'Usage

public WebSocketOutboundMessage operator implicit(
   System.ArraySegment<byte> segment
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: WebSocketOutboundMessage op_Implicit(
   System.ArraySegment<byte> segment
)
public:
operator WebSocketOutboundMessage (
   System.ArraySegment<byte> segment
)

Parameters

segment
The binary data to use as the payload of the message.

Return Value

The WebSocketOutboundMessage with binary payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


Implicit Type Conversion(WebSocketOutboundMessage,Byte[]) Operator

Implicit Type Conversion(WebSocketOutboundMessage,Byte[]) Operator

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > Implicit Type Conversion Operator : Implicit Type Conversion(WebSocketOutboundMessage,Byte[]) Operator
The binary data to use as the payload of the message.
Performs an implicit conversion from array of bytes to WebSocketOutboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal binary() As System.Byte _
) As WebSocketOutboundMessage
'Usage

public WebSocketOutboundMessage operator implicit(
   System.byte[] binary
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: WebSocketOutboundMessage op_Implicit(
   System.byte[]* binary
)
public:
operator WebSocketOutboundMessage (
   System.array<byte>^ binary
)

Parameters

binary
The binary data to use as the payload of the message.

Return Value

The WebSocketOutboundMessage with binary payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


Implicit Type Conversion(WebSocketOutboundMessage,String) Operator

Implicit Type Conversion(WebSocketOutboundMessage,String) Operator

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > Implicit Type Conversion Operator : Implicit Type Conversion(WebSocketOutboundMessage,String) Operator
The text to use as the payload of the message.
Performs an implicit conversion from System.String to WebSocketOutboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal text As System.String _
) As WebSocketOutboundMessage
'Usage

public WebSocketOutboundMessage operator implicit(
   System.string text
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: WebSocketOutboundMessage op_Implicit(
   System.string* text
)
public:
operator WebSocketOutboundMessage (
   System.String^ text
)

Parameters

text
The text to use as the payload of the message.

Return Value

The WebSocketOutboundMessage with text payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


Implicit Type Conversion(WebSocketOutboundMessage,WebSocketInboundMessage) Operator

Implicit Type Conversion(WebSocketOutboundMessage,WebSocketInboundMessage) Operator

Noemax.WebSockets Namespace > WebSocketOutboundMessage Structure > Implicit Type Conversion Operator : Implicit Type Conversion(WebSocketOutboundMessage,WebSocketInboundMessage) Operator
The binary data to use as the payload of the message.
Performs an implicit conversion from WebSocketInboundMessage to WebSocketOutboundMessage.
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Overloads Public Operator Widening CType( _
   ByVal inboundMessage As WebSocketInboundMessage _
) As WebSocketOutboundMessage
'Usage

public WebSocketOutboundMessage operator implicit(
   WebSocketInboundMessage inboundMessage
)
This operator type is not supported by Delphi
This operator type is not supported by JScript
public: WebSocketOutboundMessage op_Implicit(
   WebSocketInboundMessage* inboundMessage
)
public:
operator WebSocketOutboundMessage (
   WebSocketInboundMessage^ inboundMessage
)

Parameters

inboundMessage
The binary data to use as the payload of the message.

Return Value

The WebSocketOutboundMessage with binary payload.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketOutboundMessage Structure
WebSocketOutboundMessage Members
Overload List


WebSocketProtocolException Class Events

WebSocketProtocolException Class Events

Noemax.WebSockets Namespace : WebSocketProtocolException Class

For a list of all members of this type, see WebSocketProtocolException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketProtocolException Class
Noemax.WebSockets Namespace


WebSocketProtocolException Class Methods

WebSocketProtocolException Class Methods

Noemax.WebSockets Namespace : WebSocketProtocolException Class

For a list of all members of this type, see WebSocketProtocolException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketProtocolException Class
Noemax.WebSockets Namespace


WebSocketProtocolException Class Properties

WebSocketProtocolException Class Properties

Noemax.WebSockets Namespace : WebSocketProtocolException Class

For a list of all members of this type, see WebSocketProtocolException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | StatusCode | Gets and sets the corresponding close frame status code, if any. (Inherited from Noemax.WebSockets.WebSocketException)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketProtocolException Class
Noemax.WebSockets Namespace


Data Property (WebSocketProtocolException)

Data Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


GetBaseException Method (WebSocketProtocolException)

GetBaseException Method (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetBaseException() As System.Exception
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public System.Exception GetBaseException()
public function GetBaseException(): System.Exception;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


GetObjectData Method (WebSocketProtocolException)

GetObjectData Method (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As WebSocketProtocolException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


GetType Method (WebSocketProtocolException)

GetType Method (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


GetType() Method

GetType() Method

Noemax.WebSockets Namespace > WebSocketProtocolException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


HelpLink Property (WebSocketProtocolException)

HelpLink Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Property HelpLink As System.String
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public System.string HelpLink {get; set;}
public read-write property HelpLink: System.String;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_HelpLink();
public: __property void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


HResult Property (WebSocketProtocolException)

HResult Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


InnerException Property (WebSocketProtocolException)

InnerException Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


Message Property (WebSocketProtocolException)

Message Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Message As System.String
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public System.string Message {get;}
public read-only property Message: System.String;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_Message();
[__DynamicallyInvokable()]
public:
property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


SerializeObjectState Event (WebSocketProtocolException)

SerializeObjectState Event (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As WebSocketProtocolException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


Source Property (WebSocketProtocolException)

Source Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Property Source As System.String
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public System.string Source {get; set;}
public read-write property Source: System.String;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_Source();
public: __property void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


StackTrace Property (WebSocketProtocolException)

StackTrace Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property StackTrace As System.String
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public System.string StackTrace {get;}
public read-only property StackTrace: System.String;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


TargetSite Property (WebSocketProtocolException)

TargetSite Property (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


ToString Method (WebSocketProtocolException)

ToString Method (WebSocketProtocolException)

Noemax.WebSockets Namespace > WebSocketProtocolException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function ToString() As System.String
'Usage

Dim instance As WebSocketProtocolException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public System.string ToString()
public function ToString(): System.String;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketProtocolException Class
WebSocketProtocolException Members


WebSocketQueueSizeException Class Events

WebSocketQueueSizeException Class Events

Noemax.WebSockets Namespace : WebSocketQueueSizeException Class

For a list of all members of this type, see WebSocketQueueSizeException members.

Protected Events
 | Name | Description
Protected Event | SerializeObjectState | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketQueueSizeException Class
Noemax.WebSockets Namespace


WebSocketQueueSizeException Class Methods

WebSocketQueueSizeException Class Methods

Noemax.WebSockets Namespace : WebSocketQueueSizeException Class

For a list of all members of this type, see WebSocketQueueSizeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

WebSocketQueueSizeException Class
Noemax.WebSockets Namespace


Data Property (WebSocketQueueSizeException)

Data Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : Data Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Data As System.Collections.IDictionary
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Collections.IDictionary

value = instance.Data
[__DynamicallyInvokable()]
public System.Collections.IDictionary Data {get;}
public read-only property Data: System.Collections.IDictionary;
__DynamicallyInvokableAttribute()
public function get Data : System.Collections.IDictionary
[__DynamicallyInvokable()]
public: __property System.Collections.IDictionary* get_Data();
[__DynamicallyInvokable()]
public:
property System.Collections.IDictionary^ Data {
   System.Collections.IDictionary^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


GetBaseException Method (WebSocketQueueSizeException)

GetBaseException Method (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetBaseException() As System.Exception
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Exception

value = instance.GetBaseException()
[__DynamicallyInvokable()]
public System.Exception GetBaseException()
public function GetBaseException(): System.Exception;
__DynamicallyInvokableAttribute()
public function GetBaseException() : System.Exception;
[__DynamicallyInvokable()]
public: System.Exception* GetBaseException();
[__DynamicallyInvokable()]
public:
System.Exception^ GetBaseException();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


GetObjectData Method (WebSocketQueueSizeException)

GetObjectData Method (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<System.Security.SecurityCriticalAttribute()>
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
'Usage

Dim instance As WebSocketQueueSizeException
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
[System.Security.SecurityCritical()]
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
System.Security.SecurityCriticalAttribute()
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
[System.Security.SecurityCritical()]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
[System.Security.SecurityCritical()]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


GetType Method (WebSocketQueueSizeException)

GetType Method (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


GetType() Method

GetType() Method

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Function GetType() As System.Type
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Type

value = instance.GetType()
[__DynamicallyInvokable()]
public System.Type GetType()
public function GetType(): System.Type;
__DynamicallyInvokableAttribute()
public function GetType() : System.Type;
[__DynamicallyInvokable()]
public: System.Type* GetType();
[__DynamicallyInvokable()]
public:
System.Type^ GetType();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


HelpLink Property (WebSocketQueueSizeException)

HelpLink Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Property HelpLink As System.String
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.String

instance.HelpLink = value

value = instance.HelpLink
[__DynamicallyInvokable()]
public System.string HelpLink {get; set;}
public read-write property HelpLink: System.String;
__DynamicallyInvokableAttribute()
public function get,set HelpLink : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_HelpLink();
public: __property void set_HelpLink(
   System.string* value
);
[__DynamicallyInvokable()]
public:
property System.String^ HelpLink {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


HResult Property (WebSocketQueueSizeException)

HResult Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : HResult Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property HResult As System.Integer
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Integer

value = instance.HResult
[__DynamicallyInvokable()]
public System.int HResult {get;}
public read-only property HResult: System.Integer;
__DynamicallyInvokableAttribute()
public function get HResult : System.int
[__DynamicallyInvokable()]
public: __property System.int get_HResult();
[__DynamicallyInvokable()]
public:
property System.int HResult {
   System.int get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


InnerException Property (WebSocketQueueSizeException)

InnerException Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property InnerException As System.Exception
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Exception

value = instance.InnerException
[__DynamicallyInvokable()]
public System.Exception InnerException {get;}
public read-only property InnerException: System.Exception;
__DynamicallyInvokableAttribute()
public function get InnerException : System.Exception
[__DynamicallyInvokable()]
public: __property System.Exception* get_InnerException();
[__DynamicallyInvokable()]
public:
property System.Exception^ InnerException {
   System.Exception^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


Message Property (WebSocketQueueSizeException)

Message Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : Message Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Message As System.String
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.String

value = instance.Message
[__DynamicallyInvokable()]
public System.string Message {get;}
public read-only property Message: System.String;
__DynamicallyInvokableAttribute()
public function get Message : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_Message();
[__DynamicallyInvokable()]
public:
property System.String^ Message {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


SerializeObjectState Event (WebSocketQueueSizeException)

SerializeObjectState Event (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : SerializeObjectState Event
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Protected Event SerializeObjectState As System.EventHandler(Of SafeSerializationEventArgs)
'Usage

Dim instance As WebSocketQueueSizeException
Dim handler As System.EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
protected event System.EventHandler<SafeSerializationEventArgs> SerializeObjectState
protected event SerializeObjectState: System.EventHandler;
In JScript, you can handle the events defined by another class, but you cannot define your own.
protected: __event System.EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
protected:
event System.EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState
Event Data

The event handler receives an argument of type System.Runtime.Serialization.SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext | Gets or sets an object that describes the source and destination of a serialized stream.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


Source Property (WebSocketQueueSizeException)

Source Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : Source Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public Property Source As System.String
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.String

instance.Source = value

value = instance.Source
[__DynamicallyInvokable()]
public System.string Source {get; set;}
public read-write property Source: System.String;
__DynamicallyInvokableAttribute()
public function get,set Source : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_Source();
public: __property void set_Source(
   System.string* value
);
[__DynamicallyInvokable()]
public:
property System.String^ Source {
   System.String^ get();
   void set (    System.String^ value);
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


StackTrace Property (WebSocketQueueSizeException)

StackTrace Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
Public ReadOnly Property StackTrace As System.String
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.String

value = instance.StackTrace
[__DynamicallyInvokable()]
public System.string StackTrace {get;}
public read-only property StackTrace: System.String;
__DynamicallyInvokableAttribute()
public function get StackTrace : System.String
[__DynamicallyInvokable()]
public: __property System.string* get_StackTrace();
[__DynamicallyInvokable()]
public:
property System.String^ StackTrace {
   System.String^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


TargetSite Property (WebSocketQueueSizeException)

TargetSite Property (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.Reflection.MethodBase

value = instance.TargetSite
public System.Reflection.MethodBase TargetSite {get;}
public read-only property TargetSite: System.Reflection.MethodBase;
public function get TargetSite : System.Reflection.MethodBase
public: __property System.Reflection.MethodBase* get_TargetSite();
public:
property System.Reflection.MethodBase^ TargetSite {
   System.Reflection.MethodBase^ get();
}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


ToString Method (WebSocketQueueSizeException)

ToString Method (WebSocketQueueSizeException)

Noemax.WebSockets Namespace > WebSocketQueueSizeException Class : ToString Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function ToString() As System.String
'Usage

Dim instance As WebSocketQueueSizeException
Dim value As System.String

value = instance.ToString()
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public System.string ToString()
public function ToString(): System.String;
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ToString() : System.String;
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* ToString();
[__DynamicallyInvokable()]
[System.Runtime.TargetedPatchingOptOut("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ ToString();
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSocketQueueSizeException Class
WebSocketQueueSizeException Members


WebSocketServer<TService> Class Events

WebSocketServer<TService> Class Events

Noemax.WebSockets Namespace : WebSocketServer<TService> Class

For a list of all members of this type, see WebSocketServer<TService> members.

Public Events
 | Name | Description
Public Event | Handshake | Event triggered when the WebSocket handshake is performed. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
See Also

Reference

WebSocketServer<TService> Class
Noemax.WebSockets Namespace


WebSocketServer<TService> Class Properties

WebSocketServer<TService> Class Properties

Noemax.WebSockets Namespace : WebSocketServer<TService> Class

For a list of all members of this type, see WebSocketServer<TService> members.

Public Properties
 | Name | Description
Public Property | Compression | Gets and sets the compression scheme being used for compressing the payload sent through the WebSocket connection. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | PortSharing | Gets and sets whether the port sharing infrastructure should be used in order to share the IP endpoint across processes exposing WebSocket endpoints on the same computer. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | Security | Gets the server security settings. (Inherited from Noemax.WebSockets.WebSocketServer)
Public Property | TraceSource | Gets and sets TraceSource for tracing events generated by the server and underlying components. (Inherited from Noemax.WebSockets.WebSocketServer)
Top
See Also

Reference

WebSocketServer<TService> Class
Noemax.WebSockets Namespace


Noemax.WebSockets Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy

Noemax.WebSockets Namespace (Noemax.WebSockets.Net4) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.CompressionSettings
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.BasicWebSocketClient
Noemax.WebSockets.WebSocketConnectionChannel
Noemax.WebSockets.WebSocketClient
Noemax.WebSockets.WebSocketClient<TService>
Noemax.WebSockets.WebSocketEndpoint
Noemax.WebSockets.WebSocketHandshakeHeader
Noemax.WebSockets.WebSocketHandshakeHeaderCollection
Noemax.WebSockets.WebSocketInboundMessage
Noemax.WebSockets.Messaging.CompressedMessageSerializer.CompressedInboundMessage
Noemax.WebSockets.WebSocketInboundMessageImpl
Noemax.WebSockets.WebSocketServer
Noemax.WebSockets.WebSocketServer<TService>
Noemax.WebSockets.WebSocketServerSecurity
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.BasicWebSocketClient.SimpleWebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService
Noemax.WebSockets.Messaging.WebSocketMessagingService
Noemax.WebSockets.Messaging.MultiFormatMessagingService.HelperMessageService
Noemax.WebSockets.WebSocketUsernamePasswordCredentials
System.EventArgs
Noemax.WebSockets.WebSocketEventArgs
Noemax.WebSockets.WebSocketHandshake
System.Exception
Noemax.WebSockets.WebSocketClosedException
Noemax.WebSockets.WebSocketException
Noemax.WebSockets.WebSocketProtocolException
Noemax.WebSockets.WebSocketQueueSizeException
System.ValueType
Noemax.WebSockets.WebSocketOutboundMessage
See Also

Reference

Noemax.WebSockets.Net4 Assembly


Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Bson Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Bson.BsonObjectId
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Converters Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>
Noemax.Newtonsoft.Json.Converters.DataSetConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter
See Also

Reference

Noemax.WebSockets Assembly


JArray Class Events

JArray Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JArray Class

For a list of all members of this type, see JArray members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JArray Class
Noemax.Newtonsoft.Json.Linq Namespace


JConstructor Class Events

JConstructor Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JConstructor Class

For a list of all members of this type, see JConstructor members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JConstructor Class
Noemax.Newtonsoft.Json.Linq Namespace


JProperty Class Events

JProperty Class Events

Noemax.Newtonsoft.Json.Linq Namespace : JProperty Class

For a list of all members of this type, see JProperty members.

Public Events
 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the collection. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Public Event | ListChanged | Occurs when the list changes or an item in the list changes. (Inherited from Noemax.Newtonsoft.Json.Linq.JContainer)
Top
See Also

Reference

JProperty Class
Noemax.Newtonsoft.Json.Linq Namespace


Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Linq.JsonPath Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Linq Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Linq.JTokenReader
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter
Noemax.Newtonsoft.Json.Linq.Extensions
Noemax.Newtonsoft.Json.Linq.JToken
Noemax.Newtonsoft.Json.Linq.JContainer
Noemax.Newtonsoft.Json.Linq.JArray
Noemax.Newtonsoft.Json.Linq.JConstructor
Noemax.Newtonsoft.Json.Linq.JObject
Noemax.Newtonsoft.Json.Linq.JProperty
Noemax.Newtonsoft.Json.Linq.JValue
Noemax.Newtonsoft.Json.Linq.JRaw
Noemax.Newtonsoft.Json.Linq.JTokenEqualityComparer
System.ComponentModel.MemberDescriptor
System.ComponentModel.PropertyDescriptor
Noemax.Newtonsoft.Json.Linq.JPropertyDescriptor
System.ValueType
Noemax.Newtonsoft.Json.Linq.JEnumerable<T>
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Schema Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Schema.Extensions
Noemax.Newtonsoft.Json.Schema.JsonSchema
Noemax.Newtonsoft.Json.Schema.JsonSchemaGenerator
Noemax.Newtonsoft.Json.Schema.JsonSchemaResolver
System.EventArgs
Noemax.Newtonsoft.Json.Schema.ValidationEventArgs
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException
See Also

Reference

Noemax.WebSockets Assembly


CamelCasePropertyNamesContractResolver Class Methods

CamelCasePropertyNamesContractResolver Class Methods

Noemax.Newtonsoft.Json.Serialization Namespace : CamelCasePropertyNamesContractResolver Class

For a list of all members of this type, see CamelCasePropertyNamesContractResolver members.

Public Methods
 | Name | Description
Public Method | GetResolvedPropertyName | Gets the resolved name of the property. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Public Method | ResolveContract | Resolves the contract for a given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
Protected Methods
 | Name | Description
Protected Method | CreateArrayContract | Creates a JsonArrayContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateConstructorParameters | Creates the constructor parameters. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateContract | Determines which contract type is created for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateDictionaryContract | Creates a JsonDictionaryContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateISerializableContract | Creates a JsonISerializableContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateLinqContract | Creates a JsonLinqContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateMemberValueProvider | Creates the IValueProvider used by the serializer to get and set values from a member. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateObjectContract | Creates a JsonObjectContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePrimitiveContract | Creates a JsonPrimitiveContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperties | Creates properties for the given JsonContract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateProperty | Creates a JsonProperty for the given System.Reflection.MemberInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreatePropertyFromConstructorParameter | Creates a JsonProperty for the given System.Reflection.ParameterInfo. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | CreateStringContract | Creates a JsonStringContract for the given type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | GetSerializableMembers | Gets the serializable members for the type. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Protected Method | ResolveContractConverter | Resolves the default Noemax.Newtonsoft.Json.JsonConverter for the contract. (Inherited from Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver)
Top
See Also

Reference

CamelCasePropertyNamesContractResolver Class
Noemax.Newtonsoft.Json.Serialization Namespace


BindToName Method (DefaultSerializationBinder)

BindToName Method (DefaultSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > DefaultSerializationBinder Class : BindToName Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub BindToName( _
   ByVal serializedType As System.Type, _
   ByRef assemblyName As System.String, _
   ByRef typeName As System.String _
)
'Usage

Dim instance As DefaultSerializationBinder
Dim serializedType As System.Type
Dim assemblyName As System.String
Dim typeName As System.String

instance.BindToName(serializedType, assemblyName, typeName)
public virtual void BindToName(
   System.Type serializedType,
   out System.string assemblyName,
   out System.string typeName
)
public procedure BindToName(
    serializedType: System.Type;
   Out  assemblyName: System.String;
   Out  typeName: System.String
); virtual;
public function BindToName(
   serializedType : System.Type,
   assemblyName : System.String,
   typeName : System.String
);
public: virtual void BindToName(
   System.Type* serializedType,
   [PARAMFLAG::Out] System.string* assemblyName,
   [PARAMFLAG::Out] System.string* typeName
)
public:
virtual void BindToName(
   System.Type^ serializedType,
   [Out] System.String^ assemblyName,
   [Out] System.String^ typeName
)

Parameters

serializedType
assemblyName
typeName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DefaultSerializationBinder Class
DefaultSerializationBinder Members


BindToName Method (FlexibleSerializationBinder)

BindToName Method (FlexibleSerializationBinder)

Noemax.Newtonsoft.Json.Serialization Namespace > FlexibleSerializationBinder Class : BindToName Method
Syntax
  • Visual Basic
  • C#
  • Delphi
  • JScript
  • Managed Extensions for C++
  • C++/CLI
'Declaration

Public Overridable Sub BindToName( _
   ByVal serializedType As System.Type, _
   ByRef assemblyName As System.String, _
   ByRef typeName As System.String _
)
'Usage

Dim instance As FlexibleSerializationBinder
Dim serializedType As System.Type
Dim assemblyName As System.String
Dim typeName As System.String

instance.BindToName(serializedType, assemblyName, typeName)
public virtual void BindToName(
   System.Type serializedType,
   out System.string assemblyName,
   out System.string typeName
)
public procedure BindToName(
    serializedType: System.Type;
   Out  assemblyName: System.String;
   Out  typeName: System.String
); virtual;
public function BindToName(
   serializedType : System.Type,
   assemblyName : System.String,
   typeName : System.String
);
public: virtual void BindToName(
   System.Type* serializedType,
   [PARAMFLAG::Out] System.string* assemblyName,
   [PARAMFLAG::Out] System.string* typeName
)
public:
virtual void BindToName(
   System.Type^ serializedType,
   [Out] System.String^ assemblyName,
   [Out] System.String^ typeName
)

Parameters

serializedType
assemblyName
typeName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FlexibleSerializationBinder Class
FlexibleSerializationBinder Members


Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Serialization Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.Serialization.DefaultContractResolver
Noemax.Newtonsoft.Json.Serialization.CamelCasePropertyNamesContractResolver
Noemax.Newtonsoft.Json.Serialization.DiagnosticsTraceWriter
Noemax.Newtonsoft.Json.Serialization.DynamicValueProvider
Noemax.Newtonsoft.Json.Serialization.ErrorContext
Noemax.Newtonsoft.Json.Serialization.JsonContract
Noemax.Newtonsoft.Json.Serialization.JsonContainerContract
Noemax.Newtonsoft.Json.Serialization.JsonArrayContract
Noemax.Newtonsoft.Json.Serialization.JsonDictionaryContract
Noemax.Newtonsoft.Json.Serialization.JsonISerializableContract
Noemax.Newtonsoft.Json.Serialization.JsonObjectContract
Noemax.Newtonsoft.Json.Serialization.JsonLinqContract
Noemax.Newtonsoft.Json.Serialization.JsonPrimitiveContract
Noemax.Newtonsoft.Json.Serialization.JsonStringContract
Noemax.Newtonsoft.Json.Serialization.JsonProperty
Noemax.Newtonsoft.Json.Serialization.MemoryTraceWriter
Noemax.Newtonsoft.Json.Serialization.ReflectionValueProvider
System.Attribute
Noemax.Newtonsoft.Json.Serialization.OnErrorAttribute
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.KeyedCollection<TKey,TItem>
Noemax.Newtonsoft.Json.Serialization.JsonPropertyCollection
System.EventArgs
Noemax.Newtonsoft.Json.Serialization.ErrorEventArgs
System.Runtime.Serialization.SerializationBinder
Noemax.Newtonsoft.Json.Serialization.DefaultSerializationBinder
Noemax.Newtonsoft.Json.Serialization.FlexibleSerializationBinder
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json.Utilities Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
See Also

Reference

Noemax.WebSockets Assembly


Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.Newtonsoft.Json Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.Newtonsoft.Json.JsonConvert
Noemax.Newtonsoft.Json.JsonConverter
Noemax.Newtonsoft.Json.Converters.BinaryConverter
Noemax.Newtonsoft.Json.Converters.BsonObjectIdConverter
Noemax.Newtonsoft.Json.Converters.CustomCreationConverter<T>
Noemax.Newtonsoft.Json.Converters.DataSetConverter
Noemax.Newtonsoft.Json.Converters.DataTableConverter
Noemax.Newtonsoft.Json.Converters.DateTimeConverterBase
Noemax.Newtonsoft.Json.Converters.IsoDateTimeConverter
Noemax.Newtonsoft.Json.Converters.JavaScriptDateTimeConverter
Noemax.Newtonsoft.Json.Converters.EntityKeyMemberConverter
Noemax.Newtonsoft.Json.Converters.KeyValuePairConverter
Noemax.Newtonsoft.Json.Converters.RegexConverter
Noemax.Newtonsoft.Json.Converters.StringEnumConverter
Noemax.Newtonsoft.Json.Converters.VersionConverter
Noemax.Newtonsoft.Json.Converters.XmlNodeConverter
Noemax.Newtonsoft.Json.JsonReader
Noemax.Newtonsoft.Json.Bson.BsonReader
Noemax.Newtonsoft.Json.JsonTextReader
Noemax.Newtonsoft.Json.JsonValidatingReader
Noemax.Newtonsoft.Json.Linq.JTokenReader
Noemax.Newtonsoft.Json.Serialization.TraceJsonReader
Noemax.Newtonsoft.Json.JsonSerializer
Noemax.Newtonsoft.Json.Serialization.JsonSerializerProxy
Noemax.Newtonsoft.Json.JsonSerializerSettings
Noemax.Newtonsoft.Json.JsonWriter
Noemax.Newtonsoft.Json.Bson.BsonWriter
Noemax.Newtonsoft.Json.JsonTextWriter
Noemax.Newtonsoft.Json.Linq.JTokenWriter
Noemax.Newtonsoft.Json.Serialization.TraceJsonWriter
System.Attribute
Noemax.Newtonsoft.Json.JsonConstructorAttribute
Noemax.Newtonsoft.Json.JsonContainerAttribute
Noemax.Newtonsoft.Json.JsonArrayAttribute
Noemax.Newtonsoft.Json.JsonDictionaryAttribute
Noemax.Newtonsoft.Json.JsonObjectAttribute
Noemax.Newtonsoft.Json.JsonConverterAttribute
Noemax.Newtonsoft.Json.JsonExtensionDataAttribute
Noemax.Newtonsoft.Json.JsonIgnoreAttribute
Noemax.Newtonsoft.Json.JsonPropertyAttribute
System.Collections.ObjectModel.Collection<T>
Noemax.Newtonsoft.Json.JsonConverterCollection
System.Exception
Noemax.Newtonsoft.Json.JsonException
Noemax.Newtonsoft.Json.JsonReaderException
Noemax.Newtonsoft.Json.JsonSerializationException
Noemax.Newtonsoft.Json.JsonWriterException
Noemax.Newtonsoft.Json.Schema.JsonSchemaException
See Also

Reference

Noemax.WebSockets Assembly


Noemax.WebSockets.Core Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.WebSockets.Core Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Core.WebSocket
Noemax.WebSockets.Core.WebSocketImpl
Noemax.WebSockets.Core.WebSocketClientSecurity
Noemax.WebSockets.Core.WebSocketCloseCodes
Noemax.WebSockets.Core.WebSocketFactory
Noemax.WebSockets.Core.WebSocketListener
System.EventArgs
Noemax.WebSockets.Core.ControlFrameEventArgs
Noemax.WebSockets.Core.WebSocketCloseEventArgs
Noemax.WebSockets.Core.WebSocketPingOrPongEventArgs
Noemax.WebSockets.Core.UsernamePasswordAuthenticateEventArgs
Noemax.WebSockets.Core.WebSocketErrorEventArgs
System.MarshalByRefObject
System.IO.Stream
Noemax.WebSockets.Core.WebSocketMessageInputStream
Noemax.WebSockets.Core.WebSocketFrameReader.WebSocketMessageInputStreamImpl
Noemax.WebSockets.Messaging.CompressedMessageSerializer.CompressedInputStream
See Also

Reference

Noemax.WebSockets Assembly


Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.WebSockets.Messaging.Pom Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Messaging.Pom.WebSocketChannelExtensionsPom
See Also

Reference

Noemax.WebSockets Assembly


Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.WebSockets.Messaging Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.Messaging.CompressedMessageSerializer
Noemax.WebSockets.Messaging.DefaultClientDispatcher
Noemax.WebSockets.Messaging.EnvelopedMessage
Noemax.WebSockets.Messaging.ConversationMessage
Noemax.WebSockets.Messaging.FaultMessage
Noemax.WebSockets.Messaging.PlainMessage
Noemax.WebSockets.Messaging.RequestMessage
Noemax.WebSockets.Messaging.ResponseMessage
Noemax.WebSockets.Messaging.JsonMessageSerializer.JsonResponseMessage
Noemax.WebSockets.Messaging.Invoker
Noemax.WebSockets.Messaging.DefaultMessageDispatcher.ResponseInvoker
Noemax.WebSockets.Messaging.RequestInvoker
Noemax.WebSockets.Messaging.ActionInvoker
Noemax.WebSockets.Messaging.ActionInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker<T>
Noemax.WebSockets.Messaging.ActionOperationInvoker<T>
Noemax.WebSockets.Messaging.ActionOperation1Invoker
Noemax.WebSockets.Messaging.ActionOperationInvoker
Noemax.WebSockets.Messaging.FuncInvoker<TResult,TRequest>
Noemax.WebSockets.Messaging.FuncOperation1Invoker<TResult,T>
Noemax.WebSockets.Messaging.FuncOperationInvoker<TResult,T>
Noemax.WebSockets.Messaging.ReflectionInvoker
Noemax.WebSockets.Messaging.VoidInputInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker<TResult>
Noemax.WebSockets.Messaging.VoidInputOperationInvoker1<TResult>
Noemax.WebSockets.Messaging.InvokerFactory
Noemax.WebSockets.Messaging.ActionInvokerFactory
Noemax.WebSockets.Messaging.FuncInvokerFactory
Noemax.WebSockets.Messaging.ReflectionInvokerFactory
Noemax.WebSockets.Messaging.VoidInputInvokerFactory
Noemax.WebSockets.Messaging.JsonClientProxyProvider
Noemax.WebSockets.Messaging.MessageDispatcher
Noemax.WebSockets.Messaging.DefaultMessageDispatcher
Noemax.WebSockets.Messaging.MessageOperationDescription
Noemax.WebSockets.Messaging.MessageSerializerBase
Noemax.WebSockets.Messaging.JsonMessageSerializer
Noemax.WebSockets.Messaging.XmlMessageSerializer
Noemax.WebSockets.Messaging.WebSocketChannelExtensions
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService
Noemax.WebSockets.Messaging.WebSocketMessagingService
Noemax.WebSockets.Messaging.MultiFormatMessagingService.HelperMessageService
System.Attribute
Noemax.WebSockets.Messaging.MessageOperationAttribute
Noemax.WebSockets.Messaging.MessagingContractAttribute
System.Exception
Noemax.WebSockets.Messaging.RpcFaultException
System.ValueType
Noemax.WebSockets.Messaging.FaultInfo
See Also

Reference

Noemax.WebSockets Assembly


Noemax.WebSockets Namespace (Noemax.WebSockets) Inheritance Hierarchy

Noemax.WebSockets Namespace (Noemax.WebSockets) Inheritance Hierarchy
Inheritance Hierarchy
System.Object
Noemax.WebSockets.CompressionSettings
Noemax.WebSockets.WebSocketChannel
Noemax.WebSockets.BasicWebSocketClient
Noemax.WebSockets.WebSocketConnectionChannel
Noemax.WebSockets.WebSocketClient
Noemax.WebSockets.WebSocketClient<TService>
Noemax.WebSockets.WebSocketEndpoint
Noemax.WebSockets.WebSocketHandshakeHeader
Noemax.WebSockets.WebSocketHandshakeHeaderCollection
Noemax.WebSockets.WebSocketInboundMessage
Noemax.WebSockets.Messaging.CompressedMessageSerializer.CompressedInboundMessage
Noemax.WebSockets.WebSocketInboundMessageImpl
Noemax.WebSockets.WebSocketServer
Noemax.WebSockets.WebSocketServer<TService>
Noemax.WebSockets.WebSocketServerSecurity
Noemax.WebSockets.WebSocketService
Noemax.WebSockets.BasicWebSocketClient.SimpleWebSocketService
Noemax.WebSockets.Messaging.MultiFormatMessagingService
Noemax.WebSockets.Messaging.WebSocketMessagingService
Noemax.WebSockets.Messaging.MultiFormatMessagingService.HelperMessageService
Noemax.WebSockets.WebSocketUsernamePasswordCredentials
System.EventArgs
Noemax.WebSockets.WebSocketEventArgs
Noemax.WebSockets.WebSocketHandshake
System.Exception
Noemax.WebSockets.WebSocketClosedException
Noemax.WebSockets.WebSocketException
Noemax.WebSockets.WebSocketProtocolException
Noemax.WebSockets.WebSocketQueueSizeException
System.ValueType
Noemax.WebSockets.WebSocketOutboundMessage
See Also

Reference

Noemax.WebSockets Assembly