%%phrase%%

Noemax WCF-Xtensions
Noemax.WCFX Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Noemax.FastInfoset |
Noemax.GZip |
Noemax.Lzf |
Noemax.Lzma |
Noemax.WCFX |
Noemax.WCFX.Behaviors |
Noemax.WCFX.Channels |
Noemax.WCFX.Configuration |
Noemax.Xml |

Copyright © 2010 Noemax Technologies. All rights reserved.


%%ItemTitle%%

Noemax.FastInfoset Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ReaderVocabulary | Provides a Fast Infoset vocabulary for use by XmlFastInfosetReader.
Class | SchemaVocabulary | Provides methods and properties for generating a Fast Infoset vocabulary from an XSD schema.
Class | Vocabulary | Provides the base implementation for Fast Infoset vocabularies.
Class | WriterVocabulary | Provides a Fast Infoset vocabulary for use by XmlFastInfosetWriter.
Class | XmlFastInfosetFactory | Manages XmlFastInfosetReader and XmlFastInfosetWriter objects.
Class | XmlFastInfosetReader | Represents a reader that provides fast, non-cached, forward-only access to Fast Infoset encoded XML data.
Class | XmlFastInfosetWriter | Represents a writer that provides a fast, non-cached, forward-only way of generating streams or files containing Fast Infoset encoded XML data.
Class | XmlFastInfosetWriterProfile | Contains the settings that specify the way FastInfoset serializes primitive data types.

Interfaces

 | Interface | Description
Interface | IVocabularyProvider | Defines the interface for resolving URI references to Fast Infoset vocabularies.

Enumerations

 | Enumeration | Description
Enumeration | FastInfosetCompression | Defines the compression algorithm to be used for compressing and decompressing data.
Enumeration | XmlFastInfosetFormat | Defines the way that Fast Infoset serializes primitive data types.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

Provides a Fast Infoset vocabulary for use by XmlFastInfosetReader.

Object Model

ReaderVocabulary Class

Syntax

Visual Basic (Declaration)
Public Class ReaderVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
C#
public class ReaderVocabulary : Vocabulary
Delphi
public class ReaderVocabulary = class(Vocabulary)
JScript
public class ReaderVocabulary extends Vocabulary
Managed Extensions for C++
public __gc class ReaderVocabulary : public Vocabulary
C++/CLI
public ref class ReaderVocabulary : public Vocabulary

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.ReaderVocabulary

See Also

Reference

ReaderVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ReaderVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

The following tables list the members exposed by ReaderVocabulary.

Public Constructors

 | Name | Description
public Constructor | ReaderVocabulary Constructor | Initializes a new instance of ParserVocabulary.
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears vocabulary tables.
public Method | SetInitialVocabulary | Sets the read-only initial vocabulary for this vocabulary.
public Method | SetReferencedVocabulary | Sets the read-only referenced vocabulary for this vocabulary.
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : ReaderVocabulary Constructor

Initializes a new instance of ParserVocabulary.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ReaderVocabulary()
C#
public ReaderVocabulary()
Delphi
public ReaderVocabulary();
JScript
public function ReaderVocabulary();
Managed Extensions for C++
public: ReaderVocabulary();
C++/CLI
public:
ReaderVocabulary();

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ReaderVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

For a list of all members of this type, see ReaderVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears vocabulary tables.
public Method | SetInitialVocabulary | Sets the read-only initial vocabulary for this vocabulary.
public Method | SetReferencedVocabulary | Sets the read-only referenced vocabulary for this vocabulary.
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddAttributeName Method

prefix
name
namespaceUri
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddAttributeName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddAttributeString Method

text
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddAttributeString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddContentString Method

text
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddContentString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddElementName Method

prefix
name
namespaceUri
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddElementName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddLocalName Method

name
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddLocalName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddNamespace Method

namespaceUri
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddNamespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : AddPrefix Method

prefix
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members
Base Implementation in AddPrefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : Clear Method

Clears vocabulary tables.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary

instance.Clear()
C#
public virtual void Clear()
Delphi
public procedure Clear(); virtual;
JScript
public function Clear();
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetInitialVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : SetInitialVocabulary Method

initialVocabulary
The vocabulary to use as initial vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.
Sets the read-only initial vocabulary for this vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetInitialVocabulary( _
   ByVal initialVocabulary As ReaderVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim initialVocabulary As ReaderVocabulary
Dim clear As Boolean

instance.SetInitialVocabulary(initialVocabulary, clear)
C#
public virtual void SetInitialVocabulary(
   ReaderVocabulary initialVocabulary,
   bool clear
)
Delphi
public procedure SetInitialVocabulary(
    initialVocabulary: ReaderVocabulary;
    clear: Boolean
); virtual;
JScript
public function SetInitialVocabulary(
   initialVocabulary : ReaderVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: virtual void SetInitialVocabulary(
   ReaderVocabulary* initialVocabulary,
   bool clear
)
C++/CLI
public:
virtual void SetInitialVocabulary(
   ReaderVocabulary^ initialVocabulary,
   bool clear
)

Parameters

initialVocabulary
The vocabulary to use as initial vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetReferencedVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > ReaderVocabulary Class : SetReferencedVocabulary Method

referencedVocabularyURI
The URI of external referenced vocabulary.
referencedVocabulary
The external referenced vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.
Sets the read-only referenced vocabulary for this vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetReferencedVocabulary( _
   ByVal referencedVocabularyURI As String, _
   ByVal referencedVocabulary As ReaderVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ReaderVocabulary
Dim referencedVocabularyURI As String
Dim referencedVocabulary As ReaderVocabulary
Dim clear As Boolean

instance.SetReferencedVocabulary(referencedVocabularyURI, referencedVocabulary, clear)
C#
public virtual void SetReferencedVocabulary(
   string referencedVocabularyURI,
   ReaderVocabulary referencedVocabulary,
   bool clear
)
Delphi
public procedure SetReferencedVocabulary(
    referencedVocabularyURI: String;
    referencedVocabulary: ReaderVocabulary;
    clear: Boolean
); virtual;
JScript
public function SetReferencedVocabulary(
   referencedVocabularyURI : String,
   referencedVocabulary : ReaderVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: virtual void SetReferencedVocabulary(
   string* referencedVocabularyURI,
   ReaderVocabulary* referencedVocabulary,
   bool clear
)
C++/CLI
public:
virtual void SetReferencedVocabulary(
   String^ referencedVocabularyURI,
   ReaderVocabulary^ referencedVocabulary,
   bool clear
)

Parameters

referencedVocabularyURI
The URI of external referenced vocabulary.
referencedVocabulary
The external referenced vocabulary.
clear
If set to true then the tables of this vocabulary will be cleared.

See Also

Reference

ReaderVocabulary Class
ReaderVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SchemaVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

Provides methods and properties for generating a Fast Infoset vocabulary from an XSD schema.

Object Model

SchemaVocabulary Class

Syntax

Visual Basic (Declaration)
Public Class SchemaVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
C#
public class SchemaVocabulary : Vocabulary
Delphi
public class SchemaVocabulary = class(Vocabulary)
JScript
public class SchemaVocabulary extends Vocabulary
Managed Extensions for C++
public __gc class SchemaVocabulary : public Vocabulary
C++/CLI
public ref class SchemaVocabulary : public Vocabulary

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.SchemaVocabulary

See Also

Reference

SchemaVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SchemaVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

The following tables list the members exposed by SchemaVocabulary.

Public Constructors

 | Name | Description
public Constructor | SchemaVocabulary Constructor |
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | CopyTo | Copies all the tables of the current vocabulary into another Vocabulary.
public Method | CreateReaderVocabulary | Overloaded. Creates a new ReadVocabulary from this SchemaVocabulary instance.
public Method | CreateWriterVocabulary | Overloaded. Creates a new WriterVocabulary from this SchemaVocabulary instance.
static (Shared in Visual Basic) | FromSchemaSet | Overloaded. Generates a new SchemaVocabulary from the XSD schema set.
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SchemaVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : SchemaVocabulary Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SchemaVocabulary()
C#
public SchemaVocabulary()
Delphi
public SchemaVocabulary();
JScript
public function SchemaVocabulary();
Managed Extensions for C++
public: SchemaVocabulary();
C++/CLI
public:
SchemaVocabulary();

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SchemaVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

For a list of all members of this type, see SchemaVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the attribute value string.
public Method | AddContentString | Overridden. Adds the content string to the vocabulary.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | CopyTo | Copies all the tables of the current vocabulary into another Vocabulary.
public Method | CreateReaderVocabulary | Overloaded. Creates a new ReadVocabulary from this SchemaVocabulary instance.
public Method | CreateWriterVocabulary | Overloaded. Creates a new WriterVocabulary from this SchemaVocabulary instance.
static (Shared in Visual Basic) | FromSchemaSet | Overloaded. Generates a new SchemaVocabulary from the XSD schema set.
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddAttributeName Method

prefix
name
namespaceUri
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddAttributeName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddAttributeString Method

text
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddAttributeString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddContentString Method

text
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddContentString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddElementName Method

prefix
name
namespaceUri
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
) override

Parameters

prefix
name
namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddElementName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddLocalName Method

name
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddLocalName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddNamespace Method

namespaceUri
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddNamespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : AddPrefix Method

prefix
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Base Implementation in AddPrefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CopyTo Method

vocabulary
The vocabulary where to copy all entries too.
Copies all the tables of the current vocabulary into another Vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal vocabulary As Vocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim vocabulary As Vocabulary

instance.CopyTo(vocabulary)
C#
public void CopyTo(
   Vocabulary vocabulary
)
Delphi
public procedure CopyTo(
    vocabulary: Vocabulary
);
JScript
public function CopyTo(
   vocabulary : Vocabulary
);
Managed Extensions for C++
public: void CopyTo(
   Vocabulary* vocabulary
)
C++/CLI
public:
void CopyTo(
   Vocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary where to copy all entries too.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReaderVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CreateReaderVocabulary Method

Creates a new ReadVocabulary from this SchemaVocabulary instance.

Overload List

Overload | Description
CreateReaderVocabulary() | Creates a new ReadVocabulary from this SchemaVocabulary instance.
CreateReaderVocabulary(XmlSchemaSet) | Creates a new ReaderVocabulary from the specified XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReaderVocabulary() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateReaderVocabulary Method : CreateReaderVocabulary() Method

Creates a new ReadVocabulary from this SchemaVocabulary instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReaderVocabulary() As ReaderVocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim value As ReaderVocabulary

value = instance.CreateReaderVocabulary()
C#
public ReaderVocabulary CreateReaderVocabulary()
Delphi
public function CreateReaderVocabulary(): ReaderVocabulary;
JScript
public function CreateReaderVocabulary() : ReaderVocabulary;
Managed Extensions for C++
public: ReaderVocabulary* CreateReaderVocabulary();
C++/CLI
public:
ReaderVocabulary^ CreateReaderVocabulary();

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReaderVocabulary(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateReaderVocabulary Method : CreateReaderVocabulary(XmlSchemaSet) Method

schemaSet
Creates a new ReaderVocabulary from the specified XSD schema set.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateReaderVocabulary( _
   ByVal schemaSet As XmlSchemaSet _
) As ReaderVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As ReaderVocabulary

value = SchemaVocabulary.CreateReaderVocabulary(schemaSet)
C#
public static ReaderVocabulary CreateReaderVocabulary(
   XmlSchemaSet schemaSet
)
Delphi
public function CreateReaderVocabulary(
    schemaSet: XmlSchemaSet
): ReaderVocabulary; static;
JScript
public static function CreateReaderVocabulary(
   schemaSet : XmlSchemaSet
) : ReaderVocabulary;
Managed Extensions for C++
public: static ReaderVocabulary* CreateReaderVocabulary(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static ReaderVocabulary^ CreateReaderVocabulary(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriterVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : CreateWriterVocabulary Method

Creates a new WriterVocabulary from this SchemaVocabulary instance.

Overload List

Overload | Description
CreateWriterVocabulary() | Creates a new WriterVocabulary from this SchemaVocabulary instance.
CreateWriterVocabulary(XmlSchemaSet) | Creates a new WriterVocabulary from the specified XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriterVocabulary() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateWriterVocabulary Method : CreateWriterVocabulary() Method

Creates a new WriterVocabulary from this SchemaVocabulary instance.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriterVocabulary() As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim instance As SchemaVocabulary
Dim value As WriterVocabulary

value = instance.CreateWriterVocabulary()
C#
public WriterVocabulary CreateWriterVocabulary()
Delphi
public function CreateWriterVocabulary(): WriterVocabulary;
JScript
public function CreateWriterVocabulary() : WriterVocabulary;
Managed Extensions for C++
public: WriterVocabulary* CreateWriterVocabulary();
C++/CLI
public:
WriterVocabulary^ CreateWriterVocabulary();

Return Value

The generated vocabulary

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriterVocabulary(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > CreateWriterVocabulary Method : CreateWriterVocabulary(XmlSchemaSet) Method

schemaSet
The schema set to be used to generate the vocabulary.
Creates a new WriterVocabulary from the specified XSD schema set.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateWriterVocabulary( _
   ByVal schemaSet As XmlSchemaSet _
) As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As WriterVocabulary

value = SchemaVocabulary.CreateWriterVocabulary(schemaSet)
C#
public static WriterVocabulary CreateWriterVocabulary(
   XmlSchemaSet schemaSet
)
Delphi
public function CreateWriterVocabulary(
    schemaSet: XmlSchemaSet
): WriterVocabulary; static;
JScript
public static function CreateWriterVocabulary(
   schemaSet : XmlSchemaSet
) : WriterVocabulary;
Managed Extensions for C++
public: static WriterVocabulary* CreateWriterVocabulary(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static WriterVocabulary^ CreateWriterVocabulary(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet
The schema set to be used to generate the vocabulary.

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FromSchemaSet Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class : FromSchemaSet Method

Generates a new SchemaVocabulary from the XSD schema set.

Overload List

Overload | Description
FromSchemaSet(XmlSchemaSet) | Generates a new SchemaVocabulary from the XSD schema set.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FromSchemaSet(XmlSchemaSet) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > SchemaVocabulary Class > FromSchemaSet Method : FromSchemaSet(XmlSchemaSet) Method

schemaSet
The XmlSchemaSet to generate vocabulary from.
Generates a new SchemaVocabulary from the XSD schema set.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function FromSchemaSet( _
   ByVal schemaSet As XmlSchemaSet _
) As SchemaVocabulary
Visual Basic (Usage) Copy Code
Dim schemaSet As XmlSchemaSet
Dim value As SchemaVocabulary

value = SchemaVocabulary.FromSchemaSet(schemaSet)
C#
public static SchemaVocabulary FromSchemaSet(
   XmlSchemaSet schemaSet
)
Delphi
public function FromSchemaSet(
    schemaSet: XmlSchemaSet
): SchemaVocabulary; static;
JScript
public static function FromSchemaSet(
   schemaSet : XmlSchemaSet
) : SchemaVocabulary;
Managed Extensions for C++
public: static SchemaVocabulary* FromSchemaSet(
   XmlSchemaSet* schemaSet
)
C++/CLI
public:
static SchemaVocabulary^ FromSchemaSet(
   XmlSchemaSet^ schemaSet
)

Parameters

schemaSet
The XmlSchemaSet to generate vocabulary from.

Return Value

The generated vocabulary.

See Also

Reference

SchemaVocabulary Class
SchemaVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Vocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

Provides the base implementation for Fast Infoset vocabularies.

Object Model

Vocabulary Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
C#
public abstract class Vocabulary
Delphi
public class Vocabulary abstract;
JScript
public abstract class Vocabulary
Managed Extensions for C++
public __gc abstract class Vocabulary
C++/CLI
public ref class Vocabulary abstract

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.ReaderVocabulary
Noemax.FastInfoset.SchemaVocabulary
Noemax.FastInfoset.WriterVocabulary

See Also

Reference

Vocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
Vocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

The following tables list the members exposed by Vocabulary.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary.
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary.
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary.
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Adds the attribute value string.
public Method | AddContentString | Adds the content string to the vocabulary.
public Method | AddElementName | Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Adds the local name to the vocabulary.
public Method | AddNamespace | Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Adds the prefix to the vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
Vocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

For a list of all members of this type, see Vocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Adds the attribute value string.
public Method | AddContentString | Adds the content string to the vocabulary.
public Method | AddElementName | Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Adds the local name to the vocabulary.
public Method | AddNamespace | Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Adds the prefix to the vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddAttributeName Method

prefix
The prefix of an attribute namespace.
name
The attribute local name.
namespaceUri
The namespace URI of an attribute.
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, name, namespaceUri)
C#
public abstract void AddAttributeName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    name: String;
    namespaceUri: String
); abstract;
JScript
public __abstract function AddAttributeName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddAttributeName(
   string* prefix,
   string* name,
   string* namespaceUri
)
C++/CLI
public:
abstract void AddAttributeName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
)

Parameters

prefix
The prefix of an attribute namespace.
name
The attribute local name.
namespaceUri
The namespace URI of an attribute.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddAttributeString Method

text
The attribute value string.
Adds the attribute value string.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public abstract void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); abstract;
JScript
public __abstract function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: abstract void AddAttributeString(
   string* text
)
C++/CLI
public:
abstract void AddAttributeString(
   String^ text
)

Parameters

text
The attribute value string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddContentString Method

text
The content string.
Adds the content string to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim text As String

instance.AddContentString(text)
C#
public abstract void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); abstract;
JScript
public __abstract function AddContentString(
   text : String
);
Managed Extensions for C++
public: abstract void AddContentString(
   string* text
)
C++/CLI
public:
abstract void AddContentString(
   String^ text
)

Parameters

text
The content string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddElementName Method

prefix
The prefix of an element namespace.
name
The local name of the element.
namespaceUri
The namespace URI of the element qualified name.
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddElementName( _
   ByVal prefix As String, _
   ByVal name As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String
Dim name As String
Dim namespaceUri As String

instance.AddElementName(prefix, name, namespaceUri)
C#
public abstract void AddElementName(
   string prefix,
   string name,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    name: String;
    namespaceUri: String
); abstract;
JScript
public __abstract function AddElementName(
   prefix : String,
   name : String,
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddElementName(
   string* prefix,
   string* name,
   string* namespaceUri
)
C++/CLI
public:
abstract void AddElementName(
   String^ prefix,
   String^ name,
   String^ namespaceUri
)

Parameters

prefix
The prefix of an element namespace.
name
The local name of the element.
namespaceUri
The namespace URI of the element qualified name.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddLocalName Method

name
The local name.
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim name As String

instance.AddLocalName(name)
C#
public abstract void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); abstract;
JScript
public __abstract function AddLocalName(
   name : String
);
Managed Extensions for C++
public: abstract void AddLocalName(
   string* name
)
C++/CLI
public:
abstract void AddLocalName(
   String^ name
)

Parameters

name
The local name.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddNamespace Method

namespaceUri
The namespace URI.
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public abstract void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); abstract;
JScript
public __abstract function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: abstract void AddNamespace(
   string* namespaceUri
)
C++/CLI
public:
abstract void AddNamespace(
   String^ namespaceUri
)

Parameters

namespaceUri
The namespace URI.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : AddPrefix Method

prefix
The prefix string.
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public abstract void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); abstract;
JScript
public __abstract function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: abstract void AddPrefix(
   string* prefix
)
C++/CLI
public:
abstract void AddPrefix(
   String^ prefix
)

Parameters

prefix
The prefix string.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
Vocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : Vocabulary Class

For a list of all members of this type, see Vocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary.
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary.
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary.
Top

See Also

Reference

Vocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExternalVocabularyURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : ExternalVocabularyURI Property

Specifies the URI to an external vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable Property ExternalVocabularyURI As String
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As String

instance.ExternalVocabularyURI = value

value = instance.ExternalVocabularyURI
C#
public virtual string ExternalVocabularyURI {get; set;}
Delphi
public read-write property ExternalVocabularyURI: String; virtual;
JScript
public function get,set ExternalVocabularyURI : String
Managed Extensions for C++
public: __property virtual string* get_ExternalVocabularyURI();
public: __property virtual void set_ExternalVocabularyURI(
   string* value
);
C++/CLI
public:
virtual property String^ ExternalVocabularyURI {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasExternalVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : HasExternalVocabulary Property

Specifies whether this vocabulary is linked to an external vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasExternalVocabulary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As Boolean

value = instance.HasExternalVocabulary
C#
public virtual bool HasExternalVocabulary {get;}
Delphi
public read-only property HasExternalVocabulary: Boolean; virtual;
JScript
public function get HasExternalVocabulary : boolean
Managed Extensions for C++
public: __property virtual bool get_HasExternalVocabulary();
C++/CLI
public:
virtual property bool HasExternalVocabulary {
   bool get();
}

Property Value

true if this vocabulary is linked to an external vocabulary, false otherwise.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasInitialVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > Vocabulary Class : HasInitialVocabulary Property

Specifies whether this vocabulary uses initial read-only vocabulary.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasInitialVocabulary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vocabulary
Dim value As Boolean

value = instance.HasInitialVocabulary
C#
public virtual bool HasInitialVocabulary {get;}
Delphi
public read-only property HasInitialVocabulary: Boolean; virtual;
JScript
public function get HasInitialVocabulary : boolean
Managed Extensions for C++
public: __property virtual bool get_HasInitialVocabulary();
C++/CLI
public:
virtual property bool HasInitialVocabulary {
   bool get();
}

Property Value

true if this vocabulary uses initial read-only vocabulary; false otherwise.

See Also

Reference

Vocabulary Class
Vocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterVocabulary Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

Provides a Fast Infoset vocabulary for use by XmlFastInfosetWriter.

Object Model

WriterVocabulary Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WriterVocabulary
   Inherits Vocabulary
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
C#
public sealed class WriterVocabulary : Vocabulary
Delphi
public class WriterVocabulary = class(Vocabulary)sealed;
JScript
public sealed class WriterVocabulary extends Vocabulary
Managed Extensions for C++
public __gc __sealed class WriterVocabulary : public Vocabulary
C++/CLI
public ref class WriterVocabulary sealed : public Vocabulary

Remarks

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.WriterVocabulary

See Also

Reference

WriterVocabulary Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
WriterVocabulary Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

The following tables list the members exposed by WriterVocabulary.

Public Constructors

 | Name | Description
public Constructor | WriterVocabulary Constructor | Creates a new WriterVocabulary.
Top

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | ReadOnlyVocabulary | Returns a read-only vocabulary used by this vocabulary.
Top

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string to the vocabulary attribute value string table.
public Method | AddContentString | Overridden. Adds the string to the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears the vocabulary.
public Method | SetExternalVocabulary | Sets an external read-only vocabulary to be used by this vocabulary.
public Method | SetInitialReadOnlyVocabulary | Overloaded. Sets an initial read-only vocabulary to be used by this vocabulary.
public Method | SetReadOnlyVocabulary | Sets a read-only vocabulary to be used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterVocabulary Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : WriterVocabulary Constructor

Creates a new WriterVocabulary.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WriterVocabulary()
C#
public WriterVocabulary()
Delphi
public WriterVocabulary();
JScript
public function WriterVocabulary();
Managed Extensions for C++
public: WriterVocabulary();
C++/CLI
public:
WriterVocabulary();

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
WriterVocabulary Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

For a list of all members of this type, see WriterVocabulary members.

Public Methods

 | Name | Description
public Method | AddAttributeName | Overridden. Adds the attribute qualified name to the vocabulary.
public Method | AddAttributeString | Overridden. Adds the string to the vocabulary attribute value string table.
public Method | AddContentString | Overridden. Adds the string to the vocabulary content string table.
public Method | AddElementName | Overridden. Adds the element qualified name to the vocabulary.
public Method | AddLocalName | Overridden. Adds the local name to the vocabulary.
public Method | AddNamespace | Overridden. Adds the namespace URI to the vocabulary.
public Method | AddPrefix | Overridden. Adds the prefix to the vocabulary.
public Method | Clear | Clears the vocabulary.
public Method | SetExternalVocabulary | Sets an external read-only vocabulary to be used by this vocabulary.
public Method | SetInitialReadOnlyVocabulary | Overloaded. Sets an initial read-only vocabulary to be used by this vocabulary.
public Method | SetReadOnlyVocabulary | Sets a read-only vocabulary to be used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddAttributeName Method

prefix
The prefix of the attribute qualified name.
localName
The local name.
namespaceUri
The namespace URI.
Adds the attribute qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddAttributeName( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String
Dim localName As String
Dim namespaceUri As String

instance.AddAttributeName(prefix, localName, namespaceUri)
C#
public override void AddAttributeName(
   string prefix,
   string localName,
   string namespaceUri
)
Delphi
public procedure AddAttributeName(
    prefix: String;
    localName: String;
    namespaceUri: String
); override;
JScript
public override function AddAttributeName(
   prefix : String,
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddAttributeName(
   string* prefix,
   string* localName,
   string* namespaceUri
) override
C++/CLI
public:
void AddAttributeName(
   String^ prefix,
   String^ localName,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of the attribute qualified name.
localName
The local name.
namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddAttributeName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddAttributeString Method

text
Adds the string to the vocabulary attribute value string table.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddAttributeString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim text As String

instance.AddAttributeString(text)
C#
public override void AddAttributeString(
   string text
)
Delphi
public procedure AddAttributeString(
    text: String
); override;
JScript
public override function AddAttributeString(
   text : String
);
Managed Extensions for C++
public: void AddAttributeString(
   string* text
) override
C++/CLI
public:
void AddAttributeString(
   String^ text
) override

Parameters

text

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddAttributeString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddContentString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddContentString Method

text
The string to add to the vocabulary.
Adds the string to the vocabulary content string table.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddContentString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim text As String

instance.AddContentString(text)
C#
public override void AddContentString(
   string text
)
Delphi
public procedure AddContentString(
    text: String
); override;
JScript
public override function AddContentString(
   text : String
);
Managed Extensions for C++
public: void AddContentString(
   string* text
) override
C++/CLI
public:
void AddContentString(
   String^ text
) override

Parameters

text
The string to add to the vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddContentString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddElementName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddElementName Method

prefix
The prefix of element qualified name.
localName
The local name.
namespaceUri
The namespace URI.
Adds the element qualified name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddElementName( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String
Dim localName As String
Dim namespaceUri As String

instance.AddElementName(prefix, localName, namespaceUri)
C#
public override void AddElementName(
   string prefix,
   string localName,
   string namespaceUri
)
Delphi
public procedure AddElementName(
    prefix: String;
    localName: String;
    namespaceUri: String
); override;
JScript
public override function AddElementName(
   prefix : String,
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void AddElementName(
   string* prefix,
   string* localName,
   string* namespaceUri
) override
C++/CLI
public:
void AddElementName(
   String^ prefix,
   String^ localName,
   String^ namespaceUri
) override

Parameters

prefix
The prefix of element qualified name.
localName
The local name.
namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddElementName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddLocalName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddLocalName Method

name
The local name.
Adds the local name to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddLocalName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim name As String

instance.AddLocalName(name)
C#
public override void AddLocalName(
   string name
)
Delphi
public procedure AddLocalName(
    name: String
); override;
JScript
public override function AddLocalName(
   name : String
);
Managed Extensions for C++
public: void AddLocalName(
   string* name
) override
C++/CLI
public:
void AddLocalName(
   String^ name
) override

Parameters

name
The local name.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddLocalName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddNamespace Method

namespaceUri
The namespace URI.
Adds the namespace URI to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddNamespace( _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim namespaceUri As String

instance.AddNamespace(namespaceUri)
C#
public override void AddNamespace(
   string namespaceUri
)
Delphi
public procedure AddNamespace(
    namespaceUri: String
); override;
JScript
public override function AddNamespace(
   namespaceUri : String
);
Managed Extensions for C++
public: void AddNamespace(
   string* namespaceUri
) override
C++/CLI
public:
void AddNamespace(
   String^ namespaceUri
) override

Parameters

namespaceUri
The namespace URI.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddNamespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : AddPrefix Method

prefix
The prefix.
Adds the prefix to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub AddPrefix( _
   ByVal prefix As String _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim prefix As String

instance.AddPrefix(prefix)
C#
public override void AddPrefix(
   string prefix
)
Delphi
public procedure AddPrefix(
    prefix: String
); override;
JScript
public override function AddPrefix(
   prefix : String
);
Managed Extensions for C++
public: void AddPrefix(
   string* prefix
) override
C++/CLI
public:
void AddPrefix(
   String^ prefix
) override

Parameters

prefix
The prefix.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Base Implementation in AddPrefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : Clear Method

Clears the vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetExternalVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetExternalVocabulary Method

externalVocabularyURI
The URI to identify the external vocabulary in the document.
externalVocabulary
The external vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the external vocabulary.
Sets an external read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub SetExternalVocabulary( _
   ByVal externalVocabularyURI As String, _
   ByVal externalVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim externalVocabularyURI As String
Dim externalVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetExternalVocabulary(externalVocabularyURI, externalVocabulary, clear)
C#
public void SetExternalVocabulary(
   string externalVocabularyURI,
   WriterVocabulary externalVocabulary,
   bool clear
)
Delphi
public procedure SetExternalVocabulary(
    externalVocabularyURI: String;
    externalVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetExternalVocabulary(
   externalVocabularyURI : String,
   externalVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetExternalVocabulary(
   string* externalVocabularyURI,
   WriterVocabulary* externalVocabulary,
   bool clear
)
C++/CLI
public:
void SetExternalVocabulary(
   String^ externalVocabularyURI,
   WriterVocabulary^ externalVocabulary,
   bool clear
)

Parameters

externalVocabularyURI
The URI to identify the external vocabulary in the document.
externalVocabulary
The external vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the external vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetInitialReadOnlyVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetInitialReadOnlyVocabulary Method

Sets an initial read-only vocabulary to be used by this vocabulary.

Overload List

Overload | Description
SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) | Sets an initial read-only vocabulary to be used by this vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class > SetInitialReadOnlyVocabulary Method : SetInitialReadOnlyVocabulary(WriterVocabulary,Boolean) Method

initialVocabulary
The initial vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the initial vocabulary.
Sets an initial read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetInitialReadOnlyVocabulary( _
   ByVal initialVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim initialVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetInitialReadOnlyVocabulary(initialVocabulary, clear)
C#
public void SetInitialReadOnlyVocabulary(
   WriterVocabulary initialVocabulary,
   bool clear
)
Delphi
public procedure SetInitialReadOnlyVocabulary(
    initialVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetInitialReadOnlyVocabulary(
   initialVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetInitialReadOnlyVocabulary(
   WriterVocabulary* initialVocabulary,
   bool clear
)
C++/CLI
public:
void SetInitialReadOnlyVocabulary(
   WriterVocabulary^ initialVocabulary,
   bool clear
)

Parameters

initialVocabulary
The initial vocabulary to use.
clear
If true, this vocabulary will be cleared prior setting the initial vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetReadOnlyVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : SetReadOnlyVocabulary Method

readOnlyVocabulary
The read-only vocabulary to use.
clear
If set to true then this vocabulary will be cleared prior setting the read-only vocabulary.
Sets a read-only vocabulary to be used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public Sub SetReadOnlyVocabulary( _
   ByVal readOnlyVocabulary As WriterVocabulary, _
   ByVal clear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim readOnlyVocabulary As WriterVocabulary
Dim clear As Boolean

instance.SetReadOnlyVocabulary(readOnlyVocabulary, clear)
C#
public void SetReadOnlyVocabulary(
   WriterVocabulary readOnlyVocabulary,
   bool clear
)
Delphi
public procedure SetReadOnlyVocabulary(
    readOnlyVocabulary: WriterVocabulary;
    clear: Boolean
);
JScript
public function SetReadOnlyVocabulary(
   readOnlyVocabulary : WriterVocabulary,
   clear : boolean
);
Managed Extensions for C++
public: void SetReadOnlyVocabulary(
   WriterVocabulary* readOnlyVocabulary,
   bool clear
)
C++/CLI
public:
void SetReadOnlyVocabulary(
   WriterVocabulary^ readOnlyVocabulary,
   bool clear
)

Parameters

readOnlyVocabulary
The read-only vocabulary to use.
clear
If set to true then this vocabulary will be cleared prior setting the read-only vocabulary.

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
WriterVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : WriterVocabulary Class

For a list of all members of this type, see WriterVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | ReadOnlyVocabulary | Returns a read-only vocabulary used by this vocabulary.
Top

See Also

Reference

WriterVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadOnlyVocabulary Property
See Also Send Feedback
Noemax.FastInfoset Namespace > WriterVocabulary Class : ReadOnlyVocabulary Property

Returns a read-only vocabulary used by this vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadOnlyVocabulary As WriterVocabulary
Visual Basic (Usage) Copy Code
Dim instance As WriterVocabulary
Dim value As WriterVocabulary

value = instance.ReadOnlyVocabulary
C#
public WriterVocabulary ReadOnlyVocabulary {get;}
Delphi
public read-only property ReadOnlyVocabulary: WriterVocabulary;
JScript
public function get ReadOnlyVocabulary : WriterVocabulary
Managed Extensions for C++
public: __property WriterVocabulary* get_ReadOnlyVocabulary();
C++/CLI
public:
property WriterVocabulary^ ReadOnlyVocabulary {
   WriterVocabulary^ get();
}

See Also

Reference

WriterVocabulary Class
WriterVocabulary Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetFactory Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

Manages XmlFastInfosetReader and XmlFastInfosetWriter objects.

Object Model

XmlFastInfosetFactory Class

Syntax

Visual Basic (Declaration)
Public Class XmlFastInfosetFactory
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
C#
public class XmlFastInfosetFactory
Delphi
public class XmlFastInfosetFactory
JScript
public class XmlFastInfosetFactory
Managed Extensions for C++
public __gc class XmlFastInfosetFactory
C++/CLI
public ref class XmlFastInfosetFactory

Remarks

The XmlFastInfosetFactory performs pooling of XmlFastInfosetReader and XmlFastInfosetWriter instances to speed up the initialization of these objects.

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.XmlFastInfosetFactory

See Also

Reference

XmlFastInfosetFactory Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetFactory Class Members
See Also Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

The following tables list the members exposed by XmlFastInfosetFactory.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetFactory Constructor |
Top

Public Methods

 | Name | Description
public Method | CreateReader | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetReader.
public Method | CreateWriter | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetWriter.
Top

See Also

Reference

XmlFastInfosetFactory Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetFactory Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : XmlFastInfosetFactory Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetFactory()
C#
public XmlFastInfosetFactory()
Delphi
public XmlFastInfosetFactory();
JScript
public function XmlFastInfosetFactory();
Managed Extensions for C++
public: XmlFastInfosetFactory();
C++/CLI
public:
XmlFastInfosetFactory();

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetFactory Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFactory Class

For a list of all members of this type, see XmlFastInfosetFactory members.

Public Methods

 | Name | Description
public Method | CreateReader | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetReader.
public Method | CreateWriter | Overloaded. Creates a new or reuses an existing instance of XmlFastInfosetWriter.
Top

See Also

Reference

XmlFastInfosetFactory Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : CreateReader Method

Creates a new or reuses an existing instance of XmlFastInfosetReader.

Overload List

Overload | Description
CreateReader() | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,XmlReaderSettings) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,XmlReaderSettings) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.
CreateReader(String,XmlReaderSettings,FastInfosetCompression) | Creates a new or reuses an existing instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader() Method

Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader() As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim value As XmlFastInfosetReader

value = instance.CreateReader()
C#
public XmlFastInfosetReader CreateReader()
Delphi
public function CreateReader(): XmlFastInfosetReader;
JScript
public function CreateReader() : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader();
C++/CLI
public:
XmlFastInfosetReader^ CreateReader();

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream) Method

stream
The stream containing the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream
)
Delphi
public function CreateReader(
    stream: Stream
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream
)

Parameters

stream
The stream containing the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String) Method

filename
The URI to the file containing the Fast Infoset document
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename)
C#
public XmlFastInfosetReader CreateReader(
   string filename
)
Delphi
public function CreateReader(
    filename: String
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename
)

Parameters

filename
The URI to the file containing the Fast Infoset document

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,XmlReaderSettings) Method

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal settings As XmlReaderSettings _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlReaderSettings
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, settings)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   XmlReaderSettings settings
)
Delphi
public function CreateReader(
    stream: Stream;
    settings: XmlReaderSettings
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   settings : XmlReaderSettings
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   XmlReaderSettings^ settings
)

Parameters

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(String,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,XmlReaderSettings) Method

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal settings As XmlReaderSettings _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlReaderSettings
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, settings)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   XmlReaderSettings settings
)
Delphi
public function CreateReader(
    filename: String;
    settings: XmlReaderSettings
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   settings : XmlReaderSettings
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   XmlReaderSettings^ settings
)

Parameters

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,FastInfosetCompression) Method

stream
The stream containing the Fast Infoset document.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, compression)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    stream: Stream;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   FastInfosetCompression compression
)

Parameters

stream
The stream containing the Fast Infoset document.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(String,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,FastInfosetCompression) Method

filename
The URI to the file containing the Fast Infoset document
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, compression)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    filename: String;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   FastInfosetCompression compression
)

Parameters

filename
The URI to the file containing the Fast Infoset document
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(Stream,XmlReaderSettings,FastInfosetCompression) Method

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal stream As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(stream, settings, compression)
C#
public XmlFastInfosetReader CreateReader(
   Stream stream,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    stream: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   stream : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   Stream* stream,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   Stream^ stream,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

stream
The stream containing the Fast Infoset document.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateReader(String,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateReader Method : CreateReader(String,XmlReaderSettings,FastInfosetCompression) Method

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.
Creates a new or reuses an existing instance of XmlFastInfosetReader.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateReader( _
   ByVal filename As String, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlFastInfosetReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlFastInfosetReader

value = instance.CreateReader(filename, settings, compression)
C#
public XmlFastInfosetReader CreateReader(
   string filename,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function CreateReader(
    filename: String;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlFastInfosetReader;
JScript
public function CreateReader(
   filename : String,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlFastInfosetReader;
Managed Extensions for C++
public: XmlFastInfosetReader* CreateReader(
   string* filename,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader^ CreateReader(
   String^ filename,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

filename
The URI to the file containing the Fast Infoset document
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used to decompress the Fast Infoset document.

Return Value

An instance of XmlFastInfosetReader.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class : CreateWriter Method

Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Overload List

Overload | Description
CreateWriter() | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,XmlWriterSettings) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,XmlWriterSettings) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.
CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new or reuses an existing instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter() Method

Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter() As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter()
C#
public XmlFastInfosetWriter CreateWriter()
Delphi
public function CreateWriter(): XmlFastInfosetWriter;
JScript
public function CreateWriter() : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter();
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter();

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream) Method

stream
The stream to which you want to write.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream
)
Delphi
public function CreateWriter(
    stream: Stream
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream
)

Parameters

stream
The stream to which you want to write.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String) Method

filename
The URI of the file to write.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename
)
Delphi
public function CreateWriter(
    filename: String
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename
)

Parameters

filename
The URI of the file to write.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,XmlWriterSettings) Method

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal settings As XmlWriterSettings _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlWriterSettings
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, settings)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   XmlWriterSettings settings
)
Delphi
public function CreateWriter(
    stream: Stream;
    settings: XmlWriterSettings
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   settings : XmlWriterSettings
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   XmlWriterSettings^ settings
)

Parameters

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(String,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,XmlWriterSettings) Method

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal settings As XmlWriterSettings _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlWriterSettings
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, settings)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   XmlWriterSettings settings
)
Delphi
public function CreateWriter(
    filename: String;
    settings: XmlWriterSettings
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   settings : XmlWriterSettings
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   XmlWriterSettings^ settings
)

Parameters

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,FastInfosetCompression,Int32) Method

stream
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    stream: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

stream
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal stream As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim stream As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(stream, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   Stream stream,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    stream: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   stream : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   Stream* stream,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   Stream^ stream,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

stream
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(String,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,FastInfosetCompression,Int32) Method

filename
The URI of the file to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    filename: String;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

filename
The URI of the file to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetFactory Class > CreateWriter Method : CreateWriter(String,XmlWriterSettings,FastInfosetCompression,Int32) Method

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new or reuses an existing instance of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateWriter( _
   ByVal filename As String, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlFastInfosetWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFactory
Dim filename As String
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlFastInfosetWriter

value = instance.CreateWriter(filename, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter CreateWriter(
   string filename,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function CreateWriter(
    filename: String;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlFastInfosetWriter;
JScript
public function CreateWriter(
   filename : String,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlFastInfosetWriter;
Managed Extensions for C++
public: XmlFastInfosetWriter* CreateWriter(
   string* filename,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter^ CreateWriter(
   String^ filename,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

filename
The URI of the file to write.
settings
The XmlWriterSettings object used to configure the new XmlFastInfosetWriter instance.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An instance of XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetFactory Class
XmlFastInfosetFactory Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

Represents a reader that provides fast, non-cached, forward-only access to Fast Infoset encoded XML data.

Object Model

XmlFastInfosetReader Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class XmlFastInfosetReader
   Inherits System.Xml.XmlReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
C#
[DefaultMemberAttribute("Item")]
public sealed class XmlFastInfosetReader : System.Xml.XmlReader
Delphi
public class XmlFastInfosetReader = class(System.Xml.XmlReader)sealed;
JScript
DefaultMemberAttribute("Item")
public sealed class XmlFastInfosetReader extends System.Xml.XmlReader
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class XmlFastInfosetReader : public System.Xml.XmlReader
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class XmlFastInfosetReader sealed : public System.Xml.XmlReader

Inheritance Hierarchy

System.Object
System.Xml.XmlReader
Noemax.FastInfoset.XmlFastInfosetReader

See Also

Reference

XmlFastInfosetReader Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

The following tables list the members exposed by XmlFastInfosetReader.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetReader Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | Overridden. Gets a value indicating whether this reader can parse and resolve entities. Always returns false.
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | Overridden. Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overridden. Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class.
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | MaxDepth | Gets and sets the maximum nested node depth.
public Property | MaxNodeContentLength | Gets and sets the maximum length of the node content in bytes.
public Property | Name | Overridden. Gets the qualified name of the current node.
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of an attribute node.
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetReader class.
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadAs<T> | Reads the value from the current position in the stream as the type specified.
public Method | ReadAsBoolean | Reads a single or multiple occurrences of boolean values from the current position.
public Method | ReadAsDouble | Reads a single or multiple occurrences of double-precision floating-point values from the current position.
public Method | ReadAsFloat | Reads a single or multiple occurrences of single-precision floating-point values from the current position.
public Method | ReadAsInt | Reads a single or multiple occurrences of 32-bit integer values from the current position.
public Method | ReadAsLong | Reads a single or multiple occurrences of 64-bit integer values from the current position.
public Method | ReadAsShort | Reads a single or multiple occurrences of 16-bit integer values from the current position.
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBase64 | Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadBinHex | Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadContentAs | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsDateTime | Overridden. Reads the text content at the current position as a DateTime object.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsShort | Reads the text content at the current position as a 16-bit signed integer.
public Method | ReadContentAsString | Overridden. Reads the text content at the current position as a string.
public Method | ReadElementContentAs | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Reads the current element and returns the content as a boolean value.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Reads the node content at the current position as a decimal value.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Reads the current element and returns the content as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Reads the current element and returns the content as a single-precision floating-point number.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Reads the current element and returns the content as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Reads the current element and returns the content as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsShort | Reads the current element and returns the content as a 16-bit signed integer.
public Method | ReadElementContentAsString | Overloaded. Overridden. Reads the current element and returns the contents as a String object.
public Method | ReadElementString | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
public Method | ReadString | Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Sets the vocabulary to be used when read a Fast Infoset document.
public Method | Skip | (Inherited from System.Xml.XmlReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlFastInfosetReader Constructor

Overload List

Overload | Description
XmlFastInfosetReader Constructor() | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,FastInfosetCompression) | Initializes a new instance of the XmlFastInfosetReader class.
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression) | Initializes a new instance of the XmlFastInfosetReader class.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor()
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor()

Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetReader()
C#
public XmlFastInfosetReader()
Delphi
public XmlFastInfosetReader();
JScript
public function XmlFastInfosetReader();
Managed Extensions for C++
public: XmlFastInfosetReader();
C++/CLI
public:
XmlFastInfosetReader();

Remarks

This constructor creates an instance of XmlFastInfosetReader which is is not associated with any stream and is intended for reusing the same reader for reading more than one stream.

If you use this constructor you must initialize the reader by calling Init before using it.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor(Stream)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream)

input

The stream containing the Fast Infoset encoded XML data to read.

Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream _
)
Visual Basic (Usage) Copy Code
Dim input As Stream

Dim instance As New XmlFastInfosetReader(input)
C#
public XmlFastInfosetReader(
   Stream input
)
Delphi
public XmlFastInfosetReader(
    input: Stream
);
JScript
public function XmlFastInfosetReader(
   input : Stream
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,XmlReaderSettings)

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings

Dim instance As New XmlFastInfosetReader(input, settings)
C#
public XmlFastInfosetReader(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    settings: XmlReaderSettings
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   settings : XmlReaderSettings
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor(Stream,FastInfosetCompression)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,FastInfosetCompression)

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to be used for decompressing the data.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim compression As FastInfosetCompression

Dim instance As New XmlFastInfosetReader(input, compression)
C#
public XmlFastInfosetReader(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    compression: FastInfosetCompression
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to be used for decompressing the data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > XmlFastInfosetReader Constructor : XmlFastInfosetReader Constructor(Stream,XmlReaderSettings,FastInfosetCompression)

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used for decompressing the data.
Initializes a new instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression

Dim instance As New XmlFastInfosetReader(input, settings, compression)
C#
public XmlFastInfosetReader(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public XmlFastInfosetReader(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
);
JScript
public function XmlFastInfosetReader(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: XmlFastInfosetReader(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
XmlFastInfosetReader(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
XmlReaderSettings object to configure the new XmlFastInfosetReader instance.
compression
The compression algorithm to be used for decompressing the data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

For a list of all members of this type, see XmlFastInfosetReader members.

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetReader class.
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadAs<T> | Reads the value from the current position in the stream as the type specified.
public Method | ReadAsBoolean | Reads a single or multiple occurrences of boolean values from the current position.
public Method | ReadAsDouble | Reads a single or multiple occurrences of double-precision floating-point values from the current position.
public Method | ReadAsFloat | Reads a single or multiple occurrences of single-precision floating-point values from the current position.
public Method | ReadAsInt | Reads a single or multiple occurrences of 32-bit integer values from the current position.
public Method | ReadAsLong | Reads a single or multiple occurrences of 64-bit integer values from the current position.
public Method | ReadAsShort | Reads a single or multiple occurrences of 16-bit integer values from the current position.
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBase64 | Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadBinHex | Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.
public Method | ReadContentAs | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsDateTime | Overridden. Reads the text content at the current position as a DateTime object.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsShort | Reads the text content at the current position as a 16-bit signed integer.
public Method | ReadContentAsString | Overridden. Reads the text content at the current position as a string.
public Method | ReadElementContentAs | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded element content and returns the decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Reads the current element and returns the content as a boolean value.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Reads the node content at the current position as a decimal value.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Reads the current element and returns the content as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Reads the current element and returns the content as a single-precision floating-point number.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Reads the current element and returns the content as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Reads the current element and returns the content as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsShort | Reads the current element and returns the content as a 16-bit signed integer.
public Method | ReadElementContentAsString | Overloaded. Overridden. Reads the current element and returns the contents as a String object.
public Method | ReadElementString | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
public Method | ReadString | Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Sets the vocabulary to be used when read a Fast Infoset document.
public Method | Skip | (Inherited from System.Xml.XmlReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Clear Method

Clears the internal state of the reader.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

Clears the internal state of the reader. After a call to this method the reader remains in an uninitialized state. You must call the Init method in order to reuse the reader for reading another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Close Method

Changes the ReadState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseInput is true, the underlying stream is going to be closed as well.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Create Method

Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Overload List

Overload | Description
Create(Stream) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
Create(String) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file.
Create(Stream,XmlReaderSettings) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream using an XmlReaderSettings object.
Create(String,XmlReaderSettings) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(String,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(Stream,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.
Create(Stream,XmlReaderSettings,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.
Create(String,XmlReaderSettings,FastInfosetCompression) | Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream) Method

input
The stream containing the Fast Infoset encoded XML data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input)
C#
public static XmlReader Create(
   Stream input
)
Delphi
public function Create(
    input: Stream
): XmlReader; static;
JScript
public static function Create(
   input : Stream
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input
)

Parameters

input
The stream containing the Fast Infoset encoded XML data.

Return Value

An XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String) Method

inputFileName
The system path to the file containing the Fast Infoset encoded XML data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName)
C#
public static XmlReader Create(
   string inputFileName
)
Delphi
public function Create(
    inputFileName: String
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName
)

Parameters

inputFileName
The system path to the file containing the Fast Infoset encoded XML data.

Return Value

An System.Xml.XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,XmlReaderSettings) Method

input
The stream containing the FastInfoset encoded XML data.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance. This value can be null.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, settings)
C#
public static XmlReader Create(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public function Create(
    input: Stream;
    settings: XmlReaderSettings
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   settings : XmlReaderSettings
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input
The stream containing the FastInfoset encoded XML data.
settings
The XmlReaderSettings object used to configure the new XmlFastInfosetReader instance. This value can be null.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,XmlReaderSettings) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal settings As XmlReaderSettings _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim settings As XmlReaderSettings
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, settings)
C#
public static XmlReader Create(
   string inputFileName,
   XmlReaderSettings settings
)
Delphi
public function Create(
    inputFileName: String;
    settings: XmlReaderSettings
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   settings : XmlReaderSettings
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   XmlReaderSettings* settings
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   XmlReaderSettings^ settings
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,FastInfosetCompression) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, compression)
C#
public static XmlReader Create(
   string inputFileName,
   FastInfosetCompression compression
)
Delphi
public function Create(
    inputFileName: String;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   FastInfosetCompression compression
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,FastInfosetCompression) Method

input
The stream containing the Fast Infoset encoded XML data.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, compression)
C#
public static XmlReader Create(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public function Create(
    input: Stream;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input
The stream containing the Fast Infoset encoded XML data.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the Fast Infoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(Stream,XmlReaderSettings,FastInfosetCompression) Method

input
The stream containing the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(input, settings, compression)
C#
public static XmlReader Create(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function Create(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input
The stream containing the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Create Method : Create(String,XmlReaderSettings,FastInfosetCompression) Method

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.
Creates a new XmlReader instance for reading the Fast Infoset encoded XML file using an XmlReaderSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal inputFileName As String, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
) As XmlReader
Visual Basic (Usage) Copy Code
Dim inputFileName As String
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression
Dim value As XmlReader

value = XmlFastInfosetReader.Create(inputFileName, settings, compression)
C#
public static XmlReader Create(
   string inputFileName,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public function Create(
    inputFileName: String;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
): XmlReader; static;
JScript
public static function Create(
   inputFileName : String,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
) : XmlReader;
Managed Extensions for C++
public: static XmlReader* Create(
   string* inputFileName,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
static XmlReader^ Create(
   String^ inputFileName,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

inputFileName
The path to the file with the FastInfoset encoded XML data.
settings
The System.Xml.XmlReaderSettings to configure the new XmlFastInfosetReader instance. This value can be null.
compression
The compression algorithm to decompress the data.

Return Value

An XmlReader object to read the FastInfoset encoded XML data.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : GetAttribute Method

Gets the value of an attribute.

Overload List

Overload | Description
GetAttribute(Int32) | Gets the value of an attribute.
GetAttribute(String) | Gets the value of an attribute.
GetAttribute(String,String) | Gets the value of an attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in GetAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(Int32) Method

i
The index of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer
Dim value As String

value = instance.GetAttribute(i)
C#
public override string GetAttribute(
   int i
)
Delphi
public function GetAttribute(
    i: Integer
): String; override;
JScript
public override function GetAttribute(
   i : int
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   int i
) override
C++/CLI
public:
String^ GetAttribute(
   int i
) override

Parameters

i
The index of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in GetAttribute(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(String) Method

name
The name of an attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As String

value = instance.GetAttribute(name)
C#
public override string GetAttribute(
   string name
)
Delphi
public function GetAttribute(
    name: String
): String; override;
JScript
public override function GetAttribute(
   name : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name
) override

Parameters

name
The name of an attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in GetAttribute(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > GetAttribute Method : GetAttribute(String,String) Method

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim namespaceURI As String
Dim value As String

value = instance.GetAttribute(name, namespaceURI)
C#
public override string GetAttribute(
   string name,
   string namespaceURI
)
Delphi
public function GetAttribute(
    name: String;
    namespaceURI: String
): String; override;
JScript
public override function GetAttribute(
   name : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name,
   string* namespaceURI
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name,
   String^ namespaceURI
) override

Parameters

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in GetAttribute(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Init Method

Initializes an instance of the XmlFastInfosetReader class.

Overload List

Overload | Description
Init(Stream,XmlReaderSettings) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream,XmlReaderSettings,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream) | Initializes an instance of the XmlFastInfosetReader class.
Init(Stream,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Byte[],Int32,Int32,FastInfosetCompression) | Initializes an instance of the XmlFastInfosetReader class.
Init(Byte[],Int32,Int32) | Initializes an instance of the XmlFastInfosetReader class.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,XmlReaderSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,XmlReaderSettings) Method

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim settings As XmlReaderSettings

instance.Init(input, settings)
C#
public void Init(
   Stream input,
   XmlReaderSettings settings
)
Delphi
public procedure Init(
    input: Stream;
    settings: XmlReaderSettings
);
JScript
public function Init(
   input : Stream,
   settings : XmlReaderSettings
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   XmlReaderSettings* settings
)
C++/CLI
public:
void Init(
   Stream^ input,
   XmlReaderSettings^ settings
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,XmlReaderSettings,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,XmlReaderSettings,FastInfosetCompression) Method

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
compression
The compression algorithm to be used for decompressing the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal settings As XmlReaderSettings, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim settings As XmlReaderSettings
Dim compression As FastInfosetCompression

instance.Init(input, settings, compression)
C#
public void Init(
   Stream input,
   XmlReaderSettings settings,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Stream;
    settings: XmlReaderSettings;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : Stream,
   settings : XmlReaderSettings,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   XmlReaderSettings* settings,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   Stream^ input,
   XmlReaderSettings^ settings,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

settings
The XmlReaderSettings object used to configure the reader.
compression
The compression algorithm to be used for decompressing the data.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream) Method

input

The stream containing the Fast Infoset encoded XML data to read.

Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream

instance.Init(input)
C#
public void Init(
   Stream input
)
Delphi
public procedure Init(
    input: Stream
);
JScript
public function Init(
   input : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* input
)
C++/CLI
public:
void Init(
   Stream^ input
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Stream,FastInfosetCompression) Method

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to decompress the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input As Stream, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input As Stream
Dim compression As FastInfosetCompression

instance.Init(input, compression)
C#
public void Init(
   Stream input,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Stream;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : Stream,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   Stream* input,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   Stream^ input,
   FastInfosetCompression compression
)

Parameters

input

The stream containing the Fast Infoset encoded XML data to read.

compression
The compression algorithm to decompress the data.

Remarks

Initializes the reader and sets it to use the provided stream as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Byte[],Int32,Int32,FastInfosetCompression) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Byte[],Int32,Int32,FastInfosetCompression) Method

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

compression
The compression algorithm to decompress the data.
Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer, _
   ByVal compression As FastInfosetCompression _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input() As Byte
Dim offset As Integer
Dim length As Integer
Dim compression As FastInfosetCompression

instance.Init(input, offset, length, compression)
C#
public void Init(
   byte[] input,
   int offset,
   int length,
   FastInfosetCompression compression
)
Delphi
public procedure Init(
    input: Bytearray of;
    offset: Integer;
    length: Integer;
    compression: FastInfosetCompression
);
JScript
public function Init(
   input : byte[],
   offset : int,
   length : int,
   compression : FastInfosetCompression
);
Managed Extensions for C++
public: void Init(
   byte[]* input,
   int offset,
   int length,
   FastInfosetCompression compression
)
C++/CLI
public:
void Init(
   array<byte>^ input,
   int offset,
   int length,
   FastInfosetCompression compression
)

Parameters

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

compression
The compression algorithm to decompress the data.

Remarks

Initializes the reader and sets it to use the provided array of bytes as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another source.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > Init Method : Init(Byte[],Int32,Int32) Method

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

Initializes an instance of the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim input() As Byte
Dim offset As Integer
Dim length As Integer

instance.Init(input, offset, length)
C#
public void Init(
   byte[] input,
   int offset,
   int length
)
Delphi
public procedure Init(
    input: Bytearray of;
    offset: Integer;
    length: Integer
);
JScript
public function Init(
   input : byte[],
   offset : int,
   length : int
);
Managed Extensions for C++
public: void Init(
   byte[]* input,
   int offset,
   int length
)
C++/CLI
public:
void Init(
   array<byte>^ input,
   int offset,
   int length
)

Parameters

input

The an array of bytes containing the Fast Infoset encoded XML data to read.

offset

The offset in the array of bytes to start reading from.

length

The number of byte starting from the offset that contain FastInfoset encoded XML data.

Remarks

Initializes the reader and sets it to use the provided array of bytes as input.

This method allows the reuse of the XmlFastInfosetReader for reading from another source.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsStartElement Method

Tests if the current content node is a start element.

Overload List

Overload | Description
IsStartElement() | Tests if the current content node is a start tag.
IsStartElement(String,String) | Tests if the current content node is a start element with specified name and namespace.
IsStartElement(String) | Tests if the current content node is a start element with specified name and namespace.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in IsStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement() Method

Tests if the current content node is a start tag.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsStartElement()
C#
public override bool IsStartElement()
Delphi
public function IsStartElement(): Boolean; override;
JScript
public override function IsStartElement() : boolean;
Managed Extensions for C++
public: bool IsStartElement(); override
C++/CLI
public:
bool IsStartElement(); override

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in IsStartElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement(String,String) Method

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String
Dim value As Boolean

value = instance.IsStartElement(localname, ns)
C#
public override bool IsStartElement(
   string localname,
   string ns
)
Delphi
public function IsStartElement(
    localname: String;
    ns: String
): Boolean; override;
JScript
public override function IsStartElement(
   localname : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
bool IsStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in IsStartElement(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > IsStartElement Method : IsStartElement(String) Method

name
The string to match against the Name property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function IsStartElement( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.IsStartElement(name)
C#
public override bool IsStartElement(
   string name
)
Delphi
public function IsStartElement(
    name: String
): Boolean; override;
JScript
public override function IsStartElement(
   name : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* name
) override
C++/CLI
public:
bool IsStartElement(
   String^ name
) override

Parameters

name
The string to match against the Name property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in IsStartElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LookupNamespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : LookupNamespace Method

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Resolves the namespace prefix in the current element's scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function LookupNamespace( _
   ByVal prefix As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim prefix As String
Dim value As String

value = instance.LookupNamespace(prefix)
C#
public override string LookupNamespace(
   string prefix
)
Delphi
public function LookupNamespace(
    prefix: String
): String; override;
JScript
public override function LookupNamespace(
   prefix : String
) : String;
Managed Extensions for C++
public: string* LookupNamespace(
   string* prefix
) override
C++/CLI
public:
String^ LookupNamespace(
   String^ prefix
) override

Parameters

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Return Value

The namespace URI to which the prefix maps or a null reference (Nothing in Visual Basic) if no matching prefix is found.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in LookupNamespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToAttribute Method

Moves to the specified attribute.

Overload List

Overload | Description
MoveToAttribute(Int32) | Moves to the attribute specified by the index.
MoveToAttribute(String) | Moves to the attribute specified by the qualified name.
MoveToAttribute(String,String) | Moves to the attribute specified by the local name and namespace URI.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in MoveToAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(Int32) Method

i
The index of the attribute.
Moves to the attribute specified by the index.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub MoveToAttribute( _
   ByVal i As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer

instance.MoveToAttribute(i)
C#
public override void MoveToAttribute(
   int i
)
Delphi
public procedure MoveToAttribute(
    i: Integer
); override;
JScript
public override function MoveToAttribute(
   i : int
);
Managed Extensions for C++
public: void MoveToAttribute(
   int i
) override
C++/CLI
public:
void MoveToAttribute(
   int i
) override

Parameters

i
The index of the attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in MoveToAttribute(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(String) Method

name
The qualified name of the attribute.
Moves to the attribute specified by the qualified name.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.MoveToAttribute(name)
C#
public override bool MoveToAttribute(
   string name
)
Delphi
public function MoveToAttribute(
    name: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name
) override

Parameters

name
The qualified name of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in MoveToAttribute(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > MoveToAttribute Method : MoveToAttribute(String,String) Method

name
The local name of the attribute.
ns
The namespace URI of the attribute.
Moves to the attribute specified by the local name and namespace URI.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function MoveToAttribute( _
   ByVal name As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim ns As String
Dim value As Boolean

value = instance.MoveToAttribute(name, ns)
C#
public override bool MoveToAttribute(
   string name,
   string ns
)
Delphi
public function MoveToAttribute(
    name: String;
    ns: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name,
   string* ns
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name,
   String^ ns
) override

Parameters

name
The local name of the attribute.
ns
The namespace URI of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in MoveToAttribute(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToContent Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToContent Method

Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToContent() As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNodeType

value = instance.MoveToContent()
C#
public override XmlNodeType MoveToContent()
Delphi
public function MoveToContent(): XmlNodeType; override;
JScript
public override function MoveToContent() : XmlNodeType;
Managed Extensions for C++
public: XmlNodeType MoveToContent(); override
C++/CLI
public:
XmlNodeType MoveToContent(); override

Return Value

The NodeType of the current node found by the method or XmlNodeType.None if the reader has reached the end of the input stream.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in MoveToContent


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToElement Method

Moves to the element that contains the current attribute node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToElement()
C#
public override bool MoveToElement()
Delphi
public function MoveToElement(): Boolean; override;
JScript
public override function MoveToElement() : boolean;
Managed Extensions for C++
public: bool MoveToElement(); override
C++/CLI
public:
bool MoveToElement(); override

Return Value

true if the reader is positioned on an attribute (the reader moves to the element that owns the attribute); false if the reader is not positioned on an attribute (the position of the reader does not change).

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in MoveToElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToFirstAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToFirstAttribute Method

Moves to the first attribute.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToFirstAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToFirstAttribute()
C#
public override bool MoveToFirstAttribute()
Delphi
public function MoveToFirstAttribute(): Boolean; override;
JScript
public override function MoveToFirstAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToFirstAttribute(); override
C++/CLI
public:
bool MoveToFirstAttribute(); override

Return Value

true if an attribute exists (the reader moves to the first attribute); otherwise, false (the position of the reader does not change).

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in MoveToFirstAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToNextAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MoveToNextAttribute Method

Moves to the next attribute.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function MoveToNextAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.MoveToNextAttribute()
C#
public override bool MoveToNextAttribute()
Delphi
public function MoveToNextAttribute(): Boolean; override;
JScript
public override function MoveToNextAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToNextAttribute(); override
C++/CLI
public:
bool MoveToNextAttribute(); override

Return Value

true if there is a next attribute; false if there are no more attributes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in MoveToNextAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Read Method

Reads the next node from the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.Read()
C#
public override bool Read()
Delphi
public function Read(): Boolean; override;
JScript
public override function Read() : boolean;
Managed Extensions for C++
public: bool Read(); override
C++/CLI
public:
bool Read(); override

Return Value

true if the next node was read successfully; false if there are no more nodes to read.

Remarks

When an XmlFastInfosetReader is first created and initialized, there is no information available. You must call Read to read the first node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Read


%%PageItemTitle%%

T
The type to which the value read should be converted to.
[image]
Noemax WCF-Xtensions
ReadAs<T> Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAs<T> Method

Reads the value from the current position in the stream as the type specified.

Syntax

Visual Basic (Declaration)
Public Function ReadAs(Of T)() As T
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As T

value = instance.ReadAs(Of T)()
C#
public T ReadAs<T>()
Delphi
public function ReadAs(): T;
JScript
public function ReadAs() : T;
Managed Extensions for C++
public: T* ReadAs<T>();
C++/CLI
public:
T^ ReadAsgeneric<typename T>
();

Type Parameters

T
The type to which the value read should be converted to.

Return Value

The value of the type T read from the stream.

Remarks

If the value in the stream was encoded as a different type, the reader converts it to the required type. For example if the stream contains a binary encoded int value and a double value was requested, the reader will perform an int to double conversion automatically.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsBoolean Method

Reads a single or multiple occurrences of boolean values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsBoolean() As Boolean()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Boolean

value = instance.ReadAsBoolean()
C#
public bool[] ReadAsBoolean()
Delphi
public function ReadAsBoolean(): array of Boolean;
JScript
public function ReadAsBoolean() : boolean[];
Managed Extensions for C++
public: bool[]* ReadAsBoolean();
C++/CLI
public:
array<bool>^ ReadAsBoolean();

Return Value

The boolean values read.

Remarks

The ReadAsBoolean method reads a single or multiple boolean values from the current position in the content.

The boolean values must have been encoded using Fast Infoset's binary encoding of boolean values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsDouble Method

Reads a single or multiple occurrences of double-precision floating-point values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsDouble() As Double()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Double

value = instance.ReadAsDouble()
C#
public double[] ReadAsDouble()
Delphi
public function ReadAsDouble(): array of Double;
JScript
public function ReadAsDouble() : double[];
Managed Extensions for C++
public: double[]* ReadAsDouble();
C++/CLI
public:
array<double>^ ReadAsDouble();

Return Value

The double-precision floating-point values read.

Remarks

The ReadAsDouble method reads a single or multiple double values from the current position in the content.

The double values must have been encoded using Fast Infoset's binary encoding of double values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsFloat Method

Reads a single or multiple occurrences of single-precision floating-point values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsFloat() As Single()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Single

value = instance.ReadAsFloat()
C#
public float[] ReadAsFloat()
Delphi
public function ReadAsFloat(): array of Single;
JScript
public function ReadAsFloat() : float[];
Managed Extensions for C++
public: float[]* ReadAsFloat();
C++/CLI
public:
array<float>^ ReadAsFloat();

Return Value

The single-precision floating-point values read.

Remarks

The ReadAsFloat method reads a single or multiple single values from the current position in the content.

The single values must have been encoded using Fast Infoset's binary encoding of single values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsInt Method

Reads a single or multiple occurrences of 32-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsInt() As Integer()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Integer

value = instance.ReadAsInt()
C#
public int[] ReadAsInt()
Delphi
public function ReadAsInt(): array of Integer;
JScript
public function ReadAsInt() : int[];
Managed Extensions for C++
public: int[]* ReadAsInt();
C++/CLI
public:
array<int>^ ReadAsInt();

Return Value

The 32-bit integer values read.

Remarks

The ReadAsInt method reads a single or multiple integer values from the current position in the content.

The integer values must have been encoded using Fast Infoset's binary encoding of integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsLong Method

Reads a single or multiple occurrences of 64-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsLong() As Long()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Long

value = instance.ReadAsLong()
C#
public long[] ReadAsLong()
Delphi
public function ReadAsLong(): array of Int64;
JScript
public function ReadAsLong() : long[];
Managed Extensions for C++
public: long[]* ReadAsLong();
C++/CLI
public:
array<int64>^ ReadAsLong();

Return Value

The 64-bit integer values read.

Remarks

The ReadAsLong method reads a single or multiple long integer values from the current position in the content.

The long integer values must have been encoded using Fast Infoset's binary encoding of long integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAsShort Method

Reads a single or multiple occurrences of 16-bit integer values from the current position.

Syntax

Visual Basic (Declaration)
Public Function ReadAsShort() As Short()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Short

value = instance.ReadAsShort()
C#
public short[] ReadAsShort()
Delphi
public function ReadAsShort(): array of ShortInt;
JScript
public function ReadAsShort() : short[];
Managed Extensions for C++
public: short[]* ReadAsShort();
C++/CLI
public:
array<short>^ ReadAsShort();

Return Value

The 16-bit integer values read.

Remarks

The ReadAsShort method reads a single or multiple short integer values from the current position in the content.

The short integer values must have been encoded using Fast Infoset's binary encoding of short integer values.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAttributeValue Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadAttributeValue Method

Reads the attribute value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadAttributeValue() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadAttributeValue()
C#
public override bool ReadAttributeValue()
Delphi
public function ReadAttributeValue(): Boolean; override;
JScript
public override function ReadAttributeValue() : boolean;
Managed Extensions for C++
public: bool ReadAttributeValue(); override
C++/CLI
public:
bool ReadAttributeValue(); override

Return Value

true if there are nodes to return. false if the reader is not positioned on an attribute node when the initial call is made or if all the attribute values have been read.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadAttributeValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadBase64 Method

Reads a Base64 value from the current position in the element content and decodes it into an array of bytes.

Syntax

Visual Basic (Declaration)
Public Function ReadBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadBase64()
C#
public byte[] ReadBase64()
Delphi
public function ReadBase64(): array of Byte;
JScript
public function ReadBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadBase64();
C++/CLI
public:
array<byte>^ ReadBase64();

Return Value

An array of bytes read.

Remarks

If the node at the current position is Fast Infoset binary encoded Base64 bytes, the reader returns these bytes without transformation.

If the current node is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadBinHex Method

Reads a hexadecimal value from the current position in the element content and decodes it into an array of bytes.

Syntax

Visual Basic (Declaration)
Public Function ReadBinHex() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadBinHex()
C#
public byte[] ReadBinHex()
Delphi
public function ReadBinHex(): array of Byte;
JScript
public function ReadBinHex() : byte[];
Managed Extensions for C++
public: byte[]* ReadBinHex();
C++/CLI
public:
array<byte>^ ReadBinHex();

Return Value

An array of bytes read.

Remarks

If the node at the current position is Fast Infoset binary encoded BinHex bytes, the reader returns these bytes without transformation.

If the current node is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBase64 Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Overload List

Overload | Description
ReadContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
ReadContentAsBase64() | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadContentAsBase64 Method : ReadContentAsBase64(Byte[],Int32,Int32) Method

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method.
Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBase64(buffer, index, count)
C#
public override int ReadContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method.

Return Value

The number of bytes written to the buffer.

Remarks

If the content is binary encoded Base64 bytes, the reader returns the bytes read. If the content is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadContentAsBase64 Method : ReadContentAsBase64() Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadContentAsBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value() As Byte

value = instance.ReadContentAsBase64()
C#
public byte[] ReadContentAsBase64()
Delphi
public function ReadContentAsBase64(): array of Byte;
JScript
public function ReadContentAsBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadContentAsBase64();
C++/CLI
public:
array<byte>^ ReadContentAsBase64();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBinHex Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method
Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBinHex(buffer, index, count)
C#
public override int ReadContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned by this method

Return Value

The number of bytes written to the buffer.

Remarks

If the content is binary encoded BinHex bytes, the reader returns the bytes read. If the content is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsBoolean Method

Reads the content at the current position as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadContentAsBoolean()
C#
public override bool ReadContentAsBoolean()
Delphi
public function ReadContentAsBoolean(): Boolean; override;
JScript
public override function ReadContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadContentAsBoolean(); override
C++/CLI
public:
bool ReadContentAsBoolean(); override

Return Value

The content as a boolean value.

Remarks

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsBoolean


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDateTime Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDateTime Method

Reads the text content at the current position as a DateTime object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Date

value = instance.ReadContentAsDateTime()
C#
public override DateTime ReadContentAsDateTime()
Delphi
public function ReadContentAsDateTime(): DateTime; override;
JScript
public override function ReadContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadContentAsDateTime(); override
C++/CLI
public:
DateTime ReadContentAsDateTime(); override

Return Value

The text content as a DateTime object.

Remarks

Implements XmlReader.ReadContentAsDateTime.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsDateTime


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDecimal Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDecimal Method

Reads the text content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Decimal

value = instance.ReadContentAsDecimal()
C#
public override decimal ReadContentAsDecimal()
Delphi
public function ReadContentAsDecimal(): Currency; override;
JScript
public override function ReadContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadContentAsDecimal(); override
C++/CLI
public:
decimal ReadContentAsDecimal(); override

Return Value

The text content as a decimal value.

Remarks

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsDecimal


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsDouble Method

Reads the content at the current position as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Double

value = instance.ReadContentAsDouble()
C#
public override double ReadContentAsDouble()
Delphi
public function ReadContentAsDouble(): Double; override;
JScript
public override function ReadContentAsDouble() : double;
Managed Extensions for C++
public: double ReadContentAsDouble(); override
C++/CLI
public:
double ReadContentAsDouble(); override

Return Value

The content as a double-precision floating-point number.

Remarks

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsDouble


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsFloat Method

Reads the content at the current position as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Single

value = instance.ReadContentAsFloat()
C#
public override float ReadContentAsFloat()
Delphi
public function ReadContentAsFloat(): Single; override;
JScript
public override function ReadContentAsFloat() : float;
Managed Extensions for C++
public: float ReadContentAsFloat(); override
C++/CLI
public:
float ReadContentAsFloat(); override

Return Value

The content as a single-precision floating-point number.

Remarks

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsFloat


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsInt Method

Reads the text content at the current position as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.ReadContentAsInt()
C#
public override int ReadContentAsInt()
Delphi
public function ReadContentAsInt(): Integer; override;
JScript
public override function ReadContentAsInt() : int;
Managed Extensions for C++
public: int ReadContentAsInt(); override
C++/CLI
public:
int ReadContentAsInt(); override

Return Value

The content as a 32-bit signed integer.

Remarks

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsInt


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsLong Method

Reads the text content at the current position as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Long

value = instance.ReadContentAsLong()
C#
public override long ReadContentAsLong()
Delphi
public function ReadContentAsLong(): Int64; override;
JScript
public override function ReadContentAsLong() : long;
Managed Extensions for C++
public: long ReadContentAsLong(); override
C++/CLI
public:
int64 ReadContentAsLong(); override

Return Value

The content as a 64-bit signed integer.

Remarks

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsLong


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsShort Method

Reads the text content at the current position as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function ReadContentAsShort() As Short
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Short

value = instance.ReadContentAsShort()
C#
public short ReadContentAsShort()
Delphi
public function ReadContentAsShort(): ShortInt;
JScript
public function ReadContentAsShort() : short;
Managed Extensions for C++
public: short ReadContentAsShort();
C++/CLI
public:
short ReadContentAsShort();

Return Value

The content as a 16-bit signed integer.

Remarks

If the content is a binary encoded 16-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 16-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsString Method

Reads the text content at the current position as a string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadContentAsString()
C#
public override string ReadContentAsString()
Delphi
public function ReadContentAsString(): String; override;
JScript
public override function ReadContentAsString() : String;
Managed Extensions for C++
public: string* ReadContentAsString(); override
C++/CLI
public:
String^ ReadContentAsString(); override

Return Value

The node content as String object.

Remarks

Implements XmlReader.ReadContentAsString.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadContentAsString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBase64 Method

Reads the binary or Base64 encoded element content and returns the decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded element content and returns the decoded bytes.
ReadElementContentAsBase64(Int32) | Reads binary or Base64 encoded element content and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads the binary or Base64 encoded element content and returns the decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBase64(buffer, index, count)
C#
public override int ReadElementContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is binary encoded Base64 bytes, the reader returns the bytes read.

If the content is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64(Int32) Method

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads binary or Base64 encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBase64( _
   ByVal maxArrayLength As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim maxArrayLength As Integer
Dim value() As Byte

value = instance.ReadElementContentAsBase64(maxArrayLength)
C#
public byte[] ReadElementContentAsBase64(
   int maxArrayLength
)
Delphi
public function ReadElementContentAsBase64(
    maxArrayLength: Integer
): array of Byte;
JScript
public function ReadElementContentAsBase64(
   maxArrayLength : int
) : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBase64(
   int maxArrayLength
)
C++/CLI
public:
array<byte>^ ReadElementContentAsBase64(
   int maxArrayLength
)

Parameters

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

An array with bytes.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded Base64 bytes block, reader returns the bytes read.

If content is text, reader performs Base64 decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBinHex Method

Reads the binary or BinHex encoded element content and returns the decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBinHex(Byte[],Int32,Int32) | Reads the binary or BinHex encoded element content and returns the decoded bytes.
ReadElementContentAsBinHex(Int32) | Reads binary or BinHex encoded element content and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count

The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Reads the binary or BinHex encoded element content and returns the decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBinHex(buffer, index, count)
C#
public override int ReadElementContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count

The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is binary encoded BinHex bytes, the reader returns the bytes read.

If the content is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex(Int32) Method

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads binary or BinHex encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBinHex( _
   ByVal maxArrayLength As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim maxArrayLength As Integer
Dim value() As Byte

value = instance.ReadElementContentAsBinHex(maxArrayLength)
C#
public byte[] ReadElementContentAsBinHex(
   int maxArrayLength
)
Delphi
public function ReadElementContentAsBinHex(
    maxArrayLength: Integer
): array of Byte;
JScript
public function ReadElementContentAsBinHex(
   maxArrayLength : int
) : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBinHex(
   int maxArrayLength
)
C++/CLI
public:
array<byte>^ ReadElementContentAsBinHex(
   int maxArrayLength
)

Parameters

maxArrayLength
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

An array with bytes.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded BinHex bytes block, reader returns the bytes read.

If content is text, reader performs BinHex decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsBoolean Method

Reads the current element and returns the content as a boolean value.

Overload List

Overload | Description
ReadElementContentAsBoolean() | Reads the current element and returns the content as a boolean value.
ReadElementContentAsBoolean(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsBoolean


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean() Method

Reads the current element and returns the content as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.ReadElementContentAsBoolean()
C#
public override bool ReadElementContentAsBoolean()
Delphi
public function ReadElementContentAsBoolean(): Boolean; override;
JScript
public override function ReadElementContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(); override
C++/CLI
public:
bool ReadElementContentAsBoolean(); override

Return Value

The element content as a boolean value.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsBoolean()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDateTime Method

Reads the node content at the current position as a DateTime value.

Overload List

Overload | Description
ReadElementContentAsDateTime() | Reads the node content at the current position as a DateTime value.
ReadElementContentAsDateTime(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsDateTime


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime() Method

Reads the node content at the current position as a DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Date

value = instance.ReadElementContentAsDateTime()
C#
public override DateTime ReadElementContentAsDateTime()
Delphi
public function ReadElementContentAsDateTime(): DateTime; override;
JScript
public override function ReadElementContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(); override
C++/CLI
public:
DateTime ReadElementContentAsDateTime(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsDateTime()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDecimal Method

Reads the node content at the current position as a decimal value.

Overload List

Overload | Description
ReadElementContentAsDecimal() | Reads the node content at the current position as a decimal value.
ReadElementContentAsDecimal(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsDecimal


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal() Method

Reads the node content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Decimal

value = instance.ReadElementContentAsDecimal()
C#
public override decimal ReadElementContentAsDecimal()
Delphi
public function ReadElementContentAsDecimal(): Currency; override;
JScript
public override function ReadElementContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(); override
C++/CLI
public:
decimal ReadElementContentAsDecimal(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsDecimal()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsDouble Method

Reads the current element and returns the content as a double-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsDouble() | Reads the current element and returns the content as a double-precision floating-point number.
ReadElementContentAsDouble(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsDouble


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble() Method

Reads the current element and returns the content as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Double

value = instance.ReadElementContentAsDouble()
C#
public override double ReadElementContentAsDouble()
Delphi
public function ReadElementContentAsDouble(): Double; override;
JScript
public override function ReadElementContentAsDouble() : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(); override
C++/CLI
public:
double ReadElementContentAsDouble(); override

Return Value

The element content as a double-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsDouble()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsFloat Method

Reads the current element and returns the content as a single-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsFloat() | Reads the current element and returns the content as a single-precision floating-point number.
ReadElementContentAsFloat(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsFloat


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat() Method

Reads the current element and returns the content as a single-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Single

value = instance.ReadElementContentAsFloat()
C#
public override float ReadElementContentAsFloat()
Delphi
public function ReadElementContentAsFloat(): Single; override;
JScript
public override function ReadElementContentAsFloat() : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(); override
C++/CLI
public:
float ReadElementContentAsFloat(); override

Return Value

The element content as a single-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsFloat()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsInt Method

Reads the current element and returns the content as a 32-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsInt() | Reads the current element and returns the content as a 32-bit signed integer.
ReadElementContentAsInt(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsInt


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt() Method

Reads the current element and returns the content as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.ReadElementContentAsInt()
C#
public override int ReadElementContentAsInt()
Delphi
public function ReadElementContentAsInt(): Integer; override;
JScript
public override function ReadElementContentAsInt() : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(); override
C++/CLI
public:
int ReadElementContentAsInt(); override

Return Value

The element content as a 32-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsInt()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsLong Method

Reads the current element and returns the content as a 64-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsLong() | Reads the current element and returns the content as a 64-bit signed integer.
ReadElementContentAsLong(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsLong


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong() Method

Reads the current element and returns the content as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Long

value = instance.ReadElementContentAsLong()
C#
public override long ReadElementContentAsLong()
Delphi
public function ReadElementContentAsLong(): Int64; override;
JScript
public override function ReadElementContentAsLong() : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(); override
C++/CLI
public:
int64 ReadElementContentAsLong(); override

Return Value

The element content as a 64-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsLong()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsShort Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsShort Method

Reads the current element and returns the content as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function ReadElementContentAsShort() As Short
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Short

value = instance.ReadElementContentAsShort()
C#
public short ReadElementContentAsShort()
Delphi
public function ReadElementContentAsShort(): ShortInt;
JScript
public function ReadElementContentAsShort() : short;
Managed Extensions for C++
public: short ReadElementContentAsShort();
C++/CLI
public:
short ReadElementContentAsShort();

Return Value

The element content as a 16-bit signed integer

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 16-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 16-bit signed integer.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsString Method

Reads the current element and returns the contents as a String object.

Overload List

Overload | Description
ReadElementContentAsString() | Reads the current element and returns the contents as a String object.
ReadElementContentAsString(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadElementContentAsString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsString Method : ReadElementContentAsString() Method

Reads the current element and returns the contents as a String object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function ReadElementContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadElementContentAsString()
C#
public override string ReadElementContentAsString()
Delphi
public function ReadElementContentAsString(): String; override;
JScript
public override function ReadElementContentAsString() : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(); override
C++/CLI
public:
String^ ReadElementContentAsString(); override

Return Value

The element content as a String.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadElementContentAsString()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadEndElement Method

Checks that the current content node is an end tag and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ReadEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ReadEndElement()
C#
public override void ReadEndElement()
Delphi
public procedure ReadEndElement(); override;
JScript
public override function ReadEndElement();
Managed Extensions for C++
public: void ReadEndElement(); override
C++/CLI
public:
void ReadEndElement(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadStartElement Method

Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.

Overload List

Overload | Description
ReadStartElement(String,String) | Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.
ReadStartElement(String) | Checks that the current node is the element with specified qualified name and advances the reader to the next node.
ReadStartElement() | Checks that the current node is an element and advances the reader to the next node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement(String,String) Method

localname
The local name of the specified element
ns
The namespace of specified element
Checks that the current node is the element with specified local name and namespace and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String

instance.ReadStartElement(localname, ns)
C#
public override void ReadStartElement(
   string localname,
   string ns
)
Delphi
public procedure ReadStartElement(
    localname: String;
    ns: String
); override;
JScript
public override function ReadStartElement(
   localname : String,
   ns : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
void ReadStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The local name of the specified element
ns
The namespace of specified element

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadStartElement(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement(String) Method

name
The name of specified element.
Checks that the current node is the element with specified qualified name and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String

instance.ReadStartElement(name)
C#
public override void ReadStartElement(
   string name
)
Delphi
public procedure ReadStartElement(
    name: String
); override;
JScript
public override function ReadStartElement(
   name : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* name
) override
C++/CLI
public:
void ReadStartElement(
   String^ name
) override

Parameters

name
The name of specified element.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadStartElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadStartElement Method : ReadStartElement() Method

Checks that the current node is an element and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub ReadStartElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ReadStartElement()
C#
public override void ReadStartElement()
Delphi
public procedure ReadStartElement(); override;
JScript
public override function ReadStartElement();
Managed Extensions for C++
public: void ReadStartElement(); override
C++/CLI
public:
void ReadStartElement(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List
Base Implementation in ReadStartElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadString Method

Reads the contents of the current node into a string.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ReadString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadString()
C#
public override string ReadString()
Delphi
public function ReadString(): String; override;
JScript
public override function ReadString() : String;
Managed Extensions for C++
public: string* ReadString(); override
C++/CLI
public:
String^ ReadString(); override

Return Value

A string that contains the contents of the current node.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ResetState Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ResetState Method

Resets the ReadState to Initial.

Syntax

Visual Basic (Declaration)
Public Sub ResetState()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ResetState()
C#
public void ResetState()
Delphi
public procedure ResetState();
JScript
public function ResetState();
Managed Extensions for C++
public: void ResetState();
C++/CLI
public:
void ResetState();

Remarks

ResetState enables you to parse multiple Fast Infoset documents in a single stream. When you reach the end of a Fast Infoset document, you can call ResetState to reset the state of the reader in preparation for the next Fast Infoset document.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ResolveEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ResolveEntity Method

Throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub ResolveEntity()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.ResolveEntity()
C#
public override void ResolveEntity()
Delphi
public procedure ResolveEntity(); override;
JScript
public override function ResolveEntity();
Managed Extensions for C++
public: void ResolveEntity(); override
C++/CLI
public:
void ResolveEntity(); override

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ResolveEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : SetVocabulary Method

vocabulary
ReaderVocabulary to use.
Sets the vocabulary to be used when read a Fast Infoset document.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As ReaderVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim vocabulary As ReaderVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   ReaderVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: ReaderVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : ReaderVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   ReaderVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   ReaderVocabulary^ vocabulary
)

Parameters

vocabulary
ReaderVocabulary to use.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetReader Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetReader Class

For a list of all members of this type, see XmlFastInfosetReader members.

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | Overridden. Gets a value indicating whether this reader can parse and resolve entities. Always returns false.
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | Overridden. Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overridden. Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class.
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | MaxDepth | Gets and sets the maximum nested node depth.
public Property | MaxNodeContentLength | Gets and sets the maximum length of the node content in bytes.
public Property | Name | Overridden. Gets the qualified name of the current node.
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | QuoteChar | Overridden. Gets the quotation mark character used to enclose the value of an attribute node.
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetReader Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AttributeCount Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : AttributeCount Property

Gets the number of attributes on the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property AttributeCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.AttributeCount
C#
public override int AttributeCount {get;}
Delphi
public read-only property AttributeCount: Integer; override;
JScript
public override function get AttributeCount : int
Managed Extensions for C++
public: __property int get_AttributeCount() override;
C++/CLI
public:
property int AttributeCount {
   int get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in AttributeCount


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : BaseURI Property

Gets the base URI of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property BaseURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.BaseURI
C#
public override string BaseURI {get;}
Delphi
public read-only property BaseURI: String; override;
JScript
public override function get BaseURI : String
Managed Extensions for C++
public: __property string* get_BaseURI() override;
C++/CLI
public:
property String^ BaseURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in BaseURI


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanReadBinaryContent Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanReadBinaryContent Property

Gets a value indicating whether this reader can parse binary content. Always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanReadBinaryContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanReadBinaryContent
C#
public override bool CanReadBinaryContent {get;}
Delphi
public read-only property CanReadBinaryContent: Boolean; override;
JScript
public override function get CanReadBinaryContent : boolean
Managed Extensions for C++
public: __property bool get_CanReadBinaryContent() override;
C++/CLI
public:
property bool CanReadBinaryContent {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in CanReadBinaryContent


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanResolveEntity Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanResolveEntity Property

Gets a value indicating whether this reader can parse and resolve entities. Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanResolveEntity As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanResolveEntity
C#
public override bool CanResolveEntity {get;}
Delphi
public read-only property CanResolveEntity: Boolean; override;
JScript
public override function get CanResolveEntity : boolean
Managed Extensions for C++
public: __property bool get_CanResolveEntity() override;
C++/CLI
public:
property bool CanResolveEntity {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in CanResolveEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Depth Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Depth Property

Gets the depth of the current node in the XML document.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Depth As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

value = instance.Depth
C#
public override int Depth {get;}
Delphi
public read-only property Depth: Integer; override;
JScript
public override function get Depth : int
Managed Extensions for C++
public: __property int get_Depth() override;
C++/CLI
public:
property int Depth {
   int get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Depth


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EOF Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : EOF Property

Gets a value indicating whether the reader is positioned at the end of the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property EOF As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.EOF
C#
public override bool EOF {get;}
Delphi
public read-only property EOF: Boolean; override;
JScript
public override function get EOF : boolean
Managed Extensions for C++
public: __property bool get_EOF() override;
C++/CLI
public:
property bool EOF {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in EOF


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasValue Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : HasValue Property

Gets a value indicating whether the current node can have a Value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property HasValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.HasValue
C#
public override bool HasValue {get;}
Delphi
public read-only property HasValue: Boolean; override;
JScript
public override function get HasValue : boolean
Managed Extensions for C++
public: __property bool get_HasValue() override;
C++/CLI
public:
property bool HasValue {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in HasValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefault Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsDefault Property

Gets a value indicating whether the current node is an attribute that was generated from the default value defined in the DTD or schema.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsDefault
C#
public override bool IsDefault {get;}
Delphi
public read-only property IsDefault: Boolean; override;
JScript
public override function get IsDefault : boolean
Managed Extensions for C++
public: __property bool get_IsDefault() override;
C++/CLI
public:
property bool IsDefault {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in IsDefault


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsEmptyElement Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : IsEmptyElement Property

Gets a value indicating whether the current node is an empty element.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property IsEmptyElement As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.IsEmptyElement
C#
public override bool IsEmptyElement {get;}
Delphi
public read-only property IsEmptyElement: Boolean; override;
JScript
public override function get IsEmptyElement : boolean
Managed Extensions for C++
public: __property bool get_IsEmptyElement() override;
C++/CLI
public:
property bool IsEmptyElement {
   bool get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in IsEmptyElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Item Property

i
Gets the value of the attribute specified by the index. In C#, this property is the indexer for the XmlFastInfosetReader class. Gets the value of the attribute. In C#, this property is the indexer for the XmlFastInfosetReader class.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Default Property Item( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim i As Integer
Dim value As String

value = instance.Item(i)
C#
public override string this(
   int i
) {get;}
Delphi
public  this: : String;(
    i: Integer
);override;  read-only
JScript
public override  this(
   i : int
) get : String
Managed Extensions for C++
public: __property string* get_Item(
   int i
) override;
C++/CLI
public:
property String^ default [int] override {
   String^ get(int i) override;
}

Parameters

i

Property Value

The value of the specified attribute.The value of the specified attribute.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Item


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalName Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : LocalName Property

Gets the local name of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property LocalName As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.LocalName
C#
public override string LocalName {get;}
Delphi
public read-only property LocalName: String; override;
JScript
public override function get LocalName : String
Managed Extensions for C++
public: __property string* get_LocalName() override;
C++/CLI
public:
property String^ LocalName {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in LocalName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxDepth Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MaxDepth Property

Gets and sets the maximum nested node depth.

Syntax

Visual Basic (Declaration)
Public Property MaxDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

instance.MaxDepth = value

value = instance.MaxDepth
C#
public int MaxDepth {get; set;}
Delphi
public read-write property MaxDepth: Integer;
JScript
public function get,set MaxDepth : int
Managed Extensions for C++
public: __property int get_MaxDepth();
public: __property void set_MaxDepth(
   int value
);
C++/CLI
public:
property int MaxDepth {
   int get();
   void set (    int value);
}

Remarks

The default value assigned to this property during initialization of XmlFastInfosetReader is equal to Int32.MaxValue.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxNodeContentLength Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : MaxNodeContentLength Property

Gets and sets the maximum length of the node content in bytes.

Syntax

Visual Basic (Declaration)
Public Property MaxNodeContentLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Integer

instance.MaxNodeContentLength = value

value = instance.MaxNodeContentLength
C#
public int MaxNodeContentLength {get; set;}
Delphi
public read-write property MaxNodeContentLength: Integer;
JScript
public function get,set MaxNodeContentLength : int
Managed Extensions for C++
public: __property int get_MaxNodeContentLength();
public: __property void set_MaxNodeContentLength(
   int value
);
C++/CLI
public:
property int MaxNodeContentLength {
   int get();
   void set (    int value);
}

Remarks

This quota sets a limit on the node content length in bytes. This property applies to reading text and binary data content as well as element names, namespace URIs etc.

The default value assigned to this property during initialization of XmlFastInfosetReader is equal to Int32.MaxValue.

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Name Property

Gets the qualified name of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Name
C#
public override string Name {get;}
Delphi
public read-only property Name: String; override;
JScript
public override function get Name : String
Managed Extensions for C++
public: __property string* get_Name() override;
C++/CLI
public:
property String^ Name {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Name


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NamespaceURI Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NamespaceURI Property

Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NamespaceURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.NamespaceURI
C#
public override string NamespaceURI {get;}
Delphi
public read-only property NamespaceURI: String; override;
JScript
public override function get NamespaceURI : String
Managed Extensions for C++
public: __property string* get_NamespaceURI() override;
C++/CLI
public:
property String^ NamespaceURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in NamespaceURI


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NameTable Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NameTable Property

Gets the XmlNameTable associated with this reader.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NameTable As XmlNameTable
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNameTable

value = instance.NameTable
C#
public override XmlNameTable NameTable {get;}
Delphi
public read-only property NameTable: XmlNameTable; override;
JScript
public override function get NameTable : XmlNameTable
Managed Extensions for C++
public: __property XmlNameTable* get_NameTable() override;
C++/CLI
public:
property XmlNameTable^ NameTable {
   XmlNameTable^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in NameTable


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NodeType Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : NodeType Property

Gets the type of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property NodeType As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlNodeType

value = instance.NodeType
C#
public override XmlNodeType NodeType {get;}
Delphi
public read-only property NodeType: XmlNodeType; override;
JScript
public override function get NodeType : XmlNodeType
Managed Extensions for C++
public: __property XmlNodeType get_NodeType() override;
C++/CLI
public:
property XmlNodeType NodeType {
   XmlNodeType get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in NodeType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Prefix Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Prefix Property

Gets the namespace prefix associated with the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Prefix As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Prefix
C#
public override string Prefix {get;}
Delphi
public read-only property Prefix: String; override;
JScript
public override function get Prefix : String
Managed Extensions for C++
public: __property string* get_Prefix() override;
C++/CLI
public:
property String^ Prefix {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Prefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QuoteChar Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : QuoteChar Property

Gets the quotation mark character used to enclose the value of an attribute node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property QuoteChar As Char
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Char

value = instance.QuoteChar
C#
public override char QuoteChar {get;}
Delphi
public read-only property QuoteChar: Char; override;
JScript
public override function get QuoteChar : char
Managed Extensions for C++
public: __property char get_QuoteChar() override;
C++/CLI
public:
property char QuoteChar {
   char get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in QuoteChar


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadState Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadState Property

Gets the state of the reader.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property ReadState As ReadState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As ReadState

value = instance.ReadState
C#
public override ReadState ReadState {get;}
Delphi
public read-only property ReadState: ReadState; override;
JScript
public override function get ReadState : ReadState
Managed Extensions for C++
public: __property ReadState get_ReadState() override;
C++/CLI
public:
property ReadState ReadState {
   ReadState get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in ReadState


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Settings Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Settings Property

Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Settings As XmlReaderSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlReaderSettings

value = instance.Settings
C#
public override XmlReaderSettings Settings {get;}
Delphi
public read-only property Settings: XmlReaderSettings; override;
JScript
public override function get Settings : XmlReaderSettings
Managed Extensions for C++
public: __property XmlReaderSettings* get_Settings() override;
C++/CLI
public:
property XmlReaderSettings^ Settings {
   XmlReaderSettings^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Settings


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Value Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Value Property

Gets the text value of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.Value
C#
public override string Value {get;}
Delphi
public read-only property Value: String; override;
JScript
public override function get Value : String
Managed Extensions for C++
public: __property string* get_Value() override;
C++/CLI
public:
property String^ Value {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Base Implementation in Value


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
VocabularyProvider Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : VocabularyProvider Property

Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.

Syntax

Visual Basic (Declaration)
Public Property VocabularyProvider As IVocabularyProvider
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As IVocabularyProvider

instance.VocabularyProvider = value

value = instance.VocabularyProvider
C#
public IVocabularyProvider VocabularyProvider {get; set;}
Delphi
public read-write property VocabularyProvider: IVocabularyProvider;
JScript
public function get,set VocabularyProvider : IVocabularyProvider
Managed Extensions for C++
public: __property IVocabularyProvider* get_VocabularyProvider();
public: __property void set_VocabularyProvider(
   IVocabularyProvider* value
);
C++/CLI
public:
property IVocabularyProvider^ VocabularyProvider {
   IVocabularyProvider^ get();
   void set (    IVocabularyProvider^ value);
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

Represents a writer that provides a fast, non-cached, forward-only way of generating streams or files containing Fast Infoset encoded XML data.

Object Model

XmlFastInfosetWriter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlFastInfosetWriter
   Inherits System.Xml.XmlWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
C#
public sealed class XmlFastInfosetWriter : System.Xml.XmlWriter
Delphi
public class XmlFastInfosetWriter = class(System.Xml.XmlWriter)sealed;
JScript
public sealed class XmlFastInfosetWriter extends System.Xml.XmlWriter
Managed Extensions for C++
public __gc __sealed class XmlFastInfosetWriter : public System.Xml.XmlWriter
C++/CLI
public ref class XmlFastInfosetWriter sealed : public System.Xml.XmlWriter

Inheritance Hierarchy

System.Object
System.Xml.XmlWriter
Noemax.FastInfoset.XmlFastInfosetWriter

See Also

Reference

XmlFastInfosetWriter Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

The following tables list the members exposed by XmlFastInfosetWriter.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetWriter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AttributeStringsIndexed | Returns the number of the attribute value strings indexed in FastInfoset vocabulary.
public Property | ContentStringsIndexed | Returns the number of the element content strings indexed in FastInfoset vocabulary.
public Property | IgnoreComments | Gets and sets whether this writer should ignore calls to the WriteComment method.
public Property | IgnoreProcessingInstructions | Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | OtherStringsIndexed | Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Gets the current xml:lang scope.
public Property | XmlSpace | Overridden. Gets an XmlSpace representing the current xml:space scope.
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of XmlFastInfosetWriter.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementData | Overloaded. Writes an element containing a single value.Writes an element containing a single value.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteGuid | Writes GUID value.
public Method | WriteName | Overridden. Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.
public Method | WriteNmToken | Overridden. Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overridden. Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes a single or multiple simple-typed values.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlnsAttribute | Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlFastInfosetWriter Constructor

Overload List

Overload | Description
XmlFastInfosetWriter Constructor(Stream) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,Boolean) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean) | Initializes a new instance of the XmlFastInfosetWriter class.
XmlFastInfosetWriter Constructor() | Initializes a new instance of the XmlFastInfosetWriter class.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream)

output
The stream to which you want to write.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim output As Stream

Dim instance As New XmlFastInfosetWriter(output)
C#
public XmlFastInfosetWriter(
   Stream output
)
Delphi
public XmlFastInfosetWriter(
    output: Stream
);
JScript
public function XmlFastInfosetWriter(
   output : Stream
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings)

output
The stream to which you want to write.
settings
XmlWriterSettings object containing writer configuratoin.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings

Dim instance As New XmlFastInfosetWriter(output, settings)
C#
public XmlFastInfosetWriter(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    settings: XmlWriterSettings
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   settings : XmlWriterSettings
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings object containing writer configuratoin.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,Boolean)

output
The stream to which you want to write.
closeOutput
If set to true writer will close the output stream when closed.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal closeOutput As Boolean _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim closeOutput As Boolean

Dim instance As New XmlFastInfosetWriter(output, closeOutput)
C#
public XmlFastInfosetWriter(
   Stream output,
   bool closeOutput
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    closeOutput: Boolean
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   closeOutput : boolean
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   bool closeOutput
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   bool closeOutput
)

Parameters

output
The stream to which you want to write.
closeOutput
If set to true writer will close the output stream when closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32)

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

Dim instance As New XmlFastInfosetWriter(output, compression, compressionLevel)
C#
public XmlFastInfosetWriter(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,XmlWriterSettings,FastInfosetCompression,Int32)

output
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

Dim instance As New XmlFastInfosetWriter(output, settings, compression, compressionLevel)
C#
public XmlFastInfosetWriter(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor(Stream,FastInfosetCompression,Int32,Boolean)

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
closeOutput
If set to true writer will close the output stream when closed.
Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer, _
   ByVal closeOutput As Boolean _
)
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim closeOutput As Boolean

Dim instance As New XmlFastInfosetWriter(output, compression, compressionLevel, closeOutput)
C#
public XmlFastInfosetWriter(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)
Delphi
public XmlFastInfosetWriter(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer;
    closeOutput: Boolean
);
JScript
public function XmlFastInfosetWriter(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int,
   closeOutput : boolean
);
Managed Extensions for C++
public: XmlFastInfosetWriter(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)
C++/CLI
public:
XmlFastInfosetWriter(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel,
   bool closeOutput
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
closeOutput
If set to true writer will close the output stream when closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Constructor()
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > XmlFastInfosetWriter Constructor : XmlFastInfosetWriter Constructor()

Initializes a new instance of the XmlFastInfosetWriter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetWriter()
C#
public XmlFastInfosetWriter()
Delphi
public XmlFastInfosetWriter();
JScript
public function XmlFastInfosetWriter();
Managed Extensions for C++
public: XmlFastInfosetWriter();
C++/CLI
public:
XmlFastInfosetWriter();

Remarks

This constructor creates an instance of XmlFastInfosetWriter which is is not associated to any stream and is intended for reusing the same writer for writing into more than one stream.

If you use this constructor you must initialize the reader by calling Init before using it.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

For a list of all members of this type, see XmlFastInfosetWriter members.

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of XmlFastInfosetWriter.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Overloaded. Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | WriteAttributes | (Inherited from System.Xml.XmlWriter)
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementData | Overloaded. Writes an element containing a single value.Writes an element containing a single value.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteGuid | Writes GUID value.
public Method | WriteName | Overridden. Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.
public Method | WriteNmToken | Overridden. Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.
public Method | WriteNode | Overloaded. (Inherited from System.Xml.XmlWriter)
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overridden. Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes a single or multiple simple-typed values.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlnsAttribute | Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Clear Method

Clears the internal state of XmlFastInfosetWriter.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

Clears the internal state of the writer. After a call to this method the writer remains in an uninitialized state. You must call Init in order to reuse the writer for writing into another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Close Method

Changes the WriteState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseOutput is set to true, the underlying stream will also be closed.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Create Method

Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.

Overload List

Overload | Description
Create(Stream) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.
Create(String) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.
Create(Stream,XmlWriterSettings) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,XmlWriterSettings) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(Stream,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.
Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.
Create(String,XmlWriterSettings,FastInfosetCompression,Int32) | Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream) Method

output
The stream to which you want to write. The System.Xml.XmlWriter writes FastInfoset encoded XML and appends it to the specified stream.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output)
C#
public static XmlWriter Create(
   Stream output
)
Delphi
public function Create(
    output: Stream
): XmlWriter; static;
JScript
public static function Create(
   output : Stream
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output
)

Parameters

output
The stream to which you want to write. The System.Xml.XmlWriter writes FastInfoset encoded XML and appends it to the specified stream.

Return Value

An XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String) Method

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName)
C#
public static XmlWriter Create(
   string outputFileName
)
Delphi
public function Create(
    outputFileName: String
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName
)

Parameters

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,XmlWriterSettings) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, settings)
C#
public static XmlWriter Create(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public function Create(
    output: Stream;
    settings: XmlWriterSettings
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   settings : XmlWriterSettings
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,XmlWriterSettings) Method

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal settings As XmlWriterSettings _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim settings As XmlWriterSettings
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, settings)
C#
public static XmlWriter Create(
   string outputFileName,
   XmlWriterSettings settings
)
Delphi
public function Create(
    outputFileName: String;
    settings: XmlWriterSettings
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   settings : XmlWriterSettings
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   XmlWriterSettings* settings
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   XmlWriterSettings^ settings
)

Parameters

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,FastInfosetCompression,Int32) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, compression, compressionLevel)
C#
public static XmlWriter Create(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,FastInfosetCompression,Int32) Method

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, compression, compressionLevel)
C#
public static XmlWriter Create(
   string outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    outputFileName: String;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

outputFileName
The file to which you want to write. The System.Xml.XmlWriter creates a file at the specified path and writes to it FastInfoset encoded XML data. The outputFileName must be a file system path.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(output, settings, compression, compressionLevel)
C#
public static XmlWriter Create(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write. The XmlWriter writes Fast Infoset encoded XML and appends it to the specified stream.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(String,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Create Method : Create(String,XmlWriterSettings,FastInfosetCompression,Int32) Method

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Creates a new XmlWriter instance for writing Fast Infoset encoded XML into the specified stream using an XmlWriterSettings object.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal outputFileName As String, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
) As XmlWriter
Visual Basic (Usage) Copy Code
Dim outputFileName As String
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer
Dim value As XmlWriter

value = XmlFastInfosetWriter.Create(outputFileName, settings, compression, compressionLevel)
C#
public static XmlWriter Create(
   string outputFileName,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public function Create(
    outputFileName: String;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
): XmlWriter; static;
JScript
public static function Create(
   outputFileName : String,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
) : XmlWriter;
Managed Extensions for C++
public: static XmlWriter* Create(
   string* outputFileName,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
static XmlWriter^ Create(
   String^ outputFileName,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

outputFileName
The file to which you want to write XmlWriter creates a file at the specified path. The outputFileName must be a file system path.
settings
The XmlWriterSettings object used to configure the new XmlWriter instance. If this is null (Northing in Visual Basic), a XmlWriterSettings with default settings is used.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Return Value

An System.Xml.XmlWriter object.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Flush Method

Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Init Method

Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Overload List

Overload | Description
Init(Stream) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,XmlWriterSettings) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,FastInfosetCompression,Int32) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.
Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) | Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream) Method

output
The stream to which you want to write.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream

instance.Init(output)
C#
public void Init(
   Stream output
)
Delphi
public procedure Init(
    output: Stream
);
JScript
public function Init(
   output : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* output
)
C++/CLI
public:
void Init(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,XmlWriterSettings) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,XmlWriterSettings) Method

output
The stream to which you want to write.
settings
XmlWriterSettings to be applied to writer.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim settings As XmlWriterSettings

instance.Init(output, settings)
C#
public void Init(
   Stream output,
   XmlWriterSettings settings
)
Delphi
public procedure Init(
    output: Stream;
    settings: XmlWriterSettings
);
JScript
public function Init(
   output : Stream,
   settings : XmlWriterSettings
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   XmlWriterSettings* settings
)
C++/CLI
public:
void Init(
   Stream^ output,
   XmlWriterSettings^ settings
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings to be applied to writer.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,FastInfosetCompression,Int32) Method

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

instance.Init(output, compression, compressionLevel)
C#
public void Init(
   Stream output,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public procedure Init(
    output: Stream;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function Init(
   output : Stream,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
void Init(
   Stream^ output,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > Init Method : Init(Stream,XmlWriterSettings,FastInfosetCompression,Int32) Method

output
The stream to which you want to write.
settings
XmlWriterSettings to be to configure the writer.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes an instance of the XmlFastInfosetWriter class preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal output As Stream, _
   ByVal settings As XmlWriterSettings, _
   ByVal compression As FastInfosetCompression, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim output As Stream
Dim settings As XmlWriterSettings
Dim compression As FastInfosetCompression
Dim compressionLevel As Integer

instance.Init(output, settings, compression, compressionLevel)
C#
public void Init(
   Stream output,
   XmlWriterSettings settings,
   FastInfosetCompression compression,
   int compressionLevel
)
Delphi
public procedure Init(
    output: Stream;
    settings: XmlWriterSettings;
    compression: FastInfosetCompression;
    compressionLevel: Integer
);
JScript
public function Init(
   output : Stream,
   settings : XmlWriterSettings,
   compression : FastInfosetCompression,
   compressionLevel : int
);
Managed Extensions for C++
public: void Init(
   Stream* output,
   XmlWriterSettings* settings,
   FastInfosetCompression compression,
   int compressionLevel
)
C++/CLI
public:
void Init(
   Stream^ output,
   XmlWriterSettings^ settings,
   FastInfosetCompression compression,
   int compressionLevel
)

Parameters

output
The stream to which you want to write.
settings
XmlWriterSettings to be to configure the writer.
compression
The compression algorithm to compress the output data.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

Initializes the writer and sets it to use the provided stream as output.

This method allows the reuse the XmlFastInfosetWriter for writing to another stream.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LookupPrefix Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : LookupPrefix Method

ns

The namespace URI whose prefix you want to find.

Returns the closest prefix defined in the current namespace scope for the namespace URI

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function LookupPrefix( _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ns As String
Dim value As String

value = instance.LookupPrefix(ns)
C#
public override string LookupPrefix(
   string ns
)
Delphi
public function LookupPrefix(
    ns: String
): String; override;
JScript
public override function LookupPrefix(
   ns : String
) : String;
Managed Extensions for C++
public: string* LookupPrefix(
   string* ns
) override
C++/CLI
public:
String^ LookupPrefix(
   String^ ns
) override

Parameters

ns

The namespace URI whose prefix you want to find.

Return Value

The matching prefix or a null reference (Nothing in Visual Basic) if no matching namespace URI is found in the current scope.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in LookupPrefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : SetVocabulary Method

vocabulary
The vocabulary to use.
Sets the vocabulary to be used when writing a Fast Infoset document.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As WriterVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim vocabulary As WriterVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   WriterVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: WriterVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : WriterVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   WriterVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   WriterVocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary to use.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteBase64 Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteBase64 Method

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.
Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBase64(buffer, index, count)
C#
public override void WriteBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBase64(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteBinHex Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteBinHex Method

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBinHex(buffer, index, count)
C#
public override void WriteBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBinHex(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteCData Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteCData Method

text

The text to place inside the CDATA block.

Writes out a <![CDATA[...]]> block containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteCData( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteCData(text)
C#
public override void WriteCData(
   string text
)
Delphi
public procedure WriteCData(
    text: String
); override;
JScript
public override function WriteCData(
   text : String
);
Managed Extensions for C++
public: void WriteCData(
   string* text
) override
C++/CLI
public:
void WriteCData(
   String^ text
) override

Parameters

text

The text to place inside the CDATA block.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteCData


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteCharEntity Method

ch

The Unicode character for which to generate a character entity.

Forces the generation of a character entity for the specified Unicode character value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteCharEntity( _
   ByVal ch As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ch As Char

instance.WriteCharEntity(ch)
C#
public override void WriteCharEntity(
   char ch
)
Delphi
public procedure WriteCharEntity(
    ch: Char
); override;
JScript
public override function WriteCharEntity(
   ch : char
);
Managed Extensions for C++
public: void WriteCharEntity(
   char ch
) override
C++/CLI
public:
void WriteCharEntity(
   char ch
) override

Parameters

ch

The Unicode character for which to generate a character entity.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteCharEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteChars Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteChars Method

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

Writes text one buffer at a time.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteChars(buffer, index, count)
C#
public override void WriteChars(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteChars(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteChars(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteChars(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteChars(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteChars


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteComment Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteComment Method

text

The text to place inside the comment.

Writes out a comment containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteComment( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteComment(text)
C#
public override void WriteComment(
   string text
)
Delphi
public procedure WriteComment(
    text: String
); override;
JScript
public override function WriteComment(
   text : String
);
Managed Extensions for C++
public: void WriteComment(
   string* text
) override
C++/CLI
public:
void WriteComment(
   String^ text
) override

Parameters

text

The text to place inside the comment.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

If RemoveComments is set to true, the writer ignores all calls to this method.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteComment


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteDocType Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteDocType Method

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String
Dim pubid As String
Dim sysid As String
Dim subset As String

instance.WriteDocType(name, pubid, sysid, subset)
C#
public override void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
)
Delphi
public procedure WriteDocType(
    name: String;
    pubid: String;
    sysid: String;
    subset: String
); override;
JScript
public override function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);
Managed Extensions for C++
public: void WriteDocType(
   string* name,
   string* pubid,
   string* sysid,
   string* subset
) override
C++/CLI
public:
void WriteDocType(
   String^ name,
   String^ pubid,
   String^ sysid,
   String^ subset
) override

Parameters

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

Remarks

Writing DOCTYPE is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteDocType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteElementData Method

Writes an element containing a single value.Writes an element containing a single value.

Overload List

Overload | Description
WriteElementData(String,String,Int32) | Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Int64) | Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Int16) | Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Double) | Encodes a double-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Single) | Encodes a single-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,String,Boolean) | Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int32) | Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int64) | Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Int16) | Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Double) | Encodes a double-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Single) | Encodes a single-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.
WriteElementData(String,Boolean) | Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int32) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Integer

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   int value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Integer
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : int
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   int value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   int value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int64) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Long

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   long value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Int64
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : long
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   long value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   int64 value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Int16) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Short

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   short value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: ShortInt
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : short
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   short value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   short value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Double) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a double-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Double

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   double value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Double
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : double
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   double value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   double value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Single) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a single-precision floating-point number using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Single

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   float value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Single
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : float
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   float value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   float value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,String,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,String,Boolean) Method

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.
Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As Boolean

instance.WriteElementData(localName, ns, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   string ns,
   bool value
)
Delphi
public procedure WriteElementData(
    localName: String;
    ns: String;
    value: Boolean
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   ns : String,
   value : boolean
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   string* ns,
   bool value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   String^ ns,
   bool value
)

Parameters

localName
The local name of the element.
ns
The namespace URI of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int32) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 32-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Integer

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   int value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Integer
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : int
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   int value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   int value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int64) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 64-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Long

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   long value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Int64
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : long
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   long value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   int64 value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Int16) Method

localName
The local name of the element.
value
The value of the element.
Encodes a 16-bit signed integer using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Short

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   short value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: ShortInt
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : short
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   short value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   short value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Double) Method

localName
The local name of the element.
value
The value of the element.
Encodes a double-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Double

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   double value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Double
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : double
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   double value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   double value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Single) Method

localName
The local name of the element.
value
The value of the element.
Encodes a single-precision floating-pointing using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Single

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   float value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Single
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : float
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   float value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   float value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementData(String,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementData Method : WriteElementData(String,Boolean) Method

localName
The local name of the element.
value
The value of the element.
Encodes a boolean value using Fast Infoset's binary encoding and writes the result as a complete element content.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute()>
Public Overloads Sub WriteElementData( _
   ByVal localName As String, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As Boolean

instance.WriteElementData(localName, value)
C#
[ObsoleteAttribute()]
public void WriteElementData(
   string localName,
   bool value
)
Delphi
public procedure WriteElementData(
    localName: String;
    value: Boolean
);
JScript
ObsoleteAttribute()
public function WriteElementData(
   localName : String,
   value : boolean
);
Managed Extensions for C++
[ObsoleteAttribute()]
public: void WriteElementData(
   string* localName,
   bool value
)
C++/CLI
[ObsoleteAttribute()]
public:
void WriteElementData(
   String^ localName,
   bool value
)

Parameters

localName
The local name of the element.
value
The value of the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndAttribute Method

Closes the previous WriteStartAttribute call.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndAttribute()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndAttribute()
C#
public override void WriteEndAttribute()
Delphi
public procedure WriteEndAttribute(); override;
JScript
public override function WriteEndAttribute();
Managed Extensions for C++
public: void WriteEndAttribute(); override
C++/CLI
public:
void WriteEndAttribute(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteEndAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndDocument Method

Closes any open elements or attributes and changes the WriteState to Start.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndDocument()
C#
public override void WriteEndDocument()
Delphi
public procedure WriteEndDocument(); override;
JScript
public override function WriteEndDocument();
Managed Extensions for C++
public: void WriteEndDocument(); override
C++/CLI
public:
void WriteEndDocument(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteEndDocument


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteEndElement()
C#
public override void WriteEndElement()
Delphi
public procedure WriteEndElement(); override;
JScript
public override function WriteEndElement();
Managed Extensions for C++
public: void WriteEndElement(); override
C++/CLI
public:
void WriteEndElement(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEntityRef Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteEntityRef Method

name

The name of the entity reference.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteEntityRef( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteEntityRef(name)
C#
public override void WriteEntityRef(
   string name
)
Delphi
public procedure WriteEntityRef(
    name: String
); override;
JScript
public override function WriteEntityRef(
   name : String
);
Managed Extensions for C++
public: void WriteEntityRef(
   string* name
) override
C++/CLI
public:
void WriteEntityRef(
   String^ name
) override

Parameters

name

The name of the entity reference.

Remarks

Writing of entity references is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteEntityRef


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteFullEndElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteFullEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteFullEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteFullEndElement()
C#
public override void WriteFullEndElement()
Delphi
public procedure WriteFullEndElement(); override;
JScript
public override function WriteFullEndElement();
Managed Extensions for C++
public: void WriteFullEndElement(); override
C++/CLI
public:
void WriteFullEndElement(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteFullEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteGuid Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteGuid Method

value
Guid value to write.
Writes GUID value.

Syntax

Visual Basic (Declaration)
Public Sub WriteGuid( _
   ByVal value As Guid _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Guid

instance.WriteGuid(value)
C#
public void WriteGuid(
   Guid value
)
Delphi
public procedure WriteGuid(
    value: Guid
);
JScript
public function WriteGuid(
   value : Guid
);
Managed Extensions for C++
public: void WriteGuid(
   Guid value
)
C++/CLI
public:
void WriteGuid(
   Guid value
)

Parameters

value
Guid value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteName Method

name

The name to write.

Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteName(name)
C#
public override void WriteName(
   string name
)
Delphi
public procedure WriteName(
    name: String
); override;
JScript
public override function WriteName(
   name : String
);
Managed Extensions for C++
public: void WriteName(
   string* name
) override
C++/CLI
public:
void WriteName(
   String^ name
) override

Parameters

name

The name to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNmToken Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteNmToken Method

name

The name to write.

Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteNmToken( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String

instance.WriteNmToken(name)
C#
public override void WriteNmToken(
   string name
)
Delphi
public procedure WriteNmToken(
    name: String
); override;
JScript
public override function WriteNmToken(
   name : String
);
Managed Extensions for C++
public: void WriteNmToken(
   string* name
) override
C++/CLI
public:
void WriteNmToken(
   String^ name
) override

Parameters

name

The name to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteNmToken


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteProcessingInstruction Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteProcessingInstruction Method

name
The name of the processing instruction.
text

The text to include in the processing instruction.

Writes out a processing instruction.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim name As String
Dim text As String

instance.WriteProcessingInstruction(name, text)
C#
public override void WriteProcessingInstruction(
   string name,
   string text
)
Delphi
public procedure WriteProcessingInstruction(
    name: String;
    text: String
); override;
JScript
public override function WriteProcessingInstruction(
   name : String,
   text : String
);
Managed Extensions for C++
public: void WriteProcessingInstruction(
   string* name,
   string* text
) override
C++/CLI
public:
void WriteProcessingInstruction(
   String^ name,
   String^ text
) override

Parameters

name
The name of the processing instruction.
text

The text to include in the processing instruction.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteProcessingInstruction


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteQualifiedName Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteQualifiedName Method

localName
The local name to write.
ns

The namespace URI for the name.

Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteQualifiedName( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteQualifiedName(localName, ns)
C#
public override void WriteQualifiedName(
   string localName,
   string ns
)
Delphi
public procedure WriteQualifiedName(
    localName: String;
    ns: String
); override;
JScript
public override function WriteQualifiedName(
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteQualifiedName(
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteQualifiedName(
   String^ localName,
   String^ ns
) override

Parameters

localName
The local name to write.
ns

The namespace URI for the name.

Remarks

If ns maps to the current default namespace, no prefix is generated.

This method generates a prefix if ns is not found.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteQualifiedName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteRaw Method

This method is not supported.

Overload List

Overload | Description
WriteRaw(Char[],Int32,Int32) | This method is not supported.
WriteRaw(String) | This method is not supported.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteRaw


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw(Char[],Int32,Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteRaw Method : WriteRaw(Char[],Int32,Int32) Method

buffer
The character array containing the text to write.
index
The position within the buffer indicating the start of the text to write.
count

The number of characters to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteRaw(buffer, index, count)
C#
public override void WriteRaw(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteRaw(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteRaw(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteRaw(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteRaw(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The character array containing the text to write.
index
The position within the buffer indicating the start of the text to write.
count

The number of characters to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteRaw(Char[],Int32,Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteRaw Method : WriteRaw(String) Method

data

The string containing the text to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteRaw( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim data As String

instance.WriteRaw(data)
C#
public override void WriteRaw(
   string data
)
Delphi
public procedure WriteRaw(
    data: String
); override;
JScript
public override function WriteRaw(
   data : String
);
Managed Extensions for C++
public: void WriteRaw(
   string* data
) override
C++/CLI
public:
void WriteRaw(
   String^ data
) override

Parameters

data

The string containing the text to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteRaw(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartAttribute Method

Writes the start of an attribute.

Overload List

Overload | Description
WriteStartAttribute(String,String,String) | Writes the start of an attribute.
WriteStartAttribute(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartAttribute(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteStartAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String,String) Method

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

Writes the start of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartAttribute( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(prefix, localName, ns)
C#
public override void WriteStartAttribute(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartAttribute(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartAttribute(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartAttribute(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteStartAttribute(String,String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartDocument Method

Writes the XML declaration with the version "1.0".

Overload List

Overload | Description
WriteStartDocument() | Writes the XML declaration with the version "1.0".
WriteStartDocument(Boolean) | Writes the XML declaration with the version "1.0".

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteStartDocument


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartDocument Method : WriteStartDocument() Method

Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter

instance.WriteStartDocument()
C#
public override void WriteStartDocument()
Delphi
public procedure WriteStartDocument(); override;
JScript
public override function WriteStartDocument();
Managed Extensions for C++
public: void WriteStartDocument(); override
C++/CLI
public:
void WriteStartDocument(); override

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteStartDocument()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartDocument Method : WriteStartDocument(Boolean) Method

standalone
Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartDocument( _
   ByVal standalone As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim standalone As Boolean

instance.WriteStartDocument(standalone)
C#
public override void WriteStartDocument(
   bool standalone
)
Delphi
public procedure WriteStartDocument(
    standalone: Boolean
); override;
JScript
public override function WriteStartDocument(
   standalone : boolean
);
Managed Extensions for C++
public: void WriteStartDocument(
   bool standalone
) override
C++/CLI
public:
void WriteStartDocument(
   bool standalone
) override

Parameters

standalone

Remarks

Since XmlFastInfosetWriter does not preserve the original XML declaration, standalone is ignored.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteStartDocument(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteStartElement Method

Writes the specified start tag.

Overload List

Overload | Description
WriteStartElement(String,String,String) | Writes the specified start tag.
WriteStartElement(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartElement(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String,String,String) Method

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.
Writes the specified start tag.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteStartElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartElement(prefix, localName, ns)
C#
public override void WriteStartElement(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartElement(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartElement(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartElement(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteStartElement(String,String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteString Method

text

The text to write.

Writes the given text content.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim text As String

instance.WriteString(text)
C#
public override void WriteString(
   string text
)
Delphi
public procedure WriteString(
    text: String
); override;
JScript
public override function WriteString(
   text : String
);
Managed Extensions for C++
public: void WriteString(
   string* text
) override
C++/CLI
public:
void WriteString(
   String^ text
) override

Parameters

text

The text to write.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteSurrogateCharEntity Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteSurrogateCharEntity Method

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

Writes a Unicode surrogate char pair.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteSurrogateCharEntity( _
   ByVal lowChar As Char, _
   ByVal highChar As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim lowChar As Char
Dim highChar As Char

instance.WriteSurrogateCharEntity(lowChar, highChar)
C#
public override void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
)
Delphi
public procedure WriteSurrogateCharEntity(
    lowChar: Char;
    highChar: Char
); override;
JScript
public override function WriteSurrogateCharEntity(
   lowChar : char,
   highChar : char
);
Managed Extensions for C++
public: void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override
C++/CLI
public:
void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override

Parameters

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteSurrogateCharEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteValue Method

Writes a single or multiple simple-typed values.

Overload List

Overload | Description
WriteValue(Object) | Writes the value.
WriteValue(Int32[]) | Encodes a single or multiple 32-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Int64[]) | Encodes a single or multiple 64-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Int16[]) | Encodes a single or multiple 16-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Double[]) | Encodes a single or multiple double-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Single[]) | Encodes a single or multiple single-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Boolean[]) | Encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Decimal[]) | Encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the element content.
WriteValue(Boolean) | Writes a boolean value.
WriteValue(Double) | Writes a double-precision floating point value.
WriteValue(Single) | Writes a single-precision floating point value.
WriteValue(Int64) | Writes a 64-bit signed integer value.
WriteValue(Int32) | Writes a 32-bit signed integer.
WriteValue(Int16) | Writes a 16-bit signed integer value.
WriteValue(TimeSpan) | Write TimeSpan value.
WriteValue(Decimal) | Write Decimal value.
WriteValue(DateTime) | Write DateTime value.
WriteValue(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Object) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Object) Method

value
The object representing the value to write.

Writes the value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Object

instance.WriteValue(value)
C#
public override void WriteValue(
   object value
)
Delphi
public procedure WriteValue(
    value: TObject
); override;
JScript
public override function WriteValue(
   value : Object
);
Managed Extensions for C++
public: void WriteValue(
   Object* value
) override
C++/CLI
public:
void WriteValue(
   Object^ value
) override

Parameters

value
The object representing the value to write.

Remarks

This method takes the common language runtime (CLR) object and converts the input value to the desired output type using the FastInfoset encoding rules. If the type cannot not be represented as a binary encoded value it's serialized as a string according to the XML Schema definition language (XSD) data type conversion rules.

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Object)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int32[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int32[]) Method

value
The array containing a single or multiple 32-bit signed integers.

Encodes a single or multiple 32-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Integer

instance.WriteValue(value)
C#
public new void WriteValue(
   int[] value
)
Delphi
public procedure WriteValue(
    value: Integerarray of
);
JScript
public hide function WriteValue(
   value : int[]
);
Managed Extensions for C++
public: new void WriteValue(
   int[]* value
)
C++/CLI
public:
new void WriteValue(
   array<int>^ value
)

Parameters

value
The array containing a single or multiple 32-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int64[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int64[]) Method

value
The array containing a single or multiple 64-bit signed integers.

Encodes a single or multiple 64-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Long

instance.WriteValue(value)
C#
public new void WriteValue(
   long[] value
)
Delphi
public procedure WriteValue(
    value: Int64array of
);
JScript
public hide function WriteValue(
   value : long[]
);
Managed Extensions for C++
public: new void WriteValue(
   long[]* value
)
C++/CLI
public:
new void WriteValue(
   array<int64>^ value
)

Parameters

value
The array containing a single or multiple 64-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int16[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int16[]) Method

value
The array containing a single or multiple 16-bit signed integers.

Encodes a single or multiple 16-bit signed integers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Short

instance.WriteValue(value)
C#
public new void WriteValue(
   short[] value
)
Delphi
public procedure WriteValue(
    value: ShortIntarray of
);
JScript
public hide function WriteValue(
   value : short[]
);
Managed Extensions for C++
public: new void WriteValue(
   short[]* value
)
C++/CLI
public:
new void WriteValue(
   array<short>^ value
)

Parameters

value
The array containing a single or multiple 16-bit signed integers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Double[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Double[]) Method

value
The array containing a single or multiple double-precision floating-point numbers.

Encodes a single or multiple double-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Double

instance.WriteValue(value)
C#
public new void WriteValue(
   double[] value
)
Delphi
public procedure WriteValue(
    value: Doublearray of
);
JScript
public hide function WriteValue(
   value : double[]
);
Managed Extensions for C++
public: new void WriteValue(
   double[]* value
)
C++/CLI
public:
new void WriteValue(
   array<double>^ value
)

Parameters

value
The array containing a single or multiple double-precision floating-point numbers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Single[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Single[]) Method

value
The array containing a single or multiple single-precision floating-point numbers.

Encodes a single or multiple single-precision floating-point numbers using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Single

instance.WriteValue(value)
C#
public new void WriteValue(
   float[] value
)
Delphi
public procedure WriteValue(
    value: Singlearray of
);
JScript
public hide function WriteValue(
   value : float[]
);
Managed Extensions for C++
public: new void WriteValue(
   float[]* value
)
C++/CLI
public:
new void WriteValue(
   array<float>^ value
)

Parameters

value
The array containing a single or multiple single-precision floating-point numbers.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Boolean[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Boolean[]) Method

value
The array containing a single or multiple boolean values.

Encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Boolean

instance.WriteValue(value)
C#
public new void WriteValue(
   bool[] value
)
Delphi
public procedure WriteValue(
    value: Booleanarray of
);
JScript
public hide function WriteValue(
   value : boolean[]
);
Managed Extensions for C++
public: new void WriteValue(
   bool[]* value
)
C++/CLI
public:
new void WriteValue(
   array<bool>^ value
)

Parameters

value
The array containing a single or multiple boolean values.

Remarks

This method encodes a single or multiple boolean values using Fast Infoset's binary encoding and writes the result at the current position in the content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Decimal[]) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Decimal[]) Method

value
The array containing a single or multiple decimal values.

Encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the element content.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value() As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value() As Decimal

instance.WriteValue(value)
C#
public new void WriteValue(
   decimal[] value
)
Delphi
public procedure WriteValue(
    value: Currencyarray of
);
JScript
public hide function WriteValue(
   value : decimal[]
);
Managed Extensions for C++
public: new void WriteValue(
   decimal[]* value
)
C++/CLI
public:
new void WriteValue(
   array<decimal>^ value
)

Parameters

value
The array containing a single or multiple decimal values.

Remarks

This method encodes a single or multiple decimal values using Fast Infoset's binary encoding and writes the result at the current position in the content.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Boolean) Method

value

The boolean value to write.

Writes a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.WriteValue(value)
C#
public override void WriteValue(
   bool value
)
Delphi
public procedure WriteValue(
    value: Boolean
); override;
JScript
public override function WriteValue(
   value : boolean
);
Managed Extensions for C++
public: void WriteValue(
   bool value
) override
C++/CLI
public:
void WriteValue(
   bool value
) override

Parameters

value

The boolean value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Double) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Double) Method

value

The double-precision floating-point value to write.

Writes a double-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Double

instance.WriteValue(value)
C#
public override void WriteValue(
   double value
)
Delphi
public procedure WriteValue(
    value: Double
); override;
JScript
public override function WriteValue(
   value : double
);
Managed Extensions for C++
public: void WriteValue(
   double value
) override
C++/CLI
public:
void WriteValue(
   double value
) override

Parameters

value

The double-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Double)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Single) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Single) Method

value

The single-precision floating-point value to write.

Writes a single-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Single

instance.WriteValue(value)
C#
public override void WriteValue(
   float value
)
Delphi
public procedure WriteValue(
    value: Single
); override;
JScript
public override function WriteValue(
   value : float
);
Managed Extensions for C++
public: void WriteValue(
   float value
) override
C++/CLI
public:
void WriteValue(
   float value
) override

Parameters

value

The single-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Single)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int64) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int64) Method

value

The 64-bit signed integer value to write.

Writes a 64-bit signed integer value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Long

instance.WriteValue(value)
C#
public override void WriteValue(
   long value
)
Delphi
public procedure WriteValue(
    value: Int64
); override;
JScript
public override function WriteValue(
   value : long
);
Managed Extensions for C++
public: void WriteValue(
   long value
) override
C++/CLI
public:
void WriteValue(
   int64 value
) override

Parameters

value

The 64-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Int64)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int32) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int32) Method

value

The 32-bit signed integer value to write.

Writes a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.WriteValue(value)
C#
public override void WriteValue(
   int value
)
Delphi
public procedure WriteValue(
    value: Integer
); override;
JScript
public override function WriteValue(
   value : int
);
Managed Extensions for C++
public: void WriteValue(
   int value
) override
C++/CLI
public:
void WriteValue(
   int value
) override

Parameters

value

The 32-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int16) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Int16) Method

value

The 16-bit signed integer value to write.

Writes a 16-bit signed integer value.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value As Short _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Short

instance.WriteValue(value)
C#
public new void WriteValue(
   short value
)
Delphi
public procedure WriteValue(
    value: ShortInt
);
JScript
public hide function WriteValue(
   value : short
);
Managed Extensions for C++
public: new void WriteValue(
   short value
)
C++/CLI
public:
new void WriteValue(
   short value
)

Parameters

value

The 16-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(TimeSpan) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(TimeSpan) Method

value
TimeSpan value to write.
Write TimeSpan value.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Sub WriteValue( _
   ByVal value As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As TimeSpan

instance.WriteValue(value)
C#
public new void WriteValue(
   TimeSpan value
)
Delphi
public procedure WriteValue(
    value: TimeSpan
);
JScript
public hide function WriteValue(
   value : TimeSpan
);
Managed Extensions for C++
public: new void WriteValue(
   TimeSpan value
)
C++/CLI
public:
new void WriteValue(
   TimeSpan value
)

Parameters

value
TimeSpan value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Decimal) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(Decimal) Method

value
Decimal value to writer.
Write Decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Decimal

instance.WriteValue(value)
C#
public override void WriteValue(
   decimal value
)
Delphi
public procedure WriteValue(
    value: Currency
); override;
JScript
public override function WriteValue(
   value : decimal
);
Managed Extensions for C++
public: void WriteValue(
   decimal value
) override
C++/CLI
public:
void WriteValue(
   decimal value
) override

Parameters

value
Decimal value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(Decimal)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(DateTime) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(DateTime) Method

value
DateTime value to writer.
Write DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Sub WriteValue( _
   ByVal value As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Date

instance.WriteValue(value)
C#
public override void WriteValue(
   DateTime value
)
Delphi
public procedure WriteValue(
    value: DateTime
); override;
JScript
public override function WriteValue(
   value : DateTime
);
Managed Extensions for C++
public: void WriteValue(
   DateTime value
) override
C++/CLI
public:
void WriteValue(
   DateTime value
) override

Parameters

value
DateTime value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List
Base Implementation in WriteValue(DateTime)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteWhitespace Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteWhitespace Method

ws

The string of white space characters.

Writes out the given white space.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub WriteWhitespace( _
   ByVal ws As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim ws As String

instance.WriteWhitespace(ws)
C#
public override void WriteWhitespace(
   string ws
)
Delphi
public procedure WriteWhitespace(
    ws: String
); override;
JScript
public override function WriteWhitespace(
   ws : String
);
Managed Extensions for C++
public: void WriteWhitespace(
   string* ws
) override
C++/CLI
public:
void WriteWhitespace(
   String^ ws
) override

Parameters

ws

The string of white space characters.

Remarks

XmlFastInfosetWriter does not preserve non-significant white space unless it's written within the scope of the element with the xml:space attribute set to "true" (xml:space="true").

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteWhitespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlnsAttribute Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteXmlnsAttribute Method

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.
Writes a namespace declaration attribute.

Syntax

Visual Basic (Declaration)
Public Sub WriteXmlnsAttribute( _
   ByVal prefix As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim namespaceUri As String

instance.WriteXmlnsAttribute(prefix, namespaceUri)
C#
public void WriteXmlnsAttribute(
   string prefix,
   string namespaceUri
)
Delphi
public procedure WriteXmlnsAttribute(
    prefix: String;
    namespaceUri: String
);
JScript
public function WriteXmlnsAttribute(
   prefix : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void WriteXmlnsAttribute(
   string* prefix,
   string* namespaceUri
)
C++/CLI
public:
void WriteXmlnsAttribute(
   String^ prefix,
   String^ namespaceUri
)

Parameters

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriter Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriter Class

For a list of all members of this type, see XmlFastInfosetWriter members.

Public Properties

 | Name | Description
public Property | AttributeStringsIndexed | Returns the number of the attribute value strings indexed in FastInfoset vocabulary.
public Property | ContentStringsIndexed | Returns the number of the element content strings indexed in FastInfoset vocabulary.
public Property | IgnoreComments | Gets and sets whether this writer should ignore calls to the WriteComment method.
public Property | IgnoreProcessingInstructions | Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | OtherStringsIndexed | Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Gets the current xml:lang scope.
public Property | XmlSpace | Overridden. Gets an XmlSpace representing the current xml:space scope.
Top

See Also

Reference

XmlFastInfosetWriter Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AttributeStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : AttributeStringsIndexed Property

Returns the number of the attribute value strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AttributeStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.AttributeStringsIndexed
C#
public int AttributeStringsIndexed {get;}
Delphi
public read-only property AttributeStringsIndexed: Integer;
JScript
public function get AttributeStringsIndexed : int
Managed Extensions for C++
public: __property int get_AttributeStringsIndexed();
C++/CLI
public:
property int AttributeStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : ContentStringsIndexed Property

Returns the number of the element content strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContentStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.ContentStringsIndexed
C#
public int ContentStringsIndexed {get;}
Delphi
public read-only property ContentStringsIndexed: Integer;
JScript
public function get ContentStringsIndexed : int
Managed Extensions for C++
public: __property int get_ContentStringsIndexed();
C++/CLI
public:
property int ContentStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IgnoreComments Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : IgnoreComments Property

Gets and sets whether this writer should ignore calls to the WriteComment method.

Syntax

Visual Basic (Declaration)
Public Property IgnoreComments As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.IgnoreComments = value

value = instance.IgnoreComments
C#
public bool IgnoreComments {get; set;}
Delphi
public read-write property IgnoreComments: Boolean;
JScript
public function get,set IgnoreComments : boolean
Managed Extensions for C++
public: __property bool get_IgnoreComments();
public: __property void set_IgnoreComments(
   bool value
);
C++/CLI
public:
property bool IgnoreComments {
   bool get();
   void set (    bool value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IgnoreProcessingInstructions Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : IgnoreProcessingInstructions Property

Gets and sets whether this writer should ignore calls to the WriteProcessingInstruction method.

Syntax

Visual Basic (Declaration)
Public Property IgnoreProcessingInstructions As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Boolean

instance.IgnoreProcessingInstructions = value

value = instance.IgnoreProcessingInstructions
C#
public bool IgnoreProcessingInstructions {get; set;}
Delphi
public read-write property IgnoreProcessingInstructions: Boolean;
JScript
public function get,set IgnoreProcessingInstructions : boolean
Managed Extensions for C++
public: __property bool get_IgnoreProcessingInstructions();
public: __property void set_IgnoreProcessingInstructions(
   bool value
);
C++/CLI
public:
property bool IgnoreProcessingInstructions {
   bool get();
   void set (    bool value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that may be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum number of strings specifies up to how many strings may be added to the vocabulary. When this limit is reached, no more values are added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : MaxVocabularyStringLength Property

Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum string length specifies the maximum number of characters that a string value may contain in order to be added to the vocabulary. Longer values are not added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OtherStringsIndexed Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : OtherStringsIndexed Property

Returns the number of the comment and Processing Instruction value strings indexed in FastInfoset vocabulary.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OtherStringsIndexed As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As Integer

value = instance.OtherStringsIndexed
C#
public int OtherStringsIndexed {get;}
Delphi
public read-only property OtherStringsIndexed: Integer;
JScript
public function get OtherStringsIndexed : int
Managed Extensions for C++
public: __property int get_OtherStringsIndexed();
C++/CLI
public:
property int OtherStringsIndexed {
   int get();
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Profile Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Profile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property Profile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlFastInfosetWriterProfile

instance.Profile = value

value = instance.Profile
C#
public XmlFastInfosetWriterProfile Profile {get; set;}
Delphi
public read-write property Profile: XmlFastInfosetWriterProfile;
JScript
public function get,set Profile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_Profile();
public: __property void set_Profile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ Profile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Settings Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Settings Property

Gets the XmlWriterSettings object used to create this XmlWriter instance.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Settings As XmlWriterSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlWriterSettings

value = instance.Settings
C#
public override XmlWriterSettings Settings {get;}
Delphi
public read-only property Settings: XmlWriterSettings; override;
JScript
public override function get Settings : XmlWriterSettings
Managed Extensions for C++
public: __property XmlWriterSettings* get_Settings() override;
C++/CLI
public:
property XmlWriterSettings^ Settings {
   XmlWriterSettings^ get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in Settings


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteState Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteState Property

Gets the state of the writer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property WriteState As WriteState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As WriteState

value = instance.WriteState
C#
public override WriteState WriteState {get;}
Delphi
public read-only property WriteState: WriteState; override;
JScript
public override function get WriteState : WriteState
Managed Extensions for C++
public: __property WriteState get_WriteState() override;
C++/CLI
public:
property WriteState WriteState {
   WriteState get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in WriteState


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlLang Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlLang Property

Gets the current xml:lang scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As String

value = instance.XmlLang
C#
public override string XmlLang {get;}
Delphi
public read-only property XmlLang: String; override;
JScript
public override function get XmlLang : String
Managed Extensions for C++
public: __property string* get_XmlLang() override;
C++/CLI
public:
property String^ XmlLang {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in XmlLang


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlSpace Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : XmlSpace Property

Gets an XmlSpace representing the current xml:space scope.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As XmlSpace

value = instance.XmlSpace
C#
public override XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace; override;
JScript
public override function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property XmlSpace get_XmlSpace() override;
C++/CLI
public:
property XmlSpace XmlSpace {
   XmlSpace get() override;
}

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Base Implementation in XmlSpace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Class
Members See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

Contains the settings that specify the way FastInfoset serializes primitive data types.

Object Model

XmlFastInfosetWriterProfile Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
C#
public sealed class XmlFastInfosetWriterProfile
Delphi
public class XmlFastInfosetWriterProfile sealed;
JScript
public sealed class XmlFastInfosetWriterProfile
Managed Extensions for C++
public __gc __sealed class XmlFastInfosetWriterProfile
C++/CLI
public ref class XmlFastInfosetWriterProfile sealed

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.XmlFastInfosetWriterProfile

See Also

Reference

XmlFastInfosetWriterProfile Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Class Members
See Also Properties Methods Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

The following tables list the members exposed by XmlFastInfosetWriterProfile.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetWriterProfile Constructor | Overloaded.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Basic | The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
static (Shared in Visual Basic) | Compact | The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
static (Shared in Visual Basic) | DotNet | This profile is obsolete. If selected, the Basic profile will be used instead.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
static (Shared in Visual Basic) | Literal | Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a copy cone of the XmlFastInfosetWriterProfile.
public Method | CopyFrom | Coppies all properties from already existing XmlFastInfosetWriterProfile object.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Constructor
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : XmlFastInfosetWriterProfile Constructor

Overload List

Overload | Description
XmlFastInfosetWriterProfile Constructor(XmlFastInfosetWriterProfile) | Initializes a new instance of XmlFastInfosetWriterProfile by coping settings of already exisitng one.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Constructor(XmlFastInfosetWriterProfile)
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class > XmlFastInfosetWriterProfile Constructor : XmlFastInfosetWriterProfile Constructor(XmlFastInfosetWriterProfile)

source
The profile to copy settings from.
Initializes a new instance of XmlFastInfosetWriterProfile by coping settings of already exisitng one.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As XmlFastInfosetWriterProfile _
)
Visual Basic (Usage) Copy Code
Dim source As XmlFastInfosetWriterProfile

Dim instance As New XmlFastInfosetWriterProfile(source)
C#
public XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile source
)
Delphi
public XmlFastInfosetWriterProfile(
    source: XmlFastInfosetWriterProfile
);
JScript
public function XmlFastInfosetWriterProfile(
   source : XmlFastInfosetWriterProfile
);
Managed Extensions for C++
public: XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile* source
)
C++/CLI
public:
XmlFastInfosetWriterProfile(
   XmlFastInfosetWriterProfile^ source
)

Parameters

source
The profile to copy settings from.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Class Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

For a list of all members of this type, see XmlFastInfosetWriterProfile members.

Public Methods

 | Name | Description
public Method | Clone | Creates a copy cone of the XmlFastInfosetWriterProfile.
public Method | CopyFrom | Coppies all properties from already existing XmlFastInfosetWriterProfile object.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Clone Method

Creates a copy cone of the XmlFastInfosetWriterProfile.

Syntax

Visual Basic (Declaration)
Public Function Clone() As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetWriterProfile

value = instance.Clone()
C#
public XmlFastInfosetWriterProfile Clone()
Delphi
public function Clone(): XmlFastInfosetWriterProfile;
JScript
public function Clone() : XmlFastInfosetWriterProfile;
Managed Extensions for C++
public: XmlFastInfosetWriterProfile* Clone();
C++/CLI
public:
XmlFastInfosetWriterProfile^ Clone();

Return Value

The clone of this object.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : CopyFrom Method

source
The source XmlFastInfosetWriterProfile object to copy properties from.
Coppies all properties from already existing XmlFastInfosetWriterProfile object.

Syntax

Visual Basic (Declaration)
Public Sub CopyFrom( _
   ByVal source As XmlFastInfosetWriterProfile _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim source As XmlFastInfosetWriterProfile

instance.CopyFrom(source)
C#
public void CopyFrom(
   XmlFastInfosetWriterProfile source
)
Delphi
public procedure CopyFrom(
    source: XmlFastInfosetWriterProfile
);
JScript
public function CopyFrom(
   source : XmlFastInfosetWriterProfile
);
Managed Extensions for C++
public: void CopyFrom(
   XmlFastInfosetWriterProfile* source
)
C++/CLI
public:
void CopyFrom(
   XmlFastInfosetWriterProfile^ source
)

Parameters

source
The source XmlFastInfosetWriterProfile object to copy properties from.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetWriterProfile Class

For a list of all members of this type, see XmlFastInfosetWriterProfile members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Basic | The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
static (Shared in Visual Basic) | Compact | The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
static (Shared in Visual Basic) | DotNet | This profile is obsolete. If selected, the Basic profile will be used instead.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
static (Shared in Visual Basic) | Literal | Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

See Also

Reference

XmlFastInfosetWriterProfile Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Basic Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Basic Property

The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Basic As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Basic
C#
public static XmlFastInfosetWriterProfile Basic {get;}
Delphi
public read-only property Basic: XmlFastInfosetWriterProfile; static;
JScript
public static function get Basic : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Basic();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Basic {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BooleanFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : BooleanFormat Property

Gets and sets the format used to serialize boolean values.

Syntax

Visual Basic (Declaration)
Public Property BooleanFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.BooleanFormat = value

value = instance.BooleanFormat
C#
public XmlFastInfosetFormat BooleanFormat {get; set;}
Delphi
public read-write property BooleanFormat: XmlFastInfosetFormat;
JScript
public function get,set BooleanFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_BooleanFormat();
public: __property void set_BooleanFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat BooleanFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Compact Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Compact Property

The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Compact As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Compact
C#
public static XmlFastInfosetWriterProfile Compact {get;}
Delphi
public read-only property Compact: XmlFastInfosetWriterProfile; static;
JScript
public static function get Compact : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Compact();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Compact {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DateTimeFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DateTimeFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
Public Property DateTimeFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DateTimeFormat = value

value = instance.DateTimeFormat
C#
public XmlFastInfosetFormat DateTimeFormat {get; set;}
Delphi
public read-write property DateTimeFormat: XmlFastInfosetFormat;
JScript
public function get,set DateTimeFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DateTimeFormat();
public: __property void set_DateTimeFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DateTimeFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DecimalFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DecimalFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
Public Property DecimalFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DecimalFormat = value

value = instance.DecimalFormat
C#
public XmlFastInfosetFormat DecimalFormat {get; set;}
Delphi
public read-write property DecimalFormat: XmlFastInfosetFormat;
JScript
public function get,set DecimalFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DecimalFormat();
public: __property void set_DecimalFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DecimalFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DotNet Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DotNet Property

This profile is obsolete. If selected, the Basic profile will be used instead.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DotNet As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.DotNet
C#
public static XmlFastInfosetWriterProfile DotNet {get;}
Delphi
public read-only property DotNet: XmlFastInfosetWriterProfile; static;
JScript
public static function get DotNet : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_DotNet();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ DotNet {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DoubleFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : DoubleFormat Property

Gets and sets the format used to serialize double precision floating point values.

Syntax

Visual Basic (Declaration)
Public Property DoubleFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.DoubleFormat = value

value = instance.DoubleFormat
C#
public XmlFastInfosetFormat DoubleFormat {get; set;}
Delphi
public read-write property DoubleFormat: XmlFastInfosetFormat;
JScript
public function get,set DoubleFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_DoubleFormat();
public: __property void set_DoubleFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat DoubleFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FloatFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : FloatFormat Property

Gets and sets the format used to serialize floating point values.

Syntax

Visual Basic (Declaration)
Public Property FloatFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.FloatFormat = value

value = instance.FloatFormat
C#
public XmlFastInfosetFormat FloatFormat {get; set;}
Delphi
public read-write property FloatFormat: XmlFastInfosetFormat;
JScript
public function get,set FloatFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_FloatFormat();
public: __property void set_FloatFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat FloatFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GuidFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : GuidFormat Property

Gets and sets the format used to serialize guild values.

Syntax

Visual Basic (Declaration)
Public Property GuidFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.GuidFormat = value

value = instance.GuidFormat
C#
public XmlFastInfosetFormat GuidFormat {get; set;}
Delphi
public read-write property GuidFormat: XmlFastInfosetFormat;
JScript
public function get,set GuidFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_GuidFormat();
public: __property void set_GuidFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat GuidFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IntFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : IntFormat Property

Gets and sets the format used to encode integer values.

Syntax

Visual Basic (Declaration)
Public Property IntFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.IntFormat = value

value = instance.IntFormat
C#
public XmlFastInfosetFormat IntFormat {get; set;}
Delphi
public read-write property IntFormat: XmlFastInfosetFormat;
JScript
public function get,set IntFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_IntFormat();
public: __property void set_IntFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat IntFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Literal Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : Literal Property

Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Literal As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetWriterProfile

value = XmlFastInfosetWriterProfile.Literal
C#
public static XmlFastInfosetWriterProfile Literal {get;}
Delphi
public read-only property Literal: XmlFastInfosetWriterProfile; static;
JScript
public static function get Literal : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property static XmlFastInfosetWriterProfile* get_Literal();
C++/CLI
public:
static property XmlFastInfosetWriterProfile^ Literal {
   XmlFastInfosetWriterProfile^ get();
}

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LongFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : LongFormat Property

Gets and sets the format used to encode long integer values.

Syntax

Visual Basic (Declaration)
Public Property LongFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.LongFormat = value

value = instance.LongFormat
C#
public XmlFastInfosetFormat LongFormat {get; set;}
Delphi
public read-write property LongFormat: XmlFastInfosetFormat;
JScript
public function get,set LongFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_LongFormat();
public: __property void set_LongFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat LongFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ShortFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : ShortFormat Property

Gets and sets the format used to serialize short integer values.

Syntax

Visual Basic (Declaration)
Public Property ShortFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.ShortFormat = value

value = instance.ShortFormat
C#
public XmlFastInfosetFormat ShortFormat {get; set;}
Delphi
public read-write property ShortFormat: XmlFastInfosetFormat;
JScript
public function get,set ShortFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_ShortFormat();
public: __property void set_ShortFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat ShortFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TimeSpanFormat Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriterProfile Class : TimeSpanFormat Property

Gets and sets the format used to encode TimeSpan values.

Syntax

Visual Basic (Declaration)
Public Property TimeSpanFormat As XmlFastInfosetFormat
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
Dim value As XmlFastInfosetFormat

instance.TimeSpanFormat = value

value = instance.TimeSpanFormat
C#
public XmlFastInfosetFormat TimeSpanFormat {get; set;}
Delphi
public read-write property TimeSpanFormat: XmlFastInfosetFormat;
JScript
public function get,set TimeSpanFormat : XmlFastInfosetFormat
Managed Extensions for C++
public: __property XmlFastInfosetFormat get_TimeSpanFormat();
public: __property void set_TimeSpanFormat(
   XmlFastInfosetFormat value
);
C++/CLI
public:
property XmlFastInfosetFormat TimeSpanFormat {
   XmlFastInfosetFormat get();
   void set (    XmlFastInfosetFormat value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

XmlFastInfosetWriterProfile Class
XmlFastInfosetWriterProfile Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetCompression Enumeration
See Also Send Feedback
Noemax.FastInfoset Namespace : FastInfosetCompression Enumeration

Defines the compression algorithm to be used for compressing and decompressing data.

Syntax

Visual Basic (Declaration)
Public Enum FastInfosetCompression
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetCompression
C#
public enum FastInfosetCompression : System.Enum
Delphi
public enum FastInfosetCompression = class(System.Enum)
JScript
public enum FastInfosetCompression extends System.Enum
Managed Extensions for C++
__value public enum FastInfosetCompression : public System.Enum
C++/CLI
public enum class FastInfosetCompression : public System.Enum

Members

Member | Description
Deflate | DEFLATE compression algorithm.
GZip | GZIP compression algorithm.
Lzf | LZF compression algorithm.
Lzf3 | LZF3 compression algorithm.
Lzma | LZMA compression algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.FastInfoset.FastInfosetCompression

See Also

Reference

Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetFormat Enumeration
See Also Send Feedback
Noemax.FastInfoset Namespace : XmlFastInfosetFormat Enumeration

Defines the way that Fast Infoset serializes primitive data types.

Syntax

Visual Basic (Declaration)
Public Enum XmlFastInfosetFormat
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFormat
C#
public enum XmlFastInfosetFormat : System.Enum
Delphi
public enum XmlFastInfosetFormat = class(System.Enum)
JScript
public enum XmlFastInfosetFormat extends System.Enum
Managed Extensions for C++
__value public enum XmlFastInfosetFormat : public System.Enum
C++/CLI
public enum class XmlFastInfosetFormat : public System.Enum

Members

Member | Description
Binary | Encodes values in a binary format. Provides higher processing performance than Literal and Restricted Alphabet.
DotNet | This format is obsolete.
Literal | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
LiteralNoIndex | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
RestrictedAlphabet | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.
RestrictedAlphabetNoIndex | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.

Remarks

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. However, if there are few repeating values of the same data type then it might be preferable not to use indexing.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.FastInfoset.XmlFastInfosetFormat

See Also

Reference

Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IVocabularyProvider Interface
Members See Also Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

Defines the interface for resolving URI references to Fast Infoset vocabularies.

Syntax

Visual Basic (Declaration)
Public Interface IVocabularyProvider
Visual Basic (Usage) Copy Code
Dim instance As IVocabularyProvider
C#
public interface IVocabularyProvider
Delphi
public interface IVocabularyProvider
JScript
public interface IVocabularyProvider
Managed Extensions for C++
public __gc __interface IVocabularyProvider
C++/CLI
public interface class IVocabularyProvider

See Also

Reference

IVocabularyProvider Members
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
IVocabularyProvider Interface Members
See Also Methods Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

The following tables list the members exposed by IVocabularyProvider.

Public Methods

 | Name | Description
Method | ProvideVocabulary | Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.
Top

See Also

Reference

IVocabularyProvider Interface
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
IVocabularyProvider Interface Methods
See Also Send Feedback
Noemax.FastInfoset Namespace : IVocabularyProvider Interface

For a list of all members of this type, see IVocabularyProvider members.

Public Methods

 | Name | Description
Method | ProvideVocabulary | Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.
Top

See Also

Reference

IVocabularyProvider Interface
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProvideVocabulary Method
See Also Send Feedback
Noemax.FastInfoset Namespace > IVocabularyProvider Interface : ProvideVocabulary Method

uri
The URI to resolve.
reader
The reader to which vocabulary will be provided.
Resolves the vocabulary URI and, if found, calls the SetVocabulary method of the specified reader instance.

Syntax

Visual Basic (Declaration)
Sub ProvideVocabulary( _
   ByVal uri As String, _
   ByVal reader As XmlFastInfosetReader _
)
Visual Basic (Usage) Copy Code
Dim instance As IVocabularyProvider
Dim uri As String
Dim reader As XmlFastInfosetReader

instance.ProvideVocabulary(uri, reader)
C#
void ProvideVocabulary(
   string uri,
   XmlFastInfosetReader reader
)
Delphi
procedure ProvideVocabulary(
    uri: String;
    reader: XmlFastInfosetReader
);
JScript
function ProvideVocabulary(
   uri : String,
   reader : XmlFastInfosetReader
);
Managed Extensions for C++
void ProvideVocabulary(
   string* uri,
   XmlFastInfosetReader* reader
)
C++/CLI
void ProvideVocabulary(
   String^ uri,
   XmlFastInfosetReader^ reader
)

Parameters

uri
The URI to resolve.
reader
The reader to which vocabulary will be provided.

Remarks

The XmlFastInfosetReader calls this method when an external vocabulary URI is encountered within a document. The implementation of the IVocabularyProvider must resolve the vocabulary URI and, if found, call the SetVocabulary method of the specified reader instance.

See Also

Reference

IVocabularyProvider Interface
IVocabularyProvider Members


%%ItemTitle%%

Noemax.GZip Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | DeflateInputStream | Provides methods and properties for decompressing streams using the DEFLATE algorithm.
Class | DeflateOutputStream | Provides methods and properties for compressing streams using the DEFLATE algorithm.
Class | DeflateStream | Provides methods and properties for processing streams using the DEFLATE.
Class | ExtraFieldCollection | Represents a collection of GZip header fields.
Class | GZipHeaderField | Represents a GZip header field.
Class | GZipInputStream | Provides methods and properties to decompress GZIP stream.
Class | GZipOutputStream | Provides the compression stream writing GZip streams and files.
Class | GZipStream | Provides methods and properties for processing streams using the GZIP.
Class | InvalidInputException | The exception that is thrown when a compressed input stream is in an invalid format.

Enumerations

 | Enumeration | Description
Enumeration | CompressionMode | Defines the compression modes for GZipStream.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

Provides methods and properties for decompressing streams using the DEFLATE algorithm.

Object Model

DeflateInputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
C#
public class DeflateInputStream : System.IO.Stream
Delphi
public class DeflateInputStream = class(System.IO.Stream)
JScript
public class DeflateInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateInputStream : public System.IO.Stream
C++/CLI
public ref class DeflateInputStream : public System.IO.Stream

Remarks

By default, DeflateInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateInputStream

See Also

Reference

DeflateInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DeflateInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

The following tables list the members exposed by DeflateInputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : DeflateInputStream Constructor

Overload List

Overload | Description
DeflateInputStream Constructor(String) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream,Boolean,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream) | Initializes a new instance of DeflateInputStream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New DeflateInputStream(fileName)
C#
public DeflateInputStream(
   string fileName
)
Delphi
public DeflateInputStream(
    fileName: String
);
JScript
public function DeflateInputStream(
   fileName : String
);
Managed Extensions for C++
public: DeflateInputStream(
   string* fileName
)
C++/CLI
public:
DeflateInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Constructor(Stream,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen, zlibHeader)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New DeflateInputStream(stream)
C#
public DeflateInputStream(
   Stream stream
)
Delphi
public DeflateInputStream(
    stream: Stream
);
JScript
public function DeflateInputStream(
   stream : Stream
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DeflateInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Close Method

Closes the stream and releases any associated resources.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Close
DeflateInputStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List
Base Implementation in Dispose(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Restart Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Restart Method

Restarts the decompression starting from current possition of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Restart()
C#
public void Restart()
Delphi
public procedure Restart();
JScript
public function Restart();
Managed Extensions for C++
public: void Restart();
C++/CLI
public:
void Restart();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DeflateInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BytesBuffered Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BytesBuffered Property

Returns the number of unprocessed bytes in DeflateInputStream buffer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BytesBuffered As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.BytesBuffered
C#
public int BytesBuffered {get;}
Delphi
public read-only property BytesBuffered: Integer;
JScript
public function get BytesBuffered : int
Managed Extensions for C++
public: __property int get_BytesBuffered();
C++/CLI
public:
property int BytesBuffered {
   int get();
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanRead Property

This property always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

Provides methods and properties for compressing streams using the DEFLATE algorithm.

Object Model

DeflateOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
C#
public class DeflateOutputStream : System.IO.Stream
Delphi
public class DeflateOutputStream = class(System.IO.Stream)
JScript
public class DeflateOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateOutputStream : public System.IO.Stream
C++/CLI
public ref class DeflateOutputStream : public System.IO.Stream

Remarks

By default, DeflateOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateOutputStream

See Also

Reference

DeflateOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DeflateOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

The following tables list the members exposed by DeflateOutputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : DeflateOutputStream Constructor

Overload List

Overload | Description
DeflateOutputStream Constructor(String,Int32) | Initializes a new instance DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean) | Initializes a new instance DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32) | Initializes a new instance DeflateOutputStream class.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(String,Int32)

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(fileName, compressionLevel)
C#
public DeflateOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(stream, compressionLevel)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DeflateOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Close
DeflateOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List
Base Implementation in Dispose(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Finish Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Finish Method

Concludes compression and flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Finish()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Finish()
C#
public void Finish()
Delphi
public procedure Finish();
JScript
public function Finish();
Managed Extensions for C++
public: void Finish();
C++/CLI
public:
void Finish();

Remarks

Finish concludes compression by writing the markup indicating the end of compressed data and flushing the content of the internal buffer.

After this method has been called, no more data can be written to this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Overload List

Overload | Description
Flush() | Flushes the content of the internal buffer to the underlying stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Flush Method : Flush() Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Finish or Close method is called.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DeflateOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

This property is always true if Finish has not been called. After Finish has been called this property is false.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

Provides methods and properties for processing streams using the DEFLATE.

Object Model

DeflateStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
C#
public class DeflateStream : System.IO.Stream
Delphi
public class DeflateStream = class(System.IO.Stream)
JScript
public class DeflateStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateStream : public System.IO.Stream
C++/CLI
public ref class DeflateStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateStream

See Also

Reference

DeflateStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DeflateStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateStream Class

The following tables list the members exposed by DeflateStream.

Public Constructors

 | Name | Description
public Constructor | DeflateStream Constructor | Overloaded. Initializes a new instance of the DeflateStream class.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : DeflateStream Constructor

Initializes a new instance of the DeflateStream class.

Overload List

Overload | Description
DeflateStream Constructor(String,CompressionMode) | Initializes a new instance of DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(String,CompressionMode)

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New DeflateStream(fileName, mode)
C#
public DeflateStream(
   string fileName,
   CompressionMode mode
)
Delphi
public DeflateStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. There is no limit in the size of the stream to be compressed.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New DeflateStream(stream, mode)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default DeflateStream owns the underlying stream, so closing this stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New DeflateStream(stream, mode, compressionLevel)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DeflateStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Close
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Dispose Method

Flushes the content of internal buffer and closes the current stream.

Overload List

Overload | Description
Dispose(Boolean) | Flushes the content of internal buffer and closes the current stream.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List
Base Implementation in Dispose(Boolean)
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DeflateStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtraFieldCollection Class
Members See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

Represents a collection of GZip header fields.

Object Model

ExtraFieldCollection Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class ExtraFieldCollection
Delphi
public class ExtraFieldCollection sealed;
JScript
DefaultMemberAttribute("Item")
public sealed class ExtraFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class ExtraFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ExtraFieldCollection sealed

Inheritance Hierarchy

System.Object
Noemax.GZip.ExtraFieldCollection

See Also

Reference

ExtraFieldCollection Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ExtraFieldCollection Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

The following tables list the members exposed by ExtraFieldCollection.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ExtraFieldCollection Class Methods
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Add Method

Adds the header to the list of GZip headers.

Overload List

Overload | Description
Add(Int32,Byte[]) | Adds the header to the list of GZip headers.
Add(Byte,Byte,Byte[]) | Adds the header to the list of GZip headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add(Int32,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Int32,Byte[]) Method

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id As Integer, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim data() As Byte

instance.Add(id, data)
C#
public void Add(
   int id,
   byte[] data
)
Delphi
public procedure Add(
    id: Integer;
    data: Bytearray of
);
JScript
public function Add(
   id : int,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   int id,
   byte[]* data
)
C++/CLI
public:
void Add(
   int id,
   array<byte>^ data
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Add(Byte, Byte, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add(Byte,Byte,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Byte,Byte,Byte[]) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim data() As Byte

instance.Add(id1, id2, data)
C#
public void Add(
   byte id1,
   byte id2,
   byte[] data
)
Delphi
public procedure Add(
    id1: Byte;
    id2: Byte;
    data: Bytearray of
);
JScript
public function Add(
   id1 : byte,
   id2 : byte,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   byte id1,
   byte id2,
   byte[]* data
)
C++/CLI
public:
void Add(
   byte id1,
   byte id2,
   array<byte>^ data
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Add(UInt16, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Clear Method

Clears the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : CopyTo Method

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

Copies the content of the collection into an array of GZipHeaderField.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As GZipHeaderField, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim array() As GZipHeaderField
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   GZipHeaderField[] array,
   int arrayIndex
)
Delphi
public procedure CopyTo(
    array: GZipHeaderFieldarray of;
    arrayIndex: Integer
);
JScript
public function CopyTo(
   array : GZipHeaderField[],
   arrayIndex : int
);
Managed Extensions for C++
public: void CopyTo(
   GZipHeaderField*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<GZipHeaderField^>^ array,
   int arrayIndex
)

Parameters

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Get Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Get Method

Gets the header.Gets the header.

Overload List

Overload | Description
Get(Byte,Byte) | Gets the header associated with the ID represented as two ANSI character octet.
Get(Int32) | Gets the GZip header specified by its index in the list of headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Get(Byte,Byte) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Byte,Byte) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
Gets the header associated with the ID represented as two ANSI character octet.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim value() As Byte

value = instance.Get(id1, id2)
C#
public byte[] Get(
   byte id1,
   byte id2
)
Delphi
public function Get(
    id1: Byte;
    id2: Byte
): array of Byte;
JScript
public function Get(
   id1 : byte,
   id2 : byte
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   byte id1,
   byte id2
)
C++/CLI
public:
array<byte>^ Get(
   byte id1,
   byte id2
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Get(UInt16) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Get(Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Int32) Method

index
The index of the header field.
Gets the GZip header specified by its index in the list of headers.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal index As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value() As Byte

value = instance.Get(index)
C#
public byte[] Get(
   int index
)
Delphi
public function Get(
    index: Integer
): array of Byte;
JScript
public function Get(
   index : int
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   int index
)
C++/CLI
public:
array<byte>^ Get(
   int index
)

Parameters

index
The index of the header field.

Return Value

The array of bytes stored in the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetByID Method

id
The 16-bit unsigned integer identifier of the header field.
Gets the header associated with the ID represented as a 16-bit unsigned integer. Gets the header.

Syntax

Visual Basic (Declaration)
Public Function GetByID( _
   ByVal id As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim value() As Byte

value = instance.GetByID(id)
C#
public byte[] GetByID(
   int id
)
Delphi
public function GetByID(
    id: Integer
): array of Byte;
JScript
public function GetByID(
   id : int
) : byte[];
Managed Extensions for C++
public: byte[]* GetByID(
   int id
)
C++/CLI
public:
array<byte>^ GetByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Get(Byte, Byte) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetEnumerator Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetEnumerator Method

Gets a list of items in a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of GZipHeaderField)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As IEnumerator(Of GZipHeaderField)

value = instance.GetEnumerator()
C#
public IEnumerator<GZipHeaderField> GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: IEnumerator<GZipHeaderField*>* GetEnumerator();
C++/CLI
public:
IEnumerator<GZipHeaderField^>^ GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Remove Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Remove Method

index
The index of header field.
Removes the header with the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Delphi
public procedure Remove(
    index: Integer
);
JScript
public function Remove(
   index : int
);
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index
The index of header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
RemoveByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : RemoveByID Method

id
The 16-bit unsigned integer identifier of the header field.

Removes the header specified by the 16-bit unsigned integer ID.

Syntax

Visual Basic (Declaration)
Public Sub RemoveByID( _
   ByVal id As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer

instance.RemoveByID(id)
C#
public void RemoveByID(
   int id
)
Delphi
public procedure RemoveByID(
    id: Integer
);
JScript
public function RemoveByID(
   id : int
);
Managed Extensions for C++
public: void RemoveByID(
   int id
)
C++/CLI
public:
void RemoveByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ExtraFieldCollection Class Properties
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Count Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Count Property

Gets the number of contained headers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean;
JScript
public function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Item Property

index
Gets the header at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value As GZipHeaderField

value = instance.Item(index)
C#
public GZipHeaderField this(
   int index
) {get;}
Delphi
public  this: : GZipHeaderField;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : GZipHeaderField
Managed Extensions for C++
public: __property GZipHeaderField* get_Item(
   int index
);
C++/CLI
public:
property GZipHeaderField^ default [int] {
   GZipHeaderField^ get(int index);
}

Parameters

index

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipHeaderField Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

Represents a GZip header field.

Object Model

GZipHeaderField Class

Syntax

Visual Basic (Declaration)
Public Class GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
C#
public class GZipHeaderField
Delphi
public class GZipHeaderField
JScript
public class GZipHeaderField
Managed Extensions for C++
public __gc class GZipHeaderField
C++/CLI
public ref class GZipHeaderField

Inheritance Hierarchy

System.Object
Noemax.GZip.GZipHeaderField

See Also

Reference

GZipHeaderField Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
GZipHeaderField Class Members
See Also Properties Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

The following tables list the members exposed by GZipHeaderField.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
GZipHeaderField Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

For a list of all members of this type, see GZipHeaderField members.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Data Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : Data Property

The data contained in the header field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value() As Byte

value = instance.Data
C#
public byte[] Data {get;}
Delphi
public read-only property Data: array of Byte;
JScript
public function get Data : byte[]
Managed Extensions for C++
public: __property byte[]* get_Data();
C++/CLI
public:
property array<byte>^ Data {
   array<byte>^ get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ID Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID Property

The 16-bit identifier of the header field (concatenated ID1 and ID2).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As Short
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Short

value = instance.ID
C#
public short ID {get;}
Delphi
public read-only property ID: ShortInt;
JScript
public function get ID : short
Managed Extensions for C++
public: __property short get_ID();
C++/CLI
public:
property short ID {
   short get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ID1 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID1 Property

The 8-bit ID1 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID1
C#
public byte ID1 {get;}
Delphi
public read-only property ID1: Byte;
JScript
public function get ID1 : byte
Managed Extensions for C++
public: __property byte get_ID1();
C++/CLI
public:
property byte ID1 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ID2 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID2 Property

The 8-bit ID2 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID2
C#
public byte ID2 {get;}
Delphi
public read-only property ID2: Byte;
JScript
public function get ID2 : byte
Managed Extensions for C++
public: __property byte get_ID2();
C++/CLI
public:
property byte ID2 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

Provides methods and properties to decompress GZIP stream.

Object Model

GZipInputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
C#
public class GZipInputStream : System.IO.Stream
Delphi
public class GZipInputStream = class(System.IO.Stream)
JScript
public class GZipInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipInputStream : public System.IO.Stream
C++/CLI
public ref class GZipInputStream : public System.IO.Stream

Remarks

By default, GZipInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipInputStream

See Also

Reference

GZipInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
GZipInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

The following tables list the members exposed by GZipInputStream.

Public Constructors

 | Name | Description
public Constructor | GZipInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GZipInputStream Constructor

Overload List

Overload | Description
GZipInputStream Constructor(String) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream,Boolean) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream) | Initializes a new instance of GZipInputStream class.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New GZipInputStream(fileName)
C#
public GZipInputStream(
   string fileName
)
Delphi
public GZipInputStream(
    fileName: String
);
JScript
public function GZipInputStream(
   fileName : String
);
Managed Extensions for C++
public: GZipInputStream(
   string* fileName
)
C++/CLI
public:
GZipInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New GZipInputStream(stream, leaveOpen)
C#
public GZipInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public GZipInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function GZipInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New GZipInputStream(stream)
C#
public GZipInputStream(
   Stream stream
)
Delphi
public GZipInputStream(
    stream: Stream
);
JScript
public function GZipInputStream(
   stream : Stream
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
GZipInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.Closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream have been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Close
GZipInputStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List
Base Implementation in Dispose(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown. A cyclic redundancy check (CRC) is performed when all data up to the end of stream have been read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadHeader Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadHeader Method

Reads the GZIP header from the stream.

Syntax

Visual Basic (Declaration)
Public Sub ReadHeader()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ReadHeader()
C#
public void ReadHeader()
Delphi
public procedure ReadHeader();
JScript
public function ReadHeader();
Managed Extensions for C++
public: void ReadHeader();
C++/CLI
public:
void ReadHeader();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
GZipInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanRead Property

Gets a value indicating whether the stream supports reading while decompressing a file.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports reading and is not closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

Remarks

The length check can fail on the files that are bigger than 4GB, since GZIP header does not support serializing bigger number. For this reason it's recommended to set this property to false in cases when original data might exceed the 4294967295 bytes.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ExtraFields Property

The collection of extra-fields read from the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

If the GZip header does not contain any extra-fields this property returns an empty ExtraFieldCollection.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Filename Property

Gets the filename specified in the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As String

value = instance.Filename
C#
public string Filename {get;}
Delphi
public read-only property Filename: String;
JScript
public function get Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
C++/CLI
public:
property String^ Filename {
   String^ get();
}

Remarks

If the filename is not present in the GZip header it returns null (Nothing for Visual Basic).

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GZipInputStream will try to read the Length property of the underlying stream. Check the the Length property documentation of the underlying stream for more information.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ParseExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ParseExtraFields Property

Gets and sets whether the reader should parse the extra-fields stored in the GZip header.

Syntax

Visual Basic (Declaration)
Public Property ParseExtraFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.ParseExtraFields = value

value = instance.ParseExtraFields
C#
public bool ParseExtraFields {get; set;}
Delphi
public read-write property ParseExtraFields: Boolean;
JScript
public function get,set ParseExtraFields : boolean
Managed Extensions for C++
public: __property bool get_ParseExtraFields();
public: __property void set_ParseExtraFields(
   bool value
);
C++/CLI
public:
property bool ParseExtraFields {
   bool get();
   void set (    bool value);
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

Provides the compression stream writing GZip streams and files.

Object Model

GZipOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
C#
public class GZipOutputStream : System.IO.Stream
Delphi
public class GZipOutputStream = class(System.IO.Stream)
JScript
public class GZipOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipOutputStream : public System.IO.Stream
C++/CLI
public ref class GZipOutputStream : public System.IO.Stream

Remarks

By default, GZipOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipOutputStream

See Also

Reference

GZipOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
GZipOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

The following tables list the members exposed by GZipOutputStream.

Public Constructors

 | Name | Description
public Constructor | GZipOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GZipOutputStream Constructor

Overload List

Overload | Description
GZipOutputStream Constructor(String,Int32) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32) | Initializes a new instance of the GZipOutputStream class.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(String,Int32)

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(fileName, compressionLevel)
C#
public GZipOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipOutputStream(stream, compressionLevel, leaveOpen)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(stream, compressionLevel)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
GZipOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Close Method

Flushes the internal buffer content and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

Before closing, the GZipOutputStream will also flush its buffer and write the GZip trailer fields into the underlying stream. Do not close the underlying stream before closing this stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Close
GZipOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List
Base Implementation in Dispose(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush or Close method is called.

Upon the first write operation GZipOutputStream will write the GZip header into the underlying stream, therefore all required headers have to be specified before the first write operation.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
GZipOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports writing and is not closed; otherwise, false.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Comments Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Comments Property

Gets and sets the file comments to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Comments As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Comments = value

value = instance.Comments
C#
public string Comments {get; set;}
Delphi
public read-write property Comments: String;
JScript
public function get,set Comments : String
Managed Extensions for C++
public: __property string* get_Comments();
public: __property void set_Comments(
   string* value
);
C++/CLI
public:
property String^ Comments {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the comments for the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property has to be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ExtraFields Property

The collection of extra-fields to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

You can provide the set of extra-fields to be written into the GZip header by modifying this collection.

The GZip header will be written during the first write operation, therefore the extra-header fields should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Filename Property

Gets and sets the filename to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GzipOutputStream will try to readthe Length property of the underlying stream. Check the Length property documentation the underlying stream for more information .

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

Provides methods and properties for processing streams using the GZIP.

Object Model

GZipStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
C#
public class GZipStream : System.IO.Stream
Delphi
public class GZipStream = class(System.IO.Stream)
JScript
public class GZipStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipStream : public System.IO.Stream
C++/CLI
public ref class GZipStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipStream

See Also

Reference

GZipStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
GZipStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipStream Class

The following tables list the members exposed by GZipStream.

Public Constructors

 | Name | Description
public Constructor | GZipStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Closes the stream and releases the allocated resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GZipStream Constructor

Overload List

Overload | Description
GZipStream Constructor(String,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the GZipStream class.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(String,CompressionMode)

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New GZipStream(fileName, mode)
C#
public GZipStream(
   string fileName,
   CompressionMode mode
)
Delphi
public GZipStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function GZipStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New GZipStream(stream, mode)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, compressionLevel, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GZipStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New GZipStream(stream, mode, compressionLevel)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
GZipStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Overridden. Closes the stream and releases the allocated resources.
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Close
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Dispose Method

Closes the stream and releases the allocated resources.

Overload List

Overload | Description
Dispose(Boolean) | Closes the stream and releases the allocated resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Dispose


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Closes the stream and releases the allocated resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipStream Class
GZipStream Members
Overload List
Base Implementation in Dispose(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
GZipStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Filename Property

Gets and sets the filename to write into or read from the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InvalidInputException Class
Members See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The exception that is thrown when a compressed input stream is in an invalid format.

Object Model

InvalidInputException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidInputException
   Inherits System.IO.IOException
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
C#
public class InvalidInputException : System.IO.IOException
Delphi
public class InvalidInputException = class(System.IO.IOException)
JScript
public class InvalidInputException extends System.IO.IOException
Managed Extensions for C++
public __gc class InvalidInputException : public System.IO.IOException
C++/CLI
public ref class InvalidInputException : public System.IO.IOException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.IO.IOException
Noemax.GZip.InvalidInputException

See Also

Reference

InvalidInputException Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
InvalidInputException Class Members
See Also Properties Methods Events Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The following tables list the members exposed by InvalidInputException.

Public Constructors

 | Name | Description
public Constructor | InvalidInputException Constructor | Overloaded. Initializes a new instance of the InvalidInputException class.
Top

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InvalidInputException Constructor
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InvalidInputException Constructor

Initializes a new instance of the InvalidInputException class.

Overload List

Overload | Description
InvalidInputException Constructor() | Initializes a new instance of the InvalidInputException class.
InvalidInputException Constructor(String) | Initializes a new instance of the InvalidInputException class with a specified error message.
InvalidInputException Constructor(String,Exception) | Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InvalidInputException Constructor()
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor()

Initializes a new instance of the InvalidInputException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New InvalidInputException()
C#
public InvalidInputException()
Delphi
public InvalidInputException();
JScript
public function InvalidInputException();
Managed Extensions for C++
public: InvalidInputException();
C++/CLI
public:
InvalidInputException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InvalidInputException Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String)

message
Initializes a new instance of the InvalidInputException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As New InvalidInputException(message)
C#
public InvalidInputException(
   string message
)
Delphi
public InvalidInputException(
    message: String
);
JScript
public function InvalidInputException(
   message : String
);
Managed Extensions for C++
public: InvalidInputException(
   string* message
)
C++/CLI
public:
InvalidInputException(
   String^ message
)

Parameters

message

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InvalidInputException Constructor(String,Exception)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String,Exception)

message
innerException
Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As New InvalidInputException(message, innerException)
C#
public InvalidInputException(
   string message,
   Exception innerException
)
Delphi
public InvalidInputException(
    message: String;
    innerException: Exception
);
JScript
public function InvalidInputException(
   message : String,
   innerException : Exception
);
Managed Extensions for C++
public: InvalidInputException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidInputException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Enumeration
See Also Send Feedback
Noemax.GZip Namespace : CompressionMode Enumeration

Defines the compression modes for GZipStream.

Syntax

Visual Basic (Declaration)
Public Enum CompressionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CompressionMode
C#
public enum CompressionMode : System.Enum
Delphi
public enum CompressionMode = class(System.Enum)
JScript
public enum CompressionMode extends System.Enum
Managed Extensions for C++
__value public enum CompressionMode : public System.Enum
C++/CLI
public enum class CompressionMode : public System.Enum

Members

Member | Description
Compress | To compress data.
Decompress | To decompress data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.GZip.CompressionMode

See Also

Reference

Noemax.GZip Namespace


%%ItemTitle%%

Noemax.Lzf Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Lzf3InputStream | Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.
Class | Lzf3OutputStream | Provides methods and properties to compress streams using LZF compression algorithm.
Class | LzfInputStream | Provides methods and properties to decompress streams compressed by LZF compression algorithm.
Class | LzfOutputStream | Provides methods and properties to compress streams using LZF compression algorithm.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3InputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.

Object Model

Lzf3InputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3InputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
C#
public sealed class Lzf3InputStream : System.IO.Stream
Delphi
public class Lzf3InputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3InputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3InputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3InputStream sealed : public System.IO.Stream

Remarks

By default, Lzf3InputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3InputStream

See Also

Reference

Lzf3InputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
Lzf3InputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

The following tables list the members exposed by Lzf3InputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3InputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3InputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Lzf3InputStream Constructor

Overload List

Overload | Description
Lzf3InputStream Constructor(String) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3InputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3InputStream(fileName)
C#
public Lzf3InputStream(
   string fileName
)
Delphi
public Lzf3InputStream(
    fileName: String
);
JScript
public function Lzf3InputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3InputStream(
   string* fileName
)
C++/CLI
public:
Lzf3InputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3InputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3InputStream(stream)
C#
public Lzf3InputStream(
   Stream stream
)
Delphi
public Lzf3InputStream(
    stream: Stream
);
JScript
public function Lzf3InputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3InputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3InputStream(stream, leaveOpen)
C#
public Lzf3InputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3InputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3InputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
Lzf3InputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
Lzf3InputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

Provides methods and properties to compress streams using LZF compression algorithm.

Object Model

Lzf3OutputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3OutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
C#
public sealed class Lzf3OutputStream : System.IO.Stream
Delphi
public class Lzf3OutputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3OutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3OutputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3OutputStream sealed : public System.IO.Stream

Remarks

By default, [classname] owns the underlying stream, so closing this stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3OutputStream

See Also

Reference

Lzf3OutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

The following tables list the members exposed by Lzf3OutputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3OutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Lzf3OutputStream Constructor

Overload List

Overload | Description
Lzf3OutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(String)

fileName
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3OutputStream(fileName)
C#
public Lzf3OutputStream(
   string fileName
)
Delphi
public Lzf3OutputStream(
    fileName: String
);
JScript
public function Lzf3OutputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3OutputStream(
   string* fileName
)
C++/CLI
public:
Lzf3OutputStream(
   String^ fileName
)

Parameters

fileName
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3OutputStream(stream)
C#
public Lzf3OutputStream(
   Stream stream
)
Delphi
public Lzf3OutputStream(
    stream: Stream
);
JScript
public function Lzf3OutputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3OutputStream(stream, leaveOpen)
C#
public Lzf3OutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3OutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3OutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
Lzf3OutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfInputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

Provides methods and properties to decompress streams compressed by LZF compression algorithm.

Object Model

LzfInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
C#
public class LzfInputStream : System.IO.Stream
Delphi
public class LzfInputStream = class(System.IO.Stream)
JScript
public class LzfInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfInputStream : public System.IO.Stream
C++/CLI
public ref class LzfInputStream : public System.IO.Stream

Remarks

By default, LzfInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfInputStream

See Also

Reference

LzfInputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LzfInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

The following tables list the members exposed by LzfInputStream.

Public Constructors

 | Name | Description
public Constructor | LzfInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfInputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : LzfInputStream Constructor

Overload List

Overload | Description
LzfInputStream Constructor(String) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(String)

fileName
The path to the file from which to read copressed data from.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzfInputStream(fileName)
C#
public LzfInputStream(
   string fileName
)
Delphi
public LzfInputStream(
    fileName: String
);
JScript
public function LzfInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzfInputStream(
   string* fileName
)
C++/CLI
public:
LzfInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which to read copressed data from.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfInputStream(stream)
C#
public LzfInputStream(
   Stream stream
)
Delphi
public LzfInputStream(
    stream: Stream
);
JScript
public function LzfInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfInputStream(stream, leaveOpen)
C#
public LzfInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LzfInputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LzfInputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteTimeout Property

Get the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfOutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

Provides methods and properties to compress streams using LZF compression algorithm.

Object Model

LzfOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
C#
public class LzfOutputStream : System.IO.Stream
Delphi
public class LzfOutputStream = class(System.IO.Stream)
JScript
public class LzfOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfOutputStream : public System.IO.Stream
C++/CLI
public ref class LzfOutputStream : public System.IO.Stream

Remarks

By default, LzfOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfOutputStream

See Also

Reference

LzfOutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LzfOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

The following tables list the members exposed by LzfOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzfOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfOutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : LzfOutputStream Constructor

Overload List

Overload | Description
LzfOutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfOutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(String)

filename
The path to the file to which the compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As New LzfOutputStream(filename)
C#
public LzfOutputStream(
   string filename
)
Delphi
public LzfOutputStream(
    filename: String
);
JScript
public function LzfOutputStream(
   filename : String
);
Managed Extensions for C++
public: LzfOutputStream(
   string* filename
)
C++/CLI
public:
LzfOutputStream(
   String^ filename
)

Parameters

filename
The path to the file to which the compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfOutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfOutputStream(stream)
C#
public LzfOutputStream(
   Stream stream
)
Delphi
public LzfOutputStream(
    stream: Stream
);
JScript
public function LzfOutputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzfOutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfOutputStream(stream, leaveOpen)
C#
public LzfOutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfOutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfOutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LzfOutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LzfOutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteTimeout Property

Gets the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Base Implementation in WriteTimeout


%%ItemTitle%%

Noemax.Lzma Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | LzmaInputStream | Provides methods and properties to decompress streams compressed by LZMA compression algorithm.
Class | LzmaOutputStream | Provides methods and properties to compress streams using LZMA compression algorithm.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaInputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

Provides methods and properties to decompress streams compressed by LZMA compression algorithm.

Object Model

LzmaInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
C#
public class LzmaInputStream : System.IO.Stream
Delphi
public class LzmaInputStream = class(System.IO.Stream)
JScript
public class LzmaInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaInputStream : public System.IO.Stream
C++/CLI
public ref class LzmaInputStream : public System.IO.Stream

Remarks

By default, LzmaInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaInputStream

See Also

Reference

LzmaInputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LzmaInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

The following tables list the members exposed by LzmaInputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaInputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : LzmaInputStream Constructor

Overload List

Overload | Description
LzmaInputStream Constructor(Stream) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(String) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzmaInputStream.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzmaInputStream(stream)
C#
public LzmaInputStream(
   Stream stream
)
Delphi
public LzmaInputStream(
    stream: Stream
);
JScript
public function LzmaInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzmaInputStream(fileName)
C#
public LzmaInputStream(
   string fileName
)
Delphi
public LzmaInputStream(
    fileName: String
);
JScript
public function LzmaInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzmaInputStream(
   string* fileName
)
C++/CLI
public:
LzmaInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzmaInputStream(stream, leaveOpen)
C#
public LzmaInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzmaInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzmaInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LzmaInputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Close Method

Close this stream and the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Seek Method

offset
Not supported.
origin
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
Not supported.
origin
Not supported.

Return Value

Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : SetLength Method

value
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Write Method

buffer
Not supported.
offset
Not supported.
count
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
Not supported.
offset
Not supported.
count
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LzmaInputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanRead Property

Returns true. This stream can read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanWrite Property

Returns false. This stream cannot write.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Base Implementation in WriteTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaOutputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

Provides methods and properties to compress streams using LZMA compression algorithm.

Object Model

LzmaOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
C#
public class LzmaOutputStream : System.IO.Stream
Delphi
public class LzmaOutputStream = class(System.IO.Stream)
JScript
public class LzmaOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaOutputStream : public System.IO.Stream
C++/CLI
public ref class LzmaOutputStream : public System.IO.Stream

Remarks

By default, LzmaOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

LzmaOutputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LzmaOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

The following tables list the members exposed by LzmaOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaOutputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : LzmaOutputStream Constructor

Overload List

Overload | Description
LzmaOutputStream Constructor(String,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of LzmaOutputStream.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(String,Int32)

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(filename, compressionLevel)
C#
public LzmaOutputStream(
   string filename,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    filename: String;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   filename : String,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   string* filename,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   String^ filename,
   int compressionLevel
)

Parameters

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(stream, compressionLevel)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LzmaOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New LzmaOutputStream(stream, compressionLevel, leaveOpen)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LzmaOutputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Close Method

Flushes compressed bytes and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Flush Method

Flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Seek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in SetLength


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Write


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LzmaOutputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanRead Property

Returns false. This stream cannot be read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in CanRead


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in CanSeek


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in CanTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanWrite Property

Returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in CanWrite


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Length


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in Position


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in ReadTimeout


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Base Implementation in WriteTimeout


%%ItemTitle%%

Noemax.WCFX Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | FastInfosetSettings | The class representing the settings of Fast Infoset message encoding.
Class | XBindingConfigurator | XBindingConfigurator simplifies configuration of the binding by transparently extending it with WCF-Xtensions components.
Class | XChannelFactory<TChannel> | A ChannelFactory derived class that transparently complements the Windows Communication Foundation with WCF-Xtensions functionality.
Class | XServiceHost | A ServiceHost derived class that transparently complements the Windows Communication Foundation with additional functionality.

Interfaces

 | Interface | Description
Interface | IPluggableBindingElement | An interface that binding element implement in order to be pluggable into bindings through code and configuration files.

Enumerations

 | Enumeration | Description
Enumeration | WcfxMessageEncoding | Defines the message encoding to be used by the binding.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSettings Class
Members See Also Send Feedback
Noemax.WCFX Namespace : FastInfosetSettings Class

The class representing the settings of Fast Infoset message encoding.

Object Model

FastInfosetSettings Class

Syntax

Visual Basic (Declaration)
Public Class FastInfosetSettings
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
C#
public class FastInfosetSettings
Delphi
public class FastInfosetSettings
JScript
public class FastInfosetSettings
Managed Extensions for C++
public __gc class FastInfosetSettings
C++/CLI
public ref class FastInfosetSettings

Inheritance Hierarchy

System.Object
Noemax.WCFX.FastInfosetSettings

See Also

Reference

FastInfosetSettings Members
Noemax.WCFX Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
FastInfosetSettings Class Members
See Also Properties Send Feedback
Noemax.WCFX Namespace : FastInfosetSettings Class

The following tables list the members exposed by FastInfosetSettings.

Public Constructors

 | Name | Description
public Constructor | FastInfosetSettings Constructor | Initializes a new instance of FastInfosetSettings.
Top

Public Properties

 | Name | Description
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.
public Property | MaxVocabularyStringLength | Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | SessionMode | Gets and sets the stateful session encoding modes to be used by Fast Infoset message encoding.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

See Also

Reference

FastInfosetSettings Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSettings Constructor
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : FastInfosetSettings Constructor

Initializes a new instance of FastInfosetSettings.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FastInfosetSettings()
C#
public FastInfosetSettings()
Delphi
public FastInfosetSettings();
JScript
public function FastInfosetSettings();
Managed Extensions for C++
public: FastInfosetSettings();
C++/CLI
public:
FastInfosetSettings();

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
FastInfosetSettings Class Properties
See Also Send Feedback
Noemax.WCFX Namespace : FastInfosetSettings Class

For a list of all members of this type, see FastInfosetSettings members.

Public Properties

 | Name | Description
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.
public Property | MaxVocabularyStringLength | Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | SessionMode | Gets and sets the stateful session encoding modes to be used by Fast Infoset message encoding.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

See Also

Reference

FastInfosetSettings Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : MaxVocabularyStringLength Property

Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

If the length of the character string that is written into the writer is smaller than the specified length, the writer will try to find a match for this string within the strings that have been already placed in the vocabulary and replace it with the reference to the already written string. If no match is found, the writer adds this character string to the vocabulary and all future occurrences of the same string will be replaced by references to it.

The writer does not try to find a match for strings that are longer than the specified length and so does not add them to the vocabulary. Setting this property to a higher value might improve compactness, but it might decrease the writing speed and\or consume more memory.

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PermitStateful Property
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : PermitStateful Property

Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.

Syntax

Visual Basic (Declaration)
Public Property PermitStateful As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
Dim value As Boolean

instance.PermitStateful = value

value = instance.PermitStateful
C#
public bool PermitStateful {get; set;}
Delphi
public read-write property PermitStateful: Boolean;
JScript
public function get,set PermitStateful : boolean
Managed Extensions for C++
public: __property bool get_PermitStateful();
public: __property void set_PermitStateful(
   bool value
);
C++/CLI
public:
property bool PermitStateful {
   bool get();
   void set (    bool value);
}

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SessionMode Property
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : SessionMode Property

Gets and sets the stateful session encoding modes to be used by Fast Infoset message encoding.

Syntax

Visual Basic (Declaration)
Public Property SessionMode As FastInfosetSessionMode
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
Dim value As FastInfosetSessionMode

instance.SessionMode = value

value = instance.SessionMode
C#
public FastInfosetSessionMode SessionMode {get; set;}
Delphi
public read-write property SessionMode: FastInfosetSessionMode;
JScript
public function get,set SessionMode : FastInfosetSessionMode
Managed Extensions for C++
public: __property FastInfosetSessionMode get_SessionMode();
public: __property void set_SessionMode(
   FastInfosetSessionMode value
);
C++/CLI
public:
property FastInfosetSessionMode SessionMode {
   FastInfosetSessionMode get();
   void set (    FastInfosetSessionMode value);
}

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfile Property
See Also Send Feedback
Noemax.WCFX Namespace > FastInfosetSettings Class : WriterProfile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property WriterProfile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSettings
Dim value As XmlFastInfosetWriterProfile

instance.WriterProfile = value

value = instance.WriterProfile
C#
public XmlFastInfosetWriterProfile WriterProfile {get; set;}
Delphi
public read-write property WriterProfile: XmlFastInfosetWriterProfile;
JScript
public function get,set WriterProfile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_WriterProfile();
public: __property void set_WriterProfile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ WriterProfile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

FastInfosetSettings Class
FastInfosetSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XBindingConfigurator Class
Members See Also Send Feedback
Noemax.WCFX Namespace : XBindingConfigurator Class

XBindingConfigurator simplifies configuration of the binding by transparently extending it with WCF-Xtensions components.

Object Model

XBindingConfigurator Class

Syntax

Visual Basic (Declaration)
Public Class XBindingConfigurator
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
C#
public class XBindingConfigurator
Delphi
public class XBindingConfigurator
JScript
public class XBindingConfigurator
Managed Extensions for C++
public __gc class XBindingConfigurator
C++/CLI
public ref class XBindingConfigurator

Inheritance Hierarchy

System.Object
Noemax.WCFX.XBindingConfigurator

See Also

Reference

XBindingConfigurator Members
Noemax.WCFX Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XBindingConfigurator Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX Namespace : XBindingConfigurator Class

The following tables list the members exposed by XBindingConfigurator.

Public Constructors

 | Name | Description
public Constructor | XBindingConfigurator Constructor | Initializes a new instance of XBindingConfigurator.
Top

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to apply when compression is enabled.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | FastInfosetSettings | Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.
public Property | MessageEncoding | Specifies the message encoding to be injected into the binding during configuration.
Top

Public Methods

 | Name | Description
public Method | Configure | Extends the binding with WCF-Xtensions components according to the settings specified by properties of the XBindingConfigurator instance.
Top

See Also

Reference

XBindingConfigurator Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XBindingConfigurator Constructor
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : XBindingConfigurator Constructor

Initializes a new instance of XBindingConfigurator.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XBindingConfigurator()
C#
public XBindingConfigurator()
Delphi
public XBindingConfigurator();
JScript
public function XBindingConfigurator();
Managed Extensions for C++
public: XBindingConfigurator();
C++/CLI
public:
XBindingConfigurator();

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XBindingConfigurator Class Methods
See Also Send Feedback
Noemax.WCFX Namespace : XBindingConfigurator Class

For a list of all members of this type, see XBindingConfigurator members.

Public Methods

 | Name | Description
public Method | Configure | Extends the binding with WCF-Xtensions components according to the settings specified by properties of the XBindingConfigurator instance.
Top

See Also

Reference

XBindingConfigurator Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Configure Method
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : Configure Method

binding
Extends the binding with WCF-Xtensions components according to the settings specified by properties of the XBindingConfigurator instance.

Syntax

Visual Basic (Declaration)
Public Function Configure( _
   ByVal binding As Binding _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim binding As Binding
Dim value As Binding

value = instance.Configure(binding)
C#
public Binding Configure(
   Binding binding
)
Delphi
public function Configure(
    binding: Binding
): Binding;
JScript
public function Configure(
   binding : Binding
) : Binding;
Managed Extensions for C++
public: Binding* Configure(
   Binding* binding
)
C++/CLI
public:
Binding^ Configure(
   Binding^ binding
)

Parameters

binding

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XBindingConfigurator Class Properties
See Also Send Feedback
Noemax.WCFX Namespace : XBindingConfigurator Class

For a list of all members of this type, see XBindingConfigurator members.

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to apply when compression is enabled.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | FastInfosetSettings | Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.
public Property | MessageEncoding | Specifies the message encoding to be injected into the binding during configuration.
Top

See Also

Reference

XBindingConfigurator Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : CompressionLevel Property

Gets and sets the compression level to apply when compression is enabled.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : CompressionMode Property

Gets and sets the compression mode used by the binding.

Syntax

Visual Basic (Declaration)
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

Remarks

When content negotiation is supported by the binding, the use of compression is negotiated between the communication sides. When content negotiation is not supported by the binding, compression is always applied to all message sent through the channel.

Compression is not applied when set to None.

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSettings Property
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : FastInfosetSettings Property

Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.

Syntax

Visual Basic (Declaration)
Public Property FastInfosetSettings As FastInfosetSettings
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim value As FastInfosetSettings

instance.FastInfosetSettings = value

value = instance.FastInfosetSettings
C#
public FastInfosetSettings FastInfosetSettings {get; set;}
Delphi
public read-write property FastInfosetSettings: FastInfosetSettings;
JScript
public function get,set FastInfosetSettings : FastInfosetSettings
Managed Extensions for C++
public: __property FastInfosetSettings* get_FastInfosetSettings();
public: __property void set_FastInfosetSettings(
   FastInfosetSettings* value
);
C++/CLI
public:
property FastInfosetSettings^ FastInfosetSettings {
   FastInfosetSettings^ get();
   void set (    FastInfosetSettings^ value);
}

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncoding Property
See Also Send Feedback
Noemax.WCFX Namespace > XBindingConfigurator Class : MessageEncoding Property

Specifies the message encoding to be injected into the binding during configuration.

Syntax

Visual Basic (Declaration)
Public Property MessageEncoding As WcfxMessageEncoding
Visual Basic (Usage) Copy Code
Dim instance As XBindingConfigurator
Dim value As WcfxMessageEncoding

instance.MessageEncoding = value

value = instance.MessageEncoding
C#
public WcfxMessageEncoding MessageEncoding {get; set;}
Delphi
public read-write property MessageEncoding: WcfxMessageEncoding;
JScript
public function get,set MessageEncoding : WcfxMessageEncoding
Managed Extensions for C++
public: __property WcfxMessageEncoding get_MessageEncoding();
public: __property void set_MessageEncoding(
   WcfxMessageEncoding value
);
C++/CLI
public:
property WcfxMessageEncoding MessageEncoding {
   WcfxMessageEncoding get();
   void set (    WcfxMessageEncoding value);
}

Remarks

Default value for this property is BindingDefault, which means that the message encoding of the target binding will not be changed.

See Also

Reference

XBindingConfigurator Class
XBindingConfigurator Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Class
Members See Also Send Feedback
Noemax.WCFX Namespace : XChannelFactory<TChannel> Class

A ChannelFactory derived class that transparently complements the Windows Communication Foundation with WCF-Xtensions functionality.

Object Model

XChannelFactory<TChannel> Class

Syntax

Visual Basic (Declaration)
Public Class XChannelFactory(Of TChannel)
   Inherits System.ServiceModel.ChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
C#
public class XChannelFactory<TChannel> : System.ServiceModel.ChannelFactory<TChannel>
Delphi
public class XChannelFactory = class(System.ServiceModel.ChannelFactory)
JScript
JScript does not support Generics.
Managed Extensions for C++
public __gc class XChannelFactory<TChannel> : public System.ServiceModel.ChannelFactory<TChannel>
C++/CLI
generic<typename TChannel>
public ref class XChannelFactory : public System.ServiceModel.ChannelFactory<TChannel>

Type Parameters

TChannel

Remarks

Upon opening XChannelFactory automaticaly modify the configuration of the binding used by a factory to use Noemax.WCFX.Channels.FiMessageEncodingBindingElement. It also optionally provides compression or injects the Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior to the endpoint used by the factory. The XChannelFactory should be configured prior to its use for creating a channel. Any settings configured after the factory is already open will not be applied to channels created by the factory.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.CommunicationObject
System.ServiceModel.ChannelFactory
System.ServiceModel.ChannelFactory<TChannel>
Noemax.WCFX.XChannelFactory<TChannel>

See Also

Reference

XChannelFactory<TChannel> Members
Noemax.WCFX Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Class Members
See Also Properties Methods Events Send Feedback
Noemax.WCFX Namespace : XChannelFactory<TChannel> Class

The following tables list the members exposed by XChannelFactory<TChannel>.

Public Constructors

 | Name | Description
public Constructor | XChannelFactory<TChannel> Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | Credentials | (Inherited from System.ServiceModel.ChannelFactory)
public Property | EnableEnvelopeBehavior | Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior. Default value false.
public Property | Endpoint | (Inherited from System.ServiceModel.ChannelFactory)
public Property | FastInfosetSettings | Gets and sets the Fast Infoset message encoding writer profile.
public Property | State | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Properties

 | Name | Description
protected Property | DefaultCloseTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | DefaultOpenTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | IsDisposed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | ThisLock | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Public Methods

 | Name | Description
public Method | Abort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginClose | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginOpen | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | Close | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | CreateChannel | Overloaded. (Inherited from System.ServiceModel.ChannelFactory<TChannel>)
public Method | EndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.ChannelFactory)
public Method | Open | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Methods

 | Name | Description
protected Method | ApplyConfiguration | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | CreateDescription | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | CreateFactory | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | EnsureOpened | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | Fault | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | GetCommunicationObjectType | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | InitializeEndpoint | Overloaded. (Inherited from System.ServiceModel.ChannelFactory)
protected Method | OnAbort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnFaulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpening | Overridden.
Top

Public Events

 | Name | Description
public Event | Closed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Closing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Faulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opening | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

See Also

Reference

XChannelFactory<TChannel> Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : XChannelFactory<TChannel> Constructor

Overload List

Overload | Description
XChannelFactory<TChannel> Constructor() | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(Binding) | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(ServiceEndpoint) | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(Binding,String) | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(String) | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(Binding,EndpointAddress) | Initializes a new instance of Noemax.WCFX.XChannelFactory.
XChannelFactory<TChannel> Constructor(String,EndpointAddress) | Initializes a new instance of Noemax.WCFX.XChannelFactory.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor()
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor()

Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XChannelFactory(Of TChannel)()
C#
public XChannelFactory<TChannel>()
Delphi
public XChannelFactory<TChannel>();
JScript
public function XChannelFactory<TChannel>();
Managed Extensions for C++
public: XChannelFactory<TChannel>();
C++/CLI
public:
XChannelFactory<TChannel>();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(Binding)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(Binding)

binding
The binding to be used by the factory.
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding

Dim instance As New XChannelFactory(Of TChannel)(binding)
C#
public XChannelFactory<TChannel>(
   Binding binding
)
Delphi
public XChannelFactory<TChannel>(
    binding: Binding
);
JScript
public function XChannelFactory<TChannel>(
   binding : Binding
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   Binding* binding
)
C++/CLI
public:
XChannelFactory<TChannel>(
   Binding^ binding
)

Parameters

binding
The binding to be used by the factory.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(ServiceEndpoint)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(ServiceEndpoint)

endpoint
The ServiceEndpoint object to configure the factory
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal endpoint As ServiceEndpoint _
)
Visual Basic (Usage) Copy Code
Dim endpoint As ServiceEndpoint

Dim instance As New XChannelFactory(Of TChannel)(endpoint)
C#
public XChannelFactory<TChannel>(
   ServiceEndpoint endpoint
)
Delphi
public XChannelFactory<TChannel>(
    endpoint: ServiceEndpoint
);
JScript
public function XChannelFactory<TChannel>(
   endpoint : ServiceEndpoint
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   ServiceEndpoint* endpoint
)
C++/CLI
public:
XChannelFactory<TChannel>(
   ServiceEndpoint^ endpoint
)

Parameters

endpoint
The ServiceEndpoint object to configure the factory

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(Binding,String)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(Binding,String)

binding
The binding to be used by the factory.
address
The address of remote endpoint.
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal address As String _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim address As String

Dim instance As New XChannelFactory(Of TChannel)(binding, address)
C#
public XChannelFactory<TChannel>(
   Binding binding,
   string address
)
Delphi
public XChannelFactory<TChannel>(
    binding: Binding;
    address: String
);
JScript
public function XChannelFactory<TChannel>(
   binding : Binding,
   address : String
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   Binding* binding,
   string* address
)
C++/CLI
public:
XChannelFactory<TChannel>(
   Binding^ binding,
   String^ address
)

Parameters

binding
The binding to be used by the factory.
address
The address of remote endpoint.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(String)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(String)

endpointConfigurationName
The name of the endpoint section in configuration to configure the factory.
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal endpointConfigurationName As String _
)
Visual Basic (Usage) Copy Code
Dim endpointConfigurationName As String

Dim instance As New XChannelFactory(Of TChannel)(endpointConfigurationName)
C#
public XChannelFactory<TChannel>(
   string endpointConfigurationName
)
Delphi
public XChannelFactory<TChannel>(
    endpointConfigurationName: String
);
JScript
public function XChannelFactory<TChannel>(
   endpointConfigurationName : String
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   string* endpointConfigurationName
)
C++/CLI
public:
XChannelFactory<TChannel>(
   String^ endpointConfigurationName
)

Parameters

endpointConfigurationName
The name of the endpoint section in configuration to configure the factory.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(Binding,EndpointAddress)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(Binding,EndpointAddress)

binding
The binding to be used by the factory.
address
The address of remote endpoint.
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal address As EndpointAddress _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim address As EndpointAddress

Dim instance As New XChannelFactory(Of TChannel)(binding, address)
C#
public XChannelFactory<TChannel>(
   Binding binding,
   EndpointAddress address
)
Delphi
public XChannelFactory<TChannel>(
    binding: Binding;
    address: EndpointAddress
);
JScript
public function XChannelFactory<TChannel>(
   binding : Binding,
   address : EndpointAddress
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   Binding* binding,
   EndpointAddress* address
)
C++/CLI
public:
XChannelFactory<TChannel>(
   Binding^ binding,
   EndpointAddress^ address
)

Parameters

binding
The binding to be used by the factory.
address
The address of remote endpoint.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Constructor(String,EndpointAddress)
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > XChannelFactory<TChannel> Constructor : XChannelFactory<TChannel> Constructor(String,EndpointAddress)

endpointConfigurationName
The name of the endpoint section in configuration to configure the factory.
address
The address of remote endpoint.
Initializes a new instance of Noemax.WCFX.XChannelFactory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal endpointConfigurationName As String, _
   ByVal address As EndpointAddress _
)
Visual Basic (Usage) Copy Code
Dim endpointConfigurationName As String
Dim address As EndpointAddress

Dim instance As New XChannelFactory(Of TChannel)(endpointConfigurationName, address)
C#
public XChannelFactory<TChannel>(
   string endpointConfigurationName,
   EndpointAddress address
)
Delphi
public XChannelFactory<TChannel>(
    endpointConfigurationName: String;
    address: EndpointAddress
);
JScript
public function XChannelFactory<TChannel>(
   endpointConfigurationName : String,
   address : EndpointAddress
);
Managed Extensions for C++
public: XChannelFactory<TChannel>(
   string* endpointConfigurationName,
   EndpointAddress* address
)
C++/CLI
public:
XChannelFactory<TChannel>(
   String^ endpointConfigurationName,
   EndpointAddress^ address
)

Parameters

endpointConfigurationName
The name of the endpoint section in configuration to configure the factory.
address
The address of remote endpoint.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Class Methods
See Also Send Feedback
Noemax.WCFX Namespace : XChannelFactory<TChannel> Class

For a list of all members of this type, see XChannelFactory<TChannel> members.

Public Methods

 | Name | Description
public Method | Abort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginClose | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginOpen | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | Close | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | CreateChannel | Overloaded. (Inherited from System.ServiceModel.ChannelFactory<TChannel>)
public Method | EndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.ChannelFactory)
public Method | Open | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Methods

 | Name | Description
protected Method | ApplyConfiguration | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | CreateDescription | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | CreateFactory | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | EnsureOpened | (Inherited from System.ServiceModel.ChannelFactory)
protected Method | Fault | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | GetCommunicationObjectType | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | InitializeEndpoint | Overloaded. (Inherited from System.ServiceModel.ChannelFactory)
protected Method | OnAbort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnFaulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpening | Overridden.
Top

See Also

Reference

XChannelFactory<TChannel> Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpening Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnOpening Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnOpening()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnOpening()
C#
protected override void OnOpening()
Delphi
protected procedure OnOpening(); override;
JScript
protected override function OnOpening();
Managed Extensions for C++
protected: void OnOpening(); override
C++/CLI
protected:
void OnOpening(); override

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Base Implementation in OnOpening


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Class Properties
See Also Send Feedback
Noemax.WCFX Namespace : XChannelFactory<TChannel> Class

For a list of all members of this type, see XChannelFactory<TChannel> members.

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | Credentials | (Inherited from System.ServiceModel.ChannelFactory)
public Property | EnableEnvelopeBehavior | Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior. Default value false.
public Property | Endpoint | (Inherited from System.ServiceModel.ChannelFactory)
public Property | FastInfosetSettings | Gets and sets the Fast Infoset message encoding writer profile.
public Property | State | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Properties

 | Name | Description
protected Property | DefaultCloseTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | DefaultOpenTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | IsDisposed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | ThisLock | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

See Also

Reference

XChannelFactory<TChannel> Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : CompressionMode Property

Gets and sets the compression mode used by the binding.

Syntax

Visual Basic (Declaration)
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

Remarks

When content negotiation is supported by the binding, the use of compression is negotiated between the communication sides. When content negotiation is not supported by the binding, compression is always applied to all message sent through the channel.

Compression is never applied when set to None.

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableEnvelopeBehavior Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : EnableEnvelopeBehavior Property

Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior. Default value false.

Syntax

Visual Basic (Declaration)
Public Property EnableEnvelopeBehavior As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As Boolean

instance.EnableEnvelopeBehavior = value

value = instance.EnableEnvelopeBehavior
C#
public bool EnableEnvelopeBehavior {get; set;}
Delphi
public read-write property EnableEnvelopeBehavior: Boolean;
JScript
public function get,set EnableEnvelopeBehavior : boolean
Managed Extensions for C++
public: __property bool get_EnableEnvelopeBehavior();
public: __property void set_EnableEnvelopeBehavior(
   bool value
);
C++/CLI
public:
property bool EnableEnvelopeBehavior {
   bool get();
   void set (    bool value);
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSettings Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : FastInfosetSettings Property

Gets and sets the Fast Infoset message encoding writer profile.

Syntax

Visual Basic (Declaration)
Public Property FastInfosetSettings As FastInfosetSettings
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As FastInfosetSettings

instance.FastInfosetSettings = value

value = instance.FastInfosetSettings
C#
public FastInfosetSettings FastInfosetSettings {get; set;}
Delphi
public read-write property FastInfosetSettings: FastInfosetSettings;
JScript
public function get,set FastInfosetSettings : FastInfosetSettings
Managed Extensions for C++
public: __property FastInfosetSettings* get_FastInfosetSettings();
public: __property void set_FastInfosetSettings(
   FastInfosetSettings* value
);
C++/CLI
public:
property FastInfosetSettings^ FastInfosetSettings {
   FastInfosetSettings^ get();
   void set (    FastInfosetSettings^ value);
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XServiceHost Class
Members See Also Send Feedback
Noemax.WCFX Namespace : XServiceHost Class

A ServiceHost derived class that transparently complements the Windows Communication Foundation with additional functionality.

Object Model

XServiceHost Class

Syntax

Visual Basic (Declaration)
Public Class XServiceHost
   Inherits System.ServiceModel.ServiceHost
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
C#
public class XServiceHost : System.ServiceModel.ServiceHost
Delphi
public class XServiceHost = class(System.ServiceModel.ServiceHost)
JScript
public class XServiceHost extends System.ServiceModel.ServiceHost
Managed Extensions for C++
public __gc class XServiceHost : public System.ServiceModel.ServiceHost
C++/CLI
public ref class XServiceHost : public System.ServiceModel.ServiceHost

Remarks

Upon opening XServiceHost modifies the configuration of the bindings used by the service endpoints to use Noemax.WCFX.Channels.FiMessageEncodingBindingElement. It also optionally provides compression or injects the Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior to each endpoint exposed by the service.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.CommunicationObject
System.ServiceModel.ServiceHostBase
System.ServiceModel.ServiceHost
Noemax.WCFX.XServiceHost

See Also

Reference

XServiceHost Members
Noemax.WCFX Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XServiceHost Class Members
See Also Properties Methods Events Send Feedback
Noemax.WCFX Namespace : XServiceHost Class

The following tables list the members exposed by XServiceHost.

Public Constructors

 | Name | Description
public Constructor | XServiceHost Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Authentication | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | Authorization | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | BaseAddresses | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | ChannelDispatchers | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | CloseTimeout | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | Credentials | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | Description | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | EnableEnvelopeBehavior | Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior for each service endpoint. Default value false.
public Property | Extensions | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | FastInfosetSettings | Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.
public Property | ManualFlowControlLimit | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | OpenTimeout | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | SingletonInstance | (Inherited from System.ServiceModel.ServiceHost)
public Property | State | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Properties

 | Name | Description
protected Property | DefaultCloseTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | DefaultOpenTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | IsDisposed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | ThisLock | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Public Methods

 | Name | Description
public Method | Abort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | AddDefaultEndpoints | Overloaded. (Inherited from System.ServiceModel.ServiceHostBase)
public Method | AddServiceEndpoint | Overloaded. (Inherited from System.ServiceModel.ServiceHost)
public Method | BeginClose | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginOpen | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | Close | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | IncrementManualFlowControlLimit | (Inherited from System.ServiceModel.ServiceHostBase)
public Method | Open | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | SetEndpointAddress | (Inherited from System.ServiceModel.ServiceHostBase)
Top

Protected Methods

 | Name | Description
protected Method | AddBaseAddress | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | ApplyConfiguration | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | CreateDescription | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | Fault | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | GetCommunicationObjectType | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | InitializeDescription | Overloaded. (Inherited from System.ServiceModel.ServiceHost)
protected Method | InitializeRuntime | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | LoadConfigurationSection | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | OnAbort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnFaulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpening | Overridden. Overrides virtual method of System.ServiceMode.ServiceHost.
protected Method | ReleasePerformanceCounters | (Inherited from System.ServiceModel.ServiceHostBase)
Top

Public Events

 | Name | Description
public Event | Closed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Closing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Faulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opening | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | UnknownMessageReceived | (Inherited from System.ServiceModel.ServiceHostBase)
Top

See Also

Reference

XServiceHost Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XServiceHost Constructor
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : XServiceHost Constructor

Overload List

Overload | Description
XServiceHost Constructor() | Create new instance of XServiceHost.
XServiceHost Constructor(Object,Uri[]) | Create new instance of XServiceHost for specified singleton instance.
XServiceHost Constructor(Type,Uri[]) | Initializes a new instance of XServiceHost for specified service implementation.

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XServiceHost Constructor()
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > XServiceHost Constructor : XServiceHost Constructor()

Create new instance of XServiceHost.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XServiceHost()
C#
public XServiceHost()
Delphi
public XServiceHost();
JScript
public function XServiceHost();
Managed Extensions for C++
public: XServiceHost();
C++/CLI
public:
XServiceHost();

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XServiceHost Constructor(Object,Uri[])
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > XServiceHost Constructor : XServiceHost Constructor(Object,Uri[])

singletonInstance
The singleton instance providing the serivce.
baseAddresses
The list of base addresses.
Create new instance of XServiceHost for specified singleton instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal singletonInstance As Object, _
   ByVal ParamArray baseAddresses() As Uri _
)
Visual Basic (Usage) Copy Code
Dim singletonInstance As Object
Dim baseAddresses() As Uri

Dim instance As New XServiceHost(singletonInstance, baseAddresses)
C#
public XServiceHost(
   object singletonInstance,
   params Uri[] baseAddresses
)
Delphi
public XServiceHost(
    singletonInstance: TObject;
   params  baseAddresses: Uriarray of
);
JScript
public function XServiceHost(
   singletonInstance : Object,
   baseAddresses : Uri[]
);
Managed Extensions for C++
public: XServiceHost(
   Object* singletonInstance,
   params Uri*[]* baseAddresses
)
C++/CLI
public:
XServiceHost(
   Object^ singletonInstance,
   ... array<Uri^>^ baseAddresses
)

Parameters

singletonInstance
The singleton instance providing the serivce.
baseAddresses
The list of base addresses.

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XServiceHost Constructor(Type,Uri[])
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > XServiceHost Constructor : XServiceHost Constructor(Type,Uri[])

implementation
The type of a class providing service implementation.
baseAddresses
The list of base addresses.
Initializes a new instance of XServiceHost for specified service implementation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal implementation As Type, _
   ByVal ParamArray baseAddresses() As Uri _
)
Visual Basic (Usage) Copy Code
Dim implementation As Type
Dim baseAddresses() As Uri

Dim instance As New XServiceHost(implementation, baseAddresses)
C#
public XServiceHost(
   Type implementation,
   params Uri[] baseAddresses
)
Delphi
public XServiceHost(
    implementation: Type;
   params  baseAddresses: Uriarray of
);
JScript
public function XServiceHost(
   implementation : Type,
   baseAddresses : Uri[]
);
Managed Extensions for C++
public: XServiceHost(
   Type* implementation,
   params Uri*[]* baseAddresses
)
C++/CLI
public:
XServiceHost(
   Type^ implementation,
   ... array<Uri^>^ baseAddresses
)

Parameters

implementation
The type of a class providing service implementation.
baseAddresses
The list of base addresses.

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XServiceHost Class Methods
See Also Send Feedback
Noemax.WCFX Namespace : XServiceHost Class

For a list of all members of this type, see XServiceHost members.

Public Methods

 | Name | Description
public Method | Abort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | AddDefaultEndpoints | Overloaded. (Inherited from System.ServiceModel.ServiceHostBase)
public Method | AddServiceEndpoint | Overloaded. (Inherited from System.ServiceModel.ServiceHost)
public Method | BeginClose | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | BeginOpen | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | Close | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | EndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | IncrementManualFlowControlLimit | (Inherited from System.ServiceModel.ServiceHostBase)
public Method | Open | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Method | SetEndpointAddress | (Inherited from System.ServiceModel.ServiceHostBase)
Top

Protected Methods

 | Name | Description
protected Method | AddBaseAddress | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | ApplyConfiguration | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | CreateDescription | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | Fault | Overloaded. (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | GetCommunicationObjectType | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | InitializeDescription | Overloaded. (Inherited from System.ServiceModel.ServiceHost)
protected Method | InitializeRuntime | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | LoadConfigurationSection | (Inherited from System.ServiceModel.ServiceHostBase)
protected Method | OnAbort | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnBeginOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnClosing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndClose | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnEndOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnFaulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpen | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Method | OnOpening | Overridden. Overrides virtual method of System.ServiceMode.ServiceHost.
protected Method | ReleasePerformanceCounters | (Inherited from System.ServiceModel.ServiceHostBase)
Top

See Also

Reference

XServiceHost Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpening Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnOpening Method

Overrides virtual method of System.ServiceMode.ServiceHost.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnOpening()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnOpening()
C#
protected override void OnOpening()
Delphi
protected procedure OnOpening(); override;
JScript
protected override function OnOpening();
Managed Extensions for C++
protected: void OnOpening(); override
C++/CLI
protected:
void OnOpening(); override

Remarks

Upon opening XServiceHost modifies the configuration of the bindings used by the service endpoints to use Noemax.WCFX.Channels.FiMessageEncodingBindingElement. It also optionally provides compression or injects the Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior to each endpoint exposed by the service.

See Also

Reference

XServiceHost Class
XServiceHost Members
Base Implementation in OnOpening


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XServiceHost Class Properties
See Also Send Feedback
Noemax.WCFX Namespace : XServiceHost Class

For a list of all members of this type, see XServiceHost members.

Public Properties

 | Name | Description
public Property | Authentication | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | Authorization | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | BaseAddresses | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | ChannelDispatchers | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | CloseTimeout | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionMode | Gets and sets the compression mode used by the binding.
public Property | Credentials | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | Description | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | EnableEnvelopeBehavior | Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior for each service endpoint. Default value false.
public Property | Extensions | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | FastInfosetSettings | Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.
public Property | ManualFlowControlLimit | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | OpenTimeout | (Inherited from System.ServiceModel.ServiceHostBase)
public Property | SingletonInstance | (Inherited from System.ServiceModel.ServiceHost)
public Property | State | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

Protected Properties

 | Name | Description
protected Property | DefaultCloseTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | DefaultOpenTimeout | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | IsDisposed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
protected Property | ThisLock | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

See Also

Reference

XServiceHost Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : CompressionMode Property

Gets and sets the compression mode used by the binding.

Syntax

Visual Basic (Declaration)
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

Remarks

When content negotiation is supported by the binding, the use of compression is negotiated between the communication sides. When content negotiation is not supported by the binding, compression is always applied to all message sent through the channel.

Compression is never applied when set to None.

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableEnvelopeBehavior Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : EnableEnvelopeBehavior Property

Enables the use of Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior for each service endpoint. Default value false.

Syntax

Visual Basic (Declaration)
Public Property EnableEnvelopeBehavior As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Boolean

instance.EnableEnvelopeBehavior = value

value = instance.EnableEnvelopeBehavior
C#
public bool EnableEnvelopeBehavior {get; set;}
Delphi
public read-write property EnableEnvelopeBehavior: Boolean;
JScript
public function get,set EnableEnvelopeBehavior : boolean
Managed Extensions for C++
public: __property bool get_EnableEnvelopeBehavior();
public: __property void set_EnableEnvelopeBehavior(
   bool value
);
C++/CLI
public:
property bool EnableEnvelopeBehavior {
   bool get();
   void set (    bool value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSettings Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : FastInfosetSettings Property

Gets and sets the settings for the Fast Infoset message encoding. This settings are applied only when Fast Infoset message encoding is used.

Syntax

Visual Basic (Declaration)
Public Property FastInfosetSettings As FastInfosetSettings
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As FastInfosetSettings

instance.FastInfosetSettings = value

value = instance.FastInfosetSettings
C#
public FastInfosetSettings FastInfosetSettings {get; set;}
Delphi
public read-write property FastInfosetSettings: FastInfosetSettings;
JScript
public function get,set FastInfosetSettings : FastInfosetSettings
Managed Extensions for C++
public: __property FastInfosetSettings* get_FastInfosetSettings();
public: __property void set_FastInfosetSettings(
   FastInfosetSettings* value
);
C++/CLI
public:
property FastInfosetSettings^ FastInfosetSettings {
   FastInfosetSettings^ get();
   void set (    FastInfosetSettings^ value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WcfxMessageEncoding Enumeration
See Also Send Feedback
Noemax.WCFX Namespace : WcfxMessageEncoding Enumeration

Defines the message encoding to be used by the binding.

Syntax

Visual Basic (Declaration)
Public Enum WcfxMessageEncoding
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WcfxMessageEncoding
C#
public enum WcfxMessageEncoding : System.Enum
Delphi
public enum WcfxMessageEncoding = class(System.Enum)
JScript
public enum WcfxMessageEncoding extends System.Enum
Managed Extensions for C++
__value public enum WcfxMessageEncoding : public System.Enum
C++/CLI
public enum class WcfxMessageEncoding : public System.Enum

Members

Member | Description
BindingDefault | The message encoding default for the binding.
FastInfoset | Fast Infoset message encoding.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.WcfxMessageEncoding

See Also

Reference

Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IPluggableBindingElement Interface
Members See Also Send Feedback
Noemax.WCFX Namespace : IPluggableBindingElement Interface

An interface that binding element implement in order to be pluggable into bindings through code and configuration files.

Syntax

Visual Basic (Declaration)
Public Interface IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As IPluggableBindingElement
C#
public interface IPluggableBindingElement
Delphi
public interface IPluggableBindingElement
JScript
public interface IPluggableBindingElement
Managed Extensions for C++
public __gc __interface IPluggableBindingElement
C++/CLI
public interface class IPluggableBindingElement

See Also

Reference

IPluggableBindingElement Members
Noemax.WCFX Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
IPluggableBindingElement Interface Members
See Also Methods Send Feedback
Noemax.WCFX Namespace : IPluggableBindingElement Interface

The following tables list the members exposed by IPluggableBindingElement.

Public Methods

 | Name | Description
Method | PlugIn | Overloaded. Creates a custom binding based on the original binding, modified to use the implementation of IPluggableBindingElement.
Top

See Also

Reference

IPluggableBindingElement Interface
Noemax.WCFX Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
IPluggableBindingElement Interface Methods
See Also Send Feedback
Noemax.WCFX Namespace : IPluggableBindingElement Interface

For a list of all members of this type, see IPluggableBindingElement members.

Public Methods

 | Name | Description
Method | PlugIn | Overloaded. Creates a custom binding based on the original binding, modified to use the implementation of IPluggableBindingElement.
Top

See Also

Reference

IPluggableBindingElement Interface
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX Namespace > IPluggableBindingElement Interface : PlugIn Method

Creates a custom binding based on the original binding, modified to use the implementation of IPluggableBindingElement.

Overload List

Overload | Description
PlugIn(Binding) | Creates a custom binding based on the original binding, modified to use the implementation of IPluggableBindingElement.
PlugIn(BindingElementCollection) | Creates a binding element collection based on the original binding element collection, modified to use the implementation of IPluggableBindingElement.

See Also

Reference

IPluggableBindingElement Interface
IPluggableBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX Namespace > IPluggableBindingElement Interface > PlugIn Method : PlugIn(Binding) Method

binding
The original binding.
Creates a custom binding based on the original binding, modified to use the implementation of IPluggableBindingElement.

Syntax

Visual Basic (Declaration)
Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As IPluggableBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
CustomBinding PlugIn(
   Binding binding
)
Delphi
function PlugIn(
    binding: Binding
): CustomBinding;
JScript
function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The original binding.

Return Value

The customized binding modified to use the this instace of IPluggableBindingElement.

See Also

Reference

IPluggableBindingElement Interface
IPluggableBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX Namespace > IPluggableBindingElement Interface > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The original binding element collection.
Creates a binding element collection based on the original binding element collection, modified to use the implementation of IPluggableBindingElement.

Syntax

Visual Basic (Declaration)
Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As IPluggableBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The original binding element collection.

Return Value

The binding element collection that uses this instance IPluggableBindingElement.

See Also

Reference

IPluggableBindingElement Interface
IPluggableBindingElement Members
Overload List


%%ItemTitle%%

Noemax.WCFX.Behaviors Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | CustomOperationSelectorAttribute | Provides an alternative mechanism of dispatching messages by custom criteria.
Class | EnableCompressionAttribute | This attribute allows you to specify which operations may use compression.
Class | EnumerableStreamAttribute | An operation behavior that reduces memory consumption by serializing IEnumerable parameters in a streamed manner.
Class | EnumerableStreamBehavior | An operation behavior that reduces memory consumption by serializing IEnumerable parameters in a streamed manner.
Class | EnvelopeBehavior | An operation behavior that reduces message size by serializing the message body into a compact envelope.
Class | EnvelopeBehaviorAttribute | Specifies that EnvelopeBehavior is going to be applied to the service operation.
Class | EnvelopeEndpointBehavior | Specifies that EnvelopeBehavior will be applied on every operation of the service endpoint.
Class | ExportMetadataBehavior | Enables service to publish WSDL through WCF-Xtensions transport endpoints.
Class | MessageBodyEnvelope | Class used internaly by EnvelopeBehavior to write/read enveloped messages.
Class | OperationMessageFilterAttributeBase | Represents a base class to be derived by the custom message filter attribute which can be used to modify the message dispatching behavior.
Class | QualifiedNameMessageFilterAttribute | Associates the message to the local operation by evaluating the qualified name of the first element in the request body.
Class | QualifiedNameOperationSelectorAttribute | Provides an alternative mechanism of dispatching messages by the qualified name of the first element in the request body.

Interfaces

 | Interface | Description
Interface | IOperationMessageFilter | Defines an interface to be implemented by the custom message filter attribute which can be used to modify the message dispatching behavior.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CustomOperationSelectorAttribute Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : CustomOperationSelectorAttribute Class

Provides an alternative mechanism of dispatching messages by custom criteria.

Object Model

CustomOperationSelectorAttribute Class

Syntax

Visual Basic (Declaration)
Public Class CustomOperationSelectorAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As CustomOperationSelectorAttribute
C#
public class CustomOperationSelectorAttribute : System.Attribute
Delphi
public class CustomOperationSelectorAttribute = class(System.Attribute)
JScript
public class CustomOperationSelectorAttribute extends System.Attribute
Managed Extensions for C++
public __gc class CustomOperationSelectorAttribute : public System.Attribute
C++/CLI
public ref class CustomOperationSelectorAttribute : public System.Attribute

Remarks

By applying this attribute either to the service implementation or to the contract definition you can make WCF dispatch messages based on the custom criteria specified by IOperationMessageFilter descendant attributes.

This functionality is useful with POX messaging since it doesn't use a SOAP envelope, as well as when the service needs to dispatch SOAP messages that don't include a WS-Addressing header or don't specify a SOAPAction.

The CustomOperationSelectorAttribute can be used in combination with custom attributes that implement IOperationMessageFilter. By implementing this interface you can define your own criteria for message dispatching. These custom attributes can be applied to methods that represent Web Services operations. The CustomOperationSelectorAttribute tries to match the message to any of the criteria specified in the or IOperationMessageFilter attributes, otherwise it tries to use the default dispatching mechanism.

QualifiedNameMessageFilterAttribute also implements IOperationMessageFilter and can be used with in combination with CustomOperationSelectorAttribute just like with QualifiedNameOperationSelectorAttribute.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.CustomOperationSelectorAttribute
Noemax.WCFX.Behaviors.QualifiedNameOperationSelectorAttribute

See Also

Reference

CustomOperationSelectorAttribute Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
CustomOperationSelectorAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : CustomOperationSelectorAttribute Class

The following tables list the members exposed by CustomOperationSelectorAttribute.

Public Constructors

 | Name | Description
public Constructor | CustomOperationSelectorAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
protected Method | PropogateMessageFilters | When implemented propogates the custom message fileters into operations speificied by ContractDescriptions.
Top

See Also

Reference

CustomOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CustomOperationSelectorAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > CustomOperationSelectorAttribute Class : CustomOperationSelectorAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CustomOperationSelectorAttribute()
C#
public CustomOperationSelectorAttribute()
Delphi
public CustomOperationSelectorAttribute();
JScript
public function CustomOperationSelectorAttribute();
Managed Extensions for C++
public: CustomOperationSelectorAttribute();
C++/CLI
public:
CustomOperationSelectorAttribute();

See Also

Reference

CustomOperationSelectorAttribute Class
CustomOperationSelectorAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
CustomOperationSelectorAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : CustomOperationSelectorAttribute Class

For a list of all members of this type, see CustomOperationSelectorAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
protected Method | PropogateMessageFilters | When implemented propogates the custom message fileters into operations speificied by ContractDescriptions.
Top

See Also

Reference

CustomOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PropogateMessageFilters Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > CustomOperationSelectorAttribute Class : PropogateMessageFilters Method

contractDescription
When implemented propogates the custom message fileters into operations speificied by ContractDescriptions.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PropogateMessageFilters( _
   ByVal contractDescription As ContractDescription _
)
Visual Basic (Usage) Copy Code
Dim instance As CustomOperationSelectorAttribute
Dim contractDescription As ContractDescription

instance.PropogateMessageFilters(contractDescription)
C#
protected virtual void PropogateMessageFilters(
   ContractDescription contractDescription
)
Delphi
protected procedure PropogateMessageFilters(
    contractDescription: ContractDescription
); virtual;
JScript
protected function PropogateMessageFilters(
   contractDescription : ContractDescription
);
Managed Extensions for C++
protected: virtual void PropogateMessageFilters(
   ContractDescription* contractDescription
)
C++/CLI
protected:
virtual void PropogateMessageFilters(
   ContractDescription^ contractDescription
)

Parameters

contractDescription

See Also

Reference

CustomOperationSelectorAttribute Class
CustomOperationSelectorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableCompressionAttribute Class
Members Example See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnableCompressionAttribute Class

This attribute allows you to specify which operations may use compression.

Object Model

EnableCompressionAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class EnableCompressionAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As EnableCompressionAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class EnableCompressionAttribute : System.Attribute
Delphi
public class EnableCompressionAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=,
   Inherited=)
public class EnableCompressionAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public __gc class EnableCompressionAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public ref class EnableCompressionAttribute : public System.Attribute

Example

[C#]

[ServiceContract]

interfaceIInfoService

{

[OperationContract][EnableCompression]

Data[] GetData();

}

Copy Code

  Remarks
When the binding works in SmartCompressionMode.Selective mode it uses compression for operations marked by EnableCompressionAttribute. This attribute allows you to configure the binding in an efficient manner, enabling compression only for operations that require it.

  Inheritance Hierarchy
System.Object
   System.Attribute
      Noemax.WCFX.Behaviors.EnableCompressionAttribute

  See Also
Reference
EnableCompressionAttribute Members

Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnableCompressionAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : EnableCompressionAttribute Class

The following tables list the members exposed by EnableCompressionAttribute.

Public Constructors

 | Name | Description
public Constructor | EnableCompressionAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnableCompressionAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableCompressionAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnableCompressionAttribute Class : EnableCompressionAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnableCompressionAttribute()
C#
public EnableCompressionAttribute()
Delphi
public EnableCompressionAttribute();
JScript
public function EnableCompressionAttribute();
Managed Extensions for C++
public: EnableCompressionAttribute();
C++/CLI
public:
EnableCompressionAttribute();

See Also

Reference

EnableCompressionAttribute Class
EnableCompressionAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnumerableStreamAttribute Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamAttribute Class

An operation behavior that reduces memory consumption by serializing IEnumerable parameters in a streamed manner.

Object Model

EnumerableStreamAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class EnumerableStreamAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As EnumerableStreamAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class EnumerableStreamAttribute : System.Attribute
Delphi
public class EnumerableStreamAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=,
   Inherited=)
public class EnumerableStreamAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public __gc class EnumerableStreamAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public ref class EnumerableStreamAttribute : public System.Attribute

Remarks

The EnumerableStreamBehavior performs streamed serialization of IEnumerable parameters without loading the entire enumerable collection into memory. It is most useful when the service operation returns a large IEnumerable collection.

For the EnumerableStreamBehavior to perform as expected, the transfer mode of the transport specified by the binding being used must be set to Streamed.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.EnumerableStreamAttribute

See Also

Reference

EnumerableStreamAttribute Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnumerableStreamAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamAttribute Class

The following tables list the members exposed by EnumerableStreamAttribute.

Public Constructors

 | Name | Description
public Constructor | EnumerableStreamAttribute Constructor | Initializes a new instance of EnumerableStreamAttrtibute.
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnumerableStreamAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnumerableStreamAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnumerableStreamAttribute Class : EnumerableStreamAttribute Constructor

Initializes a new instance of EnumerableStreamAttrtibute.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnumerableStreamAttribute()
C#
public EnumerableStreamAttribute()
Delphi
public EnumerableStreamAttribute();
JScript
public function EnumerableStreamAttribute();
Managed Extensions for C++
public: EnumerableStreamAttribute();
C++/CLI
public:
EnumerableStreamAttribute();

See Also

Reference

EnumerableStreamAttribute Class
EnumerableStreamAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnumerableStreamBehavior Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamBehavior Class

An operation behavior that reduces memory consumption by serializing IEnumerable parameters in a streamed manner.

Object Model

EnumerableStreamBehavior Class

Syntax

Visual Basic (Declaration)
Public Class EnumerableStreamBehavior
Visual Basic (Usage) Copy Code
Dim instance As EnumerableStreamBehavior
C#
public class EnumerableStreamBehavior
Delphi
public class EnumerableStreamBehavior
JScript
public class EnumerableStreamBehavior
Managed Extensions for C++
public __gc class EnumerableStreamBehavior
C++/CLI
public ref class EnumerableStreamBehavior

Remarks

The EnumerableStreamBehavior performs streamed serialization of IEnumerable parameters without loading the entire enumerable collection into memory. It is most useful when the service operation returns a large IEnumerable collection.

For the EnumerableStreamBehavior to perform as expected, the transfer mode of the transport specified by the binding being used must be set to Streamed.

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.EnumerableStreamBehavior

See Also

Reference

EnumerableStreamBehavior Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnumerableStreamBehavior Class Members
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamBehavior Class

The following tables list the members exposed by EnumerableStreamBehavior.

Public Constructors

 | Name | Description
public Constructor | EnumerableStreamBehavior Constructor | Initializes a new instance of EnumerableStreamBehavior.
Top

See Also

Reference

EnumerableStreamBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnumerableStreamBehavior Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnumerableStreamBehavior Class : EnumerableStreamBehavior Constructor

Initializes a new instance of EnumerableStreamBehavior.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnumerableStreamBehavior()
C#
public EnumerableStreamBehavior()
Delphi
public EnumerableStreamBehavior();
JScript
public function EnumerableStreamBehavior();
Managed Extensions for C++
public: EnumerableStreamBehavior();
C++/CLI
public:
EnumerableStreamBehavior();

See Also

Reference

EnumerableStreamBehavior Class
EnumerableStreamBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeBehavior Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehavior Class

An operation behavior that reduces message size by serializing the message body into a compact envelope.

Object Model

EnvelopeBehavior Class

Syntax

Visual Basic (Declaration)
Public Class EnvelopeBehavior
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehavior
C#
public class EnvelopeBehavior
Delphi
public class EnvelopeBehavior
JScript
public class EnvelopeBehavior
Managed Extensions for C++
public __gc class EnvelopeBehavior
C++/CLI
public ref class EnvelopeBehavior

Remarks

The EnvelopeBehavior serializes the message body as a Fast Infoset document and compresses it using a selectable compression algorithm. As a result, a compact binary representation of the original message body is produced. This compact binary representation is referred to as an envelope.

Applying the EnvelopeBehavior requires no changes to the binding configuration. The EnvelopeBehavior can be used to reduce message size even when the binding cannot be modified.

When message security is being used, the EnvelopeBehavior not only reduces message size but also increases processing performance since the processing overhead incurred by message security is largely dependent on message size.

Even though the use of the EnvelopeBehavior will almost always result in significantly reducing message size, the final size of the message transmitted by the transport layer will be determined by the message encoding specified by the binding being used. For the same envelope, a binding which uses a binary message encoding (such as Fast Infoset or WCF Binary) will provide relatively better compactness and processing performance then a binding which uses a non-binary message encoding.

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.EnvelopeBehavior

See Also

Reference

EnvelopeBehavior Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnvelopeBehavior Class Members
See Also Properties Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehavior Class

The following tables list the members exposed by EnvelopeBehavior.

Public Constructors

 | Name | Description
public Constructor | EnvelopeBehavior Constructor | Initializes a new instance of EnvelopeBehavior associated to the specific operation.
Top

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
public Property | ProcessIncomming | Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.
public Property | ProcessOutgoing | Gets and sets whether the outgoing messages will be enveloped.
Top

See Also

Reference

EnvelopeBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeBehavior Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehavior Class : EnvelopeBehavior Constructor

operation
And opperation to associate this behavior too.
Initializes a new instance of EnvelopeBehavior associated to the specific operation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal operation As OperationDescription _
)
Visual Basic (Usage) Copy Code
Dim operation As OperationDescription

Dim instance As New EnvelopeBehavior(operation)
C#
public EnvelopeBehavior(
   OperationDescription operation
)
Delphi
public EnvelopeBehavior(
    operation: OperationDescription
);
JScript
public function EnvelopeBehavior(
   operation : OperationDescription
);
Managed Extensions for C++
public: EnvelopeBehavior(
   OperationDescription* operation
)
C++/CLI
public:
EnvelopeBehavior(
   OperationDescription^ operation
)

Parameters

operation
And opperation to associate this behavior too.

See Also

Reference

EnvelopeBehavior Class
EnvelopeBehavior Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnvelopeBehavior Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehavior Class

For a list of all members of this type, see EnvelopeBehavior members.

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
public Property | ProcessIncomming | Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.
public Property | ProcessOutgoing | Gets and sets whether the outgoing messages will be enveloped.
Top

See Also

Reference

EnvelopeBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehavior Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehavior
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

EnvelopeBehavior Class
EnvelopeBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehavior Class : CompressionMethod Property

Sets and gets the compression method to be used by the message envelope.

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As EncodingCompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehavior
Dim value As EncodingCompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public EncodingCompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: EncodingCompressionMethod;
JScript
public function get,set CompressionMethod : EncodingCompressionMethod
Managed Extensions for C++
public: __property EncodingCompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   EncodingCompressionMethod value
);
C++/CLI
public:
property EncodingCompressionMethod CompressionMethod {
   EncodingCompressionMethod get();
   void set (    EncodingCompressionMethod value);
}

See Also

Reference

EnvelopeBehavior Class
EnvelopeBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessIncomming Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehavior Class : ProcessIncomming Property

Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.

Syntax

Visual Basic (Declaration)
Public Property ProcessIncomming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehavior
Dim value As Boolean

instance.ProcessIncomming = value

value = instance.ProcessIncomming
C#
public bool ProcessIncomming {get; set;}
Delphi
public read-write property ProcessIncomming: Boolean;
JScript
public function get,set ProcessIncomming : boolean
Managed Extensions for C++
public: __property bool get_ProcessIncomming();
public: __property void set_ProcessIncomming(
   bool value
);
C++/CLI
public:
property bool ProcessIncomming {
   bool get();
   void set (    bool value);
}

Remarks

In case when this property is to true and message is actually not enveloped, no actions will be taken and message will be forwarded for farther processing.

See Also

Reference

EnvelopeBehavior Class
EnvelopeBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessOutgoing Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehavior Class : ProcessOutgoing Property

Gets and sets whether the outgoing messages will be enveloped.

Syntax

Visual Basic (Declaration)
Public Property ProcessOutgoing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehavior
Dim value As Boolean

instance.ProcessOutgoing = value

value = instance.ProcessOutgoing
C#
public bool ProcessOutgoing {get; set;}
Delphi
public read-write property ProcessOutgoing: Boolean;
JScript
public function get,set ProcessOutgoing : boolean
Managed Extensions for C++
public: __property bool get_ProcessOutgoing();
public: __property void set_ProcessOutgoing(
   bool value
);
C++/CLI
public:
property bool ProcessOutgoing {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeBehavior Class
EnvelopeBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeBehaviorAttribute Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehaviorAttribute Class

Specifies that EnvelopeBehavior is going to be applied to the service operation.

Object Model

EnvelopeBehaviorAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class EnvelopeBehaviorAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class EnvelopeBehaviorAttribute : System.Attribute
Delphi
public class EnvelopeBehaviorAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=,
   Inherited=)
public class EnvelopeBehaviorAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public __gc class EnvelopeBehaviorAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public ref class EnvelopeBehaviorAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.EnvelopeBehaviorAttribute

See Also

Reference

EnvelopeBehaviorAttribute Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnvelopeBehaviorAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehaviorAttribute Class

The following tables list the members exposed by EnvelopeBehaviorAttribute.

Public Constructors

 | Name | Description
public Constructor | EnvelopeBehaviorAttribute Constructor | Initializes a new instance of EnvelopeBehaviorAttribute.
Top

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
public Property | ProcessIncomming | Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.
public Property | ProcessOutgoing | Gets and sets whether the outgoing messages will be enveloped.
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnvelopeBehaviorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeBehaviorAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : EnvelopeBehaviorAttribute Constructor

Initializes a new instance of EnvelopeBehaviorAttribute.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnvelopeBehaviorAttribute()
C#
public EnvelopeBehaviorAttribute()
Delphi
public EnvelopeBehaviorAttribute();
JScript
public function EnvelopeBehaviorAttribute();
Managed Extensions for C++
public: EnvelopeBehaviorAttribute();
C++/CLI
public:
EnvelopeBehaviorAttribute();

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnvelopeBehaviorAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehaviorAttribute Class

For a list of all members of this type, see EnvelopeBehaviorAttribute members.

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
public Property | ProcessIncomming | Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.
public Property | ProcessOutgoing | Gets and sets whether the outgoing messages will be enveloped.
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

EnvelopeBehaviorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : CompressionMethod Property

Sets and gets the compression method to be used by the message envelope.

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As EncodingCompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As EncodingCompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public EncodingCompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: EncodingCompressionMethod;
JScript
public function get,set CompressionMethod : EncodingCompressionMethod
Managed Extensions for C++
public: __property EncodingCompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   EncodingCompressionMethod value
);
C++/CLI
public:
property EncodingCompressionMethod CompressionMethod {
   EncodingCompressionMethod get();
   void set (    EncodingCompressionMethod value);
}

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessIncomming Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : ProcessIncomming Property

Gets and sets whether incomming messages need to be de-enveloped. If set too true behavior will attempt to de-envelope incomming messages.

Syntax

Visual Basic (Declaration)
Public Property ProcessIncomming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As Boolean

instance.ProcessIncomming = value

value = instance.ProcessIncomming
C#
public bool ProcessIncomming {get; set;}
Delphi
public read-write property ProcessIncomming: Boolean;
JScript
public function get,set ProcessIncomming : boolean
Managed Extensions for C++
public: __property bool get_ProcessIncomming();
public: __property void set_ProcessIncomming(
   bool value
);
C++/CLI
public:
property bool ProcessIncomming {
   bool get();
   void set (    bool value);
}

Remarks

In case when this property is to true and message is actually not enveloped, no actions will be taken and message will be forwarded for farther processing.

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessOutgoing Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : ProcessOutgoing Property

Gets and sets whether the outgoing messages will be enveloped.

Syntax

Visual Basic (Declaration)
Public Property ProcessOutgoing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As Boolean

instance.ProcessOutgoing = value

value = instance.ProcessOutgoing
C#
public bool ProcessOutgoing {get; set;}
Delphi
public read-write property ProcessOutgoing: Boolean;
JScript
public function get,set ProcessOutgoing : boolean
Managed Extensions for C++
public: __property bool get_ProcessOutgoing();
public: __property void set_ProcessOutgoing(
   bool value
);
C++/CLI
public:
property bool ProcessOutgoing {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehavior Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeEndpointBehavior Class

Specifies that EnvelopeBehavior will be applied on every operation of the service endpoint.

Object Model

EnvelopeEndpointBehavior Class

Syntax

Visual Basic (Declaration)
Public Class EnvelopeEndpointBehavior
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehavior
C#
public class EnvelopeEndpointBehavior
Delphi
public class EnvelopeEndpointBehavior
JScript
public class EnvelopeEndpointBehavior
Managed Extensions for C++
public __gc class EnvelopeEndpointBehavior
C++/CLI
public ref class EnvelopeEndpointBehavior

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior

See Also

Reference

EnvelopeEndpointBehavior Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehavior Class Members
See Also Properties Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeEndpointBehavior Class

The following tables list the members exposed by EnvelopeEndpointBehavior.

Public Constructors

 | Name | Description
public Constructor | EnvelopeEndpointBehavior Constructor | Creates new instance of EnvelopeEndpointBehavior.
Top

Public Properties

 | Name | Description
public Property | CompressionLevel |
public Property | CompressionMethod |
public Property | ProcessIncomming |
public Property | ProcessOutgoing |
Top

See Also

Reference

EnvelopeEndpointBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehavior Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeEndpointBehavior Class : EnvelopeEndpointBehavior Constructor

Creates new instance of EnvelopeEndpointBehavior.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnvelopeEndpointBehavior()
C#
public EnvelopeEndpointBehavior()
Delphi
public EnvelopeEndpointBehavior();
JScript
public function EnvelopeEndpointBehavior();
Managed Extensions for C++
public: EnvelopeEndpointBehavior();
C++/CLI
public:
EnvelopeEndpointBehavior();

See Also

Reference

EnvelopeEndpointBehavior Class
EnvelopeEndpointBehavior Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehavior Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeEndpointBehavior Class

For a list of all members of this type, see EnvelopeEndpointBehavior members.

Public Properties

 | Name | Description
public Property | CompressionLevel |
public Property | CompressionMethod |
public Property | ProcessIncomming |
public Property | ProcessOutgoing |
Top

See Also

Reference

EnvelopeEndpointBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeEndpointBehavior Class : CompressionLevel Property

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehavior
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

See Also

Reference

EnvelopeEndpointBehavior Class
EnvelopeEndpointBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeEndpointBehavior Class : CompressionMethod Property

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As EncodingCompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehavior
Dim value As EncodingCompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public EncodingCompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: EncodingCompressionMethod;
JScript
public function get,set CompressionMethod : EncodingCompressionMethod
Managed Extensions for C++
public: __property EncodingCompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   EncodingCompressionMethod value
);
C++/CLI
public:
property EncodingCompressionMethod CompressionMethod {
   EncodingCompressionMethod get();
   void set (    EncodingCompressionMethod value);
}

See Also

Reference

EnvelopeEndpointBehavior Class
EnvelopeEndpointBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessIncomming Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeEndpointBehavior Class : ProcessIncomming Property

Syntax

Visual Basic (Declaration)
Public Property ProcessIncomming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehavior
Dim value As Boolean

instance.ProcessIncomming = value

value = instance.ProcessIncomming
C#
public bool ProcessIncomming {get; set;}
Delphi
public read-write property ProcessIncomming: Boolean;
JScript
public function get,set ProcessIncomming : boolean
Managed Extensions for C++
public: __property bool get_ProcessIncomming();
public: __property void set_ProcessIncomming(
   bool value
);
C++/CLI
public:
property bool ProcessIncomming {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeEndpointBehavior Class
EnvelopeEndpointBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessOutgoing Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeEndpointBehavior Class : ProcessOutgoing Property

Syntax

Visual Basic (Declaration)
Public Property ProcessOutgoing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehavior
Dim value As Boolean

instance.ProcessOutgoing = value

value = instance.ProcessOutgoing
C#
public bool ProcessOutgoing {get; set;}
Delphi
public read-write property ProcessOutgoing: Boolean;
JScript
public function get,set ProcessOutgoing : boolean
Managed Extensions for C++
public: __property bool get_ProcessOutgoing();
public: __property void set_ProcessOutgoing(
   bool value
);
C++/CLI
public:
property bool ProcessOutgoing {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeEndpointBehavior Class
EnvelopeEndpointBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExportMetadataBehavior Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : ExportMetadataBehavior Class

Enables service to publish WSDL through WCF-Xtensions transport endpoints.

Object Model

ExportMetadataBehavior Class

Syntax

Visual Basic (Declaration)
Public Class ExportMetadataBehavior
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As ExportMetadataBehavior
C#
public class ExportMetadataBehavior : System.Attribute
Delphi
public class ExportMetadataBehavior = class(System.Attribute)
JScript
public class ExportMetadataBehavior extends System.Attribute
Managed Extensions for C++
public __gc class ExportMetadataBehavior : public System.Attribute
C++/CLI
public ref class ExportMetadataBehavior : public System.Attribute

Remarks

Enables export of WSDL through Noemax WCF-Xtentions provided transports. This behavior can be added to the ServiceDescription.Behaviors collection (or the <serviceBehaviors> configuration element) or assigned to service implementation class as an attribute.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.ExportMetadataBehavior

See Also

Reference

ExportMetadataBehavior Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ExportMetadataBehavior Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : ExportMetadataBehavior Class

The following tables list the members exposed by ExportMetadataBehavior.

Public Constructors

 | Name | Description
public Constructor | ExportMetadataBehavior Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExportMetadataBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExportMetadataBehavior Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > ExportMetadataBehavior Class : ExportMetadataBehavior Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ExportMetadataBehavior()
C#
public ExportMetadataBehavior()
Delphi
public ExportMetadataBehavior();
JScript
public function ExportMetadataBehavior();
Managed Extensions for C++
public: ExportMetadataBehavior();
C++/CLI
public:
ExportMetadataBehavior();

See Also

Reference

ExportMetadataBehavior Class
ExportMetadataBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageBodyEnvelope Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : MessageBodyEnvelope Class

Class used internaly by EnvelopeBehavior to write/read enveloped messages.

Object Model

MessageBodyEnvelope Class

Syntax

Visual Basic (Declaration)
Public Class MessageBodyEnvelope
Visual Basic (Usage) Copy Code
Dim instance As MessageBodyEnvelope
C#
public class MessageBodyEnvelope
Delphi
public class MessageBodyEnvelope
JScript
public class MessageBodyEnvelope
Managed Extensions for C++
public __gc class MessageBodyEnvelope
C++/CLI
public ref class MessageBodyEnvelope

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.MessageBodyEnvelope

See Also

Reference

MessageBodyEnvelope Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
MessageBodyEnvelope Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : MessageBodyEnvelope Class

The following tables list the members exposed by MessageBodyEnvelope.

Public Constructors

 | Name | Description
public Constructor | MessageBodyEnvelope Constructor | Creates new instance of MessageBodyEnvelope.
Top

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
Top

Public Methods

 | Name | Description
public Method | DeEnvelope | De-envelopes the message body and returns de-enveloped message.
public Method | Envelope | Envelopes the message body and returns the enveloped message.
Top

See Also

Reference

MessageBodyEnvelope Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageBodyEnvelope Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > MessageBodyEnvelope Class : MessageBodyEnvelope Constructor

Creates new instance of MessageBodyEnvelope.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MessageBodyEnvelope()
C#
public MessageBodyEnvelope()
Delphi
public MessageBodyEnvelope();
JScript
public function MessageBodyEnvelope();
Managed Extensions for C++
public: MessageBodyEnvelope();
C++/CLI
public:
MessageBodyEnvelope();

See Also

Reference

MessageBodyEnvelope Class
MessageBodyEnvelope Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
MessageBodyEnvelope Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : MessageBodyEnvelope Class

For a list of all members of this type, see MessageBodyEnvelope members.

Public Methods

 | Name | Description
public Method | DeEnvelope | De-envelopes the message body and returns de-enveloped message.
public Method | Envelope | Envelopes the message body and returns the enveloped message.
Top

See Also

Reference

MessageBodyEnvelope Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DeEnvelope Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > MessageBodyEnvelope Class : DeEnvelope Method

message
The message to de-envelope.
De-envelopes the message body and returns de-enveloped message.

Syntax

Visual Basic (Declaration)
Public Function DeEnvelope( _
   ByVal message As Message _
) As Message
Visual Basic (Usage) Copy Code
Dim instance As MessageBodyEnvelope
Dim message As Message
Dim value As Message

value = instance.DeEnvelope(message)
C#
public Message DeEnvelope(
   Message message
)
Delphi
public function DeEnvelope(
    message: Message
): Message;
JScript
public function DeEnvelope(
   message : Message
) : Message;
Managed Extensions for C++
public: Message* DeEnvelope(
   Message* message
)
C++/CLI
public:
Message^ DeEnvelope(
   Message^ message
)

Parameters

message
The message to de-envelope.

Return Value

De-enveloped message.

See Also

Reference

MessageBodyEnvelope Class
MessageBodyEnvelope Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Envelope Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > MessageBodyEnvelope Class : Envelope Method

message
The message to envelope.
Envelopes the message body and returns the enveloped message.

Syntax

Visual Basic (Declaration)
Public Function Envelope( _
   ByVal message As Message _
) As Message
Visual Basic (Usage) Copy Code
Dim instance As MessageBodyEnvelope
Dim message As Message
Dim value As Message

value = instance.Envelope(message)
C#
public Message Envelope(
   Message message
)
Delphi
public function Envelope(
    message: Message
): Message;
JScript
public function Envelope(
   message : Message
) : Message;
Managed Extensions for C++
public: Message* Envelope(
   Message* message
)
C++/CLI
public:
Message^ Envelope(
   Message^ message
)

Parameters

message
The message to envelope.

Return Value

The enveloped message.

See Also

Reference

MessageBodyEnvelope Class
MessageBodyEnvelope Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
MessageBodyEnvelope Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : MessageBodyEnvelope Class

For a list of all members of this type, see MessageBodyEnvelope members.

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Sets and gets the compression method to be used by the message envelope.
Top

See Also

Reference

MessageBodyEnvelope Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > MessageBodyEnvelope Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As MessageBodyEnvelope
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

MessageBodyEnvelope Class
MessageBodyEnvelope Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > MessageBodyEnvelope Class : CompressionMethod Property

Sets and gets the compression method to be used by the message envelope.

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As EncodingCompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As MessageBodyEnvelope
Dim value As EncodingCompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public EncodingCompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: EncodingCompressionMethod;
JScript
public function get,set CompressionMethod : EncodingCompressionMethod
Managed Extensions for C++
public: __property EncodingCompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   EncodingCompressionMethod value
);
C++/CLI
public:
property EncodingCompressionMethod CompressionMethod {
   EncodingCompressionMethod get();
   void set (    EncodingCompressionMethod value);
}

See Also

Reference

MessageBodyEnvelope Class
MessageBodyEnvelope Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OperationMessageFilterAttributeBase Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : OperationMessageFilterAttributeBase Class

Represents a base class to be derived by the custom message filter attribute which can be used to modify the message dispatching behavior.

Object Model

OperationMessageFilterAttributeBase Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class OperationMessageFilterAttributeBase
   Implements IOperationMessageFilter
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
C#
public abstract class OperationMessageFilterAttributeBase : IOperationMessageFilter
Delphi
public class OperationMessageFilterAttributeBase = class(IOperationMessageFilter)abstract;
JScript
public abstract class OperationMessageFilterAttributeBase implements IOperationMessageFilter
Managed Extensions for C++
public __gc abstract class OperationMessageFilterAttributeBase : public IOperationMessageFilter
C++/CLI
public ref class OperationMessageFilterAttributeBase abstract : public IOperationMessageFilter

Remarks

This class simplifies the creation of an attribute class that can be used in combination with the CustomOperationSelectorAttribute and QualifiedNameOperationSelectorAttribute to provide the service with your own criteria for dispatching messages based on the content of their header or body. Prefer deriving this class to creating your own implementation of IOperationMessageFilter.

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.OperationMessageFilterAttributeBase

See Also

Reference

OperationMessageFilterAttributeBase Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
OperationMessageFilterAttributeBase Class Members
See Also Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : OperationMessageFilterAttributeBase Class

The following tables list the members exposed by OperationMessageFilterAttributeBase.

Public Methods

 | Name | Description
public Method | AddBindingParameters | Implements the IOperationBehavior.AddBindingParameters method.
public Method | ApplyClientBehavior | Implements the IOperationBehavior.ApplyClientBehavior method.
public Method | ApplyDispatchBehavior | Implements the IOperationBehavior.ApplyDispatchBehavior method.
public Method | Match | When implemented in a derived class, it tries to associate the incoming message with the local operation.
public Method | Validate | Implements the IOperationBehavior.Validate method.
Top

See Also

Reference

OperationMessageFilterAttributeBase Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
OperationMessageFilterAttributeBase Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : OperationMessageFilterAttributeBase Class

For a list of all members of this type, see OperationMessageFilterAttributeBase members.

Public Methods

 | Name | Description
public Method | AddBindingParameters | Implements the IOperationBehavior.AddBindingParameters method.
public Method | ApplyClientBehavior | Implements the IOperationBehavior.ApplyClientBehavior method.
public Method | ApplyDispatchBehavior | Implements the IOperationBehavior.ApplyDispatchBehavior method.
public Method | Match | When implemented in a derived class, it tries to associate the incoming message with the local operation.
public Method | Validate | Implements the IOperationBehavior.Validate method.
Top

See Also

Reference

OperationMessageFilterAttributeBase Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddBindingParameters Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > OperationMessageFilterAttributeBase Class : AddBindingParameters Method

operationDescription
A description of the associated operation contract.
bindingParameters
A collection of binding parameters.
Implements the IOperationBehavior.AddBindingParameters method.

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddBindingParameters( _
   ByVal operationDescription As OperationDescription, _
   ByVal bindingParameters As BindingParameterCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
Dim operationDescription As OperationDescription
Dim bindingParameters As BindingParameterCollection

instance.AddBindingParameters(operationDescription, bindingParameters)
C#
public virtual void AddBindingParameters(
   OperationDescription operationDescription,
   BindingParameterCollection bindingParameters
)
Delphi
public procedure AddBindingParameters(
    operationDescription: OperationDescription;
    bindingParameters: BindingParameterCollection
); virtual;
JScript
public function AddBindingParameters(
   operationDescription : OperationDescription,
   bindingParameters : BindingParameterCollection
);
Managed Extensions for C++
public: virtual void AddBindingParameters(
   OperationDescription* operationDescription,
   BindingParameterCollection* bindingParameters
)
C++/CLI
public:
virtual void AddBindingParameters(
   OperationDescription^ operationDescription,
   BindingParameterCollection^ bindingParameters
)

Parameters

operationDescription
A description of the associated operation contract.
bindingParameters
A collection of binding parameters.

See Also

Reference

OperationMessageFilterAttributeBase Class
OperationMessageFilterAttributeBase Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyClientBehavior Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > OperationMessageFilterAttributeBase Class : ApplyClientBehavior Method

operationDescription
A description of the associated operation.
clientOperation
An instance of ClientOperation used to modify or extend the execution behavior of a specific contract operation in a client object or client channel object.
Implements the IOperationBehavior.ApplyClientBehavior method.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyClientBehavior( _
   ByVal operationDescription As OperationDescription, _
   ByVal clientOperation As ClientOperation _
)
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
Dim operationDescription As OperationDescription
Dim clientOperation As ClientOperation

instance.ApplyClientBehavior(operationDescription, clientOperation)
C#
public virtual void ApplyClientBehavior(
   OperationDescription operationDescription,
   ClientOperation clientOperation
)
Delphi
public procedure ApplyClientBehavior(
    operationDescription: OperationDescription;
    clientOperation: ClientOperation
); virtual;
JScript
public function ApplyClientBehavior(
   operationDescription : OperationDescription,
   clientOperation : ClientOperation
);
Managed Extensions for C++
public: virtual void ApplyClientBehavior(
   OperationDescription* operationDescription,
   ClientOperation* clientOperation
)
C++/CLI
public:
virtual void ApplyClientBehavior(
   OperationDescription^ operationDescription,
   ClientOperation^ clientOperation
)

Parameters

operationDescription
A description of the associated operation.
clientOperation
An instance of ClientOperation used to modify or extend the execution behavior of a specific contract operation in a client object or client channel object.

See Also

Reference

OperationMessageFilterAttributeBase Class
OperationMessageFilterAttributeBase Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyDispatchBehavior Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > OperationMessageFilterAttributeBase Class : ApplyDispatchBehavior Method

operationDescription
A description of the associated operation.
dispatchOperation
An instance of DispatchOperation used to modify or extend the execution behavior of a specific service operation in a service endpoint.
Implements the IOperationBehavior.ApplyDispatchBehavior method.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyDispatchBehavior( _
   ByVal operationDescription As OperationDescription, _
   ByVal dispatchOperation As DispatchOperation _
)
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
Dim operationDescription As OperationDescription
Dim dispatchOperation As DispatchOperation

instance.ApplyDispatchBehavior(operationDescription, dispatchOperation)
C#
public virtual void ApplyDispatchBehavior(
   OperationDescription operationDescription,
   DispatchOperation dispatchOperation
)
Delphi
public procedure ApplyDispatchBehavior(
    operationDescription: OperationDescription;
    dispatchOperation: DispatchOperation
); virtual;
JScript
public function ApplyDispatchBehavior(
   operationDescription : OperationDescription,
   dispatchOperation : DispatchOperation
);
Managed Extensions for C++
public: virtual void ApplyDispatchBehavior(
   OperationDescription* operationDescription,
   DispatchOperation* dispatchOperation
)
C++/CLI
public:
virtual void ApplyDispatchBehavior(
   OperationDescription^ operationDescription,
   DispatchOperation^ dispatchOperation
)

Parameters

operationDescription
A description of the associated operation.
dispatchOperation
An instance of DispatchOperation used to modify or extend the execution behavior of a specific service operation in a service endpoint.

See Also

Reference

OperationMessageFilterAttributeBase Class
OperationMessageFilterAttributeBase Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > OperationMessageFilterAttributeBase Class : Match Method

message
The incoming message to try to associate to the local operation.
When implemented in a derived class, it tries to associate the incoming message with the local operation.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Match( _
   ByRef message As Message _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
Dim message As Message
Dim value As Boolean

value = instance.Match(message)
C#
public abstract bool Match(
   ref Message message
)
Delphi
public function Match(
   var  message: Message
): Boolean; abstract;
JScript
public __abstract function Match(
   message : Message
) : boolean;
Managed Extensions for C++
public: abstract bool Match(
   ref Message* message
)
C++/CLI
public:
abstract bool Match(
   Message^% message
)

Parameters

message
The incoming message to try to associate to the local operation.

Return Value

Returns true if the incoming message is associated to the local operation; otherwise false.

Remarks

Within this method the filter can always evaluate the header of the message. While it can evaluate the body of the message only if it is buffered. Implementations should return true if the message is associated with the represented local operation, otherwise false.

The message is provided ByRef, this allows substitution of the original message with a wrapper, buffered copy or any other instance of the Message class. In such cases the subsequent filters will receive the new substitute message regardless of what value this method returns.

See Also

Reference

OperationMessageFilterAttributeBase Class
OperationMessageFilterAttributeBase Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Validate Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > OperationMessageFilterAttributeBase Class : Validate Method

operationDescription
A description of the associated operation.
Implements the IOperationBehavior.Validate method.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Validate( _
   ByVal operationDescription As OperationDescription _
)
Visual Basic (Usage) Copy Code
Dim instance As OperationMessageFilterAttributeBase
Dim operationDescription As OperationDescription

instance.Validate(operationDescription)
C#
public virtual void Validate(
   OperationDescription operationDescription
)
Delphi
public procedure Validate(
    operationDescription: OperationDescription
); virtual;
JScript
public function Validate(
   operationDescription : OperationDescription
);
Managed Extensions for C++
public: virtual void Validate(
   OperationDescription* operationDescription
)
C++/CLI
public:
virtual void Validate(
   OperationDescription^ operationDescription
)

Parameters

operationDescription
A description of the associated operation.

See Also

Reference

OperationMessageFilterAttributeBase Class
OperationMessageFilterAttributeBase Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QualifiedNameMessageFilterAttribute Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameMessageFilterAttribute Class

Associates the message to the local operation by evaluating the qualified name of the first element in the request body.

Object Model

QualifiedNameMessageFilterAttribute Class

Syntax

Visual Basic (Declaration)
Public Class QualifiedNameMessageFilterAttribute
   Inherits System.Attribute
   Implements IOperationMessageFilter
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
C#
public class QualifiedNameMessageFilterAttribute : System.Attribute, IOperationMessageFilter
Delphi
public class QualifiedNameMessageFilterAttribute = class(System.Attribute, IOperationMessageFilter)
JScript
public class QualifiedNameMessageFilterAttribute extends System.Attribute implements IOperationMessageFilter
Managed Extensions for C++
public __gc class QualifiedNameMessageFilterAttribute : public System.Attribute, IOperationMessageFilter
C++/CLI
public ref class QualifiedNameMessageFilterAttribute : public System.Attribute, IOperationMessageFilter

Remarks

This class is used by QualifiedNameOperationSelectorAttribute and CustomOperationSelectorAttribute to dispatch messages based on the qualified name of the first element in the request body. It implements the IOperationMessageFilter interface in order to attach itself into the service endpoint as an operation behavior. By analyzing the service contracts it automatically decides what qualified name the first element of message body is expected for the local operation. If the incoming message matches the qualified name represented by this attribute, it will be dispatched to the operation it represents.

During evaluation of the message body, the message does not get buffered. This behavior is compatible with the streaming transfer mode.

There is also ability to override the automatically obtained qualified name by setting the NamespaceURI and LocalName properties. Unless you need to override it, you don't need to assign this attribute to the operation of the contract marked with QualifiedNameOperationSelectorAttribute as this will be done automatically.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.QualifiedNameMessageFilterAttribute

See Also

Reference

QualifiedNameMessageFilterAttribute Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
QualifiedNameMessageFilterAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameMessageFilterAttribute Class

The following tables list the members exposed by QualifiedNameMessageFilterAttribute.

Public Constructors

 | Name | Description
public Constructor | QualifiedNameMessageFilterAttribute Constructor | Initializes a new instance of QualifiedNameMessageFilterAttribute class.
Top

Public Properties

 | Name | Description
public Property | LocalName | The local name of the qualified name to match.
public Property | NamespaceURI | The namespace URI of the qualified name to match.
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

QualifiedNameMessageFilterAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QualifiedNameMessageFilterAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : QualifiedNameMessageFilterAttribute Constructor

Initializes a new instance of QualifiedNameMessageFilterAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New QualifiedNameMessageFilterAttribute()
C#
public QualifiedNameMessageFilterAttribute()
Delphi
public QualifiedNameMessageFilterAttribute();
JScript
public function QualifiedNameMessageFilterAttribute();
Managed Extensions for C++
public: QualifiedNameMessageFilterAttribute();
C++/CLI
public:
QualifiedNameMessageFilterAttribute();

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
QualifiedNameMessageFilterAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameMessageFilterAttribute Class

For a list of all members of this type, see QualifiedNameMessageFilterAttribute members.

Public Properties

 | Name | Description
public Property | LocalName | The local name of the qualified name to match.
public Property | NamespaceURI | The namespace URI of the qualified name to match.
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

QualifiedNameMessageFilterAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalName Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : LocalName Property

The local name of the qualified name to match.

Syntax

Visual Basic (Declaration)
Public Property LocalName As String
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
Dim value As String

instance.LocalName = value

value = instance.LocalName
C#
public string LocalName {get; set;}
Delphi
public read-write property LocalName: String;
JScript
public function get,set LocalName : String
Managed Extensions for C++
public: __property string* get_LocalName();
public: __property void set_LocalName(
   string* value
);
C++/CLI
public:
property String^ LocalName {
   String^ get();
   void set (    String^ value);
}

Remarks

Set this property to the local name of the qualified name to be matched by this message filter.

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NamespaceURI Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : NamespaceURI Property

The namespace URI of the qualified name to match.

Syntax

Visual Basic (Declaration)
Public Property NamespaceURI As String
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
Dim value As String

instance.NamespaceURI = value

value = instance.NamespaceURI
C#
public string NamespaceURI {get; set;}
Delphi
public read-write property NamespaceURI: String;
JScript
public function get,set NamespaceURI : String
Managed Extensions for C++
public: __property string* get_NamespaceURI();
public: __property void set_NamespaceURI(
   string* value
);
C++/CLI
public:
property String^ NamespaceURI {
   String^ get();
   void set (    String^ value);
}

Remarks

Set this property to the namespace URI of the qualified name to be matched by this message filter.

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QualifiedNameOperationSelectorAttribute Class
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameOperationSelectorAttribute Class

Provides an alternative mechanism of dispatching messages by the qualified name of the first element in the request body.

Object Model

QualifiedNameOperationSelectorAttribute Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class QualifiedNameOperationSelectorAttribute
   Inherits CustomOperationSelectorAttribute
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameOperationSelectorAttribute
C#
public sealed class QualifiedNameOperationSelectorAttribute : CustomOperationSelectorAttribute
Delphi
public class QualifiedNameOperationSelectorAttribute = class(CustomOperationSelectorAttribute)sealed;
JScript
public sealed class QualifiedNameOperationSelectorAttribute extends CustomOperationSelectorAttribute
Managed Extensions for C++
public __gc __sealed class QualifiedNameOperationSelectorAttribute : public CustomOperationSelectorAttribute
C++/CLI
public ref class QualifiedNameOperationSelectorAttribute sealed : public CustomOperationSelectorAttribute

Remarks

By applying this attribute either to the service implementation or to the contract definition you can make WCF dispatch messages based on the qualified name of the first element of the message body instead of the SOAP envelope action header.

This functionality is useful with POX messaging since it doesn't use a SOAP envelope, as well as when the service needs to dispatch SOAP messages that don't include a WS-Addressing header or don't specify a SOAPAction.

The QualifiedNameOperationSelectorAttribute is derived from CustomOperationSelectorAttribute and can be used in combination with attributes that implement IOperationMessageFilter. By implementing this interface you can define your own criteria for message dispatching. These attributes can be applied to methods that represent Web Services operations. The QualifiedNameOperationSelectorAttribute tries to match the message to any of the criteria specified in the QualifiedNameMessageFilterAttribute or IOperationMessageFilter attributes, otherwise it tries to use the default dispatching mechanism.

Inheritance Hierarchy

System.Object
System.Attribute
Noemax.WCFX.Behaviors.CustomOperationSelectorAttribute
Noemax.WCFX.Behaviors.QualifiedNameOperationSelectorAttribute

See Also

Reference

QualifiedNameOperationSelectorAttribute Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
QualifiedNameOperationSelectorAttribute Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameOperationSelectorAttribute Class

The following tables list the members exposed by QualifiedNameOperationSelectorAttribute.

Public Constructors

 | Name | Description
public Constructor | QualifiedNameOperationSelectorAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
protected Method | PropogateMessageFilters | Overridden. Provides the operations of the specified contract with qualified name based message filters.
Top

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QualifiedNameOperationSelectorAttribute Constructor
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameOperationSelectorAttribute Class : QualifiedNameOperationSelectorAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New QualifiedNameOperationSelectorAttribute()
C#
public QualifiedNameOperationSelectorAttribute()
Delphi
public QualifiedNameOperationSelectorAttribute();
JScript
public function QualifiedNameOperationSelectorAttribute();
Managed Extensions for C++
public: QualifiedNameOperationSelectorAttribute();
C++/CLI
public:
QualifiedNameOperationSelectorAttribute();

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
QualifiedNameOperationSelectorAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
QualifiedNameOperationSelectorAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameOperationSelectorAttribute Class

For a list of all members of this type, see QualifiedNameOperationSelectorAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

Protected Methods

 | Name | Description
protected Method | PropogateMessageFilters | Overridden. Provides the operations of the specified contract with qualified name based message filters.
Top

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PropogateMessageFilters Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameOperationSelectorAttribute Class : PropogateMessageFilters Method

contractDescription
The contract description.
Provides the operations of the specified contract with qualified name based message filters.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Sub PropogateMessageFilters( _
   ByVal contractDescription As ContractDescription _
)
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameOperationSelectorAttribute
Dim contractDescription As ContractDescription

instance.PropogateMessageFilters(contractDescription)
C#
protected override void PropogateMessageFilters(
   ContractDescription contractDescription
)
Delphi
protected procedure PropogateMessageFilters(
    contractDescription: ContractDescription
); override;
JScript
protected override function PropogateMessageFilters(
   contractDescription : ContractDescription
);
Managed Extensions for C++
protected: void PropogateMessageFilters(
   ContractDescription* contractDescription
) override
C++/CLI
protected:
void PropogateMessageFilters(
   ContractDescription^ contractDescription
) override

Parameters

contractDescription
The contract description.

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
QualifiedNameOperationSelectorAttribute Members
Base Implementation in PropogateMessageFilters


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IOperationMessageFilter Interface
Members See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : IOperationMessageFilter Interface

Defines an interface to be implemented by the custom message filter attribute which can be used to modify the message dispatching behavior.

Syntax

Visual Basic (Declaration)
Public Interface IOperationMessageFilter
Visual Basic (Usage) Copy Code
Dim instance As IOperationMessageFilter
C#
public interface IOperationMessageFilter
Delphi
public interface IOperationMessageFilter
JScript
public interface IOperationMessageFilter
Managed Extensions for C++
public __gc __interface IOperationMessageFilter
C++/CLI
public interface class IOperationMessageFilter

Remarks

You can create an attribute that implements the IOperationMessageFilter interface and use it in combination with the QualifiedNameOperationSelectorAttribute to provide the service with your own criteria for dispatching messages based on the content of their header or body. The OperationMessageFilterAttributeBase class simplifies the creation of a custom message filter attribute. Prefer deriving this class to creating your own implementation of IOperationMessageFilter.

See Also

Reference

IOperationMessageFilter Members
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
IOperationMessageFilter Interface Members
See Also Methods Send Feedback
Noemax.WCFX.Behaviors Namespace : IOperationMessageFilter Interface

The following tables list the members exposed by IOperationMessageFilter.

Public Methods

 | Name | Description
Method | Match | When implemented, tries to associate the incoming message with the local operation.
Top

See Also

Reference

IOperationMessageFilter Interface
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
IOperationMessageFilter Interface Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : IOperationMessageFilter Interface

For a list of all members of this type, see IOperationMessageFilter members.

Public Methods

 | Name | Description
Method | Match | When implemented, tries to associate the incoming message with the local operation.
Top

See Also

Reference

IOperationMessageFilter Interface
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > IOperationMessageFilter Interface : Match Method

message
The incoming message to try to associate to the local operation.
When implemented, tries to associate the incoming message with the local operation.

Syntax

Visual Basic (Declaration)
Function Match( _
   ByRef message As Message _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IOperationMessageFilter
Dim message As Message
Dim value As Boolean

value = instance.Match(message)
C#
bool Match(
   ref Message message
)
Delphi
function Match(
   var  message: Message
): Boolean;
JScript
function Match(
   message : Message
) : boolean;
Managed Extensions for C++
bool Match(
   ref Message* message
)
C++/CLI
bool Match(
   Message^% message
)

Parameters

message
The incoming message to try to associate to the local operation.

Return Value

Returns true if message is associated to the local operation; otherwise false.

Remarks

Within this method the filter can always evaluate the header of the message, while it can evaluate the body of the message only if it is buffered. Implementations should return true if the message is associated with the represented local operation, otherwise false.

The message is provided ByRef, thereby allowing substitution of the original message with a wrapper, buffered copy or any other instance of the Message class. In such cases the subsequent filters will receive the new substitute message regardless of what value this method returns.

See Also

Reference

IOperationMessageFilter Interface
IOperationMessageFilter Members


%%ItemTitle%%

Noemax.WCFX.Channels Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | BasicSoapTcpBinding | WS-I Basic Profile 1.1 conformant SOAP/TCP binding.
Class | CompressionBindingElement | This binding element specifies that compression will be applied on the messages exchanged through the channel.
Class | CompressionStreamBindingElement | Respresents a stream upgrade that provides transport level compression.
Class | ContentNegotiationBindingElement | Provides HTTP transport with standard HTTP compression and support of multiple message encodings on the same SOAP/REST endpoint.
Class | DuplexSoapTcpBinding | Duplex SOAP/TCP binding.
Class | FiMessageEncodingBindingElement | The binding element which specifies that the Fast Infoset binary XML format is used to encode messages.
Class | HttpsViaProxyTransportBindingElement | The binding element that enables the use of BasicHttpBinding with an SSL/TLS accelator proxy.
Class | LiteHttpsTransportBindingElement | Represents the binding element used to specify an HTTPS transport with dynamic content negotiation for transmitting messages.
Class | LiteHttpTransportBindingElement | Represents the binding element used to specify an HTTP transport with dynamic content negotiation for transmitting messages.
Class | MessageEncodingBindingElementCollection | Represents a collection of MessageEncodingBindingElement.
Class | MessageStatisticsBindingElement | This binding element reports the size of messages produced by the message encoder specified by the binding. It is used only for support purposes during development and may not be used in production systems.
Class | PluggableMessageEncodingBindingElement | Represents the MessageEncodingBindingElement that can plug itself into an already configured Binding.
Class | SmartHttpBinding | Represents a binding that fully utilizes all standard capabilities of the HTTP transport to provide support for dynamic content negotiation.
Class | SoapTcpDuplexTransportBindingElement | Represents the binding element used to specify the SOAP/TCP transport for transmitting messages.
Class | SoapTcpTransportBindingElement | Represents the binding element used to specify the SOAP/TCP transport for transmitting messages.
Class | SocksSettings | Represents the SOCKS proxy settings.
Class | StreamEnhancerBindingElement | Represents a binding element that improves the performance of streaming through the transport connection by efficiently chunking the payload.

Enumerations

 | Enumeration | Description
Enumeration | CompressionAlgorithms | Defines a set of compression algorithms.
Enumeration | CompressionMethod | Defines the compression method to be used.
Enumeration | EncodingCompressionMethod | Defines a set of comrpession algorithms to be used by EnvelopBehavior.
Enumeration | FastInfosetSessionMode | Defines a set of stateful session encoding modes that may be used by the Fast Infoset message encoding.
Enumeration | SmartCompressionMode | Defines the mode of message compression.
Enumeration | SmartMessageEncodingMode | Defines the mode of smart message encoding.
Enumeration | SmartMessageEncodingSet | Defines the set of message encodings.
Enumeration | SocksAuthentication | Defines the type of authentication that the channel use in order to connect though the SOCKS proxy.
Enumeration | SocksVersion | Defines the version of the SOCKS proxy that the channel uses in order to reach the server.
Enumeration | TransferModeX | Defines the way in which data getting transfered by Noemax transports. This enumeration is used only on .NET CF platform as replacement for System.ServiceModel.Channels.TransferMode enumeration to extend it with additional transfer modes.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBinding Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : BasicSoapTcpBinding Class

WS-I Basic Profile 1.1 conformant SOAP/TCP binding.

Object Model

BasicSoapTcpBinding Class

Syntax

Visual Basic (Declaration)
Public Class BasicSoapTcpBinding
   Inherits System.ServiceModel.Channels.Binding
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
C#
public class BasicSoapTcpBinding : System.ServiceModel.Channels.Binding
Delphi
public class BasicSoapTcpBinding = class(System.ServiceModel.Channels.Binding)
JScript
public class BasicSoapTcpBinding extends System.ServiceModel.Channels.Binding
Managed Extensions for C++
public __gc class BasicSoapTcpBinding : public System.ServiceModel.Channels.Binding
C++/CLI
public ref class BasicSoapTcpBinding : public System.ServiceModel.Channels.Binding

Remarks

BasicSoapTcpBinding uses SOAP/TCP as duplex and stateful Fast Infoset as message encoding. Optionally, it can compress the payload using a selectable compression algorithm.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.Binding
Noemax.WCFX.Channels.BasicSoapTcpBinding
Noemax.WCFX.Channels.DuplexSoapTcpBinding

See Also

Reference

BasicSoapTcpBinding Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBinding Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : BasicSoapTcpBinding Class

The following tables list the members exposed by BasicSoapTcpBinding.

Public Constructors

 | Name | Description
public Constructor | BasicSoapTcpBinding Constructor | Initializes a new instance of the BasicSoapTcpBinding class.
Top

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Compression | Enables or disables GZIP payload compression.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload
public Property | MaxBufferPoolSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.
public Property | MaxBufferSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a received message that is processed by the binding.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | Overridden. Returns the URI scheme for the transport.
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | Overridden. Creates a collection with the binding elements for the binding.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | CreateTransportBindingElement | Creates a transport binding element.
protected Method | GetMessageVersion | Returns the message version to be used by the binding.
Top

See Also

Reference

BasicSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBinding Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : BasicSoapTcpBinding Constructor

Initializes a new instance of the BasicSoapTcpBinding class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BasicSoapTcpBinding()
C#
public BasicSoapTcpBinding()
Delphi
public BasicSoapTcpBinding();
JScript
public function BasicSoapTcpBinding();
Managed Extensions for C++
public: BasicSoapTcpBinding();
C++/CLI
public:
BasicSoapTcpBinding();

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBinding Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : BasicSoapTcpBinding Class

For a list of all members of this type, see BasicSoapTcpBinding members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | Overridden. Creates a collection with the binding elements for the binding.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | CreateTransportBindingElement | Creates a transport binding element.
protected Method | GetMessageVersion | Returns the message version to be used by the binding.
Top

See Also

Reference

BasicSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElements Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CreateBindingElements Method

Creates a collection with the binding elements for the binding.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateBindingElements() As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As BindingElementCollection

value = instance.CreateBindingElements()
C#
public override BindingElementCollection CreateBindingElements()
Delphi
public function CreateBindingElements(): BindingElementCollection; override;
JScript
public override function CreateBindingElements() : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* CreateBindingElements(); override
C++/CLI
public:
BindingElementCollection^ CreateBindingElements(); override

Return Value

The collection of System.ServiceModel.Channels.BindingElement that makes up the binding.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Base Implementation in CreateBindingElements


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateTransportBindingElement Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CreateTransportBindingElement Method

Creates a transport binding element.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateTransportBindingElement() As SoapTcpTransportBindingElement
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As SoapTcpTransportBindingElement

value = instance.CreateTransportBindingElement()
C#
protected virtual SoapTcpTransportBindingElement CreateTransportBindingElement()
Delphi
protected function CreateTransportBindingElement(): SoapTcpTransportBindingElement; virtual;
JScript
protected function CreateTransportBindingElement() : SoapTcpTransportBindingElement;
Managed Extensions for C++
protected: virtual SoapTcpTransportBindingElement* CreateTransportBindingElement();
C++/CLI
protected:
virtual SoapTcpTransportBindingElement^ CreateTransportBindingElement();

Return Value

The transport binding element.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetMessageVersion Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : GetMessageVersion Method

Returns the message version to be used by the binding.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetMessageVersion() As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As MessageVersion

value = instance.GetMessageVersion()
C#
protected virtual MessageVersion GetMessageVersion()
Delphi
protected function GetMessageVersion(): MessageVersion; virtual;
JScript
protected function GetMessageVersion() : MessageVersion;
Managed Extensions for C++
protected: virtual MessageVersion* GetMessageVersion();
C++/CLI
protected:
virtual MessageVersion^ GetMessageVersion();

Return Value

Returns the message version to be used by the binding.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBinding Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : BasicSoapTcpBinding Class

For a list of all members of this type, see BasicSoapTcpBinding members.

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Compression | Enables or disables GZIP payload compression.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload
public Property | MaxBufferPoolSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.
public Property | MaxBufferSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a received message that is processed by the binding.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | Overridden. Returns the URI scheme for the transport.
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

See Also

Reference

BasicSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Compression Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : Compression Property

Enables or disables GZIP payload compression.

Syntax

Visual Basic (Declaration)
Public Property Compression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Boolean

instance.Compression = value

value = instance.Compression
C#
public bool Compression {get; set;}
Delphi
public read-write property Compression: Boolean;
JScript
public function get,set Compression : boolean
Managed Extensions for C++
public: __property bool get_Compression();
public: __property void set_Compression(
   bool value
);
C++/CLI
public:
property bool Compression {
   bool get();
   void set (    bool value);
}

Property Value

true to enable compression of message payload; otherwise false;

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CompressionMethod Property

Gets and sets the algorithm used for compressing the message payload

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As CompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As CompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public CompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: CompressionMethod;
JScript
public function get,set CompressionMethod : CompressionMethod
Managed Extensions for C++
public: __property CompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   CompressionMethod value
);
C++/CLI
public:
property CompressionMethod CompressionMethod {
   CompressionMethod get();
   void set (    CompressionMethod value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : MaxBufferPoolSize Property

Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

If you receive more data than you can buffer, the data that exceeds the buffer size remains on the underlying socket until your buffer has room for the rest of the data.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : MaxBufferSize Property

Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
public function get,set MaxBufferSize : int
Managed Extensions for C++
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

The maximum number of bytes that are used to buffer incoming messages in memory. The default value is 65,536 bytes.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : MaxReceivedMessageSize Property

Gets or sets the maximum size for a received message that is processed by the binding.

Syntax

Visual Basic (Declaration)
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size (in bytes) for a received message that is processed by the binding. The default value is 65,536 bytes.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : MaxVocabularyStringLength Property

Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum string length specifies the maximum number of characters that a string value may contain in order to be added to the vocabulary. Longer values are not added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PermitStateful Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : PermitStateful Property

Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.

Syntax

Visual Basic (Declaration)
Public Property PermitStateful As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As Boolean

instance.PermitStateful = value

value = instance.PermitStateful
C#
public bool PermitStateful {get; set;}
Delphi
public read-write property PermitStateful: Boolean;
JScript
public function get,set PermitStateful : boolean
Managed Extensions for C++
public: __property bool get_PermitStateful();
public: __property void set_PermitStateful(
   bool value
);
C++/CLI
public:
property bool PermitStateful {
   bool get();
   void set (    bool value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : Scheme Property

Returns the URI scheme for the transport.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Property Value

Returns the URI scheme for the transport "soap.tcp".

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
public function get,set TransferMode : TransferMode
Managed Extensions for C++
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfile Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : WriterProfile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property WriterProfile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As XmlFastInfosetWriterProfile

instance.WriterProfile = value

value = instance.WriterProfile
C#
public XmlFastInfosetWriterProfile WriterProfile {get; set;}
Delphi
public read-write property WriterProfile: XmlFastInfosetWriterProfile;
JScript
public function get,set WriterProfile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_WriterProfile();
public: __property void set_WriterProfile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ WriterProfile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionBindingElement Class
Members Example See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionBindingElement Class

This binding element specifies that compression will be applied on the messages exchanged through the channel.

Object Model

CompressionBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class CompressionBindingElement
   Inherits System.ServiceModel.Channels.BindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
C#
public class CompressionBindingElement : System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
Delphi
public class CompressionBindingElement = class(System.ServiceModel.Channels.BindingElement, IPluggableBindingElement)
JScript
public class CompressionBindingElement extends System.ServiceModel.Channels.BindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class CompressionBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
C++/CLI
public ref class CompressionBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement

Example

[C#]

// Adding compression to custom binding

CustomBinding binding =new CustomBinding();

binding.Elements.Add(new CompressionBindingElement());

binding.Elements.Add(new FiMessageEncodingBindingElement());

binding.Elements.Add(new TcpTransportBindingElement());

[C#]

// Plugging in compression into standard binding

Binding binding = new WSHttpBinding();

CompressionBindingElement compression = new CompressionBindingElement();

binding = compression.PlugIn(binding);

Copy Code

  Remarks
This binding element must be added to the CustomBinding before the message encoding binding element, or can be plugged into an existing and already configured binding using the PlugIn method.

  Inheritance Hierarchy
System.Object
   System.ServiceModel.Channels.BindingElement
      Noemax.WCFX.Channels.CompressionBindingElement

  See Also
Reference
CompressionBindingElement Members

Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
CompressionBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : CompressionBindingElement Class

The following tables list the members exposed by CompressionBindingElement.

Public Constructors

 | Name | Description
public Constructor | CompressionBindingElement Constructor | Overloaded. Initializes a new instance of CompressionBindingElement.Initializes a new instance of CompressionBindingElement.
Top

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Injects the CompressionBindingElement into the provided binding element collection.
Top

See Also

Reference

CompressionBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : CompressionBindingElement Constructor

Initializes a new instance of CompressionBindingElement.Initializes a new instance of CompressionBindingElement.

Overload List

Overload | Description
CompressionBindingElement Constructor() | Initializes a new instance of CompressionBindingElement.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class > CompressionBindingElement Constructor : CompressionBindingElement Constructor()

Initializes a new instance of CompressionBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CompressionBindingElement()
C#
public CompressionBindingElement()
Delphi
public CompressionBindingElement();
JScript
public function CompressionBindingElement();
Managed Extensions for C++
public: CompressionBindingElement();
C++/CLI
public:
CompressionBindingElement();

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
CompressionBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionBindingElement Class

For a list of all members of this type, see CompressionBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Injects the CompressionBindingElement into the provided binding element collection.
Top

See Also

Reference

CompressionBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel factory creates.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
The BindingContext for the factory.
Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the factory.

Type Parameters

TChannel
The type of channel the channel factory creates.

Return Value

true if the specified channel factory stack can be built on the service; otherwise, false

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the channel listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the channel listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener can be built on the service; otherwise, false

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : Clone Method

Creates a new CompressionBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A CompressionBindingElement object with property values equal to those of the current element.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The typed object for which the method is querying.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : GetProperty<T> Method

context

The BindingContext for the binding element.

Returns a typed object requested, if present, from the appropriate layer in the binding element stack.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

The BindingContext for the binding element.

Type Parameters

T
The typed object for which the method is querying.

Return Value

The typed object T requested if it is present or a null reference (Nothing in Visual Basic) if it is not.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : PlugIn Method

Injects the CompressionBindingElement into the provided binding element collection.

Overload List

Overload | Description
PlugIn(BindingElementCollection) | Injects the CompressionBindingElement into the provided binding element collection.
PlugIn(Binding) | Creates a new binding based on the provided binding with the CompressionBindingElement injected into it.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The binding element collection to have the CompressionBindingElement injected into it.
Injects the CompressionBindingElement into the provided binding element collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The binding element collection to have the CompressionBindingElement injected into it.

Return Value

The binding element collection with the CompressionBindingElement injected into it.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The binding on which the the new binding will be based.
Creates a new binding based on the provided binding with the CompressionBindingElement injected into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The binding on which the the new binding will be based.

Return Value

The new binding which is based on the provided binding with the CompressionBindingElement injected into it.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
CompressionBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionBindingElement Class

For a list of all members of this type, see CompressionBindingElement members.

Public Properties

 | Name | Description
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload.
Top

See Also

Reference

CompressionBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionBindingElement Class : CompressionMethod Property

Gets and sets the algorithm used for compressing the message payload.

Syntax

Visual Basic (Declaration)
Public Property CompressionMethod As CompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As CompressionBindingElement
Dim value As CompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
public CompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: CompressionMethod;
JScript
public function get,set CompressionMethod : CompressionMethod
Managed Extensions for C++
public: __property CompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   CompressionMethod value
);
C++/CLI
public:
property CompressionMethod CompressionMethod {
   CompressionMethod get();
   void set (    CompressionMethod value);
}

See Also

Reference

CompressionBindingElement Class
CompressionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionStreamBindingElement Class

Respresents a stream upgrade that provides transport level compression.

Object Model

CompressionStreamBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class CompressionStreamBindingElement
   Inherits System.ServiceModel.Channels.StreamUpgradeBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
C#
public class CompressionStreamBindingElement : System.ServiceModel.Channels.StreamUpgradeBindingElement, IPluggableBindingElement
Delphi
public class CompressionStreamBindingElement = class(System.ServiceModel.Channels.StreamUpgradeBindingElement, IPluggableBindingElement)
JScript
public class CompressionStreamBindingElement extends System.ServiceModel.Channels.StreamUpgradeBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class CompressionStreamBindingElement : public System.ServiceModel.Channels.StreamUpgradeBindingElement, IPluggableBindingElement
C++/CLI
public ref class CompressionStreamBindingElement : public System.ServiceModel.Channels.StreamUpgradeBindingElement, IPluggableBindingElement

Remarks

This binding element should be used only with transports which support stream upgardes.

The CompressionStreamBindingElement supports the use of an underlying stream upgrade. For example, a security stream upgrade can be used as an underlying stream upgrade. In such cases the CompressionStreamBindingElement first upgrades the stream using the underlying stream upgrade and then applies its own upgrade.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.StreamUpgradeBindingElement
Noemax.WCFX.Channels.CompressionStreamBindingElement

See Also

Reference

CompressionStreamBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Class Members
See Also Methods Send Feedback
Noemax.WCFX.Channels Namespace : CompressionStreamBindingElement Class

The following tables list the members exposed by CompressionStreamBindingElement.

Public Constructors

 | Name | Description
public Constructor | CompressionStreamBindingElement Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden.
public Method | BuildChannelListener<TChannel> | Overridden.
public Method | BuildClientStreamUpgradeProvider | Overridden.
public Method | BuildServerStreamUpgradeProvider | Overridden.
public Method | CanBuildChannelFactory<TChannel> | Overridden.
public Method | CanBuildChannelListener<TChannel> | Overridden.
public Method | Clone | Overridden.
public Method | GetProperty<T> | Overridden.
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the CompressionStreamBindingElement injected into it.
Top

See Also

Reference

CompressionStreamBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : CompressionStreamBindingElement Constructor

Overload List

Overload | Description
CompressionStreamBindingElement Constructor() | Creates a new isntance of CompressionStreamBindingElement.
CompressionStreamBindingElement Constructor(StreamUpgradeBindingElement) | Creates a new isntance of CompressionStreamBindingElement.

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class > CompressionStreamBindingElement Constructor : CompressionStreamBindingElement Constructor()

Creates a new isntance of CompressionStreamBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CompressionStreamBindingElement()
C#
public CompressionStreamBindingElement()
Delphi
public CompressionStreamBindingElement();
JScript
public function CompressionStreamBindingElement();
Managed Extensions for C++
public: CompressionStreamBindingElement();
C++/CLI
public:
CompressionStreamBindingElement();

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Constructor(StreamUpgradeBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class > CompressionStreamBindingElement Constructor : CompressionStreamBindingElement Constructor(StreamUpgradeBindingElement)

innerUpgrade
The inner stream upgrade which will be applied to the transport stream, prior compression upgrade applied.
Creates a new isntance of CompressionStreamBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal innerUpgrade As StreamUpgradeBindingElement _
)
Visual Basic (Usage) Copy Code
Dim innerUpgrade As StreamUpgradeBindingElement

Dim instance As New CompressionStreamBindingElement(innerUpgrade)
C#
public CompressionStreamBindingElement(
   StreamUpgradeBindingElement innerUpgrade
)
Delphi
public CompressionStreamBindingElement(
    innerUpgrade: StreamUpgradeBindingElement
);
JScript
public function CompressionStreamBindingElement(
   innerUpgrade : StreamUpgradeBindingElement
);
Managed Extensions for C++
public: CompressionStreamBindingElement(
   StreamUpgradeBindingElement* innerUpgrade
)
C++/CLI
public:
CompressionStreamBindingElement(
   StreamUpgradeBindingElement^ innerUpgrade
)

Parameters

innerUpgrade
The inner stream upgrade which will be applied to the transport stream, prior compression upgrade applied.

Remarks

The CompressionStreamBindingElement supports the use of an underlying stream upgrade. For example, a security stream upgrade can be used as an underlying stream upgrade. In such cases the CompressionStreamBindingElement first upgrades the stream using the underlying stream upgrade and then applies its own upgrade.

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
CompressionStreamBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionStreamBindingElement Class

For a list of all members of this type, see CompressionStreamBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden.
public Method | BuildChannelListener<TChannel> | Overridden.
public Method | BuildClientStreamUpgradeProvider | Overridden.
public Method | BuildServerStreamUpgradeProvider | Overridden.
public Method | CanBuildChannelFactory<TChannel> | Overridden.
public Method | CanBuildChannelListener<TChannel> | Overridden.
public Method | Clone | Overridden.
public Method | GetProperty<T> | Overridden.
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the CompressionStreamBindingElement injected into it.
Top

See Also

Reference

CompressionStreamBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : BuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context

Type Parameters

TChannel

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : BuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildClientStreamUpgradeProvider Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : BuildClientStreamUpgradeProvider Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildClientStreamUpgradeProvider( _
   ByVal context As BindingContext _
) As StreamUpgradeProvider
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As StreamUpgradeProvider

value = instance.BuildClientStreamUpgradeProvider(context)
C#
public override StreamUpgradeProvider BuildClientStreamUpgradeProvider(
   BindingContext context
)
Delphi
public function BuildClientStreamUpgradeProvider(
    context: BindingContext
): StreamUpgradeProvider; override;
JScript
public override function BuildClientStreamUpgradeProvider(
   context : BindingContext
) : StreamUpgradeProvider;
Managed Extensions for C++
public: StreamUpgradeProvider* BuildClientStreamUpgradeProvider(
   BindingContext* context
) override
C++/CLI
public:
StreamUpgradeProvider^ BuildClientStreamUpgradeProvider(
   BindingContext^ context
) override

Parameters

context

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in BuildClientStreamUpgradeProvider


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildServerStreamUpgradeProvider Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : BuildServerStreamUpgradeProvider Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildServerStreamUpgradeProvider( _
   ByVal context As BindingContext _
) As StreamUpgradeProvider
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As StreamUpgradeProvider

value = instance.BuildServerStreamUpgradeProvider(context)
C#
public override StreamUpgradeProvider BuildServerStreamUpgradeProvider(
   BindingContext context
)
Delphi
public function BuildServerStreamUpgradeProvider(
    context: BindingContext
): StreamUpgradeProvider; override;
JScript
public override function BuildServerStreamUpgradeProvider(
   context : BindingContext
) : StreamUpgradeProvider;
Managed Extensions for C++
public: StreamUpgradeProvider* BuildServerStreamUpgradeProvider(
   BindingContext* context
) override
C++/CLI
public:
StreamUpgradeProvider^ BuildServerStreamUpgradeProvider(
   BindingContext^ context
) override

Parameters

context

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in BuildServerStreamUpgradeProvider


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : CanBuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context

Type Parameters

TChannel

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : CanBuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : GetProperty<T> Method

context

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

Type Parameters

T

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class : PlugIn Method

Creates a new binding based on the provided binding with the CompressionStreamBindingElement injected into it.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new binding based on the provided binding with the CompressionStreamBindingElement injected into it.
PlugIn(BindingElementCollection) | Injects the CompressionStreamBindingElement into the provided binding element collection.

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The binding on which the the new binding will be based.
Creates a new binding based on the provided binding with the CompressionStreamBindingElement injected into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The binding on which the the new binding will be based.

Return Value

The new binding which is based on the provided binding with the CompressionStreamBindingElement injected into it.

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > CompressionStreamBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The binding element collection to have the CompressionStreamBindingElement injected into it.
Injects the CompressionStreamBindingElement into the provided binding element collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionStreamBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The binding element collection to have the CompressionStreamBindingElement injected into it.

Return Value

The binding element collection with the CompressionStreamBindingElement injected into it.

See Also

Reference

CompressionStreamBindingElement Class
CompressionStreamBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : ContentNegotiationBindingElement Class

Provides HTTP transport with standard HTTP compression and support of multiple message encodings on the same SOAP/REST endpoint.

Object Model

ContentNegotiationBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class ContentNegotiationBindingElement
   Inherits System.ServiceModel.Channels.BindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
C#
public class ContentNegotiationBindingElement : System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
Delphi
public class ContentNegotiationBindingElement = class(System.ServiceModel.Channels.BindingElement, IPluggableBindingElement)
JScript
public class ContentNegotiationBindingElement extends System.ServiceModel.Channels.BindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class ContentNegotiationBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
C++/CLI
public ref class ContentNegotiationBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement

Remarks

When this binding element is added to the binding, it provides the HTTP transport with a collection of alternative message encodings and a standard HTTP compression using GZIP, DEFLATE, LMZA, LZF or LZF3 compression methods.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.ContentNegotiationBindingElement

See Also

Reference

ContentNegotiationBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : ContentNegotiationBindingElement Class

The following tables list the members exposed by ContentNegotiationBindingElement.

Public Constructors

 | Name | Description
public Constructor | ContentNegotiationBindingElement Constructor | Overloaded. Initializes a new instance of the ContentNegotiationBindingElement class.
Top

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the compression mode to be used by this binding.
public Property | CompressionThreshold | Gets and sets the minimal size of the payload to be compressed, if compression is enabled.
public Property | ForceStreamedCompression | If set to true the compression and decompression of the message payload will always be performed in streamed mode, irrespecitve of the transport settings.
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.
public Property | ZlibHeader | Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the binding element can build a channel factory for a specific type of channel.
public Method | Clone | Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | Overridden. Gets a property from the specified BindingContext.
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the ContentNegotiationBindingElement injected into it.
Top

See Also

Reference

ContentNegotiationBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : ContentNegotiationBindingElement Constructor

Initializes a new instance of the ContentNegotiationBindingElement class.

Overload List

Overload | Description
ContentNegotiationBindingElement Constructor() | Initializes a new instance of the ContentNegotiationBindingElement class.
ContentNegotiationBindingElement Constructor(ContentNegotiationBindingElement) | Initializes a new instance of the ContentNegotiationBindingElement class.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class > ContentNegotiationBindingElement Constructor : ContentNegotiationBindingElement Constructor()

Initializes a new instance of the ContentNegotiationBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ContentNegotiationBindingElement()
C#
public ContentNegotiationBindingElement()
Delphi
public ContentNegotiationBindingElement();
JScript
public function ContentNegotiationBindingElement();
Managed Extensions for C++
public: ContentNegotiationBindingElement();
C++/CLI
public:
ContentNegotiationBindingElement();

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Constructor(ContentNegotiationBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class > ContentNegotiationBindingElement Constructor : ContentNegotiationBindingElement Constructor(ContentNegotiationBindingElement)

source

An instance of the ContentNegotiationBindingElement class.

Initializes a new instance of the ContentNegotiationBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As ContentNegotiationBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As ContentNegotiationBindingElement

Dim instance As New ContentNegotiationBindingElement(source)
C#
public ContentNegotiationBindingElement(
   ContentNegotiationBindingElement source
)
Delphi
public ContentNegotiationBindingElement(
    source: ContentNegotiationBindingElement
);
JScript
public function ContentNegotiationBindingElement(
   source : ContentNegotiationBindingElement
);
Managed Extensions for C++
public: ContentNegotiationBindingElement(
   ContentNegotiationBindingElement* source
)
C++/CLI
public:
ContentNegotiationBindingElement(
   ContentNegotiationBindingElement^ source
)

Parameters

source

An instance of the ContentNegotiationBindingElement class.

Remarks

This method is a copy constructor used to clone the binding element.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : ContentNegotiationBindingElement Class

For a list of all members of this type, see ContentNegotiationBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the binding element can build a channel factory for a specific type of channel.
public Method | Clone | Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | Overridden. Gets a property from the specified BindingContext.
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the ContentNegotiationBindingElement injected into it.
Top

See Also

Reference

ContentNegotiationBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
Type of channel factory.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : BuildChannelFactory<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.
Creates a channel factory that can be used to create a channel.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.

Type Parameters

TChannel
Type of channel factory.

Return Value

A channel factory of the specified type.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
Type of channel listener.
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : BuildChannelListener<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.
Creates a channel listener of the specified type.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.

Type Parameters

TChannel
Type of channel listener.

Return Value

A channel listener of the specified type.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context

Type Parameters

TChannel

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CanBuildChannelListener<TChannel> Method

context
Returns a value that indicates whether the binding element can build a channel factory for a specific type of channel.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : Clone Method

Creates a copy of the current binding element.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The property to get.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : GetProperty<T> Method

context
A BindingContext.
Gets a property from the specified BindingContext.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context
A BindingContext.

Type Parameters

T
The property to get.

Return Value

The property from the specified BindingContext.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : PlugIn Method

Creates a new binding based on the provided binding with the ContentNegotiationBindingElement injected into it.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new binding based on the provided binding with the ContentNegotiationBindingElement injected into it.
PlugIn(BindingElementCollection) | Injects the ContentNegotiationBindingElement into the provided binding element collection.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The binding on which the the new binding will be based.
Creates a new binding based on the provided binding with the ContentNegotiationBindingElement injected into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The binding on which the the new binding will be based.

Return Value

The new binding which is based on the provided binding with the ContentNegotiationBindingElement injected into it.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The binding element collection to have the ContentNegotiationBindingElement injected into it.
Injects the ContentNegotiationBindingElement into the provided binding element collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The binding element collection to have the ContentNegotiationBindingElement injected into it.

Return Value

The binding element collection with the ContentNegotiationBindingElement injected into it.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ContentNegotiationBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : ContentNegotiationBindingElement Class

For a list of all members of this type, see ContentNegotiationBindingElement members.

Public Properties

 | Name | Description
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the compression mode to be used by this binding.
public Property | CompressionThreshold | Gets and sets the minimal size of the payload to be compressed, if compression is enabled.
public Property | ForceStreamedCompression | If set to true the compression and decompression of the message payload will always be performed in streamed mode, irrespecitve of the transport settings.
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.
public Property | ZlibHeader | Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.
Top

See Also

Reference

ContentNegotiationBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CompressionMode Property

Gets and sets the compression mode to be used by this binding.

Syntax

Visual Basic (Declaration)
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

Remarks

The default value of this property is SmartCompressionMode.Pessimistic.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionThreshold Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : CompressionThreshold Property

Gets and sets the minimal size of the payload to be compressed, if compression is enabled.

Syntax

Visual Basic (Declaration)
Public Property CompressionThreshold As Integer
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As Integer

instance.CompressionThreshold = value

value = instance.CompressionThreshold
C#
public int CompressionThreshold {get; set;}
Delphi
public read-write property CompressionThreshold: Integer;
JScript
public function get,set CompressionThreshold : int
Managed Extensions for C++
public: __property int get_CompressionThreshold();
public: __property void set_CompressionThreshold(
   int value
);
C++/CLI
public:
property int CompressionThreshold {
   int get();
   void set (    int value);
}

Remarks

Specifies the minimal size of the payload that channel will compress. If the size of the payload is lower than specified value, compression will not be applied to it.

The default value of this property is 0, all payload will be compressed irrespective of it's size.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ForceStreamedCompression Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : ForceStreamedCompression Property

If set to true the compression and decompression of the message payload will always be performed in streamed mode, irrespecitve of the transport settings.

Syntax

Visual Basic (Declaration)
Public Property ForceStreamedCompression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As Boolean

instance.ForceStreamedCompression = value

value = instance.ForceStreamedCompression
C#
public bool ForceStreamedCompression {get; set;}
Delphi
public read-write property ForceStreamedCompression: Boolean;
JScript
public function get,set ForceStreamedCompression : boolean
Managed Extensions for C++
public: __property bool get_ForceStreamedCompression();
public: __property void set_ForceStreamedCompression(
   bool value
);
C++/CLI
public:
property bool ForceStreamedCompression {
   bool get();
   void set (    bool value);
}

Remarks

Setting this property to true can improve performace and reduce memory consumption in cases when large payloads getting exchanged through the channel. However, some bindings might not support streamed compression, in such cases this property must be set to false.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : MessageEncodingMode Property

Gets and sets the message encoding mode to be used by this binding.

Syntax

Visual Basic (Declaration)
Public Property MessageEncodingMode As SmartMessageEncodingMode
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As SmartMessageEncodingMode

instance.MessageEncodingMode = value

value = instance.MessageEncodingMode
C#
public SmartMessageEncodingMode MessageEncodingMode {get; set;}
Delphi
public read-write property MessageEncodingMode: SmartMessageEncodingMode;
JScript
public function get,set MessageEncodingMode : SmartMessageEncodingMode
Managed Extensions for C++
public: __property SmartMessageEncodingMode get_MessageEncodingMode();
public: __property void set_MessageEncodingMode(
   SmartMessageEncodingMode value
);
C++/CLI
public:
property SmartMessageEncodingMode MessageEncodingMode {
   SmartMessageEncodingMode get();
   void set (    SmartMessageEncodingMode value);
}

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodings Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : MessageEncodings Property

A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageEncodings As MessageEncodingBindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As MessageEncodingBindingElementCollection

value = instance.MessageEncodings
C#
public MessageEncodingBindingElementCollection MessageEncodings {get;}
Delphi
public read-only property MessageEncodings: MessageEncodingBindingElementCollection;
JScript
public function get MessageEncodings : MessageEncodingBindingElementCollection
Managed Extensions for C++
public: __property MessageEncodingBindingElementCollection* get_MessageEncodings();
C++/CLI
public:
property MessageEncodingBindingElementCollection^ MessageEncodings {
   MessageEncodingBindingElementCollection^ get();
}

Remarks

Collection should be populated with MessageEncodingBindingElement according to the rules specified in MessageEncodingBindingElementCollection.

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ZlibHeader Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > ContentNegotiationBindingElement Class : ZlibHeader Property

Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.

Syntax

Visual Basic (Declaration)
Public Property ZlibHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationBindingElement
Dim value As Boolean

instance.ZlibHeader = value

value = instance.ZlibHeader
C#
public bool ZlibHeader {get; set;}
Delphi
public read-write property ZlibHeader: Boolean;
JScript
public function get,set ZlibHeader : boolean
Managed Extensions for C++
public: __property bool get_ZlibHeader();
public: __property void set_ZlibHeader(
   bool value
);
C++/CLI
public:
property bool ZlibHeader {
   bool get();
   void set (    bool value);
}

See Also

Reference

ContentNegotiationBindingElement Class
ContentNegotiationBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBinding Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : DuplexSoapTcpBinding Class

Duplex SOAP/TCP binding.

Object Model

DuplexSoapTcpBinding Class

Syntax

Visual Basic (Declaration)
Public Class DuplexSoapTcpBinding
   Inherits BasicSoapTcpBinding
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
C#
public class DuplexSoapTcpBinding : BasicSoapTcpBinding
Delphi
public class DuplexSoapTcpBinding = class(BasicSoapTcpBinding)
JScript
public class DuplexSoapTcpBinding extends BasicSoapTcpBinding
Managed Extensions for C++
public __gc class DuplexSoapTcpBinding : public BasicSoapTcpBinding
C++/CLI
public ref class DuplexSoapTcpBinding : public BasicSoapTcpBinding

Remarks

DuplexSoapTcpBinding uses SOAP/TCP as duplex transport and stateful Fast Infoset as message encoding. Optionally, it can compress the payload using a selectable compression algorithm.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.Binding
Noemax.WCFX.Channels.BasicSoapTcpBinding
Noemax.WCFX.Channels.DuplexSoapTcpBinding

See Also

Reference

DuplexSoapTcpBinding Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBinding Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : DuplexSoapTcpBinding Class

The following tables list the members exposed by DuplexSoapTcpBinding.

Public Constructors

 | Name | Description
public Constructor | DuplexSoapTcpBinding Constructor | Creates new instance of BasicSoapTcpDuplexBinding.
Top

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Compression | Enables or disables GZIP payload compression. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxBufferPoolSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxBufferSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a received message that is processed by the binding. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | (Inherited from System.ServiceModel.Channels.Binding)
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | (Inherited from System.ServiceModel.Channels.Binding)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | CreateTransportBindingElement | Overridden. Creates the SoapTcpDuplexTransportBindingElement transport to be used by BasicSoapTcpDuplexBinding.
protected Method | GetMessageVersion | Overridden. Returns the message version to be used by the binding.
Top

See Also

Reference

DuplexSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBinding Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : DuplexSoapTcpBinding Constructor

Creates new instance of BasicSoapTcpDuplexBinding.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DuplexSoapTcpBinding()
C#
public DuplexSoapTcpBinding()
Delphi
public DuplexSoapTcpBinding();
JScript
public function DuplexSoapTcpBinding();
Managed Extensions for C++
public: DuplexSoapTcpBinding();
C++/CLI
public:
DuplexSoapTcpBinding();

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBinding Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : DuplexSoapTcpBinding Class

For a list of all members of this type, see DuplexSoapTcpBinding members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | (Inherited from System.ServiceModel.Channels.Binding)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | CreateTransportBindingElement | Overridden. Creates the SoapTcpDuplexTransportBindingElement transport to be used by BasicSoapTcpDuplexBinding.
protected Method | GetMessageVersion | Overridden. Returns the message version to be used by the binding.
Top

See Also

Reference

DuplexSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateTransportBindingElement Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : CreateTransportBindingElement Method

Creates the SoapTcpDuplexTransportBindingElement transport to be used by BasicSoapTcpDuplexBinding.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateTransportBindingElement() As SoapTcpTransportBindingElement
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As SoapTcpTransportBindingElement

value = instance.CreateTransportBindingElement()
C#
protected override SoapTcpTransportBindingElement CreateTransportBindingElement()
Delphi
protected function CreateTransportBindingElement(): SoapTcpTransportBindingElement; override;
JScript
protected override function CreateTransportBindingElement() : SoapTcpTransportBindingElement;
Managed Extensions for C++
protected: SoapTcpTransportBindingElement* CreateTransportBindingElement(); override
C++/CLI
protected:
SoapTcpTransportBindingElement^ CreateTransportBindingElement(); override

Return Value

The instance of SoapTcpDuplexTransportBindingElement.

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Base Implementation in CreateTransportBindingElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetMessageVersion Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : GetMessageVersion Method

Returns the message version to be used by the binding.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetMessageVersion() As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As MessageVersion

value = instance.GetMessageVersion()
C#
protected override MessageVersion GetMessageVersion()
Delphi
protected function GetMessageVersion(): MessageVersion; override;
JScript
protected override function GetMessageVersion() : MessageVersion;
Managed Extensions for C++
protected: MessageVersion* GetMessageVersion(); override
C++/CLI
protected:
MessageVersion^ GetMessageVersion(); override

Return Value

Returns the message version to be used by the binding.

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Base Implementation in GetMessageVersion


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Class
Members Example See Also Send Feedback
Noemax.WCFX.Channels Namespace : FiMessageEncodingBindingElement Class

The binding element which specifies that the Fast Infoset binary XML format is used to encode messages.

Object Model

FiMessageEncodingBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class FiMessageEncodingBindingElement
   Inherits PluggableMessageEncodingBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
C#
public class FiMessageEncodingBindingElement : PluggableMessageEncodingBindingElement, IPluggableBindingElement
Delphi
public class FiMessageEncodingBindingElement = class(PluggableMessageEncodingBindingElement, IPluggableBindingElement)
JScript
public class FiMessageEncodingBindingElement extends PluggableMessageEncodingBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class FiMessageEncodingBindingElement : public PluggableMessageEncodingBindingElement, IPluggableBindingElement
C++/CLI
public ref class FiMessageEncodingBindingElement : public PluggableMessageEncodingBindingElement, IPluggableBindingElement

Example

Binding binding = new WSHttpBinding();

FiMessageEncodingBindingElement fiEncoding = new FiMessageEncodingBindingElement();

binding = fiEncoding.PlugIn(binding);

Copy Code

  Remarks
This binding element specifies that the Fast Infoset binary XML format will be used as the message encoding. Fast Infoset is an efficient, standard-based cross-platform binary XML encoding that generally produces smaller encodings and improves parsing performance.

This binding element can be used with CustomBinding, or can be plugged into an already configured standard or custom binding using the PlugIn method.

  Inheritance Hierarchy
System.Object
   System.ServiceModel.Channels.BindingElement
      System.ServiceModel.Channels.MessageEncodingBindingElement
         Noemax.WCFX.Channels.PluggableMessageEncodingBindingElement
            Noemax.WCFX.Channels.FiMessageEncodingBindingElement

  See Also
Reference
FiMessageEncodingBindingElement Members

Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : FiMessageEncodingBindingElement Class

The following tables list the members exposed by FiMessageEncodingBindingElement.

Public Constructors

 | Name | Description
public Constructor | FiMessageEncodingBindingElement Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | MaxReadPoolSize | Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | MaxWritePoolSize | Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.
public Property | MessageVersion | Overridden. Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | ReaderQuotas | Gets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.
public Property | SessionMode | Gets and sets the stateful session encoding mode that will be used by the Fast Infoset message encoding.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new FiMessageEncodingBindingElement object initialized from the current one.
public Method | CreateMessageEncoderFactory | Overridden. Creates a factory for Fast Infoset message encoders.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding. (Inherited from Noemax.WCFX.Channels.PluggableMessageEncodingBindingElement)
Top

See Also

Reference

FiMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : FiMessageEncodingBindingElement Constructor

Overload List

Overload | Description
FiMessageEncodingBindingElement Constructor() | Initializes a new instance of FiMessageEncodingBindingElement.
FiMessageEncodingBindingElement Constructor(MessageVersion) | Initializes a new instance of FiMessageEncodingBindingElement.
FiMessageEncodingBindingElement Constructor(FiMessageEncodingBindingElement) | Initializes a new instance of FiMessageEncodingBindingElement cloning existing one.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class > FiMessageEncodingBindingElement Constructor : FiMessageEncodingBindingElement Constructor()

Initializes a new instance of FiMessageEncodingBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FiMessageEncodingBindingElement()
C#
public FiMessageEncodingBindingElement()
Delphi
public FiMessageEncodingBindingElement();
JScript
public function FiMessageEncodingBindingElement();
Managed Extensions for C++
public: FiMessageEncodingBindingElement();
C++/CLI
public:
FiMessageEncodingBindingElement();

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Constructor(MessageVersion)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class > FiMessageEncodingBindingElement Constructor : FiMessageEncodingBindingElement Constructor(MessageVersion)

messageVersion
The MessageVersion of new instance of FiMessageEncodingBindingElement.
Initializes a new instance of FiMessageEncodingBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal messageVersion As MessageVersion _
)
Visual Basic (Usage) Copy Code
Dim messageVersion As MessageVersion

Dim instance As New FiMessageEncodingBindingElement(messageVersion)
C#
public FiMessageEncodingBindingElement(
   MessageVersion messageVersion
)
Delphi
public FiMessageEncodingBindingElement(
    messageVersion: MessageVersion
);
JScript
public function FiMessageEncodingBindingElement(
   messageVersion : MessageVersion
);
Managed Extensions for C++
public: FiMessageEncodingBindingElement(
   MessageVersion* messageVersion
)
C++/CLI
public:
FiMessageEncodingBindingElement(
   MessageVersion^ messageVersion
)

Parameters

messageVersion
The MessageVersion of new instance of FiMessageEncodingBindingElement.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Constructor(FiMessageEncodingBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class > FiMessageEncodingBindingElement Constructor : FiMessageEncodingBindingElement Constructor(FiMessageEncodingBindingElement)

source
The instance of FiMessageEncodingBindingElement to clone.
Initializes a new instance of FiMessageEncodingBindingElement cloning existing one.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal source As FiMessageEncodingBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As FiMessageEncodingBindingElement

Dim instance As New FiMessageEncodingBindingElement(source)
C#
protected FiMessageEncodingBindingElement(
   FiMessageEncodingBindingElement source
)
Delphi
protected FiMessageEncodingBindingElement(
    source: FiMessageEncodingBindingElement
);
JScript
protected function FiMessageEncodingBindingElement(
   source : FiMessageEncodingBindingElement
);
Managed Extensions for C++
protected: FiMessageEncodingBindingElement(
   FiMessageEncodingBindingElement* source
)
C++/CLI
protected:
FiMessageEncodingBindingElement(
   FiMessageEncodingBindingElement^ source
)

Parameters

source
The instance of FiMessageEncodingBindingElement to clone.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : FiMessageEncodingBindingElement Class

For a list of all members of this type, see FiMessageEncodingBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new FiMessageEncodingBindingElement object initialized from the current one.
public Method | CreateMessageEncoderFactory | Overridden. Creates a factory for Fast Infoset message encoders.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding. (Inherited from Noemax.WCFX.Channels.PluggableMessageEncodingBindingElement)
Top

See Also

Reference

FiMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener stack can be built on the service; otherwise, false

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : Clone Method

Creates a new FiMessageEncodingBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

An FiMessageEncodingBindingElement object with property values equal to those of the current element.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateMessageEncoderFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : CreateMessageEncoderFactory Method

Creates a factory for Fast Infoset message encoders.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateMessageEncoderFactory() As MessageEncoderFactory
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As MessageEncoderFactory

value = instance.CreateMessageEncoderFactory()
C#
public override MessageEncoderFactory CreateMessageEncoderFactory()
Delphi
public function CreateMessageEncoderFactory(): MessageEncoderFactory; override;
JScript
public override function CreateMessageEncoderFactory() : MessageEncoderFactory;
Managed Extensions for C++
public: MessageEncoderFactory* CreateMessageEncoderFactory(); override
C++/CLI
public:
MessageEncoderFactory^ CreateMessageEncoderFactory(); override

Return Value

The MessageEncoderFactory that this binding element creates.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in CreateMessageEncoderFactory


%%PageItemTitle%%

T
The typed object for which the method is querying.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : GetProperty<T> Method

context

The BindingContext for the binding element.

Returns a typed object requested, if present, from the appropriate layer in the binding element stack.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

The BindingContext for the binding element.

Type Parameters

T
The typed object for which the method is querying.

Return Value

The typed object T requested if it is present or a null reference (Nothing in Visual Basic) if it is not.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : FiMessageEncodingBindingElement Class

For a list of all members of this type, see FiMessageEncodingBindingElement members.

Public Properties

 | Name | Description
public Property | MaxReadPoolSize | Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | MaxWritePoolSize | Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.
public Property | MessageVersion | Overridden. Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.
public Property | ReaderQuotas | Gets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.
public Property | SessionMode | Gets and sets the stateful session encoding mode that will be used by the Fast Infoset message encoding.
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
Top

See Also

Reference

FiMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReadPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : MaxReadPoolSize Property

Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.

Syntax

Visual Basic (Declaration)
Public Property MaxReadPoolSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As Integer

instance.MaxReadPoolSize = value

value = instance.MaxReadPoolSize
C#
public int MaxReadPoolSize {get; set;}
Delphi
public read-write property MaxReadPoolSize: Integer;
JScript
public function get,set MaxReadPoolSize : int
Managed Extensions for C++
public: __property int get_MaxReadPoolSize();
public: __property void set_MaxReadPoolSize(
   int value
);
C++/CLI
public:
property int MaxReadPoolSize {
   int get();
   void set (    int value);
}

Property Value

The number of readers in the pool. The default value is 64 readers.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that may be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum number of strings specifies up to how many strings may be added to the vocabulary. When this limit is reached, no more values are added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : MaxVocabularyStringLength Property

Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum string length specifies the maximum number of characters that a string value may contain in order to be added to the vocabulary. Longer values are not added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxWritePoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : MaxWritePoolSize Property

Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.

Syntax

Visual Basic (Declaration)
Public Property MaxWritePoolSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As Integer

instance.MaxWritePoolSize = value

value = instance.MaxWritePoolSize
C#
public int MaxWritePoolSize {get; set;}
Delphi
public read-write property MaxWritePoolSize: Integer;
JScript
public function get,set MaxWritePoolSize : int
Managed Extensions for C++
public: __property int get_MaxWritePoolSize();
public: __property void set_MaxWritePoolSize(
   int value
);
C++/CLI
public:
property int MaxWritePoolSize {
   int get();
   void set (    int value);
}

Property Value

The maximum number of writers to be kept in the pool. The default value is 16 writers.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : MessageVersion Property

Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.

Syntax

Visual Basic (Declaration)
Public Overrides Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As MessageVersion

instance.MessageVersion = value

value = instance.MessageVersion
C#
public override MessageVersion MessageVersion {get; set;}
Delphi
public read-write property MessageVersion: MessageVersion; override;
JScript
public override function get,set MessageVersion : MessageVersion
Managed Extensions for C++
public: __property MessageVersion* get_MessageVersion() override;
public: __property void set_MessageVersion(
   MessageVersion* value
) override;
C++/CLI
public:
property MessageVersion^ MessageVersion {
   MessageVersion^ get() override;
   void set (    MessageVersion^ value) override;
}

Remarks

The default MessageVersion for this constructor is the version of WS-Addressing that was submitted 10 August 2004 and SOAP 1.2.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members
Base Implementation in MessageVersion


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PermitStateful Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : PermitStateful Property

Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state.

Syntax

Visual Basic (Declaration)
Public Property PermitStateful As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As Boolean

instance.PermitStateful = value

value = instance.PermitStateful
C#
public bool PermitStateful {get; set;}
Delphi
public read-write property PermitStateful: Boolean;
JScript
public function get,set PermitStateful : boolean
Managed Extensions for C++
public: __property bool get_PermitStateful();
public: __property void set_PermitStateful(
   bool value
);
C++/CLI
public:
property bool PermitStateful {
   bool get();
   void set (    bool value);
}

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderQuotas Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : ReaderQuotas Property

Gets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReaderQuotas As XmlDictionaryReaderQuotas
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As XmlDictionaryReaderQuotas

value = instance.ReaderQuotas
C#
public XmlDictionaryReaderQuotas ReaderQuotas {get;}
Delphi
public read-only property ReaderQuotas: XmlDictionaryReaderQuotas;
JScript
public function get ReaderQuotas : XmlDictionaryReaderQuotas
Managed Extensions for C++
public: __property XmlDictionaryReaderQuotas* get_ReaderQuotas();
C++/CLI
public:
property XmlDictionaryReaderQuotas^ ReaderQuotas {
   XmlDictionaryReaderQuotas^ get();
}

Remarks

The complexity constraints protect against a class of denial of service (DOS) attacks that attempt to use message complexity to tie up endpoint processing resources. The properties that express these constraints and their default values are as follows:

  • MaxDepth = 32

  • MaxStringContentLength = 8192

  • MaxArrayLength = 16384

  • MaxBytesPerRead = 4096

  • MaxNameTableCharCount = 16384

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SessionMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : SessionMode Property

Gets and sets the stateful session encoding mode that will be used by the Fast Infoset message encoding.

Syntax

Visual Basic (Declaration)
Public Property SessionMode As FastInfosetSessionMode
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As FastInfosetSessionMode

instance.SessionMode = value

value = instance.SessionMode
C#
public FastInfosetSessionMode SessionMode {get; set;}
Delphi
public read-write property SessionMode: FastInfosetSessionMode;
JScript
public function get,set SessionMode : FastInfosetSessionMode
Managed Extensions for C++
public: __property FastInfosetSessionMode get_SessionMode();
public: __property void set_SessionMode(
   FastInfosetSessionMode value
);
C++/CLI
public:
property FastInfosetSessionMode SessionMode {
   FastInfosetSessionMode get();
   void set (    FastInfosetSessionMode value);
}

Remarks

The same FastInfosetSessionMode must be used on both communicating sides.

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfile Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : WriterProfile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property WriterProfile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim value As XmlFastInfosetWriterProfile

instance.WriterProfile = value

value = instance.WriterProfile
C#
public XmlFastInfosetWriterProfile WriterProfile {get; set;}
Delphi
public read-write property WriterProfile: XmlFastInfosetWriterProfile;
JScript
public function get,set WriterProfile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_WriterProfile();
public: __property void set_WriterProfile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ WriterProfile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : HttpsViaProxyTransportBindingElement Class

The binding element that enables the use of BasicHttpBinding with an SSL/TLS accelator proxy.

Object Model

HttpsViaProxyTransportBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class HttpsViaProxyTransportBindingElement
   Inherits System.ServiceModel.Channels.HttpTransportBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
C#
public class HttpsViaProxyTransportBindingElement : System.ServiceModel.Channels.HttpTransportBindingElement, IPluggableBindingElement
Delphi
public class HttpsViaProxyTransportBindingElement = class(System.ServiceModel.Channels.HttpTransportBindingElement, IPluggableBindingElement)
JScript
public class HttpsViaProxyTransportBindingElement extends System.ServiceModel.Channels.HttpTransportBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class HttpsViaProxyTransportBindingElement : public System.ServiceModel.Channels.HttpTransportBindingElement, IPluggableBindingElement
C++/CLI
public ref class HttpsViaProxyTransportBindingElement : public System.ServiceModel.Channels.HttpTransportBindingElement, IPluggableBindingElement

Remarks

When the BasicHttpBinding security mode is set to TransportWithMessageCredential, BasicHttpBinding enforces the use of transport security which introduces a lot of exrta overhead if the servers are proxied by and SSL/TLS accelerator proxy.

When this binding element is plugged into the BasicHttpBinding, it enables the server to avoiding extra overhead and receive client messages and credentials from the SSL/TLS accelerator proxy over an unsecured connection.

It should be used only on the server side, when transport security is provided by an SSL/TLS accelerator proxy.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
System.ServiceModel.Channels.HttpTransportBindingElement
Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement

See Also

Reference

HttpsViaProxyTransportBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : HttpsViaProxyTransportBindingElement Class

The following tables list the members exposed by HttpsViaProxyTransportBindingElement.

Public Constructors

 | Name | Description
public Constructor | HttpsViaProxyTransportBindingElement Constructor | Overloaded. Initializes a new instance of HttpsViaProxyTransportBindingElement.Initializes a new instance of HttpsViaProxyTransportBindingElement.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | AuthenticationScheme | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | BypassProxyOnLocal | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | DecompressionEnabled | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ExtendedProtectionPolicy | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | HostNameComparisonMode | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | KeepAliveEnabled | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | ProxyAddress | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ProxyAuthenticationScheme | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | Realm | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | Scheme | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | TransferMode | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | UnsafeConnectionNtlmAuthentication | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | UseDefaultWebProxy | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | BuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | Clone | Overridden. Creates a new HttpsViaProxyTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged into it.
Top

See Also

Reference

HttpsViaProxyTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : HttpsViaProxyTransportBindingElement Constructor

Initializes a new instance of HttpsViaProxyTransportBindingElement.Initializes a new instance of HttpsViaProxyTransportBindingElement.

Overload List

Overload | Description
HttpsViaProxyTransportBindingElement Constructor() | Initializes a new instance of HttpsViaProxyTransportBindingElement.
HttpsViaProxyTransportBindingElement Constructor(HttpsViaProxyTransportBindingElement) | Initializes a new instance of HttpsViaProxyTransportBindingElement.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class > HttpsViaProxyTransportBindingElement Constructor : HttpsViaProxyTransportBindingElement Constructor()

Initializes a new instance of HttpsViaProxyTransportBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New HttpsViaProxyTransportBindingElement()
C#
public HttpsViaProxyTransportBindingElement()
Delphi
public HttpsViaProxyTransportBindingElement();
JScript
public function HttpsViaProxyTransportBindingElement();
Managed Extensions for C++
public: HttpsViaProxyTransportBindingElement();
C++/CLI
public:
HttpsViaProxyTransportBindingElement();

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Constructor(HttpsViaProxyTransportBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class > HttpsViaProxyTransportBindingElement Constructor : HttpsViaProxyTransportBindingElement Constructor(HttpsViaProxyTransportBindingElement)

source
Initializes a new instance of HttpsViaProxyTransportBindingElement.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal source As HttpsViaProxyTransportBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As HttpsViaProxyTransportBindingElement

Dim instance As New HttpsViaProxyTransportBindingElement(source)
C#
protected HttpsViaProxyTransportBindingElement(
   HttpsViaProxyTransportBindingElement source
)
Delphi
protected HttpsViaProxyTransportBindingElement(
    source: HttpsViaProxyTransportBindingElement
);
JScript
protected function HttpsViaProxyTransportBindingElement(
   source : HttpsViaProxyTransportBindingElement
);
Managed Extensions for C++
protected: HttpsViaProxyTransportBindingElement(
   HttpsViaProxyTransportBindingElement* source
)
C++/CLI
protected:
HttpsViaProxyTransportBindingElement(
   HttpsViaProxyTransportBindingElement^ source
)

Parameters

source

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : HttpsViaProxyTransportBindingElement Class

For a list of all members of this type, see HttpsViaProxyTransportBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | BuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | Clone | Overridden. Creates a new HttpsViaProxyTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged into it.
Top

See Also

Reference

HttpsViaProxyTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : Clone Method

Creates a new HttpsViaProxyTransportBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

An HttpsViaProxyTransportBindingElement object with property values equal to those of the current element.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The typed object for which the method is querying.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : GetProperty<T> Method

context

The BindingContext for the binding element.

Returns a typed object requested, if present, from the appropriate layer in the binding element stack.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

The BindingContext for the binding element.

Type Parameters

T
The typed object for which the method is querying.

Return Value

The typed object T requested if it is present or a null reference (Nothing in Visual Basic) if it is not.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged into it.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged into it.
PlugIn(BindingElementCollection) | Creates a new BindingElementCollection based on the specified source, with this binding element plugged into it.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The binding to be used as source for the new CustomBinding, which will have this binding element plugged into it.
Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The binding to be used as source for the new CustomBinding, which will have this binding element plugged into it.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

collection
The collection to be used as source for the new BindingElementCollection, which will have this binding element plugged into it.
Creates a new BindingElementCollection based on the specified source, with this binding element plugged into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal collection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim collection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(collection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection collection
)
Delphi
public function PlugIn(
    collection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   collection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* collection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ collection
)

Parameters

collection
The collection to be used as source for the new BindingElementCollection, which will have this binding element plugged into it.

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpsTransportBindingElement Class

Represents the binding element used to specify an HTTPS transport with dynamic content negotiation for transmitting messages.

Object Model

LiteHttpsTransportBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class LiteHttpsTransportBindingElement
   Inherits System.ServiceModel.Channels.TransportBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
C#
public class LiteHttpsTransportBindingElement : System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
Delphi
public class LiteHttpsTransportBindingElement = class(System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement)
JScript
public class LiteHttpsTransportBindingElement extends System.ServiceModel.Channels.TransportBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class LiteHttpsTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
C++/CLI
public ref class LiteHttpsTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement

Remarks

This transport extends functionality of LiteHttpTransportBindingElement with secure HTTPS transport protocol.

This HTTP implementation is independent from system provided HTTP implementation included in .NET and does not depend from external services.

The security parameters such as authentication mode and certificates for this transport should be provided through the ClientCredentials class for client side and the ServiceCredentials class on the service side, just like for SslStreamSecurityBindingElement class.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
Noemax.WCFX.Channels.LiteHttpsTransportBindingElement

See Also

Reference

LiteHttpsTransportBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpsTransportBindingElement Class

The following tables list the members exposed by LiteHttpsTransportBindingElement.

Public Constructors

 | Name | Description
public Constructor | LiteHttpsTransportBindingElement Constructor | Overloaded. Initializes a new instance of the LiteHttpsTransportBindingElement class.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.
public Property | EnableGetWSDL | If set to true the listener will enable the export the metadata through the HTTP GET request.
public Property | IdentityVerifier | Gets and sets the identity verifier for this binding.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | Overridden. Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Overridden. Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.
public Property | ProxyAddress | The address of HTTP proxy that should be used for establishing HTTP connection.
public Property | ProxyAuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.
public Property | RequireClientCertificate | Gets or sets a value that indicates whether SSL client authentication is required.
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Determines whether a channel factory of the specified type can be built.
public Method | CanBuildChannelListener<TChannel> | Overridden. Determines whether a channel listener of the specified type can be built.
public Method | Clone | Overridden. Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | Overridden. Gets a property from the specified BindingContext.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with LiteHttpTransportBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

LiteHttpsTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : LiteHttpsTransportBindingElement Constructor

Initializes a new instance of the LiteHttpsTransportBindingElement class.

Overload List

Overload | Description
LiteHttpsTransportBindingElement Constructor() | Initializes a new instance of the LiteHttpsTransportBindingElement class.
LiteHttpsTransportBindingElement Constructor(LiteHttpsTransportBindingElement) | Initializes a new instance of the LiteHttpsTransportBindingElement class.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class > LiteHttpsTransportBindingElement Constructor : LiteHttpsTransportBindingElement Constructor()

Initializes a new instance of the LiteHttpsTransportBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LiteHttpsTransportBindingElement()
C#
public LiteHttpsTransportBindingElement()
Delphi
public LiteHttpsTransportBindingElement();
JScript
public function LiteHttpsTransportBindingElement();
Managed Extensions for C++
public: LiteHttpsTransportBindingElement();
C++/CLI
public:
LiteHttpsTransportBindingElement();

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Constructor(LiteHttpsTransportBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class > LiteHttpsTransportBindingElement Constructor : LiteHttpsTransportBindingElement Constructor(LiteHttpsTransportBindingElement)

source

An instance of the LiteHttpsTransportBindingElement class.

Initializes a new instance of the LiteHttpsTransportBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As LiteHttpsTransportBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As LiteHttpsTransportBindingElement

Dim instance As New LiteHttpsTransportBindingElement(source)
C#
public LiteHttpsTransportBindingElement(
   LiteHttpsTransportBindingElement source
)
Delphi
public LiteHttpsTransportBindingElement(
    source: LiteHttpsTransportBindingElement
);
JScript
public function LiteHttpsTransportBindingElement(
   source : LiteHttpsTransportBindingElement
);
Managed Extensions for C++
public: LiteHttpsTransportBindingElement(
   LiteHttpsTransportBindingElement* source
)
C++/CLI
public:
LiteHttpsTransportBindingElement(
   LiteHttpsTransportBindingElement^ source
)

Parameters

source

An instance of the LiteHttpsTransportBindingElement class.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpsTransportBindingElement Class

For a list of all members of this type, see LiteHttpsTransportBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Determines whether a channel factory of the specified type can be built.
public Method | CanBuildChannelListener<TChannel> | Overridden. Determines whether a channel listener of the specified type can be built.
public Method | Clone | Overridden. Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | Overridden. Gets a property from the specified BindingContext.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with LiteHttpTransportBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

LiteHttpsTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
Type of channel factory.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : BuildChannelFactory<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.
Creates a channel factory that can be used to create a channel.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.

Type Parameters

TChannel
Type of channel factory.

Return Value

A channel factory of the specified type.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
Type of channel listener.
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : BuildChannelListener<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.
Creates a channel listener of the specified type.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.

Type Parameters

TChannel
Type of channel listener.

Return Value

true if a channel listener can be built; otherwise false.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
Type of channel factory.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
Type of channel factory.
Determines whether a channel factory of the specified type can be built.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
Type of channel factory.

Type Parameters

TChannel
Type of channel factory.

Return Value

true if a channel factory can be built; otherwise false.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
Type of channel listener.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : CanBuildChannelListener<TChannel> Method

context
Type of channel listener.
Determines whether a channel listener of the specified type can be built.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
Type of channel listener.

Type Parameters

TChannel
Type of channel listener.

Return Value

true if a channel listener can be built; otherwise false.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : Clone Method

Overridden. Creates a copy of the current binding element.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A copy of the current binding element.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The property to get.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : GetProperty<T> Method

context
A BindingContext.
Gets a property from the specified BindingContext.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context
A BindingContext.

Type Parameters

T
The property to get.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding, with LiteHttpTransportBindingElement plugged into the collection of binding elements.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding, with LiteHttpTransportBindingElement plugged into the collection of binding elements.
PlugIn(BindingElementCollection) | Creates a new BindingElementCollection based on the specified source, with LiteHttpsTransportBindingElement plugged into the collection of binding elements.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The target binding to use as source.
Creates a new CustomBinding based on the specified source Binding, with LiteHttpTransportBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The target binding to use as source.

Return Value

The CustomBinding based on the source Binding with LiteHttpTransportBindingElement binding element plugged into it.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
BindingElementCollection to use as source.
Creates a new BindingElementCollection based on the specified source, with LiteHttpsTransportBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
BindingElementCollection to use as source.

Return Value

The BindingElementCollection based on the source BindingElementCollection with LiteHttpsTransportBindingElement binding element plugged into it.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpsTransportBindingElement Class

For a list of all members of this type, see LiteHttpsTransportBindingElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.
public Property | EnableGetWSDL | If set to true the listener will enable the export the metadata through the HTTP GET request.
public Property | IdentityVerifier | Gets and sets the identity verifier for this binding.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | Overridden. Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Overridden. Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.
public Property | ProxyAddress | The address of HTTP proxy that should be used for establishing HTTP connection.
public Property | ProxyAuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.
public Property | RequireClientCertificate | Gets or sets a value that indicates whether SSL client authentication is required.
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

See Also

Reference

LiteHttpsTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : AllowCookies Property

Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.

Syntax

Visual Basic (Declaration)
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
public function get,set AllowCookies : boolean
Managed Extensions for C++
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

Property Value

true if cookies are allowed; otherwise, false. The default is false.

Remarks

This property is provided as a convenience for interacting with ASMX Web services that use cookies to make sure that the cookies returned from the server are automatically copied to all future client requests for that service.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : AuthenticationScheme Property

Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.

Syntax

Visual Basic (Declaration)
Public Property AuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
C#
public AuthenticationSchemes AuthenticationScheme {get; set;}
Delphi
public read-write property AuthenticationScheme: AuthenticationSchemes;
JScript
public function get,set AuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
public: __property AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
public:
property AuthenticationSchemes AuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

Remarks

The authentication scheme can only be set once.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableGetWSDL Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : EnableGetWSDL Property

If set to true the listener will enable the export the metadata through the HTTP GET request.

Syntax

Visual Basic (Declaration)
Public Property EnableGetWSDL As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.EnableGetWSDL = value

value = instance.EnableGetWSDL
C#
public bool EnableGetWSDL {get; set;}
Delphi
public read-write property EnableGetWSDL: Boolean;
JScript
public function get,set EnableGetWSDL : boolean
Managed Extensions for C++
public: __property bool get_EnableGetWSDL();
public: __property void set_EnableGetWSDL(
   bool value
);
C++/CLI
public:
property bool EnableGetWSDL {
   bool get();
   void set (    bool value);
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IdentityVerifier Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : IdentityVerifier Property

Gets and sets the identity verifier for this binding.

Syntax

Visual Basic (Declaration)
Public Property IdentityVerifier As IdentityVerifier
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As IdentityVerifier

instance.IdentityVerifier = value

value = instance.IdentityVerifier
C#
public IdentityVerifier IdentityVerifier {get; set;}
Delphi
public read-write property IdentityVerifier: IdentityVerifier;
JScript
public function get,set IdentityVerifier : IdentityVerifier
Managed Extensions for C++
public: __property IdentityVerifier* get_IdentityVerifier();
public: __property void set_IdentityVerifier(
   IdentityVerifier* value
);
C++/CLI
public:
property IdentityVerifier^ IdentityVerifier {
   IdentityVerifier^ get();
   void set (    IdentityVerifier^ value);
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
KeepAliveEnabled Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : KeepAliveEnabled Property

Gets or sets a value indicating whether to make a persistent connection to a service endpoint.

Syntax

Visual Basic (Declaration)
Public Property KeepAliveEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.KeepAliveEnabled = value

value = instance.KeepAliveEnabled
C#
public bool KeepAliveEnabled {get; set;}
Delphi
public read-write property KeepAliveEnabled: Boolean;
JScript
public function get,set KeepAliveEnabled : boolean
Managed Extensions for C++
public: __property bool get_KeepAliveEnabled();
public: __property void set_KeepAliveEnabled(
   bool value
);
C++/CLI
public:
property bool KeepAliveEnabled {
   bool get();
   void set (    bool value);
}

Remarks

Set this property to true to send a Connection HTTP header with the value Keep-alive. A client uses this property to indicate a preference for persistent connections. When this property is true, the connection that the client makes to a service endpoint is persistent if the service endpoint supports that.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : MaxBufferPoolSize Property

Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.

Syntax

Visual Basic (Declaration)
Public Overrides Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
public override long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64; override;
JScript
public override function get,set MaxBufferPoolSize : long
Managed Extensions for C++
public: __property long get_MaxBufferPoolSize() override;
public: __property void set_MaxBufferPoolSize(
   long value
) override;
C++/CLI
public:
property int64 MaxBufferPoolSize {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in MaxBufferPoolSize


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
public function get,set MaxBufferSize : int
Managed Extensions for C++
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : MaxReceivedMessageSize Property

Gets and sets the maximum total size limit for the buffers allocated by a transport per endpoint.

Syntax

Visual Basic (Declaration)
Public Overrides Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
public override long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64; override;
JScript
public override function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
public: __property long get_MaxReceivedMessageSize() override;
public: __property void set_MaxReceivedMessageSize(
   long value
) override;
C++/CLI
public:
property int64 MaxReceivedMessageSize {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in MaxReceivedMessageSize


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : ProxyAddress Property

The address of HTTP proxy that should be used for establishing HTTP connection.

Syntax

Visual Basic (Declaration)
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
public function get,set ProxyAddress : Uri
Managed Extensions for C++
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : ProxyAuthenticationScheme Property

Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.

Syntax

Visual Basic (Declaration)
Public Property ProxyAuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As AuthenticationSchemes

instance.ProxyAuthenticationScheme = value

value = instance.ProxyAuthenticationScheme
C#
public AuthenticationSchemes ProxyAuthenticationScheme {get; set;}
Delphi
public read-write property ProxyAuthenticationScheme: AuthenticationSchemes;
JScript
public function get,set ProxyAuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
public: __property AuthenticationSchemes get_ProxyAuthenticationScheme();
public: __property void set_ProxyAuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
public:
property AuthenticationSchemes ProxyAuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
RequireClientCertificate Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : RequireClientCertificate Property

Gets or sets a value that indicates whether SSL client authentication is required.

Syntax

Visual Basic (Declaration)
Public Property RequireClientCertificate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.RequireClientCertificate = value

value = instance.RequireClientCertificate
C#
public bool RequireClientCertificate {get; set;}
Delphi
public read-write property RequireClientCertificate: Boolean;
JScript
public function get,set RequireClientCertificate : boolean
Managed Extensions for C++
public: __property bool get_RequireClientCertificate();
public: __property void set_RequireClientCertificate(
   bool value
);
C++/CLI
public:
property bool RequireClientCertificate {
   bool get();
   void set (    bool value);
}

Property Value

true if SSL client authentication is required; otherwise, false. The default is false.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : Scheme Property

Gets the URI scheme for the transport.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Remarks

This property is used to validate bindings against base addresses.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
public function get,set TransferMode : TransferMode
Managed Extensions for C++
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

The System.ServiceModel.Channels.TransferMode that indicates whether messages are sent buffered or streamed.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : UseDefaultWebProxy Property

Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

Property Value

true if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true.

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpTransportBindingElement Class

Represents the binding element used to specify an HTTP transport with dynamic content negotiation for transmitting messages.

Object Model

LiteHttpTransportBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class LiteHttpTransportBindingElement
   Inherits System.ServiceModel.Channels.TransportBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
C#
public class LiteHttpTransportBindingElement : System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
Delphi
public class LiteHttpTransportBindingElement = class(System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement)
JScript
public class LiteHttpTransportBindingElement extends System.ServiceModel.Channels.TransportBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class LiteHttpTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
C++/CLI
public ref class LiteHttpTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement

Remarks

This transport use the standard dynamic content negotiation capabilities of the HTTP protocol, that allows to transparently negotiate the message encoding and content encoding during communication. These enables channel to support efficient message encoding formats as well as payload compression without breaking interoperability with clients and servers that does not support HTTP dynamic content negotiation.

Most of existing web servers support dynamic content negotiation and payload compression, this transport can utilize this capabilities and it is fully interoperable with any other HTTP bindings in WCF or any standard HTTP implementation.

LiteHttpTransportBindingElement is used in the same way as HttpTransportBindingElement but also can be provided with ContentNegotiationBindingElement which contains the set of additional message encodings to use during communication.

This HTTP implementation is independent from system provided HTTP implementation included in .NET and does not depend from external services.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
Noemax.WCFX.Channels.LiteHttpTransportBindingElement

See Also

Reference

LiteHttpTransportBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpTransportBindingElement Class

The following tables list the members exposed by LiteHttpTransportBindingElement.

Public Constructors

 | Name | Description
public Constructor | LiteHttpTransportBindingElement Constructor | Overloaded. Initializes a new instance of the LiteHttpTransportBindingElement class.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | ProxyAddress | The address of HTTP proxy that should be used for establishing HTTP connection.
public Property | ProxyAuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Determines whether a channel factory of the specified type can be built.
public Method | CanBuildChannelListener<TChannel> | Overridden. Determines whether a channel listener of the specified type can be built.
public Method | Clone | Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the LiteHttpTransportBindingElement injected into it.
Top

See Also

Reference

LiteHttpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : LiteHttpTransportBindingElement Constructor

Initializes a new instance of the LiteHttpTransportBindingElement class.

Overload List

Overload | Description
LiteHttpTransportBindingElement Constructor() | Initializes a new instance of the LiteHttpTransportBindingElement class.
LiteHttpTransportBindingElement Constructor(LiteHttpTransportBindingElement) | Initializes a new instance of the LiteHttpTransportBindingElement class.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class > LiteHttpTransportBindingElement Constructor : LiteHttpTransportBindingElement Constructor()

Initializes a new instance of the LiteHttpTransportBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LiteHttpTransportBindingElement()
C#
public LiteHttpTransportBindingElement()
Delphi
public LiteHttpTransportBindingElement();
JScript
public function LiteHttpTransportBindingElement();
Managed Extensions for C++
public: LiteHttpTransportBindingElement();
C++/CLI
public:
LiteHttpTransportBindingElement();

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Constructor(LiteHttpTransportBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class > LiteHttpTransportBindingElement Constructor : LiteHttpTransportBindingElement Constructor(LiteHttpTransportBindingElement)

source

An instance of the LiteHttpTransportBindingElement class.

Initializes a new instance of the LiteHttpTransportBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As LiteHttpTransportBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As LiteHttpTransportBindingElement

Dim instance As New LiteHttpTransportBindingElement(source)
C#
public LiteHttpTransportBindingElement(
   LiteHttpTransportBindingElement source
)
Delphi
public LiteHttpTransportBindingElement(
    source: LiteHttpTransportBindingElement
);
JScript
public function LiteHttpTransportBindingElement(
   source : LiteHttpTransportBindingElement
);
Managed Extensions for C++
public: LiteHttpTransportBindingElement(
   LiteHttpTransportBindingElement* source
)
C++/CLI
public:
LiteHttpTransportBindingElement(
   LiteHttpTransportBindingElement^ source
)

Parameters

source

An instance of the LiteHttpTransportBindingElement class.

Remarks

This method is a copy constructor used to clone the binding element.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpTransportBindingElement Class

For a list of all members of this type, see LiteHttpTransportBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Creates a channel factory that can be used to create a channel.
public Method | BuildChannelListener<TChannel> | Overridden. Creates a channel listener of the specified type.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Determines whether a channel factory of the specified type can be built.
public Method | CanBuildChannelListener<TChannel> | Overridden. Determines whether a channel listener of the specified type can be built.
public Method | Clone | Overridden. Creates a copy of the current binding element.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new binding based on the provided binding with the LiteHttpTransportBindingElement injected into it.
Top

See Also

Reference

LiteHttpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
Type of channel factory.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : BuildChannelFactory<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.
Creates a channel factory that can be used to create a channel.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel factory.

Type Parameters

TChannel
Type of channel factory.

Return Value

A channel factory of the specified type.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
Type of channel listener.
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : BuildChannelListener<TChannel> Method

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.
Creates a channel listener of the specified type.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
BindingContext members that describe bindings, behaviors, contracts and other information required to create the channel listener.

Type Parameters

TChannel
Type of channel listener.

Return Value

true if a channel listener can be built; otherwise false.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
Type of channel factory.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
Type of channel factory.
Determines whether a channel factory of the specified type can be built.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
Type of channel factory.

Type Parameters

TChannel
Type of channel factory.

Return Value

true if a channel factory can be built; otherwise false.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
Type of channel listener.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : CanBuildChannelListener<TChannel> Method

context
Type of channel listener.
Determines whether a channel listener of the specified type can be built.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
Type of channel listener.

Type Parameters

TChannel
Type of channel listener.

Return Value

true if a channel listener can be built; otherwise false.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : Clone Method

Creates a copy of the current binding element.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A copy of the current binding element.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : PlugIn Method

Creates a new binding based on the provided binding with the LiteHttpTransportBindingElement injected into it.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new binding based on the provided binding with the LiteHttpTransportBindingElement injected into it.
PlugIn(BindingElementCollection) | Injects the LiteHttpTransportBindingElement into the provided binding element collection.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The binding on which the the new binding will be based.
Creates a new binding based on the provided binding with the LiteHttpTransportBindingElement injected into it.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The binding on which the the new binding will be based.

Return Value

The new binding which is based on the provided binding with the LiteHttpTransportBindingElement injected into it.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The binding element collection to have the LiteHttpTransportBindingElement injected into it.
Injects the LiteHttpTransportBindingElement into the provided binding element collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The binding element collection to have the LiteHttpTransportBindingElement injected into it.

Return Value

The binding element collection with the LiteHttpTransportBindingElement injected into it.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : LiteHttpTransportBindingElement Class

For a list of all members of this type, see LiteHttpTransportBindingElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | ProxyAddress | The address of HTTP proxy that should be used for establishing HTTP connection.
public Property | ProxyAuthenticationScheme | Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

See Also

Reference

LiteHttpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : AllowCookies Property

Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.

Syntax

Visual Basic (Declaration)
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
public function get,set AllowCookies : boolean
Managed Extensions for C++
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

Property Value

true if cookies are allowed; otherwise, false. The default is false.

Remarks

This property is provided as a convenience for interacting with ASMX Web services that use cookies to make sure that the cookies returned from the server are automatically copied to all future client requests for that service.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : AuthenticationScheme Property

Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP listener.

Syntax

Visual Basic (Declaration)
Public Property AuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
C#
public AuthenticationSchemes AuthenticationScheme {get; set;}
Delphi
public read-write property AuthenticationScheme: AuthenticationSchemes;
JScript
public function get,set AuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
public: __property AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
public:
property AuthenticationSchemes AuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

Remarks

The authentication scheme can only be set once.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableGetWSDL Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : EnableGetWSDL Property

Gets and sets if transport should support WSDL export through HTTP GET requests.

Syntax

Visual Basic (Declaration)
Public Property EnableGetWSDL As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Boolean

instance.EnableGetWSDL = value

value = instance.EnableGetWSDL
C#
public bool EnableGetWSDL {get; set;}
Delphi
public read-write property EnableGetWSDL: Boolean;
JScript
public function get,set EnableGetWSDL : boolean
Managed Extensions for C++
public: __property bool get_EnableGetWSDL();
public: __property void set_EnableGetWSDL(
   bool value
);
C++/CLI
public:
property bool EnableGetWSDL {
   bool get();
   void set (    bool value);
}

Remarks

In order to configure service to export WSDL through LiteHttp transport application should use ExportMetadataBehavior in combination with this property. If this EnableGetWsdl property is set to true, the transport will respond with web service WSDL on HTTP GET request to base address + "?wsdl" e.g. http://somehost/someservice?wsdl.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
KeepAliveEnabled Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : KeepAliveEnabled Property

Gets or sets a value indicating whether to make a persistent connection to a service endpoint.

Syntax

Visual Basic (Declaration)
Public Property KeepAliveEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Boolean

instance.KeepAliveEnabled = value

value = instance.KeepAliveEnabled
C#
public bool KeepAliveEnabled {get; set;}
Delphi
public read-write property KeepAliveEnabled: Boolean;
JScript
public function get,set KeepAliveEnabled : boolean
Managed Extensions for C++
public: __property bool get_KeepAliveEnabled();
public: __property void set_KeepAliveEnabled(
   bool value
);
C++/CLI
public:
property bool KeepAliveEnabled {
   bool get();
   void set (    bool value);
}

Remarks

Set this property to true to send a Connection HTTP header with the value Keep-alive. A client uses this property to indicate a preference for persistent connections. When this property is true, the connection that the client makes to a service endpoint is persistent if the service endpoint supports that.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
public function get,set MaxBufferSize : int
Managed Extensions for C++
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : ProxyAddress Property

The address of HTTP proxy that should be used for establishing HTTP connection.

Syntax

Visual Basic (Declaration)
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
public function get,set ProxyAddress : Uri
Managed Extensions for C++
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : ProxyAuthenticationScheme Property

Gets or sets the authentication scheme used to authenticate client requests being processed by an HTTP proxy.

Syntax

Visual Basic (Declaration)
Public Property ProxyAuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As AuthenticationSchemes

instance.ProxyAuthenticationScheme = value

value = instance.ProxyAuthenticationScheme
C#
public AuthenticationSchemes ProxyAuthenticationScheme {get; set;}
Delphi
public read-write property ProxyAuthenticationScheme: AuthenticationSchemes;
JScript
public function get,set ProxyAuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
public: __property AuthenticationSchemes get_ProxyAuthenticationScheme();
public: __property void set_ProxyAuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
public:
property AuthenticationSchemes ProxyAuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : Scheme Property

Gets the URI scheme for the transport.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Remarks

This property is used to validate bindings against base addresses.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
public function get,set TransferMode : TransferMode
Managed Extensions for C++
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : UseDefaultWebProxy Property

Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

Property Value

true if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true.

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageEncodingBindingElementCollection Class

Represents a collection of MessageEncodingBindingElement.

Object Model

MessageEncodingBindingElementCollection Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MessageEncodingBindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
C#
[DefaultMemberAttribute("Item")]
public class MessageEncodingBindingElementCollection
Delphi
public class MessageEncodingBindingElementCollection
JScript
DefaultMemberAttribute("Item")
public class MessageEncodingBindingElementCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class MessageEncodingBindingElementCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class MessageEncodingBindingElementCollection

Remarks

This collection is used to specify the list of message encodings to be supported by the channel or the service endpoint.

The order in which items are added into a collection specifies the preference order, where the most preferred encoding is added first and the least preferred last.

If a default message encoding is not specified, the last message encoding added is considered as the default.

The best practice is that the most interoperable encoding is the default.

Inheritance Hierarchy

System.Object
Noemax.WCFX.Channels.MessageEncodingBindingElementCollection

See Also

Reference

MessageEncodingBindingElementCollection Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : MessageEncodingBindingElementCollection Class

The following tables list the members exposed by MessageEncodingBindingElementCollection.

Public Constructors

 | Name | Description
public Constructor | MessageEncodingBindingElementCollection Constructor | Overloaded. Initializes a new instance of the MessageEncodingBindingElementCollection class.
Top

Public Properties

 | Name | Description
public Property | Count | Returns an integer containing the number of elements in a collection.
public Property | Default | The MessageEncodingBindingElement which was assigned as the default one.
public Property | IsReadOnly | Returns true if the collection is read only; otherwise, false.
public Property | Item | Gets the element at the specified index.
public Property | MessageEncodingSet | Gets and sets the predefined message encoding set used in this collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a MessageEncodingBindingElement to the collection.
public Method | AddRange | Adds an enumerable collection of MessageEncodingBindingElement to the collection.
public Method | Clear | Removes all items from the MessageEncodingBindingElementCollection.
public Method | Clone | Creates a new object of MessageEncodingBindingElementCollection initialized from this instance.
public Method | Contains | Overloaded. Determines whether this collection contains the specified MessageEncodingBindingElement.
public Method | CopyTo | Overloaded. Copies all items from this collection into another MessageEncodingBindingElementCollection.
static (Shared in Visual Basic) | Create | Initializes a new instance of the MessageEncodingBindingElementCollection class from a predefined set of message encodings.
public Method | GetEnumerator | Returns an enumerator that iterates through a collection.
public Method | IndexOf | Determines the index of a specific item in the collection.
public Method | Remove | Overloaded. Removes the first occurrence of a specific object from this collection.
public Method | RemoveAt | Removes the element located at the specified index from this collection.
public Method | SetMessageVersion | Sets a MessageVersion property of each contained MessageEncodingBindingElement to the specified value.
Top

See Also

Reference

MessageEncodingBindingElementCollection Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : MessageEncodingBindingElementCollection Constructor

Initializes a new instance of the MessageEncodingBindingElementCollection class.

Overload List

Overload | Description
MessageEncodingBindingElementCollection Constructor() | Initializes a new instance of the MessageEncodingBindingElementCollection class.
MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElement[]) | Initializes a new instance of the MessageEncodingBindingElementCollection class from an array of MessageEncodingBindingElement.
MessageEncodingBindingElementCollection Constructor(SmartMessageEncodingSet) | Initializes a new instance of the MessageEncodingBindingElementCollection class from a predefined set of message encodings.
MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElementCollection) | Initializes a new SmartHttpMessageEncodingBindingElement instance from the already existing one.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > MessageEncodingBindingElementCollection Constructor : MessageEncodingBindingElementCollection Constructor()

Initializes a new instance of the MessageEncodingBindingElementCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MessageEncodingBindingElementCollection()
C#
public MessageEncodingBindingElementCollection()
Delphi
public MessageEncodingBindingElementCollection();
JScript
public function MessageEncodingBindingElementCollection();
Managed Extensions for C++
public: MessageEncodingBindingElementCollection();
C++/CLI
public:
MessageEncodingBindingElementCollection();

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElement[])
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > MessageEncodingBindingElementCollection Constructor : MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElement[])

messageEncodings

The array of MessageEncodingBindingElement.

Initializes a new instance of the MessageEncodingBindingElementCollection class from an array of MessageEncodingBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal messageEncodings() As MessageEncodingBindingElement _
)
Visual Basic (Usage) Copy Code
Dim messageEncodings() As MessageEncodingBindingElement

Dim instance As New MessageEncodingBindingElementCollection(messageEncodings)
C#
public MessageEncodingBindingElementCollection(
   MessageEncodingBindingElement[] messageEncodings
)
Delphi
public MessageEncodingBindingElementCollection(
    messageEncodings: MessageEncodingBindingElementarray of
);
JScript
public function MessageEncodingBindingElementCollection(
   messageEncodings : MessageEncodingBindingElement[]
);
Managed Extensions for C++
public: MessageEncodingBindingElementCollection(
   MessageEncodingBindingElement*[]* messageEncodings
)
C++/CLI
public:
MessageEncodingBindingElementCollection(
   array<MessageEncodingBindingElement^>^ messageEncodings
)

Parameters

messageEncodings

The array of MessageEncodingBindingElement.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Constructor(SmartMessageEncodingSet)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > MessageEncodingBindingElementCollection Constructor : MessageEncodingBindingElementCollection Constructor(SmartMessageEncodingSet)

messageEncodingSet
The predfined set of message encoding to use.
Initializes a new instance of the MessageEncodingBindingElementCollection class from a predefined set of message encodings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal messageEncodingSet As SmartMessageEncodingSet _
)
Visual Basic (Usage) Copy Code
Dim messageEncodingSet As SmartMessageEncodingSet

Dim instance As New MessageEncodingBindingElementCollection(messageEncodingSet)
C#
public MessageEncodingBindingElementCollection(
   SmartMessageEncodingSet messageEncodingSet
)
Delphi
public MessageEncodingBindingElementCollection(
    messageEncodingSet: SmartMessageEncodingSet
);
JScript
public function MessageEncodingBindingElementCollection(
   messageEncodingSet : SmartMessageEncodingSet
);
Managed Extensions for C++
public: MessageEncodingBindingElementCollection(
   SmartMessageEncodingSet messageEncodingSet
)
C++/CLI
public:
MessageEncodingBindingElementCollection(
   SmartMessageEncodingSet messageEncodingSet
)

Parameters

messageEncodingSet
The predfined set of message encoding to use.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElementCollection)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > MessageEncodingBindingElementCollection Constructor : MessageEncodingBindingElementCollection Constructor(MessageEncodingBindingElementCollection)

collection
The already initialized collection of MessageEncodingBindingElement.
Initializes a new SmartHttpMessageEncodingBindingElement instance from the already existing one.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal collection As MessageEncodingBindingElementCollection _
)
Visual Basic (Usage) Copy Code
Dim collection As MessageEncodingBindingElementCollection

Dim instance As New MessageEncodingBindingElementCollection(collection)
C#
public MessageEncodingBindingElementCollection(
   MessageEncodingBindingElementCollection collection
)
Delphi
public MessageEncodingBindingElementCollection(
    collection: MessageEncodingBindingElementCollection
);
JScript
public function MessageEncodingBindingElementCollection(
   collection : MessageEncodingBindingElementCollection
);
Managed Extensions for C++
public: MessageEncodingBindingElementCollection(
   MessageEncodingBindingElementCollection* collection
)
C++/CLI
public:
MessageEncodingBindingElementCollection(
   MessageEncodingBindingElementCollection^ collection
)

Parameters

collection
The already initialized collection of MessageEncodingBindingElement.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageEncodingBindingElementCollection Class

For a list of all members of this type, see MessageEncodingBindingElementCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a MessageEncodingBindingElement to the collection.
public Method | AddRange | Adds an enumerable collection of MessageEncodingBindingElement to the collection.
public Method | Clear | Removes all items from the MessageEncodingBindingElementCollection.
public Method | Clone | Creates a new object of MessageEncodingBindingElementCollection initialized from this instance.
public Method | Contains | Overloaded. Determines whether this collection contains the specified MessageEncodingBindingElement.
public Method | CopyTo | Overloaded. Copies all items from this collection into another MessageEncodingBindingElementCollection.
static (Shared in Visual Basic) | Create | Initializes a new instance of the MessageEncodingBindingElementCollection class from a predefined set of message encodings.
public Method | GetEnumerator | Returns an enumerator that iterates through a collection.
public Method | IndexOf | Determines the index of a specific item in the collection.
public Method | Remove | Overloaded. Removes the first occurrence of a specific object from this collection.
public Method | RemoveAt | Removes the element located at the specified index from this collection.
public Method | SetMessageVersion | Sets a MessageVersion property of each contained MessageEncodingBindingElement to the specified value.
Top

See Also

Reference

MessageEncodingBindingElementCollection Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Add Method

Adds a MessageEncodingBindingElement to the collection.

Overload List

Overload | Description
Add(MessageEncodingBindingElement) | Adds a MessageEncodingBindingElement to the collection.
Add(MessageEncodingBindingElement,Boolean) | Adds a MessageEncodingBindingElement to the collection.
Add<T>(Boolean) | Adds a MessageEncodingBindingElement to the collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add(MessageEncodingBindingElement) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Add Method : Add(MessageEncodingBindingElement) Method

messageEncoding
The MessageEncodingBindingElement to add to the collection.
Adds a MessageEncodingBindingElement to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal messageEncoding As MessageEncodingBindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim messageEncoding As MessageEncodingBindingElement

instance.Add(messageEncoding)
C#
public void Add(
   MessageEncodingBindingElement messageEncoding
)
Delphi
public procedure Add(
    messageEncoding: MessageEncodingBindingElement
);
JScript
public function Add(
   messageEncoding : MessageEncodingBindingElement
);
Managed Extensions for C++
public: void Add(
   MessageEncodingBindingElement* messageEncoding
)
C++/CLI
public:
void Add(
   MessageEncodingBindingElement^ messageEncoding
)

Parameters

messageEncoding
The MessageEncodingBindingElement to add to the collection.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add(MessageEncodingBindingElement,Boolean) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Add Method : Add(MessageEncodingBindingElement,Boolean) Method

messageEncoding
The MessageEncodingBindingElement to add to the collection.
makeDefault

If true the MessageEncodingBindingeElement specified by messageEncoding will be set as the default.

Adds a MessageEncodingBindingElement to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal messageEncoding As MessageEncodingBindingElement, _
   ByVal makeDefault As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim messageEncoding As MessageEncodingBindingElement
Dim makeDefault As Boolean

instance.Add(messageEncoding, makeDefault)
C#
public void Add(
   MessageEncodingBindingElement messageEncoding,
   bool makeDefault
)
Delphi
public procedure Add(
    messageEncoding: MessageEncodingBindingElement;
    makeDefault: Boolean
);
JScript
public function Add(
   messageEncoding : MessageEncodingBindingElement,
   makeDefault : boolean
);
Managed Extensions for C++
public: void Add(
   MessageEncodingBindingElement* messageEncoding,
   bool makeDefault
)
C++/CLI
public:
void Add(
   MessageEncodingBindingElement^ messageEncoding,
   bool makeDefault
)

Parameters

messageEncoding
The MessageEncodingBindingElement to add to the collection.
makeDefault

If true the MessageEncodingBindingeElement specified by messageEncoding will be set as the default.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

T
The type of MessageEncodingBindingElement to create and add to the collection.
[image]
Noemax WCF-Xtensions
Add<T>(Boolean) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Add Method : Add<T>(Boolean) Method

makeDefault
If true the specified MessageEncodingBindingeElement will be set as the default.
Adds a MessageEncodingBindingElement to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add(Of T As MessageEncodingBindingElement)( _
   ByVal makeDefault As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim makeDefault As Boolean

instance.Add(Of T)(makeDefault)
C#
public void Add<T>(
   bool makeDefault
)where T: MessageEncodingBindingElement
Delphi
public procedure Add(
    makeDefault: Boolean
);
JScript
public function Add(
   makeDefault : boolean
);
Managed Extensions for C++
public: void Add<T>(
   bool makeDefault
) where T: MessageEncodingBindingElement
C++/CLI
public:
void Addgeneric<typename T>
(
   bool makeDefault
) where T: MessageEncodingBindingElement

Parameters

makeDefault
If true the specified MessageEncodingBindingeElement will be set as the default.

Type Parameters

T
The type of MessageEncodingBindingElement to create and add to the collection.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddRange Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : AddRange Method

enumerable
An enumerable collection containing the list of MessageEncodingBindingElement.
Adds an enumerable collection of MessageEncodingBindingElement to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal enumerable As IEnumerable(Of MessageEncodingBindingElement) _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim enumerable As IEnumerable(Of MessageEncodingBindingElement)

instance.AddRange(enumerable)
C#
public void AddRange(
   IEnumerable<MessageEncodingBindingElement> enumerable
)
Delphi
public procedure AddRange(
    enumerable: IEnumerable
);
JScript
public function AddRange(
   enumerable : IEnumerable
);
Managed Extensions for C++
public: void AddRange(
   IEnumerable<MessageEncodingBindingElement*>* enumerable
)
C++/CLI
public:
void AddRange(
   IEnumerable<MessageEncodingBindingElement^>^ enumerable
)

Parameters

enumerable
An enumerable collection containing the list of MessageEncodingBindingElement.

Remarks

The order in which items are added to the collection specifies the preference order, where the most preferred encoding goes first and the least preferred goes last.

If the default message encoding is not specified the last added message encoding becomes the default.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Clear Method

Removes all items from the MessageEncodingBindingElementCollection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Clone Method

Creates a new object of MessageEncodingBindingElementCollection initialized from this instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Delphi
public function Clone(): TObject;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Return Value

The new MessageEncodingBindingElementCollection object initialized from this instance.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Contains Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Contains Method

Determines whether this collection contains the specified MessageEncodingBindingElement.

Overload List

Overload | Description
Contains(MessageEncodingBindingElement) | Determines whether this collection contains the specified MessageEncodingBindingElement.
Contains<T>() | Determines whether this collection contains a MessageEncodingBindingElement of the specified type.
Contains(Type) | Determines whether this collection contains a MessageEncodingBindingElement of the specified type.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Contains(MessageEncodingBindingElement) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Contains Method : Contains(MessageEncodingBindingElement) Method

messageEncoding
The MessageEncodingBindingElement to check if it is present in the collection.

Determines whether this collection contains the specified MessageEncodingBindingElement.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal messageEncoding As MessageEncodingBindingElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim messageEncoding As MessageEncodingBindingElement
Dim value As Boolean

value = instance.Contains(messageEncoding)
C#
public bool Contains(
   MessageEncodingBindingElement messageEncoding
)
Delphi
public function Contains(
    messageEncoding: MessageEncodingBindingElement
): Boolean;
JScript
public function Contains(
   messageEncoding : MessageEncodingBindingElement
) : boolean;
Managed Extensions for C++
public: bool Contains(
   MessageEncodingBindingElement* messageEncoding
)
C++/CLI
public:
bool Contains(
   MessageEncodingBindingElement^ messageEncoding
)

Parameters

messageEncoding
The MessageEncodingBindingElement to check if it is present in the collection.

Return Value

true if the specified MessageEncodingBindingElement is found in this collection; otherwise, false.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

T
The type of the MessageEncodingBindingElement element.
[image]
Noemax WCF-Xtensions
Contains<T>() Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Contains Method : Contains<T>() Method

Determines whether this collection contains a MessageEncodingBindingElement of the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains(Of T)() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As Boolean

value = instance.Contains(Of T)()
C#
public bool Contains<T>()
Delphi
public function Contains(): Boolean;
JScript
public function Contains() : boolean;
Managed Extensions for C++
public: bool Contains<T>();
C++/CLI
public:
bool Containsgeneric<typename T>
();

Type Parameters

T
The type of the MessageEncodingBindingElement element.

Return Value

true if a MessageEncodingBindingElement of the specified type is found in this collection; otherwise, false.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Contains(Type) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Contains Method : Contains(Type) Method

type
The type of the MessageEncodingBindingElement.
Determines whether this collection contains a MessageEncodingBindingElement of the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal type As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim type As Type
Dim value As Boolean

value = instance.Contains(type)
C#
public bool Contains(
   Type type
)
Delphi
public function Contains(
    type: Type
): Boolean;
JScript
public function Contains(
   type : Type
) : boolean;
Managed Extensions for C++
public: bool Contains(
   Type* type
)
C++/CLI
public:
bool Contains(
   Type^ type
)

Parameters

type
The type of the MessageEncodingBindingElement.

Return Value

true if a MessageEncodingBindingElement of the specified type is found in this collection; otherwise, false.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : CopyTo Method

Copies all items from this collection into another MessageEncodingBindingElementCollection.

Overload List

Overload | Description
CopyTo(MessageEncodingBindingElementCollection) | Copies all items from this collection into another MessageEncodingBindingElementCollection.
CopyTo(MessageEncodingBindingElement[],Int32) | Copies the elements of this collection into an Array, starting at a particular Array index.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(MessageEncodingBindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > CopyTo Method : CopyTo(MessageEncodingBindingElementCollection) Method

collection
The target collection.
Copies all items from this collection into another MessageEncodingBindingElementCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal collection As MessageEncodingBindingElementCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim collection As MessageEncodingBindingElementCollection

instance.CopyTo(collection)
C#
public void CopyTo(
   MessageEncodingBindingElementCollection collection
)
Delphi
public procedure CopyTo(
    collection: MessageEncodingBindingElementCollection
);
JScript
public function CopyTo(
   collection : MessageEncodingBindingElementCollection
);
Managed Extensions for C++
public: void CopyTo(
   MessageEncodingBindingElementCollection* collection
)
C++/CLI
public:
void CopyTo(
   MessageEncodingBindingElementCollection^ collection
)

Parameters

collection
The target collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(MessageEncodingBindingElement[],Int32) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > CopyTo Method : CopyTo(MessageEncodingBindingElement[],Int32) Method

array

The one-dimensional array that is the destination of the elements copied from this collection. The Array must have zero-based indexing.

arrayIndex
The zero-based index in array at which copying begins.
Copies the elements of this collection into an Array, starting at a particular Array index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As MessageEncodingBindingElement, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim array() As MessageEncodingBindingElement
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   MessageEncodingBindingElement[] array,
   int arrayIndex
)
Delphi
public procedure CopyTo(
    array: MessageEncodingBindingElementarray of;
    arrayIndex: Integer
);
JScript
public function CopyTo(
   array : MessageEncodingBindingElement[],
   arrayIndex : int
);
Managed Extensions for C++
public: void CopyTo(
   MessageEncodingBindingElement*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<MessageEncodingBindingElement^>^ array,
   int arrayIndex
)

Parameters

array

The one-dimensional array that is the destination of the elements copied from this collection. The Array must have zero-based indexing.

arrayIndex
The zero-based index in array at which copying begins.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Create Method

messageEncodingSet
The predefined set of message encodings to use.
Initializes a new instance of the MessageEncodingBindingElementCollection class from a predefined set of message encodings.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal messageEncodingSet As SmartMessageEncodingSet _
) As MessageEncodingBindingElementCollection
Visual Basic (Usage) Copy Code
Dim messageEncodingSet As SmartMessageEncodingSet
Dim value As MessageEncodingBindingElementCollection

value = MessageEncodingBindingElementCollection.Create(messageEncodingSet)
C#
public static MessageEncodingBindingElementCollection Create(
   SmartMessageEncodingSet messageEncodingSet
)
Delphi
public function Create(
    messageEncodingSet: SmartMessageEncodingSet
): MessageEncodingBindingElementCollection; static;
JScript
public static function Create(
   messageEncodingSet : SmartMessageEncodingSet
) : MessageEncodingBindingElementCollection;
Managed Extensions for C++
public: static MessageEncodingBindingElementCollection* Create(
   SmartMessageEncodingSet messageEncodingSet
)
C++/CLI
public:
static MessageEncodingBindingElementCollection^ Create(
   SmartMessageEncodingSet messageEncodingSet
)

Parameters

messageEncodingSet
The predefined set of message encodings to use.

Remarks

The collection is initialized according to the set of message encodings specified by the messageEncodingSet parameter.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetEnumerator Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : GetEnumerator Method

Returns an enumerator that iterates through a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of MessageEncodingBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As IEnumerator(Of MessageEncodingBindingElement)

value = instance.GetEnumerator()
C#
public IEnumerator<MessageEncodingBindingElement> GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: IEnumerator<MessageEncodingBindingElement*>* GetEnumerator();
C++/CLI
public:
IEnumerator<MessageEncodingBindingElement^>^ GetEnumerator();

Return Value

The enumerator that iterates through this collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IndexOf Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : IndexOf Method

item
The item whose index is to be determined.
Determines the index of a specific item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As MessageEncodingBindingElement _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim item As MessageEncodingBindingElement
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   MessageEncodingBindingElement item
)
Delphi
public function IndexOf(
    item: MessageEncodingBindingElement
): Integer;
JScript
public function IndexOf(
   item : MessageEncodingBindingElement
) : int;
Managed Extensions for C++
public: int IndexOf(
   MessageEncodingBindingElement* item
)
C++/CLI
public:
int IndexOf(
   MessageEncodingBindingElement^ item
)

Parameters

item
The item whose index is to be determined.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Remove Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Remove Method

Removes the first occurrence of a specific object from this collection.

Overload List

Overload | Description
Remove(MessageEncodingBindingElement) | Removes the first occurrence of a specific object from this collection.
Remove<T>() | Removes the MessageEncodingBindingElement of the specified type from this collection.
Remove(Type) | Removes the MessageEncodingBindingElement of the specified type from this collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Remove(MessageEncodingBindingElement) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Remove Method : Remove(MessageEncodingBindingElement) Method

messageEncoding
The MessageEncodingBindingElement to remove from this collection.
Removes the first occurrence of a specific object from this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Remove( _
   ByVal messageEncoding As MessageEncodingBindingElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim messageEncoding As MessageEncodingBindingElement
Dim value As Boolean

value = instance.Remove(messageEncoding)
C#
public bool Remove(
   MessageEncodingBindingElement messageEncoding
)
Delphi
public function Remove(
    messageEncoding: MessageEncodingBindingElement
): Boolean;
JScript
public function Remove(
   messageEncoding : MessageEncodingBindingElement
) : boolean;
Managed Extensions for C++
public: bool Remove(
   MessageEncodingBindingElement* messageEncoding
)
C++/CLI
public:
bool Remove(
   MessageEncodingBindingElement^ messageEncoding
)

Parameters

messageEncoding
The MessageEncodingBindingElement to remove from this collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

T
The type of the MessageEncodingBindingElement to remove.
[image]
Noemax WCF-Xtensions
Remove<T>() Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Remove Method : Remove<T>() Method

Removes the MessageEncodingBindingElement of the specified type from this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Remove(Of T)() As MessageEncodingBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As MessageEncodingBindingElement

value = instance.Remove(Of T)()
C#
public MessageEncodingBindingElement Remove<T>()
Delphi
public function Remove(): MessageEncodingBindingElement;
JScript
public function Remove() : MessageEncodingBindingElement;
Managed Extensions for C++
public: MessageEncodingBindingElement* Remove<T>();
C++/CLI
public:
MessageEncodingBindingElement^ Removegeneric<typename T>
();

Type Parameters

T
The type of the MessageEncodingBindingElement to remove.

Return Value

The removed element.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Remove(Type) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class > Remove Method : Remove(Type) Method

type
The type of the MessageEncodingBindingElement to remove.
Removes the MessageEncodingBindingElement of the specified type from this collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Remove( _
   ByVal type As Type _
) As MessageEncodingBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim type As Type
Dim value As MessageEncodingBindingElement

value = instance.Remove(type)
C#
public MessageEncodingBindingElement Remove(
   Type type
)
Delphi
public function Remove(
    type: Type
): MessageEncodingBindingElement;
JScript
public function Remove(
   type : Type
) : MessageEncodingBindingElement;
Managed Extensions for C++
public: MessageEncodingBindingElement* Remove(
   Type* type
)
C++/CLI
public:
MessageEncodingBindingElement^ Remove(
   Type^ type
)

Parameters

type
The type of the MessageEncodingBindingElement to remove.

Return Value

The removed element.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
RemoveAt Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : RemoveAt Method

index
The index of the element to remove.
Removes the element located at the specified index from this collection.

Syntax

Visual Basic (Declaration)
Public Function RemoveAt( _
   ByVal index As Integer _
) As MessageEncodingBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim index As Integer
Dim value As MessageEncodingBindingElement

value = instance.RemoveAt(index)
C#
public MessageEncodingBindingElement RemoveAt(
   int index
)
Delphi
public function RemoveAt(
    index: Integer
): MessageEncodingBindingElement;
JScript
public function RemoveAt(
   index : int
) : MessageEncodingBindingElement;
Managed Extensions for C++
public: MessageEncodingBindingElement* RemoveAt(
   int index
)
C++/CLI
public:
MessageEncodingBindingElement^ RemoveAt(
   int index
)

Parameters

index
The index of the element to remove.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetMessageVersion Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : SetMessageVersion Method

messageVersion
MessageVersion value to set.
Sets a MessageVersion property of each contained MessageEncodingBindingElement to the specified value.

Syntax

Visual Basic (Declaration)
Public Sub SetMessageVersion( _
   ByVal messageVersion As MessageVersion _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim messageVersion As MessageVersion

instance.SetMessageVersion(messageVersion)
C#
public void SetMessageVersion(
   MessageVersion messageVersion
)
Delphi
public procedure SetMessageVersion(
    messageVersion: MessageVersion
);
JScript
public function SetMessageVersion(
   messageVersion : MessageVersion
);
Managed Extensions for C++
public: void SetMessageVersion(
   MessageVersion* messageVersion
)
C++/CLI
public:
void SetMessageVersion(
   MessageVersion^ messageVersion
)

Parameters

messageVersion
MessageVersion value to set.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
MessageEncodingBindingElementCollection Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageEncodingBindingElementCollection Class

For a list of all members of this type, see MessageEncodingBindingElementCollection members.

Public Properties

 | Name | Description
public Property | Count | Returns an integer containing the number of elements in a collection.
public Property | Default | The MessageEncodingBindingElement which was assigned as the default one.
public Property | IsReadOnly | Returns true if the collection is read only; otherwise, false.
public Property | Item | Gets the element at the specified index.
public Property | MessageEncodingSet | Gets and sets the predefined message encoding set used in this collection.
Top

See Also

Reference

MessageEncodingBindingElementCollection Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Count Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Count Property

Returns an integer containing the number of elements in a collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Property Value

The number of elements in a collection.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Default Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Default Property

The MessageEncodingBindingElement which was assigned as the default one.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Default As MessageEncodingBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As MessageEncodingBindingElement

value = instance.Default
C#
public MessageEncodingBindingElement Default {get;}
Delphi
public read-only property Default: MessageEncodingBindingElement;
JScript
public function get Default : MessageEncodingBindingElement
Managed Extensions for C++
public: __property MessageEncodingBindingElement* get_Default();
C++/CLI
public:
property MessageEncodingBindingElement^ Default {
   MessageEncodingBindingElement^ get();
}

Remarks

Returns the MessageEncodingBindingElement contained in the collection which will be used as the default when it is unknown which message encodings are supported by the remote side. Typically this should be the most interoperable one.

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : IsReadOnly Property

Returns true if the collection is read only; otherwise, false.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean;
JScript
public function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : Item Property

index
Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As MessageEncodingBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim index As Integer
Dim value As MessageEncodingBindingElement

value = instance.Item(index)
C#
public MessageEncodingBindingElement this(
   int index
) {get;}
Delphi
public  this: : MessageEncodingBindingElement;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : MessageEncodingBindingElement
Managed Extensions for C++
public: __property MessageEncodingBindingElement* get_Item(
   int index
);
C++/CLI
public:
property MessageEncodingBindingElement^ default [int] {
   MessageEncodingBindingElement^ get(int index);
}

Parameters

index

See Also

Reference

MessageEncodingBindingElementCollection Class
MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingSet Property
See Also Example Send Feedback
Noemax.WCFX.Channels Namespace > MessageEncodingBindingElementCollection Class : MessageEncodingSet Property

Gets and sets the predefined message encoding set used in this collection.

Syntax

Visual Basic (Declaration)
Public Property MessageEncodingSet As SmartMessageEncodingSet
Visual Basic (Usage) Copy Code
Dim instance As MessageEncodingBindingElementCollection
Dim value As SmartMessageEncodingSet

instance.MessageEncodingSet = value

value = instance.MessageEncodingSet
C#
public SmartMessageEncodingSet MessageEncodingSet {get; set;}
Delphi
public read-write property MessageEncodingSet: SmartMessageEncodingSet;
JScript
public function get,set MessageEncodingSet : SmartMessageEncodingSet
Managed Extensions for C++
public: __property SmartMessageEncodingSet get_MessageEncodingSet();
public: __property void set_MessageEncodingSet(
   SmartMessageEncodingSet value
);
C++/CLI
public:
property SmartMessageEncodingSet MessageEncodingSet {
   SmartMessageEncodingSet get();
   void set (    SmartMessageEncodingSet value);
}

Example

[C#]

SmartHttpBinding binding =new SmartHttpBinding();

binding.MessageEncodings.MessageEncodingSet = (SmartMessageEncodingSet.FI | SmartMessageEncodingSet.Text);

Copy Code

  Remarks
If the collection was initialized using a predefined set, this property returns a SmartMessageEncodingSet value specifying the set of message encodings used in this collection. If this collection was not initialized using a predefined set, this property returns SmartMessageEncodingSet.Custom.

If this property is assigned to a value that is not equal to the current value of the property, the collection is cleared and reconfigured according to the new value.

Regardless of the order in which the message encodings were specified when setting the SmartMessageEncodingSet value, the predefined message encoding preference order is used. See SmartMessageEncodingSet for more information.

  See Also
Reference
MessageEncodingBindingElementCollection Class

MessageEncodingBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageStatisticsBindingElement Class

This binding element reports the size of messages produced by the message encoder specified by the binding. It is used only for support purposes during development and may not be used in production systems.

Object Model

MessageStatisticsBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class MessageStatisticsBindingElement
   Inherits System.ServiceModel.Channels.BindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
C#
public class MessageStatisticsBindingElement : System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
Delphi
public class MessageStatisticsBindingElement = class(System.ServiceModel.Channels.BindingElement, IPluggableBindingElement)
JScript
public class MessageStatisticsBindingElement extends System.ServiceModel.Channels.BindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class MessageStatisticsBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
C++/CLI
public ref class MessageStatisticsBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement

Remarks

The results reported by the MessageStatisticsBindingElement depend on the other binding elements specified by the binding and do not reflect the final size of the messages exchanged between the communicating sides.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.MessageStatisticsBindingElement

See Also

Reference

MessageStatisticsBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : MessageStatisticsBindingElement Class

The following tables list the members exposed by MessageStatisticsBindingElement.

Public Constructors

 | Name | Description
public Constructor | MessageStatisticsBindingElement Constructor | Overloaded. Initializes a new instance of CompressionBindingElement.Initializes a new instance of CompressionBindingElement.
Top

Public Properties

 | Name | Description
public Property | LogFilename | The name of the output file.
public Property | Verbose | If set to true then the output file will contain detailed log of all messages exchanged during communication; otherwise only summary report.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.
Top

See Also

Reference

MessageStatisticsBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : MessageStatisticsBindingElement Constructor

Initializes a new instance of CompressionBindingElement.Initializes a new instance of CompressionBindingElement.

Overload List

Overload | Description
MessageStatisticsBindingElement Constructor() | Initializes a new instance of CompressionBindingElement.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class > MessageStatisticsBindingElement Constructor : MessageStatisticsBindingElement Constructor()

Initializes a new instance of CompressionBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MessageStatisticsBindingElement()
C#
public MessageStatisticsBindingElement()
Delphi
public MessageStatisticsBindingElement();
JScript
public function MessageStatisticsBindingElement();
Managed Extensions for C++
public: MessageStatisticsBindingElement();
C++/CLI
public:
MessageStatisticsBindingElement();

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageStatisticsBindingElement Class

For a list of all members of this type, see MessageStatisticsBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.
Top

See Also

Reference

MessageStatisticsBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel factory creates.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
The BindingContext for the factory.
Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the factory.

Type Parameters

TChannel
The type of channel the channel factory creates.

Return Value

true if the specified channel factory stack can be built on the service; otherwise, false

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the channel listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the channel listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener can be built on the service; otherwise, false

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : Clone Method

Creates a new CompressionBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A CompressionBindingElement object with property values equal to those of the current element.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The typed object for which the method is querying.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : GetProperty<T> Method

context

The BindingContext for the binding element.

Returns a typed object requested, if present, from the appropriate layer in the binding element stack.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

The BindingContext for the binding element.

Type Parameters

T
The typed object for which the method is querying.

Return Value

The typed object T requested if it is present or a null reference (Nothing in Visual Basic) if it is not.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.

Overload List

Overload | Description
PlugIn(BindingElementCollection) | Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The target BindingElementCollection to use as source to create the resulting CustomBinding.
Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The target BindingElementCollection to use as source to create the resulting CustomBinding.

Return Value

The BindingElementCollection based on the source BindingElementCollection with this binding element plugged into it.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class > PlugIn Method : PlugIn(Binding) Method

targetBinding
The target binding to use as source to create the resulting CustomBinding.
Creates a new CustomBinding based on the specified source Binding, with this binding element plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal targetBinding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim targetBinding As Binding
Dim value As CustomBinding

value = instance.PlugIn(targetBinding)
C#
public CustomBinding PlugIn(
   Binding targetBinding
)
Delphi
public function PlugIn(
    targetBinding: Binding
): CustomBinding;
JScript
public function PlugIn(
   targetBinding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* targetBinding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ targetBinding
)

Parameters

targetBinding
The target binding to use as source to create the resulting CustomBinding.

Return Value

The CustomBinding based on the source Binding with this binding element plugged into it.

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
MessageStatisticsBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : MessageStatisticsBindingElement Class

For a list of all members of this type, see MessageStatisticsBindingElement members.

Public Properties

 | Name | Description
public Property | LogFilename | The name of the output file.
public Property | Verbose | If set to true then the output file will contain detailed log of all messages exchanged during communication; otherwise only summary report.
Top

See Also

Reference

MessageStatisticsBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LogFilename Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : LogFilename Property

The name of the output file.

Syntax

Visual Basic (Declaration)
Public Property LogFilename As String
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim value As String

instance.LogFilename = value

value = instance.LogFilename
C#
public string LogFilename {get; set;}
Delphi
public read-write property LogFilename: String;
JScript
public function get,set LogFilename : String
Managed Extensions for C++
public: __property string* get_LogFilename();
public: __property void set_LogFilename(
   string* value
);
C++/CLI
public:
property String^ LogFilename {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Verbose Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > MessageStatisticsBindingElement Class : Verbose Property

If set to true then the output file will contain detailed log of all messages exchanged during communication; otherwise only summary report.

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsBindingElement
Dim value As Boolean

instance.Verbose = value

value = instance.Verbose
C#
public bool Verbose {get; set;}
Delphi
public read-write property Verbose: Boolean;
JScript
public function get,set Verbose : boolean
Managed Extensions for C++
public: __property bool get_Verbose();
public: __property void set_Verbose(
   bool value
);
C++/CLI
public:
property bool Verbose {
   bool get();
   void set (    bool value);
}

See Also

Reference

MessageStatisticsBindingElement Class
MessageStatisticsBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PluggableMessageEncodingBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : PluggableMessageEncodingBindingElement Class

Represents the MessageEncodingBindingElement that can plug itself into an already configured Binding.

Object Model

PluggableMessageEncodingBindingElement Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PluggableMessageEncodingBindingElement
   Inherits System.ServiceModel.Channels.MessageEncodingBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
C#
public abstract class PluggableMessageEncodingBindingElement : System.ServiceModel.Channels.MessageEncodingBindingElement, IPluggableBindingElement
Delphi
public class PluggableMessageEncodingBindingElement = class(System.ServiceModel.Channels.MessageEncodingBindingElement, IPluggableBindingElement)abstract;
JScript
public abstract class PluggableMessageEncodingBindingElement extends System.ServiceModel.Channels.MessageEncodingBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc abstract class PluggableMessageEncodingBindingElement : public System.ServiceModel.Channels.MessageEncodingBindingElement, IPluggableBindingElement
C++/CLI
public ref class PluggableMessageEncodingBindingElement abstract : public System.ServiceModel.Channels.MessageEncodingBindingElement, IPluggableBindingElement

Remarks

This is the base class for the message encoding binding elements that can be plugged into an exiting Binding.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.MessageEncodingBindingElement
Noemax.WCFX.Channels.PluggableMessageEncodingBindingElement
Noemax.WCFX.Channels.FiMessageEncodingBindingElement
Noemax.WCFX.Channels.SmartHttpMessageEncodingBindingElement

See Also

Reference

PluggableMessageEncodingBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
PluggableMessageEncodingBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : PluggableMessageEncodingBindingElement Class

The following tables list the members exposed by PluggableMessageEncodingBindingElement.

Public Properties

 | Name | Description
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.MessageEncodingBindingElement)
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | BuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | Clone | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CreateMessageEncoderFactory | (Inherited from System.ServiceModel.Channels.MessageEncodingBindingElement)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.
Top

See Also

Reference

PluggableMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
PluggableMessageEncodingBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : PluggableMessageEncodingBindingElement Class

For a list of all members of this type, see PluggableMessageEncodingBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | BuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelFactory<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CanBuildChannelListener<TChannel> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | Clone | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | CreateMessageEncoderFactory | (Inherited from System.ServiceModel.Channels.MessageEncodingBindingElement)
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.
Top

See Also

Reference

PluggableMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.
PlugIn(BindingElementCollection) | Creates a new BindingElementCollection based on the specified source BindingElementCollection object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class > PlugIn Method : PlugIn(Binding) Method

sourceBinding
The binding to be used as source for the new CustomBinding, which will have this binding element plugged into it.
Creates a new CustomBinding based on the specified source Binding object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal sourceBinding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim sourceBinding As Binding
Dim value As CustomBinding

value = instance.PlugIn(sourceBinding)
C#
public CustomBinding PlugIn(
   Binding sourceBinding
)
Delphi
public function PlugIn(
    sourceBinding: Binding
): CustomBinding;
JScript
public function PlugIn(
   sourceBinding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* sourceBinding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ sourceBinding
)

Parameters

sourceBinding
The binding to be used as source for the new CustomBinding, which will have this binding element plugged into it.

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElements
The collection to be used as source for the new BindingElementCollection, which will have this binding element plugged into it.
Creates a new BindingElementCollection based on the specified source BindingElementCollection object, with this binding element plugged in place of the MessageEncodingBindingElement used by the source Binding.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElements As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim bindingElements As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElements)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElements
)
Delphi
public function PlugIn(
    bindingElements: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElements : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElements
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElements
)

Parameters

bindingElements
The collection to be used as source for the new BindingElementCollection, which will have this binding element plugged into it.

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartHttpBinding Class

Represents a binding that fully utilizes all standard capabilities of the HTTP transport to provide support for dynamic content negotiation.

Object Model

SmartHttpBinding Class

Syntax

Visual Basic (Declaration)
Public Class SmartHttpBinding
   Inherits System.ServiceModel.Channels.Binding
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
C#
public class SmartHttpBinding : System.ServiceModel.Channels.Binding
Delphi
public class SmartHttpBinding = class(System.ServiceModel.Channels.Binding)
JScript
public class SmartHttpBinding extends System.ServiceModel.Channels.Binding
Managed Extensions for C++
public __gc class SmartHttpBinding : public System.ServiceModel.Channels.Binding
C++/CLI
public ref class SmartHttpBinding : public System.ServiceModel.Channels.Binding

Remarks

Using the standard dynamic content negotiation capabilities of the HTTP protocol, this binding detects the encoding that was used to serialize the incoming message and the compression algorithm used (if any) and appropriately decompresses and deserializes the incoming message.

Information obtained from the HTTP header also allows it to detect which message encodings are supported by the remote side and whether it supports compression. The SmartHttpBinding can be configured to use the preferred message encoding and/or compression algorithm to communicate with those clients that support these advanced features without breaking interoperability with those clients and servers that do not support such features.

You can configure the SmartHttpBinding behavior using the CompressionMode and MessageEncodingMode which allow you to set different modes of message encoding and compression.

By using the SmartHttpBinding you can reduce the bandwidth used by your service and improve its processing performance without sacrificing interoperability.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.Binding
Noemax.WCFX.Channels.SmartHttpBinding

See Also

Reference

SmartHttpBinding Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SmartHttpBinding Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : SmartHttpBinding Class

The following tables list the members exposed by SmartHttpBinding.

Public Constructors

 | Name | Description
public Constructor | SmartHttpBinding Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | BypassProxyOnLocal | Gets or sets a value that indicates whether to bypass the proxy server for local addresses.
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the compression mode to be used by this binding.
public Property | EnvelopeVersion | Gets the version of SOAP that is used for messages that are processed by this binding.
public Property | HostNameComparisonMode | Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.
public Property | MaxBufferPoolSize | Gets or sets the maximum amount of memory that is allocated for use by the manager of the message buffers that receive messages from the channel.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a message that can be received on a channel configured with this binding.
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | The collection of message encodings used by this binding.
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | ProxyAddress | Gets or sets the URI address of the HTTP proxy.
public Property | ReaderQuotas | Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | Overridden. Gets the URI transport scheme for the channels and listeners that are configured with this binding.
public Property | Security | Gets the type of security used with this binding.
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | Overridden. Creates a collection that contains the binding elements that are part of the current binding.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | Init | Initializes the instance of SmartHttpBinding from the MessageEncodingBindingElementCollection.
Top

See Also

Reference

SmartHttpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : SmartHttpBinding Constructor

Overload List

Overload | Description
SmartHttpBinding Constructor() | Initializes a new instance of SmartHttpBinding.
SmartHttpBinding Constructor(SmartMessageEncodingSet) | Initializes a new instance of SmartHttpBinding with a predefined set of message encodings.
SmartHttpBinding Constructor(MessageEncodingBindingElementCollection) | Initializes a new instance of SmartHttpBinding using the specified collection of message encodings.
SmartHttpBinding Constructor(BasicHttpSecurityMode,MessageEncodingBindingElementCollection) | Initializes a new instance of SmartHttpBinding using specified collection of message encodings.
SmartHttpBinding Constructor(BasicHttpSecurityMode) | Initializes a new instance of SmartHttpBinding with the specified type of security.
SmartHttpBinding Constructor(BasicHttpSecurityMode,SmartMessageEncodingSet) | Initializes a new instance of SmartHttpBinding with the specified type of security and the predefined set of message encodings.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor()

Initializes a new instance of SmartHttpBinding.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SmartHttpBinding()
C#
public SmartHttpBinding()
Delphi
public SmartHttpBinding();
JScript
public function SmartHttpBinding();
Managed Extensions for C++
public: SmartHttpBinding();
C++/CLI
public:
SmartHttpBinding();

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor(SmartMessageEncodingSet)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor(SmartMessageEncodingSet)

messageEncodingSet
The set of message encodings to support.
Initializes a new instance of SmartHttpBinding with a predefined set of message encodings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal messageEncodingSet As SmartMessageEncodingSet _
)
Visual Basic (Usage) Copy Code
Dim messageEncodingSet As SmartMessageEncodingSet

Dim instance As New SmartHttpBinding(messageEncodingSet)
C#
public SmartHttpBinding(
   SmartMessageEncodingSet messageEncodingSet
)
Delphi
public SmartHttpBinding(
    messageEncodingSet: SmartMessageEncodingSet
);
JScript
public function SmartHttpBinding(
   messageEncodingSet : SmartMessageEncodingSet
);
Managed Extensions for C++
public: SmartHttpBinding(
   SmartMessageEncodingSet messageEncodingSet
)
C++/CLI
public:
SmartHttpBinding(
   SmartMessageEncodingSet messageEncodingSet
)

Parameters

messageEncodingSet
The set of message encodings to support.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor(MessageEncodingBindingElementCollection)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor(MessageEncodingBindingElementCollection)

messageEncodings
The collection of MessageEncodingBindingElement to use.
Initializes a new instance of SmartHttpBinding using the specified collection of message encodings.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal messageEncodings As MessageEncodingBindingElementCollection _
)
Visual Basic (Usage) Copy Code
Dim messageEncodings As MessageEncodingBindingElementCollection

Dim instance As New SmartHttpBinding(messageEncodings)
C#
protected SmartHttpBinding(
   MessageEncodingBindingElementCollection messageEncodings
)
Delphi
protected SmartHttpBinding(
    messageEncodings: MessageEncodingBindingElementCollection
);
JScript
protected function SmartHttpBinding(
   messageEncodings : MessageEncodingBindingElementCollection
);
Managed Extensions for C++
protected: SmartHttpBinding(
   MessageEncodingBindingElementCollection* messageEncodings
)
C++/CLI
protected:
SmartHttpBinding(
   MessageEncodingBindingElementCollection^ messageEncodings
)

Parameters

messageEncodings
The collection of MessageEncodingBindingElement to use.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor(BasicHttpSecurityMode,MessageEncodingBindingElementCollection)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor(BasicHttpSecurityMode,MessageEncodingBindingElementCollection)

securityMode
The security settings for this binding.
messageEncodings
The collection of MessageEncodingBindingElement to use.
Initializes a new instance of SmartHttpBinding using specified collection of message encodings.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal securityMode As BasicHttpSecurityMode, _
   ByVal messageEncodings As MessageEncodingBindingElementCollection _
)
Visual Basic (Usage) Copy Code
Dim securityMode As BasicHttpSecurityMode
Dim messageEncodings As MessageEncodingBindingElementCollection

Dim instance As New SmartHttpBinding(securityMode, messageEncodings)
C#
protected SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   MessageEncodingBindingElementCollection messageEncodings
)
Delphi
protected SmartHttpBinding(
    securityMode: BasicHttpSecurityMode;
    messageEncodings: MessageEncodingBindingElementCollection
);
JScript
protected function SmartHttpBinding(
   securityMode : BasicHttpSecurityMode,
   messageEncodings : MessageEncodingBindingElementCollection
);
Managed Extensions for C++
protected: SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   MessageEncodingBindingElementCollection* messageEncodings
)
C++/CLI
protected:
SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   MessageEncodingBindingElementCollection^ messageEncodings
)

Parameters

securityMode
The security settings for this binding.
messageEncodings
The collection of MessageEncodingBindingElement to use.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor(BasicHttpSecurityMode)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor(BasicHttpSecurityMode)

securityMode

The value of BasicHttpSecurityMode that specifies the type of security that is used with the SOAP messages.

Initializes a new instance of SmartHttpBinding with the specified type of security.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal securityMode As BasicHttpSecurityMode _
)
Visual Basic (Usage) Copy Code
Dim securityMode As BasicHttpSecurityMode

Dim instance As New SmartHttpBinding(securityMode)
C#
public SmartHttpBinding(
   BasicHttpSecurityMode securityMode
)
Delphi
public SmartHttpBinding(
    securityMode: BasicHttpSecurityMode
);
JScript
public function SmartHttpBinding(
   securityMode : BasicHttpSecurityMode
);
Managed Extensions for C++
public: SmartHttpBinding(
   BasicHttpSecurityMode securityMode
)
C++/CLI
public:
SmartHttpBinding(
   BasicHttpSecurityMode securityMode
)

Parameters

securityMode

The value of BasicHttpSecurityMode that specifies the type of security that is used with the SOAP messages.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBinding Constructor(BasicHttpSecurityMode,SmartMessageEncodingSet)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > SmartHttpBinding Constructor : SmartHttpBinding Constructor(BasicHttpSecurityMode,SmartMessageEncodingSet)

securityMode

The value of BasicHttpSecurityMode that specifies the type of security that is used with the SOAP messages.

messageEncodingSet
The predefined set of message encodings to support.
Initializes a new instance of SmartHttpBinding with the specified type of security and the predefined set of message encodings.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal securityMode As BasicHttpSecurityMode, _
   ByVal messageEncodingSet As SmartMessageEncodingSet _
)
Visual Basic (Usage) Copy Code
Dim securityMode As BasicHttpSecurityMode
Dim messageEncodingSet As SmartMessageEncodingSet

Dim instance As New SmartHttpBinding(securityMode, messageEncodingSet)
C#
public SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   SmartMessageEncodingSet messageEncodingSet
)
Delphi
public SmartHttpBinding(
    securityMode: BasicHttpSecurityMode;
    messageEncodingSet: SmartMessageEncodingSet
);
JScript
public function SmartHttpBinding(
   securityMode : BasicHttpSecurityMode,
   messageEncodingSet : SmartMessageEncodingSet
);
Managed Extensions for C++
public: SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   SmartMessageEncodingSet messageEncodingSet
)
C++/CLI
public:
SmartHttpBinding(
   BasicHttpSecurityMode securityMode,
   SmartMessageEncodingSet messageEncodingSet
)

Parameters

securityMode

The value of BasicHttpSecurityMode that specifies the type of security that is used with the SOAP messages.

messageEncodingSet
The predefined set of message encodings to support.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SmartHttpBinding Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartHttpBinding Class

For a list of all members of this type, see SmartHttpBinding members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | BuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelFactory | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CanBuildChannelListener | Overloaded. (Inherited from System.ServiceModel.Channels.Binding)
public Method | CreateBindingElements | Overridden. Creates a collection that contains the binding elements that are part of the current binding.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.Binding)
Top

Protected Methods

 | Name | Description
protected Method | Init | Initializes the instance of SmartHttpBinding from the MessageEncodingBindingElementCollection.
Top

See Also

Reference

SmartHttpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElements Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CreateBindingElements Method

Creates a collection that contains the binding elements that are part of the current binding.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateBindingElements() As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As BindingElementCollection

value = instance.CreateBindingElements()
C#
public override BindingElementCollection CreateBindingElements()
Delphi
public function CreateBindingElements(): BindingElementCollection; override;
JScript
public override function CreateBindingElements() : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* CreateBindingElements(); override
C++/CLI
public:
BindingElementCollection^ CreateBindingElements(); override

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Base Implementation in CreateBindingElements


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : Init Method

messageEncodings
Initializes the instance of SmartHttpBinding from the MessageEncodingBindingElementCollection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Init( _
   ByVal messageEncodings As MessageEncodingBindingElementCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim messageEncodings As MessageEncodingBindingElementCollection

instance.Init(messageEncodings)
C#
protected virtual void Init(
   MessageEncodingBindingElementCollection messageEncodings
)
Delphi
protected procedure Init(
    messageEncodings: MessageEncodingBindingElementCollection
); virtual;
JScript
protected function Init(
   messageEncodings : MessageEncodingBindingElementCollection
);
Managed Extensions for C++
protected: virtual void Init(
   MessageEncodingBindingElementCollection* messageEncodings
)
C++/CLI
protected:
virtual void Init(
   MessageEncodingBindingElementCollection^ messageEncodings
)

Parameters

messageEncodings

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SmartHttpBinding Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartHttpBinding Class

For a list of all members of this type, see SmartHttpBinding members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | BypassProxyOnLocal | Gets or sets a value that indicates whether to bypass the proxy server for local addresses.
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the compression mode to be used by this binding.
public Property | EnvelopeVersion | Gets the version of SOAP that is used for messages that are processed by this binding.
public Property | HostNameComparisonMode | Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.
public Property | MaxBufferPoolSize | Gets or sets the maximum amount of memory that is allocated for use by the manager of the message buffers that receive messages from the channel.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a message that can be received on a channel configured with this binding.
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | The collection of message encodings used by this binding.
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | ProxyAddress | Gets or sets the URI address of the HTTP proxy.
public Property | ReaderQuotas | Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | Overridden. Gets the URI transport scheme for the channels and listeners that are configured with this binding.
public Property | Security | Gets the type of security used with this binding.
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

See Also

Reference

SmartHttpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : AllowCookies Property

Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.

Syntax

Visual Basic (Declaration)
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
public function get,set AllowCookies : boolean
Managed Extensions for C++
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

Property Value

true if the client accepts cookies and propagates them on future requests; otherwise, false. The default is false. true if cookies are allowed; otherwise, false. The default is false.

Remarks

You can use this attribute when you interact with ASMX Web services that use cookies. In this way, you can be sure that the cookies returned from the server are automatically copied to all future client requests for that service.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BypassProxyOnLocal Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : BypassProxyOnLocal Property

Gets or sets a value that indicates whether to bypass the proxy server for local addresses.

Syntax

Visual Basic (Declaration)
Public Property BypassProxyOnLocal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Boolean

instance.BypassProxyOnLocal = value

value = instance.BypassProxyOnLocal
C#
public bool BypassProxyOnLocal {get; set;}
Delphi
public read-write property BypassProxyOnLocal: Boolean;
JScript
public function get,set BypassProxyOnLocal : boolean
Managed Extensions for C++
public: __property bool get_BypassProxyOnLocal();
public: __property void set_BypassProxyOnLocal(
   bool value
);
C++/CLI
public:
property bool BypassProxyOnLocal {
   bool get();
   void set (    bool value);
}

Property Value

true if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true true to bypass the proxy server for local addresses; otherwise, false. The default value is false.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
public function get,set CompressionLevel : int
Managed Extensions for C++
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CompressionMode Property

Gets and sets the compression mode to be used by this binding.

Syntax

Visual Basic (Declaration)
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

Remarks

The default value of this property is SmartCompressionMode.Pessimistic.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : EnvelopeVersion Property

Gets the version of SOAP that is used for messages that are processed by this binding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeVersion As EnvelopeVersion
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As EnvelopeVersion

value = instance.EnvelopeVersion
C#
public EnvelopeVersion EnvelopeVersion {get;}
Delphi
public read-only property EnvelopeVersion: EnvelopeVersion;
JScript
public function get EnvelopeVersion : EnvelopeVersion
Managed Extensions for C++
public: __property EnvelopeVersion* get_EnvelopeVersion();
C++/CLI
public:
property EnvelopeVersion^ EnvelopeVersion {
   EnvelopeVersion^ get();
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HostNameComparisonMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : HostNameComparisonMode Property

Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.

Syntax

Visual Basic (Declaration)
Public Property HostNameComparisonMode As HostNameComparisonMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As HostNameComparisonMode

instance.HostNameComparisonMode = value

value = instance.HostNameComparisonMode
C#
public HostNameComparisonMode HostNameComparisonMode {get; set;}
Delphi
public read-write property HostNameComparisonMode: HostNameComparisonMode;
JScript
public function get,set HostNameComparisonMode : HostNameComparisonMode
Managed Extensions for C++
public: __property HostNameComparisonMode get_HostNameComparisonMode();
public: __property void set_HostNameComparisonMode(
   HostNameComparisonMode value
);
C++/CLI
public:
property HostNameComparisonMode HostNameComparisonMode {
   HostNameComparisonMode get();
   void set (    HostNameComparisonMode value);
}

Property Value

The System.ServiceModel.HostnameComparisonMode value that indicates whether the hostname is used to reach the service when matching on the URI. The default value is System.ServiceModel.HostnameComparisonMode.StrongWildcard, which ignores the hostname in the match.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MaxBufferPoolSize Property

Gets or sets the maximum amount of memory that is allocated for use by the manager of the message buffers that receive messages from the channel.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum amount of memory, in bytes, available for use by the message buffer manager. The default value is 524288 (0x80000) bytes.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
public function get,set MaxBufferSize : int
Managed Extensions for C++
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MaxReceivedMessageSize Property

Gets or sets the maximum size for a message that can be received on a channel configured with this binding.

Syntax

Visual Basic (Declaration)
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size, in bytes, for a message that is processed by the binding. The default value is 65,536 bytes.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The value is less than zero.
System.ServiceModel.QuotaExceededException | A message exceeded the maximum size allocated.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MessageEncodingMode Property

Gets and sets the message encoding mode to be used by this binding.

Syntax

Visual Basic (Declaration)
Public Property MessageEncodingMode As SmartMessageEncodingMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As SmartMessageEncodingMode

instance.MessageEncodingMode = value

value = instance.MessageEncodingMode
C#
public SmartMessageEncodingMode MessageEncodingMode {get; set;}
Delphi
public read-write property MessageEncodingMode: SmartMessageEncodingMode;
JScript
public function get,set MessageEncodingMode : SmartMessageEncodingMode
Managed Extensions for C++
public: __property SmartMessageEncodingMode get_MessageEncodingMode();
public: __property void set_MessageEncodingMode(
   SmartMessageEncodingMode value
);
C++/CLI
public:
property SmartMessageEncodingMode MessageEncodingMode {
   SmartMessageEncodingMode get();
   void set (    SmartMessageEncodingMode value);
}

Remarks

Regardless of the MessageEncodingMode settings, this binding is always able to decode messages encoded using any of the message encodings specified by the MessageEncodings collection.

The default value of this property is SmartMessageEncodingMode.Pessimistic.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodings Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MessageEncodings Property

The collection of message encodings used by this binding.

Syntax

Visual Basic (Declaration)
Public Property MessageEncodings As MessageEncodingBindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As MessageEncodingBindingElementCollection

instance.MessageEncodings = value

value = instance.MessageEncodings
C#
public MessageEncodingBindingElementCollection MessageEncodings {get; set;}
Delphi
public read-write property MessageEncodings: MessageEncodingBindingElementCollection;
JScript
public function get,set MessageEncodings : MessageEncodingBindingElementCollection
Managed Extensions for C++
public: __property MessageEncodingBindingElementCollection* get_MessageEncodings();
public: __property void set_MessageEncodings(
   MessageEncodingBindingElementCollection* value
);
C++/CLI
public:
property MessageEncodingBindingElementCollection^ MessageEncodings {
   MessageEncodingBindingElementCollection^ get();
   void set (    MessageEncodingBindingElementCollection^ value);
}

Remarks

The MessageEncodingsBindingElement items that are added to this list will be supported by this binding.

Regardless of the MessageEncodingMode settings, this binding will always be able to decode messages encoded using any of the message encodings specified in the MessageEncodings collection.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : ProxyAddress Property

Gets or sets the URI address of the HTTP proxy.

Syntax

Visual Basic (Declaration)
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
public function get,set ProxyAddress : Uri
Managed Extensions for C++
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

Property Value

A System.Uri that serves as the address of the HTTP proxy. The default value is null.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderQuotas Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : ReaderQuotas Property

Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReaderQuotas As XmlDictionaryReaderQuotas
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As XmlDictionaryReaderQuotas

value = instance.ReaderQuotas
C#
public XmlDictionaryReaderQuotas ReaderQuotas {get;}
Delphi
public read-only property ReaderQuotas: XmlDictionaryReaderQuotas;
JScript
public function get ReaderQuotas : XmlDictionaryReaderQuotas
Managed Extensions for C++
public: __property XmlDictionaryReaderQuotas* get_ReaderQuotas();
C++/CLI
public:
property XmlDictionaryReaderQuotas^ ReaderQuotas {
   XmlDictionaryReaderQuotas^ get();
}

Remarks

The complexity constraints provide protection from denial of service (DOS) attacks that attempt to use message complexity to tie up endpoint processing resources. Other complexity constraints include items such as a maximum element depth and a maximum length for string content within the message.

This constrains will be applied to all message encodings used by this binding if they support ReaderQuotas property.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : Scheme Property

Gets the URI transport scheme for the channels and listeners that are configured with this binding.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Property Value

"https" if the security mode in the transport binding element is set to System.ServiceModel.BasicHttpSecurityMode.Transport or System.ServiceModel.BasicHttpSecurityMode.TransportWithMessageCredential; "http" if the security mode is set to System.ServiceModel.BasicHttpSecurityMode.Transport.TransportCredentialOnly or otherwise.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Security Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : Security Property

Gets the type of security used with this binding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Security As BasicHttpSecurity
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As BasicHttpSecurity

value = instance.Security
C#
public BasicHttpSecurity Security {get;}
Delphi
public read-only property Security: BasicHttpSecurity;
JScript
public function get Security : BasicHttpSecurity
Managed Extensions for C++
public: __property BasicHttpSecurity* get_Security();
C++/CLI
public:
property BasicHttpSecurity^ Security {
   BasicHttpSecurity^ get();
}

Remarks

By default, the SOAP message is not secured and the client is not authenticated. The security used by the binding cannot be changed once the binding is created. To use a non-default type of security, use the SmartHttpBinding(BasicHttpSecurityMode) constructor.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
public function get,set TransferMode : TransferMode
Managed Extensions for C++
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

The System.ServiceModel.Channels.TransferMode that indicates whether messages are sent buffered or streamed.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : UseDefaultWebProxy Property

Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.

Syntax

Visual Basic (Declaration)
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

Property Value

true if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true.

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpDuplexTransportBindingElement Class

Represents the binding element used to specify the SOAP/TCP transport for transmitting messages.

Object Model

SoapTcpDuplexTransportBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class SoapTcpDuplexTransportBindingElement
   Inherits SoapTcpTransportBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
C#
public class SoapTcpDuplexTransportBindingElement : SoapTcpTransportBindingElement, IPluggableBindingElement
Delphi
public class SoapTcpDuplexTransportBindingElement = class(SoapTcpTransportBindingElement, IPluggableBindingElement)
JScript
public class SoapTcpDuplexTransportBindingElement extends SoapTcpTransportBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class SoapTcpDuplexTransportBindingElement : public SoapTcpTransportBindingElement, IPluggableBindingElement
C++/CLI
public ref class SoapTcpDuplexTransportBindingElement : public SoapTcpTransportBindingElement, IPluggableBindingElement

Remarks

SOAP/TCP is a specification by Sun Microsystems that describes an efficient and lightweight protocol for transmitting Web services messages over a TCP connection.

The SOAP/TCP transport included in WCF-Xtensions provides excellent performance when used with the Fast Infoset stateful message encoding which maintains the Fast Infoset vocabulary during a connection. This stateful message encoding eliminates the need to build a new vocabulary with every message, thus minimizing FI message size and maximizing FI processing performance.

With the Noemax SOAP/TCP you can use any Noemax.WCFX.Channels.TransferMode irrespective of the mode used by the remote side. You can also use message security and transport security, which is offered through StreamUpgradeBindingElement implementations such as the SslStreamSecurityElement. Note that currently the Sun SOAP/TCP only supports message security.

SOAP/TCP enables you to communicate over TCP with WCF as well as with any container that supports the Metro Web services stack.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
Noemax.WCFX.Channels.SoapTcpTransportBindingElement
Noemax.WCFX.Channels.SoapTcpDuplexTransportBindingElement

See Also

Reference

SoapTcpDuplexTransportBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpDuplexTransportBindingElement Class

The following tables list the members exposed by SoapTcpDuplexTransportBindingElement.

Public Constructors

 | Name | Description
public Constructor | SoapTcpDuplexTransportBindingElement Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | ConnectionPooling | Enables and disables connection pooling. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | IdleTimeout | Gets and set the amount of time during which server will allow connection to stay idle before terminating it. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size of the buffer to use. For buffered messages this value is the same as MaxReceivedMessageSize. For streamed messages, this value is the maximum size of the SOAP headers, which must be read in buffered mode. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new SoapTcpDuplexTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
Top

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : SoapTcpDuplexTransportBindingElement Constructor

Overload List

Overload | Description
SoapTcpDuplexTransportBindingElement Constructor() | Initializes a new instance of SoapTcpDuplexTransportBindingElement.
SoapTcpDuplexTransportBindingElement Constructor(SoapTcpDuplexTransportBindingElement) | Initializes a new instance of SoapTcpDuplexTransportBindingElement.

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class > SoapTcpDuplexTransportBindingElement Constructor : SoapTcpDuplexTransportBindingElement Constructor()

Initializes a new instance of SoapTcpDuplexTransportBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SoapTcpDuplexTransportBindingElement()
C#
public SoapTcpDuplexTransportBindingElement()
Delphi
public SoapTcpDuplexTransportBindingElement();
JScript
public function SoapTcpDuplexTransportBindingElement();
Managed Extensions for C++
public: SoapTcpDuplexTransportBindingElement();
C++/CLI
public:
SoapTcpDuplexTransportBindingElement();

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Constructor(SoapTcpDuplexTransportBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class > SoapTcpDuplexTransportBindingElement Constructor : SoapTcpDuplexTransportBindingElement Constructor(SoapTcpDuplexTransportBindingElement)

bindingElement
Initializes a new instance of SoapTcpDuplexTransportBindingElement.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal bindingElement As SoapTcpDuplexTransportBindingElement _
)
Visual Basic (Usage) Copy Code
Dim bindingElement As SoapTcpDuplexTransportBindingElement

Dim instance As New SoapTcpDuplexTransportBindingElement(bindingElement)
C#
protected SoapTcpDuplexTransportBindingElement(
   SoapTcpDuplexTransportBindingElement bindingElement
)
Delphi
protected SoapTcpDuplexTransportBindingElement(
    bindingElement: SoapTcpDuplexTransportBindingElement
);
JScript
protected function SoapTcpDuplexTransportBindingElement(
   bindingElement : SoapTcpDuplexTransportBindingElement
);
Managed Extensions for C++
protected: SoapTcpDuplexTransportBindingElement(
   SoapTcpDuplexTransportBindingElement* bindingElement
)
C++/CLI
protected:
SoapTcpDuplexTransportBindingElement(
   SoapTcpDuplexTransportBindingElement^ bindingElement
)

Parameters

bindingElement

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpDuplexTransportBindingElement Class

For a list of all members of this type, see SoapTcpDuplexTransportBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new SoapTcpDuplexTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
Top

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel factory creates.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
The BindingContext for the factory.
Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the factory.

Type Parameters

TChannel
The type of channel the channel factory creates.

Return Value

true if the specified channel factory stack can be built on the service; otherwise, false

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener stack can be built on the service; otherwise, false

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : Clone Method

Creates a new SoapTcpDuplexTransportBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A SoapTcpDuplexTransportBindingElement object with property values equal to those of the current element.

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in Clone


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpDuplexTransportBindingElement Class

For a list of all members of this type, see SoapTcpDuplexTransportBindingElement members.

Public Properties

 | Name | Description
public Property | ConnectionPooling | Enables and disables connection pooling. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | IdleTimeout | Gets and set the amount of time during which server will allow connection to stay idle before terminating it. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size of the buffer to use. For buffered messages this value is the same as MaxReceivedMessageSize. For streamed messages, this value is the maximum size of the SOAP headers, which must be read in buffered mode. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Channels.SoapTcpTransportBindingElement)
Top

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : Scheme Property

Gets the URI scheme for the transport.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Remarks

This property is used to validate bindings against base addresses.

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpTransportBindingElement Class

Represents the binding element used to specify the SOAP/TCP transport for transmitting messages.

Object Model

SoapTcpTransportBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class SoapTcpTransportBindingElement
   Inherits System.ServiceModel.Channels.TransportBindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
C#
public class SoapTcpTransportBindingElement : System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
Delphi
public class SoapTcpTransportBindingElement = class(System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement)
JScript
public class SoapTcpTransportBindingElement extends System.ServiceModel.Channels.TransportBindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class SoapTcpTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement
C++/CLI
public ref class SoapTcpTransportBindingElement : public System.ServiceModel.Channels.TransportBindingElement, IPluggableBindingElement

Remarks

SOAP/TCP is a specification by Sun Microsystems that describes an efficient and lightweight protocol for transmitting Web services messages over a TCP connection.

The SOAP/TCP transport included in WCF-Xtensions provides excellent performance when used with the Fast Infoset stateful message encoding which maintains the Fast Infoset vocabulary during a connection. This stateful message encoding eliminates the need to build a new vocabulary with every message, thus minimizing FI message size and maximizing FI processing performance.

With the Noemax SOAP/TCP you can use any TransferMode irrespective of the mode used by the remote side. You can also use message security and transport security, which is offered through StreamUpgradeBindingElement implementations such as the SslStreamSecurityElement. Note that currently the Sun SOAP/TCP only supports message security.

SOAP/TCP enables you to communicate over TCP with WCF as well as with any container that supports the Metro Web services stack.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
Noemax.WCFX.Channels.SoapTcpTransportBindingElement
Noemax.WCFX.Channels.SoapTcpDuplexTransportBindingElement

See Also

Reference

SoapTcpTransportBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpTransportBindingElement Class

The following tables list the members exposed by SoapTcpTransportBindingElement.

Public Constructors

 | Name | Description
public Constructor | SoapTcpTransportBindingElement Constructor | Overloaded. Initializes a new instance of SoapTcpTransportBindingElement.Initializes a new instance of SoapTcpTransportBindingElement.
Top

Public Properties

 | Name | Description
public Property | ConnectionPooling | Enables and disables connection pooling.
public Property | IdleTimeout | Gets and set the amount of time during which server will allow connection to stay idle before terminating it.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size of the buffer to use. For buffered messages this value is the same as MaxReceivedMessageSize. For streamed messages, this value is the maximum size of the SOAP headers, which must be read in buffered mode.
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new SoapTcpTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

SoapTcpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : SoapTcpTransportBindingElement Constructor

Initializes a new instance of SoapTcpTransportBindingElement.Initializes a new instance of SoapTcpTransportBindingElement.

Overload List

Overload | Description
SoapTcpTransportBindingElement Constructor() | Initializes a new instance of SoapTcpTransportBindingElement. Initializes a new instance of SoapTcpTransportBindingElement.
SoapTcpTransportBindingElement Constructor(SoapTcpTransportBindingElement) | Initializes a new instance of SoapTcpTransportBindingElement.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class > SoapTcpTransportBindingElement Constructor : SoapTcpTransportBindingElement Constructor()

Initializes a new instance of SoapTcpTransportBindingElement. Initializes a new instance of SoapTcpTransportBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SoapTcpTransportBindingElement()
C#
public SoapTcpTransportBindingElement()
Delphi
public SoapTcpTransportBindingElement();
JScript
public function SoapTcpTransportBindingElement();
Managed Extensions for C++
public: SoapTcpTransportBindingElement();
C++/CLI
public:
SoapTcpTransportBindingElement();

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Constructor(SoapTcpTransportBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class > SoapTcpTransportBindingElement Constructor : SoapTcpTransportBindingElement Constructor(SoapTcpTransportBindingElement)

source
Initializes a new instance of SoapTcpTransportBindingElement.

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal source As SoapTcpTransportBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As SoapTcpTransportBindingElement

Dim instance As New SoapTcpTransportBindingElement(source)
C#
protected SoapTcpTransportBindingElement(
   SoapTcpTransportBindingElement source
)
Delphi
protected SoapTcpTransportBindingElement(
    source: SoapTcpTransportBindingElement
);
JScript
protected function SoapTcpTransportBindingElement(
   source : SoapTcpTransportBindingElement
);
Managed Extensions for C++
protected: SoapTcpTransportBindingElement(
   SoapTcpTransportBindingElement* source
)
C++/CLI
protected:
SoapTcpTransportBindingElement(
   SoapTcpTransportBindingElement^ source
)

Parameters

source

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpTransportBindingElement Class

For a list of all members of this type, see SoapTcpTransportBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new SoapTcpTransportBindingElement object initialized from the current one.
public Method | GetProperty<T> | (Inherited from System.ServiceModel.Channels.BindingElement)
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

SoapTcpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel factory creates.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
The BindingContext for the factory.
Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the factory.

Type Parameters

TChannel
The type of channel the channel factory creates.

Return Value

true if the specified channel factory stack can be built on the service; otherwise, false

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener stack can be built on the service; otherwise, false

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : Clone Method

Creates a new SoapTcpTransportBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A SoapTcpTransportBindingElement object with property values equal to those of the current element.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements.
PlugIn(BindingElementCollection) | Creates a new BindingElementCollection based on the specified source, with SoapTcpTransportBindingElement plugged into the collection of binding elements.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class > PlugIn Method : PlugIn(Binding) Method

binding
The Bindin to use as source.
Creates a new CustomBinding based on the specified source Binding, with SoapTcpTransportBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal binding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim binding As Binding
Dim value As CustomBinding

value = instance.PlugIn(binding)
C#
public CustomBinding PlugIn(
   Binding binding
)
Delphi
public function PlugIn(
    binding: Binding
): CustomBinding;
JScript
public function PlugIn(
   binding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* binding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ binding
)

Parameters

binding
The Bindin to use as source.

Return Value

The CustomBinding based on the source Binding with SoapTcpTransportBindingElement binding element plugged into it.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
BindingElementCollection to use as source.
Creates a new BindingElementCollection based on the specified source, with SoapTcpTransportBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
BindingElementCollection to use as source.

Return Value

The BindingElementCollection based on the source BindingElementCollection with SoapTcpTransportBindingElement binding element plugged into it.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SoapTcpTransportBindingElement Class

For a list of all members of this type, see SoapTcpTransportBindingElement members.

Public Properties

 | Name | Description
public Property | ConnectionPooling | Enables and disables connection pooling.
public Property | IdleTimeout | Gets and set the amount of time during which server will allow connection to stay idle before terminating it.
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | Gets or sets the maximum size of the buffer to use. For buffered messages this value is the same as MaxReceivedMessageSize. For streamed messages, this value is the maximum size of the SOAP headers, which must be read in buffered mode.
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | Scheme | Overridden. Gets the URI scheme for the transport.
public Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
Top

See Also

Reference

SoapTcpTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConnectionPooling Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : ConnectionPooling Property

Enables and disables connection pooling.

Syntax

Visual Basic (Declaration)
Public Property ConnectionPooling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As Boolean

instance.ConnectionPooling = value

value = instance.ConnectionPooling
C#
public bool ConnectionPooling {get; set;}
Delphi
public read-write property ConnectionPooling: Boolean;
JScript
public function get,set ConnectionPooling : boolean
Managed Extensions for C++
public: __property bool get_ConnectionPooling();
public: __property void set_ConnectionPooling(
   bool value
);
C++/CLI
public:
property bool ConnectionPooling {
   bool get();
   void set (    bool value);
}

Property Value

If true outgoing connections are going to be pooled in connection pool and reused when client reconnects back to the same endpoint.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IdleTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : IdleTimeout Property

Gets and set the amount of time during which server will allow connection to stay idle before terminating it.

Syntax

Visual Basic (Declaration)
Public Property IdleTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As TimeSpan

instance.IdleTimeout = value

value = instance.IdleTimeout
C#
public TimeSpan IdleTimeout {get; set;}
Delphi
public read-write property IdleTimeout: TimeSpan;
JScript
public function get,set IdleTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_IdleTimeout();
public: __property void set_IdleTimeout(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan IdleTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : MaxBufferSize Property

Gets or sets the maximum size of the buffer to use. For buffered messages this value is the same as MaxReceivedMessageSize. For streamed messages, this value is the maximum size of the SOAP headers, which must be read in buffered mode.

Syntax

Visual Basic (Declaration)
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
public function get,set MaxBufferSize : int
Managed Extensions for C++
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : Scheme Property

Gets the URI scheme for the transport.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As String

value = instance.Scheme
C#
public override string Scheme {get;}
Delphi
public read-only property Scheme: String; override;
JScript
public override function get Scheme : String
Managed Extensions for C++
public: __property string* get_Scheme() override;
C++/CLI
public:
property String^ Scheme {
   String^ get() override;
}

Remarks

This property is used to validate bindings against base addresses.

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members
Base Implementation in Scheme


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Socks Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : Socks Property

Represents the settings of the SOCKS proxy to use to connect to the service endpoint.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socks As SocksSettings
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As SocksSettings

value = instance.Socks
C#
public SocksSettings Socks {get;}
Delphi
public read-only property Socks: SocksSettings;
JScript
public function get Socks : SocksSettings
Managed Extensions for C++
public: __property SocksSettings* get_Socks();
C++/CLI
public:
property SocksSettings^ Socks {
   SocksSettings^ get();
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
public function get,set TransferMode : TransferMode
Managed Extensions for C++
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettings Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : SocksSettings Class

Represents the SOCKS proxy settings.

Object Model

SocksSettings Class

Syntax

Visual Basic (Declaration)
Public Class SocksSettings
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
C#
public class SocksSettings
Delphi
public class SocksSettings
JScript
public class SocksSettings
Managed Extensions for C++
public __gc class SocksSettings
C++/CLI
public ref class SocksSettings

Inheritance Hierarchy

System.Object
Noemax.WCFX.Channels.SocksSettings

See Also

Reference

SocksSettings Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SocksSettings Class Members
See Also Properties Send Feedback
Noemax.WCFX.Channels Namespace : SocksSettings Class

The following tables list the members exposed by SocksSettings.

Public Constructors

 | Name | Description
public Constructor | SocksSettings Constructor | Overloaded. Initialize new instance of SocksSettings.
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the SOCKS protocol to use.
Top

See Also

Reference

SocksSettings Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettings Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : SocksSettings Constructor

Initialize new instance of SocksSettings.

Overload List

Overload | Description
SocksSettings Constructor() | Initialize new instance of SocksSettings.
SocksSettings Constructor(SocksSettings) | Initialize new instance of SocksSettings from already exiting object.

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettings Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class > SocksSettings Constructor : SocksSettings Constructor()

Initialize new instance of SocksSettings.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SocksSettings()
C#
public SocksSettings()
Delphi
public SocksSettings();
JScript
public function SocksSettings();
Managed Extensions for C++
public: SocksSettings();
C++/CLI
public:
SocksSettings();

See Also

Reference

SocksSettings Class
SocksSettings Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettings Constructor(SocksSettings)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class > SocksSettings Constructor : SocksSettings Constructor(SocksSettings)

settings
Initialize new instance of SocksSettings from already exiting object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal settings As SocksSettings _
)
Visual Basic (Usage) Copy Code
Dim settings As SocksSettings

Dim instance As New SocksSettings(settings)
C#
public SocksSettings(
   SocksSettings settings
)
Delphi
public SocksSettings(
    settings: SocksSettings
);
JScript
public function SocksSettings(
   settings : SocksSettings
);
Managed Extensions for C++
public: SocksSettings(
   SocksSettings* settings
)
C++/CLI
public:
SocksSettings(
   SocksSettings^ settings
)

Parameters

settings

See Also

Reference

SocksSettings Class
SocksSettings Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SocksSettings Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SocksSettings Class

For a list of all members of this type, see SocksSettings members.

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the SOCKS protocol to use.
Top

See Also

Reference

SocksSettings Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Address Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Address Property

Gets or sets the address of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public Property Address As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
Dim value As String

instance.Address = value

value = instance.Address
C#
public string Address {get; set;}
Delphi
public read-write property Address: String;
JScript
public function get,set Address : String
Managed Extensions for C++
public: __property string* get_Address();
public: __property void set_Address(
   string* value
);
C++/CLI
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authentication Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Authentication Property

Gets or sets the authentication scheme to use to connect through the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public Property Authentication As SocksAuthentication
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
Dim value As SocksAuthentication

instance.Authentication = value

value = instance.Authentication
C#
public SocksAuthentication Authentication {get; set;}
Delphi
public read-write property Authentication: SocksAuthentication;
JScript
public function get,set Authentication : SocksAuthentication
Managed Extensions for C++
public: __property SocksAuthentication get_Authentication();
public: __property void set_Authentication(
   SocksAuthentication value
);
C++/CLI
public:
property SocksAuthentication Authentication {
   SocksAuthentication get();
   void set (    SocksAuthentication value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Password Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Password Property

Sets the password to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings

instance.Password = value
C#
public string Password {set;}
Delphi
public write-only property Password: String;
JScript
public function set Password : String
Managed Extensions for C++
public: __property void set_Password(
   string* value
);
C++/CLI
public:
property String^ Password {
   void set (    String^ value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Port Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Port Property

Gets or sets the TCP port of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
Dim value As Integer

instance.Port = value

value = instance.Port
C#
public int Port {get; set;}
Delphi
public read-write property Port: Integer;
JScript
public function get,set Port : int
Managed Extensions for C++
public: __property int get_Port();
public: __property void set_Port(
   int value
);
C++/CLI
public:
property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Username Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Username Property

Gets or sets the username to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
Dim value As String

instance.Username = value

value = instance.Username
C#
public string Username {get; set;}
Delphi
public read-write property Username: String;
JScript
public function get,set Username : String
Managed Extensions for C++
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Version Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SocksSettings Class : Version Property

Gets or sets the version of the SOCKS protocol to use.

Syntax

Visual Basic (Declaration)
Public Property Version As SocksVersion
Visual Basic (Usage) Copy Code
Dim instance As SocksSettings
Dim value As SocksVersion

instance.Version = value

value = instance.Version
C#
public SocksVersion Version {get; set;}
Delphi
public read-write property Version: SocksVersion;
JScript
public function get,set Version : SocksVersion
Managed Extensions for C++
public: __property SocksVersion get_Version();
public: __property void set_Version(
   SocksVersion value
);
C++/CLI
public:
property SocksVersion Version {
   SocksVersion get();
   void set (    SocksVersion value);
}

See Also

Reference

SocksSettings Class
SocksSettings Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Channels Namespace : StreamEnhancerBindingElement Class

Represents a binding element that improves the performance of streaming through the transport connection by efficiently chunking the payload.

Object Model

StreamEnhancerBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class StreamEnhancerBindingElement
   Inherits System.ServiceModel.Channels.BindingElement
   Implements IPluggableBindingElement
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
C#
public class StreamEnhancerBindingElement : System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
Delphi
public class StreamEnhancerBindingElement = class(System.ServiceModel.Channels.BindingElement, IPluggableBindingElement)
JScript
public class StreamEnhancerBindingElement extends System.ServiceModel.Channels.BindingElement implements IPluggableBindingElement
Managed Extensions for C++
public __gc class StreamEnhancerBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement
C++/CLI
public ref class StreamEnhancerBindingElement : public System.ServiceModel.Channels.BindingElement, IPluggableBindingElement

Remarks

This extension can be used only in streaming transfer mode when transport produces chunks that are too small, which prevent the network connection to be utilized efficienty. You can use it with any transport binding element, whenever performance does not appear to be optimal or the network is not getting fully utilized by your channels.

StreamEnhancerElement plugs itself between TransportBindingElement and MessageEncodingBindingElement, ensuring that the message encoding consistently produces chunks of optimal size and equal size and also does not flush the buffer when it's not necessary.

You don't need to use StreamEnhancerBindingElement with binding elements and transports provided by WCF-Xtensions.

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.StreamEnhancerBindingElement

See Also

Reference

StreamEnhancerBindingElement Members
Noemax.WCFX.Channels Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Class Members
See Also Methods Send Feedback
Noemax.WCFX.Channels Namespace : StreamEnhancerBindingElement Class

The following tables list the members exposed by StreamEnhancerBindingElement.

Public Constructors

 | Name | Description
public Constructor | StreamEnhancerBindingElement Constructor | Overloaded. Initializes a new instance of StreamEnhancerBindingElement.Initializes a new instance of StreamEnhancerBindingElement.
Top

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with StreamEnhancerBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

StreamEnhancerBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : StreamEnhancerBindingElement Constructor

Initializes a new instance of StreamEnhancerBindingElement.Initializes a new instance of StreamEnhancerBindingElement.

Overload List

Overload | Description
StreamEnhancerBindingElement Constructor() | Initializes a new instance of StreamEnhancerBindingElement. Initializes a new instance of StreamEnhancerBindingElement.
StreamEnhancerBindingElement Constructor(StreamEnhancerBindingElement) | Initializes a new instance of StreamEnhancerBindingElement. Initializes a new instance of StreamEnhancerBindingElement.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class > StreamEnhancerBindingElement Constructor : StreamEnhancerBindingElement Constructor()

Initializes a new instance of StreamEnhancerBindingElement. Initializes a new instance of StreamEnhancerBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New StreamEnhancerBindingElement()
C#
public StreamEnhancerBindingElement()
Delphi
public StreamEnhancerBindingElement();
JScript
public function StreamEnhancerBindingElement();
Managed Extensions for C++
public: StreamEnhancerBindingElement();
C++/CLI
public:
StreamEnhancerBindingElement();

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Constructor(StreamEnhancerBindingElement)
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class > StreamEnhancerBindingElement Constructor : StreamEnhancerBindingElement Constructor(StreamEnhancerBindingElement)

source
Initializes a new instance of StreamEnhancerBindingElement. Initializes a new instance of StreamEnhancerBindingElement.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal source As StreamEnhancerBindingElement _
)
Visual Basic (Usage) Copy Code
Dim source As StreamEnhancerBindingElement

Dim instance As New StreamEnhancerBindingElement(source)
C#
public StreamEnhancerBindingElement(
   StreamEnhancerBindingElement source
)
Delphi
public StreamEnhancerBindingElement(
    source: StreamEnhancerBindingElement
);
JScript
public function StreamEnhancerBindingElement(
   source : StreamEnhancerBindingElement
);
Managed Extensions for C++
public: StreamEnhancerBindingElement(
   StreamEnhancerBindingElement* source
)
C++/CLI
public:
StreamEnhancerBindingElement(
   StreamEnhancerBindingElement^ source
)

Parameters

source

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
StreamEnhancerBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Channels Namespace : StreamEnhancerBindingElement Class

For a list of all members of this type, see StreamEnhancerBindingElement members.

Public Methods

 | Name | Description
public Method | BuildChannelFactory<TChannel> | Overridden. Builds the channel factory stack on the client that creates a specified type of channel for a specified context.
public Method | BuildChannelListener<TChannel> | Overridden. Builds the channel listener on the service that accepts a specified type of channel for a specified context.
public Method | CanBuildChannelFactory<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.
public Method | CanBuildChannelListener<TChannel> | Overridden. Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.
public Method | Clone | Overridden. Creates a new CompressionBindingElement object initialized from the current one.
public Method | GetProperty<T> | Overridden. Returns a typed object requested, if present, from the appropriate layer in the binding element stack.
public Method | PlugIn | Overloaded. Creates a new CustomBinding based on the specified source Binding, with StreamEnhancerBindingElement plugged into the collection of binding elements.
Top

See Also

Reference

StreamEnhancerBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
The type of channel the channel factory produces.
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : BuildChannelFactory<TChannel> Method

context
The BindingContext for the channel.
Builds the channel factory stack on the client that creates a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public override IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; override;
JScript
public override function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the channel.

Type Parameters

TChannel
The type of channel the channel factory produces.

Return Value

An IChannelFactory of type TChannel for the specified context.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in BuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : BuildChannelListener<TChannel> Method

context
The BindingContext for the listener.
Builds the channel listener on the service that accepts a specified type of channel for a specified context.

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public override IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; override;
JScript
public override function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the listener.

Type Parameters

TChannel
The type of channel the channel listener accepts

Return Value

An IChannelListener of type TChannel for the specified context

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in BuildChannelListener<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel factory creates.
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : CanBuildChannelFactory<TChannel> Method

context
The BindingContext for the factory.
Returns a value that indicates whether the current binding can build a channel factory for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public override bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
) override
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
) override

Parameters

context
The BindingContext for the factory.

Type Parameters

TChannel
The type of channel the channel factory creates.

Return Value

true if the specified channel factory stack can be built on the service; otherwise, false

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in CanBuildChannelFactory<TChannel>


%%PageItemTitle%%

TChannel
The type of channel the channel listener accepts.
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : CanBuildChannelListener<TChannel> Method

context
The BindingContext for the channel listener.
Returns a value that indicates whether the current binding can build a listener for a specified type of channel and context.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public override bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; override;
JScript
public override function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) override where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) override where TChannel: IChannel

Parameters

context
The BindingContext for the channel listener.

Type Parameters

TChannel
The type of channel the channel listener accepts.

Return Value

true if the specified channel listener can be built on the service; otherwise, false

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in CanBuildChannelListener<TChannel>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : Clone Method

Creates a new CompressionBindingElement object initialized from the current one.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public override BindingElement Clone()
Delphi
public function Clone(): BindingElement; override;
JScript
public override function Clone() : BindingElement;
Managed Extensions for C++
public: BindingElement* Clone(); override
C++/CLI
public:
BindingElement^ Clone(); override

Return Value

A CompressionBindingElement object with property values equal to those of the current element.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in Clone


%%PageItemTitle%%

T
The typed object for which the method is querying.
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : GetProperty<T> Method

context

The BindingContext for the binding element.

Returns a typed object requested, if present, from the appropriate layer in the binding element stack.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public override T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; override;
JScript
public override function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingContext* context
) override
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
) override

Parameters

context

The BindingContext for the binding element.

Type Parameters

T
The typed object for which the method is querying.

Return Value

The typed object T requested if it is present or a null reference (Nothing in Visual Basic) if it is not.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Base Implementation in GetProperty<T>


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class : PlugIn Method

Creates a new CustomBinding based on the specified source Binding, with StreamEnhancerBindingElement plugged into the collection of binding elements.

Overload List

Overload | Description
PlugIn(Binding) | Creates a new CustomBinding based on the specified source Binding, with StreamEnhancerBindingElement plugged into the collection of binding elements.
PlugIn(BindingElementCollection) | Creates a new BindingElementCollection based on the specified source BindingElementCollection, with StreamEnhancerBindingElement plugged into the collection of binding elements.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(Binding) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class > PlugIn Method : PlugIn(Binding) Method

targetBinding
The target binding to use as source.
Creates a new CustomBinding based on the specified source Binding, with StreamEnhancerBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal targetBinding As Binding _
) As CustomBinding
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim targetBinding As Binding
Dim value As CustomBinding

value = instance.PlugIn(targetBinding)
C#
public CustomBinding PlugIn(
   Binding targetBinding
)
Delphi
public function PlugIn(
    targetBinding: Binding
): CustomBinding;
JScript
public function PlugIn(
   targetBinding : Binding
) : CustomBinding;
Managed Extensions for C++
public: CustomBinding* PlugIn(
   Binding* targetBinding
)
C++/CLI
public:
CustomBinding^ PlugIn(
   Binding^ targetBinding
)

Parameters

targetBinding
The target binding to use as source.

Return Value

The CustomBinding based on the source Binding with StreamEnhancerBindingElement binding element plugged into it.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PlugIn(BindingElementCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > StreamEnhancerBindingElement Class > PlugIn Method : PlugIn(BindingElementCollection) Method

bindingElementCollection
The target BindingElementCollection to use as source.
Creates a new BindingElementCollection based on the specified source BindingElementCollection, with StreamEnhancerBindingElement plugged into the collection of binding elements.

Syntax

Visual Basic (Declaration)
Public Overloads Function PlugIn( _
   ByVal bindingElementCollection As BindingElementCollection _
) As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerBindingElement
Dim bindingElementCollection As BindingElementCollection
Dim value As BindingElementCollection

value = instance.PlugIn(bindingElementCollection)
C#
public BindingElementCollection PlugIn(
   BindingElementCollection bindingElementCollection
)
Delphi
public function PlugIn(
    bindingElementCollection: BindingElementCollection
): BindingElementCollection;
JScript
public function PlugIn(
   bindingElementCollection : BindingElementCollection
) : BindingElementCollection;
Managed Extensions for C++
public: BindingElementCollection* PlugIn(
   BindingElementCollection* bindingElementCollection
)
C++/CLI
public:
BindingElementCollection^ PlugIn(
   BindingElementCollection^ bindingElementCollection
)

Parameters

bindingElementCollection
The target BindingElementCollection to use as source.

Return Value

The BindingElementCollection based on the source BindingElementCollection with StreamEnhancerBindingElement binding element plugged into it.

See Also

Reference

StreamEnhancerBindingElement Class
StreamEnhancerBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionAlgorithms Enumeration

Defines a set of compression algorithms.

Syntax

Visual Basic (Declaration)
Public Enum CompressionAlgorithms
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CompressionAlgorithms
C#
public enum CompressionAlgorithms : System.Enum
Delphi
public enum CompressionAlgorithms = class(System.Enum)
JScript
public enum CompressionAlgorithms extends System.Enum
Managed Extensions for C++
__value public enum CompressionAlgorithms : public System.Enum
C++/CLI
public enum class CompressionAlgorithms : public System.Enum

Members

Member | Description
Deflate | DEFLATE.
DeflateGZip | DEFLATE or GZIP.
GZip | GZIP.
Lzf | LZF.
Lzf3 | LZF3.
Lzma | LZMA.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.CompressionAlgorithms

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : CompressionMethod Enumeration

Defines the compression method to be used.

Syntax

Visual Basic (Declaration)
Public Enum CompressionMethod
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CompressionMethod
C#
public enum CompressionMethod : System.Enum
Delphi
public enum CompressionMethod = class(System.Enum)
JScript
public enum CompressionMethod extends System.Enum
Managed Extensions for C++
__value public enum CompressionMethod : public System.Enum
C++/CLI
public enum class CompressionMethod : public System.Enum

Members

Member | Description
Deflate | DEFLATE compression algorithm.
GZip | GZIP compression algorithm.
Lzf | Lzf compression algorithm.
Lzf3 | LZF compression algorithm.
Lzma | LZMA compression algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.CompressionMethod

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EncodingCompressionMethod Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : EncodingCompressionMethod Enumeration

Defines a set of comrpession algorithms to be used by EnvelopBehavior.

Syntax

Visual Basic (Declaration)
Public Enum EncodingCompressionMethod
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As EncodingCompressionMethod
C#
public enum EncodingCompressionMethod : System.Enum
Delphi
public enum EncodingCompressionMethod = class(System.Enum)
JScript
public enum EncodingCompressionMethod extends System.Enum
Managed Extensions for C++
__value public enum EncodingCompressionMethod : public System.Enum
C++/CLI
public enum class EncodingCompressionMethod : public System.Enum

Members

Member | Description
Deflate | DEFLATE compression algorithm.
GZip | GZIP compression algorithm.
Lzf | LZF compression algorithm.
Lzf3 | LZF3 compression algorithm.
Lzma | LZMa compression algorithm.
None | No compression.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.EncodingCompressionMethod

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FastInfosetSessionMode Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : FastInfosetSessionMode Enumeration

Defines a set of stateful session encoding modes that may be used by the Fast Infoset message encoding.

Syntax

Visual Basic (Declaration)
Public Enum FastInfosetSessionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As FastInfosetSessionMode
C#
public enum FastInfosetSessionMode : System.Enum
Delphi
public enum FastInfosetSessionMode = class(System.Enum)
JScript
public enum FastInfosetSessionMode extends System.Enum
Managed Extensions for C++
__value public enum FastInfosetSessionMode : public System.Enum
C++/CLI
public enum class FastInfosetSessionMode : public System.Enum

Members

Member | Description
PerEncoder | The reader and writer maintain a single vocabulary for each message encoder.
PerThread | The reader or writer maintain a single vocabulary for each thread involved in message encoding.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.FastInfosetSessionMode

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartCompressionMode Enumeration
Example See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartCompressionMode Enumeration

Defines the mode of message compression.

Syntax

Visual Basic (Declaration)
Public Enum SmartCompressionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SmartCompressionMode
C#
public enum SmartCompressionMode : System.Enum
Delphi
public enum SmartCompressionMode = class(System.Enum)
JScript
public enum SmartCompressionMode extends System.Enum
Managed Extensions for C++
__value public enum SmartCompressionMode : public System.Enum
C++/CLI
public enum class SmartCompressionMode : public System.Enum

Members

Member | Description
Adaptive | The channel should not use compression unless the remote side indicates that it supports compression. Once compression is enabled all outgoing messages are compressed. The channel will decompress incoming compressed messages.
None | The channel will not use compression. The channel will refuse incoming compressed messages.
Optimistic | The channel should always compress and decompress messages.
Pessimistic | The channel should use compression only to reply to compressed requests or to requests which indicate that compression is supported. The channel will decompress incoming compressed messages.
Selective | The channel should use compression only for methods marked with the EnableCompression attribute and only when the remote side has indicated that it supports compression. The channel will decompress incoming compressed messages.

Example

Decompression of compressed incoming messages is supported in all modes except of None which indicates that compression and decompression are prohibited.

Copy Code

  Inheritance Hierarchy
System.Object
   System.ValueType
      System.Enum
         Noemax.WCFX.Channels.SmartCompressionMode

  See Also
Reference
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartMessageEncodingMode Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartMessageEncodingMode Enumeration

Defines the mode of smart message encoding.

Syntax

Visual Basic (Declaration)
Public Enum SmartMessageEncodingMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SmartMessageEncodingMode
C#
public enum SmartMessageEncodingMode : System.Enum
Delphi
public enum SmartMessageEncodingMode = class(System.Enum)
JScript
public enum SmartMessageEncodingMode extends System.Enum
Managed Extensions for C++
__value public enum SmartMessageEncodingMode : public System.Enum
C++/CLI
public enum class SmartMessageEncodingMode : public System.Enum

Members

Member | Description
Adaptive | The client will encode its request using the default message encoding; within this request it will also provide a list of preferred message encodings that it supports. If the server supports one of the preferred message encodings specified by the client, the server will return its response using a preferred message encoding; otherwise the server will use the default message encoding. The client will encode subsequent requests using the same encoding as the one used by the server in its last response.
Pessimistic | Pessimistic - The client will always encode its requests using the default message encoding; within these request it will also provide a list of preferred message encodings that it supports. If the server supports one of the preferred message encodings specified by the client, the server will return its response using a preferred message encoding; otherwise the server will use the default message encoding.

Remarks

The message encoding modes only affect the behavior of clients.

A server can decode any request provided that it has been encoded using one of the message encodings that it supports. To encode its response, the server will use one of the preferred message encodings specified by the client. If the server does not support any of the preferred message encodings then it will encode its response using the same message encoding as the one used by the client in its last request.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.SmartMessageEncodingMode

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartMessageEncodingSet Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SmartMessageEncodingSet Enumeration

Defines the set of message encodings.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SmartMessageEncodingSet
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SmartMessageEncodingSet
C#
[FlagsAttribute()]
public enum SmartMessageEncodingSet : System.Enum
Delphi
public enum SmartMessageEncodingSet = class(System.Enum)
JScript
FlagsAttribute()
public enum SmartMessageEncodingSet extends System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SmartMessageEncodingSet : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class SmartMessageEncodingSet : public System.Enum

Members

Member | Description
Custom | The set of message encodings defined by the MessageEncodings property of the corresponding binding.
Fi | Fast Infoset message encoding
FiText | FI (Preferred), Text (Default)
Text | Text message encoding

Remarks

The SmartMessageEncodingSet enumeration provides a fast way to specify the set of message encodings to be used by the binding. Each member of the enumeration represents a predefined combination of message encodings.

Regardless of the order in which the message encodings are specified during the initialization of the SmartMessageEncodingSet value, they are always used in the following predefined order of preference:

1. FastInfoset message encoding (Preferred).

2. Text message encoding (Default).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.SmartMessageEncodingSet

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksAuthentication Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SocksAuthentication Enumeration

Defines the type of authentication that the channel use in order to connect though the SOCKS proxy.

Syntax

Visual Basic (Declaration)
Public Enum SocksAuthentication
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SocksAuthentication
C#
public enum SocksAuthentication : System.Enum
Delphi
public enum SocksAuthentication = class(System.Enum)
JScript
public enum SocksAuthentication extends System.Enum
Managed Extensions for C++
__value public enum SocksAuthentication : public System.Enum
C++/CLI
public enum class SocksAuthentication : public System.Enum

Members

Member | Description
None | No authentication.
Username | Username/Password

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.SocksAuthentication

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksVersion Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : SocksVersion Enumeration

Defines the version of the SOCKS proxy that the channel uses in order to reach the server.

Syntax

Visual Basic (Declaration)
Public Enum SocksVersion
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SocksVersion
C#
public enum SocksVersion : System.Enum
Delphi
public enum SocksVersion = class(System.Enum)
JScript
public enum SocksVersion extends System.Enum
Managed Extensions for C++
__value public enum SocksVersion : public System.Enum
C++/CLI
public enum class SocksVersion : public System.Enum

Members

Member | Description
None | Channel does not use proxy.
Socks4 | SOCKS v4
Socks5 | SOCKS v5

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.SocksVersion

See Also

Reference

Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferModeX Enumeration
See Also Send Feedback
Noemax.WCFX.Channels Namespace : TransferModeX Enumeration

Defines the way in which data getting transfered by Noemax transports. This enumeration is used only on .NET CF platform as replacement for System.ServiceModel.Channels.TransferMode enumeration to extend it with additional transfer modes.

Syntax

Visual Basic (Declaration)
Public Enum TransferModeX
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TransferModeX
C#
public enum TransferModeX : System.Enum
Delphi
public enum TransferModeX = class(System.Enum)
JScript
public enum TransferModeX extends System.Enum
Managed Extensions for C++
__value public enum TransferModeX : public System.Enum
C++/CLI
public enum class TransferModeX : public System.Enum

Members

Member | Description
Buffered | The request and response messages are both buffered.
Streamed | The request and response messages are both streamed.
StreamedRequest | The request message is streamed and the response message is buffered.
StreamedResponse | The request message is buffered and the response message is streamed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Channels.TransferModeX

See Also

Reference

Noemax.WCFX.Channels Namespace


%%ItemTitle%%

Noemax.WCFX.Configuration Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | BasicSoapTcpBindingCollectionElement | Represents a configuration section that holds a collection of BasicSoapTcpBindingElement elements.
Class | BasicSoapTcpBindingElement | Represents a WCF configuration element which specifies the BasicSoapTcpBinding will be used and exposes its settings through configuration.
Class | BindingElementExtensionElementCollection<TBindingElementExtension> | Represents a configuration section that contains a collection of binding element extensions, each of which describes an aspect of how an endpoint communicates with other endpoints, that is built, consistently, into a channel factory on the client and a channel listener on the service.
Class | CompressionElement | Represents a WCF configuration element which specifies the CompressionBindingElement will be used and exposes its settings through configuration.
Class | ContentNegotiationElement | Represents a WCF configuration element which specifies the ContentNegotiationBindingElement will be used and exposes its settings through configuration.
Class | DuplexSoapTcpBindingCollectionElement | Represents a configuration section that holds a collection of DuplexSoapTcpBindingElement elements.
Class | DuplexSoapTcpBindingElement | Represents a WCF configuration element which specifies the DuplexSoapTcpBinding will be used and exposes its settings through configuration.
Class | EnvelopeEndpointBehaviorElement | Represents a WCF configuration element which specifies the EnvelopeEndpointBehavior will be used and exposes its settings through configuration.
Class | ExtensionBindingCollectionElement | Represents a configuration section that contains a collection of bindings, each of which describes an aspect of how an endpoint communicates with other endpoints, that is built, consistently, into a channel factory on the client and a channel listener on the service.
Class | ExtensionBindingElement | Represents a configuration section which contains a collection of binding element extensions that modify the behavior of an already defined binding.
Class | ExtensionBindingElementCollection | Represents a configuration section that holds a collection of ExtenstionBindingElement elements.
Class | FiMessageEncodingElement | Represents a WCF configuration element which specifies the FiMessageEncodingBindingElement will be used and exposes its settings through configuration.
Class | GenericConfigurationElementCollection<TConfigurationElement> | Represents a configuration element containing a collection of child elements.
Class | HttpsViaProxyTransportElement | Represents a WCF configuration element which specifies the HttpsViaProxyTransportBindingElement will be used and exposes its settings through configuration.
Class | LiteHttpsTransportElement | Represents a WCF configuration element which specifies the LiteHttpsTransportBindingElement will be used and exposes its settings through configuration.
Class | LiteHttpTransportElement | Represents a WCF configuration element which specifies the LiteHttpsTransportBindingElement will be used and exposes its settings through configuration.
Class | LocalClientSecurityUpdateElement | When used within <extensionBinding/> element, updates the target binding client security settings by overwriting them with properties of this class.
Class | LocalServiceSecurityUpdateElement | When used within <extensionBinding/> element, updates the target binding service security settings by overwriting them with properties of this class.
Class | MessageStatisticsElement | Represents a WCF configuration element which specifies the MessageStatisticsBindingElement will be used and exposes its settings through configuration.
Class | SmartHttpBindingCollectionElement | Represents a configuration section that holds a collection of SmartHttpBindingElement elements.
Class | SmartHttpBindingElement | Represents a WCF configuration element which specifies the SmartHttpBinding will be used and exposes its settings through configuration.
Class | SoapTcpDuplexTransportElement | Represents a WCF configuration element which specifies the SoapTcpDuplexTransportBindingElement will be used and exposes its settings through configuration.
Class | SoapTcpTransportElement | Represents a WCF configuration element which specifies the SoapTcpTransportBindingElement will be used and exposes its settings through configuration.
Class | SocksSettingsElement | Represents the SOCKS proxy settings.
Class | StreamEnhancerElement | Represents a WCF configuration element which specifies the StreamEnhancerBindingElement will be used and exposes its settings through configuration.
Class | WriterProfileDetailsElement | Provides customization of XmlFastInfosetWriterProfile through WCF configuration.

Enumerations

 | Enumeration | Description
Enumeration | XmlFastInfosetFormatSetting | Represents the XmlFastInfosetFormat enumeration in WCF configuration."
Enumeration | XmlFastInfosetWriterProfile | Represents the XmlFastInfosetWriterProfile enumeration in WCF configuration."

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingCollectionElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingCollectionElement Class

Represents a configuration section that holds a collection of BasicSoapTcpBindingElement elements.

Object Model

BasicSoapTcpBindingCollectionElement Class

Syntax

Visual Basic (Declaration)
Public Class BasicSoapTcpBindingCollectionElement
   Inherits System.ServiceModel.Configuration.StandardBindingCollectionElement(Of BasicSoapTcpBinding,BasicSoapTcpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
C#
public class BasicSoapTcpBindingCollectionElement : System.ServiceModel.Configuration.StandardBindingCollectionElement<BasicSoapTcpBinding,BasicSoapTcpBindingElement>
Delphi
public class BasicSoapTcpBindingCollectionElement = class(System.ServiceModel.Configuration.StandardBindingCollectionElement)
JScript
public class BasicSoapTcpBindingCollectionElement extends System.ServiceModel.Configuration.StandardBindingCollectionElement
Managed Extensions for C++
public __gc class BasicSoapTcpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<BasicSoapTcpBinding,BasicSoapTcpBindingElement>
C++/CLI
public ref class BasicSoapTcpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<BasicSoapTcpBinding,BasicSoapTcpBindingElement>

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.BindingCollectionElement
System.ServiceModel.Configuration.StandardBindingCollectionElement<TStandardBinding,TBindingConfiguration>
Noemax.WCFX.Configuration.BasicSoapTcpBindingCollectionElement

See Also

Reference

BasicSoapTcpBindingCollectionElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingCollectionElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingCollectionElement Class

The following tables list the members exposed by BasicSoapTcpBindingCollectionElement.

Public Constructors

 | Name | Description
public Constructor | BasicSoapTcpBindingCollectionElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<BasicSoapTcpBinding,BasicSoapTcpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingCollectionElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : BasicSoapTcpBindingCollectionElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BasicSoapTcpBindingCollectionElement()
C#
public BasicSoapTcpBindingCollectionElement()
Delphi
public BasicSoapTcpBindingCollectionElement();
JScript
public function BasicSoapTcpBindingCollectionElement();
Managed Extensions for C++
public: BasicSoapTcpBindingCollectionElement();
C++/CLI
public:
BasicSoapTcpBindingCollectionElement();

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingElement Class

Represents a WCF configuration element which specifies the BasicSoapTcpBinding will be used and exposes its settings through configuration.

Object Model

BasicSoapTcpBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class BasicSoapTcpBindingElement
   Inherits System.ServiceModel.Configuration.StandardBindingElement
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
C#
public class BasicSoapTcpBindingElement : System.ServiceModel.Configuration.StandardBindingElement
Delphi
public class BasicSoapTcpBindingElement = class(System.ServiceModel.Configuration.StandardBindingElement)
JScript
public class BasicSoapTcpBindingElement extends System.ServiceModel.Configuration.StandardBindingElement
Managed Extensions for C++
public __gc class BasicSoapTcpBindingElement : public System.ServiceModel.Configuration.StandardBindingElement
C++/CLI
public ref class BasicSoapTcpBindingElement : public System.ServiceModel.Configuration.StandardBindingElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.StandardBindingElement
Noemax.WCFX.Configuration.BasicSoapTcpBindingElement
Noemax.WCFX.Configuration.DuplexSoapTcpBindingElement

See Also

Reference

BasicSoapTcpBindingElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingElement Class

The following tables list the members exposed by BasicSoapTcpBindingElement.

Public Constructors

 | Name | Description
public Constructor | BasicSoapTcpBindingElement Constructor | Overloaded. Initializes a new instance of the SmartHttpBindnigElement class.
Top

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Compression | Gets and sets whether the messages sent through the will be compressed.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod |
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxBufferPoolSize | Gets and sets the size total size of the buffers used by the channel.
public Property | MaxBufferSize | Gets and sets the size limit for the buffers used by the channel.
public Property | MaxReceivedMessageSize | Gets and sets the maximum size limit for incomming messages.
public Property | MaxVocabularyStringLength |
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | PermitStateful |
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode |
public Property | WriterProfile |
public Property | WriterProfileDetails | Provides the customization of XmlFastInfosetWriterProfile through WCF configuration.
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Implements StandardBindingElement abstract class.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Implements StandardBindingElement abstract class.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | Overridden. Implements StandardBindingElement abstract class.
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BasicSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : BasicSoapTcpBindingElement Constructor

Initializes a new instance of the SmartHttpBindnigElement class.

Overload List

Overload | Description
BasicSoapTcpBindingElement Constructor() | Initializes a new instance of the BasicSoapTcpBindingElement class.
BasicSoapTcpBindingElement Constructor(String) | Initializes a new instance of the BasicSoapTcpBindingElement class with the specified configuration name.

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class > BasicSoapTcpBindingElement Constructor : BasicSoapTcpBindingElement Constructor()

Initializes a new instance of the BasicSoapTcpBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BasicSoapTcpBindingElement()
C#
public BasicSoapTcpBindingElement()
Delphi
public BasicSoapTcpBindingElement();
JScript
public function BasicSoapTcpBindingElement();
Managed Extensions for C++
public: BasicSoapTcpBindingElement();
C++/CLI
public:
BasicSoapTcpBindingElement();

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Constructor(String)
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class > BasicSoapTcpBindingElement Constructor : BasicSoapTcpBindingElement Constructor(String)

configurationName
The configuration name.
Initializes a new instance of the BasicSoapTcpBindingElement class with the specified configuration name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configurationName As String _
)
Visual Basic (Usage) Copy Code
Dim configurationName As String

Dim instance As New BasicSoapTcpBindingElement(configurationName)
C#
public BasicSoapTcpBindingElement(
   string configurationName
)
Delphi
public BasicSoapTcpBindingElement(
    configurationName: String
);
JScript
public function BasicSoapTcpBindingElement(
   configurationName : String
);
Managed Extensions for C++
public: BasicSoapTcpBindingElement(
   string* configurationName
)
C++/CLI
public:
BasicSoapTcpBindingElement(
   String^ configurationName
)

Parameters

configurationName
The configuration name.

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingElement Class

For a list of all members of this type, see BasicSoapTcpBindingElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | Overridden. Implements StandardBindingElement abstract class.
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BasicSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : OnApplyConfiguration Method

binding
Implements StandardBindingElement abstract class.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim binding As Binding

instance.OnApplyConfiguration(binding)
C#
protected override void OnApplyConfiguration(
   Binding binding
)
Delphi
protected procedure OnApplyConfiguration(
    binding: Binding
); override;
JScript
protected override function OnApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
protected: void OnApplyConfiguration(
   Binding* binding
) override
C++/CLI
protected:
void OnApplyConfiguration(
   Binding^ binding
) override

Parameters

binding

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members
Base Implementation in OnApplyConfiguration


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingElement Class

For a list of all members of this type, see BasicSoapTcpBindingElement members.

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Compression | Gets and sets whether the messages sent through the will be compressed.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod |
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxBufferPoolSize | Gets and sets the size total size of the buffers used by the channel.
public Property | MaxBufferSize | Gets and sets the size limit for the buffers used by the channel.
public Property | MaxReceivedMessageSize | Gets and sets the maximum size limit for incomming messages.
public Property | MaxVocabularyStringLength |
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | PermitStateful |
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode |
public Property | WriterProfile |
public Property | WriterProfileDetails | Provides the customization of XmlFastInfosetWriterProfile through WCF configuration.
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Implements StandardBindingElement abstract class.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Implements StandardBindingElement abstract class.
Top

See Also

Reference

BasicSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : BindingElementType Property

Implements StandardBindingElement abstract class.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Type

value = instance.BindingElementType
C#
protected override Type BindingElementType {get;}
Delphi
protected read-only property BindingElementType: Type; override;
JScript
protected override function get BindingElementType : Type
Managed Extensions for C++
protected: __property Type* get_BindingElementType() override;
C++/CLI
protected:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Compression Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : Compression Property

Gets and sets whether the messages sent through the will be compressed.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Compression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Boolean

instance.Compression = value

value = instance.Compression
C#
[ConfigurationPropertyAttribute(Name="compression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool Compression {get; set;}
Delphi
public read-write property Compression: Boolean;
JScript
ConfigurationPropertyAttribute(Name="compression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Compression : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_Compression();
public: __property void set_Compression(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool Compression {
   bool get();
   void set (    bool value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionLevel : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : CompressionMethod Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionMethod As CompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As CompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public CompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: CompressionMethod;
JScript
ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionMethod : CompressionMethod
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property CompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   CompressionMethod value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property CompressionMethod CompressionMethod {
   CompressionMethod get();
   void set (    CompressionMethod value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : MaxBufferPoolSize Property

Gets and sets the size total size of the buffers used by the channel.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : MaxBufferSize Property

Gets and sets the size limit for the buffers used by the channel.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : MaxReceivedMessageSize Property

Gets and sets the maximum size limit for incomming messages.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : MaxVocabularyStringLength Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PermitStateful Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : PermitStateful Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property PermitStateful As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Boolean

instance.PermitStateful = value

value = instance.PermitStateful
C#
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool PermitStateful {get; set;}
Delphi
public read-write property PermitStateful: Boolean;
JScript
ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set PermitStateful : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_PermitStateful();
public: __property void set_PermitStateful(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool PermitStateful {
   bool get();
   void set (    bool value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : Properties Property

Implements StandardBindingElement abstract class.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected override ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection; override;
JScript
protected override function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties() override;
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get() override;
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members
Base Implementation in Properties


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : TransferMode Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfile Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : WriterProfile Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property WriterProfile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As XmlFastInfosetWriterProfile

instance.WriterProfile = value

value = instance.WriterProfile
C#
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetWriterProfile WriterProfile {get; set;}
Delphi
public read-write property WriterProfile: XmlFastInfosetWriterProfile;
JScript
ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set WriterProfile : XmlFastInfosetWriterProfile
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetWriterProfile get_WriterProfile();
public: __property void set_WriterProfile(
   XmlFastInfosetWriterProfile value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetWriterProfile WriterProfile {
   XmlFastInfosetWriterProfile get();
   void set (    XmlFastInfosetWriterProfile value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfileDetails Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : WriterProfileDetails Property

Provides the customization of XmlFastInfosetWriterProfile through WCF configuration.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property WriterProfileDetails As WriterProfileDetailsElement
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As WriterProfileDetailsElement

instance.WriterProfileDetails = value

value = instance.WriterProfileDetails
C#
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public WriterProfileDetailsElement WriterProfileDetails {get; set;}
Delphi
public read-write property WriterProfileDetails: WriterProfileDetailsElement;
JScript
ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set WriterProfileDetails : WriterProfileDetailsElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property WriterProfileDetailsElement* get_WriterProfileDetails();
public: __property void set_WriterProfileDetails(
   WriterProfileDetailsElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property WriterProfileDetailsElement^ WriterProfileDetails {
   WriterProfileDetailsElement^ get();
   void set (    WriterProfileDetailsElement^ value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

TBindingElementExtension
[image]
Noemax WCF-Xtensions
BindingElementExtensionElementCollection<TBindingElementExtension> Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BindingElementExtensionElementCollection<TBindingElementExtension> Class

Represents a configuration section that contains a collection of binding element extensions, each of which describes an aspect of how an endpoint communicates with other endpoints, that is built, consistently, into a channel factory on the client and a channel listener on the service.

Object Model

BindingElementExtensionElementCollection<TBindingElementExtension> Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class BindingElementExtensionElementCollection(Of TBindingElementExtension)
   Inherits Noemax.WCFX.Configuration.GenericConfigurationElementCollection(Of BindingElementExtensionElement)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
C#
[DefaultMemberAttribute("Item")]
public class BindingElementExtensionElementCollection<TBindingElementExtension> : Noemax.WCFX.Configuration.GenericConfigurationElementCollection<BindingElementExtensionElement>
Delphi
public class BindingElementExtensionElementCollection = class(Noemax.WCFX.Configuration.GenericConfigurationElementCollection)
JScript
JScript does not support Generics.
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class BindingElementExtensionElementCollection<TBindingElementExtension> : public Noemax.WCFX.Configuration.GenericConfigurationElementCollection<BindingElementExtensionElement>
C++/CLI
[DefaultMemberAttribute("Item")]
generic<typename TBindingElementExtension>
public ref class BindingElementExtensionElementCollection : public Noemax.WCFX.Configuration.GenericConfigurationElementCollection<BindingElementExtensionElement>

Type Parameters

TBindingElementExtension

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Noemax.WCFX.Configuration.GenericConfigurationElementCollection<TConfigurationElement>
Noemax.WCFX.Configuration.BindingElementExtensionElementCollection<TBindingElementExtension>
Noemax.WCFX.Configuration.MessageEncodingElementCollection

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
BindingElementExtensionElementCollection<TBindingElementExtension> Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : BindingElementExtensionElementCollection<TBindingElementExtension> Class

The following tables list the members exposed by BindingElementExtensionElementCollection<TBindingElementExtension>.

Public Constructors

 | Name | Description
public Constructor | BindingElementExtensionElementCollection<TBindingElementExtension> Constructor | Initializes new instance of BindingElementExtensionElementCollection.
Top

Public Properties

 | Name | Description
public Property | CollectionType | Overridden. Gets the type of the collection.
public Property | Count | Gets the number of BindingElementExtensionElement contained in the collection.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsReadOnly |
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | Item | Overloaded. Gets or sets the element at the specified index.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Public Methods

 | Name | Description
public Method | Add | Adds BindingElementExtensionElement to the collection.
public Method | Clear | Removes all items from the collection.
public Method | Contains | Determines whether this collection contains a specific item.
public Method | ContainsKey | Returns true if collection contains element with specified key. (Inherited from Noemax.WCFX.Configuration.GenericConfigurationElementCollection<BindingElementExtensionElement>)
public Method | CopyTo | Overloaded. Copies the BindingElementExtensionElement of this collection to an Array, starting at a particular Array index.
public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
public Method | Remove | Removes the first occurrence of a specific object from the collection.
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Creates a new configruation element based on the configuration element name.
protected Method | GetElementKey | Overridden. Returns the key corresponding to the specified configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | Overridden. Checks if the element with specified name is already present in the collection.
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementExtensionElementCollection<TBindingElementExtension> Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : BindingElementExtensionElementCollection<TBindingElementExtension> Constructor

Initializes new instance of BindingElementExtensionElementCollection.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BindingElementExtensionElementCollection(Of TBindingElementExtension)()
C#
public BindingElementExtensionElementCollection<TBindingElementExtension>()
Delphi
public BindingElementExtensionElementCollection<TBindingElementExtension>();
JScript
public function BindingElementExtensionElementCollection<TBindingElementExtension>();
Managed Extensions for C++
public: BindingElementExtensionElementCollection<TBindingElementExtension>();
C++/CLI
public:
BindingElementExtensionElementCollection<TBindingElementExtension>();

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
BindingElementExtensionElementCollection<TBindingElementExtension> Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BindingElementExtensionElementCollection<TBindingElementExtension> Class

For a list of all members of this type, see BindingElementExtensionElementCollection<TBindingElementExtension> members.

Public Methods

 | Name | Description
public Method | Add | Adds BindingElementExtensionElement to the collection.
public Method | Clear | Removes all items from the collection.
public Method | Contains | Determines whether this collection contains a specific item.
public Method | ContainsKey | Returns true if collection contains element with specified key. (Inherited from Noemax.WCFX.Configuration.GenericConfigurationElementCollection<BindingElementExtensionElement>)
public Method | CopyTo | Overloaded. Copies the BindingElementExtensionElement of this collection to an Array, starting at a particular Array index.
public Method | GetEnumerator | Returns an enumerator that iterates through the collection.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
public Method | Remove | Removes the first occurrence of a specific object from the collection.
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Creates a new configruation element based on the configuration element name.
protected Method | GetElementKey | Overridden. Returns the key corresponding to the specified configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | Overridden. Checks if the element with specified name is already present in the collection.
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Add Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Add Method

item
A BindingElementExtensionElement to add to the collection.
Adds BindingElementExtensionElement to the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As BindingElementExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim item As BindingElementExtensionElement

instance.Add(item)
C#
public void Add(
   BindingElementExtensionElement item
)
Delphi
public procedure Add(
    item: BindingElementExtensionElement
);
JScript
public function Add(
   item : BindingElementExtensionElement
);
Managed Extensions for C++
public: void Add(
   BindingElementExtensionElement* item
)
C++/CLI
public:
void Add(
   BindingElementExtensionElement^ item
)

Parameters

item
A BindingElementExtensionElement to add to the collection.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Clear Method

Removes all items from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Contains Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Contains Method

item
The object to locate in the collection.
Determines whether this collection contains a specific item.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As BindingElementExtensionElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim item As BindingElementExtensionElement
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   BindingElementExtensionElement item
)
Delphi
public function Contains(
    item: BindingElementExtensionElement
): Boolean;
JScript
public function Contains(
   item : BindingElementExtensionElement
) : boolean;
Managed Extensions for C++
public: bool Contains(
   BindingElementExtensionElement* item
)
C++/CLI
public:
bool Contains(
   BindingElementExtensionElement^ item
)

Parameters

item
The object to locate in the collection.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : CopyTo Method

Copies the BindingElementExtensionElement of this collection to an Array, starting at a particular Array index.

Overload List

Overload | Description
CopyTo(BindingElementExtensionElement[],Int32) | Copies the BindingElementExtensionElement of this collection to an Array, starting at a particular Array index.
CopyTo(ConfigurationElement[],Int32) | (Inherited from System.Configuration.ConfigurationElementCollection)

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(BindingElementExtensionElement[],Int32) Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class > CopyTo Method : CopyTo(BindingElementExtensionElement[],Int32) Method

array
The one-dimensional array that is the destination of the elements copied from this collection.
arrayIndex

The zero-based index in array at which copying begins.

Copies the BindingElementExtensionElement of this collection to an Array, starting at a particular Array index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As BindingElementExtensionElement, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim array() As BindingElementExtensionElement
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   BindingElementExtensionElement[] array,
   int arrayIndex
)
Delphi
public procedure CopyTo(
    array: BindingElementExtensionElementarray of;
    arrayIndex: Integer
);
JScript
public function CopyTo(
   array : BindingElementExtensionElement[],
   arrayIndex : int
);
Managed Extensions for C++
public: void CopyTo(
   BindingElementExtensionElement*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<BindingElementExtensionElement^>^ array,
   int arrayIndex
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from this collection.
arrayIndex

The zero-based index in array at which copying begins.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : CreateNewElement Method

Creates a new configruation element based on the configuration element name.

Overload List

Overload | Description
CreateNewElement(String) | Creates a new configruation element based on the configuration element name.
CreateNewElement() | (Inherited from System.Configuration.ConfigurationElementCollection)

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Base Implementation in CreateNewElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement(String) Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class > CreateNewElement Method : CreateNewElement(String) Method

elementName
The name of configuration element to create.
Creates a new configruation element based on the configuration element name.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function CreateNewElement( _
   ByVal elementName As String _
) As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim elementName As String
Dim value As ConfigurationElement

value = instance.CreateNewElement(elementName)
C#
protected override ConfigurationElement CreateNewElement(
   string elementName
)
Delphi
protected function CreateNewElement(
    elementName: String
): ConfigurationElement; override;
JScript
protected override function CreateNewElement(
   elementName : String
) : ConfigurationElement;
Managed Extensions for C++
protected: ConfigurationElement* CreateNewElement(
   string* elementName
) override
C++/CLI
protected:
ConfigurationElement^ CreateNewElement(
   String^ elementName
) override

Parameters

elementName
The name of configuration element to create.

Return Value

A created configuration element.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Overload List
Base Implementation in CreateNewElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetElementKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : GetElementKey Method

element
The configuration element.
Returns the key corresponding to the specified configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetElementKey( _
   ByVal element As ConfigurationElement _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim element As ConfigurationElement
Dim value As Object

value = instance.GetElementKey(element)
C#
protected override object GetElementKey(
   ConfigurationElement element
)
Delphi
protected function GetElementKey(
    element: ConfigurationElement
): TObject; override;
JScript
protected override function GetElementKey(
   element : ConfigurationElement
) : Object;
Managed Extensions for C++
protected: Object* GetElementKey(
   ConfigurationElement* element
) override
C++/CLI
protected:
Object^ GetElementKey(
   ConfigurationElement^ element
) override

Parameters

element
The configuration element.

Return Value

The key corresponding to the specified configuration element

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Base Implementation in GetElementKey


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetEnumerator Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : GetEnumerator Method

Returns an enumerator that iterates through the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator(Of BindingElementExtensionElement)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As IEnumerator(Of BindingElementExtensionElement)

value = instance.GetEnumerator()
C#
public new IEnumerator<BindingElementExtensionElement> GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public hide function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: new IEnumerator<BindingElementExtensionElement*>* GetEnumerator();
C++/CLI
public:
new IEnumerator<BindingElementExtensionElement^>^ GetEnumerator();

Return Value

A IEnumerator<BindingElementExtensionElement> that can be used to iterate through the collection.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementName Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : IsElementName Method

elementName
The specified name of the element.
Checks if the element with specified name is already present in the collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsElementName( _
   ByVal elementName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim elementName As String
Dim value As Boolean

value = instance.IsElementName(elementName)
C#
protected override bool IsElementName(
   string elementName
)
Delphi
protected function IsElementName(
    elementName: String
): Boolean; override;
JScript
protected override function IsElementName(
   elementName : String
) : boolean;
Managed Extensions for C++
protected: bool IsElementName(
   string* elementName
) override
C++/CLI
protected:
bool IsElementName(
   String^ elementName
) override

Parameters

elementName
The specified name of the element.

Return Value

true if element with the specified name is already present in the collection; otherwise false.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Base Implementation in IsElementName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Remove Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Remove Method

item

The object to remove from the collection.

Removes the first occurrence of a specific object from the collection.

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As BindingElementExtensionElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim item As BindingElementExtensionElement
Dim value As Boolean

value = instance.Remove(item)
C#
public bool Remove(
   BindingElementExtensionElement item
)
Delphi
public function Remove(
    item: BindingElementExtensionElement
): Boolean;
JScript
public function Remove(
   item : BindingElementExtensionElement
) : boolean;
Managed Extensions for C++
public: bool Remove(
   BindingElementExtensionElement* item
)
C++/CLI
public:
bool Remove(
   BindingElementExtensionElement^ item
)

Parameters

item

The object to remove from the collection.

Return Value

true if item was successfully removed from the collection; otherwise, false. This method also returns false if item is not found in the original collection.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
BindingElementExtensionElementCollection<TBindingElementExtension> Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BindingElementExtensionElementCollection<TBindingElementExtension> Class

For a list of all members of this type, see BindingElementExtensionElementCollection<TBindingElementExtension> members.

Public Properties

 | Name | Description
public Property | CollectionType | Overridden. Gets the type of the collection.
public Property | Count | Gets the number of BindingElementExtensionElement contained in the collection.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsReadOnly |
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | Item | Overloaded. Gets or sets the element at the specified index.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CollectionType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : CollectionType Property

Gets the type of the collection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationElementCollectionType

value = instance.CollectionType
C#
public override ConfigurationElementCollectionType CollectionType {get;}
Delphi
public read-only property CollectionType: ConfigurationElementCollectionType; override;
JScript
public override function get CollectionType : ConfigurationElementCollectionType
Managed Extensions for C++
public: __property ConfigurationElementCollectionType get_CollectionType() override;
C++/CLI
public:
property ConfigurationElementCollectionType CollectionType {
   ConfigurationElementCollectionType get() override;
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Base Implementation in CollectionType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Count Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Count Property

Gets the number of BindingElementExtensionElement contained in the collection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Integer

value = instance.Count
C#
public new int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public hide function get Count : int
Managed Extensions for C++
public: __property new int get_Count();
C++/CLI
public:
new property int Count {
   int get();
}

Property Value

The number of BindingElementExtensionElement contained in the collection.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean;
JScript
public function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : Item Property

Gets or sets the element at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the element at the specified index.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item(Int32) Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class > Item Property : Item(Int32) Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows ReadOnly Property Item( _
   ByVal index As Integer _
) As BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim index As Integer
Dim value As BindingElementExtensionElement

value = instance.Item(index)
C#
public new BindingElementExtensionElement Item(
   int index
) {get;}
Delphi
public read-only property Item(
    index: Integer
): BindingElementExtensionElement;
JScript
public hide function get Item(
   index : int
) : BindingElementExtensionElement
Managed Extensions for C++
public: __property new BindingElementExtensionElement* get_Item(
   int index
);
C++/CLI
public:
new property BindingElementExtensionElement^ Item {
   BindingElementExtensionElement^ get(int index);
}

Parameters

index

Property Value

The element at the specified index.

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : CompressionElement Class

Represents a WCF configuration element which specifies the CompressionBindingElement will be used and exposes its settings through configuration.

Object Model

CompressionElement Class

Syntax

Visual Basic (Declaration)
Public Class CompressionElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
C#
public class CompressionElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class CompressionElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class CompressionElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class CompressionElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class CompressionElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Remarks

When this element is added to a custom binding, the resulting channel supports message compression.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.CompressionElement

See Also

Reference

CompressionElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
CompressionElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : CompressionElement Class

The following tables list the members exposed by CompressionElement.

Public Constructors

 | Name | Description
public Constructor | CompressionElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

CompressionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CompressionElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New CompressionElement()
C#
public CompressionElement()
Delphi
public CompressionElement();
JScript
public function CompressionElement();
Managed Extensions for C++
public: CompressionElement();
C++/CLI
public:
CompressionElement();

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
CompressionElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : CompressionElement Class

For a list of all members of this type, see CompressionElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

CompressionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

CompressionElement Class
CompressionElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CreateBindingElement Method

Initializes a new instance of CompressionBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

Return Value

A CompressionBindingElement instance.

See Also

Reference

CompressionElement Class
CompressionElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
CompressionElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : CompressionElement Class

For a list of all members of this type, see CompressionElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

CompressionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

Property Value

The type of BindingElement represented by this configuration element.

See Also

Reference

CompressionElement Class
CompressionElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionLevel : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CompressionMethod Property

Gets and sets the algorithm used for compressing the message payload.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionMethod As CompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As CompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public CompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: CompressionMethod;
JScript
ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionMethod : CompressionMethod
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property CompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   CompressionMethod value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property CompressionMethod CompressionMethod {
   CompressionMethod get();
   void set (    CompressionMethod value);
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ContentNegotiationElement Class

Represents a WCF configuration element which specifies the ContentNegotiationBindingElement will be used and exposes its settings through configuration.

Object Model

ContentNegotiationElement Class

Syntax

Visual Basic (Declaration)
Public Class ContentNegotiationElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
C#
public class ContentNegotiationElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class ContentNegotiationElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class ContentNegotiationElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class ContentNegotiationElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class ContentNegotiationElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.ContentNegotiationElement

See Also

Reference

ContentNegotiationElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ContentNegotiationElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : ContentNegotiationElement Class

The following tables list the members exposed by ContentNegotiationElement.

Public Constructors

 | Name | Description
public Constructor | ContentNegotiationElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. When overridden in a derived class, gets the Type object that represents the custom binding element.
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the message compression mode to be used by this binding.
public Property | CompressionThreshold | Gets and sets the minimal size of the payload to be compressed, if compression is enabled.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | ForceStreamedCompression | Enables the streamed compression in the buffered transfer mode.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.
public Property | ZlibHeader | Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets a collectoin of configuration properties.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.BindingElementExtensionElement)
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Creates a binding element object represented by the configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ContentNegotiationElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContentNegotiationElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ContentNegotiationElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ContentNegotiationElement()
C#
public ContentNegotiationElement()
Delphi
public ContentNegotiationElement();
JScript
public function ContentNegotiationElement();
Managed Extensions for C++
public: ContentNegotiationElement();
C++/CLI
public:
ContentNegotiationElement();

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ContentNegotiationElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ContentNegotiationElement Class

For a list of all members of this type, see ContentNegotiationElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.BindingElementExtensionElement)
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Creates a binding element object represented by the configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ContentNegotiationElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CreateBindingElement Method

Creates a binding element object represented by the configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

Return Value

A custom BindingElement object.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ContentNegotiationElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ContentNegotiationElement Class

For a list of all members of this type, see ContentNegotiationElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. When overridden in a derived class, gets the Type object that represents the custom binding element.
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and sets the message compression mode to be used by this binding.
public Property | CompressionThreshold | Gets and sets the minimal size of the payload to be compressed, if compression is enabled.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | ForceStreamedCompression | Enables the streamed compression in the buffered transfer mode.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.
public Property | ZlibHeader | Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets a collectoin of configuration properties.
Top

See Also

Reference

ContentNegotiationElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : BindingElementType Property

When overridden in a derived class, gets the Type object that represents the custom binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

Property Value

Returns the type of the binding element this configuration element associates with the configuration system.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionLevel : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

Remarks

At compression level 1 the emphasis is on minimum consumption of resources, so the writer configures the compression algorithm for fast processing performance and low memory use.

At compression level 9 the emphasis is on maximum compression, so the writer configures the compression algorithm to produce the smallest compressed data size.

At intermediate compression levels the writer configures the compression algorithm to a provide a progressive transition between levels 1 and 9.

The efficiency of compression algorithms varies depending on the data to be compressed. It is possible that minimum consumption of resources will be provided by a compression level other than 1, and maximum compression by a compression level other than 9. It is suggested that you try specifying different compression levels to find out which one is most suitable for your use case and requirements.

Some compression algorithms cannot be configured. In such cases, specifying different compression levels has no effect.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CompressionMode Property

Gets and sets the message compression mode to be used by this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionThreshold Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CompressionThreshold Property

Gets and sets the minimal size of the payload to be compressed, if compression is enabled.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionThreshold",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionThreshold As Integer
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Integer

instance.CompressionThreshold = value

value = instance.CompressionThreshold
C#
[ConfigurationPropertyAttribute(Name="compressionThreshold",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionThreshold {get; set;}
Delphi
public read-write property CompressionThreshold: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionThreshold",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionThreshold : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionThreshold",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionThreshold();
public: __property void set_CompressionThreshold(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionThreshold",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionThreshold {
   int get();
   void set (    int value);
}

Remarks

Specifies the minimal size of the payload that channel will compress. If the size of the payload is lower than specified value, compression will not be applied to it.

The default value of this property is 0, all payload will be compressed irrespective of it's size.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ForceStreamedCompression Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ForceStreamedCompression Property

Enables the streamed compression in the buffered transfer mode.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="forceStreamedCompression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ForceStreamedCompression As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Boolean

instance.ForceStreamedCompression = value

value = instance.ForceStreamedCompression
C#
[ConfigurationPropertyAttribute(Name="forceStreamedCompression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ForceStreamedCompression {get; set;}
Delphi
public read-write property ForceStreamedCompression: Boolean;
JScript
ConfigurationPropertyAttribute(Name="forceStreamedCompression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ForceStreamedCompression : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="forceStreamedCompression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ForceStreamedCompression();
public: __property void set_ForceStreamedCompression(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="forceStreamedCompression",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ForceStreamedCompression {
   bool get();
   void set (    bool value);
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : MessageEncodingMode Property

Gets and sets the message encoding mode to be used by this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MessageEncodingMode As SmartMessageEncodingMode
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As SmartMessageEncodingMode

instance.MessageEncodingMode = value

value = instance.MessageEncodingMode
C#
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SmartMessageEncodingMode MessageEncodingMode {get; set;}
Delphi
public read-write property MessageEncodingMode: SmartMessageEncodingMode;
JScript
ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MessageEncodingMode : SmartMessageEncodingMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SmartMessageEncodingMode get_MessageEncodingMode();
public: __property void set_MessageEncodingMode(
   SmartMessageEncodingMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SmartMessageEncodingMode MessageEncodingMode {
   SmartMessageEncodingMode get();
   void set (    SmartMessageEncodingMode value);
}

Remarks

Regardless of the MessageEncodingMode settings, this binding is always able to decode messages encoded using any of the message encodings specified by the MessageEncodings collection.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : MessageEncodings Property

A collection of MessageEncodingBindingElement used for dynamic content negotiation as set of alternative message encodings.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property MessageEncodings As BindingElementExtensionElementCollection(Of MessageEncodingBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As BindingElementExtensionElementCollection(Of MessageEncodingBindingElement)

value = instance.MessageEncodings
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public BindingElementExtensionElementCollection<MessageEncodingBindingElement> MessageEncodings {get;}
Delphi
public read-only property MessageEncodings: BindingElementExtensionElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get MessageEncodings : BindingElementExtensionElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property BindingElementExtensionElementCollection<MessageEncodingBindingElement*>* get_MessageEncodings();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property BindingElementExtensionElementCollection<MessageEncodingBindingElement^>^ MessageEncodings {
   BindingElementExtensionElementCollection<MessageEncodingBindingElement^>^ get();
}

Remarks

Collection should be populated with MessageEncodingBindingElement according to the rules specified in MessageEncodingBindingElementCollection. This is a default collection for this configuration element.

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : Properties Property

Gets a collectoin of configuration properties.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected override ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection; override;
JScript
protected override function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties() override;
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get() override;
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members
Base Implementation in Properties


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ZlibHeader Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ZlibHeader Property

Specified whether the RFC 1950 Zlib format is used for DEFLATE compression.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="zlibHeader",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ZlibHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Boolean

instance.ZlibHeader = value

value = instance.ZlibHeader
C#
[ConfigurationPropertyAttribute(Name="zlibHeader",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ZlibHeader {get; set;}
Delphi
public read-write property ZlibHeader: Boolean;
JScript
ConfigurationPropertyAttribute(Name="zlibHeader",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ZlibHeader : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="zlibHeader",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ZlibHeader();
public: __property void set_ZlibHeader(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="zlibHeader",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ZlibHeader {
   bool get();
   void set (    bool value);
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingCollectionElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingCollectionElement Class

Represents a configuration section that holds a collection of DuplexSoapTcpBindingElement elements.

Object Model

DuplexSoapTcpBindingCollectionElement Class

Syntax

Visual Basic (Declaration)
Public Class DuplexSoapTcpBindingCollectionElement
   Inherits System.ServiceModel.Configuration.StandardBindingCollectionElement(Of DuplexSoapTcpBinding,DuplexSoapTcpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
C#
public class DuplexSoapTcpBindingCollectionElement : System.ServiceModel.Configuration.StandardBindingCollectionElement<DuplexSoapTcpBinding,DuplexSoapTcpBindingElement>
Delphi
public class DuplexSoapTcpBindingCollectionElement = class(System.ServiceModel.Configuration.StandardBindingCollectionElement)
JScript
public class DuplexSoapTcpBindingCollectionElement extends System.ServiceModel.Configuration.StandardBindingCollectionElement
Managed Extensions for C++
public __gc class DuplexSoapTcpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<DuplexSoapTcpBinding,DuplexSoapTcpBindingElement>
C++/CLI
public ref class DuplexSoapTcpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<DuplexSoapTcpBinding,DuplexSoapTcpBindingElement>

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.BindingCollectionElement
System.ServiceModel.Configuration.StandardBindingCollectionElement<TStandardBinding,TBindingConfiguration>
Noemax.WCFX.Configuration.DuplexSoapTcpBindingCollectionElement

See Also

Reference

DuplexSoapTcpBindingCollectionElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingCollectionElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingCollectionElement Class

The following tables list the members exposed by DuplexSoapTcpBindingCollectionElement.

Public Constructors

 | Name | Description
public Constructor | DuplexSoapTcpBindingCollectionElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<DuplexSoapTcpBinding,DuplexSoapTcpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingCollectionElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : DuplexSoapTcpBindingCollectionElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DuplexSoapTcpBindingCollectionElement()
C#
public DuplexSoapTcpBindingCollectionElement()
Delphi
public DuplexSoapTcpBindingCollectionElement();
JScript
public function DuplexSoapTcpBindingCollectionElement();
Managed Extensions for C++
public: DuplexSoapTcpBindingCollectionElement();
C++/CLI
public:
DuplexSoapTcpBindingCollectionElement();

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingElement Class

Represents a WCF configuration element which specifies the DuplexSoapTcpBinding will be used and exposes its settings through configuration.

Object Model

DuplexSoapTcpBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class DuplexSoapTcpBindingElement
   Inherits BasicSoapTcpBindingElement
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
C#
public class DuplexSoapTcpBindingElement : BasicSoapTcpBindingElement
Delphi
public class DuplexSoapTcpBindingElement = class(BasicSoapTcpBindingElement)
JScript
public class DuplexSoapTcpBindingElement extends BasicSoapTcpBindingElement
Managed Extensions for C++
public __gc class DuplexSoapTcpBindingElement : public BasicSoapTcpBindingElement
C++/CLI
public ref class DuplexSoapTcpBindingElement : public BasicSoapTcpBindingElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.StandardBindingElement
Noemax.WCFX.Configuration.BasicSoapTcpBindingElement
Noemax.WCFX.Configuration.DuplexSoapTcpBindingElement

See Also

Reference

DuplexSoapTcpBindingElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingElement Class

The following tables list the members exposed by DuplexSoapTcpBindingElement.

Public Constructors

 | Name | Description
public Constructor | DuplexSoapTcpBindingElement Constructor | Overloaded. Initializes a new instance of the SmartHttpBindnigElement class.
Top

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Compression | Gets and sets whether the messages sent through the will be compressed. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CompressionMethod | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxBufferPoolSize | Gets and sets the size total size of the buffers used by the channel. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxBufferSize | Gets and sets the size limit for the buffers used by the channel. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxReceivedMessageSize | Gets and sets the maximum size limit for incomming messages. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxVocabularyStringLength | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | PermitStateful | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | WriterProfile | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | WriterProfileDetails | Provides the customization of XmlFastInfosetWriterProfile through WCF configuration. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Gets the type of associated System.ServiceModel.Channels.BindingElement.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : DuplexSoapTcpBindingElement Constructor

Initializes a new instance of the SmartHttpBindnigElement class.

Overload List

Overload | Description
DuplexSoapTcpBindingElement Constructor() | Initializes a new instance of the BasicSoapTcpBindingElement class.
DuplexSoapTcpBindingElement Constructor(String) | Initializes a new instance of the BasicSoapTcpBindingElement class with the specified configuration name.

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class > DuplexSoapTcpBindingElement Constructor : DuplexSoapTcpBindingElement Constructor()

Initializes a new instance of the BasicSoapTcpBindingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New DuplexSoapTcpBindingElement()
C#
public DuplexSoapTcpBindingElement()
Delphi
public DuplexSoapTcpBindingElement();
JScript
public function DuplexSoapTcpBindingElement();
Managed Extensions for C++
public: DuplexSoapTcpBindingElement();
C++/CLI
public:
DuplexSoapTcpBindingElement();

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Constructor(String)
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class > DuplexSoapTcpBindingElement Constructor : DuplexSoapTcpBindingElement Constructor(String)

configurationName
The configuration name.
Initializes a new instance of the BasicSoapTcpBindingElement class with the specified configuration name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configurationName As String _
)
Visual Basic (Usage) Copy Code
Dim configurationName As String

Dim instance As New DuplexSoapTcpBindingElement(configurationName)
C#
public DuplexSoapTcpBindingElement(
   string configurationName
)
Delphi
public DuplexSoapTcpBindingElement(
    configurationName: String
);
JScript
public function DuplexSoapTcpBindingElement(
   configurationName : String
);
Managed Extensions for C++
public: DuplexSoapTcpBindingElement(
   string* configurationName
)
C++/CLI
public:
DuplexSoapTcpBindingElement(
   String^ configurationName
)

Parameters

configurationName
The configuration name.

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingElement Class

For a list of all members of this type, see DuplexSoapTcpBindingElement members.

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Compression | Gets and sets whether the messages sent through the will be compressed. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CompressionMethod | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxBufferPoolSize | Gets and sets the size total size of the buffers used by the channel. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxBufferSize | Gets and sets the size limit for the buffers used by the channel. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxReceivedMessageSize | Gets and sets the maximum size limit for incomming messages. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | MaxVocabularyStringLength | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | PermitStateful | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | WriterProfile | (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
public Property | WriterProfileDetails | Provides the customization of XmlFastInfosetWriterProfile through WCF configuration. (Inherited from Noemax.WCFX.Configuration.BasicSoapTcpBindingElement)
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Gets the type of associated System.ServiceModel.Channels.BindingElement.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : BindingElementType Property

Gets the type of associated System.ServiceModel.Channels.BindingElement.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As Type

value = instance.BindingElementType
C#
protected override Type BindingElementType {get;}
Delphi
protected read-only property BindingElementType: Type; override;
JScript
protected override function get BindingElementType : Type
Managed Extensions for C++
protected: __property Type* get_BindingElementType() override;
C++/CLI
protected:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehaviorElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : EnvelopeEndpointBehaviorElement Class

Represents a WCF configuration element which specifies the EnvelopeEndpointBehavior will be used and exposes its settings through configuration.

Object Model

EnvelopeEndpointBehaviorElement Class

Syntax

Visual Basic (Declaration)
Public Class EnvelopeEndpointBehaviorElement
   Inherits System.ServiceModel.Configuration.BehaviorExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
C#
public class EnvelopeEndpointBehaviorElement : System.ServiceModel.Configuration.BehaviorExtensionElement
Delphi
public class EnvelopeEndpointBehaviorElement = class(System.ServiceModel.Configuration.BehaviorExtensionElement)
JScript
public class EnvelopeEndpointBehaviorElement extends System.ServiceModel.Configuration.BehaviorExtensionElement
Managed Extensions for C++
public __gc class EnvelopeEndpointBehaviorElement : public System.ServiceModel.Configuration.BehaviorExtensionElement
C++/CLI
public ref class EnvelopeEndpointBehaviorElement : public System.ServiceModel.Configuration.BehaviorExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BehaviorExtensionElement
Noemax.WCFX.Configuration.EnvelopeEndpointBehaviorElement

See Also

Reference

EnvelopeEndpointBehaviorElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehaviorElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : EnvelopeEndpointBehaviorElement Class

The following tables list the members exposed by EnvelopeEndpointBehaviorElement.

Public Constructors

 | Name | Description
public Constructor | EnvelopeEndpointBehaviorElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BehaviorType | Overridden.
public Property | CompressionLevel |
public Property | CompressionMethod |
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ProcessIncomming |
public Property | ProcessOutgoing |
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBehavior | Overridden.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

EnvelopeEndpointBehaviorElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehaviorElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : EnvelopeEndpointBehaviorElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EnvelopeEndpointBehaviorElement()
C#
public EnvelopeEndpointBehaviorElement()
Delphi
public EnvelopeEndpointBehaviorElement();
JScript
public function EnvelopeEndpointBehaviorElement();
Managed Extensions for C++
public: EnvelopeEndpointBehaviorElement();
C++/CLI
public:
EnvelopeEndpointBehaviorElement();

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehaviorElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : EnvelopeEndpointBehaviorElement Class

For a list of all members of this type, see EnvelopeEndpointBehaviorElement members.

Public Methods

 | Name | Description
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBehavior | Overridden.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

EnvelopeEndpointBehaviorElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBehavior Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : CreateBehavior Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBehavior() As Object
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Object

value = instance.CreateBehavior()
C#
protected override object CreateBehavior()
Delphi
protected function CreateBehavior(): TObject; override;
JScript
protected override function CreateBehavior() : Object;
Managed Extensions for C++
protected: Object* CreateBehavior(); override
C++/CLI
protected:
Object^ CreateBehavior(); override

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members
Base Implementation in CreateBehavior


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnvelopeEndpointBehaviorElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : EnvelopeEndpointBehaviorElement Class

For a list of all members of this type, see EnvelopeEndpointBehaviorElement members.

Public Properties

 | Name | Description
public Property | BehaviorType | Overridden.
public Property | CompressionLevel |
public Property | CompressionMethod |
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ProcessIncomming |
public Property | ProcessOutgoing |
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

EnvelopeEndpointBehaviorElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BehaviorType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : BehaviorType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BehaviorType As Type
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Type

value = instance.BehaviorType
C#
public override Type BehaviorType {get;}
Delphi
public read-only property BehaviorType: Type; override;
JScript
public override function get BehaviorType : Type
Managed Extensions for C++
public: __property Type* get_BehaviorType() override;
C++/CLI
public:
property Type^ BehaviorType {
   Type^ get() override;
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members
Base Implementation in BehaviorType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : CompressionLevel Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionLevel : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMethod Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : CompressionMethod Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionMethod As EncodingCompressionMethod
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As EncodingCompressionMethod

instance.CompressionMethod = value

value = instance.CompressionMethod
C#
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public EncodingCompressionMethod CompressionMethod {get; set;}
Delphi
public read-write property CompressionMethod: EncodingCompressionMethod;
JScript
ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionMethod : EncodingCompressionMethod
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property EncodingCompressionMethod get_CompressionMethod();
public: __property void set_CompressionMethod(
   EncodingCompressionMethod value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionMethod",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property EncodingCompressionMethod CompressionMethod {
   EncodingCompressionMethod get();
   void set (    EncodingCompressionMethod value);
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessIncomming Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : ProcessIncomming Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="processIncomming",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProcessIncomming As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Boolean

instance.ProcessIncomming = value

value = instance.ProcessIncomming
C#
[ConfigurationPropertyAttribute(Name="processIncomming",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ProcessIncomming {get; set;}
Delphi
public read-write property ProcessIncomming: Boolean;
JScript
ConfigurationPropertyAttribute(Name="processIncomming",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProcessIncomming : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="processIncomming",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ProcessIncomming();
public: __property void set_ProcessIncomming(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="processIncomming",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ProcessIncomming {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProcessOutgoing Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : ProcessOutgoing Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="processOutgoing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProcessOutgoing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Boolean

instance.ProcessOutgoing = value

value = instance.ProcessOutgoing
C#
[ConfigurationPropertyAttribute(Name="processOutgoing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ProcessOutgoing {get; set;}
Delphi
public read-write property ProcessOutgoing: Boolean;
JScript
ConfigurationPropertyAttribute(Name="processOutgoing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProcessOutgoing : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="processOutgoing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ProcessOutgoing();
public: __property void set_ProcessOutgoing(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="processOutgoing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ProcessOutgoing {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingCollectionElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingCollectionElement Class

Represents a configuration section that contains a collection of bindings, each of which describes an aspect of how an endpoint communicates with other endpoints, that is built, consistently, into a channel factory on the client and a channel listener on the service.

Object Model

ExtensionBindingCollectionElement Class

Syntax

Visual Basic (Declaration)
Public Class ExtensionBindingCollectionElement
   Inherits System.ServiceModel.Configuration.BindingCollectionElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
C#
public class ExtensionBindingCollectionElement : System.ServiceModel.Configuration.BindingCollectionElement
Delphi
public class ExtensionBindingCollectionElement = class(System.ServiceModel.Configuration.BindingCollectionElement)
JScript
public class ExtensionBindingCollectionElement extends System.ServiceModel.Configuration.BindingCollectionElement
Managed Extensions for C++
public __gc class ExtensionBindingCollectionElement : public System.ServiceModel.Configuration.BindingCollectionElement
C++/CLI
public ref class ExtensionBindingCollectionElement : public System.ServiceModel.Configuration.BindingCollectionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.BindingCollectionElement
Noemax.WCFX.Configuration.ExtensionBindingCollectionElement

See Also

Reference

ExtensionBindingCollectionElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ExtensionBindingCollectionElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingCollectionElement Class

The following tables list the members exposed by ExtensionBindingCollectionElement.

Public Constructors

 | Name | Description
public Constructor | ExtensionBindingCollectionElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | Gets the collection of ExtensionBindingElement.
public Property | BindingType | Overridden. Returns the type of the binding contained in this collection.
public Property | ConfiguredBindings | Overridden. Returns the read only collection of System.ServiceModel.Configuration.IBindnigConfigurationElement.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets the collection of configuration properties.
Top

Public Methods

 | Name | Description
public Method | ContainsKey | Overridden. Checks for the presence of the element with specified name in the collection.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetDefault | Overridden. Returns the binding with default configuration.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
protected Method | TryAdd | Overridden. Tries to add the binding with specified name into collection.
Top

See Also

Reference

ExtensionBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingCollectionElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : ExtensionBindingCollectionElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ExtensionBindingCollectionElement()
C#
public ExtensionBindingCollectionElement()
Delphi
public ExtensionBindingCollectionElement();
JScript
public function ExtensionBindingCollectionElement();
Managed Extensions for C++
public: ExtensionBindingCollectionElement();
C++/CLI
public:
ExtensionBindingCollectionElement();

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ExtensionBindingCollectionElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingCollectionElement Class

For a list of all members of this type, see ExtensionBindingCollectionElement members.

Public Methods

 | Name | Description
public Method | ContainsKey | Overridden. Checks for the presence of the element with specified name in the collection.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetDefault | Overridden. Returns the binding with default configuration.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
protected Method | TryAdd | Overridden. Tries to add the binding with specified name into collection.
Top

See Also

Reference

ExtensionBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContainsKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : ContainsKey Method

name
The name of the element to search for.
Checks for the presence of the element with specified name in the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Function ContainsKey( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim name As String
Dim value As Boolean

value = instance.ContainsKey(name)
C#
public override bool ContainsKey(
   string name
)
Delphi
public function ContainsKey(
    name: String
): Boolean; override;
JScript
public override function ContainsKey(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ContainsKey(
   string* name
) override
C++/CLI
public:
bool ContainsKey(
   String^ name
) override

Parameters

name
The name of the element to search for.

Return Value

Returns true if collection contains an element with specified name.

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in ContainsKey


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetDefault Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : GetDefault Method

Returns the binding with default configuration.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDefault() As Binding
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As Binding

value = instance.GetDefault()
C#
protected override Binding GetDefault()
Delphi
protected function GetDefault(): Binding; override;
JScript
protected override function GetDefault() : Binding;
Managed Extensions for C++
protected: Binding* GetDefault(); override
C++/CLI
protected:
Binding^ GetDefault(); override

Return Value

The binding with default configuration.

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in GetDefault


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryAdd Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : TryAdd Method

name
binding
config
Tries to add the binding with specified name into collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Function TryAdd( _
   ByVal name As String, _
   ByVal binding As Binding, _
   ByVal config As Configuration _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim name As String
Dim binding As Binding
Dim config As Configuration
Dim value As Boolean

value = instance.TryAdd(name, binding, config)
C#
protected override bool TryAdd(
   string name,
   Binding binding,
   Configuration config
)
Delphi
protected function TryAdd(
    name: String;
    binding: Binding;
    config: Configuration
): Boolean; override;
JScript
protected override function TryAdd(
   name : String,
   binding : Binding,
   config : Configuration
) : boolean;
Managed Extensions for C++
protected: bool TryAdd(
   string* name,
   Binding* binding,
   Configuration* config
) override
C++/CLI
protected:
bool TryAdd(
   String^ name,
   Binding^ binding,
   Configuration^ config
) override

Parameters

name
binding
config

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in TryAdd


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ExtensionBindingCollectionElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingCollectionElement Class

For a list of all members of this type, see ExtensionBindingCollectionElement members.

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | Gets the collection of ExtensionBindingElement.
public Property | BindingType | Overridden. Returns the type of the binding contained in this collection.
public Property | ConfiguredBindings | Overridden. Returns the read only collection of System.ServiceModel.Configuration.IBindnigConfigurationElement.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets the collection of configuration properties.
Top

See Also

Reference

ExtensionBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Bindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : Bindings Property

Gets the collection of ExtensionBindingElement.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property Bindings As ExtensionBindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ExtensionBindingElementCollection

value = instance.Bindings
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public ExtensionBindingElementCollection Bindings {get;}
Delphi
public read-only property Bindings: ExtensionBindingElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get Bindings : ExtensionBindingElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property ExtensionBindingElementCollection* get_Bindings();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property ExtensionBindingElementCollection^ Bindings {
   ExtensionBindingElementCollection^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : BindingType Property

Returns the type of the binding contained in this collection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingType As Type
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As Type

value = instance.BindingType
C#
public override Type BindingType {get;}
Delphi
public read-only property BindingType: Type; override;
JScript
public override function get BindingType : Type
Managed Extensions for C++
public: __property Type* get_BindingType() override;
C++/CLI
public:
property Type^ BindingType {
   Type^ get() override;
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in BindingType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfiguredBindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : ConfiguredBindings Property

Returns the read only collection of System.ServiceModel.Configuration.IBindnigConfigurationElement.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ConfiguredBindings As ReadOnlyCollection(Of IBindingConfigurationElement)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ReadOnlyCollection(Of IBindingConfigurationElement)

value = instance.ConfiguredBindings
C#
public override ReadOnlyCollection<IBindingConfigurationElement> ConfiguredBindings {get;}
Delphi
public read-only property ConfiguredBindings: ReadOnlyCollection; override;
JScript
public override function get ConfiguredBindings : ReadOnlyCollection
Managed Extensions for C++
public: __property ReadOnlyCollection<IBindingConfigurationElement*>* get_ConfiguredBindings() override;
C++/CLI
public:
property ReadOnlyCollection<IBindingConfigurationElement^>^ ConfiguredBindings {
   ReadOnlyCollection<IBindingConfigurationElement^>^ get() override;
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in ConfiguredBindings


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : Properties Property

Gets the collection of configuration properties.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected override ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection; override;
JScript
protected override function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties() override;
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get() override;
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members
Base Implementation in Properties


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElement Class

Represents a configuration section which contains a collection of binding element extensions that modify the behavior of an already defined binding.

Object Model

ExtensionBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class ExtensionBindingElement
   Inherits System.Configuration.ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
C#
public class ExtensionBindingElement : System.Configuration.ConfigurationElement
Delphi
public class ExtensionBindingElement = class(System.Configuration.ConfigurationElement)
JScript
public class ExtensionBindingElement extends System.Configuration.ConfigurationElement
Managed Extensions for C++
public __gc class ExtensionBindingElement : public System.Configuration.ConfigurationElement
C++/CLI
public ref class ExtensionBindingElement : public System.Configuration.ConfigurationElement

Remarks

The is used to extend an already configured binding by cloning its configuration and replacing or adding binding elements to it. It is used to plug extensions into a predefined standard binding through the configuration file. It is also used to avoid copying the same configuration section multiple times in order to create slightly different bindings.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.ExtensionBindingElement

See Also

Reference

ExtensionBindingElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElement Class

The following tables list the members exposed by ExtensionBindingElement.

Public Constructors

 | Name | Description
public Constructor | ExtensionBindingElement Constructor |
Top

Public Properties

 | Name | Description
public Property | CloseTimeout | Gets or sets the interval of time provided for a close operation to complete.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | Extensions | The collection of BindingElement object to be added to source binding configuration.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | Name | The name of the binding.
public Property | OpenTimeout | Gets or sets the interval of time provided for an open operation to complete.
public Property | ReceiveTimeout | Gets or sets the interval of time provided for a receive operation to complete.
public Property | SendTimeout | Gets or sets the interval of time provided for a send operation to complete.
public Property | SourceBinding | Gets or sets the type of binding to extend.
public Property | SourceBindingConfiguration | Gets or sets the name of the binding to extend.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets the collection of configuration properties.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Applies the content of the specified binding to this binding configuration element.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : ExtensionBindingElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ExtensionBindingElement()
C#
public ExtensionBindingElement()
Delphi
public ExtensionBindingElement();
JScript
public function ExtensionBindingElement();
Managed Extensions for C++
public: ExtensionBindingElement();
C++/CLI
public:
ExtensionBindingElement();

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElement Class

For a list of all members of this type, see ExtensionBindingElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Applies the content of the specified binding to this binding configuration element.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : ApplyConfiguration Method

binding

A binding.

Applies the content of the specified binding to this binding configuration element.

Syntax

Visual Basic (Declaration)
Public Sub ApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim binding As Binding

instance.ApplyConfiguration(binding)
C#
public void ApplyConfiguration(
   Binding binding
)
Delphi
public procedure ApplyConfiguration(
    binding: Binding
);
JScript
public function ApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
public: void ApplyConfiguration(
   Binding* binding
)
C++/CLI
public:
void ApplyConfiguration(
   Binding^ binding
)

Parameters

binding

A binding.

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElement Class

For a list of all members of this type, see ExtensionBindingElement members.

Public Properties

 | Name | Description
public Property | CloseTimeout | Gets or sets the interval of time provided for a close operation to complete.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | Extensions | The collection of BindingElement object to be added to source binding configuration.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | Name | The name of the binding.
public Property | OpenTimeout | Gets or sets the interval of time provided for an open operation to complete.
public Property | ReceiveTimeout | Gets or sets the interval of time provided for a receive operation to complete.
public Property | SendTimeout | Gets or sets the interval of time provided for a send operation to complete.
public Property | SourceBinding | Gets or sets the type of binding to extend.
public Property | SourceBindingConfiguration | Gets or sets the name of the binding to extend.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets the collection of configuration properties.
Top

See Also

Reference

ExtensionBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : CloseTimeout Property

Gets or sets the interval of time provided for a close operation to complete.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As TimeSpan

value = instance.CloseTimeout
C#
public TimeSpan CloseTimeout {get;}
Delphi
public read-only property CloseTimeout: TimeSpan;
JScript
public function get CloseTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_CloseTimeout();
C++/CLI
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
}

Property Value

The

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Extensions Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : Extensions Property

The collection of BindingElement object to be added to source binding configuration.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property Extensions As BindingElementExtensionElementCollection(Of BindingElement)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As BindingElementExtensionElementCollection(Of BindingElement)

value = instance.Extensions
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public BindingElementExtensionElementCollection<BindingElement> Extensions {get;}
Delphi
public read-only property Extensions: BindingElementExtensionElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get Extensions : BindingElementExtensionElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property BindingElementExtensionElementCollection<BindingElement*>* get_Extensions();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property BindingElementExtensionElementCollection<BindingElement^>^ Extensions {
   BindingElementExtensionElementCollection<BindingElement^>^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : Name Property

The name of the binding.

Syntax

Visual Basic (Declaration)
<StringValidatorAttribute(1)>
<ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsRequired Or  _
    ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=False,
   IsRequired=True,
   IsKey=True)>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As String

instance.Name = value

value = instance.Name
C#
[StringValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsRequired |
    ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=true,
   IsKey=true)]
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
StringValidatorAttribute(1)
ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsRequired |
    ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Name : String
Managed Extensions for C++
[StringValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsRequired |
    ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=true,
   IsKey=true)]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[StringValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsRequired |
    ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=true,
   IsKey=true)]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : OpenTimeout Property

Gets or sets the interval of time provided for an open operation to complete.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As TimeSpan

value = instance.OpenTimeout
C#
public TimeSpan OpenTimeout {get;}
Delphi
public read-only property OpenTimeout: TimeSpan;
JScript
public function get OpenTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_OpenTimeout();
C++/CLI
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
}

Property Value

The

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : Properties Property

Gets the collection of configuration properties.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected override ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection; override;
JScript
protected override function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties() override;
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get() override;
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members
Base Implementation in Properties


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : ReceiveTimeout Property

Gets or sets the interval of time provided for a receive operation to complete.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As TimeSpan

value = instance.ReceiveTimeout
C#
public TimeSpan ReceiveTimeout {get;}
Delphi
public read-only property ReceiveTimeout: TimeSpan;
JScript
public function get ReceiveTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_ReceiveTimeout();
C++/CLI
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
}

Property Value

The

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : SendTimeout Property

Gets or sets the interval of time provided for a send operation to complete.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As TimeSpan

value = instance.SendTimeout
C#
public TimeSpan SendTimeout {get;}
Delphi
public read-only property SendTimeout: TimeSpan;
JScript
public function get SendTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_SendTimeout();
C++/CLI
public:
property TimeSpan SendTimeout {
   TimeSpan get();
}

Property Value

The

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SourceBinding Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : SourceBinding Property

Gets or sets the type of binding to extend.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="sourceBinding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property SourceBinding As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As String

instance.SourceBinding = value

value = instance.SourceBinding
C#
[ConfigurationPropertyAttribute(Name="sourceBinding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string SourceBinding {get; set;}
Delphi
public read-write property SourceBinding: String;
JScript
ConfigurationPropertyAttribute(Name="sourceBinding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set SourceBinding : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="sourceBinding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_SourceBinding();
public: __property void set_SourceBinding(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="sourceBinding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ SourceBinding {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SourceBindingConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : SourceBindingConfiguration Property

Gets or sets the name of the binding to extend.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="sourceBindingConfiguration",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property SourceBindingConfiguration As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As String

instance.SourceBindingConfiguration = value

value = instance.SourceBindingConfiguration
C#
[ConfigurationPropertyAttribute(Name="sourceBindingConfiguration",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string SourceBindingConfiguration {get; set;}
Delphi
public read-write property SourceBindingConfiguration: String;
JScript
ConfigurationPropertyAttribute(Name="sourceBindingConfiguration",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set SourceBindingConfiguration : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="sourceBindingConfiguration",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_SourceBindingConfiguration();
public: __property void set_SourceBindingConfiguration(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="sourceBindingConfiguration",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ SourceBindingConfiguration {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingElementCollection Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElementCollection Class

Represents a configuration section that holds a collection of ExtenstionBindingElement elements.

Object Model

ExtensionBindingElementCollection Class

Syntax

Visual Basic (Declaration)
Public Class ExtensionBindingElementCollection
   Inherits Noemax.WCFX.Configuration.GenericConfigurationElementCollection(Of ExtensionBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
C#
public class ExtensionBindingElementCollection : Noemax.WCFX.Configuration.GenericConfigurationElementCollection<ExtensionBindingElement>
Delphi
public class ExtensionBindingElementCollection = class(Noemax.WCFX.Configuration.GenericConfigurationElementCollection)
JScript
public class ExtensionBindingElementCollection extends Noemax.WCFX.Configuration.GenericConfigurationElementCollection
Managed Extensions for C++
public __gc class ExtensionBindingElementCollection : public Noemax.WCFX.Configuration.GenericConfigurationElementCollection<ExtensionBindingElement>
C++/CLI
public ref class ExtensionBindingElementCollection : public Noemax.WCFX.Configuration.GenericConfigurationElementCollection<ExtensionBindingElement>

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Noemax.WCFX.Configuration.GenericConfigurationElementCollection<TConfigurationElement>
Noemax.WCFX.Configuration.ExtensionBindingElementCollection

See Also

Reference

ExtensionBindingElementCollection Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElementCollection Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElementCollection Class

The following tables list the members exposed by ExtensionBindingElementCollection.

Public Constructors

 | Name | Description
public Constructor | ExtensionBindingElementCollection Constructor | Initializes a new instance of the ExtensionBindingElementCollection class.
Top

Public Properties

 | Name | Description
public Property | CollectionType | Overridden. Gets the type of the ConfigurationElementCollection.
public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | Overridden. The name of the node prepresenting the configuration element.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Public Methods

 | Name | Description
public Method | ContainsKey | Returns true if collection contains element with specified key. (Inherited from Noemax.WCFX.Configuration.GenericConfigurationElementCollection<ExtensionBindingElement>)
public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Creates a new configuration element.
protected Method | GetElementKey | Overridden. Returns they key that corresponds to the specified configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionBindingElementCollection Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtensionBindingElementCollection Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : ExtensionBindingElementCollection Constructor

Initializes a new instance of the ExtensionBindingElementCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ExtensionBindingElementCollection()
C#
public ExtensionBindingElementCollection()
Delphi
public ExtensionBindingElementCollection();
JScript
public function ExtensionBindingElementCollection();
Managed Extensions for C++
public: ExtensionBindingElementCollection();
C++/CLI
public:
ExtensionBindingElementCollection();

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElementCollection Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElementCollection Class

For a list of all members of this type, see ExtensionBindingElementCollection members.

Public Methods

 | Name | Description
public Method | ContainsKey | Returns true if collection contains element with specified key. (Inherited from Noemax.WCFX.Configuration.GenericConfigurationElementCollection<ExtensionBindingElement>)
public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Creates a new configuration element.
protected Method | GetElementKey | Overridden. Returns they key that corresponds to the specified configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

ExtensionBindingElementCollection Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : CreateNewElement Method

Creates a new configuration element.

Overload List

Overload | Description
CreateNewElement() | Creates a new configuration element.
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Base Implementation in CreateNewElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement() Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class > CreateNewElement Method : CreateNewElement() Method

Creates a new configuration element.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function CreateNewElement() As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationElement

value = instance.CreateNewElement()
C#
protected override ConfigurationElement CreateNewElement()
Delphi
protected function CreateNewElement(): ConfigurationElement; override;
JScript
protected override function CreateNewElement() : ConfigurationElement;
Managed Extensions for C++
protected: ConfigurationElement* CreateNewElement(); override
C++/CLI
protected:
ConfigurationElement^ CreateNewElement(); override

Return Value

The new configuration element.

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Overload List
Base Implementation in CreateNewElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetElementKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : GetElementKey Method

element
The configuration element.
Returns they key that corresponds to the specified configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetElementKey( _
   ByVal element As ConfigurationElement _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim element As ConfigurationElement
Dim value As Object

value = instance.GetElementKey(element)
C#
protected override object GetElementKey(
   ConfigurationElement element
)
Delphi
protected function GetElementKey(
    element: ConfigurationElement
): TObject; override;
JScript
protected override function GetElementKey(
   element : ConfigurationElement
) : Object;
Managed Extensions for C++
protected: Object* GetElementKey(
   ConfigurationElement* element
) override
C++/CLI
protected:
Object^ GetElementKey(
   ConfigurationElement^ element
) override

Parameters

element
The configuration element.

Return Value

The key that corresponds to the speicified configuration element.

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Base Implementation in GetElementKey


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ExtensionBindingElementCollection Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : ExtensionBindingElementCollection Class

For a list of all members of this type, see ExtensionBindingElementCollection members.

Public Properties

 | Name | Description
public Property | CollectionType | Overridden. Gets the type of the ConfigurationElementCollection.
public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | Overridden. The name of the node prepresenting the configuration element.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

ExtensionBindingElementCollection Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CollectionType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : CollectionType Property

Gets the type of the ConfigurationElementCollection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationElementCollectionType

value = instance.CollectionType
C#
public override ConfigurationElementCollectionType CollectionType {get;}
Delphi
public read-only property CollectionType: ConfigurationElementCollectionType; override;
JScript
public override function get CollectionType : ConfigurationElementCollectionType
Managed Extensions for C++
public: __property ConfigurationElementCollectionType get_CollectionType() override;
C++/CLI
public:
property ConfigurationElementCollectionType CollectionType {
   ConfigurationElementCollectionType get() override;
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Base Implementation in CollectionType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : ElementName Property

The name of the node prepresenting the configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property ElementName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As String

value = instance.ElementName
C#
protected override string ElementName {get;}
Delphi
protected read-only property ElementName: String; override;
JScript
protected override function get ElementName : String
Managed Extensions for C++
protected: __property string* get_ElementName() override;
C++/CLI
protected:
property String^ ElementName {
   String^ get() override;
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Base Implementation in ElementName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingElement Class
Members Example See Also Send Feedback
Noemax.WCFX.Configuration Namespace : FiMessageEncodingElement Class

Represents a WCF configuration element which specifies the FiMessageEncodingBindingElement will be used and exposes its settings through configuration.

Object Model

FiMessageEncodingElement Class

Syntax

Visual Basic (Declaration)
Public Class FiMessageEncodingElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
C#
public class FiMessageEncodingElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class FiMessageEncodingElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class FiMessageEncodingElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class FiMessageEncodingElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class FiMessageEncodingElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Example

<system.serviceModel>

<extensions>

<bindingElementExtensions>

<add name="fiMessageEncoding"

type="Noemax.WCFX.Configuration.FiMessageEncodingElement, Noemax.WCFX" />

</bindingElementExtensions>

</extensions>

<bindings>

<customBinding>

<binding name ="clientBinding">

<fiMessageEncoding/>

<httpTransport/>

</binding>

</customBinding>

</bindings>

</system.serviceModel>

Copy Code

  Inheritance Hierarchy
System.Object
   System.Configuration.ConfigurationElement
      System.ServiceModel.Configuration.ServiceModelExtensionElement
         System.ServiceModel.Configuration.BindingElementExtensionElement
            Noemax.WCFX.Configuration.FiMessageEncodingElement

  See Also
Reference
FiMessageEncodingElement Members

Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : FiMessageEncodingElement Class

The following tables list the members exposed by FiMessageEncodingElement.

Public Constructors

 | Name | Description
public Constructor | FiMessageEncodingElement Constructor | Initializes a new instance of FiMessageEncodingElement class.
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxArrayLength |
public Property | MaxBytesPerRead |
public Property | MaxDepth |
public Property | MaxNameTableCharCount |
public Property | MaxReadPoolSize | Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.
public Property | MaxStringContentLength |
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.
public Property | MaxVocabularyStringLength | Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.
public Property | MaxWritePoolSize | Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.
public Property | MessageVersion | Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.
public Property | PermitStateful |
public Property | SessionMode |
public Property | WriterProfile |
public Property | WriterProfileDetails | Sets and gets the WriterProfileDetailsElement settings for Noemax.WCFX.Channels.FiMessageEncodingBindingElement.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ReaderQuotas | Gets or sets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | InitializeFrom | Overridden. Initializes the binding element by copying the settings of specified binding element.
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

FiMessageEncodingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FiMessageEncodingElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : FiMessageEncodingElement Constructor

Initializes a new instance of FiMessageEncodingElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New FiMessageEncodingElement()
C#
public FiMessageEncodingElement()
Delphi
public FiMessageEncodingElement();
JScript
public function FiMessageEncodingElement();
Managed Extensions for C++
public: FiMessageEncodingElement();
C++/CLI
public:
FiMessageEncodingElement();

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : FiMessageEncodingElement Class

For a list of all members of this type, see FiMessageEncodingElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | InitializeFrom | Overridden. Initializes the binding element by copying the settings of specified binding element.
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

FiMessageEncodingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : InitializeFrom Method

bindingElement
The binding element copy settings from.
Initializes the binding element by copying the settings of specified binding element.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeFrom( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim bindingElement As BindingElement

instance.InitializeFrom(bindingElement)
C#
protected override void InitializeFrom(
   BindingElement bindingElement
)
Delphi
protected procedure InitializeFrom(
    bindingElement: BindingElement
); override;
JScript
protected override function InitializeFrom(
   bindingElement : BindingElement
);
Managed Extensions for C++
protected: void InitializeFrom(
   BindingElement* bindingElement
) override
C++/CLI
protected:
void InitializeFrom(
   BindingElement^ bindingElement
) override

Parameters

bindingElement
The binding element copy settings from.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members
Base Implementation in InitializeFrom


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
FiMessageEncodingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : FiMessageEncodingElement Class

For a list of all members of this type, see FiMessageEncodingElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxArrayLength |
public Property | MaxBytesPerRead |
public Property | MaxDepth |
public Property | MaxNameTableCharCount |
public Property | MaxReadPoolSize | Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.
public Property | MaxStringContentLength |
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.
public Property | MaxVocabularyStringLength | Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.
public Property | MaxWritePoolSize | Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.
public Property | MessageVersion | Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.
public Property | PermitStateful |
public Property | SessionMode |
public Property | WriterProfile |
public Property | WriterProfileDetails | Sets and gets the WriterProfileDetailsElement settings for Noemax.WCFX.Channels.FiMessageEncodingBindingElement.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ReaderQuotas | Gets or sets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.
Top

See Also

Reference

FiMessageEncodingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxArrayLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxArrayLength Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxArrayLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxArrayLength = value

value = instance.MaxArrayLength
C#
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxArrayLength {get; set;}
Delphi
public read-write property MaxArrayLength: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxArrayLength : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxArrayLength();
public: __property void set_MaxArrayLength(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxArrayLength {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBytesPerRead Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxBytesPerRead Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxBytesPerRead As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxBytesPerRead = value

value = instance.MaxBytesPerRead
C#
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxBytesPerRead {get; set;}
Delphi
public read-write property MaxBytesPerRead: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxBytesPerRead : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxBytesPerRead();
public: __property void set_MaxBytesPerRead(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxBytesPerRead {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxDepth Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxDepth Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ReaderQuotas Properties")>
<ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxDepth = value

value = instance.MaxDepth
C#
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxDepth {get; set;}
Delphi
public read-write property MaxDepth: Integer;
JScript
CategoryAttribute("ReaderQuotas Properties")
ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxDepth : int
Managed Extensions for C++
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxDepth();
public: __property void set_MaxDepth(
   int value
);
C++/CLI
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxDepth {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxNameTableCharCount Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxNameTableCharCount Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxNameTableCharCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxNameTableCharCount = value

value = instance.MaxNameTableCharCount
C#
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxNameTableCharCount {get; set;}
Delphi
public read-write property MaxNameTableCharCount: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxNameTableCharCount : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxNameTableCharCount();
public: __property void set_MaxNameTableCharCount(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxNameTableCharCount {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReadPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxReadPoolSize Property

Gets or sets the number of readers that are allocated to a pool and ready for use to process incoming messages.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReadPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReadPoolSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxReadPoolSize = value

value = instance.MaxReadPoolSize
C#
[ConfigurationPropertyAttribute(Name="maxReadPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxReadPoolSize {get; set;}
Delphi
public read-write property MaxReadPoolSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxReadPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReadPoolSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReadPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxReadPoolSize();
public: __property void set_MaxReadPoolSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReadPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxReadPoolSize {
   int get();
   void set (    int value);
}

Property Value

The number of readers in the pool. The default value is 64 readers.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxStringContentLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxStringContentLength Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxStringContentLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxStringContentLength = value

value = instance.MaxStringContentLength
C#
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxStringContentLength {get; set;}
Delphi
public read-write property MaxStringContentLength: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxStringContentLength : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxStringContentLength();
public: __property void set_MaxStringContentLength(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxStringContentLength {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that can be added to the Fast Infoset vocabulary table.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxVocabularyStringIndex",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
[ConfigurationPropertyAttribute(Name="maxVocabularyStringIndex",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxVocabularyStringIndex",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxVocabularyStringIndex",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxVocabularyStringIndex",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxVocabularyStringLength Property

Gets and sets the maximum length of the string for which the writer will try to find a match in its vocabulary.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxVocabularyStringLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

If the length of the character string that is written into the writer is smaller than the specified length, the writer will try to find a match for this string within the strings that have been already placed in the vocabulary and replace it with the reference to the already written string. If no match is found, the writer adds this character string to the vocabulary and all future occurrences of the same string will be replaced by references to it.

The writer does not try to find a match for strings that are longer than the specified length and so does not add them to the vocabulary. Setting this property to a higher value might improve compactness, but it might decrease the writing speed and\or consume more memory.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxWritePoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MaxWritePoolSize Property

Gets or sets the number of writers that are allocated to a pool and ready for use to process outgoing messages.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxWritePoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxWritePoolSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Integer

instance.MaxWritePoolSize = value

value = instance.MaxWritePoolSize
C#
[ConfigurationPropertyAttribute(Name="maxWritePoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxWritePoolSize {get; set;}
Delphi
public read-write property MaxWritePoolSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxWritePoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxWritePoolSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxWritePoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxWritePoolSize();
public: __property void set_MaxWritePoolSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxWritePoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxWritePoolSize {
   int get();
   void set (    int value);
}

Property Value

The maximum number of writers to be kept in the pool. The default value is 16 writers.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : MessageVersion Property

Gets or sets the SOAP and WS-Addressing versions that are used to format the text message.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.MessageVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="messageVersion",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As MessageVersion

instance.MessageVersion = value

value = instance.MessageVersion
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.MessageVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="messageVersion",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public MessageVersion MessageVersion {get; set;}
Delphi
public read-write property MessageVersion: MessageVersion;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.MessageVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="messageVersion",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MessageVersion : MessageVersion
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.MessageVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="messageVersion",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property MessageVersion* get_MessageVersion();
public: __property void set_MessageVersion(
   MessageVersion* value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.MessageVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="messageVersion",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property MessageVersion^ MessageVersion {
   MessageVersion^ get();
   void set (    MessageVersion^ value);
}

Remarks

The default MessageVersion for this constructor is the version of WS-Addressing that was submitted 10 August 2004 and SOAP 1.2.

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PermitStateful Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : PermitStateful Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property PermitStateful As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Boolean

instance.PermitStateful = value

value = instance.PermitStateful
C#
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool PermitStateful {get; set;}
Delphi
public read-write property PermitStateful: Boolean;
JScript
ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set PermitStateful : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_PermitStateful();
public: __property void set_PermitStateful(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="permitStateful",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool PermitStateful {
   bool get();
   void set (    bool value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderQuotas Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : ReaderQuotas Property

Gets or sets constraints on the complexity of XML messages that can be processed by endpoints configured with this binding element.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Protected Property ReaderQuotas As XmlDictionaryReaderQuotasElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As XmlDictionaryReaderQuotasElement

instance.ReaderQuotas = value

value = instance.ReaderQuotas
C#
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected XmlDictionaryReaderQuotasElement ReaderQuotas {get; set;}
Delphi
protected read-write property ReaderQuotas: XmlDictionaryReaderQuotasElement;
JScript
ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
protected function get,set ReaderQuotas : XmlDictionaryReaderQuotasElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected: __property XmlDictionaryReaderQuotasElement* get_ReaderQuotas();
protected: __property void set_ReaderQuotas(
   XmlDictionaryReaderQuotasElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected:
property XmlDictionaryReaderQuotasElement^ ReaderQuotas {
   XmlDictionaryReaderQuotasElement^ get();
   void set (    XmlDictionaryReaderQuotasElement^ value);
}

Remarks

The complexity constraints protect against a class of denial of service (DOS) attacks that attempt to use message complexity to tie up endpoint processing resources. The properties that express these constraints and their default values are as follows:

  • MaxDepth = 32

  • MaxStringContentLength = 8192

  • MaxArrayLength = 16384

  • MaxBytesPerRead = 4096

  • MaxNameTableCharCount = 16384

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SessionMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : SessionMode Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="sessionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property SessionMode As FastInfosetSessionMode
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As FastInfosetSessionMode

instance.SessionMode = value

value = instance.SessionMode
C#
[ConfigurationPropertyAttribute(Name="sessionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public FastInfosetSessionMode SessionMode {get; set;}
Delphi
public read-write property SessionMode: FastInfosetSessionMode;
JScript
ConfigurationPropertyAttribute(Name="sessionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set SessionMode : FastInfosetSessionMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="sessionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property FastInfosetSessionMode get_SessionMode();
public: __property void set_SessionMode(
   FastInfosetSessionMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="sessionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property FastInfosetSessionMode SessionMode {
   FastInfosetSessionMode get();
   void set (    FastInfosetSessionMode value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfile Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : WriterProfile Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property WriterProfile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As XmlFastInfosetWriterProfile

instance.WriterProfile = value

value = instance.WriterProfile
C#
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetWriterProfile WriterProfile {get; set;}
Delphi
public read-write property WriterProfile: XmlFastInfosetWriterProfile;
JScript
ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set WriterProfile : XmlFastInfosetWriterProfile
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetWriterProfile get_WriterProfile();
public: __property void set_WriterProfile(
   XmlFastInfosetWriterProfile value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="writerProfile",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetWriterProfile WriterProfile {
   XmlFastInfosetWriterProfile get();
   void set (    XmlFastInfosetWriterProfile value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfileDetails Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : WriterProfileDetails Property

Sets and gets the WriterProfileDetailsElement settings for Noemax.WCFX.Channels.FiMessageEncodingBindingElement.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property WriterProfileDetails As WriterProfileDetailsElement
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As WriterProfileDetailsElement

instance.WriterProfileDetails = value

value = instance.WriterProfileDetails
C#
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public WriterProfileDetailsElement WriterProfileDetails {get; set;}
Delphi
public read-write property WriterProfileDetails: WriterProfileDetailsElement;
JScript
ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set WriterProfileDetails : WriterProfileDetailsElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property WriterProfileDetailsElement* get_WriterProfileDetails();
public: __property void set_WriterProfileDetails(
   WriterProfileDetailsElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="writerProfileDetails",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property WriterProfileDetailsElement^ WriterProfileDetails {
   WriterProfileDetailsElement^ get();
   void set (    WriterProfileDetailsElement^ value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

TConfigurationElement
The type of the configuration elements contained in the collection
[image]
Noemax WCF-Xtensions
GenericConfigurationElementCollection<TConfigurationElement> Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : GenericConfigurationElementCollection<TConfigurationElement> Class

Represents a configuration element containing a collection of child elements.

Object Model

GenericConfigurationElementCollection<TConfigurationElement> Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GenericConfigurationElementCollection(Of TConfigurationElement As ConfigurationElement)
   Inherits System.Configuration.ConfigurationElementCollection
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
C#
public abstract class GenericConfigurationElementCollection<TConfigurationElement> : System.Configuration.ConfigurationElementCollection where TConfigurationElement: ConfigurationElement
Delphi
public class GenericConfigurationElementCollection = class(System.Configuration.ConfigurationElementCollection)abstract;
JScript
JScript does not support Generics.
Managed Extensions for C++
public __gc abstract class GenericConfigurationElementCollection<TConfigurationElement> : public System.Configuration.ConfigurationElementCollection where TConfigurationElement: ConfigurationElement
C++/CLI
generic<typename TConfigurationElement>
public ref class GenericConfigurationElementCollection abstract : public System.Configuration.ConfigurationElementCollection where TConfigurationElement: ConfigurationElement

Type Parameters

TConfigurationElement
The type of the configuration elements contained in the collection

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.Configuration.ConfigurationElementCollection
Noemax.WCFX.Configuration.GenericConfigurationElementCollection<TConfigurationElement>
Noemax.WCFX.Configuration.BindingElementExtensionElementCollection<TBindingElementExtension>
Noemax.WCFX.Configuration.ExtensionBindingElementCollection

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
GenericConfigurationElementCollection<TConfigurationElement> Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : GenericConfigurationElementCollection<TConfigurationElement> Class

The following tables list the members exposed by GenericConfigurationElementCollection<TConfigurationElement>.

Public Properties

 | Name | Description
public Property | CollectionType | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Public Methods

 | Name | Description
public Method | ContainsKey | Returns true if collection contains element with specified key.
public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Implements ConfigurationElementCollection abstract method.
protected Method | GetElementKey | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
GenericConfigurationElementCollection<TConfigurationElement> Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : GenericConfigurationElementCollection<TConfigurationElement> Class

For a list of all members of this type, see GenericConfigurationElementCollection<TConfigurationElement> members.

Public Methods

 | Name | Description
public Method | ContainsKey | Returns true if collection contains element with specified key.
public Method | CopyTo | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | GetEnumerator | (Inherited from System.Configuration.ConfigurationElementCollection)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | BaseIndexOf | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | CreateNewElement | Overloaded. Overridden. Implements ConfigurationElementCollection abstract method.
protected Method | GetElementKey | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | IsElementRemovable | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContainsKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : ContainsKey Method

key
A key
Returns true if collection contains element with specified key.

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim key As Object
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   object key
)
Delphi
public function ContainsKey(
    key: TObject
): Boolean;
JScript
public function ContainsKey(
   key : Object
) : boolean;
Managed Extensions for C++
public: bool ContainsKey(
   Object* key
)
C++/CLI
public:
bool ContainsKey(
   Object^ key
)

Parameters

key
A key

Return Value

true if collection contains element with specified key; false otherwise.

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : CreateNewElement Method

Implements ConfigurationElementCollection abstract method.

Overload List

Overload | Description
CreateNewElement() | Implements ConfigurationElementCollection abstract method.
CreateNewElement(String) | (Inherited from System.Configuration.ConfigurationElementCollection)

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members
Base Implementation in CreateNewElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement() Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class > CreateNewElement Method : CreateNewElement() Method

Implements ConfigurationElementCollection abstract method.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function CreateNewElement() As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationElement

value = instance.CreateNewElement()
C#
protected override ConfigurationElement CreateNewElement()
Delphi
protected function CreateNewElement(): ConfigurationElement; override;
JScript
protected override function CreateNewElement() : ConfigurationElement;
Managed Extensions for C++
protected: ConfigurationElement* CreateNewElement(); override
C++/CLI
protected:
ConfigurationElement^ CreateNewElement(); override

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members
Overload List
Base Implementation in CreateNewElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : HttpsViaProxyTransportElement Class

Represents a WCF configuration element which specifies the HttpsViaProxyTransportBindingElement will be used and exposes its settings through configuration.

Object Model

HttpsViaProxyTransportElement Class

Syntax

Visual Basic (Declaration)
Public Class HttpsViaProxyTransportElement
   Inherits System.ServiceModel.Configuration.HttpTransportElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
C#
public class HttpsViaProxyTransportElement : System.ServiceModel.Configuration.HttpTransportElement
Delphi
public class HttpsViaProxyTransportElement = class(System.ServiceModel.Configuration.HttpTransportElement)
JScript
public class HttpsViaProxyTransportElement extends System.ServiceModel.Configuration.HttpTransportElement
Managed Extensions for C++
public __gc class HttpsViaProxyTransportElement : public System.ServiceModel.Configuration.HttpTransportElement
C++/CLI
public ref class HttpsViaProxyTransportElement : public System.ServiceModel.Configuration.HttpTransportElement

Remarks

When the BasicHttpBinding security mode is set to TransportWithMessageCredential, BasicHttpBinding enforces the use of transport security which introduces a lot of exrta overhead if the servers are proxied by and SSL/TLS accelerator proxy.

When this binding element is plugged into the BasicHttpBinding, it enables the server to avoiding extra overhead and receive client messages and credentials from the SSL/TLS accelerator proxy over an unsecured connection.

It should be used only on the server side, when transport security is provided by an SSL/TLS accelerator proxy.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
System.ServiceModel.Configuration.TransportElement
System.ServiceModel.Configuration.HttpTransportElement
Noemax.WCFX.Configuration.HttpsViaProxyTransportElement

See Also

Reference

HttpsViaProxyTransportElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : HttpsViaProxyTransportElement Class

The following tables list the members exposed by HttpsViaProxyTransportElement.

Public Constructors

 | Name | Description
public Constructor | HttpsViaProxyTransportElement Constructor | Initializes a new instance of Noemax.WCFX.Configuration.HttpsVisProxyTransportElement.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | AuthenticationScheme | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | BindingElementType | Overridden. Returns the type of Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.
public Property | BypassProxyOnLocal | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DecompressionEnabled | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | ExtendedProtectionPolicy | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | HostNameComparisonMode | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | KeepAliveEnabled | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | MaxBufferSize | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | ProxyAddress | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ProxyAuthenticationScheme | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | Realm | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | TransferMode | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | UnsafeConnectionNtlmAuthentication | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | UseDefaultWebProxy | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.BindingElementExtensionElement)
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Creates the Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.
protected Method | CreateDefaultBindingElement | (Inherited from System.ServiceModel.Configuration.TransportElement)
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

HttpsViaProxyTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : HttpsViaProxyTransportElement Constructor

Initializes a new instance of Noemax.WCFX.Configuration.HttpsVisProxyTransportElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New HttpsViaProxyTransportElement()
C#
public HttpsViaProxyTransportElement()
Delphi
public HttpsViaProxyTransportElement();
JScript
public function HttpsViaProxyTransportElement();
Managed Extensions for C++
public: HttpsViaProxyTransportElement();
C++/CLI
public:
HttpsViaProxyTransportElement();

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : HttpsViaProxyTransportElement Class

For a list of all members of this type, see HttpsViaProxyTransportElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.BindingElementExtensionElement)
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Creates the Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.
protected Method | CreateDefaultBindingElement | (Inherited from System.ServiceModel.Configuration.TransportElement)
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

HttpsViaProxyTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : CreateBindingElement Method

Creates the Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

Return Value

The new instance of HttpsViaProxyTransportBindingElement.

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : HttpsViaProxyTransportElement Class

For a list of all members of this type, see HttpsViaProxyTransportElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | AuthenticationScheme | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | BindingElementType | Overridden. Returns the type of Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.
public Property | BypassProxyOnLocal | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DecompressionEnabled | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | ExtendedProtectionPolicy | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | HostNameComparisonMode | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | KeepAliveEnabled | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | MaxBufferSize | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Configuration.TransportElement)
public Property | ProxyAddress | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | ProxyAuthenticationScheme | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | Realm | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | TransferMode | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | UnsafeConnectionNtlmAuthentication | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
public Property | UseDefaultWebProxy | (Inherited from System.ServiceModel.Configuration.HttpTransportElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

HttpsViaProxyTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : BindingElementType Property

Returns the type of Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpsTransportElement Class

Represents a WCF configuration element which specifies the LiteHttpsTransportBindingElement will be used and exposes its settings through configuration.

Object Model

LiteHttpsTransportElement Class

Syntax

Visual Basic (Declaration)
Public Class LiteHttpsTransportElement
   Inherits LiteHttpTransportElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
C#
public class LiteHttpsTransportElement : LiteHttpTransportElement
Delphi
public class LiteHttpsTransportElement = class(LiteHttpTransportElement)
JScript
public class LiteHttpsTransportElement extends LiteHttpTransportElement
Managed Extensions for C++
public __gc class LiteHttpsTransportElement : public LiteHttpTransportElement
C++/CLI
public ref class LiteHttpsTransportElement : public LiteHttpTransportElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.LiteHttpTransportElement
Noemax.WCFX.Configuration.LiteHttpsTransportElement

See Also

Reference

LiteHttpsTransportElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpsTransportElement Class

The following tables list the members exposed by LiteHttpsTransportElement.

Public Constructors

 | Name | Description
public Constructor | LiteHttpsTransportElement Constructor |
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | AuthenticationScheme | Gets and sets the scheme to be used for authenticating with an endpont. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | ProxyAddress | (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | ProxyAuthenticationScheme | Gets and sets the scheme to be used for authenticating with a proxy. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | RequireClientCertificate | Gets or sets a value that indicates whether SSL client authentication is required.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpsTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpsTransportElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LiteHttpsTransportElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LiteHttpsTransportElement()
C#
public LiteHttpsTransportElement()
Delphi
public LiteHttpsTransportElement();
JScript
public function LiteHttpsTransportElement();
Managed Extensions for C++
public: LiteHttpsTransportElement();
C++/CLI
public:
LiteHttpsTransportElement();

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpsTransportElement Class

For a list of all members of this type, see LiteHttpsTransportElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpsTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LiteHttpsTransportElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpsTransportElement Class

For a list of all members of this type, see LiteHttpsTransportElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | AuthenticationScheme | Gets and sets the scheme to be used for authenticating with an endpont. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | ProxyAddress | (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | ProxyAuthenticationScheme | Gets and sets the scheme to be used for authenticating with a proxy. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | RequireClientCertificate | Gets or sets a value that indicates whether SSL client authentication is required.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available. (Inherited from Noemax.WCFX.Configuration.LiteHttpTransportElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpsTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

Property Value

Returns typeof(LiteHttpsTransportBindingElement).

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
RequireClientCertificate Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : RequireClientCertificate Property

Gets or sets a value that indicates whether SSL client authentication is required.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="requireClientCertificate",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property RequireClientCertificate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Boolean

instance.RequireClientCertificate = value

value = instance.RequireClientCertificate
C#
[ConfigurationPropertyAttribute(Name="requireClientCertificate",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool RequireClientCertificate {get; set;}
Delphi
public read-write property RequireClientCertificate: Boolean;
JScript
ConfigurationPropertyAttribute(Name="requireClientCertificate",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set RequireClientCertificate : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="requireClientCertificate",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_RequireClientCertificate();
public: __property void set_RequireClientCertificate(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="requireClientCertificate",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool RequireClientCertificate {
   bool get();
   void set (    bool value);
}

Property Value

true if SSL client authentication is required; otherwise, false. The default is false.

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpTransportElement Class

Represents a WCF configuration element which specifies the LiteHttpsTransportBindingElement will be used and exposes its settings through configuration.

Object Model

LiteHttpTransportElement Class

Syntax

Visual Basic (Declaration)
Public Class LiteHttpTransportElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
C#
public class LiteHttpTransportElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class LiteHttpTransportElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class LiteHttpTransportElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class LiteHttpTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class LiteHttpTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.LiteHttpTransportElement
Noemax.WCFX.Configuration.LiteHttpsTransportElement

See Also

Reference

LiteHttpTransportElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpTransportElement Class

The following tables list the members exposed by LiteHttpTransportElement.

Public Constructors

 | Name | Description
public Constructor | LiteHttpTransportElement Constructor |
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets and sets the scheme to be used for authenticating with an endpont.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | ProxyAddress |
public Property | ProxyAuthenticationScheme | Gets and sets the scheme to be used for authenticating with a proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LiteHttpTransportElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LiteHttpTransportElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LiteHttpTransportElement()
C#
public LiteHttpTransportElement()
Delphi
public LiteHttpTransportElement();
JScript
public function LiteHttpTransportElement();
Managed Extensions for C++
public: LiteHttpTransportElement();
C++/CLI
public:
LiteHttpTransportElement();

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpTransportElement Class

For a list of all members of this type, see LiteHttpTransportElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LiteHttpTransportElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LiteHttpTransportElement Class

For a list of all members of this type, see LiteHttpTransportElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.
public Property | AuthenticationScheme | Gets and sets the scheme to be used for authenticating with an endpont.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EnableGetWSDL | Gets and sets if transport should support WSDL export through HTTP GET requests.
public Property | KeepAliveEnabled | Gets or sets a value indicating whether to make a persistent connection to a service endpoint.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | ProxyAddress |
public Property | ProxyAuthenticationScheme | Gets and sets the scheme to be used for authenticating with a proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LiteHttpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : AllowCookies Property

Gets or sets a value that indicates whether the client accepts cookies and propagates them on future requests.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set AllowCookies : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

Property Value

true if cookies are allowed; otherwise, false. The default is false.

Remarks

This property is provided as a convenience for interacting with ASMX Web services that use cookies to make sure that the cookies returned from the server are automatically copied to all future client requests for that service.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : AuthenticationScheme Property

Gets and sets the scheme to be used for authenticating with an endpont.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property AuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
C#
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public AuthenticationSchemes AuthenticationScheme {get; set;}
Delphi
public read-write property AuthenticationScheme: AuthenticationSchemes;
JScript
ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set AuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property AuthenticationSchemes AuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnableGetWSDL Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : EnableGetWSDL Property

Gets and sets if transport should support WSDL export through HTTP GET requests.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="enableGetWSDL",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property EnableGetWSDL As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.EnableGetWSDL = value

value = instance.EnableGetWSDL
C#
[ConfigurationPropertyAttribute(Name="enableGetWSDL",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool EnableGetWSDL {get; set;}
Delphi
public read-write property EnableGetWSDL: Boolean;
JScript
ConfigurationPropertyAttribute(Name="enableGetWSDL",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set EnableGetWSDL : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="enableGetWSDL",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_EnableGetWSDL();
public: __property void set_EnableGetWSDL(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="enableGetWSDL",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool EnableGetWSDL {
   bool get();
   void set (    bool value);
}

Remarks

If set to true, the transport will return web service metadata on HTTP GET request to base address + "?wsdl" e.g. http://somehost/someservice?wsdl

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
KeepAliveEnabled Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : KeepAliveEnabled Property

Gets or sets a value indicating whether to make a persistent connection to a service endpoint.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property KeepAliveEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.KeepAliveEnabled = value

value = instance.KeepAliveEnabled
C#
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool KeepAliveEnabled {get; set;}
Delphi
public read-write property KeepAliveEnabled: Boolean;
JScript
ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set KeepAliveEnabled : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_KeepAliveEnabled();
public: __property void set_KeepAliveEnabled(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool KeepAliveEnabled {
   bool get();
   void set (    bool value);
}

Property Value

true if a persistent connection to the internet resource is maintained; otherwise, false.

Remarks

Set this property to true to send a Connection HTTP header with the value Keep-alive. A client uses this property to indicate a preference for persistent connections. When this property is true, the connection that the client makes to a service endpoint is persistent if the service endpoint supports that.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ManualAddressing Property

Gets or sets a Boolean value that specifies whether the user takes control of message addressing.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false.

Remarks

This property is usually used in router scenarios, where the application determines which one of several destinations to send a message to.

If this property is set to true, the channel assumes the message has already been addressed and does not add any additional information to it.

If this property is set to false, the channel adds SOAP addressing information to the message.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : MaxBufferPoolSize Property

Gets or sets the maximum size of the buffer pool.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size of the buffer pool. The default is 524,288 bytes (512 * 1024).

Remarks

Many parts of WCF use buffers. Creating and destroying buffers each time they are used is expensive, and garbage collection for buffers is also expensive. With buffer pools, you can take a buffer from the pool, use it, and return it to the pool once you are done. Thus the overhead in creating and destroying buffers is avoided.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false. The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : MaxReceivedMessageSize Property

Gets or sets the maximum allowed message size that can be received.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum allowed message size that can be received.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ProxyAddress Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProxyAddress : Uri
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ProxyAuthenticationScheme Property

Gets and sets the scheme to be used for authenticating with a proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="proxyAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProxyAuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As AuthenticationSchemes

instance.ProxyAuthenticationScheme = value

value = instance.ProxyAuthenticationScheme
C#
[ConfigurationPropertyAttribute(Name="proxyAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public AuthenticationSchemes ProxyAuthenticationScheme {get; set;}
Delphi
public read-write property ProxyAuthenticationScheme: AuthenticationSchemes;
JScript
ConfigurationPropertyAttribute(Name="proxyAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProxyAuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="proxyAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property AuthenticationSchemes get_ProxyAuthenticationScheme();
public: __property void set_ProxyAuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="proxyAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property AuthenticationSchemes ProxyAuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

A valid TransferMode value that specifies whether messages are buffered or streamed or a request or response. The System.ServiceModel.Channels.TransferMode that indicates whether messages are sent buffered or streamed.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : UseDefaultWebProxy Property

Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

Property Value

true if thetrue if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true.

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalClientSecurityUpdateElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalClientSecurityUpdateElement Class

When used within <extensionBinding/> element, updates the target binding client security settings by overwriting them with properties of this class.

Object Model

LocalClientSecurityUpdateElement Class

Syntax

Visual Basic (Declaration)
Public Class LocalClientSecurityUpdateElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
C#
public class LocalClientSecurityUpdateElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class LocalClientSecurityUpdateElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class LocalClientSecurityUpdateElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class LocalClientSecurityUpdateElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class LocalClientSecurityUpdateElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Remarks

This configuration element is intended for updating the security settings of predefined WCF binding whenever it's not possible to do directly. Currently it updates only the MaxClockSkew property.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.LocalClientSecurityUpdateElement

See Also

Reference

LocalClientSecurityUpdateElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LocalClientSecurityUpdateElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : LocalClientSecurityUpdateElement Class

The following tables list the members exposed by LocalClientSecurityUpdateElement.

Public Constructors

 | Name | Description
public Constructor | LocalClientSecurityUpdateElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxClockSkew | Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of a binding element represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalClientSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalClientSecurityUpdateElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LocalClientSecurityUpdateElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LocalClientSecurityUpdateElement()
C#
public LocalClientSecurityUpdateElement()
Delphi
public LocalClientSecurityUpdateElement();
JScript
public function LocalClientSecurityUpdateElement();
Managed Extensions for C++
public: LocalClientSecurityUpdateElement();
C++/CLI
public:
LocalClientSecurityUpdateElement();

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LocalClientSecurityUpdateElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalClientSecurityUpdateElement Class

For a list of all members of this type, see LocalClientSecurityUpdateElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of a binding element represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalClientSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : CreateBindingElement Method

Initializes a new instance of a binding element represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LocalClientSecurityUpdateElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalClientSecurityUpdateElement Class

For a list of all members of this type, see LocalClientSecurityUpdateElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxClockSkew | Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalClientSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxClockSkew Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : MaxClockSkew Property

Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property MaxClockSkew As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As TimeSpan

value = instance.MaxClockSkew
C#
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan MaxClockSkew {get;}
Delphi
public read-only property MaxClockSkew: TimeSpan;
JScript
ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get MaxClockSkew : TimeSpan
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_MaxClockSkew();
C++/CLI
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan MaxClockSkew {
   TimeSpan get();
}

Property Value

A TimeSpan that represents the maximum allowable time difference between the system clocks of the two parties that are communicating. The default is 5 minutes

Remarks

Messages between systems whose clocks' difference exceeds the value specified in this property are rejected.

This property is used in conjunction with the message time stamp verification and the ReplayWindow property.

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalServiceSecurityUpdateElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalServiceSecurityUpdateElement Class

When used within <extensionBinding/> element, updates the target binding service security settings by overwriting them with properties of this class.

Object Model

LocalServiceSecurityUpdateElement Class

Syntax

Visual Basic (Declaration)
Public Class LocalServiceSecurityUpdateElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
C#
public class LocalServiceSecurityUpdateElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class LocalServiceSecurityUpdateElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class LocalServiceSecurityUpdateElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class LocalServiceSecurityUpdateElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class LocalServiceSecurityUpdateElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Remarks

This configuration element is intended for updating the security settings of predefined WCF binding whenever it's not possible to do directly. Currently it updates only the MaxClockSkew property.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.LocalServiceSecurityUpdateElement

See Also

Reference

LocalServiceSecurityUpdateElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
LocalServiceSecurityUpdateElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : LocalServiceSecurityUpdateElement Class

The following tables list the members exposed by LocalServiceSecurityUpdateElement.

Public Constructors

 | Name | Description
public Constructor | LocalServiceSecurityUpdateElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxClockSkew | Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalServiceSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalServiceSecurityUpdateElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LocalServiceSecurityUpdateElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New LocalServiceSecurityUpdateElement()
C#
public LocalServiceSecurityUpdateElement()
Delphi
public LocalServiceSecurityUpdateElement();
JScript
public function LocalServiceSecurityUpdateElement();
Managed Extensions for C++
public: LocalServiceSecurityUpdateElement();
C++/CLI
public:
LocalServiceSecurityUpdateElement();

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
LocalServiceSecurityUpdateElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalServiceSecurityUpdateElement Class

For a list of all members of this type, see LocalServiceSecurityUpdateElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalServiceSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
LocalServiceSecurityUpdateElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : LocalServiceSecurityUpdateElement Class

For a list of all members of this type, see LocalServiceSecurityUpdateElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxClockSkew | Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

LocalServiceSecurityUpdateElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxClockSkew Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : MaxClockSkew Property

Gets or sets the maximum allowable time difference between the system clocks of the two parties that are communicating.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property MaxClockSkew As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As TimeSpan

value = instance.MaxClockSkew
C#
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan MaxClockSkew {get;}
Delphi
public read-only property MaxClockSkew: TimeSpan;
JScript
ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get MaxClockSkew : TimeSpan
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_MaxClockSkew();
C++/CLI
[ConfigurationPropertyAttribute(Name="maxClockSkew",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan MaxClockSkew {
   TimeSpan get();
}

Property Value

A TimeSpan that represents the maximum allowable time difference between the system clocks of the two parties that are communicating. The default is 5 minutes

Remarks

Messages between systems whose clocks' difference exceeds the value specified in this property are rejected.

This property is used in conjunction with the message time stamp verification and the ReplayWindow property.

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageStatisticsElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : MessageStatisticsElement Class

Represents a WCF configuration element which specifies the MessageStatisticsBindingElement will be used and exposes its settings through configuration.

Object Model

MessageStatisticsElement Class

Syntax

Visual Basic (Declaration)
Public Class MessageStatisticsElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
C#
public class MessageStatisticsElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class MessageStatisticsElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class MessageStatisticsElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class MessageStatisticsElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class MessageStatisticsElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.MessageStatisticsElement

See Also

Reference

MessageStatisticsElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
MessageStatisticsElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : MessageStatisticsElement Class

The following tables list the members exposed by MessageStatisticsElement.

Public Constructors

 | Name | Description
public Constructor | MessageStatisticsElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | LogFilename | Gets and sets the path to the message statistics log file.
public Property | Verbose | If set to true the message statistics log will be written in verbose format.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

MessageStatisticsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageStatisticsElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : MessageStatisticsElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MessageStatisticsElement()
C#
public MessageStatisticsElement()
Delphi
public MessageStatisticsElement();
JScript
public function MessageStatisticsElement();
Managed Extensions for C++
public: MessageStatisticsElement();
C++/CLI
public:
MessageStatisticsElement();

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
MessageStatisticsElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : MessageStatisticsElement Class

For a list of all members of this type, see MessageStatisticsElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

MessageStatisticsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : CreateBindingElement Method

Initializes a new instance of CompressionBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

Return Value

A CompressionBindingElement instance.

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
MessageStatisticsElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : MessageStatisticsElement Class

For a list of all members of this type, see MessageStatisticsElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | LogFilename | Gets and sets the path to the message statistics log file.
public Property | Verbose | If set to true the message statistics log will be written in verbose format.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

MessageStatisticsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

Property Value

The type of BindingElement represented by this configuration element.

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LogFilename Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LogFilename Property

Gets and sets the path to the message statistics log file.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="logFilename",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property LogFilename As String
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As String

instance.LogFilename = value

value = instance.LogFilename
C#
[ConfigurationPropertyAttribute(Name="logFilename",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string LogFilename {get; set;}
Delphi
public read-write property LogFilename: String;
JScript
ConfigurationPropertyAttribute(Name="logFilename",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set LogFilename : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="logFilename",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_LogFilename();
public: __property void set_LogFilename(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="logFilename",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ LogFilename {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Verbose Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : Verbose Property

If set to true the message statistics log will be written in verbose format.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="verbose",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Verbose As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Boolean

instance.Verbose = value

value = instance.Verbose
C#
[ConfigurationPropertyAttribute(Name="verbose",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool Verbose {get; set;}
Delphi
public read-write property Verbose: Boolean;
JScript
ConfigurationPropertyAttribute(Name="verbose",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Verbose : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="verbose",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_Verbose();
public: __property void set_Verbose(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="verbose",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool Verbose {
   bool get();
   void set (    bool value);
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingCollectionElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingCollectionElement Class

Represents a configuration section that holds a collection of SmartHttpBindingElement elements.

Object Model

SmartHttpBindingCollectionElement Class

Syntax

Visual Basic (Declaration)
Public Class SmartHttpBindingCollectionElement
   Inherits System.ServiceModel.Configuration.StandardBindingCollectionElement(Of SmartHttpBinding,SmartHttpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
C#
public class SmartHttpBindingCollectionElement : System.ServiceModel.Configuration.StandardBindingCollectionElement<SmartHttpBinding,SmartHttpBindingElement>
Delphi
public class SmartHttpBindingCollectionElement = class(System.ServiceModel.Configuration.StandardBindingCollectionElement)
JScript
public class SmartHttpBindingCollectionElement extends System.ServiceModel.Configuration.StandardBindingCollectionElement
Managed Extensions for C++
public __gc class SmartHttpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<SmartHttpBinding,SmartHttpBindingElement>
C++/CLI
public ref class SmartHttpBindingCollectionElement : public System.ServiceModel.Configuration.StandardBindingCollectionElement<SmartHttpBinding,SmartHttpBindingElement>

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.BindingCollectionElement
System.ServiceModel.Configuration.StandardBindingCollectionElement<TStandardBinding,TBindingConfiguration>
Noemax.WCFX.Configuration.SmartHttpBindingCollectionElement

See Also

Reference

SmartHttpBindingCollectionElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingCollectionElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingCollectionElement Class

The following tables list the members exposed by SmartHttpBindingCollectionElement.

Public Constructors

 | Name | Description
public Constructor | SmartHttpBindingCollectionElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<SmartHttpBinding,SmartHttpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SmartHttpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingCollectionElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : SmartHttpBindingCollectionElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SmartHttpBindingCollectionElement()
C#
public SmartHttpBindingCollectionElement()
Delphi
public SmartHttpBindingCollectionElement();
JScript
public function SmartHttpBindingCollectionElement();
Managed Extensions for C++
public: SmartHttpBindingCollectionElement();
C++/CLI
public:
SmartHttpBindingCollectionElement();

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingElement Class

Represents a WCF configuration element which specifies the SmartHttpBinding will be used and exposes its settings through configuration.

Object Model

SmartHttpBindingElement Class

Syntax

Visual Basic (Declaration)
Public Class SmartHttpBindingElement
   Inherits System.ServiceModel.Configuration.StandardBindingElement
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
C#
public class SmartHttpBindingElement : System.ServiceModel.Configuration.StandardBindingElement
Delphi
public class SmartHttpBindingElement = class(System.ServiceModel.Configuration.StandardBindingElement)
JScript
public class SmartHttpBindingElement extends System.ServiceModel.Configuration.StandardBindingElement
Managed Extensions for C++
public __gc class SmartHttpBindingElement : public System.ServiceModel.Configuration.StandardBindingElement
C++/CLI
public ref class SmartHttpBindingElement : public System.ServiceModel.Configuration.StandardBindingElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.StandardBindingElement
Noemax.WCFX.Configuration.SmartHttpBindingElement

See Also

Reference

SmartHttpBindingElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingElement Class

The following tables list the members exposed by SmartHttpBindingElement.

Public Constructors

 | Name | Description
public Constructor | SmartHttpBindingElement Constructor | Overloaded. Initializes a new instance of the SmartHttpBindnigElement class.
Top

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a boolean value that specifies whether the client accepts cookies and propagates them on future requests.
public Property | BypassProxyOnLocal | Gets or sets the attribute that indicates whether to bypass the proxy server for local addresses.
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and set the compression mode used by the binding.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DefaultMessageEncoding | Gets and sets the name of the default message encoding.
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | HostNameComparisonMode | Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxArrayLength |
public Property | MaxBufferPoolSize | Gets or sets the maximum size for a buffer pool that stores messages processed by the binding.
public Property | MaxBufferSize | Gets and sets the maximum message size limit for messages being received the remote side.
public Property | MaxBytesPerRead |
public Property | MaxDepth |
public Property | MaxNameTableCharCount |
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a message that can be received.
public Property | MaxStringContentLength |
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | Gets and sets the string that specifies the list of message encoding algorithms that are supported by this binding.
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | ProxyAddress | Gets or sets the URI address of the HTTP proxy.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Security | Gets or sets the type of security to be used with this binding.
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode | Gets or sets a value that specifies whether messages are buffered or streamed or a request or response.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Gets a type of associated binding element.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets a collection of configuration properties.
protected Property | ReaderQuotas | Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | InitializeFrom | Overridden. Initializes this binding configuration element with the content of the specified binding collection.
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | Overridden. Applies the content of the specified binding to this binding configuration element.
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SmartHttpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : SmartHttpBindingElement Constructor

Initializes a new instance of the SmartHttpBindnigElement class.

Overload List

Overload | Description
SmartHttpBindingElement Constructor() | Initializes a new instance of the SmartHttpBindnigElement class.
SmartHttpBindingElement Constructor(String) | Initializes a new instance of the SmartHttpBindnigElement class with the specified configuration name.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Constructor()
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class > SmartHttpBindingElement Constructor : SmartHttpBindingElement Constructor()

Initializes a new instance of the SmartHttpBindnigElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SmartHttpBindingElement()
C#
public SmartHttpBindingElement()
Delphi
public SmartHttpBindingElement();
JScript
public function SmartHttpBindingElement();
Managed Extensions for C++
public: SmartHttpBindingElement();
C++/CLI
public:
SmartHttpBindingElement();

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Constructor(String)
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class > SmartHttpBindingElement Constructor : SmartHttpBindingElement Constructor(String)

configurationName
The configuration name.
Initializes a new instance of the SmartHttpBindnigElement class with the specified configuration name.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal configurationName As String _
)
Visual Basic (Usage) Copy Code
Dim configurationName As String

Dim instance As New SmartHttpBindingElement(configurationName)
C#
public SmartHttpBindingElement(
   string configurationName
)
Delphi
public SmartHttpBindingElement(
    configurationName: String
);
JScript
public function SmartHttpBindingElement(
   configurationName : String
);
Managed Extensions for C++
public: SmartHttpBindingElement(
   string* configurationName
)
C++/CLI
public:
SmartHttpBindingElement(
   String^ configurationName
)

Parameters

configurationName
The configuration name.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingElement Class

For a list of all members of this type, see SmartHttpBindingElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | InitializeFrom | Overridden. Initializes this binding configuration element with the content of the specified binding collection.
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | Overridden. Applies the content of the specified binding to this binding configuration element.
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SmartHttpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : InitializeFrom Method

binding

A collection of binding elements.

Initializes this binding configuration element with the content of the specified binding collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeFrom( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim binding As Binding

instance.InitializeFrom(binding)
C#
protected override void InitializeFrom(
   Binding binding
)
Delphi
protected procedure InitializeFrom(
    binding: Binding
); override;
JScript
protected override function InitializeFrom(
   binding : Binding
);
Managed Extensions for C++
protected: void InitializeFrom(
   Binding* binding
) override
C++/CLI
protected:
void InitializeFrom(
   Binding^ binding
) override

Parameters

binding

A collection of binding elements.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Base Implementation in InitializeFrom


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : OnApplyConfiguration Method

binding

A binding.

Applies the content of the specified binding to this binding configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim binding As Binding

instance.OnApplyConfiguration(binding)
C#
protected override void OnApplyConfiguration(
   Binding binding
)
Delphi
protected procedure OnApplyConfiguration(
    binding: Binding
); override;
JScript
protected override function OnApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
protected: void OnApplyConfiguration(
   Binding* binding
) override
C++/CLI
protected:
void OnApplyConfiguration(
   Binding^ binding
) override

Parameters

binding

A binding.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Base Implementation in OnApplyConfiguration


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingElement Class

For a list of all members of this type, see SmartHttpBindingElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | Gets or sets a boolean value that specifies whether the client accepts cookies and propagates them on future requests.
public Property | BypassProxyOnLocal | Gets or sets the attribute that indicates whether to bypass the proxy server for local addresses.
public Property | CloseTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | CompressionAlgorithms | Gets and sets the compression algorithms to be used for message compression. Default value is GZip.
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.
public Property | CompressionMode | Gets and set the compression mode used by the binding.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DefaultMessageEncoding | Gets and sets the name of the default message encoding.
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | HostNameComparisonMode | Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | MaxArrayLength |
public Property | MaxBufferPoolSize | Gets or sets the maximum size for a buffer pool that stores messages processed by the binding.
public Property | MaxBufferSize | Gets and sets the maximum message size limit for messages being received the remote side.
public Property | MaxBytesPerRead |
public Property | MaxDepth |
public Property | MaxNameTableCharCount |
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a message that can be received.
public Property | MaxStringContentLength |
public Property | MessageEncodingMode | Gets and sets the message encoding mode to be used by this binding.
public Property | MessageEncodings | Gets and sets the string that specifies the list of message encoding algorithms that are supported by this binding.
public Property | Name | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | ProxyAddress | Gets or sets the URI address of the HTTP proxy.
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | Security | Gets or sets the type of security to be used with this binding.
public Property | SendTimeout | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Property | TransferMode | Gets or sets a value that specifies whether messages are buffered or streamed or a request or response.
public Property | UseDefaultWebProxy | Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.
Top

Protected Properties

 | Name | Description
protected Property | BindingElementType | Overridden. Gets a type of associated binding element.
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | Overridden. Gets a collection of configuration properties.
protected Property | ReaderQuotas | Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.
Top

See Also

Reference

SmartHttpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : AllowCookies Property

Gets or sets a boolean value that specifies whether the client accepts cookies and propagates them on future requests.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set AllowCookies : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

Property Value

true if the client accepts cookies and propagates them on future requests; otherwise, false. The default is false.

Remarks

You can use this attribute when you interact with ASMX Web services that use cookies. In this way, you can be sure that the cookies returned from the server are automatically copied to all future client requests for that service.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : BindingElementType Property

Gets a type of associated binding element.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Type

value = instance.BindingElementType
C#
protected override Type BindingElementType {get;}
Delphi
protected read-only property BindingElementType: Type; override;
JScript
protected override function get BindingElementType : Type
Managed Extensions for C++
protected: __property Type* get_BindingElementType() override;
C++/CLI
protected:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BypassProxyOnLocal Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : BypassProxyOnLocal Property

Gets or sets the attribute that indicates whether to bypass the proxy server for local addresses.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property BypassProxyOnLocal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Boolean

instance.BypassProxyOnLocal = value

value = instance.BypassProxyOnLocal
C#
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool BypassProxyOnLocal {get; set;}
Delphi
public read-write property BypassProxyOnLocal: Boolean;
JScript
ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set BypassProxyOnLocal : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_BypassProxyOnLocal();
public: __property void set_BypassProxyOnLocal(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool BypassProxyOnLocal {
   bool get();
   void set (    bool value);
}

Property Value

A Boolean value that indicates whether to bypass the proxy server for local addresses.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionAlgorithms Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : CompressionAlgorithms Property

Gets and sets the compression algorithms to be used for message compression. Default value is GZip.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionAlgorithms As CompressionAlgorithms
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As CompressionAlgorithms

instance.CompressionAlgorithms = value

value = instance.CompressionAlgorithms
C#
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public CompressionAlgorithms CompressionAlgorithms {get; set;}
Delphi
public read-write property CompressionAlgorithms: CompressionAlgorithms;
JScript
ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionAlgorithms : CompressionAlgorithms
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property CompressionAlgorithms get_CompressionAlgorithms();
public: __property void set_CompressionAlgorithms(
   CompressionAlgorithms value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionAlgorithms",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property CompressionAlgorithms CompressionAlgorithms {
   CompressionAlgorithms get();
   void set (    CompressionAlgorithms value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionLevel Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : CompressionLevel Property

Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionLevel As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.CompressionLevel = value

value = instance.CompressionLevel
C#
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int CompressionLevel {get; set;}
Delphi
public read-write property CompressionLevel: Integer;
JScript
ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionLevel : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_CompressionLevel();
public: __property void set_CompressionLevel(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionLevel",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int CompressionLevel {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CompressionMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : CompressionMode Property

Gets and set the compression mode used by the binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CompressionMode As SmartCompressionMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As SmartCompressionMode

instance.CompressionMode = value

value = instance.CompressionMode
C#
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SmartCompressionMode CompressionMode {get; set;}
Delphi
public read-write property CompressionMode: SmartCompressionMode;
JScript
ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CompressionMode : SmartCompressionMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SmartCompressionMode get_CompressionMode();
public: __property void set_CompressionMode(
   SmartCompressionMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="compressionMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SmartCompressionMode CompressionMode {
   SmartCompressionMode get();
   void set (    SmartCompressionMode value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DefaultMessageEncoding Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : DefaultMessageEncoding Property

Gets and sets the name of the default message encoding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="defaultMessageEncoding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property DefaultMessageEncoding As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As String

instance.DefaultMessageEncoding = value

value = instance.DefaultMessageEncoding
C#
[ConfigurationPropertyAttribute(Name="defaultMessageEncoding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string DefaultMessageEncoding {get; set;}
Delphi
public read-write property DefaultMessageEncoding: String;
JScript
ConfigurationPropertyAttribute(Name="defaultMessageEncoding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set DefaultMessageEncoding : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="defaultMessageEncoding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_DefaultMessageEncoding();
public: __property void set_DefaultMessageEncoding(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="defaultMessageEncoding",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ DefaultMessageEncoding {
   String^ get();
   void set (    String^ value);
}

Remarks

The default message encoding should be one of the message encodings specified in MessageEncodings. The value of this property should be the string identifying the message encoding to be used as default.

If the default message encoding is not specified, the message encoding specified last in the MessageEncodings list will be used as default.

In the following example smartHttpBinding is getting configured to support the Fast Infoset and Text message encodings and to use the Text message encoding as default.

<smartHttpBinding>

<binding

name=" clientBinding"

messageEncodings="fi | text"

defaultMessageEncodings="text" >

<readerQuotasmaxBytesPerRead="32000"/>

</binding>

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HostNameComparisonMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : HostNameComparisonMode Property

Gets or sets a value that indicates whether the hostname is used to reach the service when matching the URI.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property HostNameComparisonMode As HostNameComparisonMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As HostNameComparisonMode

instance.HostNameComparisonMode = value

value = instance.HostNameComparisonMode
C#
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public HostNameComparisonMode HostNameComparisonMode {get; set;}
Delphi
public read-write property HostNameComparisonMode: HostNameComparisonMode;
JScript
ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set HostNameComparisonMode : HostNameComparisonMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property HostNameComparisonMode get_HostNameComparisonMode();
public: __property void set_HostNameComparisonMode(
   HostNameComparisonMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property HostNameComparisonMode HostNameComparisonMode {
   HostNameComparisonMode get();
   void set (    HostNameComparisonMode value);
}

Property Value

The HostnameComparisionMode value that indicates whether the hostname is used to reach the service when matching on the URI. The default value is StrongWildcard, which ignores the hostname in the match.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxArrayLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxArrayLength Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ReaderQuotas Properties")>
<ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxArrayLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxArrayLength = value

value = instance.MaxArrayLength
C#
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxArrayLength {get; set;}
Delphi
public read-write property MaxArrayLength: Integer;
JScript
CategoryAttribute("ReaderQuotas Properties")
ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxArrayLength : int
Managed Extensions for C++
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxArrayLength();
public: __property void set_MaxArrayLength(
   int value
);
C++/CLI
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxArrayLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxArrayLength {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxBufferPoolSize Property

Gets or sets the maximum size for a buffer pool that stores messages processed by the binding.

Syntax

Visual Basic (Declaration)
<LongValidatorAttribute(0)>
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[LongValidatorAttribute(0)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
LongValidatorAttribute(0)
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[LongValidatorAttribute(0)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[LongValidatorAttribute(0)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

An Int64 value that specifies the maximum size (in bytes) for a buffer pool that is processed by the binding. The default value is 65,536 bytes.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxBufferSize Property

Gets and sets the maximum message size limit for messages being received the remote side.

Syntax

Visual Basic (Declaration)
<IntegerValidatorAttribute(1)>
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[IntegerValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
IntegerValidatorAttribute(1)
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[IntegerValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[IntegerValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBytesPerRead Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxBytesPerRead Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ReaderQuotas Properties")>
<ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBytesPerRead As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxBytesPerRead = value

value = instance.MaxBytesPerRead
C#
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBytesPerRead {get; set;}
Delphi
public read-write property MaxBytesPerRead: Integer;
JScript
CategoryAttribute("ReaderQuotas Properties")
ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBytesPerRead : int
Managed Extensions for C++
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBytesPerRead();
public: __property void set_MaxBytesPerRead(
   int value
);
C++/CLI
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxBytesPerRead",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBytesPerRead {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxDepth Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxDepth Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ReaderQuotas Properties")>
<ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxDepth = value

value = instance.MaxDepth
C#
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxDepth {get; set;}
Delphi
public read-write property MaxDepth: Integer;
JScript
CategoryAttribute("ReaderQuotas Properties")
ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxDepth : int
Managed Extensions for C++
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxDepth();
public: __property void set_MaxDepth(
   int value
);
C++/CLI
[CategoryAttribute("ReaderQuotas Properties")]
[ConfigurationPropertyAttribute(Name="maxDepth",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxDepth {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxNameTableCharCount Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxNameTableCharCount Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxNameTableCharCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxNameTableCharCount = value

value = instance.MaxNameTableCharCount
C#
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxNameTableCharCount {get; set;}
Delphi
public read-write property MaxNameTableCharCount: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxNameTableCharCount : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxNameTableCharCount();
public: __property void set_MaxNameTableCharCount(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxNameTableCharCount",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxNameTableCharCount {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxReceivedMessageSize Property

Gets or sets the maximum size for a message that can be received.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<LongValidatorAttribute(1)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[LongValidatorAttribute(1)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
LongValidatorAttribute(1)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[LongValidatorAttribute(1)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[LongValidatorAttribute(1)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size, in bytes, for a message that can be received by the binding. The default value is 65,536 bytes.

Remarks

This limit defines the maximum message size, in bytes, including headers. The sender of a message too large for the receiver receives a SOAP fault. The receiver drops the message and creates an entry of the event in the trace log.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxStringContentLength Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MaxStringContentLength Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("ReaderQuotas Properties")>
Public Property MaxStringContentLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Integer

instance.MaxStringContentLength = value

value = instance.MaxStringContentLength
C#
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public int MaxStringContentLength {get; set;}
Delphi
public read-write property MaxStringContentLength: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("ReaderQuotas Properties")
public function get,set MaxStringContentLength : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public: __property int get_MaxStringContentLength();
public: __property void set_MaxStringContentLength(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxStringContentLength",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("ReaderQuotas Properties")]
public:
property int MaxStringContentLength {
   int get();
   void set (    int value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodingMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MessageEncodingMode Property

Gets and sets the message encoding mode to be used by this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MessageEncodingMode As SmartMessageEncodingMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As SmartMessageEncodingMode

instance.MessageEncodingMode = value

value = instance.MessageEncodingMode
C#
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SmartMessageEncodingMode MessageEncodingMode {get; set;}
Delphi
public read-write property MessageEncodingMode: SmartMessageEncodingMode;
JScript
ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MessageEncodingMode : SmartMessageEncodingMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SmartMessageEncodingMode get_MessageEncodingMode();
public: __property void set_MessageEncodingMode(
   SmartMessageEncodingMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="messageEncodingMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SmartMessageEncodingMode MessageEncodingMode {
   SmartMessageEncodingMode get();
   void set (    SmartMessageEncodingMode value);
}

Remarks

Regardless of the MessageEncodingMode settings, this binding is always able to decode messages encoded using any of the message encodings specified by the MessageEncodings collection.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageEncodings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : MessageEncodings Property

Gets and sets the string that specifies the list of message encoding algorithms that are supported by this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="messageEncodings",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MessageEncodings As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As String

instance.MessageEncodings = value

value = instance.MessageEncodings
C#
[ConfigurationPropertyAttribute(Name="messageEncodings",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string MessageEncodings {get; set;}
Delphi
public read-write property MessageEncodings: String;
JScript
ConfigurationPropertyAttribute(Name="messageEncodings",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MessageEncodings : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="messageEncodings",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_MessageEncodings();
public: __property void set_MessageEncodings(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="messageEncodings",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ MessageEncodings {
   String^ get();
   void set (    String^ value);
}

Remarks

This string must be delimiter-separated list of message encoding binding names specifying the list of message encodings that are supported by this binding. The following delimiters are supported: '|', ',' and space.

The names used to specify the message binding elements are the same as the element names used to specify the message encoding in the customBinding configuration element. For example, "textMessageEncoding, mtomMessageEncoding".

The smartHttpBinding element also supports shortcut strings for this property:

  • fi - for Fast Infoset.
  • text - for Text.

The following example specifies that Fast Infoset and Text encodings should be supported and provides a readerQuotas element that will apply to all three types of message encodings:

<smartHttpBinding>

<bindingname="clientBinding"messageEncodings="fi | text">

<readerQuotasmaxBytesPerRead="32000"/>

</binding>

</smartHttpBinding>

The full name of the message encoding can also be provided, for example:

<smartHttpBinding>

<bindingname="clientBinding"messageEncodings="textMessageEncoding">

<readerQuotasmaxBytesPerRead="32000"/>

</binding>

</smartHttpBinding>

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : Properties Property

Gets a collection of configuration properties.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected override ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection; override;
JScript
protected override function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties() override;
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get() override;
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members
Base Implementation in Properties


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ProxyAddress Property

Gets or sets the URI address of the HTTP proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProxyAddress : Uri
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

Property Value

A URI that contains the address of the HTTP proxy.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReaderQuotas Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ReaderQuotas Property

Gets or sets constraints on the complexity of SOAP messages that can be processed by endpoints configured with this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Protected Property ReaderQuotas As XmlDictionaryReaderQuotasElement
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As XmlDictionaryReaderQuotasElement

instance.ReaderQuotas = value

value = instance.ReaderQuotas
C#
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected XmlDictionaryReaderQuotasElement ReaderQuotas {get; set;}
Delphi
protected read-write property ReaderQuotas: XmlDictionaryReaderQuotasElement;
JScript
ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
protected function get,set ReaderQuotas : XmlDictionaryReaderQuotasElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected: __property XmlDictionaryReaderQuotasElement* get_ReaderQuotas();
protected: __property void set_ReaderQuotas(
   XmlDictionaryReaderQuotasElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="readerQuotas",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected:
property XmlDictionaryReaderQuotasElement^ ReaderQuotas {
   XmlDictionaryReaderQuotasElement^ get();
   void set (    XmlDictionaryReaderQuotasElement^ value);
}

Remarks

The complexity constraints include items such as a maximum element depth, a maximum length for string content within the message. The constraints protect against a class of denial of service (DOS) attacks that attempt to use message complexity to tie up endpoint processing resources.

The constrain specified by this element will be applied to all MessageEncodingBindingElements used by binding with condition that they support ReaderQuotas property.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Security Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : Security Property

Gets or sets the type of security to be used with this binding.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="security",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Security As BasicHttpSecurityElement
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As BasicHttpSecurityElement

instance.Security = value

value = instance.Security
C#
[ConfigurationPropertyAttribute(Name="security",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public BasicHttpSecurityElement Security {get; set;}
Delphi
public read-write property Security: BasicHttpSecurityElement;
JScript
ConfigurationPropertyAttribute(Name="security",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Security : BasicHttpSecurityElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="security",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property BasicHttpSecurityElement* get_Security();
public: __property void set_Security(
   BasicHttpSecurityElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="security",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property BasicHttpSecurityElement^ Security {
   BasicHttpSecurityElement^ get();
   void set (    BasicHttpSecurityElement^ value);
}

Property Value

The BasicHttpSecurityElement that specifies the type of security to be used with this binding.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : TransferMode Property

Gets or sets a value that specifies whether messages are buffered or streamed or a request or response.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

A valid TransferMode value that specifies whether messages are buffered or streamed or a request or response.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : UseDefaultWebProxy Property

Gets or sets a value that indicates whether the auto-configured HTTP proxy of the system should be used, if available.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

Property Value

true if the auto-configured HTTP proxy of the system should be used, if available; otherwise, false. The default value is true.

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpDuplexTransportElement Class

Represents a WCF configuration element which specifies the SoapTcpDuplexTransportBindingElement will be used and exposes its settings through configuration.

Object Model

SoapTcpDuplexTransportElement Class

Syntax

Visual Basic (Declaration)
Public Class SoapTcpDuplexTransportElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
C#
public class SoapTcpDuplexTransportElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class SoapTcpDuplexTransportElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class SoapTcpDuplexTransportElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class SoapTcpDuplexTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class SoapTcpDuplexTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.SoapTcpDuplexTransportElement

See Also

Reference

SoapTcpDuplexTransportElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpDuplexTransportElement Class

The following tables list the members exposed by SoapTcpDuplexTransportElement.

Public Constructors

 | Name | Description
public Constructor | SoapTcpDuplexTransportElement Constructor |
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | ConnectionPooling | Enables and disables the connection pooling on the client side.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | IdleTimeout | Gets and set an amount of time server will wait before terminating idle connections.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SoapTcpDuplexTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : SoapTcpDuplexTransportElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SoapTcpDuplexTransportElement()
C#
public SoapTcpDuplexTransportElement()
Delphi
public SoapTcpDuplexTransportElement();
JScript
public function SoapTcpDuplexTransportElement();
Managed Extensions for C++
public: SoapTcpDuplexTransportElement();
C++/CLI
public:
SoapTcpDuplexTransportElement();

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpDuplexTransportElement Class

For a list of all members of this type, see SoapTcpDuplexTransportElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SoapTcpDuplexTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SoapTcpDuplexTransportElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpDuplexTransportElement Class

For a list of all members of this type, see SoapTcpDuplexTransportElement members.

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | ConnectionPooling | Enables and disables the connection pooling on the client side.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | IdleTimeout | Gets and set an amount of time server will wait before terminating idle connections.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
Top

See Also

Reference

SoapTcpDuplexTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Address Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Address Property

Gets or sets the address of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Socks Properties")>
<ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Address As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As String

instance.Address = value

value = instance.Address
C#
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Address {get; set;}
Delphi
public read-write property Address: String;
JScript
CategoryAttribute("Socks Properties")
ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Address : String
Managed Extensions for C++
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Address();
public: __property void set_Address(
   string* value
);
C++/CLI
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authentication Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Authentication Property

Gets or sets the authentication scheme to use to connect through the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
Public Property Authentication As SocksAuthentication
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As SocksAuthentication

instance.Authentication = value

value = instance.Authentication
C#
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
public SocksAuthentication Authentication {get; set;}
Delphi
public read-write property Authentication: SocksAuthentication;
JScript
ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
public function get,set Authentication : SocksAuthentication
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
public: __property SocksAuthentication get_Authentication();
public: __property void set_Authentication(
   SocksAuthentication value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
public:
property SocksAuthentication Authentication {
   SocksAuthentication get();
   void set (    SocksAuthentication value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConnectionPooling Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ConnectionPooling Property

Enables and disables the connection pooling on the client side.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ConnectionPooling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Boolean

instance.ConnectionPooling = value

value = instance.ConnectionPooling
C#
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ConnectionPooling {get; set;}
Delphi
public read-write property ConnectionPooling: Boolean;
JScript
ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ConnectionPooling : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ConnectionPooling();
public: __property void set_ConnectionPooling(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ConnectionPooling {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IdleTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : IdleTimeout Property

Gets and set an amount of time server will wait before terminating idle connections.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property IdleTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As TimeSpan

instance.IdleTimeout = value

value = instance.IdleTimeout
C#
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan IdleTimeout {get; set;}
Delphi
public read-write property IdleTimeout: TimeSpan;
JScript
ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set IdleTimeout : TimeSpan
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_IdleTimeout();
public: __property void set_IdleTimeout(
   TimeSpan value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan IdleTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ManualAddressing Property

Gets or sets a Boolean value that specifies whether the user takes control of message addressing.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false.

Remarks

This property is usually used in router scenarios, where the application determines which one of several destinations to send a message to.

If this property is set to true, the channel assumes the message has already been addressed and does not add any additional information to it.

If this property is set to false, the channel adds SOAP addressing information to the message.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : MaxBufferPoolSize Property

Gets or sets the maximum size of the buffer pool.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size of the buffer pool. The default is 524,288 bytes (512 * 1024).

Remarks

Many parts of WCF use buffers. Creating and destroying buffers each time they are used is expensive, and garbage collection for buffers is also expensive. With buffer pools, you can take a buffer from the pool, use it, and return it to the pool once you are done. Thus the overhead in creating and destroying buffers is avoided.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false. The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : MaxReceivedMessageSize Property

Gets or sets the maximum allowed message size that can be received.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum allowed message size that can be received.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Password Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Password Property

Sets the password to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Socks Properties")>
<ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As String

instance.Password = value

value = instance.Password
C#
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Password {get; set;}
Delphi
public read-write property Password: String;
JScript
CategoryAttribute("Socks Properties")
ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Password : String
Managed Extensions for C++
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Port Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Port Property

Gets or sets the TCP port of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
Public Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Integer

instance.Port = value

value = instance.Port
C#
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public int Port {get; set;}
Delphi
public read-write property Port: Integer;
JScript
ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
public function get,set Port : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public: __property int get_Port();
public: __property void set_Port(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public:
property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Socks Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Socks Property

Represents the settings of the SOCKS proxy to use to connect to the service endpoint.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Protected Property Socks As SocksSettingsElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As SocksSettingsElement

instance.Socks = value

value = instance.Socks
C#
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected SocksSettingsElement Socks {get; set;}
Delphi
protected read-write property Socks: SocksSettingsElement;
JScript
ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
protected function get,set Socks : SocksSettingsElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected: __property SocksSettingsElement* get_Socks();
protected: __property void set_Socks(
   SocksSettingsElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected:
property SocksSettingsElement^ Socks {
   SocksSettingsElement^ get();
   void set (    SocksSettingsElement^ value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

A valid TransferModeX value that specifies whether messages are buffered or streamed or a request or response. The Noemax.WCFX.TransferModeX that indicates whether messages are sent buffered or streamed.

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Username Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Username Property

Gets or sets the username to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As String

instance.Username = value

value = instance.Username
C#
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public string Username {get; set;}
Delphi
public read-write property Username: String;
JScript
ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
public function get,set Username : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Version Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Version Property

Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
Public Property Version As SocksVersion
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As SocksVersion

instance.Version = value

value = instance.Version
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public SocksVersion Version {get; set;}
Delphi
public read-write property Version: SocksVersion;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
public function get,set Version : SocksVersion
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public: __property SocksVersion get_Version();
public: __property void set_Version(
   SocksVersion value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public:
property SocksVersion Version {
   SocksVersion get();
   void set (    SocksVersion value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpTransportElement Class

Represents a WCF configuration element which specifies the SoapTcpTransportBindingElement will be used and exposes its settings through configuration.

Object Model

SoapTcpTransportElement Class

Syntax

Visual Basic (Declaration)
Public Class SoapTcpTransportElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
C#
public class SoapTcpTransportElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class SoapTcpTransportElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class SoapTcpTransportElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class SoapTcpTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class SoapTcpTransportElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.SoapTcpTransportElement

See Also

Reference

SoapTcpTransportElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpTransportElement Class

The following tables list the members exposed by SoapTcpTransportElement.

Public Constructors

 | Name | Description
public Constructor | SoapTcpTransportElement Constructor |
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | ConnectionPooling | Enables and disables the connection pooling on the client side.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | IdleTimeout | Gets and sets an amount of time server will wait before terminating idle connections.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SoapTcpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SoapTcpTransportElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : SoapTcpTransportElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SoapTcpTransportElement()
C#
public SoapTcpTransportElement()
Delphi
public SoapTcpTransportElement();
JScript
public function SoapTcpTransportElement();
Managed Extensions for C++
public: SoapTcpTransportElement();
C++/CLI
public:
SoapTcpTransportElement();

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpTransportElement Class

For a list of all members of this type, see SoapTcpTransportElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SoapTcpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : CreateBindingElement Method

Initializes a new instance of FiMessageEncodingBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SoapTcpTransportElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SoapTcpTransportElement Class

For a list of all members of this type, see SoapTcpTransportElement members.

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the SOCKS proxy.
public Property | Authentication | Gets or sets the authentication scheme to use to connect through the SOCKS proxy.
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | ConnectionPooling | Enables and disables the connection pooling on the client side.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | IdleTimeout | Gets and sets an amount of time server will wait before terminating idle connections.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | ManualAddressing | Gets or sets a Boolean value that specifies whether the user takes control of message addressing.
public Property | MaxBufferPoolSize | Gets or sets the maximum size of the buffer pool.
public Property | MaxBufferSize | Gets or sets the maximum size for a buffer that receives messages from the channel.
public Property | MaxReceivedMessageSize | Gets or sets the maximum allowed message size that can be received.
public Property | Password | Sets the password to authenticate with the SOCKS proxy.
public Property | Port | Gets or sets the TCP port of the SOCKS proxy.
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed.
public Property | Username | Gets or sets the username to authenticate with the SOCKS proxy.
public Property | Version | Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Socks | Represents the settings of the SOCKS proxy to use to connect to the service endpoint.
Top

See Also

Reference

SoapTcpTransportElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Address Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Address Property

Gets or sets the address of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Socks Properties")>
<ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Address As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As String

instance.Address = value

value = instance.Address
C#
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Address {get; set;}
Delphi
public read-write property Address: String;
JScript
CategoryAttribute("Socks Properties")
ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Address : String
Managed Extensions for C++
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Address();
public: __property void set_Address(
   string* value
);
C++/CLI
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authentication Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Authentication Property

Gets or sets the authentication scheme to use to connect through the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<CategoryAttribute("Socks Properties")>
<ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Authentication As SocksAuthentication
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As SocksAuthentication

instance.Authentication = value

value = instance.Authentication
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SocksAuthentication Authentication {get; set;}
Delphi
public read-write property Authentication: SocksAuthentication;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
CategoryAttribute("Socks Properties")
ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Authentication : SocksAuthentication
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SocksAuthentication get_Authentication();
public: __property void set_Authentication(
   SocksAuthentication value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SocksAuthentication Authentication {
   SocksAuthentication get();
   void set (    SocksAuthentication value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConnectionPooling Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ConnectionPooling Property

Enables and disables the connection pooling on the client side.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ConnectionPooling As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Boolean

instance.ConnectionPooling = value

value = instance.ConnectionPooling
C#
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ConnectionPooling {get; set;}
Delphi
public read-write property ConnectionPooling: Boolean;
JScript
ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ConnectionPooling : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ConnectionPooling();
public: __property void set_ConnectionPooling(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="connectionPooling",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ConnectionPooling {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IdleTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : IdleTimeout Property

Gets and sets an amount of time server will wait before terminating idle connections.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property IdleTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As TimeSpan

instance.IdleTimeout = value

value = instance.IdleTimeout
C#
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan IdleTimeout {get; set;}
Delphi
public read-write property IdleTimeout: TimeSpan;
JScript
ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set IdleTimeout : TimeSpan
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_IdleTimeout();
public: __property void set_IdleTimeout(
   TimeSpan value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="idleTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan IdleTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ManualAddressing Property

Gets or sets a Boolean value that specifies whether the user takes control of message addressing.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false.

Remarks

This property is usually used in router scenarios, where the application determines which one of several destinations to send a message to.

If this property is set to true, the channel assumes the message has already been addressed and does not add any additional information to it.

If this property is set to false, the channel adds SOAP addressing information to the message.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : MaxBufferPoolSize Property

Gets or sets the maximum size of the buffer pool.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum size of the buffer pool. The default is 524,288 bytes (512 * 1024).

Remarks

Many parts of WCF use buffers. Creating and destroying buffers each time they are used is expensive, and garbage collection for buffers is also expensive. With buffer pools, you can take a buffer from the pool, use it, and return it to the pool once you are done. Thus the overhead in creating and destroying buffers is avoided.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : MaxBufferSize Property

Gets or sets the maximum size for a buffer that receives messages from the channel.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

Property Value

true if the user can address every message individually; false if the default WCF addressing mechanism automatically creates addresses for all messages. The default is false. The maximum size, in bytes, of a buffer that stores messages while they are processed for an endpoint configured with this binding. The default value is 65,536 bytes.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : MaxReceivedMessageSize Property

Gets or sets the maximum allowed message size that can be received.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

Property Value

The maximum allowed message size that can be received.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Password Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Password Property

Sets the password to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Socks Properties")>
<ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As String

instance.Password = value

value = instance.Password
C#
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Password {get; set;}
Delphi
public read-write property Password: String;
JScript
CategoryAttribute("Socks Properties")
ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Password : String
Managed Extensions for C++
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
[CategoryAttribute("Socks Properties")]
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Port Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Port Property

Gets or sets the TCP port of the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
Public Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Integer

instance.Port = value

value = instance.Port
C#
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public int Port {get; set;}
Delphi
public read-write property Port: Integer;
JScript
ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
public function get,set Port : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public: __property int get_Port();
public: __property void set_Port(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public:
property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Socks Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Socks Property

Represents the settings of the SOCKS proxy to use to connect to the service endpoint.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Protected Property Socks As SocksSettingsElement
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As SocksSettingsElement

instance.Socks = value

value = instance.Socks
C#
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected SocksSettingsElement Socks {get; set;}
Delphi
protected read-write property Socks: SocksSettingsElement;
JScript
ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
protected function get,set Socks : SocksSettingsElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected: __property SocksSettingsElement* get_Socks();
protected: __property void set_Socks(
   SocksSettingsElement* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="socks",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
protected:
property SocksSettingsElement^ Socks {
   SocksSettingsElement^ get();
   void set (    SocksSettingsElement^ value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : TransferMode Property

Gets or sets a value that indicates whether messages are sent buffered or streamed.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.TransferModeConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

Property Value

A valid TransferMode value that specifies whether messages are buffered or streamed or a request or response. The System.ServiceModel.Channels.TransferMode that indicates whether messages are sent buffered or streamed.

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Username Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Username Property

Gets or sets the username to authenticate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<CategoryAttribute("Socks Properties")>
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As String

instance.Username = value

value = instance.Username
C#
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public string Username {get; set;}
Delphi
public read-write property Username: String;
JScript
ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
CategoryAttribute("Socks Properties")
public function get,set Username : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[CategoryAttribute("Socks Properties")]
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Version Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Version Property

Gets or sets the version of the protocol to use to communicate with the SOCKS proxy.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Socks Properties")>
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Version As SocksVersion
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As SocksVersion

instance.Version = value

value = instance.Version
C#
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SocksVersion Version {get; set;}
Delphi
public read-write property Version: SocksVersion;
JScript
CategoryAttribute("Socks Properties")
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Version : SocksVersion
Managed Extensions for C++
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SocksVersion get_Version();
public: __property void set_Version(
   SocksVersion value
);
C++/CLI
[CategoryAttribute("Socks Properties")]
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SocksVersion Version {
   SocksVersion get();
   void set (    SocksVersion value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettingsElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SocksSettingsElement Class

Represents the SOCKS proxy settings.

Object Model

SocksSettingsElement Class

Syntax

Visual Basic (Declaration)
Public Class SocksSettingsElement
   Inherits System.Configuration.ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
C#
public class SocksSettingsElement : System.Configuration.ConfigurationElement
Delphi
public class SocksSettingsElement = class(System.Configuration.ConfigurationElement)
JScript
public class SocksSettingsElement extends System.Configuration.ConfigurationElement
Managed Extensions for C++
public __gc class SocksSettingsElement : public System.Configuration.ConfigurationElement
C++/CLI
public ref class SocksSettingsElement : public System.Configuration.ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.SocksSettingsElement

See Also

Reference

SocksSettingsElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
SocksSettingsElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : SocksSettingsElement Class

The following tables list the members exposed by SocksSettingsElement.

Public Constructors

 | Name | Description
public Constructor | SocksSettingsElement Constructor | Initializes a new instance of SocksSettingsElement.
Top

Public Properties

 | Name | Description
public Property | Address | The address of the SOCKS server.
public Property | Authentication | The method of SOCKS authentication to use.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | Password | The password to provide to the SOCKS server for authentication.
public Property | Port | The port of the SOCKS server.
public Property | Username | The username to provide to the SOCKS server for authentication.
public Property | Version | The version of SOCKS protocol to use.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Configures the SocksSettings with properties of this object.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SocksSettingsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SocksSettingsElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : SocksSettingsElement Constructor

Initializes a new instance of SocksSettingsElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SocksSettingsElement()
C#
public SocksSettingsElement()
Delphi
public SocksSettingsElement();
JScript
public function SocksSettingsElement();
Managed Extensions for C++
public: SocksSettingsElement();
C++/CLI
public:
SocksSettingsElement();

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SocksSettingsElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SocksSettingsElement Class

For a list of all members of this type, see SocksSettingsElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Configures the SocksSettings with properties of this object.
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SocksSettingsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : ApplyConfiguration Method

target
SocksSettings to configure.
Configures the SocksSettings with properties of this object.

Syntax

Visual Basic (Declaration)
Public Sub ApplyConfiguration( _
   ByVal target As SocksSettings _
)
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim target As SocksSettings

instance.ApplyConfiguration(target)
C#
public void ApplyConfiguration(
   SocksSettings target
)
Delphi
public procedure ApplyConfiguration(
    target: SocksSettings
);
JScript
public function ApplyConfiguration(
   target : SocksSettings
);
Managed Extensions for C++
public: void ApplyConfiguration(
   SocksSettings* target
)
C++/CLI
public:
void ApplyConfiguration(
   SocksSettings^ target
)

Parameters

target
SocksSettings to configure.

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SocksSettingsElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SocksSettingsElement Class

For a list of all members of this type, see SocksSettingsElement members.

Public Properties

 | Name | Description
public Property | Address | The address of the SOCKS server.
public Property | Authentication | The method of SOCKS authentication to use.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | Password | The password to provide to the SOCKS server for authentication.
public Property | Port | The port of the SOCKS server.
public Property | Username | The username to provide to the SOCKS server for authentication.
public Property | Version | The version of SOCKS protocol to use.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SocksSettingsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Address Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Address Property

The address of the SOCKS server.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Address As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As String

instance.Address = value

value = instance.Address
C#
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Address {get; set;}
Delphi
public read-write property Address: String;
JScript
ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Address : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Address();
public: __property void set_Address(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="address",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Address {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authentication Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Authentication Property

The method of SOCKS authentication to use.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Authentication As SocksAuthentication
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As SocksAuthentication

instance.Authentication = value

value = instance.Authentication
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SocksAuthentication Authentication {get; set;}
Delphi
public read-write property Authentication: SocksAuthentication;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Authentication : SocksAuthentication
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SocksAuthentication get_Authentication();
public: __property void set_Authentication(
   SocksAuthentication value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksAuthenticationConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="authentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SocksAuthentication Authentication {
   SocksAuthentication get();
   void set (    SocksAuthentication value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Password Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Password Property

The password to provide to the SOCKS server for authentication.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As String

instance.Password = value

value = instance.Password
C#
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Password {get; set;}
Delphi
public read-write property Password: String;
JScript
ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Password : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="password",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Port Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Port Property

The port of the SOCKS server.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As Integer

instance.Port = value

value = instance.Port
C#
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public int Port {get; set;}
Delphi
public read-write property Port: Integer;
JScript
ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Port : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property int get_Port();
public: __property void set_Port(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="port",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Username Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Username Property

The username to provide to the SOCKS server for authentication.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As String

instance.Username = value

value = instance.Username
C#
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Username {get; set;}
Delphi
public read-write property Username: String;
JScript
ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Username : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="username",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Version Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : Version Property

The version of SOCKS protocol to use.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")>
<ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Version As SocksVersion
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As SocksVersion

instance.Version = value

value = instance.Version
C#
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public SocksVersion Version {get; set;}
Delphi
public read-write property Version: SocksVersion;
JScript
TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")
ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Version : SocksVersion
Managed Extensions for C++
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property SocksVersion get_Version();
public: __property void set_Version(
   SocksVersion value
);
C++/CLI
[TypeConverterAttribute("Noemax.WCFX.Configuration.SocksVersionConverter, Noemax.WCFX, Version=4.0.14.0, Culture=neutral, PublicKeyToken=4c0defa954f97f18")]
[ConfigurationPropertyAttribute(Name="version",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property SocksVersion Version {
   SocksVersion get();
   void set (    SocksVersion value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : StreamEnhancerElement Class

Represents a WCF configuration element which specifies the StreamEnhancerBindingElement will be used and exposes its settings through configuration.

Object Model

StreamEnhancerElement Class

Syntax

Visual Basic (Declaration)
Public Class StreamEnhancerElement
   Inherits System.ServiceModel.Configuration.BindingElementExtensionElement
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
C#
public class StreamEnhancerElement : System.ServiceModel.Configuration.BindingElementExtensionElement
Delphi
public class StreamEnhancerElement = class(System.ServiceModel.Configuration.BindingElementExtensionElement)
JScript
public class StreamEnhancerElement extends System.ServiceModel.Configuration.BindingElementExtensionElement
Managed Extensions for C++
public __gc class StreamEnhancerElement : public System.ServiceModel.Configuration.BindingElementExtensionElement
C++/CLI
public ref class StreamEnhancerElement : public System.ServiceModel.Configuration.BindingElementExtensionElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Noemax.WCFX.Configuration.StreamEnhancerElement

See Also

Reference

StreamEnhancerElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
StreamEnhancerElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : StreamEnhancerElement Class

The following tables list the members exposed by StreamEnhancerElement.

Public Constructors

 | Name | Description
public Constructor | StreamEnhancerElement Constructor |
Top

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

StreamEnhancerElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StreamEnhancerElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : StreamEnhancerElement Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New StreamEnhancerElement()
C#
public StreamEnhancerElement()
Delphi
public StreamEnhancerElement();
JScript
public function StreamEnhancerElement();
Managed Extensions for C++
public: StreamEnhancerElement();
C++/CLI
public:
StreamEnhancerElement();

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
StreamEnhancerElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : StreamEnhancerElement Class

For a list of all members of this type, see StreamEnhancerElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | Overridden. Applies the content of a specified binding element to this binding configuration section.
public Method | CopyFrom | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | CreateBindingElement | Overridden. Initializes a new instance of CompressionBindingElement represented by this configuration element.
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | IsModified | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SerializeElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

StreamEnhancerElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : ApplyConfiguration Method

bindingElement

A binding element.

Applies the content of a specified binding element to this binding configuration section.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public override void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); override;
JScript
public override function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: void ApplyConfiguration(
   BindingElement* bindingElement
) override
C++/CLI
public:
void ApplyConfiguration(
   BindingElement^ bindingElement
) override

Parameters

bindingElement

A binding element.

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members
Base Implementation in ApplyConfiguration


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : CreateBindingElement Method

Initializes a new instance of CompressionBindingElement represented by this configuration element.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateBindingElement() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As BindingElement

value = instance.CreateBindingElement()
C#
protected override BindingElement CreateBindingElement()
Delphi
protected function CreateBindingElement(): BindingElement; override;
JScript
protected override function CreateBindingElement() : BindingElement;
Managed Extensions for C++
protected: BindingElement* CreateBindingElement(); override
C++/CLI
protected:
BindingElement^ CreateBindingElement(); override

Return Value

A CompressionBindingElement instance.

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members
Base Implementation in CreateBindingElement


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
StreamEnhancerElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : StreamEnhancerElement Class

For a list of all members of this type, see StreamEnhancerElement members.

Public Properties

 | Name | Description
public Property | BindingElementType | Overridden. Gets the type of this binding element.
public Property | ConfigurationElementName | (Inherited from System.ServiceModel.Configuration.ServiceModelExtensionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

StreamEnhancerElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingElementType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : BindingElementType Property

Gets the type of this binding element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BindingElementType As Type
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As Type

value = instance.BindingElementType
C#
public override Type BindingElementType {get;}
Delphi
public read-only property BindingElementType: Type; override;
JScript
public override function get BindingElementType : Type
Managed Extensions for C++
public: __property Type* get_BindingElementType() override;
C++/CLI
public:
property Type^ BindingElementType {
   Type^ get() override;
}

Property Value

The type of BindingElement represented by this configuration element.

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members
Base Implementation in BindingElementType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfileDetailsElement Class
Members See Also Send Feedback
Noemax.WCFX.Configuration Namespace : WriterProfileDetailsElement Class

Provides customization of XmlFastInfosetWriterProfile through WCF configuration.

Object Model

WriterProfileDetailsElement Class

Syntax

Visual Basic (Declaration)
Public Class WriterProfileDetailsElement
   Inherits System.Configuration.ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
C#
public class WriterProfileDetailsElement : System.Configuration.ConfigurationElement
Delphi
public class WriterProfileDetailsElement = class(System.Configuration.ConfigurationElement)
JScript
public class WriterProfileDetailsElement extends System.Configuration.ConfigurationElement
Managed Extensions for C++
public __gc class WriterProfileDetailsElement : public System.Configuration.ConfigurationElement
C++/CLI
public ref class WriterProfileDetailsElement : public System.Configuration.ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.WriterProfileDetailsElement

See Also

Reference

WriterProfileDetailsElement Members
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
WriterProfileDetailsElement Class Members
See Also Properties Methods Send Feedback
Noemax.WCFX.Configuration Namespace : WriterProfileDetailsElement Class

The following tables list the members exposed by WriterProfileDetailsElement.

Public Constructors

 | Name | Description
public Constructor | WriterProfileDetailsElement Constructor | Inititalizes new instance of WriterProfileDetailsElement.
Top

Public Properties

 | Name | Description
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

Public Methods

 | Name | Description
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

WriterProfileDetailsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriterProfileDetailsElement Constructor
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : WriterProfileDetailsElement Constructor

Inititalizes new instance of WriterProfileDetailsElement.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WriterProfileDetailsElement()
C#
public WriterProfileDetailsElement()
Delphi
public WriterProfileDetailsElement();
JScript
public function WriterProfileDetailsElement();
Managed Extensions for C++
public: WriterProfileDetailsElement();
C++/CLI
public:
WriterProfileDetailsElement();

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
WriterProfileDetailsElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : WriterProfileDetailsElement Class

For a list of all members of this type, see WriterProfileDetailsElement members.

Public Properties

 | Name | Description
public Property | BooleanFormat | Gets and sets the format used to serialize boolean values.
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | DateTimeFormat | Gets and sets the format used to serialize DateTime values.
public Property | DecimalFormat | Gets and sets the format used to serialize DateTime values.
public Property | DoubleFormat | Gets and sets the format used to serialize double precision floating point values.
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | FloatFormat | Gets and sets the format used to serialize floating point values.
public Property | GuidFormat | Gets and sets the format used to serialize guild values.
public Property | IntFormat | Gets and sets the format used to encode integer values.
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | LongFormat | Gets and sets the format used to encode long integer values.
public Property | ShortFormat | Gets and sets the format used to serialize short integer values.
public Property | TimeSpanFormat | Gets and sets the format used to encode TimeSpan values.
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

WriterProfileDetailsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BooleanFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : BooleanFormat Property

Gets and sets the format used to serialize boolean values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="booleanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property BooleanFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.BooleanFormat = value

value = instance.BooleanFormat
C#
[ConfigurationPropertyAttribute(Name="booleanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting BooleanFormat {get; set;}
Delphi
public read-write property BooleanFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="booleanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set BooleanFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="booleanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_BooleanFormat();
public: __property void set_BooleanFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="booleanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting BooleanFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DateTimeFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : DateTimeFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="dateTimeFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property DateTimeFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.DateTimeFormat = value

value = instance.DateTimeFormat
C#
[ConfigurationPropertyAttribute(Name="dateTimeFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting DateTimeFormat {get; set;}
Delphi
public read-write property DateTimeFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="dateTimeFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set DateTimeFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="dateTimeFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_DateTimeFormat();
public: __property void set_DateTimeFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="dateTimeFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting DateTimeFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DecimalFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : DecimalFormat Property

Gets and sets the format used to serialize DateTime values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="decimalFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property DecimalFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.DecimalFormat = value

value = instance.DecimalFormat
C#
[ConfigurationPropertyAttribute(Name="decimalFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting DecimalFormat {get; set;}
Delphi
public read-write property DecimalFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="decimalFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set DecimalFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="decimalFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_DecimalFormat();
public: __property void set_DecimalFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="decimalFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting DecimalFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DoubleFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : DoubleFormat Property

Gets and sets the format used to serialize double precision floating point values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="doubleFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property DoubleFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.DoubleFormat = value

value = instance.DoubleFormat
C#
[ConfigurationPropertyAttribute(Name="doubleFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting DoubleFormat {get; set;}
Delphi
public read-write property DoubleFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="doubleFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set DoubleFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="doubleFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_DoubleFormat();
public: __property void set_DoubleFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="doubleFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting DoubleFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
FloatFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : FloatFormat Property

Gets and sets the format used to serialize floating point values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="floatFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property FloatFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.FloatFormat = value

value = instance.FloatFormat
C#
[ConfigurationPropertyAttribute(Name="floatFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting FloatFormat {get; set;}
Delphi
public read-write property FloatFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="floatFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set FloatFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="floatFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_FloatFormat();
public: __property void set_FloatFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="floatFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting FloatFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GuidFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : GuidFormat Property

Gets and sets the format used to serialize guild values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="guidFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property GuidFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.GuidFormat = value

value = instance.GuidFormat
C#
[ConfigurationPropertyAttribute(Name="guidFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting GuidFormat {get; set;}
Delphi
public read-write property GuidFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="guidFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set GuidFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="guidFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_GuidFormat();
public: __property void set_GuidFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="guidFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting GuidFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IntFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : IntFormat Property

Gets and sets the format used to encode integer values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="intFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property IntFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.IntFormat = value

value = instance.IntFormat
C#
[ConfigurationPropertyAttribute(Name="intFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting IntFormat {get; set;}
Delphi
public read-write property IntFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="intFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set IntFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="intFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_IntFormat();
public: __property void set_IntFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="intFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting IntFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LongFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LongFormat Property

Gets and sets the format used to encode long integer values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="longFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property LongFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.LongFormat = value

value = instance.LongFormat
C#
[ConfigurationPropertyAttribute(Name="longFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting LongFormat {get; set;}
Delphi
public read-write property LongFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="longFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set LongFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="longFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_LongFormat();
public: __property void set_LongFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="longFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting LongFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ShortFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : ShortFormat Property

Gets and sets the format used to serialize short integer values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="shortFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ShortFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.ShortFormat = value

value = instance.ShortFormat
C#
[ConfigurationPropertyAttribute(Name="shortFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting ShortFormat {get; set;}
Delphi
public read-write property ShortFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="shortFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ShortFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="shortFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_ShortFormat();
public: __property void set_ShortFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="shortFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting ShortFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Binary
- Literal
- LiteralNoIndex
- RestrictedAlphabet
- RestrictedAlphabetNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TimeSpanFormat Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : TimeSpanFormat Property

Gets and sets the format used to encode TimeSpan values.

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="timeSpanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TimeSpanFormat As XmlFastInfosetFormatSetting
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As XmlFastInfosetFormatSetting

instance.TimeSpanFormat = value

value = instance.TimeSpanFormat
C#
[ConfigurationPropertyAttribute(Name="timeSpanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public XmlFastInfosetFormatSetting TimeSpanFormat {get; set;}
Delphi
public read-write property TimeSpanFormat: XmlFastInfosetFormatSetting;
JScript
ConfigurationPropertyAttribute(Name="timeSpanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TimeSpanFormat : XmlFastInfosetFormatSetting
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="timeSpanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property XmlFastInfosetFormatSetting get_TimeSpanFormat();
public: __property void set_TimeSpanFormat(
   XmlFastInfosetFormatSetting value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="timeSpanFormat",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property XmlFastInfosetFormatSetting TimeSpanFormat {
   XmlFastInfosetFormatSetting get();
   void set (    XmlFastInfosetFormatSetting value);
}

Remarks

Values of this data type can be encoded using any of the following representations:

- Literal
- LiteralNoIndex

When values are indexed, they are added to the Fast Infoset vocabulary in order to reduce redundancy and increase compactness. If there are few repeating values of the same data type then it might be preferable not to use indexing.

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetFormatSetting Enumeration
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : XmlFastInfosetFormatSetting Enumeration

Represents the XmlFastInfosetFormat enumeration in WCF configuration."

Syntax

Visual Basic (Declaration)
Public Enum XmlFastInfosetFormatSetting
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetFormatSetting
C#
public enum XmlFastInfosetFormatSetting : System.Enum
Delphi
public enum XmlFastInfosetFormatSetting = class(System.Enum)
JScript
public enum XmlFastInfosetFormatSetting extends System.Enum
Managed Extensions for C++
__value public enum XmlFastInfosetFormatSetting : public System.Enum
C++/CLI
public enum class XmlFastInfosetFormatSetting : public System.Enum

Members

Member | Description
Binary | Encodes values in a binary format. Provides higher processing performance than Literal and Restricted Alphabet.
DotNet | This format is obsolete.
Literal | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
LiteralNoIndex | Encodes values in a UTF-8 text string format. Provides maximum interoperability with other Fast Infoset implementations.
NotSet | Reserved for cases when detailed profile configuration is omitted.
RestrictedAlphabet | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.
RestrictedAlphabetNoIndex | Encodes values in a 4 bits per character format. Provides higher compactness than Literal.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Configuration.XmlFastInfosetFormatSetting

See Also

Reference

Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetWriterProfile Enumeration
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : XmlFastInfosetWriterProfile Enumeration

Represents the XmlFastInfosetWriterProfile enumeration in WCF configuration."

Syntax

Visual Basic (Declaration)
Public Enum XmlFastInfosetWriterProfile
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriterProfile
C#
public enum XmlFastInfosetWriterProfile : System.Enum
Delphi
public enum XmlFastInfosetWriterProfile = class(System.Enum)
JScript
public enum XmlFastInfosetWriterProfile extends System.Enum
Managed Extensions for C++
__value public enum XmlFastInfosetWriterProfile : public System.Enum
C++/CLI
public enum class XmlFastInfosetWriterProfile : public System.Enum

Members

Member | Description
Basic | The Basic profile usually provides the highest processing performance. It is set to use the Binary representation whenever available.
Compact | The Compact profile usually provides the highest compactness.It is set to use the Restricted Alphabet representation whenever available.
DotNet | This profile is obsolete. If selected, the Basic profile will be used instead.
Literal | Encodes values in a UTF-8 text string format. Provides interoperability with Fast Infoset implementations that only support the Literal representation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.WCFX.Configuration.XmlFastInfosetWriterProfile

See Also

Reference

Noemax.WCFX.Configuration Namespace


%%ItemTitle%%

Noemax.Xml Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | XmlFastInfosetDictionaryReader | The XmlFastInfosetDictionaryReader provides Fast Infoset data deserialization by delegating calls to the XmlFastInfosetReader.
Class | XmlFastInfosetDictionaryWriter | The XmlFastInfosetDictionaryWriter provides Fast Infoset data serialization by delegating calls to the XmlFastInfosetWriter.

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Class
Members See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryReader Class

The XmlFastInfosetDictionaryReader provides Fast Infoset data deserialization by delegating calls to the XmlFastInfosetReader.

Object Model

XmlFastInfosetDictionaryReader Class

Syntax

Visual Basic (Declaration)
Public Class XmlFastInfosetDictionaryReader
   Inherits System.Xml.XmlDictionaryReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
C#
public class XmlFastInfosetDictionaryReader : System.Xml.XmlDictionaryReader
Delphi
public class XmlFastInfosetDictionaryReader = class(System.Xml.XmlDictionaryReader)
JScript
public class XmlFastInfosetDictionaryReader extends System.Xml.XmlDictionaryReader
Managed Extensions for C++
public __gc class XmlFastInfosetDictionaryReader : public System.Xml.XmlDictionaryReader
C++/CLI
public ref class XmlFastInfosetDictionaryReader : public System.Xml.XmlDictionaryReader

Inheritance Hierarchy

System.Object
System.Xml.XmlReader
System.Xml.XmlDictionaryReader
Noemax.Xml.XmlFastInfosetDictionaryReader
Noemax.WCFX.Channels.FiEncoderMessageReader

See Also

Reference

XmlFastInfosetDictionaryReader Members
Noemax.Xml Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Class Members
See Also Properties Methods Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryReader Class

The following tables list the members exposed by XmlFastInfosetDictionaryReader.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetDictionaryReader Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanCanonicalize | (Inherited from System.Xml.XmlDictionaryReader)
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | (Inherited from System.Xml.XmlReader)
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | (Inherited from System.Xml.XmlReader)
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overloaded. (Inherited from System.Xml.XmlReader)
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | Name | (Inherited from System.Xml.XmlReader)
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | Quotas | Overridden. Gets the quota values that apply to the current instance of this class.
public Property | QuoteChar | (Inherited from System.Xml.XmlReader)
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Initializes a new instance of XmlFastInfosetDictionaryReader.
public Method | EndCanonicalization | (Inherited from System.Xml.XmlDictionaryReader)
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | GetNonAtomizedNames | (Inherited from System.Xml.XmlDictionaryReader)
public Method | IndexOfLocalName | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | Init | Overloaded. Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to use specified stream.
public Method | IsLocalName | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsNamespaceUri | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsStartArray | (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | MoveToStartElement | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBooleanArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAs | Overridden. Converts a node's content to a specified type.
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsChars | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsDateTime | Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsGuid | Overridden. Converts a node's content to guid.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsQualifiedName | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsString | Overloaded. Overridden. Reads the text content at the current position as a string.
public Method | ReadContentAsTimeSpan | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsUniqueId | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDateTimeArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDecimalArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDoubleArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadElementContentAs | Overloaded. Overridden. Reads the element content as the requested type.
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads binary or Base64 encoded element content and returns decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads binary or BinHex encoded element content and returns decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Converts an element's content to a Boolean.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Converts an element's content to a DateTime.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a Decimal object.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a single-precision floating-point number.
public Method | ReadElementContentAsGuid | Overridden. Converts a node's content to guid.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsString | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a String object.
public Method | ReadElementContentAsTimeSpan | Overridden. Converts an element's content to a TimeSpan.
public Method | ReadElementContentAsUniqueId | Overridden. Converts an element's content to a unique identifier.
public Method | ReadElementString | Overloaded. Overridden. Reads a text-only element.
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadFullStartElement | Overloaded. Overridden. Checks whether the current node is an element and advances the reader to the next node.
public Method | ReadGuidArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadInt16Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInt32Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInt64Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadSingleArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is an element and advances the reader to the next node.
public Method | ReadString | Overloaded. Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadTimeSpanArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueAsBase64 | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Specifies an initial vocabulary to be used while reading the data.
public Method | Skip | (Inherited from System.Xml.XmlReader)
public Method | StartCanonicalization | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetArrayLength | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetBase64ContentLength | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetLocalNameAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetNamespaceUriAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetValueAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
protected Method | IsTextNode | (Inherited from System.Xml.XmlDictionaryReader)
Top

See Also

Reference

XmlFastInfosetDictionaryReader Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : XmlFastInfosetDictionaryReader Constructor

Overload List

Overload | Description
XmlFastInfosetDictionaryReader Constructor() | Initializes a new instance of XmlFastInfosetDictionaryReader.
XmlFastInfosetDictionaryReader Constructor(Stream) | Initializes a new instance of XmlFastInfosetDictionaryReader.
XmlFastInfosetDictionaryReader Constructor(Stream,XmlDictionaryReaderQuotas) | Initializes a new instance of XmlFastInfosetDictionaryReader.
XmlFastInfosetDictionaryReader Constructor(XmlDictionaryReaderQuotas) | Initializes a new instance of XmlFastInfosetDictionaryReader.
XmlFastInfosetDictionaryReader Constructor(Stream,XmlReaderSettings,XmlDictionaryReaderQuotas) | Initializes a new instance of XmlFastInfosetDictionaryReader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor()
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > XmlFastInfosetDictionaryReader Constructor : XmlFastInfosetDictionaryReader Constructor()

Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetDictionaryReader()
C#
public XmlFastInfosetDictionaryReader()
Delphi
public XmlFastInfosetDictionaryReader();
JScript
public function XmlFastInfosetDictionaryReader();
Managed Extensions for C++
public: XmlFastInfosetDictionaryReader();
C++/CLI
public:
XmlFastInfosetDictionaryReader();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor(Stream)
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > XmlFastInfosetDictionaryReader Constructor : XmlFastInfosetDictionaryReader Constructor(Stream)

stream
The Fast Infoset encoded XML stream to read from.
Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New XmlFastInfosetDictionaryReader(stream)
C#
public XmlFastInfosetDictionaryReader(
   Stream stream
)
Delphi
public XmlFastInfosetDictionaryReader(
    stream: Stream
);
JScript
public function XmlFastInfosetDictionaryReader(
   stream : Stream
);
Managed Extensions for C++
public: XmlFastInfosetDictionaryReader(
   Stream* stream
)
C++/CLI
public:
XmlFastInfosetDictionaryReader(
   Stream^ stream
)

Parameters

stream
The Fast Infoset encoded XML stream to read from.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor(Stream,XmlDictionaryReaderQuotas)
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > XmlFastInfosetDictionaryReader Constructor : XmlFastInfosetDictionaryReader Constructor(Stream,XmlDictionaryReaderQuotas)

stream
The Fast Infoset encoded XML stream to read from.
readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal readerQuotas As XmlDictionaryReaderQuotas _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim readerQuotas As XmlDictionaryReaderQuotas

Dim instance As New XmlFastInfosetDictionaryReader(stream, readerQuotas)
C#
public XmlFastInfosetDictionaryReader(
   Stream stream,
   XmlDictionaryReaderQuotas readerQuotas
)
Delphi
public XmlFastInfosetDictionaryReader(
    stream: Stream;
    readerQuotas: XmlDictionaryReaderQuotas
);
JScript
public function XmlFastInfosetDictionaryReader(
   stream : Stream,
   readerQuotas : XmlDictionaryReaderQuotas
);
Managed Extensions for C++
public: XmlFastInfosetDictionaryReader(
   Stream* stream,
   XmlDictionaryReaderQuotas* readerQuotas
)
C++/CLI
public:
XmlFastInfosetDictionaryReader(
   Stream^ stream,
   XmlDictionaryReaderQuotas^ readerQuotas
)

Parameters

stream
The Fast Infoset encoded XML stream to read from.
readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor(XmlDictionaryReaderQuotas)
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > XmlFastInfosetDictionaryReader Constructor : XmlFastInfosetDictionaryReader Constructor(XmlDictionaryReaderQuotas)

readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal readerQuotas As XmlDictionaryReaderQuotas _
)
Visual Basic (Usage) Copy Code
Dim readerQuotas As XmlDictionaryReaderQuotas

Dim instance As New XmlFastInfosetDictionaryReader(readerQuotas)
C#
public XmlFastInfosetDictionaryReader(
   XmlDictionaryReaderQuotas readerQuotas
)
Delphi
public XmlFastInfosetDictionaryReader(
    readerQuotas: XmlDictionaryReaderQuotas
);
JScript
public function XmlFastInfosetDictionaryReader(
   readerQuotas : XmlDictionaryReaderQuotas
);
Managed Extensions for C++
public: XmlFastInfosetDictionaryReader(
   XmlDictionaryReaderQuotas* readerQuotas
)
C++/CLI
public:
XmlFastInfosetDictionaryReader(
   XmlDictionaryReaderQuotas^ readerQuotas
)

Parameters

readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Constructor(Stream,XmlReaderSettings,XmlDictionaryReaderQuotas)
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > XmlFastInfosetDictionaryReader Constructor : XmlFastInfosetDictionaryReader Constructor(Stream,XmlReaderSettings,XmlDictionaryReaderQuotas)

stream
The Fast Infoset encoded XML stream to read from.
readerSettings
The XmlReaderSettings object used to configure the new XmlFastInfosetDictionaryReader instance.
readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal readerSettings As XmlReaderSettings, _
   ByVal readerQuotas As XmlDictionaryReaderQuotas _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim readerSettings As XmlReaderSettings
Dim readerQuotas As XmlDictionaryReaderQuotas

Dim instance As New XmlFastInfosetDictionaryReader(stream, readerSettings, readerQuotas)
C#
public XmlFastInfosetDictionaryReader(
   Stream stream,
   XmlReaderSettings readerSettings,
   XmlDictionaryReaderQuotas readerQuotas
)
Delphi
public XmlFastInfosetDictionaryReader(
    stream: Stream;
    readerSettings: XmlReaderSettings;
    readerQuotas: XmlDictionaryReaderQuotas
);
JScript
public function XmlFastInfosetDictionaryReader(
   stream : Stream,
   readerSettings : XmlReaderSettings,
   readerQuotas : XmlDictionaryReaderQuotas
);
Managed Extensions for C++
public: XmlFastInfosetDictionaryReader(
   Stream* stream,
   XmlReaderSettings* readerSettings,
   XmlDictionaryReaderQuotas* readerQuotas
)
C++/CLI
public:
XmlFastInfosetDictionaryReader(
   Stream^ stream,
   XmlReaderSettings^ readerSettings,
   XmlDictionaryReaderQuotas^ readerQuotas
)

Parameters

stream
The Fast Infoset encoded XML stream to read from.
readerSettings
The XmlReaderSettings object used to configure the new XmlFastInfosetDictionaryReader instance.
readerQuotas

The XmlDictionaryReaderQuotas object to apply to this reader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Class Methods
See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryReader Class

For a list of all members of this type, see XmlFastInfosetDictionaryReader members.

Public Methods

 | Name | Description
public Method | Clear | Clears the internal state of the reader.
public Method | Close | Overridden. Changes the ReadState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Initializes a new instance of XmlFastInfosetDictionaryReader.
public Method | EndCanonicalization | (Inherited from System.Xml.XmlDictionaryReader)
public Method | GetAttribute | Overloaded. Overridden. Gets the value of an attribute.
public Method | GetNonAtomizedNames | (Inherited from System.Xml.XmlDictionaryReader)
public Method | IndexOfLocalName | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | Init | Overloaded. Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to use specified stream.
public Method | IsLocalName | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsNamespaceUri | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsStartArray | (Inherited from System.Xml.XmlDictionaryReader)
public Method | IsStartElement | Overloaded. Overridden. Tests if the current content node is a start element.
public Method | LookupNamespace | Overridden. Resolves the namespace prefix in the current element's scope.
public Method | MoveToAttribute | Overloaded. Overridden. Moves to the specified attribute.
public Method | MoveToContent | Overridden. Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
public Method | MoveToElement | Overridden. Moves to the element that contains the current attribute node.
public Method | MoveToFirstAttribute | Overridden. Moves to the first attribute.
public Method | MoveToNextAttribute | Overridden. Moves to the next attribute.
public Method | MoveToStartElement | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | Read | Overridden. Reads the next node from the stream.
public Method | ReadArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadAttributeValue | Overridden. Reads the attribute value.
public Method | ReadBooleanArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAs | Overridden. Converts a node's content to a specified type.
public Method | ReadContentAsBase64 | Overloaded. Overridden. Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBinHex | Overloaded. Overridden. Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
public Method | ReadContentAsBoolean | Overridden. Reads the content at the current position as a boolean value.
public Method | ReadContentAsChars | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsDateTime | Overridden. Reads the node content at the current position as a DateTime value.
public Method | ReadContentAsDecimal | Overridden. Reads the text content at the current position as a decimal value.
public Method | ReadContentAsDouble | Overridden. Reads the content at the current position as a double-precision floating-point number.
public Method | ReadContentAsFloat | Overridden. Reads the content at the current position as a single-precision floating point number.
public Method | ReadContentAsGuid | Overridden. Converts a node's content to guid.
public Method | ReadContentAsInt | Overridden. Reads the text content at the current position as a 32-bit signed integer.
public Method | ReadContentAsLong | Overridden. Reads the text content at the current position as a 64-bit signed integer.
public Method | ReadContentAsObject | (Inherited from System.Xml.XmlReader)
public Method | ReadContentAsQualifiedName | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsString | Overloaded. Overridden. Reads the text content at the current position as a string.
public Method | ReadContentAsTimeSpan | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadContentAsUniqueId | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDateTimeArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDecimalArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadDoubleArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadElementContentAs | Overloaded. Overridden. Reads the element content as the requested type.
public Method | ReadElementContentAsBase64 | Overloaded. Overridden. Reads binary or Base64 encoded element content and returns decoded bytes.
public Method | ReadElementContentAsBinHex | Overloaded. Overridden. Reads binary or BinHex encoded element content and returns decoded bytes.
public Method | ReadElementContentAsBoolean | Overloaded. Overridden. Converts an element's content to a Boolean.
public Method | ReadElementContentAsDateTime | Overloaded. Overridden. Converts an element's content to a DateTime.
public Method | ReadElementContentAsDecimal | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a Decimal object.
public Method | ReadElementContentAsDouble | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a double-precision floating-point number.
public Method | ReadElementContentAsFloat | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a single-precision floating-point number.
public Method | ReadElementContentAsGuid | Overridden. Converts a node's content to guid.
public Method | ReadElementContentAsInt | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 32-bit signed integer.
public Method | ReadElementContentAsLong | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 64-bit signed integer.
public Method | ReadElementContentAsObject | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadElementContentAsString | Overloaded. Overridden. Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a String object.
public Method | ReadElementContentAsTimeSpan | Overridden. Converts an element's content to a TimeSpan.
public Method | ReadElementContentAsUniqueId | Overridden. Converts an element's content to a unique identifier.
public Method | ReadElementString | Overloaded. Overridden. Reads a text-only element.
public Method | ReadEndElement | Overridden. Checks that the current content node is an end tag and advances the reader to the next node.
public Method | ReadFullStartElement | Overloaded. Overridden. Checks whether the current node is an element and advances the reader to the next node.
public Method | ReadGuidArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInnerXml | (Inherited from System.Xml.XmlReader)
public Method | ReadInt16Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInt32Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadInt64Array | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadOuterXml | (Inherited from System.Xml.XmlReader)
public Method | ReadSingleArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadStartElement | Overloaded. Overridden. Checks that the current node is an element and advances the reader to the next node.
public Method | ReadString | Overloaded. Overridden. Reads the contents of the current node into a string.
public Method | ReadSubtree | (Inherited from System.Xml.XmlReader)
public Method | ReadTimeSpanArray | Overloaded. (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadToDescendant | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToFollowing | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadToNextSibling | Overloaded. (Inherited from System.Xml.XmlReader)
public Method | ReadValueAsBase64 | (Inherited from System.Xml.XmlDictionaryReader)
public Method | ReadValueChunk | (Inherited from System.Xml.XmlReader)
public Method | ResetState | Resets the ReadState to Initial.
public Method | ResolveEntity | Overridden. Throws a NotSupportedException.
public Method | SetVocabulary | Specifies an initial vocabulary to be used while reading the data.
public Method | Skip | (Inherited from System.Xml.XmlReader)
public Method | StartCanonicalization | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetArrayLength | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetBase64ContentLength | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetLocalNameAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetNamespaceUriAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
public Method | TryGetValueAsDictionaryString | (Inherited from System.Xml.XmlDictionaryReader)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlReader)
protected Method | IsTextNode | (Inherited from System.Xml.XmlDictionaryReader)
Top

See Also

Reference

XmlFastInfosetDictionaryReader Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Clear Method

Clears the internal state of the reader.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.Clear()
C#
public virtual void Clear()
Delphi
public procedure Clear(); virtual;
JScript
public function Clear();
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Remarks

Clears the internal state of the reader. After call to this method reader remains in uninitialized states. You must call Init method in order to reuse reader for reading another stream.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Close Method

Changes the ReadState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseInput is true, the underlying stream is going to be closed as well.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Create Method

Initializes a new instance of XmlFastInfosetDictionaryReader.

Overload List

Overload | Description
Create() | Initializes a new instance of XmlFastInfosetDictionaryReader.
Create(Stream) | Initializes a new instance of XmlFastInfosetDictionaryReader.
Create(Stream,XmlDictionaryReaderQuotas) | Initializes a new instance of XmlFastInfosetDictionaryReader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Create Method : Create() Method

Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create() As XmlFastInfosetDictionaryReader
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetDictionaryReader

value = XmlFastInfosetDictionaryReader.Create()
C#
public static XmlFastInfosetDictionaryReader Create()
Delphi
public function Create(): XmlFastInfosetDictionaryReader; static;
JScript
public static function Create() : XmlFastInfosetDictionaryReader;
Managed Extensions for C++
public: static XmlFastInfosetDictionaryReader* Create();
C++/CLI
public:
static XmlFastInfosetDictionaryReader^ Create();

Return Value

A new instance of XmlFastInfosetDictionaryReader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Create Method : Create(Stream) Method

input
The stream to read data from.
Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream _
) As XmlFastInfosetDictionaryReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim value As XmlFastInfosetDictionaryReader

value = XmlFastInfosetDictionaryReader.Create(input)
C#
public static XmlFastInfosetDictionaryReader Create(
   Stream input
)
Delphi
public function Create(
    input: Stream
): XmlFastInfosetDictionaryReader; static;
JScript
public static function Create(
   input : Stream
) : XmlFastInfosetDictionaryReader;
Managed Extensions for C++
public: static XmlFastInfosetDictionaryReader* Create(
   Stream* input
)
C++/CLI
public:
static XmlFastInfosetDictionaryReader^ Create(
   Stream^ input
)

Parameters

input
The stream to read data from.

Return Value

A new instance of XmlFastInfosetDictionaryReader.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream,XmlDictionaryReaderQuotas) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Create Method : Create(Stream,XmlDictionaryReaderQuotas) Method

input
The stream to read data from.
quotas
The XmlReaderSettings object used to configure the new XmlFastInfosetDictionaryReader instance. This value can be null.
Initializes a new instance of XmlFastInfosetDictionaryReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal input As Stream, _
   ByVal quotas As XmlDictionaryReaderQuotas _
) As XmlFastInfosetDictionaryReader
Visual Basic (Usage) Copy Code
Dim input As Stream
Dim quotas As XmlDictionaryReaderQuotas
Dim value As XmlFastInfosetDictionaryReader

value = XmlFastInfosetDictionaryReader.Create(input, quotas)
C#
public static XmlFastInfosetDictionaryReader Create(
   Stream input,
   XmlDictionaryReaderQuotas quotas
)
Delphi
public function Create(
    input: Stream;
    quotas: XmlDictionaryReaderQuotas
): XmlFastInfosetDictionaryReader; static;
JScript
public static function Create(
   input : Stream,
   quotas : XmlDictionaryReaderQuotas
) : XmlFastInfosetDictionaryReader;
Managed Extensions for C++
public: static XmlFastInfosetDictionaryReader* Create(
   Stream* input,
   XmlDictionaryReaderQuotas* quotas
)
C++/CLI
public:
static XmlFastInfosetDictionaryReader^ Create(
   Stream^ input,
   XmlDictionaryReaderQuotas^ quotas
)

Parameters

input
The stream to read data from.
quotas
The XmlReaderSettings object used to configure the new XmlFastInfosetDictionaryReader instance. This value can be null.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : GetAttribute Method

Gets the value of an attribute.

Overload List

Overload | Description
GetAttribute(Int32) | Gets the value of an attribute.
GetAttribute(String,String) | Gets the value of an attribute.
GetAttribute(String) | Gets the value of an attribute.
GetAttribute(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in GetAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > GetAttribute Method : GetAttribute(Int32) Method

i
The index of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetAttribute( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim i As Integer
Dim value As String

value = instance.GetAttribute(i)
C#
public override string GetAttribute(
   int i
)
Delphi
public function GetAttribute(
    i: Integer
): String; override;
JScript
public override function GetAttribute(
   i : int
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   int i
) override
C++/CLI
public:
String^ GetAttribute(
   int i
) override

Parameters

i
The index of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in GetAttribute(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > GetAttribute Method : GetAttribute(String,String) Method

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim namespaceURI As String
Dim value As String

value = instance.GetAttribute(name, namespaceURI)
C#
public override string GetAttribute(
   string name,
   string namespaceURI
)
Delphi
public function GetAttribute(
    name: String;
    namespaceURI: String
): String; override;
JScript
public override function GetAttribute(
   name : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name,
   string* namespaceURI
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name,
   String^ namespaceURI
) override

Parameters

name
The local name of the attribute.
namespaceURI
The namespace URI of the attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in GetAttribute(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > GetAttribute Method : GetAttribute(String) Method

name
The name of an attribute.
Gets the value of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetAttribute( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As String

value = instance.GetAttribute(name)
C#
public override string GetAttribute(
   string name
)
Delphi
public function GetAttribute(
    name: String
): String; override;
JScript
public override function GetAttribute(
   name : String
) : String;
Managed Extensions for C++
public: string* GetAttribute(
   string* name
) override
C++/CLI
public:
String^ GetAttribute(
   String^ name
) override

Parameters

name
The name of an attribute.

Return Value

The value of the specified attribute.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in GetAttribute(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Init Method

Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to use specified stream.

Overload List

Overload | Description
Init(Stream) | Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to use specified stream.
Init(Byte[],Int32,Int32) | Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to read specified buffer in memory.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Stream) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Init Method : Init(Stream) Method

stream
The stream containing the Fast Infoset encoded XML data to read.
Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to use specified stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim stream As Stream

instance.Init(stream)
C#
public void Init(
   Stream stream
)
Delphi
public procedure Init(
    stream: Stream
);
JScript
public function Init(
   stream : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* stream
)
C++/CLI
public:
void Init(
   Stream^ stream
)

Parameters

stream
The stream containing the Fast Infoset encoded XML data to read.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Init Method : Init(Byte[],Int32,Int32) Method

input
The buffer that contain Fast Infoset document.
offset
And index of the byte where to start reading data.
length
The total number of bytes available to read.
Initializes an existing instance of XmlFastInfosetDictionaryReader and sets it to read specified buffer in memory.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Init( _
   ByVal input() As Byte, _
   ByVal offset As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim input() As Byte
Dim offset As Integer
Dim length As Integer

instance.Init(input, offset, length)
C#
public void Init(
   byte[] input,
   int offset,
   int length
)
Delphi
public procedure Init(
    input: Bytearray of;
    offset: Integer;
    length: Integer
);
JScript
public function Init(
   input : byte[],
   offset : int,
   length : int
);
Managed Extensions for C++
public: void Init(
   byte[]* input,
   int offset,
   int length
)
C++/CLI
public:
void Init(
   array<byte>^ input,
   int offset,
   int length
)

Parameters

input
The buffer that contain Fast Infoset document.
offset
And index of the byte where to start reading data.
length
The total number of bytes available to read.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsStartElement Method

Tests if the current content node is a start element.

Overload List

Overload | Description
IsStartElement() | Tests if the current content node is a start element.
IsStartElement(String,String) | Tests if the current content node is a start element with specified name and namespace.
IsStartElement(String) | Tests if the current content node is a start element with specified name and namespace.
IsStartElement(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in IsStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsStartElement Method : IsStartElement() Method

Tests if the current content node is a start element.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IsStartElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.IsStartElement()
C#
public override bool IsStartElement()
Delphi
public function IsStartElement(): Boolean; override;
JScript
public override function IsStartElement() : boolean;
Managed Extensions for C++
public: bool IsStartElement(); override
C++/CLI
public:
bool IsStartElement(); override

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in IsStartElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsStartElement Method : IsStartElement(String,String) Method

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IsStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localname As String
Dim ns As String
Dim value As Boolean

value = instance.IsStartElement(localname, ns)
C#
public override bool IsStartElement(
   string localname,
   string ns
)
Delphi
public function IsStartElement(
    localname: String;
    ns: String
): Boolean; override;
JScript
public override function IsStartElement(
   localname : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
bool IsStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The string to match against the LocalName property of the element found.
ns
The string to match against the NamespaceURI property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in IsStartElement(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsStartElement Method : IsStartElement(String) Method

name
The string to match against the Name property of the element found.
Tests if the current content node is a start element with specified name and namespace.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IsStartElement( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As Boolean

value = instance.IsStartElement(name)
C#
public override bool IsStartElement(
   string name
)
Delphi
public function IsStartElement(
    name: String
): Boolean; override;
JScript
public override function IsStartElement(
   name : String
) : boolean;
Managed Extensions for C++
public: bool IsStartElement(
   string* name
) override
C++/CLI
public:
bool IsStartElement(
   String^ name
) override

Parameters

name
The string to match against the Name property of the element found.

Return Value

true if MoveToContent finds a start tag or empty element tag; false if a node type other than XmlNodeType.Element was found.

Remarks

Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the local name and namespace of the element found matches the given arguments.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in IsStartElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LookupNamespace Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : LookupNamespace Method

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Resolves the namespace prefix in the current element's scope.

Syntax

Visual Basic (Declaration)
Public Overrides Function LookupNamespace( _
   ByVal prefix As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim prefix As String
Dim value As String

value = instance.LookupNamespace(prefix)
C#
public override string LookupNamespace(
   string prefix
)
Delphi
public function LookupNamespace(
    prefix: String
): String; override;
JScript
public override function LookupNamespace(
   prefix : String
) : String;
Managed Extensions for C++
public: string* LookupNamespace(
   string* prefix
) override
C++/CLI
public:
String^ LookupNamespace(
   String^ prefix
) override

Parameters

prefix
The prefix whose namespace URI you want to resolve. To match the default namespace, pass an empty string. This string does not have to be atomized.

Return Value

The namespace URI to which the prefix maps or a null reference (Nothing in Visual Basic) if no matching prefix is found.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in LookupNamespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToAttribute Method

Moves to the specified attribute.

Overload List

Overload | Description
MoveToAttribute(String,String) | Moves to the attribute specified by the local name and namespace URI.
MoveToAttribute(String) | Moves to the attribute specified by the qualified name.
MoveToAttribute(Int32) | Moves to the attribute specified by the index.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in MoveToAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToAttribute Method : MoveToAttribute(String,String) Method

name
The local name of the attribute.
ns
The namespace URI of the attribute.
Moves to the attribute specified by the local name and namespace URI.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function MoveToAttribute( _
   ByVal name As String, _
   ByVal ns As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim ns As String
Dim value As Boolean

value = instance.MoveToAttribute(name, ns)
C#
public override bool MoveToAttribute(
   string name,
   string ns
)
Delphi
public function MoveToAttribute(
    name: String;
    ns: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String,
   ns : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name,
   string* ns
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name,
   String^ ns
) override

Parameters

name
The local name of the attribute.
ns
The namespace URI of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in MoveToAttribute(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToAttribute Method : MoveToAttribute(String) Method

name
The qualified name of the attribute.
Moves to the attribute specified by the qualified name.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As Boolean

value = instance.MoveToAttribute(name)
C#
public override bool MoveToAttribute(
   string name
)
Delphi
public function MoveToAttribute(
    name: String
): Boolean; override;
JScript
public override function MoveToAttribute(
   name : String
) : boolean;
Managed Extensions for C++
public: bool MoveToAttribute(
   string* name
) override
C++/CLI
public:
bool MoveToAttribute(
   String^ name
) override

Parameters

name
The qualified name of the attribute.

Return Value

true if the attribute is found; otherwise, false. If false, the reader's position does not change.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in MoveToAttribute(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToAttribute(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToAttribute Method : MoveToAttribute(Int32) Method

i
The index of the attribute.
Moves to the attribute specified by the index.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub MoveToAttribute( _
   ByVal i As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim i As Integer

instance.MoveToAttribute(i)
C#
public override void MoveToAttribute(
   int i
)
Delphi
public procedure MoveToAttribute(
    i: Integer
); override;
JScript
public override function MoveToAttribute(
   i : int
);
Managed Extensions for C++
public: void MoveToAttribute(
   int i
) override
C++/CLI
public:
void MoveToAttribute(
   int i
) override

Parameters

i
The index of the attribute.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in MoveToAttribute(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToContent Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToContent Method

Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.

Syntax

Visual Basic (Declaration)
Public Overrides Function MoveToContent() As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlNodeType

value = instance.MoveToContent()
C#
public override XmlNodeType MoveToContent()
Delphi
public function MoveToContent(): XmlNodeType; override;
JScript
public override function MoveToContent() : XmlNodeType;
Managed Extensions for C++
public: XmlNodeType MoveToContent(); override
C++/CLI
public:
XmlNodeType MoveToContent(); override

Return Value

The NodeType of the current node found by the method or XmlNodeType.None if the reader has reached the end of the input stream.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in MoveToContent


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToElement Method

Moves to the element that contains the current attribute node.

Syntax

Visual Basic (Declaration)
Public Overrides Function MoveToElement() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.MoveToElement()
C#
public override bool MoveToElement()
Delphi
public function MoveToElement(): Boolean; override;
JScript
public override function MoveToElement() : boolean;
Managed Extensions for C++
public: bool MoveToElement(); override
C++/CLI
public:
bool MoveToElement(); override

Return Value

true if the reader is positioned on an attribute (the reader moves to the element that owns the attribute); false if the reader is not positioned on an attribute (the position of the reader does not change).

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in MoveToElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToFirstAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToFirstAttribute Method

Moves to the first attribute.

Syntax

Visual Basic (Declaration)
Public Overrides Function MoveToFirstAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.MoveToFirstAttribute()
C#
public override bool MoveToFirstAttribute()
Delphi
public function MoveToFirstAttribute(): Boolean; override;
JScript
public override function MoveToFirstAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToFirstAttribute(); override
C++/CLI
public:
bool MoveToFirstAttribute(); override

Return Value

true if an attribute exists (the reader moves to the first attribute); otherwise, false (the position of the reader does not change).

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in MoveToFirstAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToNextAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToNextAttribute Method

Moves to the next attribute.

Syntax

Visual Basic (Declaration)
Public Overrides Function MoveToNextAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.MoveToNextAttribute()
C#
public override bool MoveToNextAttribute()
Delphi
public function MoveToNextAttribute(): Boolean; override;
JScript
public override function MoveToNextAttribute() : boolean;
Managed Extensions for C++
public: bool MoveToNextAttribute(); override
C++/CLI
public:
bool MoveToNextAttribute(); override

Return Value

true if there is a next attribute; false if there are no more attributes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in MoveToNextAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Read Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Read Method

Reads the next node from the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.Read()
C#
public override bool Read()
Delphi
public function Read(): Boolean; override;
JScript
public override function Read() : boolean;
Managed Extensions for C++
public: bool Read(); override
C++/CLI
public:
bool Read(); override

Return Value

true if the next node was read successfully; false if there are no more nodes to read.

Remarks

When an XmlFastInfosetDictionaryReader is first created and initialized, there is no information available. You must call Read to read the first node.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Read


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadAttributeValue Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadAttributeValue Method

Reads the attribute value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadAttributeValue() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.ReadAttributeValue()
C#
public override bool ReadAttributeValue()
Delphi
public function ReadAttributeValue(): Boolean; override;
JScript
public override function ReadAttributeValue() : boolean;
Managed Extensions for C++
public: bool ReadAttributeValue(); override
C++/CLI
public:
bool ReadAttributeValue(); override

Return Value

true if there are nodes to return. false if the reader is not positioned on an attribute node when the initial call is made or if all the attribute values have been read.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadAttributeValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAs Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAs Method

type
The Type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion. For example, this can be used when converting an XmlQualifiedName object to an xs:string. This value can be a null reference.
Converts a node's content to a specified type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAs( _
   ByVal type As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim type As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadContentAs(type, namespaceResolver)
C#
public override object ReadContentAs(
   Type type,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadContentAs(
    type: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject; override;
JScript
public override function ReadContentAs(
   type : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadContentAs(
   Type* type,
   IXmlNamespaceResolver* namespaceResolver
) override
C++/CLI
public:
Object^ ReadContentAs(
   Type^ type,
   IXmlNamespaceResolver^ namespaceResolver
) override

Parameters

type
The Type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion. For example, this can be used when converting an XmlQualifiedName object to an xs:string. This value can be a null reference.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAs


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64 Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsBase64 Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Overload List

Overload | Description
ReadContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.
ReadContentAsBase64() | Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsBase64 Method : ReadContentAsBase64(Byte[],Int32,Int32) Method

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBase64(buffer, index, count)
C#
public override int ReadContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer

The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).

index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

If content is binary encoded Base64 bytes block, reader returns the bytes read.

If content is text, reader performs Base64 decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBase64() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsBase64 Method : ReadContentAsBase64() Method

Reads the binary or Base64 encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadContentAsBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value() As Byte

value = instance.ReadContentAsBase64()
C#
public override byte[] ReadContentAsBase64()
Delphi
public function ReadContentAsBase64(): array of Byte; override;
JScript
public override function ReadContentAsBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadContentAsBase64(); override
C++/CLI
public:
array<byte>^ ReadContentAsBase64(); override

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadContentAsBase64()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBinHex Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsBinHex Method

Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.

Overload List

Overload | Description
ReadContentAsBinHex(Byte[],Int32,Int32) | Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
ReadContentAsBinHex() | Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.
ReadContentAsBinHex(Int32) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBinHex(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsBinHex Method : ReadContentAsBinHex(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method
Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsBinHex(buffer, index, count)
C#
public override int ReadContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method

Return Value

The number of bytes written to the buffer.

Remarks

If content is binary encoded BinHex bytes block, reader returns the bytes read.

If content is text, reader performs BinHex decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBinHex() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsBinHex Method : ReadContentAsBinHex() Method

Reads the binary or BinHex encoded content at the current position and returns the decoded binary bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadContentAsBinHex() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value() As Byte

value = instance.ReadContentAsBinHex()
C#
public override byte[] ReadContentAsBinHex()
Delphi
public function ReadContentAsBinHex(): array of Byte; override;
JScript
public override function ReadContentAsBinHex() : byte[];
Managed Extensions for C++
public: byte[]* ReadContentAsBinHex(); override
C++/CLI
public:
array<byte>^ ReadContentAsBinHex(); override

Return Value

The number of bytes written to the buffer.

Remarks

If the content is binary encoded BinHex bytes, the reader returns the bytes read. If the content is text, the reader performs BinHex decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadContentAsBinHex()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBoolean Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsBoolean Method

Reads the content at the current position as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.ReadContentAsBoolean()
C#
public override bool ReadContentAsBoolean()
Delphi
public function ReadContentAsBoolean(): Boolean; override;
JScript
public override function ReadContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadContentAsBoolean(); override
C++/CLI
public:
bool ReadContentAsBoolean(); override

Return Value

The content as a boolean value.

Remarks

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsBoolean


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDateTime Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsDateTime Method

Reads the node content at the current position as a DateTime value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Date

value = instance.ReadContentAsDateTime()
C#
public override DateTime ReadContentAsDateTime()
Delphi
public function ReadContentAsDateTime(): DateTime; override;
JScript
public override function ReadContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadContentAsDateTime(); override
C++/CLI
public:
DateTime ReadContentAsDateTime(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsDateTime


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDecimal Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsDecimal Method

Reads the text content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Decimal

value = instance.ReadContentAsDecimal()
C#
public override decimal ReadContentAsDecimal()
Delphi
public function ReadContentAsDecimal(): Currency; override;
JScript
public override function ReadContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadContentAsDecimal(); override
C++/CLI
public:
decimal ReadContentAsDecimal(); override

Return Value

The text content as a decimal value.

Remarks

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsDecimal


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsDouble Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsDouble Method

Reads the content at the current position as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Double

value = instance.ReadContentAsDouble()
C#
public override double ReadContentAsDouble()
Delphi
public function ReadContentAsDouble(): Double; override;
JScript
public override function ReadContentAsDouble() : double;
Managed Extensions for C++
public: double ReadContentAsDouble(); override
C++/CLI
public:
double ReadContentAsDouble(); override

Return Value

The content as a double-precision floating-point number.

Remarks

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsDouble


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsFloat Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsFloat Method

Reads the content at the current position as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Single

value = instance.ReadContentAsFloat()
C#
public override float ReadContentAsFloat()
Delphi
public function ReadContentAsFloat(): Single; override;
JScript
public override function ReadContentAsFloat() : float;
Managed Extensions for C++
public: float ReadContentAsFloat(); override
C++/CLI
public:
float ReadContentAsFloat(); override

Return Value

The content as a single-precision floating-point number.

Remarks

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsFloat


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsGuid Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsGuid Method

Converts a node's content to guid.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsGuid() As Guid
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Guid

value = instance.ReadContentAsGuid()
C#
public override Guid ReadContentAsGuid()
Delphi
public function ReadContentAsGuid(): Guid; override;
JScript
public override function ReadContentAsGuid() : Guid;
Managed Extensions for C++
public: Guid ReadContentAsGuid(); override
C++/CLI
public:
Guid ReadContentAsGuid(); override

Return Value

The guid representation of node's content.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsGuid


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsInt Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsInt Method

Reads the text content at the current position as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Integer

value = instance.ReadContentAsInt()
C#
public override int ReadContentAsInt()
Delphi
public function ReadContentAsInt(): Integer; override;
JScript
public override function ReadContentAsInt() : int;
Managed Extensions for C++
public: int ReadContentAsInt(); override
C++/CLI
public:
int ReadContentAsInt(); override

Return Value

The content as a 32-bit signed integer.

Remarks

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsInt


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsLong Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsLong Method

Reads the text content at the current position as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Long

value = instance.ReadContentAsLong()
C#
public override long ReadContentAsLong()
Delphi
public function ReadContentAsLong(): Int64; override;
JScript
public override function ReadContentAsLong() : long;
Managed Extensions for C++
public: long ReadContentAsLong(); override
C++/CLI
public:
int64 ReadContentAsLong(); override

Return Value

The content as a 64-bit signed integer.

Remarks

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsLong


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsString Method

Reads the text content at the current position as a string.

Overload List

Overload | Description
ReadContentAsString() | Reads the text content at the current position as a string.
ReadContentAsString(Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadContentAsString(String[],Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadContentAsString(XmlDictionaryString[],Int32) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadContentAsString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsString Method : ReadContentAsString() Method

Reads the text content at the current position as a string.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadContentAsString()
C#
public override string ReadContentAsString()
Delphi
public function ReadContentAsString(): String; override;
JScript
public override function ReadContentAsString() : String;
Managed Extensions for C++
public: string* ReadContentAsString(); override
C++/CLI
public:
String^ ReadContentAsString(); override

Return Value

The node content as String object.

Remarks

Implements XmlReader.ReadContentAsString.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadContentAsString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAs Method

Reads the element content as the requested type.

Overload List

Overload | Description
ReadElementContentAs(Type,IXmlNamespaceResolver) | Reads the element content as the requested type.
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the element content as the requested type.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAs


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs(Type,IXmlNamespaceResolver) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver) Method

returnType
The type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion.
Reads the element content as the requested type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver)
C#
public override object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject; override;
JScript
public override function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver
) override
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver
) override

Parameters

returnType
The type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion.

Return Value

The element content converted to the requested typed object.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAs(Type,IXmlNamespaceResolver)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method

returnType
The type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion.
localName

The local name of the element.

namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the element content as the requested type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver, localName, namespaceURI)
C#
public override object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver,
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver;
    localName: String;
    namespaceURI: String
): TObject; override;
JScript
public override function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver,
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver,
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver,
   String^ localName,
   String^ namespaceURI
) override

Parameters

returnType
The type of the value to be returned.
namespaceResolver
An IXmlNamespaceResolver object that is used to resolve any namespace prefixes related to type conversion.
localName

The local name of the element.

namespaceURI
The namespace URI of the element.

Return Value

The element content converted to the requested typed object.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAs(Type,IXmlNamespaceResolver,String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64 Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsBase64 Method

Reads binary or Base64 encoded element content and returns decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBase64() | Reads binary or Base64 encoded element content and returns decoded bytes.
ReadElementContentAsBase64(Byte[],Int32,Int32) | Reads the binary or Base64 encoded element content and returns the decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64() Method

Reads binary or Base64 encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBase64() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value() As Byte

value = instance.ReadElementContentAsBase64()
C#
public override byte[] ReadElementContentAsBase64()
Delphi
public function ReadElementContentAsBase64(): array of Byte; override;
JScript
public override function ReadElementContentAsBase64() : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBase64(); override
C++/CLI
public:
array<byte>^ ReadElementContentAsBase64(); override

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded Base64 bytes block, reader returns the bytes read.

If content is text, reader performs Base64 decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBase64()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBase64(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBase64 Method : ReadElementContentAsBase64(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Reads the binary or Base64 encoded element content and returns the decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBase64(buffer, index, count)
C#
public override int ReadElementContentAsBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBase64(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting bytes. This value cannot be a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is binary encoded Base64 bytes, the reader returns the bytes read.

If the content is text, the reader performs Base64 decoding and returns the decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsBinHex Method

Reads binary or BinHex encoded element content and returns decoded bytes.

Overload List

Overload | Description
ReadElementContentAsBinHex() | Reads binary or BinHex encoded element content and returns decoded bytes.
ReadElementContentAsBinHex(Byte[],Int32,Int32) | Converts a node's content to an array of Base64 bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex() Method

Reads binary or BinHex encoded element content and returns decoded bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBinHex() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value() As Byte

value = instance.ReadElementContentAsBinHex()
C#
public override byte[] ReadElementContentAsBinHex()
Delphi
public function ReadElementContentAsBinHex(): array of Byte; override;
JScript
public override function ReadElementContentAsBinHex() : byte[];
Managed Extensions for C++
public: byte[]* ReadElementContentAsBinHex(); override
C++/CLI
public:
array<byte>^ ReadElementContentAsBinHex(); override

Return Value

The number of bytes written to the buffer.

Remarks

This method reads the start tag, the contents of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If content is binary encoded BinHex bytes block, reader returns the bytes read.

If content is text, reader performs BinHex decoding and returns decoded bytes.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBinHex()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBinHex(Byte[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBinHex Method : ReadElementContentAsBinHex(Byte[],Int32,Int32) Method

buffer
The buffer into which to copy the resulting text. This value cannot be null Nothing nullptr a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.
Converts a node's content to an array of Base64 bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadElementContentAsBinHex(buffer, index, count)
C#
public override int ReadElementContentAsBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public function ReadElementContentAsBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
): Integer; override;
JScript
public override function ReadElementContentAsBinHex(
   buffer : byte[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadElementContentAsBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
int ReadElementContentAsBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The buffer into which to copy the resulting text. This value cannot be null Nothing nullptr a null reference (Nothing in Visual Basic).
index
The offset into the buffer where to start copying the result.
count
The maximum number of bytes to copy into the buffer. The actual number of bytes copied is returned from this method.

Return Value

The number of bytes written to the buffer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsBoolean Method

Converts an element's content to a Boolean.

Overload List

Overload | Description
ReadElementContentAsBoolean(String,String) | Converts an element's content to a Boolean.
ReadElementContentAsBoolean() | Reads the current element and returns the content as a boolean value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsBoolean


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Converts an element's content to a Boolean.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBoolean( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadElementContentAsBoolean(localName, namespaceURI)
C#
public override bool ReadElementContentAsBoolean(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsBoolean(
    localName: String;
    namespaceURI: String
): Boolean; override;
JScript
public override function ReadElementContentAsBoolean(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
bool ReadElementContentAsBoolean(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBoolean(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean() Method

Reads the current element and returns the content as a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsBoolean() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.ReadElementContentAsBoolean()
C#
public override bool ReadElementContentAsBoolean()
Delphi
public function ReadElementContentAsBoolean(): Boolean; override;
JScript
public override function ReadElementContentAsBoolean() : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(); override
C++/CLI
public:
bool ReadElementContentAsBoolean(); override

Return Value

The element content as a boolean value.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded boolean value, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a boolean value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsBoolean()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsDateTime Method

Converts an element's content to a DateTime.

Overload List

Overload | Description
ReadElementContentAsDateTime(String,String) | Converts an element's content to a DateTime.
ReadElementContentAsDateTime() | Reads the node content at the current position as a DateTime value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsDateTime


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Converts an element's content to a DateTime.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDateTime( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Date

value = instance.ReadElementContentAsDateTime(localName, namespaceURI)
C#
public override DateTime ReadElementContentAsDateTime(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDateTime(
    localName: String;
    namespaceURI: String
): DateTime; override;
JScript
public override function ReadElementContentAsDateTime(
   localName : String,
   namespaceURI : String
) : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
DateTime ReadElementContentAsDateTime(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

Return Value

The element contents as a DateTime object.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDateTime(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime() Method

Reads the node content at the current position as a DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDateTime() As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Date

value = instance.ReadElementContentAsDateTime()
C#
public override DateTime ReadElementContentAsDateTime()
Delphi
public function ReadElementContentAsDateTime(): DateTime; override;
JScript
public override function ReadElementContentAsDateTime() : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(); override
C++/CLI
public:
DateTime ReadElementContentAsDateTime(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDateTime()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsDecimal Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a Decimal object.

Overload List

Overload | Description
ReadElementContentAsDecimal(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a Decimal object.
ReadElementContentAsDecimal() | Reads the node content at the current position as a decimal value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsDecimal


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a Decimal object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDecimal( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Decimal

value = instance.ReadElementContentAsDecimal(localName, namespaceURI)
C#
public override decimal ReadElementContentAsDecimal(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDecimal(
    localName: String;
    namespaceURI: String
): Currency; override;
JScript
public override function ReadElementContentAsDecimal(
   localName : String,
   namespaceURI : String
) : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
decimal ReadElementContentAsDecimal(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

Return Value

The element content as a Decimal object.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDecimal(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal() Method

Reads the node content at the current position as a decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDecimal() As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Decimal

value = instance.ReadElementContentAsDecimal()
C#
public override decimal ReadElementContentAsDecimal()
Delphi
public function ReadElementContentAsDecimal(): Currency; override;
JScript
public override function ReadElementContentAsDecimal() : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(); override
C++/CLI
public:
decimal ReadElementContentAsDecimal(); override

Return Value

The element content as a decimal value.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDecimal()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsDouble Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a double-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsDouble(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a double-precision floating-point number.
ReadElementContentAsDouble() | Reads the current element and returns the content as a double-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsDouble


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDouble( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Double

value = instance.ReadElementContentAsDouble(localName, namespaceURI)
C#
public override double ReadElementContentAsDouble(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDouble(
    localName: String;
    namespaceURI: String
): Double; override;
JScript
public override function ReadElementContentAsDouble(
   localName : String,
   namespaceURI : String
) : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
double ReadElementContentAsDouble(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

Return Value

The element content as a double-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDouble(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble() Method

Reads the current element and returns the content as a double-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsDouble() As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Double

value = instance.ReadElementContentAsDouble()
C#
public override double ReadElementContentAsDouble()
Delphi
public function ReadElementContentAsDouble(): Double; override;
JScript
public override function ReadElementContentAsDouble() : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(); override
C++/CLI
public:
double ReadElementContentAsDouble(); override

Return Value

The element content as a double-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded double-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a double-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsDouble()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsFloat Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a single-precision floating-point number.

Overload List

Overload | Description
ReadElementContentAsFloat(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a single-precision floating-point number.
ReadElementContentAsFloat() | Reads the current element and returns the content as a single-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsFloat


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a single-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsFloat( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Single

value = instance.ReadElementContentAsFloat(localName, namespaceURI)
C#
public override float ReadElementContentAsFloat(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsFloat(
    localName: String;
    namespaceURI: String
): Single; override;
JScript
public override function ReadElementContentAsFloat(
   localName : String,
   namespaceURI : String
) : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
float ReadElementContentAsFloat(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

Return Value

The element content as a single-precision floating point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsFloat(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat() Method

Reads the current element and returns the content as a single-precision floating-point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsFloat() As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Single

value = instance.ReadElementContentAsFloat()
C#
public override float ReadElementContentAsFloat()
Delphi
public function ReadElementContentAsFloat(): Single; override;
JScript
public override function ReadElementContentAsFloat() : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(); override
C++/CLI
public:
float ReadElementContentAsFloat(); override

Return Value

The element content as a single-precision floating-point number.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded single-precision floating-point number, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a single-precision floating-point number.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsFloat()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsGuid Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsGuid Method

Converts a node's content to guid.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadElementContentAsGuid() As Guid
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Guid

value = instance.ReadElementContentAsGuid()
C#
public override Guid ReadElementContentAsGuid()
Delphi
public function ReadElementContentAsGuid(): Guid; override;
JScript
public override function ReadElementContentAsGuid() : Guid;
Managed Extensions for C++
public: Guid ReadElementContentAsGuid(); override
C++/CLI
public:
Guid ReadElementContentAsGuid(); override

Return Value

The guid representation of node's content.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsGuid


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsInt Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 32-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsInt(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 32-bit signed integer.
ReadElementContentAsInt() | Reads the current element and returns the content as a 32-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsInt


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt(String,String) Method

localName
The local name of the element.
namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsInt( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Integer

value = instance.ReadElementContentAsInt(localName, namespaceURI)
C#
public override int ReadElementContentAsInt(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsInt(
    localName: String;
    namespaceURI: String
): Integer; override;
JScript
public override function ReadElementContentAsInt(
   localName : String,
   namespaceURI : String
) : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
int ReadElementContentAsInt(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The namespace URI of the element.

Return Value

The element content as a 32-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsInt(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt() Method

Reads the current element and returns the content as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsInt() As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Integer

value = instance.ReadElementContentAsInt()
C#
public override int ReadElementContentAsInt()
Delphi
public function ReadElementContentAsInt(): Integer; override;
JScript
public override function ReadElementContentAsInt() : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(); override
C++/CLI
public:
int ReadElementContentAsInt(); override

Return Value

The element content as a 32-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 32-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 32-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsInt()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsLong Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 64-bit signed integer.

Overload List

Overload | Description
ReadElementContentAsLong(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 64-bit signed integer.
ReadElementContentAsLong() | Reads the current element and returns the content as a 64-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsLong


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong(String,String) Method

localName
The local name of the element.
namespaceURI
The local name of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsLong( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Long

value = instance.ReadElementContentAsLong(localName, namespaceURI)
C#
public override long ReadElementContentAsLong(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsLong(
    localName: String;
    namespaceURI: String
): Int64; override;
JScript
public override function ReadElementContentAsLong(
   localName : String,
   namespaceURI : String
) : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
int64 ReadElementContentAsLong(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName
The local name of the element.
namespaceURI
The local name of the element.

Return Value

The element content as a 64-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsLong(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong() Method

Reads the current element and returns the content as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsLong() As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Long

value = instance.ReadElementContentAsLong()
C#
public override long ReadElementContentAsLong()
Delphi
public function ReadElementContentAsLong(): Int64; override;
JScript
public override function ReadElementContentAsLong() : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(); override
C++/CLI
public:
int64 ReadElementContentAsLong(); override

Return Value

The element content as a 64-bit signed integer.

Remarks

This method reads the start tag, the content of the element, and moves the reader past the end element tag. It expands entities and ignores processing instructions and comments. The element can only contain simple content. That is, it cannot have child elements.

If the content is a binary encoded 64-bit signed integer, the reader returns the value read. If the content is of any other type, the reader attempts to convert it to a 64-bit signed integer.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsLong()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsString Method

Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a String object.

Overload List

Overload | Description
ReadElementContentAsString(String,String) | Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a String object.
ReadElementContentAsString() | Reads the current element and returns the contents as a String object.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsString Method : ReadElementContentAsString(String,String) Method

localName

The local name of the element.

namespaceURI
The namespace URI of the element.
Checks that the specified local name and namespace URI matches that of the current element, then reads the current element and returns the contents as a String object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsString( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As String

value = instance.ReadElementContentAsString(localName, namespaceURI)
C#
public override string ReadElementContentAsString(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsString(
    localName: String;
    namespaceURI: String
): String; override;
JScript
public override function ReadElementContentAsString(
   localName : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(
   string* localName,
   string* namespaceURI
) override
C++/CLI
public:
String^ ReadElementContentAsString(
   String^ localName,
   String^ namespaceURI
) override

Parameters

localName

The local name of the element.

namespaceURI
The namespace URI of the element.

Return Value

The element content as a String bject.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsString(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsString Method : ReadElementContentAsString() Method

Reads the current element and returns the contents as a String object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementContentAsString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadElementContentAsString()
C#
public override string ReadElementContentAsString()
Delphi
public function ReadElementContentAsString(): String; override;
JScript
public override function ReadElementContentAsString() : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(); override
C++/CLI
public:
String^ ReadElementContentAsString(); override

Return Value

The element content as a String.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementContentAsString()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsTimeSpan Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsTimeSpan Method

Converts an element's content to a TimeSpan.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadElementContentAsTimeSpan() As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As TimeSpan

value = instance.ReadElementContentAsTimeSpan()
C#
public override TimeSpan ReadElementContentAsTimeSpan()
Delphi
public function ReadElementContentAsTimeSpan(): TimeSpan; override;
JScript
public override function ReadElementContentAsTimeSpan() : TimeSpan;
Managed Extensions for C++
public: TimeSpan ReadElementContentAsTimeSpan(); override
C++/CLI
public:
TimeSpan ReadElementContentAsTimeSpan(); override

Return Value

The node's content represented as a TimeSpan.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsTimeSpan


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsUniqueId Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsUniqueId Method

Converts an element's content to a unique identifier.

Syntax

Visual Basic (Declaration)
Public Overrides Function ReadElementContentAsUniqueId() As UniqueId
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As UniqueId

value = instance.ReadElementContentAsUniqueId()
C#
public override UniqueId ReadElementContentAsUniqueId()
Delphi
public function ReadElementContentAsUniqueId(): UniqueId; override;
JScript
public override function ReadElementContentAsUniqueId() : UniqueId;
Managed Extensions for C++
public: UniqueId* ReadElementContentAsUniqueId(); override
C++/CLI
public:
UniqueId^ ReadElementContentAsUniqueId(); override

Return Value

The node's content represented as a unique identifier.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementContentAsUniqueId


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementString Method

Reads a text-only element.

Overload List

Overload | Description
ReadElementString(String) | Checks that the name of the element found matches the given string before reading a text-only element.
ReadElementString(String,String) | Checks that the localname and namespace of the element found matches the given strings before reading a text-only element.
ReadElementString() | Reads a text-only element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadElementString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementString Method : ReadElementString(String) Method

name
The name to check.
Checks that the name of the element found matches the given string before reading a text-only element.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementString( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As String

value = instance.ReadElementString(name)
C#
public override string ReadElementString(
   string name
)
Delphi
public function ReadElementString(
    name: String
): String; override;
JScript
public override function ReadElementString(
   name : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* name
) override
C++/CLI
public:
String^ ReadElementString(
   String^ name
) override

Parameters

name
The name to check.

Return Value

The text contained in the element that was read. An empty string if the element is empty (<item></item> or <item/>).

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementString(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementString Method : ReadElementString(String,String) Method

localname
The local name to check.
ns
The namespace URI to check.
Checks that the localname and namespace of the element found matches the given strings before reading a text-only element.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementString( _
   ByVal localname As String, _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localname As String
Dim ns As String
Dim value As String

value = instance.ReadElementString(localname, ns)
C#
public override string ReadElementString(
   string localname,
   string ns
)
Delphi
public function ReadElementString(
    localname: String;
    ns: String
): String; override;
JScript
public override function ReadElementString(
   localname : String,
   ns : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* localname,
   string* ns
) override
C++/CLI
public:
String^ ReadElementString(
   String^ localname,
   String^ ns
) override

Parameters

localname
The local name to check.
ns
The namespace URI to check.

Return Value

The text contained in the element that was read. An empty string if the element is empty (<item></item> or <item/>).

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementString(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementString Method : ReadElementString() Method

Reads a text-only element.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadElementString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadElementString()
C#
public override string ReadElementString()
Delphi
public function ReadElementString(): String; override;
JScript
public override function ReadElementString() : String;
Managed Extensions for C++
public: string* ReadElementString(); override
C++/CLI
public:
String^ ReadElementString(); override

Return Value

The text contained in the element that was read. An empty string if the element is empty (<item></item> or <item/>).

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadElementString()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadEndElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadEndElement Method

Checks that the current content node is an end tag and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ReadEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.ReadEndElement()
C#
public override void ReadEndElement()
Delphi
public procedure ReadEndElement(); override;
JScript
public override function ReadEndElement();
Managed Extensions for C++
public: void ReadEndElement(); override
C++/CLI
public:
void ReadEndElement(); override

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadFullStartElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadFullStartElement Method

Checks whether the current node is an element and advances the reader to the next node.

Overload List

Overload | Description
ReadFullStartElement(String,String) | Checks whether the current node is an element with the given localName and namespaceUri and advances the reader to the next node.
ReadFullStartElement(String) | Checks whether the current node is an element with the given name and advances the reader to the next node.
ReadFullStartElement() | (Inherited from System.Xml.XmlDictionaryReader)
ReadFullStartElement(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadFullStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadFullStartElement(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadFullStartElement Method : ReadFullStartElement(String,String) Method

localName
The local name of the element.
namespaceUri

The namespace URI of the element.

Checks whether the current node is an element with the given localName and namespaceUri and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub ReadFullStartElement( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String

instance.ReadFullStartElement(localName, namespaceUri)
C#
public override void ReadFullStartElement(
   string localName,
   string namespaceUri
)
Delphi
public procedure ReadFullStartElement(
    localName: String;
    namespaceUri: String
); override;
JScript
public override function ReadFullStartElement(
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void ReadFullStartElement(
   string* localName,
   string* namespaceUri
) override
C++/CLI
public:
void ReadFullStartElement(
   String^ localName,
   String^ namespaceUri
) override

Parameters

localName
The local name of the element.
namespaceUri

The namespace URI of the element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadFullStartElement(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadFullStartElement(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadFullStartElement Method : ReadFullStartElement(String) Method

name

The qualified name of the element.

Checks whether the current node is an element with the given name and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub ReadFullStartElement( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String

instance.ReadFullStartElement(name)
C#
public override void ReadFullStartElement(
   string name
)
Delphi
public procedure ReadFullStartElement(
    name: String
); override;
JScript
public override function ReadFullStartElement(
   name : String
);
Managed Extensions for C++
public: void ReadFullStartElement(
   string* name
) override
C++/CLI
public:
void ReadFullStartElement(
   String^ name
) override

Parameters

name

The qualified name of the element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadFullStartElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadStartElement Method

Checks that the current node is an element and advances the reader to the next node.

Overload List

Overload | Description
ReadStartElement() | Checks that the current node is an element and advances the reader to the next node.
ReadStartElement(String,String) | Checks that the current content node is an element with the given localname and namespace and advances the reader to the next node.
ReadStartElement(String) | Checks that the current content node is an element with the given Name and advances the reader to the next node.
ReadStartElement(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadStartElement Method : ReadStartElement() Method

Checks that the current node is an element and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub ReadStartElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.ReadStartElement()
C#
public override void ReadStartElement()
Delphi
public procedure ReadStartElement(); override;
JScript
public override function ReadStartElement();
Managed Extensions for C++
public: void ReadStartElement(); override
C++/CLI
public:
void ReadStartElement(); override

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadStartElement()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadStartElement Method : ReadStartElement(String,String) Method

localname
The local name of the element.
ns

The namespace URI of the element.

Checks that the current content node is an element with the given localname and namespace and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub ReadStartElement( _
   ByVal localname As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localname As String
Dim ns As String

instance.ReadStartElement(localname, ns)
C#
public override void ReadStartElement(
   string localname,
   string ns
)
Delphi
public procedure ReadStartElement(
    localname: String;
    ns: String
); override;
JScript
public override function ReadStartElement(
   localname : String,
   ns : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* localname,
   string* ns
) override
C++/CLI
public:
void ReadStartElement(
   String^ localname,
   String^ ns
) override

Parameters

localname
The local name of the element.
ns

The namespace URI of the element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadStartElement(String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadStartElement Method : ReadStartElement(String) Method

name

The qualified name of the element.

Checks that the current content node is an element with the given Name and advances the reader to the next node.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub ReadStartElement( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String

instance.ReadStartElement(name)
C#
public override void ReadStartElement(
   string name
)
Delphi
public procedure ReadStartElement(
    name: String
); override;
JScript
public override function ReadStartElement(
   name : String
);
Managed Extensions for C++
public: void ReadStartElement(
   string* name
) override
C++/CLI
public:
void ReadStartElement(
   String^ name
) override

Parameters

name

The qualified name of the element.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadStartElement(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadString Method

Reads the contents of the current node into a string.

Overload List

Overload | Description
ReadString() | Reads the contents of the current node into a string.
ReadString(Int32) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadString() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadString Method : ReadString() Method

Reads the contents of the current node into a string.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ReadString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadString()
C#
public override string ReadString()
Delphi
public function ReadString(): String; override;
JScript
public override function ReadString() : String;
Managed Extensions for C++
public: string* ReadString(); override
C++/CLI
public:
String^ ReadString(); override

Return Value

A string that contains the contents of the current node.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List
Base Implementation in ReadString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ResetState Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ResetState Method

Resets the ReadState to Initial.

Syntax

Visual Basic (Declaration)
Public Sub ResetState()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.ResetState()
C#
public void ResetState()
Delphi
public procedure ResetState();
JScript
public function ResetState();
Managed Extensions for C++
public: void ResetState();
C++/CLI
public:
void ResetState();

Remarks

The ResetState method resets the ReadState to Initial.

ResetState enables you to parse multiple Fast Infoset documents in a single stream. When you reach the end of a Fast Infoset document, you can call ResetState to reset the state of the reader in preparation for the next Fast Infoset document.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ResolveEntity Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ResolveEntity Method

Throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ResolveEntity()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.ResolveEntity()
C#
public override void ResolveEntity()
Delphi
public procedure ResolveEntity(); override;
JScript
public override function ResolveEntity();
Managed Extensions for C++
public: void ResolveEntity(); override
C++/CLI
public:
void ResolveEntity(); override

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ResolveEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetVocabulary Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : SetVocabulary Method

vocabulary
ParserVocabulary object to use as initial vocabulary.
Specifies an initial vocabulary to be used while reading the data.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As ReaderVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim vocabulary As ReaderVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   ReaderVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: ReaderVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : ReaderVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   ReaderVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   ReaderVocabulary^ vocabulary
)

Parameters

vocabulary
ParserVocabulary object to use as initial vocabulary.

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryReader Class Properties
See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryReader Class

For a list of all members of this type, see XmlFastInfosetDictionaryReader members.

Public Properties

 | Name | Description
public Property | AttributeCount | Overridden. Gets the number of attributes on the current node.
public Property | BaseURI | Overridden. Gets the base URI of the current node.
public Property | CanCanonicalize | (Inherited from System.Xml.XmlDictionaryReader)
public Property | CanReadBinaryContent | Overridden. Gets a value indicating whether this reader can parse binary content. Always returns true.
public Property | CanReadValueChunk | (Inherited from System.Xml.XmlReader)
public Property | CanResolveEntity | (Inherited from System.Xml.XmlReader)
public Property | Depth | Overridden. Gets the depth of the current node in the XML document.
public Property | EOF | Overridden. Gets a value indicating whether the reader is positioned at the end of the stream.
public Property | HasAttributes | (Inherited from System.Xml.XmlReader)
public Property | HasValue | Overridden. Gets a value indicating whether the current node can have a Value.
public Property | IsDefault | (Inherited from System.Xml.XmlReader)
public Property | IsEmptyElement | Overridden. Gets a value indicating whether the current node is an empty element.
public Property | Item | Overloaded. (Inherited from System.Xml.XmlReader)
public Property | LocalName | Overridden. Gets the local name of the current node.
public Property | Name | (Inherited from System.Xml.XmlReader)
public Property | NamespaceURI | Overridden. Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.
public Property | NameTable | Overridden. Gets the XmlNameTable associated with this reader.
public Property | NodeType | Overridden. Gets the type of the current node.
public Property | Prefix | Overridden. Gets the namespace prefix associated with the current node.
public Property | Quotas | Overridden. Gets the quota values that apply to the current instance of this class.
public Property | QuoteChar | (Inherited from System.Xml.XmlReader)
public Property | ReadState | Overridden. Gets the state of the reader.
public Property | SchemaInfo | (Inherited from System.Xml.XmlReader)
public Property | Settings | Overridden. Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.
public Property | Value | Overridden. Gets the text value of the current node.
public Property | ValueType | (Inherited from System.Xml.XmlReader)
public Property | VocabularyProvider | Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.
public Property | XmlLang | (Inherited from System.Xml.XmlReader)
public Property | XmlSpace | (Inherited from System.Xml.XmlReader)
Top

See Also

Reference

XmlFastInfosetDictionaryReader Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AttributeCount Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : AttributeCount Property

Gets the number of attributes on the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property AttributeCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Integer

value = instance.AttributeCount
C#
public override int AttributeCount {get;}
Delphi
public read-only property AttributeCount: Integer; override;
JScript
public override function get AttributeCount : int
Managed Extensions for C++
public: __property int get_AttributeCount() override;
C++/CLI
public:
property int AttributeCount {
   int get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in AttributeCount


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseURI Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : BaseURI Property

Gets the base URI of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property BaseURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.BaseURI
C#
public override string BaseURI {get;}
Delphi
public read-only property BaseURI: String; override;
JScript
public override function get BaseURI : String
Managed Extensions for C++
public: __property string* get_BaseURI() override;
C++/CLI
public:
property String^ BaseURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in BaseURI


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanReadBinaryContent Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : CanReadBinaryContent Property

Gets a value indicating whether this reader can parse binary content. Always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReadBinaryContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.CanReadBinaryContent
C#
public override bool CanReadBinaryContent {get;}
Delphi
public read-only property CanReadBinaryContent: Boolean; override;
JScript
public override function get CanReadBinaryContent : boolean
Managed Extensions for C++
public: __property bool get_CanReadBinaryContent() override;
C++/CLI
public:
property bool CanReadBinaryContent {
   bool get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in CanReadBinaryContent


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Depth Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Depth Property

Gets the depth of the current node in the XML document.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Depth As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Integer

value = instance.Depth
C#
public override int Depth {get;}
Delphi
public read-only property Depth: Integer; override;
JScript
public override function get Depth : int
Managed Extensions for C++
public: __property int get_Depth() override;
C++/CLI
public:
property int Depth {
   int get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Depth


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EOF Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : EOF Property

Gets a value indicating whether the reader is positioned at the end of the stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EOF As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.EOF
C#
public override bool EOF {get;}
Delphi
public read-only property EOF: Boolean; override;
JScript
public override function get EOF : boolean
Managed Extensions for C++
public: __property bool get_EOF() override;
C++/CLI
public:
property bool EOF {
   bool get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in EOF


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasValue Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : HasValue Property

Gets a value indicating whether the current node can have a Value.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HasValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.HasValue
C#
public override bool HasValue {get;}
Delphi
public read-only property HasValue: Boolean; override;
JScript
public override function get HasValue : boolean
Managed Extensions for C++
public: __property bool get_HasValue() override;
C++/CLI
public:
property bool HasValue {
   bool get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in HasValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsEmptyElement Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsEmptyElement Property

Gets a value indicating whether the current node is an empty element.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEmptyElement As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.IsEmptyElement
C#
public override bool IsEmptyElement {get;}
Delphi
public read-only property IsEmptyElement: Boolean; override;
JScript
public override function get IsEmptyElement : boolean
Managed Extensions for C++
public: __property bool get_IsEmptyElement() override;
C++/CLI
public:
property bool IsEmptyElement {
   bool get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in IsEmptyElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LocalName Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : LocalName Property

Gets the local name of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property LocalName As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.LocalName
C#
public override string LocalName {get;}
Delphi
public read-only property LocalName: String; override;
JScript
public override function get LocalName : String
Managed Extensions for C++
public: __property string* get_LocalName() override;
C++/CLI
public:
property String^ LocalName {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in LocalName


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NamespaceURI Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : NamespaceURI Property

Gets the namespace URI (as defined in the W3C Namespace specification) of the node on which the reader is positioned.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NamespaceURI As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.NamespaceURI
C#
public override string NamespaceURI {get;}
Delphi
public read-only property NamespaceURI: String; override;
JScript
public override function get NamespaceURI : String
Managed Extensions for C++
public: __property string* get_NamespaceURI() override;
C++/CLI
public:
property String^ NamespaceURI {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in NamespaceURI


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NameTable Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : NameTable Property

Gets the XmlNameTable associated with this reader.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NameTable As XmlNameTable
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlNameTable

value = instance.NameTable
C#
public override XmlNameTable NameTable {get;}
Delphi
public read-only property NameTable: XmlNameTable; override;
JScript
public override function get NameTable : XmlNameTable
Managed Extensions for C++
public: __property XmlNameTable* get_NameTable() override;
C++/CLI
public:
property XmlNameTable^ NameTable {
   XmlNameTable^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in NameTable


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
NodeType Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : NodeType Property

Gets the type of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NodeType As XmlNodeType
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlNodeType

value = instance.NodeType
C#
public override XmlNodeType NodeType {get;}
Delphi
public read-only property NodeType: XmlNodeType; override;
JScript
public override function get NodeType : XmlNodeType
Managed Extensions for C++
public: __property XmlNodeType get_NodeType() override;
C++/CLI
public:
property XmlNodeType NodeType {
   XmlNodeType get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in NodeType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Prefix Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Prefix Property

Gets the namespace prefix associated with the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Prefix As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.Prefix
C#
public override string Prefix {get;}
Delphi
public read-only property Prefix: String; override;
JScript
public override function get Prefix : String
Managed Extensions for C++
public: __property string* get_Prefix() override;
C++/CLI
public:
property String^ Prefix {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Prefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Quotas Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Quotas Property

Gets the quota values that apply to the current instance of this class.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Quotas As XmlDictionaryReaderQuotas
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlDictionaryReaderQuotas

value = instance.Quotas
C#
public override XmlDictionaryReaderQuotas Quotas {get;}
Delphi
public read-only property Quotas: XmlDictionaryReaderQuotas; override;
JScript
public override function get Quotas : XmlDictionaryReaderQuotas
Managed Extensions for C++
public: __property XmlDictionaryReaderQuotas* get_Quotas() override;
C++/CLI
public:
property XmlDictionaryReaderQuotas^ Quotas {
   XmlDictionaryReaderQuotas^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Quotas


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadState Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadState Property

Gets the state of the reader.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ReadState As ReadState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As ReadState

value = instance.ReadState
C#
public override ReadState ReadState {get;}
Delphi
public read-only property ReadState: ReadState; override;
JScript
public override function get ReadState : ReadState
Managed Extensions for C++
public: __property ReadState get_ReadState() override;
C++/CLI
public:
property ReadState ReadState {
   ReadState get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in ReadState


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Settings Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Settings Property

Gets the XmlReaderSettings object used to create this XmlFastInfosetReader instance.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Settings As XmlReaderSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlReaderSettings

value = instance.Settings
C#
public override XmlReaderSettings Settings {get;}
Delphi
public read-only property Settings: XmlReaderSettings; override;
JScript
public override function get Settings : XmlReaderSettings
Managed Extensions for C++
public: __property XmlReaderSettings* get_Settings() override;
C++/CLI
public:
property XmlReaderSettings^ Settings {
   XmlReaderSettings^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Settings


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Value Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Value Property

Gets the text value of the current node.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.Value
C#
public override string Value {get;}
Delphi
public read-only property Value: String; override;
JScript
public override function get Value : String
Managed Extensions for C++
public: __property string* get_Value() override;
C++/CLI
public:
property String^ Value {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Base Implementation in Value


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
VocabularyProvider Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : VocabularyProvider Property

Gets and sets the IVocabularyProvider for resolving external vocabulary URI, when it is encountered within a document.

Syntax

Visual Basic (Declaration)
Public Property VocabularyProvider As IVocabularyProvider
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As IVocabularyProvider

instance.VocabularyProvider = value

value = instance.VocabularyProvider
C#
public IVocabularyProvider VocabularyProvider {get; set;}
Delphi
public read-write property VocabularyProvider: IVocabularyProvider;
JScript
public function get,set VocabularyProvider : IVocabularyProvider
Managed Extensions for C++
public: __property IVocabularyProvider* get_VocabularyProvider();
public: __property void set_VocabularyProvider(
   IVocabularyProvider* value
);
C++/CLI
public:
property IVocabularyProvider^ VocabularyProvider {
   IVocabularyProvider^ get();
   void set (    IVocabularyProvider^ value);
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Class
Members See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryWriter Class

The XmlFastInfosetDictionaryWriter provides Fast Infoset data serialization by delegating calls to the XmlFastInfosetWriter.

Object Model

XmlFastInfosetDictionaryWriter Class

Syntax

Visual Basic (Declaration)
Public Class XmlFastInfosetDictionaryWriter
   Inherits System.Xml.XmlDictionaryWriter
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
C#
public class XmlFastInfosetDictionaryWriter : System.Xml.XmlDictionaryWriter
Delphi
public class XmlFastInfosetDictionaryWriter = class(System.Xml.XmlDictionaryWriter)
JScript
public class XmlFastInfosetDictionaryWriter extends System.Xml.XmlDictionaryWriter
Managed Extensions for C++
public __gc class XmlFastInfosetDictionaryWriter : public System.Xml.XmlDictionaryWriter
C++/CLI
public ref class XmlFastInfosetDictionaryWriter : public System.Xml.XmlDictionaryWriter

Inheritance Hierarchy

System.Object
System.Xml.XmlWriter
System.Xml.XmlDictionaryWriter
Noemax.Xml.XmlFastInfosetDictionaryWriter

See Also

Reference

XmlFastInfosetDictionaryWriter Members
Noemax.Xml Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Class Members
See Also Properties Methods Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryWriter Class

The following tables list the members exposed by XmlFastInfosetDictionaryWriter.

Public Constructors

 | Name | Description
public Constructor | XmlFastInfosetDictionaryWriter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanCanonicalize | (Inherited from System.Xml.XmlDictionaryWriter)
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Current xml:lang value in scope.
public Property | XmlSpace | Overridden. Current xml:space value in scope.
Top

Public Methods

 | Name | Description
public Method | Clear | Clears the XmlFastInfosetDictionaryWriter internal state.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Initializes a new instance of XmlFastInfosetDictionaryWriter.
public Method | EndCanonicalization | (Inherited from System.Xml.XmlDictionaryWriter)
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Initializes an instance of XmlFastInfosetDictionaryWriter preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | StartCanonicalization | (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteArray | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteAttributes | Overridden. Reads attributes from the reader and writes them out into current start element node.
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteName | (Inherited from System.Xml.XmlWriter)
public Method | WriteNmToken | (Inherited from System.Xml.XmlWriter)
public Method | WriteNode | Overloaded. Overridden.
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overloaded. Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes the value.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlAttribute | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteXmlnsAttribute | Overloaded. Overridden. Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
protected Method | WriteTextNode | (Inherited from System.Xml.XmlDictionaryWriter)
Top

See Also

Reference

XmlFastInfosetDictionaryWriter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Constructor
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : XmlFastInfosetDictionaryWriter Constructor

Overload List

Overload | Description
XmlFastInfosetDictionaryWriter Constructor(Stream) | Initializes a new instance of XmlFastInfosetDictionaryWriter.
XmlFastInfosetDictionaryWriter Constructor() | Initializes a new instance of XmlFastInfosetDictionaryWriter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Constructor(Stream)
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > XmlFastInfosetDictionaryWriter Constructor : XmlFastInfosetDictionaryWriter Constructor(Stream)

output
The stream to which you want to write.
Initializes a new instance of XmlFastInfosetDictionaryWriter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim output As Stream

Dim instance As New XmlFastInfosetDictionaryWriter(output)
C#
public XmlFastInfosetDictionaryWriter(
   Stream output
)
Delphi
public XmlFastInfosetDictionaryWriter(
    output: Stream
);
JScript
public function XmlFastInfosetDictionaryWriter(
   output : Stream
);
Managed Extensions for C++
public: XmlFastInfosetDictionaryWriter(
   Stream* output
)
C++/CLI
public:
XmlFastInfosetDictionaryWriter(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Constructor()
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > XmlFastInfosetDictionaryWriter Constructor : XmlFastInfosetDictionaryWriter Constructor()

Initializes a new instance of XmlFastInfosetDictionaryWriter.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New XmlFastInfosetDictionaryWriter()
C#
public XmlFastInfosetDictionaryWriter()
Delphi
public XmlFastInfosetDictionaryWriter();
JScript
public function XmlFastInfosetDictionaryWriter();
Managed Extensions for C++
public: XmlFastInfosetDictionaryWriter();
C++/CLI
public:
XmlFastInfosetDictionaryWriter();

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Class Methods
See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryWriter Class

For a list of all members of this type, see XmlFastInfosetDictionaryWriter members.

Public Methods

 | Name | Description
public Method | Clear | Clears the XmlFastInfosetDictionaryWriter internal state.
public Method | Close | Overridden. Changes the WriteState to Closed.
static (Shared in Visual Basic) | Create | Overloaded. Initializes a new instance of XmlFastInfosetDictionaryWriter.
public Method | EndCanonicalization | (Inherited from System.Xml.XmlDictionaryWriter)
public Method | Flush | Overridden. Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.
public Method | Init | Initializes an instance of XmlFastInfosetDictionaryWriter preparing to write into the specified stream.
public Method | LookupPrefix | Overridden. Returns the closest prefix defined in the current namespace scope for the namespace URI
public Method | SetVocabulary | Sets the vocabulary to be used when writing a Fast Infoset document.
public Method | StartCanonicalization | (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteArray | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteAttributes | Overridden. Reads attributes from the reader and writes them out into current start element node.
public Method | WriteAttributeString | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteBase64 | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.
public Method | WriteBinHex | Overridden. Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.
public Method | WriteCData | Overridden. Writes out a <![CDATA[...]]> block containing the specified text.
public Method | WriteCharEntity | Overridden. Forces the generation of a character entity for the specified Unicode character value.
public Method | WriteChars | Overridden. Writes text one buffer at a time.
public Method | WriteComment | Overridden. Writes out a comment containing the specified text.
public Method | WriteDocType | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteElementString | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteEndAttribute | Overridden. Closes the previous WriteStartAttribute call.
public Method | WriteEndDocument | Overridden. Closes any open elements or attributes and changes the WriteState to Start.
public Method | WriteEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteEntityRef | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteFullEndElement | Overridden. Closes one element and pops the corresponding namespace scope.
public Method | WriteName | (Inherited from System.Xml.XmlWriter)
public Method | WriteNmToken | (Inherited from System.Xml.XmlWriter)
public Method | WriteNode | Overloaded. Overridden.
public Method | WriteProcessingInstruction | Overridden. Writes out a processing instruction.
public Method | WriteQualifiedName | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteRaw | Overloaded. Overridden. This method is not supported.
public Method | WriteStartAttribute | Overloaded. Overridden. Writes the start of an attribute.
public Method | WriteStartDocument | Overloaded. Overridden. Writes the XML declaration with the version "1.0".
public Method | WriteStartElement | Overloaded. Overridden. Writes the specified start tag.
public Method | WriteString | Overloaded. Overridden. Writes the given text content.
public Method | WriteSurrogateCharEntity | Overridden. Writes a Unicode surrogate char pair.
public Method | WriteValue | Overloaded. Overridden. Writes the value.
public Method | WriteWhitespace | Overridden. Writes out the given white space.
public Method | WriteXmlAttribute | Overloaded. (Inherited from System.Xml.XmlDictionaryWriter)
public Method | WriteXmlnsAttribute | Overloaded. Overridden. Writes a namespace declaration attribute.
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Xml.XmlWriter)
protected Method | WriteTextNode | (Inherited from System.Xml.XmlDictionaryWriter)
Top

See Also

Reference

XmlFastInfosetDictionaryWriter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clear Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Clear Method

Clears the XmlFastInfosetDictionaryWriter internal state.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.Clear()
C#
public virtual void Clear()
Delphi
public procedure Clear(); virtual;
JScript
public function Clear();
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Remarks

Clears the internal state of the writer. After call to this method reader remains in uninitialized states. You must call Init method in order to reuse writer for writing into another stream.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Close Method

Changes the WriteState to Closed.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If CloseOutput is set to true, underlying stream will also be closed.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in Close


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Create Method

Initializes a new instance of XmlFastInfosetDictionaryWriter.

Overload List

Overload | Description
Create() | Initializes a new instance of XmlFastInfosetDictionaryWriter.
Create(Stream) |

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > Create Method : Create() Method

Initializes a new instance of XmlFastInfosetDictionaryWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create() As XmlFastInfosetDictionaryWriter
Visual Basic (Usage) Copy Code
Dim value As XmlFastInfosetDictionaryWriter

value = XmlFastInfosetDictionaryWriter.Create()
C#
public static XmlFastInfosetDictionaryWriter Create()
Delphi
public function Create(): XmlFastInfosetDictionaryWriter; static;
JScript
public static function Create() : XmlFastInfosetDictionaryWriter;
Managed Extensions for C++
public: static XmlFastInfosetDictionaryWriter* Create();
C++/CLI
public:
static XmlFastInfosetDictionaryWriter^ Create();

Return Value

An instance of XmlFastInfosetDictionaryWriter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Create(Stream) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > Create Method : Create(Stream) Method

output

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal output As Stream _
) As XmlFastInfosetDictionaryWriter
Visual Basic (Usage) Copy Code
Dim output As Stream
Dim value As XmlFastInfosetDictionaryWriter

value = XmlFastInfosetDictionaryWriter.Create(output)
C#
public static XmlFastInfosetDictionaryWriter Create(
   Stream output
)
Delphi
public function Create(
    output: Stream
): XmlFastInfosetDictionaryWriter; static;
JScript
public static function Create(
   output : Stream
) : XmlFastInfosetDictionaryWriter;
Managed Extensions for C++
public: static XmlFastInfosetDictionaryWriter* Create(
   Stream* output
)
C++/CLI
public:
static XmlFastInfosetDictionaryWriter^ Create(
   Stream^ output
)

Parameters

output

Return Value

An instance of XmlFastInfosetDictionaryWriter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Flush Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Flush Method

Flushes whatever is in the buffer into the underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in Flush


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Init Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Init Method

output
The stream to which you want to write.
Initializes an instance of XmlFastInfosetDictionaryWriter preparing to write into the specified stream.

Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal output As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim output As Stream

instance.Init(output)
C#
public void Init(
   Stream output
)
Delphi
public procedure Init(
    output: Stream
);
JScript
public function Init(
   output : Stream
);
Managed Extensions for C++
public: void Init(
   Stream* output
)
C++/CLI
public:
void Init(
   Stream^ output
)

Parameters

output
The stream to which you want to write.

Remarks

Initialize the writer and sets it to use provided stream as output.

This method allows to reuse existing XmlFastInfosetDictionaryWriter instance for writing into another stream.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LookupPrefix Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : LookupPrefix Method

ns

The namespace URI whose prefix you want to find.

Returns the closest prefix defined in the current namespace scope for the namespace URI

Syntax

Visual Basic (Declaration)
Public Overrides Function LookupPrefix( _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim ns As String
Dim value As String

value = instance.LookupPrefix(ns)
C#
public override string LookupPrefix(
   string ns
)
Delphi
public function LookupPrefix(
    ns: String
): String; override;
JScript
public override function LookupPrefix(
   ns : String
) : String;
Managed Extensions for C++
public: string* LookupPrefix(
   string* ns
) override
C++/CLI
public:
String^ LookupPrefix(
   String^ ns
) override

Parameters

ns

The namespace URI whose prefix you want to find.

Return Value

The matching prefix or a null reference (Nothing in Visual Basic) if no matching namespace URI is found in the current scope.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in LookupPrefix


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetVocabulary Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : SetVocabulary Method

vocabulary
The vocabulary to use.
Sets the vocabulary to be used when writing a Fast Infoset document.

Syntax

Visual Basic (Declaration)
Public Sub SetVocabulary( _
   ByVal vocabulary As WriterVocabulary _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim vocabulary As WriterVocabulary

instance.SetVocabulary(vocabulary)
C#
public void SetVocabulary(
   WriterVocabulary vocabulary
)
Delphi
public procedure SetVocabulary(
    vocabulary: WriterVocabulary
);
JScript
public function SetVocabulary(
   vocabulary : WriterVocabulary
);
Managed Extensions for C++
public: void SetVocabulary(
   WriterVocabulary* vocabulary
)
C++/CLI
public:
void SetVocabulary(
   WriterVocabulary^ vocabulary
)

Parameters

vocabulary
The vocabulary to use.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributes Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteAttributes Method

reader
The reader to read attributes from.
defattr
If set to true default attributes will also be written.
Reads attributes from the reader and writes them out into current start element node.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteAttributes( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteAttributes(reader, defattr)
C#
public override void WriteAttributes(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteAttributes(
    reader: XmlReader;
    defattr: Boolean
); override;
JScript
public override function WriteAttributes(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteAttributes(
   XmlReader* reader,
   bool defattr
) override
C++/CLI
public:
void WriteAttributes(
   XmlReader^ reader,
   bool defattr
) override

Parameters

reader
The reader to read attributes from.
defattr
If set to true default attributes will also be written.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteAttributes


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteBase64 Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteBase64 Method

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.
Encodes the binary bytes using Fast Infoset's binary encoding of Base64 values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteBase64( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBase64(buffer, index, count)
C#
public override void WriteBase64(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBase64(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBase64(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBase64(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBase64(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position within the buffer indicating the start of the bytes to write.
count
The number of bytes to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteBase64


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteBinHex Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteBinHex Method

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

Encodes the binary bytes using Fast Infoset's binary encoding of hexadecimal values and writes the result at the current position in the content.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteBinHex( _
   ByVal buffer() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim buffer() As Byte
Dim index As Integer
Dim count As Integer

instance.WriteBinHex(buffer, index, count)
C#
public override void WriteBinHex(
   byte[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteBinHex(
    buffer: Bytearray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteBinHex(
   buffer : byte[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteBinHex(
   byte[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteBinHex(
   array<byte>^ buffer,
   int index,
   int count
) override

Parameters

buffer
the byte array to encode.
index
The position in the buffer indicating the start of the bytes to write.
count

The number of bytes to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteBinHex


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteCData Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteCData Method

text

The text to place inside the CDATA block.

Writes out a <![CDATA[...]]> block containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteCData( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim text As String

instance.WriteCData(text)
C#
public override void WriteCData(
   string text
)
Delphi
public procedure WriteCData(
    text: String
); override;
JScript
public override function WriteCData(
   text : String
);
Managed Extensions for C++
public: void WriteCData(
   string* text
) override
C++/CLI
public:
void WriteCData(
   String^ text
) override

Parameters

text

The text to place inside the CDATA block.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteCData


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteCharEntity Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteCharEntity Method

ch

The Unicode character for which to generate a character entity.

Forces the generation of a character entity for the specified Unicode character value.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteCharEntity( _
   ByVal ch As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim ch As Char

instance.WriteCharEntity(ch)
C#
public override void WriteCharEntity(
   char ch
)
Delphi
public procedure WriteCharEntity(
    ch: Char
); override;
JScript
public override function WriteCharEntity(
   ch : char
);
Managed Extensions for C++
public: void WriteCharEntity(
   char ch
) override
C++/CLI
public:
void WriteCharEntity(
   char ch
) override

Parameters

ch

The Unicode character for which to generate a character entity.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteCharEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteChars Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteChars Method

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

Writes text one buffer at a time.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteChars( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteChars(buffer, index, count)
C#
public override void WriteChars(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteChars(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteChars(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteChars(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteChars(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer
The character array containing the text to write.
index

The position in the buffer indicating the start of the text to write.

count

The number of characters to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteChars


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteComment Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteComment Method

text

The text to place inside the comment.

Writes out a comment containing the specified text.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteComment( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim text As String

instance.WriteComment(text)
C#
public override void WriteComment(
   string text
)
Delphi
public procedure WriteComment(
    text: String
); override;
JScript
public override function WriteComment(
   text : String
);
Managed Extensions for C++
public: void WriteComment(
   string* text
) override
C++/CLI
public:
void WriteComment(
   String^ text
) override

Parameters

text

The text to place inside the comment.

Remarks

If the text is a null reference (Nothing in Visual Basic) or String.Empty, this method does not write anything.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteComment


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteDocType Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteDocType Method

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteDocType( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal sysid As String, _
   ByVal subset As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim name As String
Dim pubid As String
Dim sysid As String
Dim subset As String

instance.WriteDocType(name, pubid, sysid, subset)
C#
public override void WriteDocType(
   string name,
   string pubid,
   string sysid,
   string subset
)
Delphi
public procedure WriteDocType(
    name: String;
    pubid: String;
    sysid: String;
    subset: String
); override;
JScript
public override function WriteDocType(
   name : String,
   pubid : String,
   sysid : String,
   subset : String
);
Managed Extensions for C++
public: void WriteDocType(
   string* name,
   string* pubid,
   string* sysid,
   string* subset
) override
C++/CLI
public:
void WriteDocType(
   String^ name,
   String^ pubid,
   String^ sysid,
   String^ subset
) override

Parameters

name
The name of the DOCTYPE. This must be non-empty.
pubid
If non-null it also writes PUBLIC "pubid" "sysid" where pubid and sysid are replaced with the value of the given arguments.
sysid
If pubid is a null reference (Nothing in Visual Basic) and sysid is non-null it writes SYSTEM "sysid" where sysid is replaced with the value of this argument.
subset

If non-null it writes [subset] where subset is replaced with the value of this argument.

Remarks

Writing DOCTYPE is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteDocType


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteEndAttribute Method

Closes the previous WriteStartAttribute call.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndAttribute()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.WriteEndAttribute()
C#
public override void WriteEndAttribute()
Delphi
public procedure WriteEndAttribute(); override;
JScript
public override function WriteEndAttribute();
Managed Extensions for C++
public: void WriteEndAttribute(); override
C++/CLI
public:
void WriteEndAttribute(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteEndAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndDocument Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteEndDocument Method

Closes any open elements or attributes and changes the WriteState to Start.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.WriteEndDocument()
C#
public override void WriteEndDocument()
Delphi
public procedure WriteEndDocument(); override;
JScript
public override function WriteEndDocument();
Managed Extensions for C++
public: void WriteEndDocument(); override
C++/CLI
public:
void WriteEndDocument(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteEndDocument


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEndElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.WriteEndElement()
C#
public override void WriteEndElement()
Delphi
public procedure WriteEndElement(); override;
JScript
public override function WriteEndElement();
Managed Extensions for C++
public: void WriteEndElement(); override
C++/CLI
public:
void WriteEndElement(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteEntityRef Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteEntityRef Method

name

The name of the entity reference.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteEntityRef( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim name As String

instance.WriteEntityRef(name)
C#
public override void WriteEntityRef(
   string name
)
Delphi
public procedure WriteEntityRef(
    name: String
); override;
JScript
public override function WriteEntityRef(
   name : String
);
Managed Extensions for C++
public: void WriteEntityRef(
   string* name
) override
C++/CLI
public:
void WriteEntityRef(
   String^ name
) override

Parameters

name

The name of the entity reference.

Remarks

Writing of entity references is presently not supported by XmlFastInfosetWriter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteEntityRef


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteFullEndElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteFullEndElement Method

Closes one element and pops the corresponding namespace scope.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteFullEndElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.WriteFullEndElement()
C#
public override void WriteFullEndElement()
Delphi
public procedure WriteFullEndElement(); override;
JScript
public override function WriteFullEndElement();
Managed Extensions for C++
public: void WriteFullEndElement(); override
C++/CLI
public:
void WriteFullEndElement(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteFullEndElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteNode Method

Overload List

Overload | Description
WriteNode(XmlReader,Boolean) |
WriteNode(XmlDictionaryReader,Boolean) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteNode(XPathNavigator,Boolean) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteNode


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode(XmlReader,Boolean) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteNode Method : WriteNode(XmlReader,Boolean) Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteNode( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteNode(reader, defattr)
C#
public override void WriteNode(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteNode(
    reader: XmlReader;
    defattr: Boolean
); override;
JScript
public override function WriteNode(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteNode(
   XmlReader* reader,
   bool defattr
) override
C++/CLI
public:
void WriteNode(
   XmlReader^ reader,
   bool defattr
) override

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteNode(XmlReader,Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteProcessingInstruction Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteProcessingInstruction Method

name
The name of the processing instruction.
text

The text to include in the processing instruction.

Writes out a processing instruction.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteProcessingInstruction( _
   ByVal name As String, _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim name As String
Dim text As String

instance.WriteProcessingInstruction(name, text)
C#
public override void WriteProcessingInstruction(
   string name,
   string text
)
Delphi
public procedure WriteProcessingInstruction(
    name: String;
    text: String
); override;
JScript
public override function WriteProcessingInstruction(
   name : String,
   text : String
);
Managed Extensions for C++
public: void WriteProcessingInstruction(
   string* name,
   string* text
) override
C++/CLI
public:
void WriteProcessingInstruction(
   String^ name,
   String^ text
) override

Parameters

name
The name of the processing instruction.
text

The text to include in the processing instruction.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteProcessingInstruction


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteRaw Method

This method is not supported.

Overload List

Overload | Description
WriteRaw(String) | This method is not supported.
WriteRaw(Char[],Int32,Int32) | This method is not supported.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteRaw


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteRaw Method : WriteRaw(String) Method

data

The string containing the text to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteRaw( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim data As String

instance.WriteRaw(data)
C#
public override void WriteRaw(
   string data
)
Delphi
public procedure WriteRaw(
    data: String
); override;
JScript
public override function WriteRaw(
   data : String
);
Managed Extensions for C++
public: void WriteRaw(
   string* data
) override
C++/CLI
public:
void WriteRaw(
   String^ data
) override

Parameters

data

The string containing the text to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteRaw(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteRaw(Char[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteRaw Method : WriteRaw(Char[],Int32,Int32) Method

buffer

The buffer containing characters to write.

index

The index of the first character to write.

count

The number of characters to write.

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteRaw( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim buffer() As Char
Dim index As Integer
Dim count As Integer

instance.WriteRaw(buffer, index, count)
C#
public override void WriteRaw(
   char[] buffer,
   int index,
   int count
)
Delphi
public procedure WriteRaw(
    buffer: Chararray of;
    index: Integer;
    count: Integer
); override;
JScript
public override function WriteRaw(
   buffer : char[],
   index : int,
   count : int
);
Managed Extensions for C++
public: void WriteRaw(
   char[]* buffer,
   int index,
   int count
) override
C++/CLI
public:
void WriteRaw(
   array<char>^ buffer,
   int index,
   int count
) override

Parameters

buffer

The buffer containing characters to write.

index

The index of the first character to write.

count

The number of characters to write.

Remarks

Writing raw XML text is not supported by the Fast Infoset standard. This method works the same way as WriteString.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteRaw(Char[],Int32,Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteStartAttribute Method

Writes the start of an attribute.

Overload List

Overload | Description
WriteStartAttribute(String,String,String) | Writes the start of an attribute.
WriteStartAttribute(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteStartAttribute(String,XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteStartAttribute(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartAttribute(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteStartAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String,String) Method

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

Writes the start of an attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartAttribute( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(prefix, localName, ns)
C#
public override void WriteStartAttribute(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartAttribute(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartAttribute(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartAttribute(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the attribute.
localName
The local name of the attribute.
ns

The namespace URI for the attribute.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteStartAttribute(String,String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteStartDocument Method

Writes the XML declaration with the version "1.0".

Overload List

Overload | Description
WriteStartDocument(Boolean) | Writes the XML declaration with the version "1.0".
WriteStartDocument() | Writes the XML declaration with the version "1.0".

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteStartDocument


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument(Boolean) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartDocument Method : WriteStartDocument(Boolean) Method

standalone
Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartDocument( _
   ByVal standalone As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim standalone As Boolean

instance.WriteStartDocument(standalone)
C#
public override void WriteStartDocument(
   bool standalone
)
Delphi
public procedure WriteStartDocument(
    standalone: Boolean
); override;
JScript
public override function WriteStartDocument(
   standalone : boolean
);
Managed Extensions for C++
public: void WriteStartDocument(
   bool standalone
) override
C++/CLI
public:
void WriteStartDocument(
   bool standalone
) override

Parameters

standalone

Remarks

Since XmlFastInfosetWriter does not preserve the original XML declaration, standalone is ignored.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteStartDocument(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartDocument() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartDocument Method : WriteStartDocument() Method

Writes the XML declaration with the version "1.0".

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartDocument()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.WriteStartDocument()
C#
public override void WriteStartDocument()
Delphi
public procedure WriteStartDocument(); override;
JScript
public override function WriteStartDocument();
Managed Extensions for C++
public: void WriteStartDocument(); override
C++/CLI
public:
void WriteStartDocument(); override

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteStartDocument()


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteStartElement Method

Writes the specified start tag.

Overload List

Overload | Description
WriteStartElement(String,String,String) | Writes the specified start tag.
WriteStartElement(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteStartElement(String,XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteStartElement(String,String) | (Inherited from System.Xml.XmlWriter)
WriteStartElement(String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteStartElement


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartElement Method : WriteStartElement(String,String,String) Method

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.
Writes the specified start tag.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteStartElement( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim ns As String

instance.WriteStartElement(prefix, localName, ns)
C#
public override void WriteStartElement(
   string prefix,
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    prefix: String;
    localName: String;
    ns: String
); override;
JScript
public override function WriteStartElement(
   prefix : String,
   localName : String,
   ns : String
);
Managed Extensions for C++
public: void WriteStartElement(
   string* prefix,
   string* localName,
   string* ns
) override
C++/CLI
public:
void WriteStartElement(
   String^ prefix,
   String^ localName,
   String^ ns
) override

Parameters

prefix
The namespace prefix of the element.
localName
The local name of the element.
ns
The namespace URI to associate with the element.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteStartElement(String,String,String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteString Method

Writes the given text content.

Overload List

Overload | Description
WriteString(String) | Writes the given text content.
WriteString(XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteString(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteString Method : WriteString(String) Method

text

The text to write.

Writes the given text content.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteString( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim text As String

instance.WriteString(text)
C#
public override void WriteString(
   string text
)
Delphi
public procedure WriteString(
    text: String
); override;
JScript
public override function WriteString(
   text : String
);
Managed Extensions for C++
public: void WriteString(
   string* text
) override
C++/CLI
public:
void WriteString(
   String^ text
) override

Parameters

text

The text to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteString


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteSurrogateCharEntity Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteSurrogateCharEntity Method

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

Writes a Unicode surrogate char pair.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteSurrogateCharEntity( _
   ByVal lowChar As Char, _
   ByVal highChar As Char _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim lowChar As Char
Dim highChar As Char

instance.WriteSurrogateCharEntity(lowChar, highChar)
C#
public override void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
)
Delphi
public procedure WriteSurrogateCharEntity(
    lowChar: Char;
    highChar: Char
); override;
JScript
public override function WriteSurrogateCharEntity(
   lowChar : char,
   highChar : char
);
Managed Extensions for C++
public: void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override
C++/CLI
public:
void WriteSurrogateCharEntity(
   char lowChar,
   char highChar
) override

Parameters

lowChar

The low surrogate. This must be a value between 0xDC00 and 0xDFFF.

highChar

The high surrogate. This must be a value between 0xD800 and 0xDBFF.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteSurrogateCharEntity


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteValue Method

Writes the value.

Overload List

Overload | Description
WriteValue(Object) | Writes the value.
WriteValue(Boolean) | Writes a boolean value.
WriteValue(Double) | Writes a double-precision floating point value.
WriteValue(Single) | Writes a single-precision floating point value.
WriteValue(Int32) | Writes a 32-bit signed integer.
WriteValue(Int64) | Writes a 64-bit signed integer value.
WriteValue(DateTime) | Write DateTime value.
WriteValue(Decimal) | Write Decimal value.
WriteValue(String) | Writes the string value.
WriteValue(TimeSpan) | Write TimeSpan value.
WriteValue(XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteValue(IStreamProvider) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteValue(UniqueId) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteValue(Guid) | (Inherited from System.Xml.XmlDictionaryWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteValue


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Object) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Object) Method

value
The object representing the value to write.

Writes the value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Object

instance.WriteValue(value)
C#
public override void WriteValue(
   object value
)
Delphi
public procedure WriteValue(
    value: TObject
); override;
JScript
public override function WriteValue(
   value : Object
);
Managed Extensions for C++
public: void WriteValue(
   Object* value
) override
C++/CLI
public:
void WriteValue(
   Object^ value
) override

Parameters

value
The object representing the value to write.

Remarks

This method takes the common language runtime (CLR) object and converts the input value to the desired output type using the FastInfoset encoding rules. If the type cannot not be represented as a binary encoded value it's serialized as a string according to the XML Schema definition language (XSD) data type conversion rules.

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Object)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Boolean) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Boolean) Method

value

The boolean value to write.

Writes a boolean value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Boolean

instance.WriteValue(value)
C#
public override void WriteValue(
   bool value
)
Delphi
public procedure WriteValue(
    value: Boolean
); override;
JScript
public override function WriteValue(
   value : boolean
);
Managed Extensions for C++
public: void WriteValue(
   bool value
) override
C++/CLI
public:
void WriteValue(
   bool value
) override

Parameters

value

The boolean value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Boolean)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Double) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Double) Method

value

The double-precision floating-point value to write.

Writes a double-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Double

instance.WriteValue(value)
C#
public override void WriteValue(
   double value
)
Delphi
public procedure WriteValue(
    value: Double
); override;
JScript
public override function WriteValue(
   value : double
);
Managed Extensions for C++
public: void WriteValue(
   double value
) override
C++/CLI
public:
void WriteValue(
   double value
) override

Parameters

value

The double-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Double)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Single) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Single) Method

value

The single-precision floating-point value to write.

Writes a single-precision floating point value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Single _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Single

instance.WriteValue(value)
C#
public override void WriteValue(
   float value
)
Delphi
public procedure WriteValue(
    value: Single
); override;
JScript
public override function WriteValue(
   value : float
);
Managed Extensions for C++
public: void WriteValue(
   float value
) override
C++/CLI
public:
void WriteValue(
   float value
) override

Parameters

value

The single-precision floating-point value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Single)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Int32) Method

value

The 32-bit signed integer value to write.

Writes a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Integer

instance.WriteValue(value)
C#
public override void WriteValue(
   int value
)
Delphi
public procedure WriteValue(
    value: Integer
); override;
JScript
public override function WriteValue(
   value : int
);
Managed Extensions for C++
public: void WriteValue(
   int value
) override
C++/CLI
public:
void WriteValue(
   int value
) override

Parameters

value

The 32-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Int32)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Int64) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Int64) Method

value

The 64-bit signed integer value to write.

Writes a 64-bit signed integer value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Long

instance.WriteValue(value)
C#
public override void WriteValue(
   long value
)
Delphi
public procedure WriteValue(
    value: Int64
); override;
JScript
public override function WriteValue(
   value : long
);
Managed Extensions for C++
public: void WriteValue(
   long value
) override
C++/CLI
public:
void WriteValue(
   int64 value
) override

Parameters

value

The 64-bit signed integer value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Int64)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(DateTime) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(DateTime) Method

value
DateTime value to writer.
Write DateTime value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Date _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Date

instance.WriteValue(value)
C#
public override void WriteValue(
   DateTime value
)
Delphi
public procedure WriteValue(
    value: DateTime
); override;
JScript
public override function WriteValue(
   value : DateTime
);
Managed Extensions for C++
public: void WriteValue(
   DateTime value
) override
C++/CLI
public:
void WriteValue(
   DateTime value
) override

Parameters

value
DateTime value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(DateTime)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Decimal) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Decimal) Method

value
Decimal value to writer.
Write Decimal value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As Decimal _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Decimal

instance.WriteValue(value)
C#
public override void WriteValue(
   decimal value
)
Delphi
public procedure WriteValue(
    value: Currency
); override;
JScript
public override function WriteValue(
   value : decimal
);
Managed Extensions for C++
public: void WriteValue(
   decimal value
) override
C++/CLI
public:
void WriteValue(
   decimal value
) override

Parameters

value
Decimal value to writer.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(Decimal)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(String) Method

value

The string value to write.

Writes the string value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As String

instance.WriteValue(value)
C#
public override void WriteValue(
   string value
)
Delphi
public procedure WriteValue(
    value: String
); override;
JScript
public override function WriteValue(
   value : String
);
Managed Extensions for C++
public: void WriteValue(
   string* value
) override
C++/CLI
public:
void WriteValue(
   String^ value
) override

Parameters

value

The string value to write.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(String)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(TimeSpan) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(TimeSpan) Method

value
TimeSpan value to write.
Write TimeSpan value.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteValue( _
   ByVal value As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As TimeSpan

instance.WriteValue(value)
C#
public override void WriteValue(
   TimeSpan value
)
Delphi
public procedure WriteValue(
    value: TimeSpan
); override;
JScript
public override function WriteValue(
   value : TimeSpan
);
Managed Extensions for C++
public: void WriteValue(
   TimeSpan value
) override
C++/CLI
public:
void WriteValue(
   TimeSpan value
) override

Parameters

value
TimeSpan value to write.

Remarks

If WriteValue is called multiple times in succession, values are written one next to the other without being delimited by white space. To write a list of values, call the WriteValue(Object) method using an array of values as parameter.

Values are encoded according to the Profile settings.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteValue(TimeSpan)


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteWhitespace Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteWhitespace Method

ws

The string of white space characters.

Writes out the given white space.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteWhitespace( _
   ByVal ws As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim ws As String

instance.WriteWhitespace(ws)
C#
public override void WriteWhitespace(
   string ws
)
Delphi
public procedure WriteWhitespace(
    ws: String
); override;
JScript
public override function WriteWhitespace(
   ws : String
);
Managed Extensions for C++
public: void WriteWhitespace(
   string* ws
) override
C++/CLI
public:
void WriteWhitespace(
   String^ ws
) override

Parameters

ws

The string of white space characters.

Remarks

XmlFastInfosetWriter does not preserve non-significant white space unless it's written within the scope of the element with the xml:space attribute set to "true" (xml:space="true").

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteWhitespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlnsAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteXmlnsAttribute Method

Writes a namespace declaration attribute.

Overload List

Overload | Description
WriteXmlnsAttribute(String,String) | Writes a namespace declaration attribute.
WriteXmlnsAttribute(String,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteXmlnsAttribute


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlnsAttribute(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteXmlnsAttribute Method : WriteXmlnsAttribute(String,String) Method

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.
Writes a namespace declaration attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub WriteXmlnsAttribute( _
   ByVal prefix As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim namespaceUri As String

instance.WriteXmlnsAttribute(prefix, namespaceUri)
C#
public override void WriteXmlnsAttribute(
   string prefix,
   string namespaceUri
)
Delphi
public procedure WriteXmlnsAttribute(
    prefix: String;
    namespaceUri: String
); override;
JScript
public override function WriteXmlnsAttribute(
   prefix : String,
   namespaceUri : String
);
Managed Extensions for C++
public: void WriteXmlnsAttribute(
   string* prefix,
   string* namespaceUri
) override
C++/CLI
public:
void WriteXmlnsAttribute(
   String^ prefix,
   String^ namespaceUri
) override

Parameters

prefix
The prefix that is bound to the given namespace.
namespaceUri
The namespace to which the prefix is bound.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List
Base Implementation in WriteXmlnsAttribute(String,String)


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
XmlFastInfosetDictionaryWriter Class Properties
See Also Send Feedback
Noemax.Xml Namespace : XmlFastInfosetDictionaryWriter Class

For a list of all members of this type, see XmlFastInfosetDictionaryWriter members.

Public Properties

 | Name | Description
public Property | CanCanonicalize | (Inherited from System.Xml.XmlDictionaryWriter)
public Property | MaxVocabularyStringIndex | Gets and sets the maximum number of strings that may be added to the vocabulary.
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.
public Property | Profile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.
public Property | Settings | Overridden. Gets the XmlWriterSettings object used to create this XmlWriter instance.
public Property | WriteState | Overridden. Gets the state of the writer.
public Property | XmlLang | Overridden. Current xml:lang value in scope.
public Property | XmlSpace | Overridden. Current xml:space value in scope.
Top

See Also

Reference

XmlFastInfosetDictionaryWriter Class
Noemax.Xml Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringIndex Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : MaxVocabularyStringIndex Property

Gets and sets the maximum number of strings that may be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Integer

instance.MaxVocabularyStringIndex = value

value = instance.MaxVocabularyStringIndex
C#
public int MaxVocabularyStringIndex {get; set;}
Delphi
public read-write property MaxVocabularyStringIndex: Integer;
JScript
public function get,set MaxVocabularyStringIndex : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringIndex();
public: __property void set_MaxVocabularyStringIndex(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringIndex {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum number of strings specifies up to how many strings may be added to the vocabulary. When this limit is reached, no more values are added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxVocabularyStringLength Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : MaxVocabularyStringLength Property

Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary.

Syntax

Visual Basic (Declaration)
Public Property MaxVocabularyStringLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Integer

instance.MaxVocabularyStringLength = value

value = instance.MaxVocabularyStringLength
C#
public int MaxVocabularyStringLength {get; set;}
Delphi
public read-write property MaxVocabularyStringLength: Integer;
JScript
public function get,set MaxVocabularyStringLength : int
Managed Extensions for C++
public: __property int get_MaxVocabularyStringLength();
public: __property void set_MaxVocabularyStringLength(
   int value
);
C++/CLI
public:
property int MaxVocabularyStringLength {
   int get();
   void set (    int value);
}

Remarks

The vocabulary is used by Fast Infoset to reduce redundancy and increase compactness. All occurrences of values added to the vocabulary are removed from the document and replaced by an index to the corresponding entry in the vocabulary.

The maximum string length specifies the maximum number of characters that a string value may contain in order to be added to the vocabulary. Longer values are not added to the vocabulary. A higher limit might result in higher compactness but might also result in higher resource consumption than a lower limit.

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Profile Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Profile Property

XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized.

Syntax

Visual Basic (Declaration)
Public Property Profile As XmlFastInfosetWriterProfile
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As XmlFastInfosetWriterProfile

instance.Profile = value

value = instance.Profile
C#
public XmlFastInfosetWriterProfile Profile {get; set;}
Delphi
public read-write property Profile: XmlFastInfosetWriterProfile;
JScript
public function get,set Profile : XmlFastInfosetWriterProfile
Managed Extensions for C++
public: __property XmlFastInfosetWriterProfile* get_Profile();
public: __property void set_Profile(
   XmlFastInfosetWriterProfile* value
);
C++/CLI
public:
property XmlFastInfosetWriterProfile^ Profile {
   XmlFastInfosetWriterProfile^ get();
   void set (    XmlFastInfosetWriterProfile^ value);
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Settings Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Settings Property

Gets the XmlWriterSettings object used to create this XmlWriter instance.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Settings As XmlWriterSettings
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As XmlWriterSettings

value = instance.Settings
C#
public override XmlWriterSettings Settings {get;}
Delphi
public read-only property Settings: XmlWriterSettings; override;
JScript
public override function get Settings : XmlWriterSettings
Managed Extensions for C++
public: __property XmlWriterSettings* get_Settings() override;
C++/CLI
public:
property XmlWriterSettings^ Settings {
   XmlWriterSettings^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in Settings


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteState Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteState Property

Gets the state of the writer.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property WriteState As WriteState
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As WriteState

value = instance.WriteState
C#
public override WriteState WriteState {get;}
Delphi
public read-only property WriteState: WriteState; override;
JScript
public override function get WriteState : WriteState
Managed Extensions for C++
public: __property WriteState get_WriteState() override;
C++/CLI
public:
property WriteState WriteState {
   WriteState get() override;
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in WriteState


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlLang Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : XmlLang Property

Current xml:lang value in scope.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As String

value = instance.XmlLang
C#
public override string XmlLang {get;}
Delphi
public read-only property XmlLang: String; override;
JScript
public override function get XmlLang : String
Managed Extensions for C++
public: __property string* get_XmlLang() override;
C++/CLI
public:
property String^ XmlLang {
   String^ get() override;
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in XmlLang


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlSpace Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : XmlSpace Property

Current xml:space value in scope.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As XmlSpace

value = instance.XmlSpace
C#
public override XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace; override;
JScript
public override function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property XmlSpace get_XmlSpace() override;
C++/CLI
public:
property XmlSpace XmlSpace {
   XmlSpace get() override;
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Base Implementation in XmlSpace


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ReaderVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : ReaderVocabulary Class

For a list of all members of this type, see ReaderVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

See Also

Reference

ReaderVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SchemaVocabulary Class Properties
See Also Send Feedback
Noemax.FastInfoset Namespace : SchemaVocabulary Class

For a list of all members of this type, see SchemaVocabulary members.

Public Properties

 | Name | Description
public Property | ExternalVocabularyURI | Specifies the URI to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasExternalVocabulary | Specifies whether this vocabulary is linked to an external vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
public Property | HasInitialVocabulary | Specifies whether this vocabulary uses initial read-only vocabulary. (Inherited from Noemax.FastInfoset.Vocabulary)
Top

See Also

Reference

SchemaVocabulary Class
Noemax.FastInfoset Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanReadValueChunk Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : CanReadValueChunk Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CanReadValueChunk As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.CanReadValueChunk
C#
public bool CanReadValueChunk {get;}
Delphi
public read-only property CanReadValueChunk: Boolean;
JScript
public function get CanReadValueChunk : boolean
Managed Extensions for C++
public: __property bool get_CanReadValueChunk();
C++/CLI
public:
property bool CanReadValueChunk {
   bool get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasAttributes Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : HasAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasAttributes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Boolean

value = instance.HasAttributes
C#
public bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: Boolean;
JScript
public function get HasAttributes : boolean
Managed Extensions for C++
public: __property bool get_HasAttributes();
C++/CLI
public:
property bool HasAttributes {
   bool get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAs Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAs Method

returnType
namespaceResolver

Syntax

Visual Basic (Declaration)
Public Function ReadContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadContentAs(returnType, namespaceResolver)
C#
public object ReadContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject;
JScript
public function ReadContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver
)
C++/CLI
public:
Object^ ReadContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver
)

Parameters

returnType
namespaceResolver

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsObject Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadContentAsObject Method

Syntax

Visual Basic (Declaration)
Public Function ReadContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Object

value = instance.ReadContentAsObject()
C#
public object ReadContentAsObject()
Delphi
public function ReadContentAsObject(): TObject;
JScript
public function ReadContentAsObject() : Object;
Managed Extensions for C++
public: Object* ReadContentAsObject();
C++/CLI
public:
Object^ ReadContentAsObject();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAs Method

Overload List

Overload | Description
ReadElementContentAs(Type,IXmlNamespaceResolver) | (Inherited from System.Xml.XmlReader)
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs(Type,IXmlNamespaceResolver) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver) Method

returnType
namespaceResolver

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver)
C#
public object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver
): TObject;
JScript
public function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver
)
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver
)

Parameters

returnType
namespaceResolver

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAs Method : ReadElementContentAs(Type,IXmlNamespaceResolver,String,String) Method

returnType
namespaceResolver
localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAs( _
   ByVal returnType As Type, _
   ByVal namespaceResolver As IXmlNamespaceResolver, _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim returnType As Type
Dim namespaceResolver As IXmlNamespaceResolver
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAs(returnType, namespaceResolver, localName, namespaceURI)
C#
public object ReadElementContentAs(
   Type returnType,
   IXmlNamespaceResolver namespaceResolver,
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAs(
    returnType: Type;
    namespaceResolver: IXmlNamespaceResolver;
    localName: String;
    namespaceURI: String
): TObject;
JScript
public function ReadElementContentAs(
   returnType : Type,
   namespaceResolver : IXmlNamespaceResolver,
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAs(
   Type* returnType,
   IXmlNamespaceResolver* namespaceResolver,
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
Object^ ReadElementContentAs(
   Type^ returnType,
   IXmlNamespaceResolver^ namespaceResolver,
   String^ localName,
   String^ namespaceURI
)

Parameters

returnType
namespaceResolver
localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsBoolean(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsBoolean Method : ReadElementContentAsBoolean(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsBoolean( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadElementContentAsBoolean(localName, namespaceURI)
C#
public bool ReadElementContentAsBoolean(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsBoolean(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadElementContentAsBoolean(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadElementContentAsBoolean(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadElementContentAsBoolean(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDateTime(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDateTime Method : ReadElementContentAsDateTime(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDateTime( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Date
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Date

value = instance.ReadElementContentAsDateTime(localName, namespaceURI)
C#
public DateTime ReadElementContentAsDateTime(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDateTime(
    localName: String;
    namespaceURI: String
): DateTime;
JScript
public function ReadElementContentAsDateTime(
   localName : String,
   namespaceURI : String
) : DateTime;
Managed Extensions for C++
public: DateTime ReadElementContentAsDateTime(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
DateTime ReadElementContentAsDateTime(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDecimal(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDecimal Method : ReadElementContentAsDecimal(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDecimal( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Decimal
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Decimal

value = instance.ReadElementContentAsDecimal(localName, namespaceURI)
C#
public decimal ReadElementContentAsDecimal(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDecimal(
    localName: String;
    namespaceURI: String
): Currency;
JScript
public function ReadElementContentAsDecimal(
   localName : String,
   namespaceURI : String
) : decimal;
Managed Extensions for C++
public: decimal ReadElementContentAsDecimal(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
decimal ReadElementContentAsDecimal(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsDouble(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsDouble Method : ReadElementContentAsDouble(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsDouble( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Double

value = instance.ReadElementContentAsDouble(localName, namespaceURI)
C#
public double ReadElementContentAsDouble(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsDouble(
    localName: String;
    namespaceURI: String
): Double;
JScript
public function ReadElementContentAsDouble(
   localName : String,
   namespaceURI : String
) : double;
Managed Extensions for C++
public: double ReadElementContentAsDouble(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
double ReadElementContentAsDouble(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsFloat(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsFloat Method : ReadElementContentAsFloat(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsFloat( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Single
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Single

value = instance.ReadElementContentAsFloat(localName, namespaceURI)
C#
public float ReadElementContentAsFloat(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsFloat(
    localName: String;
    namespaceURI: String
): Single;
JScript
public function ReadElementContentAsFloat(
   localName : String,
   namespaceURI : String
) : float;
Managed Extensions for C++
public: float ReadElementContentAsFloat(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
float ReadElementContentAsFloat(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsInt(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsInt Method : ReadElementContentAsInt(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsInt( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Integer

value = instance.ReadElementContentAsInt(localName, namespaceURI)
C#
public int ReadElementContentAsInt(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsInt(
    localName: String;
    namespaceURI: String
): Integer;
JScript
public function ReadElementContentAsInt(
   localName : String,
   namespaceURI : String
) : int;
Managed Extensions for C++
public: int ReadElementContentAsInt(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
int ReadElementContentAsInt(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsLong(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsLong Method : ReadElementContentAsLong(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsLong( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Long

value = instance.ReadElementContentAsLong(localName, namespaceURI)
C#
public long ReadElementContentAsLong(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsLong(
    localName: String;
    namespaceURI: String
): Int64;
JScript
public function ReadElementContentAsLong(
   localName : String,
   namespaceURI : String
) : long;
Managed Extensions for C++
public: long ReadElementContentAsLong(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
int64 ReadElementContentAsLong(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementContentAsObject Method

Overload List

Overload | Description
ReadElementContentAsObject() | (Inherited from System.Xml.XmlReader)
ReadElementContentAsObject(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Object

value = instance.ReadElementContentAsObject()
C#
public object ReadElementContentAsObject()
Delphi
public function ReadElementContentAsObject(): TObject;
JScript
public function ReadElementContentAsObject() : Object;
Managed Extensions for C++
public: Object* ReadElementContentAsObject();
C++/CLI
public:
Object^ ReadElementContentAsObject();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsObject( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAsObject(localName, namespaceURI)
C#
public object ReadElementContentAsObject(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsObject(
    localName: String;
    namespaceURI: String
): TObject;
JScript
public function ReadElementContentAsObject(
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: Object* ReadElementContentAsObject(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
Object^ ReadElementContentAsObject(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementContentAsString Method : ReadElementContentAsString(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementContentAsString( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As String

value = instance.ReadElementContentAsString(localName, namespaceURI)
C#
public string ReadElementContentAsString(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsString(
    localName: String;
    namespaceURI: String
): String;
JScript
public function ReadElementContentAsString(
   localName : String,
   namespaceURI : String
) : String;
Managed Extensions for C++
public: string* ReadElementContentAsString(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
String^ ReadElementContentAsString(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadElementString Method

Overload List

Overload | Description
ReadElementString() | (Inherited from System.Xml.XmlReader)
ReadElementString(String) | (Inherited from System.Xml.XmlReader)
ReadElementString(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString() Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadElementString()
C#
public string ReadElementString()
Delphi
public function ReadElementString(): String;
JScript
public function ReadElementString() : String;
Managed Extensions for C++
public: string* ReadElementString();
C++/CLI
public:
String^ ReadElementString();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As String

value = instance.ReadElementString(name)
C#
public string ReadElementString(
   string name
)
Delphi
public function ReadElementString(
    name: String
): String;
JScript
public function ReadElementString(
   name : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* name
)
C++/CLI
public:
String^ ReadElementString(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadElementString Method : ReadElementString(String,String) Method

localname
ns

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadElementString( _
   ByVal localname As String, _
   ByVal ns As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localname As String
Dim ns As String
Dim value As String

value = instance.ReadElementString(localname, ns)
C#
public string ReadElementString(
   string localname,
   string ns
)
Delphi
public function ReadElementString(
    localname: String;
    ns: String
): String;
JScript
public function ReadElementString(
   localname : String,
   ns : String
) : String;
Managed Extensions for C++
public: string* ReadElementString(
   string* localname,
   string* ns
)
C++/CLI
public:
String^ ReadElementString(
   String^ localname,
   String^ ns
)

Parameters

localname
ns

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInnerXml Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadInnerXml Method

Syntax

Visual Basic (Declaration)
Public Function ReadInnerXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadInnerXml()
C#
public string ReadInnerXml()
Delphi
public function ReadInnerXml(): String;
JScript
public function ReadInnerXml() : String;
Managed Extensions for C++
public: string* ReadInnerXml();
C++/CLI
public:
String^ ReadInnerXml();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadOuterXml Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadOuterXml Method

Syntax

Visual Basic (Declaration)
Public Function ReadOuterXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.ReadOuterXml()
C#
public string ReadOuterXml()
Delphi
public function ReadOuterXml(): String;
JScript
public function ReadOuterXml() : String;
Managed Extensions for C++
public: string* ReadOuterXml();
C++/CLI
public:
String^ ReadOuterXml();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadSubtree Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadSubtree Method

Syntax

Visual Basic (Declaration)
Public Function ReadSubtree() As XmlReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlReader

value = instance.ReadSubtree()
C#
public XmlReader ReadSubtree()
Delphi
public function ReadSubtree(): XmlReader;
JScript
public function ReadSubtree() : XmlReader;
Managed Extensions for C++
public: XmlReader* ReadSubtree();
C++/CLI
public:
XmlReader^ ReadSubtree();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToDescendant Method

Overload List

Overload | Description
ReadToDescendant(String) | (Inherited from System.Xml.XmlReader)
ReadToDescendant(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToDescendant Method : ReadToDescendant(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDescendant( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToDescendant(name)
C#
public bool ReadToDescendant(
   string name
)
Delphi
public function ReadToDescendant(
    name: String
): Boolean;
JScript
public function ReadToDescendant(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToDescendant(
   string* name
)
C++/CLI
public:
bool ReadToDescendant(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToDescendant Method : ReadToDescendant(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDescendant( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToDescendant(localName, namespaceURI)
C#
public bool ReadToDescendant(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToDescendant(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToDescendant(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToDescendant(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToDescendant(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToFollowing Method

Overload List

Overload | Description
ReadToFollowing(String) | (Inherited from System.Xml.XmlReader)
ReadToFollowing(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToFollowing Method : ReadToFollowing(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToFollowing( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToFollowing(name)
C#
public bool ReadToFollowing(
   string name
)
Delphi
public function ReadToFollowing(
    name: String
): Boolean;
JScript
public function ReadToFollowing(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToFollowing(
   string* name
)
C++/CLI
public:
bool ReadToFollowing(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToFollowing Method : ReadToFollowing(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToFollowing( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToFollowing(localName, namespaceURI)
C#
public bool ReadToFollowing(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToFollowing(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToFollowing(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToFollowing(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToFollowing(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadToNextSibling Method

Overload List

Overload | Description
ReadToNextSibling(String) | (Inherited from System.Xml.XmlReader)
ReadToNextSibling(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToNextSibling Method : ReadToNextSibling(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToNextSibling( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim name As String
Dim value As Boolean

value = instance.ReadToNextSibling(name)
C#
public bool ReadToNextSibling(
   string name
)
Delphi
public function ReadToNextSibling(
    name: String
): Boolean;
JScript
public function ReadToNextSibling(
   name : String
) : boolean;
Managed Extensions for C++
public: bool ReadToNextSibling(
   string* name
)
C++/CLI
public:
bool ReadToNextSibling(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class > ReadToNextSibling Method : ReadToNextSibling(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToNextSibling( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToNextSibling(localName, namespaceURI)
C#
public bool ReadToNextSibling(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToNextSibling(
    localName: String;
    namespaceURI: String
): Boolean;
JScript
public function ReadToNextSibling(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: bool ReadToNextSibling(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
bool ReadToNextSibling(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadValueChunk Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ReadValueChunk Method

buffer
index
count

Syntax

Visual Basic (Declaration)
Public Function ReadValueChunk( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim buffer() As Char
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadValueChunk(buffer, index, count)
C#
public int ReadValueChunk(
   char[] buffer,
   int index,
   int count
)
Delphi
public function ReadValueChunk(
    buffer: Chararray of;
    index: Integer;
    count: Integer
): Integer;
JScript
public function ReadValueChunk(
   buffer : char[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: int ReadValueChunk(
   char[]* buffer,
   int index,
   int count
)
C++/CLI
public:
int ReadValueChunk(
   array<char>^ buffer,
   int index,
   int count
)

Parameters

buffer
index
count

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SchemaInfo Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : SchemaInfo Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaInfo As IXmlSchemaInfo
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As IXmlSchemaInfo

value = instance.SchemaInfo
C#
public IXmlSchemaInfo SchemaInfo {get;}
Delphi
public read-only property SchemaInfo: IXmlSchemaInfo;
JScript
public function get SchemaInfo : IXmlSchemaInfo
Managed Extensions for C++
public: __property IXmlSchemaInfo* get_SchemaInfo();
C++/CLI
public:
property IXmlSchemaInfo^ SchemaInfo {
   IXmlSchemaInfo^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Skip Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : Skip Method

Syntax

Visual Basic (Declaration)
Public Sub Skip()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader

instance.Skip()
C#
public void Skip()
Delphi
public procedure Skip();
JScript
public function Skip();
Managed Extensions for C++
public: void Skip();
C++/CLI
public:
void Skip();

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ValueType Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As Type

value = instance.ValueType
C#
public Type ValueType {get;}
Delphi
public read-only property ValueType: Type;
JScript
public function get ValueType : Type
Managed Extensions for C++
public: __property Type* get_ValueType();
C++/CLI
public:
property Type^ ValueType {
   Type^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlLang Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlLang Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As String

value = instance.XmlLang
C#
public string XmlLang {get;}
Delphi
public read-only property XmlLang: String;
JScript
public function get XmlLang : String
Managed Extensions for C++
public: __property string* get_XmlLang();
C++/CLI
public:
property String^ XmlLang {
   String^ get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlSpace Property
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetReader Class : XmlSpace Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetReader
Dim value As XmlSpace

value = instance.XmlSpace
C#
public XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace;
JScript
public function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property XmlSpace get_XmlSpace();
C++/CLI
public:
property XmlSpace XmlSpace {
   XmlSpace get();
}

See Also

Reference

XmlFastInfosetReader Class
XmlFastInfosetReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributes Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteAttributes Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Sub WriteAttributes( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteAttributes(reader, defattr)
C#
public void WriteAttributes(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteAttributes(
    reader: XmlReader;
    defattr: Boolean
);
JScript
public function WriteAttributes(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteAttributes(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
void WriteAttributes(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteAttributeString Method

Overload List

Overload | Description
WriteAttributeString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As String

instance.WriteAttributeString(localName, value)
C#
public void WriteAttributeString(
   string localName,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    value: String
);
JScript
public function WriteAttributeString(
   localName : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* localName,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(localName, ns, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void WriteAttributeString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    ns: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function WriteAttributeString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void WriteAttributeString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void WriteAttributeString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(prefix, localName, ns, value)
C#
public void WriteAttributeString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteAttributeString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteElementString Method

Overload List

Overload | Description
WriteElementString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim value As String

instance.WriteElementString(localName, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteElementString(
   string localName,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteElementString(
   localName : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteElementString(
   string* localName,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteElementString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(localName, ns, value)
C#
public void WriteElementString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String,String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteElementString Method : WriteElementString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(prefix, localName, ns, value)
C#
public void WriteElementString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class : WriteNode Method

Overload List

Overload | Description
WriteNode(XmlReader,Boolean) | (Inherited from System.Xml.XmlWriter)
WriteNode(XPathNavigator,Boolean) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode(XmlReader,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteNode Method : WriteNode(XmlReader,Boolean) Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteNode( _
   ByVal reader As XmlReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim reader As XmlReader
Dim defattr As Boolean

instance.WriteNode(reader, defattr)
C#
public void WriteNode(
   XmlReader reader,
   bool defattr
)
Delphi
public procedure WriteNode(
    reader: XmlReader;
    defattr: Boolean
);
JScript
public function WriteNode(
   reader : XmlReader,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteNode(
   XmlReader* reader,
   bool defattr
)
C++/CLI
public:
void WriteNode(
   XmlReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode(XPathNavigator,Boolean) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteNode Method : WriteNode(XPathNavigator,Boolean) Method

navigator
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteNode( _
   ByVal navigator As XPathNavigator, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim navigator As XPathNavigator
Dim defattr As Boolean

instance.WriteNode(navigator, defattr)
C#
public void WriteNode(
   XPathNavigator navigator,
   bool defattr
)
Delphi
public procedure WriteNode(
    navigator: XPathNavigator;
    defattr: Boolean
);
JScript
public function WriteNode(
   navigator : XPathNavigator,
   defattr : boolean
);
Managed Extensions for C++
public: void WriteNode(
   XPathNavigator* navigator,
   bool defattr
)
C++/CLI
public:
void WriteNode(
   XPathNavigator^ navigator,
   bool defattr
)

Parameters

navigator
defattr

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String

instance.WriteStartAttribute(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName
)
Delphi
public procedure WriteStartAttribute(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String

instance.WriteStartElement(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName
)
Delphi
public procedure WriteStartElement(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String,String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteStartElement Method : WriteStartElement(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim localName As String
Dim ns As String

instance.WriteStartElement(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(String) Method
See Also Send Feedback
Noemax.FastInfoset Namespace > XmlFastInfosetWriter Class > WriteValue Method : WriteValue(String) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteValue( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetWriter
Dim value As String

instance.WriteValue(value)
C#
public void WriteValue(
   string value
)
Delphi
public procedure WriteValue(
    value: String
);
JScript
public function WriteValue(
   value : String
);
Managed Extensions for C++
public: void WriteValue(
   string* value
)
C++/CLI
public:
void WriteValue(
   String^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetWriter Class
XmlFastInfosetWriter Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.FastInfoset Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.FastInfoset.BooleanEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.BuiltInAlphabetHelper
Noemax.FastInfoset.BuiltInEncodingAlgorithmFactory
Noemax.FastInfoset.BuiltInEncodingAlgorithmState
Noemax.FastInfoset.BuiltInRestrictedAlphabets
Noemax.FastInfoset.CharArray
Noemax.FastInfoset.CharArrayString
Noemax.FastInfoset.Converter
Noemax.FastInfoset.DecoderStateTables
Noemax.FastInfoset.DoubleEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.DuplicateAttributeVerifier
Noemax.FastInfoset.DuplicateAttributeVerifier.Entry
Noemax.FastInfoset.EncodingAlgorithm
Noemax.FastInfoset.BuiltInEncodingAlgorithm
Noemax.FastInfoset.BASE64EncodingAlgorithm
Noemax.FastInfoset.BooleanEncodingAlgorithm
Noemax.FastInfoset.CDATAEncodingAlgorithm
Noemax.FastInfoset.HexadecimalEncodingAlgorithm
Noemax.FastInfoset.IEEE754FloatingPointEncodingAlgorithm
Noemax.FastInfoset.DoubleEncodingAlgorithm
Noemax.FastInfoset.FloatEncodingAlgorithm
Noemax.FastInfoset.IntegerEncodingAlgorithm
Noemax.FastInfoset.IntEncodingAlgorithm
Noemax.FastInfoset.LongEncodingAlgorithm
Noemax.FastInfoset.UUIDEncodingAlgorithm
Noemax.FastInfoset.ShortEncodingAlgorithm
Noemax.FastInfoset.RegisteredEncodingAlgorithm
Noemax.FastInfoset.NoemaxDateTimeEncodingAlgorithm
Noemax.FastInfoset.NoemaxDecimalEncodingAlgorithm
Noemax.FastInfoset.EncodingAlgorithmIndexes
Noemax.FastInfoset.EncodingConstants
Noemax.FastInfoset.FastInfosetCompressionFactory
Noemax.FastInfoset.FloatEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.KeyIntMap
Noemax.FastInfoset.CharArrayIntMap
Noemax.FastInfoset.LocalNameQualifiedNamesMap
Noemax.FastInfoset.StringIntMap
Noemax.FastInfoset.CachingStringIntMap
Noemax.FastInfoset.FixedEntryStringIntMap
Noemax.FastInfoset.KeyIntMap.BaseEntry
Noemax.FastInfoset.CharArrayIntMap.Entry
Noemax.FastInfoset.CharArrayIntMap.BytesEntry
Noemax.FastInfoset.CharArrayIntMap.CharArrayEntry
Noemax.FastInfoset.CharArrayIntMap.DateTimeEntry
Noemax.FastInfoset.CharArrayIntMap.DecimalEntry
Noemax.FastInfoset.CharArrayIntMap.DoubleEntry
Noemax.FastInfoset.CharArrayIntMap.LongEntry
Noemax.FastInfoset.CharArrayIntMap.StringEntry
Noemax.FastInfoset.StringIntMap.Entry
Noemax.FastInfoset.Notation
Noemax.FastInfoset.UnparsedEntity
Noemax.FastInfoset.PrefixArray.NamespaceEntry
Noemax.FastInfoset.PrefixArray.PrefixEntry
Noemax.FastInfoset.QualifiedName
Noemax.FastInfoset.QualifiedNamePool
Noemax.FastInfoset.ReferencedVocabulary
Noemax.FastInfoset.RestrictedAlphabet
Noemax.FastInfoset.Strings
Noemax.FastInfoset.SupportClass
Noemax.FastInfoset.SupportClass.ArraysSupport
Noemax.FastInfoset.System_Renamed
Noemax.FastInfoset.Util
Noemax.FastInfoset.ValueArray
Noemax.FastInfoset.CharArrayArray
Noemax.FastInfoset.ContiguousCharArrayArray
Noemax.FastInfoset.EphemeralQNamePool
Noemax.FastInfoset.PrefixArray
Noemax.FastInfoset.QualifiedNameArray
Noemax.FastInfoset.StringArray
Noemax.FastInfoset.Vocabulary
Noemax.FastInfoset.ReaderVocabulary
Noemax.FastInfoset.SchemaVocabulary
Noemax.FastInfoset.WriterVocabulary
Noemax.FastInfoset.XMLChar
Noemax.FastInfoset.XMLConstants
Noemax.FastInfoset.XmlFastInfosetFactory
Noemax.FastInfoset.XmlFastInfosetReader.Decoder
Noemax.FastInfoset.XmlFastInfosetReader.StAXDocumentParser
Noemax.FastInfoset.XmlFastInfosetWriter.Encoder
Noemax.FastInfoset.XmlFastInfosetWriter.StAXDocumentSerializer
Noemax.FastInfoset.XmlFastInfosetWriterProfile
Noemax.FastInfoset.XMLStreamConstants
System.Exception
Noemax.FastInfoset.FastInfosetException
Noemax.FastInfoset.EncodingAlgorithmException
System.IO.Stream
System.MarshalByRefObject
Noemax.FastInfoset.XmlFastInfosetReader.Decoder.EncodingAlgorithmInputStream
Noemax.FastInfoset.XmlFastInfosetWriter.Encoder.EncodingBufferOutputStream
System.SystemException
System.Exception
Noemax.FastInfoset.ValueArrayResourceException
System.ValueType
Noemax.FastInfoset.CachingStringIntMap.Entry
Noemax.FastInfoset.CompiledAlphabet
Noemax.FastInfoset.DoubleEncodingAlgorithm.Int64DoubleUnion
Noemax.FastInfoset.FloatEncodingAlgorithm.Int32SingleUnion
Noemax.FastInfoset.IntEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.LocalNameQualifiedNamesMap.Entry
Noemax.FastInfoset.LongEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.NoemaxDateTimeEncodingAlgorithm.DataTimeWordListener
Noemax.FastInfoset.ShortEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.UUIDEncodingAlgorithm.AnonymousClassWordListener
Noemax.FastInfoset.XmlFastInfosetReader.AttributesHolder
Noemax.FastInfoset.XmlFastInfosetWriter.StAXDocumentSerializer.AttributeInfo
Noemax.FastInfoset.XmlFastInfosetWriter.StAXDocumentSerializer.NamespaceScopeManager
Noemax.FastInfoset.XmlFastInfosetWriter.StAXDocumentSerializer.NamespaceScopeManager.NamespaceEntry
Noemax.FastInfoset.XmlFastInfosetWriter.StAXDocumentSerializer.NamespaceScopeManager.Scope
Noemax.FastInfoset.XmlFastInfosetWriter.XmlScopeStack
System.Xml.XmlReader
Noemax.FastInfoset.XmlFastInfosetReader
System.Xml.XmlWriter
Noemax.FastInfoset.XmlFastInfosetWriter

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%% $$Events$$

[image]
Noemax WCF-Xtensions
InvalidInputException Class Events
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
InvalidInputException Class Methods
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
InvalidInputException Class Properties
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Data Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Data Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As IDictionary

value = instance.Data
C#
public virtual IDictionary Data {get;}
Delphi
public read-only property Data: IDictionary; virtual;
JScript
public function get Data : IDictionary
Managed Extensions for C++
public: __property virtual IDictionary* get_Data();
C++/CLI
public:
virtual property IDictionary^ Data {
   IDictionary^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetBaseException Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetBaseException Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.GetBaseException()
C#
public virtual Exception GetBaseException()
Delphi
public function GetBaseException(): Exception; virtual;
JScript
public function GetBaseException() : Exception;
Managed Extensions for C++
public: virtual Exception* GetBaseException();
C++/CLI
public:
virtual Exception^ GetBaseException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetObjectData Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
[SecurityCriticalAttribute()]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); virtual;
JScript
SecurityCriticalAttribute()
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetType Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetType Method

Overload List

Overload | Description
GetType() | (Inherited from System.Exception)

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetType() Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > GetType Method : GetType() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function GetType() As Type
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Type

value = instance.GetType()
C#
public Type GetType()
Delphi
public function GetType(): Type;
JScript
public function GetType() : Type;
Managed Extensions for C++
public: Type* GetType();
C++/CLI
public:
Type^ GetType();

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HelpLink Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HelpLink Property

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.HelpLink = value

value = instance.HelpLink
C#
public virtual string HelpLink {get; set;}
Delphi
public read-write property HelpLink: String; virtual;
JScript
public function get,set HelpLink : String
Managed Extensions for C++
public: __property virtual string* get_HelpLink();
public: __property virtual void set_HelpLink(
   string* value
);
C++/CLI
public:
virtual property String^ HelpLink {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HResult Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HResult Property

Syntax

Visual Basic (Declaration)
Protected Property HResult As Integer
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Integer

instance.HResult = value

value = instance.HResult
C#
protected int HResult {get; set;}
Delphi
protected read-write property HResult: Integer;
JScript
protected function get,set HResult : int
Managed Extensions for C++
protected: __property int get_HResult();
protected: __property void set_HResult(
   int value
);
C++/CLI
protected:
property int HResult {
   int get();
   void set (    int value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InnerException Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InnerException Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.InnerException
C#
public Exception InnerException {get;}
Delphi
public read-only property InnerException: Exception;
JScript
public function get InnerException : Exception
Managed Extensions for C++
public: __property Exception* get_InnerException();
C++/CLI
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Message Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Message Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.Message
C#
public virtual string Message {get;}
Delphi
public read-only property Message: String; virtual;
JScript
public function get Message : String
Managed Extensions for C++
public: __property virtual string* get_Message();
C++/CLI
public:
virtual property String^ Message {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeObjectState Event
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : SerializeObjectState Event

Syntax

Visual Basic (Declaration)
Protected Event SerializeObjectState As EventHandler(Of SafeSerializationEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim handler As EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
C#
protected event EventHandler<SafeSerializationEventArgs> SerializeObjectState
Delphi
protected event SerializeObjectState: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
protected: __event EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
C++/CLI
protected:
event EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState

Event Data

The event handler receives an argument of type SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext |

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Source Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Source Property

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.Source = value

value = instance.Source
C#
public virtual string Source {get; set;}
Delphi
public read-write property Source: String; virtual;
JScript
public function get,set Source : String
Managed Extensions for C++
public: __property virtual string* get_Source();
public: __property virtual void set_Source(
   string* value
);
C++/CLI
public:
virtual property String^ Source {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StackTrace Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : StackTrace Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.StackTrace
C#
public virtual string StackTrace {get;}
Delphi
public read-only property StackTrace: String; virtual;
JScript
public function get StackTrace : String
Managed Extensions for C++
public: __property virtual string* get_StackTrace();
C++/CLI
public:
virtual property String^ StackTrace {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TargetSite Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : TargetSite Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As MethodBase

value = instance.TargetSite
C#
public MethodBase TargetSite {get;}
Delphi
public read-only property TargetSite: MethodBase;
JScript
public function get TargetSite : MethodBase
Managed Extensions for C++
public: __property MethodBase* get_TargetSite();
C++/CLI
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.GZip Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.GZip.Adler32
Noemax.GZip.Deflate
Noemax.GZip.Deflate.Config
Noemax.GZip.ExtraFieldCollection
Noemax.GZip.GZipHeaderField
Noemax.GZip.InfBlocks
Noemax.GZip.InfCodes
Noemax.GZip.Inflate
Noemax.GZip.InfTree
Noemax.GZip.JZlib
Noemax.GZip.StaticTree
Noemax.GZip.Strings
Noemax.GZip.SupportClass
Noemax.GZip.SupportClass.ArraysSupport
Noemax.GZip.System_Renamed
Noemax.GZip.Tree
Noemax.GZip.ZStream
System.IO.IOException
System.SystemException
System.Exception
Noemax.GZip.InvalidInputException
Noemax.GZip.ZStreamException
System.IO.Stream
System.MarshalByRefObject
Noemax.GZip.Crc32Stream
Noemax.GZip.DeflateInputStream
Noemax.GZip.DeflateOutputStream
Noemax.GZip.DeflateStream
Noemax.GZip.GZipInputStream
Noemax.GZip.GZipOutputStream
Noemax.GZip.GZipStream

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzf Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzf.Lzf3InputStream
Noemax.Lzf.Lzf3OutputStream
Noemax.Lzf.LzfInputStream
Noemax.Lzf.LzfOutputStream

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzma Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.Lzma.CRC
Noemax.Lzma.LzmaFactory
Noemax.Lzma.LzmaSettings
System.Exception
Noemax.Lzma.DataErrorException
Noemax.Lzma.InvalidParamException
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzma.LzmaInputStream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
CustomOperationSelectorAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : CustomOperationSelectorAttribute Class

For a list of all members of this type, see CustomOperationSelectorAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

CustomOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > CustomOperationSelectorAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomOperationSelectorAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

CustomOperationSelectorAttribute Class
CustomOperationSelectorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > CustomOperationSelectorAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CustomOperationSelectorAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

CustomOperationSelectorAttribute Class
CustomOperationSelectorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > CustomOperationSelectorAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As CustomOperationSelectorAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

CustomOperationSelectorAttribute Class
CustomOperationSelectorAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
EnableCompressionAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnableCompressionAttribute Class

For a list of all members of this type, see EnableCompressionAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnableCompressionAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnableCompressionAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnableCompressionAttribute Class

For a list of all members of this type, see EnableCompressionAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

EnableCompressionAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnableCompressionAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnableCompressionAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

EnableCompressionAttribute Class
EnableCompressionAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnableCompressionAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnableCompressionAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

EnableCompressionAttribute Class
EnableCompressionAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnableCompressionAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As EnableCompressionAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

EnableCompressionAttribute Class
EnableCompressionAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
EnumerableStreamAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamAttribute Class

For a list of all members of this type, see EnumerableStreamAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnumerableStreamAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
EnumerableStreamAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnumerableStreamAttribute Class

For a list of all members of this type, see EnumerableStreamAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

EnumerableStreamAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnumerableStreamAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnumerableStreamAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

EnumerableStreamAttribute Class
EnumerableStreamAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnumerableStreamAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnumerableStreamAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

EnumerableStreamAttribute Class
EnumerableStreamAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnumerableStreamAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As EnumerableStreamAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

EnumerableStreamAttribute Class
EnumerableStreamAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
EnvelopeBehaviorAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : EnvelopeBehaviorAttribute Class

For a list of all members of this type, see EnvelopeBehaviorAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

EnvelopeBehaviorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > EnvelopeBehaviorAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeBehaviorAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

EnvelopeBehaviorAttribute Class
EnvelopeBehaviorAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
ExportMetadataBehavior Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : ExportMetadataBehavior Class

For a list of all members of this type, see ExportMetadataBehavior members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

ExportMetadataBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
ExportMetadataBehavior Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : ExportMetadataBehavior Class

For a list of all members of this type, see ExportMetadataBehavior members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

ExportMetadataBehavior Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > ExportMetadataBehavior Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExportMetadataBehavior
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

ExportMetadataBehavior Class
ExportMetadataBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > ExportMetadataBehavior Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExportMetadataBehavior
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

ExportMetadataBehavior Class
ExportMetadataBehavior Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > ExportMetadataBehavior Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As ExportMetadataBehavior
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

ExportMetadataBehavior Class
ExportMetadataBehavior Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
QualifiedNameMessageFilterAttribute Class Methods
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameMessageFilterAttribute Class

For a list of all members of this type, see QualifiedNameMessageFilterAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

QualifiedNameMessageFilterAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameMessageFilterAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameMessageFilterAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

See Also

Reference

QualifiedNameMessageFilterAttribute Class
QualifiedNameMessageFilterAttribute Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
QualifiedNameOperationSelectorAttribute Class Properties
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace : QualifiedNameOperationSelectorAttribute Class

For a list of all members of this type, see QualifiedNameOperationSelectorAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
Noemax.WCFX.Behaviors Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefaultAttribute Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameOperationSelectorAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameOperationSelectorAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: bool IsDefaultAttribute();
C++/CLI
public:
bool IsDefaultAttribute();

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
QualifiedNameOperationSelectorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Match Method
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameOperationSelectorAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameOperationSelectorAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: bool Match(
   Object* obj
)
C++/CLI
public:
bool Match(
   Object^ obj
)

Parameters

obj

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
QualifiedNameOperationSelectorAttribute Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TypeId Property
See Also Send Feedback
Noemax.WCFX.Behaviors Namespace > QualifiedNameOperationSelectorAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As QualifiedNameOperationSelectorAttribute
Dim value As Object

value = instance.TypeId
C#
public object TypeId {get;}
Delphi
public read-only property TypeId: TObject;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property Object* get_TypeId();
C++/CLI
public:
property Object^ TypeId {
   Object^ get();
}

See Also

Reference

QualifiedNameOperationSelectorAttribute Class
QualifiedNameOperationSelectorAttribute Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.WCFX.Behaviors Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.WCFX.Behaviors.CustomOperationSelector
Noemax.WCFX.Behaviors.EnableCompressionDispatchBehavior
Noemax.WCFX.Behaviors.EnumerableFormatter
Noemax.WCFX.Behaviors.EnumerableFormatter.EnumerableContent<T>
Noemax.WCFX.Behaviors.EnumerableFormatter.EnumerableContent.Enumerator
Noemax.WCFX.Behaviors.EnumerableFormatter.FragmentReader
Noemax.WCFX.Behaviors.EnumerableStreamBehavior
Noemax.WCFX.Behaviors.EnvelopeBehavior
Noemax.WCFX.Behaviors.EnvelopeBehavior.EnvelopeClientMessageFormatter
Noemax.WCFX.Behaviors.EnvelopeBehavior.EnvelopeDispatchMessageFormatter
Noemax.WCFX.Behaviors.EnvelopeEndpointBehavior
Noemax.WCFX.Behaviors.EnvelopeFormatter
Noemax.WCFX.Behaviors.EnvelopeOperationContext
Noemax.WCFX.Behaviors.ForkedClientFormatter
Noemax.WCFX.Behaviors.ForkedDispatchFormatter
Noemax.WCFX.Behaviors.MessageBodyEnvelope
Noemax.WCFX.Behaviors.MetadataCollection
Noemax.WCFX.Behaviors.OperationMessageFilterAttributeBase
Noemax.WCFX.Behaviors.ServiceMetadataInfo
Noemax.WCFX.Behaviors.XmlFastInfosetEncoding
Noemax.WCFX.Channels.DelegatingMessage
System.ServiceModel.Channels.Message
Noemax.WCFX.Behaviors.EnvelopeFormatter.EnvelopedMessage
System.Attribute
Noemax.WCFX.Behaviors.CustomOperationSelectorAttribute
Noemax.WCFX.Behaviors.QualifiedNameOperationSelectorAttribute
Noemax.WCFX.Behaviors.EnableCompressionAttribute
Noemax.WCFX.Behaviors.EnumerableStreamAttribute
Noemax.WCFX.Behaviors.EnvelopeBehaviorAttribute
Noemax.WCFX.Behaviors.ExportMetadataBehavior
Noemax.WCFX.Behaviors.QualifiedNameMessageFilterAttribute
System.IO.Stream
System.MarshalByRefObject
Noemax.WCFX.Behaviors.EnvelopeFormatter.EnvelopedMessage.Base64ReaderStream
Noemax.WCFX.Behaviors.EnvelopeFormatter.EnvelopedMessage.Base64WriterStream
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Behaviors.HttpGetMetadataHandler
System.ServiceModel.Channels.Message
Noemax.WCFX.Behaviors.RelaxedMessage

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : BuildChannelFactory Method

Overload List

Overload | Description
BuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public virtual IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function BuildChannelFactory(
    parameters: BindingParameterCollection
): IChannelFactory; virtual;
JScript
public function BuildChannelFactory(
   parameters : BindingParameterCollection
) : IChannelFactory;
Managed Extensions for C++
public: virtual IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function BuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters() As Object
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function BuildChannelFactory(
   params  parameters: TObjectarray of
): IChannelFactory;
JScript
public function BuildChannelFactory(
   parameters : Object[]
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : BuildChannelListener Method

Overload List

Overload | Description
BuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,Object[]) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CanBuildChannelFactory Method

Overload List

Overload | Description
CanBuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function CanBuildChannelFactory(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public bool CanBuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function CanBuildChannelFactory(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelFactory(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CanBuildChannelListener Method

Overload List

Overload | Description
CanBuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelListener(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public bool CanBuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelListener(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[DefaultValueAttribute()]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : GetProperty<T> Method

parameters

Syntax

Visual Basic (Declaration)
Public Function GetProperty(Of T)( _
   ByVal parameters As BindingParameterCollection _
) As T
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As T

value = instance.GetProperty(Of T)(parameters)
C#
public T GetProperty<T>(
   BindingParameterCollection parameters
)
Delphi
public function GetProperty(
    parameters: BindingParameterCollection
): T;
JScript
public function GetProperty(
   parameters : BindingParameterCollection
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

T

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : MessageVersion Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As MessageVersion

value = instance.MessageVersion
C#
public MessageVersion MessageVersion {get;}
Delphi
public read-only property MessageVersion: MessageVersion;
JScript
public function get MessageVersion : MessageVersion
Managed Extensions for C++
public: __property MessageVersion* get_MessageVersion();
C++/CLI
public:
property MessageVersion^ MessageVersion {
   MessageVersion^ get();
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : Name Property

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
public function get,set Name : String
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Namespace Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As String

instance.Namespace = value

value = instance.Namespace
C#
public string Namespace {get; set;}
Delphi
public read-write property Namespace: String;
JScript
public function get,set Namespace : String
Managed Extensions for C++
public: __property string* get_Namespace();
public: __property void set_Namespace(
   string* value
);
C++/CLI
public:
property String^ Namespace {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[DefaultValueAttribute()]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValueAttribute()]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > BasicSoapTcpBinding Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBinding
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[DefaultValueAttribute()]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBinding Class
BasicSoapTcpBinding Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBinding Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : DuplexSoapTcpBinding Class

For a list of all members of this type, see DuplexSoapTcpBinding members.

Public Properties

 | Name | Description
public Property | CloseTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Compression | Enables or disables GZIP payload compression. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | CompressionLevel | Gets and sets the compression level to be applied when compression is used, were 1 is for fastest compression and 9 for maximum compression. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | CompressionMethod | Gets and sets the algorithm used for compressing the message payload (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxBufferPoolSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxBufferSize | Gets or sets the maximum number of bytes that are used to buffer incoming messages in memory. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxReceivedMessageSize | Gets or sets the maximum size for a received message that is processed by the binding. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MaxVocabularyStringLength | Gets and sets the maximum number of characters that a string value may contain in order to be added to the vocabulary. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Name | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Namespace | (Inherited from System.ServiceModel.Channels.Binding)
public Property | OpenTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | PermitStateful | Permits FastInfoset message encoding to work in stateful mode whenever transport can maintain state. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | ReceiveTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | Scheme | (Inherited from System.ServiceModel.Channels.Binding)
public Property | SendTimeout | (Inherited from System.ServiceModel.Channels.Binding)
public Property | TransferMode | Gets or sets a value that indicates whether messages are sent buffered or streamed. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
public Property | WriterProfile | XmlFastInfosetWriterProfile that defines the way how primitive data-type are going to be serialized. (Inherited from Noemax.WCFX.Channels.BasicSoapTcpBinding)
Top

See Also

Reference

DuplexSoapTcpBinding Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : BuildChannelFactory Method

Overload List

Overload | Description
BuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public virtual IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function BuildChannelFactory(
    parameters: BindingParameterCollection
): IChannelFactory; virtual;
JScript
public function BuildChannelFactory(
   parameters : BindingParameterCollection
) : IChannelFactory;
Managed Extensions for C++
public: virtual IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function BuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters() As Object
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function BuildChannelFactory(
   params  parameters: TObjectarray of
): IChannelFactory;
JScript
public function BuildChannelFactory(
   parameters : Object[]
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : BuildChannelListener Method

Overload List

Overload | Description
BuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,Object[]) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : CanBuildChannelFactory Method

Overload List

Overload | Description
CanBuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function CanBuildChannelFactory(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public bool CanBuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function CanBuildChannelFactory(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelFactory(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : CanBuildChannelListener Method

Overload List

Overload | Description
CanBuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelListener(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public bool CanBuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelListener(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[DefaultValueAttribute()]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateBindingElements Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : CreateBindingElements Method

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateBindingElements() As BindingElementCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As BindingElementCollection

value = instance.CreateBindingElements()
C#
public virtual BindingElementCollection CreateBindingElements()
Delphi
public function CreateBindingElements(): BindingElementCollection; virtual;
JScript
public function CreateBindingElements() : BindingElementCollection;
Managed Extensions for C++
public: virtual BindingElementCollection* CreateBindingElements();
C++/CLI
public:
virtual BindingElementCollection^ CreateBindingElements();

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : GetProperty<T> Method

parameters

Syntax

Visual Basic (Declaration)
Public Function GetProperty(Of T)( _
   ByVal parameters As BindingParameterCollection _
) As T
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim parameters As BindingParameterCollection
Dim value As T

value = instance.GetProperty(Of T)(parameters)
C#
public T GetProperty<T>(
   BindingParameterCollection parameters
)
Delphi
public function GetProperty(
    parameters: BindingParameterCollection
): T;
JScript
public function GetProperty(
   parameters : BindingParameterCollection
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

T

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : MessageVersion Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As MessageVersion

value = instance.MessageVersion
C#
public MessageVersion MessageVersion {get;}
Delphi
public read-only property MessageVersion: MessageVersion;
JScript
public function get MessageVersion : MessageVersion
Managed Extensions for C++
public: __property MessageVersion* get_MessageVersion();
C++/CLI
public:
property MessageVersion^ MessageVersion {
   MessageVersion^ get();
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : Name Property

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
public function get,set Name : String
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Namespace Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As String

instance.Namespace = value

value = instance.Namespace
C#
public string Namespace {get; set;}
Delphi
public read-write property Namespace: String;
JScript
public function get,set Namespace : String
Managed Extensions for C++
public: __property string* get_Namespace();
public: __property void set_Namespace(
   string* value
);
C++/CLI
public:
property String^ Namespace {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[DefaultValueAttribute()]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValueAttribute()]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : Scheme Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As String

value = instance.Scheme
C#
public virtual string Scheme {get;}
Delphi
public read-only property Scheme: String; virtual;
JScript
public function get Scheme : String
Managed Extensions for C++
public: __property virtual string* get_Scheme();
C++/CLI
public:
virtual property String^ Scheme {
   String^ get();
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > DuplexSoapTcpBinding Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBinding
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[DefaultValueAttribute()]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBinding Class
DuplexSoapTcpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > FiMessageEncodingBindingElement Class : CanBuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

TChannel

See Also

Reference

FiMessageEncodingBindingElement Class
FiMessageEncodingBindingElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
HttpsViaProxyTransportBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : HttpsViaProxyTransportBindingElement Class

For a list of all members of this type, see HttpsViaProxyTransportBindingElement members.

Public Properties

 | Name | Description
public Property | AllowCookies | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | AuthenticationScheme | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | BypassProxyOnLocal | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | DecompressionEnabled | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ExtendedProtectionPolicy | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | HostNameComparisonMode | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | KeepAliveEnabled | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ManualAddressing | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferPoolSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | MaxBufferSize | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | MaxReceivedMessageSize | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | ProxyAddress | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | ProxyAuthenticationScheme | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | Realm | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | Scheme | (Inherited from System.ServiceModel.Channels.TransportBindingElement)
public Property | TransferMode | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | UnsafeConnectionNtlmAuthentication | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
public Property | UseDefaultWebProxy | (Inherited from System.ServiceModel.Channels.HttpTransportBindingElement)
Top

See Also

Reference

HttpsViaProxyTransportBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : AllowCookies Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
[DefaultValueAttribute()]
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
DefaultValueAttribute()
public function get,set AllowCookies : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : AuthenticationScheme Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
C#
[DefaultValueAttribute()]
public AuthenticationSchemes AuthenticationScheme {get; set;}
Delphi
public read-write property AuthenticationScheme: AuthenticationSchemes;
JScript
DefaultValueAttribute()
public function get,set AuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[DefaultValueAttribute()]
public:
property AuthenticationSchemes AuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : BuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public virtual IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; virtual;
JScript
public function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: virtual IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
)
C++/CLI
public:
virtual IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

TChannel

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : BuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BypassProxyOnLocal Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : BypassProxyOnLocal Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BypassProxyOnLocal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.BypassProxyOnLocal = value

value = instance.BypassProxyOnLocal
C#
[DefaultValueAttribute()]
public bool BypassProxyOnLocal {get; set;}
Delphi
public read-write property BypassProxyOnLocal: Boolean;
JScript
DefaultValueAttribute()
public function get,set BypassProxyOnLocal : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_BypassProxyOnLocal();
public: __property void set_BypassProxyOnLocal(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool BypassProxyOnLocal {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : CanBuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

TChannel

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : CanBuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public virtual bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; virtual;
JScript
public function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) where TChannel: IChannel
C++/CLI
public:
virtual bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DecompressionEnabled Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : DecompressionEnabled Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DecompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.DecompressionEnabled = value

value = instance.DecompressionEnabled
C#
[DefaultValueAttribute()]
public bool DecompressionEnabled {get; set;}
Delphi
public read-write property DecompressionEnabled: Boolean;
JScript
DefaultValueAttribute()
public function get,set DecompressionEnabled : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_DecompressionEnabled();
public: __property void set_DecompressionEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool DecompressionEnabled {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtendedProtectionPolicy Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : ExtendedProtectionPolicy Property

Syntax

Visual Basic (Declaration)
Public Property ExtendedProtectionPolicy As ExtendedProtectionPolicy
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As ExtendedProtectionPolicy

instance.ExtendedProtectionPolicy = value

value = instance.ExtendedProtectionPolicy
C#
public ExtendedProtectionPolicy ExtendedProtectionPolicy {get; set;}
Delphi
public read-write property ExtendedProtectionPolicy: ExtendedProtectionPolicy;
JScript
public function get,set ExtendedProtectionPolicy : ExtendedProtectionPolicy
Managed Extensions for C++
public: __property ExtendedProtectionPolicy* get_ExtendedProtectionPolicy();
public: __property void set_ExtendedProtectionPolicy(
   ExtendedProtectionPolicy* value
);
C++/CLI
public:
property ExtendedProtectionPolicy^ ExtendedProtectionPolicy {
   ExtendedProtectionPolicy^ get();
   void set (    ExtendedProtectionPolicy^ value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HostNameComparisonMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : HostNameComparisonMode Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property HostNameComparisonMode As HostNameComparisonMode
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As HostNameComparisonMode

instance.HostNameComparisonMode = value

value = instance.HostNameComparisonMode
C#
[DefaultValueAttribute()]
public HostNameComparisonMode HostNameComparisonMode {get; set;}
Delphi
public read-write property HostNameComparisonMode: HostNameComparisonMode;
JScript
DefaultValueAttribute()
public function get,set HostNameComparisonMode : HostNameComparisonMode
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property HostNameComparisonMode get_HostNameComparisonMode();
public: __property void set_HostNameComparisonMode(
   HostNameComparisonMode value
);
C++/CLI
[DefaultValueAttribute()]
public:
property HostNameComparisonMode HostNameComparisonMode {
   HostNameComparisonMode get();
   void set (    HostNameComparisonMode value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
KeepAliveEnabled Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : KeepAliveEnabled Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property KeepAliveEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.KeepAliveEnabled = value

value = instance.KeepAliveEnabled
C#
[DefaultValueAttribute()]
public bool KeepAliveEnabled {get; set;}
Delphi
public read-write property KeepAliveEnabled: Boolean;
JScript
DefaultValueAttribute()
public function get,set KeepAliveEnabled : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_KeepAliveEnabled();
public: __property void set_KeepAliveEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool KeepAliveEnabled {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[DefaultValueAttribute()]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
DefaultValueAttribute()
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : MaxBufferPoolSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[DefaultValueAttribute()]
public virtual long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxBufferPoolSize();
public: __property virtual void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : MaxBufferSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[DefaultValueAttribute()]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
DefaultValueAttribute()
public function get,set MaxBufferSize : int
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : MaxReceivedMessageSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[DefaultValueAttribute()]
public virtual long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxReceivedMessageSize();
public: __property virtual void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : ProxyAddress Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.UriTypeConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DefaultValueAttribute()>
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
[TypeConverterAttribute("System.UriTypeConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
TypeConverterAttribute("System.UriTypeConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
DefaultValueAttribute()
public function get,set ProxyAddress : Uri
Managed Extensions for C++
[TypeConverterAttribute("System.UriTypeConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
[TypeConverterAttribute("System.UriTypeConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : ProxyAuthenticationScheme Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ProxyAuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As AuthenticationSchemes

instance.ProxyAuthenticationScheme = value

value = instance.ProxyAuthenticationScheme
C#
[DefaultValueAttribute()]
public AuthenticationSchemes ProxyAuthenticationScheme {get; set;}
Delphi
public read-write property ProxyAuthenticationScheme: AuthenticationSchemes;
JScript
DefaultValueAttribute()
public function get,set ProxyAuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property AuthenticationSchemes get_ProxyAuthenticationScheme();
public: __property void set_ProxyAuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[DefaultValueAttribute()]
public:
property AuthenticationSchemes ProxyAuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Realm Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : Realm Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Realm As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As String

instance.Realm = value

value = instance.Realm
C#
[DefaultValueAttribute()]
public string Realm {get; set;}
Delphi
public read-write property Realm: String;
JScript
DefaultValueAttribute()
public function get,set Realm : String
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Realm();
public: __property void set_Realm(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Realm {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Scheme Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : Scheme Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Scheme As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As String

value = instance.Scheme
C#
public virtual string Scheme {get;}
Delphi
public read-only property Scheme: String; virtual;
JScript
public function get Scheme : String
Managed Extensions for C++
public: __property virtual string* get_Scheme();
C++/CLI
public:
virtual property String^ Scheme {
   String^ get();
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : TransferMode Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[DefaultValueAttribute()]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
DefaultValueAttribute()
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UnsafeConnectionNtlmAuthentication Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : UnsafeConnectionNtlmAuthentication Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UnsafeConnectionNtlmAuthentication As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.UnsafeConnectionNtlmAuthentication = value

value = instance.UnsafeConnectionNtlmAuthentication
C#
[DefaultValueAttribute()]
public bool UnsafeConnectionNtlmAuthentication {get; set;}
Delphi
public read-write property UnsafeConnectionNtlmAuthentication: Boolean;
JScript
DefaultValueAttribute()
public function get,set UnsafeConnectionNtlmAuthentication : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UnsafeConnectionNtlmAuthentication();
public: __property void set_UnsafeConnectionNtlmAuthentication(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UnsafeConnectionNtlmAuthentication {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > HttpsViaProxyTransportBindingElement Class : UseDefaultWebProxy Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportBindingElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
[DefaultValueAttribute()]
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
DefaultValueAttribute()
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportBindingElement Class
HttpsViaProxyTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpsTransportBindingElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportBindingElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[DefaultValueAttribute()]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
DefaultValueAttribute()
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

LiteHttpsTransportBindingElement Class
LiteHttpsTransportBindingElement Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : GetProperty<T> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public virtual T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; virtual;
JScript
public function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: virtual T* GetProperty<T>(
   BindingContext* context
)
C++/CLI
public:
virtual T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

T

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[DefaultValueAttribute()]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
DefaultValueAttribute()
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : MaxBufferPoolSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[DefaultValueAttribute()]
public virtual long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxBufferPoolSize();
public: __property virtual void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > LiteHttpTransportBindingElement Class : MaxReceivedMessageSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[DefaultValueAttribute()]
public virtual long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxReceivedMessageSize();
public: __property virtual void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

LiteHttpTransportBindingElement Class
LiteHttpTransportBindingElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
PluggableMessageEncodingBindingElement Class Properties
See Also Send Feedback
Noemax.WCFX.Channels Namespace : PluggableMessageEncodingBindingElement Class

For a list of all members of this type, see PluggableMessageEncodingBindingElement members.

Public Properties

 | Name | Description
public Property | MessageVersion | (Inherited from System.ServiceModel.Channels.MessageEncodingBindingElement)
Top

See Also

Reference

PluggableMessageEncodingBindingElement Class
Noemax.WCFX.Channels Namespace


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : BuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim context As BindingContext
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(context)
C#
public virtual IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function BuildChannelFactory(
    context: BindingContext
): IChannelFactory; virtual;
JScript
public function BuildChannelFactory(
   context : BindingContext
) : IChannelFactory;
Managed Extensions for C++
public: virtual IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingContext* context
)
C++/CLI
public:
virtual IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

TChannel

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : BuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim context As BindingContext
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(context)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    context: BindingContext
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   context : BindingContext
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingContext* context
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : CanBuildChannelFactory<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(context)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext context
)
Delphi
public function CanBuildChannelFactory(
    context: BindingContext
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingContext* context
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

TChannel

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : CanBuildChannelListener<TChannel> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal context As BindingContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim context As BindingContext
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(context)
C#
public virtual bool CanBuildChannelListener<TChannel>(
   BindingContext context
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    context: BindingContext
): Boolean; virtual;
JScript
public function CanBuildChannelListener(
   context : BindingContext
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelListener<TChannel>(
   BindingContext* context
) where TChannel: IChannel
C++/CLI
public:
virtual bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingContext^ context
) where TChannel: IChannel

Parameters

context

Type Parameters

TChannel

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Clone Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : Clone Method

Syntax

Visual Basic (Declaration)
Public MustOverride Function Clone() As BindingElement
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim value As BindingElement

value = instance.Clone()
C#
public abstract BindingElement Clone()
Delphi
public function Clone(): BindingElement; abstract;
JScript
public __abstract function Clone() : BindingElement;
Managed Extensions for C++
public: abstract BindingElement* Clone();
C++/CLI
public:
abstract BindingElement^ Clone();

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateMessageEncoderFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : CreateMessageEncoderFactory Method

Syntax

Visual Basic (Declaration)
Public MustOverride Function CreateMessageEncoderFactory() As MessageEncoderFactory
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim value As MessageEncoderFactory

value = instance.CreateMessageEncoderFactory()
C#
public abstract MessageEncoderFactory CreateMessageEncoderFactory()
Delphi
public function CreateMessageEncoderFactory(): MessageEncoderFactory; abstract;
JScript
public __abstract function CreateMessageEncoderFactory() : MessageEncoderFactory;
Managed Extensions for C++
public: abstract MessageEncoderFactory* CreateMessageEncoderFactory();
C++/CLI
public:
abstract MessageEncoderFactory^ CreateMessageEncoderFactory();

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : GetProperty<T> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public virtual T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; virtual;
JScript
public function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: virtual T* GetProperty<T>(
   BindingContext* context
)
C++/CLI
public:
virtual T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

T

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > PluggableMessageEncodingBindingElement Class : MessageVersion Property

Syntax

Visual Basic (Declaration)
Public MustOverride Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As PluggableMessageEncodingBindingElement
Dim value As MessageVersion

instance.MessageVersion = value

value = instance.MessageVersion
C#
public abstract MessageVersion MessageVersion {get; set;}
Delphi
public read-write property MessageVersion: MessageVersion; abstract;
JScript
public __abstract function get,set MessageVersion : MessageVersion
Managed Extensions for C++
public: __property abstract MessageVersion* get_MessageVersion();
public: __property abstract void set_MessageVersion(
   MessageVersion* value
);
C++/CLI
public:
abstract property MessageVersion^ MessageVersion {
   MessageVersion^ get();
   void set (    MessageVersion^ value);
}

See Also

Reference

PluggableMessageEncodingBindingElement Class
PluggableMessageEncodingBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : BuildChannelFactory Method

Overload List

Overload | Description
BuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public virtual IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function BuildChannelFactory(
    parameters: BindingParameterCollection
): IChannelFactory; virtual;
JScript
public function BuildChannelFactory(
   parameters : BindingParameterCollection
) : IChannelFactory;
Managed Extensions for C++
public: virtual IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelFactory Method : BuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function BuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelFactory(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters() As Object
Dim value As IChannelFactory(Of TChannel)

value = instance.BuildChannelFactory(Of TChannel)(parameters)
C#
public IChannelFactory<TChannel> BuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function BuildChannelFactory(
   params  parameters: TObjectarray of
): IChannelFactory;
JScript
public function BuildChannelFactory(
   parameters : Object[]
) : IChannelFactory;
Managed Extensions for C++
public: IChannelFactory<TChannel*>* BuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
IChannelFactory<TChannel^>^ BuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : BuildChannelListener Method

Overload List

Overload | Description
BuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,BindingParameterCollection) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,Object[]) Method

listenUriBaseAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,BindingParameterCollection) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal parameters As BindingParameterCollection _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters As BindingParameterCollection
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
    parameters: BindingParameterCollection
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : BindingParameterCollection
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,ListenUriMode,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal listenUriMode As ListenUriMode, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim listenUriMode As ListenUriMode
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, listenUriMode, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
    listenUriMode: ListenUriMode;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   listenUriMode : ListenUriMode,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ListenUriMode listenUriMode,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
listenUriMode
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
BuildChannelListener<TChannel>(Uri,String,Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > BuildChannelListener Method : BuildChannelListener<TChannel>(Uri,String,Object[]) Method

listenUriBaseAddress
listenUriRelativeAddress
parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function BuildChannelListener(Of TChannel As IChannel)( _
   ByVal listenUriBaseAddress As Uri, _
   ByVal listenUriRelativeAddress As String, _
   ByVal ParamArray parameters() As Object _
) As IChannelListener(Of TChannel)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim listenUriBaseAddress As Uri
Dim listenUriRelativeAddress As String
Dim parameters() As Object
Dim value As IChannelListener(Of TChannel)

value = instance.BuildChannelListener(Of TChannel)(listenUriBaseAddress, listenUriRelativeAddress, parameters)
C#
public virtual IChannelListener<TChannel> BuildChannelListener<TChannel>(
   Uri listenUriBaseAddress,
   string listenUriRelativeAddress,
   params object[] parameters
)where TChannel: IChannel
Delphi
public function BuildChannelListener(
    listenUriBaseAddress: Uri;
    listenUriRelativeAddress: String;
   params  parameters: TObjectarray of
): IChannelListener; virtual;
JScript
public function BuildChannelListener(
   listenUriBaseAddress : Uri,
   listenUriRelativeAddress : String,
   parameters : Object[]
) : IChannelListener;
Managed Extensions for C++
public: virtual IChannelListener<TChannel*>* BuildChannelListener<TChannel>(
   Uri* listenUriBaseAddress,
   string* listenUriRelativeAddress,
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual IChannelListener<TChannel^>^ BuildChannelListenergeneric<typename TChannel>
(
   Uri^ listenUriBaseAddress,
   String^ listenUriRelativeAddress,
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

listenUriBaseAddress
listenUriRelativeAddress
parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelFactory Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CanBuildChannelFactory Method

Overload List

Overload | Description
CanBuildChannelFactory<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelFactory<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelFactory(Of TChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection parameters
)
Delphi
public function CanBuildChannelFactory(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelFactory(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelFactory<TChannel>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
virtual bool CanBuildChannelFactorygeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelFactory<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > CanBuildChannelFactory Method : CanBuildChannelFactory<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelFactory(Of TChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelFactory(Of TChannel)(parameters)
C#
public bool CanBuildChannelFactory<TChannel>(
   params object[] parameters
)
Delphi
public function CanBuildChannelFactory(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelFactory(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelFactory<TChannel>(
   params Object*[]* parameters
)
C++/CLI
public:
bool CanBuildChannelFactorygeneric<typename TChannel>
(
   ... array<Object^>^ parameters
)

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanBuildChannelListener Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CanBuildChannelListener Method

Overload List

Overload | Description
CanBuildChannelListener<TChannel>(Object[]) | (Inherited from System.ServiceModel.Channels.Binding)
CanBuildChannelListener<TChannel>(BindingParameterCollection) | (Inherited from System.ServiceModel.Channels.Binding)

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(BindingParameterCollection) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(BindingParameterCollection) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal parameters As BindingParameterCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters As BindingParameterCollection
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
    parameters: BindingParameterCollection
): Boolean; virtual;
JScript
public function CanBuildChannelListener(
   parameters : BindingParameterCollection
) : boolean;
Managed Extensions for C++
public: virtual bool CanBuildChannelListener<TChannel>(
   BindingParameterCollection* parameters
) where TChannel: IChannel
C++/CLI
public:
virtual bool CanBuildChannelListenergeneric<typename TChannel>
(
   BindingParameterCollection^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

TChannel
[image]
Noemax WCF-Xtensions
CanBuildChannelListener<TChannel>(Object[]) Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class > CanBuildChannelListener Method : CanBuildChannelListener<TChannel>(Object[]) Method

parameters

Syntax

Visual Basic (Declaration)
Public Overloads Function CanBuildChannelListener(Of TChannel As IChannel)( _
   ByVal ParamArray parameters() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters() As Object
Dim value As Boolean

value = instance.CanBuildChannelListener(Of TChannel)(parameters)
C#
public bool CanBuildChannelListener<TChannel>(
   params object[] parameters
)where TChannel: IChannel
Delphi
public function CanBuildChannelListener(
   params  parameters: TObjectarray of
): Boolean;
JScript
public function CanBuildChannelListener(
   parameters : Object[]
) : boolean;
Managed Extensions for C++
public: bool CanBuildChannelListener<TChannel>(
   params Object*[]* parameters
) where TChannel: IChannel
C++/CLI
public:
bool CanBuildChannelListenergeneric<typename TChannel>
(
   ... array<Object^>^ parameters
) where TChannel: IChannel

Parameters

parameters

Type Parameters

TChannel

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[DefaultValueAttribute()]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : GetProperty<T> Method

parameters

Syntax

Visual Basic (Declaration)
Public Function GetProperty(Of T)( _
   ByVal parameters As BindingParameterCollection _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim parameters As BindingParameterCollection
Dim value As T

value = instance.GetProperty(Of T)(parameters)
C#
public T GetProperty<T>(
   BindingParameterCollection parameters
)
Delphi
public function GetProperty(
    parameters: BindingParameterCollection
): T;
JScript
public function GetProperty(
   parameters : BindingParameterCollection
) : T;
Managed Extensions for C++
public: T* GetProperty<T>(
   BindingParameterCollection* parameters
)
C++/CLI
public:
T^ GetPropertygeneric<typename T>
(
   BindingParameterCollection^ parameters
)

Parameters

parameters

Type Parameters

T

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MessageVersion Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : MessageVersion Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageVersion As MessageVersion
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As MessageVersion

value = instance.MessageVersion
C#
public MessageVersion MessageVersion {get;}
Delphi
public read-only property MessageVersion: MessageVersion;
JScript
public function get MessageVersion : MessageVersion
Managed Extensions for C++
public: __property MessageVersion* get_MessageVersion();
C++/CLI
public:
property MessageVersion^ MessageVersion {
   MessageVersion^ get();
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : Name Property

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
public function get,set Name : String
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Namespace Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As String

instance.Namespace = value

value = instance.Namespace
C#
public string Namespace {get; set;}
Delphi
public read-write property Namespace: String;
JScript
public function get,set Namespace : String
Managed Extensions for C++
public: __property string* get_Namespace();
public: __property void set_Namespace(
   string* value
);
C++/CLI
public:
property String^ Namespace {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[DefaultValueAttribute()]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValueAttribute()]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SmartHttpBinding Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBinding
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[DefaultValueAttribute()]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
DefaultValueAttribute()
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBinding Class
SmartHttpBinding Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : GetProperty<T> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public virtual T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; virtual;
JScript
public function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: virtual T* GetProperty<T>(
   BindingContext* context
)
C++/CLI
public:
virtual T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

T

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[DefaultValueAttribute()]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
DefaultValueAttribute()
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : MaxBufferPoolSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[DefaultValueAttribute()]
public virtual long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxBufferPoolSize();
public: __property virtual void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpDuplexTransportBindingElement Class : MaxReceivedMessageSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[DefaultValueAttribute()]
public virtual long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxReceivedMessageSize();
public: __property virtual void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

SoapTcpDuplexTransportBindingElement Class
SoapTcpDuplexTransportBindingElement Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : GetProperty<T> Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProperty(Of T)( _
   ByVal context As BindingContext _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim context As BindingContext
Dim value As T

value = instance.GetProperty(Of T)(context)
C#
public virtual T GetProperty<T>(
   BindingContext context
)
Delphi
public function GetProperty(
    context: BindingContext
): T; virtual;
JScript
public function GetProperty(
   context : BindingContext
) : T;
Managed Extensions for C++
public: virtual T* GetProperty<T>(
   BindingContext* context
)
C++/CLI
public:
virtual T^ GetPropertygeneric<typename T>
(
   BindingContext^ context
)

Parameters

context

Type Parameters

T

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[DefaultValueAttribute()]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
DefaultValueAttribute()
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : MaxBufferPoolSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[DefaultValueAttribute()]
public virtual long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxBufferPoolSize();
public: __property virtual void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Channels Namespace > SoapTcpTransportBindingElement Class : MaxReceivedMessageSize Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportBindingElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[DefaultValueAttribute()]
public virtual long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64; virtual;
JScript
DefaultValueAttribute()
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual long get_MaxReceivedMessageSize();
public: __property virtual void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

SoapTcpTransportBindingElement Class
SoapTcpTransportBindingElement Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.WCFX.Channels Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.Utils.ByteCounterStream
System.IO.Stream
System.MarshalByRefObject
Noemax.WCFX.Channels.MessageStatisticsBindingElement.DiagnosticMessageEncodingBindingElement.DiagnosticMessageEncoderFactory.DiagnosticMessageEncoder.MessageSizeCounterStream
Noemax.Utils.CommunicationObjectPoolMap<Key,T>
Noemax.WCFX.Channels.HttpConnectionFactoryPool
Noemax.Utils.ThreadPoolAsyncResultBase
Noemax.WCFX.Channels.HttpRequestChannelFactory.HttpRequestChannel.AsyncRequestOperation
Noemax.WCFX.Channels.Activation.ConnectionPortManager<T>
Noemax.WCFX.Channels.SoapTcpPort
Noemax.WCFX.Channels.AsyncBufferedInputStream.ReadIntoBufferResult
Noemax.WCFX.Channels.closeChannelRequest
Noemax.WCFX.Channels.closeChannelResponse
Noemax.WCFX.Channels.CompressionStreamBindingElement.CompressionStreamUpgradeBindingParameter
Noemax.WCFX.Channels.ContentEncoding
Noemax.WCFX.Channels.DeflateCompressionFactory
Noemax.WCFX.Channels.GzipCompressionFactory
Noemax.WCFX.Channels.Lzf3CompressionFactory
Noemax.WCFX.Channels.LzfCompressionFactory
Noemax.WCFX.Channels.LzmaCompressionFactory
Noemax.WCFX.Channels.ContentNegotiationContextFactory
Noemax.WCFX.Channels.ContentNegotiationContextProperty
Noemax.WCFX.Channels.EmbeddedParam
Noemax.WCFX.Channels.EncodedContentDescription
Noemax.WCFX.Channels.EncodingCompressionMethodConverter
Noemax.WCFX.Channels.FiEncoderMessageWriter
Noemax.WCFX.Channels.HttpAuthentication
Noemax.WCFX.Channels.HttpAuthenticationScheme
Noemax.WCFX.Channels.HttpBasicAuthentication
Noemax.WCFX.Channels.HttpChannelListener.AcceptChannelResult
Noemax.WCFX.Channels.HttpConnectionContext.SyncCompleteResult
Noemax.WCFX.Channels.HttpEncodingContext
Noemax.WCFX.Channels.HttpHeader
Noemax.WCFX.Channels.HttpMessageReader
Noemax.WCFX.Channels.HttpRequestReader
Noemax.WCFX.Channels.HttpResponseReader
Noemax.WCFX.Channels.HttpMessageReader.BufferingResult
Noemax.WCFX.Channels.HttpMessageWriter
Noemax.WCFX.Channels.HttpRequestWriter
Noemax.WCFX.Channels.HttpResponseWriter
Noemax.WCFX.Channels.HttpPort
Noemax.WCFX.Channels.HttpReplyChannel.MexWSDLReplyInterceptor
Noemax.WCFX.Channels.HttpStatus
Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement.SslViaProxySecurityCapabilities
Noemax.WCFX.Channels.initiateSessionRequest
Noemax.WCFX.Channels.initiateSessionResponse
Noemax.WCFX.Channels.LogWriter
Noemax.WCFX.Channels.MessageEncoderSelector
Noemax.WCFX.Channels.MessageEncodingBindingElementCollection
Noemax.WCFX.Channels.MessageStreaming
Noemax.WCFX.Channels.mimeType
Noemax.WCFX.Channels.MultistateFIMessageEncoder.ReaderVocabularyEntry
Noemax.WCFX.Channels.openChannelRequest
Noemax.WCFX.Channels.openChannelResponse
Noemax.WCFX.Channels.ReceivedMessageState
Noemax.WCFX.Channels.ServiceChannelException
Noemax.WCFX.Channels.SmartHttpMessageEncodingBindingElement.ReaderQuotasHolder
Noemax.WCFX.Channels.SoapDictionary
Noemax.WCFX.Channels.SoapTcpBinaryReader
Noemax.WCFX.Channels.SoapTcpBinaryWriter
Noemax.WCFX.Channels.SoapTcpChannelBase.AsyncSendOperation
Noemax.WCFX.Channels.SoapTcpChannelContext
Noemax.WCFX.Channels.SoapTcpChannelListenerBase.AcceptChannelResult
Noemax.WCFX.Channels.SoapTcpChannelSettings
Noemax.WCFX.Channels.SoapTcpConnection
Noemax.WCFX.Channels.SoapTcpConnectionManager
Noemax.WCFX.Channels.SoapTcpConnectionManager.ConnectionPool
Noemax.WCFX.Channels.SoapTcpContentDescription
Noemax.WCFX.Channels.SoapTcpFrame
Noemax.WCFX.Channels.SoapTcpFramedStreamWriter
Noemax.WCFX.Channels.SoapTcpHandshake
Noemax.WCFX.Channels.SoapTcpHandshakeFormatter
Noemax.WCFX.Channels.SoapTcpHeaderFlags
Noemax.WCFX.Channels.SoapTcpMessageReader
Noemax.WCFX.Channels.SoapTcpMessageReaderBase<T>
Noemax.WCFX.Channels.SoapTcpBufferedMessageReader
Noemax.WCFX.Channels.SoapTcpStreamedMessageReader
Noemax.WCFX.Channels.SoapTcpMessageReaderBase.WaitForMessageResult
Noemax.WCFX.Channels.SoapTcpMessageReaderStream.AsyncReadFrameHeaderResult
Noemax.WCFX.Channels.SoapTcpMessageType
Noemax.WCFX.Channels.SoapTcpRequestChannelFactory.SoapTcpRequestChannel.AsyncRequestOperation
Noemax.WCFX.Channels.SoapTcpServiceChannelDispatcher.POXMessageInvoker<TInput,TOutput,TContext>
Noemax.WCFX.Channels.SoapTcpSession
Noemax.WCFX.Channels.SoapTcpSessionManager
Noemax.WCFX.Channels.SoapTcpUtils
Noemax.WCFX.Channels.SocksSettings
Noemax.WCFX.Channels.TransferEncoding
Noemax.WCFX.Channels.HttpChunkedTransferEncoding
Noemax.WCFX.Channels.TransferModeHelper
Noemax.WCFX.Channels.WcfxPolicyImporter
Noemax.Xml.XmlFastInfosetDictionaryReader
System.Xml.XmlDictionaryReader
System.Xml.XmlReader
Noemax.WCFX.Channels.FiEncoderMessageReader
System.IO.Stream
System.MarshalByRefObject
Noemax.WCFX.Channels.AsyncBufferedInputStream
Noemax.WCFX.Channels.BufferedInputStream
Noemax.WCFX.Channels.BufferedMessageReaderStream
Noemax.WCFX.Channels.BufferedMessageWriterStream
Noemax.WCFX.Channels.BufferedOutputStream
Noemax.WCFX.Channels.CompressionUpgradeStream
Noemax.WCFX.Channels.HttpChunkedTransferEncoding.ChunkedTransferStreamBase
Noemax.WCFX.Channels.HttpChunkedTransferEncoding.ChunkedTransferReaderStream
Noemax.WCFX.Channels.HttpChunkedTransferEncoding.ChunkedTransferWriterStream
Noemax.WCFX.Channels.HttpDrainConnectionReaderStream
Noemax.WCFX.Channels.HttpKnownLengthReaderStream
Noemax.WCFX.Channels.HttpThresholdStream
Noemax.WCFX.Channels.MessageStreaming.Base64StreamReader
Noemax.WCFX.Channels.SoapTcpFramedStreamWriter.ChunkedOutputStream
Noemax.WCFX.Channels.SoapTcpMessageReaderStream
Noemax.WCFX.Channels.SoapTcpMessageReaderStream.IncommingMessageStream
System.ServiceModel.Channels.Binding
Noemax.WCFX.Channels.BasicSoapTcpBinding
Noemax.WCFX.Channels.DuplexSoapTcpBinding
Noemax.WCFX.Channels.SmartHttpBinding
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.CompressionBindingElement
Noemax.WCFX.Channels.ContentNegotiationBindingElement
Noemax.WCFX.Channels.MessageStatisticsBindingElement
Noemax.WCFX.Channels.SecurityUpdateBindingElementBase
Noemax.WCFX.Channels.LocalClientSecurityUpdateBindingElement
Noemax.WCFX.Channels.LocalServiceSecurityUpdateBindingElement
Noemax.WCFX.Channels.StreamEnhancerBindingElement
System.ServiceModel.Channels.BodyWriter
Noemax.WCFX.Channels.FaultMessage<TDetail>
Noemax.WCFX.Channels.MessageStreaming.StreamBodyWriter
Noemax.WCFX.Channels.SoapTcpServiceChannelClientChannel.SerivceChannelOperation<TRequest,TResponse>
Noemax.WCFX.Channels.SoapTcpServiceChannelDispatcher.POXMessageInvoker.OutputWriter
System.ServiceModel.Channels.ChannelBase
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.HttpChannelBase
Noemax.WCFX.Channels.HttpReplyChannel
Noemax.WCFX.Channels.HttpRequestChannelFactory.HttpRequestChannel
Noemax.WCFX.Channels.SmartHttpChannelFactory.SmartEncodingRequestChannel
Noemax.WCFX.Channels.SmartHttpReplyChannel<TChannel>
Noemax.WCFX.Channels.SoapTcpChannelBase
Noemax.WCFX.Channels.SoapTcpCommonReplyChannel
Noemax.WCFX.Channels.SoapTcpDuplexChannel
Noemax.WCFX.Channels.SoapTcpClientChannelBase<TChannel>
Noemax.WCFX.Channels.SoapTcpDuplexChannelFactory.SoapTcpDuplexClientChannel
Noemax.WCFX.Channels.SoapTcpDuplexSessionChannelFactory.SoapTcpDuplexClientChannel
Noemax.WCFX.Channels.SoapTcpRequestChannelFactory.SoapTcpRequestChannel
Noemax.WCFX.Channels.SoapTcpReplyChannel
Noemax.WCFX.Channels.SoapTcpServiceChannelClientChannel
System.ServiceModel.Channels.ChannelFactoryBase<TChannel>
System.ServiceModel.Channels.ChannelFactoryBase
System.ServiceModel.Channels.ChannelManagerBase
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.HttpRequestChannelFactory
Noemax.WCFX.Channels.SmartHttpChannelFactory<TChannel>
Noemax.WCFX.Channels.SoapTcpChannelFactoryBase<TChannel>
Noemax.WCFX.Channels.SoapTcpDuplexChannelFactory
Noemax.WCFX.Channels.SoapTcpDuplexSessionChannelFactory
Noemax.WCFX.Channels.SoapTcpRequestChannelFactory
Noemax.WCFX.Channels.SoapTcpServiceChannelFactory
System.ServiceModel.Channels.ChannelListenerBase
System.ServiceModel.Channels.ChannelManagerBase
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.SmartHttpChannelListener<TChannel>
System.ServiceModel.Channels.ChannelListenerBase<TChannel>
System.ServiceModel.Channels.ChannelListenerBase
System.ServiceModel.Channels.ChannelManagerBase
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.HttpChannelListener
Noemax.WCFX.Channels.SoapTcpChannelListenerBase<TChannel>
Noemax.WCFX.Channels.SoapTcpChannelListener<TChannel>
Noemax.WCFX.Channels.SoapTcpCommonReplyChannelListener
Noemax.WCFX.Channels.SoapTcpDuplexChannelListener<TChannel>
Noemax.WCFX.Channels.SoapTcpReplyChannelListener
Noemax.WCFX.Channels.SoapTcpServiceChannelListener
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.HttpConnectionContext
Noemax.WCFX.Channels.SoapTcpServiceChannelDispatcher
Noemax.WCFX.Channels.SoapTcpServiceChannelImpl
System.ServiceModel.Channels.HttpTransportBindingElement
System.ServiceModel.Channels.TransportBindingElement
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.HttpsViaProxyTransportBindingElement
System.ServiceModel.Channels.Message
Noemax.WCFX.Channels.DelegatingMessage
Noemax.WCFX.Behaviors.EnvelopeFormatter.EnvelopedMessage
Noemax.WCFX.Channels.ReceivedMessage
Noemax.WCFX.Channels.SmartHttpMessageEncoderFactory.HttpMessage
System.ServiceModel.Channels.MessageEncoder
Noemax.WCFX.Channels.CompressionBindingElement.CompressionMessageEncodingBindingElement.CompressionMessageEncoderFactory.CompressionMessageEncoder
Noemax.WCFX.Channels.FiMessageEncoderBase
Noemax.WCFX.Channels.FIMessageEncoder
Noemax.WCFX.Channels.MultistateFIMessageEncoder
Noemax.WCFX.Channels.StatefulFIMessageEncoder
Noemax.WCFX.Channels.MessageStatisticsBindingElement.DiagnosticMessageEncodingBindingElement.DiagnosticMessageEncoderFactory.DiagnosticMessageEncoder
Noemax.WCFX.Channels.SmartMessageEncoder
Noemax.WCFX.Channels.SmartHttpMessageEncoderFactory.HttpMessageEncoder
Noemax.WCFX.Channels.StreamEnhancerBindingElement.SurrogateMessageEncodingBindingElement.SurrogateMessageEncoderFactory.SurrogateMessageEncoder
Noemax.WCFX.Channels.TextMessageEncodingWrapperBindingElement.TextMessageEncoderWrapperFactory.TextMessageEncoderWrapper
System.ServiceModel.Channels.MessageEncoderFactory
Noemax.WCFX.Channels.CompressionBindingElement.CompressionMessageEncodingBindingElement.CompressionMessageEncoderFactory
Noemax.WCFX.Channels.FIMessageEncoderFactory
Noemax.WCFX.Channels.MessageStatisticsBindingElement.DiagnosticMessageEncodingBindingElement.DiagnosticMessageEncoderFactory
Noemax.WCFX.Channels.SmartMessageEncoderFactory
Noemax.WCFX.Channels.SmartHttpMessageEncoderFactory
Noemax.WCFX.Channels.StreamEnhancerBindingElement.SurrogateMessageEncodingBindingElement.SurrogateMessageEncoderFactory
Noemax.WCFX.Channels.TextMessageEncodingWrapperBindingElement.TextMessageEncoderWrapperFactory
System.ServiceModel.Channels.MessageEncodingBindingElement
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.CompressionBindingElement.CompressionMessageEncodingBindingElement
Noemax.WCFX.Channels.MessageStatisticsBindingElement.DiagnosticMessageEncodingBindingElement
Noemax.WCFX.Channels.PluggableMessageEncodingBindingElement
Noemax.WCFX.Channels.FiMessageEncodingBindingElement
Noemax.WCFX.Channels.SmartHttpMessageEncodingBindingElement
Noemax.WCFX.Channels.StreamEnhancerBindingElement.SurrogateMessageEncodingBindingElement
Noemax.WCFX.Channels.TextMessageEncodingWrapperBindingElement
System.ServiceModel.Channels.MessageHeader
System.ServiceModel.Channels.MessageHeaderInfo
Noemax.WCFX.Channels.BufferedHeader
System.ServiceModel.Channels.RequestContext
Noemax.WCFX.Channels.HttpRequestContext
Noemax.WCFX.Channels.SmartHttpReplyChannel.SmartRequestContext
Noemax.WCFX.Channels.SoapTcpCommonReplyChannel.SoapTcpRequestContext
Noemax.WCFX.Channels.SoapTcpReplyChannel.SoapTcpRequestContext
System.ServiceModel.Channels.StreamUpgradeAcceptor
Noemax.WCFX.Channels.CompressionStreamBindingElement.CompressionStreamUpgradeProvider.CompressionStreamUpgradeAcceptor
System.ServiceModel.Channels.StreamUpgradeBindingElement
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.CompressionStreamBindingElement
System.ServiceModel.Channels.StreamUpgradeInitiator
Noemax.WCFX.Channels.CompressionStreamBindingElement.CompressionStreamUpgradeProvider.CompressionStreamUpgradeInitiator
System.ServiceModel.Channels.StreamUpgradeProvider
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.Channels.CompressionStreamBindingElement.CompressionStreamUpgradeProvider
System.ServiceModel.Channels.TransportBindingElement
System.ServiceModel.Channels.BindingElement
Noemax.WCFX.Channels.LiteHttpsTransportBindingElement
Noemax.WCFX.Channels.LiteHttpTransportBindingElement
Noemax.WCFX.Channels.SoapTcpServiceChannelBindingElement
Noemax.WCFX.Channels.SoapTcpTransportBindingElement
Noemax.WCFX.Channels.SoapTcpDuplexTransportBindingElement
System.ValueType
Noemax.WCFX.Channels.EncodedContentDescrParam
Noemax.WCFX.Channels.ReceivedMessage.Attribute
System.Xml.XmlDictionaryWriter
System.Xml.XmlWriter
Noemax.WCFX.Channels.DelegatingXmlDictionaryWriter

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingCollectionElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingCollectionElement Class

For a list of all members of this type, see BasicSoapTcpBindingCollectionElement members.

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
BasicSoapTcpBindingCollectionElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : BasicSoapTcpBindingCollectionElement Class

For a list of all members of this type, see BasicSoapTcpBindingCollectionElement members.

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<BasicSoapTcpBinding,BasicSoapTcpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : BindingName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingName As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As String

value = instance.BindingName
C#
public string BindingName {get;}
Delphi
public read-only property BindingName: String;
JScript
public function get BindingName : String
Managed Extensions for C++
public: __property string* get_BindingName();
C++/CLI
public:
property String^ BindingName {
   String^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Bindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : Bindings Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property Bindings As StandardBindingElementCollection(Of BasicSoapTcpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As StandardBindingElementCollection(Of BasicSoapTcpBindingElement)

value = instance.Bindings
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public StandardBindingElementCollection<BasicSoapTcpBindingElement> Bindings {get;}
Delphi
public read-only property Bindings: StandardBindingElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get Bindings : StandardBindingElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property StandardBindingElementCollection<BasicSoapTcpBindingElement*>* get_Bindings();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property StandardBindingElementCollection<BasicSoapTcpBindingElement^>^ Bindings {
   StandardBindingElementCollection<BasicSoapTcpBindingElement^>^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : BindingType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BindingType As Type
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As Type

value = instance.BindingType
C#
public virtual Type BindingType {get;}
Delphi
public read-only property BindingType: Type; virtual;
JScript
public function get BindingType : Type
Managed Extensions for C++
public: __property virtual Type* get_BindingType();
C++/CLI
public:
virtual property Type^ BindingType {
   Type^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfiguredBindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : ConfiguredBindings Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ConfiguredBindings As ReadOnlyCollection(Of IBindingConfigurationElement)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ReadOnlyCollection(Of IBindingConfigurationElement)

value = instance.ConfiguredBindings
C#
public virtual ReadOnlyCollection<IBindingConfigurationElement> ConfiguredBindings {get;}
Delphi
public read-only property ConfiguredBindings: ReadOnlyCollection; virtual;
JScript
public function get ConfiguredBindings : ReadOnlyCollection
Managed Extensions for C++
public: __property virtual ReadOnlyCollection<IBindingConfigurationElement*>* get_ConfiguredBindings();
C++/CLI
public:
virtual property ReadOnlyCollection<IBindingConfigurationElement^>^ ConfiguredBindings {
   ReadOnlyCollection<IBindingConfigurationElement^>^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContainsKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : ContainsKey Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsKey( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim name As String
Dim value As Boolean

value = instance.ContainsKey(name)
C#
public virtual bool ContainsKey(
   string name
)
Delphi
public function ContainsKey(
    name: String
): Boolean; virtual;
JScript
public function ContainsKey(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ContainsKey(
   string* name
)
C++/CLI
public:
virtual bool ContainsKey(
   String^ name
)

Parameters

name

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : Properties Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection;
JScript
protected function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties();
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingCollectionElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingCollectionElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

BasicSoapTcpBindingCollectionElement Class
BasicSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : ApplyConfiguration Method

binding

Syntax

Visual Basic (Declaration)
Public Sub ApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim binding As Binding

instance.ApplyConfiguration(binding)
C#
public void ApplyConfiguration(
   Binding binding
)
Delphi
public procedure ApplyConfiguration(
    binding: Binding
);
JScript
public function ApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
public: void ApplyConfiguration(
   Binding* binding
)
C++/CLI
public:
void ApplyConfiguration(
   Binding^ binding
)

Parameters

binding

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : Name Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=True)>
<StringValidatorAttribute()>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As String

instance.Name = value

value = instance.Name
C#
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
StringValidatorAttribute()
public function get,set Name : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BasicSoapTcpBindingElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BasicSoapTcpBindingElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

BasicSoapTcpBindingElement Class
BasicSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseIndexOf Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : BaseIndexOf Method

element

Syntax

Visual Basic (Declaration)
Protected Function BaseIndexOf( _
   ByVal element As ConfigurationElement _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim element As ConfigurationElement
Dim value As Integer

value = instance.BaseIndexOf(element)
C#
protected int BaseIndexOf(
   ConfigurationElement element
)
Delphi
protected function BaseIndexOf(
    element: ConfigurationElement
): Integer;
JScript
protected function BaseIndexOf(
   element : ConfigurationElement
) : int;
Managed Extensions for C++
protected: int BaseIndexOf(
   ConfigurationElement* element
)
C++/CLI
protected:
int BaseIndexOf(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo(ConfigurationElement[],Int32) Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class > CopyTo Method : CopyTo(ConfigurationElement[],Int32) Method

array
index

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As ConfigurationElement, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim array() As ConfigurationElement
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ConfigurationElement[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ConfigurationElementarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ConfigurationElement[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ConfigurationElement*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ConfigurationElement^>^ array,
   int index
)

Parameters

array
index

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement() Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class > CreateNewElement Method : CreateNewElement() Method

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function CreateNewElement() As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationElement

value = instance.CreateNewElement()
C#
protected virtual ConfigurationElement CreateNewElement()
Delphi
protected function CreateNewElement(): ConfigurationElement; virtual;
JScript
protected function CreateNewElement() : ConfigurationElement;
Managed Extensions for C++
protected: virtual ConfigurationElement* CreateNewElement();
C++/CLI
protected:
virtual ConfigurationElement^ CreateNewElement();

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : ElementName Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ElementName As String
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As String

value = instance.ElementName
C#
protected string ElementName {get;}
Delphi
protected read-only property ElementName: String;
JScript
protected function get ElementName : String
Managed Extensions for C++
protected: __property string* get_ElementName();
C++/CLI
protected:
property String^ ElementName {
   String^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EmitClear Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : EmitClear Property

Syntax

Visual Basic (Declaration)
Public Property EmitClear As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Boolean

instance.EmitClear = value

value = instance.EmitClear
C#
public bool EmitClear {get; set;}
Delphi
public read-write property EmitClear: Boolean;
JScript
public function get,set EmitClear : boolean
Managed Extensions for C++
public: __property bool get_EmitClear();
public: __property void set_EmitClear(
   bool value
);
C++/CLI
public:
property bool EmitClear {
   bool get();
   void set (    bool value);
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementRemovable Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : IsElementRemovable Method

element

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsElementRemovable( _
   ByVal element As ConfigurationElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim element As ConfigurationElement
Dim value As Boolean

value = instance.IsElementRemovable(element)
C#
protected virtual bool IsElementRemovable(
   ConfigurationElement element
)
Delphi
protected function IsElementRemovable(
    element: ConfigurationElement
): Boolean; virtual;
JScript
protected function IsElementRemovable(
   element : ConfigurationElement
) : boolean;
Managed Extensions for C++
protected: virtual bool IsElementRemovable(
   ConfigurationElement* element
)
C++/CLI
protected:
virtual bool IsElementRemovable(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsSynchronized Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Delphi
public read-only property IsSynchronized: Boolean;
JScript
public function get IsSynchronized : boolean
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SyncRoot Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Delphi
public read-only property SyncRoot: TObject;
JScript
public function get SyncRoot : Object
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ThrowOnDuplicate Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > BindingElementExtensionElementCollection<TBindingElementExtension> Class : ThrowOnDuplicate Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ThrowOnDuplicate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingElementExtensionElementCollection(Of TBindingElementExtension)
Dim value As Boolean

value = instance.ThrowOnDuplicate
C#
protected bool ThrowOnDuplicate {get;}
Delphi
protected read-only property ThrowOnDuplicate: Boolean;
JScript
protected function get ThrowOnDuplicate : boolean
Managed Extensions for C++
protected: __property bool get_ThrowOnDuplicate();
C++/CLI
protected:
property bool ThrowOnDuplicate {
   bool get();
}

See Also

Reference

BindingElementExtensionElementCollection<TBindingElementExtension> Class
BindingElementExtensionElementCollection<TBindingElementExtension> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > CompressionElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As CompressionElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

CompressionElement Class
CompressionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ApplyConfiguration Method

bindingElement

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public virtual void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); virtual;
JScript
public function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: virtual void ApplyConfiguration(
   BindingElement* bindingElement
)
C++/CLI
public:
virtual void ApplyConfiguration(
   BindingElement^ bindingElement
)

Parameters

bindingElement

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ContentNegotiationElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ContentNegotiationElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

ContentNegotiationElement Class
ContentNegotiationElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingCollectionElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingCollectionElement Class

For a list of all members of this type, see DuplexSoapTcpBindingCollectionElement members.

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingCollectionElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingCollectionElement Class

For a list of all members of this type, see DuplexSoapTcpBindingCollectionElement members.

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<DuplexSoapTcpBinding,DuplexSoapTcpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : BindingName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingName As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As String

value = instance.BindingName
C#
public string BindingName {get;}
Delphi
public read-only property BindingName: String;
JScript
public function get BindingName : String
Managed Extensions for C++
public: __property string* get_BindingName();
C++/CLI
public:
property String^ BindingName {
   String^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Bindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : Bindings Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property Bindings As StandardBindingElementCollection(Of DuplexSoapTcpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As StandardBindingElementCollection(Of DuplexSoapTcpBindingElement)

value = instance.Bindings
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public StandardBindingElementCollection<DuplexSoapTcpBindingElement> Bindings {get;}
Delphi
public read-only property Bindings: StandardBindingElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get Bindings : StandardBindingElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property StandardBindingElementCollection<DuplexSoapTcpBindingElement*>* get_Bindings();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property StandardBindingElementCollection<DuplexSoapTcpBindingElement^>^ Bindings {
   StandardBindingElementCollection<DuplexSoapTcpBindingElement^>^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : BindingType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BindingType As Type
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As Type

value = instance.BindingType
C#
public virtual Type BindingType {get;}
Delphi
public read-only property BindingType: Type; virtual;
JScript
public function get BindingType : Type
Managed Extensions for C++
public: __property virtual Type* get_BindingType();
C++/CLI
public:
virtual property Type^ BindingType {
   Type^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfiguredBindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : ConfiguredBindings Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ConfiguredBindings As ReadOnlyCollection(Of IBindingConfigurationElement)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ReadOnlyCollection(Of IBindingConfigurationElement)

value = instance.ConfiguredBindings
C#
public virtual ReadOnlyCollection<IBindingConfigurationElement> ConfiguredBindings {get;}
Delphi
public read-only property ConfiguredBindings: ReadOnlyCollection; virtual;
JScript
public function get ConfiguredBindings : ReadOnlyCollection
Managed Extensions for C++
public: __property virtual ReadOnlyCollection<IBindingConfigurationElement*>* get_ConfiguredBindings();
C++/CLI
public:
virtual property ReadOnlyCollection<IBindingConfigurationElement^>^ ConfiguredBindings {
   ReadOnlyCollection<IBindingConfigurationElement^>^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContainsKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : ContainsKey Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsKey( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim name As String
Dim value As Boolean

value = instance.ContainsKey(name)
C#
public virtual bool ContainsKey(
   string name
)
Delphi
public function ContainsKey(
    name: String
): Boolean; virtual;
JScript
public function ContainsKey(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ContainsKey(
   string* name
)
C++/CLI
public:
virtual bool ContainsKey(
   String^ name
)

Parameters

name

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : Properties Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection;
JScript
protected function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties();
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingCollectionElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingCollectionElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

DuplexSoapTcpBindingCollectionElement Class
DuplexSoapTcpBindingCollectionElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
DuplexSoapTcpBindingElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : DuplexSoapTcpBindingElement Class

For a list of all members of this type, see DuplexSoapTcpBindingElement members.

Public Methods

 | Name | Description
public Method | ApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnApplyConfiguration | (Inherited from System.ServiceModel.Configuration.StandardBindingElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | Reset | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

DuplexSoapTcpBindingElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : ApplyConfiguration Method

binding

Syntax

Visual Basic (Declaration)
Public Sub ApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim binding As Binding

instance.ApplyConfiguration(binding)
C#
public void ApplyConfiguration(
   Binding binding
)
Delphi
public procedure ApplyConfiguration(
    binding: Binding
);
JScript
public function ApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
public: void ApplyConfiguration(
   Binding* binding
)
C++/CLI
public:
void ApplyConfiguration(
   Binding^ binding
)

Parameters

binding

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : Name Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=True)>
<StringValidatorAttribute()>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As String

instance.Name = value

value = instance.Name
C#
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
StringValidatorAttribute()
public function get,set Name : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : OnApplyConfiguration Method

binding

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim binding As Binding

instance.OnApplyConfiguration(binding)
C#
protected virtual void OnApplyConfiguration(
   Binding binding
)
Delphi
protected procedure OnApplyConfiguration(
    binding: Binding
); virtual;
JScript
protected function OnApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
protected: virtual void OnApplyConfiguration(
   Binding* binding
)
C++/CLI
protected:
virtual void OnApplyConfiguration(
   Binding^ binding
)

Parameters

binding

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : Properties Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection;
JScript
protected function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties();
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get();
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > DuplexSoapTcpBindingElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DuplexSoapTcpBindingElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

DuplexSoapTcpBindingElement Class
DuplexSoapTcpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > EnvelopeEndpointBehaviorElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As EnvelopeEndpointBehaviorElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

EnvelopeEndpointBehaviorElement Class
EnvelopeEndpointBehaviorElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : BindingName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingName As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As String

value = instance.BindingName
C#
public string BindingName {get;}
Delphi
public read-only property BindingName: String;
JScript
public function get BindingName : String
Managed Extensions for C++
public: __property string* get_BindingName();
C++/CLI
public:
property String^ BindingName {
   String^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingCollectionElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingCollectionElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

ExtensionBindingCollectionElement Class
ExtensionBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseIndexOf Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : BaseIndexOf Method

element

Syntax

Visual Basic (Declaration)
Protected Function BaseIndexOf( _
   ByVal element As ConfigurationElement _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim element As ConfigurationElement
Dim value As Integer

value = instance.BaseIndexOf(element)
C#
protected int BaseIndexOf(
   ConfigurationElement element
)
Delphi
protected function BaseIndexOf(
    element: ConfigurationElement
): Integer;
JScript
protected function BaseIndexOf(
   element : ConfigurationElement
) : int;
Managed Extensions for C++
protected: int BaseIndexOf(
   ConfigurationElement* element
)
C++/CLI
protected:
int BaseIndexOf(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ConfigurationElement, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim array() As ConfigurationElement
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ConfigurationElement[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ConfigurationElementarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ConfigurationElement[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ConfigurationElement*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ConfigurationElement^>^ array,
   int index
)

Parameters

array
index

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Count Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement(String) Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class > CreateNewElement Method : CreateNewElement(String) Method

elementName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overloads Overridable Function CreateNewElement( _
   ByVal elementName As String _
) As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim elementName As String
Dim value As ConfigurationElement

value = instance.CreateNewElement(elementName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected virtual ConfigurationElement CreateNewElement(
   string elementName
)
Delphi
protected function CreateNewElement(
    elementName: String
): ConfigurationElement; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function CreateNewElement(
   elementName : String
) : ConfigurationElement;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: virtual ConfigurationElement* CreateNewElement(
   string* elementName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
virtual ConfigurationElement^ CreateNewElement(
   String^ elementName
)

Parameters

elementName

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EmitClear Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : EmitClear Property

Syntax

Visual Basic (Declaration)
Public Property EmitClear As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Boolean

instance.EmitClear = value

value = instance.EmitClear
C#
public bool EmitClear {get; set;}
Delphi
public read-write property EmitClear: Boolean;
JScript
public function get,set EmitClear : boolean
Managed Extensions for C++
public: __property bool get_EmitClear();
public: __property void set_EmitClear(
   bool value
);
C++/CLI
public:
property bool EmitClear {
   bool get();
   void set (    bool value);
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetEnumerator Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: IEnumerator* GetEnumerator();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
IEnumerator^ GetEnumerator();

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementName Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : IsElementName Method

elementName

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsElementName( _
   ByVal elementName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim elementName As String
Dim value As Boolean

value = instance.IsElementName(elementName)
C#
protected virtual bool IsElementName(
   string elementName
)
Delphi
protected function IsElementName(
    elementName: String
): Boolean; virtual;
JScript
protected function IsElementName(
   elementName : String
) : boolean;
Managed Extensions for C++
protected: virtual bool IsElementName(
   string* elementName
)
C++/CLI
protected:
virtual bool IsElementName(
   String^ elementName
)

Parameters

elementName

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementRemovable Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : IsElementRemovable Method

element

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsElementRemovable( _
   ByVal element As ConfigurationElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim element As ConfigurationElement
Dim value As Boolean

value = instance.IsElementRemovable(element)
C#
protected virtual bool IsElementRemovable(
   ConfigurationElement element
)
Delphi
protected function IsElementRemovable(
    element: ConfigurationElement
): Boolean; virtual;
JScript
protected function IsElementRemovable(
   element : ConfigurationElement
) : boolean;
Managed Extensions for C++
protected: virtual bool IsElementRemovable(
   ConfigurationElement* element
)
C++/CLI
protected:
virtual bool IsElementRemovable(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsSynchronized Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Delphi
public read-only property IsSynchronized: Boolean;
JScript
public function get IsSynchronized : boolean
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SyncRoot Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Delphi
public read-only property SyncRoot: TObject;
JScript
public function get SyncRoot : Object
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ThrowOnDuplicate Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElementCollection Class : ThrowOnDuplicate Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ThrowOnDuplicate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElementCollection
Dim value As Boolean

value = instance.ThrowOnDuplicate
C#
protected bool ThrowOnDuplicate {get;}
Delphi
protected read-only property ThrowOnDuplicate: Boolean;
JScript
protected function get ThrowOnDuplicate : boolean
Managed Extensions for C++
protected: __property bool get_ThrowOnDuplicate();
C++/CLI
protected:
property bool ThrowOnDuplicate {
   bool get();
}

See Also

Reference

ExtensionBindingElementCollection Class
ExtensionBindingElementCollection Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > ExtensionBindingElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtensionBindingElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

ExtensionBindingElement Class
ExtensionBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > FiMessageEncodingElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As FiMessageEncodingElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

FiMessageEncodingElement Class
FiMessageEncodingElement Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
GenericConfigurationElementCollection<TConfigurationElement> Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : GenericConfigurationElementCollection<TConfigurationElement> Class

For a list of all members of this type, see GenericConfigurationElementCollection<TConfigurationElement> members.

Public Properties

 | Name | Description
public Property | CollectionType | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | Count | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | EmitClear | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | IsSynchronized | (Inherited from System.Configuration.ConfigurationElementCollection)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
public Property | SyncRoot | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

Protected Properties

 | Name | Description
protected Property | ElementName | (Inherited from System.Configuration.ConfigurationElementCollection)
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | ThrowOnDuplicate | (Inherited from System.Configuration.ConfigurationElementCollection)
Top

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseIndexOf Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : BaseIndexOf Method

element

Syntax

Visual Basic (Declaration)
Protected Function BaseIndexOf( _
   ByVal element As ConfigurationElement _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim element As ConfigurationElement
Dim value As Integer

value = instance.BaseIndexOf(element)
C#
protected int BaseIndexOf(
   ConfigurationElement element
)
Delphi
protected function BaseIndexOf(
    element: ConfigurationElement
): Integer;
JScript
protected function BaseIndexOf(
   element : ConfigurationElement
) : int;
Managed Extensions for C++
protected: int BaseIndexOf(
   ConfigurationElement* element
)
C++/CLI
protected:
int BaseIndexOf(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CollectionType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : CollectionType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CollectionType As ConfigurationElementCollectionType
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationElementCollectionType

value = instance.CollectionType
C#
public virtual ConfigurationElementCollectionType CollectionType {get;}
Delphi
public read-only property CollectionType: ConfigurationElementCollectionType; virtual;
JScript
public function get CollectionType : ConfigurationElementCollectionType
Managed Extensions for C++
public: __property virtual ConfigurationElementCollectionType get_CollectionType();
C++/CLI
public:
virtual property ConfigurationElementCollectionType CollectionType {
   ConfigurationElementCollectionType get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyTo Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ConfigurationElement, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim array() As ConfigurationElement
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ConfigurationElement[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ConfigurationElementarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ConfigurationElement[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ConfigurationElement*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<ConfigurationElement^>^ array,
   int index
)

Parameters

array
index

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Count Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateNewElement(String) Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class > CreateNewElement Method : CreateNewElement(String) Method

elementName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overloads Overridable Function CreateNewElement( _
   ByVal elementName As String _
) As ConfigurationElement
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim elementName As String
Dim value As ConfigurationElement

value = instance.CreateNewElement(elementName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected virtual ConfigurationElement CreateNewElement(
   string elementName
)
Delphi
protected function CreateNewElement(
    elementName: String
): ConfigurationElement; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function CreateNewElement(
   elementName : String
) : ConfigurationElement;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: virtual ConfigurationElement* CreateNewElement(
   string* elementName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
virtual ConfigurationElement^ CreateNewElement(
   String^ elementName
)

Parameters

elementName

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : ElementName Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ElementName As String
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As String

value = instance.ElementName
C#
protected string ElementName {get;}
Delphi
protected read-only property ElementName: String;
JScript
protected function get ElementName : String
Managed Extensions for C++
protected: __property string* get_ElementName();
C++/CLI
protected:
property String^ ElementName {
   String^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EmitClear Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : EmitClear Property

Syntax

Visual Basic (Declaration)
Public Property EmitClear As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Boolean

instance.EmitClear = value

value = instance.EmitClear
C#
public bool EmitClear {get; set;}
Delphi
public read-write property EmitClear: Boolean;
JScript
public function get,set EmitClear : boolean
Managed Extensions for C++
public: __property bool get_EmitClear();
public: __property void set_EmitClear(
   bool value
);
C++/CLI
public:
property bool EmitClear {
   bool get();
   void set (    bool value);
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetElementKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : GetElementKey Method

element

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetElementKey( _
   ByVal element As ConfigurationElement _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim element As ConfigurationElement
Dim value As Object

value = instance.GetElementKey(element)
C#
protected abstract object GetElementKey(
   ConfigurationElement element
)
Delphi
protected function GetElementKey(
    element: ConfigurationElement
): TObject; abstract;
JScript
protected __abstract function GetElementKey(
   element : ConfigurationElement
) : Object;
Managed Extensions for C++
protected: abstract Object* GetElementKey(
   ConfigurationElement* element
)
C++/CLI
protected:
abstract Object^ GetElementKey(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetEnumerator Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: IEnumerator* GetEnumerator();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
IEnumerator^ GetEnumerator();

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementName Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : IsElementName Method

elementName

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsElementName( _
   ByVal elementName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim elementName As String
Dim value As Boolean

value = instance.IsElementName(elementName)
C#
protected virtual bool IsElementName(
   string elementName
)
Delphi
protected function IsElementName(
    elementName: String
): Boolean; virtual;
JScript
protected function IsElementName(
   elementName : String
) : boolean;
Managed Extensions for C++
protected: virtual bool IsElementName(
   string* elementName
)
C++/CLI
protected:
virtual bool IsElementName(
   String^ elementName
)

Parameters

elementName

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsElementRemovable Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : IsElementRemovable Method

element

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsElementRemovable( _
   ByVal element As ConfigurationElement _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim element As ConfigurationElement
Dim value As Boolean

value = instance.IsElementRemovable(element)
C#
protected virtual bool IsElementRemovable(
   ConfigurationElement element
)
Delphi
protected function IsElementRemovable(
    element: ConfigurationElement
): Boolean; virtual;
JScript
protected function IsElementRemovable(
   element : ConfigurationElement
) : boolean;
Managed Extensions for C++
protected: virtual bool IsElementRemovable(
   ConfigurationElement* element
)
C++/CLI
protected:
virtual bool IsElementRemovable(
   ConfigurationElement^ element
)

Parameters

element

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsSynchronized Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Delphi
public read-only property IsSynchronized: Boolean;
JScript
public function get IsSynchronized : boolean
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SyncRoot Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Delphi
public read-only property SyncRoot: TObject;
JScript
public function get SyncRoot : Object
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ThrowOnDuplicate Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > GenericConfigurationElementCollection<TConfigurationElement> Class : ThrowOnDuplicate Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ThrowOnDuplicate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GenericConfigurationElementCollection(Of TConfigurationElement)
Dim value As Boolean

value = instance.ThrowOnDuplicate
C#
protected bool ThrowOnDuplicate {get;}
Delphi
protected read-only property ThrowOnDuplicate: Boolean;
JScript
protected function get ThrowOnDuplicate : boolean
Managed Extensions for C++
protected: __property bool get_ThrowOnDuplicate();
C++/CLI
protected:
property bool ThrowOnDuplicate {
   bool get();
}

See Also

Reference

GenericConfigurationElementCollection<TConfigurationElement> Class
GenericConfigurationElementCollection<TConfigurationElement> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AllowCookies Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : AllowCookies Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property AllowCookies As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.AllowCookies = value

value = instance.AllowCookies
C#
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool AllowCookies {get; set;}
Delphi
public read-write property AllowCookies: Boolean;
JScript
ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set AllowCookies : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_AllowCookies();
public: __property void set_AllowCookies(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="allowCookies",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool AllowCookies {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ApplyConfiguration Method

bindingElement

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyConfiguration( _
   ByVal bindingElement As BindingElement _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)
C#
public virtual void ApplyConfiguration(
   BindingElement bindingElement
)
Delphi
public procedure ApplyConfiguration(
    bindingElement: BindingElement
); virtual;
JScript
public function ApplyConfiguration(
   bindingElement : BindingElement
);
Managed Extensions for C++
public: virtual void ApplyConfiguration(
   BindingElement* bindingElement
)
C++/CLI
public:
virtual void ApplyConfiguration(
   BindingElement^ bindingElement
)

Parameters

bindingElement

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : AuthenticationScheme Property

Syntax

Visual Basic (Declaration)
<StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)>
<ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property AuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As AuthenticationSchemes

instance.AuthenticationScheme = value

value = instance.AuthenticationScheme
C#
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public AuthenticationSchemes AuthenticationScheme {get; set;}
Delphi
public read-write property AuthenticationScheme: AuthenticationSchemes;
JScript
StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)
ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set AuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property AuthenticationSchemes get_AuthenticationScheme();
public: __property void set_AuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="authenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property AuthenticationSchemes AuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BypassProxyOnLocal Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : BypassProxyOnLocal Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property BypassProxyOnLocal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.BypassProxyOnLocal = value

value = instance.BypassProxyOnLocal
C#
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool BypassProxyOnLocal {get; set;}
Delphi
public read-write property BypassProxyOnLocal: Boolean;
JScript
ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set BypassProxyOnLocal : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_BypassProxyOnLocal();
public: __property void set_BypassProxyOnLocal(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="bypassProxyOnLocal",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool BypassProxyOnLocal {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateDefaultBindingElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : CreateDefaultBindingElement Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDefaultBindingElement() As TransportBindingElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As TransportBindingElement

value = instance.CreateDefaultBindingElement()
C#
protected virtual TransportBindingElement CreateDefaultBindingElement()
Delphi
protected function CreateDefaultBindingElement(): TransportBindingElement; virtual;
JScript
protected function CreateDefaultBindingElement() : TransportBindingElement;
Managed Extensions for C++
protected: virtual TransportBindingElement* CreateDefaultBindingElement();
C++/CLI
protected:
virtual TransportBindingElement^ CreateDefaultBindingElement();

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DecompressionEnabled Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : DecompressionEnabled Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="decompressionEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property DecompressionEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.DecompressionEnabled = value

value = instance.DecompressionEnabled
C#
[ConfigurationPropertyAttribute(Name="decompressionEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool DecompressionEnabled {get; set;}
Delphi
public read-write property DecompressionEnabled: Boolean;
JScript
ConfigurationPropertyAttribute(Name="decompressionEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set DecompressionEnabled : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="decompressionEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_DecompressionEnabled();
public: __property void set_DecompressionEnabled(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="decompressionEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool DecompressionEnabled {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ExtendedProtectionPolicy Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ExtendedProtectionPolicy Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="extendedProtectionPolicy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property ExtendedProtectionPolicy As ExtendedProtectionPolicyElement
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ExtendedProtectionPolicyElement

value = instance.ExtendedProtectionPolicy
C#
[ConfigurationPropertyAttribute(Name="extendedProtectionPolicy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public ExtendedProtectionPolicyElement ExtendedProtectionPolicy {get;}
Delphi
public read-only property ExtendedProtectionPolicy: ExtendedProtectionPolicyElement;
JScript
ConfigurationPropertyAttribute(Name="extendedProtectionPolicy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get ExtendedProtectionPolicy : ExtendedProtectionPolicyElement
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="extendedProtectionPolicy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property ExtendedProtectionPolicyElement* get_ExtendedProtectionPolicy();
C++/CLI
[ConfigurationPropertyAttribute(Name="extendedProtectionPolicy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property ExtendedProtectionPolicyElement^ ExtendedProtectionPolicy {
   ExtendedProtectionPolicyElement^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HostNameComparisonMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : HostNameComparisonMode Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.HostNameComparisonModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)>
Public Property HostNameComparisonMode As HostNameComparisonMode
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As HostNameComparisonMode

instance.HostNameComparisonMode = value

value = instance.HostNameComparisonMode
C#
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.HostNameComparisonModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
public HostNameComparisonMode HostNameComparisonMode {get; set;}
Delphi
public read-write property HostNameComparisonMode: HostNameComparisonMode;
JScript
ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.HostNameComparisonModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)
public function get,set HostNameComparisonMode : HostNameComparisonMode
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.HostNameComparisonModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
public: __property HostNameComparisonMode get_HostNameComparisonMode();
public: __property void set_HostNameComparisonMode(
   HostNameComparisonMode value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="hostNameComparisonMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.HostNameComparisonModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
public:
property HostNameComparisonMode HostNameComparisonMode {
   HostNameComparisonMode get();
   void set (    HostNameComparisonMode value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
KeepAliveEnabled Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : KeepAliveEnabled Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property KeepAliveEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.KeepAliveEnabled = value

value = instance.KeepAliveEnabled
C#
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool KeepAliveEnabled {get; set;}
Delphi
public read-write property KeepAliveEnabled: Boolean;
JScript
ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set KeepAliveEnabled : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_KeepAliveEnabled();
public: __property void set_KeepAliveEnabled(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="keepAliveEnabled",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool KeepAliveEnabled {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualAddressing Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ManualAddressing Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ManualAddressing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.ManualAddressing = value

value = instance.ManualAddressing
C#
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool ManualAddressing {get; set;}
Delphi
public read-write property ManualAddressing: Boolean;
JScript
ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ManualAddressing : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_ManualAddressing();
public: __property void set_ManualAddressing(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="manualAddressing",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool ManualAddressing {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferPoolSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : MaxBufferPoolSize Property

Syntax

Visual Basic (Declaration)
<LongValidatorAttribute(1)>
<ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxBufferPoolSize As Long
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Long

instance.MaxBufferPoolSize = value

value = instance.MaxBufferPoolSize
C#
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxBufferPoolSize {get; set;}
Delphi
public read-write property MaxBufferPoolSize: Int64;
JScript
LongValidatorAttribute(1)
ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxBufferPoolSize : long
Managed Extensions for C++
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxBufferPoolSize();
public: __property void set_MaxBufferPoolSize(
   long value
);
C++/CLI
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxBufferPoolSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxBufferPoolSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxBufferSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : MaxBufferSize Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<IntegerValidatorAttribute(1)>
Public Property MaxBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Integer

instance.MaxBufferSize = value

value = instance.MaxBufferSize
C#
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[IntegerValidatorAttribute(1)]
public int MaxBufferSize {get; set;}
Delphi
public read-write property MaxBufferSize: Integer;
JScript
ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
IntegerValidatorAttribute(1)
public function get,set MaxBufferSize : int
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[IntegerValidatorAttribute(1)]
public: __property int get_MaxBufferSize();
public: __property void set_MaxBufferSize(
   int value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="maxBufferSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[IntegerValidatorAttribute(1)]
public:
property int MaxBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MaxReceivedMessageSize Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : MaxReceivedMessageSize Property

Syntax

Visual Basic (Declaration)
<LongValidatorAttribute(1)>
<ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property MaxReceivedMessageSize As Long
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Long

instance.MaxReceivedMessageSize = value

value = instance.MaxReceivedMessageSize
C#
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public long MaxReceivedMessageSize {get; set;}
Delphi
public read-write property MaxReceivedMessageSize: Int64;
JScript
LongValidatorAttribute(1)
ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set MaxReceivedMessageSize : long
Managed Extensions for C++
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property long get_MaxReceivedMessageSize();
public: __property void set_MaxReceivedMessageSize(
   long value
);
C++/CLI
[LongValidatorAttribute(1)]
[ConfigurationPropertyAttribute(Name="maxReceivedMessageSize",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property int64 MaxReceivedMessageSize {
   int64 get();
   void set (    int64 value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : Properties Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection;
JScript
protected function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties();
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get();
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAddress Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ProxyAddress Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property ProxyAddress As Uri
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Uri

instance.ProxyAddress = value

value = instance.ProxyAddress
C#
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public Uri ProxyAddress {get; set;}
Delphi
public read-write property ProxyAddress: Uri;
JScript
ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set ProxyAddress : Uri
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property Uri* get_ProxyAddress();
public: __property void set_ProxyAddress(
   Uri* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="proxyAddress",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property Uri^ ProxyAddress {
   Uri^ get();
   void set (    Uri^ value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ProxyAuthenticationScheme Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : ProxyAuthenticationScheme Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="proxyAuthenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)>
Public Property ProxyAuthenticationScheme As AuthenticationSchemes
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As AuthenticationSchemes

instance.ProxyAuthenticationScheme = value

value = instance.ProxyAuthenticationScheme
C#
[ConfigurationPropertyAttribute(Name="proxyAuthenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
public AuthenticationSchemes ProxyAuthenticationScheme {get; set;}
Delphi
public read-write property ProxyAuthenticationScheme: AuthenticationSchemes;
JScript
ConfigurationPropertyAttribute(Name="proxyAuthenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)
public function get,set ProxyAuthenticationScheme : AuthenticationSchemes
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="proxyAuthenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
public: __property AuthenticationSchemes get_ProxyAuthenticationScheme();
public: __property void set_ProxyAuthenticationScheme(
   AuthenticationSchemes value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="proxyAuthenticationScheme",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[StandardRuntimeEnumValidatorAttribute(EnumType=System.Net.AuthenticationSchemes,
   ValidatorInstance=System.ServiceModel.Configuration.StandardRuntimeEnumValidator,
   ValidatorType=)]
public:
property AuthenticationSchemes ProxyAuthenticationScheme {
   AuthenticationSchemes get();
   void set (    AuthenticationSchemes value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Realm Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : Realm Property

Syntax

Visual Basic (Declaration)
<StringValidatorAttribute()>
<ConfigurationPropertyAttribute(Name="realm",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property Realm As String
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As String

instance.Realm = value

value = instance.Realm
C#
[StringValidatorAttribute()]
[ConfigurationPropertyAttribute(Name="realm",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public string Realm {get; set;}
Delphi
public read-write property Realm: String;
JScript
StringValidatorAttribute()
ConfigurationPropertyAttribute(Name="realm",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set Realm : String
Managed Extensions for C++
[StringValidatorAttribute()]
[ConfigurationPropertyAttribute(Name="realm",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property string* get_Realm();
public: __property void set_Realm(
   string* value
);
C++/CLI
[StringValidatorAttribute()]
[ConfigurationPropertyAttribute(Name="realm",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property String^ Realm {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TransferMode Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : TransferMode Property

Syntax

Visual Basic (Declaration)
<ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.TransferModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)>
<ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property TransferMode As TransferMode
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As TransferMode

instance.TransferMode = value

value = instance.TransferMode
C#
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.TransferModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TransferMode TransferMode {get; set;}
Delphi
public read-write property TransferMode: TransferMode;
JScript
ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.TransferModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)
ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set TransferMode : TransferMode
Managed Extensions for C++
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.TransferModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TransferMode get_TransferMode();
public: __property void set_TransferMode(
   TransferMode value
);
C++/CLI
[ServiceModelEnumValidatorAttribute(EnumHelperType=System.ServiceModel.TransferModeHelper,
   ValidatorInstance=System.ServiceModel.Configuration.ServiceModelEnumValidator,
   ValidatorType=)]
[ConfigurationPropertyAttribute(Name="transferMode",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TransferMode TransferMode {
   TransferMode get();
   void set (    TransferMode value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UnsafeConnectionNtlmAuthentication Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : UnsafeConnectionNtlmAuthentication Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="unsafeConnectionNtlmAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property UnsafeConnectionNtlmAuthentication As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.UnsafeConnectionNtlmAuthentication = value

value = instance.UnsafeConnectionNtlmAuthentication
C#
[ConfigurationPropertyAttribute(Name="unsafeConnectionNtlmAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool UnsafeConnectionNtlmAuthentication {get; set;}
Delphi
public read-write property UnsafeConnectionNtlmAuthentication: Boolean;
JScript
ConfigurationPropertyAttribute(Name="unsafeConnectionNtlmAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set UnsafeConnectionNtlmAuthentication : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="unsafeConnectionNtlmAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_UnsafeConnectionNtlmAuthentication();
public: __property void set_UnsafeConnectionNtlmAuthentication(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="unsafeConnectionNtlmAuthentication",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool UnsafeConnectionNtlmAuthentication {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UseDefaultWebProxy Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > HttpsViaProxyTransportElement Class : UseDefaultWebProxy Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property UseDefaultWebProxy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HttpsViaProxyTransportElement
Dim value As Boolean

instance.UseDefaultWebProxy = value

value = instance.UseDefaultWebProxy
C#
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public bool UseDefaultWebProxy {get; set;}
Delphi
public read-write property UseDefaultWebProxy: Boolean;
JScript
ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set UseDefaultWebProxy : boolean
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property bool get_UseDefaultWebProxy();
public: __property void set_UseDefaultWebProxy(
   bool value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="useDefaultWebProxy",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property bool UseDefaultWebProxy {
   bool get();
   void set (    bool value);
}

See Also

Reference

HttpsViaProxyTransportElement Class
HttpsViaProxyTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpsTransportElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpsTransportElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

LiteHttpsTransportElement Class
LiteHttpsTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LiteHttpTransportElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LiteHttpTransportElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

LiteHttpTransportElement Class
LiteHttpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalClientSecurityUpdateElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalClientSecurityUpdateElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

LocalClientSecurityUpdateElement Class
LocalClientSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > LocalServiceSecurityUpdateElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LocalServiceSecurityUpdateElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

LocalServiceSecurityUpdateElement Class
LocalServiceSecurityUpdateElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > MessageStatisticsElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As MessageStatisticsElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

MessageStatisticsElement Class
MessageStatisticsElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingCollectionElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingCollectionElement Class

For a list of all members of this type, see SmartHttpBindingCollectionElement members.

Public Methods

 | Name | Description
public Method | ContainsKey | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SmartHttpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax WCF-Xtensions
SmartHttpBindingCollectionElement Class Properties
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : SmartHttpBindingCollectionElement Class

For a list of all members of this type, see SmartHttpBindingCollectionElement members.

Public Properties

 | Name | Description
public Property | BindingName | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | Bindings | (Inherited from System.ServiceModel.Configuration.StandardBindingCollectionElement<SmartHttpBinding,SmartHttpBindingElement>)
public Property | BindingType | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | ConfiguredBindings | (Inherited from System.ServiceModel.Configuration.BindingCollectionElement)
public Property | CurrentConfiguration | (Inherited from System.Configuration.ConfigurationElement)
public Property | ElementInformation | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllAttributesExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAllElementsExcept | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockAttributes | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockElements | (Inherited from System.Configuration.ConfigurationElement)
public Property | LockItem | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected Property | EvaluationContext | (Inherited from System.Configuration.ConfigurationElement)
protected Property | Properties | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

SmartHttpBindingCollectionElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : BindingName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingName As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As String

value = instance.BindingName
C#
public string BindingName {get;}
Delphi
public read-only property BindingName: String;
JScript
public function get BindingName : String
Managed Extensions for C++
public: __property string* get_BindingName();
C++/CLI
public:
property String^ BindingName {
   String^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Bindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : Bindings Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=True,
   IsRequired=False,
   IsKey=False)>
Public ReadOnly Property Bindings As StandardBindingElementCollection(Of SmartHttpBindingElement)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As StandardBindingElementCollection(Of SmartHttpBindingElement)

value = instance.Bindings
C#
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public StandardBindingElementCollection<SmartHttpBindingElement> Bindings {get;}
Delphi
public read-only property Bindings: StandardBindingElementCollection;
JScript
ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get Bindings : StandardBindingElementCollection
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public: __property StandardBindingElementCollection<SmartHttpBindingElement*>* get_Bindings();
C++/CLI
[ConfigurationPropertyAttribute(Name="",
   Options=ConfigurationPropertyOptions.IsDefaultCollection,
   IsDefaultCollection=true,
   IsRequired=false,
   IsKey=false)]
public:
property StandardBindingElementCollection<SmartHttpBindingElement^>^ Bindings {
   StandardBindingElementCollection<SmartHttpBindingElement^>^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BindingType Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : BindingType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BindingType As Type
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As Type

value = instance.BindingType
C#
public virtual Type BindingType {get;}
Delphi
public read-only property BindingType: Type; virtual;
JScript
public function get BindingType : Type
Managed Extensions for C++
public: __property virtual Type* get_BindingType();
C++/CLI
public:
virtual property Type^ BindingType {
   Type^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfiguredBindings Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : ConfiguredBindings Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ConfiguredBindings As ReadOnlyCollection(Of IBindingConfigurationElement)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ReadOnlyCollection(Of IBindingConfigurationElement)

value = instance.ConfiguredBindings
C#
public virtual ReadOnlyCollection<IBindingConfigurationElement> ConfiguredBindings {get;}
Delphi
public read-only property ConfiguredBindings: ReadOnlyCollection; virtual;
JScript
public function get ConfiguredBindings : ReadOnlyCollection
Managed Extensions for C++
public: __property virtual ReadOnlyCollection<IBindingConfigurationElement*>* get_ConfiguredBindings();
C++/CLI
public:
virtual property ReadOnlyCollection<IBindingConfigurationElement^>^ ConfiguredBindings {
   ReadOnlyCollection<IBindingConfigurationElement^>^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ContainsKey Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : ContainsKey Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsKey( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim name As String
Dim value As Boolean

value = instance.ContainsKey(name)
C#
public virtual bool ContainsKey(
   string name
)
Delphi
public function ContainsKey(
    name: String
): Boolean; virtual;
JScript
public function ContainsKey(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ContainsKey(
   string* name
)
C++/CLI
public:
virtual bool ContainsKey(
   String^ name
)

Parameters

name

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Properties Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : Properties Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Properties As ConfigurationPropertyCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim value As ConfigurationPropertyCollection

value = instance.Properties
C#
protected ConfigurationPropertyCollection Properties {get;}
Delphi
protected read-only property Properties: ConfigurationPropertyCollection;
JScript
protected function get Properties : ConfigurationPropertyCollection
Managed Extensions for C++
protected: __property ConfigurationPropertyCollection* get_Properties();
C++/CLI
protected:
property ConfigurationPropertyCollection^ Properties {
   ConfigurationPropertyCollection^ get();
}

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingCollectionElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingCollectionElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

SmartHttpBindingCollectionElement Class
SmartHttpBindingCollectionElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ApplyConfiguration Method

binding

Syntax

Visual Basic (Declaration)
Public Sub ApplyConfiguration( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim binding As Binding

instance.ApplyConfiguration(binding)
C#
public void ApplyConfiguration(
   Binding binding
)
Delphi
public procedure ApplyConfiguration(
    binding: Binding
);
JScript
public function ApplyConfiguration(
   binding : Binding
);
Managed Extensions for C++
public: void ApplyConfiguration(
   Binding* binding
)
C++/CLI
public:
void ApplyConfiguration(
   Binding^ binding
)

Parameters

binding

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="closeTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : Name Property

Syntax

Visual Basic (Declaration)
<ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=True)>
<StringValidatorAttribute()>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As String

instance.Name = value

value = instance.Name
C#
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
StringValidatorAttribute()
public function get,set Name : String
Managed Extensions for C++
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[ConfigurationPropertyAttribute(Name="name",
   Options=ConfigurationPropertyOptions.IsKey,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=true)]
[StringValidatorAttribute()]
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="openTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReceiveTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : ReceiveTimeout Property

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
<ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
Public Property ReceiveTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As TimeSpan

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public TimeSpan ReceiveTimeout {get; set;}
Delphi
public read-write property ReceiveTimeout: TimeSpan;
JScript
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
public function get,set ReceiveTimeout : TimeSpan
Managed Extensions for C++
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public: __property TimeSpan get_ReceiveTimeout();
public: __property void set_ReceiveTimeout(
   TimeSpan value
);
C++/CLI
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[ConfigurationPropertyAttribute(Name="receiveTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
public:
property TimeSpan ReceiveTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SendTimeout Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : SendTimeout Property

Syntax

Visual Basic (Declaration)
<ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")>
<ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=False,
   IsRequired=False,
   IsKey=False)>
<TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")>
Public Property SendTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim value As TimeSpan

instance.SendTimeout = value

value = instance.SendTimeout
C#
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public TimeSpan SendTimeout {get; set;}
Delphi
public read-write property SendTimeout: TimeSpan;
JScript
ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")
ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=,
   IsRequired=,
   IsKey=)
TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")
public function get,set SendTimeout : TimeSpan
Managed Extensions for C++
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public: __property TimeSpan get_SendTimeout();
public: __property void set_SendTimeout(
   TimeSpan value
);
C++/CLI
[ServiceModelTimeSpanValidatorAttribute(MinValue=00:00:00, MinValueString="00:00:00")]
[ConfigurationPropertyAttribute(Name="sendTimeout",
   Options=ConfigurationPropertyOptions.None,
   IsDefaultCollection=false,
   IsRequired=false,
   IsKey=false)]
[TypeConverterAttribute("System.Runtime.TimeSpanOrInfiniteConverter, System.Runtime.DurableInstancing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public:
property TimeSpan SendTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SmartHttpBindingElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SmartHttpBindingElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

SmartHttpBindingElement Class
SmartHttpBindingElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpDuplexTransportElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpDuplexTransportElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

SoapTcpDuplexTransportElement Class
SoapTcpDuplexTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SoapTcpTransportElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SoapTcpTransportElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

SoapTcpTransportElement Class
SoapTcpTransportElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > SocksSettingsElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As SocksSettingsElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

SocksSettingsElement Class
SocksSettingsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ConfigurationElementName Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : ConfigurationElementName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConfigurationElementName As String
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As String

value = instance.ConfigurationElementName
C#
public string ConfigurationElementName {get;}
Delphi
public read-only property ConfigurationElementName: String;
JScript
public function get ConfigurationElementName : String
Managed Extensions for C++
public: __property string* get_ConfigurationElementName();
C++/CLI
public:
property String^ ConfigurationElementName {
   String^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CopyFrom Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : CopyFrom Method

from

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyFrom( _
   ByVal from As ServiceModelExtensionElement _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)
C#
public virtual void CopyFrom(
   ServiceModelExtensionElement from
)
Delphi
public procedure CopyFrom(
    from: ServiceModelExtensionElement
); virtual;
JScript
public function CopyFrom(
   from : ServiceModelExtensionElement
);
Managed Extensions for C++
public: virtual void CopyFrom(
   ServiceModelExtensionElement* from
)
C++/CLI
public:
virtual void CopyFrom(
   ServiceModelExtensionElement^ from
)

Parameters

from

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsModified Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : IsModified Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsModified() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As Boolean

value = instance.IsModified()
C#
protected virtual bool IsModified()
Delphi
protected function IsModified(): Boolean; virtual;
JScript
protected function IsModified() : boolean;
Managed Extensions for C++
protected: virtual bool IsModified();
C++/CLI
protected:
virtual bool IsModified();

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Reset Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : Reset Method

parentElement

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Protected Overridable Sub Reset( _
   ByVal parentElement As ConfigurationElement _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim parentElement As ConfigurationElement

instance.Reset(parentElement)
C#
[SecurityCriticalAttribute()]
protected virtual void Reset(
   ConfigurationElement parentElement
)
Delphi
protected procedure Reset(
    parentElement: ConfigurationElement
); virtual;
JScript
SecurityCriticalAttribute()
protected function Reset(
   parentElement : ConfigurationElement
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
protected: virtual void Reset(
   ConfigurationElement* parentElement
)
C++/CLI
[SecurityCriticalAttribute()]
protected:
virtual void Reset(
   ConfigurationElement^ parentElement
)

Parameters

parentElement

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SerializeElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : SerializeElement Method

writer
serializeCollectionKey

Syntax

Visual Basic (Declaration)
Protected Overridable Function SerializeElement( _
   ByVal writer As XmlWriter, _
   ByVal serializeCollectionKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim writer As XmlWriter
Dim serializeCollectionKey As Boolean
Dim value As Boolean

value = instance.SerializeElement(writer, serializeCollectionKey)
C#
protected virtual bool SerializeElement(
   XmlWriter writer,
   bool serializeCollectionKey
)
Delphi
protected function SerializeElement(
    writer: XmlWriter;
    serializeCollectionKey: Boolean
): Boolean; virtual;
JScript
protected function SerializeElement(
   writer : XmlWriter,
   serializeCollectionKey : boolean
) : boolean;
Managed Extensions for C++
protected: virtual bool SerializeElement(
   XmlWriter* writer,
   bool serializeCollectionKey
)
C++/CLI
protected:
virtual bool SerializeElement(
   XmlWriter^ writer,
   bool serializeCollectionKey
)

Parameters

writer
serializeCollectionKey

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > StreamEnhancerElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As StreamEnhancerElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

StreamEnhancerElement Class
StreamEnhancerElement Members


%%PageItemTitle%% $$Methods$$

[image]
Noemax WCF-Xtensions
WriterProfileDetailsElement Class Methods
See Also Send Feedback
Noemax.WCFX.Configuration Namespace : WriterProfileDetailsElement Class

For a list of all members of this type, see WriterProfileDetailsElement members.

Public Methods

 | Name | Description
public Method | IsReadOnly | (Inherited from System.Configuration.ConfigurationElement)
Top

Protected Methods

 | Name | Description
protected Method | GetTransformedAssemblyString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | GetTransformedTypeString | (Inherited from System.Configuration.ConfigurationElement)
protected Method | ListErrors | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedAttribute | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnDeserializeUnrecognizedElement | (Inherited from System.Configuration.ConfigurationElement)
protected Method | OnRequiredPropertyNotFound | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PostDeserialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | PreSerialize | (Inherited from System.Configuration.ConfigurationElement)
protected Method | SetPropertyValue | (Inherited from System.Configuration.ConfigurationElement)
Top

See Also

Reference

WriterProfileDetailsElement Class
Noemax.WCFX.Configuration Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CurrentConfiguration Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : CurrentConfiguration Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentConfiguration As Configuration
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As Configuration

value = instance.CurrentConfiguration
C#
public Configuration CurrentConfiguration {get;}
Delphi
public read-only property CurrentConfiguration: Configuration;
JScript
public function get CurrentConfiguration : Configuration
Managed Extensions for C++
public: __property Configuration* get_CurrentConfiguration();
C++/CLI
public:
property Configuration^ CurrentConfiguration {
   Configuration^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ElementInformation Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : ElementInformation Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ElementInformation As ElementInformation
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ElementInformation

value = instance.ElementInformation
C#
public ElementInformation ElementInformation {get;}
Delphi
public read-only property ElementInformation: ElementInformation;
JScript
public function get ElementInformation : ElementInformation
Managed Extensions for C++
public: __property ElementInformation* get_ElementInformation();
C++/CLI
public:
property ElementInformation^ ElementInformation {
   ElementInformation^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EvaluationContext Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : EvaluationContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property EvaluationContext As ContextInformation
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ContextInformation

value = instance.EvaluationContext
C#
protected ContextInformation EvaluationContext {get;}
Delphi
protected read-only property EvaluationContext: ContextInformation;
JScript
protected function get EvaluationContext : ContextInformation
Managed Extensions for C++
protected: __property ContextInformation* get_EvaluationContext();
C++/CLI
protected:
property ContextInformation^ EvaluationContext {
   ContextInformation^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedAssemblyString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : GetTransformedAssemblyString Method

assemblyName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedAssemblyString( _
   ByVal assemblyName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim assemblyName As String
Dim value As String

value = instance.GetTransformedAssemblyString(assemblyName)
C#
protected virtual string GetTransformedAssemblyString(
   string assemblyName
)
Delphi
protected function GetTransformedAssemblyString(
    assemblyName: String
): String; virtual;
JScript
protected function GetTransformedAssemblyString(
   assemblyName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedAssemblyString(
   string* assemblyName
)
C++/CLI
protected:
virtual String^ GetTransformedAssemblyString(
   String^ assemblyName
)

Parameters

assemblyName

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetTransformedTypeString Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : GetTransformedTypeString Method

typeName

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetTransformedTypeString( _
   ByVal typeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim typeName As String
Dim value As String

value = instance.GetTransformedTypeString(typeName)
C#
protected virtual string GetTransformedTypeString(
   string typeName
)
Delphi
protected function GetTransformedTypeString(
    typeName: String
): String; virtual;
JScript
protected function GetTransformedTypeString(
   typeName : String
) : String;
Managed Extensions for C++
protected: virtual string* GetTransformedTypeString(
   string* typeName
)
C++/CLI
protected:
virtual String^ GetTransformedTypeString(
   String^ typeName
)

Parameters

typeName

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsReadOnly Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : IsReadOnly Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsReadOnly() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As Boolean

value = instance.IsReadOnly()
C#
public virtual bool IsReadOnly()
Delphi
public function IsReadOnly(): Boolean; virtual;
JScript
public function IsReadOnly() : boolean;
Managed Extensions for C++
public: virtual bool IsReadOnly();
C++/CLI
public:
virtual bool IsReadOnly();

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ListErrors Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : ListErrors Method

errorList

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ListErrors( _
   ByVal errorList As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim errorList As IList

instance.ListErrors(errorList)
C#
protected virtual void ListErrors(
   IList errorList
)
Delphi
protected procedure ListErrors(
    errorList: IList
); virtual;
JScript
protected function ListErrors(
   errorList : IList
);
Managed Extensions for C++
protected: virtual void ListErrors(
   IList* errorList
)
C++/CLI
protected:
virtual void ListErrors(
   IList^ errorList
)

Parameters

errorList

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllAttributesExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LockAllAttributesExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllAttributesExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllAttributesExcept
C#
public ConfigurationLockCollection LockAllAttributesExcept {get;}
Delphi
public read-only property LockAllAttributesExcept: ConfigurationLockCollection;
JScript
public function get LockAllAttributesExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllAttributesExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllAttributesExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAllElementsExcept Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LockAllElementsExcept Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAllElementsExcept As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ConfigurationLockCollection

value = instance.LockAllElementsExcept
C#
public ConfigurationLockCollection LockAllElementsExcept {get;}
Delphi
public read-only property LockAllElementsExcept: ConfigurationLockCollection;
JScript
public function get LockAllElementsExcept : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAllElementsExcept();
C++/CLI
public:
property ConfigurationLockCollection^ LockAllElementsExcept {
   ConfigurationLockCollection^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockAttributes Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LockAttributes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockAttributes As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ConfigurationLockCollection

value = instance.LockAttributes
C#
public ConfigurationLockCollection LockAttributes {get;}
Delphi
public read-only property LockAttributes: ConfigurationLockCollection;
JScript
public function get LockAttributes : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockAttributes();
C++/CLI
public:
property ConfigurationLockCollection^ LockAttributes {
   ConfigurationLockCollection^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockElements Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LockElements Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LockElements As ConfigurationLockCollection
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As ConfigurationLockCollection

value = instance.LockElements
C#
public ConfigurationLockCollection LockElements {get;}
Delphi
public read-only property LockElements: ConfigurationLockCollection;
JScript
public function get LockElements : ConfigurationLockCollection
Managed Extensions for C++
public: __property ConfigurationLockCollection* get_LockElements();
C++/CLI
public:
property ConfigurationLockCollection^ LockElements {
   ConfigurationLockCollection^ get();
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LockItem Property
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : LockItem Property

Syntax

Visual Basic (Declaration)
Public Property LockItem As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim value As Boolean

instance.LockItem = value

value = instance.LockItem
C#
public bool LockItem {get; set;}
Delphi
public read-write property LockItem: Boolean;
JScript
public function get,set LockItem : boolean
Managed Extensions for C++
public: __property bool get_LockItem();
public: __property void set_LockItem(
   bool value
);
C++/CLI
public:
property bool LockItem {
   bool get();
   void set (    bool value);
}

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedAttribute Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : OnDeserializeUnrecognizedAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedAttribute( _
   ByVal name As String, _
   ByVal value As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim name As String
Dim value As String
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedAttribute(name, value)
C#
protected virtual bool OnDeserializeUnrecognizedAttribute(
   string name,
   string value
)
Delphi
protected function OnDeserializeUnrecognizedAttribute(
    name: String;
    value: String
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedAttribute(
   name : String,
   value : String
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedAttribute(
   string* name,
   string* value
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnDeserializeUnrecognizedElement Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : OnDeserializeUnrecognizedElement Method

elementName
reader

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnDeserializeUnrecognizedElement( _
   ByVal elementName As String, _
   ByVal reader As XmlReader _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim elementName As String
Dim reader As XmlReader
Dim value As Boolean

value = instance.OnDeserializeUnrecognizedElement(elementName, reader)
C#
protected virtual bool OnDeserializeUnrecognizedElement(
   string elementName,
   XmlReader reader
)
Delphi
protected function OnDeserializeUnrecognizedElement(
    elementName: String;
    reader: XmlReader
): Boolean; virtual;
JScript
protected function OnDeserializeUnrecognizedElement(
   elementName : String,
   reader : XmlReader
) : boolean;
Managed Extensions for C++
protected: virtual bool OnDeserializeUnrecognizedElement(
   string* elementName,
   XmlReader* reader
)
C++/CLI
protected:
virtual bool OnDeserializeUnrecognizedElement(
   String^ elementName,
   XmlReader^ reader
)

Parameters

elementName
reader

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnRequiredPropertyNotFound Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : OnRequiredPropertyNotFound Method

name

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnRequiredPropertyNotFound( _
   ByVal name As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim name As String
Dim value As Object

value = instance.OnRequiredPropertyNotFound(name)
C#
protected virtual object OnRequiredPropertyNotFound(
   string name
)
Delphi
protected function OnRequiredPropertyNotFound(
    name: String
): TObject; virtual;
JScript
protected function OnRequiredPropertyNotFound(
   name : String
) : Object;
Managed Extensions for C++
protected: virtual Object* OnRequiredPropertyNotFound(
   string* name
)
C++/CLI
protected:
virtual Object^ OnRequiredPropertyNotFound(
   String^ name
)

Parameters

name

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PostDeserialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : PostDeserialize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PostDeserialize()
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement

instance.PostDeserialize()
C#
protected virtual void PostDeserialize()
Delphi
protected procedure PostDeserialize(); virtual;
JScript
protected function PostDeserialize();
Managed Extensions for C++
protected: virtual void PostDeserialize();
C++/CLI
protected:
virtual void PostDeserialize();

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
PreSerialize Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : PreSerialize Method

writer

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PreSerialize( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim writer As XmlWriter

instance.PreSerialize(writer)
C#
protected virtual void PreSerialize(
   XmlWriter writer
)
Delphi
protected procedure PreSerialize(
    writer: XmlWriter
); virtual;
JScript
protected function PreSerialize(
   writer : XmlWriter
);
Managed Extensions for C++
protected: virtual void PreSerialize(
   XmlWriter* writer
)
C++/CLI
protected:
virtual void PreSerialize(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetPropertyValue Method
See Also Send Feedback
Noemax.WCFX.Configuration Namespace > WriterProfileDetailsElement Class : SetPropertyValue Method

prop
value
ignoreLocks

Syntax

Visual Basic (Declaration)
Protected Sub SetPropertyValue( _
   ByVal prop As ConfigurationProperty, _
   ByVal value As Object, _
   ByVal ignoreLocks As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WriterProfileDetailsElement
Dim prop As ConfigurationProperty
Dim value As Object
Dim ignoreLocks As Boolean

instance.SetPropertyValue(prop, value, ignoreLocks)
C#
protected void SetPropertyValue(
   ConfigurationProperty prop,
   object value,
   bool ignoreLocks
)
Delphi
protected procedure SetPropertyValue(
    prop: ConfigurationProperty;
    value: TObject;
    ignoreLocks: Boolean
);
JScript
protected function SetPropertyValue(
   prop : ConfigurationProperty,
   value : Object,
   ignoreLocks : boolean
);
Managed Extensions for C++
protected: void SetPropertyValue(
   ConfigurationProperty* prop,
   Object* value,
   bool ignoreLocks
)
C++/CLI
protected:
void SetPropertyValue(
   ConfigurationProperty^ prop,
   Object^ value,
   bool ignoreLocks
)

Parameters

prop
value
ignoreLocks

See Also

Reference

WriterProfileDetailsElement Class
WriterProfileDetailsElement Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.WCFX.Configuration Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.WCFX.Configuration.BindingElementExtensionStringList<TBindingElementExtensionType>
Noemax.WCFX.Configuration.MessageEncodingStringList
Noemax.WCFX.Configuration.SmartBindingDefaults
System.ComponentModel.TypeConverter
Noemax.WCFX.Configuration.MessageVersionConverter
Noemax.WCFX.Configuration.SocksAuthenticationConverter
Noemax.WCFX.Configuration.SocksVersionConverter
Noemax.WCFX.Configuration.TransferModeConverter
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.ExtensionBindingElement
Noemax.WCFX.Configuration.SocksSettingsElement
Noemax.WCFX.Configuration.WriterProfileDetailsElement
System.Configuration.ConfigurationElementCollection
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.GenericConfigurationElementCollection<TConfigurationElement>
Noemax.WCFX.Configuration.BindingElementExtensionElementCollection<TBindingElementExtension>
Noemax.WCFX.Configuration.MessageEncodingElementCollection
Noemax.WCFX.Configuration.ExtensionBindingElementCollection
System.ServiceModel.Configuration.BasicHttpBindingElement
System.ServiceModel.Configuration.StandardBindingElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.SmartHttpBindingElement.ExtBasicHttpBindingElement
System.ServiceModel.Configuration.BehaviorExtensionElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.EnvelopeEndpointBehaviorElement
Noemax.WCFX.Configuration.ExportMetadataElement
System.ServiceModel.Configuration.BindingCollectionElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.ExtensionBindingCollectionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.CompressionElement
Noemax.WCFX.Configuration.ContentNegotiationElement
Noemax.WCFX.Configuration.FiMessageEncodingElement
Noemax.WCFX.Configuration.LiteHttpTransportElement
Noemax.WCFX.Configuration.LiteHttpsTransportElement
Noemax.WCFX.Configuration.LocalClientSecurityUpdateElement
Noemax.WCFX.Configuration.LocalServiceSecurityUpdateElement
Noemax.WCFX.Configuration.MessageStatisticsElement
Noemax.WCFX.Configuration.SoapTcpDuplexTransportElement
Noemax.WCFX.Configuration.SoapTcpTransportElement
Noemax.WCFX.Configuration.StreamEnhancerElement
System.ServiceModel.Configuration.HttpTransportElement
System.ServiceModel.Configuration.TransportElement
System.ServiceModel.Configuration.BindingElementExtensionElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.HttpsViaProxyTransportElement
System.ServiceModel.Configuration.StandardBindingCollectionElement<TStandardBinding,TBindingConfiguration>
System.ServiceModel.Configuration.BindingCollectionElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.BasicSoapTcpBindingCollectionElement
Noemax.WCFX.Configuration.DuplexSoapTcpBindingCollectionElement
Noemax.WCFX.Configuration.SmartHttpBindingCollectionElement
System.ServiceModel.Configuration.StandardBindingElement
System.Configuration.ConfigurationElement
Noemax.WCFX.Configuration.BasicSoapTcpBindingElement
Noemax.WCFX.Configuration.DuplexSoapTcpBindingElement
Noemax.WCFX.Configuration.SmartHttpBindingElement

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%% $$Events$$

[image]
Noemax WCF-Xtensions
XChannelFactory<TChannel> Class Events
See Also Send Feedback
Noemax.WCFX Namespace : XChannelFactory<TChannel> Class

For a list of all members of this type, see XChannelFactory<TChannel> members.

Public Events

 | Name | Description
public Event | Closed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Closing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Faulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opening | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Top

See Also

Reference

XChannelFactory<TChannel> Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Abort Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Abort Method

Syntax

Visual Basic (Declaration)
Public Sub Abort()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.Abort()
C#
public void Abort()
Delphi
public procedure Abort();
JScript
public function Abort();
Managed Extensions for C++
public: void Abort();
C++/CLI
public:
void Abort();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : ApplyConfiguration Method

configurationName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overridable Sub ApplyConfiguration( _
   ByVal configurationName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim configurationName As String

instance.ApplyConfiguration(configurationName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected virtual void ApplyConfiguration(
   string configurationName
)
Delphi
protected procedure ApplyConfiguration(
    configurationName: String
); virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function ApplyConfiguration(
   configurationName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: virtual void ApplyConfiguration(
   string* configurationName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
virtual void ApplyConfiguration(
   String^ configurationName
)

Parameters

configurationName

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : BeginClose Method

Overload List

Overload | Description
BeginClose(AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)
BeginClose(TimeSpan,AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose(AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > BeginClose Method : BeginClose(AsyncCallback,Object) Method

callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginClose( _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginClose(callback, state)
C#
public IAsyncResult BeginClose(
   AsyncCallback callback,
   object state
)
Delphi
public function BeginClose(
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginClose(
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginClose(
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginClose(
   AsyncCallback^ callback,
   Object^ state
)

Parameters

callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose(TimeSpan,AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > BeginClose Method : BeginClose(TimeSpan,AsyncCallback,Object) Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginClose( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginClose(timeout, callback, state)
C#
public IAsyncResult BeginClose(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginClose(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginClose(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginClose(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginClose(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : BeginOpen Method

Overload List

Overload | Description
BeginOpen(AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)
BeginOpen(TimeSpan,AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen(AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > BeginOpen Method : BeginOpen(AsyncCallback,Object) Method

callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginOpen( _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginOpen(callback, state)
C#
public IAsyncResult BeginOpen(
   AsyncCallback callback,
   object state
)
Delphi
public function BeginOpen(
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginOpen(
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginOpen(
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginOpen(
   AsyncCallback^ callback,
   Object^ state
)

Parameters

callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen(TimeSpan,AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > BeginOpen Method : BeginOpen(TimeSpan,AsyncCallback,Object) Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginOpen( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginOpen(timeout, callback, state)
C#
public IAsyncResult BeginOpen(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginOpen(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginOpen(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginOpen(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginOpen(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Close Method

Overload List

Overload | Description
Close() | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Close(TimeSpan) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close() Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > Close Method : Close() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close(TimeSpan) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > Close Method : Close(TimeSpan) Method

timeout

Syntax

Visual Basic (Declaration)
Public Overloads Sub Close( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan

instance.Close(timeout)
C#
public void Close(
   TimeSpan timeout
)
Delphi
public procedure Close(
    timeout: TimeSpan
);
JScript
public function Close(
   timeout : TimeSpan
);
Managed Extensions for C++
public: void Close(
   TimeSpan timeout
)
C++/CLI
public:
void Close(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Closed Event
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Closed Event

Syntax

Visual Basic (Declaration)
Public Event Closed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
public event EventHandler Closed
Delphi
public event Closed: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Closed
C++/CLI
public:
event EventHandler^ Closed

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Closing Event
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Closing Event

Syntax

Visual Basic (Declaration)
Public Event Closing As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim handler As EventHandler

AddHandler instance.Closing, handler
C#
public event EventHandler Closing
Delphi
public event Closing: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Closing
C++/CLI
public:
event EventHandler^ Closing

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateChannel Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : CreateChannel Method

Overload List

Overload | Description
CreateChannel(EndpointAddress) | (Inherited from System.ServiceModel.ChannelFactory<TChannel>)
CreateChannel(EndpointAddress,Uri) | (Inherited from System.ServiceModel.ChannelFactory<TChannel>)
CreateChannel() | (Inherited from System.ServiceModel.ChannelFactory<TChannel>)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateChannel() Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > CreateChannel Method : CreateChannel() Method

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateChannel() As TChannel
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As TChannel

value = instance.CreateChannel()
C#
public TChannel CreateChannel()
Delphi
public function CreateChannel(): TChannel;
JScript
public function CreateChannel() : TChannel;
Managed Extensions for C++
public: TChannel* CreateChannel();
C++/CLI
public:
TChannel^ CreateChannel();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateChannel(EndpointAddress) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > CreateChannel Method : CreateChannel(EndpointAddress) Method

address

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateChannel( _
   ByVal address As EndpointAddress _
) As TChannel
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim address As EndpointAddress
Dim value As TChannel

value = instance.CreateChannel(address)
C#
public TChannel CreateChannel(
   EndpointAddress address
)
Delphi
public function CreateChannel(
    address: EndpointAddress
): TChannel;
JScript
public function CreateChannel(
   address : EndpointAddress
) : TChannel;
Managed Extensions for C++
public: TChannel* CreateChannel(
   EndpointAddress* address
)
C++/CLI
public:
TChannel^ CreateChannel(
   EndpointAddress^ address
)

Parameters

address

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateChannel(EndpointAddress,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > CreateChannel Method : CreateChannel(EndpointAddress,Uri) Method

address
via

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function CreateChannel( _
   ByVal address As EndpointAddress, _
   ByVal via As Uri _
) As TChannel
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim address As EndpointAddress
Dim via As Uri
Dim value As TChannel

value = instance.CreateChannel(address, via)
C#
public virtual TChannel CreateChannel(
   EndpointAddress address,
   Uri via
)
Delphi
public function CreateChannel(
    address: EndpointAddress;
    via: Uri
): TChannel; virtual;
JScript
public function CreateChannel(
   address : EndpointAddress,
   via : Uri
) : TChannel;
Managed Extensions for C++
public: virtual TChannel* CreateChannel(
   EndpointAddress* address,
   Uri* via
)
C++/CLI
public:
virtual TChannel^ CreateChannel(
   EndpointAddress^ address,
   Uri^ via
)

Parameters

address
via

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateDescription Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : CreateDescription Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDescription() As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As ServiceEndpoint

value = instance.CreateDescription()
C#
protected virtual ServiceEndpoint CreateDescription()
Delphi
protected function CreateDescription(): ServiceEndpoint; virtual;
JScript
protected function CreateDescription() : ServiceEndpoint;
Managed Extensions for C++
protected: virtual ServiceEndpoint* CreateDescription();
C++/CLI
protected:
virtual ServiceEndpoint^ CreateDescription();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateFactory Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : CreateFactory Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateFactory() As IChannelFactory
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As IChannelFactory

value = instance.CreateFactory()
C#
protected virtual IChannelFactory CreateFactory()
Delphi
protected function CreateFactory(): IChannelFactory; virtual;
JScript
protected function CreateFactory() : IChannelFactory;
Managed Extensions for C++
protected: virtual IChannelFactory* CreateFactory();
C++/CLI
protected:
virtual IChannelFactory^ CreateFactory();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Credentials Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Credentials Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Credentials As ClientCredentials
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As ClientCredentials

value = instance.Credentials
C#
public ClientCredentials Credentials {get;}
Delphi
public read-only property Credentials: ClientCredentials;
JScript
public function get Credentials : ClientCredentials
Managed Extensions for C++
public: __property ClientCredentials* get_Credentials();
C++/CLI
public:
property ClientCredentials^ Credentials {
   ClientCredentials^ get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DefaultCloseTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : DefaultCloseTimeout Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DefaultCloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As TimeSpan

value = instance.DefaultCloseTimeout
C#
protected TimeSpan DefaultCloseTimeout {get;}
Delphi
protected read-only property DefaultCloseTimeout: TimeSpan;
JScript
protected function get DefaultCloseTimeout : TimeSpan
Managed Extensions for C++
protected: __property TimeSpan get_DefaultCloseTimeout();
C++/CLI
protected:
property TimeSpan DefaultCloseTimeout {
   TimeSpan get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DefaultOpenTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : DefaultOpenTimeout Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DefaultOpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As TimeSpan

value = instance.DefaultOpenTimeout
C#
protected TimeSpan DefaultOpenTimeout {get;}
Delphi
protected read-only property DefaultOpenTimeout: TimeSpan;
JScript
protected function get DefaultOpenTimeout : TimeSpan
Managed Extensions for C++
protected: __property TimeSpan get_DefaultOpenTimeout();
C++/CLI
protected:
property TimeSpan DefaultOpenTimeout {
   TimeSpan get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : EndClose Method

result

Syntax

Visual Basic (Declaration)
Public Sub EndClose( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim result As IAsyncResult

instance.EndClose(result)
C#
public void EndClose(
   IAsyncResult result
)
Delphi
public procedure EndClose(
    result: IAsyncResult
);
JScript
public function EndClose(
   result : IAsyncResult
);
Managed Extensions for C++
public: void EndClose(
   IAsyncResult* result
)
C++/CLI
public:
void EndClose(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : EndOpen Method

result

Syntax

Visual Basic (Declaration)
Public Sub EndOpen( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim result As IAsyncResult

instance.EndOpen(result)
C#
public void EndOpen(
   IAsyncResult result
)
Delphi
public procedure EndOpen(
    result: IAsyncResult
);
JScript
public function EndOpen(
   result : IAsyncResult
);
Managed Extensions for C++
public: void EndOpen(
   IAsyncResult* result
)
C++/CLI
public:
void EndOpen(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Endpoint Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Endpoint Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Endpoint As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As ServiceEndpoint

value = instance.Endpoint
C#
public ServiceEndpoint Endpoint {get;}
Delphi
public read-only property Endpoint: ServiceEndpoint;
JScript
public function get Endpoint : ServiceEndpoint
Managed Extensions for C++
public: __property ServiceEndpoint* get_Endpoint();
C++/CLI
public:
property ServiceEndpoint^ Endpoint {
   ServiceEndpoint^ get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EnsureOpened Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : EnsureOpened Method

Syntax

Visual Basic (Declaration)
Protected Sub EnsureOpened()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.EnsureOpened()
C#
protected void EnsureOpened()
Delphi
protected procedure EnsureOpened();
JScript
protected function EnsureOpened();
Managed Extensions for C++
protected: void EnsureOpened();
C++/CLI
protected:
void EnsureOpened();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Fault Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Fault Method

Overload List

Overload | Description
Fault() | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Fault() Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > Fault Method : Fault() Method

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Fault()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.Fault()
C#
protected void Fault()
Delphi
protected procedure Fault();
JScript
protected function Fault();
Managed Extensions for C++
protected: void Fault();
C++/CLI
protected:
void Fault();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Faulted Event
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Faulted Event

Syntax

Visual Basic (Declaration)
Public Event Faulted As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim handler As EventHandler

AddHandler instance.Faulted, handler
C#
public event EventHandler Faulted
Delphi
public event Faulted: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Faulted
C++/CLI
public:
event EventHandler^ Faulted

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetCommunicationObjectType Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : GetCommunicationObjectType Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCommunicationObjectType() As Type
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As Type

value = instance.GetCommunicationObjectType()
C#
protected virtual Type GetCommunicationObjectType()
Delphi
protected function GetCommunicationObjectType(): Type; virtual;
JScript
protected function GetCommunicationObjectType() : Type;
Managed Extensions for C++
protected: virtual Type* GetCommunicationObjectType();
C++/CLI
protected:
virtual Type^ GetCommunicationObjectType();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

T
[image]
Noemax WCF-Xtensions
GetProperty<T> Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : GetProperty<T> Method

Syntax

Visual Basic (Declaration)
Public Function GetProperty(Of T)() As T
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As T

value = instance.GetProperty(Of T)()
C#
public T GetProperty<T>()
Delphi
public function GetProperty(): T;
JScript
public function GetProperty() : T;
Managed Extensions for C++
public: T* GetProperty<T>();
C++/CLI
public:
T^ GetPropertygeneric<typename T>
();

Type Parameters

T

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeEndpoint Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : InitializeEndpoint Method

Overload List

Overload | Description
InitializeEndpoint(String,EndpointAddress) | (Inherited from System.ServiceModel.ChannelFactory)
InitializeEndpoint(ServiceEndpoint) | (Inherited from System.ServiceModel.ChannelFactory)
InitializeEndpoint(Binding,EndpointAddress) | (Inherited from System.ServiceModel.ChannelFactory)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeEndpoint(Binding,EndpointAddress) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > InitializeEndpoint Method : InitializeEndpoint(Binding,EndpointAddress) Method

binding
address

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeEndpoint( _
   ByVal binding As Binding, _
   ByVal address As EndpointAddress _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim binding As Binding
Dim address As EndpointAddress

instance.InitializeEndpoint(binding, address)
C#
protected void InitializeEndpoint(
   Binding binding,
   EndpointAddress address
)
Delphi
protected procedure InitializeEndpoint(
    binding: Binding;
    address: EndpointAddress
);
JScript
protected function InitializeEndpoint(
   binding : Binding,
   address : EndpointAddress
);
Managed Extensions for C++
protected: void InitializeEndpoint(
   Binding* binding,
   EndpointAddress* address
)
C++/CLI
protected:
void InitializeEndpoint(
   Binding^ binding,
   EndpointAddress^ address
)

Parameters

binding
address

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeEndpoint(ServiceEndpoint) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > InitializeEndpoint Method : InitializeEndpoint(ServiceEndpoint) Method

endpoint

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeEndpoint( _
   ByVal endpoint As ServiceEndpoint _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim endpoint As ServiceEndpoint

instance.InitializeEndpoint(endpoint)
C#
protected void InitializeEndpoint(
   ServiceEndpoint endpoint
)
Delphi
protected procedure InitializeEndpoint(
    endpoint: ServiceEndpoint
);
JScript
protected function InitializeEndpoint(
   endpoint : ServiceEndpoint
);
Managed Extensions for C++
protected: void InitializeEndpoint(
   ServiceEndpoint* endpoint
)
C++/CLI
protected:
void InitializeEndpoint(
   ServiceEndpoint^ endpoint
)

Parameters

endpoint

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeEndpoint(String,EndpointAddress) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > InitializeEndpoint Method : InitializeEndpoint(String,EndpointAddress) Method

configurationName
address

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeEndpoint( _
   ByVal configurationName As String, _
   ByVal address As EndpointAddress _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim configurationName As String
Dim address As EndpointAddress

instance.InitializeEndpoint(configurationName, address)
C#
protected void InitializeEndpoint(
   string configurationName,
   EndpointAddress address
)
Delphi
protected procedure InitializeEndpoint(
    configurationName: String;
    address: EndpointAddress
);
JScript
protected function InitializeEndpoint(
   configurationName : String,
   address : EndpointAddress
);
Managed Extensions for C++
protected: void InitializeEndpoint(
   string* configurationName,
   EndpointAddress* address
)
C++/CLI
protected:
void InitializeEndpoint(
   String^ configurationName,
   EndpointAddress^ address
)

Parameters

configurationName
address

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDisposed Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : IsDisposed Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsDisposed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As Boolean

value = instance.IsDisposed
C#
protected bool IsDisposed {get;}
Delphi
protected read-only property IsDisposed: Boolean;
JScript
protected function get IsDisposed : boolean
Managed Extensions for C++
protected: __property bool get_IsDisposed();
C++/CLI
protected:
property bool IsDisposed {
   bool get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnAbort Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnAbort Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAbort()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnAbort()
C#
protected virtual void OnAbort()
Delphi
protected procedure OnAbort(); virtual;
JScript
protected function OnAbort();
Managed Extensions for C++
protected: virtual void OnAbort();
C++/CLI
protected:
virtual void OnAbort();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnBeginClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnBeginClose Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBeginClose( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.OnBeginClose(timeout, callback, state)
C#
protected virtual IAsyncResult OnBeginClose(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
protected function OnBeginClose(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
protected function OnBeginClose(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
protected: virtual IAsyncResult* OnBeginClose(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
protected:
virtual IAsyncResult^ OnBeginClose(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnBeginOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnBeginOpen Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBeginOpen( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.OnBeginOpen(timeout, callback, state)
C#
protected virtual IAsyncResult OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
protected function OnBeginOpen(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
protected function OnBeginOpen(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
protected: virtual IAsyncResult* OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
protected:
virtual IAsyncResult^ OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnClose Method

timeout

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClose( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan

instance.OnClose(timeout)
C#
protected virtual void OnClose(
   TimeSpan timeout
)
Delphi
protected procedure OnClose(
    timeout: TimeSpan
); virtual;
JScript
protected function OnClose(
   timeout : TimeSpan
);
Managed Extensions for C++
protected: virtual void OnClose(
   TimeSpan timeout
)
C++/CLI
protected:
virtual void OnClose(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClosed Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnClosed Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClosed()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnClosed()
C#
protected virtual void OnClosed()
Delphi
protected procedure OnClosed(); virtual;
JScript
protected function OnClosed();
Managed Extensions for C++
protected: virtual void OnClosed();
C++/CLI
protected:
virtual void OnClosed();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClosing Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnClosing Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClosing()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnClosing()
C#
protected virtual void OnClosing()
Delphi
protected procedure OnClosing(); virtual;
JScript
protected function OnClosing();
Managed Extensions for C++
protected: virtual void OnClosing();
C++/CLI
protected:
virtual void OnClosing();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnEndClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnEndClose Method

result

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEndClose( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim result As IAsyncResult

instance.OnEndClose(result)
C#
protected virtual void OnEndClose(
   IAsyncResult result
)
Delphi
protected procedure OnEndClose(
    result: IAsyncResult
); virtual;
JScript
protected function OnEndClose(
   result : IAsyncResult
);
Managed Extensions for C++
protected: virtual void OnEndClose(
   IAsyncResult* result
)
C++/CLI
protected:
virtual void OnEndClose(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnEndOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnEndOpen Method

result

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEndOpen( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim result As IAsyncResult

instance.OnEndOpen(result)
C#
protected virtual void OnEndOpen(
   IAsyncResult result
)
Delphi
protected procedure OnEndOpen(
    result: IAsyncResult
); virtual;
JScript
protected function OnEndOpen(
   result : IAsyncResult
);
Managed Extensions for C++
protected: virtual void OnEndOpen(
   IAsyncResult* result
)
C++/CLI
protected:
virtual void OnEndOpen(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnFaulted Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnFaulted Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFaulted()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnFaulted()
C#
protected virtual void OnFaulted()
Delphi
protected procedure OnFaulted(); virtual;
JScript
protected function OnFaulted();
Managed Extensions for C++
protected: virtual void OnFaulted();
C++/CLI
protected:
virtual void OnFaulted();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnOpen Method

timeout

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnOpen( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan

instance.OnOpen(timeout)
C#
protected virtual void OnOpen(
   TimeSpan timeout
)
Delphi
protected procedure OnOpen(
    timeout: TimeSpan
); virtual;
JScript
protected function OnOpen(
   timeout : TimeSpan
);
Managed Extensions for C++
protected: virtual void OnOpen(
   TimeSpan timeout
)
C++/CLI
protected:
virtual void OnOpen(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpened Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : OnOpened Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnOpened()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.OnOpened()
C#
protected virtual void OnOpened()
Delphi
protected procedure OnOpened(); virtual;
JScript
protected function OnOpened();
Managed Extensions for C++
protected: virtual void OnOpened();
C++/CLI
protected:
virtual void OnOpened();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Open Method

Overload List

Overload | Description
Open() | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Open(TimeSpan) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open() Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > Open Method : Open() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open()
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)

instance.Open()
C#
public void Open()
Delphi
public procedure Open();
JScript
public function Open();
Managed Extensions for C++
public: void Open();
C++/CLI
public:
void Open();

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open(TimeSpan) Method
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class > Open Method : Open(TimeSpan) Method

timeout

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim timeout As TimeSpan

instance.Open(timeout)
C#
public void Open(
   TimeSpan timeout
)
Delphi
public procedure Open(
    timeout: TimeSpan
);
JScript
public function Open(
   timeout : TimeSpan
);
Managed Extensions for C++
public: void Open(
   TimeSpan timeout
)
C++/CLI
public:
void Open(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Opened Event
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Opened Event

Syntax

Visual Basic (Declaration)
Public Event Opened As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim handler As EventHandler

AddHandler instance.Opened, handler
C#
public event EventHandler Opened
Delphi
public event Opened: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Opened
C++/CLI
public:
event EventHandler^ Opened

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Opening Event
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : Opening Event

Syntax

Visual Basic (Declaration)
Public Event Opening As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim handler As EventHandler

AddHandler instance.Opening, handler
C#
public event EventHandler Opening
Delphi
public event Opening: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Opening
C++/CLI
public:
event EventHandler^ Opening

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
State Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : State Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As CommunicationState
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As CommunicationState

value = instance.State
C#
public CommunicationState State {get;}
Delphi
public read-only property State: CommunicationState;
JScript
public function get State : CommunicationState
Managed Extensions for C++
public: __property CommunicationState get_State();
C++/CLI
public:
property CommunicationState State {
   CommunicationState get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ThisLock Property
See Also Send Feedback
Noemax.WCFX Namespace > XChannelFactory<TChannel> Class : ThisLock Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ThisLock As Object
Visual Basic (Usage) Copy Code
Dim instance As XChannelFactory(Of TChannel)
Dim value As Object

value = instance.ThisLock
C#
protected object ThisLock {get;}
Delphi
protected read-only property ThisLock: TObject;
JScript
protected function get ThisLock : Object
Managed Extensions for C++
protected: __property Object* get_ThisLock();
C++/CLI
protected:
property Object^ ThisLock {
   Object^ get();
}

See Also

Reference

XChannelFactory<TChannel> Class
XChannelFactory<TChannel> Members


%%PageItemTitle%% $$Events$$

[image]
Noemax WCF-Xtensions
XServiceHost Class Events
See Also Send Feedback
Noemax.WCFX Namespace : XServiceHost Class

For a list of all members of this type, see XServiceHost members.

Public Events

 | Name | Description
public Event | Closed | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Closing | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Faulted | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opened | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | Opening | (Inherited from System.ServiceModel.Channels.CommunicationObject)
public Event | UnknownMessageReceived | (Inherited from System.ServiceModel.ServiceHostBase)
Top

See Also

Reference

XServiceHost Class
Noemax.WCFX Namespace


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Abort Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Abort Method

Syntax

Visual Basic (Declaration)
Public Sub Abort()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.Abort()
C#
public void Abort()
Delphi
public procedure Abort();
JScript
public function Abort();
Managed Extensions for C++
public: void Abort();
C++/CLI
public:
void Abort();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddBaseAddress Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : AddBaseAddress Method

baseAddress

Syntax

Visual Basic (Declaration)
Protected Sub AddBaseAddress( _
   ByVal baseAddress As Uri _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim baseAddress As Uri

instance.AddBaseAddress(baseAddress)
C#
protected void AddBaseAddress(
   Uri baseAddress
)
Delphi
protected procedure AddBaseAddress(
    baseAddress: Uri
);
JScript
protected function AddBaseAddress(
   baseAddress : Uri
);
Managed Extensions for C++
protected: void AddBaseAddress(
   Uri* baseAddress
)
C++/CLI
protected:
void AddBaseAddress(
   Uri^ baseAddress
)

Parameters

baseAddress

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddDefaultEndpoints Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : AddDefaultEndpoints Method

Overload List

Overload | Description
AddDefaultEndpoints() | (Inherited from System.ServiceModel.ServiceHostBase)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddDefaultEndpoints() Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddDefaultEndpoints Method : AddDefaultEndpoints() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function AddDefaultEndpoints() As ReadOnlyCollection(Of ServiceEndpoint)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ReadOnlyCollection(Of ServiceEndpoint)

value = instance.AddDefaultEndpoints()
C#
public virtual ReadOnlyCollection<ServiceEndpoint> AddDefaultEndpoints()
Delphi
public function AddDefaultEndpoints(): ReadOnlyCollection; virtual;
JScript
public function AddDefaultEndpoints() : ReadOnlyCollection;
Managed Extensions for C++
public: virtual ReadOnlyCollection<ServiceEndpoint*>* AddDefaultEndpoints();
C++/CLI
public:
virtual ReadOnlyCollection<ServiceEndpoint^>^ AddDefaultEndpoints();

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : AddServiceEndpoint Method

Overload List

Overload | Description
AddServiceEndpoint(Type,Binding,String) | (Inherited from System.ServiceModel.ServiceHost)
AddServiceEndpoint(Type,Binding,String,Uri) | (Inherited from System.ServiceModel.ServiceHost)
AddServiceEndpoint(Type,Binding,Uri) | (Inherited from System.ServiceModel.ServiceHost)
AddServiceEndpoint(Type,Binding,Uri,Uri) | (Inherited from System.ServiceModel.ServiceHost)
AddServiceEndpoint(String,Binding,String) | (Inherited from System.ServiceModel.ServiceHostBase)
AddServiceEndpoint(String,Binding,String,Uri) | (Inherited from System.ServiceModel.ServiceHostBase)
AddServiceEndpoint(String,Binding,Uri) | (Inherited from System.ServiceModel.ServiceHostBase)
AddServiceEndpoint(String,Binding,Uri,Uri) | (Inherited from System.ServiceModel.ServiceHostBase)
AddServiceEndpoint(ServiceEndpoint) | (Inherited from System.ServiceModel.ServiceHostBase)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(ServiceEndpoint) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(ServiceEndpoint) Method

endpoint

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub AddServiceEndpoint( _
   ByVal endpoint As ServiceEndpoint _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim endpoint As ServiceEndpoint

instance.AddServiceEndpoint(endpoint)
C#
public virtual void AddServiceEndpoint(
   ServiceEndpoint endpoint
)
Delphi
public procedure AddServiceEndpoint(
    endpoint: ServiceEndpoint
); virtual;
JScript
public function AddServiceEndpoint(
   endpoint : ServiceEndpoint
);
Managed Extensions for C++
public: virtual void AddServiceEndpoint(
   ServiceEndpoint* endpoint
)
C++/CLI
public:
virtual void AddServiceEndpoint(
   ServiceEndpoint^ endpoint
)

Parameters

endpoint

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(String,Binding,String) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(String,Binding,String) Method

implementedContract
binding
address

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As String, _
   ByVal binding As Binding, _
   ByVal address As String _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As String
Dim binding As Binding
Dim address As String
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public ServiceEndpoint AddServiceEndpoint(
   string implementedContract,
   Binding binding,
   string address
)
Delphi
public function AddServiceEndpoint(
    implementedContract: String;
    binding: Binding;
    address: String
): ServiceEndpoint;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function AddServiceEndpoint(
   implementedContract : String,
   binding : Binding,
   address : String
) : ServiceEndpoint;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: ServiceEndpoint* AddServiceEndpoint(
   string* implementedContract,
   Binding* binding,
   string* address
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
ServiceEndpoint^ AddServiceEndpoint(
   String^ implementedContract,
   Binding^ binding,
   String^ address
)

Parameters

implementedContract
binding
address

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(String,Binding,String,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(String,Binding,String,Uri) Method

implementedContract
binding
address
listenUri

Syntax

Visual Basic (Declaration)
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As String, _
   ByVal binding As Binding, _
   ByVal address As String, _
   ByVal listenUri As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As String
Dim binding As Binding
Dim address As String
Dim listenUri As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address, listenUri)
C#
public ServiceEndpoint AddServiceEndpoint(
   string implementedContract,
   Binding binding,
   string address,
   Uri listenUri
)
Delphi
public function AddServiceEndpoint(
    implementedContract: String;
    binding: Binding;
    address: String;
    listenUri: Uri
): ServiceEndpoint;
JScript
public function AddServiceEndpoint(
   implementedContract : String,
   binding : Binding,
   address : String,
   listenUri : Uri
) : ServiceEndpoint;
Managed Extensions for C++
public: ServiceEndpoint* AddServiceEndpoint(
   string* implementedContract,
   Binding* binding,
   string* address,
   Uri* listenUri
)
C++/CLI
public:
ServiceEndpoint^ AddServiceEndpoint(
   String^ implementedContract,
   Binding^ binding,
   String^ address,
   Uri^ listenUri
)

Parameters

implementedContract
binding
address
listenUri

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(String,Binding,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(String,Binding,Uri) Method

implementedContract
binding
address

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As String, _
   ByVal binding As Binding, _
   ByVal address As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As String
Dim binding As Binding
Dim address As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public ServiceEndpoint AddServiceEndpoint(
   string implementedContract,
   Binding binding,
   Uri address
)
Delphi
public function AddServiceEndpoint(
    implementedContract: String;
    binding: Binding;
    address: Uri
): ServiceEndpoint;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function AddServiceEndpoint(
   implementedContract : String,
   binding : Binding,
   address : Uri
) : ServiceEndpoint;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: ServiceEndpoint* AddServiceEndpoint(
   string* implementedContract,
   Binding* binding,
   Uri* address
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
ServiceEndpoint^ AddServiceEndpoint(
   String^ implementedContract,
   Binding^ binding,
   Uri^ address
)

Parameters

implementedContract
binding
address

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(String,Binding,Uri,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(String,Binding,Uri,Uri) Method

implementedContract
binding
address
listenUri

Syntax

Visual Basic (Declaration)
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As String, _
   ByVal binding As Binding, _
   ByVal address As Uri, _
   ByVal listenUri As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As String
Dim binding As Binding
Dim address As Uri
Dim listenUri As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address, listenUri)
C#
public ServiceEndpoint AddServiceEndpoint(
   string implementedContract,
   Binding binding,
   Uri address,
   Uri listenUri
)
Delphi
public function AddServiceEndpoint(
    implementedContract: String;
    binding: Binding;
    address: Uri;
    listenUri: Uri
): ServiceEndpoint;
JScript
public function AddServiceEndpoint(
   implementedContract : String,
   binding : Binding,
   address : Uri,
   listenUri : Uri
) : ServiceEndpoint;
Managed Extensions for C++
public: ServiceEndpoint* AddServiceEndpoint(
   string* implementedContract,
   Binding* binding,
   Uri* address,
   Uri* listenUri
)
C++/CLI
public:
ServiceEndpoint^ AddServiceEndpoint(
   String^ implementedContract,
   Binding^ binding,
   Uri^ address,
   Uri^ listenUri
)

Parameters

implementedContract
binding
address
listenUri

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(Type,Binding,String) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(Type,Binding,String) Method

implementedContract
binding
address

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As Type, _
   ByVal binding As Binding, _
   ByVal address As String _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As Type
Dim binding As Binding
Dim address As String
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public ServiceEndpoint AddServiceEndpoint(
   Type implementedContract,
   Binding binding,
   string address
)
Delphi
public function AddServiceEndpoint(
    implementedContract: Type;
    binding: Binding;
    address: String
): ServiceEndpoint;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function AddServiceEndpoint(
   implementedContract : Type,
   binding : Binding,
   address : String
) : ServiceEndpoint;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: ServiceEndpoint* AddServiceEndpoint(
   Type* implementedContract,
   Binding* binding,
   string* address
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
ServiceEndpoint^ AddServiceEndpoint(
   Type^ implementedContract,
   Binding^ binding,
   String^ address
)

Parameters

implementedContract
binding
address

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(Type,Binding,String,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(Type,Binding,String,Uri) Method

implementedContract
binding
address
listenUri

Syntax

Visual Basic (Declaration)
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As Type, _
   ByVal binding As Binding, _
   ByVal address As String, _
   ByVal listenUri As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As Type
Dim binding As Binding
Dim address As String
Dim listenUri As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address, listenUri)
C#
public ServiceEndpoint AddServiceEndpoint(
   Type implementedContract,
   Binding binding,
   string address,
   Uri listenUri
)
Delphi
public function AddServiceEndpoint(
    implementedContract: Type;
    binding: Binding;
    address: String;
    listenUri: Uri
): ServiceEndpoint;
JScript
public function AddServiceEndpoint(
   implementedContract : Type,
   binding : Binding,
   address : String,
   listenUri : Uri
) : ServiceEndpoint;
Managed Extensions for C++
public: ServiceEndpoint* AddServiceEndpoint(
   Type* implementedContract,
   Binding* binding,
   string* address,
   Uri* listenUri
)
C++/CLI
public:
ServiceEndpoint^ AddServiceEndpoint(
   Type^ implementedContract,
   Binding^ binding,
   String^ address,
   Uri^ listenUri
)

Parameters

implementedContract
binding
address
listenUri

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(Type,Binding,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(Type,Binding,Uri) Method

implementedContract
binding
address

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As Type, _
   ByVal binding As Binding, _
   ByVal address As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As Type
Dim binding As Binding
Dim address As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public ServiceEndpoint AddServiceEndpoint(
   Type implementedContract,
   Binding binding,
   Uri address
)
Delphi
public function AddServiceEndpoint(
    implementedContract: Type;
    binding: Binding;
    address: Uri
): ServiceEndpoint;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function AddServiceEndpoint(
   implementedContract : Type,
   binding : Binding,
   address : Uri
) : ServiceEndpoint;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: ServiceEndpoint* AddServiceEndpoint(
   Type* implementedContract,
   Binding* binding,
   Uri* address
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
ServiceEndpoint^ AddServiceEndpoint(
   Type^ implementedContract,
   Binding^ binding,
   Uri^ address
)

Parameters

implementedContract
binding
address

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
AddServiceEndpoint(Type,Binding,Uri,Uri) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > AddServiceEndpoint Method : AddServiceEndpoint(Type,Binding,Uri,Uri) Method

implementedContract
binding
address
listenUri

Syntax

Visual Basic (Declaration)
Public Overloads Function AddServiceEndpoint( _
   ByVal implementedContract As Type, _
   ByVal binding As Binding, _
   ByVal address As Uri, _
   ByVal listenUri As Uri _
) As ServiceEndpoint
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContract As Type
Dim binding As Binding
Dim address As Uri
Dim listenUri As Uri
Dim value As ServiceEndpoint

value = instance.AddServiceEndpoint(implementedContract, binding, address, listenUri)
C#
public ServiceEndpoint AddServiceEndpoint(
   Type implementedContract,
   Binding binding,
   Uri address,
   Uri listenUri
)
Delphi
public function AddServiceEndpoint(
    implementedContract: Type;
    binding: Binding;
    address: Uri;
    listenUri: Uri
): ServiceEndpoint;
JScript
public function AddServiceEndpoint(
   implementedContract : Type,
   binding : Binding,
   address : Uri,
   listenUri : Uri
) : ServiceEndpoint;
Managed Extensions for C++
public: ServiceEndpoint* AddServiceEndpoint(
   Type* implementedContract,
   Binding* binding,
   Uri* address,
   Uri* listenUri
)
C++/CLI
public:
ServiceEndpoint^ AddServiceEndpoint(
   Type^ implementedContract,
   Binding^ binding,
   Uri^ address,
   Uri^ listenUri
)

Parameters

implementedContract
binding
address
listenUri

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ApplyConfiguration Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : ApplyConfiguration Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ApplyConfiguration()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.ApplyConfiguration()
C#
protected virtual void ApplyConfiguration()
Delphi
protected procedure ApplyConfiguration(); virtual;
JScript
protected function ApplyConfiguration();
Managed Extensions for C++
protected: virtual void ApplyConfiguration();
C++/CLI
protected:
virtual void ApplyConfiguration();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authentication Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Authentication Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Authentication As ServiceAuthenticationBehavior
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ServiceAuthenticationBehavior

value = instance.Authentication
C#
public ServiceAuthenticationBehavior Authentication {get;}
Delphi
public read-only property Authentication: ServiceAuthenticationBehavior;
JScript
public function get Authentication : ServiceAuthenticationBehavior
Managed Extensions for C++
public: __property ServiceAuthenticationBehavior* get_Authentication();
C++/CLI
public:
property ServiceAuthenticationBehavior^ Authentication {
   ServiceAuthenticationBehavior^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Authorization Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Authorization Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Authorization As ServiceAuthorizationBehavior
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ServiceAuthorizationBehavior

value = instance.Authorization
C#
public ServiceAuthorizationBehavior Authorization {get;}
Delphi
public read-only property Authorization: ServiceAuthorizationBehavior;
JScript
public function get Authorization : ServiceAuthorizationBehavior
Managed Extensions for C++
public: __property ServiceAuthorizationBehavior* get_Authorization();
C++/CLI
public:
property ServiceAuthorizationBehavior^ Authorization {
   ServiceAuthorizationBehavior^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BaseAddresses Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : BaseAddresses Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseAddresses As ReadOnlyCollection(Of Uri)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ReadOnlyCollection(Of Uri)

value = instance.BaseAddresses
C#
public ReadOnlyCollection<Uri> BaseAddresses {get;}
Delphi
public read-only property BaseAddresses: ReadOnlyCollection;
JScript
public function get BaseAddresses : ReadOnlyCollection
Managed Extensions for C++
public: __property ReadOnlyCollection<Uri*>* get_BaseAddresses();
C++/CLI
public:
property ReadOnlyCollection<Uri^>^ BaseAddresses {
   ReadOnlyCollection<Uri^>^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : BeginClose Method

Overload List

Overload | Description
BeginClose(AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)
BeginClose(TimeSpan,AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose(AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > BeginClose Method : BeginClose(AsyncCallback,Object) Method

callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginClose( _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginClose(callback, state)
C#
public IAsyncResult BeginClose(
   AsyncCallback callback,
   object state
)
Delphi
public function BeginClose(
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginClose(
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginClose(
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginClose(
   AsyncCallback^ callback,
   Object^ state
)

Parameters

callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginClose(TimeSpan,AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > BeginClose Method : BeginClose(TimeSpan,AsyncCallback,Object) Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginClose( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginClose(timeout, callback, state)
C#
public IAsyncResult BeginClose(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginClose(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginClose(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginClose(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginClose(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : BeginOpen Method

Overload List

Overload | Description
BeginOpen(AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)
BeginOpen(TimeSpan,AsyncCallback,Object) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen(AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > BeginOpen Method : BeginOpen(AsyncCallback,Object) Method

callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginOpen( _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginOpen(callback, state)
C#
public IAsyncResult BeginOpen(
   AsyncCallback callback,
   object state
)
Delphi
public function BeginOpen(
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginOpen(
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginOpen(
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginOpen(
   AsyncCallback^ callback,
   Object^ state
)

Parameters

callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
BeginOpen(TimeSpan,AsyncCallback,Object) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > BeginOpen Method : BeginOpen(TimeSpan,AsyncCallback,Object) Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginOpen( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginOpen(timeout, callback, state)
C#
public IAsyncResult BeginOpen(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginOpen(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
public function BeginOpen(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
public: IAsyncResult* BeginOpen(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
public:
IAsyncResult^ BeginOpen(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ChannelDispatchers Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : ChannelDispatchers Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChannelDispatchers As ChannelDispatcherCollection
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ChannelDispatcherCollection

value = instance.ChannelDispatchers
C#
public ChannelDispatcherCollection ChannelDispatchers {get;}
Delphi
public read-only property ChannelDispatchers: ChannelDispatcherCollection;
JScript
public function get ChannelDispatchers : ChannelDispatcherCollection
Managed Extensions for C++
public: __property ChannelDispatcherCollection* get_ChannelDispatchers();
C++/CLI
public:
property ChannelDispatcherCollection^ ChannelDispatchers {
   ChannelDispatcherCollection^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Close Method

Overload List

Overload | Description
Close() | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Close(TimeSpan) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close() Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > Close Method : Close() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Close(TimeSpan) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > Close Method : Close(TimeSpan) Method

timeout

Syntax

Visual Basic (Declaration)
Public Overloads Sub Close( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan

instance.Close(timeout)
C#
public void Close(
   TimeSpan timeout
)
Delphi
public procedure Close(
    timeout: TimeSpan
);
JScript
public function Close(
   timeout : TimeSpan
);
Managed Extensions for C++
public: void Close(
   TimeSpan timeout
)
C++/CLI
public:
void Close(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Closed Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Closed Event

Syntax

Visual Basic (Declaration)
Public Event Closed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
public event EventHandler Closed
Delphi
public event Closed: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Closed
C++/CLI
public:
event EventHandler^ Closed

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CloseTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : CloseTimeout Property

Syntax

Visual Basic (Declaration)
Public Property CloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As TimeSpan

instance.CloseTimeout = value

value = instance.CloseTimeout
C#
public TimeSpan CloseTimeout {get; set;}
Delphi
public read-write property CloseTimeout: TimeSpan;
JScript
public function get,set CloseTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_CloseTimeout();
public: __property void set_CloseTimeout(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan CloseTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Closing Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Closing Event

Syntax

Visual Basic (Declaration)
Public Event Closing As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler

AddHandler instance.Closing, handler
C#
public event EventHandler Closing
Delphi
public event Closing: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Closing
C++/CLI
public:
event EventHandler^ Closing

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CreateDescription Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : CreateDescription Method

implementedContracts

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDescription( _
   ByRef implementedContracts As IDictionary(Of String,ContractDescription) _
) As ServiceDescription
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim implementedContracts As IDictionary(Of String,ContractDescription)
Dim value As ServiceDescription

value = instance.CreateDescription(implementedContracts)
C#
protected virtual ServiceDescription CreateDescription(
   out IDictionary<string,ContractDescription> implementedContracts
)
Delphi
protected function CreateDescription(
   Out  implementedContracts: IDictionary
): ServiceDescription; virtual;
JScript
protected function CreateDescription(
   implementedContracts : IDictionary
) : ServiceDescription;
Managed Extensions for C++
protected: virtual ServiceDescription* CreateDescription(
   [PARAMFLAG::Out] IDictionary<string*,ContractDescription*>* implementedContracts
)
C++/CLI
protected:
virtual ServiceDescription^ CreateDescription(
   [Out] IDictionary<String^,ContractDescription^>^ implementedContracts
)

Parameters

implementedContracts

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Credentials Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Credentials Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Credentials As ServiceCredentials
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ServiceCredentials

value = instance.Credentials
C#
public ServiceCredentials Credentials {get;}
Delphi
public read-only property Credentials: ServiceCredentials;
JScript
public function get Credentials : ServiceCredentials
Managed Extensions for C++
public: __property ServiceCredentials* get_Credentials();
C++/CLI
public:
property ServiceCredentials^ Credentials {
   ServiceCredentials^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DefaultCloseTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : DefaultCloseTimeout Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DefaultCloseTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As TimeSpan

value = instance.DefaultCloseTimeout
C#
protected TimeSpan DefaultCloseTimeout {get;}
Delphi
protected read-only property DefaultCloseTimeout: TimeSpan;
JScript
protected function get DefaultCloseTimeout : TimeSpan
Managed Extensions for C++
protected: __property TimeSpan get_DefaultCloseTimeout();
C++/CLI
protected:
property TimeSpan DefaultCloseTimeout {
   TimeSpan get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
DefaultOpenTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : DefaultOpenTimeout Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DefaultOpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As TimeSpan

value = instance.DefaultOpenTimeout
C#
protected TimeSpan DefaultOpenTimeout {get;}
Delphi
protected read-only property DefaultOpenTimeout: TimeSpan;
JScript
protected function get DefaultOpenTimeout : TimeSpan
Managed Extensions for C++
protected: __property TimeSpan get_DefaultOpenTimeout();
C++/CLI
protected:
property TimeSpan DefaultOpenTimeout {
   TimeSpan get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Description Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Description Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As ServiceDescription
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As ServiceDescription

value = instance.Description
C#
public ServiceDescription Description {get;}
Delphi
public read-only property Description: ServiceDescription;
JScript
public function get Description : ServiceDescription
Managed Extensions for C++
public: __property ServiceDescription* get_Description();
C++/CLI
public:
property ServiceDescription^ Description {
   ServiceDescription^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : EndClose Method

result

Syntax

Visual Basic (Declaration)
Public Sub EndClose( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim result As IAsyncResult

instance.EndClose(result)
C#
public void EndClose(
   IAsyncResult result
)
Delphi
public procedure EndClose(
    result: IAsyncResult
);
JScript
public function EndClose(
   result : IAsyncResult
);
Managed Extensions for C++
public: void EndClose(
   IAsyncResult* result
)
C++/CLI
public:
void EndClose(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : EndOpen Method

result

Syntax

Visual Basic (Declaration)
Public Sub EndOpen( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim result As IAsyncResult

instance.EndOpen(result)
C#
public void EndOpen(
   IAsyncResult result
)
Delphi
public procedure EndOpen(
    result: IAsyncResult
);
JScript
public function EndOpen(
   result : IAsyncResult
);
Managed Extensions for C++
public: void EndOpen(
   IAsyncResult* result
)
C++/CLI
public:
void EndOpen(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Extensions Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Extensions Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Extensions As IExtensionCollection(Of ServiceHostBase)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As IExtensionCollection(Of ServiceHostBase)

value = instance.Extensions
C#
public IExtensionCollection<ServiceHostBase> Extensions {get;}
Delphi
public read-only property Extensions: IExtensionCollection;
JScript
public function get Extensions : IExtensionCollection
Managed Extensions for C++
public: __property IExtensionCollection<ServiceHostBase*>* get_Extensions();
C++/CLI
public:
property IExtensionCollection<ServiceHostBase^>^ Extensions {
   IExtensionCollection<ServiceHostBase^>^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Fault Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Fault Method

Overload List

Overload | Description
Fault() | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Fault() Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > Fault Method : Fault() Method

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Fault()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.Fault()
C#
protected void Fault()
Delphi
protected procedure Fault();
JScript
protected function Fault();
Managed Extensions for C++
protected: void Fault();
C++/CLI
protected:
void Fault();

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Faulted Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Faulted Event

Syntax

Visual Basic (Declaration)
Public Event Faulted As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler

AddHandler instance.Faulted, handler
C#
public event EventHandler Faulted
Delphi
public event Faulted: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Faulted
C++/CLI
public:
event EventHandler^ Faulted

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetCommunicationObjectType Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : GetCommunicationObjectType Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCommunicationObjectType() As Type
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Type

value = instance.GetCommunicationObjectType()
C#
protected virtual Type GetCommunicationObjectType()
Delphi
protected function GetCommunicationObjectType(): Type; virtual;
JScript
protected function GetCommunicationObjectType() : Type;
Managed Extensions for C++
protected: virtual Type* GetCommunicationObjectType();
C++/CLI
protected:
virtual Type^ GetCommunicationObjectType();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IncrementManualFlowControlLimit Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : IncrementManualFlowControlLimit Method

incrementBy

Syntax

Visual Basic (Declaration)
Public Function IncrementManualFlowControlLimit( _
   ByVal incrementBy As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim incrementBy As Integer
Dim value As Integer

value = instance.IncrementManualFlowControlLimit(incrementBy)
C#
public int IncrementManualFlowControlLimit(
   int incrementBy
)
Delphi
public function IncrementManualFlowControlLimit(
    incrementBy: Integer
): Integer;
JScript
public function IncrementManualFlowControlLimit(
   incrementBy : int
) : int;
Managed Extensions for C++
public: int IncrementManualFlowControlLimit(
   int incrementBy
)
C++/CLI
public:
int IncrementManualFlowControlLimit(
   int incrementBy
)

Parameters

incrementBy

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeDescription Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : InitializeDescription Method

Overload List

Overload | Description
InitializeDescription(Object,UriSchemeKeyedCollection) | (Inherited from System.ServiceModel.ServiceHost)
InitializeDescription(Type,UriSchemeKeyedCollection) | (Inherited from System.ServiceModel.ServiceHost)
InitializeDescription(UriSchemeKeyedCollection) | (Inherited from System.ServiceModel.ServiceHostBase)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeDescription(Object,UriSchemeKeyedCollection) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > InitializeDescription Method : InitializeDescription(Object,UriSchemeKeyedCollection) Method

singletonInstance
baseAddresses

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeDescription( _
   ByVal singletonInstance As Object, _
   ByVal baseAddresses As UriSchemeKeyedCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim singletonInstance As Object
Dim baseAddresses As UriSchemeKeyedCollection

instance.InitializeDescription(singletonInstance, baseAddresses)
C#
protected void InitializeDescription(
   object singletonInstance,
   UriSchemeKeyedCollection baseAddresses
)
Delphi
protected procedure InitializeDescription(
    singletonInstance: TObject;
    baseAddresses: UriSchemeKeyedCollection
);
JScript
protected function InitializeDescription(
   singletonInstance : Object,
   baseAddresses : UriSchemeKeyedCollection
);
Managed Extensions for C++
protected: void InitializeDescription(
   Object* singletonInstance,
   UriSchemeKeyedCollection* baseAddresses
)
C++/CLI
protected:
void InitializeDescription(
   Object^ singletonInstance,
   UriSchemeKeyedCollection^ baseAddresses
)

Parameters

singletonInstance
baseAddresses

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeDescription(Type,UriSchemeKeyedCollection) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > InitializeDescription Method : InitializeDescription(Type,UriSchemeKeyedCollection) Method

serviceType
baseAddresses

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeDescription( _
   ByVal serviceType As Type, _
   ByVal baseAddresses As UriSchemeKeyedCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim serviceType As Type
Dim baseAddresses As UriSchemeKeyedCollection

instance.InitializeDescription(serviceType, baseAddresses)
C#
protected void InitializeDescription(
   Type serviceType,
   UriSchemeKeyedCollection baseAddresses
)
Delphi
protected procedure InitializeDescription(
    serviceType: Type;
    baseAddresses: UriSchemeKeyedCollection
);
JScript
protected function InitializeDescription(
   serviceType : Type,
   baseAddresses : UriSchemeKeyedCollection
);
Managed Extensions for C++
protected: void InitializeDescription(
   Type* serviceType,
   UriSchemeKeyedCollection* baseAddresses
)
C++/CLI
protected:
void InitializeDescription(
   Type^ serviceType,
   UriSchemeKeyedCollection^ baseAddresses
)

Parameters

serviceType
baseAddresses

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeDescription(UriSchemeKeyedCollection) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > InitializeDescription Method : InitializeDescription(UriSchemeKeyedCollection) Method

baseAddresses

Syntax

Visual Basic (Declaration)
Protected Overloads Sub InitializeDescription( _
   ByVal baseAddresses As UriSchemeKeyedCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim baseAddresses As UriSchemeKeyedCollection

instance.InitializeDescription(baseAddresses)
C#
protected void InitializeDescription(
   UriSchemeKeyedCollection baseAddresses
)
Delphi
protected procedure InitializeDescription(
    baseAddresses: UriSchemeKeyedCollection
);
JScript
protected function InitializeDescription(
   baseAddresses : UriSchemeKeyedCollection
);
Managed Extensions for C++
protected: void InitializeDescription(
   UriSchemeKeyedCollection* baseAddresses
)
C++/CLI
protected:
void InitializeDescription(
   UriSchemeKeyedCollection^ baseAddresses
)

Parameters

baseAddresses

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
InitializeRuntime Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : InitializeRuntime Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeRuntime()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.InitializeRuntime()
C#
protected virtual void InitializeRuntime()
Delphi
protected procedure InitializeRuntime(); virtual;
JScript
protected function InitializeRuntime();
Managed Extensions for C++
protected: virtual void InitializeRuntime();
C++/CLI
protected:
virtual void InitializeRuntime();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDisposed Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : IsDisposed Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsDisposed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Boolean

value = instance.IsDisposed
C#
protected bool IsDisposed {get;}
Delphi
protected read-only property IsDisposed: Boolean;
JScript
protected function get IsDisposed : boolean
Managed Extensions for C++
protected: __property bool get_IsDisposed();
C++/CLI
protected:
property bool IsDisposed {
   bool get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
LoadConfigurationSection Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : LoadConfigurationSection Method

serviceSection

Syntax

Visual Basic (Declaration)
Protected Sub LoadConfigurationSection( _
   ByVal serviceSection As ServiceElement _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim serviceSection As ServiceElement

instance.LoadConfigurationSection(serviceSection)
C#
protected void LoadConfigurationSection(
   ServiceElement serviceSection
)
Delphi
protected procedure LoadConfigurationSection(
    serviceSection: ServiceElement
);
JScript
protected function LoadConfigurationSection(
   serviceSection : ServiceElement
);
Managed Extensions for C++
protected: void LoadConfigurationSection(
   ServiceElement* serviceSection
)
C++/CLI
protected:
void LoadConfigurationSection(
   ServiceElement^ serviceSection
)

Parameters

serviceSection

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ManualFlowControlLimit Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : ManualFlowControlLimit Property

Syntax

Visual Basic (Declaration)
Public Property ManualFlowControlLimit As Integer
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Integer

instance.ManualFlowControlLimit = value

value = instance.ManualFlowControlLimit
C#
public int ManualFlowControlLimit {get; set;}
Delphi
public read-write property ManualFlowControlLimit: Integer;
JScript
public function get,set ManualFlowControlLimit : int
Managed Extensions for C++
public: __property int get_ManualFlowControlLimit();
public: __property void set_ManualFlowControlLimit(
   int value
);
C++/CLI
public:
property int ManualFlowControlLimit {
   int get();
   void set (    int value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnAbort Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnAbort Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAbort()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnAbort()
C#
protected virtual void OnAbort()
Delphi
protected procedure OnAbort(); virtual;
JScript
protected function OnAbort();
Managed Extensions for C++
protected: virtual void OnAbort();
C++/CLI
protected:
virtual void OnAbort();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnBeginClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnBeginClose Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBeginClose( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.OnBeginClose(timeout, callback, state)
C#
protected virtual IAsyncResult OnBeginClose(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
protected function OnBeginClose(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
protected function OnBeginClose(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
protected: virtual IAsyncResult* OnBeginClose(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
protected:
virtual IAsyncResult^ OnBeginClose(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnBeginOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnBeginOpen Method

timeout
callback
state

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBeginOpen( _
   ByVal timeout As TimeSpan, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.OnBeginOpen(timeout, callback, state)
C#
protected virtual IAsyncResult OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback callback,
   object state
)
Delphi
protected function OnBeginOpen(
    timeout: TimeSpan;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
protected function OnBeginOpen(
   timeout : TimeSpan,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
protected: virtual IAsyncResult* OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
protected:
virtual IAsyncResult^ OnBeginOpen(
   TimeSpan timeout,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

timeout
callback
state

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnClose Method

timeout

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClose( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan

instance.OnClose(timeout)
C#
protected virtual void OnClose(
   TimeSpan timeout
)
Delphi
protected procedure OnClose(
    timeout: TimeSpan
); virtual;
JScript
protected function OnClose(
   timeout : TimeSpan
);
Managed Extensions for C++
protected: virtual void OnClose(
   TimeSpan timeout
)
C++/CLI
protected:
virtual void OnClose(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClosed Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnClosed Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClosed()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnClosed()
C#
protected virtual void OnClosed()
Delphi
protected procedure OnClosed(); virtual;
JScript
protected function OnClosed();
Managed Extensions for C++
protected: virtual void OnClosed();
C++/CLI
protected:
virtual void OnClosed();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnClosing Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnClosing Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClosing()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnClosing()
C#
protected virtual void OnClosing()
Delphi
protected procedure OnClosing(); virtual;
JScript
protected function OnClosing();
Managed Extensions for C++
protected: virtual void OnClosing();
C++/CLI
protected:
virtual void OnClosing();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnEndClose Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnEndClose Method

result

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEndClose( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim result As IAsyncResult

instance.OnEndClose(result)
C#
protected virtual void OnEndClose(
   IAsyncResult result
)
Delphi
protected procedure OnEndClose(
    result: IAsyncResult
); virtual;
JScript
protected function OnEndClose(
   result : IAsyncResult
);
Managed Extensions for C++
protected: virtual void OnEndClose(
   IAsyncResult* result
)
C++/CLI
protected:
virtual void OnEndClose(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnEndOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnEndOpen Method

result

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEndOpen( _
   ByVal result As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim result As IAsyncResult

instance.OnEndOpen(result)
C#
protected virtual void OnEndOpen(
   IAsyncResult result
)
Delphi
protected procedure OnEndOpen(
    result: IAsyncResult
); virtual;
JScript
protected function OnEndOpen(
   result : IAsyncResult
);
Managed Extensions for C++
protected: virtual void OnEndOpen(
   IAsyncResult* result
)
C++/CLI
protected:
virtual void OnEndOpen(
   IAsyncResult^ result
)

Parameters

result

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnFaulted Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnFaulted Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFaulted()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnFaulted()
C#
protected virtual void OnFaulted()
Delphi
protected procedure OnFaulted(); virtual;
JScript
protected function OnFaulted();
Managed Extensions for C++
protected: virtual void OnFaulted();
C++/CLI
protected:
virtual void OnFaulted();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpen Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnOpen Method

timeout

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnOpen( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan

instance.OnOpen(timeout)
C#
protected virtual void OnOpen(
   TimeSpan timeout
)
Delphi
protected procedure OnOpen(
    timeout: TimeSpan
); virtual;
JScript
protected function OnOpen(
   timeout : TimeSpan
);
Managed Extensions for C++
protected: virtual void OnOpen(
   TimeSpan timeout
)
C++/CLI
protected:
virtual void OnOpen(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OnOpened Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OnOpened Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnOpened()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.OnOpened()
C#
protected virtual void OnOpened()
Delphi
protected procedure OnOpened(); virtual;
JScript
protected function OnOpened();
Managed Extensions for C++
protected: virtual void OnOpened();
C++/CLI
protected:
virtual void OnOpened();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Open Method

Overload List

Overload | Description
Open() | (Inherited from System.ServiceModel.Channels.CommunicationObject)
Open(TimeSpan) | (Inherited from System.ServiceModel.Channels.CommunicationObject)

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open() Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > Open Method : Open() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.Open()
C#
public void Open()
Delphi
public procedure Open();
JScript
public function Open();
Managed Extensions for C++
public: void Open();
C++/CLI
public:
void Open();

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Open(TimeSpan) Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class > Open Method : Open(TimeSpan) Method

timeout

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal timeout As TimeSpan _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim timeout As TimeSpan

instance.Open(timeout)
C#
public void Open(
   TimeSpan timeout
)
Delphi
public procedure Open(
    timeout: TimeSpan
);
JScript
public function Open(
   timeout : TimeSpan
);
Managed Extensions for C++
public: void Open(
   TimeSpan timeout
)
C++/CLI
public:
void Open(
   TimeSpan timeout
)

Parameters

timeout

See Also

Reference

XServiceHost Class
XServiceHost Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Opened Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Opened Event

Syntax

Visual Basic (Declaration)
Public Event Opened As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler

AddHandler instance.Opened, handler
C#
public event EventHandler Opened
Delphi
public event Opened: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Opened
C++/CLI
public:
event EventHandler^ Opened

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Opening Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : Opening Event

Syntax

Visual Basic (Declaration)
Public Event Opening As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler

AddHandler instance.Opening, handler
C#
public event EventHandler Opening
Delphi
public event Opening: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* Opening
C++/CLI
public:
event EventHandler^ Opening

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
OpenTimeout Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : OpenTimeout Property

Syntax

Visual Basic (Declaration)
Public Property OpenTimeout As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As TimeSpan

instance.OpenTimeout = value

value = instance.OpenTimeout
C#
public TimeSpan OpenTimeout {get; set;}
Delphi
public read-write property OpenTimeout: TimeSpan;
JScript
public function get,set OpenTimeout : TimeSpan
Managed Extensions for C++
public: __property TimeSpan get_OpenTimeout();
public: __property void set_OpenTimeout(
   TimeSpan value
);
C++/CLI
public:
property TimeSpan OpenTimeout {
   TimeSpan get();
   void set (    TimeSpan value);
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReleasePerformanceCounters Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : ReleasePerformanceCounters Method

Syntax

Visual Basic (Declaration)
Protected Sub ReleasePerformanceCounters()
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost

instance.ReleasePerformanceCounters()
C#
protected void ReleasePerformanceCounters()
Delphi
protected procedure ReleasePerformanceCounters();
JScript
protected function ReleasePerformanceCounters();
Managed Extensions for C++
protected: void ReleasePerformanceCounters();
C++/CLI
protected:
void ReleasePerformanceCounters();

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SetEndpointAddress Method
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : SetEndpointAddress Method

endpoint
relativeAddress

Syntax

Visual Basic (Declaration)
Public Sub SetEndpointAddress( _
   ByVal endpoint As ServiceEndpoint, _
   ByVal relativeAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim endpoint As ServiceEndpoint
Dim relativeAddress As String

instance.SetEndpointAddress(endpoint, relativeAddress)
C#
public void SetEndpointAddress(
   ServiceEndpoint endpoint,
   string relativeAddress
)
Delphi
public procedure SetEndpointAddress(
    endpoint: ServiceEndpoint;
    relativeAddress: String
);
JScript
public function SetEndpointAddress(
   endpoint : ServiceEndpoint,
   relativeAddress : String
);
Managed Extensions for C++
public: void SetEndpointAddress(
   ServiceEndpoint* endpoint,
   string* relativeAddress
)
C++/CLI
public:
void SetEndpointAddress(
   ServiceEndpoint^ endpoint,
   String^ relativeAddress
)

Parameters

endpoint
relativeAddress

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SingletonInstance Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : SingletonInstance Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SingletonInstance As Object
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Object

value = instance.SingletonInstance
C#
public object SingletonInstance {get;}
Delphi
public read-only property SingletonInstance: TObject;
JScript
public function get SingletonInstance : Object
Managed Extensions for C++
public: __property Object* get_SingletonInstance();
C++/CLI
public:
property Object^ SingletonInstance {
   Object^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
State Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : State Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As CommunicationState
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As CommunicationState

value = instance.State
C#
public CommunicationState State {get;}
Delphi
public read-only property State: CommunicationState;
JScript
public function get State : CommunicationState
Managed Extensions for C++
public: __property CommunicationState get_State();
C++/CLI
public:
property CommunicationState State {
   CommunicationState get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ThisLock Property
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : ThisLock Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ThisLock As Object
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim value As Object

value = instance.ThisLock
C#
protected object ThisLock {get;}
Delphi
protected read-only property ThisLock: TObject;
JScript
protected function get ThisLock : Object
Managed Extensions for C++
protected: __property Object* get_ThisLock();
C++/CLI
protected:
property Object^ ThisLock {
   Object^ get();
}

See Also

Reference

XServiceHost Class
XServiceHost Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
UnknownMessageReceived Event
See Also Send Feedback
Noemax.WCFX Namespace > XServiceHost Class : UnknownMessageReceived Event

Syntax

Visual Basic (Declaration)
Public Event UnknownMessageReceived As EventHandler(Of UnknownMessageReceivedEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As XServiceHost
Dim handler As EventHandler(Of UnknownMessageReceivedEventArgs)

AddHandler instance.UnknownMessageReceived, handler
C#
public event EventHandler<UnknownMessageReceivedEventArgs> UnknownMessageReceived
Delphi
public event UnknownMessageReceived: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler<UnknownMessageReceivedEventArgs*>* UnknownMessageReceived
C++/CLI
public:
event EventHandler<UnknownMessageReceivedEventArgs^>^ UnknownMessageReceived

Event Data

The event handler receives an argument of type UnknownMessageReceivedEventArgs containing data related to this event. The following UnknownMessageReceivedEventArgs properties provide information specific to this event.

Property | Description
Message | Gets the unknown message that caused the event.

See Also

Reference

XServiceHost Class
XServiceHost Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.WCFX Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.WCFX.FastInfosetSettings
Noemax.WCFX.XBindingConfigurator
Noemax.WCFX.XCompressionConverter
System.ServiceModel.ChannelFactory<TChannel>
System.ServiceModel.ChannelFactory
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.XChannelFactory<TChannel>
System.ServiceModel.ServiceHost
System.ServiceModel.ServiceHostBase
System.ServiceModel.Channels.CommunicationObject
Noemax.WCFX.XServiceHost

See Also

Reference

Noemax.WCFX Assembly


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanCanonicalize Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : CanCanonicalize Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanCanonicalize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.CanCanonicalize
C#
public virtual bool CanCanonicalize {get;}
Delphi
public read-only property CanCanonicalize: Boolean; virtual;
JScript
public function get CanCanonicalize : boolean
Managed Extensions for C++
public: __property virtual bool get_CanCanonicalize();
C++/CLI
public:
virtual property bool CanCanonicalize {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanReadValueChunk Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : CanReadValueChunk Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanReadValueChunk As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.CanReadValueChunk
C#
public virtual bool CanReadValueChunk {get;}
Delphi
public read-only property CanReadValueChunk: Boolean; virtual;
JScript
public function get CanReadValueChunk : boolean
Managed Extensions for C++
public: __property virtual bool get_CanReadValueChunk();
C++/CLI
public:
virtual property bool CanReadValueChunk {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanResolveEntity Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : CanResolveEntity Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanResolveEntity As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.CanResolveEntity
C#
public virtual bool CanResolveEntity {get;}
Delphi
public read-only property CanResolveEntity: Boolean; virtual;
JScript
public function get CanResolveEntity : boolean
Managed Extensions for C++
public: __property virtual bool get_CanResolveEntity();
C++/CLI
public:
virtual property bool CanResolveEntity {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndCanonicalization Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : EndCanonicalization Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndCanonicalization()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.EndCanonicalization()
C#
public virtual void EndCanonicalization()
Delphi
public procedure EndCanonicalization(); virtual;
JScript
public function EndCanonicalization();
Managed Extensions for C++
public: virtual void EndCanonicalization();
C++/CLI
public:
virtual void EndCanonicalization();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetAttribute(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > GetAttribute Method : GetAttribute(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetAttribute( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As String

value = instance.GetAttribute(localName, namespaceUri)
C#
public virtual string GetAttribute(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function GetAttribute(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): String; virtual;
JScript
public function GetAttribute(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : String;
Managed Extensions for C++
public: virtual string* GetAttribute(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual String^ GetAttribute(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
GetNonAtomizedNames Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : GetNonAtomizedNames Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetNonAtomizedNames( _
   ByRef localName As String, _
   ByRef namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String

instance.GetNonAtomizedNames(localName, namespaceUri)
C#
public virtual void GetNonAtomizedNames(
   out string localName,
   out string namespaceUri
)
Delphi
public procedure GetNonAtomizedNames(
   Out  localName: String;
   Out  namespaceUri: String
); virtual;
JScript
public function GetNonAtomizedNames(
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: virtual void GetNonAtomizedNames(
   [PARAMFLAG::Out] string* localName,
   [PARAMFLAG::Out] string* namespaceUri
)
C++/CLI
public:
virtual void GetNonAtomizedNames(
   [Out] String^ localName,
   [Out] String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
HasAttributes Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : HasAttributes Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasAttributes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.HasAttributes
C#
public virtual bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: Boolean; virtual;
JScript
public function get HasAttributes : boolean
Managed Extensions for C++
public: __property virtual bool get_HasAttributes();
C++/CLI
public:
virtual property bool HasAttributes {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IndexOfLocalName Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IndexOfLocalName Method

Overload List

Overload | Description
IndexOfLocalName(String[],String) | (Inherited from System.Xml.XmlDictionaryReader)
IndexOfLocalName(XmlDictionaryString[],XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IndexOfLocalName(String[],String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IndexOfLocalName Method : IndexOfLocalName(String[],String) Method

localNames
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOfLocalName( _
   ByVal localNames() As String, _
   ByVal namespaceUri As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localNames() As String
Dim namespaceUri As String
Dim value As Integer

value = instance.IndexOfLocalName(localNames, namespaceUri)
C#
public virtual int IndexOfLocalName(
   string[] localNames,
   string namespaceUri
)
Delphi
public function IndexOfLocalName(
    localNames: Stringarray of;
    namespaceUri: String
): Integer; virtual;
JScript
public function IndexOfLocalName(
   localNames : String[],
   namespaceUri : String
) : int;
Managed Extensions for C++
public: virtual int IndexOfLocalName(
   string*[]* localNames,
   string* namespaceUri
)
C++/CLI
public:
virtual int IndexOfLocalName(
   array<String^>^ localNames,
   String^ namespaceUri
)

Parameters

localNames
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IndexOfLocalName(XmlDictionaryString[],XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IndexOfLocalName Method : IndexOfLocalName(XmlDictionaryString[],XmlDictionaryString) Method

localNames
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOfLocalName( _
   ByVal localNames() As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localNames() As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As Integer

value = instance.IndexOfLocalName(localNames, namespaceUri)
C#
public virtual int IndexOfLocalName(
   XmlDictionaryString[] localNames,
   XmlDictionaryString namespaceUri
)
Delphi
public function IndexOfLocalName(
    localNames: XmlDictionaryStringarray of;
    namespaceUri: XmlDictionaryString
): Integer; virtual;
JScript
public function IndexOfLocalName(
   localNames : XmlDictionaryString[],
   namespaceUri : XmlDictionaryString
) : int;
Managed Extensions for C++
public: virtual int IndexOfLocalName(
   XmlDictionaryString*[]* localNames,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual int IndexOfLocalName(
   array<XmlDictionaryString^>^ localNames,
   XmlDictionaryString^ namespaceUri
)

Parameters

localNames
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsDefault Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsDefault Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Boolean

value = instance.IsDefault
C#
public virtual bool IsDefault {get;}
Delphi
public read-only property IsDefault: Boolean; virtual;
JScript
public function get IsDefault : boolean
Managed Extensions for C++
public: __property virtual bool get_IsDefault();
C++/CLI
public:
virtual property bool IsDefault {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsLocalName Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsLocalName Method

Overload List

Overload | Description
IsLocalName(String) | (Inherited from System.Xml.XmlDictionaryReader)
IsLocalName(XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsLocalName(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsLocalName Method : IsLocalName(String) Method

localName

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsLocalName( _
   ByVal localName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim value As Boolean

value = instance.IsLocalName(localName)
C#
public virtual bool IsLocalName(
   string localName
)
Delphi
public function IsLocalName(
    localName: String
): Boolean; virtual;
JScript
public function IsLocalName(
   localName : String
) : boolean;
Managed Extensions for C++
public: virtual bool IsLocalName(
   string* localName
)
C++/CLI
public:
virtual bool IsLocalName(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsLocalName(XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsLocalName Method : IsLocalName(XmlDictionaryString) Method

localName

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsLocalName( _
   ByVal localName As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim value As Boolean

value = instance.IsLocalName(localName)
C#
public virtual bool IsLocalName(
   XmlDictionaryString localName
)
Delphi
public function IsLocalName(
    localName: XmlDictionaryString
): Boolean; virtual;
JScript
public function IsLocalName(
   localName : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool IsLocalName(
   XmlDictionaryString* localName
)
C++/CLI
public:
virtual bool IsLocalName(
   XmlDictionaryString^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsNamespaceUri Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsNamespaceUri Method

Overload List

Overload | Description
IsNamespaceUri(String) | (Inherited from System.Xml.XmlDictionaryReader)
IsNamespaceUri(XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsNamespaceUri(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsNamespaceUri Method : IsNamespaceUri(String) Method

namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsNamespaceUri( _
   ByVal namespaceUri As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim namespaceUri As String
Dim value As Boolean

value = instance.IsNamespaceUri(namespaceUri)
C#
public virtual bool IsNamespaceUri(
   string namespaceUri
)
Delphi
public function IsNamespaceUri(
    namespaceUri: String
): Boolean; virtual;
JScript
public function IsNamespaceUri(
   namespaceUri : String
) : boolean;
Managed Extensions for C++
public: virtual bool IsNamespaceUri(
   string* namespaceUri
)
C++/CLI
public:
virtual bool IsNamespaceUri(
   String^ namespaceUri
)

Parameters

namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsNamespaceUri(XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsNamespaceUri Method : IsNamespaceUri(XmlDictionaryString) Method

namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsNamespaceUri( _
   ByVal namespaceUri As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim namespaceUri As XmlDictionaryString
Dim value As Boolean

value = instance.IsNamespaceUri(namespaceUri)
C#
public virtual bool IsNamespaceUri(
   XmlDictionaryString namespaceUri
)
Delphi
public function IsNamespaceUri(
    namespaceUri: XmlDictionaryString
): Boolean; virtual;
JScript
public function IsNamespaceUri(
   namespaceUri : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool IsNamespaceUri(
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual bool IsNamespaceUri(
   XmlDictionaryString^ namespaceUri
)

Parameters

namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsStartArray Method

type

Syntax

Visual Basic (Declaration)
Public Overridable Function IsStartArray( _
   ByRef type As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim type As Type
Dim value As Boolean

value = instance.IsStartArray(type)
C#
public virtual bool IsStartArray(
   out Type type
)
Delphi
public function IsStartArray(
   Out  type: Type
): Boolean; virtual;
JScript
public function IsStartArray(
   type : Type
) : boolean;
Managed Extensions for C++
public: virtual bool IsStartArray(
   [PARAMFLAG::Out] Type* type
)
C++/CLI
public:
virtual bool IsStartArray(
   [Out] Type^ type
)

Parameters

type

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsStartElement(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > IsStartElement Method : IsStartElement(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IsStartElement( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As Boolean

value = instance.IsStartElement(localName, namespaceUri)
C#
public virtual bool IsStartElement(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function IsStartElement(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): Boolean; virtual;
JScript
public function IsStartElement(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool IsStartElement(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual bool IsStartElement(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
IsTextNode Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : IsTextNode Method

nodeType

Syntax

Visual Basic (Declaration)
Protected Function IsTextNode( _
   ByVal nodeType As XmlNodeType _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim nodeType As XmlNodeType
Dim value As Boolean

value = instance.IsTextNode(nodeType)
C#
protected bool IsTextNode(
   XmlNodeType nodeType
)
Delphi
protected function IsTextNode(
    nodeType: XmlNodeType
): Boolean;
JScript
protected function IsTextNode(
   nodeType : XmlNodeType
) : boolean;
Managed Extensions for C++
protected: bool IsTextNode(
   XmlNodeType nodeType
)
C++/CLI
protected:
bool IsTextNode(
   XmlNodeType nodeType
)

Parameters

nodeType

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Item Property

Overload List

Overload | Description
Item(Int32) | (Inherited from System.Xml.XmlReader)
Item(String) | (Inherited from System.Xml.XmlReader)
Item(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item(Int32) Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Item Property : Item(Int32) Property

i

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal i As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim i As Integer
Dim value As String

value = instance.Item(i)
C#
public virtual string Item(
   int i
) {get;}
Delphi
public read-only property Item(
    i: Integer
): String; virtual;
JScript
public function get Item(
   i : int
) : String
Managed Extensions for C++
public: __property virtual string* get_Item(
   int i
);
C++/CLI
public:
virtual property String^ Item {
   String^ get(int i);
}

Parameters

i

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item(String) Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Item Property : Item(String) Property

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As String

value = instance.Item(name)
C#
public virtual string Item(
   string name
) {get;}
Delphi
public read-only property Item(
    name: String
): String; virtual;
JScript
public function get Item(
   name : String
) : String
Managed Extensions for C++
public: __property virtual string* get_Item(
   string* name
);
C++/CLI
public:
virtual property String^ Item {
   String^ get(String^ name);
}

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Item(String,String) Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > Item Property : Item(String,String) Property

name
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim namespaceURI As String
Dim value As String

value = instance.Item(name, namespaceURI)
C#
public virtual string Item(
   string name,
   string namespaceURI
) {get;}
Delphi
public read-only property Item(
    name: String;
    namespaceURI: String
): String; virtual;
JScript
public function get Item(
   name : String,
   namespaceURI : String
) : String
Managed Extensions for C++
public: __property virtual string* get_Item(
   string* name,
   string* namespaceURI
);
C++/CLI
public:
virtual property String^ Item {
   String^ get(String^ name, String^ namespaceURI);
}

Parameters

name
namespaceURI

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToStartElement Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : MoveToStartElement Method

Overload List

Overload | Description
MoveToStartElement() | (Inherited from System.Xml.XmlDictionaryReader)
MoveToStartElement(String) | (Inherited from System.Xml.XmlDictionaryReader)
MoveToStartElement(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
MoveToStartElement(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToStartElement() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToStartElement Method : MoveToStartElement() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub MoveToStartElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.MoveToStartElement()
C#
public virtual void MoveToStartElement()
Delphi
public procedure MoveToStartElement(); virtual;
JScript
public function MoveToStartElement();
Managed Extensions for C++
public: virtual void MoveToStartElement();
C++/CLI
public:
virtual void MoveToStartElement();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToStartElement(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToStartElement Method : MoveToStartElement(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub MoveToStartElement( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String

instance.MoveToStartElement(name)
C#
public virtual void MoveToStartElement(
   string name
)
Delphi
public procedure MoveToStartElement(
    name: String
); virtual;
JScript
public function MoveToStartElement(
   name : String
);
Managed Extensions for C++
public: virtual void MoveToStartElement(
   string* name
)
C++/CLI
public:
virtual void MoveToStartElement(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToStartElement(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToStartElement Method : MoveToStartElement(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub MoveToStartElement( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String

instance.MoveToStartElement(localName, namespaceUri)
C#
public virtual void MoveToStartElement(
   string localName,
   string namespaceUri
)
Delphi
public procedure MoveToStartElement(
    localName: String;
    namespaceUri: String
); virtual;
JScript
public function MoveToStartElement(
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: virtual void MoveToStartElement(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual void MoveToStartElement(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
MoveToStartElement(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > MoveToStartElement Method : MoveToStartElement(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub MoveToStartElement( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.MoveToStartElement(localName, namespaceUri)
C#
public virtual void MoveToStartElement(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure MoveToStartElement(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function MoveToStartElement(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void MoveToStartElement(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void MoveToStartElement(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Name Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Name Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.Name
C#
public virtual string Name {get;}
Delphi
public read-only property Name: String; virtual;
JScript
public function get Name : String
Managed Extensions for C++
public: __property virtual string* get_Name();
C++/CLI
public:
virtual property String^ Name {
   String^ get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
QuoteChar Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : QuoteChar Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property QuoteChar As Char
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Char

value = instance.QuoteChar
C#
public virtual char QuoteChar {get;}
Delphi
public read-only property QuoteChar: Char; virtual;
JScript
public function get QuoteChar : char
Managed Extensions for C++
public: __property virtual char get_QuoteChar();
C++/CLI
public:
virtual property char QuoteChar {
   char get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadArray Method

Overload List

Overload | Description
ReadArray(String,String,Boolean[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Int16[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Int32[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Int64[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Single[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Double[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Decimal[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,DateTime[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,Guid[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(String,String,TimeSpan[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)
ReadArray(XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Boolean[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Boolean[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Boolean, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Boolean
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   bool[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Booleanarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : boolean[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   bool[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<bool>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,DateTime[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,DateTime[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Date, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Date
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   DateTime[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: DateTimearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : DateTime[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   DateTime[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<DateTime>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Decimal[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Decimal[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Decimal, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Decimal
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   decimal[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Currencyarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : decimal[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   decimal[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<decimal>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Double[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Double[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Double, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Double
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   double[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Doublearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : double[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   double[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<double>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Guid[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Guid[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Guid, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Guid
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   Guid[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Guidarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : Guid[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   Guid[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<Guid>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Int16[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Int16[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Short, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Short
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   short[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: ShortIntarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : short[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   short[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<short>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Int32[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Int32[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Integer, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Integer
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   int[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Integerarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : int[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   int[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<int>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Int64[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Int64[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Long, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Long
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   long[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Int64array of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : long[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   long[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<int64>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,Single[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,Single[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Single, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As Single
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   float[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: Singlearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : float[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   float[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<float>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(String,String,TimeSpan[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(String,String,TimeSpan[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As TimeSpan, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim array() As TimeSpan
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   string localName,
   string namespaceUri,
   TimeSpan[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: String;
    namespaceUri: String;
    array: TimeSpanarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : String,
   namespaceUri : String,
   array : TimeSpan[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   string* localName,
   string* namespaceUri,
   TimeSpan[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   String^ localName,
   String^ namespaceUri,
   array<TimeSpan>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Boolean, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Boolean
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   bool[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Booleanarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : boolean[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   bool[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<bool>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Date, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Date
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   DateTime[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: DateTimearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : DateTime[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   DateTime[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<DateTime>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Decimal, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Decimal
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   decimal[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Currencyarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : decimal[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   decimal[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<decimal>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Double, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Double
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   double[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Doublearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : double[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   double[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<double>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Guid, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Guid
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   Guid[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Guidarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : Guid[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   Guid[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<Guid>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Short, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Short
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   short[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: ShortIntarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : short[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   short[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<short>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Integer, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Integer
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   int[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Integerarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : int[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   int[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<int>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Long, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Long
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   long[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Int64array of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : long[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   long[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<int64>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Single, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Single
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   float[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Singlearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : float[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   float[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<float>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadArray(XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadArray Method : ReadArray(XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) Method

localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As TimeSpan, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As TimeSpan
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadArray(localName, namespaceUri, array, offset, count)
C#
public virtual int ReadArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   TimeSpan[] array,
   int offset,
   int count
)
Delphi
public function ReadArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: TimeSpanarray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : TimeSpan[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   TimeSpan[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<TimeSpan>^ array,
   int offset,
   int count
)

Parameters

localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadBooleanArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadBooleanArray Method

Overload List

Overload | Description
ReadBooleanArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadBooleanArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadBooleanArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadBooleanArray Method : ReadBooleanArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadBooleanArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Boolean()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Boolean

value = instance.ReadBooleanArray(localName, namespaceUri)
C#
public virtual bool[] ReadBooleanArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadBooleanArray(
    localName: String;
    namespaceUri: String
): array of Boolean; virtual;
JScript
public function ReadBooleanArray(
   localName : String,
   namespaceUri : String
) : boolean[];
Managed Extensions for C++
public: virtual bool[]* ReadBooleanArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<bool>^ ReadBooleanArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadBooleanArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadBooleanArray Method : ReadBooleanArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadBooleanArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Boolean()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Boolean

value = instance.ReadBooleanArray(localName, namespaceUri)
C#
public virtual bool[] ReadBooleanArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadBooleanArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Boolean; virtual;
JScript
public function ReadBooleanArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : boolean[];
Managed Extensions for C++
public: virtual bool[]* ReadBooleanArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<bool>^ ReadBooleanArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsBinHex(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsBinHex Method : ReadContentAsBinHex(Int32) Method

maxByteArrayContentLength

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overloads Function ReadContentAsBinHex( _
   ByVal maxByteArrayContentLength As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim maxByteArrayContentLength As Integer
Dim value() As Byte

value = instance.ReadContentAsBinHex(maxByteArrayContentLength)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected byte[] ReadContentAsBinHex(
   int maxByteArrayContentLength
)
Delphi
protected function ReadContentAsBinHex(
    maxByteArrayContentLength: Integer
): array of Byte;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function ReadContentAsBinHex(
   maxByteArrayContentLength : int
) : byte[];
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: byte[]* ReadContentAsBinHex(
   int maxByteArrayContentLength
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
array<byte>^ ReadContentAsBinHex(
   int maxByteArrayContentLength
)

Parameters

maxByteArrayContentLength

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsChars Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsChars Method

chars
offset
count

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadContentAsChars( _
   ByVal chars() As Char, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim chars() As Char
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadContentAsChars(chars, offset, count)
C#
public virtual int ReadContentAsChars(
   char[] chars,
   int offset,
   int count
)
Delphi
public function ReadContentAsChars(
    chars: Chararray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadContentAsChars(
   chars : char[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadContentAsChars(
   char[]* chars,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadContentAsChars(
   array<char>^ chars,
   int offset,
   int count
)

Parameters

chars
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsObject Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsObject Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Object

value = instance.ReadContentAsObject()
C#
public virtual object ReadContentAsObject()
Delphi
public function ReadContentAsObject(): TObject; virtual;
JScript
public function ReadContentAsObject() : Object;
Managed Extensions for C++
public: virtual Object* ReadContentAsObject();
C++/CLI
public:
virtual Object^ ReadContentAsObject();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsQualifiedName Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsQualifiedName Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overridable Sub ReadContentAsQualifiedName( _
   ByRef localName As String, _
   ByRef namespaceUri As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String

instance.ReadContentAsQualifiedName(localName, namespaceUri)
C#
public virtual void ReadContentAsQualifiedName(
   out string localName,
   out string namespaceUri
)
Delphi
public procedure ReadContentAsQualifiedName(
   Out  localName: String;
   Out  namespaceUri: String
); virtual;
JScript
public function ReadContentAsQualifiedName(
   localName : String,
   namespaceUri : String
);
Managed Extensions for C++
public: virtual void ReadContentAsQualifiedName(
   [PARAMFLAG::Out] string* localName,
   [PARAMFLAG::Out] string* namespaceUri
)
C++/CLI
public:
virtual void ReadContentAsQualifiedName(
   [Out] String^ localName,
   [Out] String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsString Method : ReadContentAsString(Int32) Method

maxStringContentLength

Syntax

Visual Basic (Declaration)
Protected Overloads Function ReadContentAsString( _
   ByVal maxStringContentLength As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim maxStringContentLength As Integer
Dim value As String

value = instance.ReadContentAsString(maxStringContentLength)
C#
protected string ReadContentAsString(
   int maxStringContentLength
)
Delphi
protected function ReadContentAsString(
    maxStringContentLength: Integer
): String;
JScript
protected function ReadContentAsString(
   maxStringContentLength : int
) : String;
Managed Extensions for C++
protected: string* ReadContentAsString(
   int maxStringContentLength
)
C++/CLI
protected:
String^ ReadContentAsString(
   int maxStringContentLength
)

Parameters

maxStringContentLength

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString(String[],Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsString Method : ReadContentAsString(String[],Int32) Method

strings
index

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadContentAsString( _
   ByVal strings() As String, _
   ByRef index As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim strings() As String
Dim index As Integer
Dim value As String

value = instance.ReadContentAsString(strings, index)
C#
public virtual string ReadContentAsString(
   string[] strings,
   out int index
)
Delphi
public function ReadContentAsString(
    strings: Stringarray of;
   Out  index: Integer
): String; virtual;
JScript
public function ReadContentAsString(
   strings : String[],
   index : int
) : String;
Managed Extensions for C++
public: virtual string* ReadContentAsString(
   string*[]* strings,
   [PARAMFLAG::Out] int index
)
C++/CLI
public:
virtual String^ ReadContentAsString(
   array<String^>^ strings,
   [Out] int index
)

Parameters

strings
index

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsString(XmlDictionaryString[],Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadContentAsString Method : ReadContentAsString(XmlDictionaryString[],Int32) Method

strings
index

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadContentAsString( _
   ByVal strings() As XmlDictionaryString, _
   ByRef index As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim strings() As XmlDictionaryString
Dim index As Integer
Dim value As String

value = instance.ReadContentAsString(strings, index)
C#
public virtual string ReadContentAsString(
   XmlDictionaryString[] strings,
   out int index
)
Delphi
public function ReadContentAsString(
    strings: XmlDictionaryStringarray of;
   Out  index: Integer
): String; virtual;
JScript
public function ReadContentAsString(
   strings : XmlDictionaryString[],
   index : int
) : String;
Managed Extensions for C++
public: virtual string* ReadContentAsString(
   XmlDictionaryString*[]* strings,
   [PARAMFLAG::Out] int index
)
C++/CLI
public:
virtual String^ ReadContentAsString(
   array<XmlDictionaryString^>^ strings,
   [Out] int index
)

Parameters

strings
index

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsTimeSpan Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsTimeSpan Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadContentAsTimeSpan() As TimeSpan
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As TimeSpan

value = instance.ReadContentAsTimeSpan()
C#
public virtual TimeSpan ReadContentAsTimeSpan()
Delphi
public function ReadContentAsTimeSpan(): TimeSpan; virtual;
JScript
public function ReadContentAsTimeSpan() : TimeSpan;
Managed Extensions for C++
public: virtual TimeSpan ReadContentAsTimeSpan();
C++/CLI
public:
virtual TimeSpan ReadContentAsTimeSpan();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadContentAsUniqueId Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadContentAsUniqueId Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadContentAsUniqueId() As UniqueId
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As UniqueId

value = instance.ReadContentAsUniqueId()
C#
public virtual UniqueId ReadContentAsUniqueId()
Delphi
public function ReadContentAsUniqueId(): UniqueId; virtual;
JScript
public function ReadContentAsUniqueId() : UniqueId;
Managed Extensions for C++
public: virtual UniqueId* ReadContentAsUniqueId();
C++/CLI
public:
virtual UniqueId^ ReadContentAsUniqueId();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDateTimeArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadDateTimeArray Method

Overload List

Overload | Description
ReadDateTimeArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadDateTimeArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDateTimeArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDateTimeArray Method : ReadDateTimeArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDateTimeArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Date()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Date

value = instance.ReadDateTimeArray(localName, namespaceUri)
C#
public virtual DateTime[] ReadDateTimeArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadDateTimeArray(
    localName: String;
    namespaceUri: String
): array of DateTime; virtual;
JScript
public function ReadDateTimeArray(
   localName : String,
   namespaceUri : String
) : DateTime[];
Managed Extensions for C++
public: virtual DateTime[]* ReadDateTimeArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<DateTime>^ ReadDateTimeArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDateTimeArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDateTimeArray Method : ReadDateTimeArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDateTimeArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Date()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Date

value = instance.ReadDateTimeArray(localName, namespaceUri)
C#
public virtual DateTime[] ReadDateTimeArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadDateTimeArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of DateTime; virtual;
JScript
public function ReadDateTimeArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : DateTime[];
Managed Extensions for C++
public: virtual DateTime[]* ReadDateTimeArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<DateTime>^ ReadDateTimeArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDecimalArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadDecimalArray Method

Overload List

Overload | Description
ReadDecimalArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadDecimalArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDecimalArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDecimalArray Method : ReadDecimalArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDecimalArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Decimal()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Decimal

value = instance.ReadDecimalArray(localName, namespaceUri)
C#
public virtual decimal[] ReadDecimalArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadDecimalArray(
    localName: String;
    namespaceUri: String
): array of Currency; virtual;
JScript
public function ReadDecimalArray(
   localName : String,
   namespaceUri : String
) : decimal[];
Managed Extensions for C++
public: virtual decimal[]* ReadDecimalArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<decimal>^ ReadDecimalArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDecimalArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDecimalArray Method : ReadDecimalArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDecimalArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Decimal()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Decimal

value = instance.ReadDecimalArray(localName, namespaceUri)
C#
public virtual decimal[] ReadDecimalArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadDecimalArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Currency; virtual;
JScript
public function ReadDecimalArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : decimal[];
Managed Extensions for C++
public: virtual decimal[]* ReadDecimalArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<decimal>^ ReadDecimalArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDoubleArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadDoubleArray Method

Overload List

Overload | Description
ReadDoubleArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadDoubleArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDoubleArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDoubleArray Method : ReadDoubleArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDoubleArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Double()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Double

value = instance.ReadDoubleArray(localName, namespaceUri)
C#
public virtual double[] ReadDoubleArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadDoubleArray(
    localName: String;
    namespaceUri: String
): array of Double; virtual;
JScript
public function ReadDoubleArray(
   localName : String,
   namespaceUri : String
) : double[];
Managed Extensions for C++
public: virtual double[]* ReadDoubleArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<double>^ ReadDoubleArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadDoubleArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadDoubleArray Method : ReadDoubleArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadDoubleArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Double()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Double

value = instance.ReadDoubleArray(localName, namespaceUri)
C#
public virtual double[] ReadDoubleArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadDoubleArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Double; virtual;
JScript
public function ReadDoubleArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : double[];
Managed Extensions for C++
public: virtual double[]* ReadDoubleArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<double>^ ReadDoubleArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadElementContentAsObject Method

Overload List

Overload | Description
ReadElementContentAsObject() | (Inherited from System.Xml.XmlReader)
ReadElementContentAsObject(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadElementContentAsObject() As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Object

value = instance.ReadElementContentAsObject()
C#
public virtual object ReadElementContentAsObject()
Delphi
public function ReadElementContentAsObject(): TObject; virtual;
JScript
public function ReadElementContentAsObject() : Object;
Managed Extensions for C++
public: virtual Object* ReadElementContentAsObject();
C++/CLI
public:
virtual Object^ ReadElementContentAsObject();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadElementContentAsObject(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadElementContentAsObject Method : ReadElementContentAsObject(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadElementContentAsObject( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Object

value = instance.ReadElementContentAsObject(localName, namespaceURI)
C#
public virtual object ReadElementContentAsObject(
   string localName,
   string namespaceURI
)
Delphi
public function ReadElementContentAsObject(
    localName: String;
    namespaceURI: String
): TObject; virtual;
JScript
public function ReadElementContentAsObject(
   localName : String,
   namespaceURI : String
) : Object;
Managed Extensions for C++
public: virtual Object* ReadElementContentAsObject(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
virtual Object^ ReadElementContentAsObject(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadFullStartElement() Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadFullStartElement Method : ReadFullStartElement() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub ReadFullStartElement()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.ReadFullStartElement()
C#
public virtual void ReadFullStartElement()
Delphi
public procedure ReadFullStartElement(); virtual;
JScript
public function ReadFullStartElement();
Managed Extensions for C++
public: virtual void ReadFullStartElement();
C++/CLI
public:
virtual void ReadFullStartElement();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadFullStartElement(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadFullStartElement Method : ReadFullStartElement(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub ReadFullStartElement( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.ReadFullStartElement(localName, namespaceUri)
C#
public virtual void ReadFullStartElement(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure ReadFullStartElement(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function ReadFullStartElement(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void ReadFullStartElement(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void ReadFullStartElement(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadGuidArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadGuidArray Method

Overload List

Overload | Description
ReadGuidArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadGuidArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadGuidArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadGuidArray Method : ReadGuidArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadGuidArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Guid()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Guid

value = instance.ReadGuidArray(localName, namespaceUri)
C#
public virtual Guid[] ReadGuidArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadGuidArray(
    localName: String;
    namespaceUri: String
): array of Guid; virtual;
JScript
public function ReadGuidArray(
   localName : String,
   namespaceUri : String
) : Guid[];
Managed Extensions for C++
public: virtual Guid[]* ReadGuidArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<Guid>^ ReadGuidArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadGuidArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadGuidArray Method : ReadGuidArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadGuidArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Guid()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Guid

value = instance.ReadGuidArray(localName, namespaceUri)
C#
public virtual Guid[] ReadGuidArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadGuidArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Guid; virtual;
JScript
public function ReadGuidArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : Guid[];
Managed Extensions for C++
public: virtual Guid[]* ReadGuidArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<Guid>^ ReadGuidArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInnerXml Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadInnerXml Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadInnerXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadInnerXml()
C#
public virtual string ReadInnerXml()
Delphi
public function ReadInnerXml(): String; virtual;
JScript
public function ReadInnerXml() : String;
Managed Extensions for C++
public: virtual string* ReadInnerXml();
C++/CLI
public:
virtual String^ ReadInnerXml();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt16Array Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadInt16Array Method

Overload List

Overload | Description
ReadInt16Array(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadInt16Array(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt16Array(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt16Array Method : ReadInt16Array(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt16Array( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Short()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Short

value = instance.ReadInt16Array(localName, namespaceUri)
C#
public virtual short[] ReadInt16Array(
   string localName,
   string namespaceUri
)
Delphi
public function ReadInt16Array(
    localName: String;
    namespaceUri: String
): array of ShortInt; virtual;
JScript
public function ReadInt16Array(
   localName : String,
   namespaceUri : String
) : short[];
Managed Extensions for C++
public: virtual short[]* ReadInt16Array(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<short>^ ReadInt16Array(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt16Array(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt16Array Method : ReadInt16Array(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt16Array( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Short()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Short

value = instance.ReadInt16Array(localName, namespaceUri)
C#
public virtual short[] ReadInt16Array(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadInt16Array(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of ShortInt; virtual;
JScript
public function ReadInt16Array(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : short[];
Managed Extensions for C++
public: virtual short[]* ReadInt16Array(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<short>^ ReadInt16Array(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt32Array Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadInt32Array Method

Overload List

Overload | Description
ReadInt32Array(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadInt32Array(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt32Array(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt32Array Method : ReadInt32Array(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt32Array( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Integer

value = instance.ReadInt32Array(localName, namespaceUri)
C#
public virtual int[] ReadInt32Array(
   string localName,
   string namespaceUri
)
Delphi
public function ReadInt32Array(
    localName: String;
    namespaceUri: String
): array of Integer; virtual;
JScript
public function ReadInt32Array(
   localName : String,
   namespaceUri : String
) : int[];
Managed Extensions for C++
public: virtual int[]* ReadInt32Array(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<int>^ ReadInt32Array(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt32Array(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt32Array Method : ReadInt32Array(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt32Array( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Integer()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Integer

value = instance.ReadInt32Array(localName, namespaceUri)
C#
public virtual int[] ReadInt32Array(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadInt32Array(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Integer; virtual;
JScript
public function ReadInt32Array(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : int[];
Managed Extensions for C++
public: virtual int[]* ReadInt32Array(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<int>^ ReadInt32Array(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt64Array Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadInt64Array Method

Overload List

Overload | Description
ReadInt64Array(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadInt64Array(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt64Array(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt64Array Method : ReadInt64Array(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt64Array( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Long()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Long

value = instance.ReadInt64Array(localName, namespaceUri)
C#
public virtual long[] ReadInt64Array(
   string localName,
   string namespaceUri
)
Delphi
public function ReadInt64Array(
    localName: String;
    namespaceUri: String
): array of Int64; virtual;
JScript
public function ReadInt64Array(
   localName : String,
   namespaceUri : String
) : long[];
Managed Extensions for C++
public: virtual long[]* ReadInt64Array(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<int64>^ ReadInt64Array(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadInt64Array(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadInt64Array Method : ReadInt64Array(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadInt64Array( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Long()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Long

value = instance.ReadInt64Array(localName, namespaceUri)
C#
public virtual long[] ReadInt64Array(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadInt64Array(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Int64; virtual;
JScript
public function ReadInt64Array(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : long[];
Managed Extensions for C++
public: virtual long[]* ReadInt64Array(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<int64>^ ReadInt64Array(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadOuterXml Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadOuterXml Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadOuterXml() As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.ReadOuterXml()
C#
public virtual string ReadOuterXml()
Delphi
public function ReadOuterXml(): String; virtual;
JScript
public function ReadOuterXml() : String;
Managed Extensions for C++
public: virtual string* ReadOuterXml();
C++/CLI
public:
virtual String^ ReadOuterXml();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadSingleArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadSingleArray Method

Overload List

Overload | Description
ReadSingleArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadSingleArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadSingleArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadSingleArray Method : ReadSingleArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadSingleArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As Single()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As Single

value = instance.ReadSingleArray(localName, namespaceUri)
C#
public virtual float[] ReadSingleArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadSingleArray(
    localName: String;
    namespaceUri: String
): array of Single; virtual;
JScript
public function ReadSingleArray(
   localName : String,
   namespaceUri : String
) : float[];
Managed Extensions for C++
public: virtual float[]* ReadSingleArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<float>^ ReadSingleArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadSingleArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadSingleArray Method : ReadSingleArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadSingleArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As Single()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As Single

value = instance.ReadSingleArray(localName, namespaceUri)
C#
public virtual float[] ReadSingleArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadSingleArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of Single; virtual;
JScript
public function ReadSingleArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : float[];
Managed Extensions for C++
public: virtual float[]* ReadSingleArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<float>^ ReadSingleArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadStartElement(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadStartElement Method : ReadStartElement(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub ReadStartElement( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.ReadStartElement(localName, namespaceUri)
C#
public virtual void ReadStartElement(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure ReadStartElement(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function ReadStartElement(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void ReadStartElement(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void ReadStartElement(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadString(Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadString Method : ReadString(Int32) Method

maxStringContentLength

Syntax

Visual Basic (Declaration)
Protected Overloads Function ReadString( _
   ByVal maxStringContentLength As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim maxStringContentLength As Integer
Dim value As String

value = instance.ReadString(maxStringContentLength)
C#
protected string ReadString(
   int maxStringContentLength
)
Delphi
protected function ReadString(
    maxStringContentLength: Integer
): String;
JScript
protected function ReadString(
   maxStringContentLength : int
) : String;
Managed Extensions for C++
protected: string* ReadString(
   int maxStringContentLength
)
C++/CLI
protected:
String^ ReadString(
   int maxStringContentLength
)

Parameters

maxStringContentLength

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadSubtree Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadSubtree Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadSubtree() As XmlReader
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlReader

value = instance.ReadSubtree()
C#
public virtual XmlReader ReadSubtree()
Delphi
public function ReadSubtree(): XmlReader; virtual;
JScript
public function ReadSubtree() : XmlReader;
Managed Extensions for C++
public: virtual XmlReader* ReadSubtree();
C++/CLI
public:
virtual XmlReader^ ReadSubtree();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeSpanArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadTimeSpanArray Method

Overload List

Overload | Description
ReadTimeSpanArray(String,String) | (Inherited from System.Xml.XmlDictionaryReader)
ReadTimeSpanArray(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeSpanArray(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadTimeSpanArray Method : ReadTimeSpanArray(String,String) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadTimeSpanArray( _
   ByVal localName As String, _
   ByVal namespaceUri As String _
) As TimeSpan()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceUri As String
Dim value() As TimeSpan

value = instance.ReadTimeSpanArray(localName, namespaceUri)
C#
public virtual TimeSpan[] ReadTimeSpanArray(
   string localName,
   string namespaceUri
)
Delphi
public function ReadTimeSpanArray(
    localName: String;
    namespaceUri: String
): array of TimeSpan; virtual;
JScript
public function ReadTimeSpanArray(
   localName : String,
   namespaceUri : String
) : TimeSpan[];
Managed Extensions for C++
public: virtual TimeSpan[]* ReadTimeSpanArray(
   string* localName,
   string* namespaceUri
)
C++/CLI
public:
virtual array<TimeSpan>^ ReadTimeSpanArray(
   String^ localName,
   String^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadTimeSpanArray(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadTimeSpanArray Method : ReadTimeSpanArray(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadTimeSpanArray( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
) As TimeSpan()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value() As TimeSpan

value = instance.ReadTimeSpanArray(localName, namespaceUri)
C#
public virtual TimeSpan[] ReadTimeSpanArray(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public function ReadTimeSpanArray(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
): array of TimeSpan; virtual;
JScript
public function ReadTimeSpanArray(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
) : TimeSpan[];
Managed Extensions for C++
public: virtual TimeSpan[]* ReadTimeSpanArray(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual array<TimeSpan>^ ReadTimeSpanArray(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadToDescendant Method

Overload List

Overload | Description
ReadToDescendant(String) | (Inherited from System.Xml.XmlReader)
ReadToDescendant(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToDescendant Method : ReadToDescendant(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToDescendant( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As Boolean

value = instance.ReadToDescendant(name)
C#
public virtual bool ReadToDescendant(
   string name
)
Delphi
public function ReadToDescendant(
    name: String
): Boolean; virtual;
JScript
public function ReadToDescendant(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToDescendant(
   string* name
)
C++/CLI
public:
virtual bool ReadToDescendant(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToDescendant(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToDescendant Method : ReadToDescendant(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToDescendant( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToDescendant(localName, namespaceURI)
C#
public virtual bool ReadToDescendant(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToDescendant(
    localName: String;
    namespaceURI: String
): Boolean; virtual;
JScript
public function ReadToDescendant(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToDescendant(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
virtual bool ReadToDescendant(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadToFollowing Method

Overload List

Overload | Description
ReadToFollowing(String) | (Inherited from System.Xml.XmlReader)
ReadToFollowing(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToFollowing Method : ReadToFollowing(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToFollowing( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As Boolean

value = instance.ReadToFollowing(name)
C#
public virtual bool ReadToFollowing(
   string name
)
Delphi
public function ReadToFollowing(
    name: String
): Boolean; virtual;
JScript
public function ReadToFollowing(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToFollowing(
   string* name
)
C++/CLI
public:
virtual bool ReadToFollowing(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToFollowing(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToFollowing Method : ReadToFollowing(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToFollowing( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToFollowing(localName, namespaceURI)
C#
public virtual bool ReadToFollowing(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToFollowing(
    localName: String;
    namespaceURI: String
): Boolean; virtual;
JScript
public function ReadToFollowing(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToFollowing(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
virtual bool ReadToFollowing(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadToNextSibling Method

Overload List

Overload | Description
ReadToNextSibling(String) | (Inherited from System.Xml.XmlReader)
ReadToNextSibling(String,String) | (Inherited from System.Xml.XmlReader)

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToNextSibling Method : ReadToNextSibling(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToNextSibling( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim name As String
Dim value As Boolean

value = instance.ReadToNextSibling(name)
C#
public virtual bool ReadToNextSibling(
   string name
)
Delphi
public function ReadToNextSibling(
    name: String
): Boolean; virtual;
JScript
public function ReadToNextSibling(
   name : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToNextSibling(
   string* name
)
C++/CLI
public:
virtual bool ReadToNextSibling(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadToNextSibling(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class > ReadToNextSibling Method : ReadToNextSibling(String,String) Method

localName
namespaceURI

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ReadToNextSibling( _
   ByVal localName As String, _
   ByVal namespaceURI As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As String
Dim namespaceURI As String
Dim value As Boolean

value = instance.ReadToNextSibling(localName, namespaceURI)
C#
public virtual bool ReadToNextSibling(
   string localName,
   string namespaceURI
)
Delphi
public function ReadToNextSibling(
    localName: String;
    namespaceURI: String
): Boolean; virtual;
JScript
public function ReadToNextSibling(
   localName : String,
   namespaceURI : String
) : boolean;
Managed Extensions for C++
public: virtual bool ReadToNextSibling(
   string* localName,
   string* namespaceURI
)
C++/CLI
public:
virtual bool ReadToNextSibling(
   String^ localName,
   String^ namespaceURI
)

Parameters

localName
namespaceURI

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadValueAsBase64 Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadValueAsBase64 Method

buffer
offset
count

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadValueAsBase64( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadValueAsBase64(buffer, offset, count)
C#
public virtual int ReadValueAsBase64(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function ReadValueAsBase64(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadValueAsBase64(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadValueAsBase64(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
virtual int ReadValueAsBase64(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ReadValueChunk Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ReadValueChunk Method

buffer
index
count

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadValueChunk( _
   ByVal buffer() As Char, _
   ByVal index As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim buffer() As Char
Dim index As Integer
Dim count As Integer
Dim value As Integer

value = instance.ReadValueChunk(buffer, index, count)
C#
public virtual int ReadValueChunk(
   char[] buffer,
   int index,
   int count
)
Delphi
public function ReadValueChunk(
    buffer: Chararray of;
    index: Integer;
    count: Integer
): Integer; virtual;
JScript
public function ReadValueChunk(
   buffer : char[],
   index : int,
   count : int
) : int;
Managed Extensions for C++
public: virtual int ReadValueChunk(
   char[]* buffer,
   int index,
   int count
)
C++/CLI
public:
virtual int ReadValueChunk(
   array<char>^ buffer,
   int index,
   int count
)

Parameters

buffer
index
count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
SchemaInfo Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : SchemaInfo Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SchemaInfo As IXmlSchemaInfo
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As IXmlSchemaInfo

value = instance.SchemaInfo
C#
public virtual IXmlSchemaInfo SchemaInfo {get;}
Delphi
public read-only property SchemaInfo: IXmlSchemaInfo; virtual;
JScript
public function get SchemaInfo : IXmlSchemaInfo
Managed Extensions for C++
public: __property virtual IXmlSchemaInfo* get_SchemaInfo();
C++/CLI
public:
virtual property IXmlSchemaInfo^ SchemaInfo {
   IXmlSchemaInfo^ get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Skip Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : Skip Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Skip()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader

instance.Skip()
C#
public virtual void Skip()
Delphi
public procedure Skip(); virtual;
JScript
public function Skip();
Managed Extensions for C++
public: virtual void Skip();
C++/CLI
public:
virtual void Skip();

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StartCanonicalization Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : StartCanonicalization Method

stream
includeComments
inclusivePrefixes

Syntax

Visual Basic (Declaration)
Public Overridable Sub StartCanonicalization( _
   ByVal stream As Stream, _
   ByVal includeComments As Boolean, _
   ByVal inclusivePrefixes() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim stream As Stream
Dim includeComments As Boolean
Dim inclusivePrefixes() As String

instance.StartCanonicalization(stream, includeComments, inclusivePrefixes)
C#
public virtual void StartCanonicalization(
   Stream stream,
   bool includeComments,
   string[] inclusivePrefixes
)
Delphi
public procedure StartCanonicalization(
    stream: Stream;
    includeComments: Boolean;
    inclusivePrefixes: Stringarray of
); virtual;
JScript
public function StartCanonicalization(
   stream : Stream,
   includeComments : boolean,
   inclusivePrefixes : String[]
);
Managed Extensions for C++
public: virtual void StartCanonicalization(
   Stream* stream,
   bool includeComments,
   string*[]* inclusivePrefixes
)
C++/CLI
public:
virtual void StartCanonicalization(
   Stream^ stream,
   bool includeComments,
   array<String^>^ inclusivePrefixes
)

Parameters

stream
includeComments
inclusivePrefixes

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryGetArrayLength Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : TryGetArrayLength Method

count

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetArrayLength( _
   ByRef count As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim count As Integer
Dim value As Boolean

value = instance.TryGetArrayLength(count)
C#
public virtual bool TryGetArrayLength(
   out int count
)
Delphi
public function TryGetArrayLength(
   Out  count: Integer
): Boolean; virtual;
JScript
public function TryGetArrayLength(
   count : int
) : boolean;
Managed Extensions for C++
public: virtual bool TryGetArrayLength(
   [PARAMFLAG::Out] int count
)
C++/CLI
public:
virtual bool TryGetArrayLength(
   [Out] int count
)

Parameters

count

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryGetBase64ContentLength Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : TryGetBase64ContentLength Method

length

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetBase64ContentLength( _
   ByRef length As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim length As Integer
Dim value As Boolean

value = instance.TryGetBase64ContentLength(length)
C#
public virtual bool TryGetBase64ContentLength(
   out int length
)
Delphi
public function TryGetBase64ContentLength(
   Out  length: Integer
): Boolean; virtual;
JScript
public function TryGetBase64ContentLength(
   length : int
) : boolean;
Managed Extensions for C++
public: virtual bool TryGetBase64ContentLength(
   [PARAMFLAG::Out] int length
)
C++/CLI
public:
virtual bool TryGetBase64ContentLength(
   [Out] int length
)

Parameters

length

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryGetLocalNameAsDictionaryString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : TryGetLocalNameAsDictionaryString Method

localName

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetLocalNameAsDictionaryString( _
   ByRef localName As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim localName As XmlDictionaryString
Dim value As Boolean

value = instance.TryGetLocalNameAsDictionaryString(localName)
C#
public virtual bool TryGetLocalNameAsDictionaryString(
   out XmlDictionaryString localName
)
Delphi
public function TryGetLocalNameAsDictionaryString(
   Out  localName: XmlDictionaryString
): Boolean; virtual;
JScript
public function TryGetLocalNameAsDictionaryString(
   localName : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool TryGetLocalNameAsDictionaryString(
   [PARAMFLAG::Out] XmlDictionaryString* localName
)
C++/CLI
public:
virtual bool TryGetLocalNameAsDictionaryString(
   [Out] XmlDictionaryString^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryGetNamespaceUriAsDictionaryString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : TryGetNamespaceUriAsDictionaryString Method

namespaceUri

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetNamespaceUriAsDictionaryString( _
   ByRef namespaceUri As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim namespaceUri As XmlDictionaryString
Dim value As Boolean

value = instance.TryGetNamespaceUriAsDictionaryString(namespaceUri)
C#
public virtual bool TryGetNamespaceUriAsDictionaryString(
   out XmlDictionaryString namespaceUri
)
Delphi
public function TryGetNamespaceUriAsDictionaryString(
   Out  namespaceUri: XmlDictionaryString
): Boolean; virtual;
JScript
public function TryGetNamespaceUriAsDictionaryString(
   namespaceUri : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool TryGetNamespaceUriAsDictionaryString(
   [PARAMFLAG::Out] XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual bool TryGetNamespaceUriAsDictionaryString(
   [Out] XmlDictionaryString^ namespaceUri
)

Parameters

namespaceUri

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
TryGetValueAsDictionaryString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : TryGetValueAsDictionaryString Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetValueAsDictionaryString( _
   ByRef value As XmlDictionaryString _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlDictionaryString
Dim value As Boolean

value = instance.TryGetValueAsDictionaryString(value)
C#
public virtual bool TryGetValueAsDictionaryString(
   out XmlDictionaryString value
)
Delphi
public function TryGetValueAsDictionaryString(
   Out  value: XmlDictionaryString
): Boolean; virtual;
JScript
public function TryGetValueAsDictionaryString(
   value : XmlDictionaryString
) : boolean;
Managed Extensions for C++
public: virtual bool TryGetValueAsDictionaryString(
   [PARAMFLAG::Out] XmlDictionaryString* value
)
C++/CLI
public:
virtual bool TryGetValueAsDictionaryString(
   [Out] XmlDictionaryString^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
ValueType Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As Type

value = instance.ValueType
C#
public virtual Type ValueType {get;}
Delphi
public read-only property ValueType: Type; virtual;
JScript
public function get ValueType : Type
Managed Extensions for C++
public: __property virtual Type* get_ValueType();
C++/CLI
public:
virtual property Type^ ValueType {
   Type^ get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlLang Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : XmlLang Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property XmlLang As String
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As String

value = instance.XmlLang
C#
public virtual string XmlLang {get;}
Delphi
public read-only property XmlLang: String; virtual;
JScript
public function get XmlLang : String
Managed Extensions for C++
public: __property virtual string* get_XmlLang();
C++/CLI
public:
virtual property String^ XmlLang {
   String^ get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
XmlSpace Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryReader Class : XmlSpace Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property XmlSpace As XmlSpace
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryReader
Dim value As XmlSpace

value = instance.XmlSpace
C#
public virtual XmlSpace XmlSpace {get;}
Delphi
public read-only property XmlSpace: XmlSpace; virtual;
JScript
public function get XmlSpace : XmlSpace
Managed Extensions for C++
public: __property virtual XmlSpace get_XmlSpace();
C++/CLI
public:
virtual property XmlSpace XmlSpace {
   XmlSpace get();
}

See Also

Reference

XmlFastInfosetDictionaryReader Class
XmlFastInfosetDictionaryReader Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
CanCanonicalize Property
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : CanCanonicalize Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanCanonicalize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Boolean

value = instance.CanCanonicalize
C#
public virtual bool CanCanonicalize {get;}
Delphi
public read-only property CanCanonicalize: Boolean; virtual;
JScript
public function get CanCanonicalize : boolean
Managed Extensions for C++
public: __property virtual bool get_CanCanonicalize();
C++/CLI
public:
virtual property bool CanCanonicalize {
   bool get();
}

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
Dispose Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : Dispose Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
EndCanonicalization Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : EndCanonicalization Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndCanonicalization()
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter

instance.EndCanonicalization()
C#
public virtual void EndCanonicalization()
Delphi
public procedure EndCanonicalization(); virtual;
JScript
public function EndCanonicalization();
Managed Extensions for C++
public: virtual void EndCanonicalization();
C++/CLI
public:
virtual void EndCanonicalization();

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
StartCanonicalization Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : StartCanonicalization Method

stream
includeComments
inclusivePrefixes

Syntax

Visual Basic (Declaration)
Public Overridable Sub StartCanonicalization( _
   ByVal stream As Stream, _
   ByVal includeComments As Boolean, _
   ByVal inclusivePrefixes() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim stream As Stream
Dim includeComments As Boolean
Dim inclusivePrefixes() As String

instance.StartCanonicalization(stream, includeComments, inclusivePrefixes)
C#
public virtual void StartCanonicalization(
   Stream stream,
   bool includeComments,
   string[] inclusivePrefixes
)
Delphi
public procedure StartCanonicalization(
    stream: Stream;
    includeComments: Boolean;
    inclusivePrefixes: Stringarray of
); virtual;
JScript
public function StartCanonicalization(
   stream : Stream,
   includeComments : boolean,
   inclusivePrefixes : String[]
);
Managed Extensions for C++
public: virtual void StartCanonicalization(
   Stream* stream,
   bool includeComments,
   string*[]* inclusivePrefixes
)
C++/CLI
public:
virtual void StartCanonicalization(
   Stream^ stream,
   bool includeComments,
   array<String^>^ inclusivePrefixes
)

Parameters

stream
includeComments
inclusivePrefixes

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteArray Method

Overload List

Overload | Description
WriteArray(String,String,String,Boolean[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Int16[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Int32[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Int64[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Single[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Double[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Decimal[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,DateTime[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,Guid[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,String,String,TimeSpan[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteArray(String,XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) | (Inherited from System.Xml.XmlDictionaryWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Boolean[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Boolean[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Boolean, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Boolean
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   bool[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Booleanarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : boolean[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   bool[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<bool>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,DateTime[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,DateTime[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Date, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Date
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   DateTime[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: DateTimearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : DateTime[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   DateTime[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<DateTime>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Decimal[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Decimal[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Decimal, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Decimal
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   decimal[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Currencyarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : decimal[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   decimal[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<decimal>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Double[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Double[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Double, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Double
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   double[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Doublearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : double[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   double[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<double>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Guid[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Guid[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Guid, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Guid
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   Guid[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Guidarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : Guid[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   Guid[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<Guid>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Int16[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Int16[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Short, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Short
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   short[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: ShortIntarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : short[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   short[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<short>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Int32[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Int32[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Integer, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Integer
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   int[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Integerarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : int[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   int[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<int>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Int64[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Int64[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Long, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Long
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   long[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Int64array of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : long[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   long[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<int64>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,Single[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,Single[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As Single, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As Single
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   float[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: Singlearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : float[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   float[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<float>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,String,String,TimeSpan[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,String,String,TimeSpan[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal namespaceUri As String, _
   ByVal array() As TimeSpan, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim namespaceUri As String
Dim array() As TimeSpan
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   string localName,
   string namespaceUri,
   TimeSpan[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: String;
    namespaceUri: String;
    array: TimeSpanarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : String,
   namespaceUri : String,
   array : TimeSpan[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   string* localName,
   string* namespaceUri,
   TimeSpan[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   String^ localName,
   String^ namespaceUri,
   array<TimeSpan>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Boolean[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Boolean, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Boolean
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   bool[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Booleanarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : boolean[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   bool[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<bool>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,DateTime[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Date, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Date
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   DateTime[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: DateTimearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : DateTime[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   DateTime[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<DateTime>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Decimal[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Decimal, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Decimal
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   decimal[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Currencyarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : decimal[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   decimal[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<decimal>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Double[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Double, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Double
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   double[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Doublearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : double[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   double[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<double>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Guid[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Guid, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Guid
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   Guid[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Guidarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : Guid[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   Guid[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<Guid>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int16[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Short, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Short
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   short[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: ShortIntarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : short[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   short[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<short>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int32[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Integer, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Integer
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   int[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Integerarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : int[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   int[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<int>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Int64[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Long, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Long
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   long[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Int64array of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : long[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   long[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<int64>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,Single[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As Single, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As Single
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   float[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: Singlearray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : float[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   float[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<float>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteArray(String,XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteArray Method : WriteArray(String,XmlDictionaryString,XmlDictionaryString,TimeSpan[],Int32,Int32) Method

prefix
localName
namespaceUri
array
offset
count

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteArray( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal array() As TimeSpan, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim array() As TimeSpan
Dim offset As Integer
Dim count As Integer

instance.WriteArray(prefix, localName, namespaceUri, array, offset, count)
C#
public virtual void WriteArray(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   TimeSpan[] array,
   int offset,
   int count
)
Delphi
public procedure WriteArray(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    array: TimeSpanarray of;
    offset: Integer;
    count: Integer
); virtual;
JScript
public function WriteArray(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   array : TimeSpan[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: virtual void WriteArray(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   TimeSpan[]* array,
   int offset,
   int count
)
C++/CLI
public:
virtual void WriteArray(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   array<TimeSpan>^ array,
   int offset,
   int count
)

Parameters

prefix
localName
namespaceUri
array
offset
count

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteAttributeString Method

Overload List

Overload | Description
WriteAttributeString(String,XmlDictionaryString,XmlDictionaryString,String) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteAttributeString(XmlDictionaryString,XmlDictionaryString,String) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteAttributeString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteAttributeString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteAttributeString Method : WriteAttributeString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim value As String

instance.WriteAttributeString(localName, value)
C#
public void WriteAttributeString(
   string localName,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    value: String
);
JScript
public function WriteAttributeString(
   localName : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* localName,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Sub WriteAttributeString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(localName, ns, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void WriteAttributeString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: String;
    ns: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function WriteAttributeString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void WriteAttributeString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void WriteAttributeString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteAttributeString Method : WriteAttributeString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteAttributeString(prefix, localName, ns, value)
C#
public void WriteAttributeString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteAttributeString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteAttributeString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(String,XmlDictionaryString,XmlDictionaryString,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteAttributeString Method : WriteAttributeString(String,XmlDictionaryString,XmlDictionaryString,String) Method

prefix
localName
namespaceUri
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteAttributeString( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As String

instance.WriteAttributeString(prefix, localName, namespaceUri, value)
C#
public void WriteAttributeString(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   string value
)
Delphi
public procedure WriteAttributeString(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    value: String
);
JScript
public function WriteAttributeString(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   value : String
);
Managed Extensions for C++
public: void WriteAttributeString(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   string* value
)
C++/CLI
public:
void WriteAttributeString(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   String^ value
)

Parameters

prefix
localName
namespaceUri
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteAttributeString(XmlDictionaryString,XmlDictionaryString,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteAttributeString Method : WriteAttributeString(XmlDictionaryString,XmlDictionaryString,String) Method

localName
namespaceUri
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteAttributeString( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As String

instance.WriteAttributeString(localName, namespaceUri, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteAttributeString(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   string value
)
Delphi
public procedure WriteAttributeString(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteAttributeString(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteAttributeString(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteAttributeString(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   String^ value
)

Parameters

localName
namespaceUri
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteElementString Method

Overload List

Overload | Description
WriteElementString(XmlDictionaryString,XmlDictionaryString,String) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteElementString(String,XmlDictionaryString,XmlDictionaryString,String) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteElementString(String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String) | (Inherited from System.Xml.XmlWriter)
WriteElementString(String,String,String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteElementString Method : WriteElementString(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim value As String

instance.WriteElementString(localName, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteElementString(
   string localName,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteElementString(
   localName : String,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteElementString(
   string* localName,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteElementString(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteElementString Method : WriteElementString(String,String,String) Method

localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(localName, ns, value)
C#
public void WriteElementString(
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

localName
ns
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,String,String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteElementString Method : WriteElementString(String,String,String,String) Method

prefix
localName
ns
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal prefix As String, _
   ByVal localName As String, _
   ByVal ns As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As String
Dim ns As String
Dim value As String

instance.WriteElementString(prefix, localName, ns, value)
C#
public void WriteElementString(
   string prefix,
   string localName,
   string ns,
   string value
)
Delphi
public procedure WriteElementString(
    prefix: String;
    localName: String;
    ns: String;
    value: String
);
JScript
public function WriteElementString(
   prefix : String,
   localName : String,
   ns : String,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* prefix,
   string* localName,
   string* ns,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ prefix,
   String^ localName,
   String^ ns,
   String^ value
)

Parameters

prefix
localName
ns
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(String,XmlDictionaryString,XmlDictionaryString,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteElementString Method : WriteElementString(String,XmlDictionaryString,XmlDictionaryString,String) Method

prefix
localName
namespaceUri
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub WriteElementString( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As String

instance.WriteElementString(prefix, localName, namespaceUri, value)
C#
public void WriteElementString(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   string value
)
Delphi
public procedure WriteElementString(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    value: String
);
JScript
public function WriteElementString(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   value : String
);
Managed Extensions for C++
public: void WriteElementString(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   string* value
)
C++/CLI
public:
void WriteElementString(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   String^ value
)

Parameters

prefix
localName
namespaceUri
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteElementString(XmlDictionaryString,XmlDictionaryString,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteElementString Method : WriteElementString(XmlDictionaryString,XmlDictionaryString,String) Method

localName
namespaceUri
value

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteElementString( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString
Dim value As String

instance.WriteElementString(localName, namespaceUri, value)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteElementString(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri,
   string value
)
Delphi
public procedure WriteElementString(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString;
    value: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteElementString(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString,
   value : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteElementString(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri,
   string* value
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteElementString(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri,
   String^ value
)

Parameters

localName
namespaceUri
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteName Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteName Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteName( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim name As String

instance.WriteName(name)
C#
public virtual void WriteName(
   string name
)
Delphi
public procedure WriteName(
    name: String
); virtual;
JScript
public function WriteName(
   name : String
);
Managed Extensions for C++
public: virtual void WriteName(
   string* name
)
C++/CLI
public:
virtual void WriteName(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNmToken Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteNmToken Method

name

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteNmToken( _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim name As String

instance.WriteNmToken(name)
C#
public virtual void WriteNmToken(
   string name
)
Delphi
public procedure WriteNmToken(
    name: String
); virtual;
JScript
public function WriteNmToken(
   name : String
);
Managed Extensions for C++
public: virtual void WriteNmToken(
   string* name
)
C++/CLI
public:
virtual void WriteNmToken(
   String^ name
)

Parameters

name

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode(XmlDictionaryReader,Boolean) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteNode Method : WriteNode(XmlDictionaryReader,Boolean) Method

reader
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteNode( _
   ByVal reader As XmlDictionaryReader, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim reader As XmlDictionaryReader
Dim defattr As Boolean

instance.WriteNode(reader, defattr)
C#
public virtual void WriteNode(
   XmlDictionaryReader reader,
   bool defattr
)
Delphi
public procedure WriteNode(
    reader: XmlDictionaryReader;
    defattr: Boolean
); virtual;
JScript
public function WriteNode(
   reader : XmlDictionaryReader,
   defattr : boolean
);
Managed Extensions for C++
public: virtual void WriteNode(
   XmlDictionaryReader* reader,
   bool defattr
)
C++/CLI
public:
virtual void WriteNode(
   XmlDictionaryReader^ reader,
   bool defattr
)

Parameters

reader
defattr

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteNode(XPathNavigator,Boolean) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteNode Method : WriteNode(XPathNavigator,Boolean) Method

navigator
defattr

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteNode( _
   ByVal navigator As XPathNavigator, _
   ByVal defattr As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim navigator As XPathNavigator
Dim defattr As Boolean

instance.WriteNode(navigator, defattr)
C#
public virtual void WriteNode(
   XPathNavigator navigator,
   bool defattr
)
Delphi
public procedure WriteNode(
    navigator: XPathNavigator;
    defattr: Boolean
); virtual;
JScript
public function WriteNode(
   navigator : XPathNavigator,
   defattr : boolean
);
Managed Extensions for C++
public: virtual void WriteNode(
   XPathNavigator* navigator,
   bool defattr
)
C++/CLI
public:
virtual void WriteNode(
   XPathNavigator^ navigator,
   bool defattr
)

Parameters

navigator
defattr

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteQualifiedName Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteQualifiedName Method

Overload List

Overload | Description
WriteQualifiedName(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteQualifiedName(String,String) | (Inherited from System.Xml.XmlWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteQualifiedName(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteQualifiedName Method : WriteQualifiedName(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteQualifiedName( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim ns As String

instance.WriteQualifiedName(localName, ns)
C#
public virtual void WriteQualifiedName(
   string localName,
   string ns
)
Delphi
public procedure WriteQualifiedName(
    localName: String;
    ns: String
); virtual;
JScript
public function WriteQualifiedName(
   localName : String,
   ns : String
);
Managed Extensions for C++
public: virtual void WriteQualifiedName(
   string* localName,
   string* ns
)
C++/CLI
public:
virtual void WriteQualifiedName(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteQualifiedName(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteQualifiedName Method : WriteQualifiedName(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteQualifiedName( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.WriteQualifiedName(localName, namespaceUri)
C#
public virtual void WriteQualifiedName(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteQualifiedName(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function WriteQualifiedName(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteQualifiedName(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void WriteQualifiedName(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartAttribute Method : WriteStartAttribute(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String

instance.WriteStartAttribute(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName
)
Delphi
public procedure WriteStartAttribute(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim ns As String

instance.WriteStartAttribute(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   string localName,
   string ns
)
Delphi
public procedure WriteStartAttribute(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(String,XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartAttribute Method : WriteStartAttribute(String,XmlDictionaryString,XmlDictionaryString) Method

prefix
localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteStartAttribute( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.WriteStartAttribute(prefix, localName, namespaceUri)
C#
public virtual void WriteStartAttribute(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteStartAttribute(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function WriteStartAttribute(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteStartAttribute(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void WriteStartAttribute(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

prefix
localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartAttribute(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartAttribute Method : WriteStartAttribute(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartAttribute( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.WriteStartAttribute(localName, namespaceUri)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartAttribute(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteStartAttribute(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartAttribute(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartAttribute(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartAttribute(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartElement Method : WriteStartElement(String) Method

localName

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String

instance.WriteStartElement(localName)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName
)
Delphi
public procedure WriteStartElement(
    localName: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName
)

Parameters

localName

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartElement Method : WriteStartElement(String,String) Method

localName
ns

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As String, _
   ByVal ns As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim ns As String

instance.WriteStartElement(localName, ns)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   string localName,
   string ns
)
Delphi
public procedure WriteStartElement(
    localName: String;
    ns: String
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : String,
   ns : String
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   string* localName,
   string* ns
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   String^ localName,
   String^ ns
)

Parameters

localName
ns

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(String,XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartElement Method : WriteStartElement(String,XmlDictionaryString,XmlDictionaryString) Method

prefix
localName
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteStartElement( _
   ByVal prefix As String, _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.WriteStartElement(prefix, localName, namespaceUri)
C#
public virtual void WriteStartElement(
   string prefix,
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteStartElement(
    prefix: String;
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function WriteStartElement(
   prefix : String,
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteStartElement(
   string* prefix,
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void WriteStartElement(
   String^ prefix,
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

prefix
localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteStartElement(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteStartElement Method : WriteStartElement(XmlDictionaryString,XmlDictionaryString) Method

localName
namespaceUri

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub WriteStartElement( _
   ByVal localName As XmlDictionaryString, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim namespaceUri As XmlDictionaryString

instance.WriteStartElement(localName, namespaceUri)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void WriteStartElement(
   XmlDictionaryString localName,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteStartElement(
    localName: XmlDictionaryString;
    namespaceUri: XmlDictionaryString
);
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function WriteStartElement(
   localName : XmlDictionaryString,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void WriteStartElement(
   XmlDictionaryString* localName,
   XmlDictionaryString* namespaceUri
)
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void WriteStartElement(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ namespaceUri
)

Parameters

localName
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteString(XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteString Method : WriteString(XmlDictionaryString) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteString( _
   ByVal value As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As XmlDictionaryString

instance.WriteString(value)
C#
public virtual void WriteString(
   XmlDictionaryString value
)
Delphi
public procedure WriteString(
    value: XmlDictionaryString
); virtual;
JScript
public function WriteString(
   value : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteString(
   XmlDictionaryString* value
)
C++/CLI
public:
virtual void WriteString(
   XmlDictionaryString^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteTextNode Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteTextNode Method

reader
isAttribute

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteTextNode( _
   ByVal reader As XmlDictionaryReader, _
   ByVal isAttribute As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim reader As XmlDictionaryReader
Dim isAttribute As Boolean

instance.WriteTextNode(reader, isAttribute)
C#
protected virtual void WriteTextNode(
   XmlDictionaryReader reader,
   bool isAttribute
)
Delphi
protected procedure WriteTextNode(
    reader: XmlDictionaryReader;
    isAttribute: Boolean
); virtual;
JScript
protected function WriteTextNode(
   reader : XmlDictionaryReader,
   isAttribute : boolean
);
Managed Extensions for C++
protected: virtual void WriteTextNode(
   XmlDictionaryReader* reader,
   bool isAttribute
)
C++/CLI
protected:
virtual void WriteTextNode(
   XmlDictionaryReader^ reader,
   bool isAttribute
)

Parameters

reader
isAttribute

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(Guid) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(Guid) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As Guid _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As Guid

instance.WriteValue(value)
C#
public virtual void WriteValue(
   Guid value
)
Delphi
public procedure WriteValue(
    value: Guid
); virtual;
JScript
public function WriteValue(
   value : Guid
);
Managed Extensions for C++
public: virtual void WriteValue(
   Guid value
)
C++/CLI
public:
virtual void WriteValue(
   Guid value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(IStreamProvider) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(IStreamProvider) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As IStreamProvider _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As IStreamProvider

instance.WriteValue(value)
C#
public virtual void WriteValue(
   IStreamProvider value
)
Delphi
public procedure WriteValue(
    value: IStreamProvider
); virtual;
JScript
public function WriteValue(
   value : IStreamProvider
);
Managed Extensions for C++
public: virtual void WriteValue(
   IStreamProvider* value
)
C++/CLI
public:
virtual void WriteValue(
   IStreamProvider^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(UniqueId) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(UniqueId) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As UniqueId _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As UniqueId

instance.WriteValue(value)
C#
public virtual void WriteValue(
   UniqueId value
)
Delphi
public procedure WriteValue(
    value: UniqueId
); virtual;
JScript
public function WriteValue(
   value : UniqueId
);
Managed Extensions for C++
public: virtual void WriteValue(
   UniqueId* value
)
C++/CLI
public:
virtual void WriteValue(
   UniqueId^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteValue(XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteValue Method : WriteValue(XmlDictionaryString) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteValue( _
   ByVal value As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim value As XmlDictionaryString

instance.WriteValue(value)
C#
public virtual void WriteValue(
   XmlDictionaryString value
)
Delphi
public procedure WriteValue(
    value: XmlDictionaryString
); virtual;
JScript
public function WriteValue(
   value : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteValue(
   XmlDictionaryString* value
)
C++/CLI
public:
virtual void WriteValue(
   XmlDictionaryString^ value
)

Parameters

value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlAttribute Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class : WriteXmlAttribute Method

Overload List

Overload | Description
WriteXmlAttribute(String,String) | (Inherited from System.Xml.XmlDictionaryWriter)
WriteXmlAttribute(XmlDictionaryString,XmlDictionaryString) | (Inherited from System.Xml.XmlDictionaryWriter)

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlAttribute(String,String) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteXmlAttribute Method : WriteXmlAttribute(String,String) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteXmlAttribute( _
   ByVal localName As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As String
Dim value As String

instance.WriteXmlAttribute(localName, value)
C#
public virtual void WriteXmlAttribute(
   string localName,
   string value
)
Delphi
public procedure WriteXmlAttribute(
    localName: String;
    value: String
); virtual;
JScript
public function WriteXmlAttribute(
   localName : String,
   value : String
);
Managed Extensions for C++
public: virtual void WriteXmlAttribute(
   string* localName,
   string* value
)
C++/CLI
public:
virtual void WriteXmlAttribute(
   String^ localName,
   String^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlAttribute(XmlDictionaryString,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteXmlAttribute Method : WriteXmlAttribute(XmlDictionaryString,XmlDictionaryString) Method

localName
value

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteXmlAttribute( _
   ByVal localName As XmlDictionaryString, _
   ByVal value As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim localName As XmlDictionaryString
Dim value As XmlDictionaryString

instance.WriteXmlAttribute(localName, value)
C#
public virtual void WriteXmlAttribute(
   XmlDictionaryString localName,
   XmlDictionaryString value
)
Delphi
public procedure WriteXmlAttribute(
    localName: XmlDictionaryString;
    value: XmlDictionaryString
); virtual;
JScript
public function WriteXmlAttribute(
   localName : XmlDictionaryString,
   value : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteXmlAttribute(
   XmlDictionaryString* localName,
   XmlDictionaryString* value
)
C++/CLI
public:
virtual void WriteXmlAttribute(
   XmlDictionaryString^ localName,
   XmlDictionaryString^ value
)

Parameters

localName
value

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%PageItemTitle%%

[image]
Noemax WCF-Xtensions
WriteXmlnsAttribute(String,XmlDictionaryString) Method
See Also Send Feedback
Noemax.Xml Namespace > XmlFastInfosetDictionaryWriter Class > WriteXmlnsAttribute Method : WriteXmlnsAttribute(String,XmlDictionaryString) Method

prefix
namespaceUri

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub WriteXmlnsAttribute( _
   ByVal prefix As String, _
   ByVal namespaceUri As XmlDictionaryString _
)
Visual Basic (Usage) Copy Code
Dim instance As XmlFastInfosetDictionaryWriter
Dim prefix As String
Dim namespaceUri As XmlDictionaryString

instance.WriteXmlnsAttribute(prefix, namespaceUri)
C#
public virtual void WriteXmlnsAttribute(
   string prefix,
   XmlDictionaryString namespaceUri
)
Delphi
public procedure WriteXmlnsAttribute(
    prefix: String;
    namespaceUri: XmlDictionaryString
); virtual;
JScript
public function WriteXmlnsAttribute(
   prefix : String,
   namespaceUri : XmlDictionaryString
);
Managed Extensions for C++
public: virtual void WriteXmlnsAttribute(
   string* prefix,
   XmlDictionaryString* namespaceUri
)
C++/CLI
public:
virtual void WriteXmlnsAttribute(
   String^ prefix,
   XmlDictionaryString^ namespaceUri
)

Parameters

prefix
namespaceUri

See Also

Reference

XmlFastInfosetDictionaryWriter Class
XmlFastInfosetDictionaryWriter Members
Overload List


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Xml Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Xml.XmlDictionaryReader
System.Xml.XmlReader
Noemax.Xml.XmlFastInfosetDictionaryReader
Noemax.WCFX.Channels.FiEncoderMessageReader
System.Xml.XmlDictionaryWriter
System.Xml.XmlWriter
Noemax.Xml.XmlFastInfosetDictionaryWriter

See Also

Reference

Noemax.WCFX Assembly